Komponentenvorlagen

Um die Erstellung Ihrer Bauteile zu vereinfachen, unterstützt Altium Designer in Verbindung mit Ihrem verbundenen Workspace das Erstellen und Definieren von Component Templates (Bauteilvorlagen-Items) in diesem Workspace. So wie eine Schaltplanvorlage Informationen auf Schaltplanblättern vordefinieren kann, die auf sie verweisen, wird eine Bauteilvorlage von einem Workspace-Bibliotheksbauteil referenziert und stellt vordefinierte Einstellungen für die Definition dieses Bauteils bereit.

Bauteilvorlagen wurden insbesondere mit Blick auf Parameterinformationen entwickelt. Sie ermöglichen es Ihnen, an einer zentralen Stelle einen Parametersatz zu definieren, der dem referenzierenden Bauteil zur Verfügung steht. Über die Vorlage können Sie steuern, welche dieser Parameter sichtbar sein sollen, Standardwerte eintragen und erforderliche Parameter sogar als Pflichtangaben kennzeichnen. Beim Speichern des Bauteils wird durch Validierungsprüfungen sichergestellt, dass diese Vorgaben eingehalten werden.

Festgelegte Standardwerte für viele Vorlageneinstellungen können schreibgeschützt werden. Alternativ können Sie gezielt zulassen, dass der Entwickler sie beim Definieren eines Bauteils überschreibt.

Eine Bauteilvorlage bildet auch die Grundlage für die Erstellung eines generischen Bauteils. Weitere Informationen finden Sie auf der Seite Generische Bauteile erstellen.

Der Zugriff auf Bauteilvorlagen hängt von der Softwarelizenzierung ab. Weitere Informationen finden Sie im Kasten Note auf der rechten Seite.

Solche Bauteilvorlagen werden direkt im Workspace erstellt. Sobald eine Bauteilvorlage erstellt wurde und ihre Daten in einer Revision gespeichert wurden, kann sie zur Erstellung eines oder mehrerer Bauteile wiederverwendet werden.

Ordnertyp

Beim Erstellen des Ordners, in dem Bauteilvorlagen gespeichert werden sollen, können Sie den Ordnertyp festlegen. Dieser hat keinen Einfluss auf den Inhalt des Ordners – die Freigabe einer Bauteilvorlage führt immer zu einem entsprechenden Bauteilvorlagen-Item. Der Ordnertyp liefert lediglich einen visuellen Hinweis darauf, was in einem Ordner gespeichert ist, und kann bei der Suche nach bestimmten Inhalten in einem Workspace hilfreich sein. Um einen Ordner als Ablage für Bauteilvorlagen zu kennzeichnen, setzen Sie dessen Folder Type auf Component Templates, wenn Sie die Ordnereigenschaften im Dialogfeld „Ordner bearbeiten“ definieren.

Die Angabe des Ordnertyps – also seines vorgesehenen Verwendungszwecks – gibt beim Durchsuchen des Workspace einen visuellen Hinweis auf den Inhalt dieses Ordners.
Die Angabe des Ordnertyps – also seines vorgesehenen Verwendungszwecks – gibt beim Durchsuchen des Workspace einen visuellen Hinweis auf den Inhalt dieses Ordners.

Inhaltstyp

Wenn Sie ein Ziel-Bauteilvorlagen-Item erstellen, in dem Ihre Bauteilvorlage gespeichert werden soll, stellen Sie sicher, dass dessen Content Type im Dialogfeld „Neues Item erstellen“ auf Component Template gesetzt ist. Wenn Sie das Item in einem Ordner des Typs Component Templates erstellen, steht dieser Inhaltstyp beim Erstellen des Items im Kontextmenü zur Verfügung.

Erstellen einer Bauteilvorlage in einem Component Templates-Ordner – der passende Content Type ist im Kontextmenü verfügbar.
Erstellen einer Bauteilvorlage in einem Component Templates-Ordner – der passende Content Type ist im Kontextmenü verfügbar.

Eine Bauteilvorlage speichern

Related page: Inhalte erstellen und bearbeiten

Bisher haben wir die Unterstützung für Bauteilvorlagen im Workspace im Hinblick auf die zugehörigen Ordner- und Inhaltstypen erläutert. Eine fertig definierte Bauteilvorlage lässt sich auf einfache Weise in einer Revision eines solchen Bauteilvorlagen-Items speichern.

Dank der Unterstützung des Workspace für die direkte Bearbeitung kann eine Bauteilvorlage bearbeitet und in der ersten Revision eines neu erstellten Bauteilvorlagen-Items gespeichert werden. Die direkte Bearbeitung befreit Sie von der Bindung an separate, versionsverwaltete Quelldaten. Sie können einen unterstützten Inhaltstyp einfach in einem temporären Editor bearbeiten, der mit den neuesten Quelldaten direkt aus dem Workspace geladen wird. Nach Abschluss der Bearbeitung wird das Objekt in einer nachfolgenden geplanten Revision seines übergeordneten Items gespeichert bzw. erneut gespeichert und der temporäre Editor geschlossen. Es befinden sich keine Dateien auf Ihrer Festplatte, Sie müssen sich nicht fragen, ob Sie mit den richtigen oder neuesten Quelldaten arbeiten, und Sie müssen keine separate Versionsverwaltungssoftware pflegen. Der Workspace übernimmt all dies mit hoher Datenintegrität und beschleunigt Änderungen an Ihren Daten erheblich.

Wenn Sie ein Komponentenvorlagen-Item erstellen, können Sie nach der Erstellung eine Komponentenvorlage bearbeiten und in der ersten Revision dieses Items speichern. Aktivieren Sie dazu die Option Open for editing after creation unten im Dialog „Create New Item“ (die standardmäßig aktiviert ist). Das Item wird erstellt und der temporäre Komponentenvorlagen-Editor geöffnet. Dabei wird ein .CMPT-Dokument als aktives Dokument im Hauptentwurfsfenster angezeigt. Dieses Dokument wird entsprechend der Item-Revision im folgenden Format benannt: <Item><Revision>.CMPT (z. B. CMPT-0001-1.CMPT).

 
 
 
 
 

Beispiel für die Bearbeitung der ersten Revision einer Komponentenvorlage direkt aus dem Workspace – der temporäre Komponentenvorlagen-Editor stellt das Dokument bereit, mit dem Sie Ihre Komponentenvorlage definieren.
Beispiel für die Bearbeitung der ersten Revision einer Komponentenvorlage direkt aus dem Workspace – der temporäre Komponentenvorlagen-Editor stellt das Dokument bereit, mit dem Sie Ihre Komponentenvorlage definieren.

Verwenden Sie das Dokument, um die Komponentenvorlage nach Bedarf zu definieren. Weitere Informationen hierzu finden Sie unter Definieren der Vorlage.

Für die direkte Bearbeitung stehen drei relevante Bedienelemente zur Verfügung, die über Quick Access Bar (oben links im Hauptanwendungsfenster) oder über die Symbolleiste Component Template Standard zugänglich sind:

  • – Save Active Document. Verwenden Sie diese Schaltfläche, um alle am Dokument vorgenommenen Änderungen lokal zu speichern. So können Sie die aktuellen Änderungen speichern, wenn Sie später weitere Änderungen vornehmen möchten, bevor Sie die Vorlage endgültig im Workspace speichern.
  • / – Save to Server. Verwenden Sie diese Schaltfläche, um die definierte Komponentenvorlage im Workspace zu speichern und in der ersten (geplanten) Revision des Ziel-Komponentenvorlagen-Items abzulegen. Der Dialog Edit Revision wird angezeigt. Darin können Sie den Namen und die Beschreibung ändern sowie bei Bedarf Freigabehinweise hinzufügen. Nach dem Speichern werden das Dokument und der Editor geschlossen. Das Dokument mit der Quell-Komponentenvorlage, *.CMPT, wird in der Revision des Items gespeichert.

    Ein Bedienelement Save to Server steht außerdem direkt rechts neben dem Eintrag der Komponentenvorlage im Projects-Panel zur Verfügung.
  • / – Discard Local Changes. Verwenden Sie diese Schaltfläche, wenn Sie die Bearbeitung abbrechen und alle vorgenommenen Änderungen verwerfen möchten. Das Dokument und der Editor werden geschlossen, und es wird nichts für das Ziel-Komponentenvorlagen-Item freigegeben.

Diese Bedienelemente sind auch als Befehle – Save (Tastenkombination: Ctrl+S), Save to Server (Tastenkombination: Ctrl+Alt+S) und Discard Local Changes – im Hauptmenü File sowie im Kontextmenü des Eintrags der Komponentenvorlage im Panel Projects verfügbar.

Die im Workspace gespeicherten Daten bestehen aus der Quell-Komponentenvorlage, die in der Komponentenvorlagendatei (<Item><Revision>.CMPT) definiert ist.

 
 
 
 
 

Beispiel einer definierten Komponentenvorlage, die im Workspace gespeichert wurde.
Beispiel einer definierten Komponentenvorlage, die im Workspace gespeichert wurde.

Vererben einer Komponentenvorlage

Diese Funktion ist verfügbar, wenn die Option UI.ComponentTemplateInheritance im Dialog „Advanced Settings“ aktiviert ist.

Sie können eine Komponentenvorlage des obersten Komponententyps verwenden, wenn mit dem Untertyp keine Komponentenvorlage verknüpft ist. Beim Aufbau einer Hierarchie von Komponententypen erben die Komponentenuntertypen die Komponentenvorlage, die dem obersten bzw. übergeordneten Komponententyp zugewiesen ist.

Der CMPT-Editor (Komponentenvorlagen-Editor)

Um auf den Komponentenvorlagen-Editor in Altium Designer zugreifen zu können, muss die Softwareerweiterung Component Template Editor installiert sein. Diese Erweiterung wird standardmäßig mit Altium Designer installiert. Sie kann manuell installiert oder entfernt werden.

Weitere Informationen zur Verwaltung von Erweiterungen finden Sie auf der Seite Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Definieren der Vorlage

Der Komponentenvorlagen-Editor ist im Wesentlichen in zwei Hauptbereiche unterteilt, die in der folgenden Abbildung dargestellt und anschließend zusammengefasst werden.

 
 
 
 
 

Der Komponentenvorlagen-Editor lässt sich grob in zwei wesentliche Bereiche unterteilen.
Der Komponentenvorlagen-Editor lässt sich grob in zwei wesentliche Bereiche unterteilen.

  1. Upper Region – zum Definieren von Optionen auf Komponentenebene (Lebenszyklus-, Benennungs- und Ordneroptionen) für eine Komponente, die auf die Vorlage verweist.
  2. Lower Region – zum Definieren der Parameter, die für eine Komponente verwendet werden sollen, die auf die Vorlage verweist.

Festlegen der Komponentenoptionen

Die obere Hälfte des Editors dient zum Definieren von Standardwerten für die folgenden Komponenteneigenschaften:

  • Lifecycle Definition – wählen Sie die Lebenszyklusdefinition aus, die auf eine mit der Vorlage erstellte Komponente angewendet werden soll. Das Dropdown-Feld listet alle für den Workspace definierten Definitionen auf, die für die Verwendung durch eine Komponente zulässig sind.

  • Revision Naming – wählen Sie das Revisionsbenennungsschema aus, das auf eine mit der Vorlage erstellte Komponente angewendet werden soll. Das Dropdown-Feld listet alle für den Workspace definierten Schemata auf, die für die Verwendung durch eine Komponente zulässig sind.

    Wenn die Option zur Steuerung der Verwendung von Lebenszyklusdefinitionen und Revisionsbenennungsschemata je Inhaltstyp für Definitionen oder Schemata aktiviert ist und der Inhaltstyp „Komponente“ nicht für die Verwendung einer bestimmten Definition bzw. eines bestimmten Schemas konfiguriert ist, steht diese Definition bzw. dieses Schema in der entsprechenden Dropdown-Liste nicht zur Verfügung.

  • Component Naming – verwenden Sie dieses Feld, um ein standardmäßiges Elementbenennungsschema für eine mithilfe der Vorlage erstellte Komponente festzulegen. Dadurch erhält die Komponente im Workspace eine eindeutige ID. Der hier eingegebene Wert dient als Vorlage für die automatische Benennung der Komponente (im zugehörigen Feld Id, wenn der Komponenten-Editor im Modus Single Component Editing verwendet wird, oder im Feld Item ID, wenn der Komponenten-Editor im Modus Batch Component Editing verwendet wird). Die Software durchsucht den gesamten Workspace und die Kennungen vorhandener Inhalte und vergibt anhand dieses Schemas automatisch die nächste verfügbare eindeutige ID. Ein standardmäßiges Elementbenennungsschema – CMP-{00000} – ist bereits vorhanden. Sie können jedoch selbstverständlich ein eigenes Schema erstellen, indem Sie es in das Feld eingeben. Achten Sie darauf, den variablen Teil in geschweifte Klammern einzuschließen (z. B. CMP-001-{0000}).

  • Default Folder – hier legen Sie einen Standardordner im Ziel-Workspace fest, in dem eine gespeicherte Komponente abgelegt werden soll. Klicken Sie dazu auf die Schaltfläche Choose, um den Dialog Choose Folder (eine Variante des Explorer-Panels) zu öffnen. Dort können Sie einen vorhandenen Ordner im Workspace suchen und auswählen oder direkt einen neuen erstellen.

Es gibt kein Feld zum Festlegen des Ziel-Workspace, da fest vorgegeben ist, dass derselbe Workspace verwendet wird, in dem sich die Revision der Komponentenvorlage befindet.

Mit der Option Allow override für jede Eigenschaft lässt sich unabhängig festlegen, ob der Benutzer diese Eigenschaft beim Definieren einer Komponente im Komponenten-Editor ändern kann (aktiviert) oder nicht (deaktiviert).

Wenn die Vorlage referenziert wird, werden die in diesem Bereich angegebenen Einträge verwendet, um die entsprechenden Felder im Komponenten-Editor vorab auszufüllen (sofern verfügbar):

  • Single Component Editing mode – die Felder Id und Folder im Bereich Advanced Settings des Abschnitts Component.
  • Batch Component Editing mode – auf der Registerkarte Document Options des Dialogs „Dokumentoptionen“ und damit auch die Felder Item ID und FolderPath im Bereich Component des Abschnitts für Komponentendefinitionen.

Wenn die Vorlage referenziert wird, werden die Einträge verwendet, um die entsprechenden Felder beim Bearbeiten einer Komponente im Komponenten-Editor im Modus Single Component Editing (links) und im Modus Batch Component Editing (rechts) vorab auszufüllen.
Wenn die Vorlage referenziert wird, werden die Einträge verwendet, um die entsprechenden Felder beim Bearbeiten einer Komponente im Komponenten-Editor im Modus Single Component Editing (links) und im Modus Batch Component Editing (rechts) vorab auszufüllen.

Parameter definieren

Die untere Hälfte des Editors dient zum Definieren und Verwalten der Parameter, die einer Komponente zur Verfügung gestellt werden, die diese Vorlage referenziert.

 
 
 
 
 

Beispielparameter, die in einer Komponentenvorlage definiert sind.
Beispielparameter, die in einer Komponentenvorlage definiert sind.

Standard-Systemparameter

Beim Erstellen einer neuen Komponentenvorlage sind standardmäßig verschiedene Systemparameter enthalten, wie in der folgenden Abbildung dargestellt und anschließend erläutert.

 
 
 
 
 

Standardmäßig enthaltene Systemparameter in einer neu erstellten Komponentenvorlage.
Standardmäßig enthaltene Systemparameter in einer neu erstellten Komponentenvorlage.

  • ComponentType – mit diesem Parameter können Sie den Komponententyp angeben. Dies erleichtert die gezielte Suche mit der leistungsfähigen Suchfunktion des Workspace. Damit können Sie nicht nur nach Komponententyp suchen, sondern dank der Unterstützung von Komponentenparametern mit Einheitenerkennung auch intelligenter suchen. Wenn Sie Ihre eigenen Workspace-Komponenten im Komponenten-Panel durchsuchen, wird die Gruppierung Categories der Komponenten aus den Parametern ComponentType abgeleitet, die den einzelnen Komponenten zugeordnet sind. Klicken Sie auf das zugehörige Feld Default Value und anschließend auf die Schaltfläche , um den Dialog Choose component type zu öffnen. Wählen Sie dort den gewünschten Komponententyp aus und klicken Sie auf OK. Der ausgewählte Typ wird anschließend im Hauptparameterraster als Wert für den Parameter ComponentType eingetragen.

    Der Dialog Choose component type zeigt die Komponententypen an, die auf der Seite „Datenverwaltung – Komponententypen“ des Dialogs Preferences definiert sind. Klicken Sie unten im Dialog Choose component type auf die Schaltfläche , um diese Einstellungsseite aufzurufen. Dort können Sie die Liste an Ihre Anforderungen anpassen, indem Sie neue Typen und Untertypen hinzufügen oder vorhandene Typen bearbeiten und entfernen.

    Beispiel einer Komponentenvorlage, bei der der Systemparameter ComponentType auf Diodes gesetzt ist.
    Beispiel einer Komponentenvorlage, bei der der Systemparameter ComponentType auf Diodes gesetzt ist.

     
     
     
     
     

    Der Datentyp für diesen Parameter ist auf ComponentType festgelegt und kann nicht geändert werden. Außerdem kann der Parameter ComponentType weder kopiert noch entfernt werden. Wählen Sie die Zelle aus und verwenden Sie die Taste Delete , um den Wert zu löschen.

  • SCHLIB und PCBLIB – mit diesen beiden Parametern können Sie die standardmäßig verwendeten Symbol- bzw. Footprint-Modelle angeben. Klicken Sie für jeden Parameter auf das zugehörige Feld Default Value und anschließend auf die Schaltfläche , um einen Dialog zur Auswahl des gewünschten Modells zu öffnen.

    Beachten Sie, dass Sie das Modell auswählen, nicht eine bestimmte Revision dieses Modells. Auf diese Weise verwendet ein Bauteil, das auf der Vorlage basiert, immer die neueste Revision des ausgewählten Modells.

    Legen Sie Symbol- und Footprint-Modelle als Bestandteil Ihrer Vorlage fest.
    Legen Sie Symbol- und Footprint-Modelle als Bestandteil Ihrer Vorlage fest.

     
     
     
     
     

    Die Datentypen für diese Parameter sind auf SCHLIB bzw. PCBLIB festgelegt und können nicht geändert werden. Außerdem können die Modellparameter weder kopiert noch entfernt werden. Wählen Sie die Zelle aus und verwenden Sie die Taste Delete , um den Wert zu löschen.

  • Name und Description – mit diesen beiden Parametern können Sie den Namen bzw. die Beschreibung des Bauteils festlegen. Geben Sie für jeden Parameter die gewünschten Zeichenfolgen in das zugehörige Feld Default Value ein.

    Legen Sie die Parameter Name und Description als Bestandteil Ihrer Vorlage fest.
    Legen Sie die Parameter Name und Description als Bestandteil Ihrer Vorlage fest.

     
     
     
     
     

    Der Datentyp für diese beiden Parameter ist auf Text festgelegt und kann nicht geändert werden. Außerdem können diese Parameter weder kopiert noch entfernt werden.

Hinzufügen eines neuen Benutzerparameters

Um der Liste einen neuen Benutzerparameter hinzuzufügen, klicken Sie auf die Schaltfläche (oder verwenden Sie den Befehl Add aus dem Kontextmenü) – der Parameter wird am Ende der aktuellen Liste hinzugefügt.

 
 
 
 
 

Beispiel für das Hinzufügen eines neuen Benutzerparameters zur Vorlage.
Beispiel für das Hinzufügen eines neuen Benutzerparameters zur Vorlage.

Jeder Parameter wird in der Tabelle mit den folgenden Informationen dargestellt:

  • Name – verwenden Sie dieses Feld, um den Parameter zu benennen. Wählen Sie in der Regel einen aussagekräftigen Namen, der seinen Zweck verdeutlicht. Beim erstmaligen Hinzufügen erhalten Parameter Standardnamen (Parameter, Parameter 1, Parameter 2 usw.).

  • Type – der Parametertyp. Dieser Eintrag ist zunächst standardmäßig auf Text gesetzt. Es werden jedoch verschiedene einheitenbezogene Datentypen unterstützt sowie der Typ PCBLIB, der die Definition mehrerer Footprints ermöglicht, und HarnessWiring, der die Definition einer Kabelbaum-Verdrahtungskomponente ermöglicht. Auch Parametertypen, die durch verfügbare Wörterbücher definiert werden, werden unterstützt – mehr erfahren.

  • Visible – aktivieren Sie diese Option (die bei einem neu hinzugefügten Parameter standardmäßig aktiviert ist), damit beim Bearbeiten einer oder mehrerer Komponenten im Komponenten-Editor (im Modus Batch Component Editing) die entsprechende Option Show für den Parameter aktiviert ist. Dadurch wird wiederum die Anzeige der entsprechenden Spalte für diesen Parameter im unteren Bereich des Komponenten-Editors gesteuert, in dem die eigentlichen Komponentendefinitionen festgelegt werden. Diese Eigenschaft hat keine Auswirkung, wenn eine Komponente im Modus Single Component Editing des Editors definiert wird.

  • Read Only – aktivieren Sie diese Option, um den Parameter schreibgeschützt zu machen. Beim Bearbeiten einer Komponente, die auf die Vorlage verweist, kann der Parameterwert dann nicht geändert werden.

  • Required – aktivieren Sie diese Option, um den Parameter als Pflichtparameter festzulegen. Beim Bearbeiten einer Komponente, die auf die Vorlage verweist, muss für diesen Parameter ein Wert definiert sein. Andernfalls kann die Komponente nicht gespeichert werden. Im Komponenten-Editor wird ein solcher Parameter bei fehlendem Wert durch einen roten Rahmen um die Wertzelle (im Modus Batch Component Editing) oder durch das Symbol in der Wertzelle (im Modus Single Component Editing) gekennzeichnet.

  • Default Value – verwenden Sie dieses Feld, um einen Standardwert für den Parameter einzugeben.

    • Wenn der Parameter als erforderlich gekennzeichnet ist (Option Required aktiviert) und zugleich als schreibgeschützt festgelegt wurde (Option Read Only aktiviert), MUST ein Standardwert eingegeben werden. Andernfalls wird der Parameter beim Bearbeiten einer Komponente, die auf die Vorlage verweist, als Parameter ohne Wert gekennzeichnet. Dies lässt sich jedoch nicht beheben, da der Parameter aufgrund des Schreibschutzes nicht bearbeitet werden kann. Eine neue Revision dieser Komponentenvorlage kann erst im Workspace gespeichert werden, wenn dieses Problem behoben wurde.

    • Beim Bearbeiten einer Komponentenrevision wird ein vorhandener benutzerdefinierter Parameter, der denselben Namen wie ein Parameter in der verknüpften Komponentenvorlage hat, durch die Vorlagenversion ersetzt. Ein vorhandener Wert dieses Parameters bleibt erhalten und wird nicht durch den Standardwert aus der Vorlage überschrieben.

  • Description – fügen Sie eine Beschreibung für den Parameter hinzu, beispielsweise einen kurzen Hinweis zu seiner Funktion. Wenn für einen Parameter in der Vorlage eine Beschreibung definiert ist, wird die Spalte Description entsprechend im Bereich Parameters des Komponenten-Editors in dessen Single Component Editing angezeigt.

Die Parameterliste unterstützt auch einfache Kopier- und Einfügevorgänge, mit denen Sie einen oder mehrere vorhandene Benutzerparameter duplizieren können. Die eingefügten Parameter werden am Ende der Liste hinzugefügt.

Die standardmäßigen Tastenkombinationen zum Kopieren (Ctrl+C) und Einfügen (Ctrl+V) werden unterstützt. Diese Befehle sind auch über das Rechtsklickmenü verfügbar. Mehrere Benutzerparameter können mit den üblichen Ctrl+Click- und Shift+Click-Verfahren zum Kopieren und Einfügen ausgewählt werden.
Um einen oder mehrere Benutzerparameter aus der Liste zu löschen, wählen Sie die jeweiligen Parameter aus und klicken Sie anschließend auf die Schaltfläche oder verwenden Sie den Befehl Remove im Rechtsklick-Kontextmenü.

Einheitenbasierte Datentypen für Komponentenparameter

Mit dem Komponentenvorlagen-Editor können Sie explizite Datentypen für Komponentenparameter definieren, die innerhalb einer Komponentenvorlage festgelegt sind (*.CMPT). Darüber hinaus berücksichtigen diese Datentypen Einheiten und unterstützen eine Reihe gängiger Einheitenpräfixe. So können Sie den Wert eines Parameters in verschiedenen Formaten eingeben – etwa 2.2k, 2k2, 4M oder 2.5GHz. Der Workspace verfügt über die erforderliche Logik, um den numerischen Wert hinter diesen Eingaben zu erkennen.

Diese Funktion einer Komponentenvorlage erleichtert die gezielte Suche mit der erweiterten Suchfunktion des Servers. Damit können Sie nicht nur nach Komponententyp suchen, sondern dank Bereichssuchen auch präzisere Suchanfragen durchführen. Mithilfe einheitenbasierter Komponentenparameter können Sie schnell eine Suche definieren, um beispielsweise alle Kondensatoren mit einer Kapazität zwischen 47uF und 220uF zu finden.

Einheitenbasierte Parameter werden auch für die intelligente Filterung verwendet, wenn Sie Ihre eigenen Komponenten über das Components-Panel durchsuchen.

In den folgenden aufklappbaren Abschnitten erfahren Sie mehr über einheitenbasierte Parameter.

Wörterbuchdefinierte Parameterdatentypen

Wörterbücher sind benutzerdefinierte Parametertypen mit mehreren festgelegten Werten. Wörterbücher werden von Workspace-Administratoren auf der Seite Settings – Vault – Dictionaries der Browseroberfläche des Workspace verwaltet. Diese Seite kann vom Bauteilvorlageneditor aus aufgerufen werden, indem Sie die Option Add New Dictionary aus der Dropdown-Liste Type auswählen oder auf das Steuerelement Manage Dictionaries oben rechts im Bereich Parameters klicken.

  • Die Seite Settings – Vault – Dictionaries kann auch über die Seite Datenverwaltung – Wörterbücher des Dialogs Preferences aufgerufen werden, indem Sie auf das Steuerelement Manage Dictionaries klicken. Ebenso können Sie sie über die Seite Datenverwaltung – Server des Dialogs Preferences aufrufen, indem Sie auf das Steuerelement Properties für den aktiven oder einen bekannten Workspace klicken und den Eintrag Dictionaries aus dem Menü auswählen.

  • Wenn für einen Parameter ein wörterbuchdefinierter Typ ausgewählt ist, kann die Seite Settings – Vault – Dictionaries auch aufgerufen werden, indem Sie in die Zelle des Parameters in der Spalte Type und anschließend auf die Schaltfläche  () klicken.

Rufen Sie die Seite zur Verwaltung von Wörterbüchern in der Browseroberfläche des Workspace über den Bauteilvorlageneditor auf.
Rufen Sie die Seite zur Verwaltung von Wörterbüchern in der Browseroberfläche des Workspace über den Bauteilvorlageneditor auf.

Erfahren Sie mehr über die Verwaltung von Wörterbüchern über die Browseroberfläche des Workspace (Altium 365 Workspace, Enterprise Server Workspace).

Definierte Wörterbücher stehen in der Dropdown-Liste Type als Parametertypen zur Verfügung.

Wählen Sie in der Dropdown-Liste „Typ“ einen wörterbuchdefinierten Parametertyp aus.
Wählen Sie in der Dropdown-Liste „Typ“ einen wörterbuchdefinierten Parametertyp aus.

Die für den ausgewählten wörterbuchdefinierten Typ festgelegten Werte stehen in der Dropdown-Liste Default Value zur Verfügung. Wählen Sie den gewünschten Wert als Standardwert des Parameters aus oder wählen Sie <None>.

Wählen Sie einen Standardwert aus den für den ausgewählten wörterbuchdefinierten Typ festgelegten Werten aus.
Wählen Sie einen Standardwert aus den für den ausgewählten wörterbuchdefinierten Typ festgelegten Werten aus.

  • Standardwerte werden beim Speichern der Bauteilvorlage im Workspace validiert. Wenn der Standardwert nicht mehr mit dem Wörterbuch übereinstimmt (z. B. wenn der Wert aus dem Wörterbuch entfernt und anschließend die Vorlage, die diesen Wert verwendet, zur Bearbeitung geöffnet wurde), wird dieser Standardwert in der Spalte „Standardwert“ rot hervorgehoben. Beim Versuch, die Vorlage wieder im Workspace zu speichern, wird im Panel Messages eine Fehlermeldung angezeigt.

  • Wenn der Wert eines Bauteilparameters nicht mehr mit dem Wörterbuch übereinstimmt (z. B. wenn der Typ dieses Parameters in der Bauteilvorlage von „Text“ auf einen wörterbuchdefinierten Typ umgestellt wurde und der aktuelle Bauteilwert mit keinem Wert des ausgewählten wörterbuchdefinierten Typs übereinstimmt), wird dieser Parameter beim Bearbeiten des Bauteils im Bauteileditor hervorgehoben: Im Einzelbauteil-Bearbeitungsmodus des Editors wird neben dem nicht übereinstimmenden Parameterwert ein Ausrufezeichensymbol angezeigt, und im Stapelbearbeitungsmodus wird der Parameterwert rot hervorgehoben. Stellen Sie sicher, dass alle Bauteilparameter mit den Vorlagenwerten übereinstimmen; andernfalls können Sie das Bauteil nicht als nächste Revision speichern.

  • Wenn Wörterbücher in der Browseroberfläche des verbundenen Workspace geändert wurden, müssen Sie die Verbindung zum Workspace trennen und erneut herstellen, damit diese Änderungen in Altium Designer übernommen werden. Weitere Informationen finden Sie auf der Seite Zugriff auf Ihren Workspace.

Definieren mehrerer Footprints

Der Bauteilvorlageneditor unterstützt auch die Definition mehrerer PCB-Footprints innerhalb einer Bauteilvorlage. Es können beliebig viele Footprint-Modellverknüpfungen angegeben werden. Dies ist besonders nützlich, wenn Sie Bauteile erstellen möchten, die auf drei Footprints verweisen und damit die IPC-Anforderungen für unterschiedliche Dichteklassen erfüllen: L (geringste bzw. minimale Kupferfläche), M (größte bzw. maximale Kupferfläche) und N (nominale bzw. mittlere Kupferfläche).

Um der Vorlage eine zusätzliche Footprint-Modelldefinition hinzuzufügen, klicken Sie auf , um einen neuen Parameter hinzuzufügen, und wählen Sie anschließend den Eintrag PCBLIB im Dropdown-Menü des Felds Type aus.

Wandeln Sie einen neu hinzugefügten Parameter in eine Footprint-Modelldefinition um, indem Sie Type auf PCBLIB setzen.
Wandeln Sie einen neu hinzugefügten Parameter in eine Footprint-Modelldefinition um, indem Sie Type auf PCBLIB setzen.

Der Name des Parameters ändert sich von Parameter zu PCBLIB n, wobei n die nächste verfügbare ganze Zahl ist, um mehrere Footprint-Modelle voneinander zu unterscheiden (z. B. PCBLIB 1, PCBLIB 2 usw.). Das Standardmodell ist das Modell, das dem Eintrag PCBLIB zugeordnet ist. Wenn die Footprints bei der Definition eines Bauteils in den Bauteileditor übernommen werden, wird das Standard-Footprint-Modell durch das Symbol oben links im Modellvorschaufenster (im Modus Single Component Editing) und durch den Eintrag PCBLIB (default) im Bereich Required Models/Parameters (im Modus Batch Component Editing) gekennzeichnet.

Eine Beispielkomponente, die im Komponenten-Editor (Modus Single Component Editing) unter Verwendung einer referenzierten Komponentenvorlage definiert wird. In der Vorlage sind drei Footprint-Modelle definiert, die in die Komponentendefinition übernommen werden. Beachten Sie, dass der Modelleintrag PCBLIB in der Vorlage beim Definieren der Komponente als Standard-Footprint-Modell verwendet wird (gekennzeichnet durch ein Symbol oben links). Bewegen Sie den Mauszeiger über das Bild, um dieselbe Komponente bei der Definition im Komponenten-Editor im Modus Batch Component Editing zu sehen. In diesem Fall wird der Standard-Footprint als PCBLIB (default) bezeichnet.
Eine Beispielkomponente, die im Komponenten-Editor (Modus Single Component Editing) unter Verwendung einer referenzierten Komponentenvorlage definiert wird. In der Vorlage sind drei Footprint-Modelle definiert, die in die Komponentendefinition übernommen werden. Beachten Sie, dass der Modelleintrag PCBLIB in der Vorlage beim Definieren der Komponente als Standard-Footprint-Modell verwendet wird (gekennzeichnet durch ein Symbol oben links). Bewegen Sie den Mauszeiger über das Bild, um dieselbe Komponente bei der Definition im Komponenten-Editor im Modus Batch Component Editing zu sehen. In diesem Fall wird der Standard-Footprint als PCBLIB (default) bezeichnet.

Import und Export von Komponentenvorlagen

Eine vorhandene Komponentenvorlagendatei (*.CMPT) oder Komponentenbibliotheksdatei (*.CMPLIB) kann in den Komponentenvorlagen-Editor importiert werden. Die gerade bearbeitete Komponentenvorlage kann in eine Komponentenvorlagendatei (*.CMPT) exportiert werden. Verwenden Sie die Befehle File » Import » Component Template, File » Import » Component Library und File » Export im Hauptmenü des Komponenten-Editors, um die gewünschte Aktion auszuwählen. Navigieren Sie anschließend im sich öffnenden Windows-Standarddialog zum gewünschten Speicherort und wählen Sie eine Datei für den Import aus oder legen Sie den Namen der zu exportierenden Datei fest.

Wiederverwenden einer Komponentenvorlage

Eine Revision einer Komponentenvorlage lässt sich auf folgende Weise verwenden – genauer gesagt, aus der Revision einer Komponente heraus referenzieren, die Sie gerade bearbeiten.

Eine Komponente kann immer nur eine Komponentenvorlage referenzieren.

Beim Erstellen einer neuen Komponente

Wenn Sie mit dem Befehl File » New » Component aus den Hauptmenüs eine neue Komponente erstellen, können Sie die Vorlage im Dialog Create new component auswählen.

Schnelles Verknüpfen einer Komponentenvorlage aus einer Liste aller verfügbaren Vorlagen beim Erstellen einer neuen Komponente.
Schnelles Verknüpfen einer Komponentenvorlage aus einer Liste aller verfügbaren Vorlagen beim Erstellen einer neuen Komponente.

Manuell im Komponenten-Editor

Wie eine Revision einer Komponentenvorlage im Komponenten-Editor wiederverwendet wird, hängt vom Betriebsmodus des Editors ab.

Im Einzelkomponenten-Bearbeitungsmodus

Wenn Sie in diesem Modus des Komponenten-Editors eine einzelne Komponente bearbeiten, wählen Sie die gewünschte Komponentenvorlage aus dem Dropdown-Menü des Felds Template aus. Dieses Feld gehört zur Gruppe Advanced Settings im Bereich Component des Editors. Alle Komponentenvorlagen, die derzeit im selben Workspace wie die Komponente verfügbar sind, werden nach Namen aufgelistet; ihre neuesten Revisionen sind in Klammern angegeben. Wählen Sie die gewünschte Vorlage aus, um sie anzuwenden.

Schnelles Verknüpfen einer Komponentenvorlage aus einem Menü aller verfügbaren Vorlagen beim Bearbeiten einer Komponentenrevision im Komponenten-Editor im Modus Single Component Editing.
Schnelles Verknüpfen einer Komponentenvorlage aus einem Menü aller verfügbaren Vorlagen beim Bearbeiten einer Komponentenrevision im Komponenten-Editor im Modus Single Component Editing.

Im Stapelbearbeitungsmodus für Komponenten

Es gibt zwei Möglichkeiten, eine Revision einer Komponentenvorlage mit der gerade bearbeiteten Komponentenrevision zu verknüpfen:

  • Über die Registerkarte Template des Dialogs Dokumentoptionen (Edit » Document Options). Klicken Sie auf die Schaltfläche Choose rechts neben dem Feld Item Revision. Dadurch wird der Dialog Choose Item geöffnet (eine Variante des Explorer-Panels). Navigieren Sie in diesem Dialog zur gewünschten Komponentenvorlage und wählen Sie deren Revision aus. Nachdem Sie auf OK geklickt haben, wird eine Verknüpfung zwischen der Komponentenrevision und der Zielrevision der Komponentenvorlage erstellt. Diese Verknüpfung ist anschließend auf der Registerkarte Template des Dialogs Document Options sichtbar.

    Manuelles Verknüpfen einer Komponente mit einer Revision einer Komponentenvorlage im Ziel-Workspace.
    Manuelles Verknüpfen einer Komponente mit einer Revision einer Komponentenvorlage im Ziel-Workspace.

    Die verwendete Komponentenvorlage kann jederzeit geändert werden – klicken Sie auf Choose und wählen Sie eine Revision einer anderen Komponentenvorlage aus.
    Der Status der verknüpften Komponentenvorlagen-Item-Revision wird auf der Registerkarte Template des Dialogs Document Options angezeigt. Wenn eine neuere Revision des verknüpften Items verfügbar ist, klicken Sie auf die Schaltfläche , um diese neueste Revision zu verwenden.
  • Über das Menü Add, das dem Bereich Required Models/Parameters des Komponenten-Editors zugeordnet ist. Das Untermenü Templates listet alle Komponentenvorlagen, die derzeit im selben Workspace wie die Komponente verfügbar sind, nach Namen auf; ihre neuesten Revisionen sind in Klammern angegeben. Klicken Sie auf einen Eintrag, um eine Verknüpfung zur neuesten Revision dieser Komponentenvorlage zu erstellen. Die Verknüpfung lässt sich wiederum auf der Registerkarte Templates des Dialogs Document Options überprüfen.

    Schnelles Verknüpfen einer Komponentenvorlage aus einem Menü aller verfügbaren Vorlagen.
    Schnelles Verknüpfen einer Komponentenvorlage aus einem Menü aller verfügbaren Vorlagen.

Vom Komponentenordner im Workspace geerbt

Sie können eine Komponentenvorlage festlegen, die automatisch für alle Komponenten (und deren Revisionen) verwendet wird, die in einem Komponentenordner im Workspace gespeichert sind.

Eine Standard-Komponentenvorlage kann nur für einen Ordner des Typs Components definiert werden.

Legen Sie die gewünschte Vorlage über das Feld Component Template fest, wenn Sie die Ordnereigenschaften im Dialog Ordner bearbeiten definieren. Die Dropdown-Liste des Felds enthält alle Komponentenvorlagen, die derzeit im selben Workspace wie der Komponentenordner verfügbar sind, nach Namen aufgelistet; ihre neuesten Revisionen sind in Klammern angegeben. Wählen Sie einen Eintrag aus, um für jede anschließend in diesem Ordner erstellte Komponente eine Verknüpfung zur neuesten Revision dieser Komponentenvorlage zu erstellen.

Festlegen einer Standard-Komponentenvorlage, die auf alle im übergeordneten Komponentenordner erstellten Komponenten angewendet wird.
Festlegen einer Standard-Komponentenvorlage, die auf alle im übergeordneten Komponentenordner erstellten Komponenten angewendet wird.

Wenn Sie diese Funktion nicht verwenden möchten, belassen Sie das Feld Component Template auf None oder setzen Sie es auf diesen Wert.

Wenn auf Ordnerebene eine Komponentenvorlage ausgewählt wird, wird standardmäßig dieselbe Vorlage verwendet, wenn Komponenten in darunterliegenden Unterordnern erstellt werden. So lässt sich die Vorlage schnell an alle Komponenten in untergeordneten Ordnern vererben.

Wenn eine Komponentenrevision im Workspace gespeichert wird, wird damit die verwendete Revision der Komponentenvorlage festgeschrieben – es entsteht eine feste Verknüpfung zu dieser Revision, sofern sie nicht manuell geändert wird.

Auswirkungen auf Komponentenmodelle und Parameter bei Verwendung einer Komponentenvorlage

Wenn Sie eine Komponentenrevision bearbeiten und dabei eine Revision einer Komponentenvorlage verknüpft oder referenziert wird, geschieht im Komponenten-Editor hinsichtlich der Modelle und Parameter Folgendes:

  • Die in der referenzierten Vorlage definierten Modelle werden dem Bereich Models (Modus Single Component Editing) und dem Bereich Model Links (Modus Batch Component Editing) hinzugefügt.
  • Ein bereits referenziertes Modell bleibt erhalten, und die Komponente verwendet dieses Modell weiterhin, sofern es nicht gezielt manuell geändert wird.
  • Die in der referenzierten Vorlage definierten Parameter werden dem Bereich Parameters (Modus Single Component Editing) und dem Bereich Required Models/Parameters (Modus Batch Component Editing) hinzugefügt.

    Beispiel für Parameter nach der Verknüpfung mit einer Revision einer Komponentenvorlage bei Verwendung des Komponenten-Editors im Modus Single Component Editing (links) und im Modus Batch Component Editing (rechts).
    Beispiel für Parameter nach der Verknüpfung mit einer Revision einer Komponentenvorlage bei Verwendung des Komponenten-Editors im Modus Single Component Editing (links) und im Modus Batch Component Editing (rechts).

    Alle Parameter, die aus der referenzierten Komponentenvorlage stammen, werden durch das Symbol (Modus Single Component Editing) bzw. das Symbol (Modus Batch Component Editing) gekennzeichnet. Darüber hinaus übernimmt die Option Show für jeden vorlagenbasierten Parameter den Zustand der entsprechenden Option Visible in der Vorlage – dies gilt nur für den Stapelbearbeitungsmodus für Komponenten.
    Vorlagenbasierte Parameter können nicht entfernt werden.
    Sie können nach Bedarf zusätzliche benutzerdefinierte Parameter hinzufügen.
  • Nur im Modus Batch Component Editing werden vorlagenbasierte Parameter, die zur Anzeige vorgesehen sind, im Komponentendefinitionsbereich des Editors zusammengefasst. Dabei wird Template Parameters als Überschrift verwendet.

    Darstellung beispielhafter vorlagenbasierter Parameter in dem Bereich, in dem die Komponentendefinitionen selbst festgelegt werden, wenn der Komponenten-Editor im Modus Batch Component Editing verwendet wird.
    Darstellung beispielhafter vorlagenbasierter Parameter in dem Bereich, in dem die Komponentendefinitionen selbst festgelegt werden, wenn der Komponenten-Editor im Modus Batch Component Editing verwendet wird.

  • Die Wertefelder für vorlagenbasierte Parameter, die als schreibgeschützt gekennzeichnet wurden, können nicht bearbeitet werden. Bei allen anderen vorlagenbasierten Parametern, die nicht als schreibgeschützt gekennzeichnet wurden, können Sie die Werte nach Bedarf ändern.

    Wenn sich der Komponenten-Editor im Modus Single Component Editing befindet, wird ein schreibgeschützter Vorlagenparameter im Bereich Parameters durch das Symbol gekennzeichnet.
  • Wenn ein vorlagenbasierter Parameter als erforderlich gekennzeichnet wurde, ihm aber in der Vorlage kein Wert zugewiesen wurde, erscheint sein Wertefeld mit einem roten Rahmen (im Modus Batch Component Editing) oder mit dem Symbol (im Modus Single Component Editing). Dies weist darauf hin, dass für diesen Parameter ein Wert erforderlich ist. Sie können eine Komponente erst im Workspace speichern, wenn für alle erforderlichen Parameter Werte festgelegt wurden.

    Wenn sich der Komponenten-Editor im Modus Single Component Editing befindet, wird ein erforderlicher Vorlagenparameter im Bereich Parameters durch das Symbol gekennzeichnet.

Erneutes Speichern einer Komponentenvorlage

Sie können jederzeit zu einer beliebigen Revision einer Komponentenvorlage im Workspace zurückkehren und diese direkt bearbeiten. Klicken Sie mit der rechten Maustaste auf die Revision und wählen Sie im Kontextmenü den Befehl Edit. Der temporäre Editor wird erneut geöffnet, wobei die in der Revision enthaltene Vorlage zur Bearbeitung bereitsteht. Nehmen Sie die erforderlichen Änderungen vor und speichern Sie die Komponentenvorlage anschließend als nächste Revision des Items.

Wenn Sie mit der rechten Maustaste auf den obersten Eintrag der Komponentenvorlage selbst klicken, wird die neueste Revision dieser Vorlage bearbeitet.

Zugriff auf den Befehl zum Starten der direkten Bearbeitung einer vorhandenen Revision einer Komponentenvorlage.
Zugriff auf den Befehl zum Starten der direkten Bearbeitung einer vorhandenen Revision einer Komponentenvorlage.

Herunterladen gespeicherter Daten

Laden Sie die in einer Revision einer Komponentenvorlage gespeicherten Daten herunter, indem Sie mit der rechten Maustaste auf diese Revision (im Panel Explorer) klicken und im Kontextmenü den Befehl Operations » Download wählen. Die Komponentenvorlagendatei wird in einen Unterordner des ausgewählten Verzeichnisses heruntergeladen, der nach der Item-Revisions-ID benannt ist. Die Datei befindet sich dort im Ordner Released.

Rufen Sie den Befehl Download über den obersten Eintrag der Komponentenvorlage selbst auf, um die in der neuesten Revision dieser Vorlage gespeicherte Komponentenvorlagendatei herunterzuladen.
Klicken Sie im Dialogfeld Download from Server auf die Schaltfläche Explore, um direkt zum Download-Ordner zu gelangen.

Vorläufiges Löschen

Wenn eine Verbindung zu einem Workspace besteht, stehen Ihnen flexible Funktionen zur Verfügung, um eine Komponentenvorlage direkt in Altium Designer über das Explorer-Panel zu entfernen. Klicken Sie mit der rechten Maustaste auf den Eintrag der Komponentenvorlage im Panel und wählen Sie im Kontextmenü den Befehl Delete Item. Das Dialogfeld Delete Items wird angezeigt, in dem Sie das Löschen bestätigen können. Bei diesem Vorgang handelt es sich um ein „vorläufiges Löschen“, bei dem die Komponentenvorlage in den Bereich Trash des Workspace verschoben wird. Trash ist im Wesentlichen ein Papierkorb, in den beliebige Inhalte Ihres Workspace verschoben werden können (durch vorläufiges Löschen). Er ist vom übrigen Workspace getrennt.

Mit der Funktion zum vorläufigen Löschen können Sie auch eine Komponentenvorlage löschen, die derzeit verwendet wird.
Mehrere Komponentenvorlagen können in einem einzigen Vorgang gelöscht werden. Wählen Sie alle gewünschten Komponentenvorlagen mit den üblichen Methoden zur Mehrfachauswahl (Shift+Click, Ctrl+Click) aus, klicken Sie anschließend mit der rechten Maustaste und wählen Sie im Kontextmenü den Befehl Delete Items.

Vorläufiges Löschen einer Komponentenvorlage. Die Vorlage wird in den Bereich Trash des Workspace verschoben.
Vorläufiges Löschen einer Komponentenvorlage. Die Vorlage wird in den Bereich Trash des Workspace verschoben.

Um mit dem Löschen fortzufahren, klicken Sie auf die Schaltfläche . Das Item wird entfernt und das Dialogfeld Deletion Summary bestätigt das erfolgreiche Löschen. Falls beim Löschen ein Problem aufgetreten ist, werden Sie darauf hingewiesen.

Alle auf diese Weise gelöschten Inhalte finden Sie auf der Seite Trash der Browseroberfläche des Workspace. Beachten Sie, dass Sie nur Inhalte sehen können, die Sie selbst vorläufig gelöscht haben. Administratoren können den gesamten Inhalt der Seite Trash sehen – also alle Inhalte, die vorläufig gelöscht wurden.

Bei einer vorläufig gelöschten Komponentenvorlage ist Folgendes zu beachten:

  • Die Komponentenvorlage ist weder in Ihrer Designsoftware noch in der Weboberfläche verfügbar.
  • Überall dort, wo die Komponentenvorlage verwendet wurde, wird angezeigt, dass sie gelöscht wurde.
  • Eine Komponentenvorlage kann auf der Seite Trash wiederhergestellt oder endgültig gelöscht werden, sofern Sie über Bearbeitungsrechte verfügen. Ein endgültiges Löschen ist nur möglich, wenn sie nicht von einem übergeordneten Item verwendet wird.
Beachten Sie: Wenn Sie eine Komponentenvorlage vorläufig gelöscht – also nach Trash verschoben – haben, können Sie erneut eine Komponentenvorlage mit demselben Namen erstellen. Wenn Sie anschließend die ursprüngliche Komponentenvorlage wiederherstellen und ihr ursprünglicher Name bereits vergeben ist, wird eine Ganzzahl als Suffix angehängt, damit ihr Name innerhalb des Workspace eindeutig bleibt.
AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents