Komponentenvorlagen
Auf einen Blick
- Erfahren Sie, wie Sie Workspace-Ordner und Bauteilvorlagen-Items mit geeigneten Benennungs-, Revisions- und Lebenszyklusschemata einrichten.
- Verstehen Sie, wie Vorlagen Bauteilparameter steuern, einschließlich erforderlicher Werte und schreibgeschützter Standardwerte.
- Entdecken Sie, wie Sie Vorlagen direkt bearbeiten und als neue Revisionen in Ihrem Workspace speichern.
Um die Erstellung Ihrer Bauteile zu vereinfachen, unterstützt Altium Designer in Verbindung mit Ihrem verbundenen Workspace das Erstellen und Definieren von Component Templates (Component Template Items) in diesem Workspace. So wie sich mit einer Schaltplanvorlage Informationen auf den Schaltplanblättern vordefinieren lassen, die auf diese Vorlage verweisen, wird eine Bauteilvorlage von einem Workspace-Bibliotheksbauteil referenziert und stellt vordefinierte Einstellungen für die Definition dieses Bauteils bereit.
Bauteilvorlagen wurden insbesondere im Hinblick auf Parameterinformationen entwickelt. Sie ermöglichen es Ihnen, an einer zentralen Stelle einen Parametersatz zu definieren, der dem referenzierenden Bauteil zur Verfügung gestellt wird. Über die Vorlage können Sie festlegen, welche dieser Parameter sichtbar sein sollen, Standardwerte eintragen und erforderliche Parameter sogar als Pflichtangaben kennzeichnen. Beim Speichern des Bauteils wird durch Validierungsprüfungen sichergestellt, dass diese Vorgaben eingehalten werden.
Solche Bauteilvorlagen werden direkt im Workspace erstellt. Sobald eine Bauteilvorlage erstellt wurde und ihre Daten in einer Revision gespeichert wurden, kann sie zur Erstellung eines oder mehrerer Bauteile wiederverwendet werden.
Ordnertyp
Beim Erstellen des Ordners, in dem Bauteilvorlagen gespeichert werden sollen, können Sie den Ordnertyp festlegen. Dies hat keinen Einfluss auf den Inhalt des Ordners – die Freigabe einer Bauteilvorlage führt immer zu einem entsprechenden Component Template Item. Der Ordnertyp bietet lediglich einen visuellen Hinweis auf den Inhalt eines Ordners und kann hilfreich sein, wenn Sie einen Workspace nach bestimmten Inhalten durchsuchen. Um einen Ordner als Ablage für Bauteilvorlagen zu kennzeichnen, setzen Sie dessen Folder Type auf Component Templates, wenn Sie die Ordnereigenschaften im Dialogfeld „Edit Folder“ festlegen.

Die Angabe des Ordnertyps – also seines Verwendungszwecks – gibt beim Durchsuchen des Workspace einen visuellen Hinweis auf den Inhalt dieses Ordners.
Item-Benennungsschema
Ein weiterer wichtiger Aspekt des übergeordneten Ordners ist das dafür verwendete Item Naming Scheme. Es legt das Format der eindeutigen ID für jedes Item fest, das in diesem Ordner erstellt wird. Es stehen mehrere vordefinierte Beispielschemata zur Verfügung, die den Kurzcode für den Ordnertyp (CTC – Bauteilvorlagensammlung) oder den Inhaltstyp (CMPT – Bauteilvorlage) verwenden:
-
$CONTENT_TYPE_CODE-001-{0000}– zum BeispielCMPT-001-0001. -
$CONTENT_TYPE_CODE-001-{A00}– zum BeispielCMPT-001-A01. -
$FOLDER_TYPE_CODE-001-{0000}– zum BeispielCTC-001-0001. -
$FOLDER_TYPE_CODE-001-{A000}– zum BeispielCTC-001-A001.
Bei Verwendung eines vordefinierten Benennungsschemas weist die Software automatisch die nächste verfügbare eindeutige ID gemäß diesem Schema zu, nachdem sie den gesamten Workspace und die Kennungen vorhandener Inhalte durchsucht hat. Dies kann beim manuellen Erstellen von Bauteilvorlagen viel Zeit sparen.
Sie können für einen Ordner auch ein benutzerdefiniertes Schema festlegen, indem Sie es einfach in das Feld eingeben. Achten Sie darauf, den variablen Teil in geschweifte Klammern zu setzen (z. B. CMP-TMP-{0000}).

Das Item-Benennungsschema des übergeordneten Ordners wird auf die eindeutige ID jedes Items angewendet, das in diesem Ordner erstellt wird.
Inhaltstyp
Wenn Sie ein Component Template Item als Ziel zum Speichern Ihrer Bauteilvorlage erstellen, stellen Sie sicher, dass dessen Content Type im Dialogfeld „Create New Item“ auf Component Template gesetzt ist. Wenn Sie das Item in einem Ordner des Typs Component Templates erstellen, steht dieser Inhaltstyp beim Erstellen des Items im Rechtsklick-Kontextmenü zur Verfügung.

Erstellen einer Bauteilvorlage in einem Ordner vom Typ Component Templates – der richtige Content Type steht im Kontextmenü zur Verfügung.
Lebenszyklusdefinition und Revisionsbenennung für Items
Related pages: Revisionsbenennungsschemata für einen Workspace definieren, Lebenszyklusdefinitionen für einen Workspace festlegen
Achten Sie beim Definieren einer Bauteilvorlage darauf, sowohl die Art der Lebenszyklusverwaltung für die Bauteilvorlage als auch das Benennungsschema für ihre Revisionen anzugeben.
Welche Inhaltstypen eine bestimmte Lebenszyklusdefinition oder ein bestimmtes Revisionsbenennungsschema verwenden dürfen, kann beim Definieren des jeweiligen Schemas im Dialogfeld Content Types global festgelegt und aktiviert werden. Die einer Bauteilvorlage standardmäßig zugewiesenen Schemata sind Generic Lifecycle bzw. 1-Level Revision Scheme.
Legen Sie die erforderlichen Schemata im Dialogfeld Create New Item über die Felder Lifecycle Definition bzw. Revision Naming Scheme fest.

Auswahl der Lebenszyklusdefinition und der Revisionsbenennungsschemata für eine manuell erstellte Bauteilvorlage.
Eine Bauteilvorlage speichern
Related page: Inhalte erstellen und bearbeiten
Bisher haben wir die Unterstützung für Bauteilvorlagen im Workspace im Hinblick auf die zugehörigen Ordner- und Inhaltstypen erläutert. Das Speichern einer tatsächlich definierten Bauteilvorlage in einer Revision eines solchen Component Template Items lässt sich auf einfache Weise durchführen.
Dank der Unterstützung des Workspace für die direkte Bearbeitung kann eine Bauteilvorlage bearbeitet und in der ersten Revision eines neu erstellten Component Template Items gespeichert werden. Die direkte Bearbeitung befreit Sie von der Notwendigkeit, separate, versionsverwaltete Quelldaten zu pflegen. Sie können einen unterstützten Inhaltstyp einfach in einem temporären Editor bearbeiten, in den die neuesten Quelldaten direkt aus dem Workspace geladen werden. Sobald die Bearbeitung abgeschlossen ist, wird das Objekt in einer nachfolgenden geplanten Revision des übergeordneten Items gespeichert bzw. erneut gespeichert und der temporäre Editor geschlossen. Es gibt keine Dateien auf Ihrer Festplatte, keine Zweifel daran, ob Sie mit den richtigen oder neuesten Quelldaten arbeiten, und keine Notwendigkeit, separate Versionsverwaltungssoftware zu pflegen. Der Workspace übernimmt all dies mit hoher Datenintegrität und beschleunigt Änderungen an Ihren Daten erheblich.
Wenn Sie ein Komponentenvorlagen-Item erstellen, können Sie nach der Erstellung eine Komponentenvorlage bearbeiten und in der ersten Revision dieses Items speichern. Aktivieren Sie dazu die Option Open for editing after creation unten im Dialog Create New Item (standardmäßig aktiviert). Das Item wird erstellt und der temporäre Komponentenvorlagen-Editor geöffnet. Dabei wird ein .CMPT-Dokument als aktives Dokument im Hauptentwurfsfenster angezeigt. Dieses Dokument wird entsprechend der Item-Revision im folgenden Format benannt: <Item><Revision>.CMPT (z. B. CMPT-0001-1.CMPT).
Verwenden Sie das Dokument, um die Komponentenvorlage nach Bedarf zu definieren. Weitere Informationen hierzu finden Sie unter Definieren der Vorlage.
Für die direkte Bearbeitung stehen drei relevante Bedienelemente zur Verfügung, die über Quick Access Bar (oben links im Hauptanwendungsfenster) oder über die Symbolleiste Component Template Standard zugänglich sind:
-
– Save Active Document. Verwenden Sie diese Schaltfläche, um alle am Dokument vorgenommenen Änderungen lokal zu speichern. So können Sie den aktuellen Stand speichern und später weitere Änderungen vornehmen, bevor Sie das Dokument schließlich im Workspace speichern.
-
/
– Save to Server. Verwenden Sie diese Schaltfläche, um die definierte Komponentenvorlage im Workspace zu speichern. Sie wird dabei in der ersten (geplanten) Revision des Ziel-Komponentenvorlagen-Items abgelegt. Der Dialog Edit Revision wird angezeigt, in dem Sie bei Bedarf den Namen und die Beschreibung ändern sowie Freigabehinweise hinzufügen können. Nach dem Speichern werden das Dokument und der Editor geschlossen. Das Dokument mit der Quell-Komponentenvorlage, *.CMPT, wird in der Revision des Items gespeichert. -
/
– Discard Local Changes. Verwenden Sie diese Schaltfläche, wenn Sie die Bearbeitung abbrechen und alle vorgenommenen Änderungen verwerfen möchten. Das Dokument und der Editor werden geschlossen, und es wird nichts für das Ziel-Komponentenvorlagen-Item freigegeben.
Diese Bedienelemente stehen auch als Befehle – Save (Tastenkürzel: Ctrl+S), Save to Server (Tastenkürzel: Ctrl+Alt+S) und Discard Local Changes – im Hauptmenü File sowie im Kontextmenü des Komponentenvorlageneintrags im Panel Projects zur Verfügung.
Die im Workspace gespeicherten Daten bestehen aus der Quell-Komponentenvorlage, die in der Komponentenvorlagendatei (<Item><Revision>.CMPT) definiert ist.
Vererbung einer Komponentenvorlage
Sie können eine Komponentenvorlage des übergeordneten Komponententyps verwenden, wenn mit dem Untertyp keine Komponentenvorlage verknüpft ist. Beim Aufbau einer Hierarchie von Komponententypen erben die Komponentenuntertypen die Komponentenvorlage, die dem obersten bzw. übergeordneten Komponententyp zugewiesen ist.
Der CMPT-Editor (Komponentenvorlagen-Editor)
Definieren der Vorlage
Der Komponentenvorlagen-Editor ist im Wesentlichen in zwei Hauptbereiche unterteilt, die in der folgenden Abbildung dargestellt und anschließend zusammengefasst werden.
- Upper Region – zum Definieren von Optionen auf Komponentenebene (Lebenszyklus-, Benennungs- und Ordneroptionen) für eine Komponente, die auf die Vorlage verweist.
- Lower Region – zum Definieren der Parameter, die für eine Komponente verwendet werden sollen, die auf die Vorlage verweist.
Festlegen von Komponentenoptionen
Die obere Hälfte des Editors dient zum Definieren von Standardwerten für die folgenden Komponenteneigenschaften:
-
Lifecycle Definition – wählen Sie die Lebenszyklusdefinition aus, die auf eine mit der Vorlage erstellte Komponente angewendet werden soll. Das Dropdown-Feld listet alle für den Workspace definierten Definitionen auf, die für die Verwendung durch eine Komponente zulässig sind.
-
Revision Naming – wählen Sie das Revisionsbenennungsschema aus, das auf eine mit der Vorlage erstellte Komponente angewendet werden soll. Das Dropdown-Feld listet alle für den Workspace definierten Schemata auf, die für die Verwendung durch eine Komponente zulässig sind.
-
Component Naming – verwenden Sie dieses Feld, um ein standardmäßiges Item-Benennungsschema für eine mit der Vorlage erstellte Komponente festzulegen. So wird eine eindeutige ID für die resultierende Komponente im Workspace sichergestellt. Der hier eingegebene Eintrag dient als Vorlage für die automatische Benennung der Komponente (im zugehörigen Feld Id, wenn der Komponenteneditor im Modus Single Component Editing verwendet wird, bzw. im Feld Item ID, wenn der Komponenteneditor im Modus Batch Component Editing verwendet wird). Die Software durchsucht den gesamten Workspace und die Kennungen vorhandener Inhalte und weist anhand dieses Schemas automatisch die nächste verfügbare eindeutige ID zu. Ein standardmäßiges Item-Benennungsschema –
CMP-{00000}– ist bereits vorhanden. Sie können jedoch selbstverständlich Ihr eigenes Schema erstellen, indem Sie es in das Feld eingeben. Achten Sie dabei darauf, den variablen Teil in geschweifte Klammern einzuschließen (z. B.CMP-001-{0000}). -
Default Folder – hiermit legen Sie einen Standardordner im Ziel-Workspace fest, in dem eine gespeicherte Komponente abgelegt werden soll. Klicken Sie dazu auf die Schaltfläche Choose, um den Dialog Choose Folder (eine Variante des Explorer-Panels) zu öffnen. Dort können Sie zu einem vorhandenen Ordner im Workspace navigieren und diesen auswählen oder direkt einen neuen Ordner erstellen.
Wenn die Vorlage referenziert wird, werden die in diesem Bereich angegebenen Einträge verwendet, um die entsprechenden Felder im Komponenteneditor vorab auszufüllen (sofern vorhanden):
- Single Component Editing mode – die Felder Id und Folder im Bereich Advanced Settings des Abschnitts Component.
- Batch Component Editing mode – auf der Registerkarte Document Options des Dialogs Document Options und folglich in den Feldern Item ID und FolderPath im Bereich Component des Abschnitts mit den Komponentendefinitionen.

Wenn die Vorlage referenziert wird, werden die Einträge verwendet, um die entsprechenden Felder beim Bearbeiten einer Komponente im Komponenteneditor im Modus Single Component Editing (links) und im Modus Batch Component Editing (rechts) vorab auszufüllen.
Parameter definieren
Die untere Hälfte des Editors dient zum Definieren und Verwalten der Parameter, die einer Komponente zur Verfügung stehen, welche die Vorlage referenziert.
Standardmäßige Systemparameter
Beim Erstellen einer neuen Komponentenvorlage sind standardmäßig verschiedene Systemparameter enthalten, wie in der folgenden Abbildung gezeigt und anschließend ausführlich beschrieben.
-
ComponentType– mit diesem Parameter können Sie den Komponententyp angeben. Dies erleichtert die gezielte Suche mit der leistungsfähigen Suchfunktion des Workspace. Diese ermöglicht nicht nur die Suche nach Komponententyp, sondern auch eine intelligentere Suche mithilfe unterstützter einheitenbezogener Komponentenparameter. Wenn Sie Ihre eigenen Workspace-Komponenten im Components-Panel durchsuchen, wird die Gruppierung Categories der Komponenten aus den ParameternComponentTypeabgeleitet, die der jeweiligen Komponente zugeordnet sind. Klicken Sie auf das zugehörige Feld Default Value und anschließend auf die Schaltfläche
, um den Dialog Choose component type zu öffnen. Wählen Sie darin den gewünschten Komponententyp aus und klicken Sie auf OK. Der ausgewählte Typ wird daraufhin als Wert für den Parameter ComponentType in die Hauptparametertabelle übernommen.

Beispiel einer Komponentenvorlage, bei der der Systemparameter ComponentType aufDiodesgesetzt ist. -
SCHLIBundPCBLIB– mit diesen beiden Parametern können Sie ein standardmäßiges Symbol- bzw. Footprint-Modell festlegen. Klicken Sie für jeden Parameter auf das zugehörige Feld Default Value und anschließend auf die Schaltfläche
, um einen Dialog zur Auswahl des gewünschten Modells zu öffnen.

Legen Sie Symbol- und Footprint-Modelle als Bestandteil Ihrer Vorlage fest. -
NameundDescription– mit diesen beiden Parametern können Sie den Namen bzw. die Beschreibung der Komponente definieren. Geben Sie die gewünschten Zeichenfolgen für jeden Parameter in das zugehörige Feld Default Value ein.
Legen Sie die ParameterNameundDescriptionals Bestandteil Ihrer Vorlage fest.
Hinzufügen eines neuen Benutzerparameters
Um einen neuen Benutzerparameter zur Liste hinzuzufügen, klicken Sie auf die Schaltfläche
(oder verwenden Sie den Befehl Add aus dem Kontextmenü) – der Parameter wird am Ende der aktuellen Liste hinzugefügt.

Beispiel für das Hinzufügen eines neuen Benutzerparameters zur Vorlage.
Jeder Parameter wird in der Tabelle mit den folgenden Informationen aufgeführt:
-
Name – Verwenden Sie dieses Feld, um den Parameter zu benennen, üblicherweise mit einem aussagekräftigen Namen, der seinen Zweck vermittelt. Beim Hinzufügen erhalten Parameter zunächst Standardnamen (
Parameter,Parameter 1,Parameter 2usw.). -
Type – Der Parametertyp. Dieser Eintrag ist zunächst standardmäßig auf
Textgesetzt. Es werden jedoch verschiedene einheitenbezogene Datentypen unterstützt, ebenso wie der TypPCBLIB, der die Definition mehrerer Footprints ermöglicht, undHarnessWiring, der die Definition einer Kabelbaum-Verdrahtungskomponente ermöglicht. Auch Parametertypen, die durch verfügbare Wörterbücher definiert sind, werden unterstützt – mehr erfahren. -
Visible – Aktivieren Sie diese Option (die bei einem neu hinzugefügten Parameter standardmäßig aktiviert ist), damit die entsprechende Option Show für den Parameter beim Bearbeiten eines oder mehrerer Bauteile im Bauteileditor (im Modus Batch Component Editing) aktiviert ist. Dies wiederum steuert die Anzeige der entsprechenden Spalte für diesen Parameter im unteren Bereich des Bauteileditors, in dem die eigentlichen Bauteildefinitionen festgelegt werden. Diese Eigenschaft hat keine Auswirkung, wenn ein Bauteil im Modus Single Component Editing des Editors definiert wird.
-
Read Only – Aktivieren Sie diese Option, um den Parameter schreibgeschützt zu machen. Beim Bearbeiten eines Bauteils, das auf die Vorlage verweist, kann der Wert dieses Parameters nicht bearbeitet werden.
-
Required – Aktivieren Sie diese Option, um den Parameter als Pflichtparameter festzulegen. Beim Bearbeiten eines Bauteils, das auf die Vorlage verweist, muss für diesen Parameter ein Wert definiert sein. Andernfalls kann das Bauteil nicht gespeichert werden. Im Bauteileditor ist ein solcher Parameter bei fehlendem Wert durch eine rote Umrandung der Wertzelle (im Modus Batch Component Editing) oder durch das Symbol
in der Wertzelle (im Modus Single Component Editing) gekennzeichnet.
-
Default Value – Verwenden Sie dieses Feld, um einen Standardwert für den Parameter einzugeben.
-
Description – Fügen Sie eine beliebige Beschreibung für den Parameter hinzu, beispielsweise eine kurze Erläuterung seines Zwecks. Wenn für einen Parameter in der Vorlage eine Beschreibung definiert ist, wird die Spalte Description im Bereich Parameters des Bauteileditors entsprechend in dessen Single Component Editing angezeigt.
Die Parameterliste unterstützt auch einfache Kopier- und Einfügevorgänge, mit denen Sie einen oder mehrere vorhandene Benutzerparameter duplizieren können. Die eingefügten Parameter werden am Ende der Liste hinzugefügt.
Spaltenreihenfolge und -breite
Die Reihenfolge der Spalten lässt sich anpassen. Klicken Sie auf die Kopfzeile einer Spalte und ziehen Sie diese horizontal an die gewünschte neue Position. Gültige Positionen werden durch vertikale Positionspfeile hervorgehoben.
Sortierung
Parameter können nach einer bestimmten Spalte sortiert werden, indem Sie auf deren Kopfzeile klicken. Klicken Sie einmal, um aufsteigend zu sortieren (basierend auf dem Inhalt dieser Spalte). Klicken Sie erneut, um absteigend zu sortieren.
Sie können nach mehreren Spalten sortieren. Wenn die Parameter bereits nach einer bestimmten Spalte sortiert sind, führen Sie Shift+Click auf einer anderen Spalte aus, um eine zusätzliche Sortierung nach dem Inhalt dieser Spalte vorzunehmen.
Einheitenbezogene Datentypen für Komponentenparameter
Mit dem Component Template Editor können Sie explizite Datentypen für Komponentenparameter festlegen, die innerhalb einer Komponentenvorlage definiert sind (*.CMPT). Darüber hinaus berücksichtigen diese Datentypen Einheiten und unterstützen eine Reihe gängiger Einheitenpräfixe. Somit können Sie den Wert eines Parameters in verschiedenen Formaten eingeben – etwa 2.2k, 2k2, 4M oder 2.5GHz. Der Workspace verfügt über die erforderliche Logik, um den numerischen Wert hinter diesen Eingaben zu erkennen.
Diese Funktion einer Komponentenvorlage ermöglicht eine gezielte Suche über die erweiterte Suchfunktion des Servers. Damit können Sie nicht nur nach Komponententyp suchen, sondern mithilfe von Bereichssuchen auch präzisere Suchabfragen durchführen. Dank einheitenbezogener Komponentenparameter können Sie schnell eine Suchabfrage definieren, um beispielsweise alle Kondensatoren mit einer Kapazität zwischen 47uF und 220uF zu finden.
In den folgenden aufklappbaren Abschnitten erfahren Sie mehr über einheitenbezogene Parameter.
Unterstützte Einheiten
Die folgenden einheitenbezogenen Datentypen werden unterstützt, wenn Sie einen Benutzerparameter als Teil einer Komponentenvorlage definieren:
-
Ganzzahl
-
Dezimalzahl
-
Ampere (A)
-
Fläche (mm2)
-
Bit
-
Candela (cd)
-
Celsius (C)
-
Dezibel (dB)
-
Farad (F)
-
Gramm (g)
-
Henry (H)
-
Hertz (Hz)
-
Joule (J)
-
Lumen (lm)
-
Meter (m)
-
Millimeter (mm)
-
Ohm
-
Prozent (%)
-
Pascal (Pa)
-
Bar (bar)
-
Pfund pro Quadratzoll (psi)
-
Umdrehungen pro Minute (rpm)
-
Sekunde (s)
-
Siemens (S)
-
Temperaturkoeffizient (ppm/°C)
-
Tesla (T)
-
Volt (V)
-
Watt (W)
Unterstützte Einheitenpräfixe
Die folgende Tabelle listet die Einheitenpräfixe auf, die bei der Eingabe eines Werts für einen einheitenbezogenen Parametertyp unterstützt werden.
| Präfix | Bezeichnung | Wert (wissenschaftliche Schreibweise) | Wert (normale Schreibweise) |
|---|---|---|---|
| T | Tera | 1 x 1012 | 1.000.000.000.000 |
| G | Giga | 1 x 109 | 1.000.000.000 |
| M | Mega | 1 x 106 | 1.000.000 |
| k | Kilo | 1 x 103 | 1.000 |
| m | Milli | 1 x 10-3 | 1 / 1.000 |
| u | Mikro | 1 x 10-6 | 1 / 1.000.000 |
| n | Nano | 1 x 10-9 | 1 / 1.000.000.000 |
| p | Piko | 1 x 10-12 | 1 / 1.000.000.000.000 |
| f | Femto | 1 x 10-15 | 1 / 1.000.000.000.000.000 |
Hinzufügen eines einheitenbezogenen Bauteilparameters
Wenn Sie der Vorlage einen Parameter hinzufügen (klicken Sie im Bereich Parameters auf , wählen Sie im zugehörigen Feld Type den gewünschten einheitenbezogenen Datentyp aus der Dropdown-Liste aus.

Auswahl eines unterstützten einheitenbezogenen Datentyps für einen benutzerdefinierten Parameter in einer Bauteilvorlage. In diesem Beispiel ist Ampere der Parametertyp.
Bei der Eingabe eines Werts für einen Bauteilparameter mit einem einheitenbezogenen Datentyp – entweder als Default Value in einer Bauteilvorlage oder als erforderlicher Wert in einer Bauteildefinition – ist Folgendes zu beachten:
-
Sie können den Wert in verschiedenen Formaten eingeben:
-
Nur Zahlenwert (z. B.
10). Beachten Sie, dass die Einheit automatisch angewendet wird, wenn der Datentyp eine Einheit besitzt. Bei Typen mit Einheiten steht die Einheit in Klammern hinter dem Namen. -
Zahlenwert in wissenschaftlicher Schreibweise (z. B.
1e10,1E6). -
Zahlenwert und Einheit (z. B.
10F)). -
Zahlenwert mit Präfix (z. B.
10k). Die entsprechende Einheit wird gegebenenfalls automatisch hinzugefügt. -
Zahlenwert mit Präfix und Einheit (z. B.
10kF). -
Zahlenwert mit Präfix in der üblichen technischen Schreibweise (z. B. für einen Widerstand:
2k2,2K2,10r2,10R2). Der Wert wird automatisch entsprechend normalisiert (z. B. wird2K2zu2.2k).
-
Nur Zahlenwert (z. B.
-
Sie können Präfix und/oder Einheit mit oder ohne Leerzeichen nach dem Zahlenwert eingeben (z. B.
10uFoder10 uF). Das Leerzeichen wird automatisch entfernt.
Datenvalidierung
Wenn für einen Bauteilparameter ein einheitenbezogener Datentyp verwendet wird, wird der eingegebene Wert anhand des angegebenen Datentyps validiert. Dadurch wird sichergestellt, dass die richtige Maßeinheit für diesen Datentyp verwendet wird. Ein Parameter vom Typ Celsius kann beispielsweise nicht den Wert 10V haben!
Die Validierung erfolgt überall dort, wo ein Bauteilparameter mit einem einheitenbezogenen Datentyp verwendet und ein Wert für diesen Parameter angegeben wird:
- Beim Festlegen eines Standardwerts für einen Parameter in einer Bauteilvorlage.
- Beim Festlegen eines Parameterwerts als Teil einer Bauteildefinition im Bauteileditor.
- Beim Konfigurieren einer Bereichssuche anhand eines Parameterwerts als Teil eines gespeicherten Suchschemas.

Beispiel für die Datenvalidierung im Bauteilvorlagen-Editor.
Durch Wörterbücher definierte Parameterdatentypen
Wörterbücher sind benutzerdefinierte Parametertypen mit mehreren festgelegten Werten. Wörterbücher werden von Workspace-Administratoren auf der Seite Settings – Vault – Dictionaries der Browseroberfläche des Workspace verwaltet. Sie können diese Seite vom Bauteilvorlagen-Editor aus aufrufen, indem Sie die Option Add New Dictionary aus der Dropdown-Liste Type auswählen oder auf das Steuerelement Manage Dictionaries oben rechts im Bereich Parameters klicken.

Rufen Sie vom Bauteilvorlagen-Editor aus die Seite zur Verwaltung von Wörterbüchern in der Browseroberfläche des Workspace auf.
Definierte Wörterbücher stehen in der Dropdown-Liste Type als Parametertypen zur Verfügung.

Wählen Sie in der Dropdown-Liste „Typ“ einen durch ein Wörterbuch definierten Parametertyp aus.
Die für den ausgewählten wörterbuchdefinierten Typ festgelegten Werte stehen in der Dropdown-Liste Default Value zur Verfügung. Wählen Sie den gewünschten Wert als Standardwert des Parameters aus oder wählen Sie <None>.

Wählen Sie einen Standardwert aus den für den ausgewählten wörterbuchdefinierten Typ festgelegten Werten aus.
Mehrere Footprints definieren
Der Component Template Editor unterstützt auch die Definition mehrerer Leiterplatten-Footprints innerhalb einer Bauteilvorlage. Es können beliebig viele Verknüpfungen zu Footprint-Modellen angegeben werden. Dies ist besonders hilfreich, wenn Sie Bauteile erstellen möchten, die auf drei Footprints verweisen und damit die IPC-Anforderungen für unterschiedliche Bestückungsdichten erfüllen: L (geringste bzw. minimale Kupferfläche), M (größte bzw. maximale Kupferfläche) und N (nominelle bzw. mittlere Kupferfläche).
Um der Vorlage eine weitere Footprint-Modelldefinition hinzuzufügen, klicken Sie auf
, um einen neuen Parameter hinzuzufügen. Wählen Sie anschließend im Dropdown-Menü des Feldes Type den Eintrag PCBLIB aus.

Wandeln Sie einen neu hinzugefügten Parameter in eine Footprint-Modelldefinition um, indem Sie dessen Type auf PCBLIB setzen.

Ein Beispielbauteil, das im Component Editor (Modus Single Component Editing) mithilfe einer referenzierten Bauteilvorlage definiert wird. In der Vorlage sind drei Footprint-Modelle definiert, die in die Bauteildefinition übernommen werden. Beachten Sie, dass der Modelleintrag PCBLIB in der Vorlage beim Definieren des Bauteils als Standard-Footprint-Modell verwendet wird (gekennzeichnet durch ein Symbol oben links). Bewegen Sie den Mauszeiger über das Bild, um zu sehen, wie dasselbe Bauteil im Component Editor im Modus Batch Component Editing definiert wird. In diesem Fall wird der Standard-Footprint als PCBLIB (default) bezeichnet.
Import und Export von Bauteilvorlagen
Eine vorhandene Bauteilvorlagendatei (*.CMPT) oder Bauteilbibliotheksdatei (*.CMPLIB) kann in den Bauteilvorlagen-Editor importiert werden. Die aktuell bearbeitete Bauteilvorlage kann als Bauteilvorlagendatei (*.CMPT) exportiert werden. Verwenden Sie die Befehle File » Import » Component Template, File » Import » Component Library und File » Export im Hauptmenü des Bauteil-Editors, um die gewünschte Aktion auszuwählen. Navigieren Sie im daraufhin geöffneten Windows-Standarddialog zum gewünschten Speicherort und wählen Sie eine zu importierende Datei aus oder legen Sie den Namen der zu exportierenden Datei fest.
Eine Bauteilvorlage wiederverwenden
Eine Revision einer Bauteilvorlage lässt sich auf die folgenden Arten verwenden – genauer gesagt: aus der aktuell bearbeiteten Revision eines Bauteils heraus referenzieren.
Beim Erstellen eines neuen Bauteils
Wenn Sie mit dem Befehl File » New » Component aus den Hauptmenüs ein neues Bauteil erstellen, können Sie die Vorlage im Dialog Create new component auswählen.

Beim Erstellen eines neuen Bauteils lässt sich eine Bauteilvorlage schnell aus einer Liste aller verfügbaren Vorlagen verknüpfen.
Manuell im Component Editor
Wie eine Revision einer Bauteilvorlage im Component Editor wiederverwendet wird, hängt vom Betriebsmodus des Editors ab.
Im Einzelbauteil-Bearbeitungsmodus
Wenn Sie ein einzelnes Bauteil in diesem Modus des Component Editor bearbeiten, wählen Sie die gewünschte Bauteilvorlage aus dem Dropdown-Menü des Feldes Template aus. Dieses gehört zur Gruppe Advanced Settings im Bereich Component des Editors. Alle aktuell im selben Workspace wie das Bauteil verfügbaren Bauteilvorlagen werden nach Namen aufgelistet; ihre jeweils neuesten Revisionen sind in Klammern angegeben. Wählen Sie die gewünschte Vorlage aus, um sie anzuwenden.

Beim Bearbeiten einer Bauteilrevision im Component Editor im Modus Single Component Editing lässt sich eine Bauteilvorlage schnell aus einem Menü aller verfügbaren Vorlagen verknüpfen.
Im Stapelbearbeitungsmodus
Es gibt zwei Möglichkeiten, eine Revision einer Bauteilvorlage mit der aktuell bearbeiteten Bauteilrevision zu verknüpfen:
-
Über die Registerkarte Template im Dialog Dokumentoptionen (Edit » Document Options). Klicken Sie auf die Schaltfläche Choose rechts neben dem Feld Item Revision. Dadurch wird der Dialog Choose Item geöffnet (eine Variante des Panels Explorer). Navigieren Sie in diesem Dialog zur gewünschten Bauteilvorlage und wählen Sie deren Revision aus. Nachdem Sie auf OK geklickt haben, wird eine Verknüpfung zwischen der Bauteilrevision und der Zielrevision der Bauteilvorlage erstellt. Diese Verknüpfung ist anschließend auf der Registerkarte Template des Dialogs Document Options zu sehen.

Manuelles Verknüpfen eines Bauteils mit einer Revision einer Bauteilvorlage im Ziel-Workspace. -
Über das Menü Add, das dem Bereich Required Models/Parameters des Komponenten-Editors zugeordnet ist. Das Untermenü Templates listet alle Komponentenvorlagen nach Namen auf, die derzeit in demselben Workspace verfügbar sind, in dem sich auch die Komponente befindet. Die jeweils neuesten Revisionen werden in Klammern angegeben. Klicken Sie auf einen Eintrag, um eine Verknüpfung zur neuesten Revision dieser Komponentenvorlage zu erstellen. Auch hier können Sie die Verknüpfung auf der Registerkarte Templates des Dialogs Document Options überprüfen.

Schnelles Verknüpfen einer Komponentenvorlage über ein Menü mit allen verfügbaren Vorlagen.
Vom Workspace-Ordner für Komponenten geerbt
Sie können eine Komponentenvorlage festlegen, die automatisch für alle Komponenten und deren Revisionen verwendet wird, die in einem Komponentenordner im Workspace gespeichert sind.
Geben Sie die gewünschte Vorlage im Feld Component Template an, wenn Sie die Ordnereigenschaften im Dialog „Edit Folder“ festlegen. Die zugehörige Dropdown-Liste enthält alle Komponentenvorlagen nach Namen, die derzeit in demselben Workspace verfügbar sind, in dem sich auch der Komponentenordner befindet. Die jeweils neuesten Revisionen werden in Klammern angegeben. Wählen Sie einen Eintrag aus, um für jede anschließend in diesem Ordner erstellte Komponente eine Verknüpfung zur neuesten Revision dieser Komponentenvorlage zu erstellen.

Legen Sie eine Standard-Komponentenvorlage fest, die auf alle im übergeordneten Komponentenordner erstellten Komponenten angewendet wird.
Wenn auf Ordnerebene eine Komponentenvorlage ausgewählt ist, wird diese Vorlage standardmäßig auch für Komponenten verwendet, die in darunterliegenden Unterordnern erstellt werden. So lässt sich eine Vorlage schnell an alle Komponenten in untergeordneten Ordnern vererben.
Auswirkungen auf Komponentenmodelle und Parameter bei Verwendung einer Komponentenvorlage
Wenn Sie eine Komponentenrevision bearbeiten und eine Revision einer Komponentenvorlage verknüpft bzw. referenziert wird, geschieht im Komponenten-Editor hinsichtlich der Modelle und Parameter Folgendes:
- Die in der referenzierten Vorlage definierten Modelle werden dem Bereich Models (Modus Single Component Editing) und dem Bereich Model Links (Modus Batch Component Editing) hinzugefügt.
- Ein bereits referenziertes Modell bleibt erhalten, und die Komponente verwendet dieses Modell weiterhin, sofern es nicht gezielt manuell geändert wird.
-
Die in der referenzierten Vorlage definierten Parameter werden dem Bereich Parameters (Modus Single Component Editing) und dem Bereich Required Models/Parameters (Modus Batch Component Editing) hinzugefügt.

Beispiel für Parameter nach dem Verknüpfen mit einer Revision einer Komponentenvorlage bei Verwendung des Komponenten-Editors im Modus Single Component Editing (links) und im Modus Batch Component Editing (rechts). -
Nur im Modus Batch Component Editing werden vorlagenbasierte Parameter, die zur Anzeige vorgesehen sind, im Bereich für Komponentendefinitionen des Editors unter der Überschrift
Template Parametersgruppiert.
Darstellung beispielhafter vorlagenbasierter Parameter im Bereich, in dem die Komponentendefinitionen selbst festgelegt werden, bei Verwendung des Komponenten-Editors im Modus Batch Component Editing. -
Die Wertefelder vorlagenbasierter Parameter, die als schreibgeschützt gekennzeichnet sind, können nicht bearbeitet werden. Bei allen anderen vorlagenbasierten Parametern, die nicht als schreibgeschützt gekennzeichnet sind, können Sie die Werte nach Bedarf ändern.
-
Wenn ein vorlagenbasierter Parameter als erforderlich gekennzeichnet ist, ihm in der Vorlage jedoch kein Wert zugewiesen wurde, erscheint sein Wertefeld mit einem roten Rahmen (im Modus Batch Component Editing) oder enthält das Symbol
(im Modus Single Component Editing). Dies weist Sie darauf hin, dass für diesen Parameter ein Wert erforderlich ist. Sie können eine Komponente erst dann im Workspace speichern, wenn für alle erforderlichen Parameter Werte definiert sind.
Erneutes Speichern einer Komponentenvorlage
Sie können jederzeit zu einer beliebigen Revision einer Komponentenvorlage im Workspace zurückkehren und diese direkt bearbeiten. Klicken Sie mit der rechten Maustaste auf die Revision und wählen Sie im Kontextmenü den Befehl Edit. Der temporäre Editor wird erneut geöffnet, wobei die in der Revision enthaltene Vorlage zur Bearbeitung bereitsteht. Nehmen Sie die gewünschten Änderungen vor und speichern Sie die Komponentenvorlage anschließend als nächste Revision des Elements.

Aufrufen des Befehls zum direkten Bearbeiten einer vorhandenen Revision einer Komponentenvorlage.
Herunterladen gespeicherter Daten
Um die in einer Revision einer Komponentenvorlage gespeicherten Daten herunterzuladen, klicken Sie im Panel Explorer mit der rechten Maustaste auf diese Revision und wählen Sie im Kontextmenü den Befehl Operations » Download. Die Komponentenvorlagendatei wird in einen Unterordner des ausgewählten Verzeichnisses heruntergeladen, der nach der Elementrevisions-ID benannt ist. Die Datei befindet sich darin im Ordner Released.
Vorläufiges Löschen
Wenn Sie mit einem Workspace verbunden sind, stehen Ihnen flexible Funktionen zur Verfügung, um eine Komponentenvorlage direkt aus Altium Designer über das Explorer-Panel zu entfernen. Klicken Sie im Panel mit der rechten Maustaste auf den Eintrag der Komponentenvorlage und wählen Sie im Kontextmenü den Befehl Delete Item. Der Dialog Delete Items wird angezeigt, in dem Sie den Löschvorgang bestätigen können. Tatsächlich handelt es sich dabei um ein „vorläufiges Löschen“, bei dem die Komponentenvorlage in den Bereich Trash des Workspace verschoben wird. Der Bereich Trash ist im Wesentlichen ein Papierkorb, in den beliebige Inhalte Ihres Workspace durch vorläufiges Löschen verschoben werden können. Er ist vom übrigen Workspace isoliert.

Vorläufiges Löschen einer Komponentenvorlage. Die Vorlage wird in den Bereich Trash des Workspace verschoben.
Um mit dem Löschen fortzufahren, klicken Sie auf die Schaltfläche
. Das Element wird entfernt, und ein Dialogfeld Deletion Summary bestätigt das erfolgreiche Löschen. Falls beim Löschen ein Problem auftritt, werden Sie darauf hingewiesen.
Alle auf diese Weise gelöschten Inhalte finden Sie auf der Seite Trash der Browseroberfläche des Workspace. Beachten Sie, dass Sie nur Inhalte anzeigen können, die Sie selbst vorläufig gelöscht haben. Administratoren können den gesamten Inhalt der Seite Trash sehen – also alle Inhalte, die vorläufig gelöscht wurden.
Bei einer vorläufig gelöschten Bauteilvorlage ist Folgendes zu beachten:
- Die Bauteilvorlage ist weder in Ihrer Designsoftware noch in der Weboberfläche verfügbar.
- Überall dort, wo die Bauteilvorlage verwendet wurde, wird angezeigt, dass sie gelöscht wurde.
- Eine Bauteilvorlage kann auf der Seite Trash wiederhergestellt oder endgültig gelöscht werden, sofern Sie über Bearbeitungsrechte verfügen. Das endgültige Löschen ist nur möglich, wenn sie nicht von einem übergeordneten Element verwendet wird.







)