Designanforderungen mit dem Constraint Manager definieren
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Auf einen Blick
- Sie erfahren, wie Sie prüfen, ob der Constraint Manager für Ihr Projekt verfügbar ist, und was es bedeutet, wenn Ihr Projekt noch die bisherige Regelverwaltung verwendet.
- Sie lernen den Aufbau des Constraint Managers kennen, erfahren, welche Arten von Designvorgaben sich in den einzelnen Ansichten definieren lassen und wie Sie ihn über den Schaltplan- oder Leiterplatteneditor öffnen.
- Sie erhalten wichtige Hinweise für die tägliche Arbeit, darunter das Speichern und Aktualisieren von Änderungen, das Anzeigen von Standardwerten und benutzerdefinierten Werten sowie das Definieren von Abständen in der Matrix.
Der Constraint Manager ist eine dokumentbasierte, tabellenartige Benutzeroberfläche, mit der Sie die für Ihre PCB-Designs verwendeten Design-Constraints anzeigen, erstellen und verwalten können.
Zu den Vorteilen des Constraint Managers, insbesondere bei komplexen Designs mit vielen Netzen, Klassen usw., gehören:
-
Die Verfügbarkeit auf Projektebene ermöglicht einen einheitlichen Zugriff auf die Verwaltung von Design-Constraints sowohl aus der Schaltplanerfassung als auch aus dem PCB-Design.
-
Der Wechsel von der abfragebasierten Festlegung des Regelgeltungsbereichs zur Zuordnung anhand des jeweiligen Objekttyps vereinfacht die Erstellung von Constraint-Regeln.
-
Die Verwendung von Constraint-Sätzen beschleunigt die Definition der Constraints.
-
Die Regelpriorität wird automatisch anhand der natürlichen Hierarchie der Designobjekte festgelegt.
-
Durch die Verwendung einer dokumentbasierten Oberfläche anstelle eines Dialogs bleiben der Schaltplan- und PCB-Editor sowie die zugehörigen Funktionen aktiv und zugänglich.
Zugriff auf den Constraint Manager
Sie öffnen den Constraint Manager, indem Sie den Befehl Design » Constraint Manager in den Hauptmenüs des Schaltplan- oder PCB-Editors auswählen.

Constraint Manager aus dem Schaltplan-Editor öffnen

Constraint Manager aus dem PCB-Editor öffnen
Constraint-Typen
Mit den Schaltflächen oben links im Constraint Manager können Sie zwischen den Ansichten wechseln, um verschiedene Constraint-Typen zu definieren.
Hinweise zur Arbeit mit dem Constraint Manager:
-
Verwenden Sie die Option Units im Panel Properties (oder die entsprechenden Optionen im Untermenü Tools » Measurement Units der Hauptmenüs; Tastenkürzel:
Ctrl+Q), um zwischen den Maßeinheiten (mm oder mils) zu wechseln, in denen die Werte im Tabellenbereich des Constraint Managers angezeigt werden. -
Verwenden Sie die Option Show Default Values im Panel Properties (oder die entsprechende Option im Hauptmenü View oder im Untermenü View Options des Kontextmenüs des Tabellenbereichs), um die Anzeige von Standardwerten (z. B. von einer Netzklasse oder einem differenziellen Paar geerbten Werten) im Constraint Manager ein- oder auszuschalten. Wenn diese Standardwerte eingeblendet sind, werden sie im Tabellenbereich des Constraint Managers grau dargestellt. Benutzerdefinierte Werte werden im Tabellenbereich des Constraint Managers weiß dargestellt.
-
Verwenden Sie in der Ansicht Physical oder Electrical die Option Show Only Object Custom Values im Panel Properties (oder die entsprechende Option im Hauptmenü View oder im Untermenü View Options des Kontextmenüs des Tabellenbereichs), um die Anzeige von Objekteinträgen mit Standardwerten ein- oder auszuschalten (bei aktivierter Option werden Einträge mit Standardwerten ausgefiltert).
-
Das Kopieren und Einfügen von Werten aus bzw. in Zellen wird unterstützt – verwenden Sie die Befehle im Untermenü Copy/Paste Values des Kontextmenüs oder die Tastenkürzel
Ctrl+CundCtrl+V. -
Verwenden Sie das Feld Search oben rechts im Constraint Manager, um die Objektliste durch Eingabe eines Suchbegriffs zu filtern. Klicken Sie auf das Symbol
rechts in der Leiste Search, um den aktuell eingegebenen Suchbegriff zu entfernen.
-
Verwenden Sie das Feld Comment unten im Constraint Manager, wenn eine Zelle für eine Vorgabe/Regel ausgewählt ist, um dieser Vorgabe/Regel einen Kommentar hinzuzufügen, beispielsweise eine aussagekräftige Beschreibung ihres Verwendungszwecks Wenn im unteren Bereich des Constraint Managers Vorgaben für verschiedene Regeln definiert werden können, können Sie jeder Regel einen eigenen Kommentar zuweisen, indem Sie die aktuelle Regel über das Dropdown-Menü Rule wechseln
-
Im Constraint Manager muss gespeichert werden, bevor Änderungen im Design wirksam werden. Verwenden Sie dazu den Befehl File » Save (wenn der Constraint Manager aus dem Schaltplan heraus geöffnet wurde) oder File » Save to PCB (wenn der Constraint Manager aus dem PCB heraus geöffnet wurde) in den Hauptmenüs des Constraint Managers oder das Tastenkürzel
Ctrl+S. -
Beim ersten Speichern im Constraint Manager, wenn dieser aus dem Schaltplan heraus geöffnet wurde, wird das Dokument mit den Schaltplanvorgaben (
Constraints.xml) dem Projekt hinzugefügt und über das Panel Projects bereitgestellt (im Unterordner Settings/Constraints – Außerdem werden die Vorgabendaten im Dokument nach einer Aktualisierung des Projekts aus dem verbundenen Workspace neu geladen bzw. aktualisiert. -
Wenn sich das Schaltplandesign oder der PCB-Lagenaufbau geändert hat (Änderungen an betroffenen Lagen und/oder Impedanzprofilen), klicken Sie oben im Constraint Manager (aus dem jeweiligen Editor heraus geöffnet) auf die Schaltfläche
, um diese Änderungen im Constraint Manager zu übernehmen. Über diese Schaltfläche können Sie auch Direktiven aus Schaltplänen in den Constraint Manager importieren – mehr erfahren. Wenn Sie im Constraint Manager noch nicht gespeicherte Änderungen vorgenommen haben, erscheint zur Bestätigung ein Dialog mit dem Hinweis, dass diese Änderungen verloren gehen.
-
Die folgenden globalen Optionen sind im Bereich Clearances Settings des Panels Properties in den Ansichten Clearances und Physical verfügbar, wenn der Constraint Manager aus dem Schaltplan oder dem PCB heraus geöffnet wird:
-
Ignore Pad to Pad clearances within a footprint – Mit dieser Option wenden Sie die Einstellung auf alle definierten Abstandsregeln an. Damit können Sie festlegen, ob Abstände zwischen Pads innerhalb desselben Bauteil-Footprints ignoriert werden.
-
Apply zero Keepout clearance – Wenn diese Option aktiviert ist, wird zwischen einem Sperrbereich und allen anderen Primitiven im Design eine Standard-Abstandsregel mit einem Abstand von „0“ angewendet. Beachten Sie, dass diese Regel in keiner Ansicht des Constraint Managers sichtbar ist und daher nicht geändert werden kann. Wenn deaktiviert ist, gelten die regulären Werte der Abstandsmatrix.
-
-
Sie können Änderungen im Constraint Manager schnell rückgängig machen oder wiederherstellen, indem Sie
oben links im Designbereich oder Edit » Undo/Redo in den Hauptmenüs verwenden. Dies ist in den meisten Bereichen möglich, einschließlich Regeln, Geltungsbereichen und Vorgabensätzen. Wie in anderen Bereichen der Software sind die Symbole/Befehle nur verfügbar, wenn eine Aktion (zum Rückgängigmachen) bzw. eine Rückgängig-Aktion (zum Wiederherstellen) ausgeführt wurde.
Arbeiten mit der Abstandsmatrix
Standardmäßig enthält die Abstandsmatrix in der Ansicht Clearances des Constraint Managers einen einzelnen Eintrag von All Net Classes zu All Net Classes, mit dem Sie einen Standardabstand zwischen beliebigen Netzen im Design definieren können. Verwenden Sie das Bedienelement Add oben links in der Matrix (oder klicken Sie mit der rechten Maustaste auf eine beliebige Zelle der Abstandsmatrix und verwenden Sie den Befehl Add im Kontextmenü), um ein Pop-up mit einer Liste der aktuell definierten Netz- und Differenzialpaarklassen anzuzeigen. Wählen Sie eine oder mehrere benötigte Klassen aus (mehrere Klasseneinträge lassen sich mit der Methode Shift+Click oder Ctrl+Click auswählen) und klicken Sie auf die Schaltfläche Add. Für jede ausgewählte Klasse werden der Matrix eine Zeile und eine Spalte hinzugefügt.
Klicken Sie auf eine Zelle am Schnittpunkt der Zeile und Spalte zweier Klassen, um sie auszuwählen und die detaillierten Abstandseinstellungen im unteren Bereich des Constraint Managers anzuzeigen. Dort können Sie spezifische Abstandswerte zwischen verschiedenen Objekten und auf verschiedenen Lagen definieren.
Verwenden Sie das Feld Clearance im unteren Bereich, um den gewünschten Wert einzugeben, der für alle Objektpaarungen und alle Lagen dieses Klassenpaars gelten soll. Alternativ können Sie auf eine Zelle in der Matrix im oberen Bereich doppelklicken, um den gewünschten Wert direkt einzugeben.
Geben Sie die gewünschten Abstandswerte für bestimmte Objektpaare in die Tabelle ein. Beachten Sie, dass die Zelle in der Abstandsmatrix den Bereich zwischen dem kleinsten und dem größten in der Tabelle definierten Wert anzeigt.
Hinweise zum Arbeiten mit der Ansicht Clearances:
-
Wenn Sie einen Wert in eine Zelle der Abstandsmatrix oder in das Feld Clearance eingeben, wird dieser Wert automatisch auf alle Felder im Tabellenbereich unten im Constraint Manager angewendet, sofern eine Zelle in der Abstandsmatrix ausgewählt ist. Sie müssen den Tabellenbereich nur bearbeiten, wenn Sie einen Abstand abhängig vom Objekttyp definieren möchten.
-
In den detaillierten Abstandseinstellungen im unteren Bereich des Constraint Managers können Sie außerdem die Vorgabe Creepage für die ausgewählten Klassen aktivieren und den Kriechstreckenwert definieren. Diese Vorgabe prüft die Kriechstrecke zwischen den betreffenden Signalen über die Leiterplattenoberfläche, durch nicht metallisierte Bohrungen und Ausschnitte sowie um die Leiterplattenkante herum.
-
In den detaillierten Abstandseinstellungen im unteren Bereich des Constraint Managers können Sie außerdem die Vorgabe Z-Axis Clearance für die ausgewählten Klassen aktivieren und den Abstandswert in Z-Richtung definieren. Diese Vorgabe dient zur Prüfung der Mindestabstände zwischen Primitiven auf verschiedenen Kupferlagen.
-
Um den Mindestabstand für ein bestimmtes Objektpaar (z. B. ein Paar aus Track und Track) auf seinen Standardwert zurückzusetzen (d. h. auf den für den Eintrag All Net Classes zu All Net Classes definierten Wert), wählen Sie die entsprechende Zelle in der unteren Tabelle aus und drücken Sie die Taste
Delete, oder klicken Sie mit der rechten Maustaste auf die Zelle und wählen Sie den Befehl Reset to Default aus dem Kontextmenü. -
Um die Mindestabstände für alle Objektpaare eines bestimmten Eintrags in der Abstandsmatrix (z. B. eines Eintrags für eine Netzklasse und eine andere Netzklasse) auf ihre Standardwerte zurückzusetzen, klicken Sie mit der rechten Maustaste auf die entsprechende Zelle in der Abstandsmatrix und wählen Sie den Befehl Remove Rule aus dem Kontextmenü.
-
Um eine Klasse aus der Abstandsmatrix zu entfernen, klicken Sie mit der rechten Maustaste auf eine beliebige Zelle in der Zeile dieser Klasse in der Abstandsmatrix und wählen Sie den Befehl Remove Scope aus dem Kontextmenü.
Mindestabstände pro Lage konfigurieren
Über die Registerkarten unterhalb der Tabelle können Sie auch lagenbezogene Mindestabstände definieren. Verwenden Sie das Steuerelement Add, um eine Registerkarte für eine bestimmte Lage hinzuzufügen.
Klassen filtern
Um die Arbeit mit einer großen Anzahl von Klassen in der Ansicht Clearances zu erleichtern, können Sie die Filter- und Gruppierungsfunktion verwenden. Damit lassen sich Filter (oder Gruppierungen) für Klassen erstellen, um zwischen gezielten Teilbereichen der Abstandsmatrix zu wechseln und mit diesen zu arbeiten.
Verwenden Sie die Schaltfläche
oben rechts in der Ansicht Clearances, um ein Pop-up zu öffnen, in dem Sie Filter erstellen, bearbeiten, entfernen sowie aktivieren und deaktivieren können.
Mit physikalischen und elektrischen Constraints arbeiten
Klicken Sie in der Ansicht Physical oder Electrical des Constraint Managers auf eine Zelle im Tabellenbereich, um die Einstellungen der entsprechenden Regel(n) im unteren Bereich des Constraint Managers anzuzeigen. Dort können Sie die Constraint-Werte festlegen.
Die folgenden Constraints können in der Ansicht Physical konfiguriert werden:
-
Width – Dieser Constraint legt die Breite der Leiterbahnen auf den Signallagen fest.
-
Diff Pair Gap – Dieser Constraint legt den Abstand (bzw. die Lücke) zwischen den Netzen der differentiellen Paare im Geltungsbereich fest.
-
Clearance – Dieser Constraint legt den zulässigen Mindestabstand zwischen Objekten der Netze im Geltungsbereich und Objekten anderer Netze im Design fest.
-
Via Style – Dieser Constraint legt die Art der Vias fest, die beim Routing verwendet werden können. Sie können spezifische Mindest-, Höchst- und Vorzugswerte für den Via-Durchmesser und den Bohrungsdurchmesser definieren (Min/Max Preferred). Wenn Sie über das PCB auf den Constraint Manager zugreifen oder Constraints für einen bestimmten Lagenaufbau konfigurieren (mehr erfahren), können Sie auch die für das Leiterplattendesign verfügbaren Vorlagen verwenden (Templates).
-
Polygon Connect – Dieser Constraint legt die Art der Anbindung eines Bauteilpads oder eines beim Routing platzierten Vias an eine Polygonfläche fest.
Weitere Informationen zu den Constraint-Werten finden Sie auf der Seite Regeltypen für Versorgungsebenen.
-
Same Net Clearance – Dieser Constraint legt den zulässigen Mindestabstand zwischen zwei beliebigen primitiven Objekten desselben Netzes fest (z. B. zwischen einem Via und einem Pad desselben Netzes oder zwischen zwei Leiterbahnsegmenten desselben Netzes).
-
Routing Neck Down – Dieser Constraint legt die maximal zulässige Länge durchgehender Leiterbahnabschnitte fest, deren Breite zwischen Min Width und Preferred Width liegt, die durch den geltenden Breiten-Constraint definiert sind.
Die folgenden Constraints können in der Ansicht Electrical konfiguriert werden:
-
Die Registerkarte Nets:
-
Topology – Dieser Constraint legt die Topologie fest, die beim Routen von Netzen auf der Leiterplatte verwendet werden soll. Die Topologie eines Netzes ist die Anordnung bzw. das Muster der Verbindungen zwischen den Pins.
Weitere Informationen zu den Constraint-Werten finden Sie auf der Seite Routing-Regeltypen.
-
Impedance – diese Vorgabe legt die zulässige minimale und maximale Netzimpedanz fest.
-
All Layer Sets – diese Vorgabe legt fest, welche Lagen für das Routing verwendet werden dürfen.
-
Maximum Via Count – diese Vorgabe legt die maximal zulässige Anzahl von Vias fest.
-
Min / Max Total Length – diese Vorgabe legt die minimale und maximale Länge eines Netzes fest.
-
Max Stub Length – diese Vorgabe legt die maximal zulässige Stichleitungslänge für ein Netz mit Daisy-Chain-Topologie fest.
-
Max Via Stub Length – ein Stub ist der Abschnitt der durchkontaktierten Bohrung eines Vias oder Pads, der über die letzte verwendete Signallage hinausreicht, auf der das Via bzw. Pad eine Verbindung herstellt. Geeignete Vias/Pads in den betreffenden Netzen werden rückgebohrt. Dabei werden die aktivierten Layer Kontrollkästchen für die Leiterplattenseiten sowie die Rückbohrpaare berücksichtigt, die auf der Registerkarte Back Drills des Layer Stack Manager definiert sind.
Weitere Informationen zu Vorgabewerten finden Sie auf der Seite High-Speed-Regeltypen.
Weitere Informationen zum Rückbohren finden Sie auf der Seite Tiefenkontrolliertes Bohren (Rückbohren).
-
-
Die Registerkarte Diff Pairs:
-
Impedance – diese Vorgabe legt die zulässige minimale und maximale Netzimpedanz fest.
-
Gap – diese Vorgabe legt den Abstand zwischen den Netzen der Differenzialpaare im Geltungsbereich fest.
-
Width – diese Vorgabe legt die zulässige Leiterbahnbreite beim Routing des Differenzialpaares fest.
-
Max Uncoupled Length – diese Vorgabe legt die maximal zulässige ungekoppelte Länge zwischen dem positiven und dem negativen Netz innerhalb des Differenzialpaares fest.
-
Tolerance – diese Vorgabe legt eine Längentoleranz für den Vergleich mit dem längsten Netz im Differenzialpaar fest.
-
Dynamic Phase Tolerance – diese Vorgabe legt die zulässige Phasenabweichung zwischen den Leiterbahnen eines Differenzialpaares fest, bei deren Überschreitung eine Kompensation erforderlich ist.
-
Matching Distance – diese Vorgabe legt die Strecke nach Überschreiten der Toleranz fest, innerhalb derer eine Kompensation erfolgen muss.
-
-
Die Registerkarte xSignals:
-
Tolerance – diese Vorgabe legt eine Längentoleranz für den Vergleich jedes xSignals innerhalb der xSignal-Klasse mit dem für die Klasse als Matching Target ausgewählten xSignal fest.
-
Hinweise zur Arbeit mit den Ansichten Physical oder Electrical:
-
Der Constraint Manager legt die Prioritäten der Regeln in diesen Ansichten automatisch fest: Die Priorität steigt von All (niedrigste) über die Objektklasse bis zum Objekt (höchste).
-
Um benutzerdefinierte Vorgabewerte einer bestimmten Regel zu entfernen und damit die Werte dieser Regel auf die Standardwerte zurückzusetzen, klicken Sie mit der rechten Maustaste auf die entsprechende Zelle in der Tabelle und wählen Sie im Kontextmenü den Befehl Remove rule.
-
Um die benutzerdefinierten Vorgabewerte aller Regeln für ein Objekt zu entfernen, klicken Sie mit der rechten Maustaste auf eine beliebige Zelle in der Zeile dieses Objekts und wählen Sie im Kontextmenü den Befehl Remove rules from scope.
-
Alle Knoten außer den vordefinierten (z. B. All Nets) sind in den Ansichten Physical und Electrical standardmäßig eingeklappt. Mit den Kontextmenübefehlen Expand All und Collapse All können Sie die Knoten der Tabelle steuern.
-
Wenn in der oberen Tabelle der Ansicht Physical ein Wert für ein einzelnes Netz oder xNet (Min Width oder Preferred Width), ein Differenzialpaar (Min Width, Preferred Width oder Preferred Diff Pair Gap) oder eine Netz-, xNet- oder Differenzialpaarklasse eingegeben wird, wird dieser Wert in die entsprechenden Felder für die Breite (Min Width/Preferred Width/Max Width) oder den Abstand (Min Gap/Preferred Gap/Max Gap) in den darunterliegenden Vorgabebereichen übernommen. Beachten Sie, dass ein eingegebener Wert nur dann in andere Felder übernommen wird, wenn für das Objekt keine entsprechende spezifische Regel definiert ist.
-
Wenn Sie in der Ansicht Physical Werte für die minimale, maximale und bevorzugte Routingbreite sowie für die Abstände von Differenzialpaaren festlegen, werden ungültige Eingaben in der Tabelle Values by Layer am unteren Rand der Ansicht durch roten Text hervorgehoben. Dies kann beispielsweise auftreten, wenn Sie einen minimalen Vorgabewert angeben, der größer als der maximale Vorgabewert ist. Die fehlerhafte Vorgabedefinition wird zusätzlich dadurch hervorgehoben, dass die Breiten- bzw. Abstandswerte in der oberen Tabelle der Ansicht rot dargestellt werden.
Vorgabewerte pro Lage konfigurieren
Wenn Sie den Constraint Manager vom Schaltplan aus öffnen, können Sie die Vorgaben für die Breite und das Routing von Differenzialpaaren für die Lagen eines ausgewählten Lagenaufbaus konfigurieren.
Wählen Sie über die Dropdown-Liste oben im Constraint Manager einen Eintrag für ein bestimmtes PCB-Dokument des Designprojekts aus. Wenn die ausgewählte Leiterplatte mehrere Lagenaufbauten enthält, können Sie bei ausgewählter entsprechender Regel über die Registerkarten im unteren Bereich des Constraint Managers den gewünschten Lagenaufbau auswählen, für den die Vorgaben konfiguriert werden sollen. Außerdem können Sie ein Impedanzprofil auswählen, sofern eines als Teil des Lagenaufbaus der ausgewählten Leiterplatte definiert ist.
Differenzialpaare definieren
Differenzialpaare werden in der Ansicht Physical oder auf der Registerkarte Diff Pairs der Ansicht Electrical des Constraint Managers erstellt. Damit der Constraint Manager Differenzialpaare aus Netzen erstellen kann, müssen die zu paarenden Netze einem einheitlichen Benennungsschema folgen. Sie müssen also einen gemeinsamen Namensstamm haben, auf den ein einheitliches Suffix für positiv bzw. negativ folgt, beispielsweise TX0_P und TX0_N.
Klicken Sie mit der rechten Maustaste an eine beliebige Stelle im Tabellenbereich der Ansicht Physical oder der Registerkarte Diff Pairs der Ansicht Electrical und wählen Sie im Kontextmenü den Befehl Differential Pairs » Create Differential Pairs From Nets, um den Dialog Create Differential Pairs From Nets zu öffnen und die Optionen für die Erstellung von Differenzialpaaren festzulegen. Mit den Filtern oben im Dialog können Sie die gewünschten Netze schnell anhand ihrer Netzklasse und des jeweiligen Unterscheidungsmerkmals auswählen, mit dem die positiven und negativen Netze eines vorgesehenen Paares gekennzeichnet sind, beispielsweise _P und _N. Sie können außerdem ein Präfix festlegen, das den erstellten Differenzialpaarobjekten vorangestellt wird, und bestimmen, welcher Differenzialpaarklasse sie hinzugefügt werden.
Für jedes Differenzialpaarobjekt führt der Dialog die zugehörigen positiven und negativen Netze auf. Standardmäßig sind alle potenziellen Differenzialpaarobjekte zur Erstellung ausgewählt. Einzelne Objekte können ausgeschlossen werden, indem Sie das zugehörige Kontrollkästchen Create deaktivieren.
Wenn alle Optionen wie gewünscht eingestellt sind, klicken Sie auf die Schaltfläche
– die Differenzialpaarobjekte werden erstellt und in der Ansicht Physical des Constraint Managers angezeigt. Die zugehörigen Netze werden unter den jeweiligen Einträgen aufgeführt.
Differenzialpaare können auch aus xNets erstellt werden. Wählen Sie über die Dropdown-Liste oben im Dialog Create Differential Pairs From Nets die Option All xNets oder eine bestimmte xNet-Klasse aus. Wenn die übrigen Optionen im Dialog wie gewünscht konfiguriert sind, klicken Sie auf die Schaltfläche
, um die entsprechenden Differenzialpaare zu erstellen.
Um ein Differenzialpaar zu entfernen, klicken Sie mit der rechten Maustaste auf dessen Eintrag und wählen Sie im Kontextmenü den Befehl Differential Pairs » Remove Differential Pair aus. Sie können auch mehrere Differenzialpaare entfernen, indem Sie deren Einträge mithilfe der Auswahlmethode Ctrl+Click, Shift+Click oder Click, Hold&Drag auswählen, mit der rechten Maustaste auf die Auswahl klicken und im Kontextmenü den Befehl Differential Pairs » Remove Differential Pair auswählen.
Die Registerkarte Diff Pairs der Ansicht Electrical kann ebenfalls zur gezielten Verwaltung von Differenzialpaaren verwendet werden. Auf dieser Registerkarte wird eine hierarchische Liste der Differenzialpaare im Design angezeigt. Wählen Sie eine Zelle für ein Differenzialpaar oder eine Differenzialpaarklasse aus, um die zugehörigen Constraints im unteren Bereich des Constraint Managers anzuzeigen.
xNets definieren
Ein Pfad von einer Quellkomponente zu einer Zielkomponente, der durch eine oder mehrere in Reihe geschaltete Komponenten verläuft, kann als xNet definiert werden.
Kommagetrennte Listen von Präfixen für die Referenzbezeichner von Komponenten, die als Quell- oder Zielkomponenten (Sources/Destinations) bzw. als in Reihe geschaltete Komponenten (Discretes) verwendet werden können, lassen sich im Bereich xNets Creation auf der Registerkarte „Optionen“ des Dialogs „Projektoptionen“ definieren.

Der Bereich xNets Creation auf der Registerkarte Options des Dialogs Project Options

Ein Beispielpfad, der im Constraint Manager als xNet definiert werden kann (gemäß den oben gezeigten Einstellungen zur xNet-Erstellung)
Klicken Sie in der Ansicht Physical oder Electrical des Constraint Managers (beim Zugriff über einen Schaltplan oder eine Leiterplatte) mit der rechten Maustaste auf ein Netz, das in ein neues xNet aufgenommen werden soll, und wählen Sie im Kontextmenü den Befehl xNets » Create xNets From Selected Nets aus. Ein neues xNet wird erstellt und in den Ansichten Physical oder Electrical des Constraint Managers angezeigt. Die zugehörigen Netze werden unter dessen Eintrag aufgeführt.
Die Erstellung von xNets unterstützt auch in Reihe geschaltete Komponenten mit mehr als zwei Pins. Die folgenden in Reihe geschalteten Komponenten werden unterstützt:
-
Dual-inline component with an even number of pins – xNets können aus Netzen erstellt werden, die mit dem ersten und dem letzten Pin der Komponente verbunden sind, anschließend mit dem zweiten und dem vorletzten Pin usw.
-
Single-inline component with an even number of pins – xNets können aus Netzen erstellt werden, die mit dem ersten und dem zweiten Pin der Komponente verbunden sind, anschließend mit dem dritten und dem vierten Pin usw. Beachten Sie, dass die Komponente einen Parameter namens
PinPairsConfigurationmit dem WertSIPenthalten muss; andernfalls werden xNets wie bei einer Dual-Inline-Komponente erstellt. -
Component with an odd number of pins – Ein xNet wird aus Netzen erstellt, die mit allen Pins der Komponente verbunden sind.
Um ein xNet zu entfernen, klicken Sie mit der rechten Maustaste auf dessen Eintrag und wählen Sie im Kontextmenü den Befehl xNets » Remove xNet aus. Sie können auch mehrere xNets entfernen, indem Sie deren Einträge mithilfe der Auswahlmethode Ctrl+Click, Shift+Click oder Click, Hold&Drag auswählen, mit der rechten Maustaste auf die Auswahl klicken und im Kontextmenü den Befehl xNets » Remove xNet auswählen.
xSignals definieren
Im Constraint Manager können Sie auch xSignals definieren – benutzerdefinierte Signalpfade zwischen zwei Knoten auf der Leiterplatte. Wählen Sie in der Ansicht Electrical des Constraint Managers die Zelle in der Spalte Topology für ein Netz oder xNet aus, wählen Sie Custom aus der Dropdown-Liste im unteren Bereich des Constraint Managers und verwenden Sie anschließend die bereitgestellten Steuerelemente, um die benutzerdefinierte Topologie zu definieren und die entsprechenden xSignals auszuwählen.
Im Folgenden wird anhand des unten gezeigten xNets ein Beispiel für die Definition von xSignals beschrieben und demonstriert.

Ein Beispiel für ein xNet, für das xSignals erstellt werden sollen.
Eine benutzerdefinierte Topologie kann mithilfe des Topologiegraphen im unteren Bereich des Constraint Managers definiert werden. Verwenden Sie das Kontextmenü im Graphbereich, um Knoten hinzuzufügen und zu entfernen, ihren Typ von Source zu Destination und zurück zu ändern und die Knoten mit Click, Hold&Drag zu verbinden, um die Topologie zu definieren.
Die Liste der vorgeschlagenen xSignals (benannt nach dem Schema <SourceNetName> (<SourcePinDesignator> → <DestinationPinDesignator>)) wird rechts neben dem Tabellenbereich angezeigt. Die Liste ist in zwei Gruppen unterteilt: xSignals von einer Quelle zu einem Ziel (S-T) und xSignals von einem Ziel zu einem anderen (T-T). Verwenden Sie die Kontrollkästchen für Gruppen oder einzelne xSignals, um die zu erstellenden xSignals auszuwählen bzw. abzuwählen. Ausgewählte xSignals werden auf der Registerkarte xSignals der Ansicht Electrical angezeigt.
Ein Beispiel für die Erstellung von xSignals mithilfe des Topologiegraphen
Für eine erstellte xSignal-Klasse (Einzelheiten finden Sie unten im Abschnitt Klassen definieren) kann die Designvorgabe Tolerance definiert werden, und ein xSignal innerhalb dieser Klasse kann als Matching Length ausgewählt werden. Wenn der Constraint Manager von der PCB-Seite aus geöffnet wird, sind auch die Spalten Actual Value und Margin verfügbar.
Im PCB-Dokument können die definierten xSignals im PCB-Panel im Modus xSignals eingesehen werden. Außerdem werden entsprechende From-Tos erstellt, die im PCB-Panel im Modus From-To Editor eingesehen werden können.
Klassen definieren
Mit dem Constraint Manager können Sie Klassen für Netze, Differenzpaare, xNets und xSignals definieren.
-
Um Objekte in der Ansicht Physical oder Electrical des Constraint Managers zu einer bestehenden Klasse hinzuzufügen, wählen Sie mehrere Objekteinträge mithilfe der Auswahlmethode
Ctrl+Click,Shift+ClickoderClick, Hold&Dragaus. Klicken Sie anschließend mit der rechten Maustaste auf die Auswahl und wählen Sie die gewünschte Klasse aus dem Untermenü Classes » Add Selected to Class des Kontextmenüs.Wenn mehr als 30 Klassen vorhanden sind, wird anstelle der Klassenliste der Befehl Classes » Add Selected to Class » Existing Class angezeigt. Öffnen Sie mit diesem Befehl einen Dialog, in dem Sie eine bestehende Klasse auswählen können, zu der die ausgewählten Objekte hinzugefügt werden sollen.
-
Um eine neue Klasse aus Objekten zu erstellen, die in der Ansicht Physical oder Electrical des Constraint Managers aufgeführt sind, wählen Sie diese aus. Klicken Sie anschließend mit der rechten Maustaste auf die Auswahl und wählen Sie im Kontextmenü den Befehl Classes » Add Selected to Class » New Class , um den Dialog Add Class zu öffnen. Legen Sie für die Klasse Name (muss eindeutig sein und darf nicht leer sein) sowie die Klassenmitglieder fest. Die vor dem Öffnen des Dialogs ausgewählten Objekte befinden sich bereits in der Liste Member. Passen Sie bei Bedarf die Klassenmitglieder weiter an, indem Sie Objekteinträge mithilfe der Pfeilschaltflächen zwischen den Listen Non-Members und Member verschieben.
-
Alternativ klicken Sie mit der rechten Maustaste in den Tabellenbereich und wählen in der Ansicht Clearances oder Electrical den Befehl Classes » Add Class oder einen Befehl aus dem (zum Hinzufügen einer Netzklasse) oder dem Untermenü Classes » Add Class , um den Dialog Add Class zu öffnen. Wenn Sie den Dialog auf diese Weise öffnen, sind die Listen Member zunächst leer.
-
Um Objekte aus einer Klasse zu entfernen, der sie derzeit zugeordnet sind, wählen Sie diese aus. Klicken Sie anschließend mit der rechten Maustaste auf die Auswahl und wählen Sie im Kontextmenü den Befehl Classes » Remove Selected from Class .
-
Um eine Klasse zu bearbeiten, klicken Sie mit der rechten Maustaste auf ihren Eintrag und wählen Sie im Kontextmenü den Befehl Classes » Edit Class, um den Dialog Edit Class zu öffnen. Dort können Sie den Namen und die Mitglieder der Klasse bearbeiten.
-
Um eine bestehende Klasse zu entfernen, klicken Sie mit der rechten Maustaste auf ihren Eintrag und wählen Sie im Kontextmenü den Befehl Classes » Remove Class . Sie können auch mehrere Klassen entfernen, indem Sie deren Einträge mithilfe der Auswahlmethode
Ctrl+Click,Shift+ClickoderClick, Hold&Dragauswählen, mit der rechten Maustaste auf die Auswahl klicken und im Kontextmenü den Befehl Classes » Remove Class wählen.
Alternativ können Sie den Dialog Object Class Explorer verwenden, um Klassen hinzuzufügen, zu bearbeiten und zu entfernen. Klicken Sie mit der rechten Maustaste in den Tabellenbereich und wählen Sie im Kontextmenü den Befehl Classes » Class Explorer , um den Dialog zu öffnen.
Der Ordnerbaumbereich auf der linken Seite des Dialogs listet die unterstützten Objektklassentypen und die bestehenden Objektklassen jedes Typs auf.
- Klicken Sie auf den Stammordner Object Classes, um im Hauptbearbeitungsbereich des Dialogs eine Übersicht aller konkreten Klassen anzuzeigen, die für sämtliche Objektklassentypen definiert wurden.
- Klicken Sie auf einen untergeordneten Ordner für einen Objektklassentyp, um eine Übersicht aller konkreten Klassen anzuzeigen, die für diesen Typ definiert wurden.
- Klicken Sie auf den Eintrag einer bestimmten Klasse (oder doppelklicken Sie auf ihren Eintrag in einer Übersichtsliste), um auf die Steuerelemente zur Verwaltung der Objektzugehörigkeit zu dieser Klasse zuzugreifen.
Um im Dialog Object Class Explorer eine neue benutzerdefinierte Klasse hinzuzufügen, klicken Sie mit der rechten Maustaste in die Kategorie der Klasse, die Sie erstellen möchten, und wählen Sie im Kontextmenü Add Class . Um eine benutzerdefinierte Klasse umzubenennen oder zu löschen, klicken Sie mit der rechten Maustaste auf ihren Namen und wählen Sie Rename Class bzw. Delete Class.
Designvorgabensätze
Um das Definieren von Designvorgaben für Objekte zu beschleunigen, bietet der Constraint Manager die Möglichkeit, eine Gruppe von Designvorgaben als Designvorgabensatz zu speichern und diesen anschließend auf Objekte anzuwenden.
Um die derzeit für ein Objekt definierten Designvorgaben als Designvorgabensatz zu speichern, klicken Sie mit der rechten Maustaste auf eine Zelle dieses Objekts und wählen Sie im Kontextmenü den Befehl Save as Constraint Set. Geben Sie im Pop-up New Constraint Set den gewünschten Namen des Designvorgabensatzes ein (muss eindeutig sein und darf nicht leer sein) und klicken Sie auf Create.
Ein neu erstellter Designvorgabensatz wird auf das Objekt angewendet, aus dem er erstellt wurde. Um einen Designvorgabensatz auf ein anderes Objekt anzuwenden, klicken Sie mit der rechten Maustaste auf dessen Zelle und wählen Sie den gewünschten Designvorgabensatz aus dem Untermenü Select Constraint Set des Kontextmenüs. Die Zellen, auf die ein Designvorgabensatz angewendet wird, sind durch ein Symbol in ihrer oberen linken Ecke gekennzeichnet (z. B. In den Ansichten Physical oder Electrical wird zudem der Name des angewendeten Designvorgabensatzes in der Spalte Constraint Set angezeigt.
Um die Werte eines bestehenden Designvorgabensatzes zu bearbeiten, wählen Sie ein Objekt aus, auf das dieser Designvorgabensatz angewendet wird, und klicken Sie auf
Schaltfläche. Ändern Sie die Constraint-Werte nach Bedarf und klicken Sie anschließend im angezeigten Pop-up auf die Schaltfläche Save, um die Änderungen zu speichern. Die Änderungen werden auf alle Objekte angewendet, denen dieser Constraint-Satz derzeit zugewiesen ist.
Die aktuell definierten Constraint-Sätze werden im Bereich Constraint Sets des Panels Properties aufgelistet. Klicken Sie auf den Eintrag eines Constraint-Satzes, um dessen Constraint-Werte anzuzeigen. Ein im Panel Properties ausgewählter Constraint-Satz kann durch Klicken auf die Schaltfläche
unten im Bereich Constraint Sets entfernt werden. Objekte, denen der entfernte Constraint-Satz zugewiesen war, behalten die Constraint-Werte bei, die vor dem Entfernen durch diesen Constraint-Satz angewendet wurden.
Direktiven aus Schaltplänen importieren
Sie können Netz- und Differenzialpaarklassen, Differenzialpaare und Constraints aus den Design-Direktiven Parametersatz und Differenzialpaar, die in Ihren Schaltplan-Quelldokumenten platziert und definiert sind, in den Constraint Manager importieren. Öffnen Sie dazu den Constraint Manager vom Schaltplan aus und klicken Sie auf die Schaltfläche
. Der Dialog Refresh Constraint Manager zeigt eine Zusammenfassung des Imports vom Schaltplan in den Constraint Manager an. Durch Klicken auf die Schaltfläche
im Dialog wird der Import abgeschlossen.
Der Synchronisierungsstatus zwischen einem Constraint im Constraint Manager und dem entsprechenden Constraint in einer auf dem Schaltplan platzierten Direktive wird angezeigt.
-
Wenn auf einem Objekt im Schaltplan eine Parametersatz- oder Differenzialpaar-Direktive platziert ist und diese Direktive Constraint-Werte enthält, die von den für dasselbe Objekt im Constraint Manager definierten Werten abweichen, werden diese Werte mit einem orangefarbenen Balken am linken Rand der entsprechenden Zelle in der Ansicht Physical oder Electrical des Constraint Managers markiert, wenn der Constraint Manager vom Schaltplan aus geöffnet wird (z. B.
-
Wenn die Constraint-Werte zwischen dem Constraint Manager und der Direktive synchronisiert sind, wird stattdessen ein grüner Balken angezeigt (z. B.
Auch der Synchronisierungsstatus von Netzklassen, Differenzialpaaren und Differenzialpaarklassen, die aus Direktiven importiert wurden, wird angezeigt. Änderungen (neue/entfernte Elemente) werden erkannt. Inkonsistenzen, die eine Synchronisierung erfordern, werden durch einen orangefarbenen Balken links neben dem entsprechenden Objektnamen angezeigt (z. B. Der synchronisierte Status wird durch einen grünen Balken angezeigt (z. B.
Hinweise zum Importieren von Direktiven in den Constraint Manager:
-
Alle bereits über den Constraint Manager für Netze/Netzklassen/Differenzialpaare/Differenzialpaarklassen definierten Constraints haben Vorrang und bleiben beim Import erhalten. Wenn daher ein mit einer Direktive synchronisierter Constraint-Wert nach dem Import im Constraint Manager bearbeitet wird, wird er bei einem späteren erneuten Import nicht synchronisiert.
-
Nach dem Synchronisieren der Daten durch Importieren aus Direktiven in den Constraint Manager und dem Speichern der Änderungen im Constraint Manager:
-
Importierte Direktiven werden im Designbereich durch eine blaue Farbe und ein leicht abweichendes Symbol gekennzeichnet
-
Einträge für Klassen und Regeln, die in den Constraint Manager importiert wurden, können mithilfe der Schaltfläche Constraint Manager oben im Bereich Parameters des Panels Properties ausgeblendet werden.
-
Bei einer Parametersatz-Direktive, die an einer einzelnen Leitung angebracht ist, können zugehörige Daten aus dem Constraint Manager (Name der Netz-/Differenzialpaarklasse und Regeleinstellungen) in der Nähe dieser Direktive auf dem Schaltplanblatt angezeigt werden. Bei einer Parametersatz-Direktive mit definierten Netzklassen, die an einem Blanket angebracht ist, lässt sich nach der Synchronisierung mit bzw. dem Import in den Constraint Manager auch die Anzeige der Netzklassen-Direktiveninformationen im Designbereich ein- und ausschalten. Bei einer Differenzialpaar-Direktive, die an einem Blanket angebracht ist, lässt sich nach der Synchronisierung mit bzw. dem Import der Direktiven in den Constraint Manager die Anzeige der Differenzialpaarklasse und der zugehörigen Regelinformationen im Designbereich ein- und ausschalten. Verwenden Sie bei ausgewählter Direktive das Steuerelement für die Sichtbarkeit links neben dem entsprechenden Dateneintrag im Panel Properties.
-
Die Steuerelemente zum Hinzufügen oder Entfernen einer Netzklasse, Differenzialpaarklasse oder Bauteilklasse sind im Panel Properties für die entsprechenden Direktiven ausgegraut.
-
Die Steuerelemente zum Hinzufügen einer neuen Regel sowie zum Bearbeiten oder Entfernen einer vorhandenen Regel bleiben im Panel Properties für die entsprechenden Direktiven verfügbar. Außerdem können Sie den Namen einer Netzklasse bearbeiten. Um Änderungen an Regeln und/oder am Netzklassennamen einer bereits importierten Direktive auf die Daten im Constraint Manager anzuwenden, klicken Sie auf die Schaltfläche
, wenn der Constraint Manager vom Schaltplan aus geöffnet ist.
-
-
Regeln, die einer Parametersatz-Direktive hinzugefügt wurden und nicht in den Ansichten Physical und Electrical enthalten sind, werden automatisch als erweiterte Regeln erstellt und in der Ansicht All Rules angezeigt, wenn der Constraint Manager von der Leiterplatte aus geöffnet wird. Die erweiterten Regeln werden nach Abschluss des Direktivenimports und der anschließenden ECO-Übertragung vom Schaltplan auf die Leiterplatte erstellt.
-
Damit mithilfe von Direktiven definierte Netzklassen in den Constraint Manager importiert werden können, muss die Option Generate Net Classes auf der Registerkarte Class Generation im Dialog Project Options aktiviert sein. Beachten Sie, dass bei einem späteren Import in den Constraint Manager das Entfernen der importierten Netzklassen vorgeschlagen wird, wenn zuvor Netzklassen in den Constraint Manager importiert wurden und anschließend die Option Generate Net Classes deaktiviert wurde.
Ändern von Direktiven, die aus schreibgeschützten Dokumenten importiert wurden
Direktiven, die aus schreibgeschützten Dokumenten importiert wurden (beispielsweise Device Sheets und Managed Sheets), können nicht geändert werden, wenn die Option Make Device Sheets In Projects Read-Only auf der Seite Datenverwaltung – Device Sheets des Dialogfelds Preferences aktiviert ist (Kontrollkästchen ausgewählt).
Wenn die Option deaktiviert ist (Kontrollkästchen nicht ausgewählt), können die Direktiven geändert werden. Nachdem Direktiven bei aktivierter Option importiert wurden, wird die Regel im Constraint Manager blau hervorgehoben.
Importieren und Exportieren von Beschränkungen und Beschränkungssätzen
Sie können Beschränkungen und Beschränkungssätze zwischen Designs importieren und exportieren. Um auf diese Funktion zuzugreifen, klicken Sie in der Ansicht Clearances, Physical, oder Electrical des Constraint Managers mit der rechten Maustaste und wählen Sie anschließend Import oder Export.
Nach der Auswahl von Import wird das Standarddialogfeld File Explorer geöffnet, in dem Sie die gewünschte Beschränkung bzw. den gewünschten Beschränkungssatz (*.CstrDot ) zum Importieren in Ihr Design auswählen können. Das Dialogfeld Constraints to Import wird geöffnet. Dort können Sie die Beschränkungen bzw. Beschränkungssätze auswählen, die in das aktuelle Design importiert werden sollen. Die ausgewählten Beschränkungen bzw. Beschränkungssätze werden auf die entsprechenden Objekte im Zieldesign angewendet.
Exporting Constraints and Constraint Sets
Nachdem Sie eine oder mehrere Zellen in der Ansicht Clearances oder eine oder mehrere Zeilen in der Ansicht Physical oder Electrical ausgewählt und anschließend Export gewählt haben, wird das Dialogfeld Constraints to Export geöffnet. In dessen Tabelle werden die Beschränkungen und Beschränkungssätze für alle Objekte aufgeführt, die vor dem Aufrufen des Befehls ausgewählt waren. Wählen Sie mithilfe der Kontrollkästchen die Beschränkungen bzw. Beschränkungssätze aus, die Sie exportieren möchten. Beschränkungen, die sich auf die aktuelle Ansicht beziehen, sind im Dialogfeld standardmäßig ausgewählt. Nach dem Klicken auf die Schaltfläche Export items wird das Standarddialogfeld File Explorer geöffnet, in dem Sie die Beschränkungen bzw. Beschränkungssätze benennen und speichern können. Die Datei wird mit der Erweiterung *.CstrDot exportiert und kann anschließend in ein anderes Design importiert werden.
Arbeiten mit allen Regeln auf der PCB-Seite
Wenn der Constraint Manager über den PCB-Editor aufgerufen wird, ist die Ansicht All Rules verfügbar, die eine Liste aller Regeln im PCB-Design enthält. Hier können Sie erweiterte Regeln erstellen, deren Geltungsbereich durch komplexere Abfrageausdrücke definiert wird.
Erstellen einer neuen erweiterten Regel
Um in der Ansicht All Rules des Constraint Managers eine neue erweiterte Regel zu erstellen, wählen Sie Add Advanced Rule im Kontextmenü aus. Alternativ können Sie die Schaltfläche
im unteren Bereich des Constraint Managers verwenden, wenn im Tabellenbereich keine Regel ausgewählt ist. Geben Sie anschließend einen abfragebasierten Geltungsbereich und die Beschränkungsparameter in der Tabelle oder in der unteren grafischen Darstellung ein.
Verwalten der Geltungsbereichsbibliothek
Um das wiederholte Erstellen erweiterter Regeln zu vereinfachen, können Sie mit Constraints Manager abfragebasierte Geltungsbereiche für die Objektzuordnung in der Geltungsbereichsbibliothek speichern. Die Bibliothek wird mithilfe von Scopes Library verwaltet. Dialog, der durch Klicken auf die Schaltfläche Edit Library im Bereich Scopes Library des Panels Properties aufgerufen wird. Die Bibliothek wird im Panel Properties angezeigt. Dort können benutzerdefinierte Geltungsbereiche als XML-Datei importiert und exportiert werden, die anschließend zum Befüllen der Geltungsbereichsbibliothek einer anderen Altium Designer-Installation verwendet werden kann.
Um einen Geltungsbereich in die Bibliothek zu exportieren oder aus ihr zu importieren, verwenden Sie die Befehle im Menü der Schaltfläche
neben dem Feld Object Match / Second Object Match im unteren Bereich des Constraint Managers. Sobald ein bibliotheksbasierter Geltungsbereich auf eine Regel angewendet wurde, wird sein Name in der Spalte Object Match / Second Object Match im Tabellenbereich und oberhalb des Felds Object Match / Second Object Match angezeigt. Über das Menü
des Felds können Sie den Geltungsbereich wieder in sein abfragebasiertes Format zurückversetzen (Detach Scope).
Regeln aktivieren/deaktivieren
Sie können die in der Ansicht All Rules aufgeführten Basisregeln und erweiterten Regeln aktivieren/deaktivieren. Die Spalte Enabled zeigt den Status einer Regel an: True (aktiviert) oder False (deaktiviert). Doppelklicken Sie auf eine Zelle in dieser Spalte, um den Status der jeweiligen Regel umzuschalten. Zellen, die deaktivierten Basisregeln entsprechen, sind in den Ansichten Physical und Electrical mit (Disabled) gekennzeichnet und ausgegraut.
Der Aktivierungsstatus erweiterter Regeln eines bestimmten Typs, einer bestimmten Kategorie oder aller erweiterten Regeln kann auch über die Befehle im Rechtsklick-Kontextmenü des entsprechenden Eintrags in der Baumstruktur Rule Class umgeschaltet werden.
|
Klicken Sie mit der rechten Maustaste auf einen Regeltypeintrag in der Baumstruktur Rule Class, um erweiterte Regeln dieses Typs zu aktivieren/deaktivieren. Klicken Sie mit der rechten Maustaste auf einen Regelkategorieeintrag in der Baumstruktur Rule Class, um erweiterte Regeln dieser Kategorie zu aktivieren/deaktivieren. Klicken Sie mit der rechten Maustaste auf die Überschrift Rule Class, um alle erweiterten Regeln zu aktivieren/deaktivieren. |
Regeln importieren und exportieren
In der Ansicht All Rules können Sie Regeln (erweiterte Regeln und/oder Basisregeln) importieren und exportieren.
Wählen Sie zum Exportieren mehrere Regeln in der Liste mithilfe von Ctrl+Click, Shift+Click oder Click, Hold&Drag aus. Klicken Sie anschließend mit der rechten Maustaste und wählen Sie den Befehl Export Selected Rules (x) (x steht für die Anzahl der ausgewählten Regeln). Sie können Regeln auch über die Befehle im Rechtsklick-Kontextmenü des entsprechenden Eintrags in der Baumstruktur Rule Class exportieren:
-
Klicken Sie mit der rechten Maustaste auf einen Regeltypeintrag in der Baumstruktur und wählen Sie den Befehl Export <RuleType> Rules , um Regeln dieses Regeltyps zu exportieren.
-
Klicken Sie mit der rechten Maustaste auf einen Regelkategorieeintrag in der Baumstruktur und wählen Sie den Befehl Export <RuleCategory> Rules , um Regeln dieser Regelkategorie zu exportieren.
-
Klicken Sie mit der rechten Maustaste auf die Überschrift Rule Class der Baumstruktur und wählen Sie den Befehl Export All Rules , um alle Regeln zu exportieren.
Nach Auswahl eines Export-Befehls wird der Dialog Constraints to Export geöffnet. Dort können Sie auswählen, welche Regel in eine *.CstrDot-Datei exportiert werden soll, die später in ein anderes Projekt importiert werden kann. Nach dem Klicken auf die Schaltfläche Export x Items (x steht für die Anzahl der im Dialog ausgewählten Elemente) wird der Standarddialog File Explorer geöffnet, in dem Sie den Namen und Speicherort der Datei festlegen können. Die Regeln werden in eine *.CstrDot-Datei exportiert, die später in ein anderes Design importiert werden kann.
|
Klicken Sie mit der rechten Maustaste auf eine oder mehrere ausgewählte Regeln, um sie zu exportieren. Klicken Sie mit der rechten Maustaste auf einen Regeltypeintrag in der Baumstruktur Rule Class, um Regeln dieses Typs zu exportieren. Klicken Sie mit der rechten Maustaste auf einen Regelkategorieeintrag in der Baumstruktur Rule Class, um Regeln dieser Kategorie zu exportieren. Klicken Sie mit der rechten Maustaste auf die Überschrift Rule Class, um alle Regeln zu exportieren. |
Klicken Sie zum Importieren mit der rechten Maustaste in den Listenbereich oder die Baumstruktur Rule Class der Ansicht All Rules und wählen Sie den Befehl Import Rules. Das Standardfenster File Explorer wird geöffnet. Wählen Sie darin die gewünschte *.CstrDot-Datei aus und klicken Sie anschließend auf Open. Der Dialog Constraints to Import wird geöffnet, in dem Sie die Regeln auswählen können, die in das aktuelle Design importiert werden sollen. Beim Import werden die zugehörigen benutzerdefinierten Geltungsbereiche automatisch angewendet.
Erweiterte Regeln löschen
Um die aktuell ausgewählte erweiterte Regel zu löschen, klicken Sie mit der rechten Maustaste darauf und wählen Sie Remove Advanced Rule. Um mehrere erweiterte Regeln gleichzeitig zu löschen, wählen Sie mehrere Regeln mithilfe von Ctrl+Click, Shift+Click oder Click, Hold&Drag aus. Klicken Sie anschließend mit der rechten Maustaste und wählen Sie Remove Advance Rules (x). „x“ steht für die Anzahl der Regeln, die entfernt werden. Sie können auch alle erweiterten Regeln eines bestimmten Typs, einer bestimmten Kategorie oder sämtliche erweiterten Regeln über die Befehle im Rechtsklick-Kontextmenü des entsprechenden Eintrags in der Baumstruktur Rule Class entfernen.
|
Klicken Sie mit der rechten Maustaste auf mehrere ausgewählte Regeln, um sie zu entfernen. Klicken Sie mit der rechten Maustaste auf einen Regeltypeintrag in der Baumstruktur Rule Class, um erweiterte Regeln dieses Typs zu entfernen. Klicken Sie mit der rechten Maustaste auf einen Regelkategorieeintrag in der Baumstruktur Rule Class, um erweiterte Regeln dieser Kategorie zu entfernen. Klicken Sie mit der rechten Maustaste auf die Überschrift Rule Class, um alle erweiterten Regeln zu entfernen. |
In jedem Fall werden die Regeln sofort und ohne Bestätigung gelöscht.
Cross-Probing
Der Constraint Manager bietet eine Cross-Probing-Funktion, die die zugehörigen Objekte im entsprechenden Dokument visuell hervorhebt. Um Cross-Probing für ein beliebiges Objekt auszuführen, klicken Sie mit der rechten Maustaste auf dessen Eintrag und wählen Sie die Option Cross Probe aus dem Kontextmenü oder wählen Sie Cross Probe aus dem Menü
einer erweiterten Regel.
Legen Sie Cross Probe View Settings im Panel Properties fest, um die Cross-Probing-Einstellungen zu konfigurieren.
Verwenden Sie die Option Clear Filter des Schaltplan-/PCB-Editors (klicken Sie mit der rechten Maustaste in den Designbereich und wählen Sie Clear Filter, Tastenkürzel: Shift+C), um die Cross-Probing-Hervorhebung zurückzusetzen.
Weitere Informationen zum Cross-Probing in Altium Designer finden Sie auf der Seite Cross-Probing & Auswahl.
Dokumentübergreifende Auswahl
Die Funktion zur dokumentübergreifenden Auswahl ermöglicht eine dynamische, bidirektionale Objektauswahl. Wenn der Modus zur dokumentübergreifenden Auswahl aktiviert ist (über Cross Select Mode Befehl aus dem Tools Hauptmenü des Constraint Managers, des Schaltplan- oder PCB-Editors) werden im Constraint Manager ausgewählte Objekte auch in den Schaltplan- und PCB-Dokumenten ausgewählt und umgekehrt.
Weitere Informationen zur übergreifenden Auswahl in Altium Designer finden Sie auf der Seite Cross-Probing & Auswahl.
Übertragen von Constraints zwischen Schaltplan und PCB
Im Constraint Manager vorgenommene Änderungen werden mithilfe des Engineering Change Order (ECO)-Prozesses zwischen Schaltplan- und PCB-Design übertragen. Wählen Sie einen Befehl aus, um die Constraints auf der jeweils anderen Seite zu aktualisieren.
-
Um Änderungen vom Schaltplan auf die PCB zu übertragen, wählen Sie den Befehl Design » Update PCB Document <PCBDocumentName> aus den Hauptmenüs des Schaltplan-Editors.
-
Um Änderungen (die in den Ansichten Clearances, Physical und/oder Electrical des Constraint Managers vorgenommen wurden) von der PCB auf den Schaltplan zu übertragen, wählen Sie den Befehl Design » Update Schematics in <PCBProjectName> aus den Hauptmenüs des PCB-Editors.
Verwenden Sie den anschließend angezeigten Dialog Engineering Change Order, um die Änderungen zu prüfen, zu validieren und auszuführen.
Weitere Informationen finden Sie auf der Seite Schaltpläne & PCB synchron halten.
Migration von Designregeln zum Constraint Manager
Wenn ein PCB-Projekt das alte Regelverwaltungssystem verwendet (d. h. den Dialog PCB Rules and Constraints Editor), können Sie eine einmalige, unidirektionale Migration zum Constraint Manager durchführen.
Verwenden Sie den Befehl Design » Migrate Project to Constraint Manager Flow aus den Hauptmenüs des PCB- und des Schaltplan-Editors. Der Dialog Migration Required wird geöffnet und weist darauf hin, dass die Migration durchgeführt wird und nach dem Klicken auf die Schaltfläche
nicht mehr rückgängig gemacht werden kann.
Sowohl PCB-Designregeln als auch Schaltplandirektiven werden in die jeweils entsprechenden Constraints im Constraint Manager übertragen. Nach erfolgreichem Abschluss der Migration wird der Constraint Manager geöffnet (im Kontext des Editors, der beim Durchführen der Migration aktiv war).
).



).
).
).

)
)
).






)
)
)








).
).





)

).










).
).
).