Diseñando la disposición de tu PCB

Altium Training

Altium Essentials: PCB Introduction

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

De un vistazo

Este artículo presenta los pasos fundamentales de configuración para diseñar una PCB en Altium Designer. Comienza con la configuración del editor de PCB y continúa con la creación de un documento de PCB, la definición de la forma y el origen de la placa, el control de la visibilidad de las capas y la configuración del apilado de capas. Estas tareas se enmarcan en los retos actuales del diseño de PCB, donde los formatos compactos, el enrutamiento de alta densidad y los requisitos eléctricos y mecánicos más complejos hacen que una configuración sólida del entorno de diseño sea esencial. Si buscas una guía práctica sobre cómo preparar el espacio y el entorno de diseño de tu PCB antes de comenzar el trabajo de diseño en detalle, este artículo te ayudará a sentar esa base con confianza. Sigue leyendo y prepárate para un proceso de diseño de PCB más fluido.

- Cómo configurar el editor de PCB y el documento de PCB, incluidas las preferencias, las rejillas y las unidades.
- Cómo definir y editar la forma de la placa, establecer el origen y gestionar la visualización de las capas mientras trabajas en el editor de PCB.
- Cómo organiza Altium Designer las capas de fabricación y las capas no eléctricas, y dónde configurar el apilado de capas y los tipos de vías.
Profundiza con IA:

Dentro de cada producto electrónico hay una placa de circuito impreso o PCB. Hoy en día, los componentes se han reducido tanto que se miden en fracciones de milímetro en lugar de centímetros, y las pistas han pasado de ser líneas de 10 mil de ancho, bien separadas, a líneas finas como cabellos de 2 o 3 mil, muy próximas entre sí. El aumento de la velocidad de las señales también ha hecho que las interconexiones de la PCB dejen de ser simples conductores de cobre que transportan energía eléctrica y se comporten como líneas de transmisión de alta velocidad, lo que requiere técnicas de diseño que tengan en cuenta este comportamiento. Los requisitos mecánicos también se han vuelto más complejos. Los productos electrónicos modernos, compactos y de formas poco convencionales, requieren placas de circuito impreso igualmente compactas y de formas poco convencionales, que a menudo se implementan como estructuras rígido-flexibles. Estas placas pueden tener bordes curvos y recortes, por lo que los componentes deben colocarse con cuidado.

Estos retos pueden afrontarse con las tecnologías de diseño de PCB de Altium. El editor de PCB de Altium Designer le permite crear, editar y verificar sus diseños de PCB.

Configuración del editor de PCB

La categoría PCB Editor del cuadro de diálogo Preferences (al que se accede haciendo clic en el icono  situado en la esquina superior derecha del espacio de diseño) permite acceder a páginas de preferencias que afectan al comportamiento del editor de PCB. Acceda a estas preferencias en cualquier momento para configurar los ajustes según sea necesario.

Utilice la categoría PCB Editor de Preferences de Altium Designer para configurar el editor de PCB.
Utilice la categoría PCB Editor de Preferences de Altium Designer para configurar el editor de PCB.

Más información sobre las preferencias de PCB: Preferencias del editor de PCB.

Configuración de un documento de PCB

Para empezar a diseñar su PCB, añada un nuevo documento de PCB al proyecto de PCB. Para ello, haga clic con el botón derecho en la entrada del proyecto en el panel Projects y seleccione el comando Add New to Project » PCB en el menú contextual. El documento de PCB predeterminado aparecerá en el espacio de diseño.

El documento de PCB recién creado será el documento activo en el espacio de diseño.
El documento de PCB recién creado será el documento activo en el espacio de diseño.

Las opciones de un documento de PCB se configuran en el panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño. Las opciones principales se configuran en la pestaña General del panel:

  • Configuración de la cuadrícula (región Grid Manager): configure las opciones de la cuadrícula global predeterminada o añada cuadrículas adicionales (cartesianas y polares) según sea necesario. Las cuadrículas garantizan el movimiento y la colocación precisos de los objetos.

    Cuando esté en el espacio de diseño, pulse G para abrir un menú desde el que podrá establecer rápidamente la cuadrícula global en uno de los valores estándar.
  • Unidades (región Other): seleccione las unidades de medida preferidas (mm o mils) para el documento.

Configure las opciones del documento de PCB en el panel Properties.
Configure las opciones del documento de PCB en el panel Properties.

Más información sobre la configuración de un documento de PCB: Configuración del entorno de PCB.

Definición de la forma de la placa y del origen

La forma de la placa, también denominada contorno de la placa, define sus dimensiones generales. De forma predeterminada, la placa es un rectángulo de 6000 x 4000 mil (152,4 x 101,6 mm). El editor de PCB proporciona varias herramientas para definir la forma de la placa según sea necesario.

Puede definir de forma interactiva una nueva forma de placa mediante el siguiente procedimiento:

  1. Acceda al modo de planificación de placa del editor seleccionando el comando View » Board Planning Mode en los menús principales.

  2. Seleccione el comando Design » Redefine Board Shape en los menús principales.

  3. Sitúe el cursor y haga clic para fijar el vértice inicial de la forma de la placa.

  4. Mueva el cursor hasta la posición del segundo vértice y haga clic para colocarlo.

    • Pulse Shift+Spacebar para alternar entre los cinco modos de esquina disponibles: 45 grados, 45 grados con arco, 90 grados, 90 grados con arco y cualquier ángulo.
    • Pulse Spacebar para alternar entre los dos submodos de dirección de esquina.
    • En cualquiera de los modos de esquina con arco, mantenga pulsadas las teclas «,» o «.» para reducir o ampliar el arco. Mantenga pulsada la tecla Shift mientras pulsa estas teclas para acelerar el cambio de tamaño del arco.
  5. Siga moviendo el ratón y haciendo clic para colocar más vértices.

  6. Después de colocar el último vértice, haga clic con el botón derecho para cerrar y completar la definición de la forma de la placa. No es necesario cerrar manualmente la forma de la placa, ya que el editor de PCB la completará automáticamente conectando el punto inicial con el último punto colocado.

También puede editar la forma existente en lugar de redefinirla mediante el siguiente procedimiento:

  1. Acceda al modo de planificación de placa del editor seleccionando el comando View » Board Planning Mode en los menús principales.
  2. Seleccione el comando Design » Edit Board Shape en los menús principales.
  3. Haga clic en un lado o vértice de la forma de la placa, mantenga pulsado el botón y arrástrelo para moverlo.

    • Al mover un vértice, utilice Shift+Spacebar para cambiar de modo.
    • Ctrl+Click en cualquier punto de un borde alejado de los controles de edición para insertar un nuevo vértice final.
  4. Salga del modo de edición haciendo clic en cualquier punto del espacio de diseño (sobre la forma de la placa o fuera de ella).

Utilice el comando View » 2D Layout Mode de los menús principales para volver al modo de diseño 2D del editor.

Las posiciones de los objetos colocados en el documento de PCB se muestran y definen respecto al origen actual, que aparece en el espacio de diseño como una cruz blanca dentro de un círculo. Utilice el comando Edit » Origin » Set de los menús principales para definir una ubicación del espacio de diseño como el nuevo origen actual y establecer sus coordenadas en (0,0).

Más información sobre las técnicas disponibles para definir la forma de la placa: Definición de la forma de la placa.

Configuración de la visualización de las capas

Además de las capas utilizadas para fabricar la placa, que incluyen las capas de señal, planos de alimentación, máscara y serigrafía, el editor de PCB también admite muchas otras capas no eléctricas. Las capas suelen agruparse de la siguiente manera:

  • Electrical Layers – incluye 128 capas de señal y 16 capas internas de planos de alimentación.

  • Component Layers – capas utilizadas en el diseño de los componentes, incluidas las capas de serigrafía, máscara de soldadura y pasta de soldadura. Si se coloca un objeto en la huella de un componente en una de estas capas en el editor de bibliotecas, al voltear el componente de la cara superior a la cara inferior de la placa, todos los objetos detectados en una capa de componente se trasladan a su capa de componente correspondiente. Esto incluye los objetos situados en pares de capas de componente definidos por el usuario (capas mecánicas emparejadas).

  • Mechanical Layers – el software admite un número ilimitado de capas mecánicas de uso general, que se utilizan para tareas de diseño como cotas, detalles de fabricación, instrucciones de montaje, etc. Estas capas pueden incluirse de forma selectiva en la generación de salidas de impresión y Gerber, si es necesario. Las capas mecánicas también pueden emparejarse; cuando están emparejadas, se comportan como capas de componente. Las capas de componente emparejadas se utilizan para tareas como la colocación de cuerpos 3D, puntos de adhesivo y recubrimiento selectivo de oro en conectores de borde.

  • Other Layers – estas incluyen la capa Keep-Out (utilizada para definir zonas de exclusión que se aplican a todas las capas de cobre), la multicapa (utilizada para objetos presentes en todas las capas de señal, como pads y vías), la capa Drill Drawing (utilizada para colocar información de taladrado, como una tabla de taladros) y la capa Drill Guide (utilizada para mostrar marcadores que indican las ubicaciones y los tamaños de los taladros).

Las capas de cobre se añaden al diseño y se eliminan de él en el Administrador de apilado de capas, que se describe en la siguiente sección. Todas las demás capas se habilitan y configuran en el panel View Configuration.

Las dos pestañas del panel View Configuration   View Configuration panel, View Options tab
Las dos pestañas del panel View Configuration

Además del estado de visualización de las capas y los ajustes de color, el panel View Configuration también permite acceder a otros ajustes de visualización, entre ellos:

  • El color y la visibilidad de System Colors, como el color de selección o si las líneas de conexión son visibles.

  • Cómo se muestra cada tipo de objeto (sólido o en contorno) y su transparencia (sección Object Visibility).

  • Diversas opciones de visualización, como si se deben mostrar Origin Marker, los nombres de Pad Net y Pad Numbers (sección Additional Options).

  • El grado de atenuación de la visualización cuando los objetos se atenúan o se enmascaran (sección Mask and Dim Settings).

  • La creación de conjuntos de capas, que permiten cambiar rápidamente qué capas son visibles mediante el control PCB editor design space, Layer Set control (sección Layers).

  • La creación y selección de configuraciones de vista, que se utilizan para preconfigurar todas las propiedades de las capas, como el color, la visibilidad, la transparencia de los objetos, etc. (sección General Settings).

Algunas notas sobre las capas:

  • Las capas habilitadas actualmente se muestran como una serie de pestañas en la parte inferior del espacio de diseño de la PCB, tal como se muestra en la imagen siguiente. Haga clic con el botón derecho en una pestaña para acceder a los comandos de visualización de capas más utilizados.

  • Al colocar objetos en una PCB, debe tener en cuenta en qué capa se colocarán. Los objetos se colocan en la capa actual, que se muestra como la pestaña de capa activa en la parte inferior del espacio de diseño. En la imagen anterior, Top Layer es la capa activa.

  • Para cambiar la capa activa:

    • Haga clic en la pestaña de la capa en la parte inferior del espacio de diseño, o

    • Pulse las teclas numéricas + o - para recorrer todas las capas, o

    • Pulse la tecla numérica * para recorrer las capas de señal, o

    • Utilice los atajos Ctrl+Shift+Mouse Wheel.

  • En un diseño complejo, puede resultar útil mostrar únicamente la capa en la que se está trabajando; esto se denomina Single Layer Mode. Para activar o desactivar el modo de una sola capa, pulse el atajo Shift+S. Los Available Single Layer Modes se configuran en la página Editor de PCB – Visualización de Board Insight del cuadro de diálogo Preferences. Cada vez que pulse Shift+S, se pasará al siguiente modo de una sola capa habilitado.

Más información sobre cómo configurar la vista de una PCB: Su vista de la PCB.

Definición del apilado de capas

La PCB se diseña y se forma como un apilado de capas definido en el Administrador de apilado de capas (Design » Layer Stack Manager). El Layer Stack Manager se abre en un editor de documentos, del mismo modo que una hoja de esquemático, la PCB y otros tipos de documentos. Las funciones se distribuyen entre las pestañas que aparecen en la parte inferior del Layer Stack Manager. Las principales operaciones de configuración se realizan en las pestañas Stackup y Via Types.

La pestaña Stackup detalla las capas de fabricación. En esta pestaña se añaden, eliminan y configuran las capas.

Javascript

Para añadir una capa, seleccione en el área de la cuadrícula una capa por encima o por debajo de la cual se deba añadir la nueva capa, haga clic en el botón Add situado en la parte superior del Layer Stack Manager y utilice la ventana emergente que aparece.

Para eliminar una capa, selecciónela en el área de la cuadrícula y haga clic en el botón Delete.

Para seleccionar un material de capa de la biblioteca de materiales, seleccione la capa deseada en el área de la cuadrícula y haga clic en el botón Modify. Las propiedades definidas para el material elegido se aplicarán a la capa.

Las propiedades de la capa seleccionada actualmente también se pueden editar directamente en el área de la cuadrícula o en el panel Properties.

  • Para acceder a la biblioteca de materiales, seleccione el comando Design » Layer Stack Manager en los menús principales.
  • En el menú Tools » Presets hay varios apilados de capas predefinidos disponibles.

La pestaña Via Types se utiliza para definir los requisitos permitidos de extensión entre capas en el eje Z para las vías utilizadas en el diseño.

Javascript

El tipo de vía pasante predeterminado siempre está presente en un diseño de PCB.

Para añadir un tipo de vía adicional (ciega, enterrada o microvía), haga clic en el botón Add situado en la parte superior del Layer Stack Manager y, a continuación, seleccione las capas que abarca este tipo de vía en las listas desplegables First layer y Last layer del panel Properties, cuando el tipo de vía esté seleccionado en el área de la cuadrícula.

Para eliminar un tipo de vía añadido, selecciónelo en el área de la cuadrícula y haga clic en el botón Delete.

Tenga en cuenta que el diámetro y el tamaño del taladro (propiedades X&Y) de las vías colocadas en el diseño se controlan mediante la regla de diseño de estilo de vía de enrutamiento aplicable si la vía se coloca durante el enrutamiento interactivo.

Utilice el comando File » Save to PCB del Layer Stack Manager para reflejar los cambios en la PCB.

Más información sobre Layer Stack Manager: Definición del apilado de capas, Definición de vías ciegas, enterradas y microvías.

Configuración de las reglas de diseño

Las reglas de diseño supervisan y comprueban el diseño con respecto a distintos requisitos, como las separaciones entre objetos de cobre, las anchuras de las pistas, las longitudes de las redes, etc. En conjunto, las reglas de diseño forman un conjunto de instrucciones que debe seguir el editor de PCB.

Las reglas de diseño se definen y gestionan desde el cuadro de diálogo PCB Rules and Constraints Editor, al que se accede seleccionando el comando Design » Rules en los menús principales.

Tenga en cuenta que, si la función Administrador de restricciones estaba disponible al crear el proyecto de PCB, se utiliza Constraint Manager para definir las restricciones de diseño de ese proyecto. En este caso, el PCB Rule and Constraints Editor no estará disponible en el editor de PCB. De lo contrario, solo se podrán utilizar los métodos anteriores para definir las restricciones de diseño (directivas de diseño y el cuadro de diálogo PCB Rule and Constraints Editor).

El cuadro de diálogo PCB Rules and Constraints Editor tiene dos secciones:

  • La parte izquierda del cuadro de diálogo muestra un árbol con las categorías de reglas disponibles, los tipos de reglas de cada categoría y las reglas individuales de cada tipo que están definidas actualmente.
  • La parte derecha del cuadro de diálogo muestra información relacionada con el elemento seleccionado en el árbol. Por ejemplo, seleccione una regla individual para mostrar su configuración.
Javascript

Haga clic en la entrada Design Rules para acceder a una lista resumida de todas las reglas específicas que se han definido para el diseño.

Haga clic en una categoría para acceder a una lista resumida de todas las reglas específicas que se han definido para todos los tipos de reglas de diseño asociados a esa categoría.

Haga clic en la entrada de una regla específica para acceder a los controles que permiten gestionar su definición.

Las reglas de diseño tienen tres grupos de ajustes, que se describen a continuación y se muestran en las imágenes posteriores:

  1. Atributos principales de la regla: aquí puede asignar a la regla un nombre significativo y añadir un comentario opcional.
  2. Ámbito de la regla – define los objetos específicos de un diseño a los que se aplica la regla. Según el tipo de regla, se debe definir un ámbito (para una regla unaria que define el comportamiento requerido de un objeto) o dos (para una regla binaria que define la interacción entre dos objetos).
  3. Restricciones de la regla – restricciones específicas de la regla.
Javascript

Las reglas del tipo Ancho son reglas unarias. Para una regla unaria se debe definir un único ámbito (Where the Object Matches). 

Las reglas del tipo Separación son reglas binarias. Para una regla binaria se deben definir dos ámbitos (Where the First Object Matches y Where the Second Object Matches).

Para crear una regla nueva, haga clic con el botón derecho en el tipo de regla deseado en el árbol del cuadro de diálogo y seleccione el comando New Rule del menú contextual. La regla nueva se añadirá al árbol bajo la categoría seleccionada. Seleccione la entrada de la regla en el árbol para editarla.

Cuando hay varias reglas del mismo tipo que se aplican a los mismos objetos, el editor de PCB utiliza la prioridad de las reglas para garantizar que se aplique la regla pertinente de mayor prioridad. Haga clic en el botón Priorities  situado en la parte inferior del cuadro de diálogo PCB Rules and Constraints Editor para abrir el cuadro de diálogo Edit Rule Priorities y cambiar las prioridades según sea necesario. 1 es la prioridad más alta. Cuando se añade una regla nueva (mediante el comando New Rule), se le asigna la prioridad más alta.

Obtenga más información sobre cómo trabajar con reglas de diseño de PCB y tipos de reglas específicos: Definición, delimitación del ámbito y gestión de las reglas de diseño de PCB, Tipos de reglas de diseño de PCB.

Colocación de componentes

Cuando se transfieren los datos de diseño de los esquemas del proyecto de PCB al documento de PCB (mediante el comando Design » Update PCB Document de los menús principales del editor de esquemas y el posterior proceso de ejecución de ECO), las huellas predeterminadas de los componentes utilizados en los esquemas se colocarán en posiciones arbitrarias en el documento de PCB. Los pads de los componentes se conectarán mediante líneas de conexión, según las redes (pines de componentes conectados) definidas en los esquemas.

Una PCB después de actualizarla a partir de los esquemas.
Una PCB después de actualizarla a partir de los esquemas.

Las técnicas básicas para definir la ubicación de un componente en una PCB son:

  • Para mover un componente a la ubicación deseada, Click, Hold&Drag y, a continuación, suelte el botón del ratón para colocarlo.
  • Para girar un componente, pulse Spacebar mientras lo arrastra.
  • Para pasar un componente al otro lado de la placa, pulse L mientras lo arrastra. 

Las líneas de conexión se vuelven a optimizar automáticamente al mover un componente. Utilícelas como guía para orientar y colocar los componentes de forma que se reduzca el número de cruces entre las líneas de conexión.

  • Los objetos seleccionados también se pueden mover con el teclado en lugar del ratón. Para ello, mantenga pulsada la tecla Ctrl; cada vez que pulse una arrow key, la selección se moverá un paso de la cuadrícula en la dirección de esa flecha. Mantenga pulsada también la tecla Shift para mover los objetos seleccionados en incrementos de 10 pasos de la cuadrícula de ajuste.

  • Al mover un componente con el ratón, puede restringir su movimiento a un eje manteniendo pulsada la tecla Alt. El componente intentará mantenerse en el mismo eje horizontal (si se mueve horizontalmente) o vertical (si se mueve verticalmente); aléjelo más del eje para anular este comportamiento o suelte la tecla Alt.

Obtenga más información sobre la conectividad en una PCB y la colocación de componentes: Comprender la conectividad de su PCB, Colocación de componentes.

Enrutamiento de la placa

El enrutamiento es el proceso de colocar pistas, arcos y vías en la placa para conectar los pads de los componentes. El editor de PCB ofrece herramientas, incluidas herramientas de enrutamiento interactivo, para ayudarle a enrutar las conexiones de la placa.

Dado que las herramientas de enrutamiento se rigen por reglas, es esencial configurar las reglas de diseño antes de empezar a enrutar. Las principales reglas de diseño utilizadas durante el proceso de enrutamiento interactivo son:

  • La regla de Separación (la categoría Electrical) – define cuánto pueden acercarse las pistas de la red que se está enrutando a otros objetos de la placa.
  • La regla de Ancho (la categoría Routing) – define el ancho de las pistas de la red que se está enrutando.
  • El Estilo de vías de enrutamiento (la categoría Routing) – define el diámetro y el tamaño del taladro de las vías que se colocan al cambiar de capa durante el enrutamiento.

También se recomienda establecer una cuadrícula de ajuste adecuada para el enrutamiento.

Aunque puede resultar tentador seleccionar una cuadrícula de enrutamiento muy fina para poder colocar las pistas prácticamente en cualquier lugar, este no es un buen enfoque. ¿Por qué? Porque el objetivo de establecer la cuadrícula con un paso igual a la suma del ancho de pista y la separación, o a una fracción de esa suma, es garantizar que las pistas se coloquen sin desperdiciar espacio disponible para el enrutamiento, algo que puede ocurrir si se utiliza una cuadrícula muy fina.

Para enrutar una sola conexión, se utiliza la herramienta de Enrutamiento interactivo. El proceso es el siguiente:

  1. Seleccione el comando Route » Interactive Routing en los menús principales.

  2. Haga clic en el pad de un componente desde el que desee iniciar el enrutamiento.

  3. Posicione el cursor y, a continuación, haga clic en el espacio de diseño para colocar las pistas hasta el cursor. Continúe definiendo el recorrido de las pistas.

  4. Haga clic en el pad de destino para terminar de enrutar la conexión. La conexión se liberará automáticamente y permanecerá en el modo de enrutamiento interactivo, listo para enrutar la siguiente conexión.

  5. Haga clic con el botón derecho para salir del modo de enrutamiento interactivo.

Notas sobre el enrutamiento interactivo:

  • Al acercar el cursor a un pad durante el enrutamiento interactivo, este se ajustará automáticamente al centro del pad. Esto se debe a la función de puntos de ajuste de objetos, que atrae el cursor hacia el punto de ajuste del objeto eléctrico más cercano.

    A veces, esta función atrae el cursor cuando no lo desea. En ese caso, pulse la tecla Ctrl para desactivar temporalmente el ajuste. También puede utilizar el atajo Shift+E para alternar el modo Hotspot Snap entre los tres estados posibles: Hotspot Snap (All Layers) / Hotspot Snap (solo se ajusta en la capa actual) / Off. El modo actual se muestra en la barra de estado (no se muestra nada cuando la función está desactivada).

    Más información sobre Cómo trabajar con el sistema de ajuste del cursor.

  • Durante el enrutamiento interactivo, puede utilizar los siguientes atajos:

    • Tab para pausar el enrutamiento y abrir el panel Properties para configurar las opciones de enrutamiento interactivo. Cuando termine, haga clic en el botón Haga clic y arrastre para mover​ del espacio de diseño para volver al modo de enrutamiento interactivo.

    • Shift+Spacebar para alternar entre los estilos de esquina: pista a 45°, línea a 45°/90° con arco, cualquier ángulo, etc.

    • Spacebar para alternar la dirección de la esquina.

    • Shift+R para alternar entre los modos disponibles de resolución de conflictos de enrutamiento: rodear obstáculos, desplazar obstáculos, ignorar obstáculos, etc.

    • Ctrl+Shift+Wheel Scroll para cambiar a la siguiente capa de señal disponible e insertar una vía.

    • Shift+F1 para mostrar la lista de atajos de enrutamiento interactivo.

  • Durante el enrutamiento, los segmentos de pista se muestran de distintas formas (como se ilustra en las imágenes siguientes):

    • Solid – el segmento ya se ha colocado.

    • Hatched – los segmentos con trama están propuestos, pero aún no se han confirmado; se colocarán al hacer clic.

    • Hollow – este se denomina segmento de anticipación y le permite determinar dónde debe terminar el último segmento propuesto. Este segmento not se coloca al hacer clic, a menos que el siguiente clic complete la ruta. En ese caso, la opción Automatically Terminate Routing entra en acción y anula el comportamiento predeterminado de anticipación. El modo de anticipación se puede activar o desactivar mediante el atajo 1 durante el enrutamiento.

    Los segmentos sólidos ya están colocados, los segmentos con trama están propuestos pero no confirmados, y el segmento hueco es el de anticipación. 
    Los segmentos sólidos ya están colocados, los segmentos con trama están propuestos pero no confirmados, y el segmento hueco es el de anticipación.

  • Una función excelente para visualizar el espacio disponible para el enrutamiento es la posibilidad de mostrar los límites de separación alrededor de todos los objetos de otras redes (). Utilice el atajo Ctrl+W para activar o desactivar los límites de separación. Cuando esta función está activada y se está enrutando una red, todos los objetos de otras redes muestran un límite de separación definido por la restricción de separación eléctrica aplicable. No es posible cruzar este límite durante el enrutamiento.

  • Durante el enrutamiento, hay numerosos detalles útiles, como el nombre de la red y el ajuste de ancho actual, disponibles en la visualización de información superpuesta y en la barra de estado ().

  • En lugar de enrutar hasta el pad de destino, también puede pulsar Ctrl+Click para utilizar la función Auto-Complete e indicar al motor de enrutamiento que intente enrutar toda la conexión. La función de autocompletado se comporta de las siguientes maneras:

    • Toma la ruta más corta, que puede no ser la mejor, ya que siempre debe tener en cuenta las rutas de otras conexiones que aún no se han enrutado. Si está en el modo de desplazamiento, el autocompletado puede desplazar las rutas existentes para llegar al destino.

    • En conexiones más largas, es posible que la ruta de autocompletado no siempre esté disponible, ya que la ruta de enrutamiento se traza sección por sección y puede que no sea posible trazarla por completo entre los pads de origen y destino.

    • También puede utilizar el autocompletado (Ctrl+Click) directamente sobre un pad o una línea de conexión.

No existe una única solución para enrutar una placa, por lo que es inevitable que quiera modificar el enrutamiento. El editor de PCB incluye funciones y herramientas que le ayudarán a hacerlo. Hay dos enfoques: volver a enrutar o reorganizar.

  • Reroute – seleccione el comando Route » Interactive Routing y comience a enrutar desde cualquier punto de una ruta existente para redefinir el recorrido de la conexión. La función de eliminación de bucles eliminará automáticamente los segmentos de pista (y las vías) redundantes en cuanto cierre el bucle y haga clic con el botón derecho para indicar que ha terminado.

  • Rearrange – Click, Hold&Drag para deslizar o arrastrar de forma interactiva segmentos de pista por la placa.

Más información sobre el enrutamiento de la PCB: Enrutamiento de la PCB.

Colocación de polígonos

Para cubrir una capa de señal de la PCB con una gran área de cobre, puede utilizar un relleno poligonal. Un relleno poligonal se extiende automáticamente alrededor de los objetos existentes y solo se conecta a los objetos de la misma red que el relleno. Las separaciones y las propiedades de conexión se controlan mediante las reglas de diseño aplicables de separación y de estilo de conexión de polígonos.

Para colocar un relleno poligonal:

  1. Seleccione el comando Place » Polygon Pour en los menús principales.
  2. Durante la colocación, puede pulsar la tecla Tab para abrir el panel Properties y configurar las propiedades del polígono que está colocando: red, capa, modo de relleno, etc. Cuando termine, haga clic en el botón  del espacio de diseño para volver al modo de colocación.
  3. Sitúe el cursor y haga clic para fijar el vértice inicial del relleno poligonal.
  4. Mueva el cursor hasta la posición del segundo vértice y haga clic para colocarlo.

    • Pulse Shift+Spacebar para alternar entre los cinco modos de esquina disponibles: 45 grados, 45 grados con arco, 90 grados, 90 grados con arco y cualquier ángulo.
    • Pulse Spacebar para alternar entre los dos submodos de dirección de esquina.
    • En cualquiera de los modos de esquina con arco, mantenga pulsadas las teclas "," o "." para reducir o ampliar el arco. Mantenga pulsada la tecla Shift mientras pulsa estas teclas para acelerar el cambio de tamaño del arco.
  5. Siga moviendo el ratón y haciendo clic para colocar más vértices.
  6. Después de colocar el último vértice, haga clic con el botón derecho para cerrar y completar la colocación del relleno poligonal. No es necesario cerrar manualmente la forma del polígono, ya que el editor de PCB la completará automáticamente conectando el punto inicial con el último punto colocado.
  7. Siga colocando más rellenos poligonales o haga clic con el botón derecho para salir del modo de colocación.

Cuando se modifica un relleno poligonal (por ejemplo, si se cambia su forma o sus propiedades), debe volver a rellenarse para reflejar los cambios. Para volver a rellenar un polígono, haga clic en el botón Repour situado en la parte superior del panel Properties con el polígono seleccionado.

Más información sobre los rellenos poligonales: Polígonos en capas de señal.

Ejecución de una comprobación de reglas de diseño

El editor de PCB ofrece funciones de comprobación de reglas de diseño (DRC) para verificar que el diseño cumple las reglas de diseño habilitadas.

La comprobación de reglas de diseño se configura en el cuadro de diálogo Design Rule Checker, al que se accede mediante el comando Tools » Design Rule Check de los menús principales.

  • Haga clic en la entrada Report Options del árbol situado a la izquierda del cuadro de diálogo para configurar las opciones adicionales disponibles al ejecutar una DRC por lotes.

  • Haga clic en la entrada Rules to Check o en una entrada de una categoría de reglas específica para cargar en el cuadro de diálogo una lista de tipos de reglas y habilitar cada tipo para la DRC en línea y/o por lotes, según sea necesario:

    • DRC en línea: la comprobación se realiza en tiempo real mientras diseña.

    • DRC por lotes: la comprobación se realiza como un proceso por lotes al hacer clic en el botón Run Design Rule Check del cuadro de diálogo. Los resultados se muestran en el panel Messages y, opcionalmente, en un informe generado.

Una lista larga de infracciones puede resultar abrumadora al principio. Una buena forma de gestionarla es deshabilitar y habilitar los tipos de reglas en el cuadro de diálogo Design Rule Check en distintas etapas del proceso de diseño. Si hay infracciones, no es aconsejable deshabilitar las propias reglas de diseño, sino únicamente su comprobación. Por ejemplo, conviene mantener deshabilitada la comprobación Un-Routed Net hasta que la placa esté completamente enrutada.

Javascript

Al ejecutar una DRC en línea o por lotes, las infracciones de reglas detectadas se indican en el espacio de diseño (mediante gráficos personalizados de infracción y/o una superposición de infracciones). A continuación se muestran algunos ejemplos de infracciones en el espacio de diseño:

Pistas que infringen una regla de anchura. La infracción se indica mediante gráficos personalizados de infracción y una superposición de infracciones.
Pistas que infringen una regla de anchura. La infracción se indica mediante gráficos personalizados de infracción y una superposición de infracciones.

Una pista que infringe una regla de antenas de red. La infracción se indica mediante gráficos personalizados de infracción.
Una pista que infringe una regla de antenas de red. La infracción se indica mediante gráficos personalizados de infracción.

Puede configurar cómo se muestran las infracciones de los distintos tipos de reglas en el espacio de diseño mediante la página Editor de PCB – Visualización de infracciones de DRC del cuadro de diálogo Preferences.

Según la información sobre cuánto se desvía una infracción del límite permitido, puede decidir cuál es la mejor forma de resolverla. Por ejemplo, si la restricción de anchura mínima de la franja de máscara de soldadura está establecida en 0,25 mm y la franja real mide 0,24 mm, la situación no es tan grave y quizá pueda ajustar la restricción para aceptar este valor. Pero si la anchura real de la franja es de 0,02 mm, probablemente no sea una situación que pueda resolverse ajustando la restricción.

  • Los detalles se incluyen en el panel Messages. El valor real se detalla junto con el valor especificado (por ejemplo, 0.017mm < 0.254mm).

  • También puede hacer clic con el botón derecho en una infracción y abrir el submenú Violations para examinar qué restricción se está infringiendo y las condiciones de la infracción ().

  • El editor de PCB también incluye prácticas herramientas de medición que permiten medir la distancia entre dos puntos, medir los objetos seleccionados (longitud de las pistas y los arcos seleccionados) y medir la distancia entre dos primitivas. Consulte la página Medición de distancias en una PCB para obtener más información.

El panel PCB Rules And Violations es una excelente herramienta para localizar y comprender las condiciones de las infracciones. De forma predeterminada, muestra [All Rules] en la lista Rule Classes. Una vez que haya identificado un tipo de regla de interés, seleccione esa clase de regla específica para que solo se muestren esas infracciones en la parte inferior del panel. El panel detalla el tipo de infracción, el valor medido, la restricción y los objetos que la infringen. Las infracciones de reglas detectadas para la clase de regla o la regla específica seleccionada también se enumeran en la región Violations del panel. Haga clic en una entrada de infracción para resaltarla en el espacio de diseño, según la configuración de la parte superior del panel: Mask/Dim/Normal, Select, Zoom. Haga doble clic en una infracción para abrir el cuadro de diálogo Violation Details.​​​

También se puede ejecutar la DRC para todas las reglas, para las reglas de un tipo específico o para una regla concreta haciendo clic con el botón derecho en la entrada correspondiente del panel PCB Rules And Violations y seleccionando el comando Run DRC.

Ejecute la DRC directamente desde el panel PCB Rules And Violations. Aquí se muestra la ejecución de la DRC para todas las reglas de separación definidas.
Ejecute la DRC directamente desde el panel PCB Rules And Violations. Aquí se muestra la ejecución de la DRC para todas las reglas de separación definidas.

Más información sobre la DRC: Comprobación de reglas de diseño (DRC).

AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Nav
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents