Travail avec les pastilles et les vias

En un coup d'œil

Cet article présente le fonctionnement des pastilles et des vias dans Altium Designer : leur définition, leurs différences, leurs usages, ainsi que leur placement et leur modification dans les éditeurs de PCB et d’empreintes de PCB. Il décrit également les principaux types de vias, détaille les méthodes de placement direct et de conversion, et aborde les fonctionnalités du logiciel liées aux performances pour la gestion des modèles et des vias. Si vous souhaitez mieux comprendre ces objets essentiels du PCB, qui permettent de connecter les composants et d’assurer le routage entre les couches, poursuivez votre lecture pour maîtriser ces concepts fondamentaux.

- Vous découvrirez les différences pratiques entre les pastilles et les vias, notamment leur structure, leur rôle et les principaux types de vias utilisés dans la conception de PCB.
- Vous verrez comment placer, déplacer, convertir et attribuer des pastilles et des vias dans les processus de travail d’Altium Designer.
- Vous obtiendrez un aperçu de la gestion des propriétés des pastilles et des vias, notamment de l’utilisation des modèles et des principales options de modification du panneau Properties.
Approfondissez avec l'IA :

Présentation des pastilles et des vias

Les pastilles assurent à la fois la fixation mécanique et les connexions électriques des broches des composants Les pastilles assurent à la fois la fixation mécanique et les connexions électriques des broches des composants

Une pastille est un objet de conception primitif. Les pastilles servent à fixer le composant sur la carte et à créer les points d’interconnexion entre les broches du composant et le routage de la carte. Les pastilles peuvent se trouver sur une seule couche, comme les pastilles pour composants montés en surface, ou être des pastilles traversantes tridimensionnelles, dotées d’un corps cylindrique creux dans le plan Z (vertical) et d’une surface plane sur chaque couche de cuivre (horizontale). Le corps cylindrique creux de la pastille est formé lors du perçage et de la métallisation des trous pendant la fabrication de la carte. Dans les plans X et Y, les pastilles peuvent être rondes, rectangulaires, octogonales, rectangulaires à coins arrondis, rectangulaires à coins chanfreinés ou de forme personnalisée. Les pastilles peuvent être utilisées individuellement comme pastilles libres dans une conception, mais elles sont plus généralement utilisées dans l’éditeur de bibliothèques PCB, où elles sont intégrées avec d’autres primitives aux empreintes de composants.

Un via reliant la couche supérieure (rouge) à la couche inférieure (bleue), et également connecté à un plan d’alimentation interne (vert). 
Un via reliant la couche supérieure (rouge) à la couche inférieure (bleue), et également connecté à un plan d’alimentation interne (vert).

Un via est un objet de conception primitif. Les vias sont utilisés pour établir une connexion électrique verticale entre deux ou plusieurs couches électriques d’un PCB. Les vias sont des objets tridimensionnels et possèdent un corps cylindrique creux dans le plan Z (vertical), avec un anneau plat sur chaque couche de cuivre (horizontale). Le corps cylindrique creux du via est formé lors du perçage et de la métallisation des trous pendant la fabrication de la carte. Les vias sont circulaires dans les plans X et Y, comme les pastilles rondes. La principale différence entre un via et une pastille est qu’en plus de pouvoir traverser toutes les couches de la carte (de la couche supérieure à la couche inférieure), un via peut également relier une couche de surface à une couche interne ou deux couches internes entre elles.

Les vias peuvent être de l’un des types suivants :

  • Thru-Hole – ce type de via traverse la carte de la couche supérieure à la couche inférieure et permet des connexions à toutes les couches de signal internes.
  • Blind – ce type de via relie la surface de la carte à une couche de signal interne.
  • Buried – ce type de via relie une couche de signal interne à une autre couche de signal interne.

Les types de vias pouvant être utilisés dans la conception sont définis dans Layer Stack Manager. Pour en savoir plus, consultez la page Définition des vias borgnes, enterrés et des microvias.

Les définitions de pastilles et de vias peuvent également être stockées dans des bibliothèques de modèles de pastilles et de vias ; consultez la page Utilisation des modèles et des bibliothèques de pastilles et de vias pour en savoir plus.

Les modèles de pastilles et de vias qui ne sont pas liés à une bibliothèque externe de pastilles et de vias sont stockés dans le document PCB, ce qui permet de réduire les temps de chargement.

Cette fonctionnalité est disponible lorsque l’option PCB.Performance.PadViaTemplate.LoadingOptimization est activée dans la boîte de dialogue des paramètres avancés.

L’éditeur PCB utilise le concept d’« instanciation des vias », une approche permettant de construire la géométrie d’une instance de via plutôt que celle d’un modèle de via. Cela améliore les performances tout en réduisant la consommation de mémoire et le temps de construction de la scène.

Cette fonctionnalité est en bêta ouverte et disponible lorsque l’option PCB.ViaInstancing est activée dans la boîte de dialogue des paramètres avancés.

Placement direct des pastilles et des vias

Les pastilles et les vias peuvent être placés dans l’éditeur PCB comme dans l’éditeur d’empreintes PCB. Les vias sont généralement placés automatiquement pendant les processus de routage interactif ou automatique, mais ils peuvent être placés manuellement si nécessaire. Les vias placés manuellement sont appelés vias « libres ». Après le lancement de la commande de placement de pastille (Place » Pad) ou de via (Place » Via), le curseur prend la forme d’une croix et vous passez en mode placement.

  1. Positionnez le curseur, puis cliquez ou appuyez sur Enter pour placer une pastille ou un via.
  2. Continuez à placer d’autres pastilles ou vias, ou faites un clic droit ou appuyez sur Esc pour quitter le mode placement.
Une pastille ou un via adopte le nom du net si cet élément est placé sur un objet déjà connecté à un net.

Pendant le placement, appuyez sur la touche Alt pour contraindre le déplacement à l’axe horizontal ou vertical, selon la direction initiale du déplacement.

En général, les vias ne sont pas placés manuellement ; ils sont placés automatiquement au cours du routage interactif. Consultez la section Placement des vias pendant le routage interactif pour en savoir plus.

Les pastilles libres sur la couche Multi-layer peuvent être converties en vias. Une pastille libre est une pastille qui n’appartient pas à un objet composant parent. La conversion de pastilles libres en vias peut être utile lors de la reconversion manuelle de fichiers Gerber importés au format PCB. Sélectionnez toutes les pastilles libres que vous souhaitez convertir dans l’espace de conception, puis choisissez la commande Tools » Convert » Convert Selected Free Pads to Vias dans les menus principaux. Les pastilles libres seront converties en vias de même diamètre de trou. La valeur la plus élevée parmi toutes les paires de dimensions XY disponibles pour la pastille (correspondant à la taille de la pastille sur les différentes couches) sera utilisée comme diamètre du via.

Les vias peuvent également être convertis en pastilles libres. La conversion de vias en pastilles libres peut être utile lors de l’importation de fichiers PADS-PCB et PADS 2000, dans lesquels les vias servent à établir des connexions aux couches d’alimentation et de masse. Cela permet d’assurer une connexion correcte aux plans d’alimentation internes à l’aide de pastilles modifiables. Sélectionnez tous les vias que vous souhaitez convertir dans l’espace de conception, puis choisissez la commande Tools » Convert » Convert Selected Vias to Free Pads dans les menus principaux. Les vias seront convertis en pastilles libres de même style (Simple, Top-Middle-Bottom ou Full Stack) et de même diamètre de trou. Le diamètre du via est utilisé pour définir les dimensions XY de la pastille sur les couches concernées. La forme de la pastille sera définie sur Round.

Modification graphique

Les propriétés des pastilles et des vias ne peuvent pas être modifiées graphiquement, à l’exception de leur position.

  • Pour déplacer une pastille libre ainsi que les pistes qui y sont connectées, cliquez sur la pastille, maintenez le bouton enfoncé et déplacez-la. Le routage connecté restera attaché à la pastille pendant son déplacement. Notez que la pastille ne se déplacera pas si elle appartient à un composant.
  • Pour déplacer une pastille libre sans déplacer les pistes connectées dans l’éditeur PCB ou PCB Library, sélectionnez la commande Edit » Move » Move, puis cliquez sur la pastille, maintenez le bouton enfoncé et déplacez-la.
  • Si vous cliquez et faites glisser un rectangle de sélection autour de pastilles component, elles ne seront pas sélectionnées, car ce sont en réalité des objets enfants du composant. Pour sélectionner uniquement les pastilles, maintenez Ctrl enfoncé pendant que vous cliquez et faites glisser la fenêtre de sélection.
  • Si vous déplacez un via avec les pistes afin de libérer de l’espace pour le routage ou les composants, il peut être plus efficace de refaire le routage que de déplacer les pistes. Le logiciel inclut une fonctionnalité appelée Loop Removal. Lorsque cette fonctionnalité est activée, vous effectuez le routage selon un nouveau parcours (en commençant et en terminant à un endroit du routage d’origine) ; dès que vous cliquez avec le bouton droit pour quitter le mode de routage interactif, l’ancien routage (la boucle) est supprimé, ainsi que les éventuels vias redondants.

Modification non graphique via le panneau Properties

Cette méthode de modification utilise le mode associé du panneau Properties pour modifier les propriétés d’un objet pastille/via.

Freins thermiques des pastilles et des vias

Le champ Thermal Relief de la zone Pad Stack / Via Stack du panneau Properties récapitule la configuration des freins thermiques actuellement appliquée. Par exemple, Relief, 15mil, 10mil, 4, 90 signifie que :

  • la connexion par frein thermique est appliquée ;
  • l’espace d’isolation a une largeur de 15 mil ;
  • les conducteurs du frein thermique ont une largeur de 10 mil ;
  • les conducteurs du frein thermique présentent une rotation de 90 degrés.

Lorsque la case du champ Thermal Relief est décochée, les freins thermiques reliant les pastilles et les vias aux polygones sont rules-driven, c’est-à-dire qu’ils sont définis par les règles de conception de style de connexion aux polygones applicables. Pour chaque pastille, la configuration des freins thermiques peut être personnalisée en activant l’option Thermal Relief associée à la couche souhaitée. Dans ce cas, les freins thermiques sont considérés comme custom. Pour en savoir plus, consultez Définition de freins thermiques personnalisés.

Expansions des masques de soudure et de pâte à braser

Le masque de soudure est créé automatiquement à l’emplacement de chaque pastille/via sur la couche de masque de soudure. Il est défini en négatif, c’est-à-dire que les objets placés définissent des ouvertures dans cette couche. Le masque de pâte à braser est créé automatiquement à l’emplacement de chaque pastille sur la couche de masque de pâte à braser. La forme créée sur la couche de masque correspond à celle de la pastille ou du via, agrandie ou réduite selon la valeur spécifiée par les règles de conception Expansion du masque de soudure et Expansion du masque de pâte à braser définies dans l’éditeur de PCB ou selon les paramètres du panneau Properties.

Pastilles avec le masque de soudure affiché.
Pastilles avec le masque de soudure affiché.

Lorsque vous modifiez une pastille ou un via, les paramètres d’expansion du masque de soudure et du masque de pâte à braser sont affichés respectivement dans les sections Pad Stack et Solder Mask Expansion du panneau Properties. Bien que ces paramètres permettent de contrôler localement les exigences d’expansion d’une pastille ou d’un via, vous n’aurez généralement pas besoin de les utiliser. Il est en général plus simple de gérer les exigences relatives au masque de pâte à braser et au masque de soudure en définissant les règles de conception appropriées dans l’éditeur de PCB. Une règle permet de définir l’expansion pour tous les composants de la carte. Si nécessaire, vous pouvez ensuite ajouter d’autres règles ciblant des cas particuliers, tels que toutes les instances d’un type d’empreinte utilisé sur la carte, une pastille donnée d’un composant précis, etc.

  

Pour définir les expansions des masques dans les règles de conception :

  1. Vérifiez que l’option Rule Expansion est sélectionnée pour le paramètre Shape dans la section Pad Stack du panneau Properties (pour les pastilles) et/ou que l’option Rule est sélectionnée dans la section Solder Mask Expansion du panneau Properties (pour les vias).

  2. Dans l’éditeur de PCB, sélectionnez Design » Rules dans les menus principaux et examinez les règles de conception de la catégorie Mask dans la boîte de dialogue Éditeur de règles et de contraintes PCB. Ces règles seront appliquées lorsque l’empreinte sera placée sur le PCB.

Pour remplacer les règles de conception d’expansion et définir une expansion de masque comme attribut d’une pastille ou d’un via, sélectionnez Manual Expansion pour le paramètre Shape dans la section Pad Stack du panneau Properties (pour les pastilles) et/ou Manual dans la section Solder Mask Expansion du panneau Properties (pour les vias), puis saisissez la ou les valeurs requises.

La couche de masque de pâte à braser pour les pastilles traversantes est prise en charge dans les documents Draftsman et dans les sorties Gerber, Gerber X2, ODB++, IPC-2581 et d’impression PCB.
Pour les pastilles, vous pouvez également sélectionner manuellement une forme de masque dans un ensemble standard de formes prédéfinies ou créer votre propre forme personnalisée – en savoir plus.

Recouvrement des pastilles et des vias

Le recouvrement partiel ou complet des pastilles et des vias par le masque de soudure peut être obtenu en définissant une valeur appropriée pour l’expansion du masque de soudure. Cette contrainte d’expansion peut être définie individuellement pour chaque objet dans le panneau Properties ou au moyen de règles de conception d’expansion du masque de soudure appropriées. En choisissant une valeur d’expansion adaptée, vous pouvez obtenir les résultats suivants :

  • Pour recouvrir partiellement une pastille ou un via, en couvrant uniquement la zone de cuivre, définissez une expansion négative qui referme le masque jusqu’au bord du trou de la pastille ou du via.
  • Pour recouvrir complètement une pastille ou un via, en couvrant la zone de cuivre et le trou, définissez une expansion négative dont la valeur absolue est supérieure ou égale au rayon de la pastille ou du via.
  • Pour recouvrir toutes les pastilles et tous les vias d’une même couche, définissez la valeur d’expansion appropriée et assurez-vous que la portée (requête complète) d’une règle d’expansion du masque de soudure cible toutes les pastilles et tous les vias de la couche concernée.
  • Pour recouvrir complètement toutes les pastilles et tous les vias d’une conception comportant des vias de tailles différentes, définissez une expansion négative dont la valeur absolue est supérieure ou égale au plus grand rayon de pastille ou de via. Lors du recouvrement d’une pastille ou d’un via individuel, vous pouvez choisir de suivre l’expansion définie dans la règle de conception applicable ou de remplacer cette règle et d’appliquer directement une expansion spécifiée à la pastille ou au via concerné.

Points de test

Related page: Affectation des points de test sur la carte

Le logiciel prend entièrement en charge les points de test et permet de désigner des pastilles (traversantes ou CMS) et des vias comme emplacements de points de test pour les tests de fabrication et/ou d’assemblage. Pour désigner une pastille ou un via comme point de test, définissez les propriétés correspondantes : point de test de fabrication ou d’assemblage, et face de la carte sur laquelle il doit être utilisé. Ces propriétés se trouvent dans la section Testpoint du panneau Propriétés .

Pour simplifier le processus et éviter de définir manuellement les propriétés des points de test, le logiciel propose une méthode d’affectation automatique fondée sur les règles de conception définies, à l’aide du Gestionnaire de points de test (Tools » Testpoint Manager). Dans chaque cas, cette affectation automatique définit les propriétés de point de test correspondantes pour la pastille ou le via.

Particularités des pastilles

Désignateurs des pastilles

Chaque pastille doit être identifiée par un désignateur (représentant généralement le numéro de broche d’un composant) comportant jusqu’à 20 caractères alphanumériques. Les désignateurs des pastilles sont automatiquement incrémentés de un lors du placement si le désignateur de la première pastille se termine par un chiffre. Avant le placement, modifiez le désignateur de la première pastille dans le panneau Propriétés .

Pour obtenir des incréments alphabétiques, par exemple 1A, 1B, ou des incréments numériques autres que 1, utilisez la boîte de dialogue Configuration du collage en réseau accessible en cliquant sur le bouton Paste Array dans la boîte de dialogue Collage spécial (Edit » Paste Special).

Fonction de collage en réseau

En définissant le désignateur de la pastille avant de la copier dans le presse-papiers, vous pouvez utiliser la boîte de dialogue Setup Paste Array pour appliquer automatiquement une séquence de désignation lors du placement des pastilles. Le champ Text Increment de la boîte de dialogue Setup Paste Array permet de placer des pastilles selon les séquences de désignateurs suivantes :

  • Numérique (1, 3, 5)
  • Alphabétique (A, B, C)
  • Alphanumérique (A1 A2, 1A 1B, A1 B1 ou 1A 2A, etc.)

Pour une incrémentation numérique, définissez le champ Text Increment sur la valeur d’incrément souhaitée. Pour une incrémentation alphabétique, définissez le champ Text Increment sur la lettre de l’alphabet correspondant au nombre de lettres à avancer. Par exemple, si la première pastille porte le désignateur 1A, définissez ce champ sur A (première lettre de l’alphabet) pour incrémenter les désignateurs de 1. Si vous définissez ce champ sur C (troisième lettre de l’alphabet), les désignateurs seront 1A, 1D (trois lettres après A), 1G, etc.

Connexions par cavaliers

Les connexions par cavaliers définissent des connexions électriques entre les pastilles de composants qui ne sont pas physiquement routées à l’aide de primitives sur le PCB. Elles sont particulièrement utiles sur les cartes monocouches, où un fil permet de passer au-dessus des pistes de l’unique couche physique.

Les pastilles d'un composant peuvent être identifiées par une Jumper valeur dans le panneau Properties. Les pastilles qui partagent le même cavalier et le même réseau électrique indiquent au système qu'il existe entre elles une connexion valide, bien qu'elles ne soient pas physiquement reliées.

Les connexions par cavalier sont représentées par des lignes de connexion courbes dans l'éditeur PCB. Le vérificateur des règles de conception ne signale pas les connexions par cavalier comme des réseaux non routés.

Spécificités des vias

Définition des propriétés des vias

Bien que les exigences relatives aux couches traversées (plan Z) par chaque type de via soient définies dans l'onglet Via Types du gestionnaire d'empilage des couches, les dimensions du via sont définies :

Configuration de la règle de conception Routing Via Style

Main page: Définition, délimitation du champ d'application et gestion des règles de conception PCB

Les dimensions des vias placés pendant le routage interactif, avec ActiveRouting ou lors du routage automatique sont contrôlées par la règle de conception Routing Via Style applicable. Pour faciliter le ciblage des vias dans la règle de conception, vous pouvez utiliser un ensemble de mots-clés de requête relatifs aux vias dans le champ d'application de la règle (Where the Object Matches) ; ils sont détaillés ci-dessous.

Lorsque vous changez de couche pendant le routage, le logiciel examine les couches de départ et d'arrivée de ce changement et choisit un type de via autorisé dans Layer Stack Manager. Il identifie ensuite la règle de conception Routing Via Style applicable ayant la priorité la plus élevée et applique au via sur le point d'être placé les dimensions définies dans la section Constraints de cette règle.

Par exemple, vous pouvez avoir un ensemble de réseaux DRAM_DATA qui nécessitent des µVias pour la transition de la couche TopLayer à la couche S2 et de la couche S2 à la couche S3, ainsi qu'un via traversant percé pour toutes les autres transitions entre couches (également différent du via requis par les autres réseaux). Vous pouvez gérer cette situation en créant deux règles de conception Routing Via Style ciblant ces réseaux DRAM_DATA. Un exemple de règle de conception adaptée aux µVias est présenté ci-dessous ; survolez l'image avec le curseur pour afficher la règle de conception des vias traversants.

Le champ d'application des règles de conception peut être défini de manière à cibler des types de vias spécifiques.
Le champ d'application des règles de conception peut être défini de manière à cibler des types de vias spécifiques.

Lorsqu'un via est placé dans une zone libre, le logiciel ne peut pas appliquer une règle de conception de style de routage pendant le placement. Dans ce cas, le via par défaut est placé.

Query Keywords

Pour simplifier la définition du champ d'application des règles de conception Routing Via Style, les mots-clés de requête relatifs aux vias suivants sont disponibles :

Via Type Query Returns
IsVia Tous les objets via, quel que soit leur type.
IsThruVia Tous les vias allant de la couche supérieure à la couche inférieure.
IsBlindVia Tous les vias qui commencent sur une couche externe et se terminent sur une couche interne, et qui ne sont pas des µVias.
IsBuriedVia Tous les vias qui commencent sur une couche interne et se terminent sur une autre couche interne, et qui ne sont pas des µVias.
IsMicroVia Tous les vias dont l'option µVia est activée et qui relient des couches adjacentes.
IsSkipVia Tous les vias dont l'option µVia est activée et qui traversent deux couches.

Utilisez la fonction Mask de l'assistant de requête pour trouver les mots-clés disponibles relatifs aux vias. Appuyez sur F1 lorsqu'un mot-clé de requête est sélectionné dans la liste pour obtenir de l'aide à son sujet.

Placement de vias pendant le routage interactif

Lorsque vous changez de couche pendant le routage interactif, le logiciel insère automatiquement un via. Le via choisi dépend des éléments suivants :

  • Le ou les types de vias disponibles pour les couches traversées lors du changement de couche.
  • La règle de conception Routing Via Style applicable au type de via sélectionné pour ce changement de couche.

Pour changer de couche pendant le routage interactif :

  • Appuyez sur la touche * du pavé numérique pour passer à la couche de signal suivante.
  • Utilisez la combinaison Ctrl+Shift+WheelRoll pour passer aux couches supérieures ou inférieures.

Placement de µVias empilés lors d'un changement de couche de L1 à L4. Le mode Interactive Routing du panneau Properties affiche le ou les types de vias qui seront placés ; appuyez sur 6 pour parcourir les empilages de vias possibles ; appuyez sur 8 pour afficher la liste des empilages de vias possibles.

Contrôle du via placé pendant le routage interactif

  • Lorsque vous changez de couche de routage, le logiciel choisit automatiquement le type de via le plus adapté aux couches à traverser.

  • Si plusieurs types de vias ou combinaisons (empilages de vias) peuvent être utilisés, appuyez sur le raccourci clavier 6 pour parcourir de manière interactive tous les empilages de vias disponibles pour ce changement de couche, ou sur le raccourci 8 pour en afficher la liste. Les empilages de vias sont présentés dans l'ordre suivant : µVia(s), µVia sautant une couche, via borgne, via traversant. Des vias empilés peuvent être placés si le changement de couche dépasse une couche et que des types de vias adaptés sont définis. Les types de vias proposés sont détaillés dans la barre d'état et dans l'affichage tête haute, par exemple [µVia 1:2, µVia 2:3, µVia 3:4], comme le montre l'image ci-dessus.

  • Le dernier empilage de vias utilisé est conservé comme empilage par défaut pour le prochain réseau que vous routez. L'empilage de vias par défaut n'est conservé que pour la session d'édition en cours.

  • Les dimensions du via sont définies par la règle de conception Routing Via Style applicable. Les stratégies permettant de définir une règle de conception Routing Via Style adaptée sont présentées ci-dessus.

  • Pour modifier de manière interactive les dimensions du via pendant un changement de couche, appuyez sur le raccourci 4. Vous parcourrez ainsi les modes de dimensions des vias : Rule Minimum ; Rule Preferred ; Rule Maximum ; User Choice ; le mode actuel étant indiqué dans l'affichage tête haute et dans la barre d'état (comme le montre l'image ci-dessus). Si User Choice est sélectionné, appuyez sur Shift+V pour ouvrir la boîte de dialogue Choose Via Sizes et sélectionner les dimensions de via souhaitées. La liste des dimensions de vias disponibles affichée dans cette boîte de dialogue est issue de la liste des vias déjà utilisés dans la conception ; vous pouvez les consulter dans le mode Pad and Via Templates du panneau PCB.

    Si le mode Template preferred est utilisé dans la règle de conception Routing Via Style applicable, le raccourci 4 permet de parcourir les modèles de vias activés.

  • Une vue de profil du ou des types de vias proposés est affichée dans le panneau Properties, comme illustré ci-dessus.

  • Pour placer un via et poursuivre le routage sur la même couche, appuyez sur le raccourci 2.

  • Pour placer un via et suspendre le routage de cette connexion, appuyez sur le raccourci / du pavé numérique.

  • Si le réseau en cours de routage doit être connecté à un plan d'alimentation interne, appuyez sur la touche / du pavé numérique pour placer un via relié au plan d'alimentation approprié. Cette fonction est disponible dans tous les modes de placement de pistes, à l'exception du mode Any Angle .

  • Appuyez sur Shift+F1 pendant le routage pour afficher un menu de tous les raccourcis disponibles dans la commande.

Utilisation des vias empilés

  • Les vias empilés qui forment une connexion continue peuvent être manipulés comme un seul via. click and drag sur l’empilement pour les déplacer tous, avec le routage qui leur est associé.

  • Cliquez une fois pour sélectionner le via situé au sommet de l’empilement. Si vous ne déplacez pas la souris, les clics simples suivants sélectionneront successivement chacun des autres vias de l’empilement.

    Si l’option Display popup selection dialog est activée sur la page PCB Editor – General de la boîte de dialogue Preferences, un clic sur un empilement de vias ouvre une fenêtre de sélection dans laquelle vous pouvez sélectionner le via souhaité.

  • Ctrl+Click and drag pour déplacer uniquement le via sélectionné avec le routage qui lui est associé.

  • Pour sélectionner tous les vias d’un empilement, cliquez une fois pour en sélectionner un, puis appuyez sur Tab pour étendre la sélection à tous les vias de cet empilement.

Configuration de l’affichage des vias

Plusieurs fonctions d’affichage sont disponibles pour faciliter le travail avec les vias.

Couleurs des vias

Les couleurs des vias se configurent dans le panneau View Configuration. La couronne de cuivre du via s’affiche avec la couleur actuellement définie par le paramètre Multi-Layer dans la section Layers . La couleur du trou du via est définie par le paramètre Via Holes dans la section System Colors . Vous pouvez également désactiver l’affichage des trous en basculant le  pour le ou les paramètres souhaités.

La première image montre un via traversant. Le via de la deuxième image est un via borgne ; le trou est affiché dans les couleurs des couches de départ et d’arrivée.
La première image montre un via traversant. Le via de la deuxième image est un via borgne ; le trou est affiché dans les couleurs des couches de départ et d’arrivée.

Vias et masque de soudure

Par défaut, l’éditeur de PCB affiche toujours la couche Multi-Layer au premier plan. Cela peut rendre difficile la visualisation précise du contenu des couches de masque de soudure, en particulier lorsqu’une pastille ou un via utilise une expansion négative du masque, car le contenu de la couche de masque de soudure disparaît alors sous l’objet multicouche. Vous pouvez modifier ce comportement en changeant l’ordre de dessin des couches sur la page PCB Editor – Display de la boîte de dialogue Preferences. Configurez la couche courante pour qu’elle soit dessinée au premier plan.

En modifiant l’ordre de dessin des couches pour afficher la couche courante au premier plan, les ouvertures du masque sont représentées avec précision lorsque vous définissez Top Solder comme couche courante, comme le montre l’image ci-dessous. Les flèches vertes indiquent la taille de l’ouverture du masque de soudure pour un via à gauche, une pastille dont l’ouverture du masque est réduite au centre et une pastille dont l’ouverture est agrandie à droite.

Configurez les paramètres d’affichage pour pouvoir examiner les ouvertures du masque de soudure.
Configurez les paramètres d’affichage pour pouvoir examiner les ouvertures du masque de soudure.

Affichage des vias empilés

En présence de vias empilés, les numéros affichés correspondent aux couches de départ et d’arrivée de tous les vias de l’empilement. Survolez l’image ci-dessous avec le curseur pour afficher les vias en 3D ; à droite de l’image se trouve un empilement de trois vias.

Les couches traversées peuvent être affichées dans les vias. Survolez l’image avec le curseur pour afficher les vias en 3D.Les couches traversées peuvent être affichées dans les vias. Survolez l’image avec le curseur pour afficher les vias en 3D.

Autres paramètres d’affichage des vias

Pour afficher le nom du net du via et les numéros des couches traversées, activez respectivement les options Via Nets et Via Span dans la zone Additional Options de l’onglet View Options du panneau View Configuration.

Exploration des trous de pastilles et de vias

En mode du panneau PCB Hole Size Editor, ses trois zones principales changent pour présenter les éléments suivants (de haut en bas) :

  • Le filtrage général des types de trous et de leur état, avec une sous-section pour les paires de couches de perçage actuellement définies pour la carte.
  • Unique Holes organisés en groupes selon leur taille et leur forme.
  • Les Pads/Vias individuels qui constituent chaque groupe d’objets de trou.

Les sections du panneau affichent le filtrage cumulé appliqué aux types, aux styles et aux états des trous.
Les sections du panneau affichent le filtrage cumulé appliqué aux types, aux styles et aux états des trous.

Les groupes de trous peuvent être modifiés collectivement dans la zone Unique Holes du panneau en saisissant des valeurs dans les cellules des colonnes appropriées. Vous pouvez saisir une valeur numérique dans la colonne Hole Size  pour modifier la taille actuelle des trous des pastilles et des vias.

Modification de la taille des trous pour le groupe sélectionné de six styles de trous identiques.
Modification de la taille des trous pour le groupe sélectionné de six styles de trous identiques.

Vous pouvez également modifier les entrées Hole Length, Hole Type et Plated correspondantes pour les trous, le cas échéant.

Modification du type de trou pour le groupe sélectionné de six styles de trous identiques.
Modification du type de trou pour le groupe sélectionné de six styles de trous identiques.

Les objets pastille/via individuels appartenant au groupe de trous sélectionné sont répertoriés dans la section inférieure Pad/Via du panneau PCB. Cliquez avec le bouton droit sur un objet de la liste, puis sélectionnez Properties (ou double-cliquez directement sur l’entrée) pour ouvrir le mode correspondant du panneau Properties pour cette primitive, afin de consulter et de modifier ses propriétés.

Pour mettre à jour le panneau PCB dans son mode Hole Size Editor avec les données actuelles des symboles de perçage du PCB, cliquez avec le bouton droit dans une zone du panneau dans ce mode, puis sélectionnez la commande Refresh.

Les données des symboles de perçage sont mises à jour automatiquement lors de l’enregistrement du document PCB et pour toutes les sorties contenant ces données.

Pour améliorer les performances, les données des symboles de perçage ne sont pas mises à jour automatiquement dans le panneau PCB. La mise à jour manuelle de ces données est possible lorsque l’option PCB.LiveDrillSymbols est désactivée dans la boîte de dialogue Advanced Settings.

Prise en charge du rétroperçage

Le mode Hole Size Editor du panneau PCB peut également servir à examiner les pastilles et les vias destinés au rétroperçage. Les paires de couches de rétroperçage sont affichées dans la liste Layer Pairs et identifiées par l’ajout du texte [BD].

Lorsqu’une taille de trou de rétroperçage est sélectionnée, le Kind des objets s’affiche sous la forme Backdrill. Utilisez cette fonction pour localiser et examiner rapidement les trous rétropercés. Notez que les paramètres de rétroperçage ne peuvent pas être modifiés dans le panneau.

Rapport de rétroperçage

Pour générer un rapport de toutes les opérations de rétroperçage, cliquez avec le bouton droit dans la liste Unique Holes, puis sélectionnez Backdrill Report dans le menu contextuel.

Le rapport détaille chaque opération de rétroperçage, notamment son emplacement, le diamètre de perçage et la profondeur de perçage.

Pour en savoir plus sur le rétroperçage, consultez Perçage à profondeur contrôlée, ou rétroperçage.

Prise en charge des lamages et fraisures

Le mode Hole Size Editor du panneau PCB peut également servir à examiner les pastilles pour lesquelles des fonctions de lamage ou de fraisure sont activées. Lorsque la conception du PCB comporte des objets pastille avec des fonctions de lamage ou de fraisure activées sur une face ou sur les deux faces, les groupes Counterholes Top et/ou Counterholes Bottom correspondants sont affichés dans la liste Layer Pairs. Les colonnes Counterhole Depth et Counterhole Angle peuvent être affichées dans le Unique Holes zone du panneau. Notez que les paramètres des contre-perçages ne peuvent pas être modifiés dans le panneau.

Les informations sur les contre-perçages de la conception sont affichées dans le mode Hole Size Editor du panneau PCB.
Les informations sur les contre-perçages de la conception sont affichées dans le mode Hole Size Editor du panneau PCB.

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Nav
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents