Annotation des composants dans une conception
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
En un coup d'œil
- Découvrez le rôle de l’annotation des conceptions et l’importance des repères uniques des composants dans les schémas, le routage des PCB et les documents de sortie tels que la nomenclature.
- Comprenez les différences entre l’annotation au niveau du schéma, du PCB et de la carte, ainsi que les types de conceptions auxquels chaque méthode convient le mieux.
- Obtenez un aperçu de la boîte de dialogue Annotate et des principaux paramètres permettant de contrôler le périmètre de l’annotation, l’ordre de traitement, les options de correspondance et les modifications proposées.
L’annotation d’une conception est un processus systématique et méthodique visant à garantir que chaque composant de la conception puisse être identifié individuellement au moyen d’un repère unique. Bien qu’Altium Designer puisse conserver l’identité des composants à l’aide d’identifiants uniques globaux (GUID), la plupart des concepteurs utilisent traditionnellement le repère du composant comme principal moyen de le référencer dans le schéma (domaine logique) et sur le PCB (domaine physique), ainsi que dans les documents de sortie tels que la nomenclature (BOM).
Il existe trois approches pour annoter une conception. Le choix de l’outil d’annotation dépend de plusieurs facteurs, notamment du type de conception, des préférences personnelles, ainsi que de la politique et des procédures de l’entreprise.
Schematic Level Annotation
L’annotation au niveau du schéma utilise une vue purement logique de la conception pour déterminer les repères des composants. Elle est particulièrement utile pour les conceptions simples qui n’utilisent pas de feuilles de dispositifs. Toutefois, comme elle permet de spécifier l’ordre de traitement et de compléter les boîtiers existants pour les composants à plusieurs parties, elle constitue également une étape préalable à l’annotation au niveau de la carte.
En résumé, utilisez l’annotation au niveau du schéma pour :
- Regrouper les parties des composants à plusieurs parties dans des boîtiers.
- Annoter les composants en fonction de leur position dans le schéma.
- Annoter les conceptions multicanaux à l’aide du modèle de dénomination par défaut défini dans les options du projet.
- Préparer une conception à une annotation complémentaire.
PCB Annotation
L’annotation du PCB utilise l’emplacement physique des composants sur le PCB pour déterminer leurs repères. Elle permet ainsi d’intégrer efficacement les informations de position dans le repère d’un composant et peut s’avérer très utile lors du débogage d’un PCB assemblé. En bref, utilisez l’annotation du PCB pour annoter les composants en fonction de leur position sur la carte dans la conception du PCB.
Board Level Annotation
L’annotation au niveau de la carte établit une correspondance entre les repères utilisés dans le schéma (conception logique) et leurs équivalents réels sur le PCB (conception physique). Bien qu’elle puisse être utilisée dans toute conception, elle est particulièrement utile pour les conceptions multicanaux ou celles qui intègrent des feuilles de dispositifs dont les repères ne peuvent pas être modifiés directement sur la feuille. Ainsi, l’ensemble de la conception peut être réannoté sans modifier les feuilles de dispositifs d’origine. L’annotation au niveau de la carte résout les conflits d’annotation susceptibles de survenir en raison de repères en double dans un projet et enregistre ses modifications dans un fichier texte *.Annotation. Elle comprend des mots-clés supplémentaires pour personnaliser les modèles de dénomination et permet de les appliquer à tous les éléments ou uniquement à une sélection d’entre eux.
En résumé, utilisez l’annotation au niveau de la carte pour :
- Annoter les composants compilés dans les feuilles de dispositifs.
- Attribuer un nom unique à chaque composant sur plusieurs canaux à l’aide de modèles de dénomination comprenant l’annotation positionnelle, l’indexation globale et d’autres options configurables.
- Nommer manuellement les composants.
Annotation du schéma
L’annotation du schéma se configure dans la boîte de dialogue Annotate . Cette boîte de dialogue fournit des commandes permettant d’attribuer systématiquement des repères à tous les éléments, ou à une sélection d’entre eux, dans les feuilles sélectionnées d’un projet. Elle garantit que les repères sont uniques et ordonnés en fonction de leur position. Les options d’annotation permettent de regrouper les parties des composants dans des boîtiers, de définir les options d’index et de suffixe, de réinitialiser les repères du schéma, y compris les doublons, et d’effectuer une rétroannotation depuis le PCB.
La boîte de dialogue Annotate est accessible en exécutant la commande Annoter les schémas (Tools » Annotation » Annotate Schematics).

La boîte de dialogue Annotate s’ouvre à partir de la commande Annotate Schematics.
Elle est divisée en deux zones principales :
- Schematic Annotation Configuration - cette zone permet de configurer le modèle d’annotation ainsi que la portée de l’annotation.
- Proposed Change List - cette zone répertorie les modifications proposées qui seront appliquées une fois acceptées et exécutées au moyen d’un ordre de modification technique (ECO).
Options et commandes de la boîte de dialogue d’annotation
Configuration de l’annotation du schéma
Ordre de traitement
Utilisez cette zone pour spécifier la méthode d’annotation positionnelle souhaitée. Lorsque vous sélectionnez une méthode dans la liste déroulante, la représentation graphique associée se met à jour dynamiquement pour illustrer la manière dont les composants seront annotés. Choisissez parmi les méthodes d’annotation positionnelle suivantes :
- Up Then Across
- Down Then Across
- Across Then Up
- Across Then Down
Référence de position pour le traitement
Utilisez cette zone pour spécifier la référence de position des composants utilisée lors du traitement de l’ordre d’annotation. Choisissez parmi les options suivantes :
- Designator - le repère du composant sert de référence pour sa position lors de la détermination de l’ordre de traitement.
- Part - le centre du composant sert de référence pour sa position lors de la détermination de l’ordre de traitement.
Remplacer les sous-parties
Utilisez la liste déroulante pour choisir de remplacer ou non les sous-parties lors du processus d’annotation.
Options de correspondance
Lors de l’utilisation de boîtiers à plusieurs parties, il est souvent souhaitable de regrouper un maximum de parties dans un minimum de composants physiques, afin de réduire le coût global de la nomenclature de la conception. Les commandes de cette zone permettent de définir la manière dont les composants seront associés et regroupés, ainsi que les critères permettant de déterminer les regroupements valides.
-
Complete Existing Packages - utilisez cette commande pour déterminer si les parties non annotées doivent être intégrées aux boîtiers existants et de quelle manière. Utilisez la liste déroulante pour choisir parmi les options suivantes :
- None - les boîtiers existants ne seront pas complétés et toutes les nouvelles parties seront placées dans de nouveaux boîtiers.
- Per Sheet - les boîtiers existants n’intégreront que les nouvelles parties provenant de la même feuille de schéma.
- Whole Project - les boîtiers existants intégreront les nouvelles parties provenant de n’importe quelle feuille de schéma du projet.
- Component Parameter - cette liste comprend tous les paramètres présents dans les composants de la conception actuelle. Cochez la case associée à un paramètre pour l’utiliser comme critère de regroupement des parties dans les boîtiers. Si des composants à plusieurs parties possèdent les mêmes paramètres activés avec des valeurs identiques, ils seront regroupés dans un même boîtier (à condition que l’option Complete Existing Packages ne soit pas réglée sur None). Les composants restants qui ne possèdent pas les paramètres activés sont également regroupés.
- Strictly - activez cette option pour un Component Parameter de la liste afin d’indiquer que tous les composants must possèdent ce paramètre pour être regroupés dans un boîtier. Les composants qui ne possèdent pas ce paramètre sont annotés en tant que composants individuels et ne sont pas regroupés dans un boîtier.
Menu contextuel
- Parameter » Enable Selected Parameters - permet de cocher la case « Inclure » pour tous les paramètres actuellement sélectionnés dans la liste.
- Parameter » Enable All Parameters - permet de cocher la case « Inclure » pour tous les paramètres de la liste.
- Parameter » Disable Selected Parameters - permet de décocher la case « Inclure » pour tous les paramètres actuellement sélectionnés dans la liste.
- Parameter » Disable All Parameters - permet de décocher la case « Inclure » pour tous les paramètres de la liste.
- Match Strictly » Enable Strict Matching On Selected Parameters - permet d’activer l’option Strictly pour tous les paramètres actuellement sélectionnés dans la liste.
- Match Strictly » Enable Strict Matching On All Parameters - permet d’activer l’option Strictly pour tous les paramètres de la liste.
- Match Strictly » Disable Strict Matching On Selected Parameters - permet de désactiver l’option Strictly pour tous les paramètres actuellement sélectionnés dans la liste.
- Match Strictly » Disable Strict Matching On All Parameters - permet de désactiver l’option Strictly pour tous les paramètres de la liste.
- Selection » Select All - permet de sélectionner toutes les entrées de paramètres de la liste.
- Selection » Deselect All - permet de désélectionner toutes les entrées de paramètres de la liste.
- Selection » Invert Selection - permet de sélectionner tous les paramètres qui ne sont pas actuellement sélectionnés dans la liste et de désélectionner ceux qui le sont.
Feuilles de schéma à annoter
Cette zone de la boîte de dialogue répertorie toutes les feuilles de schéma sources du projet de conception. Les commandes disponibles dans cette zone permettent de déterminer les feuilles à inclure dans le processus d’annotation ainsi que les modalités de calcul des modifications d’annotation. Pour chaque feuille, les éléments suivants sont présentés :
- Include/Exclude checkbox - cochez cette case pour inclure la feuille de schéma dans le processus d’annotation.
- Schematic Sheet - ce champ affiche le nom de la feuille de schéma.
-
Annotation Scope - utilisez ce champ pour définir la portée de l’annotation pour les composants de la feuille. Utilisez la liste déroulante pour choisir l’une des portées suivantes :
- All - toutes les unités de la feuille de schéma seront annotées.
- Ignore Selected Parts - toutes les unités, à l’exception de celles actuellement sélectionnées dans la conception, seront annotées.
- Only Selected Parts - seules les unités actuellement sélectionnées dans la conception seront annotées.
- Order - utilisez ce champ pour définir la position de cette feuille dans l’ordre global d’annotation des feuilles. Saisissez directement le numéro d’ordre souhaité dans le champ ou utilisez les flèches qui apparaissent lorsque vous cliquez dans le champ pour choisir la valeur souhaitée.
- Designator Index Control - utilisez les commandes de cette colonne pour activer l’utilisation d’un indice de départ (en cochant la case correspondante) et définir sa valeur. La numérotation des repères commencera à cette valeur d’indice.
- Add Suffix - utilisez ce champ pour définir un suffixe à ajouter à chaque repère annoté. Les suffixes alphabétiques (A, B, C...), numériques (1, 2, 3...) et non alphanumériques (_ * . %...) sont pris en charge, ainsi que toute combinaison de ces caractères.
Additional Controls
- All On - cliquez pour inclure toutes les feuilles de schéma dans le processus d’annotation.
- All Off - cliquez pour exclure toutes les feuilles de schéma du processus d’annotation.
-
Right-Click Menu - les commandes suivantes sont disponibles dans le menu contextuel de cette zone :
-
Order Alphabetically - permet de trier la liste des schémas par ordre alphabétique. Cela modifie l’entrée Order associée à chaque feuille.
-
Order By Project Order - permet de trier la liste des schémas selon leur ordre d’apparition dans le projet (tel qu’il apparaît dans le panneau Projects ). Cela modifie l’entrée Order associée à chaque feuille.
-
All On - permet d’inclure toutes les feuilles de schéma dans le processus d’annotation.
-
All Off - permet d’exclure toutes les feuilles de schéma du processus d’annotation.
-
Liste des modifications proposées
-
Main List - cette zone de la boîte de dialogue répertorie tous les repères des unités contenues dans les feuilles sélectionnées pour l’annotation. Pour chaque entrée, les valeurs Current et Proposed Designator sont indiquées, ainsi que le Sub (unité) du composant et le Location of Part source. Les icônes de cadenas signalent les colonnes verrouillées pour empêcher toute modification des repères et des sous-unités.
Cocher la case située à côté d’un repère dans la colonne Current (« repère verrouillé ») empêche toute modification de ce repère. De même, cocher la case située à côté du champ Sub d’un repère (« sous-unité verrouillée ») empêche la mise à jour de cette sous-unité du composant parent à plusieurs unités.
Les commandes suivantes sont disponibles dans le menu contextuel de cette zone :
- Designator » Lock Selected Designators - permet de cocher la case « repère verrouillé » pour tous les repères actuellement sélectionnés dans la liste.
- Designator » Lock All Designators - permet de cocher la case « repère verrouillé » pour tous les repères.
- Designator » Unlock Selected Designators - permet de décocher la case « repère verrouillé » pour tous les repères actuellement sélectionnés dans la liste.
- Designator » Unlock All Designators - permet de décocher la case « repère verrouillé » pour tous les repères.
- Part ID » Lock Selected Part ID - permet de cocher la case « sous-unité verrouillée » pour tous les repères actuellement sélectionnés dans la liste.
- Part ID » Lock All Part ID - permet de cocher la case « sous-unité verrouillée » pour tous les repères.
- Part ID » Unlock Selected Part ID - permet de décocher la case « sous-unité verrouillée » pour tous les repères actuellement sélectionnés dans la liste.
- Part ID » Unlock All Part ID - permet de décocher la case « sous-unité verrouillée » pour tous les repères.
- Selection » Select All - permet de sélectionner toutes les entrées de repères de la liste.
- Selection » Select All With '?' - permet de sélectionner toutes les entrées dont le repère actuel contient un « ? » (c’est-à-dire qui ont été réinitialisées).
- Selection » Deselect All - permet de désélectionner toutes les entrées de repères de la liste.
- Selection » Invert Selection - permet de sélectionner tous les repères qui ne sont pas actuellement sélectionnés dans la liste et de désélectionner ceux qui le sont.
- Annotation Summary - cette zone fournit un récapitulatif de l’annotation indiquant le nombre de feuilles concernées et les options de correspondance. Elle se met à jour dynamiquement lorsque ces éléments sont modifiés.
- Update Changes List - cliquez pour actualiser la liste principale des modifications proposées avec les nouvelles modifications calculées en fonction des paramètres d’annotation définis dans la partie gauche de la boîte de dialogue. Une boîte de dialogue d’information indiquera le nombre de modifications effectuées depuis l’état précédent et depuis l’état initial.
- Reset All - cliquez pour réinitialiser tous les repères de la liste principale (qui ne sont pas verrouillés) à leurs préfixes de composant par défaut, par exemple R?, C?, D?. Les modifications seront chargées dans la colonne des repères Proposed . Le menu déroulant du bouton permet de remplacer la commande par Reset Duplicates. Si plusieurs composants ont le même repère, tous sauf un seront réinitialisés à leurs préfixes par défaut. Là encore, une boîte de dialogue d’information indiquera le nombre de modifications effectuées depuis l’état précédent et depuis l’état initial.
- Back Annotate - cliquez pour ouvrir une boîte de dialogue permettant de rechercher et de sélectionner le fichier de rétroannotation.
- Accept Changes (Create ECO) - après avoir examiné toutes les modifications proposées, cliquez sur ce bouton pour accéder à la boîte de dialogue Engineering Change Order, qui répertorie les modifications proposées dans la catégorie de modification Annoter un composant. Utilisez cette boîte de dialogue pour valider et exécuter l’ECO, afin de terminer le processus d’annotation au niveau du schéma.
Verrouiller les composants
Pour les composants à plusieurs unités non homogènes, assurez-vous que les icônes de verrouillage sont fermées dans le panneau Properties afin d’empêcher toute modification des sous-unités pendant l’annotation.
Option Strictly
Si la case Strictly est cochée pour un Component Parameter, tous les composants doivent avoir une valeur correspondante pour ce paramètre afin d’être regroupés dans un boîtier. Les composants qui ne possèdent pas ce paramètre sont annotés comme des composants individuels et ne sont pas regroupés.
L’exemple suivant illustre comment ces options se combinent pour produire un résultat précis :
Considérons une conception comportant huit portes OU et huit résistances (comme le montre l’image ci-dessous). Les portes OU contiennent un paramètre appelé QuadOrGate : un groupe de quatre portes OU possède la valeur Package1 pour ce paramètre, et l’autre groupe de quatre portes OU possède la valeur Package2. Les résistances ne possèdent pas ce paramètre. Cocher la case de QuadOrGate dans la commande Component Parameter permet d’utiliser ce paramètre pour déterminer la manière dont les composants sont regroupés dans des boîtiers ; dans ce cas, la case Strictly n’est pas cochée.
Après le lancement de la commande Tools » Annotation » Annotate Schematics, les unités ayant le paramètre QuadOrGate = Package1 seront regroupées dans le même composant physique, tandis que celles ayant le paramètre QuadOrGate = Package2 seront regroupées séparément. Tous les composants restants qui ne possèdent pas le paramètre QuadOrGate seront regroupés ensemble. Dans ce cas, les résistances sont regroupées ensemble, car leur caractéristique commune est de ne pas posséder le paramètre QuadOrGate.

Exemple de composants regroupés lorsque l’option Strictly est décochée.
Si la même conception est annotée avec l’option Strictly cochée, seuls les composants possédant le paramètre QuadOrGate seront regroupés. Dans ce cas, les portes OU seront regroupées, mais les résistances resteront séparées. Par conséquent, bien que l’option Strictly offre un contrôle extrêmement précis du processus de regroupement, il conviendra de la laisser décochée dans la plupart des situations.

Exemple de composants regroupés lorsque l’option Strictly est cochée.
Feuilles de schéma à annoter
Vous disposez d’un contrôle précis sur les feuilles de schéma et les composants concernés par l’annotation, ainsi que sur les modalités de calcul de ces modifications.

Définition de la portée de l’annotation.
- Une case cochée à gauche d’une feuille de schéma répertoriée indique que celle-ci sera traitée par la commande d’annotation.
- La portée de l’annotation est déterminée par la liste déroulante Annotation Scope et peut être étendue à l’ensemble de la feuille de schéma ou limitée aux composants sélectionnés ou non sélectionnés. L’utilisation des options Ignore Selected Parts ou Only Selected Parts nécessite que les composants aient été sélectionnés dans la conception avant l’exécution de la commande d’annotation.
- Configurez l’ordre d’annotation des feuilles de schéma à l’aide du champ Order. Saisissez une valeur directement dans le champ ou utilisez les flèches qui apparaissent lorsque vous cliquez dans le champ pour définir la valeur souhaitée.
- Si l’option Designator Index Control est cochée, la numérotation des repères commencera à la valeur Start Index. Le paramètre Start Index n’a aucun effet si l’option Designator Index Control n’est pas cochée.
- Un suffixe supplémentaire peut être ajouté à la fin de chaque repère en spécifiant une chaîne ou une valeur dans la colonne Suffix associée. Évitez les suffixes à un seul caractère, tels que « A » ou « 1 », car ils peuvent facilement être confondus avec des sous-unités et/ou d’autres valeurs de repère.
Liste des modifications proposées
Cliquez sur le bouton Update Changes List pour actualiser Proposed Change List, afin de pouvoir examiner toutes les modifications de repères avant de les appliquer. Seuls les repères qui n’ont pas encore été attribués (c.-à-d. R?, C?, etc.) seront affectés par les modifications. Par conséquent, pour mettre à jour tous les repères de la conception, il faut d’abord les réinitialiser en appuyant sur le bouton Reset All.

Réinitialisation des repères avant l’application des paramètres d’annotation.
La liste Proposed Change List répertorie tous les repères des unités contenues dans les feuilles sélectionnées pour l’annotation. Pour chaque entrée, les valeurs des repères Current et Proposed sont indiquées, ainsi que le Sub (unité) du composant et le Location of Part source.
Cocher la case associée à un Designator verrouille ce repère afin d’empêcher toute modification. De même, cocher la case Sub empêche la mise à jour du composant à plusieurs unités concerné. Cette option peut être utilisée au lieu d’activer l’icône Lock dans le panneau Properties .
Après avoir examiné la liste des modifications proposées, cliquez sur le bouton Accept Changes (Create ECO) pour ouvrir la boîte de dialogue Engineering Change Order. Une fois l’ECO exécuté, les modifications d’annotation seront appliquées à la conception.
Commandes supplémentaires d’annotation du schéma
Le menu Outils » Annotation contient plusieurs commandes ciblées d’annotation du schéma. La première commande du groupe, Annotate Schematic, a déjà été présentée.

Différentes commandes d’annotation disponibles
Réinitialiser les repères du schéma
Si de grandes portions de contenu ont été coupées et collées depuis différentes sources dans une nouvelle conception, il peut être nécessaire de réinitialiser tous les désignateurs. Comme cette commande utilise les paramètres de la boîte de dialogue Annoter , elle s’applique aux éléments précédemment sélectionnés dans cette boîte de dialogue. Par exemple, si tous les Schematic Sheets To Annotate ont été cochés précédemment, la commande Reset Schematic Designators s’appliquera à l’ensemble du projet, que les feuilles soient actuellement ouvertes dans l’éditeur ou non. Si seuls quelques Schematic Sheets To Annotate ont été cochés précédemment, la commande Reset Schematic Designators n’affectera que ces feuilles.
Après le lancement de la commande, une boîte de dialogue de confirmation s’affiche pour récapituler le nombre de désignateurs à mettre à jour et vous demander si vous souhaitez effectuer les modifications. Après avoir cliqué sur Yes, tous les désignateurs de composants de toutes les feuilles de schéma du projet actif pour lesquelles l’annotation est activée seront réinitialisés et apparaîtront sous la forme suivante : R?, C?, D?, U?, etc.
Les désignateurs verrouillés ne sont ni réinitialisés ni modifiés de quelque manière que ce soit.
Réinitialiser les désignateurs de schéma en double
Lorsque vous dupliquez des portions d’une conception, les composants nouvellement copiés conservent les mêmes valeurs de désignateur que les composants d’origine. La commande Reset Duplicate Schematic Designators permet de réinitialiser rapidement les désignateurs en double à « ? ». Comme cette commande utilise les paramètres de la boîte de dialogue Annotate , elle s’applique aux éléments précédemment sélectionnés dans cette boîte de dialogue. Par exemple, si tous les Schematic Sheets To Annotate ont été cochés précédemment, la commande Reset Duplicate Schematic Designators s’appliquera à l’ensemble du projet, que les feuilles soient actuellement ouvertes dans l’éditeur ou non. Si seuls quelques Schematic Sheets to Annotate ont été cochés précédemment, la commande Reset Schematic Designators n’affectera que ces feuilles.
Après le lancement de la commande, une boîte de dialogue de confirmation s’affiche pour récapituler le nombre de désignateurs à mettre à jour et vous demander si vous souhaitez effectuer les modifications. Après avoir cliqué sur Yes, tous les désignateurs de composants en double trouvés dans toutes les feuilles de schéma du projet actif pour lesquelles l’annotation est activée seront réinitialisés et apparaîtront sous la forme suivante : R?, C?, D?, U?, etc.
Les désignateurs verrouillés ne sont ni réinitialisés ni modifiés de quelque manière que ce soit.
Annoter les schémas en mode silencieux
La commande Annotate Schematics Quietly permet d’examiner tous les documents schématiques sources du projet actif pour lesquels l’annotation est activée et d’attribuer un désignateur unique à tout composant qui n’en possède pas encore. L’annotation est effectuée en mode silencieux, ce qui permet d’appliquer tous les paramètres précédemment définis dans la boîte de dialogue Annotate sans avoir à la rouvrir. Cela s’avère particulièrement utile lorsque la conception traverse une phase de développement rapide et que le concepteur souhaite effectuer rapidement l’annotation avant de compiler la conception.
Forcer l’annotation de tous les schémas
Cette commande permet d’examiner tous les documents schématiques sources du projet actif pour lesquels l’annotation est activée et de réannoter tous les composants qu’ils contiennent conformément au schéma d’annotation actuellement défini dans la boîte de dialogue Annotate.
L’exécution de la commande Force Annotate All Schematics équivaut à exécuter la commande Reset Schematic Designators, immédiatement suivie de la commande Annotate Schematics Quietly. Par conséquent, la commande Force Annotate All Schematics utilise les paramètres précédemment définis dans la boîte de dialogue Annotate pour déterminer les composants et les feuilles pouvant être mis à jour.
Après le lancement de cette commande, une demande de confirmation s’affiche et indique le nombre de désignateurs qui seront mis à jour si vous acceptez. Après avoir cliqué sur Yes, tous les désignateurs de composants de toutes les feuilles de schéma du projet actif pour lesquelles l’annotation est activée seront réannotés, si nécessaire, afin de respecter le schéma d’annotation positionnelle actuellement défini dans la zone Schematic Annotation Configuration de la boîte de dialogue Annotate .
Rétro-annoter les schémas
Avant l’introduction de Design Compiler et de Synchronizer dans Altium Designer, les modifications d’annotation étaient transmises du schéma au PCB au moyen d’un fichier de netlist (*.net). Les modifications d’annotation devant être propagées dans le sens inverse, du PCB vers le schéma, étaient gérées par un processus de rétro-annotation. Ce processus utilise un fichier Was-Is (*.WAS) ou un fichier d’ordre de modification technique (ECO, *.ECO) pour définir les modifications à appliquer aux désignateurs du schéma.
Après le lancement de la commande, la boîte de dialogue Choose WAS-IS File for Back-Annotation from PCB s’affiche. Recherchez et sélectionnez le fichier .was (ou .eco) requis. Après avoir cliqué sur Open, une boîte de dialogue d’information s’affiche pour indiquer le nombre de modifications apportées aux désignateurs depuis l’état précédent et depuis l’état d’origine. À ce stade, les modifications ne sont pas encore appliquées. Cliquez sur OK pour ouvrir la boîte de dialogue Annotate, dans laquelle vous pouvez examiner les modifications proposées pour les désignateurs actuels avant de décider de créer un ECO pour les appliquer.
Numéroter les feuilles de schéma
La commande Number Schematic Sheets ne modifie pas les désignateurs de composants, mais ceux des feuilles de schéma (numéros). Sur le plan conceptuel, elle est donc liée à la notion générale d’annotation de conception.
La numérotation des feuilles et des documents vous permet de maîtriser la désignation des feuilles et de stocker ces désignations sous forme de paramètres dans les documents schématiques correspondants. La fonctionnalité de chaînes spéciales d’Altium Designer (=SheetNumber, =DocumentNumber, =SheetTotal) peut ensuite être utilisée pour afficher ces valeurs sur la feuille (dans le pied de page, par exemple) sous forme d’objets texte.

Numérotation des feuilles de schéma.
La procédure de numérotation des feuilles est la suivante :
Numérotation automatique des feuilles (option du projet)
Activez cette option pour numéroter automatiquement les feuilles. Les valeurs seront affichées dans le panneau Projects. Vous pouvez également activer la numérotation automatique des feuilles en cochant l’option Automatic Sheet Numbering dans l’onglet Options de la boîte de dialogue Project Options.
Numérotation automatique des feuilles
Cliquez sur le bouton déroulant Auto Sheet Number pour accéder aux options de numérotation des feuilles.
Les options Select Numbering Scheme sont les suivantes :
- Display Order - les feuilles sont numérotées dans leur ordre d’affichage.
- Sheets Hierarchical Structure - Depth First - les feuilles sont numérotées à partir du niveau supérieur, puis dans chaque branche. Le niveau supérieur est numéroté en premier, puis la première branche située sous ce niveau est numérotée intégralement, suivie de la deuxième branche, et ainsi de suite.
- Sheets Hierarchical Structure - Breadth First - les feuilles sont numérotées selon leur niveau dans la hiérarchie. Le niveau supérieur est numéroté en premier, puis toutes les feuilles du deuxième niveau, et ainsi de suite.
Les options Select Numbering Method permettent de sélectionner des valeurs séquentielles Increasing ou Decreasing .
Numérotation automatique des documents
Cliquez sur la liste déroulante Auto Document Number pour accéder aux options de numérotation des documents. Elles sont essentiellement identiques aux options Auto Sheet Number, avec toutefois l’ajout des valeurs Prefix et Postfix .
Les options Parameters sont les suivantes :
-
Prefix - choisissez un préfixe à placer devant le numéro du document. Les préfixes alphabétiques (
A,B,C, etc.), numériques (1,2,3, etc.) et non numériques (_,*,.,%, etc.) sont pris en charge, ainsi que toutes leurs combinaisons. - Start - choisissez une valeur numérique à partir de laquelle commencer la numérotation.
-
Postfix - choisissez un suffixe à ajouter au numéro du document. Les suffixes alphabétiques (
A,B,C, etc.), numériques (1,2,3, etc.) et non numériques (_,*,.,%, etc.) sont pris en charge, ainsi que toutes leurs combinaisons. - Step - choisissez la valeur d’incrémentation de chaque numéro de document. Par exemple, si l’indice Start est défini sur 1 et que la valeur Step est définie sur 100, le premier numéro de document sera 1, le suivant sera 101 (valeur de départ + pas), puis 201, et ainsi de suite.
Mettre à jour le nombre de feuilles
Cliquez sur le bouton Update Sheet Count pour calculer le nombre de feuilles du projet actuel et placer le résultat dans la colonne SheetTotal. Le nombre de feuilles correspond au nombre total de feuilles du projet, quel que soit le mode de numérotation sélectionné dans l’une ou l’autre des commandes précédentes.
Monter/Descendre
Utilisez les boutons Move Up ou Move Down pour déplacer le document schématique sélectionné vers le haut ou vers le bas dans la liste. Cela s’applique lorsque vous utilisez le mode de numérotation Display Order pour définir les numéros de feuille ou de document.
Numérotation/Nommage personnalisés
Si une organisation utilise un système de numérotation ou de nommage spécifique qui ne peut pas être automatisé à l’aide des commandes Auto Sheet Number ou Auto Document Number, les noms et numéros de feuilles personnalisés peuvent être saisis directement dans les champs SheetNumber ou DocumentNumber .
Numérotation des feuilles schématiques et feuilles de dispositifs
Les numéros de feuille ou de document ne peuvent pas être configurés pour les feuilles de dispositifs lorsqu’elles sont en lecture seule (état par défaut). Ces feuilles sont hachurées dans la boîte de dialogue Numérotation des feuilles du projet pour indiquer qu’elles ne peuvent pas être mises à jour. Lorsque les feuilles de dispositifs sont définies comme modifiables, les hachures disparaissent et la numérotation des feuilles et des documents peut être configurée normalement.
Contrôle de l’affichage des repères sur le PCB
Les chaînes de repères étendus d’une conception multicanal peuvent être fastidieuses à placer dans l’éditeur PCB. Vous pouvez soit choisir des options de nommage qui produisent un nom court, soit afficher à la place le repère logique d’origine du composant. Par exemple, C30_CIN1 s’afficherait sous la forme C30. Cela nécessiterait l’ajout d’une autre indication sur la carte pour distinguer les différents canaux, par exemple un cadre tracé autour de chaque canal sur la couche de sérigraphie des composants.
Vous pouvez choisir d’afficher les repères logiques ou physiques sur le PCB à l’aide de la liste déroulante Designator Display dans la zone Other du panneau Properties en mode Board . Si vous choisissez d’afficher les repères logiques des composants d’une conception multicanal, ceux-ci seront affichés sur le PCB et dans toutes les sorties générées, telles que les impressions et les fichiers Gerber. Les repères physiques uniques sont toutefois toujours utilisés lors de la génération d’une nomenclature.
Synchronisation de la conception - Finalisation du processus d’annotation
La synchronisation directe de la conception est la méthode recommandée pour maintenir la correspondance entre les repères du schéma et ceux du PCB, sauf si vous n’avez pas accès à la fois à l’éditeur de schémas et à l’éditeur PCB. La synchronisation de la conception compare directement les composants et la connectivité du schéma à ceux du PCB et produit une liste des différences. Une liste des modifications nécessaires pour résoudre ces différences est générée sous la forme d’un ECO (Engineering Change Order, ordre de modification technique). Un fichier ECO décrit les différences entre la conception actuelle et la conception souhaitée et peut être exécuté pour mettre à jour la cible et synchroniser la conception.
Synchronisation directe et synchronisation inverse
Les termes « synchronisation directe » et « synchronisation inverse » désignent le sens dans lequel les annotations et les modifications de conception sont transférées lors de la synchronisation des données. Dans un flux de conception qui commence par le schéma et qui est piloté par celui-ci, la synchronisation directe consiste à répercuter sur le PCB les modifications apportées dans l’éditeur de schémas. La synchronisation inverse consiste à répercuter dans l’éditeur de schémas les modifications apportées au PCB.
Synchronisation directe
Voici quelques raisons de synchroniser les données du schéma vers le PCB :
- Un nouveau composant a été ajouté dans l’éditeur de schémas et doit figurer dans le routage du PCB.
- Vous avez annoté votre schéma pour la première fois ou depuis la dernière synchronisation de la conception.
- Dans une conception multicanal, vous avez modifié Project Options pour changer le style de nommage physique (PCB).
- Vous avez effectué une annotation au niveau de la carte pour la première fois ou depuis la dernière synchronisation de la conception.
Pour synchroniser votre schéma vers le PCB
Choisissez l’une des méthodes suivantes pour synchroniser votre schéma vers votre PCB :
- Sélectionnez Update PCB Document dans le menu Design de l’éditeur de schémas. S’il existe des différences entre les documents schématiques et le document PCB cible, la boîte de dialogue Engineering Change Order s’ouvre et affiche la liste des modifications nécessaires pour synchroniser le PCB avec le schéma. Cliquez sur Execute Changes pour synchroniser votre conception.
- Sélectionnez Import Changes dans le menu Design de l’éditeur PCB afin d’importer les modifications des documents schématiques dans le document PCB.
Synchronisation inverse
La synchronisation inverse s’effectue lorsque vous avez annoté ou modifié votre PCB et que vous souhaitez mettre à jour le schéma.
Pour synchroniser votre PCB vers le schéma
Choisissez l’une des méthodes suivantes pour synchroniser votre PCB vers votre schéma :
-
Dans l’éditeur PCB, sélectionnez Update Schematics dans le menu Design . Par défaut, l’option Push Component Designator Changes to Annotation File (if any) de l’onglet Génération ECO de la boîte de dialogue Project Options est cochée : les modifications apportées dans l’éditeur PCB sont donc transmises uniquement au fichier d’annotation, puis aux documents compilés lors de la compilation. Décochez cette option pour transmettre les modifications uniquement au document schématique source (vue Editor ).
- Depuis l’éditeur de schémas, sélectionnez Tools » Annotation » Annotate Schematics, puis cliquez sur le bouton Back Annotate dans la boîte de dialogue Annotation. Choisissez le fichier WAS-IS généré lors de la réannotation des désignateurs dans l’environnement PCB.
- Depuis l’éditeur de schémas, sélectionnez Tools » Annotation » Board Level Annotate, puis cliquez sur le bouton Back Annotate dans la boîte de dialogue Annotation au niveau de la carte. Choisissez le fichier WAS-IS généré lors de la réannotation des désignateurs dans l’environnement PCB.
- Depuis l’éditeur de schémas, sélectionnez Tools » Annotation » Back Annotate Schematics. Choisissez le fichier WAS-IS généré lors de la réannotation des désignateurs dans l’environnement PCB.
Méthodes traditionnelles de synchronisation de la conception
Altium Designer prend en charge l’approche traditionnelle de synchronisation de la conception au moyen de fichiers intermédiaires (netlist et WAS/IS). La synchronisation des données d’annotation du schéma vers le PCB peut être effectuée à l’aide d’un fichier netlist, tandis que la synchronisation du PCB vers le schéma peut être effectuée à l’aide d’un fichier WAS/IS (qui indique ce que chaque désignateur WAS et ce qu’il ISdésormais). La méthode recommandée pour synchroniser votre conception est la synchronisation directe de la conception.
Liaison des composants à l’aide d’identifiants uniques
Si vous avez réannoté votre conception, les désignateurs des composants du schéma ou les désignateurs des composants compilés ne correspondront plus à ceux des composants du PCB. Une synchronisation est donc nécessaire pour finaliser correctement la conception. Plutôt que de s’appuyer sur le désignateur lui-même comme champ clé reliant un symbole de schéma à son empreinte PCB équivalente, Altium Designer peut maintenir la synchronisation de la conception grâce au système d’identifiants uniques (UID). L’UID est une valeur générée par le système qui identifie de manière unique le composant source et associe chaque composant du schéma au composant correspondant du PCB.
Lorsqu’un composant est placé sur une feuille de schéma, un UID lui est automatiquement attribué. Lors du premier transfert des informations des composants depuis les documents de schéma sources vers un PCB vierge, l’UID de chaque composant du schéma est attribué au composant correspondant du PCB.
La refactorisation permet de convertir des feuilles de dispositifs en feuilles de schéma et inversement, tout en conservant l’identifiant unique de la feuille et de ses composants. Vous pouvez également refactoriser (ou déplacer) des sous-circuits vers d’autres feuilles de schéma du projet en cours, tout en conservant leur identifiant unique. La commande Refactor se trouve dans le menu Edit .
La fonctionnalité de synchronisation d’Altium Designer, activée par la commande Design » Update, utilise ces UID pour associer chaque composant du schéma à son équivalent sur le PCB. Les mises à jour et modifications de la conception peuvent ensuite être appliquées à l’aide d’ordres de modification technique (ECO). Un ECO répertorie toutes les modifications à apporter à un ou plusieurs documents de conception pour réaliser l’opération de synchronisation demandée. Les ECO servent à appliquer des mises à jour de la conception dans diverses situations, notamment :
- Mise à jour de la conception du schéma vers le PCB.
- Mise à jour de l’annotation des désignateurs des composants du schéma et des désignateurs des composants compilés.
- Application de mises à jour des paramètres à l’aide de Parameter Manager (Tools » Parameter Manager).
- Mise à jour des paramètres à partir des informations stockées dans les bibliothèques sources ou dans une base de données d’entreprise. Chaque fois que vous comparez le schéma et le PCB (par exemple lorsque vous sélectionnez Design » Update), Altium Designer commence par associer les composants qui partagent le même UID. Lorsque des composants ne partageant pas le même UID sont détectés, vous en êtes averti et l’application propose de tenter une association par désignateur. Ce message continuera de s’afficher tant que vous n’aurez pas attribué des UID correspondants aux composants du schéma et du PCB. Les identifiants uniques et leurs correspondances sont gérés dans la boîte de dialogue Modifier les liaisons des composants (Project » Component Links).
Notez que cette boîte de dialogue ne peut être ouverte que lorsqu’un document PCB est actif, car les modifications des UID sont toujours appliquées au PCB et non au schéma. Vous pouvez utiliser cette boîte de dialogue à n’importe quelle étape de la conception pour afficher les liaisons entre les composants et vérifier que les composants des différents documents sont correctement associés, ainsi que pour attribuer des UID correspondants aux composants qui ne sont pas encore associés.
