Création d’une empreinte de PCB

La surface occupée par le composant sur la carte fabriquée est définie par son empreinte. Une empreinte type comprend des pastilles et une sérigraphie du composant, et peut également inclure tous les autres détails mécaniques nécessaires. Dans l’exemple d’empreinte ci-dessous, la majeure partie du contour du composant est définie sur une couche mécanique (les lignes vertes) plutôt que sur la sérigraphie (jaune), car ce composant sera monté de façon à surplomber une découpe dans la carte.

L’empreinte définit l’espace occupé par le composant et fournit les points de connexion entre les broches/pastilles du composant et le routage de la carte. 
L’empreinte définit l’espace occupé par le composant et fournit les points de connexion entre les broches/pastilles du composant et le routage de la carte.

Le composant monté sur cette empreinte peut être modélisé à l’aide d’objets Corps 3D. L’objet Corps 3D sert de conteneur dans lequel un modèle au format MCAD générique peut être importé, comme illustré dans l’image ci-dessous.

Un modèle MCAD approprié peut être importé dans un objet Corps 3D.
Un modèle MCAD approprié peut être importé dans un objet Corps 3D.

Même avec un vaste ensemble de ressources proposant des composants de PCB prêts à l’emploi (comme le panneau de recherche de pièces fabricant), il est probable qu’à un moment de votre carrière, vous deviez créer un composant de PCB personnalisé. Les empreintes de composants de PCB sont créées dans l’éditeur d’empreintes de PCB à l’aide du même ensemble d’objets primitifs que ceux disponibles dans l’éditeur de PCB. Outre les empreintes, les logos d’entreprise, les informations de fabrication et les autres objets nécessaires à la conception de la carte peuvent également être enregistrés en tant que composants de PCB.

Création d’une nouvelle empreinte de PCB

Les empreintes peuvent être créées directement dans votre espace de travail connecté. Pour ce faire :

  1. Sélectionnez File » New » Library dans les menus principaux, puis, dans la boîte de dialogue New Library qui s’ouvre, sélectionnez Create Library Content » Footprint dans la section Workspace de la boîte de dialogue.

    Créez une nouvelle empreinte d’espace de travail à l’aide de la boîte de dialogue New Library
    Créez une nouvelle empreinte d’espace de travail à l’aide de la boîte de dialogue New Library

  2. Dans la boîte de dialogue Create New Item qui s’ouvre, saisissez les informations requises, assurez-vous que l’option Open for editing after creation est activée et cliquez sur OK. L’empreinte d’espace de travail est créée et l’éditeur temporaire d’empreintes de PCB s’ouvre, avec un document .PcbLib comme document actif. Ce document est nommé en fonction de l’élément et de sa révision, au format : <Item><Revision>.PcbLib (par exemple, PCC-001-0001-1.PcbLib). Utilisez ce document pour définir l’empreinte comme décrit ci-dessous.

    Exemple de modification de la révision initiale d’une empreinte d’espace de travail : l’éditeur temporaire d’empreintes de PCB fournit le document permettant de définir votre empreinte.
    Exemple de modification de la révision initiale d’une empreinte d’espace de travail : l’éditeur temporaire d’empreintes de PCB fournit le document permettant de définir votre empreinte.

  3. Une fois l’empreinte définie conformément à vos besoins, enregistrez-la dans l’espace de travail à l’aide de la commande Save to Server située à droite de son entrée dans le panneau Projects. La boîte de dialogue Edit Revision s’affiche ; vous pouvez y modifier le nom et la description, et ajouter des notes de publication si nécessaire. Le document et l’éditeur se ferment après l’enregistrement.

Une empreinte d’espace de travail enregistrée peut être utilisée lors de la définition d’un composant dans l’éditeur de composants, en mode de modification d’un seul composant ou en mode de modification de composants par lot.

Vous pouvez parcourir les empreintes d’espace de travail à l’aide du panneau Components. Activez l’affichage des modèles en cliquant sur le bouton  en haut du panneau et en sélectionnant Models, puis sélectionnez la catégorie Footprints.

Pour modifier une empreinte d’espace de travail, cliquez avec le bouton droit sur son entrée dans le panneau Components et sélectionnez la commande Edit. L’éditeur temporaire s’ouvre à nouveau, avec l’empreinte prête à être modifiée. Effectuez les modifications nécessaires, puis enregistrez le document dans la révision suivante de l’empreinte d’espace de travail.

 
 
 
 
 

Lorsque vous enregistrez une empreinte modifiée dans votre espace de travail, vous pouvez conserver son état actuel dans le cycle de vie. Ce comportement est contrôlé par l’option Preserve lifecycle state (not recommended) disponible dans la boîte de dialogue Create Revision lors d’un nouvel enregistrement (). Lorsque cette option est activée, la nouvelle révision de l’empreinte reprend automatiquement l’état de cycle de vie de la révision précédente. Cette fonctionnalité est accessible aux utilisateurs disposant de l’autorisation opérationnelle Allow to skip lifecycle state change for new revisions (pour en savoir plus, consultez Définition des autorisations d’opérations globales pour un espace de travail).

  • Lorsque vous modifiez une empreinte d’espace de travail, dès que vous enregistrez cette modification dans une nouvelle révision de l’empreinte, tous les composants de l’espace de travail qui utilisent cette empreinte deviennent de fait obsolètes, car ils utilisent toujours la révision précédente. Dans la plupart des cas, vous souhaiterez sans doute enregistrer à nouveau ces composants d’espace de travail, en mettant à jour leurs liens vers les modèles respectifs afin d’utiliser les dernières révisions disponibles. Pour simplifier ce processus, l’espace de travail, conjointement avec Altium Designer, permet de mettre à jour les composants parents lors du nouvel enregistrement d’une empreinte d’espace de travail, après avoir modifié cette empreinte à l’aide de la fonction de modification directe.

    Pour plus d’informations sur la mise à jour des composants parents lors de l’enregistrement d’un modèle de domaine, consultez la page Création et modification de contenu.

  • Vous pouvez également mettre à jour à la volée l’empreinte d’espace de travail utilisée par un composant d’espace de travail, directement lors de la modification de ce composant dans l’éditeur de composants, en mode de modification d’un seul composant ou en mode de modification de composants par lot.

  • Du point de vue du concepteur, un composant d’espace de travail regroupe, au sein d’une seule entité, toutes les informations nécessaires pour représenter ce composant dans l’ensemble des domaines de conception. Il peut donc être considéré comme un conteneur dans lequel sont stockés tous les modèles de domaine et toutes les informations paramétriques. Pour sa représentation dans les différents domaines, un composant d’espace de travail ne contient pas les modèles de domaine de l’espace de travail eux-mêmes, mais plutôt des liens vers ces modèles. Ces liens sont spécifiés lors de la définition du composant.

  • Des empreintes de PCB peuvent également être créées dans l’espace de travail lors de l’importation de bibliothèques de composants existantes d’ancienne génération (SchLib, PcbLib, IntLib, DbLib, SVNDbLib). L’interface dédiée à ce processus, le Library Importer, propose un parcours intuitif qui permet d’importer dans votre espace de travail les bibliothèques initialement sélectionnées. Pour en savoir plus, consultez la rubrique Importateur de bibliothèques.

  • Une nouvelle empreinte d’espace de travail peut également être créée lors de la définition d’un composant d’espace de travail dans l’éditeur de composants en mode de modification d’un seul composant.

  • Une empreinte peut également être créée au sein d’une bibliothèque d’empreintes de PCB basée sur des fichiers.

Définition d’une empreinte de PCB

Les empreintes sont toujours créées sur la face supérieure, quelle que soit la face du circuit imprimé sur laquelle elles seront finalement placées, à l’aide des mêmes outils et objets de conception que ceux disponibles dans l’éditeur PCB. Les attributs propres à chaque couche, tels que les pastilles de montage en surface et les définitions du masque de soudure, sont automatiquement transférés vers les couches correspondantes de la face inférieure lorsque vous retournez l’empreinte sur l’autre face du circuit imprimé pendant le placement du composant.

Les objets de conception peuvent être placés sur n’importe quelle couche. Toutefois, le contour est généralement créé sur la couche Top Overlay (sérigraphie), et les pastilles sur la couche multicouche (pour les broches des composants traversants) ou sur la couche de signal supérieure (pour les broches des composants montés en surface). Lorsque vous placez l’empreinte sur un PCB, tous les objets qui la constituent sont affectés aux couches définies pour chacun d’eux.

Vues 2D et 3D de l’empreinte d’un composant de type joystick. L’image 3D montre le modèle STEP importé pour ce composant. Notez que les pastilles et la sérigraphie du composant sont visibles sous le modèle STEP.
Vues 2D et 3D de l’empreinte d’un composant de type joystick. L’image 3D montre le modèle STEP importé pour ce composant. Notez que les pastilles et la sérigraphie du composant sont visibles sous le modèle STEP.

Les empreintes présentées sur cette page servent uniquement à illustrer les procédures requises ; leurs dimensions ne sont pas exactes. Vérifiez toujours les caractéristiques d’une nouvelle empreinte par rapport à la fiche technique du fabricant.

La séquence habituelle pour créer manuellement l’empreinte d’un composant est la suivante :

  1. Préparez l’espace de conception : définissez les options d’accrochage, configurez les grilles et les guides - en savoir plus.

  2. Les empreintes doivent être créées autour du point de référence de l’espace de conception, situé au centre de l’éditeur d’empreintes PCB. Ce point de référence est en réalité l’origine relative de l’espace de conception et constitue le point par lequel le curseur saisit l’empreinte du composant lors des opérations de placement et de déplacement (selon le réglage actuel de Object Snap Options dans la page PCB Editor – General de la boîte de dialogue Preferences). Utilisez les touches de raccourci J, R pour accéder directement au point de référence. Si vous avez oublié de vous positionner sur le point de référence avant de commencer à créer votre empreinte, vous pouvez déplacer ce point vers votre empreinte à l’aide des commandes du sous-menu Edit » Set Reference :
    • Pin 1 - définir le point de référence du composant sur la broche 1 de son empreinte.

    • Center - définir le point de référence du composant au centre de son empreinte.

    • Location - définir le point de référence du composant à un emplacement choisi par l’utilisateur.

    Le point choisi sera défini sur 0,0 - il devient la nouvelle origine relative, et les coordonnées de toutes les primitives sont mises à jour par rapport à ce point.

  3. Placez les pastilles (Place » Pad) conformément aux exigences du composant. Après avoir exécuté la commande de placement de pastille, mais avant de placer la première pastille, appuyez sur la touche Tab pour ouvrir le panneau Properties et définir toutes les propriétés de la pastille, notamment Designator, Size and Shape, Layer et Hole Size (pour une pastille traversante). Le repère s’incrémente automatiquement lors du placement des pastilles suivantes. Pour une pastille de montage en surface, définissez Layer sur Top Layer. Pour une pastille traversante, définissez Layer sur Multi-Layer.

    Certaines empreintes nécessitent des pastilles de forme irrégulière. Vous pouvez les créer à l’aide d’objets pastille de forme personnalisée. Pour en savoir plus, consultez la page Personnalisation d’un empilement de pastille.
    • L’une des étapes les plus importantes de la création d’une nouvelle empreinte de composant est le placement des pastilles qui serviront à souder le composant au PCB. Elles doivent être placées à des positions parfaitement exactes pour correspondre aux broches du composant physique.
    • Une attention particulière doit également être portée à la désignation des pastilles, car c’est cette propriété qu’Altium Designer utilise pour établir la correspondance avec les numéros de broches du symbole schématique.
  4. Pour garantir un placement précis des pastilles, envisagez de configurer une grille spécialement pour cette tâche. Utilisez les touches de raccourci Ctrl+G pour ouvrir la boîte de dialogue de l’éditeur de grille cartésienne et la touche Q pour faire passer la grille du système impérial au système métrique.

  5. Pour placer précisément une pastille pendant que vous la déplacez à la souris, utilisez les touches fléchées du clavier afin de déplacer le curseur par incréments de la grille actuelle. En maintenant également Shift enfoncé, vous effectuerez des déplacements par pas de 10 fois l’incrément de la grille. Les coordonnées X et Y actuelles sont indiquées dans la barre d’état ainsi que dans l’affichage tête haute. L’affichage tête haute indique à la fois la position et l’écart entre l’emplacement du dernier clic et la position actuelle du curseur. Utilisez le raccourci Shift+H pour activer ou désactiver l’affichage tête haute. Vous pouvez également double-cliquer sur une pastille déjà placée pour la modifier et saisir les coordonnées X et Y souhaitées dans le panneau Properties .

  6. Pour vérifier la distance entre deux points de l’espace de conception, utilisez Reports » Measure Distance (raccourci Ctrl+M). Suivez les instructions affichées dans la barre d’état.

  7. Les attributs propres aux pastilles, tels que le masque de soudure et le masque de pâte à braser, sont automatiquement calculés en fonction des dimensions des pastilles et des règles de conception applicables aux masques. Bien que les paramètres des masques puissent être définis manuellement pour chaque pastille, cela rend leur modification ultérieure difficile pendant la conception du circuit imprimé. Cette méthode n’est généralement utilisée que lorsqu’il est impossible de cibler les pastilles à l’aide de règles de conception. Notez que les règles sont définies dans l’éditeur PCB pendant la conception du circuit imprimé.

  8. Utilisez des pistes, des arcs et d’autres objets primitifs pour définir le contour du composant qui apparaît sur la sérigraphie du PCB, sur la couche Top Overlay. Si le composant est retourné sur la face inférieure du circuit imprimé pendant le placement, la sérigraphie est automatiquement transférée sur la couche Bottom Overlay.

  9. Placez des pistes et d’autres objets primitifs sur une couche mécanique pour définir des détails mécaniques supplémentaires, tels qu’une zone d’encombrement pour le placement. Les couches mécaniques sont des couches à usage général. Vous devez attribuer une fonction à ces couches et les utiliser de manière cohérente dans toutes vos empreintes.

  10. Placez des objets de corps 3D pour définir la forme tridimensionnelle du composant physique à monter sur le PCB.

    Un objet de corps 3D ajouté à une empreinte peut faire référence à un modèle 3D chargé dans l’espace de travail connecté.
  11. Les chaînes de repère et de commentaire sont automatiquement ajoutées à la couche de sérigraphie de l’empreinte lors de son placement dans l’espace de conception PCB. Des chaînes de repère et de commentaire supplémentaires peuvent être ajoutées en plaçant les chaînes spéciales .Designator et .Comment sur une couche mécanique.

    Lors du placement des chaînes de repère et de commentaire, une paire de couches doit être définie dans l’éditeur PCB. Cela garantit que les chaînes sont liées à la face du circuit imprimé sur laquelle le composant est monté et qu’elles passent sur l’autre face lorsque le composant est retourné. Pour plus d’informations, consultez la section Gestion des exigences particulières propres aux couches ci-dessous.
  12. Définissez les propriétés de l’empreinte (par exemple, son nom et sa description) dans l’onglet Footprint du panneau Properties, en mode Library Options (actif lorsqu’aucun objet n’est sélectionné dans l’espace de conception ; accessible à l’aide de Tools » Footprint Properties depuis les menus principaux). Consultez la section ci-dessous pour en savoir plus sur les options et les commandes disponibles dans l’onglet Footprint du panneau.

  • Pour obtenir une définition standardisée des pastilles et des vias dans toutes les empreintes, vous pouvez utiliser la bibliothèque de pastilles/vias (*.PvLib) pour leur placement – en savoir plus.
  • L’éditeur d’empreintes PCB propose également des assistants pour accélérer la création d’empreintes :
    • Le IPC Compliant Footprint Wizard – génère une empreinte PCB entièrement conforme à la révision B de la norme IPC 7351 – Generic Requirements for Surface Mount Design and Land Pattern Standard – en savoir plus.
    • Le IPC Compliant Footprints Batch Generator – lorsque vous travaillez avec une bibliothèque d’empreintes PCB basée sur des fichiers, utilisez le IPC Compliant Footprints Batch Generator pour générer rapidement plusieurs empreintes à différents niveaux de densité – en savoir plus.
    • Le Footprint Wizard – vous permet de choisir parmi différents types de boîtiers et de renseigner les informations appropriées, puis crée l’empreinte du composant pour vous – en savoir plus.

Préparation de l’espace de conception

Par défaut, les grilles sont affichées sous forme de points. Si vous le préférez, elles peuvent être affichées sous forme de lignes. Ce réglage s’effectue dans la boîte de dialogue Grid Editor, accessible en cliquant sur le bouton Properties du panneau Properties, comme illustré ci-dessous. Vous pouvez également utiliser le raccourci Ctrl+G pour ouvrir cette boîte de dialogue.

Sur l’image, la grille fine est affichée sous forme de points et la grille grossière sous forme de lignes.
Sur l’image, la grille fine est affichée sous forme de points et la grille grossière sous forme de lignes.

Panneau Propriétés

Lors de la modification d’une empreinte dans l’éditeur d’empreintes PCB, lorsqu’aucun objet de conception n’est sélectionné dans l’espace de conception, le panneau Properties présente le Library Options.

Les sections repliables suivantes contiennent des informations sur les options et les commandes disponibles dans l’onglet General du panneau :

Les sections repliables suivantes présentent les options et les commandes disponibles dans l’onglet Footprint du panneau :

Il est possible de définir les propriétés de l’empreinte à l’aide de l’onglet Footprint du panneau Properties lorsque l’option PCB.FootprintParameters est activée dans la boîte de dialogue Paramètres avancés. Lorsque cette option est désactivée, les propriétés de l’empreinte sont définies dans la boîte de dialogue PCB Library Footprint (), accessible en sélectionnant la commande Tools » Footprint Properties dans les menus principaux, en sélectionnant une entrée d’empreinte dans la zone Footprints du panneau PCB Library puis en cliquant sur le bouton Edit, ou en double-cliquant sur une entrée d’empreinte dans la zone Footprints du panneau PCB Library.

Lorsqu’un objet de conception est sélectionné, le panneau présente les options propres à ce type d’objet. Le tableau suivant répertorie les types d’objets pouvant être placés dans l’espace de conception des empreintes de PCB. Cliquez sur un lien pour accéder à la page des propriétés de l’objet correspondant.

Corps 3D Arc
Zone d’exclusion en arc Remplissage
Zone d’exclusion par remplissage Pastille
Région Zone d’exclusion par région
Texte (chaîne, cadre de texte) Piste
Zone d’exclusion par piste Via

Expansions du masque de soudure et du masque de pâte

Pour vérifier que les masques de soudure et/ou de pâte ont été correctement définis dans l’éditeur d’empreintes de PCB, ouvrez le panneau Configuration de l’affichage et activez l’option d’affichage () pour chaque couche de masque.

L’anneau qui apparaît autour de chaque pastille dans la couleur de la couche de masque de soudure supérieure représente le bord de la forme du masque de soudure, qui dépasse de sous la pastille multicouche de la valeur d’expansion définie, car multi-layer se trouve en tête de l’ordre de tracé des couches ; il est donc dessiné par-dessus. Le Layer Drawing Order est défini sur la page Éditeur PCB - Affichage de la boîte de dialogue Preferences).

L’image ci-dessous montre une empreinte de PCB avec une bordure violette (couleur de la couche de masque de soudure supérieure) qui apparaît autour de chaque pastille.

Pour parcourir rapidement les couches, utilisez le mode Couche unique (Shift+S) en combinaison avec Ctrl+Shift+Wheel roll.

Par défaut, la forme créée sur les couches de masque correspond à celle de la pastille, agrandie ou réduite selon la valeur spécifiée par les règles de conception Expansion du masque de soudure et Expansion du masque de pâte définies dans le PCB sur lequel l’empreinte est placée. Dans certains cas, vous devrez peut-être remplacer les règles de conception d’expansion et spécifier une expansion de masque comme attribut de la pastille, choisir parmi un ensemble de formes de masque standard prédéfinies ou créer votre propre forme personnalisée. Dans ces situations, vous pouvez configurer les masques de pâte et de soudure d’une pastille sélectionnée dans son panneau Properties - en savoir plus. Vous pouvez également placer des primitives appropriées (régions, pistes, etc.) sur la couche de masque requise.

Dans une bibliothèque de PCB, tous les objets dont l’expansion du masque de soudure est pilotée par une règle auront une valeur d’expansion égale à 0 mil. Cette fonctionnalité est disponible lorsque l’option PCB.SolderMaskZeroExpansion est activée dans la boîte de dialogue Paramètres avancés. Lorsque cette option est désactivée, la valeur d’expansion du masque de soudure pour ces objets dans une bibliothèque de PCB est de 4 mils.

Prise en charge des paramètres

Les paramètres appliqués aux objets dans Altium Designer constituent un moyen puissant et flexible d’ajouter des informations à une conception de PCB. Définis comme propriétés de l’objet parent, les paramètres peuvent être appliqués à différents niveaux, notamment aux projets, aux documents, aux modèles et aux objets individuels d’un document de conception.

Consultez la section Objet Paramètre pour plus d’informations.

Les paramètres disponibles dans l’espace PCB peuvent être utilisés pour filtrer les requêtes, les règles de conception, les scripts et les variantes, et peuvent être appliqués aux empreintes de composants PCB pour appeler des chaînes personnalisées dans les empreintes placées.

Paramètres via un ordre de modification technique

Les fonctionnalités de gestion des paramètres PCB reposent sur celles du mécanisme ECO et du document PCB, qui permettent de transférer les paramètres de composants définis par l’utilisateur vers l’espace PCB et de les y conserver. Ce transfert est unidirectionnel et les paramètres transférés sont en lecture seule dans l’environnement PCB.

Le transfert des paramètres s’effectue en créant un ECO du schéma vers le PCB à l’aide de la commande de menu Design » Update PCB Document .

Lorsque l’ECO est exécuté (à l’aide du bouton Execute Changes ), tous les nouveaux paramètres de composants du schéma définis par l’utilisateur sont transférés vers la référence d’empreinte correspondante dans la conception du PCB. 

La détection et la migration des paramètres vers le PCB sont déterminées par les options du projet (Project » Project Options). Dans la boîte de dialogue Project Options , définissez le comportement de détection des différences et de modification dans la section Differences Associated with Parameters de l’onglet Comparator et dans la section Modifications Associated with Parameters de l’onglet ECO Generation .

Pour afficher les paramètres transférés dans l’éditeur PCB, double-cliquez sur un composant pour ouvrir le panneau Properties , puis sélectionnez l’onglet Parameters . Cet onglet répertorie les paramètres utilisateur actuels attribués à l’empreinte du composant sélectionné. Les paramètres de l’empreinte du composant sélectionné sont également disponibles dans le panneau Components .

Liens vers des informations de référence

L’environnement PCB accepte automatiquement les paramètres prédéfinis ComponentLink du schéma. Ceux-ci sont définis sous forme de paires de paramètres (description et URL du lien) qui établissent généralement des liens vers des fichiers ou des emplacements Internet spécifiques, le plus souvent le site Web d’un fabricant ou l’URL d’une fiche technique.

Consultez les sections Définition de liens cliquables vers des informations de référence dans une bibliothèque de schémas et Accès aux liens cliquables vers des informations de référence dans un document PCB pour obtenir des informations sur les paramètres de liens de référence.

Dans les espaces de conception du schéma et du PCB, les liens sont accessibles depuis le menu contextuel ouvert par un clic droit lorsque le pointeur survole un composant (dans les options du sous-menu References ). Les paramètres spécifiques sont ajoutés dans le panneau Properties et, une fois transférés vers l’espace PCB, ils apparaissent comme paramètres de l’empreinte du composant. 

Paramètres dans les empreintes sources

Les paramètres transférés vers le PCB peuvent servir à fournir des informations supplémentaires sur la fabrication ou le fonctionnement de la carte via les empreintes des composants. En ajoutant des chaînes de paramètres spéciales aux empreintes dans la bibliothèque source, les chaînes personnalisées seront interprétées sur la couche mécanique ou de sérigraphie cible.

Une chaîne spéciale représentant un paramètre défini par l’utilisateur peut être ajoutée à l’empreinte du composant source à l’aide du bouton et de la liste déroulante des chaînes spéciales () dans le panneau Properties .

Dans l’empreinte de bibliothèque ci-dessous, la chaîne spéciale .Designator a été placée sur la couche Mécanique 2.

Une chaîne spéciale représentant un paramètre utilisateur peut être ajoutée à l’empreinte du composant.

Lorsque ce paramètre personnalisé a également été appliqué aux composants du schéma et que les données du paramètre ont été transférées vers le PCB, les chaînes interprétées des empreintes apparaissent à la fois dans la vue de la carte et dans les fichiers de sortie générés. Dans ce cas, la chaîne de paramètre spéciale contient un identifiant personnalisé du composant pour faciliter l’assemblage.

L’application de paramètres utilisateur aux empreintes de composants sous forme de chaînes spéciales peut répondre à diverses autres exigences personnalisées pour les PCB, notamment l’ajout d’étiquettes de fonction pour les interrupteurs et les connecteurs. Une chaîne de paramètre « fonction » peut ainsi être placée sur la couche de sérigraphie supérieure dans les empreintes de ces types de composants.

Pour afficher la valeur interprétée des chaînes spéciales dans le dessin de la carte, activez l’option Special Strings dans la section Additional Options de l’onglet View Options dans View Configuration panneau. Les chaînes spéciales sont toujours converties dans les fichiers de sortie générés.
Dans l’éditeur de schémas, si nécessaire, activez l’option Display Names of Special Strings that have No Value Defined sur la page Schematic – Graphical Editing de la boîte de dialogue Preferences.

Requêtes sur les paramètres

Les chaînes de paramètres du domaine PCB sont également accessibles via le langage de requête d’Altium Designer et sont donc disponibles pour les fonctions de filtrage des objets, notamment la fonction Rechercher des objets similaires.

Pour sélectionner des objets similaires, cliquez avec le bouton droit sur un composant, puis sélectionnez Find Similar Objects dans le menu contextuel pour ouvrir la boîte de dialogue Find Similar Objects.

La boîte de dialogue Rechercher des objets similaires comprend une section Parameters dans laquelle les options de filtrage peuvent être sélectionnées selon les besoins.

Le panneau PCB Filter permet d’utiliser des mots-clés de requête propres aux paramètres comme critères de filtrage et de créer des règles de conception basées sur les paramètres PCB.

Plusieurs mots-clés de requête permettent de travailler avec les paramètres des empreintes PCB, notamment des fonctions spécifiques pour convertir les valeurs de chaîne en nombres (comme StrToNumber). Les conversions des chaînes de valeur tiennent compte des unités (V, mA, mV, kOhm, etc.) et permettent de déterminer le résultat de la requête par le traitement numérique d’une chaîne de valeur de paramètre.

Les types d’unités pris en charge qui peuvent être spécifiés dans les requêtes sont les suivants :

  • % – Pourcentage
  • A – Courant
  • C – Température
  • dB – Décibels
  • F – Capacité
  • G – Conductance
  • H – Inductance
  • Hz – Fréquence
  • Kg – Masse
  • m – Longueur
  • Ohm – Résistance
  • Q – Charge
  • s – Temps
  • V – Tension
  • W – Puissance
  • Z – Impédance

Plusieurs mots-clés de requête sur les paramètres permettent de travailler avec les paramètres des empreintes de composants PCB.

L’exemple présenté dans la boîte de dialogue Query Helper ci-dessus traite le paramètre de tension nominale de chaque composant (à l’aide de la conversion de chaîne en nombre – StrToNumber(Unit Value, Unit Type))  pour déterminer si sa valeur est supérieure à 50 V. Lorsqu’il est appliqué dans le panneau PCB Filter, l’exemple d’implantation de la carte fait apparaître un seul composant haute tension, C1 (dont la tension nominale est de 3 kV).

La notation scientifique E est également prise en charge. Par exemple, une requête visant à filtrer les valeurs de condensateurs supérieures à 1 nF serait semblable à :
StrToNumber(ParameterValue('CapacitanceValue'), F) > 1e-9
La fonction de conversion numérique peut également être utilisée à la fois pour la valeur ParameterValue renvoyée and la valeur de comparaison :
StrToNumber(ParameterValue('CapacitanceValue'), F) > StrToNumber('1nF', F)

Règles et scripts

Les requêtes sur les paramètres PCB peuvent également être appliquées aux scripts et aux règles de conception d’Altium Designer. Ces dernières peuvent effectuer des contrôles de validation de l’implantation, par exemple en détectant des paramètres d’empreinte afin d’évaluer le placement des composants ou l’affectation des couches. Notez que les fonctions répertoriées dans la boîte de dialogue Query Helper ci-dessus sont disponibles dans le langage de script.

L’exemple ci-dessous montre la requête sur la tension nominale des condensateurs (voir la requête de filtrage ci-dessus) appliquée à une règle de placement des composants. Lors de son exécution, cette règle vérifie des valeurs d’espacement spécifiques pour les composants détectés comme des dispositifs haute tension (>50V).

Les règles de conception définies par des paramètres d’empreinte spécifiques, transférés depuis l’espace schématique, peuvent être utilisées pour détecter des conditions d’implantation personnalisées.

De même, les paramètres PCB personnalisés peuvent servir à vérifier la compatibilité des composants avec les couches, par exemple lorsqu’un composant ne prend pas en charge le soudage à la vague et ne peut donc pas être placé sur la couche inférieure. Dans ce cas, une requête de correspondance d’objets qui traite un paramètre personnalisé « WaveSoldering » (Yes/No) peut être appliquée à la règle des couches autorisées.

La règle (par lots) vérifie ensuite la valeur de ce paramètre de composant et génère une violation si un composant n’est pas compatible avec un placement sur la couche inférieure.

Variantes

Les paramètres transférés au PCB qui sont inclus dans des variantes de la conception (Variantes de conception) sont traités lors de la sélection d’une variante.

En pratique, un paramètre de composant modifié dans l’espace PCB est détecté dynamiquement par une chaîne de requête ou, par exemple, affiché sur une couche de la carte à l’aide d’une chaîne spéciale. 

Paramètres d’empreinte définis par l’utilisateur

Cette fonctionnalité est disponible lorsque l’option PCB.FootprintParameters est activée dans la boîte de dialogue Paramètres avancés.

Altium Designer prend en charge les paramètres d’empreinte définis par l’utilisateur. La zone Parameters de l’onglet Footprint du panneau Properties , dans son mode Library Options , permet de consulter et de modifier les paramètres d’empreinte lorsqu’aucun objet n’est sélectionné dans l’espace de conception de l’éditeur d’empreintes PCB.

Lorsque le composant est placé sur le PCB, vous pouvez voir ces paramètres dans le panneau Properties , en mode Component , sur l’onglet Parameters .

  • Les paramètres d’empreinte des composants placés sur un PCB sont propagés aux empreintes des bibliothèques générées par la commande Make PCB Library ou Make Integrated Library du menu principal de l’éditeur PCB.
  • Les paramètres d’empreinte sont pris en charge par le moteur de comparaison d’Altium Designer ainsi que dans les sorties Pick and Place et ODB++ générées.
Altium MCAD CoDesigner prend en charge le placement de composants MCAD natifs dans l’environnement MCAD selon les liens configurés. Dans certains cas, plusieurs empreintes avec des modèles différents sont liées à un même composant (par exemple, une LED pouvant être montée sur un PCB de deux façons : verticalement, avec des pattes droites, ou horizontalement, avec des pattes pliées). Grâce aux paramètres d’empreinte, vous pouvez désormais faire référence aux différents modèles MCAD à partir de ces différentes empreintes. Pour en savoir plus, consultez Liaison des composants de conception ECAD et MCAD natifs.

Chaînes de désignateur et de commentaire

Chaînes de désignateur et de commentaire par défaut

Lorsqu’une empreinte est placée sur une carte, un désignateur et un commentaire lui sont attribués à partir des informations extraites de la vue schématique de la conception. Il n’est pas nécessaire de définir manuellement des espaces réservés pour les chaînes de désignateur et de commentaire, car ils sont ajoutés automatiquement lorsque l’empreinte est placée sur une carte. Les emplacements de ces chaînes sont déterminés par l’option Autoposition des chaînes de désignateur et de commentaire dans le panneau Properties en mode Parameter lorsque la chaîne de désignateur ou de commentaire est sélectionnée dans l’espace de conception. La position et la taille par défaut des chaînes de désignateur et de commentaire sont configurées dans la primitive correspondante sur la page Éditeur PCB - Valeurs par défaut de la boîte de dialogue Preferences .

Chaînes de désignateur et de commentaire supplémentaires

Il peut arriver que vous ayez besoin de copies supplémentaires des chaînes de désignateur ou de commentaire. Par exemple, votre sous-traitant d’assemblage souhaite un plan d’assemblage détaillé avec le désignateur affiché à l’intérieur du contour de chaque composant, tandis que votre entreprise exige que le désignateur soit placé juste au-dessus du composant, sur la couche de sérigraphie du PCB final. Ce besoin de désignateur supplémentaire peut être satisfait en ajoutant la chaîne spéciale .Designator à l’empreinte. Une chaîne spéciale .Comment est également disponible pour spécifier l’emplacement de la chaîne de commentaire sur d’autres couches ou à d’autres endroits.

Pour répondre aux exigences du sous-traitant d’assemblage, la chaîne .Designator doit être placée sur une couche mécanique dans l’éditeur d’empreintes PCB. Des impressions incluant cette couche peuvent ensuite être générées dans le cadre des instructions d’assemblage de la conception.

Gestion des exigences particulières propres aux couches

Un composant PCB peut présenter diverses exigences particulières, comme la nécessité d’un point de colle ou d’une définition de masque de soudure pelable. Bon nombre de ces exigences sont liées à la face de la carte sur laquelle le composant est monté et doivent passer sur l’autre face de la carte lorsque le composant est retourné.

Plutôt que d’inclure un grand nombre de couches dédiées qui seraient rarement utilisées, l’éditeur PCB d’Altium Designer répond à ce besoin grâce à une fonctionnalité appelée paires de couches. Une paire de couches se compose de deux couches mécaniques définies comme une paire. Chaque fois qu’un composant est retourné d’une face de la carte à l’autre, tous les objets présents sur une couche mécanique appariée sont transférés sur l’autre couche mécanique de la paire. Avec cette approche, vous sélectionnez une couche mécanique appropriée pour y placer le point de colle (ou répondre à d’autres exigences particulières) et vous définissez sa forme à l’aide des objets disponibles. Lorsque vous placez cette empreinte sur une carte, vous devez configurer l’appariement des couches. Cela indique au logiciel vers quelle couche transférer les objets lorsque ce composant est retourné sur l’autre face de la carte. Vous ne pouvez pas définir de paires de couches dans l’éditeur d’empreintes PCB ; cette opération s’effectue dans l’éditeur PCB.

L’appariement des couches doit être défini before le retournement du composant. Si l’appariement est défini après le déplacement du composant sur la face inférieure, les objets de la couche mécanique sont retournés, mais restent sur leur couche d’origine. Si vous oubliez de créer les paires de couches avant le retournement, vous pouvez effectuer une mise à jour à partir de la bibliothèque pour actualiser l’instance du composant placée sur la carte.

Les noms des couches mécaniques peuvent être modifiés directement depuis le panneau View Configurations, en effectuant un clic droit puis en sélectionnant Edit Layer.

Une approche courante pour gérer l’utilisation des couches mécaniques consiste à attribuer un numéro de couche dédié à chaque fonction mécanique requise. Cette approche exige que tous les concepteurs respectent le même schéma d’affectation et de numérotation des couches. Elle peut également créer des difficultés lorsque les composants proviennent d’autres sources qui ne suivent pas le même schéma d’affectation et de numérotation. Si un schéma différent a été utilisé, les objets de conception doivent être déplacés de leur couche mécanique actuelle vers la couche mécanique attribuée à cette fonction.

Ce problème est résolu grâce à l’introduction de la propriété Layer Type. Lorsqu’un composant est placé depuis une bibliothèque dans l’éditeur PCB, copié d’une bibliothèque à une autre ou créé par le IPC Footprint Wizard, les affectations de type de couche existantes sont automatiquement mises en correspondance, quels que soient les numéros de couche mécanique attribués à ces types de couche. Les objets sont déplacés vers les couches appropriées en fonction de leur type de couche. Si le logiciel ne parvient pas à établir une correspondance par type de couche, il utilise le numéro de couche.

Pour les couches mécaniques individuelles comme pour les paires de couches de composants, vous pouvez sélectionner un type de couche dans une liste de types prédéfinis. Vous pouvez accéder aux boîtes de dialogue présentées ci-dessous en effectuant un clic droit sur une couche individuelle, puis en sélectionnant la commande Edit Layer ou Add Component Layer dans le menu.

Pour obtenir des informations détaillées sur les types de couches mécaniques liés aux composants, consultez la page Utilisation des couches mécaniques.

Ajout d’une hauteur à une empreinte PCB

Au niveau le plus simple de la représentation 3D, des informations de hauteur peuvent être ajoutées à une empreinte PCB. Pour ce faire, ouvrez le panneau Properties dans son mode Library Options (actif lorsqu’aucun objet n’est sélectionné dans l’espace de conception) et saisissez la hauteur recommandée pour le composant dans le champ Height de l’onglet Footprint du panneau.

Des règles de conception relatives à la hauteur peuvent être définies lors de la conception de la carte (cliquez sur Design » Rules dans l’éditeur PCB), généralement pour vérifier la hauteur maximale des composants dans une classe de composants ou dans une zone définie.

Une meilleure option pour définir les informations de hauteur consiste à associer des corps 3D à l’empreinte PCB.

Gestion des composants comportant des primitives de routage

Lors du transfert d’une conception, l’empreinte spécifiée pour chaque composant est extraite des bibliothèques disponibles et placée sur la carte. La propriété de net de chaque pastille de l’empreinte est ensuite définie sur le nom du net connecté à la broche correspondante du composant dans le schéma. Tous les objets en contact avec une pastille sont connectés au même net que celle-ci.

L’éditeur PCB comprend un outil complet de gestion des nets. Pour le lancer, sélectionnez Design » Netlist » Configure Physical Nets dans les menus principaux afin d’ouvrir la boîte de dialogue de configuration des nets physiques. Cliquez sur le bouton Menu pour afficher un menu d’options. Cliquez sur la liste déroulante de l’en-tête New Net Name pour sélectionner le net à attribuer aux primitives non affectées.

Empreintes comportant plusieurs pastilles connectées à la même broche

L’empreinte présentée ci-dessous, celle d’un transistor SOT223, comporte plusieurs pastilles connectées à la même broche logique du composant dans le schéma : la broche 2. Pour établir cette connexion, deux pastilles portant le même désignateur, « 2 », ont été ajoutées. Lorsque la commande Design » Update PCB est utilisée dans l’éditeur de schémas pour transférer les informations de conception vers le PCB, la synchronisation qui en résulte affiche les lignes de connexion vers les deux pastilles dans l’éditeur PCB, ce qui signifie qu’elles appartiennent au même net. Les deux peuvent être routées.

Empreinte SOT223 présentant deux pastilles portant le désignateur 2.
Empreinte SOT223 présentant deux pastilles portant le désignateur 2.

Préparation de la sérigraphie

Pour aider à résoudre les problèmes courants de conception pour la fabrication (DFM) liés au chevauchement de la sérigraphie avec le cuivre exposé et les trous, l’éditeur d’empreintes PCB comprend une fonctionnalité dédiée à la préparation de la sérigraphie de vos empreintes. Ces problèmes peuvent être résolus efficacement grâce aux opérations suivantes :

  • découpage automatique des lignes et des arcs de sérigraphie ;
  • découpage ou déplacement automatique des remplissages et des régions ;
  • déplacement automatique des chaînes de texte de sérigraphie.
L’outil de préparation de la sérigraphie est également accessible lors de la conception d’un PCB – en savoir plus.

Pour accéder à l’outil de préparation de la sérigraphie dans l’éditeur d’empreintes PCB, utilisez la commande Tools » Silkscreen Preparation dans les menus principaux. La boîte de dialogue Silkscreen Preparation s’ouvre.

Utilisez cette boîte de dialogue pour configurer les paramètres de découpage et de déplacement des objets de sérigraphie. Les options disponibles sont les suivantes :

  • Clip to Exposed Copper – activez cette option pour découper automatiquement les objets au niveau du cuivre exposé.
  • Clip to Solder Mask Openings – activez cette option pour découper automatiquement les objets au niveau des ouvertures du masque de soudure.
  • Silkscreen Clearance – définissez l’espacement minimal acceptable entre les objets de sérigraphie et le cuivre exposé, les ouvertures du masque de soudure et les trous.
  • Min Remaining Length – si la longueur de la ligne ou de l’arc est inférieure à la valeur définie après découpe, les objets seront supprimés de l’empreinte. Notez que cette longueur est mesurée de sommet à sommet, et non de bord à bord – voir l’image.
  • Move Text – activez cette option pour éloigner les chaînes de texte de sérigraphie du cuivre exposé, des ouvertures du masque de soudure et des trous si la distance qui les sépare est inférieure à Silkscreen Clearance. Le déplacement est limité par la valeur Max Distance.
  • Fill & Region – sélectionnez une action à effectuer sur les remplissages et les régions lorsque la distance qui les sépare du cuivre exposé, des ouvertures du masque de soudure et des trous est inférieure à Silkscreen Clearance :
    • None – les remplissages et les régions restent inchangés.
    • Clip – les remplissages et les régions seront découpés pour respecter Silkscreen Clearance. Les remplissages sont convertis en régions si nécessaire.
    • Move – les remplissages et les régions seront éloignés du cuivre exposé, des ouvertures du masque de soudure et des trous. Le déplacement est limité par la valeur Max Distance.
  • Max Distance – définissez la distance maximale de déplacement des chaînes de texte, des repères de composants, des remplissages et des régions permettant de respecter Silkscreen Clearance.

Cliquez sur OK pour découper et/ou déplacer les objets de sérigraphie conformément aux paramètres de la boîte de dialogue.

Si une action ne peut pas être effectuée sur un objet (par exemple, si une chaîne de texte ne peut pas être déplacée en raison de la limite imposée par Max Distance), un message concernant cet objet apparaîtra dans le panneau Messages.

Un exemple du résultat obtenu avec l’outil de préparation de la sérigraphie est présenté ci-dessous.

Javascript

Création d’une empreinte à l’aide de l’assistant d’empreintes conformes à l’IPC

Le IPC Compliant Footprint Wizard génère une empreinte de PCB entièrement conforme à la révision B de la norme IPC 7351 - Generic Requirements for Surface Mount Design and Land Pattern Standard. Plutôt que de travailler directement à partir des dimensions de l’empreinte (comme le fait l’assistant d’empreintes), le IPC Compliant Footprint Wizard utilise les dimensions du composant lui-même, puis calcule les propriétés appropriées des pastilles et les autres propriétés de l’empreinte conformément aux algorithmes publiés par l’IPC.

Au lieu de vous demander de saisir les propriétés des pastilles et des pistes utilisées pour définir l’empreinte, le Wizard utilise les dimensions réelles du composant comme données d’entrée. À partir des formules élaborées pour la norme IPC-7351, le Wizard génère ensuite l’empreinte à l’aide d’objets standard d’Altium Designer, tels que des pastilles et des pistes.

  • Cette boîte de dialogue est conforme à la révision B de la norme IPC 7351 - Exigences générales pour la conception de montage en surface et norme relative aux empreintes. La norme IPC-7351B a été publiée en 2010 et remplace la norme IPC-7351A (publiée en 2007).

  • Pour accéder au IPC Compliant Footprint Wizard dans Altium Designer, l’extension logicielle IPC Footprint Generator doit être installée. Cette extension est installée par défaut avec Altium Designer. Elle peut être installée ou supprimée manuellement.

    Pour plus d’informations sur la gestion des extensions, consultez la page Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Pour lancer le IPC Compliant Footprint Wizard, sélectionnez Tools » IPC Compliant Footprint Wizard dans les menus principaux d’un document de bibliothèque PCB.

Sur la page Select Component Type, choisissez la famille de composants pour laquelle vous souhaitez créer une empreinte sur la page Select Component Type. La zone d’aperçu située à droite de l’assistant se met à jour dynamiquement pour afficher le composant actuellement sélectionné et indique également les types de boîtiers pouvant être générés. Le tableau suivant répertorie les types de composants et les boîtiers pris en charge par l’assistant.

Nom Description Boîtiers inclus
BGA Matrice de billes BGA, CGA
BQFP Boîtier plat quadrilatéral avec protections d’angle BQFP
CAPAE Condensateur électrolytique en aluminium CAPAE
CFP Boîtier plat céramique à deux rangées de broches — broches en aile de mouette coupées et formées CFP
Réseau de composants CMS Réseau de composants CMS Réseau de composants CMS
DFN Boîtier plat à deux côtés sans broches DFN
CHIP Composants CMS à 2 broches Condensateur, inductance, résistance
CQFP Boîtier plat quadrilatéral en céramique — broches en aile de mouette coupées et formées CQFP
DPAK Boîtier de transistor DPAK
LCC Boîtier de puce sans broches LCC
LGA Matrice de plages de contact LGA
MELF Composants MELF à 2 broches Diode, résistance
MOLDED Composants moulés à 2 broches Condensateur, inductance, diode
PLCC Boîtier de puce en plastique avec broches, carré — broches en J PLCC
PQFN Boîtier plat quadrilatéral sans broches, à contacts en retrait PQFN
PQFP Boîtier plat quadrilatéral en plastique PQFP, PQFP avec pastille exposée
PSON Boîtier de faible encombrement sans broches, à contacts en retrait PSON
QFN Boîtier plat quadrilatéral sans broches QFN, LLP
QFN-2ROW Boîtier plat quadrilatéral sans broches, à 2 rangées, carré QFN à double rangée
SODFL Diode de faible encombrement à broches plates SODFL
SOIC Boîtier de circuit intégré de faible encombrement, au pas de 1,27 mm — broches en aile de mouette SOIC, SOIC avec pastille exposée
SOJ Boîtier de faible encombrement — broches en J SOJ
SON Boîtier de faible encombrement sans broches SON, SON avec pastille exposée
SOP, TSOP Boîtier de faible encombrement — broches en aile de mouette SOP, TSOP, TSSOP
SOT143/343 Transistor de faible encombrement SOT143, SOT343
SOT223 Transistor de faible encombrement SOT223
SOT23 Transistor de faible encombrement 3 broches, 5 broches, 6 broches
SOT89 Transistor de faible encombrement SOT89
SOTFL Transistor de faible encombrement à broches plates 3 broches, 5 broches, 6 broches
BOBINÉ Inductance bobinée de précision à 2 broches Inductance

Les pages suivantes de l’assistant varient en fonction du type de composant sélectionné. Suivez les pages intuitives de l’assistant pour configurer l’empreinte du composant selon vos besoins. Quelques remarques sur l’utilisation du IPC Compliant Footprint Wizard :

  • Toutes les dimensions sont saisies dans l’assistant en unités métriques (mm).

  • Les dimensions hors tout du boîtier, les informations sur les broches, l’espacement entre les talons, les congés de soudure et les tolérances peuvent être saisis et immédiatement visualisés.

    La modification des tolérances IPC peut entraîner la création d’empreintes de PCB non conformes à l’IPC.

  • Les dimensions mécaniques, telles que celles de la zone d’encombrement, de l’assemblage et du corps du composant (3D), peuvent être saisies.

  • Le Wizard permet de revenir aux étapes précédentes pour faciliter la vérification et les ajustements.

  • Des aperçus de l’empreinte sont affichés à chaque étape. Pour chaque type de composant, la Preview zone se met à jour dynamiquement pour afficher la nouvelle position, les nouvelles dimensions, etc., pour plusieurs paramètres. Dans la zone Preview , vous pouvez cliquer sur  ou  pour basculer entre les aperçus 2D et 3D.

  • Si vous le souhaitez, vous pouvez afficher un aperçu du modèle STEP 3D avant de le générer. Cliquez sur Generate STEP Model Preview sur n’importe quelle page du Wizard après avoir sélectionné le type de composant pour afficher un aperçu du modèle STEP 3D dans la zone Preview.

  • Les ouvertures du masque de pâte à braser sont divisées en petites zones de remplissage pour les boîtiers dotés d’une grande plage thermique (de dimensions supérieures ou égales à 2,1 mm x 1,6 mm).

  • Pour les boîtiers à broches en aile de mouette, les pastilles sont raccourcies afin d’éviter qu’elles ne s’étendent sous le corps du boîtier.

  • Pour les petits boîtiers dotés d’une grande plage thermique centrale, les pastilles périphériques sont raccourcies pour garantir l’espacement requis entre les pastilles, conformément à la norme IPC.

  • Lorsque les pastilles sont raccourcies, un avertissement s’affiche dans la boîte de dialogue.

  • Le nom et la description de l’empreinte sont automatiquement proposés en fonction des informations que vous saisissez dans le Wizard , mais peuvent être modifiés pour répondre aux exigences de votre organisation.

  • Conformément à la norme IPC, l’assistant prend en charge trois variantes d’empreinte (_L, _N, _M), chacune adaptée à une densité de carte différente.

  • Vous pouvez cliquer sur le bouton Finish à n’importe quelle étape pour générer l’empreinte actuellement affichée dans l’aperçu. Si vous cliquez sur Finish avant d’avoir terminé l’ensemble du Wizard, l’empreinte sera créée avec les valeurs par défaut du système pour le type de composant sélectionné.

  • Lorsque vous travaillez avec une bibliothèque d’empreintes PCB basée sur un fichier, utilisez le générateur par lots d’empreintes conformes à la norme IPC pour générer rapidement plusieurs empreintes, à différents niveaux de densité.

Lorsque l’assistant est ouvert depuis une bibliothèque d’empreintes PCB basée sur un fichier, la page Footprint Destination est disponible et vous permet de sélectionner l’emplacement où enregistrer l’empreinte nouvellement créée – afficher l’image :

  • Sélectionnez Existing PcbLib File si vous souhaitez enregistrer l’empreinte dans un fichier de bibliothèque PCB existant. Vous pouvez saisir directement le fichier dans la zone de texte ou utiliser le  pour ouvrir une boîte de dialogue et rechercher le fichier souhaité.
  • Sélectionnez New PcbLib File si vous souhaitez enregistrer l’empreinte dans un nouveau fichier de bibliothèque PCB. Saisissez le nom du nouveau fichier de bibliothèque PCB dans la zone de texte. Le système ajoutera l’extension .PcbLib au nom du nouveau fichier de bibliothèque.
  • Sélectionnez Current PcbLib File pour enregistrer l’empreinte dans le fichier de bibliothèque PCB affiché.
  • Activez Produce 3D/STEP model pour générer un modèle STEP 3D.
  • Si vous disposez d’une licence « MCAD Co-Designer - SOLIDWORKS(R) » valide, vous pouvez choisir d’enregistrer le modèle au format de fichier Parasolid. Cliquez sur la liste déroulante à droite de Format puis sélectionnez Parasolid. Le fichier affiché dans la zone de texte External File est désormais un fichier *.x_t. Il s’agit du nom et de l’emplacement du fichier qui sera enregistré.
  • Sélectionnez Embedded (par défaut) ou External File. Sélectionnez External File pour enregistrer votre modèle STEP 3D dans un fichier externe. Le format de fichier par défaut est STEP et le nom du fichier apparaît dans la zone de texte External File avec *.step comme extension. Si vous le souhaitez, cliquez sur  pour parcourir les dossiers et sélectionner celui dans lequel enregistrer le modèle STEP 3D généré.

Création d’une empreinte à l’aide de l’assistant d’empreintes

L’éditeur d’empreintes PCB comprend un Footprint Wizard. Ce Wizard vous permet de choisir parmi différents types de boîtiers et de renseigner les informations appropriées ; il crée ensuite l’empreinte du composant pour vous. Notez que dans le Footprint Wizard, vous saisissez les dimensions requises pour les pastilles et la sérigraphie du composant.

Pour lancer le Footprint Wizard, sélectionnez Tools » Footprint Wizard dans les menus principaux ou faites un clic droit dans l’espace de conception et choisissez la commande Tools » Footprint Wizard dans le menu contextuel.

Utilisez la page Component patterns pour spécifier la configuration du composant que vous souhaitez créer. Sélectionnez la configuration souhaitée dans la liste, puis utilisez la liste déroulante pour sélectionner l’unité du composant (Imperial (mil) ou Metric (mm)). Les configurations disponibles sont :

  • Ball Grid Arrays (BGA)
  • Capacitors
  • Diodes
  • Dual In-line Packages (DIP)
  • Edge Connectors
  • Leadless Chip Carriers (LCC)
  • Pin Grid Arrays (PGA)
  • Quad Packs (QUAD)
  • Resistors
  • Small Outline Packages (SOP)
  • Staggered Ball Grid Arrays (SBGA)
  • Staggered Pin Grid Arrays (SPGA)

Les pages suivantes de l’assistant varient selon la configuration du composant sélectionnée. Suivez les pages intuitives de l’assistant pour configurer l’empreinte du composant selon vos besoins.

Lorsque vous définissez le style de nommage des pastilles pour une empreinte de configuration Edge Connectors, Leadless Chip Carriers (LCC) ou Quad Packs (QUAD), cliquez sur la flèche verte pour modifier l’ordre ou le sens du nommage – afficher l’image.

Génération d’un rapport de composant

Pour générer un rapport sur l’empreinte PCB active, choisissez la commande Reports » Component dans les menus principaux. Après le lancement de la commande, le rapport est généré (<PCBLibraryDocumentName>.CMP) dans le même dossier que le document de bibliothèque PCB source et s’ouvre automatiquement en tant que document actif dans la fenêtre principale de conception. Le rapport répertorie notamment les dimensions de l’empreinte ainsi que le détail des objets primitifs qui la constituent et les couches sur lesquelles ils se trouvent.

Le rapport est ajouté au panneau Projects en tant que document libre dans le sous-dossier Documentation\Text Documents.

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Nav
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents