Defining the Wiring Diagram

Les connexions filaires individuelles au sein du faisceau sont spécifiées dans le schéma de câblage du faisceau (*.WirDoc). Ajoutez ce document au projet de faisceau depuis le panneau Projects en cliquant avec le bouton droit sur l’entrée du projet, puis en sélectionnant Add New to Project » Harness Wiring Diagram dans le menu contextuel (ou utilisez la commande File » New » Harness Wiring Diagram depuis les menus principaux).

Configuration d’un document de schéma de câblage de faisceau

Les options d’un document de schéma de câblage de faisceau peuvent être configurées dans le panneau Properties lorsqu’aucun objet n’est sélectionné dans l’espace de conception du document. Les principaux paramètres sont les suivants :

  • Dans la région General de l’onglet General du panneau – sélectionnez les unités de mesure applicables au document et à ses éléments graphiques, et définissez les grilles pour faciliter le placement. Altium Designer propose trois types de grille : une grille visible pour la navigation, une grille d’accrochage pour le placement, et une distance d’accrochage pour aider à la création des connexions.

  • Dans la région Page Options de l’onglet General du panneau – configurez la taille de la feuille du document et le cartouche, ou sélectionnez parmi les modèles disponibles de schéma de câblage de faisceau.

Les onglets General et Parameters du panneau Properties lorsqu’aucun objet n’est sélectionné dans le document de schéma de câblage de faisceau 
Les onglets General et Parameters du panneau Properties lorsqu’aucun objet n’est sélectionné dans le document de schéma de câblage de faisceau

  • La configuration d’un document de schéma de câblage de faisceau est similaire à celle d’un document schématique (*.SchDoc) d’un projet de conception de PCB. Reportez-vous à la page Configuration d’un document schématique pour en savoir plus.

  • Utilisez la liste déroulante Length Units pour choisir les unités de longueur du document. Les valeurs Strip Length et Pull Off Length des cavités de connecteur seront affichées à l’aide des unités sélectionnées. Les unités prises en charge sont mm, cm, m, in et ft. Les unités de longueur par défaut des nouveaux documents de schéma de câblage peuvent être définies sur la page Harness Design – General de la boîte de dialogue Preferences.

  • Pour en savoir plus sur la création de modèles de documents de câblage de faisceau, reportez-vous à la page Creating Harness Template Documents.

  • Les propriétés par défaut des objets de schéma de câblage de faisceau peuvent être configurées sur la page Harness Design – Defaults de la boîte de dialogue Preferences. Ces propriétés seront appliquées lors du placement des objets suivants.

  • Lors de la création d’un document de schéma de câblage de faisceau, vous pouvez également utiliser des objets de texte et de dessin. L’utilisation de ces objets dans un document de schéma de câblage de faisceau est similaire à leur utilisation dans un document schématique (*.SchDoc) d’un projet de conception de PCB. Reportez-vous à Working with Text Objects on a Schematic et Working with Drawing Objects on a Schematic pour en savoir plus sur ces objets.

    • Notez que les liens actifs vers les objets du schéma de câblage de faisceau (par ex., fils et composants) et les objets du dessin d’implantation de faisceau (par ex., torons et points de connexion) sont également pris en charge dans les cadres de texte et les notes. Cliquez sur un lien dans le cadre de texte ou la note placée pour effectuer une sonde croisée vers cet objet dans le document associé.

  • Pour vérifier votre schéma de câblage de faisceau quant aux violations logiques, électriques et de mise en plan, un certain nombre de contrôles de violation sont pris en charge. Reportez-vous à la page Validating the Harness Design pour en savoir plus.

  • Un document de schéma de câblage de faisceau peut être enregistré au format ASCII, ce qui peut être utile lors du partage. Utilisez la commande File » Save As et sélectionnez Harness Wiring ascii (*.WirDoc) dans la liste déroulante Save as type de la boîte de dialogue Save As qui s’ouvre. Lors de l’enregistrement d’un schéma de câblage ASCII à l’aide de la commande File » Save, la boîte de dialogue File Format s’ouvrira pour vous avertir que le format ASCII est utilisé. Choisissez la version ASCII dans la boîte de dialogue  pour continuer à utiliser ce format.

Synchronisation des projets multi-cartes et de faisceau

 
 
 
 
 

Lorsque le projet de faisceau fait partie d’un projet de conception multi-cartes, le schéma de câblage de faisceau peut être synchronisé à partir des données du document schématique multi-cartes (*.MbsDoc). Pour ce faire, sélectionnez la commande Design » Import Changes From <Multi-board Project> dans les menus principaux.

Pour en savoir plus sur l’ajout d’un projet de conception de faisceau à un projet multi-cartes, reportez-vous à la page Harness Design.

Si le document schématique multi-cartes contient plus d’une définition de connexion de faisceau, la boîte de dialogue Select Harness Definition s’ouvrira. Spécifiez la définition liée au projet de faisceau en cours.

La boîte de dialogue Select Harness Definition
La boîte de dialogue Select Harness Definition

La boîte de dialogue Engineering Change Order s’ouvrira ensuite en affichant les composants connecteurs de faisceau et les nets de faisceau définis dans le schématique multi-cartes, qui constitueront la base du schéma de câblage de faisceau.

Utilisez la boîte de dialogue Engineering Change Order pour importer les données du projet multi-cartes. 
Utilisez la boîte de dialogue Engineering Change Order pour importer les données du projet multi-cartes. 

Après exécution des modifications (), les données du document schématique multi-cartes sont importées dans le schéma de câblage de faisceau. Les composants connecteurs, chacun représenté par son symbole schématique, apparaîtront dans le document de schéma de câblage de faisceau, initialement à des positions arbitraires.

Exemple d’un schéma de câblage de faisceau juste après l’importation.
Exemple d’un schéma de câblage de faisceau juste après l’importation.

Des lignes de net seront affichées entre les broches pour représenter les connexions logiques définies dans le schématique multi-cartes. Notez qu’à ce stade, il n’y a pas de fils physiques dans la conception.

Notez que les données de connectivité importées du projet multi-cartes vers le projet de faisceau reposent sur les noms de broche des composants connecteurs ; assurez-vous donc que des noms uniques et corrects sont attribués aux broches des composants dans la bibliothèque source avant l’importation des données.

Utilisation des composants

En plus de la synchronisation depuis le document schématique multi-cartes, les composants peuvent également être placés manuellement dans le schéma de câblage de faisceau. Cela permet de placer des composants dans un projet de faisceau autonome (c’est-à-dire ne faisant pas partie d’un projet multi-cartes), mais aussi d’ajouter des composants supplémentaires dans un schéma de câblage de faisceau faisant partie d’un projet multi-cartes.

Utilisez le panneau Components pour placer les symboles des composants requis. Le processus de placement des composants est similaire à celui de l’éditeur Schématique – reportez-vous à la page Searching for & Placing Components pour en savoir plus. Notez qu’il n’y aura pas de lignes de net pour les composants ajoutés manuellement, car il n’existe aucune conception logique de niveau supérieur pour les piloter.

  • Les composants sont placés à partir des bibliothèques disponibles et représentés par leurs modèles de symbole schématique dans un schéma de câblage de faisceau. Reportez-vous à la page Building & Maintaining Your Components and Libraries pour en savoir plus sur la création de composants.

  • Les composants multiparties peuvent également être placés dans un schéma de câblage de faisceau. Lorsque les données de conception sont importées dans le dessin d’implantation de faisceau, les désignateurs sont correctement attribués aux composants dans le dessin d’implantation de faisceau. Si plusieurs parties d’un même composant sont placées sur le schéma de câblage de faisceau, une seule instance du composant est placée sur le dessin d’implantation de faisceau ().

  • Les connecteurs de faisceau peuvent être utilisés pour réaliser des connexions entre plusieurs projets multi-cartes dans une configuration imbriquée.

  • Lors du collage de composants de faisceau coupés/copïés sur un schéma de câblage de faisceau, les désignateurs des composants collés respectent l’option Reset Parts Designators On Paste de la page Schematic – Graphical Editing de la boîte de dialogue Preferences. Lorsque les composants sont collés, la partie numérique de leurs désignateurs sera réinitialisée à ? si l’option est activée.

Pour déplacer un composant placé (ou un composant en cours de placement depuis le panneau Components) vers la position souhaitée, cliquez dessus et maintenez le bouton gauche de la souris enfoncé, puis déplacez la souris. Pendant le glissement, utilisez la touche Spacebar pour faire pivoter les composants de 90 degrés, et les touches X et Y pour les retourner horizontalement et verticalement, respectivement.

Le schéma de câblage de faisceau après déplacement des composants
Le schéma de câblage de faisceau après déplacement des composants

Les propriétés d’un composant placé peuvent être configurées dans le panneau Properties lorsque le composant est sélectionné dans l’espace de conception. Le panneau Properties d’un composant comprend les onglets suivants :

 
 
 
 
 
  • General – propriétés générales du composant, telles que le désignateur et le commentaire, l’emplacement, les paramètres, etc.

  • Pins – la liste des broches du composant.

  • Cavities – permet d’affecter des cavités de connecteur au composant (en savoir plus).

  • Associated Parts – permet d’affecter des pièces supplémentaires, telles que la gaine thermorétractable, au composant.

Onglets du panneau Properties lorsqu’un composant est sélectionné
Onglets du panneau Properties lorsqu’un composant est sélectionné

Affectation des cavités de connecteur

 
 
 
 
 

Des cavités de connecteur et leur type peuvent être affectés à un composant de faisceau. Sélectionnez un composant dans l’espace de conception pour ajouter une cavité et un type. Sélectionnez une broche dans l’onglet Cavities du panneau Properties , puis cliquez sur le bouton . Sélectionnez le type souhaité dans la liste déroulante. Les types de cavité suivants sont pris en charge :

  • Crimp – utilisé pour assurer une connexion électrique en comprimant un fût de contact autour d’un conducteur.

  • Seal – utilisé pour assurer une protection environnementale en scellant le point d’entrée du fil.

  • Plug – utilisé pour remplir une cavité de connecteur ouverte (inutilisée) afin de maintenir l’intégrité du joint d’étanchéité environnemental.

  • Other – utilisé pour spécifier d’autres pièces ou matériaux supplémentaires, par ex. de la soudure.

Pour le type de cavité Crimp ou les lignes auxquelles aucun type de cavité n’a été ajouté, vous pouvez spécifier les valeurs suivantes :

  • Strip Length – la longueur à laquelle l’isolant est coupé du conducteur.

  • Pull Off Length – la longueur à laquelle l’isolant coupé est tiré hors du conducteur. Cela peut être utilisé dans les cas où l’extrémité du fil n’est pas complètement dénudée et où la partie d’isolant retirée est conservée sur le fil afin d’éviter d’endommager le brin.

Les unités dans lesquelles ces valeurs sont affichées dans le panneau Properties lorsqu’un composant est sélectionné sont spécifiées à l’aide de la liste déroulante Length Units de l’onglet General du panneau Properties lorsqu’aucun objet n’est sélectionné dans le document.

Dans la boîte de dialogue Select Connector qui s’ouvre, recherchez et sélectionnez le composant souhaité. Le type spécifique et les informations pertinentes seront ajoutés à la broche dans l’onglet, comme indiqué dans les images ci-dessous pour l’ajout d’un sertissage à la broche 1.

Notez que les broches sont présentées dans le tableau de l’onglet Cavities par leurs noms (colonne Pins) et que l’affectation de cavité repose sur les noms de broche ; assurez-vous donc que des noms uniques et corrects sont attribués aux broches du composant.

Pour un sertissage, un joint ou un bouchon, une seule cavité d’un type donné peut être ajoutée à une broche. Une fois qu’une cavité d’un type particulier a été ajoutée, l’entrée n’est plus disponible (grisée) dans la liste déroulante. N’importe quel nombre de cavités du type Other peut être ajouté à une broche.

Les broches auxquelles des sertissages sont affectés sont indiquées par le symbole dans l’espace de conception, comme illustré dans l’image ci-dessous.

La région de grille de l’onglet Cavities prend en charge la sélection multiple ainsi que les opérations copier/coller/supprimer pour les entrées sélectionnées.

  • Plusieurs entrées de broche peuvent être sélectionnées à l’aide des raccourcis Click, Hold&DragCtrl+ClickShift+Click et Ctrl+A.

  • Lorsque plusieurs entrées de broche sont sélectionnées, cliquez sur   pour ajouter une cavité à toutes les broches sélectionnées, ou cliquez sur  ou appuyez sur Delete pour supprimer les cavités ajoutées des broches sélectionnées. 

  • Pour modifier la cavité d’une broche, sélectionnez son entrée, puis cliquez sur  pour ouvrir la boîte de dialogue Select Connector afin de sélectionner la nouvelle cavité.

  • Sélectionnez une ou plusieurs entrées de broche et utilisez les raccourcis Ctrl+X/Ctrl+C pour couper/copier les entrées sélectionnées, puis utilisez le raccourci Ctrl+V pour coller le contenu coupé/copié sur l’entrée actuellement sélectionnée.

Création de la connectivité dans le schéma de câblage du faisceau

Les fils physiques sont placés dans le document de schéma de câblage du faisceau en sélectionnant la commande Place » Harness Wire dans les menus principaux (raccourci : Shift+W).

Après avoir sélectionné la commande, cliquez sur une broche d’un connecteur (une croix rouge apparaît au curseur lorsqu’il survole la zone active d’une broche) pour placer le point de départ du fil du faisceau. Positionnez le curseur et cliquez pour ancrer une série de sommets qui définissent la forme du fil du faisceau. Après avoir placé le dernier sommet sur la zone active d’une autre broche, cliquez avec le bouton droit pour terminer le placement.

Lors du placement d’un fil de faisceau, appuyez sur Shift+Spacebar pour parcourir les modes de placement. Le mode spécifie la façon dont les angles sont créés lors du placement des fils et les angles selon lesquels les fils peuvent être placés. En mode 90 Degree ou 45 Degree (modes véritablement orthogonaux), appuyez sur Spacebar pour alterner entre les sous-modes début et fin. Le mode et le sous-mode actuels sont affichés dans la barre d’état.

Lors du placement d’un fil de faisceau, les lignes de réseau effectuent un suivi/rafraîchissement « en direct », vous montrant en temps réel où câbler, comme illustré dans la vidéo ci-dessous. Une fois une connexion terminée, sa ligne de réseau disparaît du document.

Démonstration de la fonction de tracé en direct

Une fois placé et sélectionné, les sommets d’un fil de faisceau peuvent être déplacés pour modifier l’angle entre deux segments adjacents (Show example).

Sélectionnez un fil de faisceau dans l’espace de conception pour le modifier dans le panneau Properties. Depuis ce panneau, vous pouvez renommer le fil de faisceau sélectionné, modifier sa largeur et sa couleur, et ajouter des paramètres qui peuvent être affichés ou masqués dans l’espace de conception.

Le panneau Properties lorsqu’un fil de faisceau est sélectionné
Le panneau Properties lorsqu’un fil de faisceau est sélectionné

  • Un fil de faisceau placé peut être remplacé par un composant de câblage de faisceau comprenant un seul fil. Pour ce faire, sélectionnez le fil de faisceau à remplacer et cliquez sur le bouton  à droite du champ Design Item ID dans le panneau Properties. Dans la boîte de dialogue Replace Component qui s’ouvre, recherchez et sélectionnez le composant requis. Le fil placé sera mis à jour avec les propriétés et paramètres du composant choisi tout en conservant sa géométrie inchangée. Reportez-vous à la section Placing a Harness Wiring Component pour en savoir plus.

  • La couleur principale d’un fil est définie par le paramètre Color, qui est présenté par défaut dans un fil de faisceau placé. Pour modifier la couleur, saisissez son nom (par ex., Red) ou son code hexadécimal (en saisissant le caractère # suivi du nombre hexadécimal, par ex., #9900FF) comme valeur du paramètre. Vous pouvez également cliquer sur le bouton de couleur à gauche de la valeur du paramètre et utiliser le sélecteur de couleur qui s’ouvre, où la couleur du fil peut être spécifiée par valeur RVB ou HEX, par sélection libre ou à partir d’une gamme de préréglages.

  • Les fils de faisceau multicolores sont pris en charge dans le schéma de câblage du faisceau en choisissant les couleurs secondaire et tertiaire d’un fil. Dans le panneau Properties, cliquez sur la liste déroulante   en bas de la zone Parameters , puis choisissez Secondary et Tertiary pour définir les couleurs souhaitées ; le paramètre correspondant à la couleur choisie apparaîtra dans la zone Parameters . Vous pouvez également définir la couleur de bordure du fil de faisceau à l’aide de la même liste déroulante, puis en sélectionnant Border. Notez que le paramètre Color contrôle la visibilité de la valeur combinée des paramètres de fil définis Color, Secondary Color et Tertiary Color. Cliquez dans le diaporama ci-dessous pour voir des exemples.

    Javascript ID: Harness_WD_Pnl_Properties_Wire_Colors_AD25

    Un fil avec uniquement la couleur principale définie

    Un fil avec la couleur secondaire définie

    Un fil avec la couleur tertiaire définie

    Un fil avec la couleur de bordure définie

    Un fil avec toutes les options de couleur définies

    Les fils multicolores sont également pris en charge par les tableaux dans les documents de plan de fabrication de conception de faisceau (*.HarDwf) – en savoir plus.

  • Si un fil de faisceau a la valeur No pour son paramètre Include Cut, ce fil ne sera pas présenté dans une liste de câblage ni dans une table de connexion du plan de fabrication.

  • Les paramètres Color, Min. Bending Radius, Thickness et Units d’un fil de faisceau sont utilisés lors de la synchronisation d’un projet de conception de faisceau avec un outil MCAD à l’aide de MCAD CoDesigner. Reportez-vous à la page Synchronizing a Harness Design Project pour en savoir plus.

Ajout d’épissures et de dérivations

Dans les situations de conception où un nouveau fil doit être connecté à un fil déjà placé, un objet d’épissure (Place » Splice) ou de dérivation (Place » Tap) doit d’abord être placé.

  • Splice – le fil d’origine est divisé en deux fils distincts par l’épissure.

    Javascript ID: Harness_WD_PlacingSplice_AD25

    Un autre fil doit être connecté au fil sélectionné (W4).

    Une épissure placée sur le fil. Notez que l’épissure divise le fil d’origine en deux à l’emplacement de l’épissure.

    Un autre fil a été connecté à l’épissure.

    Lorsque deux fils sont connectés en forme de T, une épissure est placée automatiquement à l’emplacement de la jonction en T (Show example).

  • Tap – le fil d’origine reste intact.

    Javascript ID: Harness_WD_PlacingTap_AD25

    Un autre fil doit être connecté au fil sélectionné (W4).

    Une dérivation placée sur le fil. Notez que la dérivation ne divise pas le fil d’origine.

    Un autre fil a été connecté à la dérivation.

Les propriétés d’une épissure ou dérivation placée (son emplacement et sa représentation visuelle) peuvent être configurées dans le panneau Properties lorsque l’objet est sélectionné dans l’espace de conception.

Le panneau Properties lorsqu’une épissure/dérivation est sélectionnée
Le panneau Properties lorsqu’une épissure/dérivation est sélectionnée

La zone Associated Parts du panneau Properties permet d’affecter des composants à l’épissure/dérivation sélectionnée, et ce composant sera répercuté dans la nomenclature du projet.

Ajout de câbles

Pour définir un ou plusieurs fils comme ajoutés à un câble, vous pouvez placer un objet câble sur le schéma de câblage du faisceau (Place » Harness Cable).

Placez un câble pour définir un ou plusieurs fils comme ajoutés à un câble.
Placez un câble pour définir un ou plusieurs fils comme ajoutés à un câble.

Lorsqu’un objet câble est sélectionné, les fils couverts par ce câble sont mis en surbrillance en vert néon dans l’espace de conception ().

Les propriétés d’un objet câble placé (son emplacement, sa représentation visuelle et ses paramètres) peuvent être configurées dans le panneau Properties lorsque l’objet est sélectionné dans l’espace de conception.

 
 
 
 
 

Le panneau Properties lorsqu’un câble est sélectionné
Le panneau Properties lorsqu’un câble est sélectionné

Un câble a un rapport d’aspect fixe de 2:1 pendant le placement ou l’édition graphique, la taille finale de placement étant déterminée par la valeur actuelle de la grille d’accrochage du document.

  • Si un câble est associé à des fils à plusieurs endroits du schéma de câblage du faisceau (c.-à-d. lorsque plusieurs objets câble portant le même désignateur sont placés sur différents fils), la sélection d’un objet mettra en surbrillance tous les fils associés du groupe, et tous ces fils seront listés dans la zone Cable Objects du panneau Properties ().

  • Les paramètres Color, Min. Bending Radius, Thickness et Units d’un câble sont utilisés lors de la synchronisation d’un projet de conception de faisceau avec un outil MCAD à l’aide de MCAD CoDesigner. Reportez-vous à la page Synchronizing a Harness Design Project pour en savoir plus.

Blindage et torsadage des fils

Un blindage (avec ou sans connexion, telle qu’une connexion de fil de drain) peut être attaché à un groupe de fils en plaçant soit un blindage (Place » Shield) , soit un objet blindage avec connexion (Place » Shield with Connection).

Dans l’exemple ci-dessous, les fils W1, W2 et W3 sont blindés par un blindage sans connexion (SH1), et les fils W4, W8 et W9 sont blindés par un blindage avec connexion (SH2). Le fil W10 est placé pour connecter SH2 à une broche de composant.

Placez un objet blindage ou blindage avec connexion pour indiquer que des fils sont blindés.
Placez un objet blindage ou blindage avec connexion pour indiquer que des fils sont blindés.

Lorsqu’un objet blindage ou blindage avec connexion est sélectionné, les fils couverts sont mis en surbrillance en vert néon dans l’espace de conception ().

Les propriétés d’un objet blindage ou blindage avec connexion placé (emplacement et représentation visuelle) peuvent être configurées dans le panneau Properties lorsque l’objet est sélectionné dans l’espace de conception. La zone Shield Objects du panneau répertorie les fils couverts par l’objet sélectionné.

 
 
 
 
 

Le panneau Properties lorsqu’un blindage est sélectionné
Le panneau Properties lorsqu’un blindage est sélectionné

  • Un blindage a un rapport d’aspect fixe de 2:1 pendant le placement ou l’édition graphique, la taille finale de placement étant déterminée par la valeur actuelle de la grille d’accrochage du document. 

  • Si un blindage est associé à des fils à plusieurs endroits du schéma de câblage du faisceau (c.-à-d. lorsque plusieurs objets blindage portant le même désignateur sont placés sur différents fils), la sélection d’un objet mettra en surbrillance tous les fils associés du groupe, et tous ces fils seront listés dans la zone Shield Objects du panneau Properties ().

Des fils peuvent être indiqués comme torsadés ensemble en plaçant une torsade (Place » Twist). Une torsade peut être placée sur deux fils ou plus.

Dans l’exemple ci-dessous, les fils W1 et W2 sont indiqués comme torsadés ensemble avec la torsade Tw1.

Placez un objet torsade pour indiquer que des fils sont torsadés ensemble.
Placez un objet torsade pour indiquer que des fils sont torsadés ensemble.

Lorsqu’une torsade est sélectionnée, les fils couverts sont mis en surbrillance en vert néon dans l’espace de conception ().

Les propriétés d’une torsade placée (son emplacement et sa représentation visuelle) peuvent être configurées dans le panneau Properties lorsque l’objet est sélectionné dans l’espace de conception. La zone Twist Objects du panneau répertorie les fils couverts par la torsade sélectionnée.

 
 
 
 
 

Le panneau Properties lorsqu’une torsade est sélectionnée
Le panneau Properties lorsqu’une torsade est sélectionnée

  • Une torsade a un rapport d’aspect fixe de 1:1 pendant le placement ou l’édition graphique, la taille finale de placement étant déterminée par la valeur actuelle de la grille d’accrochage du document. 

  • Si une torsade est associée à des fils à plusieurs endroits du schéma de câblage du faisceau (c.-à-d. lorsque plusieurs objets torsade portant le même désignateur sont placés sur différents fils), la sélection d’un objet mettra en surbrillance tous les fils associés du groupe, et tous ces fils seront listés dans la zone Twist Objects du panneau Properties ().

  • Le paramètre Twists per Unit Length et les paramètres Thickness d’une torsade sont utilisés lors de la synchronisation d’un projet de conception de faisceau avec un outil MCAD à l’aide de MCAD CoDesigner. Reportez-vous à la page Synchronizing a Harness Design Project pour en savoir plus.

Fils non connectés

Les extrémités de fil non connectées sont indiquées par un carré plein.

Un fil non connecté indiqué
Un fil non connecté indiqué

Une extrémité de fil ne doit pas être laissée non connectée. Si la conception nécessite une extrémité de fil non connectée, un objet « no connect » doit être placé à l’extrémité (Place » No Connect).

Placez un objet « no connect » à l’extrémité d’un fil qui doit rester non connecté.
Placez un objet « no connect » à l’extrémité d’un fil qui doit rester non connecté.

Les propriétés d’un objet « no connect » placé (son emplacement et sa représentation visuelle) peuvent être configurées dans le panneau Properties lorsque l’objet est sélectionné dans l’espace de conception.

Le panneau Properties lorsqu’un objet « no connect » est sélectionné
Le panneau Properties lorsqu’un objet « no connect » est sélectionné

Utilisation de plusieurs feuilles

Un schéma de câblage de faisceau complet peut être défini sur plusieurs feuilles (dans une approche de conception « plate », où toutes les feuilles existent au même niveau), chacune étant représentée par son propre document *.WirDoc. La connectivité est créée directement de n’importe quelle feuille vers n’importe quelle autre feuille à l’aide d’objets de rupture de fil (Place » Wire Break) portant le même désignateur de fil.

Après avoir sélectionné la commande de placement de rupture de fil, positionnez l’objet de sorte que son point d’accroche électrique (l’extrémité tenue par le curseur) touche le fil auquel vous souhaitez vous connecter, puis cliquez ou appuyez sur Enter pour effectuer le placement. Une rupture de fil placée hérite des propriétés (désignateur et couleur) du fil auquel elle est connectée.

Sélectionnez une rupture de fil dans l’espace de conception pour la modifier dans le panneau Properties. Depuis le panneau, vous pouvez définir le désignateur du fil auquel elle est connectée ainsi que son style : direction (Left ou Right) et couleur.

Synchronisation des fils

Les fils de faisceau connectés par une rupture de fil sont reconnus même s’ils ont des ID d’élément de conception différents. De plus, tous les segments de fil portant le même désignateur et connectés par la même rupture de fil sont comparés (référence, commentaire, couleur et tous les paramètres). Si des différences sont détectées, la violation Mismatched parameters in connected wire segments est signalée. Un avertissement apparaît également dans le panneau Properties du fil et de la rupture de fil, indiquant qu’un conflit a été détecté entre les paramètres. Cliquez sur Synchronize dans l’avertissement pour ouvrir la boîte de dialogue Conflict Wire Parameters, qui vous permet de choisir quels paramètres utiliser pour le segment de fil.

Propriétés et paramètres du fil avant synchronisation

Un avertissement apparaît dans le panneau Properties , indiquant qu’il existe un conflit entre les paramètres. Après avoir cliqué sur Synchronize dans l’avertissement, la boîte de dialogue Confirm Wire Parameters s’ouvre. Sélectionnez l’option souhaitée puis cliquez sur OK pour effectuer la synchronisation.

La violation Mismatched parameters in connected wire segments dans la boîte de dialogue Project Options

Après la synchronisation, les propriétés des segments de fil ont été synchronisées. 

 
  • Notez que lorsque vous modifiez la couleur et le désignateur d’une rupture de fil, la couleur et le désignateur du fil auquel la rupture de fil est connectée sont modifiés en conséquence ; et inversement, lorsque vous modifiez la couleur et le désignateur d’un fil, la couleur et le désignateur de la rupture de fil connectée au fil sont modifiés en conséquence.

  • Vous pouvez également modifier les propriétés d’une rupture de fil en cours de placement en appuyant sur Tab après avoir sélectionné la commande de placement. Notez que si un désignateur est défini pour la rupture de fil avant son placement, le fil auquel elle est connectée héritera du désignateur et de la couleur de la rupture de fil.

  • Si une couleur de bordure est définie pour un fil auquel une rupture de fil est connectée, cette rupture de fil sera également affichée avec une bordure de cette couleur. De plus, le désignateur de la rupture de fil sera affiché dans la couleur de bordure du fil connecté.

  • Les ruptures de fil n’ont pas de propriétés de police indépendantes ; elles utilisent les propriétés Document Font du document de schéma de câblage de faisceau sur lequel elles sont placées.

  • Les ruptures de fil peuvent également être utilisées pour créer une connectivité au sein de la même feuille de schéma de câblage de faisceau – par exemple, au lieu de placer un fil d’une broche de connecteur à une autre, vous pouvez placer un court fil de faisceau et une rupture de fil sur chacune de ces broches ().

Placement d’un composant de schéma de câblage de faisceau

Lorsque vous êtes connecté à votre Workspace, vous pouvez créer des composants avec une structure et des propriétés prédéfinies selon les besoins dans le Workspace connecté, puis réutiliser ces composants dans vos conceptions de faisceaux, en les plaçant directement dans les documents de schéma de câblage de faisceau.

Consultez la page Creating a Harness Wiring Component pour en savoir plus.

Ces composants (chacun avec un modèle de câblage de faisceau attribué) sont accessibles depuis le panneau Components panel. Lorsque le document de schéma de câblage de faisceau requis est le document actif dans l’espace de conception, placez un composant en cliquant avec le bouton droit sur son entrée dans le panneau et en sélectionnant la commande Place <ComponentName> dans le menu contextuel. Le comportement de placement d’un composant diffère selon que le composant inclut un seul objet fil ou une structure de câble (plusieurs fils et/ou des objets supplémentaires : câbles, blindages, etc.).

  • Single wire – lors du placement d’un composant qui inclut un seul objet fil, vous passez en mode de placement de fil de faisceau. Le fil en cours de placement héritera des propriétés définies lors de la création du composant. Reportez-vous à la section Creating Connectivity in the Harness Wiring Diagram ci-dessus pour en savoir plus sur le placement de fils de faisceau.

  • Cable structure – lors de la sélection de la commande de placement d’un composant qui inclut une structure de câble, cette structure de câble apparaît attachée au curseur exactement telle qu’elle a été définie lors de la création du composant. Cliquez à l’emplacement souhaité dans le document de schéma de câblage de faisceau pour placer le composant. Vous pouvez ensuite modifier individuellement les objets du composant, par exemple pour attacher les fils constituant le câble aux broches des connecteurs du faisceau.

Mise à jour du schéma de câblage à partir des bibliothèques

Les objets suivants peuvent être mis à jour depuis leur bibliothèque source du Workspace :

  • Composants de faisceau

  • Cavités des composants de faisceau

  • Pièces associées aux composants de faisceau

  • Fils

Lorsqu’un objet est sélectionné, les informations sur le composant Workspace lié se trouvent dans le panneau Properties (par exemple, l’onglet Associated Parts pour les pièces associées d’un composant de faisceau).

Si une révision plus récente du composant Workspace est disponible, l’entrée correspondant à l’état de la révision l’indiquera à l’aide du texte Out of date. Au niveau de l’objet individuel, le lien peut être mis à jour vers la dernière révision du composant Workspace en cliquant sur le bouton .

Exemple d’indication d’une révision obsolète d’un composant de faisceau
Exemple d’indication d’une révision obsolète d’un composant de faisceau

La fonctionnalité Update from Libraries (Tools » Update from Libraries) peut également être utilisée pour mettre à jour les composants obsolètes liés aux objets répertoriés ci-dessus. Notez que pour qu’un objet soit inclus dans la mise à jour à l’aide de la fonctionnalité Update from Libraries, un composant attribué à l’objet doit inclure un lien vers un symbole schématique.

Annotation des objets de schéma de câblage de faisceau

Utilisez les commandes du menu Tools » Annotation pour annoter les objets suivants dans le document de schéma de câblage de faisceau :

  • Composants de faisceau

  • Fils

  • Épissures et dérivations

  • Câbles

  • Blindages et blindages avec connexion

  • Torsades

  • Objets « non connecté »

L’annotation des objets dans un document de schéma de câblage de faisceau est similaire à l’annotation des composants dans un document schématique (*.SchDoc) d’un projet de conception de PCB. Utilisez les liens suivants pour en savoir plus sur les commandes d’annotation disponibles pour un document de schéma de câblage de faisceau :

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contenu