Numérotation de vos feuilles de schéma
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
En un coup d'œil
- Découvrez où accéder aux outils de numérotation des feuilles, comment modifier SheetNumber, DocumentNumber et SheetTotal, et dans quels cas activer ou désactiver la numérotation automatique.
- Comprenez la différence entre la numérotation des feuilles de schéma logiques et l’annotation des instances de feuilles compilées, notamment la manière dont chacune est stockée et affichée.
- Découvrez comment utiliser des chaînes spéciales telles que =SheetNumber dans les cartouches, les sorties imprimées et les données du projet pour refléter vos choix de numérotation.
La numérotation des feuilles de schéma d'un projet vous permet de contrôler la désignation des feuilles et de stocker ces désignations sous forme de paramètres dans les documents schématiques correspondants. La fonctionnalité de chaînes spéciales (=SheetNumber, =DocumentNumber, =SheetTotal) peut ensuite être utilisée pour afficher ces valeurs sur la feuille (dans son cartouche, par exemple) sous forme d'objets texte. La numérotation ne modifie pas les repères des composants, mais les désignations (numéros) des feuilles de schéma. Elle relève donc du concept général d'annotation de la conception.
Numérotation des feuilles
Pour accéder à la numérotation des feuilles, cliquez sur Tools » Annotation » Number Schematic Sheets dans les menus principaux afin d'ouvrir la boîte de dialogue Sheet Numbering For Project.

Utilisez la boîte de dialogue Sheet Numbering For Project pour numéroter et organiser les feuilles de schéma d'un projet.
Options et commandes de la boîte de dialogue de numérotation des feuilles du projet
De nombreuses options et commandes de cette boîte de dialogue sont explicites et ne nécessitent aucune explication supplémentaire. Celles qui en nécessitent sont décrites ci-dessous.
| SheetNumber DocumentNumber |
Ces champs peuvent être modifiés directement dans la grille. Cliquez une fois pour sélectionner la cellule, puis une seconde fois pour passer en mode édition. Utilisez les commandes du menu contextuel pour copier/coller des valeurs ou modifier plusieurs cellules sélectionnées. Dans ce dernier cas, sélectionnez les cellules souhaitées, puis faites un clic droit sur l'une d'elles et choisissez la commande Edit. Saisissez la nouvelle valeur, puis appuyez sur Enter ; cette valeur sera appliquée à chaque cellule de la sélection. |
| SheetTotal | La valeur actuelle du paramètre SheetTotal défini au niveau du document. Ce champ est mis à jour lorsque vous cliquez sur le bouton Update Sheet Count. |
| Automatic Sheet Numbering (Project Option) | Activez cette option pour appliquer une numérotation automatique aux feuilles de schéma du projet. Cela vous permet de contrôler la désignation des feuilles et de stocker ces désignations sous forme de paramètres dans les documents schématiques correspondants. Cette option peut également être activée dans la boîte de dialogue Options du projet - Options . |
| Auto Sheet Number Auto Document Number |
Cliquez pour appliquer la numérotation des feuilles/documents selon le schéma ou la méthode de numérotation choisis. Cliquez sur la flèche déroulante associée au bouton pour accéder aux options de numérotation disponibles.
|
| Update the Sheet Count | Cliquez pour calculer le nombre total de feuilles du projet actuel et placer le résultat dans la colonne SheetTotal. Ce nombre correspond au nombre total de feuilles du projet, quel que soit le schéma de numérotation sélectionné dans les commandes précédentes. L'option Automatic Sheet Numbering (Project Option) doit être désactivée pour pouvoir accéder à ce champ. |
Numérotation des feuilles de schéma et feuilles de périphérique
Les numéros de feuille ou de document ne peuvent pas être configurés pour les feuilles de périphérique lorsqu'elles sont en lecture seule (état par défaut). Dans la boîte de dialogue Sheet Numbering For Project, ils sont hachurés pour indiquer qu'ils ne peuvent pas être mis à jour, comme illustré dans l'image ci-dessous. Lorsque les feuilles de périphérique sont définies comme modifiables, les hachures disparaissent et la numérotation peut être configurée normalement.
Numérotation automatique des feuilles
La numérotation automatique des feuilles peut être activée ou désactivée à l'aide de l'option Automatic Sheet Numbering de l'onglet Options de la boîte de dialogue Project Options et de l'option Automatic Sheet Numbering (Project Option) de la boîte de dialogue Sheet Numbering For Project. Il suffit que l'option soit activée dans l'une des deux boîtes de dialogue pour que la numérotation automatique des feuilles soit effectuée. Si l'option est désactivée dans les deux boîtes de dialogue, les feuilles peuvent être numérotées manuellement.
Si l'une des options mentionnées ci-dessus est activée, la numérotation automatique peut être appliquée aux feuilles de schéma directement dans le panneau Projects . Pour modifier la numérotation, faites glisser les feuilles de schéma dans le panneau. Le numéro de la feuille est affiché à gauche de son nom.
Annotation des feuilles compilées
L'annotation des feuilles compilées vous permet de contrôler la numérotation des feuilles compilées (instances physiques d'une feuille), de la même manière que la numérotation des feuilles contrôle celle des feuilles logiques.
Prenons l'exemple d'une conception comprenant un document schématique nommé Input channel.SchDoc. Le circuit de cette feuille est utilisé huit fois dans la conception. Après compilation de la conception, Input channel.SchDoc sera donc instancié huit fois (c'est-à-dire une fois pour chaque instance du circuit sur le PCB physique). La numérotation des feuilles sert à numéroter la feuille Input channel.SchDoc dans la structure logique de la conception ; l'annotation des feuilles compilées sert à numéroter les différentes instances de cette feuille dans la vue physique (compilée) de la conception.
L'annotation des feuilles compilées s'effectue dans la boîte de dialogue Annotate Compiled Sheets, accessible en sélectionnant la commande Tools » Annotation » Annotate Compiled Sheets dans les menus principaux.
La boîte de dialogue répertorie toutes les feuilles compilées du projet actuel. Vous pouvez créer des noms personnalisés pour vos feuilles compilées en les saisissant directement dans le champ Sheet Number . Utilisez n'importe quelle combinaison de caractères (alphanumériques ou non), puis cliquez sur OK pour appliquer votre annotation personnalisée.
Cliquez sur le bouton Annotate Sheet pour annoter la ou les feuilles après avoir sélectionné les options accessibles en cliquant sur la flèche vers le bas associée. (Consultez la section Numérotation des feuilles pour obtenir une description des champs, si nécessaire.) Le champ SheetNumber sera mis à jour en fonction de vos sélections.
Les numéros de feuille mis à jour par cette boîte de dialogue sont stockés dans le fichier *.Annotation du projet, sous le sous-dossier Settings\Annotation Documents du panneau Projects . Les informations et les paramètres d'annotation sont ainsi conservés d'une session de modification du projet à l'autre.
Utilisation de l'annotation des feuilles compilées dans l'annotation au niveau de la carte
Une fois les feuilles compilées annotées à l’aide de la boîte de dialogue Annotate Compiled Sheets, le mot-clé $SheetNumber peut être utilisé dans le schéma de nommage de la boîte de dialogue Board Level Annotation Options. Si les feuilles compilées du projet n’ont pas encore été annotées, la numérotation des feuilles définie dans la boîte de dialogue Sheet Numbering For Project sera utilisée par défaut.
Utilisation de l’annotation des feuilles compilées dans un projet
Une fois vos feuilles compilées annotées, vous pouvez placer la chaîne spéciale SheetNumber dans votre projet pour faire référence à ces informations.
-
La chaîne spéciale est toujours affichée ; si sa valeur est nulle, le nom du paramètre est affiché.
-
Placez une chaîne spéciale dont la valeur est
=SheetNumberpour utiliser les valeurs d’annotation de vos feuilles compilées. Vous pouvez utiliser des chaînes spéciales dans les valeurs des propriétés de paramètres, les chaînes de texte, les étiquettes de nets, etc. -
Le numéro de feuille attribué par la boîte de dialogue peut être référencé dans les sorties imprimées de la feuille compilée (physique) à l’aide de la chaîne spéciale =SheetNumber. Il sera alors mis à jour dans toutes les sorties imprimées de la conception.

