Préparation des livrables et publication du projet
Main page: Préparation de votre conception pour la fabrication
Maintenant que vous avez terminé la conception et le routage du PCB, vous êtes prêt à produire la documentation de sortie nécessaire à la vérification, à la fabrication et à l’assemblage de la carte.
Comme il existe diverses technologies et méthodes de fabrication de PCB, Altium Designer permet de produire de nombreux types de sorties pour différents usages, notamment des fichiers Gerber, des fichiers ODB++, des fichiers de placement, des rapports de nomenclature, etc.
Ajout d’un fichier Output Job au projet
Main page: Préparation des données de fabrication avec les fichiers Output Job
Bien que vous puissiez générer de manière sélective les sorties requises à partir d’éditeurs spécifiques (par exemple, à l’aide des commandes des sous-menus Fabrication Outputs et Assembly Outputs du menu principal File de l’éditeur PCB), Altium Designer prend en charge les fichiers Output Job. Un fichier Output Job (ou « OutJob » en abrégé) enregistre les paramètres de chaque type de sortie. Un OutJob vous permet de configurer chaque type de sortie, ainsi que le nom, le format et l’emplacement des fichiers générés. Les sorties peuvent être générées directement à partir d’un OutJob ou dans le cadre du processus intégré de publication du projet.
-
Cliquez avec le bouton droit sur l’entrée du projet dans le panneau Projects et sélectionnez la commande Add New to Project » Output Job File dans le menu contextuel. Un nouveau fichier Output Job s’ouvre et son entrée apparaît, liée au projet, dans le panneau Projects, sous l’entrée Settings\Output Job Files.
-
Cliquez avec le bouton droit sur l’entrée OutJob dans le panneau Projects et sélectionnez la commande Save As. La boîte de dialogue Save As s’ouvre, prête à enregistrer le document au même emplacement que le fichier de projet. Saisissez le nom
Fabricationdans le champ File name et cliquez sur le bouton Save. -
L’ajout de l’OutJob a modifié le projet. Enregistrez donc le projet localement en cliquant avec le bouton droit sur son entrée dans le panneau Projects et en sélectionnant Save.
Ajout et configuration des sorties de fabrication
Main page: Préparation des données de fabrication
Dans cette partie du tutoriel, vous allez configurer les sorties nécessaires à la fabrication de la carte : les fichiers Gerber et de perçage CN.
-
Pour ajouter une nouvelle sortie Gerber, cliquez sur le lien Add New Fabrication Output dans la section Fabrication Outputs de la zone Outputs de l’OutJob et sélectionnez Gerber Files » [PCB Document].
-
Double-cliquez sur l’entrée de sortie Gerber Files ajoutée. La boîte de dialogue Gerber Setup s’ouvre. Configurez les options de cette boîte de dialogue comme suit :
-
La carte ayant été conçue dans le système métrique, assurez-vous que l’option Units est définie sur Millimeters.
-
La plus petite unité utilisée sur la carte est de 0,25 mm pour le routage et l’espacement. Cependant, comme la plupart des composants ont leur point de référence au centre géométrique (et ont été placés sur une grille de 1 mm), certaines de leurs pastilles se trouvent en réalité sur une grille de 0,01 mm. Définissez l’option Decimal sur 0.001 mm. Cela garantit que la résolution des données de sortie est largement suffisante pour représenter ces positions sur la grille.
-
Cliquez sur le bouton
au bas de l’onglet Layer to plot et choisissez Select Used. Les couches utilisées dans la conception seront activées dans la colonne Plot du tableau au-dessus.
-
-
Cliquez sur Apply pour accepter les autres paramètres par défaut et fermer la boîte de dialogue Gerber Setup.
-
La carte comportant des trous, un fichier de perçage CN doit également être généré. De la même manière, ajoutez la sortie de perçage CN au fichier OutJob : cliquez sur le lien Add New Fabrication Output dans la section Fabrication Outputs de la zone Outputs de l’OutJob et sélectionnez NC Drill Files » [PCB Document].
-
Double-cliquez sur l’entrée de sortie NC Drill Files ajoutée pour accéder à la boîte de dialogue NC Drill Setup. Pour vous assurer que les fichiers de perçage CN seront créés au même format que les fichiers Gerber, définissez Units sur Millimeters et Format sur 4:3. Assurez-vous que l’option Coordinate Position est définie sur Reference to relative origin.
-
Cliquez sur OK pour accepter les autres paramètres par défaut et fermer la boîte de dialogue NC Drill Setup.
-
Maintenant que les paramètres Gerber et de perçage CN sont configurés, l’étape suivante consiste à configurer les noms et l’emplacement des fichiers de sortie. Pour cela, associez-les à un conteneur de sortie sur le côté droit de l’OutJob. Pour les fichiers distincts ayant leur propre format, utilisez un conteneur de structure de dossiers. Un nouvel OutJob comprend certains conteneurs par défaut. Sélectionnez l’entrée Folder Structure dans la liste des conteneurs de sortie, puis cliquez sur les boutons radio des fichiers Gerber et de perçage CN dans la colonne Enabled de la zone Outputs pour associer ces sorties au conteneur sélectionné, comme illustré ci-dessous.
-
La dernière étape consiste à configurer le conteneur. Pour cela, cliquez sur le lien Change dans l’entrée du conteneur lorsqu’elle est sélectionnée pour ouvrir la boîte de dialogue Folder Structure settings. En haut de cette boîte de dialogue, un ensemble de commandes permet de configurer l’emplacement de sortie. Assurez-vous que la première commande est définie sur Release Managed. La partie inférieure de la boîte de dialogue montre comment les noms et la structure des dossiers évoluent lorsque vous sélectionnez différentes options.
-
Cliquez sur OK pour fermer la boîte de dialogue Folder Structure settings.
Ajout et configuration d’un rapport de validation DRC
Main page: Préparation des rapports de validation
Altium Designer comprend plusieurs contrôles de validation qui peuvent être inclus comme sorties lors de la génération des fichiers de sortie. Chacun produit un fichier de rapport HTML. Lors du processus de publication du projet, ces contrôles sont effectués avant la génération des autres sorties. Si l’un des contrôles de validation échoue, la publication échoue également.
-
Pour ajouter une nouvelle sortie de validation DRC, cliquez sur le lien Add Validation Output dans la section Validation Outputs de la zone Outputs de l’OutJob et sélectionnez Design Rules Check » [PCB Document].
-
Associez le rapport ajouté au conteneur Folder Structure existant. Sélectionnez l’entrée Folder Structure dans la liste située sur le côté droit de l’OutJob, puis cliquez sur le bouton radio de la sortie Design Rules Check dans la colonne Enabled de la zone Outputs.
-
Enregistrez le fichier Output Job localement en cliquant avec le bouton droit sur son entrée dans le panneau Projects et en sélectionnant Save dans le menu contextuel.
-
Fermez le fichier Output Job en cliquant avec le bouton droit sur son onglet en haut de l’espace de conception et en sélectionnant la commande Close Fabrication.OutJob dans le menu contextuel.
Ajout et configuration des sorties d’assemblage
Main page: Configuration de la nomenclature dans le gestionnaire de rapports
Le fichier de nomenclature de sortie est généré à l’aide de la boîte de dialogue Report Manager, un moteur de génération de rapports hautement configurable qui permet de produire des sorties dans divers formats, notamment texte, CSV, PDF, HTML et Excel. Vous pouvez également appliquer un modèle aux nomenclatures au format Excel, en utilisant l’un des modèles prédéfinis ou l’un de vos propres modèles.
-
Ajoutez un nouveau fichier OutJob au projet en cliquant avec le bouton droit sur l’entrée du projet dans le panneau Projects et en sélectionnant la commande Add New to Project » Output Job File dans le menu contextuel.
-
Cliquez avec le bouton droit sur l’entrée OutJob dans le panneau Projects et sélectionnez la commande Save As. La boîte de dialogue Save As s’ouvre, prête à enregistrer le document au même emplacement que le fichier de projet. Saisissez le nom
Assemblydans le champ File name et cliquez sur le bouton Save. -
Enregistrez le projet localement en cliquant avec le bouton droit sur l’entrée du projet dans le panneau Projects et en sélectionnant Save.
-
Pour ajouter une nouvelle sortie de nomenclature, cliquez sur le lien Add New Report Output dans la section Report Outputs de l’OutJob et sélectionnez Bill of Materials » [ActiveBOM Document].
-
Double-cliquez sur la sortie Bill of Materials ajoutée pour ouvrir la boîte de dialogue Report Manager.
-
Dans la zone Export Options du volet Properties situé à droite de la boîte de dialogue, utilisez la liste déroulante File Format pour sélectionner Generic XLS (*.xls, *.xlsx, *.xlsm), puis utilisez la liste déroulante Template pour sélectionner le modèle BOM Template Single Supplier parmi ceux présents dans votre espace de travail.
-
Cliquez sur OK pour enregistrer les modifications et fermer la boîte de dialogue Report Manager.
-
Ajoutez une nouvelle sortie Draftsman en cliquant sur le lien Add New Documentation Output dans la section Documentation Outputs de l’OutJob et en sélectionnant Draftsman » All Draftsman Documents.
-
Associez les sorties de nomenclature et Draftsman ajoutées au conteneur de sortie PDF existant. Pour ce faire, sélectionnez l’entrée PDF dans la liste des conteneurs de sortie à droite de l’OutJob, puis cliquez sur les boutons radio des sorties Bill of Materials et Draftsman dans la colonne Enabled de la zone Outputs.
-
Une fois l’entrée du conteneur PDF sélectionnée, cliquez sur le lien Change dans cette entrée pour ouvrir la boîte de dialogue PDF settings.
-
Cliquez sur l’entrée Assembly.PDF en haut de la boîte de dialogue PDF settings, sélectionnez Separate file for each output using output name, puis cliquez sur le bouton
. La nomenclature et le dessin de sortie recevront le nom défini pour chaque sortie dans l’OutJob (Bill of Materials.pdf et Draftsman.pdf, respectivement), visible dans la zone Preview de la boîte de dialogue.
-
Cliquez sur OK pour fermer la boîte de dialogue.
-
Ajoutez une nouvelle sortie Pick & Place en cliquant sur le lien Add New Documentation Output dans la section Documentation Outputs de l’OutJob et en sélectionnant Generates pick and place files » [PCB Document].
-
Double-cliquez sur la sortie Generates pick and place files ajoutée pour accéder à la boîte de dialogue Pick and Place Setup.
-
Dans la zone Output Setting située en bas à gauche de la boîte de dialogue, définissez Units sur Metric.
-
Cliquez sur OK pour accepter les autres paramètres par défaut et fermer la boîte de dialogue Pick and Place Setup.
-
Associez la sortie Pick & Place ajoutée au conteneur de sortie Folder Structure existant. Pour ce faire, sélectionnez l’entrée Folder Structure dans la liste des conteneurs de sortie à droite de l’OutJob, puis cliquez sur le bouton radio de la sortie Generates pick and place files dans la colonne Enabled de la zone Outputs.
-
Enregistrez le fichier Output Job localement en cliquant avec le bouton droit sur son entrée dans le panneau Projects et en sélectionnant Save dans le menu contextuel.
-
Fermez le fichier Output Job en cliquant avec le bouton droit sur son onglet en haut de l’espace de conception et en sélectionnant la commande Close Assembly.OutJob dans le menu contextuel.
Publication du projet
Main page: Publication du projet de conception
Une fois la documentation de sortie configurée dans les fichiers Output Job, le projet est prêt à être publié dans l’espace de travail connecté. Le processus de publication de la conception de carte est automatisé, ce qui vous permet de publier vos projets de conception de cartes sans les risques associés aux procédures de publication manuelles. Lorsqu’un projet est publié, un instantané des sources de conception est créé et archivé avec toutes les sorties générées, qui représentent un produit tangible réalisé à partir de ce projet de conception et vendu par l’entreprise.
Le processus de publication lui-même s’effectue à l’aide de Project Releaser d’Altium Designer, dont l’interface utilisateur est accessible dans une vue dédiée : la vue Release. Le processus de publication se déroule par étapes ; les entrées situées à gauche de la vue vous permettent de voir d’un coup d’œil l’étape à laquelle vous vous trouvez.
-
Cliquez avec le bouton droit sur l’entrée du projet dans le panneau Projects et sélectionnez la commande Project Releaser dans le menu contextuel. La vue Release s’ouvre dans un onglet de document distinct.
-
À la première étape, 1. Configure Server Release, vous spécifiez le ou les types de données que vous souhaitez générer. Cliquez sur les commandes Details à l’extrémité droite de l’en-tête de chaque jeu de données pour consulter les détails de ce qui sera exactement généré par ce jeu de données.
-
Cliquez sur le bouton
en bas à gauche de la vue pour accéder à la boîte de dialogue Project Release Options. Dans l’onglet Release Options de cette boîte de dialogue, assurez-vous que Managed - <WorkspaceName> est sélectionné comme Release Target, que Fabrication est affecté au jeu Fabrication Data et que Assembly est affecté au jeu Assembly Data.
-
Cliquez sur OK pour fermer la boîte de dialogue et revenir à la vue Release.
-
Assurez-vous que les deux options Include Fabrication Data et Include Assembly Data for No Variant sont activées.
-
Cliquez sur le bouton
en bas à droite de la vue pour continuer.
-
La boîte de dialogue Item Creation s’ouvre et affiche la liste des éléments de publication cibles à créer dans l’espace de travail. Sélectionnez l’option Create items pour confirmer la création des éléments.
-
Dans la boîte de dialogue Project Modified qui s’ouvre, sélectionnez l’option Save and Commit changes pour enregistrer les modifications localement et poursuivre leur enregistrement dans l’espace de travail.
-
Dans la boîte de dialogue Commit to Version Control qui s’ouvre, saisissez un commentaire pertinent dans le champ Comment (par exemple,
The project is ready for release), puis cliquez sur le bouton
.
-
L’étape suivante du processus de publication – 2. Validate Project – est exécutée automatiquement, car le fichier de tâches de sortie
Fabricationinclut le rapport de vérification des règles de conception. -
Une fois la validation réussie, l’étape suivante du processus de publication – 3. Generate Data – est exécutée automatiquement. C’est à cette étape que toutes les autres sorties, définies dans les fichiers OutJob affectés aux éléments de données inclus, sont générées afin de produire les données à publier dans les éléments cibles correspondants de l’espace de travail.
-
Une fois tous les contrôles de validation réussis et les données de sortie générées, l’étape suivante du processus de publication – 4. Review Data – vous permet d’examiner les données générées. Poursuivez la publication en cliquant sur le bouton
en bas à droite de la vue.
-
La boîte de dialogue Confirm Release s’ouvre et récapitule les configurations du projet qui seront publiées dans l’espace de travail. Saisissez un Release Note (par exemple,
Initial Release), puis cliquez sur OK.
-
Après la confirmation de la publication à l’étape précédente, l’étape suivante – 5. Upload Data – démarre automatiquement. Elle présente simplement la progression du transfert des données vers les révisions des éléments de données correspondants dans l’espace de travail.
-
La dernière étape du processus – 6. Execution Report – fournit un récapitulatif de la publication. Fermez la vue de publication en cliquant sur le bouton
en bas à droite de la vue.
Conception collaborative avec un espace de travail
Le plus souvent, plusieurs personnes participent à la conception et au développement d’un produit électronique. Pour travailler efficacement, les membres de l’équipe de conception doivent pouvoir collaborer. Altium Designer, associé à un espace de travail connecté, propose plusieurs fonctionnalités de conception collaborative. Certaines sont présentées ci-dessous.
-
Project history – une vue dédiée à l’historique présente une chronologie graphique avancée de l’historique du projet, retraçant les événements majeurs qui le concernent : sa création, les commits, les publications, les clonages et les échanges MCAD. Différentes actions sont disponibles selon le contexte Pour accéder à la vue de l’historique d’un projet de l’espace de travail depuis Altium Designer, cliquez avec le bouton droit sur l’entrée du projet dans le panneau Projects, puis sélectionnez la commande History & Version Control » Show Project History dans le menu contextuel.
En savoir plus : Historique du projet, Project History (Espace de travail Altium 365, Espace de travail Enterprise Server)
-
Web Viewer – l’interface Web Viewer de l’espace de travail offre un accès universel aux documents du projet depuis un navigateur standard. Bien plus qu’une simple visionneuse dans un navigateur, sa technologie avancée permet aux utilisateurs de parcourir la structure du projet, d’interagir avec les documents de conception, de mettre en évidence des zones ou des objets pour y ajouter des commentaires, ainsi que de rechercher, d’effectuer des sélections croisées, de sélectionner et d’inspecter des composants et des nets dans l’ensemble de la conception. Pour accéder à Web Viewer pour un projet de l’espace de travail depuis Altium Designer, cliquez avec le bouton droit sur l’entrée du projet dans le panneau Projects, puis sélectionnez la commande Show in Web Browser dans le menu contextuel.
En savoir plus : Web Viewer (Plateforme Altium 365, Espace de travail Enterprise Server)
-
Document commenting – un commentaire est une note ajoutée par un utilisateur et associée à un point, un objet ou une zone spécifique, selon le cas, dans une vue de données prise en charge. Les autres utilisateurs peuvent y répondre. Les commentaires favorisent la collaboration entre utilisateurs sans modifier les données partagées elles-mêmes, car ils sont stockés par l’espace de travail indépendamment de ces données. Les commentaires ajoutés dans l’interface Web Viewer aux emplacements suivants sont disponibles dans Altium Designer, et inversement. Dans Altium Designer, la fonctionnalité de commentaires est gérée dans le panneau Comments and Tasks
En savoir plus : Commentaires sur les documents, Web Viewer (Plateforme Altium 365, Espace de travail Enterprise Server)
-
Sharing a project – une fois un projet enregistré dans l’espace de travail, vous pouvez définir quels utilisateurs peuvent effectivement y accéder pour collaborer à sa conception et/ou le passer en revue. Pour cela, partagez le projet ou, plus précisément, configurez ses autorisations d’accès. Dans Altium Designer, le partage de projet est géré dans la boîte de dialogue Share , accessible en cliquant avec le bouton droit sur l’entrée du projet dans le panneau Projects, puis en sélectionnant la commande Share dans le menu contextuel.
En savoir plus : Partage d’une conception, Workspace Projects (Espace de travail Altium 365, Espace de travail Enterprise Server)



















).
).
)