Creazione e definizione della libreria di database

A colpo d'occhio

Scopri come creare e definire librerie di database standard e con controllo delle versioni in Altium Designer. Questo articolo spiega come connettersi a un database esterno, collegare un file SVNDbLib a un repository Subversion, scegliere quali tabelle del database includere e impostare i criteri di corrispondenza che collegano i componenti posizionati ai rispettivi record di origine. Continua a leggere per compiere il passo successivo nella configurazione della tua libreria di database.

- Comprendi il ruolo dei file DbLib e SVNDbLib e scopri dove crearli.
- Esplora le opzioni di connessione al database, tra cui le scorciatoie per Access ed Excel, le stringhe di connessione e i file Microsoft Data Link.
- Scopri come esplorare e modificare le tabelle collegate, gestirne l'inclusione nella libreria e definire i criteri di corrispondenza dei componenti per ciascuna tabella.
Approfondisci con l'IA:

Il fulcro della funzionalità di libreria database è il file di libreria database. Questo è disponibile in due forme, a seconda che si utilizzi una libreria database standard o una libreria database con controllo di versione:

  • Standard Database Library - il file Database Library. Questo file viene creato e gestito tramite l'editor DatabaseLib di Altium Designer. Questo editor diventa disponibile quando il documento attivo nella finestra di progettazione principale è un file *.DbLib.
  • Version-Controlled Database Library - il file SVN Database Library. Questo file viene creato e gestito tramite l'editor SVNDatabaseLib di Altium Designer. Questo editor diventa disponibile quando il documento attivo nella finestra di progettazione principale è un file *.SVNDbLib.

Esempio di file DbLib aperto nell'editor DatabaseLib. Passare il puntatore sull'immagine per visualizzare un esempio di file SVNDbLib aperto nell'editor SVNDatabaseLib.Esempio di file DbLib aperto nell'editor DatabaseLib. Passare il puntatore sull'immagine per visualizzare un esempio di file SVNDbLib aperto nell'editor SVNDatabaseLib.

Creare un nuovo file di questi tipi scegliendo il comando File » New » Library  dai menu principali e selezionando l'opzione Database Library o SVN Database Library nell'area Database della finestra di dialogo New Library che si apre.

Connessione a un database esterno

I dati delle tabelle e delle mappature vengono visualizzati nella finestra principale dell'editor solo dopo che il file Database Library/SVN Database Library attivo è stato connesso correttamente al database esterno richiesto. La connessione viene definita tramite i controlli disponibili nell'area Source of Connection.

Definizione della connessione al database esterno tramite un file DbLib. Passare il puntatore sull'immagine per visualizzare la connessione tramite un file SVNDbLib.Definizione della connessione al database esterno tramite un file DbLib. Passare il puntatore sull'immagine per visualizzare la connessione tramite un file SVNDbLib.

È possibile connettersi a qualsiasi database che supporti OLE DB. Le opzioni disponibili in quest'area utilizzano ciascuna una stringa di connessione OLE DB per connettersi al database di destinazione. Alcuni database potrebbero non supportare OLE DB. Tuttavia, praticamente tutti i sistemi di gestione dei database attualmente in uso sono accessibili tramite l'interfaccia Open Database Connectivity (ODBC). La funzionalità di collegamento al database utilizza il provider ODBC di Microsoft, che consente a un oggetto ADO (ActiveX Data Object) di connettersi a qualsiasi origine dati ODBC. Di conseguenza, è possibile connettersi a qualsiasi database ODBC. Il provider OLE DB per il database ODBC viene specificato all'interno della stringa di connessione.

La connessione può essere definita anche nella scheda Connection della finestra di dialogo Database Connection, accessibile scegliendo il comando Tools » Database Connection dai menu principali oppure facendo clic sul pulsante Advanced (a destra del pulsante Connect , nella parte inferiore dell'area).

Connessione rapida ai database Access ed Excel

L'opzione Select Database Type offre un metodo rapido per creare una stringa di connessione quando il database di destinazione è stato creato con Microsoft Access o Microsoft Excel. Utilizzando questa opzione, selezionare il tipo di database, quindi individuare e selezionare il file di database richiesto. La stringa di connessione corrispondente verrà composta automaticamente e inserita nel campo dell'opzione Use Connection String.

È possibile specificare il percorso completo oppure scegliere di memorizzare il percorso relativo al file Database Library/SVN Database Library.

Creazione di una stringa di connessione

Se il database aziendale non è basato su Access o Excel e si desidera creare esplicitamente la stringa di connessione, abilitare l'opzione Use Connection String, quindi fare clic sul pulsante Build associato a destra. Verrà visualizzata la finestra di dialogo Data Link Properties.

Creazione di una stringa di connessione tramite la finestra di dialogo Data Link Properties.Creazione di una stringa di connessione tramite la finestra di dialogo Data Link Properties.

La finestra di dialogo si apre sulla scheda Connection . Il provider OLE DB Microsoft Office <Version> Access Database Engine OLE DB Provider è impostato per default nella scheda Provider della finestra di dialogo. Questo è il provider predefinito per i nuovi file Database Library/SVN Database Library e viene utilizzato anche per connettersi ai file di database Access (*.mdb). Modificare il provider secondo necessità.

Nella scheda Connection inserire il nome (incluso il percorso) del database a cui si desidera connettersi.

Se il database richiede credenziali di accesso, inserirle secondo necessità, insieme alle altre impostazioni avanzate disponibili nella scheda Advanced della finestra di dialogo. La scheda All fornisce un elenco riepilogativo delle opzioni di collegamento definite, nonché opzioni estese relative al provider OLE DB scelto. Le opzioni possono essere modificate secondo necessità da questa scheda.

Una volta definite le opzioni di collegamento, è possibile verificare che la connessione sia riuscita facendo clic sul pulsante Test Connection (nella scheda Connection ). Se la connessione riesce, verrà visualizzata una finestra di dialogo di conferma.

La finestra di dialogo Data Link Properties è una finestra di dialogo Microsoft e, pertanto, premendo F1 o utilizzando il pulsante Help disponibile si accederà al file Microsoft Data Link Help. Questo file non fa parte della documentazione di Altium Designer.

Specifica di un file di collegamento dati

Se l'origine dati a cui si desidera connettersi è descritta tramite un file Microsoft Data Link (*.udl), abilitare la terza opzione di connessione - Use Data Link File - e fare clic sul pulsante Browse associato per individuare il file richiesto. Un file di collegamento dati è essenzialmente un contenitore per la memorizzazione di una stringa di connessione.

Proseguimento della connessione

Dopo aver definito la connessione al database esterno, il testo del pulsante Connect diventerà in grassetto, indicando che è possibile procedere con la connessione. Se i dettagli della connessione sono corretti, le informazioni sulle tabelle e sulle mappature del database di destinazione verranno caricate nel file Database Library/SVN Database Library. Il testo del pulsante Connect cambierà in Connected e il pulsante verrà disabilitato.

Se si verifica un problema con i dettagli della connessione, ad esempio una stringa di connessione non corretta o un percorso inserito erroneamente, la connessione non riuscirà e verrà visualizzato un messaggio di avviso. Controllare le impostazioni di connessione e fare nuovamente clic sul pulsante Connect .

Esempi di segnalazione di una connessione non riuscita in una libreria di database. Esempi di segnalazione di una connessione non riuscita in una libreria di database.

Se si modificano le impostazioni di connessione mentre si è connessi a un database, la connessione attiva verrà interrotta e il testo del pulsante Connect cambierà in Reconnect. Fare clic per ristabilire la connessione.

Dopo la prima connessione riuscita e dopo aver salvato il file Database Library/SVN Database Library, la connessione verrà stabilita automaticamente a ogni apertura del file, a condizione che la posizione e il nome del file del database di destinazione non vengano modificati.

Specificare il collegamento al repository di controllo versione (solo SVNDbLib)

Con una DbLib, le librerie di simboli e modelli sono memorizzate sul disco rigido o su un altro supporto locale o di rete. Per una SVNDbLib, invece, queste librerie sono archiviate sotto controllo versione in un repository Subversion. Nel file SVNDbLib è necessario definire il collegamento a questo repository. La connessione al repository SVN viene definita nella scheda SVN Repository della finestra di dialogo Database Library Options (Tools » Options). È possibile accedere a questa finestra di dialogo anche facendo clic sul pulsante Options nell'area Field Settings della vista del documento.

Esempio di connessione a un repository SVN basato su file.Esempio di connessione a un repository SVN basato su file.

Elenco delle tabelle del database

Dopo aver stabilito la connessione al database esterno, verranno caricati i dati delle tabelle e delle mappature. Il lato sinistro del documento DbLib/SVNDbLib elenca tutte le tabelle presenti nel database connesso.

Per un database basato su Excel, una tabella corrisponde in realtà a un foglio della cartella di lavoro collegata. Il nome della tabella avrà il suffisso $.

Tabelle presenti nel database connesso.Tabelle presenti nel database connesso.

L'opzione Enable accanto a ciascuna voce di tabella consente di controllare se la tabella debba far parte della libreria di database risultante. Quando la libreria di database viene aggiunta all'elenco delle librerie basate su file disponibili per la consultazione nel pannello Components, ogni tabella apparirà come una libreria separata. Quindi, sebbene venga effettivamente aggiunta una sola libreria di database, dal punto di vista del pannello Components è come se fossero state aggiunte più librerie distinte. Per ulteriori informazioni, vedere Ricerca di componenti nelle librerie basate su file e nei database.

Quando si fa clic su una tabella nell'elenco, la relativa icona cambia da Database table icon, inactive table a Database table icon, active table per identificarla come tabella attualmente attiva. La tabella, con tutti i suoi dati, viene visualizzata nella scheda Table Browser del documento. Questa vista modificabile della tabella consente di consultarne rapidamente il contenuto e modificarlo dove necessario, senza dover aprire il database esterno.

Consultazione di una tabella di origine nel database connesso.Consultazione di una tabella di origine nel database connesso.

Per ingrandire l'area del browser delle tabelle (come mostrato nell'illustrazione precedente), comprimere l'intera area superiore (impostazioni di connessione e dei campi) facendo clic sul controllo Collapse icon - collapse a region of the database library document in alto a destra nella vista del documento. Fare clic su Expand icon - expand a region of the database library document per espanderla. La tabella supporta anche le consuete funzioni di raggruppamento, ordinamento e filtro.

Specificare i criteri di corrispondenza

Dopo aver posizionato un componente dal database esterno, è necessario mantenere il collegamento tra il componente posizionato e il record del database le cui informazioni sono state utilizzate per crearlo. In sostanza, è necessario stabilire una corrispondenza tra i due.

Quando un componente viene posizionato, le informazioni sui suoi parametri vengono create al momento, utilizzando i campi corrispondenti nel record del database. Il collegamento successivo al posizionamento tra il componente dello schema e il record del database viene stabilito utilizzando uno o più di questi parametri. L'area Field Settings del documento consente di definire i criteri di corrispondenza: una semplice ricerca a chiave singola oppure una corrispondenza più avanzata mediante una clausola WHERE.

I criteri di corrispondenza vengono specificati per ciascuna tabella.

Controllo dei criteri di corrispondenza dopo il posizionamento.Controllo dei criteri di corrispondenza dopo il posizionamento.

Ricerca a chiave singola

Se l'opzione Single key lookup è abilitata (impostazione predefinita), i campi Database field e Part parameter diventano disponibili. Il primo elenca tutti i nomi dei campi disponibili (intestazioni delle colonne) nella tabella attiva del database. Poiché i parametri di un componente dello schema vengono aggiunti al momento del posizionamento, il campo Part parameter rifletterà il campo del database selezionato.

In genere, come campo chiave di ricerca si utilizza un elemento che identifica in modo univoco ciascun componente nel database esterno, ad esempio un codice componente. Il campo di ricerca scelto è contraddistinto nella scheda Field Mappings del documento dalla voce Design Parameter visualizzata in grigio.

Mappatura a chiave singola tramite codice componente.Mappatura a chiave singola tramite codice componente.

Quando si utilizza la funzione Update Parameters From Database dopo il posizionamento, le informazioni vengono lette dal parametro chiave scelto nei componenti dello schema posizionati e quindi cercate nel campo chiave selezionato del database, in tutte le tabelle abilitate. Quando viene trovata una corrispondenza, le informazioni contenute nelle altre celle di quel record della tabella di origine possono essere trasferite ai parametri mappati nel componente dello schema.

Corrispondenza avanzata: la clausola WHERE

Sebbene l'opzione Single key lookup funzioni bene quando è disponibile un codice componente o un ID univoco su cui basare la corrispondenza, non è altrettanto efficace quando si utilizza un parametro non univoco, come la capacità o la resistenza. In questo caso è opportuno utilizzare la clausola WHERE, più avanzata, che consente di specificare una corrispondenza basata su più chiavi per collegare il componente dello schema al record del database di origine.

Nella sua forma più semplice, la clausola WHERE (scritta utilizzando la sintassi SQL) riflette le voci selezionate che definiscono la ricerca a chiave singola. Ad esempio, se per Database field fosse stato scelto Part Number, il valore predefinito, anche il campo Part parameter verrebbe impostato automaticamente su Part Number e la clausola WHERE sarebbe:

[Part Number] = '{Part Number}'

Le parentesi quadre attorno al campo del database (colonna della tabella) sono caratteri di delimitazione, come specificato nella scheda Advanced della finestra di dialogo Database Connection. Per accedere a questa finestra di dialogo, fare clic sul pulsante Advanced nell'area Source of Connection del documento oppure utilizzare il menu principale Tools .

Mapping between the component parameters and the database, using a Where clause La scheda Advanced della finestra di dialogo Database Connection fornisce ulteriori opzioni SQL per delimitare
i nomi delle tabelle o utilizzare i nomi degli schemi delle tabelle in una clausola WHERE costruita.

Quando si delimitano i nomi delle tabelle, i caratteri da utilizzare dipendono dal database in uso. Ad esempio, le parentesi quadre [ ] sono utilizzabili solo nei database Microsoft come Access, Excel tramite ADO o MSSQL (versioni più recenti). MYSQL utilizza il carattere ` (accento grave) come delimitatore. In qualsiasi database, è necessario delimitare i nomi delle colonne solo se contengono spazi o sono parole riservate (per quel database). Consulta la documentazione del software di database in uso per verificare quali caratteri vengono utilizzati come delimitatori, se previsti.

Le parentesi graffe specificano che la voce a cui si fa riferimento è un parametro di progetto. Gli apici singoli specificano che il parametro di progetto deve essere trattato come una stringa, anziché come un numero (senza apici). La corrispondenza dei tipi è molto importante, poiché SQL distingue i tipi di dati. Il parametro di progetto deve essere dello stesso tipo della colonna nel database.

Utilizzando la sintassi SQL standard, la clausola Where può quindi essere estesa per trovare corrispondenze utilizzando più voci Database field/Part parameter, ad esempio:

[Capacitance] = '{Capacitance}' AND [Tolerance] = {Tolerance} AND [Manufacturer] = '{Manufacturer}'

In questo caso, verrebbe collegato un singolo record della tabella pertinente del database, utilizzando tre diversi parametri di progetto. Nota che la voce relativa al parametro di progetto Tolerance non è racchiusa tra apici. Ciò significa che il tipo di colonna nella tabella associata del database è Number e non String.

Utilizzando la sintassi SQL standard, puoi rendere la clausola Where semplice o complessa quanto desideri.

Mappatura dei campi del database ai parametri di progetto

I parametri di progetto di un componente posizionato da una libreria di database vengono creati/aggiunti al momento del posizionamento. I parametri effettivamente creati e le opzioni utilizzate per aggiornarne le informazioni dopo il posizionamento, tramite il comando Tools » Update Parameters From Database, sono determinati dalle informazioni di mappatura e aggiornamento specificate nel file Database Library/SVN Database Library. Queste impostazioni vengono configurate nella scheda Field Mappings della vista principale del documento.

Le opzioni di mappatura e aggiornamento vengono specificate per ciascuna tabella.

Specifica le opzioni di mappatura e aggiornamento dei parametri nella scheda Field Mappings del documento DbLib/SVNDbLib.Specifica le opzioni di mappatura e aggiornamento dei parametri nella scheda Field Mappings del documento DbLib/SVNDbLib.

Mappatura di modelli e parametri

Le prime due colonne (da sinistra) della scheda Field Mappings consentono di controllare quali informazioni del database devono essere mappate agli attributi, ai modelli e ai parametri del componente.

  • Database Field Name - questa colonna elenca tutti i nomi dei campi (colonne) della tabella attualmente attiva del database.
  • Design Parameter - questa colonna definisce come deve essere utilizzato ciascun campo corrispondente del database. Può servire a indicare il simbolo o il modello di footprint di un componente (in tal caso sarà racchiuso tra parentesi quadre), oppure può essere incluso come parametro del componente (in tal caso non sarà racchiuso tra parentesi).
Quando apri un documento DbLib/SVNDbLib collegato a un database, noterai che alcuni parametri di progetto includono parentesi quadre e altri no. Le parentesi quadre indicano un nome riservato, ad esempio [Library Ref]. Questi dati vengono utilizzati per popolare gli attributi e i modelli del componente. I parametri di progetto che non includono parentesi quadre diventano parametri del componente.

La mappatura iniziale viene eseguita automaticamente al momento della connessione al database, mappando tutti i campi del database.

Nota che la mappatura automatica presuppone che i nomi dei campi del database corrispondano ai nomi riservati utilizzati in Altium Designer. In caso contrario, la mappatura deve essere configurata manualmente.

Attributi e modelli

Se il nome del campo del database è uno dei seguenti nomi riservati, la voce di mappatura dell'attributo/modello corrispondente verrà impostata automaticamente nel campo Design Parameter:

  • Description → [Description]
  • Footprint Ref → [Footprint Ref]
  • Footprint Path → [Footprint Path]
  • Footprint Ref n → [Footprint Ref n]
  • Footprint Path n → [Footprint Path n]
In una tabella del database è possibile specificare un numero illimitato di riferimenti ai modelli di footprint (e relativi percorsi) e mapparli nel file DbLib/SVNDbLib. Nei nomi riservati, n rappresenta un numero intero positivo a partire da 2.
  • Library Ref → [Library Ref]
  • Library Path → [Library Path]
  • Orcad Footprint → [Orcad Footprint]
  • Orcad Library → [Orcad Library]
Questi riferimenti vengono utilizzati durante l'importazione di un file di configurazione OrCAD CIS e delle relative librerie e la generazione di una libreria di database standard (DbLib).
  • PCB3D Ref → [PCB3D Ref]
  • PCB3D Path → [PCB3D Path]

    • I riferimenti a PCB3D riguardano il visualizzatore 3D legacy e non devono essere utilizzati per i nuovi progetti. Il motore 3D nativo dell'editor PCB può eseguire il rendering dei corpi dei componenti e dei file di modelli 3D importati associati ai footprint dei componenti.
    • Le mappature dei modelli PCB3D possono essere definite in un file SVNDbLib; tuttavia, l'archiviazione delle librerie di modelli PCB3D nel repository Subversion non è supportata.
  • Sim Description → [Sim Description]
  • Sim Excluded Parts → [Sim Excluded Parts]
  • Sim File → [Sim File]
  • Sim Kind → [Sim Kind]
  • Sim Model Name → [Sim Model Name]
  • Sim Netlist → [Sim Netlist]
  • Sim Parameters → [Sim Parameters]
  • Sim Port Map → [Sim Port Map]
  • Sim Spice Prefix → [Sim Spice Prefix]
  • Sim SubKind → [Sim SubKind]

    Consulta la sezione Mappatura dei modelli di simulazione di seguito per ulteriori dettagli sui campi relativi ai modelli di simulazione.
    Per un componente in un database esterno è possibile definire un solo collegamento a un modello di simulazione. In genere, a un componente viene collegato un solo modello di simulazione. Se desideri impostare più collegamenti a modelli di simulazione, gli altri collegamenti dovranno essere definiti e memorizzati insieme al componente nel file della libreria di simboli schematici di origine.
    I modelli di simulazione collegati sono supportati per una libreria di database sottoposta a controllo di versione (SVNDbLib); tuttavia, l'archiviazione dei file dei modelli di simulazione nel repository Subversion non è supportata.

Queste mappature definiscono le informazioni sugli attributi e sui modelli del componente. Quando il componente viene posizionato, il simbolo schematico specificato dal campo [Library Ref] del record corrispondente nel database verrà estratto dalla libreria di simboli schematici specificata. Analogamente, le informazioni sul footprint PCB e sul modello di simulazione memorizzate nel record verranno aggiunte al componente rispettivamente come modelli di footprint e di simulazione collegati.

Per poter posizionare un componente dalla Database Library/SVN Database Library su uno schema, la voce [Library Ref] deve essere presente nella colonna Design Parameter ed essere mappata al Database Field Name che specifica il simbolo schematico. Se la tabella del database contiene il riferimento al simbolo sotto un diverso Database Field Name, ad esempio SCH Symbol, dovrai impostare manualmente la voce Design Parameter associata a questo campo su [Library Ref], utilizzando l'elenco a discesa disponibile per quella cella.

Analogamente, se le informazioni di riferimento ai modelli vengono inserite nel database utilizzando nomi di campo diversi, dovrai eseguire manualmente la mappatura scegliendo la voce Design Parameter appropriata ([Footprint Ref], [Footprint Ref n], [PCB3D Ref], [Sim Model Name] e così via) dall'elenco a discesa, per ciascun campo.

Mapping the symbol and footprint models from the database to the design componentPer definire le informazioni sul simbolo e sui modelli di un componente al momento del posizionamento, gli elementi fondamentali della mappatura sono i campi di riferimento ai simboli e ai modelli nel database
: assicurati che la mappatura definita includa un riferimento al simbolo e almeno un riferimento a un footprint PCB.

Come accennato, è possibile mappare più modelli PCB. Il Database Field Name mappato a Design Parameter [Footprint Ref] sarà il footprint predefinito quando il componente viene posizionato sullo schema. È questo il footprint che verrà posizionato quando il progetto viene trasferito all'ambiente PCB.
Durante la mappatura di simboli e modelli per un file DbLib/SVNDbLib, le informazioni sui percorsi nel database esterno sono facoltative. Per ulteriori informazioni, consulta Specifica delle posizioni delle librerie di simboli e modelli.

Mappatura dei modelli di simulazione

Questa sezione descrive ciascuno dei campi del database che possono essere aggiunti a una tabella di un database esterno per definire il collegamento al modello di simulazione, che verrà creato al posizionamento del componente.

  • Sim Model Name – il nome del modello che si desidera utilizzare. Dopo il posizionamento del componente, questa informazione apparirà nel campo Model Name della finestra di dialogo Sim Model.

    Quando si associano i campi del database ai parametri di progetto nel file DBLib, il campo Sim Model Name è analogo ai campi Footprint Ref, Library Ref, ecc.
  • Sim Description – una descrizione del modello collegato. Questa informazione è facoltativa e non influisce sul funzionamento del collegamento al modello di simulazione.
  • Sim File – un file di modello specifico in cui cercare il modello di simulazione indicato nel campo Sim Model Name. Questo campo può essere utilizzato in diversi modi:

    • È possibile inserire un percorso assoluto a un file di modello (ad esempio, C:\DbLibs\Switching Diodes\Libraries\JAS33.mdl). Il modello specificato nel campo Sim Model Name verrà cercato all'interno di questo file e utilizzato se trovato.
    • È possibile inserire un percorso relativo (rispetto al file DbLib) a un file di modello (ad esempio, Libraries\JAS33.mdl). Il modello specificato nel campo Sim Model Name verrà cercato all'interno di questo file e utilizzato se trovato.
    • È possibile inserire solo il nome del file di modello (ad esempio, JAS33.mdl)). I percorsi di ricerca definiti nel file DbLib verranno utilizzati per individuare il primo file di modello che corrisponde al nome specificato e che contiene il modello indicato nel campo Sim Model Name.
    • È possibile lasciare il campo vuoto. I percorsi di ricerca definiti nel file DbLib verranno utilizzati per individuare il primo file di modello contenente il modello indicato nel campo Sim Model Name.
    I percorsi di ricerca per il file DbLib vengono definiti nella scheda Symbol & Model Search Paths della finestra di dialogo Database Library Options (Tools » Options).
  • Sim Kind – la categoria principale del modello a cui viene creato il collegamento.
  • Sim SubKind – il tipo di modello a cui viene creato il collegamento.
  • Sim Netlist – le informazioni del template di netlist, in base al tipo di modello a cui viene creato il collegamento. Questo campo diventa particolarmente importante se si specifica un template di netlist personalizzato e si imposta il campo Sim SubKind su Generic Editor, ottenendo un maggiore controllo sulle informazioni inserite nella netlist.

    Questo campo deve essere definito e non può essere lasciato vuoto; in caso contrario, non verrà inserita alcuna voce relativa al modello nella netlist di simulazione e il componente non verrà simulato quando viene posizionato dalla libreria di database.
  • Sim Spice Prefix – il prefisso SPICE per il tipo di modello a cui si sta creando il collegamento.
  • Sim Port Map – la mappatura dei pin del componente nello schema ai pin del modello collegato. Dopo il posizionamento del componente, queste informazioni appariranno nell'area Pin Mapping della finestra di dialogo Sim Model.

    Ogni coppia di pin deve essere inserita nel seguente formato:

    (SchematicPinNumber:ModelPinNumber),

    separando ciascuna coppia mappata con una virgola.

    Ad esempio, quando si mappa un modello di simulazione di un diodo in cui il pin 1 dello schema (anodo) deve essere mappato al pin 1 del modello (anodo) e il pin 3 dello schema (catodo) deve essere mappato al pin 2 del modello (catodo), nel campo del database si dovrà inserire:

    (1:1),(3:2)

  • Sim Excluded Parts – creare questo campo nel database se si desidera escludere dalla simulazione alcune parti di un componente multiparte. Queste informazioni corrispondono all'opzione Exclude part from simulation nell'area Pin Mapping della finestra di dialogo Sim Model.

    Per impostazione predefinita, tutte le parti di un componente multiparte vengono incluse nella simulazione, quindi è sufficiente specificare, tramite il loro numero, le parti che si desidera escludere. Separare con virgole le diverse parti nell'elenco di esclusione. Ad esempio, se un componente ha quattro parti e non si desidera che le parti 2 e 4 siano incluse in alcuna simulazione, nel campo del database si dovrà inserire quanto segue:

    2,4

  • Sim Parameters – creare questo campo nel database se si desidera assegnare valori ai parametri di simulazione del modello. Si tratta di parametri che possono essere definiti a livello di componente, a differenza dei parametri più avanzati che possono essere inclusi in un file di modello.

    Un parametro deve essere inserito nel seguente formato:

    ParameterName=Value,

    I parametri multipli devono essere separati dal carattere barra verticale (|).

    Si ricorda che un parametro di simulazione a livello di componente può anche essere impostato come parametro del componente: apparirà nell'area Parameters della finestra di dialogo Component Properties associata e potrà quindi essere visualizzato sul foglio dello schema. Per impostazione predefinita, un parametro inserito nel campo Sim Parameters verrà aggiunto automaticamente come parametro del componente. Se non si desidera che un parametro di simulazione venga aggiunto come parametro del componente, è sufficiente anteporre un punto esclamativo al nome del parametro (ad esempio, !Initial Voltage=100mV).

    Si consideri un modello di diodo con i seguenti quattro parametri a livello di componente:

    • Fattore di area
    • Condizione iniziale
    • Tensione iniziale
    • Temperatura.

    Si supponga ora di aggiungere nel database i valori per il fattore di area (ad esempio 2) e la temperatura (ad esempio 22 °C). Si desidera inoltre che nessuno dei due venga aggiunto come parametro del componente. Nel campo Sim Parameters si dovrà inserire:

    !Area Factor=2|!Temperature=22

Dopo aver posizionato il componente dalla libreria di database, è possibile verificare che le informazioni definite per il collegamento di simulazione siano effettivamente quelle richieste. Con il componente posizionato selezionato nell'area di progettazione, selezionare la voce del modello di simulazione nell'area Parameters del pannello Properties, quindi fare clic sul pulsante  per accedere alla finestra di dialogo Sim Model, dalla quale è possibile verificare che:

  • Il file del modello sia stato individuato come previsto. Una volta trovato, la scheda Model File della finestra di dialogo mostrerà il contenuto del file.
  • Le restanti informazioni di simulazione provenienti dal database siano state aggiunte alla finestra di dialogo come previsto.

I valori memorizzati nei campi del database verranno utilizzati per il componente posizionato dalla libreria di database durante l'esecuzione di una simulazione. Si noti tuttavia che, se si accede alla finestra di dialogo Sim Model di un modello di simulazione per un componente posizionato da una libreria di database e si fa clic su OK, i campi Sim Netlist e Sim Spice Prefix verranno impostati automaticamente per quel componente in base al testo del modello scelto.

Parametri

Tutti gli altri nomi dei campi del database verranno mappati automaticamente a parametri di progetto con gli stessi nomi. Ad esempio, se un campo del database si chiama Tolerance, a esso verrà mappato un parametro di progetto denominato Tolerance. È possibile modificare il nome di un parametro di progetto facendo clic nella relativa cella e digitando direttamente il nuovo nome. Sono questi i nomi dei parametri di progetto che appariranno nell'area Parameters della finestra di dialogo delle proprietà associata al componente, una volta che questo sarà stato posizionato su un foglio dello schema.

A un componente nel database può essere associato un gran numero di campi dati, non tutti da aggiungere necessariamente al componente come parametri di progetto quando viene posizionato su un foglio schematico. Molte di queste informazioni possono essere necessarie solo per generare una distinta base. La finestra di dialogo Report Manager consente di aggiungere informazioni sui parametri a una distinta base direttamente da un database collegato, riducendo così la quantità di informazioni «trasportate» con i documenti sorgente dello schema. Per ulteriori informazioni, consultare la sezione Preparazione di una distinta base in Report Manager.

Per i campi che non si desidera esplicitamente mappare dal database, impostare la voce Design Parameter su [None]. I campi del database non mappati sono contrassegnati nella scheda da un'icona a croce rossa (Cross icon, indicating that a database field is not mapped to a component parameter). I campi del database mappati sono contrassegnati da un'icona con un segno di spunta verde (Tick icon, indicating that a database field is mapped to a component parameter).

Configurare la mappatura dei parametri secondo necessità. Impostare su [None] per impedire che un parametro del database venga mappato al componente posizionato. Se necessario, i parametri non mappati possono essere inclusi direttamente nella distinta base.Configurare la mappatura dei parametri secondo necessità. Impostare su [None] per impedire che un parametro del database venga mappato al componente posizionato. Se necessario, i parametri non mappati possono essere inclusi direttamente nella distinta base.

Per rimappare rapidamente un campo non mappato, fare clic nella riga corrispondente e utilizzare la scorciatoia da tastiera Ctrl+D. Per le mappature dei modelli, è necessario effettuare manualmente la selezione dal menu a discesa Design Parameter associato.

Opzioni di aggiornamento dei parametri

Le colonne rimanenti nella scheda Field Mappings consentono di specificare le azioni da eseguire sui parametri quando si posiziona per la prima volta un componente dalla libreria database oppure quando si aggiorna un componente già posizionato tramite il comando Tools » Update Parameters From Database.

Le quattro colonne sono le seguenti:

  • Update Values - una cella in questa colonna consente di determinare l'azione da eseguire se il parametro esiste sia sul foglio schematico sia nel database, ma i valori sono attualmente diversi. È possibile scegliere di aggiornare il parametro del componente posizionato con il valore memorizzato nel database (Update) oppure di non aggiornarlo affatto (Do not update). Questa opzione viene rispettata quando si utilizza il comando Update Parameters From Database, dopo il posizionamento del componente.
  • Add To Design - una cella in questa colonna consente di determinare l'azione da eseguire se il parametro è presente nel database, ma non esiste per il componente posizionato. È possibile scegliere di aggiungere il parametro (Add), non aggiungerlo (Do not add) oppure aggiungerlo solo se nel database gli è assegnato un valore (Add only if not blank in database). Questa opzione viene rispettata sia al primo posizionamento del componente dalla libreria database sia quando si utilizza il comando Update Parameters From Database, dopo il posizionamento del componente.
  • Visible On Add - una casella di controllo in questa colonna consente di determinare se un parametro appena aggiunto, in seguito al posizionamento iniziale o a un aggiornamento successivo, viene reso visibile per il componente sul foglio schematico (opzione abilitata) oppure no (opzione disabilitata).
  • Remove From Design - una cella in questa colonna consente di determinare l'azione da eseguire se il parametro esiste per il componente posizionato, ma non è presente nel database oppure è presente ma privo di valore. È possibile scegliere di non rimuovere mai il parametro (Do not remove) oppure di rimuoverlo solo se nel database non gli è assegnato alcun valore (Remove only if blank in database). Questa opzione viene rispettata quando si utilizza il comando Update Parameters From Database, dopo il posizionamento del componente.

Inizialmente, i campi Update Values, Add To Design e Remove From Design, per ciascun campo del database mappato, sono impostati sulla voce Default e l'opzione Visible On Add è disabilitata, come illustrato nell'immagine seguente.

Opzioni iniziali (predefinite) di aggiornamento dei parametri.Opzioni iniziali (predefinite) di aggiornamento dei parametri.

Osservando l'immagine, è importante evidenziare quattro aspetti relativi alle opzioni di aggiornamento:

  1. I campi del database non mappati non hanno opzioni di aggiornamento associate.
  2. Le mappature basate su attributi e modelli (voci tra parentesi quadre nella colonna Design Parameter) non hanno opzioni di aggiornamento associate, poiché non sono parametri di progetto.
  3. Il campo chiave (ad esempio Part Number nell'immagine) non ha opzioni di aggiornamento associate. Questo campo viene utilizzato esclusivamente per la corrispondenza dei parametri.
  4. L'impostazione Default fa sì che un'opzione di aggiornamento segua la corrispondente definizione predefinita, specificata nella scheda Default Actions della finestra di dialogo Database Library Options (Tools » Options dai menu principali oppure Options dal menu contestuale della scheda Table Browser). È possibile accedere a questa finestra di dialogo anche facendo clic sul pulsante Options nell'area Field Settings della vista del documento.

Definire le opzioni predefinite di aggiornamento dei parametri in un'unica posizione per una DbLib. Passare il puntatore sull'immagine per visualizzare l'equivalente per una SVNDbLib.Definire le opzioni predefinite di aggiornamento dei parametri in un'unica posizione per una DbLib. Passare il puntatore sull'immagine per visualizzare l'equivalente per una SVNDbLib.

Il quarto aspetto è vantaggioso perché consente di specificare le opzioni di aggiornamento in un'unica posizione e di fare riferimento a tale posizione quando si definiscono le opzioni di aggiornamento per ciascun campo mappato. Ecco perché la voce Default viene caricata automaticamente nei campi di aggiornamento pertinenti quando si mappa un campo del database a un parametro di progetto.

Per sovrascrivere l'impostazione predefinita di un'opzione di aggiornamento, fare clic nel campo di aggiornamento pertinente, nella scheda Field Mappings, quindi fare nuovamente clic per accedere a un menu a discesa con le opzioni di aggiornamento disponibili.

Se necessario, le opzioni di aggiornamento dei parametri possono essere sovrascritte manualmente.Se necessario, le opzioni di aggiornamento dei parametri possono essere sovrascritte manualmente.

In questo modo, si ha il pieno controllo su come vengono aggiornati i parametri del progetto. È possibile impostare tutti i campi su Default e prendere le decisioni di aggiornamento necessarie nella finestra di dialogo Database Library Options, impostare ogni campo di aggiornamento singolarmente oppure combinare i due approcci: la scelta è interamente a propria discrezione. Per i componenti posizionati, l'aggiornamento viene eseguito tramite una finestra di dialogo Engineering Change Order. Se in questa fase sono presenti aggiornamenti che si preferisce non eseguire, è possibile escludere le modifiche specifiche, mantenendo così la decisione finale su quali parametri di progetto aggiornare.

Specifica delle posizioni delle librerie di simboli e modelli

Quando si posiziona un componente da una libreria database, il suo simbolo, specificato dalla mappatura [Library Ref], viene estratto dalla libreria schematica specificata (*.SchLib). Analogamente, i riferimenti ai modelli (footprint, PCB3D, simulazione) specificati nel database risiedono nei file sottostanti di libreria PCB (*.PcbLib), libreria PCB3D (*.PCB3DLib) e modello di simulazione (*.mdl, *.ckt). I percorsi di questi file possono essere specificati esplicitamente nel database:

  • Inserendo un percorso assoluto del file.
  • Inserendo un percorso relativo del file.

Se nel database sono stati definiti campi per le informazioni sui percorsi, questi devono essere mappati ai parametri di progetto appropriati: [Library Path], [Footprint Path], [PCB3D Path], [Sim File] e così via (vedere la precedente sezione Mappatura di modelli e parametri).

L'inserimento di percorsi, anche relativi, in una tabella del database può risultare un po' limitante. Se si modifica la posizione di una libreria o di un file di modello, occorre aggiornare di conseguenza la tabella del database. Per offrire maggiore flessibilità, è possibile specificare le informazioni di ricerca delle librerie direttamente nel file DbLib/SVNDbLib. Ciò consente di specificare nel database il nome della libreria sorgente o del file di modello, oppure di non definirlo affatto.

Using Search Paths with a large number of symbol/model files - sebbene i percorsi di ricerca offrano maggiore flessibilità e semplicità nella configurazione delle modalità di individuazione di simboli e modelli, questo approccio non è consigliato quando nel percorso di ricerca è presente un numero elevato di file di simboli o modelli. A seconda della convenzione di denominazione dei file utilizzata, i percorsi di ricerca possono richiedere la scansione di ogni file di libreria/modello presente nel percorso ogni volta che è necessario un simbolo/modello, ad esempio durante la consultazione dei componenti o il trasferimento del progetto dallo schema al PCB.

Per una libreria database

Per una DbLib, i percorsi di ricerca delle librerie sono definiti nella scheda Symbol and Model Search Paths della finestra di dialogo Database Library Options (Tools » Options). È possibile accedere a questa finestra di dialogo anche facendo clic sul pulsante Options nell'area Field Settings della vista del documento.

Definizione dei percorsi di ricerca per le librerie di simboli e modelli.Definizione dei percorsi di ricerca per le librerie di simboli e modelli.

Per aggiungere un percorso all'elenco:

  1. Digitare il percorso direttamente nel campo sotto l'area Library Search Paths oppure fare clic sul pulsante Browse for a folder button per accedere alla finestra di dialogo Browse for Folder, da cui è possibile individuare la directory in cui si trovano i file di libreria/modello richiesti.
  2. È possibile aggiungere un percorso assoluto oppure un percorso relativo (rispetto alla posizione del file DbLib). Per scegliere, utilizzare l'opzione Add/Update As Relative Path.
  3. Dopo aver specificato il percorso desiderato, aggiungerlo all'elenco dei percorsi di ricerca facendo clic sul pulsante Add .
  4. Continuare ad aggiungere altri percorsi di ricerca secondo necessità.
Se si inserisce direttamente un percorso errato (ad esempio, verso una cartella che non esiste), è comunque possibile aggiungerlo, ma nell'elenco apparirà in grigio per indicare che si tratta di un percorso di ricerca non valido. Se ci si accorge di aver inserito un percorso per errore, è possibile selezionarlo nell'elenco e fare clic sul pulsante Remove , oppure modificarne la definizione e fare clic sul pulsante Update .

I percorsi di ricerca delle librerie determinano dove è possibile trovare i file di libreria e modello durante il posizionamento dalla libreria database e durante la ricerca di un modello dopo il posizionamento. Il modello specifico utilizzato dipende da come sono stati configurati i percorsi di ricerca delle librerie e dall'eventuale aggiunta di informazioni specifiche sulle librerie nel database. La ricerca procederà nel seguente ordine:

  1. Se nel campo del percorso mappato per il simbolo o il modello è presente un percorso assoluto, utilizzare quel file di libreria/modello ed estrarre il simbolo o il modello specificato nel relativo campo di riferimento.
  2. Se nel campo del percorso mappato per il simbolo o il modello è presente un percorso relativo, utilizzare quel file di libreria/modello ed estrarre il simbolo o il modello specificato nel relativo campo di riferimento.
  3. Se nel campo del percorso mappato per il simbolo o il modello è presente solo il nome di un file di libreria/modello, utilizzare i percorsi di ricerca per individuare il primo file di libreria/modello il cui nome corrisponde a quello specificato e che contiene il simbolo o il modello specificato nel relativo campo di riferimento.
  4. Se nel database non sono presenti informazioni sul file di libreria/modello, utilizzare i percorsi di ricerca per individuare il primo file di libreria/modello contenente il simbolo o il modello specificato nel relativo campo di riferimento.

Per una libreria database SVN

Per una SVNDbLib, le directory di base all'interno del repository Subversion, in cui risiedono i simboli e i modelli di footprint, sono specificate nella scheda SVN Repository della finestra di dialogo Database Library Options (Tools » Options). È possibile accedere a questa finestra di dialogo anche facendo clic sul pulsante Options nell'area Field Settings della vista del documento.

Definizione delle directory di base del repository per simboli e footprint.Definizione delle directory di base del repository per simboli e footprint.

Utilizzare i campi disponibili nell'area Models Location per specificare la directory di base per i simboli e i footprint. Fare clic sul pulsante Click the ellipsis button to select the repository folder for the symbols and footprints a destra di un campo per accedere alla finestra di dialogo Browse for directory, che consente di esplorare il repository collegato. Utilizzare questa finestra di dialogo per selezionare la cartella desiderata.

Ricerca della directory pertinente nel repository SVN collegato.Ricerca della directory pertinente nel repository SVN collegato.

È importante sottolineare che i simboli e i footprint devono risiedere all'interno delle directory di base del repository specificate. Naturalmente, possono trovarsi in sottocartelle di tali directory e i percorsi specificati per i simboli e i footprint possono puntare alla stessa directory nel repository.

Le posizioni dei modelli determinano dove è possibile trovare i file di libreria e modello durante il posizionamento dalla libreria database sottoposta a controllo di versione e durante la ricerca di un modello dopo il posizionamento. Il simbolo di schema e i modelli di footprint specifici utilizzati dipendono da come sono state configurate queste posizioni e dall'eventuale aggiunta di informazioni specifiche sulle librerie nel database. La ricerca procederà nel seguente ordine:

  1. Se nel campo del percorso mappato per il simbolo o il modello di footprint è presente un percorso assoluto (ad esempio http://MyServer/svn/MyCompany/ParentDirectory/SchematicSymbols/Capacitor_NonPolarized.SchLib), utilizzare quel file di libreria ed estrarre il simbolo o il footprint specificato nel relativo campo di riferimento.
  2. Se nel campo del percorso mappato per il simbolo o il modello di footprint è presente un percorso relativo (rispetto alla directory radice del repository) (ad esempio /ParentDirectory/SchematicSymbols/Capacitor_NonPolarized.SchLib), utilizzare quel file di libreria ed estrarre il simbolo o il footprint specificato nel relativo campo di riferimento. L'URL del repository, specificato nell'area Repository Server Connection della finestra di dialogo, verrà anteposto al percorso inserito per ottenere l'indirizzo assoluto.
  3. Se nel campo del percorso mappato per il simbolo o il modello di footprint è presente solo il nome di un file di libreria (ad esempio Capacitor_NonPolarized.SchLib), utilizzare le posizioni dei modelli specificate all'interno del repository per individuare il primo file di libreria il cui nome corrisponde a quello specificato e che contiene il simbolo o il modello di footprint specificato nel relativo campo di riferimento.
Durante la ricerca di un simbolo/modello corrispondente, i percorsi delle cartelle nella directory di base dei simboli o dei footprint vengono appiattiti, ordinati e analizzati in ordine alfabetico. Se si utilizza la procedura guidata di suddivisione delle librerie, sarà sempre presente una libreria corrispondente con il nome del simbolo/footprint effettivo.
  1. Se nel database non sono presenti informazioni sul file di libreria, utilizzare le posizioni dei modelli specificate per individuare il primo file di libreria contenente il simbolo o il modello di footprint specificato nel relativo campo di riferimento.
Durante l'individuazione del simbolo/footprint, il sistema cercherà inizialmente la prima libreria con lo stesso nome del simbolo o del footprint. Ad esempio, se il nome logico del simbolo nel database (specificato dalla mappatura [Library Ref]) è Capacitor_NonPolarized, il sistema cercherà il primo file denominato Capacitor_NonPolarized.SchLib e cercherà il simbolo al suo interno. Se non è possibile trovare il simbolo/footprint in questo modo, il sistema cercherà una corrispondenza in tutte le librerie.
AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents