Collegamento dei componenti esistenti a un database aziendale tramite un file di collegamento al database

A colpo d'occhio

Collega i componenti esistenti negli schemi o nelle librerie al database centralizzato dei componenti della tua azienda utilizzando un file Database Link in Altium Designer. Questo articolo spiega in cosa DbLink si differenzia dagli approcci basati sulle librerie di database, come creare un file DbLink e come configurare una connessione a un database esterno. Illustra inoltre come sincronizzare i parametri mappati dei componenti con i record del database, in modo da includere queste informazioni nella distinta base. Continua a leggere per compiere il prossimo passo verso la sincronizzazione dei dati dei tuoi componenti.

- Scopri quando utilizzare DbLink anziché DbLib o SVNDbLib.
- Impara a creare un file Database Link e a configurare le connessioni ad Access, Excel e altri database supportati.
- Individua i requisiti per il collegamento tramite campi chiave e gli aspetti da considerare per i motori di database a 64 bit.
Approfondisci con l'IA:

Un'esigenza comune a molte organizzazioni è collegare i componenti CAD elettronici al database centrale dei componenti dell'azienda. Altium Designer soddisfa questa esigenza offrendo la possibilità di collegare i componenti esistenti ai record del database aziendale, attraverso la creazione e l'utilizzo di un file Database Link. Il file Database Link viene aggiunto al progetto o al pacchetto di librerie, consentendo di collegare, rispettivamente, i componenti già posizionati sui fogli dello schema o, più comunemente, i componenti definiti in una libreria di schemi sorgente.

Una volta stabilito il collegamento, è possibile trasferire le informazioni parametriche mappate dai record del database ai parametri di progetto dei componenti utilizzando il comando Tools » Update Parameters From Database. Queste informazioni possono quindi essere incluse nella distinta base (BOM) finale, pronta per l'approvvigionamento dei componenti.

The Move from 32-bit to 64-bit Software

Con il rilascio di Altium Designer versione 18.0 e Altium NEXUS versione 1.0, il software di progettazione è passato a 64 bit. Per collegare i componenti di progetto a un database in una versione a 64 bit del software Altium, anche il motore del database di backend deve essere a 64 bit. Se si utilizza Microsoft Access o Excel per gestire i dati di backend ed è installata una versione a 32 bit di Office, è possibile installare anche il motore di database Microsoft Access a 64 bit. Per informazioni dettagliate su come procedere, seguire le istruzioni nella pagina Utilizzo delle librerie di database con Altium Designer a 32 bit e a 64 bit sullo stesso computer.

Se si tenta di connettersi tramite il motore di database Microsoft Access a 32 bit, viene visualizzato il seguente messaggio di errore.

Error dialog, reporting that a 64-bit version of the Microsoft Access Database engine is required for database linking

Si noti che alcuni errori di connessione, come una sintassi errata nei dettagli Provider di Connection String, possono causare il richiamo del motore di database sbagliato e la visualizzazione della finestra di errore mostrata sopra, anche dopo l'installazione del motore di database a 64 bit.

Una nota sulle opzioni di collegamento...

Altium Designer offre tre metodi per collegare un componente a un database, utilizzando rispettivamente un file Database Link (*.DbLink), un file Database Library (*.DbLib) o un file SVN Database Library (*.SVNDbLib). L'approccio DbLink offre un metodo efficiente per collegare e mantenere sincronizzati i componenti utilizzati nel progetto (o nelle librerie) con i dati inseriti nel database. L'approccio DbLib/SVNDbLib riprende questa comprovata efficienza di collegamento e vi aggiunge la libertà di posizionare un componente direttamente dal database, creando di fatto il componente in modo dinamico a partire dalle informazioni memorizzate nel record corrispondente del database.

Prima di approfondire la funzionalità di collegamento al database, vale la pena esaminare le differenze tra questi due metodi dal punto di vista del loro utilizzo.

Collegamento tramite un file Database Link

  • Con questo metodo, il file Database Link definisce il collegamento tra il componente dello schema e un record corrispondente in un database. La corrispondenza con il record viene stabilita tramite il collegamento mediante campi chiave, che può utilizzare un singolo campo chiave (ad esempio un codice componente) oppure più campi chiave (definendo una clausola Where).
  • Con questo metodo di collegamento, le informazioni sui modelli e sui parametri del componente devono essere predefinite nel componente di libreria di Altium Designer. La definizione del componente di libreria deve inoltre includere le informazioni necessarie sui campi chiave. Una volta completata questa definizione, si aggiunge un file Database Link al pacchetto di librerie o al progetto; a questo punto è possibile sincronizzare le informazioni del componente (parametri) con il contenuto dei campi nel database.
  • Sebbene non sia necessario che ogni componente fisico definito da ciascun record del database corrisponda a un componente di libreria Altium Designer univoco — più componenti del database possono condividere lo stesso simbolo — questo metodo di collegamento viene in genere utilizzato secondo una corrispondenza «un record del database a un componente Altium Designer». Il componente Altium Designer univoco può essere un'istanza posizionata su un foglio dello schema oppure un componente univoco in una libreria di componenti.
  • Con il collegamento al database di tipo DbLink, il file Database Link viene incluso nel pacchetto di librerie o nel progetto.

Il collegamento tra i componenti di libreria e un database esterno è possibile solo se la libreria fa parte di un pacchetto di librerie integrate (*.LibPkg). Scegliere il comando File » New » Library » Integrated Library per creare un nuovo pacchetto di librerie, quindi aggiungervi le librerie di schemi sorgente.

► Ulteriori informazioni sulle librerie integrate.

Collegamento tramite un file Database Library

Related page: Librerie di database

  • Anche con questo metodo, il file Database Library definisce il collegamento tra il componente dello schema e un record corrispondente in un database. Anche in questo caso, la corrispondenza con il record viene stabilita tramite il collegamento mediante campi chiave, che può utilizzare un singolo campo chiave (ad esempio un codice componente) oppure più campi chiave (definendo una clausola Where).
  • Con questo metodo di collegamento, le informazioni sul simbolo, sui modelli e sui parametri di un componente sono memorizzate nella definizione del record relativo a quel componente nel database esterno. Il componente dello schema a cui si fa riferimento (memorizzato in una libreria di componenti sottostante (*.SchLib)) è costituito soltanto dal simbolo: non ha modelli collegati né parametri di progetto definiti.
  • Quando il componente viene posizionato, le informazioni sui suoi parametri e modelli vengono create al momento, utilizzando i campi corrispondenti del record del database individuato e in base alla mappatura definita. Uno o più di questi parametri verranno quindi utilizzati per mantenere un collegamento permanente al database, secondo i criteri di corrispondenza definiti, consentendo successive sincronizzazioni dopo il posizionamento.
  • Questo metodo di collegamento, grazie alla creazione dinamica dei componenti al momento del posizionamento, si presta molto bene a un utilizzo secondo una corrispondenza «più record del database a un componente Altium Designer». Ad esempio, il database potrebbe includere la serie di resistori E96, con ogni record che fa riferimento allo stesso simbolo di resistore nello schema e alla stessa impronta PCB.
  • A differenza del collegamento al database di tipo DbLink, in cui il file DbLink deve essere incluso nel pacchetto di librerie (o nel progetto), il file DbLib/SvnDbLib non deve necessariamente essere aggiunto al progetto. La libreria di database (DbLib) è inclusa nelle librerie disponibili, accessibili dal pannello Components. Si ricordi che le librerie disponibili possono comprendere librerie di progetto, librerie installate o librerie presenti nei percorsi di ricerca specificati.
  • In genere, i file DbLib/SVNDbLib vengono configurati organizzandoli per libreria. Ad esempio, si potrebbe avere un file per tutti i resistori presenti nel database aziendale, un altro per i condensatori e così via.
Una SVN Database Library (*.SVNDbLib) è un'estensione del modello di collegamento DbLib. Questo tipo di file viene utilizzato esattamente come un file DbLib, ma il simbolo dello schema e i modelli associati sono memorizzati in librerie sottoposte a controllo di versione (Subversion).

Creazione del file Database Link

Come accennato, l'elemento centrale della funzionalità di collegamento al database è il file Database Link. Questo file viene creato e gestito tramite l'editor DatabaseLink di Altium Designer. L'editor diventa disponibile quando il documento attivo nella finestra principale di progettazione è un file *.DbLink.

Esempio di file DbLink aperto nell'editor DatabaseLink.Esempio di file DbLink aperto nell'editor DatabaseLink.

Per creare un nuovo file di questo tipo:

  • Scegliere il comando File » New » Library » Database Link File dai menu principali.
  • Fare clic con il pulsante destro del mouse sulla voce del progetto desiderato nel pannello Projects e scegliere il comando Add New to Project » Database Link File dal menu contestuale.

I file Database Link, quando vengono aggiunti a un progetto, compaiono nel pannello Projects all'interno della sottocartella Settings\Database Link Files.

The DbLink file appears in the Settings folder in the Projects panel

Se è stato specificato un documento predefinito nella pagina System - New Document Defaults della finestra di dialogo Preferences, il file Database Link verrà creato utilizzando tale documento come modello. È possibile assegnare un documento predefinito diverso per un file Database Link creato come parte di un progetto PCB, di un pacchetto di librerie integrate o come documento libero.

Connessione a un database esterno

I dati delle tabelle e delle mappature appariranno nella finestra di visualizzazione principale dell'editor solo dopo che il file Database Link attivo sarà stato connesso correttamente al database esterno richiesto. La connessione viene definita utilizzando i controlli disponibili nell'area Source of Connection.

Definizione della connessione al database esterno.Definizione della connessione al database esterno.

È possibile connettersi a qualsiasi database che supporti OLE DB. Ciascuna delle opzioni disponibili in quest'area utilizza una stringa di connessione OLE DB per connettersi al database di destinazione. Alcuni database potrebbero non supportare OLE DB. Tuttavia, praticamente tutti i sistemi di gestione di database attualmente in uso sono accessibili tramite l'interfaccia Open Database Connectivity (ODBC). La funzione di collegamento al database utilizza il provider ODBC di Microsoft, che consente a un oggetto ADO (ActiveX Data Object) di connettersi a qualsiasi origine dati ODBC. Di conseguenza, è possibile connettersi a qualsiasi database ODBC. Il provider OLE DB per il database ODBC viene specificato nella stringa di connessione.

La connessione può essere definita anche nella scheda Connection della finestra di dialogo Database Connection, accessibile dal menu principale Tools o facendo clic sul pulsante Advanced (a destra del pulsante Connect , nella parte inferiore dell'area).

Connessione rapida ai database Access ed Excel

L'opzione Select Database Type offre un metodo rapido per creare una stringa di connessione quando il database di destinazione è stato creato con Microsoft Access o Microsoft Excel. Utilizzando questa opzione, selezionare il tipo di database, quindi individuare e selezionare il file di database richiesto. La stringa di connessione corrispondente verrà composta automaticamente e inserita nel campo dell'opzione Use Connection String.

È possibile specificare il percorso completo oppure scegliere di memorizzare il percorso relativo al file Database Link.

Creazione di una stringa di connessione

Se il database aziendale non è basato su Access o Excel e si desidera creare esplicitamente la stringa di connessione, abilitare l'opzione Use Connection String, quindi fare clic sul pulsante associato Build a destra. Verrà visualizzata la finestra di dialogo Data Link Properties.

Creazione di una stringa di connessione tramite la finestra di dialogo Data Link Properties. Creazione di una stringa di connessione tramite la finestra di dialogo Data Link Properties.

La finestra di dialogo si apre sulla scheda Connection . Il provider OLE DB Microsoft Office <Version> Access Database Engine OLE DB Provider è impostato per impostazione predefinita nella scheda Provider della finestra di dialogo. Questo è il provider predefinito per i nuovi file Database Link e viene utilizzato anche per connettersi ai file di database Access (*.mdb). Modificare il provider secondo necessità.

Nella scheda Connection , immettere il nome (incluso il percorso) del database a cui si desidera connettersi.

Se il database richiede credenziali di accesso, immetterle come richiesto, insieme alle eventuali altre impostazioni avanzate disponibili nella scheda Advanced della finestra di dialogo. La scheda All fornisce un elenco riepilogativo delle opzioni di collegamento definite, nonché opzioni estese relative al provider OLE DB selezionato. Anche in questa scheda è possibile modificare le opzioni secondo necessità.

Una volta definite le opzioni di collegamento, è possibile verificare che la connessione riesca facendo clic sul pulsante Test Connection (nella scheda Connection ). Se la connessione riesce, verrà visualizzata una finestra di dialogo di conferma.

La finestra di dialogo Data Link Properties è una finestra di dialogo Microsoft e, pertanto, premendo F1 o utilizzando il pulsante disponibile Help si accede al file Microsoft Data Link Help. Questo file non fa parte della documentazione di Altium.

Specifica di un file Data Link

Se l'origine dati a cui si desidera connettersi è descritta tramite un file Microsoft Data Link (*.udl), abilitare la terza opzione di connessione, Use Data Link File, e fare clic sul pulsante associato Browse per individuare il file richiesto. Un file Data Link è essenzialmente un contenitore per la memorizzazione di una stringa di connessione.

Esecuzione della connessione

Dopo aver definito la connessione al database esterno, il testo del pulsante Connect diventerà in grassetto, a indicare che è possibile procedere con la connessione. Se i dettagli della connessione sono corretti, le informazioni sulle tabelle e sulle mappature del database di destinazione verranno caricate nel file Database Link. Il testo del pulsante Connect cambierà in Connected e il pulsante verrà disabilitato.

Se si verifica un problema con i dettagli della connessione, ad esempio una stringa di connessione creata in modo errato o un percorso immesso erroneamente, la connessione non riuscirà e verrà visualizzato un messaggio di avviso. Controllare le impostazioni di connessione e fare nuovamente clic sul pulsante Connect .

Esempi di segnalazione di una connessione non riuscita.Esempi di segnalazione di una connessione non riuscita.

Se si modificano le impostazioni di connessione mentre si è connessi a un database, la connessione attiva verrà interrotta e il testo del pulsante Connect cambierà in Reconnect. Fare clic per ristabilire la connessione.

Dopo la prima connessione riuscita e il salvataggio del file Database Link, la connessione verrà stabilita automaticamente a ogni apertura del file, purché il percorso e il nome del file del database di destinazione non vengano modificati.

Elenco delle tabelle del database

Dopo la connessione riuscita al database esterno, verranno caricati i dati delle tabelle e delle mappature. Sul lato sinistro del documento DbLink sono elencate tutte le tabelle presenti nel database connesso.

Tabelle presenti nel database connesso.Tabelle presenti nel database connesso.

L'opzione Enable accanto a ciascuna voce di tabella consente di controllare se tale tabella debba essere utilizzata o meno durante l'aggiornamento dei parametri dal database.

Facendo clic su una voce di tabella nell'elenco, la relativa icona passa da Database table icon, inactive table a Database table icon, active table per contrassegnarla come tabella attualmente attiva. La tabella, con tutti i suoi dati, viene visualizzata nella scheda Table Browser del documento. Si tratta di una copia non modificabile della tabella, che consente di consultarne rapidamente il contenuto senza dover aprire il database esterno.

Consultazione di una tabella di origine nel database connesso.Consultazione di una tabella di origine nel database connesso.

Per ingrandire l'area del browser delle tabelle (come mostrato nell'illustrazione precedente), comprimere l'intera area sovrastante (impostazioni di connessione e dei campi) facendo clic sul controllo Collapse icon - collapse a region of the DbLink document, nell'angolo superiore destro della vista del documento DbLink. Fare clic su Expand icon - expand a region of the DbLink document per espanderla nuovamente.

Definizione dei criteri di corrispondenza

Per aggiornare le informazioni sui parametri dei componenti con quelle memorizzate nei campi del database esterno, è necessario innanzitutto associare ciascun componente del progetto a una riga di una tabella del database. L'area Field Settings del documento consente di definire i criteri di corrispondenza: una semplice ricerca a chiave singola oppure una corrispondenza più avanzata tramite una clausola Where.

I criteri di corrispondenza vengono specificati per ogni singola tabella.

Controllo dei criteri di corrispondenza.Controllo dei criteri di corrispondenza.

Ricerca a chiave singola

Se l'opzione Single key lookup è abilitata (impostazione predefinita), i campi Database field e Part parameter diventano disponibili. Database field elenca tutti i nomi dei campi disponibili (intestazioni delle colonne) nella tabella attiva del database. Il campo Part parameter elenca tutti i parametri presenti in tutti i componenti del progetto, sia quelli di sistema sia quelli definiti dall'utente.

Utilizza questi campi per specificare la corrispondenza tra un campo della tabella e un parametro di un componente (comune a tutti i componenti). In genere, il campo di corrispondenza in entrambi i casi identifica in modo univoco ciascun componente nel database esterno, ad esempio un codice componente. Il campo di ricerca scelto è contraddistinto nella scheda Field Mappings del documento dalla voce Design Parameter visualizzata in grigio.

Mappatura a chiave singola tramite codice componenteMappatura a chiave singola tramite codice componente

Quando si utilizza la funzione Tools » Update Parameters From Database, le informazioni vengono lette dal parametro chiave scelto nei componenti posizionati nello schema e quindi cercate nel campo (chiave) scelto del database, in tutte le tabelle abilitate. Quando viene trovata una corrispondenza, le informazioni delle altre celle di quel record della tabella di origine possono essere riportate nei parametri mappati del componente nello schema.

Corrispondenza avanzata: la clausola WHERE

Sebbene l'opzione Single key lookup funzioni bene quando è disponibile un codice/ID componente univoco su cui basare la corrispondenza, non è altrettanto efficace quando si utilizza un parametro non univoco, come la capacità o la resistenza. In questo caso è necessario utilizzare la clausola WHERE, più avanzata, che consente di specificare una corrispondenza basata su più chiavi per collegare il componente nello schema alla riga desiderata della relativa tabella del database.

Nella sua forma più semplice, la clausola WHERE (scritta con sintassi SQL) rispecchia le voci scelte per definire la ricerca a chiave singola. Ad esempio, se per Database field è stato scelto Part Number e per il parametro univoco Part parameter (presente in tutti i componenti del progetto) è stato scelto Part Number, la clausola WHERE sarà:

[Part Number] = '{Part Number}'

Le parentesi quadre attorno al campo del database (colonna della tabella) sono caratteri di delimitazione, come specificato nella scheda Advanced della finestra di dialogo Database Connection. Per accedere a questa finestra di dialogo, fai clic sul pulsante Advanced nell'area Source of Connection del documento oppure utilizza il menu principale Tools .

La scheda Advanced  della finestra di dialogo Database Connection offre ulteriori opzioni SQL per delimitare i nomi delle tabelle o utilizzare i nomi degli schemi delle tabelle nella clausola WHERE generata. La scheda Advanced della finestra di dialogo Database Connection offre ulteriori opzioni SQL per delimitare i nomi delle tabelle o utilizzare i nomi degli schemi delle tabelle nella clausola WHERE generata.

Quando si delimitano i nomi delle tabelle, i caratteri di delimitazione specifici dipendono dal database utilizzato. Ad esempio, le parentesi quadre [ ] sono utilizzabili solo nei database Microsoft come Access, Excel tramite ADO o MSSQL (versioni più recenti). MYSQL utilizza invece il carattere ' come delimitatore. In qualsiasi database, è necessario delimitare i nomi delle colonne solo se contengono spazi o sono parole riservate (per quel database). Consulta la documentazione del software di database in uso per verificare quali caratteri di delimitazione vengono utilizzati, se previsti.

Le parentesi graffe specificano che la voce a cui si fa riferimento è un parametro di progetto. Gli apici singoli indicano che il parametro di progetto deve essere trattato come una stringa anziché come un numero (senza apici). La corrispondenza dei tipi è molto importante, poiché SQL distingue i tipi di dati. Il parametro di progetto deve essere dello stesso tipo della colonna nel database.

Utilizzando la sintassi SQL standard, la clausola WHERE può quindi essere estesa per trovare corrispondenze utilizzando più voci Database field/Part parameter, ad esempio:

[Capacitance] = '{Capacitance}' AND [Tolerance] = {Tolerance} AND [Manufacturer] = '{Manufacturer}'

In questo caso, il collegamento avverrebbe con un singolo record della relativa tabella del database, utilizzando tre diversi parametri di progetto. Nota che la voce relativa al parametro di progetto Tolerance non è racchiusa tra apici. Ciò significa che il tipo della colonna nella tabella associata del database è Number e non String.

Utilizzando la sintassi SQL standard, puoi rendere la clausola WHERE semplice o complessa quanto desideri. Un esempio di clausola più complessa potrebbe essere:

[Tolerance] BETWEEN {Min Tolerance} AND {Max Tolerance} AND [Price] <= {Max Price} AND [Manufacturer] IN ('{Preferred Manufacturer 1}', '{Preferred Manufacturer 2}')

In questo caso, la tabella verrebbe interrogata per trovare i componenti corrispondenti in base a tre campi del database: Tolerance, Price e Manufacturer. La tolleranza deve rientrare nell'intervallo definito dai parametri di progetto Min Tolerance e Max Tolerance. Il prezzo deve essere inferiore o uguale a quello specificato nel parametro di progetto Max Price e il produttore può essere uno dei due candidati specificati dai parametri di progetto Preferred Manufacturer 1 e Preferred Manufacturer 2.

Creazione di un parametro del componente

Se nei componenti di Altium Designer non esiste un parametro adatto da utilizzare come Part parameter per la corrispondenza nel file DbLink, sarà necessario crearne uno. Puoi aggiungere rapidamente questo parametro di base utilizzando il comando Tools » Parameter Manager oppure il pannello Properties dell'editor pertinente.

Aggiunta di un parametro tramite la funzione di gestione dei parametri

Per aggiungere un nuovo parametro tramite la funzione di gestione dei parametri:

  1. Da un documento schematico (o da un documento di libreria schematica), scegli Tools » Parameter Manager dai menu principali. Verrà visualizzata la finestra di dialogo Parameter Editor Options. Per aggiungere il nuovo parametro a tutti i componenti, assicurati che l'opzione Parts sia abilitata nell'area Include Parameters Owned By e che All Objects sia impostato come criterio nell'area That Meet the Following Criteria.

Impostazione delle opzioni di gestione dei parametri.Impostazione delle opzioni di gestione dei parametri.

  1. Facendo clic su OK verrà visualizzata la finestra di dialogo Parameter Table Editor, che mostra tutti i parametri attualmente appartenenti a tutti gli oggetti componente presenti nei documenti schematici sorgente del progetto attivo (o ai componenti schematici della libreria schematica attiva). Fai clic sul pulsante Add Column e utilizza la finestra di dialogo Add Parameter visualizzata per definire il nome del parametro. Assicurati che l'opzione Add to all objects sia abilitata, in modo che il nuovo parametro venga aggiunto a tutti i componenti.

Al primo passaggio, lascia Value del parametro non assegnato: limitati ad aggiungere il parametro a ciascun componente. Puoi eseguire Parameter Table Editor una seconda volta per definire il valore di ciascun parametro. La finestra di dialogo supporta le scorciatoie di modifica standard di Windows, come l'uso dei tasti freccia per spostarsi da una cella all'altra, F2 per modificare il valore della cella corrente e la copia e l'incolla di blocchi da un editor di testo o da un foglio di calcolo nella cella selezionata e nel numero necessario di celle sottostanti.

Esempio di utilizzo della funzione di gestione dei parametri per aggiungere un nuovo parametro a tutti i componenti, in tutti gli schemi sorgente di un progetto.Esempio di utilizzo della funzione di gestione dei parametri per aggiungere un nuovo parametro a tutti i componenti, in tutti gli schemi sorgente di un progetto.

  1. Una volta aggiunta la nuova colonna, fai clic sul pulsante Accept Changes (Create ECO). Utilizza la finestra di dialogo Engineering Change Order visualizzata per Validate e quindi Execute le modifiche, aggiungendo il parametro a ciascuno dei componenti richiesti.

Esecuzione delle modifiche ai parametri (aggiunta del nuovo parametro a tutti i componenti) tramite un ordine di modifica tecnica (ECO).Esecuzione delle modifiche ai parametri (aggiunta del nuovo parametro a tutti i componenti) tramite un ordine di modifica tecnica (ECO).

Aggiunta di un parametro tramite il pannello Properties

È possibile aggiungere un nuovo parametro a tutti i componenti selezionati utilizzando il pannello Properties. La procedura seguente descrive il caso in cui si desideri aggiungere lo stesso parametro a tutti i componenti nel documento di libreria schematica attivo, utilizzando i pannelli SCHLIB Filter e Properties.

La procedura è simile quando si aggiunge un parametro ai componenti posizionati nei documenti schematici sorgente. In questo caso, si utilizzeranno i pannelli SCH Filter e Properties dell'editor schematico.
  1. Per prima cosa, seleziona tutti i componenti della libreria utilizzando il pannello SCH Filter e la query IsPart. Assicurati che l'opzione Whole Library sia abilitata, altrimenti verrà considerato solo il componente attivo della libreria.

Configura un filtro per selezionare tutti i componenti nel documento di libreria schematica attivo.Configura un filtro per selezionare tutti i componenti nel documento di libreria schematica attivo.

  1. Nel pannello Properties dell'editor di librerie, verifica, tramite il testo nella parte inferiore del pannello, che tutti i componenti della libreria siano attualmente selezionati. Se il pannello Properties non è visibile, fai clic sul pulsante  Panels button, click to display a menu of available panels in basso a destra nell'area di lavoro per visualizzarlo.

Verifica che tutte le parti siano selezionate. Verifica che tutte le parti siano selezionate.

  1. Aggiungi il parametro richiesto utilizzando la scheda Parameters del pannello. Fai clic sul pulsante Add per aggiungere un nuovo parametro predefinito, quindi modificane il nome secondo necessità. Tieni presente che il parametro è già stato aggiunto a tutti i componenti selezionati: facendo nuovamente clic sul pulsante Add, verrà aggiunto un secondo nuovo parametro.

Aggiungi il nuovo parametro richiesto a tutte le parti selezionate. Aggiungi il nuovo parametro richiesto a tutte le parti selezionate.

Mappatura dei campi del database ai parametri di progetto

I parametri di progetto dei componenti esistenti, sia quelli posizionati sui fogli schematici sorgente di un progetto, sia quelli definiti in una libreria di componenti schematici aggiunta a un pacchetto di librerie, vengono aggiornati con informazioni memorizzate esternamente in un database aziendale tramite il comando Update Parameters From Database, disponibile nel menu principale Tools quando è attivo il documento schematico o il documento della libreria di schematici.

Quando viene trovata una corrispondenza tra un componente di progetto e un record in una tabella del database collegato, ciò che accade successivamente è determinato dalle informazioni di mappatura e aggiornamento specificate nel file Database Link. Queste impostazioni si configurano nella scheda Field Mappings della vista principale del documento.

Le opzioni di mappatura e aggiornamento vengono specificate per ogni singola tabella.

Specifica le opzioni di mappatura e aggiornamento dei parametri nella scheda Field Mappings del documento DbLink.Specifica le opzioni di mappatura e aggiornamento dei parametri nella scheda Field Mappings del documento DbLink.

Mappatura dei parametri

Le prime due colonne da sinistra nella scheda Field Mappings consentono di controllare quali informazioni del database devono essere mappate ai parametri di un componente.

La colonna Database Field Name elenca tutti i nomi dei campi (colonne) nella tabella attualmente attiva del database. La colonna Design Parameter consente di specificare il parametro di progetto da mappare al campo corrispondente nel database. La mappatura iniziale viene eseguita automaticamente al momento della connessione al database, mappando tutti i campi del database a parametri di progetto con gli stessi nomi. Ad esempio, se un campo nel database si chiama Tolerance, a esso verrà mappato un parametro di progetto denominato Tolerance.

Puoi modificare la voce relativa a un parametro di progetto:

  • Facendo clic nella relativa cella e digitando direttamente il nome di un parametro diverso.
  • Utilizzando l'elenco a discesa associato alla cella per scegliere un parametro di progetto esistente.

Nel database potrebbe essere presente un gran numero di campi dati associati a un componente, non tutti desiderati o necessari come parametri di progetto da aggiungere al componente esistente. Gran parte di queste informazioni potrebbe essere necessaria solo per generare una distinta base. La finestra di dialogo Report Manager include un'opzione che consente di aggiungere informazioni sui parametri a una distinta base direttamente da un database collegato, riducendo così la quantità di informazioni che vengono «trasportate» con i documenti schematici sorgente. Per ulteriori informazioni, consulta la sezione Aggiunta di informazioni del database direttamente a una distinta base.

Per i campi che desideri esplicitamente escludere dalla mappatura dal database, imposta la voce Design Parameter su [None]. I campi del database non mappati sono contrassegnati nella scheda da un'icona con una croce rossa (Cross icon, indicating that a database field is not mapped to a component parameter). I campi del database mappati sono contrassegnati da un'icona con un segno di spunta verde (Tick icon, indicating that a database field is mapped to a component parameter).

Definisci la mappatura dei parametri secondo necessità. Definisci la mappatura dei parametri secondo necessità.

Per rimappare rapidamente un campo non mappato, fai clic all'interno della riga relativa al campo e utilizza la scorciatoia da tastiera Ctrl+D. Il nome del parametro di progetto sarà identico a quello del corrispondente Database Field Name.

Opzioni di aggiornamento dei parametri

Le colonne rimanenti nella scheda Field Mappings consentono di specificare le azioni da eseguire sui parametri quando si aggiorna un componente tramite il comando Tools » Update Parameters From Database. Nelle descrizioni seguenti, il termine Altium component viene utilizzato per indicare un componente posizionato su un foglio schematico oppure un componente definito in una libreria di componenti schematici, che fa parte di un pacchetto di librerie.

Le quattro colonne sono le seguenti:

  • Update Values - una cella in questa colonna consente di determinare l'azione da eseguire se il parametro esiste sia per il componente Altium sia nel database, ma i valori sono attualmente diversi. Puoi scegliere di aggiornare il parametro del componente Altium con il valore memorizzato nel database (Update) oppure di non aggiornarlo (Do not update).
  • Add To Design - una cella in questa colonna consente di determinare l'azione da eseguire se il parametro è presente nel database, ma non esiste per il componente Altium Designer. Puoi scegliere di aggiungere il parametro (Add), di non aggiungerlo (Do not add) oppure di aggiungerlo solo se nel database gli è assegnato un valore (Add only if not blank in database).
  • Visible On Add - una casella di controllo in questa colonna consente di determinare se un parametro appena aggiunto viene reso visibile per il componente Altium (se selezionata) oppure no (se deselezionata).
  • Remove From Design - una cella in questa colonna consente di determinare l'azione da eseguire se il parametro esiste per il componente Altium Designer, ma non è presente nel database oppure è presente ma non ha alcun valore. Puoi scegliere di non rimuovere mai il parametro (Do not remove) oppure di rimuoverlo solo se nel database non gli è assegnato alcun valore (Remove only if blank in database).

Inizialmente, i campi Update Values, Add To Design e Remove From Design, per ciascun campo del database mappato, saranno impostati sulla voce Default e l'opzione Visible On Add sarà disabilitata, come illustrato nell'immagine seguente.

Opzioni iniziali (predefinite) di aggiornamento dei parametri.Opzioni iniziali (predefinite) di aggiornamento dei parametri.

Osservando l'immagine, è importante evidenziare tre aspetti relativi alle opzioni di aggiornamento:

  1. I campi del database non mappati non avranno opzioni di aggiornamento associate.
  2. Il campo chiave (ad esempio Part Number nell'immagine) non avrà opzioni di aggiornamento associate. Questo campo viene utilizzato esclusivamente per la corrispondenza dei parametri.
  3. L'impostazione Default fa sì che un'opzione di aggiornamento segua la corrispondente definizione predefinita, specificata nella scheda Default Actions della finestra di dialogo Database Link Options (Tools » Options). È possibile accedere a questa finestra di dialogo anche facendo clic sul pulsante Options nell'area Field Settings della vista del documento.

Definisci le opzioni predefinite di aggiornamento dei parametri in un'unica posizione centralizzata.Definisci le opzioni predefinite di aggiornamento dei parametri in un'unica posizione centralizzata.

Il terzo aspetto è vantaggioso perché consente di specificare le opzioni di aggiornamento in un'unica posizione centralizzata e di fare poi riferimento a tale posizione quando si definiscono le opzioni di aggiornamento per ciascun campo mappato. Per questo motivo, la voce Default viene caricata automaticamente nei campi di aggiornamento pertinenti quando si mappa un campo del database a un parametro di progetto.

Se desideri sostituire l'impostazione predefinita di un'opzione di aggiornamento, fai clic all'interno del campo di aggiornamento pertinente nella scheda Field Mappings, quindi fai nuovamente clic per accedere a un elenco a discesa con le opzioni di aggiornamento applicabili.

Le opzioni di aggiornamento dei parametri possono essere modificate manualmente, se necessario.Le opzioni di aggiornamento dei parametri possono essere modificate manualmente, se necessario.

In questo modo, hai il pieno controllo su come vengono aggiornati i parametri del progetto. Puoi impostare tutti i campi su Default e decidere quali aggiornamenti eseguire dalla finestra di dialogo Database Link Options, impostare singolarmente ciascun campo di aggiornamento oppure combinare i due approcci: la scelta spetta interamente a te, in base alle tue esigenze. L'aggiornamento, quando viene eseguito, avviene tramite una finestra di dialogo Engineering Change Order. Se in questa fase ci sono aggiornamenti che preferisci non eseguire, puoi scegliere di escludere quelle specifiche modifiche, mantenendo così il controllo finale su quali parametri del progetto vengono aggiornati.

Garantire la sincronizzazione

Dopo aver specificato le opzioni di mappatura e aggiornamento nel file Database Link in base alle esigenze e aver salvato il file, potrai trasferire le informazioni dal database ai parametri mappati dei componenti di Altium Designer. Ricorda che il parametro scelto come campo chiave viene utilizzato per garantire che un componente di Altium Designer mantenga il collegamento al record corrispondente nel database esterno. Ciò significa che, in qualsiasi momento futuro, le modifiche alle informazioni dei parametri nel database potranno essere trasferite facilmente al componente di Altium Designer, mantenendo i due sincronizzati. Gli aggiornamenti vengono eseguiti tramite il comando Update Parameters From Database, disponibile nel menu principale Tools dell'editor degli schemi o delle librerie schematiche.

Sincronizzazione doppia: DbLib/SVNDbLib e DBLink

Potresti avere un progetto esistente in cui la maggior parte dei componenti posizionati è stata collegata a un database esterno tramite un file DbLink. Le modifiche al progetto potrebbero richiedere circuiti aggiuntivi, i cui componenti potrebbero essere posizionati utilizzando la funzionalità Libreria database. Il file DbLib/SVNDbLib associato potrebbe tranquillamente fare riferimento a un database esterno diverso.

Quando si utilizza il comando Update Parameters From Database, vengono interrogati tutti i parametri collegati dei componenti posizionati, in tutti i database collegati e indipendentemente dal metodo di collegamento utilizzato, e le differenze rilevate per tali parametri vengono visualizzate nella finestra di dialogo Seleziona modifiche ai parametri.

Se nei file DbLink e DbLib/SVNDbLib è stato utilizzato lo stesso campo del database per individuare le corrispondenze, la ricerca verrà eseguita prima nel database collegato tramite il file DbLink e poi in quello collegato tramite il file DbLib/SVNDbLib. Se il componente è presente in entrambi i database, potresti individuare una corrispondenza e aggiornare i dati a partire dal record esterno sbagliato.

Aggiungere informazioni del database direttamente a una distinta base

Related page: Configurazione della distinta base in Report Manager

In passato, le informazioni di origine per una distinta base (BOM) venivano ricavate dalle informazioni dei parametri dei componenti posizionati nel progetto. Questo, però, può portare ad associare allo schema molte informazioni utilizzate esclusivamente per la distinta base. Se i componenti di Altium Designer posizionati sono collegati a un database esterno tramite un file DbLink, il generatore della distinta base può estrarre qualsiasi altra informazione dei record che non sia stata aggiunta ai componenti come parametro di progetto.

È possibile includere parametri da un database esterno, indipendentemente dal metodo utilizzato per collegarsi a quel database: DbLink, DbLib o SVNDbLib.

Quando configuri il report della distinta base tramite la finestra di dialogo Report Manager, fai clic sul pulsante Database Parameters (  Database Parameters source button, click to make linked database parameters available in the Report Manager ) nella scheda Colonne della finestra di dialogo per includerli come origine dei dati della distinta base, come mostrato di seguito. Questa opzione è disponibile solo se uno o più componenti del progetto sono collegati a un database esterno.

Nell'elenco Colonne, l'icona Database icon, indicates that this parameter comes from the database viene utilizzata per distinguere un parametro presente in un database esterno collegato per uno o più componenti posizionati. Fai clic sull'icona di visibilità in modo che diventi un occhio ( Visibility icon ), per includere quella colonna (parametro) nella distinta base.

Includi informazioni aggiuntive sui componenti presenti solo in un database esterno.Includi informazioni aggiuntive sui componenti presenti solo in un database esterno.

Per un progetto che include Varianti, i parametri utilizzati per interrogare il database vengono modificati nella finestra di dialogo Gestione varianti. Poiché i valori di tali parametri esistono solo nella finestra di dialogo Variant Management, vengono utilizzati per interrogare il database e individuare i record corrispondenti solo quando si configura una distinta base da generare. A tale scopo, assicurati che la sotto-opzione Include DB Parameters in Variations sia abilitata nella scheda Generale delle proprietà di Report Manager.

Altium Designer include anche un potente editor di distinte base, chiamato ActiveBOM. ActiveBOM offre una suite completa di funzionalità per la gestione della distinta base, tra cui la possibilità di aggiungere ulteriori voci alla distinta base e una stretta integrazione con la catena di approvvigionamento dei componenti.

► Scopri di più su ActiveBOM

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents