Strumenti di migrazione della libreria database

A colpo d'occhio

Esplora gli strumenti di migrazione delle librerie di database disponibili in Altium Designer, con istruzioni dettagliate per convertire le librerie integrate in librerie di database standard (DbLib) o in librerie di database SVN con controllo di versione (SVNDbLib). L'articolo spiega come le procedure guidate di conversione gestiscono i dati dei componenti, i simboli e i footprint, evidenziando al contempo le restrizioni dei database e i requisiti di configurazione. Continua a leggere per scegliere il percorso di conversione più adatto e preparare le tue librerie per la migrazione.

- Scopri quando utilizzare una DbLib anziché una SVNDbLib.
- Impara a configurare le procedure guidate di conversione, selezionare le librerie di origine e specificare le destinazioni del database e del repository.
- Individua i requisiti e le limitazioni principali, tra cui il supporto alla conversione limitato ad Access, la preparazione del repository SVN e la gestione dei collegamenti ai modelli.
Approfondisci con l'IA:

Il software di progettazione Altium consente di posizionare componenti direttamente da un database aziendale creando e utilizzando una libreria database. Il tipo di libreria database utilizzato dipende da come si desidera gestire le librerie sorgente di simboli e modelli. Se le librerie devono essere conservate in una posizione su un disco rigido o un'unità di rete, è sufficiente utilizzare una libreria database (DbLib). Se invece si desidera sottoporre le librerie al controllo di versione utilizzando un repository Subversion, occorre utilizzare una libreria database SVN (SVNDbLib).

Indipendentemente dal tipo di libreria database utilizzato, il principio alla base della funzionalità rimane lo stesso in entrambi i casi: la possibilità di posizionare componenti direttamente dal database esterno collegato. Per rendere questa potente funzionalità il più accessibile possibile, sono disponibili strumenti che consentono di trasferire rapidamente le librerie esistenti nella struttura di una libreria database. Questi strumenti consentono di migrare da:

  • Una libreria integrata a una libreria database (DbLib o SVNDbLib).
  • Una libreria database (DbLib o SVNDbLib) a una libreria integrata.
  • Librerie sorgente di schemi/PCB a una libreria database SVN.
  • Una libreria database a una libreria database SVN.
  • Un sistema OrCAD Component Information System (CIS) a una libreria database (DbLib).

Le sezioni seguenti illustrano più in dettaglio come eseguire queste migrazioni all'interno del software.

Creazione di una libreria database da una libreria integrata

Le librerie integrate sono, per loro natura, intrinsecamente sicure. A questo si aggiunge la loro portabilità ideale per i progetti che vengono trasferiti all'esterno dell'azienda. Se il progetto deve rimanere all'interno dell'azienda e/o si desidera che i componenti di progettazione Altium siano strettamente collegati al database aziendale, le librerie database sono la scelta perfetta. Il software consente di convertire rapidamente le librerie integrate aziendali nella struttura di una libreria database (DbLib) o di una libreria database SVN (SVNDbLib). È possibile includere nella conversione più librerie integrate, ognuna delle quali viene aggiunta come tabella separata al database di destinazione.

Conversione in una DbLib

La creazione di una libreria database standard (DbLib) da una libreria integrata (IntLib) viene eseguita utilizzando Integrated Library to Database Library Translator Wizard. La procedura guidata decompila le librerie integrate specificate, utilizzando ciascuna libreria per creare una tabella separata nel database di destinazione scelto, completa delle informazioni sui parametri e sui modelli estratte dai componenti che contiene. Un file di libreria database specificato viene quindi utilizzato per fornire una connessione a tale database.

La procedura guidata può essere utilizzata anche per importare/aggiungere ulteriori componenti in un database esistente, collegato tramite un file DbLib esistente.
La conversione supporta esclusivamente l'utilizzo di database di tipo Access.

Il trasferimento di una o più librerie integrate sorgente nella struttura di una libreria database è un processo semplificato, che utilizza Integrated Library to Database Library Translator Wizard.Il trasferimento di una o più librerie integrate sorgente nella struttura di una libreria database è un processo semplificato, che utilizza Integrated Library to Database Library Translator Wizard.

Il processo prevede i seguenti passaggi:

  1. Creare un nuovo file di libreria database o aprirne uno esistente (*.DbLib). In genere, si utilizza un file DbLib esistente quando si convertono una o più librerie integrate in un database Access esistente a cui tale file DbLib è attualmente connesso.
  2. Con il file di libreria database (*.DbLib) aperto come documento attivo, scegliere il comando Tools » Import From Integrated Libraries dai menu principali per accedere a Integrated Library to Database Library Translator Wizard.
  3. Utilizzare la pagina iniziale Specify your Database details della procedura guidata per specificare il database di destinazione: un nuovo database Access o uno esistente. Se si crea un nuovo database, fare clic sull'icona della cartella a destra del campo Database Location per accedere alla finestra di dialogo standard Open . Utilizzare questa finestra di dialogo per stabilire dove e con quale nome creare il nuovo database. Il nome/percorso scelto verrà inserito nel campo Database Location.

    Se la procedura guidata è stata avviata da un file DbLib esistente, l'opzione Existing Access Database sarà selezionata per impostazione predefinita e il campo Database Location sarà precompilato con il database a cui si connette tale file DbLib.
  4. Utilizzare la pagina successiva Specify your Target Database Library della procedura guidata per specificare il file di libreria database di destinazione. Specificare il percorso e il nome di un nuovo file DbLib da creare oppure individuare e aprire un file esistente. In genere, si utilizza un file DbLib esistente quando si convertono una o più librerie integrate nel database Access esistente a cui il file DbLib è attualmente connesso. Per impostazione predefinita, il campo sarà precompilato con il file DbLib attivo.

    Se si utilizza un file DbLib esistente e si cambia il database di destinazione, al termine della procedura guidata il file DbLib sarà connesso al nuovo database di destinazione.
  5. Utilizzare la pagina seguente Locate the Integrated Libraries to Import della procedura guidata per specificare le librerie integrate da convertire. Utilizzare il pulsante Add per aprire la finestra di dialogo Select Source Integrated Libraries, da cui è possibile individuare e selezionare le librerie desiderate. Le librerie di simboli schematici e modelli che le compongono (se presenti) verranno estratte e salvate nella posizione specificata nel campo Destination Folder. Utilizzare i pulsanti Remove e Clear per rimuovere o eliminare la libreria selezionata.

    Per impostazione predefinita, Destination Folder punterà a una sottocartella, Libraries, all'interno della cartella contenente il file DbLib (specificato nella pagina precedente della procedura guidata).
  6. Dopo aver scelto le librerie integrate sorgente, fare clic su Next per procedere con la conversione. Verrà visualizzata una barra di avanzamento insieme alle informazioni sulla libreria attualmente in fase di conversione. Al termine della conversione, fare clic su Finish nell'ultima pagina della procedura guidata per rendere attivo il file DbLib specificato nella finestra di progettazione principale (se non lo è già).

    Ogni libreria integrata coinvolta nella conversione genererà una tabella separata nel database, con lo stesso nome della libreria integrata. Nel caso di un database esistente, se è già presente una tabella con lo stesso nome della libreria integrata, le informazioni di tale libreria verranno aggiunte alla tabella esistente.

File DbLib risultante al termine del processo di conversione.
File DbLib risultante al termine del processo di conversione.

Una volta completato il processo di conversione, è possibile accedere alle librerie schematiche sorgente e rimuovere dai simboli tutte le informazioni sui parametri e sui modelli. È quindi possibile apportare eventuali modifiche di dettaglio alla configurazione delle mappature dei campi nel documento DbLib per fare riferimento alle colonne appropriate del database, secondo necessità. Per ulteriori informazioni, consultare la sezione Mappatura dei campi del database ai parametri di progettazione della pagina Creazione e definizione della libreria database.

La procedura guidata estrae le informazioni sui modelli di footprint solo in termini di riferimento al modello e percorso dei modelli definiti. Per i modelli di simulazione, le informazioni di collegamento devono essere inserite manualmente nel database esterno.
Assicurarsi che i componenti della libreria schematica nell'IntLib non possiedano un parametro Part Number. Le informazioni sul codice componente inserite nel database (per identificare ogni record di componente) provengono dal campo Design Item ID del componente schematico nella sezione Properties della scheda General del pannello Properties quando si consultano le proprietà del componente di libreria selezionato. Inserire queste informazioni anche come parametro causerà il fallimento della conversione a causa di valori duplicati.

Conversione in una SVNDbLib

La creazione di una libreria di database sotto controllo di versione (SVNDbLib) a partire da una libreria integrata (IntLib) viene eseguita utilizzando SVN Database Library Conversion Wizard. La procedura guidata decompila le librerie integrate selezionate utilizzando ciascuna libreria per creare una tabella distinta in un nuovo database di destinazione, completa delle informazioni sui parametri e sui modelli estratte dai componenti al suo interno. Viene quindi creato il file di libreria di database SVN specificato, utilizzato per fornire la connessione al database. Le librerie di schemi e PCB che la compongono vengono suddivise e salvate tramite commit nelle directory specificate di un repository SVN per il controllo di versione, a cui fa riferimento il file SVNDbLib.

La conversione supporta esclusivamente l'utilizzo di un database di tipo Access.

L'inserimento di una o più librerie integrate di origine nella struttura della libreria di database SVN è un processo semplificato che utilizza SVN Database Library Conversion Wizard.L'inserimento di una o più librerie integrate di origine nella struttura della libreria di database SVN è un processo semplificato che utilizza SVN Database Library Conversion Wizard.

Il processo prevede i seguenti passaggi:

  1. Accedere a SVN Database Library Conversion Wizard. È possibile farlo:
  • Scegliendo il comando Tools » SVN Database Library Maker dai menu principali dell'editor di librerie di schemi, dell'editor di librerie PCB o dell'editor di librerie di database.
  • Nel pannello Projects, facendo clic con il pulsante destro del mouse sulla voce di una libreria di progetto (SchLib, PcbLib o IntLib) e scegliendo il comando SVN Database Library Maker dal menu contestuale.
  1. Utilizzare la pagina Libraries to Convert per specificare le librerie integrate da convertire. Inizialmente, l'elenco contiene già una o più librerie (la libreria attiva o tutte le librerie di progetto aggiunte al progetto, a seconda del metodo di accesso utilizzato). Rimuoverle dall'elenco prima di scegliere le librerie integrate da convertire. Utilizzare il pulsante Add per accedere alla finestra di dialogo Library Files, da cui è possibile individuare e selezionare le librerie integrate desiderate.
  2. Utilizzare la pagina Options per definire le opzioni di conversione, tra cui la modalità di suddivisione delle librerie di origine, le directory e il repository in cui memorizzarle e la directory di destinazione del file SVNDbLib. Per una libreria di schemi sono inoltre disponibili due opzioni che consentono di rimuovere le informazioni sui parametri e/o sui modelli da ciascun componente, lasciando solo il simbolo.

    Il repository SVN e la relativa struttura di cartelle devono essere definiti in precedenza. Si tratta semplicemente di selezionare il repository e le cartelle al suo interno in cui memorizzare i file delle librerie suddivise. Il repository e le cartelle non vengono creati al momento.
  3. Dopo aver scelto le librerie integrate di origine e impostato le opzioni di conversione secondo necessità, fare clic su Next per procedere con la conversione. Verrà visualizzata una barra di avanzamento, insieme alle informazioni sulla libreria attualmente in fase di conversione. Il processo di conversione prevede:
    1. L'estrazione delle librerie di origine dalle librerie integrate fornite.
    2. La suddivisione delle librerie di schemi e PCB in file di libreria contenenti un singolo simbolo o footprint.
    3. Il commit delle librerie di simboli e footprint suddivise nel repository, nelle directory di base specificate.
    4. La procedura guidata estrae solo le informazioni di riferimento ai modelli di footprint. I modelli di simulazione collegati sono supportati nelle librerie di database sotto controllo di versione (SVNDbLib); tuttavia, la memorizzazione dei file dei modelli di simulazione nel repository Subversion non è supportata. Se presenti, tali collegamenti vengono aggiunti come parametri.
    5. La creazione di una tabella distinta nel database Access generato (che assume lo stesso nome specificato per il file SVNDbLib) per ciascuna libreria integrata da convertire, completa delle informazioni sui parametri e sui modelli estratte dai componenti al suo interno. A ciascuna tabella viene assegnato il nome della libreria integrata con il suffisso _IntLib (ad esempio, Capacitor - Ceramic_IntLib).
    6. La creazione del file SVNDbLib specificato, connesso al database e al repository.
  4. Al termine della conversione, fare clic su Finish per chiudere la procedura guidata e rendere il file SVNDbLib il documento attivo.

File SVNDbLib risultante al termine del processo di conversione.File SVNDbLib risultante al termine del processo di conversione.

Assicurarsi che i componenti della libreria di schemi contenuta nella IntLib non abbiano un parametro Part Number. Le informazioni sul codice articolo inserite nel database (per identificare il record di ciascun componente) vengono ricavate dal campo Design Item ID del componente dello schema, nella sezione Properties della scheda General del pannello Properties, quando si consultano le proprietà del componente di libreria selezionato. L'inserimento di queste informazioni anche come parametro causa il fallimento della conversione a causa di valori duplicati.

Creazione di una libreria integrata da una libreria di database

Le librerie di database sono la scelta ideale se si desidera che i componenti Altium Design siano strettamente collegati al database aziendale. Se il progetto deve uscire dall'azienda o se si preferisce che i progettisti lavorino con librerie integrate sicure, è possibile farlo facilmente. Il software offre la possibilità di compilare una libreria integrata direttamente da una libreria di database, sia essa una libreria di database standard (DbLib) o una libreria di database SVN sotto controllo di versione (SVNDbLib). In questo modo, i responsabili delle librerie CAD possono continuare a utilizzare le librerie di database, mentre i progettisti utilizzano librerie integrate rigenerate periodicamente, lavorando, per così dire, in modalità «offline».

La conversione viene eseguita utilizzando Offline Integrated Library Maker. Il processo viene effettuato per singola tabella del database, con il pieno controllo sulle tabelle da prendere in considerazione. I componenti degli schemi e i modelli PCB, PCB3D e di simulazione sono inclusi nel processo di conversione. Per ogni tabella inclusa viene generata una libreria integrata distinta. Queste tabelle vengono convertite in singole librerie integrate, che vengono poi aggiunte a Installed Libraries.

Convertire le librerie di database (DbLib o SVNDbLib) in librerie integrate «offline» utilizzando Offline Integrated Library Maker.
Convertire le librerie di database (DbLib o SVNDbLib) in librerie integrate «offline» utilizzando Offline Integrated Library Maker.

Il processo prevede i seguenti passaggi:

  1. Con il file di libreria di database (*.DbLib) o il file di libreria di database SVN (*.SVNDbLib) da convertire aperto come documento attivo, scegliere il comando Tools » Offline Integrated Library Maker dai menu principali per accedere a Offline Integrated Library Maker.
  2. Utilizzare la pagina Library to Convert per specificare la DbLib o SVNDbLib da elaborare. La libreria attiva da cui è stato aperto Offline Integrated Library Maker  verrà impostata come libreria da convertire per impostazione predefinita. Se necessario, è possibile individuare e scegliere un'altra libreria di database.

  3. Utilizzare la pagina Options per specificare quali tabelle del database collegato includere nella conversione. Per impostazione predefinita, vengono incluse tutte le tabelle del database. Per escludere una tabella, assicurarsi che la relativa opzione Convert sia disattivata. Questa pagina consente inoltre di specificare una directory di destinazione in cui memorizzare le librerie integrate generate. Immettere direttamente il percorso di questa directory di base oppure fare clic sull'icona Browse icon a destra del campo per accedere a una finestra di dialogo da cui individuare e selezionare la directory desiderata. L'output generato (libreria integrata) per ciascuna tabella del database inclusa verrà memorizzato in una sottocartella dedicata all'interno della directory di destinazione specificata, con lo stesso nome della tabella.

  4. Dopo aver scelto la libreria database e impostato le relative opzioni di conversione secondo necessità, fai clic su Next per procedere con la conversione. Verrà visualizzata una barra di avanzamento insieme alle informazioni sulla tabella del database attualmente in fase di conversione. Ricorda che il processo di conversione viene eseguito per ogni tabella del database selezionata per la conversione. Di seguito sono descritte le fasi principali di questo processo:
    1. Viene creato un pacchetto di libreria integrata (*.LibPkg), che viene aperto nel pannello Projects. Al pacchetto viene assegnato il nome della tabella. Ad esempio, per una tabella denominata Capacitor - Ceramic, si otterrebbe Capacitor - Ceramic.LibPkg.
    2. Viene creato un documento di libreria schematica e aggiunto al LibPkg. Anche alla libreria schematica viene assegnato il nome della tabella (ad es., Capacitor - Ceramic.SchLib).
    3. Viene quindi esaminato ogni record della tabella e creato il corrispondente componente Altium Design. A tale scopo, il simbolo schematico a cui viene fatto riferimento viene recuperato dalla libreria sorgente appropriata e aggiunto come componente al nuovo documento di libreria schematica. Le informazioni sui parametri e sui collegamenti ai modelli definite nel record vengono quindi aggiunte a tale componente.
    4. I modelli di footprint a cui il record fa riferimento vengono recuperati e aggiunti a un documento di libreria PCB. Anche a questo documento viene assegnato il nome della tabella (ad es., Capacitor - Ceramic.PcbLib). Il documento di libreria PCB viene quindi aggiunto al LibPkg.
    5. Se la libreria sorgente è una DbLib e nel record del database sono stati definiti collegamenti a modelli di simulazione, anche i file dei modelli di simulazione a cui viene fatto riferimento vengono aggiunti al LibPkg. La posizione di tali modelli rimane invariata. Il percorso completo di un modello è specificato come parte del relativo collegamento al modello.
    6. Il LibPkg viene quindi compilato per ottenere la libreria integrata (ad es., Capacitor - Ceramic.IntLib), che viene successivamente aggiunta alle librerie installate del software.

Le librerie attualmente installate possono essere visualizzate nella scheda Installed della finestra di dialogo Available File-based Libraries, accessibile facendo clic sul pulsante Open Libraries dialogs in Components Panel in alto a destra nel pannello Components e selezionando quindi File-based Libraries Preferences.

Risultati del processo di conversione: progetti di pacchetti di librerie con i relativi documenti di simboli e modelli di footprint e le IntLib compilate, che vengono anche aggiunte come librerie installate e rese quindi disponibili a tutti i progetti PCB.
Risultati del processo di conversione: progetti di pacchetti di librerie con i relativi documenti di simboli e modelli di footprint e le IntLib compilate, che vengono anche aggiunte come librerie installate e rese quindi disponibili a tutti i progetti PCB.

Creazione di una SVNDbLib da librerie sorgente (SCHLib/PCBLib)

La SVN Database Library Conversion Wizard ti aiuta a convertire le librerie schematiche, PCB, database e integrate in librerie database SVN. Questa procedura guidata semplifica il processo di trasformazione di varie metodologie di gestione dei componenti in una libreria database SVN (*.SVNDBLib). Una libreria database SVN sfrutta la possibilità di posizionare i componenti direttamente da un database ed estende questo metodo di collegamento per consentire l'uso di librerie sottoposte a controllo di versione, che contengono i simboli schematici e i modelli di footprint all'interno di un repository basato su Subversion. Il collegamento al repository e al database esterno è definito all'interno di un file di libreria database SVN (*.SVNDBLib), un'estensione del file di libreria database (*.DBLib), spesso indicato come Version-Controlled Database Library.

Usa la procedura guidata per definire le opzioni di conversione, tra cui la modalità di suddivisione delle librerie sorgente, le directory e il repository in cui devono essere archiviate e la directory di output per il file SVNDBLib. 

Dovrai scegliere quali librerie database o schematiche (*.SchLib), PCB (*.PcbLib) o integrate (*.IntLib) convertire; queste verranno quindi inserite in un repository SVN. Verrà inoltre creata un'unica libreria database SVN. 

Con questa procedura guidata puoi definire la connessione al repository SVN, la directory di base per simboli e modelli e il percorso del documento di libreria database SVN. Per impostazione predefinita, la directory di output sarà la stessa in cui è archiviata la libreria sorgente.

Se desideri che il file SVNDBLib generato e il database si trovino nella stessa posizione, hai essenzialmente due opzioni. La prima consiste nell'impostare il percorso di output del file SVNDBLib sulla stessa directory in cui si trova attualmente il database. La seconda consiste nel generare il file SVNDBLib in una directory diversa e spostare quindi il database in tale directory. In questo caso, dovrai ricordarti di modificare la connessione all'interno del file SVNDBLib in modo che punti alla nuova posizione del database e ristabilire la connessione.

  • Poiché i file delle librerie suddivise verranno aggiunti al repository SVN, dovrai predisporre esternamente, sul disco locale, la struttura di cartelle desiderata nel repository per i file dei simboli e dei modelli. La struttura delle cartelle all'interno del repository viene gestita utilizzando un client SVN, come TortoiseSVN.
  • Devi disporre di un repository SVN e di un sistema di controllo di versione SVN installato sul computer o accessibile dalla rete. Assicurati inoltre che Provider nella pagina Data Management - Version Control della finestra di dialogo Preferences sia impostato su SVN - Subversion.
  • La conversione supporta esclusivamente l'uso di un database di tipo Access.

SVN Database Library Conversion WizardL'inserimento di una o più librerie sorgente schematiche e PCB nella struttura della libreria database SVN è un processo semplificato grazie alla SVN Database Library
Conversion
Wizard.

Il processo comprende i seguenti passaggi:

  1. Apri la SVN Database Library Conversion Wizard nei seguenti modi:

    • Fai clic su Tools » SVN Database Library Maker da un file di libreria schematica (*.SchLib), un file di libreria PCB (*.PcbLib), un file di libreria integrata (*.IntLib) o un file di libreria database (*.DbLib). Tuttavia, se accedi alla procedura guidata da una libreria schematica e desideri includere nella conversione i modelli di footprint collegati, dovrai individuare e aggiungere le rispettive librerie di footprint PCB. Inoltre, la conversione delle sole librerie di footprint PCB non è uno scenario tipico; dovrai pertanto individuare e aggiungere le rispettive librerie di componenti schematici.
    • Dal pannello Projects , fai clic con il pulsante destro del mouse sulla voce della libreria desiderata (*.SchLib, *.PcbLib o *.IntLib), quindi seleziona SVN Database Library Maker. La procedura guidata caricherà automaticamente tutte le librerie del progetto. Questo è di gran lunga il metodo più semplice e richiede che le librerie sorgente schematiche e PCB siano aggiunte a un progetto. Molto spesso questa condizione si verifica quando non sono state utilizzate librerie integrate.
    La procedura guidata viene precompilata con le voci delle librerie in base al punto da cui viene aperta; pertanto, per risparmiare tempo, avviala dall'editor appropriato, come descritto di seguito.

  2. Usa la pagina Libraries to Convert per selezionare le librerie da convertire. Scegli tra librerie database oppure librerie schematiche, PCB e integrate. Le librerie selezionate verranno suddivise in librerie di singoli componenti e quindi inserite in un repository SVN. Verrà creato un unico database SVN.

    • Converting a Database Library

      Durante la conversione di Database Libraries, il processo prevede:

      1. La suddivisione delle librerie di schemi e PCB a cui fanno riferimento i record dei componenti nel database collegato in file di libreria contenenti un singolo simbolo o footprint.
      2. Il commit delle librerie di simboli e footprint suddivise nel repository, nelle directory di base specificate.
      3. La creazione del file SVNDBLib specificato, con il collegamento al database e al repository.
    • Converting Schematic, PCB, and Integrated Libraries

      Utilizza il pulsante Add per accedere a una finestra di dialogo standard in cui cercare e selezionare il file da aggiungere. Fai clic sul pulsante Remove  per rimuovere la libreria attualmente selezionata.

      Durante la conversione di librerie di schemi, PCB e integrate, il processo prevede:

      1. L'estrazione delle librerie sorgente dalle eventuali librerie integrate fornite.
      2. La suddivisione delle librerie di schemi e PCB in file di libreria contenenti un singolo simbolo o footprint
      3. Il commit delle librerie di simboli e footprint suddivise nel repository nelle directory di base specificate.
      4. La procedura guidata estrae solo le informazioni di riferimento dei modelli di footprint. I modelli PCB3D e di simulazione collegati non sono supportati per una SVNDBLib. Se presenti, questi collegamenti vengono aggiunti come parametri.
      5. La creazione di una tabella separata nel database Access generato per ogni libreria di schemi e/o libreria integrata in fase di conversione, completa delle informazioni sui parametri e sui modelli estratte dai componenti. Ogni tabella viene denominata utilizzando il nome della libreria di schemi, con il suffisso _SchLib(ad esempio, Mixer_SchLib), e/o il nome della libreria integrata, con il suffisso _IntLib (ad esempio, AD Differential Amplifier_IntLib).
      6. La creazione del file SVNDBLib specificato, con il collegamento al database e al repository.
  3. Utilizza la pagina Options per definire le opzioni di conversione, tra cui la modalità di suddivisione delle librerie sorgente, le directory e il repository in cui archiviarle e la directory di output per il file SVNDbLib. Per una libreria di schemi sono disponibili anche due opzioni che consentono di rimuovere le informazioni sui parametri e/o sui modelli da ciascun componente, lasciando solo il simbolo.

    Il repository SVN e la relativa struttura di cartelle devono essere definiti in anticipo. È sufficiente indicare il repository e le cartelle al suo interno in cui archiviare i file di libreria suddivisi. Il repository e le cartelle non vengono creati durante il processo.

    SVN Options

    Utilizza quest'area per definire le impostazioni di connessione al repository SVN. 

    Utilizza il menu a discesa Method per selezionare il metodo di connessione: file (un repository basato su file), http (un repository basato su cloud), https (un repository sicuro basato su cloud), svn o svn+ssh. 

    L'area Location (disponibile solo quando è selezionato file per Method) consente di impostare il percorso del repository. Utilizza l'icona di esplorazione delle cartelle per cercare e selezionare la posizione desiderata. 

    L'area Server (disponibile solo quando file è not selezionato per Method) consente di impostare il server desiderato.

    Imposta Server Port su Default o Non-Default. Se è selezionato Non-Default, inserisci la porta del server nella casella di testo. Dovrai inoltre inserire il nome di Repository folder nella casella di testo.

    Server Port e Repository folder sono opzioni accessibili solo quando il valore selezionato per Method è not file. 

    Specifica la directory di base del repository per Symbols e Footprints facendo clic su ... per cercare e selezionare le cartelle desiderate per entrambi.

    SVN DB Library Options

    L'area SVN DB Library Options consente di specificare il percorso del documento di libreria database SVN. Se non esiste già un database Access di back-end, ne verrà creato uno nella stessa cartella. Utilizza l'icona di esplorazione delle cartelle per cercare e selezionare il percorso.

    Se desideri che il file SVNDBLib generato e il database si trovino nella stessa posizione, hai essenzialmente due opzioni. La prima consiste nell'impostare il percorso di output del file SVNDBLib sulla stessa directory in cui si trova attualmente il database. La seconda consiste nel generare il file SVNDBLib in una directory diversa e poi spostare il database in tale directory. In questo caso, dovrai ricordarti di modificare la connessione nel file SVNDBLib in modo che punti alla nuova posizione del database e ristabilire la connessione.

    Library Splitting Options

    Utilizza il menu a discesa per scegliere se i file devono essere Overwrite Existing Files o Append Incrementing Number To File Names (per creare nuovi file con un suffisso aggiunto al nome quando le librerie vengono suddivise). Quando è selezionato Overwrite Existing Files, gli eventuali file esistenti nei repository vengono sovrascritti durante la suddivisione delle librerie. Se è selezionato Append Incrementing Number To File Names, tutti i file nei repository specificati vengono protetti e non vengono sovrascritti; ai nomi delle nuove librerie di componenti con lo stesso nome viene aggiunto il suffisso "_#IncrementNumber".

    Per una libreria di schemi sono disponibili anche due opzioni che consentono di rimuovere le informazioni sui parametri e/o sui modelli dai componenti di schema suddivisi, lasciando solo il simbolo. Seleziona Remove All Parameters e/o Remove All Models. Poiché il database esterno esiste già ed è collegato al file DBLib originale, non ne verrà creato uno nuovo. Il database rimarrà nella posizione attuale.

  4. Dopo aver scelto le librerie sorgente di schemi e PCB e aver impostato le relative opzioni di conversione in base alle esigenze, fai clic su Next per procedere con la conversione. Verrà visualizzata una barra di avanzamento, insieme alle informazioni sulla libreria attualmente in fase di conversione. Il processo di conversione prevede:
    1. La suddivisione delle librerie di schemi e PCB in file di libreria contenenti un singolo simbolo o footprint.
    2. Il commit delle librerie di simboli e footprint suddivise nel repository, nelle directory di base specificate.
    3. La procedura guidata estrae solo le informazioni di riferimento dei modelli di footprint. I modelli di simulazione collegati sono supportati per una libreria database con controllo di versione (SVNDbLib); tuttavia, l'archiviazione dei file dei modelli di simulazione nel repository Subversion non è supportata. Se presenti, questi collegamenti vengono aggiunti come parametri.
    4. La creazione di una tabella separata nel database Access generato (che assume lo stesso nome specificato per il file SVNDbLib) per ogni libreria di schemi in fase di conversione, completa delle informazioni sui parametri e sui modelli estratte dai componenti al suo interno. Ogni tabella viene denominata utilizzando il nome della libreria di schemi con il suffisso _SchLib (ad esempio, Capacitor - Ceramic_SchLib).
    5. La creazione del file SVNDbLib specificato, con il collegamento al database e al repository.
  5. Al termine della conversione, fai clic su Finish per chiudere la procedura guidata e rendere il file SVNDbLib il documento attivo.

File SVNDbLib risultante al termine del processo di conversione.File SVNDbLib risultante al termine del processo di conversione.

Assicurati che i componenti della libreria schematica non abbiano un parametro Part Number. Le informazioni sul codice componente inserite nel database, per identificare ogni record di componente, vengono ricavate dal campo Design Item ID del componente schematico nella sezione Properties della scheda General del pannello Properties quando si visualizzano le proprietà del componente di libreria selezionato. Inserirle anche come parametro causerà un errore di conversione dovuto a valori duplicati. Sebbene il processo venga completato, i componenti schematici che presentano questo parametro non verranno creati nel database e pertanto non compariranno nell'elenco dei componenti del database nella scheda Table Browser del documento SVNDbLib.

Conversione di una DbLib in una SVNDbLib

Potresti già sfruttare le potenzialità delle librerie database dopo aver convertito le tue librerie integrate esistenti nella struttura DbLib o aver creato una DbLib da zero. Come passo successivo, potresti voler trasferire le librerie sorgente di simboli e footprint sotto la protezione sicura di un repository di controllo versione. Il software fornisce gli strumenti per eseguire questa migrazione dall'attuale libreria database standard (DbLib) a una libreria database sotto controllo versione (SVNDbLib).

La conversione viene eseguita con SVN Database Library Conversion Wizard in modo molto simile alla conversione di una libreria integrata.

SVN Database Library Conversion WizardLa conversione di una libreria database standard esistente (DbLib) in una libreria database sotto controllo versione (SVNDbLib) è un processo semplificato che utilizza SVN Database
Library Conversion Wizard
.

Il processo prevede i seguenti passaggi:

  1. Apri la DbLib esistente da convertire, quindi scegli Tools » SVN Database Library Maker dai menu principali. Si aprirà SVN Database Library Conversion Wizard.
  2. Usa la pagina Libraries to Convert per specificare la libreria database sorgente che desideri convertire. L'opzione Database Libraries sarà già abilitata e il campo associato sarà precompilato con il percorso della libreria attiva. Se desideri convertire una DbLib diversa, fai clic sul pulsante Browse icon e usa la finestra di dialogo visualizzata per individuarla.
  3. Dopo aver fatto clic su Next, il file DbLib scelto viene analizzato e compare una finestra di conferma che avvisa che il database di backend potrebbe essere modificato. Fai clic su Yes per continuare.
  4. Usa la pagina Options per definire le opzioni di conversione, tra cui la modalità di suddivisione delle librerie sorgente, le directory e il repository in cui archiviarle e la directory di output per il file SVNDbLib. Per una libreria schematica sono disponibili anche due opzioni che consentono di rimuovere le informazioni sui parametri e/o sui modelli da ciascun componente, lasciando soltanto il simbolo.
Il repository SVN e la relativa struttura di cartelle devono essere definiti in anticipo. Devi semplicemente selezionare il repository e le cartelle al suo interno in cui archiviare i file delle librerie suddivise. Il repository e le cartelle non vengono creati al momento.
Poiché il database esterno esiste già ed è collegato al file DbLib originale, non ne verrà creato uno nuovo. Il database rimarrà nella posizione attuale. Se desideri che il file SVNDbLib generato e il database si trovino nella stessa posizione, hai essenzialmente due opzioni. La prima consiste nell'impostare come percorso di output per la SVNDbLib la stessa directory in cui si trova attualmente il database. La seconda consiste nel generare la SVNDbLib in una directory diversa e poi spostare il database in quella directory. In questo caso, dovrai ricordarti di modificare la connessione nel file SVNDbLib affinché punti al database nella nuova posizione e di riconnetterti.
  1. Dopo aver scelto il file DbLib sorgente e impostato le relative opzioni di conversione secondo necessità, fai clic su Next per procedere con la conversione. Verrà visualizzata una barra di avanzamento insieme alle informazioni sulla libreria in fase di conversione. Il processo di conversione comprende:
    1. La suddivisione delle librerie schematiche e PCB, a cui fanno riferimento i record dei componenti nel database collegato, in file di libreria contenenti un singolo simbolo o footprint.
    2. Il commit delle librerie di simboli e footprint suddivise nel repository, nelle directory di base specificate.
    3. La creazione del file SVNDbLib specificato, con la connessione al database e al repository.
  2. Una volta completata la conversione, fai clic su Finish per chiudere la procedura guidata e rendere il file SVNDbLib il documento attivo.

File SVNDbLib risultante al termine del processo di conversione.File SVNDbLib risultante al termine del processo di conversione.

Una nota sulle mappature dei campi

Nella SVNDbLib generata, le mappature definite tra i campi del database e i parametri di progettazione nella scheda Field Mappings rimangono invariate rispetto a quelle originariamente definite nella DbLib.

Le mappature dei campi rimangono identiche tra la DbLib originale e la SVNDbLib generata.Le mappature dei campi rimangono identiche tra la DbLib originale e la SVNDbLib generata.

Vi sono tuttavia due aspetti importanti da evidenziare:

  • Le eventuali mappature dei percorsi definite per i simboli e i modelli di footprint vengono ignorate. La SVNDbLib utilizza soltanto i campi di riferimento mappati, [Library Ref] e [Footprint Ref], per individuare il simbolo e il footprint richiesti nelle librerie di cui è stato eseguito il commit nel repository. Le informazioni sui percorsi definite nel database vengono ignorate, poiché rimandano a librerie situate su un disco rigido o su un altro supporto locale o di rete.
Se desideri comunque includere le informazioni sui percorsi nel database, modificale affinché puntino alle librerie nel repository. È utile ricordare che non specificare nel database le informazioni sui percorsi delle librerie lo rende molto più robusto. La posizione del repository e/o la sua struttura interna di cartelle potrebbero cambiare senza richiedere l'aggiornamento del database.
  • Anche le eventuali mappature dei modelli di simulazione rimarranno definite nel file SVNDbLib. Tuttavia, l'archiviazione dei file dei modelli di simulazione nel repository Subversion non è supportata. Sebbene i collegamenti ai modelli vengano aggiunti all'istanza di un componente al momento del posizionamento, i modelli stessi non verranno trovati.

Supporto diretto per OrCAD® CIS

Basato sul sistema delle librerie database, il software offre il supporto completo per la connessione e l'utilizzo dei sistemi OrCAD Component Information System (CIS) esistenti. La struttura CIS viene essenzialmente convertita nella struttura di libreria database standard (DbLib) di Altium Designer.

Da OrCAD ad Altium Designer: conversioni necessarie

Per consentire il posizionamento diretto dal database esterno (*.mdb, *.xls), sono necessarie le seguenti conversioni di file:

  • Il file di configurazione OrCAD CIS (*.dbc), che gestisce il collegamento al database esterno e include le informazioni di mappatura tra i campi del database e i parametri di progettazione, deve essere convertito in un file di libreria database di Altium Designer (*.DbLib).
Altium Designer attualmente supporta solo i file .dbc di OrCAD CIS in formato binario.
  • I file di libreria OrCAD pertinenti devono essere convertiti in file di libreria di Altium Designer:
    • Libreria OrCAD Capture (*.olb) ---> Libreria schematica (*.SchLib).
    • File di libreria OrCAD Max (*.llb) ---> Libreria PCB (*.PcbLib).

Creazione automatica della libreria database

Il metodo più semplice ed efficiente per creare il file DbLib e le librerie sorgente di Altium Designer consiste nell'utilizzare Import Wizard (File » Import Wizard). Nella seconda pagina della procedura guidata, assicurati che la voce OrCAD CIS Configuration Files and Libraries sia selezionata come tipo di file da importare.

Utilizza Import Wizard per convertire rapidamente il file di configurazione CIS e le relative librerie OrCAD in file DbLib e librerie sorgente (SchLib e PcbLib) di Altium Designer.
Utilizza Import Wizard per convertire rapidamente il file di configurazione CIS e le relative librerie OrCAD in file DbLib e librerie sorgente (SchLib e PcbLib) di Altium Designer.

Utilizza Import Wizard per convertire rapidamente il file di configurazione CIS e le relative librerie OrCAD in file DbLib e librerie sorgente (SchLib e PcbLib) di Altium NEXUS.
Utilizza Import Wizard per convertire rapidamente il file di configurazione CIS e le relative librerie OrCAD in file DbLib e librerie sorgente (SchLib e PcbLib) di Altium NEXUS.

Segui le pagine successive della procedura guidata, nelle quali dovrai specificare:

  • Il percorso del database esterno.
  • Il percorso del file di configurazione CIS (*.dbc): ricorda che deve essere in formato binario e non XML.
  • Dove e con quale nome deve essere creato il file DbLib di destinazione.
  • Le librerie di schemi e/o PCB OrCAD a cui fa riferimento il database esterno.
Quando specifichi le librerie sorgente OrCAD, puoi anche scegliere dove salvare le librerie Altium Designer risultanti. Per impostazione predefinita, queste librerie verranno salvate nella sottocartella \Libraries situata nella stessa directory del file DbLib di destinazione.

Segui le pagine della procedura guidata, specificando il database, il file di configurazione CIS, le librerie sorgente OrCAD e il file DbLib di destinazione.
Segui le pagine della procedura guidata, specificando il database, il file di configurazione CIS, le librerie sorgente OrCAD e il file DbLib di destinazione.

Segui le pagine della procedura guidata, specificando il database, il file di configurazione CIS, le librerie sorgente OrCAD e il file DbLib di destinazione.
Segui le pagine della procedura guidata, specificando il database, il file di configurazione CIS, le librerie sorgente OrCAD e il file DbLib di destinazione.

Dopo aver specificato i file e le directory di origine e di destinazione richiesti, fai clic su Next per procedere con l'importazione. Al termine dell'importazione, fai clic su Finish per chiudere la procedura guidata e rendere il file DbLib il documento attivo.

File DbLib risultante al termine del processo di importazione.
File DbLib risultante al termine del processo di importazione.

File DbLib risultante al termine del processo di importazione.
File DbLib risultante al termine del processo di importazione.

Aspetti da tenere presenti:

  • Al file DbLib viene aggiunto automaticamente un percorso di ricerca delle librerie nella scheda Symbol & Model Search Paths della finestra di dialogo Database Library Options, che punta alla directory contenente i file delle librerie convertite.
  • Le informazioni di mappatura dei parametri, inclusa la chiave di ricerca definita, vengono ricavate direttamente dal file di configurazione CIS di OrCAD.
  • Vengono impostate automaticamente due voci di mappatura dei modelli. Di seguito sono riportati alcuni esempi di nomi dei campi del database per queste voci e le voci Design Parameter assegnate:
    • Footprint Name ---> [Orcad Footprint]
    • Symbol Name ---> [Orcad Library]

Queste voci forniscono il collegamento al simbolo schematico sorgente per uno specifico record di componente nel database esterno e al modello di footprint PCB pertinente associato a quel componente.

Creazione manuale della libreria di database

  1. La creazione del file DbLib tramite Import Wizard è il metodo più rapido, ma non l'unico. Puoi anche creare il file DbLib manualmente. Per farlo:
  2. Crea un nuovo file DbLib, collegalo al database esterno e definisci le opzioni di mappatura e di aggiornamento dei parametri in base alle esigenze.
  3. Dovrai quindi importare le librerie OrCAD. Puoi farlo utilizzando Import Wizard per convertire i file delle librerie OrCAD (*.olb, *.llb) in librerie Altium Designer (*.SchLib, *.PcbLib).
    1. Quando scegli i tipi di file da importare, seleziona la voce OrCAD Designs and Libraries Files.

    2. Salta la pagina relativa a Importing OrCAD Designs e passa alla pagina relativa a Importing OrCAD Libraries. Aggiungi tutte le librerie sorgente OrCAD a cui fa riferimento il database.

    3. Salta le altre pagine successive relative all'importazione dei file di progetto.

    4. Nella pagina Output Library Options, lascia abilitata l'opzione predefinita Output Libraries as PCB Project.

    5. Nella pagina Output Libraries, specifica la directory di destinazione dei file di libreria generati.

Importazione delle librerie sorgente OrCAD contenenti i simboli e i footprint a cui fa riferimento il database.
Importazione delle librerie sorgente OrCAD contenenti i simboli e i footprint a cui fa riferimento il database.

Importazione delle librerie sorgente OrCAD contenenti i simboli e i footprint a cui fa riferimento il database.
Importazione delle librerie sorgente OrCAD contenenti i simboli e i footprint a cui fa riferimento il database.

  1. Al termine dell'importazione, nella directory specificata verrà generata una cartella denominata Imported OrCAD Libraries.PrjPcb. Puoi spostare le librerie Altium Designer generate in un'altra posizione, secondo le esigenze. Ad esempio, potresti voler spostare le librerie in una cartella denominata Libraries creata all'interno della directory contenente il file DbLib.
  2. Una volta ottenute le librerie di simboli e footprint, dovrai tornare al file DbLib e impostare i percorsi di ricerca delle librerie (nella scheda Symbol & Model Search Paths della finestra di dialogo Database Library Options) affinché puntino alla cartella in cui sono memorizzate tali librerie.
AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents