シンボルとフットプリントの変更

概略

Altium Designerでデータベースにリンクされたシンボルやフットプリントを管理する際は、標準のDbLibライブラリと、バージョン管理されたSVNDbLibライブラリとでワークフローが異なります。この記事では、参照先のシンボルやデフォルトのフットプリントを開いて編集する方法、SVNライブラリ用のローカル作業フォルダーを設定する方法、Storage Managerパネルを使ってリポジトリの変更を管理し、リビジョンを比較する方法を説明します。次回のライブラリ更新を自信を持って進められるよう、ぜひお読みください。

- 参照先のシンボルやデフォルトのフットプリントにアクセスし、編集して保存する方法を学びます。
- ライブラリのチェックアウトから、ステータスの再取得、ファイルの更新、変更のコミットまで、SVNのワークフローを理解します。
- ライブラリのリビジョンを視覚的に比較し、検出された差異を確認する方法を学びます。
AIでさらに深掘り:

データベース自体の内容を管理するだけでなく、参照されているシンボルやモデルも、必要に応じて管理する必要があります。これには、回路図シンボルとフットプリントモデルの変更が含まれます。また、標準データベースライブラリ(DbLib)の場合は、シミュレーションモデルファイル内の定義の変更も含まれます。

標準とバージョン管理対応のどちらのデータベースライブラリでも、DbLib/SVNDbLibドキュメントをアクティブドキュメントとして開いているときに、そのメインビューから参照先のシンボルやフットプリントモデルに直接アクセスして編集できます。以降のセクションでは、その方法を説明します。SVNDbLibを使用する場合は、手順がやや複雑になりますが、より高度な操作が可能です。

各データベースライブラリファイルをアクティブにして編集用にアクセスできるのは、コンポーネントレコードのシンボルとデフォルトのフットプリントのみです。デフォルトのフットプリントモデルは、Design Parameter [Footprint Ref]にマッピングされたDatabase Field Nameに入力されているモデルであることに注意してください。

DbLibを使用する場合

コンポーネントが参照するシンボル/フットプリントモデルのライブラリファイルを編集用に開くには、Table Browserでコンポーネントのエントリを右クリックし、コンテキストメニューから該当するコマンド(Open SymbolまたはOpen Footprint)を選択します。該当するライブラリファイルが開き、シンボル/フットプリントがデザインスペースにアクティブな要素として表示され、編集できるようになります。

開かれるのは、参照先のシンボル/フットプリントが格納されているライブラリです。データベースにライブラリ情報がある場合はその情報に基づき、ない場合はDatabase Library OptionsダイアログのSymbol and Model Search Pathsタブで定義されたパスを使用して検索されます (該当するライブラリが、指定したパスに実際に存在することも確認してください)。データベースライブラリのシンボルおよびモデルライブラリの場所の指定のセクションを参照してください。

必要な変更を行ったら、ライブラリファイルを保存します。

DbLib内から、データベースコンポーネントが参照するシンボルに直接アクセスする例。DbLib内から、データベースコンポーネントが参照するシンボルに直接アクセスする例。

ソースライブラリファイルには、DbLibファイルの外からアクセスすることもできます。ライブラリエディターのFile » Openコマンドを使用して必要なライブラリを参照して開くか、WindowsエクスプローラーからライブラリファイルをAltium Designerに直接ドラッグ&ドロップします。

SVNDbLibを使用する場合

前述のとおり、SVNDbLibファイルを通じて、データベースコンポーネントが参照するシンボルやモデルにアクセスして編集する操作は、やや複雑ですが、より高度な操作が可能です。変更は、SVNリポジトリに保存されているライブラリのローカル作業コピーに対して行います。

ローカルワークスペースの指定

コンポーネントのシンボルやフットプリントモデルを変更するには、リポジトリからローカル作業ディレクトリにファイルをチェックアウトする必要があります。使用するディレクトリは、PreferencesダイアログのData Management - SVN Librariesページで指定します。デフォルトの作業フォルダーの場所として、\Users\<ProfileName>\Documents\My Designs\SVNDBlib Working Folderが定義されています。必要に応じて、 Button used to browse and select the repository working folderボタンをクリックして既存のフォルダーを参照するか、フォルダーへのパスを直接入力して変更してください。

ローカル作業ディレクトリとして指定するフォルダーには、バージョン管理対象ファイルのコピーのみを格納してください。*.SVNDbLib、*.mdb、*.xlsなどのその他のファイルは、バージョン管理の対象ではないため、別のディレクトリに配置する必要があります。

ローカル作業ディレクトリの指定。ローカル作業ディレクトリの指定。

デフォルトの作業フォルダーは、初期状態では実際には存在しません。リポジトリからファイルをチェックアウトするときに作成されます。現在存在しないフォルダーをパスの直接入力で指定した場合も同様です。

リポジトリ内のすべてのシンボルライブラリとフットプリントモデルライブラリを、指定したローカル作業フォルダーにまとめてチェックアウトするには、SVNDatabaseLibエディターのメインのToolsメニューからCheck Out All Working Foldersコマンドを実行します。チェックアウトされるフォルダーは、Database Library OptionsダイアログのSVN RepositoryタブにあるModels Location領域で指定されたフォルダーです。

SVNリポジトリに保存され、Database Library Optionsの一部として指定されたシンボルとフットプリントを、ローカル作業フォルダーにチェックアウトした例。SVNリポジトリに保存され、Database Library Optionsの一部として指定されたシンボルとフットプリントを、ローカル作業フォルダーにチェックアウトした例。

変更の実施

シンボルライブラリとフットプリントモデルライブラリを指定のローカル作業フォルダーにチェックアウトすると、必要に応じて変更できるようになります。回路図シンボルとフットプリントモデルのローカルコピーを変更し、その変更をSVNリポジトリにコミットします。

DbLibと同様に、次の方法でシンボル/モデルにアクセスして編集できます。

  • SVNDbLibドキュメント内のTable Browserでコンポーネントのエントリを右クリックし、コンテキストメニューから該当するコマンド(Open SymbolまたはOpen Footprint)を選択します。
開かれるローカルライブラリは、参照先のシンボル/フットプリントが格納されているライブラリです。データベースにライブラリ情報がある場合はその情報に基づき、ない場合はDatabase Library OptionsダイアログのSVN Repositoryタブで定義されたモデルの場所を使用して検索されます。データベースライブラリのシンボルおよびモデルライブラリの場所の指定のセクションを参照してください。
  • SVNDbLibがAvailable File-based Librariesリストに追加されている場合は、Componentsパネルから編集コマンドに直接アクセスできます。必要なコンポーネントのエントリを選択し、Edit Symbolコマンド(Components 領域の右クリックコンテキストメニュー)またはEdit Footprintコマンド(Models 領域の右クリックコンテキストメニュー)をそれぞれ使用します。
  • ライブラリエディターのFile » Openコマンドを使用して、ローカル作業フォルダー内の必要なライブラリを参照して開きます。
  • Windowsエクスプローラーから、ローカル作業フォルダー内のライブラリファイルをAltium Designerに直接ドラッグ&ドロップします。

いずれの場合も、必要な変更を行ったら、ライブラリファイルを保存します。

ただし、ローカル作業フォルダーにチェックアウトされたフォルダーやファイルと、リポジトリ自体との間の主な操作窓口となるのは、Storage Managerパネルです。SVNDbLibファイルがアクティブドキュメントになっていると、Storage Manager パネルに、ローカル作業フォルダーにチェックアウトされたシンボルおよびモデルのフォルダーが表示されます。表示されるのは、Database Library OptionsダイアログのSVN RepositoryタブにあるModel Locations領域で指定されたフォルダーです。

Altium DesignerでSVNDbLibファイルがアクティブドキュメントになっている場合、Storage Managerパネルにはローカル作業フォルダーの内容が反映されます。 Altium DesignerでSVNDbLibファイルがアクティブドキュメントになっている場合、Storage Managerパネルにはローカル作業フォルダーの内容が反映されます。

ライブラリファイルを編集用に開くには、パネルのAll Files領域にある該当エントリを右クリックし、表示されるコンテキストメニューからOpenを選択します。必要な変更を行い、対応するエディターの標準のSaveコマンドを使用して、通常どおりファイルを保存します。

変更をリポジトリにコミットする

Panel page: Storage Manager

ライブラリを編集用に開く方法はいくつかありますが、Altium Designerwithinから変更をコミットできるのは、Storage Managerパネルを使用する場合のみです。

Altium Designerでは、リポジトリへのコミットとリポジトリからの更新を行うためのコントロールは、Storage Managerパネルでのみ使用できます。もちろん、外部SVNクライアントの機能を使用して、Altium Designerの外部でコミット、更新、変更の確認を行うこともできます。

Storage Manager パネルを使用する際に特に重要なのは、パネルに表示されているローカルの作業フォルダー/ファイルと、ソース管理リポジトリ内の対応するフォルダー/ファイルとのリンク状態を最新にすることです。個別に選択したライブラリについては、パネルのAll Files領域の右クリックメニューからRefreshコマンドを使用して状態を更新できます。フォルダー全体の状態をすばやく更新するには、Ctrl+F5キーボードショートカットを使用します。

ソースライブラリの状態の更新は、複数の担当者がソースシンボルやモデルファイルのリポジトリを管理する環境では、さらに重要になります。

シンボルおよびモデルのローカルライブラリで使用されるステータスは、次のとおりです。

アイコン ステータス 説明
SVN icon - Normal No modification ライブラリのローカルコピーは、リポジトリ内のものと同一です。ファイルを開いて自由に変更できます。
SVN icon - Out of Date Out of date 作業フォルダー内のファイルのローカルコピーは、リポジトリ内の対応するファイルよりも古く、最新ではありません。変更を加えてコミットする前に、リポジトリからファイルの最新バージョンを取得し、ローカルの作業コピーを更新する必要があります。リポジトリから最新のファイルを取得するには、右クリックのコンテキストメニューでUpdate コマンドを使用します。
SVN icon - Modified Modified ファイルのローカルコピーがAltium Designerで変更され、作業フォルダーに保存されています。ローカルの変更をリポジトリに反映するには、ファイルの項目を右クリックし、コンテキストメニューからCommitコマンドを選択します。リポジトリにチェックインされると、ステータスはNo modificationに戻ります。
SVN icon - Conflict Conflict 編集して保存したファイルをコミットする前に、別のAltium Designerユーザーがそのファイルをコミットしています。Update またはResolve コマンドを使用して、どちらのバージョンのファイルをリポジトリ内の最新リビジョンにするかを決定します。
SVN icon - Locked Locked ファイルが自分または別のユーザーによってロックされています。ロックされたファイルは、強制的にロックを解除しない限り、別のユーザーがリポジトリ内の新しいリビジョンに更新することはできません。この状態は、Modified SVN icon - Locked and ModifiedやNo Modification SVN icon - Locked not Modifiedなどのステータス条件も該当する場合、それらのアイコンと併せて表示されることがあります。
バージョン管理の詳細については、外部バージョン管理の使用を参照してください。

リビジョンの物理的な比較

同じシンボル(モデルライブラリ)の任意の2つのリビジョン間で、物理的な比較を実行できます。これにより、ファイルの連続するリビジョン間、または連続しないリビジョン間で加えられた変更を、視覚的に明確に確認できます。

Storage Managerパネルでは、パネル下部のVCS Revisions領域から比較を実行します。

Storage Managerパネルには、選択したファイルの履歴が、VCS RevisionsとLocal Historyの個別の領域に分けて表示されます。Storage Managerパネルには、選択したファイルの履歴が、VCS RevisionsとLocal Historyの個別の領域に分けて表示されます。

任意の2つのリビジョン間で比較できます。WindowsのCtrl+click選択方法を使用して、パネルのVCS Revisions領域で比較するライブラリの2つのリビジョンを選択し、右クリックしてCompareを選択します。

Compare コマンドを実行すると、選択した2つのドキュメントリビジョンがワークスペースに並べて開かれ、グラフィカルな比較が実行されます。検出された差分は、Differencesパネルに一覧表示されます。

ライブラリエディターの設計 スペースで直接行うグラフィカルな比較。ライブラリエディターの設計 スペースで直接行うグラフィカルな比較。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Nav
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents