データベースライブラリ移行ツール

概略

Altium Designerで利用できるデータベースライブラリ移行ツールをご紹介します。統合ライブラリを標準のデータベースライブラリ(DbLib)、またはバージョン管理に対応したSVNデータベースライブラリ(SVNDbLib)に変換する手順を、ステップごとに解説します。この記事では、変換ウィザードがコンポーネントデータ、シンボル、フットプリントをどのように処理するかを説明し、データベースの制約やセットアップ要件も取り上げます。適切な変換方法を選び、ライブラリの移行を準備するために、ぜひ読み進めてください。

- DbLibとSVNDbLibの使い分けを理解する。
- 変換ウィザードの設定、変換元ライブラリの選択、変換先データベースとリポジトリの指定方法を学ぶ。
- Accessのみが変換に対応していること、SVNリポジトリの事前準備、モデルリンクの処理など、重要な要件と制限事項を把握する。
AIでさらに深掘り:

Altium設計ソフトウェアでは、データベースライブラリを作成して使用することで、企業のデータベースからコンポーネントを直接配置できます。使用するデータベースライブラリの種類は、ソースのシンボルライブラリとモデルライブラリをどのように管理するかによって異なります。ライブラリをハードディスクやネットワークドライブ上に保存する場合は、データベースライブラリ(DbLib)を使用します。一方、Subversionリポジトリを使用してライブラリをソース管理する場合は、SVNデータベースライブラリ(SVNDbLib)を使用します。

どちらのデータベースライブラリを使用する場合も、この機能の基本原理は同じです。リンクされた外部データベースから直接配置できるという点です。この強力な機能をできるだけ簡単に利用できるよう、既存のライブラリをデータベースライブラリ構造へ迅速に移行するためのツールが用意されています。これらのツールでは、次の移行を行えます。

  • 統合ライブラリからデータベースライブラリ(DbLibまたはSVNDbLib)への移行。
  • データベースライブラリ(DbLibまたはSVNDbLib)から統合ライブラリへの移行。
  • ソースの回路図/PCBライブラリからSVNデータベースライブラリへの移行。
  • データベースライブラリからSVNデータベースライブラリへの移行。
  • OrCAD Component Information System(CIS)からデータベースライブラリ(DbLib)への移行。

以下のセクションでは、ソフトウェア内でこれらの移行を実行する方法について詳しく説明します。

統合ライブラリからのデータベースライブラリの作成

統合ライブラリは、その性質上、高い安全性を備えています。さらに、社外に持ち出す設計に適した優れた可搬性も備えています。設計を社内で管理する場合や、Altium設計コンポーネントを企業のデータベースと密接に連携させたい場合には、データベースライブラリが最適です。ソフトウェアには、社内の統合ライブラリをデータベースライブラリ(DbLib)またはSVNデータベースライブラリ(SVNDbLib)の構造にすばやく変換する機能が用意されています。複数の統合ライブラリをまとめて変換することもでき、それぞれが変換先データベースの個別のテーブルとして追加されます。

DbLibへの変換

統合ライブラリ(IntLib)から標準のデータベースライブラリ(DbLib)を作成するには、Integrated Library to Database Library Translator Wizardを使用します。このウィザードは、指定した統合ライブラリを逆コンパイルし、各ライブラリから、選択した変換先データベース内に個別のテーブルを作成します。テーブルには、ライブラリ内のコンポーネントから抽出したパラメーターとモデルの情報も含まれます。その後、指定したデータベースライブラリファイルを使用して、そのデータベースへの接続を確立します。

このウィザードを使用して、既存のDbLibファイルでリンクされている既存のデータベースに、コンポーネントをインポートまたは追加することもできます。
変換で使用できるのは、Access形式のデータベースのみです。

1つ以上のソース統合ライブラリをデータベースライブラリ構造に取り込む処理は、Integrated Library to Database Library Translator Wizardを使用して簡単に行えます。1つ以上のソース統合ライブラリをデータベースライブラリ構造に取り込む処理は、Integrated Library to Database Library Translator Wizardを使用して簡単に行えます。

手順は次のとおりです。

  1. 新しいデータベースライブラリファイル(*.DbLib)を作成するか、既存のファイルを開きます。通常、1つ以上の統合ライブラリを、DbLibファイルが現在接続している既存のAccessデータベースに変換する場合は、その既存のDbLibファイルを使用します。
  2. データベースライブラリファイル(*.DbLib)をアクティブなドキュメントとして開いた状態で、メインメニューからTools » Import From Integrated Librariesコマンドを選択し、Integrated Library to Database Library Translator Wizardを開きます。
  3. ウィザードの最初のSpecify your Database detailsページで、変換先データベースとして、新規または既存のAccessデータベースを指定します。新しいデータベースを作成する場合は、Database Locationフィールドの右側にあるフォルダーアイコンをクリックして、標準のOpen ダイアログを開きます。このダイアログで、新しいデータベースの作成場所と名前を指定します。選択した名前とパスがDatabase Locationフィールドに入力されます。

    既存のDbLibファイルからウィザードを開いた場合は、デフォルトでExisting Access Database オプションが選択され、Database Locationフィールドには、そのDbLibファイルの接続先データベースがあらかじめ入力されます。
  4. ウィザードの次のSpecify your Target Database Libraryページで、変換先のデータベースライブラリファイルを指定します。新規作成するDbLibファイルのパスと名前を指定するか、既存のファイルを参照して開きます。通常、1つ以上の統合ライブラリを、DbLibファイルが現在接続している既存のAccessデータベースに変換する場合は、その既存のDbLibファイルを使用します。デフォルトでは、アクティブなDbLibファイルがフィールドにあらかじめ入力されます。

    既存のDbLibファイルを使用し、変換先データベースを変更した場合は、ウィザードの完了後、そのDbLibファイルは新しい変換先データベースに接続されます。
  5. ウィザードの次のLocate the Integrated Libraries to Importページで、変換する統合ライブラリを指定します。AddボタンをクリックしてSelect Source Integrated Librariesダイアログを開き、必要なライブラリを参照して選択します。ライブラリを構成する回路図シンボルライブラリとモデルライブラリ(存在する場合)が抽出され、Destination Folderフィールドで指定した場所に保存されます。選択したライブラリを一覧から除外または削除するには、Remove ボタンとClear ボタンを使用します。

    デフォルトでは、Destination Folderは、DbLibファイルを含むフォルダー(ウィザードの前のページで指定)の下にあるサブフォルダーLibrariesを指します。
  6. ソースの統合ライブラリを選択したら、Nextをクリックして変換を開始します。進行状況バーとともに、現在変換中のライブラリの情報が表示されます。変換が完了したら、ウィザードの最後のページでFinishをクリックし、指定したDbLibファイルをメイン設計ウィンドウでアクティブにします(まだアクティブになっていない場合)。

    変換対象の各統合ライブラリについて、その統合ライブラリと同じ名前のテーブルがデータベース内に個別に作成されます。既存のデータベースに統合ライブラリと同名のテーブルがすでに存在する場合、そのライブラリの情報は既存のテーブルに追加されます。

変換処理完了後のDbLibファイル。
変換処理完了後のDbLibファイル。

変換処理が完了したら、ソースの回路図ライブラリを開き、シンボルからすべてのパラメーター情報とモデル情報を削除できます。その後、必要に応じてDbLibドキュメントのフィールドマッピング設定を微調整し、適切なデータベース列を参照するようにできます。詳細については、データベースライブラリの作成と定義ページのデータベースフィールドと設計パラメーターのマッピングセクションを参照してください。

ウィザードが抽出するフットプリントモデル情報は、モデル参照と、定義されたモデルへのパスのみです。シミュレーションモデルについては、リンク情報を外部データベースに手動で入力する必要があります。
IntLib内の回路図ライブラリコンポーネントに、Part Numberパラメーターが存在しないことを確認してください。データベースに入力されるPart Number情報(各コンポーネントレコードの識別に使用)は、選択したライブラリコンポーネントのプロパティを表示したときの、PropertiesパネルのGeneralタブにあるPropertiesセクション内の、回路図コンポーネントのDesign Item IDフィールドから取得されます。この情報をパラメーターとしても入力すると、値の重複により変換に失敗します。

SVNDbLibへの変換

統合ライブラリ(IntLib)からバージョン管理されたデータベースライブラリ(SVNDbLib)を作成するには、SVN Database Library Conversion Wizardを使用します。このウィザードは、指定された統合ライブラリを基本的に逆コンパイルし、各ライブラリから新しい出力先データベースに個別のテーブルを作成します。各テーブルには、ライブラリ内のコンポーネントから抽出されたパラメーターとモデルの情報が含まれます。続いて、指定されたSVNデータベースライブラリファイルが作成され、そのファイルを使用してデータベースに接続します。構成要素である回路図ライブラリとPCBライブラリは分割され、指定したSVNバージョン管理リポジトリ内の所定のディレクトリにコミットされます。これらのディレクトリはSVNDbLibファイルから参照されます。

変換では、Access形式のデータベースのみがサポートされています。

1つ以上のソース統合ライブラリをSVNデータベースライブラリ構造に取り込む処理は、SVN Database Library Conversion Wizardを使用して簡単に行えます。1つ以上のソース統合ライブラリをSVNデータベースライブラリ構造に取り込む処理は、SVN Database Library Conversion Wizardを使用して簡単に行えます。

手順は次のとおりです。

  1. SVN Database Library Conversion Wizardを開きます。次のいずれかの方法で開くことができます。
  • 回路図ライブラリエディター、PCBライブラリエディター、またはデータベースライブラリエディターのメインメニューから、Tools » SVN Database Library Makerコマンドを選択します。
  • Projectsパネルで、プロジェクトライブラリ(SchLib、PcbLib、またはIntLib)の項目を右クリックし、コンテキストメニューからSVN Database Library Makerコマンドを選択します。
  1. Libraries to Convertページで、変換する統合ライブラリを指定します。リストには、最初から1つ以上のライブラリが表示されています(開いた方法に応じて、アクティブなライブラリ、またはプロジェクトに追加されているすべてのプロジェクトライブラリが表示されます)。変換する統合ライブラリを選択する前に、これらをリストから削除してください。Addボタンを使用してLibrary Filesダイアログを開き、必要な統合ライブラリを参照して選択します。
  2. Options ページで、ソースライブラリの分割方法、保存先のリポジトリとディレクトリ、SVNDbLibファイルの出力ディレクトリなど、変換に関するオプションを設定します。回路図ライブラリについては、各構成コンポーネントからパラメーター情報やモデル情報を削除し、シンボルのみを残すための2つのオプションも用意されています。

    SVNリポジトリとそのフォルダー構造は、あらかじめ定義しておく必要があります。ここでは、分割されたライブラリファイルの保存先として、既存のリポジトリとその構造内のフォルダーを指定するだけです。処理中にリポジトリやフォルダーが作成されることはありません。
  3. ソース統合ライブラリを選択し、必要に応じて関連する変換オプションを設定したら、Next をクリックして変換を開始します。進行状況バーと、現在変換中のライブラリに関する情報が表示されます。変換処理には、次の操作が含まれます。
    1. 指定された統合ライブラリからソースライブラリを抽出します。
    2. 回路図ライブラリとPCBライブラリを、シンボルまたはフットプリントを1つずつ含むライブラリファイルに分割します。
    3. 分割されたシンボルライブラリとフットプリントライブラリを、リポジトリ内の指定されたベースディレクトリにコミットします。
    4. ウィザードは、フットプリントモデルの参照情報のみを抽出します。バージョン管理されたデータベースライブラリ(SVNDbLib)は、リンクされたシミュレーションモデルをサポートしていますが、Subversionリポジトリへのシミュレーションモデルファイルの保存はサポートしていません。このようなリンクが存在する場合は、パラメーターとして追加されます。
    5. 生成されたAccessデータベース(SVNDbLibに指定された名前と同じ名前になります)に、変換する統合ライブラリごとに個別のテーブルを作成します。各テーブルには、ライブラリ内のコンポーネントから抽出されたパラメーターとモデルの情報が含まれます。各テーブルの名前は、統合ライブラリの名前に_IntLibサフィックスを付けたものになります(例:Capacitor - Ceramic_IntLib)。
    6. 指定されたSVNDbLibファイルを作成し、データベースとリポジトリに接続します。
  4. 変換が完了したら、Finish をクリックしてウィザードを閉じ、SVNDbLibファイルをアクティブなドキュメントにします。

変換処理完了後のSVNDbLibファイル。変換処理完了後のSVNDbLibファイル。

IntLib内の回路図ライブラリコンポーネントに、Part Numberパラメーターが含まれていないことを確認してください。データベースに入力される部品番号情報(各コンポーネントレコードを識別するための情報)は、選択したライブラリコンポーネントのプロパティを表示したときに、PropertiesパネルのGeneralタブにあるPropertiesセクションの、回路図コンポーネントのDesign Item IDフィールドから取得されます。この情報をパラメーターとしても入力すると、値が重複するため変換に失敗します。

データベースライブラリからの統合ライブラリの作成

データベースライブラリは、Altiumの設計コンポーネントを社内データベースと密接に連携させたい場合に最適です。設計を社外に持ち出す必要がある場合や、設計者に安全な統合ライブラリを使用して作業してもらいたい場合にも、簡単に対応できます。このソフトウェアには、標準のデータベースライブラリ(DbLib)またはバージョン管理されたSVNデータベースライブラリ(SVNDbLib)から、統合ライブラリを直接コンパイルする機能があります。これにより、CADライブラリ管理者は引き続きデータベースライブラリを使用し、設計者は定期的に再生成される統合ライブラリを使用して、いわば「オフライン」で作業できます。

変換にはOffline Integrated Library Makerを使用します。処理はデータベースのテーブル単位で実行され、データベース内のどのテーブルを対象とするかを完全に制御できます。変換処理には、回路図コンポーネント、PCBモデル、PCB3Dモデル、およびシミュレーションモデルが含まれます。対象のテーブルごとに、個別の統合ライブラリが生成されます。これらのテーブルはそれぞれ統合ライブラリに変換され、Installed Librariesに追加されます。

Offline Integrated Library Maker.
Offline Integrated Library Maker.

を使用して、データベースライブラリ(DbLibまたはSVNDbLib)を「オフライン」の統合ライブラリに変換します。手順は次のとおりです。

  1. 変換するデータベースライブラリファイル(*.DbLib)またはSVNデータベースライブラリファイル(*.SVNDbLib)をアクティブなドキュメントとして開いた状態で、メインメニューからTools » Offline Integrated Library Makerコマンドを選択し、Offline Integrated Library Makerを開きます。
  2. Library to Convertページで、処理するDbLibまたはSVNDbLibを指定します。デフォルトでは、Offline Integrated Library Maker を開いたときにアクティブだったライブラリが、変換対象のライブラリとして指定されます。必要に応じて、別のデータベースライブラリを参照して選択できます。

  3. Optionsページで、リンク先のデータベース内のどのテーブルを変換対象に含めるかを指定します。デフォルトでは、すべてのデータベーステーブルが対象に含まれます。テーブルを除外するには、そのテーブルに対応するConvert オプションを無効にしてください。このページでは、生成される統合ライブラリを保存する出力ディレクトリも指定できます。このベースディレクトリへのパスを直接入力するか、フィールドの右側にあるBrowse iconアイコンをクリックしてダイアログを開き、必要なディレクトリを参照して選択します。対象となる各データベーステーブルから生成された出力(統合ライブラリ)は、指定された出力ディレクトリ内に、テーブル名を使用して作成された個別のサブフォルダーに保存されます。

  4. データベースライブラリを選択し、必要に応じて関連する変換オプションを設定したら、Next をクリックして変換を開始します。進行状況バーとともに、現在変換中のデータベーステーブルに関する情報が表示されます。変換処理は、変換対象として指定した各データベーステーブルに対して実行されます。この処理の概要は次のとおりです。
    1. 統合ライブラリパッケージ(*.LibPkg)が作成され、Projectsパネルで開かれます。パッケージにはテーブル名が使用されます。たとえば、テーブル名がCapacitor - Ceramicの場合、パッケージ名はCapacitor - Ceramic.LibPkgになります。
    2. 回路図ライブラリドキュメントが作成され、LibPkgに追加されます。この回路図ライブラリにもテーブル名が使用されます(例: Capacitor - Ceramic.SchLib)。
    3. 次に、テーブル内の各レコードが処理され、対応するAltium Designコンポーネントが構築されます。この処理では、参照されている回路図シンボルが該当するソースライブラリから取得され、新しい回路図ライブラリドキュメントにコンポーネントとして追加されます。その後、レコードで定義されているパラメーターとモデルリンクの情報が、そのコンポーネントに追加されます。
    4. レコードで参照されているフットプリントモデルが取得され、PCBライブラリドキュメントに追加されます。このドキュメントにもテーブル名が使用されます(例: Capacitor - Ceramic.PcbLib)。その後、PCBライブラリドキュメントがLibPkgに追加されます。
    5. ソースライブラリがDbLibで、データベースレコードにシミュレーションモデルへのリンクが定義されている場合、参照されているシミュレーションモデルファイルもLibPkgに追加されます。これらのモデルの保存場所は変更されません。モデルへのフルパスは、対応するモデルリンクの一部として指定されます。
    6. その後、LibPkgがコンパイルされて統合ライブラリ(例: Capacitor - Ceramic.IntLib)が生成され、ソフトウェアのインストール済みライブラリに追加されます。

現在インストールされているライブラリは、Available File-based LibrariesダイアログのInstalled タブで確認できます。このダイアログには、Componentsパネルの右上にある Open Libraries dialogs in Components Panel ボタンをクリックし、File-based Libraries Preferencesを選択してアクセスできます。

変換処理の結果:シンボルとフットプリントモデルの各ドキュメントを含むライブラリパッケージプロジェクト、およびコンパイル済みのIntLib。IntLibはインストール済みライブラリとしても追加されるため、すべてのPCB設計プロジェクトで使用できます。
変換処理の結果:シンボルとフットプリントモデルの各ドキュメントを含むライブラリパッケージプロジェクト、およびコンパイル済みのIntLib。IntLibはインストール済みライブラリとしても追加されるため、すべてのPCB設計プロジェクトで使用できます。

ソースライブラリ(SCHLib/PCBLib)からのSVNDbLibの作成

SVN Database Library Conversion Wizardを使用すると、回路図ライブラリ、PCBライブラリ、データベースライブラリ、統合ライブラリをSVNデータベースライブラリに変換できます。 このウィザードは、さまざまなコンポーネント管理方式をSVNデータベースライブラリ(*.SVNDBLib)に移行する処理を効率化します。 SVNデータベースライブラリは、データベースからコンポーネントを直接配置する機能を基に、リンク方式を拡張して、ソース管理されたライブラリを利用できるようにしたものです。回路図シンボルとフットプリントモデルは、Subversionベースのリポジトリ内に格納されます。リポジトリおよび外部データベースへのリンクは、SVNデータベースライブラリファイル(*.SVNDBLib)内で定義されます。このファイルはデータベースライブラリファイル(*.DBLib)を拡張したもので、一般に Version-Controlled Database Libraryと呼ばれます。

ウィザードを使用して、ソースライブラリの分割方法、保存先となるリポジトリとディレクトリ、SVNDBLibファイルの出力ディレクトリなど、変換に関するオプションを設定します。 

変換対象となるデータベースライブラリ、回路図ライブラリ(*.SchLib)、PCBライブラリ(*.PcbLib)、または統合ライブラリ(*.IntLib)を選択する必要があります。変換されたライブラリはSVNリポジトリにチェックインされます。また、単一のSVNデータベースライブラリも作成されます。 

このウィザードでは、SVNリポジトリへの接続、シンボルとモデルのベースディレクトリ、SVNデータベースライブラリドキュメントへのパスを設定できます。デフォルトでは、出力ディレクトリはソースライブラリが保存されているディレクトリと同じ場所に設定されます。

生成するSVNDBLibファイルとデータベースを同じ場所に配置したい場合、基本的に2つの方法があります。1つ目は、SVNDBLibの出力先を、データベースが現在保存されているディレクトリに設定する方法です。2つ目は、別のディレクトリにSVNDBLibを生成してから、そのディレクトリにデータベースを移動する方法です。この場合は、SVNDBLibファイル内の接続設定を変更してデータベースの新しい場所を指定し、再接続する必要があります。

  • 分割されたライブラリファイルはSVNリポジトリに追加されるため、リポジトリ内で使用するシンボル/モデルファイルのフォルダー構成を、ローカルのハードディスク上にあらかじめ別途作成しておく必要があります。 リポジトリ内のフォルダー構成は、TortoiseSVNなどのSVNクライアントを使用して管理します。
  • SVNリポジトリとSVNバージョン管理システムが、お使いのマシンにインストールされているか、ネットワーク経由で利用できる必要があります。また、Preferences ダイアログの Data Management - Version Controlページで、Providerが SVN - Subversionに設定されていることを確認してください。
  • 変換で使用できるのは、Access形式のデータベースのみです。

SVN Database Library Conversion WizardSVN Database Library
Conversion
Wizardを使用すると、1つ以上のソース回路図ライブラリとPCBライブラリを、SVNデータベースライブラリ構造に効率よく取り込むことができます。

この処理には、次の手順が含まれます。

  1. 次のいずれかの方法でSVN Database Library Conversion Wizardを開きます。

    • 回路図ライブラリファイル(*.SchLib)、PCBライブラリファイル(*.PcbLib)、統合ライブラリファイル(*.IntLib)、またはデータベースライブラリファイル(*.DbLib)から、 Tools » SVN Database Library Maker をクリックします。ただし、回路図ライブラリからウィザードを開き、リンクされたフットプリントモデルも変換対象に含める場合は、対応するPCBフットプリントライブラリを参照して追加する必要があります。また、PCBフットプリントライブラリのみを変換するケースは一般的ではないため、対応する回路図コンポーネントライブラリも参照して追加する必要があります。
    • Projects パネルで、目的のライブラリ(*.SchLib、*.PcbLib、または*.IntLib)のエントリを右クリックし、SVN Database Library Makerを選択します。ウィザードは、プロジェクト内のすべてのライブラリを自動的に読み込みます。これは最も簡単な方法ですが、ソースの回路図ライブラリとPCBライブラリがプロジェクトに追加されている必要があります。統合ライブラリを使用していない場合は、多くの場合この状態になっています。
    ウィザードには、起動元に応じたライブラリエントリがあらかじめ設定されます。そのため、時間を節約するには、以下の説明に従って適切なエディターからウィザードを起動してください。

  2. Libraries to Convertページで、変換するライブラリを選択します。 データベースライブラリ、または回路図ライブラリ、PCBライブラリ、統合ライブラリから選択します。 選択したライブラリは、個々のコンポーネントライブラリに分割された後、SVNリポジトリにチェックインされます。単一のSVNデータベースが作成されます。

    • Converting a Database Library

      Database Librariesを変換する際は、次の処理が行われます。

      1. リンクされたデータベースのコンポーネントレコードが参照する回路図ライブラリとPCBライブラリを、単一のシンボル/フットプリントを含むライブラリファイルに分割します。
      2. 分割したシンボルライブラリとフットプリントライブラリを、リポジトリ内の指定されたベースディレクトリにコミットします。
      3. 指定されたSVNDBLibファイルを作成し、データベースとリポジトリに接続します。
    • Converting Schematic, PCB, and Integrated Libraries

      Addボタンを使用して標準ダイアログを開き、追加するファイルを検索して選択します。現在選択されているライブラリを削除するには、Remove ボタンをクリックします。

      回路図ライブラリ、PCBライブラリ、統合ライブラリを変換する際は、次の処理が行われます。

      1. 指定された統合ライブラリからソースライブラリを抽出します。
      2. 回路図ライブラリとPCBライブラリを、単一のシンボル/フットプリントを含むライブラリファイルに分割します。
      3. 分割したシンボルライブラリとフットプリントライブラリを、リポジトリ内の指定されたベースディレクトリにコミットします。
      4. ウィザードはフットプリントモデルの参照情報のみを抽出します。SVNDBLibでは、リンクされたPCB3Dモデルおよびシミュレーションモデルはサポートされていません。このようなリンクが存在する場合は、パラメーターとして追加されます。
      5. 変換する回路図ライブラリおよび/または統合ライブラリごとに、生成されたAccessデータベース内に個別のデータベーステーブルを作成します。各テーブルには、コンポーネントから抽出されたパラメーター情報とモデル情報が含まれます。各テーブルの名前には、回路図ライブラリ名に_SchLibという接尾辞を付けた名前(例:Mixer_SchLib)、および/または統合ライブラリ名に_IntLibという接尾辞を付けた名前(例:AD Differential Amplifier_IntLib)が使用されます。
      6. 指定されたSVNDBLibファイルを作成し、データベースとリポジトリに接続します。
  3. Optionsページでは、ソースライブラリの分割方法、保存先のリポジトリとそのディレクトリ、SVNDbLibファイルの出力ディレクトリなど、変換に関するオプションを設定します。回路図ライブラリについては、各コンポーネントからパラメーター情報および/またはモデル情報を削除し、シンボルのみを残すための2つのオプションも用意されています。

    SVNリポジトリとそのフォルダー構造は、あらかじめ定義しておく必要があります。ここでは、分割したライブラリファイルの保存先となるリポジトリと、その構造内のフォルダーを指定するだけです。リポジトリやフォルダーがその場で作成されることはありません。

    SVN Options

    この領域で、SVNリポジトリへの接続設定を行います。

    Methodドロップダウンから接続方法を選択します。選択肢は、file(ファイルベースのリポジトリ)、http(クラウドベースのリポジトリ)、https(セキュアなクラウドベースのリポジトリ)、svn、またはsvn+sshです。

    Location 領域(Methodでfileを選択した場合のみ使用可能)では、リポジトリの場所を示すパスを設定します。フォルダー参照アイコンを使用して、目的の場所を検索し、選択します。

    Server領域(Methodでfileがnot選択されている場合のみ使用可能)では、目的のサーバーを設定します。

    Server PortをDefaultまたはNon-Defaultに設定します。Non-Defaultを選択した場合は、テキストボックスにサーバーのポート番号を入力します。また、Repository folderの名前もテキストボックスに入力する必要があります。

    Server PortおよびRepository folderのオプションは、選択したMethodがnot fileの場合のみ使用できます。

    ...をクリックして、それぞれの保存先フォルダーを検索・選択し、SymbolsとFootprintsのリポジトリ内ベースディレクトリを指定します。

    SVN DB Library Options

    SVN DB Library Options領域では、SVNデータベースライブラリドキュメントのパスを指定できます。バックエンドのAccessデータベースがまだ存在しない場合は、同じフォルダー内に作成されます。フォルダー参照アイコンを使用して、パスを検索し、選択します。

    生成されるSVNDBLibファイルとデータベースを同じ場所に配置するには、基本的に2つの方法があります。1つ目は、SVNDBLibの出力パスを、データベースが現在保存されているディレクトリと同じにする方法です。2つ目は、別のディレクトリにSVNDBLibを生成してから、そのディレクトリにデータベースを移動する方法です。この場合は、SVNDBLibファイル内の接続設定を変更して、移動先のデータベースを参照するようにし、再接続する必要があります。

    Library Splitting Options

    ドロップダウンで、ファイルをOverwrite Existing Filesするか、Append Incrementing Number To File Namesするか(ライブラリの分割時に接尾辞を付けた新しいファイルを作成するか)を選択します。Overwrite Existing Filesを選択すると、ライブラリの分割時にリポジトリ内の既存ファイルが上書きされます。Append Incrementing Number To File Namesを選択すると、指定したリポジトリ内のすべてのファイルが保護されて上書きされなくなり、同名の新しいコンポーネントライブラリには接尾辞「_#IncrementNumber」が付加されます。

    回路図ライブラリについては、分割された回路図コンポーネントからパラメーター情報および/またはモデル情報を削除し、シンボルのみを残すための2つのオプションも用意されています。Remove All Parametersおよび/またはRemove All Modelsを選択します。元のDBLibファイルにリンクされた外部データベースがすでに存在するため、新しいデータベースは作成されません。データベースは現在の場所にそのまま残ります。

  4. ソースとなる回路図ライブラリとPCBライブラリを選択し、必要に応じて関連する変換オプションを設定したら、Next をクリックして変換を開始します。進行状況バーとともに、現在変換中のライブラリに関する情報が表示されます。変換では、次の処理が行われます。
    1. 回路図ライブラリとPCBライブラリを、単一のシンボル/フットプリントを含むライブラリファイルに分割します。
    2. 分割したシンボルライブラリとフットプリントライブラリを、リポジトリ内の指定されたベースディレクトリにコミットします。
    3. ウィザードはフットプリントモデルの参照情報のみを抽出します。バージョン管理されたデータベースライブラリ(SVNDbLib)では、リンクされたシミュレーションモデルがサポートされていますが、Subversionリポジトリへのシミュレーションモデルファイルの保存はサポートされていません。このようなリンクが存在する場合は、パラメーターとして追加されます。
    4. 変換する回路図ライブラリごとに、生成されたAccessデータベース(SVNDbLibに指定した名前と同じ名前が付けられます)内に個別のデータベーステーブルを作成します。各テーブルには、そのライブラリ内のコンポーネントから抽出されたパラメーター情報とモデル情報が含まれます。各テーブルには、回路図ライブラリ名に_SchLibという接尾辞を付けた名前が付けられます(例:Capacitor - Ceramic_SchLib)。
    5. 指定されたSVNDbLibファイルを作成し、データベースとリポジトリに接続します。
  5. 変換が完了したら、Finish をクリックしてウィザードを閉じ、SVNDbLibファイルをアクティブなドキュメントにします。

変換処理の完了後に生成されたSVNDbLibファイル。変換処理の完了後に生成されたSVNDbLibファイル。

回路図ライブラリのコンポーネントに Part Number パラメーターが含まれていないことを確認してください。各コンポーネントレコードを識別するためにデータベースに入力される部品番号情報は、選択したライブラリコンポーネントのプロパティを表示した際に、Propertiesパネルの General タブにある Properties セクションの、回路図コンポーネントの Design Item ID フィールドから取得されます。この情報をパラメーターとしても入力すると、値の重複により変換に失敗します。処理自体は完了しますが、このパラメーターを持つ回路図コンポーネントはデータベースに作成されず、SVNDbLibドキュメントの Table Browser タブにあるデータベースコンポーネントの一覧にも表示されません。

DbLibからSVNDbLibへの変換

既存の統合ライブラリをDbLib構造に変換したり、DbLibを一から作成したりして、データベースライブラリ機能の利便性をすでに実感しているかもしれません。さらに、ソースのシンボルライブラリとフットプリントライブラリを、ソース管理リポジトリの保護された安全な環境で管理したいと考えることもあるでしょう。このソフトウェアには、現在の標準データベースライブラリ(DbLib)をバージョン管理されたデータベースライブラリ(SVNDbLib)へ移行する機能が用意されています。

変換には SVN Database Library Conversion Wizard を使用し、統合ライブラリを変換する場合とほぼ同じ方法で実行できます。

SVN Database Library Conversion WizardSVN Database
Library Conversion Wizard
を使用すると、既存の標準データベースライブラリ(DbLib)をバージョン管理されたデータベースライブラリ(SVNDbLib)へ簡単に変換できます。

手順は次のとおりです。

  1. 変換する既存のDbLibを開き、メインメニューから Tools » SVN Database Library Maker を選択します。SVN Database Library Conversion Wizard が開きます。
  2. Libraries to Convert ページで、変換するソースデータベースライブラリを指定します。Database Libraries オプションはすでに有効になっており、対応するフィールドにはアクティブなライブラリのパスが入力されています。別のDbLibを変換する場合は、Browse icon ボタンをクリックし、表示されるダイアログで目的のファイルを参照して選択します。
  3. Next をクリックすると、選択したDbLibファイルが解析され、バックエンドデータベースが変更される可能性があることを通知する確認ダイアログが表示されます。Yes をクリックして続行します。
  4. Options ページで、ソースライブラリの分割方法、保存先のリポジトリとそのディレクトリ、SVNDbLibファイルの出力ディレクトリなど、変換に関するオプションを設定します。回路図ライブラリについては、各コンポーネントからパラメーター情報やモデル情報を削除し、シンボルのみを残すための2つのオプションも用意されています。
SVNリポジトリとそのフォルダー構造は、あらかじめ定義しておく必要があります。ここでは、分割したライブラリファイルの保存先となるリポジトリと、その構造内のフォルダーを指定するだけです。リポジトリやフォルダーがその場で作成されるわけではありません。
外部データベースは元のDbLibファイルにリンクされた状態ですでに存在するため、新たに作成されることはありません。データベースは現在の場所にそのまま残ります。生成されるSVNDbLibファイルとデータベースを同じ場所に配置するには、基本的に2つの方法があります。1つ目は、SVNDbLibの出力先を、データベースが現在保存されているディレクトリに設定する方法です。2つ目は、別のディレクトリにSVNDbLibを生成してから、データベースをそのディレクトリに移動する方法です。後者の場合は、SVNDbLibファイル内の接続設定を変更してデータベースの新しい場所を指定し、再接続することを忘れないでください。
  1. ソースのDbLibファイルを選択し、必要に応じて変換関連のオプションを設定したら、Next をクリックして変換を開始します。変換中のライブラリに関する情報と進行状況バーが表示されます。変換では、次の処理が行われます。
    1. リンクされたデータベース内のコンポーネントレコードが参照する回路図ライブラリとPCBライブラリを、シンボルまたはフットプリントを1つずつ含むライブラリファイルに分割します。
    2. 分割したシンボルライブラリとフットプリントライブラリを、リポジトリ内の指定したベースディレクトリにコミットします。
    3. 指定したSVNDbLibファイルを作成し、データベースとリポジトリに接続します。
  2. 変換が完了したら、Finish をクリックしてウィザードを閉じ、SVNDbLibファイルをアクティブドキュメントにします。

変換処理の完了後に生成されたSVNDbLibファイル。変換処理の完了後に生成されたSVNDbLibファイル。

フィールドマッピングについて

生成されたSVNDbLibでは、Field Mappings タブで定義されているデータベースフィールドと設計パラメーター間のマッピングは、元のDbLibで定義されたまま維持されます。

元のDbLibと生成されたSVNDbLibの間で、フィールドマッピングは変わりません。元のDbLibと生成されたSVNDbLibの間で、フィールドマッピングは変わりません。

ただし、次の2つの重要な点に注意してください。

  • シンボルとフットプリントモデルに定義されているパスマッピングは無視されます。SVNDbLibは、マッピングされた参照フィールドである [Library Ref] と [Footprint Ref] のみを使用して、リポジトリにコミットされたライブラリ内から必要なシンボルとフットプリントを検索します。データベースに定義されているパス情報は、ハードディスクやその他のローカル/ネットワークメディア上のライブラリを指しているため、無視されます。
データベースにパス情報を引き続き含めたい場合は、リポジトリ内のライブラリを指すように情報を変更してください。ただし、データベースにライブラリのパス情報を指定しないほうが、変更に対してはるかに強くなることを覚えておくとよいでしょう。リポジトリの場所や内部のフォルダー構造が変更されても、データベースを更新する必要がなくなります。
  • 定義済みのシミュレーションモデルのマッピングも、SVNDbLibファイル内にそのまま残ります。ただし、Subversionリポジトリへのシミュレーションモデルファイルの保存はサポートされていません。コンポーネントインスタンスを配置するとモデルリンクは追加されますが、モデル自体は見つかりません。

OrCAD® CISの直接サポート

このソフトウェアは、データベースライブラリシステムを基盤として、既存のOrCAD Component Information Systems(CIS)への接続と利用を全面的にサポートしています。CIS構造は、実質的にAltium Designerの標準データベースライブラリ構造(DbLib)へ変換されます。

OrCADからAltium Designerへ — 必要な変換

外部データベースから直接配置(*.mdb、*.xls)できるようにするには、次のファイル変換が必要です。

  • 外部データベースへのリンクを管理し、データベースフィールドと設計パラメーターのマッピング情報を含むOrCAD CIS設定ファイル(*.dbc)を、Altium Designerデータベースライブラリファイル(*.DbLib)に変換する必要があります。
Altium Designerは現在、バイナリ形式のOrCAD CIS .dbcファイルのみをサポートしています。
  • 関連するOrCADライブラリファイルを、Altium Designerのライブラリファイルに変換する必要があります。
    • OrCAD Captureライブラリ(*.olb)---> 回路図ライブラリ(*.SchLib)。
    • OrCAD Maxライブラリファイル(*.llb)---> PCBライブラリ(*.PcbLib)。

データベースライブラリの自動作成

DbLibファイルとソースとなるAltium Designerライブラリを作成する最も簡単で効率的な方法は、Import Wizard(File » Import Wizard)を使用することです。ウィザードの2ページ目で、インポートするファイルの種類として OrCAD CIS Configuration Files and Libraries が選択されていることを確認してください。

Import Wizardを使用すると、CIS設定ファイルと関連するOrCADライブラリを、Altium DesignerのDbLibファイルおよびソースライブラリ(SchLibおよびPcbLib)ファイルにすばやく変換できます。
Import Wizardを使用すると、CIS設定ファイルと関連するOrCADライブラリを、Altium DesignerのDbLibファイルおよびソースライブラリ(SchLibおよびPcbLib)ファイルにすばやく変換できます。

Import Wizardを使用すると、CIS設定ファイルと関連するOrCADライブラリを、Altium NEXUSのDbLibファイルおよびソースライブラリ(SchLibおよびPcbLib)ファイルにすばやく変換できます。
Import Wizardを使用すると、CIS設定ファイルと関連するOrCADライブラリを、Altium NEXUSのDbLibファイルおよびソースライブラリ(SchLibおよびPcbLib)ファイルにすばやく変換できます。

ウィザードの以降のページに従って、次の項目を指定します。

  • 外部データベースの場所。
  • CIS設定ファイル(*.dbc)の場所。このファイルはXML形式ではなく、バイナリ形式である必要があることに注意してください。
  • 作成するDbLibファイルの保存先と名前。
  • 外部データベースが参照するOrCADの回路図ライブラリおよびPCBライブラリ。
OrCADソースライブラリを指定する際には、変換後のAltium Designerライブラリの保存先も指定できます。デフォルトでは、これらのライブラリは、作成先のDbLibファイルと同じディレクトリ内にあるサブフォルダー\Librariesに保存されます。

ウィザードの各ページに従って、データベース、CIS設定ファイル、ソースOrCADライブラリ、および作成先のDbLibファイルを指定します。
ウィザードの各ページに従って、データベース、CIS設定ファイル、ソースOrCADライブラリ、および作成先のDbLibファイルを指定します。

ウィザードの各ページに従って、データベース、CIS設定ファイル、ソースOrCADライブラリ、および作成先のDbLibファイルを指定します。
ウィザードの各ページに従って、データベース、CIS設定ファイル、ソースOrCADライブラリ、および作成先のDbLibファイルを指定します。

必要なソースファイル、作成先ファイル、およびディレクトリを指定したら、Nextをクリックしてインポートを開始します。インポートが完了したら、Finish をクリックしてウィザードを閉じ、DbLibファイルをアクティブなドキュメントにします。

インポート処理の完了後に生成されたDbLibファイル。
インポート処理の完了後に生成されたDbLibファイル。

インポート処理の完了後に生成されたDbLibファイル。
インポート処理の完了後に生成されたDbLibファイル。

注意事項:

  • Database Library OptionsダイアログのSymbol & Model Search Pathsタブで、変換後のライブラリファイルが格納されているディレクトリを指すライブラリ検索パスが、DbLibファイルに自動的に追加されます。
  • 定義済みのルックアップキーを含むパラメータのマッピング情報は、OrCAD CIS設定ファイルから直接取得されます。
  • モデルのマッピングエントリが2つ自動的に設定されます。これらに対応するデータベースのフィールド名と、割り当てられるDesign Parameterエントリの例を以下に示します。
    • Footprint Name ---> [Orcad Footprint]
    • Symbol Name ---> [Orcad Library]

これらのエントリは、外部データベース内の特定のコンポーネントレコードに対応するソース回路図シンボルと、そのコンポーネントにリンクされた該当するPCBフットプリントモデルへのリンクを提供します。

データベースライブラリの手動作成

  1. Import Wizardを使用するのがDbLibファイルを作成する最も速い方法ですが、これが唯一の方法ではありません。DbLibファイルは手動で作成することもできます。手順は次のとおりです。
  2. 新しいDbLibファイルを作成して外部データベースに接続し、必要に応じてマッピングとパラメータの更新オプションを定義します。
  3. 次に、OrCADライブラリをインポートする必要があります。Import Wizardを使用すると、OrCADライブラリファイル(*.olb、*.llb)をAltium Designerライブラリ(*.SchLib、*.PcbLib)に変換できます。
    1. インポートするファイルの種類を選択する際は、OrCAD Designs and Libraries Filesの項目を選択します。

    2. Importing OrCAD Designsのページをスキップして、Importing OrCAD Librariesのページに進みます。データベースが参照するすべてのソースOrCADライブラリを追加します。

    3. それ以降の設計ファイルのインポートに関するページはスキップします。

    4. Output Library Optionsページでは、デフォルトのOutput Libraries as PCB Projectオプションを有効のままにします。

    5. Output Librariesページでは、生成されるライブラリファイルの出力ディレクトリを指定します。

データベース内で参照されているシンボルとフットプリントを含む、OrCADソースライブラリのインポート。
データベース内で参照されているシンボルとフットプリントを含む、OrCADソースライブラリのインポート。

データベース内で参照されているシンボルとフットプリントを含む、OrCADソースライブラリのインポート。
データベース内で参照されているシンボルとフットプリントを含む、OrCADソースライブラリのインポート。

  1. インポートが完了すると、指定したディレクトリ内にImported OrCAD Libraries.PrjPcbという名前のフォルダーが生成されます。生成されたAltium Designerライブラリは、必要に応じて別の場所に移動できます。たとえば、DbLibファイルを含むディレクトリ内にLibrariesという名前のフォルダーを作成し、そこにライブラリを移動できます。
  2. シンボルライブラリとフットプリントライブラリを用意したら、DbLibファイルに戻り、これらのライブラリが格納されているフォルダーを指すように、ライブラリ検索パスを設定する必要があります(Database Library OptionsダイアログのSymbol & Model Search Pathsタブ)。
AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Nav
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents