Altium Designer Documentation

回路図シンボルの作成_AD

Created: April 27, 2022 | Updated: July 7, 2022

The schematic symbol typically includes a shape that can reflect the function of the component and one or more pins. How a component is represented, i.e. the look of the symbol and arrangement of component pins, is up to the designer. This should be done to comply with the requirements of your organization and the design standards you choose to adopt. One component symbol can represent the entire physical component, or the component can be defined by multiple sub-parts where each sub-part represents some logical entity within the physical component (e.g., each AND gate in a quad AND gate component, or the coil and contact sets in a relay). This type of component is also called a multi-part component.

Schematic symbols are created by placing drawing objects to represent the component body and pins that represent the physical pins on the actual component. Schematic symbols are created in Altium Designer's schematic symbol editor.

Notes about symbol creation:

  • Objects placed in the library editor are stacked in the order they are placed. Use the Edit » Move commands to change the display order if the pins become hidden behind the component body.
  • Only one end of a pin is electrical. This end is referred to as the hotspot. Make sure the hotspot (the end by which you hold the pin) is away from the component body. Refer to the Pin object for more information.
  • In the schematic library editor, the properties of the currently active symbol, such as the default designator and the description, are edited in the Properties panel in Symbol mode. The panel displays in this mode when nothing is selected. If you double-click on a primitive placed as part of the component symbol, the Properties panel will display the properties of that primitive rather than the parent component.
  • The option used to display the designator and comment on the symbol editor sheet (Show Comment/Designator) is enabled/disabled for the current library in the Library Options mode of the Properties panel. Select the Tools Document » Options command to displays the Properties panel in this mode
  • The fonts can be configured individually for each object as they are placed, or you can set your preferred fonts for new objects by editing each of the appropriate objects on the Schematic - Defaults page of the Preferences dialog.
  • Multiple pins can be imported from a spreadsheet into the current component via the Smart Grid commands on the right-click menu in the SCHLIB List panel.
  • Install the Schematic Symbol Generation Tool extension to quickly build high-pin count components. The tool also supports importing pin details from a spreadsheet via the right-click menu.

Before you start creating component symbols, it is worth spending some time configuring your preferred defaults. The defaults for all schematic design objects (both library and sheet) are configured on the Schematic - Defaults page of the Preferences dialog. When the Preferences dialog page is open, press F1 for more information about an option.

During the installation of a new version of the software, you will be prompted to load your preferences from the previous version (or you can choose to use system defaults). You can also Save/Load them to/from a file (or an Altium Server), which is convenient if you need to transfer them to another computer.

Preparing the Design Space

Always draw the component symbol close to the sheet origin (the center of the sheet). If necessary, relocate the origin of the sheet to the center of the design window by selecting Edit » Jump » Origin (shortcut J, O). Check the Status bar at the bottom left of the screen to confirm that you have the cursor at the origin. Components supplied by Altium are created around this point, marked with a crosshair through the center of the sheet. You should always create your components close to this origin. When you place a component on the schematic, the component will be 'held' by the electrical hot spot (pin end) that is nearest to this origin.

The default units for schematic and schematic library grids are imperial. Since all Altium components are designed on this imperial grid, it is important to appreciate the impact of deciding to switch to a metric sheet grid as it becomes difficult to correctly wire to components created on different grids. Note that imperial grids can be used with metric sheet sizes, such as A3, so it is not necessary to change to a metric grid when working with metric-sized sheets. The units for the current sheet are defined on the General tab in the General region of the Properties panel in Library Options mode (use the Tools » Document Options command from the main menus to access this mode of the Properties panel).

Use the General region of the Properties panel in Library Options mode to set the units for the current sheet.
Use the General region of the Properties panel in Library Options mode to set the units for the current sheet.

Units for new sheets (schematic and library) are defined on the Schematic – General page of the Preferences dialog.

If desired, enable the Show Comment/Designator option in the Properties panel to display the Comment/Designator strings for the current component in your library document.

Objects are placed on the current snap grid. The current grid is displayed at the bottom of the design space on the left-hand end of the Status bar.

The Snap Grid and Visible Grid can also be set in the Properties panel in Library Options mode. Rather than opening the Properties panel whenever you need to change the grid, you can press G to cycle the snap grid through the available settings. Available settings can be edited on the Schematic – Grids page of the Preferences dialog.

Typically, objects and pins are placed on a grid of 10 or 5, with strings being the only object needing to be placed on a grid of 1.

Properties Panel

When the active document is a Schematic Library document (*.SchLib), choose the Tools » Document Options command from the main menus – the Properties panel presents the Library Options. The following collapsible sections contain information about the options and controls available:

The options in this section of the panel determine which schematic library objects may be selected in the design space.

  • All Objects button – select remove object filtering so that all types of objects may be selected.
  • Object buttons – toggle each object button to enable/disable the ability to select that object type.

  • Units – select the desired unit. Choose either mm or mils.
  • Visible Grid – enter the desired grid. Use the or to show/hide the grid in the design space.
  • Snap Grid – check the box to enable snap grids. Enter the desired grid in the text box or use the G shortcut key.
  • Sheet Border – check the box to enable a sheet border then click the colored box to change the border color.
  • Sheet Color – click the colored box to change the sheet color.
  • Show Hidden Pins – enable to show hidden pins on the design space.
  • Show Comment/Designator – enable to show comments/designators on the design space.

When a design object is selected, the panel will present options specific to that object type. The following table lists the object types available for placement within the library design space. Click a link to access the properties page for that object.

Arc Ellipse
Graphic IEEE Symbol
Pin Polygon
Polyline Rectangle
Round Rectangle Text Frame
Text String Bezier

Creating the Schematic Symbol Body

After setting up the design space options as required, the next step is to capture the graphical representation of the component, i.e. to create the symbol graphics that will represent that component when placed on a schematic sheet. It is important to decide upon a standard for the graphical schematic symbols by which to adhere. This will provide a formal template when designing the symbol graphics and result in a guaranteed level of consistency. Altium's design methodology follows standard IEEE 315, which not only covers the most common circuit elements but also clearly defines how semiconductor elements can be combined to symbolize any number of silicon device types.

The body of the symbol is created by placing graphical design objects in the schematic library editor design space by using the Place menu, the Utilities bar, or the Active Bar. Double-click the placed schematic symbol to open the Properties panel to further define each shape.

Altium Designer includes a variety of closed symbol shapes including rectangle, polygon, ellipse, and round rectangle as shown below. 

            

Line-type shapes include arc, line/polyline, bezier, and elliptical arc. Lines/polylines can include arrowheads and tails. Double-click to open the Properties panel to define the heads and tails.  

 

Adding Pins to the Symbol

It is the component pins that give the component its electrical properties and define connection points on the component for directing signals in and out. A pin is placed to represent each pin on the actual physical component.

A pin can be placed in the schematic library document design space using one of the following methods. In each case, the pin appears floating on the cursor held by the electrical end. Rotate and/or flip the pin as required and click to effect placement.

  • Use the Place » Pin command (or shortcut P, P).
  • Click the  button on the design object drop-down of the Utilities toolbar.
  • Click the  button on the Active Bar.
  • With the Properties panel in Component mode (active when no object is selected in the design space), click the  button on the Pins tab to open the Component Pin Editor dialog in which you can add (or edit) pins.

Use the highlighted button on the Pins tab of the Properties panel to open the Component Pin Editor dialog.
Use the highlighted button on the Pins tab of the Properties panel to open the Component Pin Editor dialog.

Use the Component Pin Editor dialog to add (or edit) pins.
Use the Component Pin Editor dialog to add (or edit) pins.

For a multi-part component, the relevant pins for the selected part will be highlighted in the Component Pin Editor dialog. All pins of other parts are grayed out.

Configuring Pin Properties

Press Tab to open the Component mode of the Properties panel to edit the pin properties before placement. Numerical values will auto-increment on subsequent pin placements. Auto-increment behavior is configured in the Auto-Increment During Placement settings on the Schematic – General page of the Preferences dialog. Use negative values to auto-decrement.

Use the Schematic - General page of the Preferences dialog to define auto-increment behavior.
Use the Schematic - General page of the Preferences dialog to define auto-increment behavior.  During placement or whenever a pin is moved, the pin is held by the electrical end (also called the hot end of the pin). The pin must be positioned so that the electrical end is away from the component body. Press the spacebar to rotate a pin while it is being moved.

Pins also can be placed to represent electro-mechanical points on the component, such as the tab on a voltage regulator.

A pin has a number of properties including a Name and a Designator. It is the pin Designator that is used to match the symbol pin to the PCB footprint pad. The default distance that the pin's Designator and Name appear from the end of the pin is a system-wide setting for the Schematic and Schematic Library editor. Configure the Pin Margin on the Schematic – General page of the Preferences dialog.

Individual settings for the Name can be configured in the Component Pin Editor dialog.

A pin has an Electrical Type that is used by Altium's electrical rules check system to verify that pin-to-pin connections are valid. Set this option in the Component Pin Editor dialog to suit the electrical type of that component pin. The default Pin Length should suit the chosen snap grid (typically 10 or 5). The default length is 30; typical lengths are 20 or 30.

Symbols can be added in the Component Pin Editor dialog to different positions of the Pin to represent electrical information from the pin.

The schematic Pin represents the physical component pin in the schematic design space.
The schematic Pin represents the physical component pin in the schematic design space.

Summary

A pin is an electrical design primitive. Pins give a component (part) its electrical properties and define the connection points on the part for the incoming and outgoing signals.

Availability

Pins can only be placed in the schematic library editor using one of the following methods:

  • Click Place » Pin from the main menus.
  • Click  on the drop-down of the Utilities toolbar ().
  • Right-click then choose Place » Pin from the context menu.

Placement

After launching the command, the cursor will change to a cross-hair and you will enter pin placement mode. Placement is made by performing the following sequence of actions:

  1. Click or press Enter to anchor the pin. Note that the floating pin is held by the electrical end, which must be positioned away from the component body. Only one end of the pin is electrical; it is always this end that the pin is held.
  2. Continue placing additional pins or right-click or press Esc to exit placement mode.

Additional actions that can be performed during placement – while the pin is still floating on the cursor, and before the electrical end of the pin is anchored – are:

  • Press the Tab key to pause the placement and access the Pin mode of the Properties panel from where its properties can be changed on the fly. Click the design space pause button overlay () to resume placement.
  • Press the Alt key to constrain the direction of movement to the horizontal or vertical axis depending on the initial direction of movement.
  • Press the Spacebar to rotate the pin counterclockwise or Shift+Spacebar for clockwise rotation. Rotation is in increments of 90°.
  • Press the X or Y keys to mirror the pin along the X-axis or Y-axis.
Create the Library component near the origin (center) of the Library Editor sheet, which is marked by dark cross-hair lines. Typically a pin or the corner of the component body is placed at the sheet origin.
The pin number (Designator) must be defined since that is what is used to establish the connectivity. The Electrical Type is also important as this is used in the Schematic Editor for the Electrical Rules Check (ERC).

Adding Pins in the Component Pin Editor

Pins can also be added through the Component Pin Editor dialog, which is accessed by clicking the  button on the Pins tab of the Properties panel in Component mode.

Add one or more pins in the Component Pin Editor dialog.
Add one or more pins in the Component Pin Editor dialog.

Click the Add button to add a new pin, then define the properties in the dialog. Note that multiple pins can be added and defined. You can also use Tab and Shift+Tab to step between the fields.

Notes on Pin Numbering

For many components, there will be a series of pins that have numerical names and numbers. The Auto-Increment During Placement feature on the Schematic – General page of the Preferences dialog can be used to speed the placement of these pins. Auto-increment is invoked automatically if the pin properties are edited before placement (press Tab while the pin is floating on the cursor). The feature works for both the Designator and the Name; the pin Designator uses the Primary auto-increment field and the pin Name uses the Secondary auto-increment field. It supports ascending alpha and numeric values and descending numeric values.

Configure the Auto-Increment During Placement settings on the Schematic – General page of the Preferences dialog.
Configure the Auto-Increment During Placement settings on the Schematic – General page of the Preferences dialog.

Note the increasing alpha pin name and decreasing numeric pin number.
Note the increasing alpha pin name and decreasing numeric pin number.

Graphical Editing

To move a pin, click and hold. The cursor will jump to the electrical hotspot end of the pin; move it to the new location, placing it with the electrical end away from the component body.

While dragging, the pin can be rotated (Spacebar/Shift+Spacebar) or mirrored (X or Y keys to mirror along the X-axis or Y-axis).

Non-Graphical Editing

Editing via the Pin Dialog or Properties Panel

Properties page: Pin Properties

The properties of a Pin can be edited in the Pin dialog and the Properties panel, which allows editing of all item(s) currently selected in the design space.

Pin Display Name and Designator – Position and Font

The location of the pin Display Name and pin Designator (number) is defined globally by the Pin Margin settings on the Schematic – General page of the Preferences dialog. This is an environment setting, meaning it applies to the PC where the setting is defined. The settings define a relative distance the text is away from the non-electrical end of the pin.

Set the distance of the pin text (Pin Margin) in the Preferences dialog.
Set the distance of the pin text (Pin Margin) in the Preferences dialog.

The default system font for a schematic library document is Times New Roman, 10pt, Regular. This is fixed and cannot be changed. When a library component is placed on a schematic sheet, this same default font is applied but is not fixed and can be changed as required. Keep in mind that the system font used for a schematic sheet applies to other objects as well, including Power Ports, Ports, and the X, Y region markers in the schematic sheet border.

For pins, these system-level settings of position and font can be overridden. Controls for customization of the position and font for a pin's Designator and Name can be found in the Pin mode of the Properties panel.

The font and location of the pin Designator (number) and Name can be modified for individual pins if required.
The font and location of the pin Designator (number) and Name can be modified for individual pins if required.

Use the Custom Position option to change the default settings for the position to an overriding, customized position. For the Margin, enter a new value directly in the associated field. For the Orientation, use the drop-down to choose the angle (0° or 90°) and the To reference (Pin or Component).

Use the Custom Settings option to change from using the default system font to using an overriding, customized font.

Pin Symbol Line Width

When representing a component in the schematic editing domain, each pin defined as part of that device's schematic symbol can have one or more symbols displayed. These are symbols displayed on the Inside, Inside Edge, Outside, or Outside Edge in relation to the main component symbol outline, as required. Examples might include a Clock symbol on the Inside Edge or a Dot symbol on the Outside Edge. Such symbols greatly improve the readability of the design through visual indication of the purpose of the signal traversing a particular pin.

Use the Line Width setting in the Symbols region of the Properties panel to specify the width of the line used to draw these symbols. Choose from either Small or Smallest.

Older designs sometimes included components with hidden power pins, which were connected to the appropriate power net. While this practice is not recommended, hidden pins can be connected by entering the net name in the Hidden Net Name field in the SCHLIB List or SCH List panels.

General Tab

Location

  • (X/Y)
    • X (first field) – the current X (horizontal) coordinate of the reference point of the object, relative to the current design space origin. Edit to change the X position of the object. The value can be entered in either metric or imperial; include the units when entering a value whose units are not the current default.
    • Y (second field) – The current Y (vertical) coordinate of the reference point of the object, relative to the current origin. Edit to change the Y position of the object. The value can be entered in either metric or imperial; include the units when entering a value whose units are not the current default.
  • Rotation – use the drop-down to select the rotation.

Properties

  • Designator – the numerical identifier of the pin. Each pin in a part must have a unique designator. Use or to determine whether the Designator for the pin is displayed or hidden (respectively) when the parent part is placed on a schematic sheet.
  • Name – use to specify an optional display name for the pin. By default, a newly placed pin will be named using the designator value. Supplying a display name is particularly useful for IC-type components where a meaningful name enables you to see quickly how the pin is being used. Use or to determine whether the Name for the pin is displayed or hidden when the parent part is placed on a schematic sheet.

    To negate (include a bar over the top of) a pin name, use one of the following methods:

    • Include a backslash character after each character in the pin name (e.g. H\O\L\D\).
    • Enable the Single '\' Negation option on the Schematic – Graphical Editing page of the Preferences dialog, then include one backslash character at the start of the pin name (e.g. \HOLD).
  • Function – use this field to specify a number of names (functions) for the multi-functional pin being edited. Enter an alternative name of the pin, then press Enter or click the  button at the right of the field. Added alternative names will be shown as labels below the field. Click 'x' in the label of a function to remove it.

    After placing the component on a schematic sheet, the function that will be shown as the pin name can be selected on the Pins tabs of the Properties panel in the Component mode.
  • Electrical Type – use the drop-down to set the electrical type of the pin. This is used when compiling a project or analyzing a schematic document to detect electrical connection errors (using the Electrical Rules Check feature).
  • Description – enter a meaningful description of the pin, if desired.
  • Pin Package Length – enter the pin-package length. The unit will automatically be entered after you press Enter.
  • Propagation Delay – this field lists the propagation delay, which is the amount of time it takes for the head of the signal to travel from the sender to the receiver.
  • Part Number – this field is available when the pin is being added to a multi-part component. Use the up/down arrows to specify the part to which the pin is to be associated. A multi-part component also includes a non-graphical part, Part Zero. Part Zero is used for pins that are to be included in all parts of the multi-part component, for example, power pins.
  • Pin Length – use to specify the length of the pin in accordance with the currently defined units of measurement. Click the color box to edit the color of the pin.

Symbols

These symbols are purely graphical. The true electrical property of the pin is determined by the entry set for the pin's Electrical Type.
  • Inside – use to optionally add a symbol to the pin on the inside of the component graphic.
  • Inside Edge – use to optionally add a symbol to the pin on the inside edge of the component graphic.
  • Outside Edge – use to optionally add a symbol to the pin on the outside edge of the component graphic.
  • Outside – use to optionally add a symbol to the pin on the outside of the component graphic.
  • Line Width – use this field to determine the width of the line used to draw the symbols. This provides support for meeting GOST standards, which stipulates that these symbols should be of the same width as the line used to draw the component's symbol.

    The Line Width setting will also apply to the automatic symbol used in relation to the pin's defined Electrical Type.

Font Settings

  • Designator
    • Custom Settings – enable to access the Font Settings below to customize the font.
    • Font Settings – use the controls to configure the font, font size, color, and special settings such as bold and underlining.
    • Custom Position – enable to access the controls below to customize the position.
    • Margin – enter the desired margin.
    • Orientation – use the drop-down to select the orientation.
    • To – use the drop-down to select the desired object of the designator.
  • Name
    • Custom Settings – enable to access the Font Settings below to customize the font.
    • Font Settings – use the controls to configure the font, font size, color, and special settings such as bold and underlining.
    • Custom Position – enable to access the controls below to customize the position.
    • Margin – enter the desired margin.
    • Orientation – use the drop-down to select the orientation.
    • To – use the drop-down to select the desired object of the name.

Parameters Tab

Parameters

Use this region to manage parameters attached to the currently selected pin object.

  • Grid – this region lists all of the parameters currently defined for the pin. Use the or icon to show/hide the value of the associated parameter in the design space. Use the or icon to lock/unlock the associated parameter.
    • Name – the name of the parameter. For a rule-type parameter, this entry will be locked as Rule.
    • Value – the value of the parameter. For a rule-type parameter, the entry will reflect the rule type along with a listing of its defined constraints.
  • Font – click to open a menu to select the desired font, font size, color, and attributes to bold, italicize, etc., if desired.
  • Other – click to open a drop-down to change additional options:
    • Show Parameter Name – enable to show the parameter name within the Schematic Library editor.
    • Allow Synchronization with Database – enable to synchronize with the database. This option is used to control if the comment can be updated. By default, these options are enabled to always allow synchronization with the source library/database. You may disable this option to prevent that comment from being included in an update process.
    • X/Y – enter the X and Y coordinates desired.
    • Rotation – use the drop-down to select the rotation.
    • Autoposition – check to enable auto-positioning, meaning that the text will remain in the chosen position as the component is moved and rotated.
  • Add – click to add a parameter. Use to delete the currently selected parameter.
While this practice is not recommended, a pin can be hidden in the Component Pin Editor dialog, if required.
Older designs sometimes included components with hidden power pins, which were connected to the appropriate power net. While this practice is not recommended, hidden pins can be connected by entering the net name in the Hidden Net Name field in the SCHLIB List or SCH List panels.

Adding IEEE Symbols

For representing logic functions or devices, IEEE symbols can be used in a schematic symbol. These symbols enable users to understand the logic characteristics of these functions or devices without requiring specific knowledge of their internal characteristics.

The IEEE Symbols available for placement are shown in the image below.

A placed IEEE Symbol (Sigma)
A placed IEEE Symbol (Sigma)

Summary

IEEE symbols are non-electrical drawing primitives. They are used for representing logic functions or devices. These symbols enable users to understand the logic characteristics of these functions or devices without requiring specific knowledge of their internal characteristics.

Availability

IEEE Symbol objects are available for placement only in the Schematic Library Editor. A total of 34 symbols are available for placement in the following ways:

  • Choose Place » IEEE Symbols from the main menus.
  • Right-click then choose Place » IEEE Symbols from the context menu.
  • Click the  button on the Utilities toolbar.

Placement

After launching a command, the cursor will change to a cross-hair and you will enter IEEE symbol placement mode. The chosen IEEE symbol will appear floating on the cursor.

  1. Position the object then click or press Enter to effect placement.
  2. Continue placing further symbols or right-click or press Esc to exit placement mode.

Additional actions that can be performed during placement are:

  • Press the Tab key to pause the placement and access the IEEE Symbol mode of the Properties panel in which its properties can be changed on the fly. Click the design space pause button overlay () to resume placement.
  • Press the Spacebar to rotate the object counterclockwise or Shift+Spacebar for clockwise rotation. Rotation is in increments of 90°.
  • Press the X or Y keys to mirror the symbol along the X-axis or Y-axis.
  • Press the + or - keys (on the numeric keypad) to enlarge or shrink the symbol.

Graphical Editing

This method of editing allows you to select a placed IEEE symbol object directly in the design space and change its location or orientation graphically. IEEE symbols are fixed with respect to their shape and can be resized only through use of the relevant keyboard shortcuts. As such, editing handles are not available when the IEEE symbol object is selected.

A selected IEEE Symbol (Sigma)
A selected IEEE Symbol (Sigma)

Click anywhere inside the dashed box and drag to reposition the symbol as required. While dragging, the symbol can be rotated (Spacebar/Shift+Spacebar), mirrored (X or Y keys to mirror along the X-axis or Y-axis), or resized (+/- keys on numeric keypad).

Location

  • (X/Y) - the current X (horizontal) and Y (vertical) coordinate of the reference point of the object, relative to the current design space origin. Edit to change the X and Y position of the object. The values can be entered in either metric or imperial; include the units when entering a value whose units are not the current default. 
  • Rotation - use the drop-down to select the rotation. 

Properties

  • Symbol - defines the graphical IEEE symbol. Select a symbol from the drop-down list.
  • Size - the current size of the IEEE symbol. The default size is 10 DXP Default Units (100mil). Increase or decrease this value to make the symbol bigger or smaller. Entering a negative value results in the symbol appearing as if rotated by 180 degrees.
  • Line - the width of the line used to draw the outline of the symbol. 

Defining Symbol Properties

Symbol properties, such as the designator and description of the symbol, are edited in the Symbol mode of the Properties panel.

  • Designator - enter the required designator prefix followed by a ?.
  • Name and Description - these strings are helpful when symbol searches are performed.
  • Type defines what type of component this symbol represents. Non-standard components, such as a company logo (Graphical) or a heatsink (Mechanical) can be created as schematic symbols and placed into a project.

The Component Type

In a design environment, you may also need to create design entities that are not necessarily components that will be mounted on the finished PCB. For example, there might be an external module that connects to the board that you would like to draw as a component and include on the schematic for design clarity but you do not want this to be included in the BOM for this board. Or there might be mechanical hardware, such as a heat sink and mounting screw that must be included in the BOM, but you do not want to include on the schematic.

These situations are managed by setting the component's Type. For the example just described, the component type could be set to Graphical. Another special class of components is a test point – this component is required on both the schematic and the PCB. It should be checked during design synchronization but is not required in the BOM. In this case, the component Type is set to Standard (No BOM).

For a non-standard type of component, set the Type accordingly.
For a non-standard type of component, set the Type accordingly.

As well as being used to determine if a component should be included in the BOM, the Type field is also used to determine how that component is managed during component synchronization. All of the Standard, Net Tie and Jumper Types are fully synchronized, meaning the component is passed from the schematic to the PCB and the net connectivity is checked. For the Mechanical and Graphical Type, the component is not passed from schematic to PCB. If a component with one of these types has been placed manually in the PCB and the matching Type option has been chosen, then component-level synchronization is performed but no net-level connectivity checks are performed.

Refer to the Component mode of the Properties panel for detailed information about the various Type options.

Breaking the Component into Multiple Parts

In some instances, it is more appropriate to divide the component into a number of symbols, each of which is referred to as a Part. Examples include resistor networks that contain eight individual resistors and each can be used independently of the others, the coil and contact sets in a relay, or each pin in a connector, for example, if you prefer to place connector pins throughout the sheet, rather than routing the wiring to a single connector symbol. Another example would be a 74F08SJX quadruple 2-input AND gate - in this device, there are four independent 2 input AND gates. While the component could be drawn as a single symbol showing all four gates, it would be more useful if it is drawn as four separate gates, where each gate can be placed independently of the others anywhere on the schematic.

These components are referred to as multi-part components. Each part is drawn individually in the schematic library editor and pins are added accordingly. The image below shows the same resistor network drawn as a single part then as four separate parts.

The same resistor network is shown as a single part on the left and as four separate parts on the right.
The same resistor network is shown as a single part on the left and as four separate parts on the right.

Notes on working with multi-part components:

  • In the schematic symbol editor, use the Tools » New Part command from the main menus to add another part to the current component.
  • Use the SCH Library panel to move between parts in a multi-part component, as shown below.

  • If the component parts differ slightly, you can copy and paste the content between parts and update, for example, only the pin information in new parts.
  • The designator of a multi-part component includes a suffix to identify each part. The suffix can be alpha or numeric and are set in the Alpha Numeric Suffix region on the Schematic - General page of the Preferences dialog. Note that this option is a software installation environment setting. It does not get stored in the library or the schematic file, and therefore, does not travel with the design files.
  • Multi-part components are considered homogeneous, that is, all parts are equivalent during design annotation and can potentially be swapped during the annotation process. For example, a relay coil might be swapped with a set of relay contacts, depending on their relative locations on the schematic sheet. To lock a specific part in a placed component, enable the Lock Icon in the Properties panel as shown below.

  • During schematic annotation, the parts in a multi-part component are packed together to complete a component in accordance with the Matching Options configured in the Annotate dialog (as shown below). The enabled checkboxes on the left determine which component properties must match for parts to be eligible to be packed together. If you need to control the packing of specific parts so they are together in the same physical component, for example, a pair of op-amps in a filter design, and do not want to assign and lock them manually, add an additional parameter to that component and enter a value that defines which parts are to be packed together. The top image below shows the Annotate dialog matching options. The enabled parameters are used for multi-part component matching, the ResPack parameter has been added in the Properties panel (bottom image) to control the packaging of resistors into packages (when the parts have the same parameter value, they can be packaged together into the same physical component). Note the Strictly option. If this option is enabled, the parts must include this parameter to be packed together. Be careful of this option if you have different types of multi-part components that you are controlling the packaging of - all of them must include that parameter if Strictly is enabled.

  • PCB part swapping can only be performed on a component whose parts are defined as a multi-part component. Learn more in the Pin Pair and Part Swapping document.
  • To define the power pins, you can create an additional part for the component and place the VCC and GND pins on that part. Remember to enable the  option in the Properties panel to ensure that it cannot be swapped with any of the gates during re-annotation.

Display Modes - Multiple Presentations of the Same Component

The software supports different display representations of the same component. These representations can contain different graphical representations of the component, such as a DeMorgan or an IEEE representation. Or, for example, some of your customers might prefer to have their resistors drawn as a rectangle, while others prefer a wavy line.

Each of these representations is referred to as a display Mode. If an alternate view of a part has been added, it is displayed for editing in the schematic symbol editor by selecting the alternate mode from the Mode drop-down in the Mode toolbar.

A resistor created with two display modes. The library editor includes a Mode toolbar that can be used to add/remove and step through the modes. A resistor created with two display modes. The library editor includes a Mode toolbar that can be used to add/remove and step through the modes. A resistor created with two display modes. The library editor includes a Mode toolbar that can be used to add/remove and step through the modes.
A resistor created with two display modes. The library editor includes a Mode toolbar that can be used to add/remove and step through the modes.

To add an alternate view mode, with the component part displayed in the design window of the schematic symbol editor, select Tools » Mode » Add or click on the  button on the Mode toolbar. A blank sheet for Alternate 1 displays. Typically, you would copy the part you created in the Normal mode and paste it into the new Alternate mode. Use Edit » Copy and Edit » Paste to copy and paste the Normal mode to the Alternate mode. This gives you the correct set of pins and you can modify the graphical elements and position the pins as required.

The required mode is chosen when the component is placed from the library onto the schematic sheet using the Mode selector in the Graphical region of the Properties panel. The default placement mode is the mode that was displayed in the library editor when the library was last saved.

Each mode must include the same set of pins. If they do not, a warning will be generated when the project is compiled. This is required because you can only define one set of pin-to-pad mappings for each footprint associated with that component. Pins do not need to be in the same location in each mode.

Support for Jumper Components

Jumpers, also referred to as wire links, allow you to replace routing with a Jumper component, which is often an essential ingredient to successfully designing a single-sided board. Altium Designer supports use of jumper components through a special component type of Jumper.

While you can start by placing the Jumper footprints directly onto the PCB, a suggested workflow starts at the schematic. To learn more, refer to the Working with Jumper Components section of the Creating a PCB Footprint page.

Using the Schematic Symbol Generation Tool

The task of creating a component library symbol and its pin data has become an increasingly involved undertaking as components have advanced in complexity. With current large scale BGA devices requiring the placement and configuration of hundreds of pins for example, substantial time and effort is often required to create viable component symbols.

To ease the workload associated with creating component symbols, Altium Designer provides an advanced Schematic Symbol Generation Tool, based on a symbol wizard interface and pin editor dialog. This features automatic symbol graphic generation, grid pin tables and smart data paste capabilities.

The Schematic Symbol Generation Tool is provided as a software extension - Schematic symbol generation tool - which must be installed to enable the tool’s features.

Extension Access

Functionality is provided courtesy of the Schematic symbol generation tool extension (a Software Extension).

For more information on working with extensions, see Extending Altium Designer.

The Schematic symbol generation tool extension.
The Schematic symbol generation tool extension.

The Symbol Wizard functionality can only be accessed provided the Schematic symbol generation tool extension is installed as part of your Altium Designer installation. This extension is installed by default when installing the software, but in case of an inadvertent uninstall, it can be found back on the Purchased tab of the Extensions & Updates page (accessed from the  drop-down then choose Extensions and Updates). If reinstalling, you will need to restart Altium Designer once the extension has been successfully downloaded and installed.

Creating a Symbol

The Schematic Symbol Generation Tool becomes available from the Schematic Library editor by choosing the Tools » Symbol Wizard command from the main menus.

To create a new component symbol using the tool, first, add a new component to the active library document. The new symbol can then be developed through the tool's interface - the Symbol Wizard dialog - which opens when the command is launched.

  • Number of Pins - manually type or use the up and down arrows to increase or decrease the desired number of pins.
  • Layout Style - choose from a set of predefined patterns for where the pin positioning is automatically assigned. Use the drop-down to select the preferred arrangement. The Preview image to the right and the data in the Side column will be updated accordingly. Selections include:
    • Dual in-line
    • Quad side 
    • Connector zig-zag 
    • Connector 
    • Single in-line 
    • Manual
      The Manual configuration denotes that pin positions are not automatically assigned. The layout style will revert to this setting when the pin positioning of a standard style (Quad sideConnector zig-zag, and Single in-line) has been edited.

Grid

  • Position – the reference position index of a symbol pin. This data is not editable.
  • Group – a manually entered string used to define a collective group of pins.
  • Display Name – the component pin’s display name attribute string.

    Pin names entered with slashes will be recognized as alternate pin names and added to the generated symbol's pin properties.
  • Designator – the pin’s designator attribute string. This will automatically match the pin Position by default.
  • Electrical Type – use the drop-down in the field to select the electrical type for the pin. Selections include InputI/OOutputOpen CollectorPassiveHiZOpen Emitter, and Power.
  • Description – the pin’s description string attribute.
  • Side – use the drop-down in the field to select the position of the symbol. Select from LeftBottomRight, and Top. When this region has been changed, the Layout style setting changes to Manual.
Click on a column heading to order the grid data by that column. Click again to toggle the order between ascending and descending.
Within the table, standard copy and paste techniques can be used to populate data from one group of cells to another. For example, you can select three cells in a column, copy the data (right-click – Copy), then select three target cells to paste the data (right-click – Paste). The same technique can be used to copy a data selection from an external source, such as a spreadsheet, text, or PDF file.
Grid cells can be manually edited on a single or multiple basis. Use standard Ctrl+click and Shift+click techniques. To edit multiple cells in columns that feature drop-down menus, select the desired cell range then make the new menu selection on one of the selected cells.

Right-click Menu

  • Move Up - use to move the selected data up one row.
  • Move Down - use to move the selected data down one row.
  • Copy - use to copy the selected data to the clipboard.
  • Paste - use to paste the most recent data that was copied to the clipboard to the cursor position.
  • Smart Paste - use to open the Pin Data Smart Paste dialog to copy several columns of external source data into matching columns in the grid. Use the dialog to configure the column data and delimiters, then click Paste.
  • Clear - use to delete the pin data.

Preview

This region displays a preview of the symbol graphic and dynamically represents the current settings and pin data. Use the slider bar or - and + to zoom in/out on the graphic.

Additional Controls

  • Continue editing after placement - if checked, the dialog will remain active (allowing further editing) once the component has been placed.
  • Place - use to place the completed symbol and pin data. Choices include:
    • Place Symbol
    • Place New Symbol
    • Place New Part

Pasting Pin Data

While the pin data in the table can be edited to a common value for multiple cells, the dialog's Paste and Smart Paste features provide an advanced way to populate all cell data by bringing in large amounts of different data from external sources.

Within the table, standard copy and paste techniques can be used to populate data from one group of cells to another. For example, by selecting three cells in a column, copying the data (right-click - Copy), then selecting three target cells to paste into (right-click - Paste).

The same technique can be used to copy and paste a data selection from an external source, such as a spreadsheet, text file, or PDF file.

An example of pasting data copied from an external spreadsheet, into the Pin data table.An example of pasting data copied from an external spreadsheet, into the Pin data table.

Smart Paste

Beyond standard copy and paste techniques, Smart Paste offers the capability to populate multiple columns of data from an external source, using an automated column mapping approach.

To copy several columns of source data into matching columns in the Pin data table, right-click in the table and choose the Smart Paste command from the context menu. This opens the Pin Data Smart Paste dialog, which will be populated with the source data. A range of data delimiters are available, which can be selected to match the delimiters used in the source data.

Symbol Placement

With its settings and pin data configured as required, the symbol can then be placed into the workspace for the active library component. Placement can be in terms of a single component, or as one section of a multi-part component, using the respective commands available from the context menu associated to the dialog's Place button. Note that if the Continue editing after placement option is enabled, the Symbol Wizard dialog will remain active (allowing further editing) once the component/part has been placed.

When accessing the Symbol Wizard dialog for an existing component in a schematic library, all settings and pin data will be displayed, ready for further changes. The dialog will only present in its default state when used for a new library component.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: