パッドとビアの操作
パッドとビアの概要
パッドは、部品ピンに対する機械的な取り付けと電気的接続の両方を提供するために使用されます
パッドはプリミティブ設計オブジェクトです。パッドは、部品を基板に固定するため、および部品ピンから基板上の配線への相互接続ポイントを作成するために使用されます。パッドは、たとえば表面実装デバイスのパッドのように単一レイヤー上に存在することもあれば、Z平面(垂直方向)に樽状の本体を持ち、各(水平方向の)銅レイヤー上に平坦な領域を持つ、3次元のスルーホールパッドであることもあります。パッドの樽状の本体は、製造時に基板へ穴あけとスルーホールめっきが施されることで形成されます。X平面およびY平面では、パッドは円形、長方形、八角形、角丸長方形、面取り長方形、またはカスタム形状にできます。パッドは、設計内で個別にフリーパッドとして使用することもできますが、一般的には PCB Library エディタで、他のプリミティブと組み合わせて部品フットプリントの一部として使用されます。

トップレイヤー(赤)からボトムレイヤー(青)まで貫通して接続し、さらに1つの内部電源プレーン(緑)にも接続するビア。
ビアはプリミティブ設計オブジェクトです。ビアは、PCB の2つ以上の電気レイヤー間に垂直方向の電気的接続を形成するために使用されます。ビアは3次元オブジェクトであり、Z平面(垂直方向)に樽状の本体を持ち、各(水平方向の)銅レイヤー上に平坦なリングを備えています。ビアの樽状の本体は、製造時に基板へ穴あけとスルーホールめっきが施されることで形成されます。ビアは、円形パッドと同様に、X平面およびY平面では円形です。ビアとパッドの主な違いは、ビアは基板の全レイヤー(トップからボトム)を貫通できるだけでなく、表面レイヤーから内部レイヤーへ、または2つの内部レイヤー間を接続することもできる点です。
パッドおよびビアの直接配置
パッドとビアは、PCB エディタと PCB Footprint エディタの両方で配置できます。ビアは通常、インタラクティブルーティングまたは自動ルーティングの過程で自動的に配置されますが、必要に応じて手動で配置することもできます。手動で配置されたビアは「フリー」ビアと呼ばれます。パッド(Place » Pad)またはビア(Place » Via)の配置コマンドを起動すると、カーソルは十字形に変わり、配置モードに入ります。
- カーソルを位置決めし、クリックするか Enter を押してパッド/ビアを配置します。
- 続けて追加のパッド/ビアを配置するか、右クリックまたは Esc を押して配置モードを終了します。
配置中に Alt キーを押すと、最初の移動方向に応じて、移動方向が水平方向または垂直方向に制限されます。
グラフィカル編集
パッドおよびビアは、位置以外のプロパティをグラフィカルに変更することはできません。
- フリーパッドを移動し、かつ接続されたトラックも一緒に移動するには、パッドをクリックしたままドラッグします。接続された配線は、パッドの移動中もパッドに接続されたまま維持されます。なお、そのパッドがコンポーネントに属している場合は移動できません。
- PCB または PCB Library Editor で、接続されたトラックを移動せずにフリーパッドを移動するには、Edit » Move » Move コマンドを選択してから、パッドをクリックしたままドラッグします。
Properties パネルによる非グラフィカル編集
この編集方法では、Properties パネルの対応するモードを使用して Pad/Via オブジェクトのプロパティを変更します。
Pad Properties
ネット情報
この領域には、パッドが属するネット、およびそのネットがメンバーである場合は差動ペアや xSignal に関する情報が表示されます。必要に応じてクラス情報も表示されます。Delay および Length の値も表示されます。
ネット情報の詳細については、PCB Placement & Editing Techniques ページを参照してください。
プロパティ
-
Component – このフィールドは、選択された Pad が PCB Component の構成要素である場合にのみ PCB エディタで表示され、親 PCB コンポーネントのデジグネータを表示します。クリック可能な Component リンクを選択すると、親コンポーネント用の Component mode of the Properties panel が開きます。
-
Designator – このフィールドには現在のパッドデジグネータが表示されます。パッドがコンポーネントの一部である場合、通常デジグネータは対応する部品ピン番号に設定されます。フリーパッドにはデジグネータを含めることも、フィールドを空のままにすることもできます。デジグネータの先頭または末尾が数字である場合、複数のパッドを順次配置するとその数字は自動的にインクリメントされます。パッドデジグネータを変更するには、このフィールドの値を編集します。
-
Layer – パッドが割り当てられるレイヤーを選択します。スルーホールパッドを定義するには Multi-Layer を選択します。
-
Net – パッドのネットを選択するために使用します。アクティブな基板設計内のすべてのネットがドロップダウンリストに表示されます。パッドがどのネットにも接続されていないことを指定するには No Net を選択します。プリミティブの Net プロパティは、その PCB オブジェクトが正しく配置されているかどうかを Design Rule Checker が判定するために使用されます。あるいは、Assign Net アイコン(
)をクリックして設計空間内のオブジェクトを選択することもでき、そのオブジェクトのネットが選択したパッドに割り当てられます。
-
Electrical Type – このフィールドには、パッドの現在の電気的ステータスが表示されます。このステータスはコンポーネントパッドにのみ関連し、これらのパッドの伝送線路特性を設定します。パッドは Load、Source、または Terminator として指定できます。Source および Terminator の設定は、ネットが Daisy chain ルーティングトポロジのいずれかを必要とする場合に使用されます。ドロップダウンリストから電気タイプを変更するには、このフィールドをクリックします。
-
Propagation Delay – このフィールドには伝搬遅延が表示されます。これは、信号先頭が送信側から受信側まで伝わるのにかかる時間です。
-
Pin Package Length – Pin Package Length は、Signal Length パネルに表示される PCB の計算に自動的に含まれます。選択したネット内のピンの Pin/Pkg Length の値を確認または編集するには、PCB パネルを Nets モードに設定します。
-
Jumper – PCB 上でジャンパー接続を使用している場合、このフィールドはパッドにジャンパー接続識別番号(1~1000)を与えます。ジャンパー接続は、ワイヤを使用して PCB 上のパッド同士を物理的に接続するもので、基板上のトラックや電気オブジェクトは使用しません。Jumper の値により、ソフトウェアはどのパッドを「接続済み」として扱うかを判断します。ジャンパー接続は、部品フットプリント内のパッド間でのみ作成できます。使用するパッドは同じ Jumper 値を使用し、かつ同じネットを共有している必要があります。ジャンパー接続は PCB Editor 上で曲線の接続線として表示されます。スクロール矢印を使用するか、目的のジャンパー接続識別番号を直接入力します。
-
Template – パッドの現在のテンプレートを表示します。ドロップダウンから別のテンプレートを選択します。関連付けられた Library がある場合、そのライブラリが表示されます。関連付けられた Pad/Via Template ライブラリからテンプレートのリンクを解除するには、
ボタンをクリックします。
-
(X/Y)
-
X (1番目のフィールド) – このフィールドには、現在の原点を基準としたパッド中心の現在の X 位置が表示されます。現在の原点に対するパッドの位置を変更するには、このフィールドの値を編集します。値はメートル法またはヤード・ポンド法のいずれでも入力でき、現在のデフォルトと異なる単位の値を入力する場合は単位を含めます。デフォルト単位(メートル法またはヤード・ポンド法)は、Board モードの Properties パネルの Other 領域にある Units 設定によって決まり(設計空間でオブジェクトが選択されていない場合にアクセス)、単位が指定されていない場合に使用されます。
-
Y (2番目のフィールド) – このフィールドには、現在の原点を基準としたパッド中心の現在の Y 位置が表示されます。現在の原点に対するパッドの位置を変更するには、このフィールドの値を編集します。値はメートル法またはヤード・ポンド法のいずれでも入力でき、現在のデフォルトと異なる単位の値を入力する場合は単位を含めます。デフォルト単位(メートル法またはヤード・ポンド法)は、Board モードの Properties パネルの Other 領域にある Units 設定によって決まり(設計空間でオブジェクトが選択されていない場合にアクセス)、単位が指定されていない場合に使用されます。
-
-
Rotation – パッドの回転角度(度)。ゼロ(3 o'clock 水平方向)から反時計回りに測定されます。パッドの回転を変更するにはこのフィールドを編集します。最小角度分解能は 0.001° です。
Pad Stack
-
Simple / Top-Middle-Bottom / Full Stack – スルーホールパッド(つまり、パッドの Layer として Multi-Layer が選択されている場合)に対して希望するパッドスタックモードを選択します。その他のレイヤーについては、Simple モードのオプションが適用されます。
-
Simple – シンプルな積層パッドを選択します。このパッドのすべての信号銅レイヤーに共通するパッド形状属性を定義できます。
-
Top-Middle-Bottom – Top-Middle-Bottom の積層パッドを選択します。このパッドのトップ、中間、ボトムの各信号銅レイヤーについて、X および Y サイズと形状属性を定義できます。
-
Full Stack – Full Stack の積層パッドを選択します。このパッドのすべての信号銅レイヤーについて、X および Y サイズと形状属性を定義できます。
-
-
Copper – 折りたたみ可能な領域を展開するか、グリッドを使用して信号銅レイヤー上のパッド属性を定義します。使用可能な銅レイヤーのセットは、パッドが配置されているレイヤーと選択されたパッドスタックモードによって異なります。
- Shape – パッド形状を選択します。標準パッド形状(Round、Rectangular、Octagonal、Rounded Rectangle、Chamfered Rectangle、および Donut)は、X および Y の設定を変更することで非対称パッド形状にできます。標準ではない形状のパッドを定義するには Custom Shape を選択します(詳細はこちら)。
-
Edit Shape – カスタム形状パッドの領域を設計空間内で対話的に編集するにはクリックします。このボタンは、Shape として Custom Shape が選択されている場合にのみ使用できます。
-
(X/Y) – パッドの X(水平)サイズおよび Y(垂直)サイズを定義します。X サイズと Y サイズは独立して設定でき、非対称のパッド形状を定義できます。値はメートル法またはヤード・ポンド法のいずれでも入力でき、現在のデフォルトと異なる単位の値を入力する場合は単位を含めます。デフォルト単位(メートル法またはヤード・ポンド法)は、Board モードの Properties パネルの Other 領域にある Units 設定によって決まり(設計空間でオブジェクトが選択されていない場合にアクセス)、単位が指定されていない場合に使用されます。このオプションは、Shape として Rounded Rectangle または Chamfered Rectangle が選択されている場合にのみ使用できます。
-
Corner Radius – パッド角の半径/面取りの絶対値を入力します。この値は、パッドの最も短い辺の半分以下でなければなりません。計算されたパーセンテージ値(最も短い辺の半分に対する割合)がフィールドの右側に表示されます。値の後に
%記号を付けて入力すると、半径/面取りを最も短いパッド辺の半分に対する割合として定義できます。この場合、100%は最も短い辺を完全に丸めることを意味し、計算された絶対値がフィールドの右側に表示されます。このオプションは、対応する銅レイヤー上のパッド Shape に対して Rounded Rectangle または Chamfered Rectangle が選択されている場合にのみ使用できます。 -
Upper Left、Upper Right、Lower Left、Lower Right – パッド形状の角を丸める/面取りするかどうかを有効にします。これらのオプションは、対応する銅レイヤー上のパッド Shape に対して Rounded Rectangle または Chamfered Rectangle が選択されている場合にのみ使用できます。
-
Outer Diameter – パッドの外径を入力します。このオプションは、対応する銅レイヤー上のパッド Shape に対して Donut が選択されている場合にのみ使用できます。
-
Width – パッドの幅を入力します。このオプションは、対応する銅レイヤー上のパッド Shape に対して Donut が選択されている場合にのみ使用できます。 対応する銅箔レイヤー上。
-
Thermal Relief – 有効にすると、パッドのサーマルリリーフをカスタマイズでき、適用される Polygon Connect Style ルールを上書きします。チェックを入れると、リンクをクリックして Polygon Connect Style ダイアログを開き、必要に応じてサーマルリリーフのオプションを変更できます。Edit Points ボタンをクリックすると、サーマルリリーフのスポーク接続点を手動で定義できます。詳細は カスタム サーマルリリーフの定義 を参照してください。
-
Center Offset (X/Y) (SMD パッドのみ、つまりパッドの Layer として Multi-Layer 以外のレイヤーが選択されている場合)– 値を入力して、パッドのランディング領域を中心からオフセットします。
-
Hole – 折りたたみ可能セクションを展開するか、グリッドを使用してパッド穴の属性を定義します。穴オプションはスルーホール パッドの場合のみ使用できます(つまり、パッドの Layer として Multi-Layer が選択されている場合)。
-
Shape – 目的の穴形状を選択します。
- Round – パッドの穴サイズに対して丸穴形状を指定します。穴種別ごと、およびメッキ穴/非メッキ穴ごとに、それぞれ個別のドリルファイル(NC Drill Excellon format 2)が生成されます。これらの種類に対して最大 6 種類のドリルファイルが作成されます。
- Rectangular – このパッドに対して長方形(打ち抜き)穴を指定します。長方形穴はメッキあり/なしのいずれも使用できます。穴種別ごと、およびメッキ穴/非メッキ穴ごとに、それぞれ個別のドリルファイル(NC Drill Excellon format 2)が生成されます。これらの種類に対して最大 6 種類のドリルファイルが作成されます。
- Slot – このパッドに対して両端が丸いスロット穴を指定します。スロット穴はメッキあり/なしのいずれも使用できます。穴種別ごと、およびメッキ穴/非メッキ穴ごとに、それぞれ個別のドリルファイル(NC Drill Excellon format 2)が生成されます。これらの種類に対して最大 6 種類のドリルファイルが作成されます。
- Size – このフィールドには、パッドの現在の穴サイズが表示されます。この値は、製造時にパッドに形成される穴の、丸穴の場合は直径、長方形穴またはスロット穴の場合は幅を mil または mm で指定します。SMD パッドまたはエッジコネクタでは、これを 0 に設定する必要があります。穴サイズは 0 ~ 1000mil の範囲で設定でき、パッドより大きく設定して(銅なしの)機械穴を定義することもできますが、Rectangular または Slot 穴の Length を超えることはできません。パッド穴サイズを変更するには、このフィールドの値を編集します。値はメートル系/ヤード・ポンド系のいずれでも入力できます。現在のデフォルト単位と異なる単位で値を入力する場合は、単位を含めてください。デフォルト単位(メートル系またはヤード・ポンド系)は、Board モードの Properties パネルの Other 領域にある Units 設定(デザインスペースでオブジェクトが選択されていないときにアクセス可能)で決まり、単位が指定されていない場合に使用されます。
-
Tolerance – 穴公差属性を設定すると、基板のはめあいや許容限界の判断に役立ちます。穴の最小公差(-)と最大公差(+)を指定してください。
-
Length – 穴の Shape が Rectangular または Slot に設定されている場合に、パッド内の穴の長さを表示します。この値は、製造時にパッドに NC ルーティングされる長さを mm または mil で指定します。穴サイズは 0 ~ 1000mil の範囲で設定でき、パッドより大きく設定して(銅なしの)機械穴を定義することもできますが、Rectangular または Slot 穴の Size より小さくすることはできません(必要な X-Y 形式を得るには Rotation 設定を使用してください)。長さを変更するには、このフィールドの値を編集します。値はメートル系/ヤード・ポンド系のいずれでも入力できます。現在のデフォルト単位と異なる単位で値を入力する場合は、単位を含めてください。デフォルト単位(メートル系またはヤード・ポンド系)は、Board モードの Properties パネルの Other 領域にある Units 設定(デザインスペースでオブジェクトが選択されていないときにアクセス可能)で決まり、単位が指定されていない場合に使用されます。このオプションは、穴の Shape が Round に設定されている場合は使用できません。
- Rotation – 現在の穴の、パッドに対する反時計回りの回転角度を度単位で表示します。このフィールドを編集して回転を変更します。最小角度分解能は 0.001° です。このオプションは、穴の Shape として Rectangular または Slot が選択されている場合にのみ使用できます。
- Copper Offset (X/Y) – 値を入力して、パッドのランディング領域をパッド穴の中心からオフセットします。
- Plated – このオプションは、パッドがメッキ穴を持つかどうかを決定します。このフィールドにチェックを入れると、パッドはメッキ穴パッドとして設定されます。設計内にメッキパッドと非メッキパッドの両方が存在する場合、NC ドリルファイルでは非メッキ穴に対してメッキ穴とは異なるツールが使用されます。
-
Shape – 目的の穴形状を選択します。
-
Paste – 折りたたみ可能セクションを展開するか、グリッドを使用して、ペーストマスク レイヤー上のパッド属性を定義します。使用可能なペーストマスク レイヤーのセットは、パッドが配置されているレイヤーによって異なります。
-
Shape – ペーストマスク レイヤー上の形状を選択します。
-
Rule Expansion – パッドのペーストマスク拡張に、適用される Paste Mask Expansion デザインルールで定義された値を適用する場合に選択します。
-
Manual Expansion – パッドのペーストマスク拡張値を指定する場合に選択します。
-
Round, Rectangular, Octagonal, Rounded Rectangle, Chamfered Rectangle、および Donut – 標準のペーストマスク形状を定義する場合に選択します。これらの形状は、X および Y の設定を変更することで、非対称形状に調整できます。
- Donut 形状の場合、D はドーナツの外径を示し、W は幅を示します。
-
Custom Shape – 非標準のペーストマスク形状を定義する場合に選択します。
-
-
Edit – クリックして、デザインスペース内でペーストマスク レイヤー上のカスタム形状を対話的に編集します。このボタンは、Shape として Custom Shape が選択されている場合にのみ使用できます。
-
Paste Expansion – 目的のペーストマスク拡張値を入力します。値は、絶対値(mil/mm)またはパッド面積の割合として定義できます。絶対値を入力する場合、現在のデフォルト単位と異なる単位で値を入力するときは単位を含めてください。デフォルト単位は、Board モードの Properties パネルの Other 領域にある Units 設定(デザインスペースでオブジェクトが選択されていないときにアクセス可能)で決まり、単位が指定されていない場合に使用されます。このオプションは、Shape として Manual Expansion が選択され、かつペーストマスクの使用が Enabled の場合にのみ使用できます。
-
(X/Y) – ペーストマスク形状の X(水平)サイズおよび Y(垂直)サイズを定義します。X サイズと Y サイズは独立して設定でき、非対称形状を定義できます。値はメートル系/ヤード・ポンド系のいずれでも入力できます。現在のデフォルト単位と異なる単位で値を入力する場合は、単位を含めてください。デフォルト単位(メートル系またはヤード・ポンド系)は、Board モードの Properties パネルの Other 領域にある Units 設定で決まり(デザインスペースでオブジェクトが選択されていないときにアクセス可能)、単位が指定されていない場合に使用されます。このオプションは、Shape として Round、Rectangular、Octagonal、Rounded Rectangle、または Chamfered Rectangle が選択されている場合にのみ使用できます。
-
Corner Radius – ペーストマスク形状の角の半径/面取りの絶対値を入力します。この値は、ペーストマスク形状の最短辺の半分以下である必要があります。計算された割合値(ペーストマスク形状の最短辺の半分に対する割合)がフィールドの右側に表示されます。値の後に
%記号を付けて入力すると、半径/面取りをペーストマスク形状の最短辺の半分に対する割合として定義できます。このとき、100%は最短辺を完全に丸めることを意味します(この場合、計算された絶対値がフィールドの右側に表示されます)。このオプションは、対応するペーストマスク レイヤー上のパッド Shape として Rounded Rectangle または Chamfered Rectangle が選択されている場合にのみ使用できます。 -
Upper Left、Upper Right、Lower Left、Lower Right – ペーストマスク形状の角を丸める/面取りする機能を有効にします。これらのオプションは、対応するペーストマスク レイヤー上のパッド Shape として Rounded Rectangle または Chamfered Rectangle が選択されている場合にのみ使用できます。
-
Offset (X/Y) – 値を入力して、ペーストマスク形状をパッド中心からオフセットします。
-
Outer Diameter – パッドの外径を入力します。このオプションは、対応するペーストマスク レイヤー上のパッド Shape として Donut が選択されている場合にのみ使用できます。
-
Width – パッドの幅を入力します。このオプションは、対応するペーストマスク レイヤー上のパッド Shape として Donut が選択されている場合にのみ使用できます。
-
Enabled – このオプションを使用して、パッドに対するペーストマスク形状の使用を有効/無効にします。このオプションは、Shape として Rule Expansion 以外が選択されている場合にのみ使用できます。
-
-
Solder – 折りたたみ可能セクションを展開するか、グリッドを使用して、ソルダーマスク レイヤー上のパッド属性を定義します。使用可能なソルダーマスク レイヤーのセットは、パッドが配置されているレイヤーによって異なります。
-
Shape – ソルダーマスク レイヤー上の形状を選択します。
-
Rule Expansion – パッドのソルダーマスク拡張に、適用される Solder Mask Expansion デザインルールで定義された値を適用する場合に選択します。
-
Manual Expansion – パッドのソルダーマスク拡張値を指定する場合に選択します。
- Round, Rectangular, Octagonal, Rounded Rectangle, Chamfered Rectangle、および Donut – 標準のソルダーマスク形状を定義する場合に選択します。これらの形状は、X および Y の設定を変更することで、非対称形状に調整できます。
-
Custom Shape – 非標準のソルダーマスク形状を定義する場合に選択します。
-
-
Edit – クリックして、デザインスペース内でソルダーマスク レイヤー上のカスタム形状を対話的に編集します。このボタンは、Shape として Custom Shape が選択されている場合にのみ使用できます。
-
Solder Expansion – 目的のペーストマスク拡張値を入力します。値は、絶対値(mil/mm)またはパッド面積の割合として定義できます。絶対値を入力する場合、現在のデフォルト単位と異なる単位で値を入力するときは単位を含めてください。デフォルト単位は、Board モードの Properties パネルの Other 領域にある Units 設定で決まり(デザインスペースでオブジェクトが選択されていないときにアクセス可能)、単位が指定されていない場合に使用されます。このオプションは、Shape として Manual Expansion が選択され、かつ Tented オプションが無効な場合にのみ使用できます。
-
From Hole Edge – 有効にすると、ソルダーマスク開口は穴の形状に従います。したがって、マスクはパッドの形状やサイズに依存せず、穴のサイズと形状の両方に基づいてスケーリングされます。たとえば、正方形の穴を持つパッドでは、穴寸法および割り当てられた拡張値に一致する正方形のマスク開口が作成されます。また、パッドの拡張マスク開口サイズは、穴サイズの変更にも追従することに注意してください。このオプションは、スルーホール パッドにのみ使用できます(つまり、パッドの Layer として Multi-Layer が選択されている場合)。さらに、Shape として Manual Expansion が選択され、かつ Tented オプションが無効な場合に限ります。
-
(X/Y) – ソルダーマスク形状の X(水平)サイズおよび Y(垂直)サイズを定義します。X サイズと Y サイズは独立して設定でき、非対称形状を定義できます。値はメートル系/ヤード・ポンド系のいずれでも入力できます。現在のデフォルト単位と異なる単位で値を入力する場合は、単位を含めてください。デフォルト単位(メートル系またはヤード・ポンド系)は、Board モードの Properties パネルの Other 領域にある Units 設定で決まり(デザインスペースでオブジェクトが選択されていないときにアクセス可能)、単位が指定されていない場合に使用されます。このオプションは、Shape として Round、Rectangular、Octagonal、Rounded Rectangle、または Chamfered Rectangle が選択されている場合にのみ使用できます。
-
Corner Radius – ソルダーマスク形状の角の半径/面取りの絶対値を入力します。この値は、ソルダーマスク形状の最短辺の半分以下である必要があります。計算された割合値(ソルダーマスク形状の最短辺の半分に対する割合)がフィールドの右側に表示されます。値の後に
%記号を付けて入力すると、半径/面取りをソルダーマスク形状の最短辺の半分に対する割合として定義できます。このとき、100%は最短辺を完全に丸めることを意味します(この場合、計算された絶対値がフィールドの右側に表示されます)。このオプションは、対応するソルダーマスク レイヤー上のパッド Shape として Rounded Rectangle または Chamfered Rectangle が選択されている場合にのみ使用できます。 -
Upper Left、Upper Right、Lower Left、Lower Right – ソルダーマスク形状の角を丸める/面取りする機能を有効にします。これらのオプションは、対応するソルダーマスク レイヤー上のパッド Shape として Rounded Rectangle または Chamfered Rectangle が選択されている場合にのみ使用できます。
-
Offset (X/Y) – 値を入力して、ソルダーマスク形状をパッド中心からオフセットします。
-
Outer Diameter – パッドの外径を入力します。このオプションは、対応するソルダーマスク レイヤー上のパッド Shape として Donut が選択されている場合にのみ使用できます。
-
Width – パッドの幅を入力します。このオプションは、対応するソルダーマスク レイヤー上のパッド Shape として Donut が選択されている場合にのみ使用できます。
-
Tented – ソルダーマスク拡張デザインルール内のソルダーマスク設定を上書きし、このパッドの上面/下面レイヤーのソルダーマスクに開口を作らず、テント処理としたい場合にチェックします。このオプションを無効にすると、このパッドにはソルダーマスク拡張ルールまたは特定の拡張値が適用されます。このオプションは、Shape として Rule Expansion 以外が選択されている場合にのみ使用できます。
-
/
– Shape として Manual Expansion が選択されている場合、ボタンが
に設定されていれば、Bottom Solder Mask 領域(したがってその Solder Expansion オプション)にアクセスできます。ボタンが
状態の場合、下面レイヤーのソルダーマスク拡張値は上面レイヤーと同じになります。
-
Pad Features
Top Side / Bottom Side – 基板の上面/下面側におけるパッドのカウンターホールについて、目的のオプションを選択します。使用可能なオプションは None、Counterbore、Countersink です。これらのオプションは、丸形のスルーホール パッドの場合にのみ使用できます(つまり、パッドの Layer として Multi-Layer が選択され、パッドの穴形状として Round が選択されている場合)。
ラミネートに設ける座ぐり穴により、ねじ頭のためのスペースを確保できます。皿穴(countersink)と座ぐり穴(counterbore)は、異なる種類のねじに対応する2種類の座ぐり穴です。このリリースでは、counterbore または countersink の穴を選択できるようになりました。countersink 用ねじと counterbore 用ねじの主な違いは穴のサイズと形状にあります。counterbore 穴はより広く、より角張った形状で、ワッシャーを追加できるようになっています。countersink 穴は、皿ねじの頭部下面の角度付き形状に一致する円錐状の穴を形成します。countersink は、ラミネートに加工される円錐形の穴です。通常は、テーパ状のねじ頭がラミネート上面と面一になるようにするために使用されます。これに対して、counterbore は底が平らな穴で、側面はまっすぐ下方向に加工されます。これは通常、六角頭のキャップまたはねじを収めるために使用されます。1つのパッドにつき、countersink または counterbore の穴は1つのみ許可されます。
アクティブレイヤー上の座ぐり穴輪郭を定義するため、2D ではパッドの周囲に破線が表示されます。counterhole は 2D、3D、および Draftsman でサポートされます。
Testpoint
Fabrication/Assembly – これらのオプションでは、製造時および/または組み立て試験時のテストポイント位置として使用するパッド(スルーホールまたは SMD)を指定できます。Top を有効にすると、このパッドはトップレイヤーのテストポイントとして定義されます。Bottom を有効にすると、このパッドはボトムレイヤーのテストポイントとして定義されます。
Via Properties
Net Information
この領域には、そのビアが属するネットに関する情報、およびそのネットがメンバーである場合は差動ペアや xSignal に関する情報が表示されます。必要に応じてクラス情報も表示されます。Delay、Length、Max Current、および Resistance の値も表示されます。
ネット情報の詳細については、PCB Placement & Editing Techniques ページを参照してください。
Definition
-
Component – このフィールドは、選択した Via が PCB Component の構成要素である場合にのみ PCB エディターで表示され、親 PCB コンポーネントのデジグネーターを表示します。クリック可能な Component リンクを選択すると、親コンポーネントの Component mode of the Properties panel を開きます。
-
Net – ビアのネットを選択するために使用します。アクティブな基板設計内のすべてのネットがドロップダウンリストに表示されます。No Net を選択すると、そのビアがどのネットにも接続されていないことを指定できます。プリミティブの Net プロパティは、PCB オブジェクトが適法に配置されているかどうかを Design Rule Checker が判定するために使用されます。あるいは、Assign Net アイコン(
)をクリックして設計空間内のオブジェクトを選択することもでき、そのオブジェクトのネットが選択したビアに割り当てられます。
-
Name – 1つ以上のビアが選択されている場合、ドロップダウンをクリックするとビア名が表示されます。このリストには、Layer Stack で定義されたすべてのビアスパンが含まれます。基板上で使用されるすべてのビアは、Layer Stack で定義されたビアスパンのいずれかでなければなりません。
-
Propagational Delay – このフィールドには伝搬遅延が表示されます。これは信号の先頭が送信側から受信側へ到達するまでにかかる時間です。
-
Template – 現在のビアテンプレートを表示します。ドロップダウンを使用して別のテンプレートを選択します。関連付けられた Library がある場合、そのライブラリが表示されます。
-
Library – 現在のライブラリに含まれるビアテンプレートを表示します。Pad Via Library(*.PvLib)からビアを配置した場合、このフィールドにはそのライブラリ名が含まれます。配置後は
アイコンが有効になり、配置されたビアのプロパティがライブラリで定義されていて、編集できなくなっていることを示します。
アイコンが有効でない場合は、内容を引き続き編集できます。
-
(X/Y)
- X (最初のフィールド)– このフィールドには、現在の原点を基準としたビア中心の現在の X 位置が表示されます。フィールド内の値を編集して、現在の原点に対するビア位置を変更します。値はメートル法またはヤード・ポンド法のいずれでも入力でき、現在のデフォルト単位でない値を入力する場合は単位を含めてください。デフォルト単位(メートル法またはヤード・ポンド法)は、Units 設定により、Other 領域の Properties panel の Board mode(設計空間でオブジェクトが選択されていないときにアクセス)で決定され、単位が指定されない場合に使用されます。
- Y (2番目のフィールド)– このフィールドには、現在の原点を基準としたビア中心の現在の Y 位置が表示されます。フィールド内の値を編集して、現在の原点に対するビア位置を変更します。値はメートル法またはヤード・ポンド法のいずれでも入力でき、現在のデフォルト単位でない値を入力する場合は単位を含めてください。デフォルト単位(メートル法またはヤード・ポンド法)は、Units 設定により、Other 領域の Properties panel の Board mode(設計空間でオブジェクトが選択されていないときにアクセス)で決定され、単位が指定されない場合に使用されます。
Via Stack
-
Simple – 選択すると単純ビアを選べます。
- Diameter – 必要なビア径を入力します。ビア径はすべてのレイヤーで同一です。
- Relief – 有効にすると、該当する Polygon Connect Style ルールを上書きして、このビアのサーマルリリーフをカスタマイズできます。
-
Thermal Relief – Relief オプションを有効にすると、このリンクをクリックして Polygon Connect Style ダイアログを開き、必要に応じてサーマルリリーフのオプションを変更できます。Edit Points ボタンをクリックすると、サーマルリリーフスポークの接続点を手動で定義できます。
-
Top-Middle-Bottom – 選択すると、トップレイヤー、すべての内部信号レイヤー、および Bottom Layer に対して異なる径を選択できます。
- Displayed Layer(s) – 表示されたレイヤーをクリックして、そのレイヤーのビアを設定します。選択したレイヤーはハイライト表示されます。
- Diameter – ドロップダウンをクリックし、選択したレイヤーに対して必要なビア径を入力します。
- Relief – 有効にすると、該当する Polygon Connect Style ルールを上書きして、このビアのサーマルリリーフをカスタマイズできます。
-
Thermal Relief – Relief オプションを有効にすると、このリンクをクリックして Polygon Connect Style ダイアログを開き、必要に応じてサーマルリリーフのオプションを変更できます。Edit Points ボタンをクリックすると、サーマルリリーフスポークの接続点を手動で定義できます。
-
Full Stack – 選択すると Full Stack ビアオブジェクトを選べます。
- Displayed Layer(s) – 表示されたレイヤーをクリックして、そのレイヤーのビアを設定します。選択したレイヤーはハイライト表示されます。
- Diameter – ドロップダウンをクリックし、選択したレイヤーに対して必要なビア径を入力します。
- Relief – 有効にすると、該当する Polygon Connect Style ルールを上書きして、このビアのサーマルリリーフをカスタマイズできます。
-
Thermal Relief – Relief オプションを有効にすると、このリンクをクリックして Polygon Connect Style ダイアログを開き、必要に応じてサーマルリリーフのオプションを変更できます。Edit Points ボタンをクリックすると、サーマルリリーフスポークの接続点を手動で定義できます。
-
Hole Size – このフィールドには、ビアの現在の穴サイズが表示されます。この値は、製造時にビアへ加工される穴(円形、正方形、またはスロット形状)の直径を mil または mm で指定します。穴サイズは 0~1000mil の範囲で設定でき、ビア径より大きく設定して(銅なしの)機械穴を定義することもできます。このフィールドの値を編集して、ビアの穴サイズを変更します。値はメートル法またはヤード・ポンド法のいずれでも入力でき、現在のデフォルト単位でない値を入力する場合は単位を含めてください。デフォルト単位(メートル法またはヤード・ポンド法)は、Units 設定により、Other 領域の Properties panel の Board mode(設計空間でオブジェクトが選択されていないときにアクセス)で決定され、単位が指定されない場合に使用されます。
-
Tolerance – 穴の公差属性を設定すると、基板のはめあいと許容限界の判断に役立ちます。穴の最小公差(-)および最大公差(+)を指定してください。Altium Designer にはデフォルトの穴公差値はありません。
Solder Mask Expansion
-
Rule – このビアのソルダーマスク拡張を、該当する Solder Mask Expansion 設計ルールで定義された値に従わせるには、これを選択します。
-
Top
- Tented – ソルダーマスク拡張設計ルール内のソルダーマスク設定を上書きし、このビアのトップレイヤーにソルダーマスク開口を設けず、結果としてテント処理する場合にチェックします。このオプションを無効にすると、このビアはソルダーマスク拡張ルールまたは特定の拡張値の影響を受けます。
-
Bottom
- Tented – ソルダーマスク拡張設計ルール内のソルダーマスク設定を上書きし、このビアのボトムレイヤーにソルダーマスク開口を設けず、結果としてテント処理する場合にチェックします。このオプションを無効にすると、このビアはソルダーマスク拡張ルールまたは特定の拡張値の影響を受けます。
-
Top
-
Manual – 該当する設計ルールを上書きし、このビアのソルダーマスク拡張値を指定するには選択します。
-
Top – トップレイヤーのソルダーマスク拡張値を入力します。値はメートル法またはヤード・ポンド法のいずれでも入力でき、現在のデフォルト単位でない値を入力する場合は単位を含めてください。デフォルト単位(メートル法またはヤード・ポンド法)は、Units 設定により、Other 領域の Properties panel の Board mode(設計空間でオブジェクトが選択されていないときにアクセス)で決定され、単位が指定されない場合に使用されます。このフィールドは Tented が有効でない場合にのみ使用できます。
- Tented – ソルダーマスク拡張設計ルール内のソルダーマスク設定を上書きし、このビアのトップレイヤーにソルダーマスク開口を設けず、結果としてテント処理する場合にチェックします。このオプションを無効にすると、このビアはソルダーマスク拡張ルールまたは特定の拡張値の影響を受けます。
-
Bottom – ボトムレイヤーのソルダーマスク拡張値を入力します。値はメートル法またはヤード・ポンド法のいずれでも入力でき、現在のデフォルト単位でない値を入力する場合は単位を含めてください。デフォルト単位(メートル法またはヤード・ポンド法)は、Units 設定により、Other 領域の Properties panel の Board mode(設計空間でオブジェクトが選択されていないときにアクセス)で決定され、単位が指定されない場合に使用されます。このフィールドは、この領域の右側にある
アイコンが
に設定され、かつ Tented オプションが有効でない場合にのみ使用できます。アイコンが
状態で、かつ オプションが有効でない場合、ボトムレイヤーのソルダーマスク拡張値はトップレイヤーと同じになります。 - Tented – ソルダーマスク拡張設計ルール内のソルダーマスク設定を上書きし、このビアのボトムレイヤーにソルダーマスク開口を設けず、結果としてテント処理する場合にチェックします。このオプションを無効にすると、このビアはソルダーマスク拡張ルールまたは特定の拡張値の影響を受けます。
- From Hole Edge – 有効にすると、ソルダーマスク開口は穴サイズに従います。したがって、マスクはビアサイズに依存せず、穴サイズを基準にスケーリングされます。また、ビアの拡張マスク開口サイズは、穴サイズの変更にも追従します。
-
Top – トップレイヤーのソルダーマスク拡張値を入力します。値はメートル法またはヤード・ポンド法のいずれでも入力でき、現在のデフォルト単位でない値を入力する場合は単位を含めてください。デフォルト単位(メートル法またはヤード・ポンド法)は、Units 設定により、Other 領域の Properties panel の Board mode(設計空間でオブジェクトが選択されていないときにアクセス)で決定され、単位が指定されない場合に使用されます。このフィールドは Tented が有効でない場合にのみ使用できます。
Via Types & Features
- IPC 4761 Via Type – ドロップダウンを使用して、IPC 4761 規格に基づくビアタイプ Design Guide for Protection of Printed Board Via Structures を選択します。
-
Grid – IPC 4761 Via Type ドロップダウンで
None以外のビアタイプが選択されると表示されます。選択したビアタイプで使用可能なフィーチャに応じて、基板の Side を選択し、Material を入力します。
Testpoint
Fabrication/Assembly – これらのオプションでは、製造時および/または組み立て試験時のテストポイント位置として使用するビアを指定できます。Top を有効にすると、このビアはトップレイヤーのテストポイントとして定義されます。Bottom を有効にすると、このビアはボトムレイヤーのテストポイントとして定義されます。
パッドおよびビアのサーマルリリーフ
Thermal Relief フィールドは、Pad Stack / Via Stack 領域の Properties panel 内で、現在適用されているサーマルリリーフ設定の要約を表示します。たとえば、Relief, 15mil, 10mil, 4, 90 は次のことを意味します。
- サーマルリリーフ接続が適用されている。
- エアギャップ幅が 15mil である。
- サーマルリリーフ導体の幅が 10mil である。
- サーマルリリーフ導体の回転角度が 90 度である。
Thermal Relief フィールドのチェックボックスが無効な場合、パッドおよびビアのポリゴンサーマルリリーフは rules-driven です。つまり、これらのリリーフは該当する Polygon Connect Style design rules によって定義されます。個々のパッドについては、必要なレイヤーに関連付けられた Thermal Relief オプションを有効にすることで、サーマルリリーフ設定をカスタマイズできます。この場合、サーマルリリーフは custom と見なされます。詳細は Defining Custom Thermal Reliefs を参照してください。
ソルダーおよびペーストマスク拡張
ソルダーマスクは、各パッド/ビア位置の Solder Mask レイヤー上に自動生成されます。ソルダーマスクはネガティブ定義です。つまり、配置されたオブジェクトが Solder Mask レイヤー上の開口を定義します。ペーストマスクは、各パッド位置の Paste Mask レイヤー上に自動生成されます。マスクレイヤー上に生成される形状はパッド/ビア形状であり、PCB エディターで設定された Solder Mask Expansion および Paste Mask Expansion 設計ルール、または Properties panel で指定された量だけ拡張または縮小されます。
パッドまたはビアを編集すると、それぞれ Pad Stack 領域および Solder Mask Expansion 領域の Properties panel に、ソルダーマスク拡張とペーストマスク拡張の設定が表示されます。これらの設定は、パッド/ビアの拡張要件をローカルに制御するためのものですが、通常は使用する必要はありません。一般的には、PCB エディターで適切な設計ルールを定義して、ペーストマスクおよびソルダーマスク要件を制御する方が容易です。設計ルールを使用すれば、まず基板上のすべてのコンポーネントに対する拡張を設定する1つのルールを作成し、その後必要に応じて、基板上で使用される特定のフットプリントタイプのすべてのインスタンスや、特定コンポーネント上の特定パッドなど、個別の状況を対象とする他のルールを追加できます。
設計ルールでマスク拡張を設定するには:
-
Rule Expansion オプションが、Shape として Pad Stack 領域の Properties panel(パッド用)で選択されていること、および/または Rule オプションが
領域の Properties panel(ビア用)で選択されていることを確認します。 -
PCB エディターでメインメニューから Design » Rules を選択し、PCB Rules and Constraints Editor dialog の Mask カテゴリ設計ルールを確認します。フットプリントが PCB に配置されると、これらのルールが適用されます。
拡張設計ルールを上書きし、パッド/ビア属性としてマスク拡張を指定するには、Manual Expansion を Pad Stack 領域の Properties panel(パッド用)の Shape として選択し、および/または Manual を
パッドおよびビアのテント処理
パッドおよびビアの部分的または完全なテント処理は、Solder Mask Expansion に適切な値を定義することで実現できます。この拡張制約は、Properties panel でオブジェクトごとに定義することも、適切な Solder Mask Expansion 設計ルールを定義することでも設定できます。拡張値を適切な値に設定することで、次のことが可能になります。
- パッド/ビアを部分的にテント処理するには – ランド領域のみを覆う場合、Expansion を負の値に設定して、マスクがパッド/ビア穴の直前まで閉じるようにします。
- パッド/ビアを完全にテント化し、ランドと穴を覆うには、Expansion をパッド/ビア半径と同じかそれ以上の負の値に設定します。
- 単一レイヤー上のすべてのパッド/ビアをテント化するには、適切な Expansion 値を設定し、Solder Mask Expansion ルールのスコープ(Full Query)が対象レイヤー上のすべてのパッド/ビアを指定するようにします。
- 異なるビアサイズが定義されている設計で、すべてのパッド/ビアを完全にテント化するには、Expansion を最大のパッド/ビア半径と同じかそれ以上の負の値に設定します。個別のパッド/ビアをテント化する場合は、適用される設計ルールで定義された expansion に従うか、そのルールを上書きして対象の個別パッド/ビアに直接指定した expansion を適用するかを選択できます。
テストポイント
Related page: 基板上でのテストポイントの割り当て
このソフトウェアはテストポイントを完全にサポートしており、パッド(スルーホールまたは SMD)およびビアを、製造テストおよび/または組み立てテストで使用するテストポイント位置として指定できます。パッド/ビアをテストポイントとして使用するには、関連するテストポイントプロパティを設定します。つまり、製造用か組み立て用のテストポイントか、また基板のどちらの面でテストポイントとして使用するかを指定します。これらのプロパティは、Testpoint Properties パネルの領域にあります。
このプロセスを簡略化し、テストポイントプロパティを手動で設定する必要を減らすために、このソフトウェアでは、定義された設計ルールに基づいて Testpoint Manager(Tools » Testpoint Manager)を使用し、テストポイントを自動割り当てする方法を提供しています。いずれの場合も、この自動割り当てにより、そのパッド/ビアに関連するテストポイントプロパティが設定されます。
パッド固有の設定
パッドデジグネータ
各パッドには、最大 20 文字の英数字からなるデジグネータ(通常はコンポーネントのピン番号を表す)を付ける必要があります。最初のパッドのデジグネータが数字で終わっている場合、配置中にパッドデジグネータは 1 ずつ自動増分されます。配置前に、最初のパッドのデジグネータを Properties パネルから変更してください。
アルファベット増分、たとえば 1A、1B、または 1 以外の数値増分を行うには、Paste Special dialog(Edit » Paste Special)の Paste Array ボタンを押して開く Setup Paste Array dialog を使用します。
Paste Array 機能
パッドをクリップボードにコピーする前にそのデジグネータを設定しておくと、Setup Paste Array ダイアログを使用して、パッド配置時にデジグネータの連番を自動適用できます。Setup Paste Array ダイアログの Text Increment フィールドを使用すると、次のようなパッドデジグネータ列を配置できます。
- 数値(1、3、5)
- アルファベット(A、B、C)
- 英数字の組み合わせ(A1 A2、1A 1B、A1 B1、または 1A 2A など)
数値で増分するには、 Text Increment フィールドに増分量を設定します。アルファベットで増分するには、Text Increment フィールドに、スキップしたい文字数を表すアルファベットの文字を設定します。たとえば、最初のパッドのデジグネータが 1A の場合、デジグネータを 1 ずつ増分するには、フィールドを A(アルファベットの最初の文字)に設定します。フィールドを C(アルファベットの 3 番目の文字)に設定すると、デジグネータは 1A、1D(A の 3 文字後)、1G… のようになります。
ジャンパ接続
ジャンパ接続は、PCB 上でプリミティブにより物理配線されていないコンポーネントパッド間の電気的接続を定義します。これは特に単層基板で有用で、1 つの物理レイヤー上のトラックを飛び越えるためにワイヤーを使用する場合に役立ちます。
コンポーネント内のパッドには、Properties パネル内で Jumper 値を設定できます。同じ Jumper と同じ電気ネットを共有するパッドは、物理的には未接続であっても、正当な接続が存在することをシステムに伝えます。
ジャンパ接続は PCB Editor では曲線の接続線として表示されます。Design Rules Checker はジャンパ接続を未配線ネットとして報告しません。
ビア固有の設定
ビアプロパティの定義
各ビアタイプのレイヤー貫通方向(Z プレーン)の要件は the Via Types tab of the Layer Stack Manager で定義されますが、ビアのサイズプロパティは次のいずれかで定義されます。
-
Properties panel で配置済みビアを手動編集する、または
-
ビアを手動配置した場合の PCB default primitives(Place » Via)、または
-
インタラクティブルーティング、ActiveRouting、またはオートルーティング中にビアを配置した場合の Routing Via Style design rule。
Routing Via Style 設計ルールの設定
Main page: PCB 設計ルールの定義、スコープ設定、管理
インタラクティブルーティング、ActiveRouting、またはオートルーティング中に配置されるビアのサイズプロパティは、適用される Routing Via Style 設計ルールによって制御されます。設計ルールでビアを対象指定しやすくするために、ルールスコープ(Where the Object Matches)で使用できるビア関連のクエリキーワード群が用意されており、これらについては 以下で詳しく説明します。
配線中にレイヤー変更を行うと、ソフトウェアはそのレイヤー変更の開始レイヤーと終了レイヤーを確認し、Layer Stack Manager から許可された Via Type を選択します。次に、最優先の適用可能な Routing Via Style 設計ルールを特定し、そのルールの Constraints セクションにあるビアサイズ設定を、これから配置するビアに適用します。
たとえば、DRAM_DATA ネット群では、TopLayer - S2 間のレイヤー遷移と S2 - S3 間のレイヤー遷移に µVia を必要とし、それ以外のすべてのレイヤー遷移にはドリルされたスルーホールビアを必要とする場合があります(しかもこれは他のネットで必要なビアとも異なります)。これは、これらの DRAM_DATA ネットを対象とする 2 つの Routing Via Style 設計ルールを作成することで対応できます。適切な µVia 設計ルールの例を以下に示します。画像にカーソルを重ねると、スルーホール設計ルールが表示されます。

設計ルールは、特定のタイプのビアに適用されるようスコープ設定できます。
Routing Via Style 設計ルールのスコープ設定を簡単にするために、次のビア関連クエリキーワードを利用できます。
| Via Type Query | Returns |
|---|---|
| IsVia | Via Type に関係なく、すべてのビアオブジェクト。 |
| IsThruVia | トップレイヤーからボトムレイヤーまで貫通するすべてのビア。 |
| IsBlindVia | µVia ではなく、サーフェスレイヤーから内部レイヤーへ開始して終端するすべてのビア。 |
| IsBuriedVia | µVia ではなく、ある内部レイヤーから別の内部レイヤーへ開始して終端するすべてのビア。 |
| IsMicroVia | µVia オプションが有効で、隣接レイヤーを接続するすべてのビア。 |
| IsSkipVia | µVia オプションが有効で、2 レイヤーにまたがるすべてのビア。 |
インタラクティブルーティング中のビア配置
インタラクティブルーティング中にレイヤーを変更すると、ソフトウェアは自動的にビアを挿入します。選択されるビアは次の要因によって決まります。
- そのレイヤー変更でまたがるレイヤーに対して利用可能な Via Type。
- そのレイヤー変更で選択された Via Type に適用される Routing Via Style 設計ルール。
L1 から L4 へのレイヤー変更中に配置される積層 µVia。Properties パネルの Interactive Routing モードには、配置される Via Type が表示されます。6 を押すと可能なビアスタックを順に切り替え、8 を押すと可能なビアスタックの一覧を表示します。
インタラクティブルーティング中に配置されるビアの制御
-
配線レイヤーを変更すると、ソフトウェアはそのレイヤースパンに適した Via Type を自動的に選択します。
-
使用可能な Via Type/組み合わせ(ビアスタック)が複数ある場合は、6 ショートカットキーを押すと、そのレイヤー変更で利用可能なすべてのビアスタックを対話的に順送りで切り替えられます。8 ショートカットを押すと一覧が表示されます。ビアスタックは、µVia を使用、Skip µVia を使用、Blind via を使用、Thruhole via を使用、の順で提示されます。レイヤー変更が 1 層を超え、適切な Via Type が定義されている場合は、積層ビアを配置できます。提案された Via Type は、ステータスバーおよび Heads Up 表示に、たとえば [µVia 1:2, µVia 2:3, µVia 3:4] のように表示されます。これは上の画像に示されています。
-
最後に使用したビアスタックは、次に配線するネットのデフォルトとして保持されます。このデフォルトビアスタックは、現在の編集セッション中のみ保持されます。
-
ビアのサイズプロパティは、適用される Routing Via Style design rule で指定されます。適切な Routing Via Style 設計ルールを定義するための方針については、上で説明しています。
-
レイヤー変更の実行中にビアサイズを対話的に変更するには、4 ショートカットを押します。これにより Via Size モードが順に切り替わります:
Rule Minimum、Rule Preferred、Rule Maximum、User Choice。現在の Via-Size モードは Heads Up 表示とステータスバーに表示されます(上の画像参照)。User Choice が選択されている場合は、Shift+V を押して Choose Via Sizes dialog を開き、希望するビアサイズを選択します。ダイアログに表示される利用可能なビアサイズの一覧は、設計内ですでに使用されているビアの一覧から取得されます。これらは PCB パネルの Pad and Via Templates mode で確認できます。適用される Routing Via Style design rule で Template preferred モードが使用されている場合、4 ショートカットを使うと有効なビアテンプレートが順に切り替わります。
-
提案された Via Type の側面図が、上記のように Properties パネルに表示されます。
-
ビアを配置して同じレイヤー上で配線を続行するには、2 ショートカットを押します。
-
ビアを配置してこの接続の配線を中断するには、テンキーの / ショートカットを押します。
-
配線中のネットを内部電源プレーンに接続する場合は、適切な電源プレーンに接続するビアを配置するために、テンキーの / キーを押します。これは Any Angle mode を除くすべてのトラック配置モードで機能します。
-
配線中に Shift+F1 を押すと、コマンド実行中のすべてのショートカットを表示するメニューが表示されます。
積層ビアの操作
-
連続した接続を形成する積層ビアは、単一のビアのように扱うことができ、スタック上で click and drag すると、接続された配線を含めてすべて一緒に移動します。
-
1 回クリックすると、スタック内の最上位の Via が選択されます。マウスを動かさなければ、その後のシングルクリックごとにスタック内の他の Via が順番に選択されます。
-
Ctrl+Click and drag を行うと、選択した Via のみを接続された配線とともに移動します。
-
スタック内のすべての Via を選択するには、1 回クリックして 1 つ選択し、その後 Tab を押して、そのスタック内のすべての Via を含むように選択範囲を拡張します。
ビア表示の設定
ビアの操作を支援するために、さまざまな表示機能が用意されています。
ビアの色
ビアの色は View Configuration panel で設定します。ビアの銅リングは、Layers セクションの現在の Multi-Layer 設定で表示されます。ビアホールの色は、System Colors セクションの Via Holes 設定で表示されます。必要な設定について
を切り替えることで、ホールの表示を無効にすることもできます。

最初の画像にはスルーホールビアが表示されています。2 番目の画像のビアはブラインドビアで、ホールは開始レイヤーと終了レイヤーの色で表示されています。
ビアとソルダーマスク
PCB editor におけるレイヤーのデフォルト表示は、常に Multi-Layer を最前面に表示する設定です。このため、特にパッドやビアで負のマスク expansion を使用している場合、ソルダーマスクレイヤーの内容がマルチレイヤーオブジェクトの下に隠れて見えなくなるため、ソルダーマスクレイヤーの内容を正確に確認しにくくなります。これは、Preferences ダイアログの PCB Editor – Display ページでレイヤー描画順序を変更することで改善できます。現在のレイヤーが最前面に描画されるように設定してください。
レイヤー描画順序を Current Layer が上になるよう変更すると、Top Solder を現在のレイヤーにした際、下の画像に示すようにマスク開口が正確に表示されます。緑の矢印は、左のビアのソルダーマスク開口サイズ、中央のマスク開口が縮小されたパッド、右の開口が拡大されたパッドのサイズを示しています。

ソルダーマスク開口を確認できるように表示設定を構成します。
積層ビアの表示
積層ビアがある場合、表示される数字はスタック内のすべてのビアの開始レイヤーと終了レイヤーです。下の画像にカーソルを重ねると 3D 表示になり、画像右側には 3 つのビアからなるスタックが示されます。
ビア内にまたがるレイヤーを表示できます。カーソルを重ねるとビアの 3D 表示が見られます。
その他のビア表示設定
ビアのネット名と、ビアのスパン内のレイヤー番号を表示するには、View Configuration パネルの View Options タブにある Additional Options 領域で、それぞれ Via Nets オプションと Via Span オプションを有効にします。
パッドおよびビアホールの参照
PCB panel’s Hole Size Editor モードでは、3 つの主な領域が次の内容を反映するように変化します(上から順に)。
- ホールタイプとそのステータスの一般フィルタリング。これには、現在基板に定義されているレイヤードリルペアのサブセクションも含まれます。
- Unique Holes サイズと形状によって決定されるグループとして配置されたもの。
- 各ホールオブジェクトグループを構成する個別の Pads/Vias。

パネルの各セクションには、ホールタイプ、スタイル、ステータスに対して累積的に適用されたフィルタリングが表示されます。
ホールのグループは、適切な列セルに値を入力することで、パネルの Unique Holes 領域で一括編集できます。Hole Size 列では数値を入力して、パッドおよびビアの現在のホールサイズを変更できます。

一致する 6 つのホールスタイルの選択グループについてホールサイズを編集。
必要に応じて、対応する Hole Length、Hole Type、Plated の各項目も変更できます。

一致する 6 つのホールスタイルの選択グループについてホールタイプを変更。
選択したホールグループに属する個々のパッド/ビアオブジェクトは、PCB パネルの下部 Pad/Via セクションに一覧表示されます。リスト内のオブジェクトを右クリックして Properties を選択するか(または項目を直接ダブルクリックして)、そのプリミティブに対応する Properties パネルの関連モードを開くと、そのプロパティを表示および編集できます。
PCB から現在のドリルシンボルデータを反映して PCB パネルの Hole Size Editor モードを更新するには、このモードのパネル領域内を右クリックし、Refresh コマンドを選択します。
バックドリリングのサポート
PCB パネルの Hole Size Editor モードは、バックドリリング対象のパッドおよびビアの確認にも使用できます。バックドリルのレイヤーペアは、Layer Pairs リスト内で [BD] というテキストが追加されて表示されます。
バックドリルのホールサイズが選択されると、オブジェクトの Kind が Backdrill として表示されます。この機能を使って、バックドリルされたホールをすばやく見つけて確認できます。なお、バックドリル設定はパネルでは編集できません。
バックドリルレポート
すべてのバックドリルイベントのレポートを生成するには、Unique Holes リスト内で右クリックし、コンテキストメニューから Backdrill Report を選択します。
このレポートには、位置、ドリルサイズ、ドリル深さを含む各バックドリルイベントの詳細が記載されます。
カウンターホールのサポート
PCB パネルの Hole Size Editor モードは、カウンターホール機能が有効になっているパッドの確認にも使用できます。PCB 設計で、一方または両方の面に対してカウンターホール(座ぐり/皿もみ)機能が有効なパッドオブジェクトがある場合、対応する Counterholes Top および/または Counterholes Bottom グループが Layer Pairs リストに表示されます。Counterhole Depth 列および Counterhole Angle 列は、パネルの Unique Holes 領域に表示できます。なお、カウンターホール設定はパネルでは編集できません。

設計内のカウンターホールに関する情報は、 PCB パネルの Hole Size Editor モードに表示されます。









