曲げ線の定義 - 詳細モード

概略

この記事では、Altium Designerのアドバンスドリジッドフレックスモードでベンディングラインがどのように機能するかを解説します。特に、標準のリジッドフレックスモードとの違いと、その違いがフレックス領域の定義や基板の折り曲げに与える影響に焦点を当てます。PCBで使用されているリジッドフレックスモードの確認方法、基板プランニングモードでのベンディングラインの配置と調整、プロパティの編集、そして3Dで基板を折り曲げた際の曲げ形状の制御方法を紹介します。より複雑なリジッドフレックス設計に取り組んでおり、曲げ位置、角度、半径、折り曲げ順序の定義について実践的なガイダンスが必要な方に役立つ内容です。リジッドフレックス設計のワークフローをより正確で予測しやすいものにするために、ぜひ読み進めてください。

- 標準のリジッドフレックスモードとアドバンスドリジッドフレックスモードの違い、特にアドバンスドモードで分割線オブジェクトを使用しない理由を理解します。
- 基板プランニングモードでベンディングラインを配置、移動、削除し、位置を正確に指定するための基本的なワークフローを学びます。
- 角度、半径、スタック領域の割り当て、折り曲げ順序など、3Dでの曲げ動作を制御するベンディングラインのプロパティを確認します。
AIでさらに深掘り:

AltiumのPCB設計ソフトウェアでは、2つのリジッドフレックス設計モードを使用できます。従来の標準モードであるRigid-Flexは、シンプルなリジッドフレックス設計に対応しています。フレックス領域の重なりなど、より複雑なリジッドフレックス要件がある設計には、Advanced Rigid-Flexモード(リジッドフレックス2.0とも呼ばれます)が必要です。モードは、レイヤースタックマネージャーのToolsメニューで選択します。

これらのモードの根本的な違いは、従来のモードでは分割線を配置することで基板外形を個別の基板領域に分割し、その分割線が、ある基板領域の終端と次の基板領域の始端を定義するオブジェクトとして残る点です。Advancedモードでは、各基板領域を個別に配置します。また、大きな領域をスライスすると、2つの独立した領域オブジェクトになります。Advancedモードでは、分割線の存在ではなく、隣接する基板領域のエッジによって、2つの領域が接する位置が定義されます。この違いにより、Advanced Rigid-Flexモードの基板には分割線オブジェクトは存在しません。

► 詳細については、リジッドフレックスPCBの設計を参照してください

Viewメニューには、覚えやすいショートカットが割り当てられた3つのPCBエディター作業モードがあり、次のモードをすばやく切り替えられます。

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

2D表示モードと3D表示モードを切り替える際、デフォルトでは各表示モードのズームと向きの設定が個別に保持されます。切り替え時に基板の同じ位置と向きを表示したい場合は、2または3の代わりに、Ctrl+Alt+2 または Ctrl+Alt+3を押してください。

PCBを開いたばかりで、標準リジッドフレックスモードとAdvanced Rigid-Flexモードのどちらが使用されているか確認したい場合は、どうすればよいでしょうか。

レイヤースタックマネージャーを開いて確認できます。または、基板プランニングモード(ショートカット:1)に切り替え、アクティブバーを確認してください。

標準リジッドフレックスモード
Advanced Rigid-Flexモード

フレックス基板の曲げ方を定義するには、1本以上の曲げ線を配置します。曲げ線は、フレックス領域の表面上で曲げを行う位置を定義します。また、曲げの角度と半径も定義します。曲げられる帯状の基板表面の幅はオレンジ色で表示され、この幅は曲げ角度と半径から計算されます(詳細については、曲げ線のプロパティを参照してください)。曲げ線の配置と編集は、PCBエディターをBoard Planning Modeにして行います(View » Board Planning Mode、またはショートカット 1を押します)。


フレックス領域上に曲げ線を配置し、基板を180度折り曲げられるように設定しています。この動画では、Advanced Rigid-Flexモードで曲げ線を配置する方法を紹介します。

曲げ線の配置

曲げ線を配置するには:

  1. View » Board Planning Modeを選択するか、ショートカット 1を押して、Board Planning Modeに切り替えます。
  2. Place » Define Bending Lineコマンドを選択するか、アクティブバーの  ボタンをクリックします。
  3. 曲げ線は対象の基板領域上に配置されますが、その領域に接続されるわけではありません(曲げ線は、Stack Regionsプロパティによって1つ以上の基板領域に関連付けられます)。基板領域のエッジ付近をクリックして、曲げ線の開始位置を定義します。
  4. カーソルを目的の終了位置に移動し、クリックして曲げ線を配置します。曲げ線の少なくとも一方の端は、適用先の基板領域の境界に接するか、境界を横切る必要があります。
  5. 曲げ線の配置モードが維持されるため、必要に応じて別の曲げ線を続けて配置できます。配置を終了する場合は、右クリックするかEscを押して、曲げ線の配置モードを終了します。

選択した曲げ線のプロパティは、Propertiesパネルで編集できます。曲げ線は領域の上にあるため、曲げ線をクリックしても、その下の領域が選択される場合があります。カーソルを動かさずにもう一度クリックすると、基板領域の代わりに曲げ線を選択できます。

選択した曲げ線のプロパティがPropertiesパネルに表示されます。
選択した曲げ線のプロパティがPropertiesパネルに表示されます。

  • 曲げ線の開始点や終了点を基板領域のエッジに正確に合わせる必要はありません。ソフトウェアが曲げ線を自動的に延長または短縮し、領域の一方のエッジからもう一方のエッジまでの線として定義します。
  • PropertiesパネルのStack Regionsセクションで、正しい基板領域が有効になっていることを確認してください。

曲げ線の移動

既存の曲げ線の位置を変更するには:

  1. View » Board Planning Mode を選択して(またはショートカット 1を押して)、Board Planning Modeに切り替えます。
  2. 曲げ線のいずれかの端の頂点をクリックしたまま、目的の位置までドラッグし、マウスボタンを離します。カーソルの動きは現在のカーソルスナップ設定に制約されます。操作中にCtrl+Eを押すと設定を変更できます。
  3. 曲げ線の新しい位置に基づいて、曲げ位置が再定義されます。

曲げ線の頂点を選択してドラッグすると、基板上の曲げ線の位置を変更できます。カーソルの動きは、現在のカーソルスナップ設定に制約されます。
曲げ線の頂点を選択してドラッグすると、基板上の曲げ線の位置を変更できます。カーソルの動きは、現在のカーソルスナップ設定に制約されます。

曲げ線の正確な位置決め

曲げ線のハンドルを移動すると、現在のスナップ設定に従ってハンドルがスナップします。移動中にCtrl+Eを押すと、下図のようなスナップ設定の対話型コントロールパネルがポップアップ表示されます。設定を変更した後、Escを押して設定を適用し、パネルを閉じます。

曲げ線は、スナップグリッドやワークスペースガイドだけでなく、メカニカルレイヤー上の線など、既存の設計オブジェクトにもスナップできます。下図では、曲げ線のハンドルをメカニカルレイヤー上の線の端点に配置しています。移動中は、現在のホットスポットスナップ設定(ステータスバーに表示)が適用されます。メカニカルレイヤーがアクティブな設計レイヤーでない場合、このスナップ動作を使用するには、ホットスポットスナップをAll Layersに設定する必要があります。操作中にショートカットShift+Eを押すと、ホットスポットスナップ設定を使用可能なモード間で順に切り替えられます。

曲げ線のハンドルを、メカニカルレイヤー上に配置されたトラックの頂点にスナップさせています。
曲げ線のハンドルを、メカニカルレイヤー上に配置されたトラックの頂点にスナップさせています。

曲げ線の削除

曲げ線を削除するには:

  1. View » Board Planning Modeを選択して(またはショートカット 1を押して)、Board Planning Modeに切り替えます。
  2. 曲げ線の頂点の1つをクリックしたままにして曲げ線を選択し、Deleteキーを押します。

曲げ線のプロパティの設定

Propertiesパネルで曲げ線のプロパティを編集するには:

  1. Board Planning Modeに切り替えます(1を押します)。
  2. 曲げ線のオレンジ色の帯の内側をクリックして選択します。
  3. 曲げ線はPropertiesパネルで編集できます。

定義した曲げは、基板を3Dモードで表示しているときに適用できます。5ショートカットを押すと、基板が折り曲げられます。3D Lockedチェックボックスがオンになっているリジッド基板領域が、3D表示モードでの物理的な基準面(Z = 0)になります。基板が期待どおりに折り曲げられない場合は、正しいリジッド領域の3D Lockedチェックボックスがオンになっていることを確認してください。別の基板領域でこのオプションをオンにする前に、現在の基板領域でオフにする必要はありません。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Nav
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents