PCB配置&編集テクニック

概略

この記事では、Altium DesignerにおけるPCBオブジェクトの配置と編集の基本的なワークフローを解説します。まずプリミティブオブジェクトとグループオブジェクトの違いを説明し、続いてオブジェクトの配置方法、配置前のデフォルト設定の調整方法、配置中にTabキーでプロパティを編集する方法、配置後にPropertiesパネルまたはダイアログでオブジェクトを変更する方法を紹介します。また、適切なレイヤーで作業することの重要性にも触れ、重なったオブジェクト、ネット、接続された銅箔、コンポーネント、配線済みの接続を効率よく扱うためのPCBエディターのオブジェクト選択コマンドを紹介します。PCBオブジェクトの配置、編集、選択を、より確実に、意図どおりに行うための実践的な概要を知りたい方は、ぜひ読み進めてください。

- プリミティブオブジェクトとグループオブジェクトの違いを理解し、その違いがPCBエディターでの配置や操作にどう影響するかを把握します。
- デフォルト設定、Propertiesへのアクセス、表示単位の切り替えなど、配置前、配置中、配置後の一般的な編集の流れを学びます。
- 重なったオブジェクト、論理的なネット階層、接続された銅箔、コンポーネントを基準とした配線の選択に役立つPCB選択コマンドを確認します。
AIでさらに深掘り:

PCBの設計に使用できるオブジェクトは多種多様です。PCBドキュメントに配置されるほとんどのオブジェクトは、銅箔領域または銅箔のない領域を定義します。これは、トラックやパッドなどの電気的オブジェクトにも、テキストや寸法などの非電気的オブジェクトにも当てはまります。そのため、各オブジェクトを定義する線の幅と、オブジェクトを配置するレイヤーに注意することが重要です。

PCBエディターには、プリミティブオブジェクトとグループオブジェクトの2種類のオブジェクトがあります。

  • プリミティブオブジェクトは設計の基本要素であり、トラック、パッド、ビア、フィル、アーク、テキストオブジェクトなどが含まれます。最も基本的な要素であることから、「プリミティブ」と呼ばれます。

  • プリミティブで構成され、設計オブジェクトとして識別されるものは、すべてグループオブジェクトです。グループオブジェクトの例として、コンポーネント、寸法、ポリゴンプアがあります。グループオブジェクトは、設計スペース内で単一のオブジェクトとして操作できます。たとえば、配置、選択、コピー、変更、移動、削除が可能です。

オブジェクトの配置と編集に共通する操作

Altium Designerでは、どのオブジェクトを配置する場合でも、配置の手順はほぼ同じです。基本的な手順は次のとおりです。

  1. いずれかのツールバーまたはPlace メニューから、配置するオブジェクトを選択します。

  2. マウスを使用して、PCBエディターの設計スペース内でオブジェクトの配置位置と、必要に応じてサイズを指定します。

  3. 右クリックするか、Escを押してコマンドを終了し、配置モードを終了します。

オブジェクトは現在のレイヤーに配置されます。配置する前に、正しいレイヤーが現在のレイヤーに設定されていることを確認してください。オブジェクトが属するレイヤーは、配置後に変更できます。

配置前の編集

オブジェクトのデフォルトプロパティは、Preferences ダイアログのPCBエディター – デフォルトページでいつでも変更できます。これらのプロパティは、以降に配置するオブジェクトに適用されます。

Primitives 列を使用してオブジェクトのプロパティにアクセスし、必要に応じてデフォルト値を編集します。
Primitives 列を使用してオブジェクトのプロパティにアクセスし、必要に応じてデフォルト値を編集します。

オブジェクトのデフォルト値は、既定ではADVPCB.dftファイルに保存されます。別の名前の.dftファイルに保存することもできます。.dftファイルを保存および読み込むためのコントロールが用意されているため、よく使うオブジェクトのデフォルト値を「セット」として作成できます。.dftファイルに保存される設定と、そこから読み込まれる設定は、すべてユーザー定義のデフォルト値です。必要に応じて、 Set To DefaultsまたはReset Allオプションを使用し、いつでも元のデフォルト値に戻すことができます。元のデフォルト値はハードコードされています。

配置中の編集

オブジェクトを最初に配置する際には、いくつかの属性を編集できます。これらの属性にアクセスするには、配置モードでTab キーを押して、対応するPropertiesパネルを開きます。Tab キーを押すと配置が一時停止し、オブジェクトに必要な編集を行えます。

パッドオブジェクトのプロパティダイアログの例。 
パッドオブジェクトのプロパティダイアログの例。

編集が完了したら、設計スペースに重ねて表示される一時停止ボタン( )をクリックして、配置を再開します。

この方法で設定した属性は、Preferences ダイアログのPCBエディター – デフォルトページにあるPermanent オプションが有効になっていない限り、以降に配置するオブジェクトのデフォルト設定になります。このオプションが有効な場合、変更は現在配置中のオブジェクトと、同じ配置セッション中に続けて配置するオブジェクトにのみ適用されます。

配置後の編集

配置済みのオブジェクトは、さまざまな方法で編集できます。それぞれの方法を以下に説明します。

対応するプロパティパネルまたはダイアログ

この編集方法では、対応するPropertiesパネルのモードとダイアログを使用して、配置済みオブジェクトのプロパティを変更します。

配置後は、次の方法で対応するダイアログにアクセスできます。

  • 配置済みのオブジェクトをダブルクリックします。

  • オブジェクトにカーソルを合わせて右クリックし、コンテキストメニューからPropertiesを選択します。

配置後は、次のいずれかの方法でPropertiesパネルの対応するモードにアクセスできます。

  • Propertiesパネルがすでにアクティブな場合は、オブジェクトを選択します。
  • オブジェクトを選択した後、設計スペースの右下にあるPanelsボタンからPropertiesパネルを選択するか、メインメニューからView » Panels » Propertiesを選択します。
PreferencesダイアログのPCBエディター – 一般ページでDouble Click Runs Interactive Propertiesオプションが無効(デフォルト)の場合、プリミティブをダブルクリックするか、選択したプリミティブを右クリックしてPropertiesを選択すると、ダイアログが開きます。Double Click Runs Interactive Propertiesオプションが有効な場合は、Propertiesパネルが開きます。
ダイアログとパネルのオプションは同じですが、オプションの順序や配置が多少異なる場合があります。
Ctrl+Qを押すと、パネル/ダイアログで現在使用されている測定単位を、メートル法(mm)とヤード・ポンド法(mil)の間で切り替えられます。これはパネル/ダイアログ内の測定値の表示にのみ影響し、基板に指定されている測定単位は変更されません。基板の測定単位は、設計スペース内でオブジェクトが選択されていない状態で、PropertiesパネルのUnits設定から指定します。

PCBオブジェクトの選択コマンド

PCBエディターには、標準のオブジェクト選択/選択解除コマンドに加え、オブジェクトの選択/選択解除操作を容易にする特殊なコマンドがいくつか用意されています。これらのコマンドには、メインメニューのEdit » SelectおよびEdit » DeSelectサブメニューからアクセスできます。選択コマンドには、Active Barのボタンメニューからもアクセスできます。

  • Select overlapped - 選択用のポップアップウィンドウを使わずに、同じ位置にある(重なっている)オブジェクト群の中から、次の設計オブジェクトを1つ選択します。選択は次の固定された優先順位に従い、コマンドを繰り返し実行すると、この順序で循環します。

    1. パッド
    2. ビア
    3. トラック/アーク
    4. コンポーネント
    5. ポリゴン
    6. リージョン/フィル
    7. テキスト

    また、Shift キーを使用して現在の選択にオブジェクトを追加している間は、Shift+Tabを使用すると、元の選択を維持したまま、重なっているオブジェクトの選択を順に切り替えられます。

    • このコマンドを使用するには、Preferencesダイアログの「PCB Editor - General」ページでDisplay popup selection dialog オプションが無効になっていることを確認してください。
    • 選択順序では、まず現在のレイヤーが優先され、その後、他のレイヤー上のオブジェクトが対象となります。
    • オブジェクトが重なっている領域をダブルクリックすると、常に選択用のポップアップウィンドウが表示されます。
  • Select next (ショートカット:Tab)- 設計内で最初のオブジェクトを選択した状態でこのコマンドを使用すると、論理階層に基づいて、1つ上の階層のオブジェクトが含まれるように選択範囲が拡張されます。次の循環的な論理選択の「フロー」がサポートされています。

    • トラックセグメント ---> 同一レイヤー上の接続された(連続する)すべてのトラック ---> 接続されたすべての銅箔 ---> 関連ネット内のすべての電気オブジェクト
    • 接続されたパッド ---> 同一レイヤー上の接続された(連続する)すべてのトラック ---> 接続されたすべての銅箔 ---> 関連ネット内のすべての電気オブジェクト
    • 未接続のパッド ---> 関連ネット内のすべての電気オブジェクト
    • ビア ---> ビアに関連するレイヤー上の接続された(連続する)すべてのトラック ---> 接続されたすべての銅箔 ---> 関連ネット内のすべての電気オブジェクト
    • 銅箔(リジョン/ポリゴンポア/フィル) ---> 接続されたすべての銅箔 ---> 関連ネット内のすべての電気オブジェクト
    • フリーパッド/ビア ---> パッドと同じレイヤー、またはビアに関連するレイヤー上の接続された(連続する)すべてのトラック ---> 接続されたすべての銅箔 ---> 関連ネット内のすべての電気オブジェクト。
    • コンポーネント ---> ビアファンアウト、エスケープ、相互接続

    Via Fanouts - パッドとビアが十分に短い配線で接続されており、そのビアに、より短い配線で接続された他のパッドがない場合、その配線とビアは、このパッドのFanoutと見なされます。

    Escapes - パッドに接続された十分に短いアンテナは、このパッドのEscapeと見なされます。

    Interconnect - すでに選択されている2つのオブジェクト(パッドやファンアウトビアなど)を接続する配線は、Interconnectと見なされます。

    さらに、この機能では、設計内の異なるネットにまたがって選択された複数のオブジェクトに対しても、選択範囲を拡張できます。

    最初に選択したトラックセグメントから、より上位の論理階層へと選択範囲を拡張する、複数ネットにまたがる選択の例。
    最初に選択したトラックセグメントから、より上位の論理階層へと選択範囲を拡張する、複数ネットにまたがる選択の例。

    このコマンドは、配線済みネットを選択する際に特に便利です。詳細については、配線を選択するための方法を参照してください。

  • Board - 定義された基板外形の境界内にあるすべてのオブジェクトを選択します。

  • Net - 特定のネットに関連するすべての電気オブジェクトを選択します。

    コマンドを実行した後、電気オブジェクトまたは接続をクリックすると、関連ネット内のすべての電気オブジェクトを選択できます。また、選択するネットの名前がわかっている場合は、設計内のオブジェクトがない領域をクリックすると、Net Nameダイアログが開きます。そこで目的のネット名を入力すると、ダイアログを閉じたときにそのネットが選択されます。ネット名が不明な場合は、?と入力してから OK をクリックすると、Nets Loadedダイアログが開き、設計に現在読み込まれているすべてのネットが一覧表示されます。

  • Connected Copper - 同一の銅箔に接続されているすべての電気オブジェクトを選択します。

  • Physical Connection - パッドオブジェクト間に物理的に配線されたすべてのトラックを選択します。トラック、パッド、またはビアをクリックすると、別のパッドまで連続するすべてのトラックが、途中のビアも含めて選択されます(パッド自体は選択に含まれません)。

  • Physical Connection Single Layer - 単一レイヤー上でパッドオブジェクト間に物理的に配線されたすべてのトラックを選択します。トラックまたはビアをクリックすると、同一レイヤー上で別のパッドまで連続するすべてのトラックが選択されます(パッドとビア自体は選択に含まれません)。

  • Component Connections - 指定したコンポーネントのパッドから延びるすべての配線接続(トラックとビアを含む)を、それぞれ次のパッドに到達するまで選択します。パッド自体は選択に含まれません。

    このコマンドは、配置済みコンポーネント上で右クリックし、コンテキストメニューから Component Actions » Select Component Connections コマンドを選択して実行することもできます。

  • Component Nets - 現在のドキュメントで、指定したコンポーネントに接続されているすべてのネット(およびそれらのネットに属するオブジェクト)を選択します。

    このコマンドは、配置済みコンポーネント上で右クリックし、コンテキストメニューから Component Actions » Select Component Nets コマンドを選択して実行することもできます。

  • Room Connections - 現在のドキュメントで、指定したルームの境界内に完全に収まる、パッド間のすべての配線接続を選択します。

    このコマンドは、配置済みルーム上で右クリックし、コンテキストメニューから Room Actions » Select Room Connections コマンドを選択して実行することもできます。

  • All on Layer - 現在のレイヤー上のすべてのオブジェクトを選択/選択解除します。

    コンポーネントが特定のレイヤーに配置されていても、DeSelect » All on Layer コマンドでは選択を解除できない場合があります。これは、コンポーネントを構成するすべてのプリミティブが同じレイヤーに配置されているとは限らないためです。たとえば、デジグネータとコメントのテキストはTop Overlayレイヤーに配置されていても、構成要素であるパッドはMulti-Layerに配置されている場合があります。
  • Free Objects - 設計内のすべてのフリープリミティブオブジェクトを選択します。コンポーネント、座標、寸法、長さチューニング、OLE、およびポリゴンポアの各オブジェクトはすべてグループオブジェクトであるため、このコマンドの影響を受けません。

  • All Locked - Locked プロパティが有効になっているすべての設計オブジェクトを選択します。

  • Off Grid Pads - 現在のスナップグリッド上に配置されていないすべてのパッドを選択します。

PCBエディタでは、Lasso Select / Lasso Deselectコマンドに次の2つの動作モードがあります。

  • Free-form - 実際の投げ縄のように、必要な設計オブジェクトを囲む選択領域をフリーハンドで描画できます。

  • Polyline - 多角形の「投げ縄」を使用するモードです。オブジェクトの選択をより正確に解除する必要がある場合は、フリーフォームモードよりもこちらのモードが適していることがあります。このモードは、コンポーネントが45度回転して配置されている設計や、必ずしも直交する形状ではないフレックス基板での作業に非常に便利です。

両方のモードを組み合わせて使用することで、選択解除領域を思いどおりに設定することもできます。 現在のモードはStatus Barに表示されます。 Spacebar を押すと、Free-formモードとPolylineモードを切り替えられます。

Lasso Select、Inside Area、Outside Area、Touching LineまたはTouching Rectangleコマンドの使用中にCtrl キーを押し続けると、コンポーネントオブジェクトのプリミティブを対象にできます。

グラフィカル編集

この編集方法では、デザインスペース内に配置されたオブジェクトを直接選択し、サイズ、形状、位置をグラフィカルに変更できます。形状やサイズの変更(対応している場合)は、オブジェクトを選択すると表示される編集「ハンドル」を使用して行います。


選択したフィルオブジェクトの編集ハンドルの例。

オブジェクト上の編集ハンドル以外の場所(ハンドルがある場合)をクリックしてドラッグすると、オブジェクトの位置を変更できます。オブジェクトの種類によっては、ドラッグ中に回転や反転もできます。

  • Spacebar を押すとオブジェクトが反時計回りに回転し、Shift+Spacebarを押すと時計回りに回転します。回転は、PreferencesダイアログのPCB Editor – Generalページで定義されたRotation Stepの値に従います。
  • Lキーを押すと、オブジェクトを基板の反対側の面に反転できます(対応している場合)。
  • X キーまたはY キーを押すと、オブジェクトをX軸方向またはY軸方向に反転できます(対応している場合)。
  • Altキーを押すと、最初に移動した方向に応じて、移動方向を水平軸または垂直軸に制限できます。
  • Ctrl キーを押しながら矢印キーを押すと、オブジェクトを少しずつ移動できます(現在のスナップグリッド値に従います)。Ctrl+Shiftキーを押しながら矢印キーを押すと、より大きな単位(スナップグリッド値の10倍)で移動できます。

選択した複数のオブジェクトをドラッグするときに表示されるプリミティブの数は、Advanced SettingsダイアログのPCB.Rendering.MultiselectionDragオプションで制御されます(デフォルト値は500)。

移動コマンド

オブジェクトの位置は、メインメニューのEdit » Moveサブメニュー、またはActive Barの移動サブメニューにあるコマンドで変更できます。

  • Move - このコマンドは、現在のドキュメント内の任意のオブジェクトを移動するために使用します。オブジェクトに関連付けられたネットの接続は維持され、移動時には接続線がオブジェクトに追従します(表示の有無は、現在有効な接続モードに従います)。オブジェクトに接続されている配線済みトラックは移動しません。

  • Drag - このコマンドは、現在のドキュメント内の任意のオブジェクトを移動するために使用します。オブジェクト(コンポーネント、パッド、ビアなど)にトラックやアークが接続されている場合、オブジェクトを移動してもこれらの接続は維持されます。

    • 接続されたトラックをコンポーネントと一緒に移動するには、PreferencesダイアログのPCB Editor - Generalページで、Comp DragモードをConnected Tracksに設定する必要があります。このモードがNoneに設定されている場合、このコマンドは基本的な移動コマンドと同じように動作します。
    • Comp DragモードをConnected Tracksに設定してこのコマンドでコンポーネントをドラッグする場合、回転と反転のキーコマンドは使用できなくなります。また、スマート移動機能(動的な位置合わせと押しのけ)も使用できません。
  • Component - このコマンドでは、現在のドキュメント内のコンポーネントを移動できます。コマンドを実行したら、デザイン内で移動するコンポーネントをクリックし、目的の位置に移動してクリックします。または、デザインスペース内のオブジェクトがない場所をクリックして、Choose Componentダイアログを開きます。このダイアログで移動するコンポーネントを探し(コンポーネントの位置へジャンプするか、コンポーネントをカーソル位置に呼び出します)、上記と同じ方法で再配置します。この機能は、対象コンポーネントがnotロックされている場合にのみ動作することに注意してください。

    デザインスペース内のコンポーネント上で右クリックし、コンテキストメニューからComponent Actions » Move Componentコマンドを選択しても、このコマンドを実行できます。

    詳細は、コンポーネントの配置を参照してください。
  • Move Selection - このコマンドでは、現在のドキュメントで選択されているオブジェクトを手動で再配置できます。選択内のオブジェクトに関連付けられたネットの接続は維持され、移動時には接続線がオブジェクトに追従します(表示の有無は、現在有効な接続モードに従います)。オブジェクトに接続されている配線済みトラックは移動しません。

  • Move Selection by X, Y - このコマンドは、現在選択されているオブジェクトをX方向やY方向に正確な量だけオフセットするために使用します。コマンドを実行すると、Get X/Y Offsetsダイアログが開きます。このダイアログで、選択範囲を移動する量をデルタXやデルタYの値として指定します。

    このコマンドは、デザインスペース内で少なくとも1つのオブジェクトが選択されている場合にのみ使用できます。

    Get X/Y Offsetsダイアログ
    Get X/Y Offsetsダイアログ

  • Rotate Selection - このコマンドは、デザインスペースで選択したオブジェクトを、指定した回転角度で反時計回りまたは時計回りに回転させるために使用します。コマンドを実行すると、Rotation Angle (Degrees) ダイアログが開きます。必要な回転角度を 0.001°~360.00° の範囲で入力します(分解能は 0.001°)。反時計回りに回転させる場合は正の値を、時計回りに回転させる場合は負の値を入力します。OK をクリックしてダイアログを閉じ、カーソルを移動してクリックし、回転の基準点を指定します。選択したオブジェクトが、基準点を中心に入力した角度だけ回転します。

    Rotation Angle ダイアログ
    Rotation Angle ダイアログ

  • Flip Selection - 選択したオブジェクトを水平方向(Y 軸を中心)に反転させ、基板の反対側の対応するレイヤーに移動します。たとえば、Top Layer 上のオブジェクトは Bottom Layer に、Top Overlay 上のオブジェクトは Bottom Overlay に反転されます。

    • 反転操作を行うと、デジグネーターとコメントのテキストは鏡像になります。

    • Multi-Layer 上に存在するパッドの場合、反転すると、実質的に XY サイズの組み合わせと形状の順序が逆になります。そのため、Top-Middle-Bottom スタイルを使用していて、初期の形状が Round-Rectangle-Octagonal の場合、反転によってスタックの順序が逆になり、上から順に形状が Octagonal-Rectangle-Round になります。

    • 複数のオブジェクトが選択されている場合、選択したオブジェクト群の幾何学的中心を基準に反転します。

    選択したオブジェクトは、いずれかの位置がロックされていない限り、警告なしですべて反転されることに注意してください。位置がロックされたオブジェクトがある場合は、Confirm ダイアログが表示され、反転する前に確認を求められます。

整列コマンド

オブジェクトは、整列状態を変更することでも移動できます。オブジェクトをほかのオブジェクトに揃えるには、選択したオブジェクトを右クリックし、Align を選択します。または、メインメニューの Edit » Align サブメニュー、もしくは Active Bar の整列サブメニューを使用します。整列サブメニューには、選択したオブジェクトを配置するための各種オプションが用意されています。

整列コマンドで移動するのは、選択したオブジェクトのうち移動可能なものだけです。ロックされたオブジェクトは移動しません。

Align コマンドを使用すると、Align Objects ダイアログが開きます。このダイアログには、現在選択されているデザインオブジェクト群を、必要に応じてすばやく整列するためのコントロールが用意されています。ダイアログで、選択したオブジェクトの Vertical および/または Horizontal の整列オプションを必要に応じて設定し、OK をクリックして整列を実行します。

Align Objects ダイアログ
Align Objects ダイアログ

  • Horizontal と Vertical の両方のオプションを同時に有効にすると、競合が発生し、選択したオブジェクトが互いに重なり合う場合があります。
  • Space equally オプションを使用すると、移動したオブジェクトがグリッドから外れる場合があります。

Position Component Text コマンドは、Component Text Position ダイアログを開くために使用します。このダイアログでは、現在のドキュメントで選択されている 1 つ以上のコンポーネントについて、デジグネーターやコメントのテキスト位置を変更できます。

Component Text Position ダイアログ
Component Text Position ダイアログ

このダイアログは、大きく分けてデジグネーターとコメントのテキスト用の 2 つの領域で構成されています。どちらの領域でも、コンポーネントの図を使って、選択した位置に応じてテキストがどこに表示されるかを確認できます。テキストには、次の 9 種類の配置スタイルを使用できます。これらはすべて「自動位置」に分類され、コンポーネントを移動または回転しても、テキストは選択した位置を維持します。

  • Left-Above
  • Left-Center
  • Left-Below
  • Center-Above
  • Center
  • Center-Below
  • Right-Above
  • Right-Center
  • Right-Below

テキストを変更せず現在の位置に残すには、No Change オプションを有効にしたままにします。

  • デジグネーターとコメントのテキスト位置は、Properties パネルの Properties セクションからも変更できます。デジグネーター/コメント、または親コンポーネントを選択すると、これらのプロパティが表示されます。デジグネーター/コメントの現在のレイヤー、位置、回転をテキストで要約している該当のコントロールをクリックし、ポップアップウィンドウの Autoposition プロパティを必要に応じて設定します。
  • デジグネーター/コメントのテキストを自由に配置し、親コンポーネントの移動や向きの変更に追従させるには、Properties パネルでプロパティを設定する際に、Autoposition プロパティのスタイルとして Manual を選択します。ワークスペース内でテキストを直接クリックしたまま、目的の位置までドラッグすることもできます。この場合、Autoposition プロパティは自動的に Manual に切り替わります。

Align Left / Align Right / Align Top / Align Bottom コマンドを使用すると、選択したデザインオブジェクトを、それぞれ左端/右端/上端/下端で揃えることができます。コマンドを実行すると、最も左/右/上/下にあるオブジェクトの左端/右端/上端/下端が基準となり、選択したほかのすべてのオブジェクトが左/右/上/下に移動して、左端がこの基準に揃えられます。

Align Left (maintain spacing) / Align Right (maintain spacing) / Align Top (maintain spacing) / Align Bottom (maintain spacing) コマンドを使用すると、適用されるデザインルールに従って適切な間隔を維持しながら、選択した設計オブジェクトの左端/右端/上端/下端を揃えることができます。コマンドを実行すると、最も左/右/上/下にあるオブジェクトの左端/右端/上端/下端が基準となり、選択した他のすべてのオブジェクトが左/右/上/下に移動して、その端がこの基準に揃います。 各オブジェクトは、適用されるクリアランスルールで許容される範囲内で、基準オブジェクトにできるだけ近づくように左/右/上/下に移動します。

Align Horizontal Centers / Align Vertical Centers コマンドを使用すると、選択したオブジェクトを水平方向/垂直方向の中心で揃え、1列/1行に配置できます。コマンドを実行すると、カーソルが十字に変わり、選択中のオブジェクトのいずれかを指定するよう求められます。対象のオブジェクトをクリックしてください。このオブジェクトが基準オブジェクトになります。選択中の他のすべてのオブジェクトは、この基準オブジェクトに対して移動し、水平方向/垂直方向の中心が揃えられます。

Distribute Horizontally / Distribute Vertically コマンドを使用すると、選択したオブジェクトの水平方向/垂直方向の間隔を均等にできます。 コマンドを実行すると、選択範囲の最も左と右/最も上と下のオブジェクトはその位置に固定され、他のすべてのオブジェクトがその間に等間隔で配置されます。オブジェクトの垂直方向/水平方向の位置は変更されません。

Increase Horizontal Spacing / Increase Vertical Spacing コマンドを使用すると、選択したオブジェクトの水平方向/垂直方向の間隔を広げることができます。 コマンドを実行すると、最も左/下のオブジェクトはその位置に固定され、選択中の他のオブジェクトは右/上に移動します。隣接するオブジェクトの基準点間の水平/垂直距離が、デフォルトの Global Board Snap Grid の Step X / Step Y フィールドで指定された量だけ増加するように移動します。

Decrease Horizontal Spacing / Decrease Vertical Spacing コマンドを使用すると、選択したオブジェクトの水平方向/垂直方向の間隔を狭めることができます。 コマンドを実行すると、最も左/下のオブジェクトはその位置に固定され、選択中の他のオブジェクトは左/下に移動します。隣接するオブジェクトの基準点間の水平/垂直距離が、デフォルトの Global Board Snap Grid の Step X / Step Y フィールドで指定された量だけ減少するように移動します。

Align To Grid コマンドは、選択したコンポーネントを、適用対象となる変更済みのスナップグリッド上の最も近い点に移動するために使用します。 コマンドを実行すると、選択した各コンポーネントの基準点が、適用されるスナップグリッド上の最も近い点に移動します。

Move All Components Origin To Grid コマンドは、すべてのコンポーネントの基準点を現在のスナップグリッド上に移動するために使用します。 コマンドを実行すると、設計スペース内でパッドがグリッド上にあるすべてのコンポーネントが移動し、その基準点が現在のスナップグリッドに揃えられます。デフォルトでは、移動したコンポーネントと移動しなかったコンポーネントの詳細を示すレポート(Move Component(s) Origin To Grid - <PCBDocumentName>.html)が自動的に生成され、アクティブなドキュメントとして開かれます。

  • 生成および表示するレポートの形式は、Preferences ダイアログの PCB Editor - Reports ページで設定できます。
  • 適用されるスナップグリッドは、Properties パネルの Grid Manager セクションで必要に応じて設定できます。
現在パッドがグリッドから外れているコンポーネントは移動しないことに注意してください。

PCB List パネルを使用する

PCB List パネルでは、設計オブジェクトを表形式で表示し、オブジェクトの属性をすばやく確認、変更できます。PCB Filter パネルと併用すると、アクティブなフィルターの対象範囲に含まれるオブジェクトだけを表示できるため、複数の設計オブジェクトをより正確かつ効率的に絞り込み、編集できます。

アクティブレイヤーの選択

アクティブレイヤーとは、オブジェクトを配置するレイヤーです。 設計スペース下部にある該当レイヤーのタブをクリックするか、View Configuration パネルの Layers & Colors タブにある Layers 領域の Active Layer ドロップダウンを使用して、現在表示されているレイヤーからアクティブレイヤーを選択できます。

次のショートカットを使用して、アクティブレイヤーをすばやく選択することもできます。

  • * (テンキー)– 次の有効な信号レイヤーに切り替えます。
  • Shift+* (テンキー)– 前の有効な信号レイヤーに切り替えます。

    このコマンドは、エディターが2D表示モードの場合にのみ使用できます。3Dモードでは、Shift キーは方向球へのアクセスに使用されます。
  • + (テンキー)– 次の有効なレイヤーに切り替えます。
  • - (テンキー)– 前の有効なレイヤーに切り替えます。
マルチレイヤーに配置されたオブジェクトは、すべての信号レイヤーに自動的に表示されます。

切り取り/コピーと貼り付けの使用

PCBエディターでは、同じPCBドキュメント内、または異なるPCBドキュメント間でオブジェクトを切り取り/コピーして貼り付けることができます。たとえば、あるPCBのコンポーネントを別のPCBドキュメントにコピーできます。オブジェクトをWindowsクリップボードに切り取り/コピーして、他のドキュメントに貼り付けることもできます。

2D Layout Mode を使用する場合は、切り取り/コピーするオブジェクトを選択し、メインメニューから Edit » Cut (Ctrl+X) / Edit » Copy (Ctrl+C) をクリックするか、右クリックメニューから Cut/Copy コマンドを選択します。 カーソルが十字に変わり、基準点を選択するよう求められます。これは選択したオブジェクトに対する相対座標で、貼り付けコマンドを使用する際に、選択したオブジェクトを正確に配置するために使用されます。

3D Layout Mode でコピーコマンドを使用すると、設計スペースの現在の表示がビットマップ形式でクリップボードにコピーされます。続いて開く 3D Snapshot Resolution ダイアログで、コピーする画像の解像度を設定できます。

現在選択されている設計オブジェクトをテキスト形式でクリップボードにコピーするには、メインメニューのEdit » Copy As Text コマンドを使用します。この情報は、任意のテキストフィールドや外部のテキストドキュメントに貼り付けることができます。クリップボードにコピーされる詳細情報には、次のものが含まれます。

  • オブジェクトの種類。
  • デジグネータとコメント(コンポーネントオブジェクトの場合)。
  • 設計スペース内のオブジェクトの位置。
  • オブジェクトが配置されているレイヤー(ビアの場合は開始レイヤーと終了レイヤー)。

コンポーネントをテキストとしてクリップボードにコピーした例を以下に示します。

Component Y1-25MHz (100.6mm,1.5mm) on Top Layer

トラックとビアをテキストとしてクリップボードにコピーした例を以下に示します。

Track (20mm,6mm)(80mm,6mm)  Top Layer
Via (45mm,6mm) Top Layer to Bottom Layer

最後に切り取りまたはコピーしたクリップボードの内容をアクティブなドキュメントに配置するには、メインメニューから Edit » Paste コマンドを選択するか、設計スペース内で右クリックしてコンテキストメニューから Paste コマンドを選択します(ショートカット: Ctrl+V)。 クリップボードの最新の内容がカーソルに追従して表示されます。内容に対するカーソルの相対位置は、 Cut または Copy を使用して選択内容をクリップボードに追加したときに指定した基準点によって決まります。

Pasteコマンドを使用すると、エディターで現在アクティブに設定されているレイヤーに関係なく、コピー元のオブジェクトと同じレイヤーにオブジェクトが貼り付けられます。

対応するOLEアプリケーションからコピーしたテキストを、開いている任意のPCBドキュメントに配置するには、メインメニューのEdit » Paste Text コマンドを使用します。テキストは、単一のOLEオブジェクトではなく、PCB文字列オブジェクトに変換されて貼り付けられます。対応するファイル形式には、 CSV および XLS 形式のスプレッドシートや、 DOC および RTF 形式のワープロ文書など、汎用的な形式が含まれます。

設計スペースに貼り付ける際の特定のオブジェクト属性の扱いを制御するには、メインメニューの Edit » Paste Special コマンドを使用します。 このコマンドを実行すると、Paste Specialダイアログが開きます。

Paste Specialダイアログ
Paste Specialダイアログ

貼り付ける内容に応じて、次の属性を制御できます。

  • コピー元のオブジェクトと同じレイヤーに貼り付けるデフォルトの動作ではなく、現在のレイヤーにオブジェクトを貼り付けることができます。

    Alt+Insertキーボードショートカットを使用して、設計スペースで現在のレイヤーに内容を直接貼り付けることもできます。
  • 割り当てられているネット名を保持できます。
  • デジグネータを重複させることができます(貼り付けるコンポーネントの場合)。
  • 貼り付けるコンポーネントを、コピー元のコンポーネントと同じコンポーネントクラスに追加できます。

必要に応じてオプションを設定し、Paste ボタンをクリックして貼り付け操作を開始します。

Paste SpecialダイアログのPaste Arrayボタンをクリックすると、Setup Paste Arrayダイアログが開き、クリップボード内のオブジェクトの複数のコピーを現在のドキュメントに貼り付けることができます。

Setup Paste Arrayダイアログ
Setup Paste Arrayダイアログ

このダイアログに適切な値を入力し、OK をクリックして配列を配置します。

  • 直線配列を配置する場合は、配列の開始点を選択するよう求められます。カーソルを配置位置に移動し、クリックするか Enter を押して配列を配置します。
  • 円形配列を配置する場合は、配列の中心点、続いて配列の開始点を選択するよう求められます。それぞれの位置にカーソルを合わせ、クリックするか Enter を押して配列を配置します。オブジェクトは、指定した中心点の周りに反時計回りに配置されます。
配列の開始点には、Cut または Copy を使用して選択範囲をクリップボードに追加した際に指定した基準点が配置されます。そのため、切り取りやコピーの際には、基準点を適切に指定しておくことをお勧めします。そうしないと、配列の貼り付け時に予期しない結果が生じる場合があります。

選択した1つ以上のオブジェクトをコピーし、現在のドキュメント内の必要な場所に複数回貼り付けるには、メインメニューの Edit » Duplicate コマンド(ショートカット:Ctrl+R)も使用できます。コマンドを実行すると、カーソルが十字に変わり、複製モードになります。手順は次のとおりです。

  1. まず、基準点を選択するよう求められます。これは、選択範囲を貼り付ける際の基準となる点です。選択範囲の近くの目的の位置にカーソルを移動し、クリックするか Enter を押します。選択範囲のコピーがカーソルに追従して表示されます。
  2. デザインスペース内の目的の位置にカーソルを移動し、クリックするか Enter を押してコピーを配置します。
  3. 選択範囲の次のコピーがカーソルに追従して表示され、配置できる状態になります。
  4. スタンプを押すように、コピーした選択範囲を引き続き配置します。終了するには、右クリックするか Esc を押します。

このコマンドは、オブジェクトのコピーと貼り付けに使用するものです。そのため、グループオブジェクトの子オブジェクトを複製することはできません。

デザインオブジェクトのロック

デザインオブジェクトの Locked 属性を有効にすると、PCBドキュメント上で移動や編集ができないようにロックできます。たとえば、特定のオブジェクトの位置やサイズが重要な場合は、それらをロックしてください。以下の例のように、Properties パネルで対象のオブジェクトの南京錠アイコン()をクリックするとロックできます。 

選択したコンポーネントとパッドについて、Properties  パネルに表示される Lock  アイコンの例。 
選択したコンポーネントとパッドについて、Properties パネルに表示される Lock アイコンの例。

Locked  プロパティを持つ配置済みオブジェクトの Locked  プロパティの状態を切り替えるには、デザインスペースでオブジェクトを右クリックし、コンテキストメニューから <ObjectType> Locked コマンドを選択することもできます。オブジェクトがすでにロックされている場合は、メニューのコマンドの左側にチェックマークが表示されます。

Locked プロパティが有効になっているデザインオブジェクトを移動または回転しようとすると、編集を続行するかどうかを確認するダイアログが表示されます。

Preferences ダイアログの PCB Editor – General ページで Protect Locked Objects オプションが有効になっており、デザインオブジェクトがロックされている場合、そのオブジェクトは選択もグラフィカルな編集もできません。このオブジェクトをグラフィカルに編集するには、Properties パネルの Lock アイコンを使用してロックを解除するか、Protect Locked Objects オプションを無効にしてください。

Protect Locked Objects オプションが有効になっている場合、ロックされたオブジェクトを他のオブジェクトと一緒に選択しようとしても、ロックされていないオブジェクトだけが選択され、グループとして移動できます。

コンポーネントプリミティブのロック

PCBコンポーネントのプリミティブがロックされている場合(PropertiesパネルのComponentモードにある Primitives オプションが  の状態)、これらのプリミティブのすべて、または大部分のプロパティは、グラフィカルな編集方法(ドラッグ&ドロップなど)でも、非グラフィカルな編集方法(Properties パネルや List パネルの使用など)でも変更できません。これにより、組み立て用および製造用の出力に誤りを生じさせる可能性のある、コンポーネントプリミティブの意図しない変更を防止できます。

PCBコンポーネントプリミティブの変更を防止する機能を有効または無効にするには、Preferences ダイアログの PCB Editor – Generalページにある Protect Locked Primitives In Component オプションを使用します。

例として、プリミティブがロックされたPCBコンポーネントの構成要素であるパッドについて、PropertiesパネルのPadモードを下の画像に示します。パッドのすべてのプロパティ(Net と Testpoint を除く)がグレー表示になっており、編集できません。また、パッドの Component の右端には  アイコンが表示されています。フィールド。これは、親コンポーネントのプリミティブがロックされており、パッドのプロパティを変更できないことを示します。

プリミティブがロックされたPCBコンポーネントのパッド(右)に対する、PropertiesパネルのPadモード(左)。
プリミティブがロックされたPCBコンポーネントのパッド(右)に対する、PropertiesパネルのPadモード(左)。

リエントラント編集

PCBエディターには、re-entrant editingと呼ばれる強力な機能があります。この機能を使用すると、現在の操作を終了せずに、キーボードショートカットで別の操作を実行できます。リエントラント編集により、より柔軟かつ直感的に作業できます。たとえば、トラックの配置を開始した後で、別のトラックセグメントを削除する必要があることに気づいたとします。この場合、インタラクティブ配線モードを終了する必要はありません。ショートカットキーE、Dを押し、必要なトラックセグメントを削除してから、Esc キーを押すと、設計のインタラクティブ配線に戻れます。

PCBカーソルの外観の設定

デフォルトでは、PCBカーソルは小さな緑色の90度の十字に設定されています。これは、Preferences ダイアログのPCB Editor – GeneralページにあるCursor Type およびCursor Colorの設定で変更できます。たとえば、設計ウィンドウの端まで伸びる大きな90度の十字(Large 90オプション)は、設計オブジェクトの配置や位置合わせに役立ちます。また、90度の十字がグリッド線と重なって見づらい場合は、45度の十字(Small 45オプション)が役立つことがあります。

TrueTypeフォントのサポート

PCBエディターでは、設計内のテキスト関連オブジェクト(文字列/テキストフレーム、寸法、ドリルテーブル、レイヤースタックテーブル)に、ストロークベースのフォントまたはTrueTypeフォントを使用できます。フォントは、対応するProperties パネルで選択します。ストロークベースのフォントには、Default、Sans Serif、Serifの3つの選択肢があります。Defaultスタイルは、ペンプロッティングとベクターフォトプロッティングをサポートするシンプルなベクターフォントです。Sans SerifおよびSerif フォントはより複雑で、Gerberなどのベクター出力の生成に時間がかかります。ストロークベースのフォントはソフトウェアに組み込まれており、変更できません。3つのフォントはいずれも、英語およびその他のヨーロッパ言語をサポートするIBM拡張ASCII文字セット全体を備えています。TrueTypeフォントを使用する場合は、\Windows\FontsフォルダーにあるTrueTypeおよびOpenType(TrueTypeのスーパーセット)フォントを使用できます。また、この機能はUnicodeを完全にサポートしています。

使用できるのは、検出された、一意の名前を持つルートフォントのみです。たとえば、ArialとArial Blackは使用できますが、Arial Bold と Arial Bold Italic は使用できません。

TrueTypeフォントを使用するテキストオブジェクトの形状データは、PCBドキュメント内に自動的に保存されます。PCBドキュメント内のオブジェクトがTrueTypeフォントを使用している場合、そのPCBドキュメントを別のコンピューターで開いても、該当するTrueTypeフォントがインストールされているかどうかにかかわらず、同じフォント形状で表示されます。

見つからないフォントを使用しているオブジェクトを選択すると、Propertiesパネルの上部に警告メッセージが表示されます。テキストに影響するオブジェクトのプロパティ(テキストの高さやテキスト自体など)を変更すると、Missing fontsダイアログが開き、代替フォント(Replacement)を選択できます。Apply to all text elements オプションを有効にすると、見つからないフォントを使用しているPCBドキュメント内のすべてのオブジェクトに代替フォントが適用されます。

このダイアログは、PCB Listパネルからテキスト関連のプロパティを変更する場合にも表示されます。

異なる見つからないフォントを使用している複数のオブジェクトを編集しようとすると、このダイアログで、見つからないフォントごとに代替フォントを選択できます。

TrueTypeフォントを使用するテキストオブジェクトの形状データをPCBドキュメント内に自動保存する機能は、詳細設定ダイアログで PCB.Text.TTFontSaving オプションが有効になっている場合に使用できます。このオプションが無効の場合は、TrueTypeフォントを埋め込むようにAltium Designerを設定できます。Preferences ダイアログのPCB Editor – TrueType Fontsページ(詳細設定ダイアログで PCB.Text.TTFontSetting.Hide オプションが無効になっている場合に使用可能)には、設計の保存時にTrueTypeフォントを埋め込むためのEmbed TrueType fonts inside PCB documentsオプションと、設計の読み込み時に選択したフォント置換を適用するためのSubstitution fontオプションがあります。

フォントの埋め込みは、設計を読み込む対象コンピューターにそのフォントがあるかどうかにかかわらず、指定したフォントでテキストを表示する必要がある場合に便利です。フォント置換では、フォントが埋め込まれておらず、設計を読み込むコンピューター上にもそのフォントがない可能性がある場合に、代わりに使用するTrueTypeフォントを指定できます。

真の円弧の描画をサポート

この機能はオープンベータであり、詳細設定ダイアログでPCB.Rendering.DrawArcBaseGeometryオプションが有効になっている場合に使用できます。

Note: 真の円弧を描画するには、Advanced Settingsダイアログで PCB.Polygon.AdvancedPour オプションも有効にする必要があります。

PCBエディターとPCBライブラリエディターの両方の設計スペースで生成される円弧について、近似ではなく真の円弧がサポートされます。このサポートは、2D/3Dレイアウトモード(PCBエディターでは基板プランニングモードも含む)全体に適用されます。真の円弧の描画は、次の領域で確認できます。

  • ポリゴンポア(ソリッド、ハッチング、なし)

  • ポリゴンポアのカットアウト

  • ポリゴンポアとリージョンの選択輪郭

  • リージョン

  • ソルダーマスクとペーストマスクの拡張

  • ネットのハイライト

  • クリアランス境界

  • 違反のオーバーレイ(リージョンまたはポリゴンポア上の別のポリゴンポア)

PCB上の他のオブジェクトの周囲に注がれたポリゴンポアにおける、真の円弧の描画例を以下に示します。

 

ネット情報

PCB上の銅箔オブジェクト(トラック、ビア、ポリゴンなど)を選択すると、PropertiesパネルのNet Information領域に次の情報が表示されます。

  • 親のNet、Diff Pair、xSignal、およびそれぞれに関連付けられたクラス。なお、Diff PairとxSignal の項目は、オブジェクトがそれぞれ差動ペアまたはxSignalの一部である場合にのみ表示されます。
  • Delay – 選択したオブジェクトの遅延、およびネット全体の配線済みセグメントの遅延。パッドとビアにPropagation Delayの値が定義されている場合は、それらの値も含まれます。

    ビアの伝搬遅延は、使用されているビアの長さに比例して計算されます。この機能は、詳細設定ダイアログで PCB.Delay.Via オプションを有効にすると使用できます。PCB.Delay.Via オプションが無効の場合は、ビアのプロパティで定義された Propagation Delay の値が使用されます。

  • Length – 選択したオブジェクトの長さの合計と、Signal Length の合計です。Signal Length は、ノード間の総距離を正確に計算した値です。配置されたオブジェクトを解析し、積み重なったオブジェクトや重複するオブジェクト、パッド内で迂回する経路を考慮します。また、ビアの長さも含まれます。パッドに Pin Package Length が定義されている場合は、それも含まれます。ネットの配線が完了していない場合は、接続線のマンハッタン距離(X + Y)も含まれます。信号長とその用途の詳細については、PCB - Netsパネルの情報を参照してください。

    • 総延長には、ネットの未配線部分の推定長(接続線のマンハッタン距離(X + Y))が含まれますが、総遅延には含まれません。
    • 定義済みの Supply Netsデザインルールの対象となるネット(または、そのルールで使用されるネットクラスに属するネット)の Delay と Length は計算されません。
  • Max Current - 選択した トラック、アーク、または ビアオブジェクトに流せる最大電流で、IPC-2221Aの式(セクション6.2)から求められます。  

    I = k * ΔT0.44 * A0.725

    ここで:

    I = 電流 [A]
    A = 断面積 [平方mil](配線幅 * レイヤースタックの銅箔厚、または下図に示す Abarrel)
    ΔT = 周囲温度に対する許容温度上昇 [°C]
    k = 定数。値は次のとおりです。

    k = 外層の場合は0.048
    k = 内層の場合は0.024

    ネット全体など、複数のオブジェクトを選択した場合、そのネットの最大電流は、選択した各オブジェクトの最大電流値のうち最小の値になります。

  • Resistance - 選択したトラック、アーク、ビアオブジェクトの抵抗の合計で、次の導出式から求められます。

    R = (ρ * L / A) 

    ここで:

    R = 抵抗 [Ω]
    ρ = 銅の抵抗率 [Ω*mm2/m]
    L = 配線長 [m] (または、後述のビア長)
    A = 断面積 = T * W [mm2] (または下図に示す Abarrel)
    T = 配線の厚さ(レイヤースタックから取得)[mm]
    W = 配線幅 [mm]

    Assumptions:

    • 周囲温度 = 22 °C
    • 許容温度上昇 = 20 °C
    • スルーホールの銅壁厚 = 0.018mm 
    • 銅の抵抗率 = 0.017 Ω*mm2/m

    選択したオブジェクトの総抵抗は、各オブジェクトの抵抗の合計です。

Via Barrel Cross-Sectional Area - 次のように求められます。

Abarrel = AViaHoleSize - AFinishedHoleSize

Abarrel = [ π * (ViaHoleSize/2)2 ] - [ π * ((ViaHoleSize - 2 * ViaWallThickness)/2)2 ]

Abarrel = π (ViaHoleSize * ViaWallThickness - ViaWallThickness2)

Via Length = 上図に示す、入口側レイヤーの中心から出口側レイヤーの中心までの距離

Notes - これらの計算で使用するビア長は、ビアがネットに属しているかどうか、および接続されたトラックが使用するレイヤーによって異なります。ネットが割り当てられていないビアを選択すると、レイヤーの中心間の長さではなく、レイヤーの端から端までの長さが表示されます。また、ネットが割り当てられていても、接続されたトラックがないビアは、長さがゼロと表示されます。

Properties パネルの Net Information 領域。ここでは、選択したトラックの例を示しています。
Properties パネルの Net Information 領域。ここでは、選択したトラックの例を示しています。

Net Information 領域のリンクをクリックすると、関連するネット/差動ペア/xSignalが PCBパネルで開きます。

オブジェクトへのネットの割り当て

PCBエディターには、プリミティブオブジェクトにネットを割り当てる方法がいくつかあります。

  • 1つ以上のオブジェクトを選択した状態で、Properties パネルの Nets フィールドのドロップダウンを使用します。 アクティブな基板デザインのすべてのネットがドロップダウンリストに表示されます。 No Net を選択すると、トラックがどのネットにも接続されていないことを指定できます。また、Assign Net アイコン()をクリックしてデザインスペース内のオブジェクトを選択すると、そのオブジェクトのネットが選択中のオブジェクトに割り当てられます。
  • 選択した1つ以上のオブジェクト上で右クリックし、Net Actions  » Assign Net を選択します。 コマンドを実行すると、十字カーソルが表示されます。オブジェクトを割り当てたいネットに十字カーソルを合わせ、クリックしてそのネットを選択します。
  • 配線プリミティブのネット名を、接続先のパッドのネット名に再同期するには、メインメニューから Design » Netlist » Update Free Primitives From Component Pads コマンドを選択します。コマンドを実行すると、フリープリミティブのネットをコンポーネントパッドのネットで更新するかどうかを確認するダイアログが開きます。Yes をクリックすると、各パッドを起点として接続された銅箔が選択され、各プリミティブのネット名がパッドのネット名と一致するように設定されます。この操作は、PCB内部のネットリストには影響しません。

物理的に接続されているオブジェクトに、その物理ネットに属する正しいネットが割り当てられていることを確認するには(ここでは physical net は connected copper を意味します)、メインメニューから Design » Netlist » Configure Physical Nets コマンドを選択して開く Configure Physical Nets ダイアログを使用できます。ソフトウェアは設計を解析し、すべてのパッドと、それらを物理的に接続するオブジェクト(トラック、アーク、フィルなど)に同じネット名が割り当てられているかを確認します。ネット内のすべてのオブジェクトが正しく設定されている場合、そのネットは緑色で表示されます。接触しているにもかかわらず異なるネットが割り当てられているオブジェクトが検出されると、それらは赤色で示されます。このような状況が発生する一般的な例として、コンポーネントのフットプリント内に追加の銅箔オブジェクトが含まれている場合があります。このフットプリントが同期中に読み込まれると、各パッドには割り当てられたネット名が適用されますが、追加の銅箔には適用されません。このダイアログは対話式で、ネットまたはプリミティブをクリックすると、そのオブジェクトにクロスプローブできます。右クリックするか、Menu ボタンをクリックすると、使用可能なコマンドにアクセスできます。ダイアログの Action 領域には、接続された銅箔の問題を解決するために必要なアクションを指定するコントロールがあります。デフォルトではアクションが自動設定されますが、必要に応じて調整できます。アクションを設定したら、Execute ボタンをクリックしてネットの割り当てを更新します。

このダイアログでは、デフォルトで Only Show Errors に設定されているため、正しく割り当てられたオブジェクトは一覧に表示されません。Menu ボタンを使用してすべてのオブジェクトを表示するには、Menu ボタンを使用して Only Show Errors オプションを無効にしてください。

Configure Physical Nets ダイアログ(奥は Only Show Errors オプションが有効、手前は Only Show Errors オプションが無効な状態)。
Configure Physical Nets ダイアログ(奥は Only Show Errors オプションが有効、手前は Only Show Errors オプションが無効な状態)。

現在の設計ドキュメントからすべてのネットをクリアし、内部のPCBネットリストを実質的に空にすることもできます。これは、ソース回路図ドキュメントのネット情報を変更し、PCBをソース回路図のネットリスト情報と完全に再同期させたい場合に役立ちます。これを行うには、次を選択します:Design » Netlist » Clear All Netsメインメニューから コマンドを選択します。 コマンドを実行すると、この操作によってPCBのすべてのネット情報が消去されることを知らせる確認ダイアログが開きます。 Yesをクリックすると、すべてのネット情報が削除されます。配線済みのトラックはそのまま残りますが、 No Net が割り当てられます。未配線の論理接続はすべて削除されます。

PCB設計の接続性について詳しくは、 PCBの接続性についてのページを参照してください。

現在の設計で配線によって作成された接続に基づいてネットリストファイルを作成するには、メインメニューから Design » Netlist » Create Netlist From Connected Copper コマンドを選択します。 表示される確認ダイアログで Yes をクリックすると、PCB設計ドキュメントと同じフォルダーにネットリスト(Generated <PCBDocumentName>.Net。 Projectsパネルの Source Documents サブフォルダー内にフリードキュメントとして追加されます)が作成され、アクティブドキュメントとして自動的に開きます。ネットリスト内の各ネットには、配線された銅箔が接続するパッドのいずれかの名前が付けられます。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Nav
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents