Altium Designer Documentation

Library Component Properties

Modified by Susan Riege on Apr 12, 2018
このページは、サポート対象外となったAltium Vaultについて紹介しています。Altium Vaultとそのコンポーネント管理機能は Altium Concord Proに移行しました。

  
The Library Component Properties incarnation of the dialog (back), the Schematic Symbol Properties incarnation of the dialog (middle),
and the Properties for Schematic Component in Sheet incarnation of the dialog (front).

Summary

This dialog enables designer to view/edit attributes associated with the currently selected component. The dialog also provides access for creating links to new models and/or editing existing ones.

Access

For the Library Component Properties incarnation of the dialog:

  • From the Sch Library editor by selecting Tools » Component Properties from the main menu.

For the Schematic Symbols Properties incarnation of the dialog:

  • From the Sch Library editor, after linking the Sch Library to a selected Vault (File » Link Library to Vault), select Tools » Component Properties from the main menu.

For the Properties for Schematic Component in Sheet incarnation of the dialog:

  • From the Sch Editor, double-click over a placed component or select Edit » Change from the toolbar and click on the desired component.

Options/Controls

Properties

  • Default Designator - This field shows the part designator, which identifies each part in your schematic project. If you do not enter a designator before you place a part then its designator will be the pre assigned default such as U?. To enter the designator before you place a part, press the Tab key while the component is floating under the cursor. If you enter the designator at this time, then the designator will increment automatically (U1, U2, U3, etc) as additional parts are placed. If the component is a multi-part device it will automatically be assigned a part suffix, for example U3A, U3B and so on. The suffix will automatically increment if the designator is assigned before you place the part.
    • Visible - Enable this option to display the designator text field of the current schematic component.
    • Locked - Enable this option to prevent this component from being re-annotated.
  •  Default Comment - Use the Comment field to enter a description of the component, such as 74LS04, or 10K. This field maps to the Comment field of the PCB component when the schematic and PCB are synchronized.
  • As well as typing a string in the Comment field, you can also select one of the parameters from the Comment drop down list. This list includes all the Parameters currently available in the Parameters list of this dialog. When one of the =Value parameters is used as the Comment, this parameter can be used to map a component’s simulation Value into the Comment field of a schematic component and its linked PCB component.
    • Visible - Enable this option to display the comment field of the current schematic component.
  • First Part - Click on one of these buttons to assign the current part ID to an existing part of a multi-part device. The field indicates which part this particular instance is, and a multi-part device will be assigned a part suffix. For example U3A, U3B etc. Click << to the first part of a multi-part device.
  • Prev Part - Click on one of these buttons to assign the current part ID to an existing part of a multi-part device. The field indicates which part this particular instance is, and a multi-part device will be assigned a part suffix. For example U3A, U3B etc. Click < to the previous part of a multi-part device.
  • Next Part - Click on one of these buttons to assign the current part ID to an existing part of a multi-part device. The field indicates which part this particular instance is, and a multi-part device will be assigned a part suffix. For example U3A, U3B etc. Click > to the next part of a multi-part device.
  • Last Part - Click on one of these buttons to assign the current part ID to an existing part of a multi-part device. The field indicates which part this particular instance is, and a multi-part device will be assigned a part suffix. For example U3A, U3B etc. Click >> to the last part of a multi-part device.
    • Locked - Enable this option to lock the sub part of a component from being re-annotated with a different part ID.
  • Description - This field shows the component description, which can be used to describe this component. Edit this field to update the description if required.
  • Unique ID - The current unique identifier for the part. The Unique ID (UID) is a system generated value that uniquely identifies this part. A new UID value can be entered directly into this field.
    • Reset - Click this button to have the system generate a new UID for the part.
  • Type - Select one of the following component types from the drop-down list:
  • Standard - These components possess standard electrical properties, are always synchronized, and are the type most commonly used on a schematic sheet.
  • Mechanical - These components do not have electrical properties and will appear in the BOM. They are synchronized if the same components exist on both the Schematic and PCB documents. An example is a heatsink.
  • Graphical - These components are not used during synchronization or checked for electrical errors. These components are used, for example, when adding company logos to documents.
  • Tie Net (in BOM) - These components short two or more different nets and these components will appear in the BOM and are maintained during synchronization.
  • Tie Net - These components short two or more different nets and these components will NOT appear in the BOM and are maintained during synchronization.
  • Standard (No BOM) - These components possess standard electrical properties and are synchronized BUT are not included in any BOM file produced from the file.

Library Link/Symbol Name

  • Symbol Reference  - Shows the reference name of the symbol

Graphical

For the Library Component Properties and Schematic Symbol Properties incarnations of the dialog, the following options are available:

  • Mode  - The Schematic editor supports up to three "Modes," or drawing styles, for each part - NormalDeMorgan, and IEEE. Use this option to select an alternative mode. Each mode is defined in the Library Editor, however only the Normal mode must be defined. If the drawing style does not change when you change this option it means that only the normal mode has been created.
  • Locked Pins - Enable this option to prevent the pins of this schematic component from being edited. Only the component itself can be edited. If you wish to edit a pin, disable this option.
  • Mirrored - Enable this option and the schematic component will be mirrored along the x - axis.
  • Show All Pins On Sheet (Even if Hidden) - Enable this option to display all pins including the hidden pins of a component on the current schematic document. Note, power pins are often defined as Hidden. Once a pin is defined as hidden, you must enable this Show All Pins On Sheet option to be able to see them or disable the Hide option in the Pin Properties dialog to show this particular pin.
  • Local Colors - Enable the local color option and the schematic component's fill, line, and pin colors are overridden with the colors from the FillLines, and Pins color boxes respectively. Disable this option to use the predefined colors from the library

For the Properties for Schematic Component in Sheet incarnation of the dialog, the following options are available:

  • Location X/Y - the current X (horizontal) and Y (vertical) coordinates for the top-left corner of the part's bounding rectangle (0 degree orientation), in relation to the bottom-left corner of the schematic sheet. Edit these values to change the position of the part in the horizontal and/or vertical planes respectively.
  • Orientation - specify the orientation of the part, counter-clockwise in relation to the horizontal. Options available are: 0 degrees, 90 degrees, 180 degrees, 270 degrees.
  • Mode - The Schematic editor supports up to three "Modes," or drawing styles, for each part - NormalDeMorgan, and IEEE. Use this option to select an alternative mode. Each mode is defined in the Library Editor, however only the Normal mode must be defined. If the drawing style does not change when you change this option it means that only the normal mode has been created.
  • Lock Pins - Enable this option to prevent the pins of this schematic component from being edited. Only the component itself can be edited. If you wish to edit a pin, disable this option.
  • Locked - enable this option to protect the part from being edited graphically.
An object that has its Locked property enabled cannot be selected or graphically edited. Double-click on the locked object directly and disable the Locked property to graphically edit the object.
 
  • Mirrored - Enable this option and the schematic component will be mirrored along the X-axis.
  • Show All Pins On Sheet (Even if Hidden) - Enable this option to display all pins including the hidden pins of a component on the current schematic document. Note, power pins are often defined as Hidden. Once a pin is defined as hidden, you must enable this Show All Pins On Sheet option to be able to see them or disable the Hide option in the Pin Properties dialog to show this particular pin.
  • Local Colors - Enable the local color option and the schematic component's fill, line, and pin colors are overridden with the colors from the FillLines, and Pins color boxes respectively. Disable this option to use the predefined colors from the library

Vault Links

(Schematic Symbol Properties incarnation only)

  • Item Revision  - Displays the current item revision.
    • Choose - Click to open the Vault Explorer and select a different revision.
  • Vault - Displays which Vault the Schematic Library is linked to.
    • Show in Explorer - Click to open the Vault Explorer and view the location of the linked Schematic Library.
  • Revision Details - Displays any details about the linked Schematic Library.
  • Revision State - Displays the revision state of the linked Schematic Library.

Parameters

This section lists out all parameters of the  schematic component. Parameters can be added, edited, and removed.

  • Add - Click to open the Parameter Properties dialog which allows the designer to specify the properties of a Parameter object and create a new parameter.
  • Remove - Remove a selected parameter(s).
  • Edit - Click to open the Parameter Properties dialog and edit a selected parameter.
  • Add as Rule - Click to open the Parameter Properties dialog and add a new parameter as a rule.

Models

This table lists the models (including simulation, PCB, EDIF Macro and Signal Integrity) that link to this schematic component. Select a model and click Edit to configure symbol-to-model links. Multiple models can be linked, the first enabled model of each type is used. The model location is typically not defined at the component level and the model is searched in the currently open and installed libraries.

  • Add - Click to add a new model (including simulation, PCB and Signal Integrity) that links to this schematic component. Multiple models can be linked, the first enabled model of each type is used. The model location is typically not defined at the component level, the model is searched for in the currently Installed Libraries, then down the project search path (Project » Project Options).
  • Remove - Click to delete a selected model (including simulation, PCB and Signal Integrity) from the table. This model's link to the schematic component is also removed.
  • Edit - Click to edit the selected model from the table to configure the symbol-to-model links. This model is linked to the current schematic component and the model location is typically not defined at the component level, the model is searched for in the currently Installed Libraries, then down the project search path (Project » Project Options).
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 無償評価版
Altium Designer 無償評価版
Altium Designerを使用していますか?

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

評価版ライセンスが必要な理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、評価版ライセンスは不要です。

ボタンをクリックして、最新のAltium Designerインストーラをダウンロードしてください。

Altium Designerインストーラをダウンロードする

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

Altium Designerの新規ライセンスのお見積もりをご希望の場合、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerサブスクリプションをご利用中の場合、評価版ライセンスは不要です。

お客様がAltium Designerサブスクリプションの有効なメンバーではない場合、下記のフォームに入力して無償評価版をダウンロードしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerを評価する理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

無償評価版を使用するには、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

素晴らしいですね。アルティウムではモノづくりに最適なプログラムを提供しています。

Upverterは、コミュニティ主導型の無償プラットフォームで、お客様のような作り手の要求に合わせて設計されています。

試してみる場合、こちらをクリック してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。