일괄 부품 편집

Workspace 컴포넌트는 Component Editor를 사용하여 정의/편집하며, 이 편집기는 두 가지 모드인 Single Component EditingBatch Component Editing로 동작할 수 있습니다. 후자는 여러 컴포넌트를 정의/편집하기 위한 인터페이스를 제공하지만, 원할 경우 단일 컴포넌트의 정의/편집에도 사용할 수 있습니다. Component Editor가 Single Component Editing 모드일 때는 편집기 메인 메뉴에서 Tools » Switch to Batch Editor 명령을 선택하여 일괄 편집 모드에 접근할 수 있습니다.

  • Single Component Editing 모드에서 컴포넌트를 정의하는 경우, 해당 컴포넌트에 아직 Workspace에 저장되지 않은 모델이 있으면 Batch Component Editing 모드로 전환할 수 없습니다. 먼저 컴포넌트를 Workspace에 저장한 다음 편집해야 하며, 그 후에는 편집 모드를 전환할 수 있습니다.

  • 현재 Component Editor의 Batch Component Editing 모드에 컴포넌트 정의가 하나만 포함되어 있다면, 메인 메뉴에서 Tools » Switch to Single Component Editor 명령을 선택하여 Single Component Editing 모드로 전환할 수 있습니다. 이 컴포넌트 정의의 데이터는 Single Component Editing 모드에 반영됩니다.

Component Editor의 Batch Component Editing 모드는 Components panel 또는 Explorer panel에서 여러 컴포넌트를 편집 대상으로 선택한 경우에도 열립니다. 각 컴포넌트 정의는 공통 파라미터 집합과 필요한 도메인 모델 링크를 갖습니다. 일괄 편집은 예를 들어 칩 저항기 세트처럼 컴포넌트를 하나의 집합으로 관리하는 것이 적절한 경우 특히 유용합니다.

이 문서에서는 Component Editor의 Batch Component Editing 모드에서 작업하는 방법을 설명합니다.

Component Editor의 Single Component Editing 모드에서 작업하는 방법에 대한 자세한 내용은 Single Component Editing을 참조하십시오.

인터페이스 개요

Batch Component Editing 모드에서 Component Editor 인터페이스는 기본적으로 네 개의 주요 영역으로 나뉘며, 아래 이미지에 표시되어 있고 이어서 요약되어 있습니다.

Component Editor를 Batch Component Editing 모드로 전환하면 네 개의 핵심 영역으로 나눌 수 있습니다.
Component Editor를 Batch Component Editing 모드로 전환하면 네 개의 핵심 영역으로 나눌 수 있습니다.

  1. Required Models/Parameters – 컴포넌트 정의에 어떤 유형의 도메인 모델이 필요한지 정의하고, 모든 컴포넌트 정의에 적용될 파라메트릭 데이터 집합을 작성하는 영역입니다.
  2. Model Links – 컴포넌트 정의에서 사용할 저장된 도메인 모델에 대한 링크를 추가하는 영역입니다.
  3. Preview Window – 현재 선택된 모델의 미리보기를 제공합니다. 심볼과 풋프린트는 그래픽으로, 그 외 모델 유형은 텍스트로 표시됩니다.
  4. Component Definition(s) – 폴더, 이름, 유형, 참조 도메인 모델, 파라메트릭 데이터 및 part choice를 포함하여 컴포넌트를 정의하는 영역입니다.
Required Models/ParametersModel Links 영역은 각 영역의 좌측 상단에 있는 컨트롤을 클릭하여 가로로 접을 수 있습니다. 또한 우측 상단의 컨트롤을 사용하면 위쪽 세 영역을 접고 Component Definitions 영역만 남길 수 있습니다.

문서 옵션

컴포넌트가 생성될 대상 Workspace 폴더와 해당 컴포넌트에 사용할 라이프사이클 정의 및 네이밍 스킴을 지정하는 컨트롤은 Document Options 대화상자(Edit » Document Options)에서 사용할 수 있습니다. 또한 Component Editor에서 릴리스되는 컴포넌트에 대한 기본 Component Naming scheme을 정의하여 Workspace에서 생성되는 각 컴포넌트에 고유 ID가 부여되도록 할 수 있습니다.

Workspace 설정은 Document Options 대화상자에서 정의합니다.
Workspace 설정은 Document Options 대화상자에서 정의합니다.

  • Target Server – 하나 이상의 새 컴포넌트를 생성하는 경우 대상 Workspace는 현재 활성 연결된 Workspace가 됩니다. 기존 컴포넌트를 편집하는 경우 이 필드에는 해당 컴포넌트가 존재하는 Workspace가 표시됩니다. 드롭다운 오른쪽의 Server Admin 버튼(컴포넌트가 아직 릴리스되지 않은 경우 사용 가능)을 클릭하면 Preferences 대화상자의 Data Management – Servers page에 접근할 수 있으며, 여기에서 활성 및 알려진 Workspace를 탐색하고 관리할 수 있습니다.

    여러 Workspace에 연결할 수는 있지만, 한 번에 활성 연결할 수 있는 Workspace는 하나뿐입니다.

  • Default Folder – 하나 이상의 새 컴포넌트를 생성할 때 이 필드를 사용하여 저장할 대상 Workspace 내의 기본 폴더를 지정합니다. Choose 버튼을 클릭하여 Choose Folder 대화상자(즉, Explorer panel의 한 형태)를 열고, 여기에서 Workspace 내 기존 폴더를 찾아 선택하거나 즉시 새 폴더를 만들 수 있습니다. 여기 입력된 값은 새 컴포넌트 정의를 추가할 때 FolderPath의 기본값으로 사용됩니다. 하나 이상의 기존 컴포넌트 리비전을 편집하는 경우 이 필드에는 기존 폴더가 표시되며 수정할 수 없습니다. 이 경우 Choose 버튼도 사용할 수 없습니다. Show in Explorer 버튼을 클릭하면 Explorer panel에서 지정된 기본 폴더를 바로 찾아볼 수 있습니다.

  • Lifecycle DefinitionRevision Naming – 이 필드들을 사용하여 각각 적절한 기본 스킴(Component Lifecycle1-Level Revision Scheme)을 설정합니다. 각 필드에 연결된 드롭다운을 사용하여 상위 Workspace에 현재 정의된 스킴 중 다른 스킴을 선택할 수 있습니다.

    콘텐츠 유형별로 라이프사이클 정의 및 리비전 네이밍 스킴 사용을 제어하는 옵션이 특정 정의/스킴에 대해 활성화되어 있고, Component 콘텐츠 유형이 특정 정의/스킴을 사용하도록 설정되지 않은 경우 해당 정의/스킴은 해당 드롭다운 목록에서 사용할 수 없습니다.

  • Item Naming – 이 필드는 Component Editor에서 저장되는 컴포넌트에 대한 기본 Item Naming Scheme을 정의하는 데 사용되며, Workspace에서 생성되는 각 Component Item에 고유 ID가 부여되도록 합니다. 여기 입력된 값은 새로 추가되는 컴포넌트 정의의 이름을 자동으로 지정하기 위한 템플릿으로 사용됩니다(연관된 Item ID 필드). 소프트웨어는 전체 Workspace와 기존 콘텐츠의 식별자를 스캔한 뒤, 해당 스킴에 따라 다음 사용 가능한 고유 ID를 자동 할당합니다.

    컴포넌트가 위치한(또는 생성될) 상위 폴더에 네이밍 스킴이 정의되어 있다면 그것이 기본값으로 미리 채워집니다. 그렇지 않으면 기본 스킴인 CMP-{00000}이 제공됩니다. 물론 필드에 직접 입력하여 사용자 정의 스킴을 만들 수도 있습니다. 파라미터 기반 Component Name Templates도 지원됩니다. 이러한 템플릿을 사용하면 Component Editor에서 해당 컴포넌트에 대해 현재 정의된 파라미터 값을 기반으로 컴포넌트 이름을 정확하게 지정하거나 다시 지정할 수 있습니다. 템플릿에 파라미터를 포함하려면 [<ParameterName>] 형식을 사용하십시오. 템플릿에는 여러 파라미터를 사용할 수 있으며, 중괄호로 지정되는 iterator 매크로도 추가할 수 있습니다(예: {000}, {00A}).

    또는 정의의 Item ID 필드에 필요한 ID를 직접 입력하여 컴포넌트에 자동 할당된 ID를 재정의할 수 있습니다. Item이 어떻게 식별될지에 대해서는 언제나 사용자가 완전한 제어권과 최종 결정권을 가집니다.

이 대화상자에서는 정의된 Component Template를 참조하는 기능도 제공합니다. 대화상자의 Template  탭에서 제공되는 컨트롤을 사용해 템플릿을 선택하십시오. Component Template는 Component Editor 내에서 정의되는 컴포넌트 정의에 사용할 사전 정의된 설정을 제공합니다. 이후 추가하는 모든 컴포넌트 정의는 연결된 컴포넌트 템플릿에 따라 생성됩니다.

편집 중인 컴포넌트가 Component Template를 참조하는 경우, 템플릿에서 지정된 Lifecycle Definition, Revision Naming, Component Naming,Default Folder 항목이 Document Options 대화상자의 Document Options 탭에 있는 해당 필드를 미리 채우는 데 사용됩니다. 이 옵션들(Component editor 측)은 템플릿에서 대응하는 Allow override 옵션이 활성화된 경우에만 편집할 수 있습니다. 또한 대상 Workspace는 Component Template의 리비전이 존재하는 동일한 Workspace를 사용하도록 고정됩니다.

Required Models/Parameters

이 편집기 영역은 컴포넌트 정의에 어떤 도메인 모델이 필요한지 지정하고, 모든 컴포넌트 정의에 적용될 파라메트릭 데이터 집합을 작성하는 데 사용됩니다.

 
 
 
 
 

필요한 모델과 파라미터를 정의합니다.
필요한 모델과 파라미터를 정의합니다.

  • Models – 가장 기본적인 수준에서, 보드 설계에 사용되는 컴포넌트는 회로도 및 PCB 편집 도메인에서의 표현이 필요합니다. 따라서 회로도 심볼 및 PCB 풋프린트 모델이 필요합니다. 이들은 기본적으로 required model로 추가되며 제거할 수 없습니다. 필요에 따라 이 영역의 AddRemove 컨트롤을 사용하여 다른 모델 유형을 추가/제거하십시오.

    모델 유형을 지정한다고 해서 컴포넌트 정의가 이를 반드시 사용한다는 뜻은 아니며, 해당 모델 유형에 대한 필드가 컴포넌트 정의에 추가된다는 의미입니다.
    목록에서 PCBLIB 항목을 사용할 수 있다는 점에 주목하십시오. 이를 통해 하나의 컴포넌트에 서로 다른 PCB 풋프린트 모델을 연결할 수 있습니다. 또한 PCBLIB (default) 파라미터를 사용하여 컴포넌트의 기본 풋프린트 모델을 지정할 수 있습니다.
  • Parameters – 기본 파라미터 항목 두 개, 즉 NameDescription가 존재합니다. 이들은 시스템 파라미터입니다. 필요에 따라 추가 파라미터를 얼마든지 더할 수 있습니다. 추가하려면 영역 하단의 Add 컨트롤을 클릭한 다음 Parameter 항목을 선택하십시오. 새 파라미터가 목록에 추가됩니다. Parameter Name 필드 내부를 클릭하여 이름을 필요에 맞게 변경하십시오. 파라미터를 제거하려면 선택한 후 Remove 컨트롤을 클릭하십시오. 시스템 파라미터는 제거할 수 없습니다.
각 항목과 연결된 Show 옵션을 사용하면 편집기 하단 영역, 즉 실제 컴포넌트 정의가 이루어지는 영역에서 해당 모델/파라미터에 대응하는 열의 표시 여부를 전환할 수 있습니다. 많은 수의 파라미터가 정의되어 아래 영역이 매우 복잡해지기 시작할 때 특히 큰 도움이 됩니다. 여러 모델/파라미터의 표시 상태를 전환하려면 멀티 선택과 우클릭 메뉴 옵션을 함께 사용하십시오.

이 편집기 영역은 Add 메뉴를 통해 다음 기능도 제공합니다.

  • Linking to a Component TemplateTemplates 하위 메뉴에는 컴포넌트 자체가 위치한 동일한 Workspace에서 현재 사용할 수 있는 모든 Component Templates가 나열됩니다. 항목을 클릭하면 해당 Component Template의 최신 리비전에 대한 링크가 생성됩니다. 템플릿의 파라미터는 이 영역으로 가져와지며 아이콘으로 구분됩니다.

  • Enabling the use of Datasheets – 이렇게 하려면 Datasheet 항목을 선택하십시오. 자세한 내용은 Attaching Datasheets to Component Definitions을 참조하십시오.

  • Adding Part ChoicesPart Choices 하위 메뉴를 사용하고 By MPN를 선택하십시오. 그러면 정의 영역에 Part Choice n 항목이 추가되고, 선택 사항을 지정하기 위한 두 개의 열(ManufacturerPart Number)이 생성됩니다. 또는 Workspace가 이를 지원하고 사용자 정의 데이터베이스 part source를 구성한 경우 By Internal ID 메뉴 항목을 선택하십시오. 그러면 정의 영역에 Part Choice n 항목이 추가되고, 회사 내부 부품 데이터베이스에서 part choice를 지정하기 위한 두 개의 열(Part sourceInternal ID)이 생성됩니다. 자세한 내용은 Part Choices를 참조하십시오.

Model Links

이 편집기 영역은 컴포넌트 정의에서 사용할 저장된 도메인 모델에 대한 링크를 추가하는 데 사용됩니다. Model Links 영역은 어떤 컴포넌트 정의에서도 접근할 수 있는 도메인 모델의 '버킷'으로 생각할 수 있습니다. 할당은 각 정의에 어떤 링크가 필요한지 지정하는 방식으로 이루어집니다.

특정 유형의 모델에 대한 링크는 해당 모델 유형이 Required Models/Parameters 영역에 추가되어 있는 경우에만 추가할 수 있습니다.

Model Links 영역은 모델 링크 정의와 컴포넌트 정의에 대한 할당을 간소화하는 기능으로 가득 차 있습니다.
Model Links 영역은 모델 링크 정의와 컴포넌트 정의에 대한 할당을 간소화하는 기능으로 가득 차 있습니다.

아래의 접을 수 있는 섹션을 사용하여 모델 링크 작업 방법을 자세히 알아보십시오.

컴포넌트 정의

매개변수 집합을 지정하고 모델 링크 ‘버킷’을 준비했다면, 이제 필요한 컴포넌트를 정의할 수 있습니다. 이는 문서의 아래쪽 영역에서 수행됩니다.

Component Editor를 사용하여 논리적이고 직관적인 방식으로 컴포넌트를 정의할 수 있습니다.
Component Editor를 사용하여 논리적이고 직관적인 방식으로 컴포넌트를 정의할 수 있습니다.

이 영역에 처음 표시되는 내용은 편집 중인 컴포넌트에 따라 달라집니다:

  • 새 컴포넌트를 생성할 때 상위 폴더에서 참조된 Component Template is not가 있으면, 해당 항목에는 FolderPathItem ID가 할당되지만 그 외에는 비어 있습니다. 말하자면 빈 캔버스와 같습니다.
  • 새 컴포넌트를 생성할 때 상위 폴더에서 참조된 Component Template is가 있으면, 해당 템플릿이 제공하는 미리 채워진 정의 정보가 항목에 포함됩니다.
  • 기존 단일 컴포넌트의 리비전을 편집 중이고 Single Component Editing 모드에서 전환한 경우, 해당 리비전과 그 시점까지 정의된 정보가 함께 표시됩니다.
  • 선택한 여러 컴포넌트 리비전을 편집하여 Batch Component Editing 모드에 직접 액세스하는 경우, 그 모든 리비전이 표시됩니다.
영역 하단의 Add Component 컨트롤을 클릭하거나, 메인 메뉴에서 Edit » Add Component 명령을 선택하거나, 해당 영역의 오른쪽 클릭 컨텍스트 메뉴에서 같은 이름의 명령을 사용하여 목록에 새 컴포넌트 정의를 추가할 수 있습니다.

각 컴포넌트 정의는 다음 정보를 포함하는 단일 행 항목으로 표시됩니다:

 
 
 
 
 
  • Component: FolderPath – 이 필드는 대상 Workspace의 특정 폴더에 컴포넌트를 저장하는 데 사용됩니다. 그리드에 새로 추가되는 각 컴포넌트에 대해, Document Options dialog(Edit » Document Options)의 Default Folder 필드에 지정되어 있다면 이 필드가 기본 위치로 채워질 수 있습니다. 기본 경로 지정 여부와 관계없이, 대상 Workspace 내에서 컴포넌트를 어디에 저장할지는 사용자가 완전히 제어할 수 있습니다. 대상 폴더를 수동으로 지정하려면 컴포넌트의 FolderPath 필드 안을 한 번 클릭하여 버튼을 표시한 다음 클릭하여 Choose Folder 대화상자에 액세스합니다. 기존 폴더를 찾아 선택하거나 즉석에서 새 폴더를 만들 수 있습니다.

    컴포넌트의 폴더 경로를 신중하게 결정해 두면 처음부터 올바른 대상 폴더에 저장되도록 할 수 있습니다. 하지만 필요한 경우 저장 후에도 Workspace 구조 내의 어떤 폴더로든 콘텐츠를 쉽게 이동할 수 있습니다.
    컴포넌트가 이미 Workspace에 저장된 경우 이 필드는 읽기 전용입니다. Operations 하위 메뉴의 오른쪽 클릭 Clear Link To Target Item 명령을 사용하면 Workspace의 기존 Item에 대한 링크가 지워집니다. 그러면 컴포넌트 정의의 필드가 새 Item을 생성할 준비 상태로 되돌아가고, FolderPath 필드를 다시 편집할 수 있게 됩니다.
  • Component: Item ID – 이 필드는 Workspace에 저장되는 컴포넌트에 사용할 ID를 결정하는 데 사용됩니다. 그리드에 새로 추가되는 각 컴포넌트에 대해, 이 필드는 Document Options 대화상자의 Item Naming 필드에 지정된 기본 명명 방식에 따라 채워집니다. 소프트웨어는 전체 Workspace와 기존 콘텐츠의 식별자를 검사한 후, 해당 방식에 따라 사용 가능한 다음 고유 ID를 자동으로 할당합니다.

    기본 Item 명명 방식인 CMP-{00000}이 제공되지만, 물론 필드에 직접 입력하여 자신만의 방식을 만들 수도 있습니다. 이때 변수 부분은 중괄호로 감싸야 합니다(예: CMP-001-{0000}). 또는 정의의 Item ID 필드에 필요한 ID를 직접 입력하여 컴포넌트의 자동 할당 ID를 재정의할 수도 있습니다. Item 식별 방식을 최종적으로 결정하는 권한은 항상 사용자에게 있습니다.

    매개변수 기반 Component Name Templates 사용도 지원됩니다. 이러한 템플릿을 사용하면 Component Editor에서 해당 컴포넌트에 사용 가능한 매개변수의 현재 정의 값을 기반으로 컴포넌트 이름을 정확하게 지정하거나, 다시 말해 변경할 수 있습니다.
    컴포넌트가 이미 Workspace에 저장된 경우 이 필드는 읽기 전용입니다. Operations 하위 메뉴의 오른쪽 클릭 Clear Link To Target Item 명령을 사용하면 Workspace의 기존 Item에 대한 링크가 지워집니다. 그러면 컴포넌트 정의의 필드가 새 Item을 생성할 준비 상태로 되돌아가고, Item ID 필드를 다시 편집할 수 있게 됩니다.
  • Component: Name – 이 필드는 컴포넌트에 지정된 사람이 읽기 쉬운 이름을 반영합니다. 이 시스템 매개변수는 Workspace 내 검색 시 사용 가능하며 인덱싱되므로, Item ID를 기억하지 않고도 특정 컴포넌트를 찾는 좋은 수단이 됩니다.

    참조된 Component Template에서 Name 시스템 매개변수의 기본값이 정의되어 있으면 이 필드에 채워집니다.
  • Component: Type – 이 필드는 컴포넌트 유형을 정의하는 기능을 제공하며, Workspace 컴포넌트의 대상 searching of Workspace components를 용이하게 하는 핵심 속성입니다(또한 Components panel을 통해 컴포넌트를 탐색할 때도 자주 사용하게 됩니다). 이 필드를 클릭한 다음 을 클릭하여 Choose component type 대화상자에 액세스합니다. 이 대화상자에서 현재 정의된 모든 유형 중 필요한 컴포넌트 유형을 선택한 후 OK를 클릭하면, 선택한 유형이 메인 정의 그리드의 Type 속성 값으로 삽입됩니다.

    참조된 Component Template에서 정의된 ComponentType 매개변수의 기본값이 있거나, File » New » Component 명령을 사용해 새 컴포넌트를 생성하려 할 때 나타나는 Create new component 대화상자에서 컴포넌트 유형을 선택한 경우, 이 필드에 그 값이 채워집니다. 유형은 환경설정 수준에서 정의됩니다. Choose component type 대화상자 하단의 버튼을 클릭하면 Preferences 대화상자의 Data Management – Component Types 페이지에 액세스할 수 있으며, 여기에서 새 유형 및 하위 유형을 추가하거나 기존 유형을 편집 및 제거하여 이 목록을 필요에 맞게 구성할 수 있습니다.
  • Component: Description – 이 필드는 컴포넌트에 추가된 설명을 반영합니다. 이 시스템 매개변수는 Workspace 내 검색 시 사용 가능하며 인덱싱됩니다.

    참조된 Component Template에서 Description 시스템 매개변수의 기본값이 정의되어 있으면 이 필드에 채워집니다.
  • Models – 이 필드들은 문서의 Required Models/Parameters 영역에 있는 항목에 대응합니다. 추가된 각 필수 모델마다 하나의 필드가 있으며, 풋프린트 모델은 여러 개를 정의할 수 있다는 점만 예외입니다. 각 필드는 컴포넌트에 사용할 연결된 모델(Model Links 영역 내)을 지정하는 데 사용됩니다.

    Required Model 항목에 대해 관련 Show 옵션을 각각 활성화/비활성화하여 모델 열 표시를 전환합니다. 다중 선택과 오른쪽 클릭 메뉴 옵션을 조합하여 여러 모델 유형의 표시 상태를 전환할 수 있습니다.
  • Template Parameters – 이 필드들은 참조된 Component Template 리비전으로부터 Component Editor에 가져온 사용자 매개변수에 대응합니다. 매개변수마다 하나의 필드가 있습니다. 컴포넌트 정의에서 매개변수의 좌우 순서는 Required Models/Parameters 영역에서의 상하 순서에 대응합니다. 필요에 따라, 그리고 해당되는 경우 매개변수 값을 입력하거나 선택합니다. 예를 들어 템플릿에서 Read Only로 표시된 매개변수는 편집할 수 없지만, 다른 매개변수는 편집할 수 있습니다. 또한 템플릿에서 Required로 표시된 경우에는 반드시 값을 지정해야 하며, 그렇지 않으면 컴포넌트 정의를 Workspace에 저장할 수 없습니다.

  • Parameters – 이 필드들은 문서의 Required Models/Parameters 영역에 입력한 추가 사용자 매개변수에 대응합니다. 추가 매개변수마다 하나의 필드가 있습니다. 컴포넌트 정의에서 매개변수의 좌우 순서는 Required Models/Parameters 영역에서의 상하 순서에 대응합니다. 필요에 따라 매개변수 값을 입력합니다.

    동적(Item 수준) 매개변수는 Component Editor의 Batch Component Editing 모드에서는 표시되지 않지만, Single Component Editing 모드에서는 표시됩니다 – 자세히 알아보기.

  • Release: Current Rev. – 이 읽기 전용 필드는 Workspace에 있는 컴포넌트의 현재(가장 최근/최신) 리비전을 반영합니다.

  • Release: Next Rev. – 이 읽기 전용 필드는 선택한 리비전 명명 방식에 따라 다음에 컴포넌트 정의를 Workspace에 저장할 때 생성될 컴포넌트의 다음 리비전을 반영합니다.

  • Release: Action – 이 필드는 저장 프로세스의 일부로서, 해당 컴포넌트 정의에 대해 릴리스 관리자가 수행할 작업을 보여줍니다. 아직 Workspace에 저장되지 않은 컴포넌트 정의의 경우 이 항목에는 Create Item이 표시됩니다. 이미 Workspace에 저장된 정의의 경우 이 항목에는 Create Revision이 표시됩니다. 컴포넌트의 계획된 리비전을 대상으로 하는 경우에는 Release To Existing Revision이 표시됩니다.

  • Part Choice n – 이 항목은 문서의 Required Models/Parameters 영역에 추가한 Part Choice에 대응합니다. 컴포넌트 정의에서 Part Choice의 좌우 순서는 Required Models/Parameters 영역에서의 상하 순서에 대응합니다. 추가된 각 Part Choice마다 선택을 지정하기 위한 두 개의 필드, ManufacturerPart Number가 있습니다. 또는 사용자 지정 데이터베이스 부품 소스를 구성하고 By Internal ID 메뉴 항목을 사용하여 Part Choice를 추가한 경우, 두 필드는 Part sourceInternal ID가 됩니다. 이를 사용하여 회사 내부 부품 데이터베이스에서 부품 선택을 지정할 수 있습니다.

Current Rev., Next Rev., Action 필드들은 함께 Release Status을 구성하며, 영역 하단에 있는 Show Release Status 옵션을 사용해 해당 영역에서의 표시 여부를 전환할 수 있습니다. 각각의 Required Parameter 항목에 대해 연관된 Show 옵션을 활성화/비활성화하여 Template Parameter, Parameter, Part Choice 열의 표시를 전환하십시오. 여러 매개변수의 표시 상태를 전환하려면 다중 선택과 오른쪽 클릭 메뉴 옵션을 함께 사용하십시오.
컴포넌트를 다시 Workspace에 저장하려고 하면 Component Editor가 유효성 검사를 실행합니다. 즉, Component Rule Check입니다. 이 기능은 메인 메뉴에서 Tools » Component Rule Check 명령을 선택하여 언제든지 수동으로 실행할 수도 있습니다. 실행하기 전에 컴포넌트를 로컬에 저장(File » Save)했는지 반드시 확인하십시오. 자세한 내용은 Running a Component Rule Check를 참조하십시오.

Component Definitions 작업

다음 섹션에서는 이 편집기 영역을 사용하는 방법과 함께, 시간을 절약해 주는 유용한 기능들을 알아봅니다.

기존 컴포넌트에 모델 링크 할당하기

기존 컴포넌트 정의의 경우, 필요한 모델 링크를 다음과 같은 방법으로 할당할 수 있습니다:

  • 모델 링크를 컴포넌트 정의의 관련 열로 드래그 앤 드롭합니다.

    Model Links 영역에서 해당 컴포넌트의 대응하는 모델 열로 드래그 앤 드롭하여 기존 컴포넌트에 모델을 할당합니다.
    Model Links 영역에서 해당 컴포넌트의 대응하는 모델 열로 드래그 앤 드롭하여 기존 컴포넌트에 모델을 할당합니다.

  • 모델 열의 드롭다운 필드를 사용하면 전용 모델 링크 팝업 창을 열 수 있습니다. 이 창에는 할당하려는 모델 유형에 적용 가능한 기존 모델 링크가 모든 데이터 열과 함께 그리드로 표시됩니다. 컴포넌트 정의 수가 많아 드래그 앤 드롭 방식이 불편하거나, Model Links 영역이 포함된 Component Editor의 상단 섹션이 접혀 있는 경우 특히 모델을 찾고 할당하는 데 큰 도움이 됩니다. 또한 이 방법은 동일한 모델 링크를 여러 컴포넌트 정의에 할당하는 데도 사용할 수 있습니다. 팝업 창을 열기 전에 각 컴포넌트의 모델 열을 선택하면 됩니다.

    필요에 따라 창 크기를 조정하십시오. 창 오른쪽 아래의 컨트롤을 클릭하여 끌면 가로와 세로 크기를 동시에 조정할 수 있습니다. 창 왼쪽 위의 열 제어 버튼 을 클릭한 후, 표시하지 않을 열은 비활성화하십시오. 열 머리글을 끌어 열 순서를 변경할 수도 있습니다.

    팝업의 검색 필드를 사용하면 필요한 모델을 빠르게 찾을 수 있습니다. 문자를 입력하기 시작하면 모든 열의 데이터를 기반으로 동적 하이라이트가 적용됩니다. 필요한 모델 링크를 선택한 다음 Enter를 누르거나 더블클릭하여 해당 모델을 할당하십시오.

    전용 모델 링크 선택 팝업을 사용해 필요한 모델을 검색, 찾기, 할당할 수 있습니다.
    전용 모델 링크 선택 팝업을 사용해 필요한 모델을 검색, 찾기, 할당할 수 있습니다.

링크된 모델로 새 컴포넌트 만들기

컴포넌트 정의가 아직 없는 경우, 다음과 같은 방법으로 새 정의를 만들고 필요한 모델 링크도 자동으로 할당할 수 있습니다:

  • Model Links 영역에서 모델 링크를 Definitions 영역의 빈 공간으로 드래그 앤 드롭하면 해당 모델을 사용하는 새 컴포넌트 정의가 추가됩니다.

    Model Links 영역에서 드래그 앤 드롭하여 즉시 모델을 할당하고 새 컴포넌트를 추가합니다.
    Model Links 영역에서 드래그 앤 드롭하여 즉시 모델을 할당하고 새 컴포넌트를 추가합니다.

  • Explorer panel에서 모델을 직접 Definition 영역으로 드래그 앤 드롭합니다. 그러면 해당 모델을 사용하는 새 컴포넌트 정의가 추가됩니다. 또한 그 모델이 Model Links 영역에 아직 없으면 해당 항목도 추가됩니다.

    Explorer panel에서 드래그 앤 드롭하여 즉시 모델을 할당하고 새 컴포넌트를 추가합니다. 모델 링크가 아직 없으면 Model Links 영역에 추가됩니다.
    Explorer panel에서 드래그 앤 드롭하여 즉시 모델을 할당하고 새 컴포넌트를 추가합니다. 모델 링크가 아직 없으면 Model Links 영역에 추가됩니다.

여러 컴포넌트 추가하기

Component Editor는 여러 개의 새 컴포넌트를 한 번에 추가할 수 있도록 지원합니다. 오른쪽 클릭 후 Operations » Add Components 명령을 선택하십시오. 그런 다음 표시되는 Add Components dialog에서 추가할 컴포넌트 수를 입력하고 click OK 하면 지정한 수만큼의 새 컴포넌트 정의가 현재 컴포넌트 정의 목록의 맨 아래에 있는 컴포넌트 정의 그리드에 추가됩니다. 그리드의 다중 셀 편집 지원 및 복사/붙여넣기 기능과 함께 사용하면 짧은 시간 안에 상당한 수의 컴포넌트 정의를 빠르게 만들 수 있습니다.

이 명령은 편집기의 메인 Edit 메뉴(Edit » Operations » Add Components)에서도 실행할 수 있습니다.
Add Components dialog에 너무 큰 숫자를 입력하면 성능에 영향을 줄 수 있으며, 요청을 처리하는 동안 소프트웨어가 상당 시간 '멈춘 것처럼' 보일 수 있으니 주의하십시오!

두 단계만으로 여러 개의 새 컴포넌트 정의를 빠르게 추가할 수 있습니다.
두 단계만으로 여러 개의 새 컴포넌트 정의를 빠르게 추가할 수 있습니다.

기본 칩 저항 생성하기

메인 메뉴에서 Edit » Operations » Generate Basic Chip Resistors 명령을 선택하거나, 현재 정의된 정의가 없는 영역의 definitions region에서 오른쪽 클릭한 다음 컨텍스트 메뉴에서 Operations » Generate Basic Chip Resistors 명령을 선택하여 칩 저항 컴포넌트 정의를 여러 개 빠르게 생성할 수도 있습니다.

현재 선택된 컴포넌트 정의가 없을 때에만 해당 명령이 각 메뉴에서 사용 가능합니다.

명령을 실행하면 지정된 컴포넌트 유형에 대한 컴포넌트 정의가 자동으로 생성됩니다.

이 명령으로 생성된 컴포넌트 정의는 이미 정의된 항목에 추가됩니다. 즉, 기존 항목이 새로 생성된 항목으로 덮어써지지는 않습니다.

Manufacturer Part Search에서 컴포넌트 만들기

컴포넌트 생성 기능을 강화하기 위해 Altium Designer는 Manufacturer Part Search 기능을 통해 실제 부품을 검색한 뒤, 그 부품을 Component Editor에 추가할 수 있도록 지원합니다. 선택한 부품에 대한 새 컴포넌트 정의 항목뿐 아니라 모든 매개변수, 데이터시트, 그리고 이를 기반으로 한 part choice까지 함께 가져오므로, 사용자는 도메인 모델을 정리하고 컴포넌트 유형과 대상 폴더를 설정한 후 Workspace에 저장하기만 하면 됩니다!

참고로, Component Editor를 Single Component Editing mode에서 사용할 때 Manufacturer Part Search 기능을 사용하는 경우와 달리, Batch Component Editing mode에서는 모델(존재하더라도)이 함께 가져와지지 않습니다.

Altium Designer에서 이 기능을 사용하려면 Component From Supplier Search 소프트웨어 확장이 설치되어 있어야 합니다. 이 확장은 기본적으로 Altium Designer와 함께 설치됩니다. 수동으로 설치하거나 제거할 수도 있습니다.

확장 관리에 대한 자세한 내용은 Extending Your Installation 페이지를 참조하십시오(Altium Designer Develop, Altium Designer Agile, Altium Designer).

이 기능은 Component Editor의 Definitions 영역에서 사용할 수 있습니다. 오른쪽 클릭 후 해당 영역의 컨텍스트 메뉴에서 Operations » Create from Part Search 명령을 선택하십시오. 또는 메인 메뉴에서 Edit » Operations » Create from Part Search 명령을 선택하거나, definitions 영역 내부를 클릭한 뒤 키보드 단축키 Shift+Ctrl+M를 사용하십시오.

Manufacturer Part Search dialog가 나타납니다. 현재 활성화된 공급업체가 제공하는 실제 제조 품목 데이터베이스 전반에서 원하는 부품(또는 여러 부품)을 검색하고, 항목을 선택한 다음 OK 버튼을 클릭하십시오.

이 dialog는 Manufacturer Search panel과 동일한 방식으로 사용됩니다. 자세한 내용은 연결된 페이지를 참조하십시오.
dialog의 검색 결과는 Manufacturer Part 기준으로 표시되며, 관련 SPN 항목은 해당 부품을 공급하는 활성화된 벤더를 반영합니다. 부품을 선택하면 새 컴포넌트 정의를 만드는 데 사용되는 것은 manufacturer part입니다. 또한 Part Choice 측면에서는 특정 벤더/공급업체가 아니라 manufacturer part를 기준으로 생성하므로, 해당 부품을 판매하는 공급업체(그리고 Workspace를 통해 사용 가능한 공급업체)를 모두 포함하는 단일 Part Choice를 얻게 됩니다. 매개변수는 정의된 Parameter Import Options에 따라 가져오며, 이 설정은 Preferences dialog의 Data Management – Parts Providers page에서 구성합니다.

Manufacturer Part Search dialog를 열고 Component Editor로 가져오고 싶은 부품을 검색하십시오.
Manufacturer Part Search dialog를 열고 Component Editor로 가져오고 싶은 부품을 검색하십시오.

OK를 클릭하면 다음이 수행됩니다:

  • 선택한 부품에 대한 컴포넌트 항목이 Component Editor의 definitions 영역에 생성됩니다. 이 정의에는 다음이 적용됩니다:
    • Component Editor에서 사용하는 정의된 Item Naming 규칙에 따라 다음 사용 가능한 고유 Item ID가 할당됩니다.
    • 선택한 부품의 Manufacturer Part Number 매개변수 값이 해당 정의의 Name 시스템 매개변수 값으로 할당됩니다.
    • 선택한 부품의 Description 매개변수 값이 해당 정의의 Description 시스템 매개변수 값으로 할당됩니다.
  • dialog에서 선택한 부품에 대해 정의된 모든 매개변수(해당 부품에 대해 보이는 항목)가 Required Models/Parameters 목록에 추가됩니다. 모두 표시되도록 설정됩니다(연관된 Show 옵션 활성화). 즉, 기본적으로 Definitions 영역에 각 매개변수별 열이 하나씩 표시된다는 뜻입니다.
  • 선택한 부품에 사용 가능한 각 데이터시트에 대해서도 파라메트릭 항목이 추가됩니다(ComponentLinknDescriptionComponentLinknURL 쌍의 형태).
  • 해당 정의에 대해 Part Choice(Part Choice 1)가 추가되며, 부품의 ManufacturerManufacturer Part Number 매개변수 값이 각각 그 choice의 ManufacturerPart Number 필드를 채우는 데 사용됩니다.
매개변수는 정의된 Parameter Import Options에 따라 가져오며, 이 설정은 Preferences dialog의 Data Management – Parts Providers page에서 구성합니다.

Manufacturer Part Search dialog에서 선택한 부품에 대해 생성된 결과 정의와 추가된 매개변수의 예입니다. Manufacturer Part에서 가져온 데이터를 보여주기 위해 하이라이트가 사용됩니다.
Manufacturer Part Search dialog에서 선택한 부품에 대해 생성된 결과 정의와 추가된 매개변수의 예입니다. Manufacturer Part에서 가져온 데이터를 보여주기 위해 하이라이트가 사용됩니다.

컴포넌트 유형 설정

Component Editor는 컴포넌트 정의를 구성할 때 컴포넌트 유형을 정의할 수 있도록 지원합니다. 이를 통해 Workspace의 강력한 Search facility를 사용해 보다 목적에 맞는 검색이 가능해집니다. 이 기능은 컴포넌트 유형으로 검색할 수 있을 뿐 아니라, 단위를 인식하는 지원 컴포넌트 매개변수를 활용해 더 똑똑한 검색도 가능하게 합니다. Components panel을 사용해 자신의 Workspace 라이브러리를 탐색할 때, 컴포넌트의 Categories 그룹화는 각 컴포넌트에 정의된 컴포넌트 유형을 기반으로 합니다.

컴포넌트 유형은 definitions 영역의 Component region 안에 있는 Type 속성을 통해 지정합니다. Type 필드를 클릭한 다음 를 클릭하여 Choose component type dialog를 엽니다. 이 dialog에서 필요한 컴포넌트 유형을 선택한 후 OK를 클릭하면, 선택한 유형이 메인 definitions grid의 Type 속성 값으로 삽입됩니다.

Choose component type 대화상자에는 기본 컴포넌트 유형 세트가 표시됩니다. 이러한 유형은 환경설정 수준에서 정의됩니다. 대화상자 하단의 버튼을 클릭하면 Preferences 대화상자의 Data Management – Component Types 페이지로 이동할 수 있으며, 여기서 새 유형 및 하위 유형을 추가하거나 기존 유형을 편집 및 제거하여 이 목록을 필요에 맞게 구성할 수 있습니다.

Type 속성을 Diode(으)로 설정하는 컴포넌트 정의의 예.
Type 속성을 Diode(으)로 설정하는 컴포넌트 정의의 예.

Type 필드는 여러 컴포넌트 정의에 대해 한 번의 작업으로 설정할 수 있습니다. 필요한 각 컴포넌트 정의의 Type 필드를 선택한 다음, 그중 하나의 유형을 선택하면 나머지 모두에 적용됩니다.

저장 후에도 하나 이상의 컴포넌트에 대해 컴포넌트 유형을 즉시 완전히 다른 유형으로 변경할 수 있습니다. Components panel 또는 Explorer panel에서 변경하려는 컴포넌트를 선택한 다음, 마우스 오른쪽 버튼을 클릭하고 컨텍스트 메뉴에서 Operations » Change Component Type 명령을 선택합니다. 그러면 새 컴포넌트 유형을 선택할 수 있는 Choose component type 대화상자가 나타납니다.
이 필드는 참조된 Component Template에 정의된 ComponentType 매개변수의 기본값이나, File » New » Component 명령을 사용해 새 컴포넌트를 만들려고 할 때 나타나는 Create new component 대화상자를 통해 선택한 컴포넌트 유형으로 채워집니다.

단위를 인식하는 컴포넌트 매개변수 데이터 유형 지원

Component Editor는 참조된 Component Template 내에 정의된 단위 인식형 컴포넌트 매개변수 데이터 유형을 지원합니다. 2.2k, 2k2, 4M, 2.5GHz와 같은 다양한 형식으로 컴포넌트 정의의 해당 필드에 매개변수 값을 직접 입력할 수 있으며, Workspace는 이러한 입력 뒤에 있는 수치 값을 인식하도록 설계되어 있습니다.

컴포넌트 템플릿의 이 기능은 Workspace의 Search facility를 통한 대상 검색을 가능하게 합니다. 이 기능은 컴포넌트 유형별 검색뿐 아니라 범위 검색을 통해 더 똑똑한 검색도 지원합니다. 단위를 인식하는 컴포넌트 매개변수의 강력한 기능을 사용하면, 예를 들어 정전용량이 47uF에서 220uF 사이인 모든 커패시터를 찾는 검색을 빠르게 정의할 수 있습니다.

단위 인식형 매개변수는 Components panel을 사용해 자체 컴포넌트를 검색할 때의 스마트 필터링에도 사용됩니다.
컴포넌트 매개변수의 단위 인식형 데이터 유형은 컴포넌트 템플릿을 통해서만 정의할 수 있습니다.

참조된 컴포넌트 템플릿에서 단위 인식형 데이터 유형을 가진 컴포넌트 매개변수.
참조된 컴포넌트 템플릿에서 단위 인식형 데이터 유형을 가진 컴포넌트 매개변수.

단위 인식형 데이터 유형을 사용하는 컴포넌트 매개변수 값, 즉 컴포넌트 정의에 필요한 값을 입력할 때는 다음 사항을 고려해야 합니다.

  • 다음과 같은 다양한 형식으로 값을 입력할 수 있습니다. 
    • 숫자 값만 입력(예: 10). 데이터 유형에 단위가 있는 경우 해당 단위가 자동으로 적용됩니다. 단위가 있는 유형은 이름 뒤 괄호 안에 단위가 표시됩니다.
    • 과학적 표기법의 숫자 값(예: 1e10, 1E6).
    • 숫자 값과 단위(예: 10F).
    • 접두사가 포함된 숫자 값(예: 10k). 적절한 단위는 자동으로 추가됩니다(해당되는 경우).
    • 접두사와 단위가 포함된 숫자 값(예: 10kF).
    • 일반적인 엔지니어링 형식의 접두사가 포함된 숫자 값(예: 저항의 경우 2k2, 2K2, 10r2, 10R2). 값은 그에 맞게 자동으로 정규화됩니다(예: 2K2은(는) 2.2k(으)로 변환됨).
  • 숫자 값 뒤에 공백을 넣거나 넣지 않고 접두사 및/또는 단위를 입력할 수 있습니다(예: 10uF 또는 10 uF). 공백은 자동으로 제거됩니다.
엔지니어링 약어는 대소문자를 구분하지 않으므로 2k2를 입력하는 것은 2K2를 입력하는 것과 같고, 100R 를 입력하는 것은 100r을 입력하는 것과 같습니다. 유일한 예외는 M(메가)와 m(밀리)입니다.

사전 정의 컴포넌트 매개변수 데이터 유형 지원

Component Editor는 참조된 Component Template 내에 구성된 사전 정의 컴포넌트 매개변수 데이터 유형을 지원합니다. 값 셀을 클릭하고 드롭다운을 사용하여 사전에 정의된 선택지에서 매개변수 값을 선택할 수 있습니다. 값 셀을 클릭한 후 값을 입력하기 시작하면 드롭다운이 열리고 목록에서 가장 가까운 값이 강조 표시됩니다.

컴포넌트 매개변수의 사전 정의 데이터 유형은 컴포넌트 템플릿을 통해서만 구성할 수 있습니다.

참조된 컴포넌트 템플릿에서 단위 인식형 데이터 유형을 가진 컴포넌트 매개변수.
참조된 컴포넌트 템플릿에서 단위 인식형 데이터 유형을 가진 컴포넌트 매개변수.

Workspace 관리자라면 값 필드 오른쪽의 아이콘을 클릭하여 Workspace의 브라우저 인터페이스에서 Settings – Vault – Dictionaries 페이지를 열고 사전을 관리할 수 있습니다. 

  • ​​​​​사전 정의 매개변수의 값은 컴포넌트를 Workspace에 저장할 때 검증됩니다. 값이 사전과 일치하지 않게 되면(예: 값이 Workspace에서 제거된 뒤 그 값을 사용하는 컴포넌트를 편집하려고 연 경우), 값 필드가 빨간색으로 강조되어 해당 값이 더 이상 적용되지 않음을 알려줍니다. 값이 사전과 일치할 때까지는 컴포넌트를 Workspace에 저장할 수 없습니다.

  • 연결된 Workspace의 브라우저 인터페이스에서 사전이 변경된 경우, 이러한 변경 사항을 Altium Designer에 반영하려면 Workspace 연결을 끊었다가 다시 연결해야 합니다. 자세한 내용은 Accessing Your Workspace 페이지를 참조하십시오.

컴포넌트 이름 템플릿 사용

Component Editor는(오직 Batch Component Editing 모드에서만) 매개변수 기반 Component Name Templates의 사용을 지원합니다. 이러한 템플릿을 사용하면 편집기에서 해당 컴포넌트에 사용 가능한 현재 정의된 매개변수 값(사용자/템플릿 매개변수, 시스템 매개변수 제외)을 기반으로 컴포넌트, 즉 그 Item ID의 이름을 정확하게 지정하거나 다시 지정할 수 있습니다. [<ParameterName>] 형식을 사용하여 이름 지정 템플릿에 매개변수를 포함하십시오. 예를 들면 다음과 같습니다.

  • CMP-[Value]

  • CMP-[Part Number]

  • [Part Number]-[Value]

  • [Value]

  • [Part Number]

템플릿에서 여러 개의 파라메트릭 선언을 사용할 수도 있습니다. 예:

  • CMP-[Part Number]-[Value]
  • CMP-[Manufacturer Part Number]-[Value]-[Tolerance]

또한 선택 사항으로, 중괄호 안에 지정된 반복자 매크로(예: {000}, {00A})를 추가할 수도 있습니다. 예:

  • CMP-[Value]-{001}
  • CMP-[Part Number]-{00A}

가장 상위 수준에서는 필요한 이름 지정 템플릿을 Document Options 대화상자의 Item Naming 필드에 기본 이름 지정 체계로 간단히 입력할 수 있습니다. 이 경우 초기 인덱스는 항상 0입니다. 더 세밀하게 제어하려면 이름을 바꿀 컴포넌트를 선택하고 메인 메뉴에서 Edit » Operations » Rename Component (Edit » Operations » Rename n Components) 명령을 선택하거나, 마우스 오른쪽 버튼을 클릭하고 컨텍스트 메뉴에서 Operations » Rename Component (Operations » Rename n Components) 명령을 선택합니다. 그러면 Component Name Template 대화상자가 나타납니다. 이 대화상자에서 필요한 Naming Scheme를 지정하고, 템플릿에 반복자 매크로가 추가된 경우 Initial Index를 제어할 수 있습니다.

대화상자에는 처음에 Document Options 대화상자에 입력한 기본 이름 지정 체계가 표시됩니다. 이 체계를 그대로 두면 Initial Index를 변경할 수 없습니다. 후자는 다른 이름 지정 체계를 사용할 때만 변경할 수 있습니다.

이름 지정 템플릿에서 CompanyPrtType 및 Value 매개변수를 사용하여 Component Editor에서 정의 중인 선택한 컴포넌트의 이름을 빠르게 바꾸는 예.
이름 지정 템플릿에서 CompanyPrtTypeValue 매개변수를 사용하여 Component Editor에서 정의 중인 선택한 컴포넌트의 이름을 빠르게 바꾸는 예.

  • 이름 변경 과정에서 사용된 이름 지정 체계는 해당 과정에만 사용됩니다. 문서에 정의된 기본 이름 지정 체계를 대체하지는 않습니다. 이후에 추가되는 컴포넌트 정의에도 동일한 체계를 사용해 이름을 지정하려면 Document Options dialog의 Component Naming 필드를 적절히 변경하여 문서 수준에서 이 체계를 정의해야 합니다.
  • 개별 컴포넌트 정의의 Item ID 도 그리드에서 직접 변경할 수 있습니다. Item ID  셀에 포커스를 주기 위해 한 번 클릭한 다음, 다시 클릭하거나 F2를 눌러 제자리 편집 모드로 들어갑니다. 필요에 따라 이름을 변경하십시오. 이 방식으로 이름을 직접 편집할 때는 파라메트릭 선언 사용이 지원되지 않습니다.

Part Choices

Component Editor를 사용하여 컴포넌트에 대해 하나 이상의 Part Choices를 지정할 수 있습니다. 이는 조립된 보드에서 해당 컴포넌트를 구현하는 데 사용할 수 있는 '허용된' 제조업체 부품입니다. 실제 공급망 인텔리전스(제조업체(및 부품 번호), 공급업체(및 부품 번호), 설명, 가격, 가용성 포함)는 Workspace의 로컬 Part Catalog 및 관련 Part Source에서 가져옵니다.

각 Workspace에는 전용 Part Catalog가 있습니다. 이는 제조업체 부품 및 관련 공급업체 부품을 관리하고 추적하기 위한 로컬 부품 카탈로그 데이터베이스입니다. 로컬 Part Catalog에는 실제 Manufacturer Parts를 나타내는 항목과, 하나 이상의 Supplier Parts를 나타내는 항목이 저장됩니다. Supplier Parts는 공급업체/벤더가 판매하는 해당 Manufacturer Parts의 구현체입니다. 각 Supplier Part는 부품 데이터베이스의 항목을 참조합니다. 이 데이터베이스는 Altium Parts Provider의 통합 부품 데이터베이스(활성화된 공급업체로부터 부품을 수집하고 연동함)이거나, Enterprise Server Workspace의 경우 연결된 로컬 부품 데이터베이스(ODBC 기반)입니다. 필요한 공급업체를 활성화하고 Workspace 브라우저 인터페이스의 Part Providers 영역에서 Altium Parts Provider에 대한 지역/통화 범위를 결정하십시오. Altium Designer에서 Workspace에 연결된 상태를 유지하는 동안 Preferences 대화상자의 Data Management – Parts Providers page에 있는 Altium Parts Options 영역은 읽기 전용이 되며 Workspace에 정의된 설정을 따릅니다. Workspace의 Altium Parts Provider 부품 소스를 관리하는 방법에 대한 자세한 내용은 Part Source Configuration (Altium 365 Workspace, Enterprise Server Workspace)를 참조하십시오.

Required Models/Parameters 영역에서 부품 선택 항목을 추가하려면 Add 컨트롤을 클릭하고 Part Choices 하위 메뉴에서 By MPN 명령을 사용하십시오. 또는 사용자 지정 데이터베이스 부품 소스를 구성한 경우 By Internal ID 메뉴 항목을 선택하십시오. 사용할 부품 선택 항목은 원하는 만큼 추가할 수 있습니다.

정의 중인 컴포넌트에 사용할 부품 선택 항목을 추가하면 정의 영역에 Part Choice n 항목이 추가되며, 해당 선택 항목을 지정하기 위한 두 개의 열이 제공됩니다. 이 열은 선택한 부품 선택 항목의 스타일에 따라 달라집니다.

  • By MPN – 표시되는 두 열은 ManufacturerPart Number입니다.

  • By Internal ID – 표시되는 두 열은 Part sourceInternal ID입니다.

정의 중인 컴포넌트에 사용할 부품 선택 항목(By MPN) 추가. 마우스를 올려 By Internal ID으로 추가된 예제 부품 선택 항목을 확인하십시오. 이를 통해 회사 내부 부품 데이터베이스의 부품을 연결할 수 있습니다.
정의 중인 컴포넌트에 사용할 부품 선택 항목(By MPN) 추가. 마우스를 올려 By Internal ID으로 추가된 예제 부품 선택 항목을 확인하십시오. 이를 통해 회사 내부 부품 데이터베이스의 부품을 연결할 수 있습니다.

ManufacturerPart Number 필드에, 보드 제조 및 조립 시 사용되기를 원하는 실제 부품의 제조업체명과 제조업체 부품 번호를 각각 입력하십시오.

구성된 사용자 지정 데이터베이스 부품 소스를 사용하는 경우 Part source 필드를 사용하여 부품 소스를 선택하십시오. Workspace에 정의된 모든 사용자 지정 데이터베이스 부품 소스가 목록에 표시됩니다. 필요한 부품의 ID를 Internal ID 필드에 입력하십시오.

Component editor를 Batch Component Editing 모드로 열었을 때 컴포넌트에서 제조업체 및 제조업체 부품 번호 매개변수 쌍이 감지되면, 이러한 매개변수를 part choices()로 변환하라는 제안과 함께 Part Choice Migration 대화상자가 열립니다. 매개변수를 part choices로 복사하거나 이동하도록 선택하면 새 part choices가 생성되고, 그 Part Number 값은 해당 매개변수 값으로 정의됩니다.

제조업체와 제조업체 부품 번호로 감지된 컴포넌트 매개변수는 아래의 접을 수 있는 섹션에 나열됩니다. 매개변수 이름에 숫자 접미사가 있는 경우(예: 매개변수 이름이 Manufacturer 1Manufacturer Part Number 1인 경우)에도 이러한 매개변수가 감지됩니다.

알아두어야 할 사항이 몇 가지 있습니다.

  • 부품 선택 항목을 추가했다고 해서 컴포넌트 정의가 반드시 그것을 사용해야 하는 것은 아닙니다. 하지만 두 필드 중 하나에 값을 입력하면 다른 필드에 빨간색 테두리가 표시되어, 해당 컴포넌트를 Workspace에 저장하기 전에 이제 값이 필요하다는 점을 알려줍니다.

  • 필드 값이 잘못 입력되어 Workspace가 해당 부품을 가져올 수 없으면 텍스트가 회색 기울임꼴로 표시됩니다. 두 항목이 모두 올바르면 텍스트는 일반적인 흰색 텍스트로 표시됩니다. 값은 대소문자를 구분하지 않습니다.

대화상자를 통한 MPN 부품 선택 항목 추가

부품 선택 항목에 대해 제조업체 및 부품 번호 정보를 관련 셀에 직접 입력할 수 있지만, 제조업체 부품을 검색할 수 있는 대화상자를 사용하는 편이 훨씬 쉽습니다. 이 기능을 사용하려면 먼저 Required Models/Parameters 영역에 초기 Part Choice 1 항목을 추가한 후, 해당 선택 항목의 셀 중 하나(정의 중인 필요한 컴포넌트와 연결된 셀)를 클릭하십시오. 그러면 편집기의 Preview 영역에 버튼이 표시됩니다. 이를 클릭하면 Add Part Choices 대화상자가 열리며, 이는 Manufacturer Part Search panel 과 동일한 방식으로 사용됩니다(UI 전체 요소에 대한 자세한 내용은 해당 페이지 참조).

부품 선택 항목 만들기 – Add Part Choices 대화상자를 사용하여 필요한 제조업체 부품을 검색하고, 해당 항목을 선택한 다음 OK를 클릭하십시오.
부품 선택 항목 만들기 – Add Part Choices 대화상자를 사용하여 필요한 제조업체 부품을 검색하고, 해당 항목을 선택한 다음 OK를 클릭하십시오.

대화상자의 검색 결과는 Manufacturer Part 기준으로 표시되며, 연결된 SPN 항목은 해당 부품을 공급하는 활성화된 벤더를 반영합니다. 부품을 선택하면 Part Choices 목록에 추가되는 것은 제조업체 부품입니다. 특정 벤더/공급업체가 아닌 제조업체 부품을 사용하면, 해당 부품을 판매하는 공급업체를 기반으로 한 모든 솔루션을 함께 제공하는 단일 Part Choice를 얻게 됩니다(그리고 그 공급업체들은 Workspace를 통해 사용할 수 있어야 합니다).

대화상자를 사용하여 필요한 제조업체 부품을 검색하고, 부품을 선택한 다음 OK 버튼을 클릭하십시오. 제조업체 부품의 SPNs 항목(Supplier Part Numbers)을 클릭하면 해당 부품의 사용 가능한 공급업체를 확인하고, 가용성, 가격 등을 기준으로 올바른 부품 선택인지 판단할 수 있습니다. 선택한 부품은 Component Editor로 다시 입력되며, Part Choice 1 항목의 셀과 Preview 영역 모두에 반영됩니다.

Add Part Choices 대화상자를 사용해 추가된 예제 부품 선택 항목이 Component Editor에 다시 표시된 모습.
Add Part Choices 대화상자를 사용해 추가된 예제 부품 선택 항목이 Component Editor에 다시 표시된 모습.

필요에 따라 버튼을 클릭해 추가 부품 선택 항목을 계속 추가하십시오. 관련된 Part Choice n 항목은 자동으로 생성됩니다.

부품 선택 항목을 제거하려면 목록에서 해당 항목을 선택한 다음 버튼을 클릭하십시오.

Part choice가 제공하는 정보에 대해 자세히 알아보려면 Adding Supply Chain Information to a Component 페이지를 참조하십시오.

Part Choices의 자동 순위 지정

별표 기능을 사용하여 part choice에 사용자 순위를 지정할 수 있을 뿐만 아니라, Component editor에서 정의/편집 중인 컴포넌트의 part choices에 대해 자동으로 순위를 설정할 수도 있습니다.

  • 하나 이상의 컴포넌트 정의 항목을 선택한 다음, 선택 영역을 마우스 오른쪽 버튼으로 클릭하고 우클릭 메뉴에서 Set Part Choice Ranks Automatically 명령을 선택하여 선택한 컴포넌트의 part choices 순위를 설정하십시오.

  • 메인 메뉴에서 Tools » Set Part Choice Ranks Automatically 명령을 선택하여 모든 컴포넌트의 part choices 순위를 설정하십시오.

부품 선택은 설정된 순위에 따라 컴포넌트 정의 그리드와 편집기의 미리보기 영역에 정렬됩니다. 이미 순위가 지정된 부품 선택은 기존 순서를 유지합니다.

컴포넌트 정의에 데이터시트 첨부

Component Editor를 통해 컴포넌트를 정의하는 동안 하나 이상의 데이터시트를 하나 이상의 컴포넌트에 첨부할 수 있습니다. 예를 들어, 이를 통해 특정 패밀리에 속한 모든 컴포넌트에 동일하게 필요한 데이터시트를 빠르게 첨부할 수 있습니다.

Component Editor에서 컴포넌트를 편집하는 관점에서 본 다양한 데이터시트 연결.
Component Editor에서 컴포넌트를 편집하는 관점에서 본 다양한 데이터시트 연결.

컴포넌트 정의에 데이터시트를 첨부하는 작업은 여러 단계로 이루어지며, 여기서는 이를 요약하고 이후 섹션에서 자세히 설명합니다.

  1. 데이터시트 사용 활성화.
  2. 선택한 컴포넌트에 데이터시트 업로드.
  3. 업로드한 데이터시트를 다른 컴포넌트 정의에 할당.

컴포넌트 명명에 대한 유효성 검사

소프트웨어는 여러 사용자가 Workspace에 저장하기 위해 생성 중인 컴포넌트의 ID를 검증하여 중복 Item ID 문제를 방지합니다. 사용자가 Component Item을 생성하면 할당된 Item ID는 '잠금' 상태가 되어, 첫 번째 사용자가 해당 컴포넌트를 Workspace에 저장하지 않았거나 저장하지 않더라도 다른 사용자가 그 ID를 사용할 수 없게 됩니다. 다른 사용자가 컴포넌트 정의의 일부로 Item ID를 수동 변경하여 현재 기존 Item(또는 생성 예정 Item)에서 사용 중인 ID로 설정하면, 해당 ID는 적용 가능한 명명 규칙에 따라 다음으로 사용 가능한 미사용 ID로 변경됩니다.

저장 없이 30분이 지나면 잠긴 Component Item ID는 자동으로 해제됩니다.

컴포넌트 정의 복사하기

서로 약간만 다른 컴포넌트 정의를 빠르게 만들 수 있도록 편집기는 복사 기능을 제공합니다. 기존 정의를 복사하려면 정의 목록에서 해당 정의를 선택한 후 기본 메뉴에서 Edit » Make a copy of the component 명령을 선택하거나 마우스 오른쪽 버튼을 클릭하여 컨텍스트 메뉴에서 Make a copy of the component 명령을 선택합니다(단축키: Ctrl+D). 복사본은 정의 목록의 맨 아래에 추가됩니다.

복사본은 다음 측면에서 원본 컴포넌트 정의와 완전히 동일합니다.

  • Workspace 내 동일한 폴더를 대상으로 함 - 원본 컴포넌트가 존재하는 폴더 또는(아직 저장되지 않은 경우) 저장 대상 폴더.
  • 동일한 도메인 모델 참조.
  • Name, Description, Type, 템플릿 파라미터 및 추가 사용자 정의 파라미터에 대해 동일한 값 보유.

다음 점에서는 차이가 있습니다.

  • 원본 컴포넌트에 정의된 데이터시트는 포함되지 않음.

  • 원본 컴포넌트에 정의된 부품 선택은 포함되지 않음.

  • 다음으로 사용 가능한 고유 Item ID를 가짐.

  • 새 Component Item의 초기 리비전에 저장되도록 설정됨(ActionCreate Item(으)로 설정됨).

컴포넌트 정의 복사 예시 - 복사 후 필요에 따라 하나 이상의 파라미터 값 변경, 부품 선택 정의, 필요한 데이터시트 추가 등의 변경을 수행합니다.
컴포넌트 정의 복사 예시 - 복사 후 필요에 따라 하나 이상의 파라미터 값 변경, 부품 선택 정의, 필요한 데이터시트 추가 등의 변경을 수행합니다.

복사 후 필요에 따라 예를 들어 하나 이상의 파라미터 값 변경 등의 수정을 수행합니다.

복사 기능은 Copy Component 명령과 Paste Component 명령을 순서대로 사용하는 것과 유사합니다. 기존 컴포넌트 정의를 더 빠르게 복사할 수 있는 방법이지만, 복사는 단일 컴포넌트 정의에만 수행할 수 있는 반면 Copy/Paste Component 명령은 여러 정의에 대해 작동합니다.

컴포넌트 정의 그룹화

컴포넌트 정의는 표시되는 어떤 열 제목을 기준으로도 그룹화할 수 있습니다. 이렇게 하려면 열 헤더를 클릭한 채로 Drag a column header here to group by that column라고 표시된 텍스트 위로 드래그 앤 드롭합니다.

예를 들어 아래 이미지는 Case-Metric 파라미터를 기준으로 컴포넌트 정의를 그룹화한 모습을 보여줍니다. 이렇게 하면 그룹화 열의 서로 다른 값 개수만큼 컴포넌트 정의가 그룹으로 나뉘며, 이 경우 9개의 그룹이 생성됩니다.

열의 값을 기준으로 컴포넌트 정의를 그룹화하는 예시. 이 경우 Case-Metric 파라미터 기준.
열의 값을 기준으로 컴포넌트 정의를 그룹화하는 예시. 이 경우 Case-Metric 파라미터 기준.

열 헤더를 중첩하여 그룹 계층 구조를 만들 수 있습니다. 그룹화된 열 영역 내에서 드래그 앤 드롭을 사용해 필요에 따라 그룹화 '정렬 순서'를 다시 정의합니다.

컴포넌트 정의 정렬

컴포넌트 정의는 특정 열의 헤더를 클릭하여 정렬할 수 있습니다. 한 번 클릭하면 오름차순(해당 열의 내용 기준)으로 정렬되고, 다시 클릭하면 내림차순으로 정렬됩니다.

여러 열을 기준으로 정렬할 수도 있습니다. 이미 특정 열 기준으로 정렬된 상태에서 다른 열에서 Shift+Click하여 해당 열의 내용을 기준으로 '보조 정렬'을 수행합니다.

열의 정렬을 제거하려면 해당 헤더에서 Ctrl+Click합니다.

열 기반 컴포넌트 정의 필터링

Excel 스프레드시트처럼 컴포넌트 정의는 각 열의 내용을 기준으로 추가 필터링할 수 있습니다. 이렇게 하려면 열 헤더 오른쪽에 있는 작은 깔때기(필터) 아이콘()을 클릭합니다. 해당 열에 존재하는 각 값에 대한 체크박스가 포함된 메뉴가 표시됩니다. 필요한 체크박스를 활성화하면 해당 값을 가진 컴포넌트 정의만 목록에 남게 됩니다.

또는 더 세밀한 필터 제어를 위해 (Custom...)을 선택하면 Custom Filter 대화상자가 표시됩니다. 이 대화상자에서는 데이터 열에 적용할 필터 기준을 지정하여 표시할 정보 행을 정함으로써 요구사항에 맞는 사용자 정의 필터를 설정할 수 있습니다.

표준 열 필터링 또는 사용자 정의 열 필터링 적용 선택.
표준 열 필터링 또는 사용자 정의 열 필터링 적용 선택.

열 필터가 적용되면 필터 아이콘이 파란색()으로 표시되어 해당 열 기준의 필터링이 적용 중임을 나타냅니다. 필터링은 여러 데이터 열에 적용할 수 있습니다. 각 '열 필터'는 전체 필터에서 AND 조건으로 결합됩니다. 현재 적용 중인 필터의 텍스트 표현이 영역 하단에 표시됩니다.

열 필터링이 동작하는 예시.
열 필터링이 동작하는 예시.

열의 필터링을 지우려면 필터링 드롭다운에서 (All) 항목을 선택합니다. 필터링을 완전히 지우려면 필터 텍스트 표현 왼쪽의 버튼을 클릭합니다. 필터를 비활성화하려면 해당 텍스트 표현 왼쪽의 체크박스를 해제합니다. 다시 활성화하려면 체크박스를 선택합니다.
편집 세션 동안 방금 사용한 필터의 기록을 사용할 수 있습니다. 현재 필터의 텍스트 표현 오른쪽에 있는 버튼을 클릭하면 기록이 표시됩니다. 이 기록 목록은 임시 Component Editor를 닫으면 지워집니다.

현재 필터를 더 세부적으로 사용자 정의하려면 필터 텍스트 표현 맨 오른쪽의 버튼을 클릭하여 Filter Builder 대화상자를 엽니다.

Filter Builder 대화상자를 사용하여 더 정교한 필터링을 만들 수 있습니다.
Filter Builder 대화상자를 사용하여 더 정교한 필터링을 만들 수 있습니다.

이 대화상자를 사용하여 필요에 따라 더 정교하고 복잡한 필터를 만들 수 있습니다.

  • Filter - 클릭하여 추가 필터 조건에 액세스합니다. Clear All 를 클릭하면 모든 필터가 지워집니다. 선택 항목은 다음과 같습니다.
    • Add Condition - 클릭하여 equalsbetween 등과 같은 필터 조건을 추가합니다.
    • Add Group - 클릭하여 ANDOR 등과 같은 필터 그룹을 추가합니다.
  • Links - 다양한 링크를 클릭하여 필터를 추가로 정의합니다.
    • Id - 다양한 링크를 클릭하여 필터링 기준이 될 원하는 항목(예: DescriptionName 등)을 선택합니다.
    • AND 등 - 다양한 링크를 클릭하여 예를 들어 OR 등의 논리 연산자/유형을 지정합니다.
    • like - 다양한 링크를 클릭하여 equalsis blankis greater than 등과 같은 연산자를 지정합니다.
    • <empty> - 다양한 링크를 클릭하여 조건 값을 추가합니다. 링크를 클릭한 후 텍스트 상자에 원하는 값을 입력합니다.
  • press the button to add a new condition - 클릭하여 추가 조건을 더합니다.
자주 사용하는 필터는 저장하여 다시 사용할 수 있습니다. 이는 Filter Builder 대화상자에서 버튼을 클릭해 현재 필터를 Filters 파일(*.flt)로 저장하여 수행합니다. 이전에 저장한 필터를 다시 불러오려면 버튼을 클릭합니다.

데이터 표시

정의 중인 컴포넌트 유형에 따라 상당한 수의 파라미터가 있을 수 있으며, 이들이 다른 데이터 열과 함께 추가되면 부분적으로 읽기 어려운 내용이 뒤엉킨 상태가 될 수 있습니다. 이를 해결하기 위해 컴포넌트 정의 영역에는 몇 가지 표시 모드가 제공됩니다. 영역 오른쪽 하단의 컨트롤을 사용해 모드를 전환합니다.

이 컨트롤은 현재 활성화된 모드가 아니라, 클릭했을 때 활성화될 모드를 표시합니다.
  • Best Fit – 이 모드에서는 각 데이터 열이 해당 열 내의 모든 데이터를 표시할 수 있도록 가장 큰 데이터 항목에 맞춰 약간의 여백을 더해 크기가 조정됩니다. 각 열이 데이터를 표시하도록 크기 조정되므로, 열 전체가 현재 보이는 영역을 넘어 확장될 수 있습니다. 이를 지원하기 위해 가로 스크롤바가 제공되어 쉽게 읽을 수 있습니다.
  • Auto Width – 이 모드에서는 소프트웨어가 모든 데이터 열을 그리드의 보이는 영역 안에 표시하려고 시도하며, 필요에 따라 늘이거나 압축합니다. 데이터 열 수가 많지 않을 때는 잘 작동하지만, 열 수가 많아지면 가독성이 떨어질 수 있습니다.

Auto Width 및 Best Fit 표시 모드 사용 예시.
Auto WidthBest Fit 표시 모드 사용 예시.

데이터 표시를 더 돕기 위해 모델 열과 파라미터 열의 표시를 선택적으로 전환할 수 있습니다. 이는 편집기의 Required Models/Parameters 영역에서 각 항목에 대해 제공되는 Show 옵션을 사용하여 수행합니다.
데이터 표시를 세밀하게 조정하기 위해 데이터 열 너비를 수동으로 조정할 수도 있습니다. 열 헤더의 오른쪽 가장자리를 클릭해 드래그하세요.

컴포넌트 정의 – 편집 기법

생성하는 컴포넌트에 따라 Component Editor에는 상당수의 컴포넌트 정의가 포함될 수 있습니다. 경우에 따라 이러한 정의들은 아주 약간만 다를 수 있으며, 많은 정의가 유사한 모델 또는 파라메트릭 정보를 필요로 할 수 있습니다. 이 문서는 하나 이상의 컴포넌트 정의에 빠르게 변경을 적용할 수 있도록 다양한 편집 기능을 지원합니다.

  • 모델 및 파라미터에 대해 다중 셀 편집이 구현되어 있습니다. 표준 Ctrl+ClickShift+Click 키보드 기능을 사용하여 하나의 열 내 여러 데이터 셀을 선택해 작업할 수 있습니다. 여러 컴포넌트에 모델을 할당하려면 셀 범위를 선택한 다음 드롭다운을 클릭해 모델 링크 팝업 창을 표시합니다. 팝업에서 필요한 모델을 더블클릭하면 선택된 모든 모델 셀에 해당 모델이 할당됩니다.

    매개변수의 경우, 같은 열 내에서 필요한 셀들을 선택한 다음 포커스된 셀에 원하는 값을 입력하고, 다른 곳을 클릭하거나 Enter를 누르십시오. 선택된 모든 셀에 동일한 값이 적용됩니다.

    이 기능은 FolderPath에도 사용할 수 있습니다. 해당 컴포넌트 정의의 FolderPath 열에서 항목들을 선택한 뒤, 포커스된 항목의 버튼을 클릭하고 Choose Folder 대화상자에서 원하는 대상 폴더를 선택하십시오. 선택된 모든 정의의 FolderPath가 이 폴더를 가리키도록 변경됩니다.
  • 선택한 데이터 셀 사이에서 Ctrl+XCtrl+CCtrl+V를 사용하여 데이터를 잘라내기, 복사, 붙여넣기할 수 있습니다(또는 오른쪽 클릭 메뉴나 기본 Edit 메뉴의 해당 명령 사용).

    대상 셀이 클립보드 데이터와 호환되지 않으면 붙여넣기가 수행되지 않습니다(예: 파라메트릭 데이터를 모델 링크 필드에 붙여넣는 경우).

  • Delete 키를 사용하여 선택한 데이터 셀의 내용을 지울 수 있습니다(또는 오른쪽 클릭 메뉴의 Clear Contents 명령이나 기본 메뉴의 Edit » Clear Contents 명령 사용).

    Component Library 문서가 Component Template를 참조하는 경우, 다음 사항을 유의하십시오.

    • 템플릿에서 매개변수가 Read Only로 표시되어 있으면 해당 매개변수 셀의 내용을 지울 수 없습니다.
    • 템플릿에서 매개변수가 Required 로 표시되어 있으면 해당 매개변수 셀의 내용을 지웠을 때 값이 필요하다는 것을 알리기 위해 셀이 빨간 테두리로 강조 표시됩니다.
  • 선택한 컴포넌트 정의를 Ctrl+Shift+CCtrl+Shift+XCtrl+Shift+V를 사용하여 복사, 잘라내기, 붙여넣기할 수 있습니다(또는 오른쪽 클릭 메뉴나 기본 Edit 메뉴의 해당 명령 사용).

    • 단일 컴포넌트 정의를 빠르게 복제하려면 Make a copy of the component command를 사용하십시오.

    • 클립보드의 컴포넌트 정의는 Component Editor의 기본 그리드 영역에 두 가지 방식으로 붙여넣을 수 있습니다.

      • 현재 정의 목록의 끝에 추가 - 현재 선택된 정의가 없도록 한 다음 명령을 실행하십시오.
      • 현재 정의 덮어쓰기 - 덮어쓸 정의 위에서 오른쪽 클릭한 뒤 명령을 실행하십시오. 확인을 요청하는 대화상자가 나타나면 진행하려면 Yes 를 클릭하십시오. 기존에 정의된 셀 데이터는 붙여넣은 정의의 데이터로 덮어써집니다. 덮어쓰기는 포커스된 정의에만 적용됩니다. 클립보드에 여러 정의가 있으면 첫 번째 정의만 포커스된 정의 위에 붙여넣어지고, 나머지는 정의 목록 하단에 붙여넣어집니다.
  • 컴포넌트 정의 그리드 아래의 Remove Component 컨트롤, 오른쪽 클릭 메뉴 또는 기본 Edit 메뉴의 Remove <ComponentName> (Remove n Components) 명령, 또는 Ctrl+Del 단축키를 사용하여 선택한 컴포넌트 정의를 완전히 제거할 수 있습니다.
  • 기본 Edit 또는 View 메뉴나 기본 그리드 영역의 오른쪽 클릭 메뉴에서 Refresh 명령을 사용하거나, F5 키보드 단축키를 사용하거나, Component Library Standard 도구 모음의 버튼을 클릭하여 그리드 내용을 새로 고칠 수 있습니다.
  • 선택한 데이터 셀을 Windows 클립보드로 복사하여 외부 스프레드시트 응용프로그램에서 편집할 수 있습니다. 외부 스프레드시트의 컴포넌트 정의 정보도 컴포넌트 정의 영역에 다시 붙여넣을 수 있습니다.
또한 편집기 오른쪽 상단의 작은 화살표 를 클릭하여 Component Editor의 상단 영역을 접을 수 있으며, 이렇게 하면 전체 표시 영역을 컴포넌트 정의 편집에 사용할 수 있습니다.

저장된 정의 찾아보기

Workspace에 저장한 후에는 Components panel 또는 Explorer panel을 사용해 Workspace에서 직접 컴포넌트를 찾아볼 수 있습니다.

이미 저장되었고 현재 편집 중인 컴포넌트의 경우, 정의 영역에서 해당 항목을 오른쪽 클릭하고 Operations » Show in Explorer 명령을 선택하거나 기본 메뉴에서 Edit » Operations » Show In Explorer 명령을 선택하여 Component Editor에서 Workspace의 해당 Component Item으로 바로 이동할 수 있습니다.

저장을 마친 컴포넌트 리비전을 편집용으로 열어 둔 상태에서, Component Editor에서 직접 Explorer 패널의 해당 컴포넌트로 이동할 수 있습니다.
저장을 마친 컴포넌트 리비전을 편집용으로 열어 둔 상태에서, Component Editor에서 직접 Explorer 패널의 해당 컴포넌트로 이동할 수 있습니다.

기존 Component Item 대상 지정

대부분의 경우 대상 Workspace에 컴포넌트를 만드는 작업은 저장 과정의 일부로 두는 것이 일반적입니다. 컴포넌트 정의를 추가하고 Item ID를 할당하면 바로 진행할 수 있습니다. 말하자면 즉석에서 콘텐츠를 생성하는 방식입니다. 그러나 컴포넌트를 Workspace에서 직접 생성했거나 생성하려는 경우, 이 기존 컴포넌트들에 연결할 수도 있습니다. 또는 기존에 릴리스된 컴포넌트 정의와 연결된 대상 Component Item을 변경하려는 경우도 있을 수 있습니다.

컴포넌트 정의와 연결된 오른쪽 클릭 Operations 하위 메뉴(및 기본 메뉴의 Edit » Operations 하위 메뉴)에는 수동으로 생성한 컴포넌트에 정의를 연결할 수 있도록 지원하는 몇 가지 명령이 포함되어 있습니다.

  • Change Link To Target Item – 이 명령을 사용하면 Choose Target Item 대화상자에 접근할 수 있으며, 여기서 Workspace를 탐색하여 필요한 컴포넌트를 선택할 수 있습니다.

    선택한 컴포넌트 정의가 이미 컴포넌트에 연결되어 있으면 대화상자에 해당 컴포넌트가 선택된 상태로 표시됩니다. 아직 연결되어 있지 않으면 대화상자에 해당 정의에 대해 설정된 대상 폴더가 표시됩니다.

    대상 Workspace의 기존 컴포넌트에 연결되면 컴포넌트 정의의 Item ID 가 회색으로 표시되어(편집 불가) 변경할 수 없게 됩니다.

    이 명령은 컴포넌트 정의가 선택되어 있을 때만 해당 메뉴에서 사용할 수 있습니다. 여러 컴포넌트 정의가 선택된 경우 이 명령은 포커스된 정의에 대해 작동하며, 포커스된 정의는 선택된 셀 주위의 점선 테두리로 구분됩니다.
  • Clear Link To Target Item (Clear Links To Target Items) – 이 명령을 사용하면 Workspace의 기존 컴포넌트에 대한 링크를 해제할 수 있습니다. 그러면 컴포넌트 정의의 릴리스 관련 필드는 새 Item을 생성할 수 있는 상태로 되돌아갑니다.

    이 링크를 끊어야 하는 경우는 새 컴포넌트 세트로 다시 릴리스해야 할 때 발생할 수 있습니다. 예를 들어 이전에 릴리스한 후 Workspace에서 해당 컴포넌트를 삭제한 경우, 소스 라이브러리에는 여전히 링크가 정의되어 있지만 Workspace에서 더 이상 컴포넌트를 찾을 수 없으므로 그 링크는 유효하지 않게 됩니다.

    컴포넌트 정의를 이미 저장한 상태에서 이 절차를 수행하면, 해당 정의와 이전에 연결되어 있던 컴포넌트는 서로에 대한 연결 정보를 잃게 됩니다.

    대상 Workspace의 기존 컴포넌트에 대한 링크를 해제하면 컴포넌트 정의의 Item ID 를 다시 편집할 수 있게 됩니다. 그리드의 Release  영역에 있는 Action  필드의 항목은 Create Item로 변경되며, 이는 현재 해당 컴포넌트 정의가 대상 Workspace의 컴포넌트에 연결되어 있지 않음을 나타냅니다.

컴포넌트 규칙 검사 실행

Component Editor에서 정의하거나 편집한 Workspace Library 컴포넌트를 연결된 Workspace에 저장하고 설계에서 사용할 수 있도록 하기 전에, 구성된 설정에 따라 이 컴포넌트가 요구사항을 충족하는지 반드시 확인해야 합니다. Component Editor는 컴포넌트를 Workspace에 다시 저장하려고 하거나 이 기능을 수동으로 실행할 때 검증, 즉 Component Rule Check 을 수행합니다.

컴포넌트 검증에 대해 자세히 알아보려면 Validating a Component 페이지를 참조하십시오.

연결된 시뮬레이션 모델에 대한 참고

Related page: 시뮬레이션 모델 생성

심볼 및 풋프린트 모델과 마찬가지로, 컴포넌트도 시뮬레이션 모델의 리비전을 참조할 수 있습니다. 이 유형의 모델 링크를 추가하는 방법은 심볼 및 풋프린트와 정확히 동일하므로, 이에 대한 정보는 앞선 섹션을 참조하십시오. 여기서는 컴포넌트 수준 시뮬레이션 매개변수 포함과 핀 매핑 구성에 대해 살펴봅니다.

컴포넌트 수준 시뮬레이션 매개변수 추가

설계에서 컴포넌트용 시뮬레이션 모델을 사용할 때, 해당 모델에 특화된 매개변수는 두 가지 다른 수준에서 지정할 수 있습니다.

  • Model-Level Parameter – 시뮬레이션 모델 정의 자체의 일부로 지정되며(SimModel 파일 내), 연결된 시뮬레이션 모델의 리비전에 그 정의와 함께 저장됩니다.
  • Component-Level Parameter – 컴포넌트 정의의 일부로 지정되며(여기서는 Component Editor에서), 연결된 컴포넌트의 리비전에 그 정의와 함께 저장됩니다.
컴포넌트 수준 매개변수는 여러 모델 간에 공유되거나, 설계자가 그러한 매개변수를 회로도에서 보이거나 편집 가능하게 하려는 경우(예: value, frequency 등)에 사용됩니다.

매개변수는 Component Editor의 Required Models/Parameters 영역에서 컴포넌트 수준으로 추가됩니다. 매개변수 이름은 모델 수준에서 정의된 매개변수와 동일해야 한다는 점에 유의하는 것이 중요합니다. 모델 수준 매개변수, 즉 컴포넌트 수준에 추가할 수 있는 매개변수(와 그 이름)를 확인하려면 SIM 모델 링크를 선택한 다음 미리보기 창 하단의 View Parameters 컨트롤을 클릭하십시오.

Simulation Model Item의 모델 수준 매개변수를 확인하여 어떤 매개변수를 컴포넌트 수준에 추가할 수 있는지, 그리고 이름이 어떻게 지정되어 있는지 확인하십시오.
Simulation Model Item의 모델 수준 매개변수를 확인하여 어떤 매개변수를 컴포넌트 수준에 추가할 수 있는지, 그리고 이름이 어떻게 지정되어 있는지 확인하십시오.

사용 가능한 모델 수준 매개변수를 확인했다면 이제 그와 동일한 매개변수를 컴포넌트 수준에 추가하여 모든 컴포넌트 정의에서 사용할 수 있습니다. 이렇게 하려면 Required Models/Parameters 영역 하단의 Add 컨트롤을 클릭하고 메뉴에서 Parameter를 선택하십시오. 목록에 새 매개변수 항목이 추가됩니다. 필요에 따라 이름을 변경하되, 해당 모델 수준 매개변수의 이름과 정확히 일치하도록 하십시오.

시뮬레이션 관련 매개변수를 컴포넌트 수준에 추가합니다. 이 예제 컴포넌트가 참조하는 Component Template 덕분에 이미 하나의 매개변수인 Area Factor를 사용할 수 있다는 점에 유의하십시오.
시뮬레이션 관련 매개변수를 컴포넌트 수준에 추가합니다. 이 예제 컴포넌트가 참조하는 Component Template 덕분에 이미 하나의 매개변수인 Area Factor를 사용할 수 있다는 점에 유의하십시오.

저장된 컴포넌트의 인스턴스를 설계에 배치하면, 시뮬레이션 매개변수는 동일한 매개변수의 모델 수준 값과 다른 값을 컴포넌트 수준에서 가질 수 있습니다. 넷리스트가 생성될 때는 컴포넌트 수준 매개변수가 우선합니다.
일부 내장 SPICE3f5 모델의 경우, 컴포넌트 수준에서 매개변수 값을 입력하면 연결된 모델 파일(*.mdl)에 정의된 관련 매개변수를 덮어쓰게 됩니다. 예를 들어 반도체 커패시터의 경우, 컴포넌트 수준 Width 매개변수에 값을 지정하면 연결된 모델 파일의 DEFW 매개변수에 지정된 값보다 우선합니다. 서브서킷 모델에 대해 컴포넌트 수준 매개변수가 지정된 경우에도, 그 값은 연결된 서브서킷 파일(*.ckt)에 정의된 값을 덮어씁니다.

핀 매핑

필요한 SIM 모델에 대한 링크를 선택한 후에는 회로도 도메인에서 표현되는 컴포넌트의 핀이 시뮬레이션 모델의 핀에 올바르게 매핑되었는지 확인해야 합니다. 이는 컴포넌트 정의의 SIM 모델 항목을 오른쪽 클릭하고 컨텍스트 메뉴에서 Operations » Edit Pin Mapping를 선택하거나, SIM 모델 셀을 선택한 다음 기본 메뉴에서 Edit » Operations » Edit Pin Mapping 명령을 선택하여 여는 Pin Mapping 대화상자에서 수행합니다. 각 회로도 핀에 대해 제공되는 드롭다운을 사용하여 연결된 Model Pin 항목을 적절히 변경하십시오. 디바이스가 멀티파트인 경우 각 파트의 매핑을 반드시 확인하십시오.

회로도 핀과 모델 핀 간 매핑이 올바른지 확인합니다.
회로도 핀과 모델 핀 간 매핑이 올바른지 확인합니다.

멀티파트 컴포넌트의 경우, 시뮬레이션에서 특정 파트를 제외할 수 있는 기능도 Pin Mapping 대화상자에서 설정합니다.
내장 SPICE3f5 및 지원되는 PSpice 모델의 경우, 모델의 각 핀 기능은 SPICE 3f5 사용자 매뉴얼에서 해당 모델의 일반 형식 섹션에서 확인할 수 있습니다. 서브서킷 모델의 경우 제조업체가 일반적으로 각 모델 핀에 대해 그 핀의 기능을 설명하는 주석을 삽입합니다. 주석이 보이지 않는다면, 일반적으로 해당 모델의 핀 배열은 실제 물리 디바이스의 핀 배열과 동일합니다. 이런 경우 디바이스의 데이터시트를 참조하십시오.
AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

콘텐츠