PCB 풋프린트 생성하기

제작된 보드에서 부품이 차지하는 영역은 부품 풋프린트로 정의됩니다. 일반적인 풋프린트에는 패드와 부품 오버레이가 포함되며, 필요한 경우 기타 기구 관련 세부 정보도 포함될 수 있습니다. 아래 예시 풋프린트에서는 이 부품이 보드의 컷아웃 위로 걸쳐지도록 장착되기 때문에, 부품 외형의 대부분이 (노란색) 오버레이가 아니라 기계 레이어(초록색 선) 위에 정의되어 있습니다.

풋프린트는 부품이 차지하는 공간을 정의하고, 부품 핀/패드와 보드 배선 사이의 접속 지점을 제공합니다. 
풋프린트는 부품이 차지하는 공간을 정의하고, 부품 핀/패드와 보드 배선 사이의 접속 지점을 제공합니다.

이 풋프린트에 장착되는 부품은 3D Body 객체를 사용해 모델링할 수 있습니다. 3D Body 객체는 아래 이미지에 표시된 것처럼 일반적인 MCAD 형식 모델을 가져올 수 있는 컨테이너로 사용됩니다.

적절한 MCAD 모델은 3D Body 객체로 가져올 수 있습니다.
적절한 MCAD 모델은 3D Body 객체로 가져올 수 있습니다.

기성 PCB 부품을 제공하는 다양한 리소스(예: Manufacturer Part Search panel)가 풍부하게 제공되더라도, 엔지니어 경력 중 어느 시점에는 사용자 정의 PCB 부품을 직접 만들어야 할 가능성이 높습니다. PCB 부품 풋프린트는 PCB 편집기에서 사용할 수 있는 것과 동일한 기본 객체 세트를 사용하여 PCB Footprint 편집기에서 생성됩니다. 풋프린트 외에도 회사 로고, 제작 정의, 그리고 보드 설계 중 필요한 기타 객체 역시 PCB 부품으로 저장할 수 있습니다.

새 PCB 풋프린트 만들기

풋프린트는 연결된 Workspace에서 직접 생성할 수 있습니다. 방법은 다음과 같습니다.

  1. 메인 메뉴에서 File » New » Library 을(를) 선택한 다음, 열리는 New Library 대화상자에서 대화상자의 Workspace 영역에 있는 Create Library Content » Footprint 을(를) 선택합니다.

    New Library 대화상자를 사용하여 새 Workspace Footprint 만들기
    New Library 대화상자를 사용하여 새 Workspace Footprint 만들기

  2. 열리는 Create New Item 대화상자에서 필요한 정보를 입력하고, Open for editing after creation 옵션이 활성화되어 있는지 확인한 뒤 OK을(를) 클릭합니다. Workspace Footprint가 생성되고 임시 PCB Footprint 편집기가 열리며, .PcbLib 문서가 활성 문서로 표시됩니다. 이 문서의 이름은 Item-Revision에 따라 다음 형식으로 지정됩니다: <Item><Revision>.PcbLib (예: PCC-001-0001-1.PcbLib). 이 문서를 사용하여 아래에 설명된 대로 풋프린트를 정의합니다.

    Workspace Footprint의 초기 리비전을 편집하는 예 - 임시 PCB 풋프린트 편집기는 풋프린트를 정의할 수 있는 문서를 제공합니다.
    Workspace Footprint의 초기 리비전을 편집하는 예 - 임시 PCB 풋프린트 편집기는 풋프린트를 정의할 수 있는 문서를 제공합니다.

  3. 풋프린트 정의가 완료되면, Projects 패널 내 풋프린트의 항목 오른쪽에 있는 Save to Server 컨트롤을 사용해 Workspace에 저장합니다. 그러면 Edit Revision 대화상자가 나타나며, 여기서 Name, Description을 변경하고 필요에 따라 릴리스 노트를 추가할 수 있습니다. 저장 후 문서와 편집기는 닫힙니다.

저장된 Workspace Footprint는 Component Editor의 Single Component Editing mode 또는 Batch Component Editing mode에서 부품을 정의할 때 사용할 수 있습니다.

Workspace Footprint는 Components panel을 사용해 찾아볼 수 있습니다. 패널 상단의  버튼을 클릭하고 Models을(를) 선택하여 모델 표시를 활성화한 다음, Footprints 카테고리를 선택합니다.

Workspace Footprint를 편집하려면 Components panel에서 해당 항목을 마우스 오른쪽 버튼으로 클릭하고 Edit 명령을 선택합니다. 그러면 다시 임시 편집기가 열리고, 해당 풋프린트가 편집 가능한 상태로 열립니다. 필요한 변경을 수행한 뒤, 해당 문서를 Workspace Footprint의 다음 리비전으로 저장합니다.

편집한 풋프린트를 Workspace에 저장할 때 현재 풋프린트의 라이프사이클 상태를 유지할 수 있습니다. 이 기능은 다시 저장할 때() Create Revision 대화상자에서 사용할 수 있는 Preserve lifecycle state (not recommended) 옵션으로 제어됩니다. 이 옵션이 활성화되면 새 풋프린트 리비전은 이전 리비전의 라이프사이클 상태로 자동 설정됩니다. 이 기능은 Allow to skip lifecycle state change for new revisions 운영 권한이 할당된 사용자에게 제공됩니다(Setting Global Operation Permissions for a Workspace에 대해 자세히 알아보기).

또한 Component Editor의 Single Component Editing mode 또는 Batch Component Editing mode에서 해당 Workspace Component를 편집하는 과정에서, 사용 중인 Workspace Footprint를 즉시 직접 업데이트할 수도 있습니다.
  • 설계자 관점에서 보면 Workspace Component는 모든 설계 도메인 전반에서 해당 부품을 표현하는 데 필요한 모든 정보를 하나의 엔티티에 모아 둡니다. 그런 의미에서 이것은 하나의 컨테이너, 즉 모든 도메인 모델과 파라메트릭 정보가 저장되는 ‘버킷’으로 생각할 수 있습니다. 다양한 도메인에서의 표현 측면에서 Workspace Component는 Workspace 도메인 모델 자체를 포함하는 것이 아니라, 이러한 모델에 대한 링크를 포함합니다. 이러한 링크는 부품을 정의할 때 지정됩니다.
  • PCB 풋프린트는 기존의 구형 세대(SchLib, PcbLib, IntLib, DbLib, SVNDbLib) 부품 라이브러리를 가져오는 과정의 일부로 Workspace에서 생성할 수도 있습니다. 이 과정을 위한 인터페이스인 Library Importer 는 선택한 초기 라이브러리를 사용자의 Workspace로 가져오는 직관적인 흐름을 제공합니다. Library Importer에 대해 자세히 알아보십시오.
  • 새 Workspace Footprint는 Component Editor in its Single Component Editing mode에서 Workspace Component를 정의할 때도 생성할 수 있습니다.
  • 풋프린트는 file-based PCB footprint library의 일부로도 생성할 수 있습니다.

PCB 풋프린트 정의하기

풋프린트는 최종적으로 보드의 어느 면에 배치되든 항상 상단 면 기준으로 작성되며, PCB 편집기에서 사용할 수 있는 것과 동일한 도구 및 설계 객체 세트를 사용합니다. 표면실장 패드와 솔더 마스크 정의 같은 레이어별 속성은 부품 배치 중 풋프린트를 보드의 반대쪽 면으로 뒤집을 때 적절한 하단 면 레이어로 자동 전송됩니다.

설계 객체는 어떤 레이어에든 배치할 수 있지만, 외형은 일반적으로 Top Overlay(실크스크린) 레이어에 만들고 패드는 멀티레이어(스루홀 부품 핀용) 또는 Top Signal 레이어(표면실장 부품 핀용)에 배치합니다. 풋프린트를 PCB에 배치하면, 풋프린트를 구성하는 모든 객체는 정의된 레이어에 할당됩니다.

조이스틱 부품 풋프린트의 2D 및 3D 보기입니다. 3D 이미지에는 해당 부품에 대해 가져온 STEP 모델이 표시됩니다. 패드와 부품 오버레이가 STEP 모델 아래에 보인다는 점에 유의하십시오.
조이스틱 부품 풋프린트의 2D 및 3D 보기입니다. 3D 이미지에는 해당 부품에 대해 가져온 STEP 모델이 표시됩니다. 패드와 부품 오버레이가 STEP 모델 아래에 보인다는 점에 유의하십시오.

이 페이지에 표시된 풋프린트는 필요한 절차를 설명하기 위한 예시일 뿐이며, 치수적으로 정확하지는 않습니다. 새 풋프린트는 항상 제조업체의 데이터시트와 대조하여 사양을 확인하십시오.

수동으로 부품 풋프린트를 생성하는 일반적인 순서는 다음과 같습니다.

  1. 설계 공간 준비: 스냅 옵션 정의, 그리드 및 가이드 구성 - 자세히 알아보기.

  2. 풋프린트는 PCB 풋프린트 편집기 중앙의 설계 공간 기준점을 중심으로 작성해야 합니다. 이 기준점은 실제로 설계 공간의 상대 원점이며, Place 및 Move 작업에서 커서가 부품 풋프린트를 집는 기준점이 됩니다(현재 PCB Editor – General 대화상자의 Preferences 페이지에 있는 Object Snap Options에 따라 다름). J, R 단축키를 사용하면 기준점으로 바로 이동할 수 있습니다. 풋프린트를 만들기 전에 기준점으로 이동하는 것을 잊었다면, Edit » Set Reference 하위 메뉴 명령을 사용해 기준 패드를 풋프린트로 가져올 수 있습니다.
    • Pin 1 - 부품 기준점을 부품 풋프린트의 핀 1로 설정합니다.

    • Center - 부품 기준점을 부품 풋프린트의 중심으로 설정합니다.

    • Location - 부품 기준점을 사용자 정의 위치로 설정합니다.

    선택한 점은 0,0 으로 설정되며, 새 상대 원점이 되고 모든 기본 객체의 위치가 이 점을 기준으로 갱신됩니다.

  3. 부품 요구사항에 따라 pads (Place » Pad)를 배치합니다. Place Pad 명령을 실행한 후 첫 번째 패드를 배치하기 전에 Tab 키를 눌러 Properties panel을 열고 패드 Designator, Size and Shape, Layer, 그리고(스루홀 패드의 경우) Hole Size을 포함한 모든 패드 속성을 정의합니다. 이후 패드 배치에서는 Designator가 자동으로 증가합니다. 표면실장 패드의 경우 Layer Top Layer로 설정합니다. 스루홀 패드의 경우 Layer Multi-Layer로 설정합니다.

    일부 풋프린트에는 불규칙한 형상의 패드가 필요합니다. 이 경우 사용자 정의 형상의 패드 객체를 사용하면 됩니다. 자세한 내용은 Customizing a Pad Stack 페이지를 참조하십시오.
    • 새 부품 풋프린트를 만들 때 가장 중요한 절차 중 하나는 부품을 PCB에 납땜하는 데 사용될 패드를 배치하는 것입니다. 이 패드들은 실제 디바이스의 핀과 정확히 대응되도록 반드시 정확한 위치에 배치되어야 합니다.
    • 또한 패드 Designator를 지정할 때도 주의해야 하는데, Altium Designer는 이 속성을 사용하여 회로도 심볼의 핀 번호와 매핑하기 때문입니다.
  4. 패드를 정확히 배치하려면 이 작업 전용 그리드를 설정하는 것을 고려하십시오. Ctrl+G 단축키를 사용해 Cartesian Grid Editor dialog를 열고, Q 키를 사용해 그리드를 Imperial과 Metric 사이에서 전환할 수 있습니다.

  5. 마우스로 이동하면서 패드를 정확히 배치하려면 키보드 화살표 키를 사용해 현재 그리드 증분만큼 커서를 이동합니다. 또한 Shift를 누르고 있으면 그리드의 10배 단위로 이동합니다. 현재 X, Y 위치는 상태 표시줄과 Heads Up 디스플레이에 표시됩니다. Heads Up Display에는 현재 위치와 마지막 클릭 위치부터 현재 커서 위치까지의 델타가 모두 포함됩니다. Shift+H 단축키를 사용해 Heads Up 표시를 켜거나 끌 수 있습니다. 또는 배치된 패드를 더블클릭하여 편집하고 Properties panel에서 필요한 X 및 Y 위치를 입력할 수 있습니다.

  6. 설계 공간에서 두 점 사이의 거리를 확인하려면 Reports » Measure Distance을(를) 사용하십시오(단축키 Ctrl+M). 상태 표시줄의 안내를 따르십시오.

  7. 솔더 마스크 및 페이스트 마스크와 같은 패드별 속성은 패드 치수와 해당 마스크 설계 규칙을 기반으로 자동 계산됩니다. 마스크 설정은 각 패드마다 수동으로 정의할 수 있지만, 이렇게 하면 나중에 보드 설계 과정에서 이러한 설정을 수정하기가 어려워집니다. 일반적으로는 설계 규칙으로 해당 패드를 지정할 수 없을 때만 이렇게 합니다. 규칙은 보드 설계 중 PCB 편집기에서 정의된다는 점에 유의하십시오.

  8. 트랙, 아크 및 기타 기본 객체를 사용하여 Top Overlay 레이어의 PCB 실크스크린에 표시될 부품 외형을 정의합니다. 배치 중 부품이 보드 하단으로 뒤집히면 오버레이는 Bottom Overlay 레이어로 자동 전송됩니다.

  9. 배치 코트야드와 같은 추가 기계 세부 정보를 정의하려면 기계 레이어에 트랙 및 기타 기본 객체를 배치합니다. 기계 레이어는 범용 레이어입니다. 이러한 레이어의 기능을 정하고 모든 풋프린트에서 일관되게 사용해야 합니다.

  10. PCB에 장착될 실제 부품의 3차원 형상을 정의하려면 3D Body objects를 배치합니다.

    풋프린트에 추가된 3D Body 객체는 연결된 Workspace에 업로드된 3D model을 참조할 수 있습니다.
  11. Designator 및 Comment 문자열은 PCB 설계 공간에 배치될 때 풋프린트의 Overlay 레이어에 자동으로 추가됩니다. 추가 Designator 및 Comment 문자열은 기계 레이어에 .Designator.Comment 특수 문자열을 배치하여 포함할 수 있습니다.

    Designator 및 Comment 문자열을 배치할 때는 PCB 편집기에서 Layer Pair를 정의해야 합니다. 이렇게 하면 문자열이 부품이 장착된 보드 면에 연결되고, 부품이 뒤집힐 때 문자열도 보드의 반대쪽 면으로 함께 뒤집히게 됩니다. 자세한 내용은 아래의 Handling Special Layer-specific Requirements 섹션을 참조하십시오.
  12. 풋프린트의 속성(예: 이름 및 설명)은 Properties panel의 Library Options 모드에서 Footprint 탭에서 정의합니다(설계 공간에서 어떤 객체도 선택되지 않았을 때 활성화되며, 메인 메뉴의 Tools » Footprint Properties 명령으로 접근 가능). 사용 가능한 옵션과 컨트롤에 대한 자세한 내용은 아래의 section below를 참조하십시오.

  • 모든 풋프린트에서 표준화된 패드/비아 정의를 위해 Pad/Via 라이브러리(*.PvLib)를 Pad/Via 배치에 사용할 수 있습니다 - 자세히 알아보기.
  • PCB Footprint 편집기는 풋프린트 생성 과정을 빠르게 진행할 수 있도록 몇 가지 Wizard도 제공합니다.
    • IPC Compliant Footprint Wizard – 는 IPC 표준 7351 Revision B를 진정으로 준수하는 PCB 풋프린트를 생성합니다 - Generic Requirements for Surface Mount Design and Land Pattern Standard – 자세히 알아보기.
    • file-based PCB footprint library로 작업할 때는 IPC Compliant Footprints Batch Generator 를 사용하여 여러 밀도 레벨의 다수 풋프린트를 빠르게 생성할 수 있습니다 - 자세히 알아보기.
    • Footprint Wizard 는 다양한 패키지 유형 중에서 선택하고 적절한 정보를 입력하면 부품 풋프린트를 자동으로 작성해 줍니다 - 자세히 알아보기.

설계 공간 준비하기

기본 설정에서는 그리드가 점으로 표시됩니다. 원한다면 그리드를 선으로 표시할 수도 있습니다. 이 설정은 아래 이미지와 같이 Properties panel의 Properties 버튼을 클릭하여 열 수 있는 Grid Editor 대화상자에서 구성합니다. 또는 Ctrl+G 단축키를 눌러 대화상자를 열 수 있습니다.

이미지에서는 미세 그리드는 점으로, 거친 그리드는 선으로 표시됩니다.
이미지에서는 미세 그리드는 점으로, 거친 그리드는 선으로 표시됩니다.

Properties Panel

PCB 풋프린트 편집기에서 풋프린트를 편집하는 동안 설계 공간에서 현재 선택된 설계 객체가 없으면, Properties panel에는 Library Options이(가) 표시됩니다.

다음의 접을 수 있는 섹션에는 패널의 General 탭에서 사용할 수 있는 옵션과 컨트롤에 대한 정보가 포함되어 있습니다.

다음 접을 수 있는 섹션에는 패널의 Footprint 탭에서 사용할 수 있는 옵션과 컨트롤에 대한 정보가 포함되어 있습니다:

Footprint 탭을 사용하여 Properties 패널에서 풋프린트 속성을 정의하는 기능은 PCB.FootprintParameters 옵션이 Advanced Settings dialog에서 활성화된 경우에 사용할 수 있습니다. 이 옵션이 비활성화되면 풋프린트 속성은 PCB Library Footprint 대화상자()를 사용하여 정의합니다. 이 대화상자는 메인 메뉴에서 Tools » Footprint Properties 명령을 선택하거나, PCB Library 패널의 Footprints 영역에서 풋프린트 항목을 선택한 뒤 Edit 버튼을 클릭하거나, PCB Library 패널의 Footprints 영역에서 풋프린트 항목을 더블클릭하여 열 수 있습니다.

설계 객체를 선택하면 패널에 해당 객체 유형에 맞는 옵션이 표시됩니다. 다음 표에는 PCB 풋프린트 설계 공간 내에 배치할 수 있는 객체 유형이 나열되어 있습니다. 링크를 클릭하면 해당 객체의 속성 페이지로 이동합니다.

3D Body Arc
Arc Keepout Fill
Fill Keepout Pad
Region Region Keepout
Text (String, Text Frame) Track
Track Keepout Via

Solder and Paste Mask Expansions

PCB 풋프린트 편집기에서 솔더 및/또는 페이스트 마스크가 올바르게 정의되었는지 확인하려면 View Configuration panel을 열고 각 마스크 레이어에 대해 표시 옵션()을 활성화하십시오.

각 패드 가장자리 둘레에 Top Solder Mask 레이어 색상으로 나타나는 링은, multi-layer가 레이어 그리기 순서의 맨 위에 있어 최상단에 그려지기 때문에, 멀티레이어 패드 아래에서 확장량만큼 돌출된 솔더 마스크 형상의 가장자리를 나타냅니다. Layer Drawing Order Preferences 대화상자의 PCB Editor - Display page 에서 설정됩니다).

아래 이미지는 각 패드의 가장자리 둘레에 보라색(Top Solder Mask 레이어의 색상) 테두리가 나타나는 PCB 풋프린트를 보여줍니다.

레이어를 빠르게 순환하려면 Single Layer Mode(Shift+S)를 Ctrl+Shift+Wheel roll와 함께 사용하십시오.

기본적으로 마스크 레이어에 생성되는 형상은 패드 형상이며, 풋프린트가 배치된 PCB에 설정된 Solder Mask ExpansionPaste Mask Expansion 설계 규칙에 지정된 양만큼 확장 또는 축소됩니다. 경우에 따라 이러한 확장 설계 규칙을 재정의하고 패드 속성으로 마스크 확장을 지정하거나, 미리 정의된 표준 마스크 형상 세트에서 선택하거나, 사용자 정의 형상을 직접 만들어야 할 수 있습니다. 이러한 경우에는 선택한 패드의 Properties 패널에서 페이스트/솔더 마스크를 구성할 수 있습니다 - 자세히 알아보기. 또는 필요한 마스크 레이어에 적절한 프리미티브(Region, Track 등)를 배치할 수도 있습니다.

PCB 라이브러리에서는 규칙 기반 솔더 마스크 확장을 사용하는 모든 객체의 확장 값이 0 mil과 같게 됩니다. 이 기능은 PCB.SolderMaskZeroExpansion 옵션이 Advanced Settings dialog에서 활성화된 경우에 사용할 수 있습니다. 이 옵션이 비활성화되면 PCB 라이브러리에서 이러한 객체의 솔더 마스크 확장 값은 4 mil입니다.

Parameter Support

Altium Designer에서 객체에 적용되는 파라미터는 PCB 설계에 추가 정보를 더할 수 있는 강력하고 유연한 수단을 제공합니다. 상위 객체의 속성으로 적용되는 파라미터는 프로젝트, 문서, 템플릿, 설계 문서 내 개별 객체 등 다양한 수준에 적용할 수 있습니다.

자세한 내용은 Parameter object를 참조하십시오.

PCB 공간에서 사용할 수 있게 된 파라미터는 Queries, Design Rules, Scripts, Variants를 필터링하는 데 사용할 수 있으며, 배치된 Footprint에서 사용자 지정 문자열을 호출하기 위해 PCB 컴포넌트 풋프린트에 적용할 수 있습니다.

Parameters via an Engineering Change Order

PCB 파라미터 기능은 ECO 메커니즘과 PCB 문서에 포함된 기능을 기반으로 하며, 이를 통해 사용자 정의 컴포넌트 파라미터를 PCB 공간으로 전송하고 유지할 수 있습니다. 이는 단방향 전송이며, 전달된 파라미터는 PCB 도메인에서 읽기 전용입니다.

파라미터 전송은 회로도에서 PCB로 ECO를 생성할 때 Design » Update PCB Document 메뉴 명령을 사용하여 수행됩니다.

ECO가 실행되면( Execute Changes 버튼 사용), 새로 정의된 사용자 정의 회로도 컴포넌트 파라미터는 해당하는 PCB 설계의 풋프린트 참조로 전송됩니다. 

PCB로의 파라미터 감지 및 마이그레이션은 프로젝트의 옵션 설정(Project » Project Options)에 의해 결정됩니다. Project Options 대화상자에서 Comparator 탭의 Differences Associated with Parameters 섹션과 ECO Generation 탭의 Modifications Associated with Parameters 섹션에서 차이 감지 및 수정 동작을 설정하십시오.

PCB 편집기에서 전송된 파라미터를 보려면 컴포넌트를 더블클릭하여 Properties 패널을 연 다음 Parameters 탭을 선택하십시오. 이 탭에는 선택한 컴포넌트 풋프린트에 할당된 현재 사용자 파라미터가 나열됩니다. 선택한 컴포넌트 풋프린트의 파라미터는 Components 패널에서도 사용할 수 있습니다.

Information Reference Links

PCB 도메인은 회로도에서 미리 정의된 ComponentLink 파라미터를 자동으로 수용합니다. 이들은 일반적으로 특정 파일이나 인터넷 위치에 대한 데이터 참조 링크를 설정하는 파라미터 쌍(Description 및 링크 URL)으로 정의되며, 보통 제조업체 웹사이트 또는 데이터시트 URL입니다.

Reference Link 파라미터에 대한 정보는 회로도 라이브러리의 Defining Clickable Links to Reference Information 및 PCB 문서의 Accessing Clickable Links to Reference Information 을 참조하십시오.

회로도와 PCB 설계 공간 모두에서, 링크는 컴포넌트 위에 마우스를 올린 상태에서 오른쪽 클릭 컨텍스트 메뉴(하위 메뉴 옵션 References 아래)를 통해 접근할 수 있습니다. 이러한 특수 파라미터는 Properties 패널에서 추가되며, PCB 공간으로 전송되면 컴포넌트 풋프린트 파라미터로 표시됩니다. 

Parameters in Source Footprints

PCB로 전달된 파라미터는 컴포넌트 풋프린트를 통해 추가적인 보드 생산 정보 또는 기능 정보를 제공하는 데 사용할 수 있습니다. 소스 라이브러리 수준에서 풋프린트에 특수 파라미터 문자열을 추가하면, 사용자 지정 문자열이 대상 기계 레이어 또는 오버레이에서 해석됩니다.

사용자 정의 파라미터를 나타내는 특수 문자열은 Properties 패널의 특수 문자열 버튼 및 드롭다운()을 사용하여 소스 컴포넌트 풋프린트에 추가할 수 있습니다.

아래 라이브러리 풋프린트에서는 특수 문자열 .Designator 이 Mechanical 2 레이어에 배치되어 있습니다.

사용자 파라미터를 나타내는 특수 문자열을 컴포넌트 풋프린트에 추가할 수 있습니다.

해당 사용자 지정 파라미터가 회로도 컴포넌트에도 적용되고 파라미터 데이터가 PCB로 전송되면, 해석된 풋프린트 문자열은 보드 보기와 생성된 출력 파일 모두에 표시됩니다. 이 경우 특수 파라미터 문자열에는 조립을 돕기 위한 사용자 정의 컴포넌트 부품 식별자가 포함됩니다.

특수 문자열로서 컴포넌트 풋프린트에 사용자 파라미터를 적용하면, 스위치와 커넥터의 기능 라벨처럼 다양한 사용자 정의 PCB 요구사항에도 활용할 수 있습니다. 예를 들어 이러한 컴포넌트 유형의 풋프린트에서는 'function' 파라미터 문자열을 Top Overlay에 배치할 수 있습니다.

보드 레이아웃에서 특수 문자열의 해석된 값을 보려면 View Configuration 패널의 View Options 탭에 있는 Additional Options region 아래에서 Special Strings 옵션을 활성화하십시오. 생성된 출력 파일에서는 특수 문자열이 항상 변환됩니다.
회로도 편집기에서는 필요에 따라 Preferences 대화상자의 Schematic – Graphical Editing 페이지에서 Display Names of Special Strings that have No Value Defined 옵션을 활성화하십시오.

Parameter Queries

PCB 도메인의 파라미터 문자열은 Altium Designer 쿼리 언어를 통해서도 접근할 수 있으므로, Find Similar Objects 기능을 포함한 객체 필터링 기능에 사용할 수 있습니다.

유사 객체 선택을 수행하려면 컴포넌트를 오른쪽 클릭한 다음 컨텍스트 메뉴에서 Find Similar Objects 을 선택하여 Find Similar Objects 대화상자를 엽니다.

Find Similar Objects dialog에는 필요에 따라 필터링 옵션을 선택할 수 있는 Parameters 섹션이 포함되어 있습니다.

PCB Filter 패널은 파라미터별 쿼리 단어를 필터 기준으로 적용할 수 있으며, PCB 파라미터를 기반으로 Design Rules를 생성하는 데 사용할 수 있습니다.

PCB 컴포넌트 풋프린트 파라미터 작업에는 여러 쿼리 단어를 사용할 수 있으며, 문자열 값을 숫자로 변환하는 특정 함수 단어(예: StrToNumber)도 포함됩니다. 문자열 Value 변환은 단위 인식 방식(V, mA, mV, kOhm 등)을 지원하며, 파라미터 값 문자열의 수치 처리 결과에 따라 쿼리 결과를 결정할 수 있습니다.

쿼리에서 지정할 수 있는 지원 단위 유형은 다음과 같습니다:

  • % – 백분율
  • A – 전류
  • C – 온도
  • dB – 데시벨
  • F – 정전용량
  • G – 컨덕턴스
  • H – 인덕턴스
  • Hz – 주파수
  • Kg – 질량
  • m – 길이
  • Ohm – 저항
  • Q – 전하
  • s – 시간
  • V – 전압
  • W – 전력
  • Z – 임피던스

PCB 컴포넌트 풋프린트 파라미터 작업에 사용할 수 있는 여러 Parameter 쿼리 단어가 제공됩니다.

위의 Query Helper 대화상자에 표시된 예에서는 각 컴포넌트의 Voltage Rating 파라미터를 처리하여(문자열-숫자 변환 사용 – StrToNumber(Unit Value, Unit Type)) 그 값이 50V보다 큰지 판단합니다. 이를 PCB Filter 패널에 적용하면 예제 보드 레이아웃에서 단일 고전압 컴포넌트 하나가 표시되며, C1 (의 Voltage Rating 값은 3kV입니다).

과학적 E 표기법도 지원되므로, 예를 들어 1nF를 초과하는 커패시터 값을 필터링하는 쿼리는 다음과 유사합니다:
StrToNumber(ParameterValue('CapacitanceValue'), F) > 1e-9
또는 반환된 ParameterValue와 비교 값 모두에 숫자 변환 함수를 사용할 수도 있습니다:
StrToNumber(ParameterValue('CapacitanceValue'), F) > StrToNumber('1nF', F)

Rules and ScriptsPCB 매개변수 쿼리는 Altium Designer 스크립트와 설계 규칙에도 적용할 수 있습니다. 후자의 경우 레이아웃 검증 검사를 수행할 수 있으며, 예를 들어 풋프린트 매개변수를 감지하여 부품 배치나 레이어 할당을 평가할 수 있습니다. 위의 Query Helper 대화상자에 나열된 함수들은 스크립팅 언어에서도 사용할 수 있습니다.

아래 예시는 커패시터 전압 정격 쿼리(위의 필터 쿼리 참조)를 부품 배치 규칙에 적용한 것으로, 실행 시 고전압(>50V) 장치로 감지된 부품에 대해 특정 이격값을 확인합니다.

회로도 공간에서 전달된 특정 풋프린트 매개변수로 정의된 설계 규칙은 사용자 정의 레이아웃 조건을 감지하는 데 사용할 수 있습니다.

마찬가지로 사용자 정의 PCB 매개변수는 부품 레이어 호환성을 확인하는 데 사용할 수 있습니다. 예를 들어 어떤 부품이 웨이브 솔더링을 지원하지 않아 Bottom Layer 배치를 허용하지 않는 경우입니다. 여기서는 사용자 정의 ‘WaveSoldering’ 매개변수(Yes/No)를 처리하는 객체 매칭 쿼리를 Permitted Layers Rule에 적용할 수 있습니다.

이후 (배치) 규칙은 해당 부품 매개변수의 값을 확인하고, 부품이 Bottom Layer 배치와 호환되지 않으면 위반 사항을 생성합니다.

변형

설계의 변형(Design Variants)에 포함되어 PCB로 전달된 매개변수는 Variant 선택과 함께 처리됩니다.

실제로 PCB 공간에서 변형된 부품 매개변수는 쿼리 문자열에 의해 동적으로 감지되거나, 예를 들어 특수 문자열을 통해 보드 레이어에 표시될 수 있습니다. 

사용자 정의 풋프린트 매개변수

이 기능은 PCB.FootprintParameters 옵션이 Advanced Settings dialog에서 활성화되어 있을 때 사용할 수 있습니다.

풋프린트용 사용자 정의 매개변수는 Altium Designer에서 지원됩니다. PCB 풋프린트 편집기 설계 공간에서 아무 객체도 선택되어 있지 않을 때, Properties panel의 Library Options mode에서 Footprint 탭에 있는 Parameters 영역을 사용하여 풋프린트 매개변수를 보고 편집할 수 있습니다.

부품이 PCB에 배치되면, Parameters  탭의 Component mode에 있는 Properties panel에서 이러한 매개변수를 확인할 수 있습니다.

  • PCB에 배치된 부품의 풋프린트 매개변수는 PCB 편집기 메인 메뉴의 Make PCB Library 또는 Make Integrated Library 명령으로 생성된 라이브러리의 풋프린트로 전파됩니다.
  • 풋프린트 매개변수는 Altium Designer의 비교 엔진과 생성된 Pick and Place 및 ODB++ 출력에서도 지원됩니다.
Altium MCAD CoDesigner는 구성된 링크에 따라 MCAD에서 네이티브 MCAD 부품의 배치를 지원합니다. 경우에 따라 서로 다른 모델을 가진 여러 풋프린트가 하나의 부품에 연결되기도 합니다(예: PCB에 두 가지 방식으로 실장할 수 있는 LED - 직선 리드의 수직형 또는 절곡 리드의 수평형). 이제 풋프린트 매개변수를 사용하면 이러한 서로 다른 풋프린트에서 서로 다른 MCAD 모델을 참조할 수 있습니다. 자세한 내용은 Linking Native ECAD and MCAD Design Components를 참조하십시오.

디지그네이터 및 코멘트 문자열

기본 디지그네이터 및 코멘트 문자열

풋프린트가 보드에 배치되면 설계의 회로도 보기에서 추출된 정보를 바탕으로 Designator와 Comment가 부여됩니다. Designator 및 Comment 문자열의 플레이스홀더는 풋프린트가 보드에 배치될 때 자동으로 추가되므로 수동으로 정의할 필요가 없습니다. 이 문자열들의 위치는 설계 공간에서 designator 또는 comment 문자열을 선택했을 때 Parameter mode의 Properties panel에 있는 Designator and Comment string Autoposition 옵션에 의해 결정됩니다. Designator 및 Comment 문자열의 기본 위치와 크기는 Preferences dialog의 PCB Editor - Defaults page에서 해당 Primitive에 대해 구성됩니다.

추가 Designator 및 Comment 문자열

추가적인 designator 또는 comment 문자열 사본이 필요한 경우가 있을 수 있습니다. 예를 들어 조립 업체는 각 부품 외곽선 내부에 designator가 표시된 상세 조립 도면을 원하고, 반면 귀사는 최종 PCB의 component overlay에서 designator가 부품 바로 위에 위치하기를 요구할 수 있습니다. 이러한 추가 designator 요구사항은 풋프린트에 .Designator 특수 문자열을 포함하여 충족할 수 있습니다. 대체 레이어나 위치에 comment 문자열 위치를 지정하기 위한 .Comment 특수 문자열도 제공됩니다.

조립 업체의 요구사항을 충족하기 위해 .Designator 문자열을 PCB 풋프린트 편집기의 mechanical layer에 배치할 수 있으며, 이 레이어를 포함하는 출력물을 생성하여 설계 조립 지침의 일부로 사용할 수 있습니다.

레이어별 특수 요구사항 처리

PCB 부품에는 접착제 점(glue dot)이나 벗겨낼 수 있는 솔더 마스크 정의와 같은 여러 특수 요구사항이 있을 수 있습니다. 이러한 특수 요구사항 중 다수는 부품이 실장되는 보드 면과 연관되며, 부품이 뒤집힐 때 보드의 반대 면으로 함께 뒤집혀야 합니다.

드물게만 사용될 수 있는 특수 목적 레이어를 많이 포함하는 대신, Altium Designer의 PCB 편집기는 layer pair라는 기능을 통해 이 요구사항을 지원합니다. layer pair는 한 쌍으로 정의된 두 개의 mechanical layer입니다. 부품이 보드의 한 면에서 다른 면으로 뒤집힐 때마다, 페어링된 mechanical layer 위의 모든 객체도 그 쌍의 다른 mechanical layer로 뒤집힙니다. 이 접근 방식을 사용하면 glue dot(또는 기타 특수 요구사항)을 포함할 적절한 mechanical layer를 선택하고 사용 가능한 객체로 그 형상을 정의할 수 있습니다. 그 풋프린트를 보드에 배치할 때는 layer pairing을 설정해야 합니다. 그러면 이 부품이 반대 면으로 뒤집힐 때 소프트웨어가 객체를 어떤 레이어로 옮겨야 하는지 알 수 있습니다. PCB 풋프린트 편집기에서는 layer pair를 정의할 수 없으며, 이는 PCB 편집기에서 수행합니다.

Layer Pairing은 부품을 뒤집기 before 전에 정의해야 합니다. 페어링을 부품이 하단 면으로 이동한 후에 정의하면 mechanical 내용은 뒤집히지만 원래 레이어에 그대로 남습니다. 뒤집기 전에 layer pair를 만드는 것을 잊은 경우, 라이브러리에서 업데이트하여 보드에 배치된 부품 인스턴스를 새로 고칠 수 있습니다.

Mechanical Layer의 이름은 View Configurations panel에서 마우스 오른쪽 버튼을 클릭한 다음 Edit Layer을(를) 선택하여 직접 편집할 수 있습니다.

Mechanical layer 사용을 관리하는 일반적인 방법은 필요한 각 mechanical layer 기능에 대해 전용 레이어 번호를 할당하는 것입니다. 이 방법은 모든 설계자가 동일한 레이어 할당 및 번호 체계를 준수해야 합니다. 또한 동일한 할당 및 번호 체계를 따르지 않는 다른 출처의 부품을 사용할 때 어려움이 생길 수 있습니다. 다른 체계가 사용된 경우 설계 객체를 현재 mechanical layer에서 해당 기능에 할당된 mechanical layer로 이동해야 합니다.

Layer Type 속성이 도입되면서 이 문제는 해결되었습니다. 라이브러리에서 PCB 편집기로 부품을 배치하거나, 한 라이브러리에서 다른 라이브러리로 복사하거나, IPC Footprint Wizard로 생성할 때 기존 Layer Type 할당은 Layer Type에 할당된 mechanical layer 번호와 관계없이 자동으로 일치됩니다. 객체는 해당 Layer Type에 따라 올바른 레이어로 재배치됩니다. 소프트웨어가 Layer Type으로 매칭할 수 없는 경우에는 Layer Number 매칭으로 대체됩니다.

개별 mechanical layer와 Component Layer Pairs 모두에 대해 미리 정의된 유형 목록에서 Layer Type을 선택할 수 있습니다. 아래 표시된 대화상자는 개별 레이어를 마우스 오른쪽 버튼으로 클릭한 다음 메뉴에서 Edit Layer 또는 Add Component Layer 명령을 선택하여 열 수 있습니다.

부품 관련 mechanical layer 유형에 대한 자세한 내용은 Working with Mechanical Layers 페이지를 참조하십시오.

PCB 풋프린트에 높이 추가

가장 단순한 수준의 3D 표현에서는 PCB 풋프린트에 높이 정보를 추가할 수 있습니다. 이를 위해 Properties panel을 Library Options mode로 열고(설계 공간에서 아무 객체도 선택되지 않았을 때 활성화됨), panel의 Footprint 탭에 있는 Height 필드에 해당 부품의 권장 높이를 입력합니다.

높이 설계 규칙은 보드 설계 중에 정의할 수 있으며(PCB Editor에서 Design » Rules 클릭), 일반적으로 부품 클래스 또는 room 정의 내에서 최대 부품 높이를 검사합니다.

높이 정보를 정의하는 더 좋은 방법은 PCB 풋프린트에 3D Bodies를 추가하는 것입니다.

라우팅 프리미티브가 있는 부품 관리

설계가 전달되면 각 부품에 지정된 풋프린트가 사용 가능한 라이브러리에서 추출되어 보드에 배치됩니다. 그런 다음 풋프린트의 각 패드에는 회로도에서 해당 부품 핀에 연결된 넷 이름으로 net 속성이 설정됩니다. 패드와 접촉하는 모든 객체는 그 패드와 동일한 net에 연결됩니다.

PCB 편집기에는 포괄적인 net 관리 도구가 포함되어 있습니다. 실행하려면 메인 메뉴에서 Design » Netlist » Configure Physical Nets을 선택하여 Configure Physical Nets dialog를 엽니다. 옵션 메뉴를 보려면 Menu 버튼을 클릭합니다. 할당되지 않은 프리미티브에 할당할 net을 선택하려면 New Net Name 헤더 드롭다운을 클릭합니다.

동일한 핀에 연결된 여러 패드를 가진 풋프린트

아래에 표시된 SOT223 트랜지스터 풋프린트에는 동일한 논리 회로도 부품 핀인 Pin 2에 연결된 여러 패드가 있습니다. 이 연결을 만들기 위해 동일한 designator인 '2'를 가진 두 개의 패드가 추가되었습니다. Schematic Editor에서 Design » Update PCB 명령을 사용하여 설계 정보를 PCB로 전달하면, 결과 동기화에서 PCB 편집기 내 두 패드 모두로 연결선이 표시됩니다. 즉, 두 패드는 동일한 net에 있습니다. 이 둘 모두 라우팅할 수 있습니다.

designator가 2인 두 개의 패드를 보여주는 SOT223 풋프린트.
designator가 2인 두 개의 패드를 보여주는 SOT223 풋프린트.

실크스크린 준비

노출된 구리와 홀 위에 실크스크린이 겹치는 것으로 인해 발생하는 일반적인 제조 용이성(DFM) 문제를 해결할 수 있도록, PCB 풋프린트 편집기에는 풋프린트의 실크스크린을 준비하는 전용 기능이 포함되어 있습니다. 이러한 문제는 다음과 같은 방법으로 효과적으로 해결할 수 있습니다.

  • 실크스크린 선 및 호의 자동 클리핑
  • 필 및 영역의 자동 클리핑 또는 이동
  • 실크스크린 텍스트 문자열의 자동 이동
실크스크린 준비 도구는 PCB를 설계할 때도 사용할 수 있습니다 – 자세히 알아보기.

PCB 풋프린트 편집기에서 실크스크린 준비 도구에 액세스하려면 메인 메뉴에서 Tools » Silkscreen Preparation 명령을 사용합니다. 그러면 Silkscreen Preparation 대화상자가 열립니다.

대화상자를 사용하여 실크스크린 객체 클리핑/이동 설정을 구성합니다. 사용 가능한 옵션은 다음과 같습니다.

  • Clip to Exposed Copper – 활성화하면 객체를 노출된 구리에 맞추어 자동으로 클리핑합니다.
  • Clip to Solder Mask Openings – 활성화하면 객체를 솔더 마스크 개구부에 맞추어 자동으로 클리핑합니다.
  • Silkscreen Clearance – 실크스크린 객체와 노출된 구리 / 솔더 마스크 개구부 및 홀 사이의 허용 가능한 최소값을 정의합니다.
  • Min Remaining Length – 클리핑 후 선/호 길이가 정의된 값보다 작으면 해당 객체는 풋프린트에서 제거됩니다. 이 길이는 edge-to-edge 길이가 아니라 vertex-to-vertex 길이라는 점에 유의하십시오 – 이미지 표시.
  • Move Text – Silkscreen Clearance보다 거리가 작을 경우 실크스크린 텍스트 문자열을 노출된 구리 / 솔더 마스크 개구부 및 홀에서 멀어지도록 이동합니다. 이동 거리는 Max Distance 값으로 제한됩니다.
  • Fill & Region – 필 및 영역과 노출된 구리 / 솔더 마스크 개구부 및 홀 사이의 거리가 Silkscreen Clearance보다 작을 때 수행할 동작을 선택합니다.
    • None – 필 및 영역은 변경되지 않습니다.
    • Clip – 필 및 영역은 Silkscreen Clearance를 유지하도록 클리핑됩니다. 해당되는 경우 필은 영역으로 변환됩니다.
    • Move – 필 및 영역은 노출된 구리 / 솔더 마스크 개구부 및 홀에서 멀어지도록 이동합니다. 이동 거리는 Max Distance 값으로 제한됩니다.
  • Max Distance – 텍스트 문자열, 부품 designator, 필 및 영역이 Silkscreen Clearance를 유지하기 위해 이동할 수 있는 최대 거리를 정의합니다.

OK을 클릭하면 대화상자 설정에 따라 실크스크린 객체의 클리핑 및/또는 이동이 수행됩니다.

객체에 대해 동작을 수행할 수 없는 경우(예: Max Distance 제한으로 인해 텍스트 문자열을 이동할 수 없는 경우), 해당 객체에 대한 메시지가 Messages panel에 표시됩니다.

아래에는 실크스크린 준비 도구의 동작 예가 나와 있습니다.

Javascript

IPC 규격 준수 Footprint Wizard를 사용한 풋프린트 생성

IPC Compliant Footprint Wizard는 IPC 표준 7351 Revision B를 진정으로 준수하는 PCB 풋프린트를 생성합니다 - Generic Requirements for Surface Mount Design and Land Pattern Standard. 풋프린트 치수에서 직접 작업하는 대신(즉, Footprint Wizard 방식), IPC Compliant Footprint Wizard 는 부품 자체의 치수 정보를 사용한 다음 IPC에서 발표한 알고리즘에 따라 적절한 패드 및 기타 풋프린트 속성을 계산합니다.

풋프린트를 정의하는 데 사용되는 패드와 트랙의 속성을 입력하는 대신, Wizard는 실제 부품 치수를 입력값으로 사용합니다. IPC-7351 표준용으로 개발된 공식에 따라 Wizard는 패드와 트랙 같은 표준 Altium Designer 객체를 사용해 풋프린트를 생성합니다.

  • 이 대화상자는 IPC 표준 7351 Revision B - Generic Requirements for Surface Mount Design and Land Pattern Standard를 준수합니다. IPC-7351B는 2010년에 발표되었으며 2007년에 발표된 IPC-7351A를 대체합니다.

  • Altium Designer에서 IPC Compliant Footprint Wizard 에 액세스하려면 IPC Footprint Generator 소프트웨어 확장이 설치되어 있어야 합니다. 이 확장은 기본적으로 Altium Designer와 함께 설치됩니다. 수동으로 설치하거나 제거할 수도 있습니다.

    확장 관리에 대한 자세한 내용은 Extending Your Installation 페이지(Altium Designer Develop, Altium Designer Agile, Altium Designer)를 참조하십시오.

IPC Compliant Footprint Wizard를 실행하려면 PCB Library 문서의 메인 메뉴에서 Tools » IPC Compliant Footprint Wizard 를 선택합니다.

Select Component Type 페이지에서 Select Component Type 페이지에 풋프린트를 생성하려는 부품군을 선택합니다. Wizard 오른쪽의 미리보기 영역은 현재 선택된 부품을 표시하도록 동적으로 변경되며, 생성 가능한 패키지 유형도 함께 보여줍니다. 아래 표에는 Wizard에서 지원하는 부품 유형과 패키지가 나와 있습니다.

이름 설명 포함된 패키지
BGA 볼 그리드 어레이 BGA, CGA
BQFP 범퍼형 쿼드 플랫 팩 BQFP
CAPAE 전해 알루미늄 커패시터 CAPAE
CFP 세라믹 듀얼 플랫 팩 - 트리밍 및 성형된 걸윙 리드 CFP
Chip Array 칩 어레이 Chip Array
DFN 듀얼 플랫 노리드 DFN
CHIP 칩 부품, 2핀 커패시터, 인덕터, 저항기
CQFP 세라믹 쿼드 플랫 팩 - 트리밍 및 성형된 걸윙 리드 CQFP
DPAK 트랜지스터 아웃라인 DPAK
LCC 리드리스 칩 캐리어 LCC
LGA 랜드 그리드 어레이 LGA
MELF MELF 부품, 2핀 다이오드, 저항기
MOLDED 몰드 부품, 2핀 커패시터, 인덕터, 다이오드
PLCC 플라스틱 리드형 칩 캐리어, 사각형 - J 리드 PLCC
PQFN 풀백 쿼드 플랫 노리드 PQFN
PQFP 플라스틱 쿼드 플랫 팩 PQFP, PQFP Exposed Pad
PSON 풀백 소형 아웃라인 노리드 PSON
QFN 쿼드 플랫 노리드 QFN, LLP
QFN-2ROW 쿼드 플랫 노리드, 2열, 사각형 더블 로우 QFN
SODFL 소형 아웃라인 다이오드, 플랫 리드 SODFL
SOIC 소형 아웃라인 집적 패키지, 1.27mm 피치 - 걸윙 리드 SOIC, SOIC Exposed Pad
SOJ 소형 아웃라인 패키지 - J 리드 SOJ
SON 소형 아웃라인 노리드 SON, SON Exposed Pad
SOP, TSOP 소형 아웃라인 패키지 - 걸윙 리드 SOP, TSOP, TSSOP
SOT143/343 소형 아웃라인 트랜지스터 SOT143, SOT343
SOT223 소형 아웃라인 트랜지스터 SOT223
SOT23 소형 아웃라인 트랜지스터 3리드, 5리드, 6리드
SOT89 소형 아웃라인 트랜지스터 SOT89
SOTFL 소형 아웃라인 트랜지스터, 플랫 리드 3리드, 5리드, 6리드
WIRE WOUND 정밀 권선 인덕터, 2핀 인덕터

이후 Wizard 페이지는 선택한 부품 유형에 따라 달라집니다. 각 페이지의 안내에 따라 필요한 부품 풋프린트를 설정하십시오. IPC Compliant Footprint Wizard 사용 시 참고 사항은 다음과 같습니다.

 
 
 
 
 
  • 모든 치수는 Wizard에 미터법(mm) 단위로 입력합니다.

  • 전체 패키지 치수, 핀 정보, 힐 간격, 솔더 필렛 및 공차를 입력하고 즉시 확인할 수 있습니다.

    IPC 공차를 수정하면 IPC를 준수하지 않는 PCB 풋프린트가 생성될 수 있습니다.

  • 코트야드, 어셈블리 및 부품(3D) 바디 정보와 같은 기계적 치수를 입력할 수 있습니다.

  • Wizard는 재진입 가능하며 검토와 조정을 쉽게 할 수 있습니다.

  • 풋프린트 미리보기는 모든 단계에서 표시됩니다. 각 부품 유형에 대해 Preview 영역은 여러 설정에 따라 새로운 위치, 크기 등을 동적으로 업데이트합니다. Preview 영역에서는  또는  를 클릭하여 2D와 3D 미리보기 이미지 사이를 전환할 수 있습니다.

  • 원하는 경우 모델을 생성하기 전에 3D STEP 모델의 미리보기를 볼 수 있습니다. Generate STEP Model Preview을 클릭합니다. Wizard의 아무 페이지에서든 부품 유형을 선택한 후 Preview 영역에서 3D STEP 모델의 미리보기를 보려면 클릭합니다.

  • 대형 열 패드(크기 2.1mm x 1.6mm 이상)가 있는 패키지의 경우 Paste Mask는 작은 필 형태로 분할됩니다.

  • 걸윙 리드가 있는 패키지의 경우, 패키지 본체 아래로 패드가 연장되는 것을 방지하기 위해 패드가 트리밍됩니다.

  • 중앙의 대형 열 패드가 있는 소형 패키지의 경우, IPC 표준에 따라 패드 간 필요한 이격거리를 확보할 수 있도록 주변 패드가 트리밍됩니다.

  • 패드 트리밍이 적용되면 대화상자에 경고가 표시됩니다.

  • 풋프린트의 이름과 설명은 Wizard 에 입력한 정보를 기반으로 자동 제안되지만, 조직의 요구사항에 맞게 변경할 수 있습니다.

  • IPC 표준에 따라 Wizard는 세 가지 풋프린트 변형(_L_N_M)을 지원하며, 각각은 서로 다른 보드 밀도에 맞게 조정되어 있습니다.

  • Finish 버튼은 어느 단계에서든 눌러 현재 미리보기 중인 풋프린트를 생성할 수 있습니다. 전체 Wizard를 완료하기 전에 Finish 를 클릭하면, 선택한 부품 유형에 대한 시스템 기본값을 사용하여 풋프린트가 생성됩니다.

  • 파일 기반 PCB 풋프린트 라이브러리로 작업할 때는 IPC Compliant Footprints Batch Generator를 사용하여 여러 밀도 레벨에서 여러 풋프린트를 빠르게 생성할 수 있습니다.

파일 기반 PCB 풋프린트 라이브러리에서 Wizard에 액세스하면 Footprint Destination 페이지를 사용할 수 있으며, 여기서 새로 생성된 풋프린트를 저장할 위치를 선택할 수 있습니다 – show image:

  • 풋프린트를 기존 PCB Library 파일에 저장하려면 Existing PcbLib File를 선택합니다. 텍스트 상자에 파일을 직접 입력하거나 를 사용하여 원하는 파일을 검색하는 대화상자를 열 수 있습니다.
  • 풋프린트를 새 PCB Library 파일에 저장하려면 New PcbLib File를 선택합니다. 텍스트 상자에 새 PCB Library 파일의 이름을 입력합니다. 시스템은 새 라이브러리 파일 이름에 .PcbLib 확장자를 추가합니다.
  • 표시된 PCB Library 파일에 풋프린트를 저장하려면 Current PcbLib File를 선택합니다.
  • 3D STEP 모델을 생성하려면 Produce 3D/STEP model를 활성화합니다.
  • 유효한 'MCAD Co-Designer - SOLIDWORKS(R)' 라이선스가 있으면 모델을 Parasolid 파일 형식으로 저장하도록 선택할 수 있습니다. Format 오른쪽의 드롭다운을 클릭한 다음 Parasolid을 선택합니다. 이제 External File 텍스트 상자에 표시된 파일은 *.x_t 파일입니다. 이것이 저장될 파일의 이름과 위치입니다.
  • Embedded (기본값) 또는 External File 중 하나를 선택합니다. 3D STEP 모델을 외부 파일로 저장하려면 External File를 선택합니다. 기본 파일 형식은 STEP이며 파일 이름은 External File 텍스트 상자에 *.step를 파일 확장자로 하여 표시됩니다. 원하는 경우 를 클릭하여 생성된 3D STEP 모델을 저장할 폴더를 찾아 선택할 수 있습니다.

Footprint Wizard를 사용하여 풋프린트 만들기

PCB 풋프린트 편집기에는 Footprint Wizard가 포함되어 있습니다. 이 Wizard 를 사용하면 다양한 패키지 유형 중에서 선택하고 적절한 정보를 입력하여 부품 풋프린트를 만들 수 있습니다. Footprint Wizard에서는 패드와 부품 오버레이에 필요한 크기를 입력한다는 점에 유의하십시오.

Footprint Wizard를 시작하려면, 메인 메뉴에서 Tools » Footprint Wizard를 선택하거나 디자인 공간에서 마우스 오른쪽 버튼을 클릭한 뒤 컨텍스트 메뉴에서 Tools » Footprint Wizard 명령을 선택합니다.

Component patterns 페이지를 사용하여 만들고자 하는 부품의 패턴을 지정합니다. 목록에서 원하는 패턴을 선택한 다음 드롭다운을 사용하여 부품의 단위(Imperial (mil) 또는 Metric (mm))를 선택합니다. 사용 가능한 패턴은 다음과 같습니다.

  • Ball Grid Arrays (BGA)
  • Capacitors
  • Diodes
  • Dual In-line Packages (DIP)
  • Edge Connectors
  • Leadless Chip Carriers (LCC)
  • Pin Grid Arrays (PGA)
  • Quad Packs (QUAD)
  • Resistors
  • Small Outline Packages (SOP)
  • Staggered Ball Grid Arrays (SBGA)
  • Staggered Pin Grid Arrays (SPGA)

이후의 Wizard 페이지는 선택한 부품 패턴에 따라 달라집니다. 직관적인 Wizard 페이지를 따라 필요한 특정 부품 풋프린트를 설정하십시오.

Edge ConnectorsLeadless Chip Carriers (LCC) 또는 Quad Packs (QUAD) 패턴의 풋프린트에 대한 패드 이름 지정 스타일을 설정할 때는 초록색 화살표를 클릭하여 이름 지정 순서/방향을 변경합니다 – show image.

부품 보고서 생성

활성 PCB 풋프린트에 대한 보고서를 생성하려면 메인 메뉴에서 Reports » Component 명령을 선택합니다. 명령을 실행하면 보고서가 소스 PCB 라이브러리 문서와 동일한 폴더에 생성되며(<PCBLibraryDocumentName>.CMP), 메인 디자인 창에서 활성 문서로 자동 열립니다. 이 보고서에는 풋프린트 치수, 풋프린트를 구성하는 프리미티브 객체의 세부 내역, 그리고 해당 객체가 위치한 레이어 등의 정보가 나열됩니다.

보고서는 Projects 패널의 Documentation\Text Documents 하위 폴더 아래에 자유 문서로 추가됩니다.

AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

콘텐츠