컴포넌트 유효성 검사

개요

Altium Designer에서 연결된 워크스페이스에 라이브러리 컴포넌트를 저장하기 전에 컴포넌트 Rule 검사를 실행하여 설정된 요구 사항을 충족하는지 확인하세요. 이 문서에서는 자동 및 수동 유효성 검사, 보고된 위반 사항을 검토하는 위치, 사용자 정의 검사를 구성하는 방법을 설명합니다. 또한 폴더 경로 누락, 식별자 중복, 잘못된 핀 매핑 등의 문제를 해결하는 방법도 안내합니다. 계속 읽고 컴포넌트의 문제를 파악하여 워크스페이스에 저장하기 전에 유효성 검사 실패를 해결하세요.

- 컴포넌트 Editor의 싱글 컴포넌트 편집 모드와 일괄 컴포넌트 편집 모드에서 컴포넌트 Rule 검사를 실행하고 Messages Panel에서 결과를 검토하는 방법을 알아보세요.
- 어떤 유효성 검사 실패가 워크스페이스에 컴포넌트를 저장하지 못하게 하는지 알아보세요.
- 사용자 정의 검사를 구성하는 위치와 일반적인 컴포넌트 위반 사항을 해결하는 방법을 알아보세요.
AI로 더 깊이 알아보기:

컴포넌트 편집기에서 정의하거나 편집한 워크스페이스 라이브러리 컴포넌트를(싱글 컴포넌트 편집 또는 일괄 컴포넌트 편집 모드) 연결된 워크스페이스 에 저장하여 설계에 사용할 수 있도록 하기 전에, 해당 컴포넌트가 구성된 설정에 따른 요구 사항을 충족하는지 반드시 확인해야 합니다. 컴포넌트를 워크스페이스에 다시 저장하려고 하면 컴포넌트 편집기는 컴포넌트 Rule 검사라는 유효성 검사를 실행합니다.

  • 이 기능은 메인 메뉴에서 Tools » Component Rule Check 명령을 선택하여 언제든지 수동으로 실행할 수도 있습니다. 실행하기 전에 컴포넌트를 로컬에 저장했는지(File » Save) 확인하십시오.

  • Component Rule Check 명령은 편집기의 메인 File 메뉴와 Projects 패널에 있는 컴포넌트 항목의 마우스 오른쪽 버튼 클릭 메뉴에서도 사용할 수 있습니다.

보드 프로젝트에 위반 사항을 감지하는 유효성 검사 프로세스가 있는 것처럼, 컴포넌트 편집기에도 컴포넌트 유효성 검사 기능이 있습니다. 발견된 모든 위반 사항은 Messages 패널에 나열됩니다.

 
 
 
 
 

워크스페이스에 저장하기 전에 컴포넌트의 문제를 감지합니다. 여기서는 Single Component Editing 모드의 컴포넌트 편집기에서 Component Rule Check 명령을 실행하는 모습을 보여 줍니다.

워크스페이스에 저장하기 전에 컴포넌트의 문제를 감지합니다. 여기서는 Batch Component Editing 모드의 컴포넌트 편집기에서 Component Rule Check 명령을 실행하는 모습을 보여 줍니다.

 

컴포넌트 유효성 검사는 컴포넌트와 여기에 정의된 모델의 다양한 잠재적 문제를 검사합니다. 여기에는 기본 제공 검사와 전역 수준에서 사용자가 정의할 수 있는 다양한 위반 유형 검사가 포함됩니다.

다음 기본 제공 유효성 검사의 보고 모드는 모두 입니다.

사용자 정의 검사는 Preferences 대화 상자의 데이터 관리 – 컴포넌트 Rule 검사 페이지에서 구성합니다.

 
 
 
 
 

컴포넌트 유효성 검사에 사용하도록 전역 환경설정에서 구성할 수 있는 사용자 정의 위반 검사입니다.
컴포넌트 유효성 검사에 사용하도록 전역 환경설정에서 구성할 수 있는 사용자 정의 위반 검사입니다.

내장된 테스트 중 하나라도 실패하거나 사용자 정의 검사에서 치명적 오류 수준의 문제가 발생하면 컴포넌트를 워크스페이스에 저장할 수 없습니다.

사용자 정의 검사의 기본 설정이 사용 중인 컴포넌트에 적합하지 않을 수 있으므로, 옵션과 이를 설계에 맞게 구성하는 방법을 숙지하는 것이 중요합니다. 각 사용자 정의 오류 검사에 대한 정보는 아래에서 확인할 수 있습니다.

컴포넌트 관련 위반 사항

풋프린트 관련 위반 사항

심볼 관련 위반 사항

AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

Contents