컴포넌트 템플릿

Altium Designer는 연결된 워크스페이스와 연동하여 해당 워크스페이스에서 Component Templates (컴포넌트 템플릿 Item)을 생성하고 정의할 수 있도록 지원하므로 컴포넌트를 더욱 간편하게 생성할 수 있습니다. Schematic 템플릿을 사용하여 이를 참조하는 Schematic 시트의 정보를 미리 정의할 수 있는 것처럼, 컴포넌트 템플릿은 워크스페이스 라이브러리 컴포넌트에서 참조되며 해당 컴포넌트를 정의할 때 사용할 사전 정의된 설정을 제공합니다.

특히 컴포넌트 템플릿은 파라미터 정보를 중점적으로 고려하여 개발되었으므로, 템플릿을 참조하는 컴포넌트에 제공할 파라미터 집합을 한곳에서 정의할 수 있습니다. 템플릿을 통해 표시할 파라미터를 제어하고, Default 값을 입력하며, 반드시 필요한 파라미터를 필수로 지정할 수도 있습니다. 컴포넌트를 저장할 때 유효성 검사를 수행하여 이러한 요구 사항의 준수 여부를 확인합니다.

여러 템플릿 설정에 지정된 Default 값은 읽기 전용으로 잠그거나, 컴포넌트를 정의할 때 설계자가 선택적으로 재정의할 수 있도록 허용할 수 있습니다.

컴포넌트 템플릿은 범용 컴포넌트를 생성하는 기반이기도 합니다. 자세한 내용은 범용 컴포넌트 생성 페이지를 참조하세요.

컴포넌트 템플릿에 대한 액세스는 소프트웨어 라이선스에 따라 달라집니다. 자세한 내용은 페이지 오른쪽의 Note 상자를 참조하세요.

이러한 컴포넌트 템플릿은 워크스페이스 내에서 직접 생성됩니다. 컴포넌트 템플릿을 생성하고 해당 리비전에 데이터를 저장하면, 하나 이상의 컴포넌트를 생성할 때 재사용할 수 있습니다.

폴더 유형

컴포넌트 템플릿을 저장할 폴더를 생성할 때 폴더 유형을 지정할 수 있습니다. 이 유형은 폴더의 내용에 영향을 주지 않습니다. 컴포넌트 템플릿을 릴리스하면 항상 해당 컴포넌트 템플릿 Item이 생성됩니다. 폴더 유형은 폴더에 저장된 내용을 시각적으로 알려주는 단서일 뿐이며, 워크스페이스에서 특정 콘텐츠를 찾을 때 유용할 수 있습니다. 폴더를 컴포넌트 템플릿 저장용으로 지정하려면 폴더 편집 대화 상자에서 폴더 속성을 정의할 때 Folder Type을(를) Component Templates(으)로 설정하세요.

폴더 유형, 즉 용도를 지정하면 워크스페이스를 탐색할 때 해당 폴더의 내용을 시각적으로 파악할 수 있습니다.
폴더 유형, 즉 용도를 지정하면 워크스페이스를 탐색할 때 해당 폴더의 내용을 시각적으로 파악할 수 있습니다.

콘텐츠 유형

컴포넌트 템플릿을 저장할 타겟 컴포넌트 템플릿 Item을 생성할 때는 새 Item 생성 대화 상자에서 해당 Content Type이(가) Component Template(으)로 설정되어 있는지 확인하세요. Component Templates 유형의 폴더에서 Item을 생성하는 경우, Item 생성 시 마우스 오른쪽 버튼 클릭 컨텍스트 메뉴에서 이 콘텐츠 유형을 선택할 수 있습니다.

Component Templates 폴더 내에서 컴포넌트 템플릿 생성 – 컨텍스트 메뉴에서 적절한 Content Type을(를) 선택할 수 있습니다.
Component Templates 폴더 내에서 컴포넌트 템플릿 생성 – 컨텍스트 메뉴에서 적절한 Content Type을(를) 선택할 수 있습니다.

컴포넌트 템플릿 저장

Related page: 콘텐츠 생성 및 편집

지금까지 관련 폴더 및 콘텐츠 유형을 중심으로 워크스페이스의 컴포넌트 템플릿 지원 기능을 살펴보았습니다. 실제로 정의한 컴포넌트 템플릿을 이러한 컴포넌트 템플릿 Item의 리비전에 저장하는 작업도 간편하게 수행할 수 있습니다.

워크스페이스의 직접 편집 기능을 통해 컴포넌트 템플릿을 편집하고 새로 생성한 컴포넌트 템플릿 Item의 초기 리비전에 저장할 수 있습니다. 직접 편집을 사용하면 별도로 버전 관리되는 소스 데이터에 얽매일 필요가 없습니다. 워크스페이스 자체에서 최신 소스를 직접 불러온 임시 Editor를 사용하여 지원되는 콘텐츠 유형을 간편하게 편집할 수 있습니다. 편집을 완료하면 해당 개체가 상위 Item의 다음 예정 리비전에 저장되거나 다시 저장되고, 임시 Editor가 닫힙니다. 하드 드라이브에 파일을 저장할 필요도, 올바른 소스나 최신 소스로 작업하고 있는지 고민할 필요도, 별도의 버전 관리 소프트웨어를 유지할 필요도 없습니다. 워크스페이스가 높은 무결성을 유지하면서 이 모든 작업을 처리하므로 데이터를 훨씬 빠르게 변경할 수 있습니다.

컴포넌트 템플릿 Item을 생성할 때, 생성 후 해당 Item의 초기 리비전에 컴포넌트 템플릿을 편집하고 저장할 수 있습니다. 이렇게 하려면 새 Item 생성 대화 상자 하단의 Open for editing after creation 옵션을 활성화합니다(이 옵션은 Default로 활성화되어 있습니다). Item이 생성되고 임시 컴포넌트 템플릿 Editor가 열리며, 기본 설계 창에 .CMPT 문서가 활성 문서로 표시됩니다. 이 문서의 이름은 Item-리비전에 따라 다음 형식으로 지정됩니다: <Item><Revision>.CMPT(예: CMPT-0001-1.CMPT).

 
 
 
 
 

워크스페이스에서 직접 컴포넌트 템플릿의 초기 리비전을 편집하는 예 – 임시 컴포넌트 템플릿 Editor는 컴포넌트 템플릿을 정의할 문서를 제공합니다.
워크스페이스에서 직접 컴포넌트 템플릿의 초기 리비전을 편집하는 예 – 임시 컴포넌트 템플릿 Editor는 컴포넌트 템플릿을 정의할 문서를 제공합니다.

이 문서를 사용하여 필요에 맞게 컴포넌트 템플릿을 정의합니다. 자세한 내용은 템플릿 정의를 참조하세요.

직접 편집할 때 사용하는 세 가지 관련 컨트롤은 Quick Access Bar(기본 애플리케이션 창의 왼쪽 상단) 또는 Component Template Standard 도구 모음에서 쉽게 사용할 수 있습니다.

  • – Save Active Document. 이 버튼을 사용하여 문서의 변경 사항을 로컬에 저장합니다. 워크스페이스에 최종적으로 저장하기 전에 나중에 다시 돌아와 추가로 변경하려는 경우, 현재 변경 사항을 저장해 둘 수 있습니다.
  • / – Save to Server. 이 버튼을 사용하여 정의한 컴포넌트 템플릿을 워크스페이스에 저장하고, 타겟 컴포넌트 템플릿 Item의 초기(계획된) 리비전에 보관합니다. Edit Revision 대화 상자가 나타나면 필요에 따라 이름과 설명을 변경하고 릴리스 노트를 추가할 수 있습니다. 저장 후 문서와 Editor가 닫힙니다. 원본 컴포넌트 템플릿이 포함된 문서인 *.CMPT는 Item의 리비전에 저장됩니다.

    Projects Panel 내의 컴포넌트 템플릿 Entry 오른쪽에도 Save to Server 컨트롤이 제공되어 편리하게 사용할 수 있습니다.
  • / – Discard Local Changes. 편집을 취소하고 모든 변경 사항을 버리려면 이 버튼을 사용합니다. 문서와 Editor가 닫히며, 타겟 컴포넌트 템플릿 Item에는 아무것도 릴리스되지 않습니다.

이 컨트롤은 기본 File 메뉴와 Projects Panel에 있는 컴포넌트 템플릿 Entry의 오른쪽 클릭 메뉴에서도 Save(단축키: Ctrl+S), Save to Server(단축키: Ctrl+Alt+S), Discard Local Changes 명령으로 사용할 수 있습니다.

워크스페이스에 저장되는 데이터는 컴포넌트 템플릿 파일(<Item><Revision>.CMPT)에 정의된 원본 컴포넌트 템플릿으로 구성됩니다.

 
 
 
 
 

정의를 완료한 후 워크스페이스에 다시 저장한 컴포넌트 템플릿의 예.
정의를 완료한 후 워크스페이스에 다시 저장한 컴포넌트 템플릿의 예.

컴포넌트 템플릿 상속

이 기능은 고급 설정 대화 상자에서 UI.ComponentTemplateInheritance 옵션을 활성화하면 사용할 수 있습니다.

하위 유형에 연결된 컴포넌트 템플릿이 없는 경우 루트 컴포넌트 유형의 컴포넌트 템플릿을 사용할 수 있습니다. 컴포넌트 유형의 계층 구조를 만들면 하위 컴포넌트 유형은 루트/Parent 컴포넌트 유형에 할당된 컴포넌트 템플릿을 상속합니다.

CMPT(컴포넌트 템플릿) Editor

Altium Designer에서 컴포넌트 템플릿 Editor에 액세스하려면 Component Template Editor 소프트웨어 확장 기능이 설치되어 있어야 합니다. 이 확장 기능은 Altium Designer와 함께 Default로 설치됩니다. 수동으로 설치하거나 제거할 수도 있습니다.

확장 기능 관리에 대한 자세한 내용은 Extending Your Installation 페이지(Altium Designer Develop, Altium Designer Agile, Altium Designer)를 참조하세요.

템플릿 정의

컴포넌트 템플릿 Editor는 기본적으로 두 개의 주요 영역으로 나뉘며, 아래 이미지와 그 뒤의 설명에서 각 영역을 확인할 수 있습니다.

 
 
 
 
 

컴포넌트 템플릿 Editor는 크게 두 개의 핵심 영역으로 나눌 수 있습니다.
컴포넌트 템플릿 Editor는 크게 두 개의 핵심 영역으로 나눌 수 있습니다.

  1. Upper Region – 템플릿을 참조하는 컴포넌트의 컴포넌트 수준 옵션(수명 주기, 이름 지정 및 폴더 옵션)을 정의하는 영역입니다.
  2. Lower Region – 템플릿을 참조하는 컴포넌트에 사용할 매개변수를 정의하는 영역입니다.

컴포넌트 옵션 지정

Editor의 상단 절반은 다음 컴포넌트 속성의 Default 값을 정의하는 영역입니다.

  • Lifecycle Definition – 템플릿을 사용하여 생성한 컴포넌트에 적용할 수명 주기 정의를 선택합니다. 드롭다운 필드에는 워크스페이스에 정의된 항목 중 컴포넌트에 사용하도록 허용된 모든 정의가 표시됩니다.

  • Revision Naming – 템플릿을 사용하여 생성한 컴포넌트에 적용할 리비전 이름 지정 체계를 선택합니다. 드롭다운 필드에는 워크스페이스에 정의된 체계 중 컴포넌트에 사용하도록 허용된 모든 체계가 표시됩니다.

    콘텐츠 유형별로 수명 주기 정의 및 리비전 명명 체계의 사용을 제어하는 옵션이 정의 또는 체계에 대해 활성화되어 있고, 컴포넌트 콘텐츠 유형이 특정 정의 또는 체계를 사용하도록 설정되어 있지 않으면 해당 정의 또는 체계는 관련 드롭다운 목록에 표시되지 않습니다.

  • Component Naming – 이 필드에서 템플릿을 사용하여 생성되는 컴포넌트의 Default Item 명명 체계를 정의하면 워크스페이스 내에서 생성된 컴포넌트에 고유 ID를 부여할 수 있습니다. 여기에 입력한 값은 컴포넌트 이름을 자동으로 지정하는 템플릿으로 사용됩니다(컴포넌트 Editor를 Single Component Editing 모드로 사용할 때는 연결된 Id 필드에서, Batch Component Editing 모드로 사용할 때는 Item ID 필드에서 사용). 소프트웨어는 전체 워크스페이스와 기존 콘텐츠의 식별자를 검색한 후 해당 체계를 기반으로 사용 가능한 다음 고유 ID를 자동으로 할당합니다. Default Item 명명 체계인 CMP-{00000}이 제공되지만, 필드에 직접 입력하여 고유한 체계를 만들 수도 있습니다. 이때 가변 부분은 반드시 중괄호로 묶어야 합니다(예: CMP-001-{0000}).

  • Default Folder – 저장된 컴포넌트를 보관할 타겟 워크스페이스 내의 Default 폴더를 지정합니다. Choose 버튼을 클릭하여 Choose Folder 대화 상자(Explorer Panel의 한 형태)를 엽니다. 여기에서 워크스페이스의 기존 폴더를 찾아 선택하거나 즉시 새 폴더를 생성할 수 있습니다.

타겟 워크스페이스를 설정하는 필드는 없습니다. 컴포넌트 템플릿의 리비전이 있는 워크스페이스와 동일한 워크스페이스를 사용하도록 하드코딩되어 있기 때문입니다.

각 속성의 Allow override 옵션을 사용하면 사용자가 컴포넌트 Editor에서 컴포넌트를 정의할 때 해당 속성을 변경할 수 있는지(활성화) 또는 변경할 수 없는지(비활성화)를 개별적으로 제어할 수 있습니다.

템플릿을 참조하면 이 Region에 지정된 값이 컴포넌트 Editor의 해당 필드에 미리 입력됩니다(해당 필드가 있는 경우).

  • Single Component Editing mode – Component Region의 Advanced Settings 영역에 있는 Id 및 Folder 필드.
  • Batch Component Editing mode – 문서 옵션 대화 상자의 Document Options 탭과, 이에 따라 컴포넌트 정의 Region의 Component 영역에 있는 Item ID 및 FolderPath 필드.

템플릿을 참조하면 컴포넌트 Editor의 Single Component Editing 모드(왼쪽) 및 Batch Component Editing 모드(오른쪽)에서 컴포넌트를 편집할 때 해당 필드에 지정된 값이 미리 입력됩니다.
템플릿을 참조하면 컴포넌트 Editor의 Single Component Editing 모드(왼쪽) 및 Batch Component Editing 모드(오른쪽)에서 컴포넌트를 편집할 때 해당 필드에 지정된 값이 미리 입력됩니다.

파라미터 정의

Editor의 하단 절반은 템플릿을 참조하는 컴포넌트에서 사용할 수 있는 파라미터를 정의하고 관리하는 데 사용됩니다.

 
 
 
 
 

컴포넌트 템플릿에 정의된 파라미터의 예.
컴포넌트 템플릿에 정의된 파라미터의 예.

Default 시스템 파라미터

새 컴포넌트 템플릿을 생성할 때 다양한 시스템 파라미터가 기본적으로 포함됩니다. 다음 이미지에 이를 보여주며, 이어서 자세히 설명합니다.

 
 
 
 
 

새로 생성된 컴포넌트 템플릿에 포함된 Default 시스템 수준 파라미터.
새로 생성된 컴포넌트 템플릿에 포함된 Default 시스템 수준 파라미터.

  • ComponentType – 이 파라미터로 컴포넌트 유형을 지정할 수 있습니다. 이를 통해 워크스페이스의 강력한 검색 기능으로 원하는 대상을 쉽게 검색할 수 있습니다. 이 기능은 컴포넌트 유형별 검색뿐 아니라 지원되는 단위 인식 컴포넌트 파라미터를 활용한 더욱 스마트한 검색도 제공합니다. 컴포넌트 Panel에서 자신의 워크스페이스 컴포넌트를 찾아볼 때, 컴포넌트의 Categories 그룹은 각 컴포넌트에 연결된 ComponentType 파라미터를 기반으로 구성됩니다. 연결된 Default Value 필드를 클릭한 다음 버튼을 클릭하여 Choose component type 대화 상자를 엽니다. 여기에서 필요한 컴포넌트 유형을 선택하고 OK을 클릭하면 선택한 유형이 기본 파라미터 Grid의 ComponentType 파라미터 값으로 입력됩니다.

    Choose component type 대화 상자는 Preferences 대화 상자의 데이터 관리 – 컴포넌트 유형 페이지 에 정의된 컴포넌트 유형 목록을 반영합니다. Choose component type 대화 상자 하단의 버튼을 클릭하여 이 환경설정 페이지에 접근할 수 있습니다. 여기에서 새 유형 및 하위 유형을 추가하거나 기존 유형을 편집 및 제거하여 필요에 맞게 목록을 구성할 수 있습니다.

    ComponentType 시스템 파라미터가 Diodes으로 설정된 컴포넌트 템플릿의 예.
    ComponentType 시스템 파라미터가 Diodes으로 설정된 컴포넌트 템플릿의 예.

     
     
     
     
     

    이 파라미터의 데이터 유형은 ComponentType로 설정되어 있으며 변경할 수 없습니다. 또한 ComponentType 파라미터는 복사하거나 제거할 수 없습니다. 셀을 선택하고 Delete 키를 사용하여 값을 지우세요.

  • SCHLIB 및 PCBLIB – 이 두 파라미터를 사용하면 각각 기본 심볼 모델과 풋프린트 모델을 지정할 수 있습니다. 각 파라미터의 해당 Default Value 필드를 클릭한 다음 버튼을 클릭하여 필요한 모델을 선택할 수 있는 대화 상자를 여세요.

    선택하는 것은 모델의 특정 리비전이 아니라 모델 자체라는 점에 유의하세요. 따라서 이 템플릿을 사용하는 컴포넌트는 항상 선택한 모델의 최신 리비전을 사용합니다.

    템플릿에 심볼 및 풋프린트 모델을 지정하세요.
    템플릿에 심볼 및 풋프린트 모델을 지정하세요.

     
     
     
     
     

    이 파라미터들의 데이터 유형은 각각 SCHLIB 및 PCBLIB로 설정되어 있으며 변경할 수 없습니다. 또한 모델 파라미터는 복사하거나 제거할 수 없습니다. 셀을 선택하고 Delete 키를 사용하여 값을 지우세요.

  • Name 및 Description – 이 두 파라미터를 사용하면 각각 컴포넌트의 이름과 설명을 정의할 수 있습니다. 각 파라미터의 해당 Default Value 필드에 필요한 문자열을 입력하세요.

    템플릿에 Name 및 Description 파라미터를 지정하세요.
    템플릿에 Name 및 Description 파라미터를 지정하세요.

     
     
     
     
     

    이 두 파라미터의 데이터 유형은 모두 Text로 설정되어 있으며 변경할 수 없습니다. 또한 이 파라미터들은 복사하거나 제거할 수 없습니다.

새 사용자 파라미터 추가

목록에 새 사용자 파라미터를 추가하려면 버튼을 클릭하거나 오른쪽 클릭 컨텍스트 메뉴에서 Add 명령을 사용하세요. 파라미터는 현재 목록의 맨 아래에 추가됩니다.

 
 
 
 
 

템플릿에 새 사용자 파라미터를 추가하는 예.
템플릿에 새 사용자 파라미터를 추가하는 예.

각 파라미터는 Grid 목록에 다음 정보와 함께 표시됩니다.

  • Name – 이 필드에 파라미터의 이름을 입력합니다. 일반적으로 용도를 잘 나타내는 의미 있는 이름을 사용합니다. 처음 추가된 파라미터에는 기본 이름(Parameter, Parameter 1, Parameter 2 등)이 지정됩니다.

  • Type – 파라미터의 유형입니다. 이 항목은 처음에는 Text으로 기본 설정되지만, 다양한 단위 인식 데이터 유형도 지원됩니다. 또한 여러 풋프린트 정의를 지원하는 PCBLIB 유형과 하네스 배선 컴포넌트 정의를 지원하는 HarnessWiring 유형도 지원됩니다. 사용 가능한 사전에 정의된 파라미터 유형도 지원됩니다. 자세히 알아보기.

  • Visible – 이 옵션을 활성화하면(새로 추가된 파라미터에서는 기본적으로 활성화됨) 컴포넌트 Editor에서 하나 이상의 컴포넌트를 편집할 때(Batch Component Editing 모드로 구성된 경우) 해당 파라미터의 Show 옵션이 활성화됩니다. 이 옵션은 컴포넌트 정의를 지정하는 컴포넌트 Editor 하단 영역에서 해당 파라미터 열의 표시 여부를 제어합니다. Editor의 Single Component Editing 모드에서 컴포넌트를 정의할 때는 이 속성이 영향을 미치지 않습니다.

  • Read Only – 이 옵션을 활성화하면 파라미터가 읽기 전용으로 설정됩니다. 템플릿을 참조하는 컴포넌트를 편집할 때 해당 파라미터 값을 편집할 수 없게 됩니다.

  • Required – 이 옵션을 활성화하면 파라미터가 '필수 파라미터'로 설정됩니다. 템플릿을 참조하는 컴포넌트를 편집할 때 해당 파라미터에 값을 지정해야 하며, 그렇지 않으면 컴포넌트를 저장할 수 없습니다. 컴포넌트 Editor에서는 값이 입력되지 않은 필수 파라미터의 값 셀에 빨간색 테두리가 표시되거나(Batch Component Editing 모드), 아이콘이 표시됩니다(Single Component Editing 모드).

  • Default Value – 이 필드에 파라미터의 기본값을 입력합니다.

    • 파라미터가 필수로 지정되어 있고(Required 옵션 활성화) 읽기 전용으로도 설정되어 있다면(Read Only 옵션 활성화), 기본값을 MUST 입력해야 합니다. 그렇지 않으면 템플릿을 참조하는 컴포넌트를 편집할 때 해당 파라미터에 값이 없다는 표시가 나타나지만, 읽기 전용이라 편집할 수 없으므로 이를 해결할 수 없습니다. 이 문제가 해결될 때까지 이 컴포넌트 템플릿의 새 리비전을 워크스페이스에 저장할 수 없습니다.

    • 컴포넌트의 리비전을 편집할 때 연결된 컴포넌트 템플릿의 파라미터와 이름이 같은 기존 사용자 정의 파라미터는 템플릿 버전으로 대체됩니다. 해당 파라미터의 기존 값은 유지되며, 템플릿의 기본값으로 덮어쓰이지 않습니다.

  • Description – 파라미터에 대한 설명을 추가합니다. 예를 들어 제공하는 기능에 대한 간략한 메모를 입력할 수 있습니다. 템플릿의 파라미터에 설명이 정의되어 있으면 컴포넌트 Editor의 Single Component Editing에서 Parameters 영역에 Description 열이 표시됩니다.

파라미터 목록은 간단한 복사 및 붙여넣기 작업도 지원하므로 기존 사용자 파라미터를 하나 이상 복제할 수 있습니다. 붙여넣은 파라미터는 목록 맨 아래에 추가됩니다.

표준 복사(Ctrl+C) 및 붙여넣기(Ctrl+V) 단축키가 지원되며, 마우스 오른쪽 버튼 메뉴에서도 이 명령을 사용할 수 있습니다. 표준 Ctrl+Click 및 Shift+Click 방식을 사용하여 복사 및 붙여넣기 작업을 수행할 여러 사용자 파라미터를 선택할 수 있습니다.
목록에서 사용자 파라미터를 하나 이상 삭제하려면 각 파라미터를 선택한 다음 버튼을 클릭하거나 마우스 오른쪽 버튼 컨텍스트 메뉴에서 Remove 명령을 사용합니다.

단위 인식 컴포넌트 파라미터 데이터 유형

컴포넌트 템플릿 Editor에서는 컴포넌트 템플릿 내에 정의된 컴포넌트 파라미터에 명시적인 데이터 유형을 지정할 수 있습니다(*.CMPT). 또한 이러한 데이터 유형은 단위를 인식하며, 일반적으로 사용되는 다양한 단위 접두사를 지원합니다. 따라서 2.2k, 2k2, 4M, 2.5GHz 등 다양한 형식으로 파라미터 값을 입력할 수 있으며, 워크스페이스는 이러한 입력값이 나타내는 수치를 인식하도록 설계되어 있습니다.

컴포넌트 템플릿의 이 기능을 활용하면 서버의 고급 검색 기능을 통해 원하는 항목을 정밀하게 검색할 수 있습니다. 이 기능은 컴포넌트 유형별 검색뿐 아니라 범위 검색을 통한 더욱 스마트한 검색도 지원합니다. 단위 인식 컴포넌트 파라미터를 활용하면, 예를 들어 정전 용량이 47uF에서 220uF 사이인 모든 커패시터를 찾는 검색 조건을 빠르게 설정할 수 있습니다.

단위 인식 파라미터는 컴포넌트 Panel을 사용하여 자신의 컴포넌트를 검색할 때 스마트 필터링에도 사용됩니다.

아래의 펼침/접기 섹션에서 단위 인식 파라미터에 대해 자세히 알아보세요.

사전 정의 파라미터 데이터 유형

사전은 여러 값이 정의된 사용자 지정 파라미터 유형입니다. 사전은 워크스페이스 관리자가 워크스페이스 브라우저 인터페이스의 Settings – Vault – Dictionaries 페이지에서 관리합니다. 컴포넌트 템플릿 Editor에서 Type 드롭다운의 Add New Dictionary 옵션을 선택하거나 Parameters 영역 오른쪽 상단의 Manage Dictionaries 컨트롤을 클릭하여 이 페이지에 액세스할 수 있습니다.

  • Settings – Vault – Dictionaries 페이지는 Preferences 대화 상자의 데이터 관리 – 사전 페이지에서 Manage Dictionaries 컨트롤을 클릭하여 액세스할 수도 있습니다. 또한 Preferences 대화 상자의 데이터 관리 – 서버 페이지에서 활성 워크스페이스 또는 알려진 워크스페이스의 Properties 컨트롤을 클릭하고 메뉴에서 Dictionaries 항목을 선택하여 액세스할 수도 있습니다.

  • 파라미터에 사전 정의 유형을 선택한 경우, Type 열에서 해당 파라미터의 셀을 클릭한 다음  버튼()을 클릭하여 Settings – Vault – Dictionaries 페이지에 액세스할 수도 있습니다.

컴포넌트 템플릿 Editor에서 워크스페이스 브라우저 인터페이스의 사전 관리 페이지에 액세스합니다.
컴포넌트 템플릿 Editor에서 워크스페이스 브라우저 인터페이스의 사전 관리 페이지에 액세스합니다.

워크스페이스 브라우저 인터페이스에서 사전을 관리하는 방법에 대해 자세히 알아보세요 (Altium 365 워크스페이스, Enterprise Server 워크스페이스).

정의된 사전은 Type 드롭다운에서 파라미터 유형으로 사용할 수 있습니다.

Type 드롭다운에서 사전 정의 파라미터 유형을 선택합니다.
Type 드롭다운에서 사전 정의 파라미터 유형을 선택합니다.

선택한 사전 정의 유형에 정의된 값은 Default Value 드롭다운에서 사용할 수 있습니다. 파라미터의 기본값으로 사용할 값을 선택하거나 <None>를 선택합니다.

선택한 사전 정의 유형에 정의된 값 중에서 기본값을 선택합니다.
선택한 사전 정의 유형에 정의된 값 중에서 기본값을 선택합니다.

  • 컴포넌트 템플릿을 워크스페이스에 저장할 때 기본값의 유효성이 검사됩니다. 기본값이 사전과 일치하지 않게 되면(예: 사전에서 값이 제거된 후 해당 값을 사용하는 템플릿을 편집하기 위해 연 경우), 이 기본값은 Default Value 열에서 빨간색으로 강조 표시되며, 템플릿을 워크스페이스에 다시 저장하려고 하면 Messages 패널에 오류 메시지가 표시됩니다.

  • 컴포넌트 파라미터의 값이 사전과 일치하지 않게 되면(예: 컴포넌트 템플릿에서 해당 파라미터의 유형이 Text에서 사전 정의 유형으로 변경되었고, 현재 컴포넌트 값이 선택한 사전 정의 유형의 어떤 값과도 일치하지 않는 경우), 컴포넌트 Editor에서 컴포넌트를 편집할 때 해당 파라미터가 강조 표시됩니다. Editor의 싱글 컴포넌트 편집 모드에서 컴포넌트를 편집할 때는 일치하지 않는 파라미터 값 옆에 느낌표 아이콘이 표시되고, Editor의 일괄 컴포넌트 편집 모드에서 컴포넌트를 편집할 때는 파라미터 값이 빨간색으로 강조 표시됩니다. 모든 컴포넌트 파라미터가 템플릿 값과 일치하는지 확인하세요. 그렇지 않으면 컴포넌트를 다음 리비전으로 저장할 수 없습니다.

  • 연결된 워크스페이스의 브라우저 인터페이스에서 사전이 변경된 경우, Altium Designer에 이러한 변경 사항을 반영하려면 워크스페이스 연결을 해제한 후 다시 연결해야 합니다. 자세한 내용은 워크스페이스에 액세스하기 페이지를 참조하세요.

여러 풋프린트 정의하기

컴포넌트 템플릿 Editor는 컴포넌트 템플릿의 일부로 여러 PCB 풋프린트를 정의하는 기능도 지원합니다. 풋프린트 모델 링크는 개수 제한 없이 지정할 수 있습니다. 이 기능은 서로 다른 밀도 수준에 대한 IPC 요구 사항을 충족하는 3개의 풋프린트, 즉 L(최소 또는 최소 구리), M(최대 또는 최대 구리), N(공칭 또는 중간 구리)를 참조하는 컴포넌트를 만들려는 사용자에게 유용합니다.

템플릿에 풋프린트 모델 정의를 추가하려면 를 클릭하여 새 파라미터를 추가한 다음, Type 필드와 연결된 드롭다운 메뉴에서 PCBLIB 항목을 선택합니다.

새로 추가한 파라미터의 Type를 PCBLIB로 설정하여 풋프린트 모델 정의로 변환합니다.
새로 추가한 파라미터의 Type를 PCBLIB로 설정하여 풋프린트 모델 정의로 변환합니다.

파라미터 이름은 Parameter에서 PCBLIB n로 변경됩니다. 여기서 n는 여러 풋프린트 모델을 구분하기 위해 사용할 수 있는 다음 정수입니다(예: PCBLIB 1, PCBLIB 2 등). 기본 모델은 PCBLIB 항목에 연결된 모델입니다. 컴포넌트를 정의할 때 풋프린트를 컴포넌트 Editor로 가져오면, 기본 풋프린트 모델은 모델 미리보기 창 왼쪽 상단의 아이콘(Single Component Editing 모드인 경우)과 Required Models/Parameters 영역의 PCBLIB (default) 항목(Batch Component Editing 모드인 경우)으로 구분됩니다.

참조된 컴포넌트 템플릿을 사용하여 컴포넌트 Editor(Single Component Editing 모드)에서 정의한 컴포넌트의 예입니다. 템플릿에는 세 개의 풋프린트 모델이 정의되어 있으며, 이 모델들이 컴포넌트 정의에 추가됩니다. 컴포넌트를 정의할 때 템플릿의 PCBLIB 모델 항목이 기본 풋프린트 모델로 사용되는 점에 유의하세요. 이 모델은 왼쪽 상단의 아이콘으로 구분됩니다. 이미지 위에 마우스 포인터를 올리면 컴포넌트 Editor의 Batch Component Editing 모드에서 동일한 컴포넌트를 정의하는 모습을 볼 수 있습니다. 이 경우 기본 풋프린트는 PCBLIB (default)이라고 합니다.
참조된 컴포넌트 템플릿을 사용하여 컴포넌트 Editor(Single Component Editing 모드)에서 정의한 컴포넌트의 예입니다. 템플릿에는 세 개의 풋프린트 모델이 정의되어 있으며, 이 모델들이 컴포넌트 정의에 추가됩니다. 컴포넌트를 정의할 때 템플릿의 PCBLIB 모델 항목이 기본 풋프린트 모델로 사용되는 점에 유의하세요. 이 모델은 왼쪽 상단의 아이콘으로 구분됩니다. 이미지 위에 마우스 포인터를 올리면 컴포넌트 Editor의 Batch Component Editing 모드에서 동일한 컴포넌트를 정의하는 모습을 볼 수 있습니다. 이 경우 기본 풋프린트는 PCBLIB (default)이라고 합니다.

컴포넌트 템플릿 Import 및 내보내기

기존 컴포넌트 템플릿 파일(*.CMPT) 또는 컴포넌트 라이브러리 파일(*.CMPLIB)을 컴포넌트 템플릿 Editor로 가져올 수 있으며, 편집 중인 컴포넌트 템플릿을 컴포넌트 템플릿 파일(*.CMPT)로 내보낼 수 있습니다. 컴포넌트 Editor의 주 메뉴에서 File » Import » Component Template, File » Import » Component Library 및 File » Export 명령을 사용하여 원하는 작업을 선택하세요. 그런 다음 열리는 표준 Windows 대화 상자에서 필요한 위치로 이동하여 가져올 파일을 선택하거나 내보낼 파일의 이름을 지정하세요.

컴포넌트 템플릿 재사용

컴포넌트 템플릿의 리비전을 사용하거나, 더 정확히 말해 현재 편집 중인 컴포넌트의 리비전에서 템플릿 리비전을 참조하는 방법은 다음과 같습니다.

컴포넌트는 한 번에 하나의 컴포넌트 템플릿만 참조할 수 있습니다.

새 컴포넌트 생성 시

주 메뉴의 File » New » Component 명령을 사용하여 새 컴포넌트를 생성할 때 Create new component 대화 상자에서 템플릿을 선택할 수 있습니다.

새 컴포넌트 생성 시 사용 가능한 모든 템플릿 목록에서 컴포넌트 템플릿을 빠르게 연결합니다.
새 컴포넌트 생성 시 사용 가능한 모든 템플릿 목록에서 컴포넌트 템플릿을 빠르게 연결합니다.

컴포넌트 Editor에서 수동으로 연결

컴포넌트 Editor에서 컴포넌트 템플릿의 리비전을 재사용하는 방법은 Editor의 작업 모드에 따라 달라집니다.

싱글 컴포넌트 편집 모드에서

컴포넌트 Editor의 이 모드에서 싱글 컴포넌트를 편집할 때는 Template 필드에 연결된 드롭다운 메뉴에서 필요한 컴포넌트 템플릿을 선택하세요. 이 필드는 Editor의 Component 영역에 있는 Advanced Settings 그룹에 포함되어 있습니다. 컴포넌트가 있는 워크스페이스에서 현재 사용 가능한 모든 컴포넌트 템플릿이 이름별로 나열되며, 최신 리비전은 괄호 안에 표시됩니다. 필요한 템플릿을 선택하면 적용됩니다.

컴포넌트 Editor의 Single Component Editing 모드에서 컴포넌트 리비전을 편집할 때 사용 가능한 모든 템플릿 메뉴에서 컴포넌트 템플릿을 빠르게 연결합니다.
컴포넌트 Editor의 Single Component Editing 모드에서 컴포넌트 리비전을 편집할 때 사용 가능한 모든 템플릿 메뉴에서 컴포넌트 템플릿을 빠르게 연결합니다.

일괄 컴포넌트 편집 모드에서

현재 편집 중인 컴포넌트 리비전에 컴포넌트 템플릿의 리비전을 연결하는 방법은 두 가지입니다.

  • 문서 옵션 대화 상자(Edit » Document Options)의 Template 탭에서 연결합니다. Item Revision 필드 오른쪽의 Choose 버튼을 클릭하세요. 그러면 Choose Item 대화 상자(Explorer 패널의 한 형태)가 열립니다. 이 대화 상자를 사용하여 필요한 컴포넌트 템플릿의 리비전을 찾아 선택하세요. OK를 클릭하면 컴포넌트 리비전과 컴포넌트 템플릿의 대상 리비전 간에 링크가 생성됩니다. 생성된 링크는 Document Options 대화 상자의 Template 탭에서 확인할 수 있습니다.

    대상 워크스페이스에 있는 컴포넌트 템플릿의 리비전에 컴포넌트를 수동으로 연결합니다.
    대상 워크스페이스에 있는 컴포넌트 템플릿의 리비전에 컴포넌트를 수동으로 연결합니다.

    사용 중인 컴포넌트 템플릿은 언제든지 변경할 수 있습니다. Choose를 클릭하고 다른 컴포넌트 템플릿의 리비전을 선택하세요.
    연결된 컴포넌트 템플릿 Item 리비전의 상태는 Document Options 대화 상자의 Template 탭에 표시됩니다. 연결된 Item의 새 리비전이 있으면 버튼을 클릭하여 최신 리비전을 사용하세요.
  • 컴포넌트 Editor의 Required Models/Parameters 영역에 연결된 Add 메뉴에서 연결합니다. Templates 하위 메뉴에는 컴포넌트가 있는 워크스페이스에서 현재 사용 가능한 모든 컴포넌트 템플릿이 이름별로 나열되며, 최신 리비전은 괄호 안에 표시됩니다. 항목을 클릭하면 해당 컴포넌트 템플릿의 최신 리비전에 대한 링크가 생성됩니다. 이 경우에도 Document Options 대화 상자의 Templates 탭에서 링크를 확인할 수 있습니다.

    사용 가능한 모든 템플릿 메뉴에서 컴포넌트 템플릿을 빠르게 연결합니다.
    사용 가능한 모든 템플릿 메뉴에서 컴포넌트 템플릿을 빠르게 연결합니다.

워크스페이스의 컴포넌트 폴더에서 상속

워크스페이스의 컴포넌트 폴더에 저장되는 모든 컴포넌트와 해당 리비전에 자동으로 사용할 컴포넌트 템플릿을 지정할 수 있습니다.

기본 컴포넌트 템플릿은 Components 유형의 폴더에만 정의할 수 있습니다.

폴더 편집 대화 상자에서 폴더 속성을 정의할 때 Component Template 필드를 사용하여 필요한 템플릿을 지정하세요. 이 필드의 드롭다운에는 컴포넌트 폴더가 있는 워크스페이스에서 현재 사용 가능한 모든 컴포넌트 템플릿이 이름별로 나열되며, 최신 리비전은 괄호 안에 표시됩니다. 항목을 선택하면 이후 해당 폴더에서 생성되는 각 컴포넌트에 대해 해당 컴포넌트 템플릿의 최신 리비전으로 연결되는 링크가 생성됩니다.

상위 컴포넌트 폴더에서 생성되는 모든 컴포넌트에 적용할 기본 컴포넌트 템플릿을 지정합니다.
상위 컴포넌트 폴더에서 생성되는 모든 컴포넌트에 적용할 기본 컴포넌트 템플릿을 지정합니다.

이 기능을 사용하지 않으려면 Component Template 필드를 None로 유지하거나 설정하세요.

폴더 수준에서 컴포넌트 템플릿을 선택하면 하위 폴더에서 컴포넌트를 생성할 때도 기본적으로 동일한 템플릿이 사용됩니다. 이를 통해 하위 폴더의 모든 컴포넌트에 템플릿을 빠르게 상속할 수 있습니다.

컴포넌트의 리비전을 워크스페이스에 저장하면 사용된 컴포넌트 템플릿의 특정 리비전이 사실상 고정됩니다. 따라서 수동으로 변경하지 않는 한 해당 리비전과의 연결이 유지됩니다.

컴포넌트 템플릿 사용 시 컴포넌트 모델 및 파라미터에 미치는 영향

컴포넌트 리비전을 편집하면서 컴포넌트 템플릿의 리비전을 연결하거나 참조하면 컴포넌트 Editor의 모델 및 파라미터에 다음과 같은 변화가 발생합니다.

  • 참조된 템플릿에 정의된 모델이 Models 영역(Single Component Editing 모드)과 Model Links 영역(Batch Component Editing 모드)에 추가됩니다.
  • 기존에 참조된 모델은 유지되며, 의도적으로 수동 변경하지 않는 한 컴포넌트는 해당 모델을 계속 사용합니다.
  • 참조된 템플릿에 정의된 파라미터가 Parameters 영역(Single Component Editing 모드)과 Required Models/Parameters 영역(Batch Component Editing 모드)에 추가됩니다.

    컴포넌트 Editor를 Single Component Editing 모드(왼쪽)와 Batch Component Editing 모드(오른쪽)로 사용할 때 컴포넌트 템플릿의 리비전에 연결한 후의 파라미터 예입니다.
    컴포넌트 Editor를 Single Component Editing 모드(왼쪽)와 Batch Component Editing 모드(오른쪽)로 사용할 때 컴포넌트 템플릿의 리비전에 연결한 후의 파라미터 예입니다.

    참조된 컴포넌트 템플릿에서 가져온 모든 파라미터는 아이콘(Single Component Editing 모드)과 아이콘(Batch Component Editing 모드)으로 구분됩니다. 또한 일괄 컴포넌트 편집 모드에서만 각 템플릿 기반 파라미터의 Show 옵션이 템플릿의 해당 Visible 옵션 상태를 따릅니다.
    템플릿 기반 파라미터는 제거할 수 없습니다.
    필요에 따라 사용자 파라미터를 자유롭게 추가할 수 있습니다.
  • Batch Component Editing 모드에서만 표시하도록 설정된 템플릿 기반 파라미터가 Editor의 컴포넌트 정의 영역에 함께 그룹화되며, Template Parameters가 헤더 텍스트로 사용됩니다.

    컴포넌트 Editor를 Batch Component Editing 모드로 사용할 때, 컴포넌트 정의 자체를 지정하는 영역에 표시되는 템플릿 기반 파라미터의 예.
    컴포넌트 Editor를 Batch Component Editing 모드로 사용할 때, 컴포넌트 정의 자체를 지정하는 영역에 표시되는 템플릿 기반 파라미터의 예.

  • 읽기 전용으로 지정된 템플릿 기반 파라미터의 값 필드는 편집할 수 없습니다. 읽기 전용으로 지정되지 않은 다른 모든 템플릿 기반 파라미터는 필요에 따라 값을 자유롭게 변경할 수 있습니다.

    컴포넌트 Editor가 Single Component Editing 모드일 때, 읽기 전용 템플릿 파라미터는 Parameters Region에서 아이콘으로 구분됩니다.
  • 템플릿 기반 파라미터가 필수로 지정되었지만 템플릿에서 값이 지정되지 않은 경우, 값 필드에 빨간색 테두리가 표시되거나(Batch Component Editing 모드), 아이콘이 표시되어(Single Component Editing 모드) 해당 파라미터에 값이 필요함을 알려줍니다. 모든 필수 파라미터에 값을 지정하기 전에는 컴포넌트를 워크스페이스에 저장할 수 없습니다.

    컴포넌트 Editor가 Single Component Editing 모드일 때, 필수 템플릿 파라미터는 Parameters Region에서 아이콘으로 구분됩니다.

컴포넌트 템플릿 다시 저장하기

언제든지 워크스페이스에 있는 컴포넌트 템플릿의 원하는 리비전으로 돌아가 직접 편집할 수 있습니다. 해당 리비전을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Edit 명령을 선택하세요. 임시 Editor가 다시 열리고, 해당 리비전에 포함된 템플릿이 편집할 수 있는 상태로 열립니다. 필요에 따라 변경한 후 컴포넌트 템플릿을 Item의 다음 리비전으로 저장하세요.

컴포넌트 템플릿 자체의 최상위 Entry를 마우스 오른쪽 버튼으로 클릭하면 해당 템플릿의 최신 리비전을 편집하게 됩니다.

컴포넌트 템플릿의 기존 리비전을 직접 편집하기 위한 명령에 액세스하는 모습.
컴포넌트 템플릿의 기존 리비전을 직접 편집하기 위한 명령에 액세스하는 모습.

저장된 데이터 다운로드하기

컴포넌트 템플릿의 리비전에 저장된 데이터를 다운로드하려면 Explorer Panel에서 해당 리비전을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Operations » Download 명령을 선택하세요. 컴포넌트 템플릿 파일은 선택한 디렉터리 아래에 Item 리비전 ID를 이름으로 사용하는 하위 폴더로 다운로드됩니다. 파일은 그 안의 Released 폴더에서 찾을 수 있습니다.

컴포넌트 템플릿 자체의 최상위 Entry에서 Download 명령을 실행하면 해당 템플릿의 최신 리비전에 저장된 컴포넌트 템플릿 파일을 다운로드할 수 있습니다.
Download from Server 대화 상자에서 Explore 버튼을 클릭하면 다운로드 폴더를 빠르게 열 수 있습니다.

소프트 삭제

워크스페이스에 연결되어 있으면 Altium Designer의 Explorer Panel에서 컴포넌트 템플릿을 직접 제거할 수 있는 유연한 기능을 사용할 수 있습니다. Panel에서 컴포넌트 템플릿의 Entry를 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Delete Item 명령을 선택하세요. 삭제를 확인할 수 있는 Delete Items 대화 상자가 나타납니다. 이 작업은 실제로 '소프트 삭제'이며, 컴포넌트 템플릿은 워크스페이스의 Trash 영역으로 이동됩니다. Trash는 기본적으로 워크스페이스 내의 모든 콘텐츠를 소프트 삭제 작업을 통해 이동할 수 있는 휴지통입니다. 이 영역은 워크스페이스의 나머지 부분과 분리되어 있습니다.

소프트 삭제 기능을 사용하면 현재 사용 중인 컴포넌트 템플릿도 삭제할 수 있습니다.
여러 컴포넌트 템플릿을 한 번에 삭제할 수 있습니다. 표준 다중 선택 방식(Shift+Click, Ctrl+Click)으로 필요한 컴포넌트 템플릿을 모두 선택한 다음, 마우스 오른쪽 버튼을 클릭하고 컨텍스트 메뉴에서 Delete Items 명령을 선택하세요.

컴포넌트 템플릿의 소프트 삭제. 템플릿은 워크스페이스의 Trash 영역으로 이동됩니다.
컴포넌트 템플릿의 소프트 삭제. 템플릿은 워크스페이스의 Trash 영역으로 이동됩니다.

삭제를 진행하려면 버튼을 클릭하세요. Item이 제거되고 Deletion Summary 대화 상자에서 삭제가 완료되었음을 확인할 수 있습니다. 삭제 중 문제가 발생하면 알림이 표시됩니다.

이 방식으로 삭제된 모든 콘텐츠는 워크스페이스 브라우저 인터페이스의 Trash 페이지에서 찾을 수 있습니다. 본인이 직접 소프트 삭제한 콘텐츠만 볼 수 있다는 점에 유의하세요. 관리자는 Trash 페이지의 전체 콘텐츠, 즉 소프트 삭제된 모든 콘텐츠를 볼 수 있습니다.

소프트 삭제된 컴포넌트 템플릿과 관련하여 고려할 사항:

  • 설계 소프트웨어나 웹 인터페이스에서 해당 컴포넌트 템플릿을 사용할 수 없습니다.
  • 해당 컴포넌트 템플릿이 사용되던 모든 위치에 컴포넌트 템플릿이 삭제되었음이 표시됩니다.
  • 편집 권한이 있으면 Trash 페이지에서 컴포넌트 템플릿을 복원하거나 영구 삭제할 수 있습니다. 영구 삭제는 해당 템플릿이 Parent Item에서 사용되고 있지 않은 경우에만 가능합니다.
컴포넌트 템플릿을 소프트 삭제하여 Trash로 이동한 경우, 동일한 이름으로 새 컴포넌트 템플릿을 다시 만들 수 있습니다. 이후 원래 컴포넌트 템플릿을 복원할 때 원래 이름이 이미 사용 중이면, 워크스페이스 내에서 고유한 이름을 유지하도록 정수 접미사가 추가됩니다.
AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

Contents