Validating a Component

Przed zapisaniem komponentu biblioteki Workspace, zdefiniowanego/edytowanego w edytorze komponentów (w trybie Single Component Editing lub Batch Component Editing), do connected Workspace i udostępnieniem komponentu do użycia w projektach, należy koniecznie upewnić się, że komponent spełnia wymagania zgodnie ze skonfigurowanymi ustawieniami. Gdy próbujesz zapisać komponent z powrotem do Workspace, edytor komponentów uruchamia walidację – sprawdzenie reguł komponentu.

  • Tę funkcję można również uruchomić ręcznie w dowolnym momencie, wybierając polecenie Tools » Component Rule Check z menu głównego. Pamiętaj, aby wcześniej zapisać komponent lokalnie (File » Save).

  • Polecenie Component Rule Check jest również dostępne w głównym menu File edytora oraz w menu kontekstowym pozycji komponentu w panelu Projects.

Tak jak projekt płytki ma proces walidacji służący do wykrywania naruszeń, tak edytor komponentów ma funkcję walidacji komponentu. Wszystkie wykryte naruszenia są wyświetlane w panelu Messages.

 
 
 
 
 

Wykrywanie problemów z komponentem przed zapisaniem do Workspace. Pokazano tutaj uruchomienie polecenia Component Rule Check z edytora komponentów w trybie Single Component Editing.

Wykrywanie problemów z komponentem przed zapisaniem do Workspace. Pokazano tutaj uruchomienie polecenia Component Rule Check z edytora komponentów w trybie Batch Component Editing.

 

Walidacja komponentu sprawdza szereg potencjalnych problemów dotyczących komponentu i jego zdefiniowanych modeli – zarówno testy wbudowane na stałe, jak i zakres typów naruszeń definiowanych przez użytkownika na poziomie globalnym.

Następujące wbudowane kontrole walidacyjne mają wszystkie tryb raportowania :

Kontrole definiowane przez użytkownika konfiguruje się na stronie Data Management – Component Rule Checks page okna dialogowego Preferences.

 
 
 
 
 

Kontrole naruszeń definiowane przez użytkownika, które można skonfigurować jako część preferencji globalnych do użycia podczas walidacji komponentu.
Kontrole naruszeń definiowane przez użytkownika, które można skonfigurować jako część preferencji globalnych do użycia podczas walidacji komponentu.

Każdy z niezmiennych testów, który zakończy się niepowodzeniem, lub kontrole zdefiniowane przez użytkownika na poziomie Błąd krytyczny uniemożliwią zapisanie komponentu do Workspace.

Domyślne ustawienia kontroli definiowanych przez użytkownika mogą nie odpowiadać Twoim komponentom, dlatego ważne jest, aby zapoznać się z opcjami i sposobem ich konfiguracji tak, aby pasowały do Twoich projektów. Informacje o każdej kontroli błędów definiowanej przez użytkownika można znaleźć poniżej.

Naruszenia powiązane z komponentami

Naruszenia związane z footprintami

Naruszenia związane z symbolami

AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Contents