Creating a PCB Footprint

Obszar zajmowany przez komponent na wyprodukowanej płytce jest określony przez jego footprint. Typowy footprint zawiera pola lutownicze i nadruk komponentu, a także może obejmować wszelkie inne wymagane szczegóły mechaniczne. W przykładowym footprincie poniżej większość obrysu komponentu zdefiniowano na warstwie mechanicznej (zielone linie), a nie na warstwie nadruku (żółte linie), ponieważ komponent ten będzie zamontowany tak, aby wystawał nad wycięcie w płytce.

Footprint określa przestrzeń zajmowaną przez komponent i zapewnia punkty połączenia wyprowadzeń lub pól lutowniczych komponentu ze ścieżkami na płytce. 
Footprint określa przestrzeń zajmowaną przez komponent i zapewnia punkty połączenia wyprowadzeń lub pól lutowniczych komponentu ze ścieżkami na płytce.

Komponent montowany na tym footprincie można modelować za pomocą obiektów bryły 3D. Obiekt bryły 3D służy jako kontener, do którego można zaimportować model w uniwersalnym formacie MCAD, jak pokazano na ilustracji poniżej.

Odpowiedni model MCAD można zaimportować do obiektu bryły 3D.
Odpowiedni model MCAD można zaimportować do obiektu bryły 3D.

Nawet przy bogatym zestawie zasobów udostępniających gotowe komponenty PCB (takich jak panel Manufacturer Part Search) prawdopodobnie na pewnym etapie pracy zawodowej zajdzie potrzeba utworzenia własnego komponentu PCB. Footprinty komponentów PCB tworzy się w edytorze footprintów PCB przy użyciu tego samego zestawu obiektów podstawowych, który jest dostępny w edytorze PCB. Oprócz footprintów jako komponenty PCB można również zapisywać logotypy firm, definicje produkcyjne i inne obiekty wymagane podczas projektowania płytki.

Tworzenie nowego footprintu PCB

Footprinty można tworzyć bezpośrednio w połączonej przestrzeni roboczej. W tym celu:

  1. Wybierz File » New » Library z menu głównego, a następnie w otwartym oknie dialogowym New Library wybierz Create Library Content » Footprint w obszarze Workspace tego okna.

    Utwórz nowy footprint w przestrzeni roboczej za pomocą okna dialogowego New Library
    Utwórz nowy footprint w przestrzeni roboczej za pomocą okna dialogowego New Library

  2. W otwartym oknie dialogowym Create New Item wprowadź wymagane informacje, upewnij się, że opcja Open for editing after creation jest włączona, i kliknij OK. Footprint zostanie utworzony w przestrzeni roboczej i otworzy się tymczasowy edytor footprintów PCB z dokumentem .PcbLib jako aktywnym dokumentem. Dokument otrzyma nazwę zgodną z identyfikatorem elementu i rewizji, w formacie: <Item><Revision>.PcbLib (np. PCC-001-0001-1.PcbLib). Użyj tego dokumentu, aby zdefiniować footprint w sposób opisany poniżej.

    Przykład edycji początkowej rewizji footprintu w przestrzeni roboczej — tymczasowy edytor footprintów PCB udostępnia dokument, w którym można zdefiniować footprint.
    Przykład edycji początkowej rewizji footprintu w przestrzeni roboczej — tymczasowy edytor footprintów PCB udostępnia dokument, w którym można zdefiniować footprint.

  3. Po zdefiniowaniu footprintu zgodnie z wymaganiami zapisz go w przestrzeni roboczej za pomocą elementu sterującego Save to Server po prawej stronie wpisu footprintu w panelu Projects. Pojawi się okno dialogowe Edit Revision, w którym można zmienić nazwę i opis oraz w razie potrzeby dodać informacje o wydaniu. Po zapisaniu dokument i edytor zostaną zamknięte.

Zapisany footprint z przestrzeni roboczej można wykorzystać podczas definiowania komponentu w edytorze komponentów w trybie edycji pojedynczego komponentu lub trybie edycji zbiorczej komponentów.

Footprinty w przestrzeni roboczej można przeglądać za pomocą panelu Components. Włącz widoczność modeli, klikając przycisk  u góry panelu i wybierając Models, a następnie wybierz kategorię Footprints.

Aby edytować footprint w przestrzeni roboczej, kliknij prawym przyciskiem myszy jego wpis w panelu Components i wybierz polecenie Edit. Ponownie otworzy się tymczasowy edytor z footprintem gotowym do edycji. Wprowadź wymagane zmiany, a następnie zapisz dokument jako kolejną rewizję footprintu w przestrzeni roboczej.

  • Gdy zmienisz footprint w przestrzeni roboczej i zapiszesz tę zmianę jako nową rewizję, wszystkie komponenty w przestrzeni roboczej korzystające z tego footprintu staną się nieaktualne, ponieważ nadal będą używać poprzedniej rewizji. W większości przypadków zapewne zechcesz ponownie zapisać te komponenty, aktualizując odpowiednie powiązania z modelami tak, aby korzystały z najnowszych dostępnych rewizji. Aby usprawnić ten proces, przestrzeń robocza we współpracy z Altium Designer umożliwia aktualizowanie komponentów nadrzędnych podczas ponownego zapisywania footprintu po wprowadzeniu w nim zmian za pomocą funkcji edycji bezpośredniej.

    Więcej informacji na temat aktualizowania komponentów nadrzędnych podczas zapisywania modelu dziedzinowego można znaleźć na stronie Tworzenie i edytowanie zawartości.

  • Footprint używany przez komponent w przestrzeni roboczej można również aktualizować na bieżąco podczas edycji tego komponentu w edytorze komponentów w trybie edycji pojedynczego komponentu lub trybie edycji zbiorczej komponentów.

  • Z punktu widzenia projektanta komponent w przestrzeni roboczej skupia w jednym elemencie wszystkie informacje potrzebne do reprezentowania go we wszystkich dziedzinach projektowania. Można go zatem traktować jako kontener — „pojemnik”, w którym przechowywane są wszystkie modele dziedzinowe i informacje parametryczne. Jeśli chodzi o reprezentację w poszczególnych dziedzinach, komponent w przestrzeni roboczej nie zawiera samych modeli dziedzinowych z tej przestrzeni, lecz powiązania z tymi modelami. Powiązania te określa się podczas definiowania komponentu.

  • Footprinty PCB można również tworzyć w przestrzeni roboczej podczas importowania istniejących bibliotek komponentów starszej generacji (SchLib, PcbLib, IntLib, DbLib, SVNDbLib). Interfejs tego procesu — Library Importer — zapewnia intuicyjny przebieg pracy: od wyboru bibliotek źródłowych po ich zaimportowanie do przestrzeni roboczej. Dowiedz się więcej o importerze bibliotek.

  • Nowy footprint w przestrzeni roboczej można również utworzyć podczas definiowania komponentu w przestrzeni roboczej w edytorze komponentów w trybie edycji pojedynczego komponentu.

  • Footprint można również utworzyć jako część plikowej biblioteki footprintów PCB.

Definiowanie footprintu PCB

Footprinty zawsze tworzy się po górnej stronie płytki, niezależnie od tego, po której stronie zostaną ostatecznie umieszczone, korzystając z tego samego zestawu narzędzi i obiektów projektowych, który jest dostępny w edytorze PCB. Atrybuty właściwe dla poszczególnych warstw, takie jak pola lutownicze do montażu powierzchniowego i definicje maski lutowniczej, są automatycznie przenoszone na odpowiednie warstwy dolnej strony po odwróceniu footprintu na drugą stronę płytki podczas rozmieszczania komponentów.

Obiekty projektowe można umieszczać na dowolnej warstwie, jednak obrys zwykle tworzy się na warstwie Top Overlay (nadruku), a pola lutownicze na warstwie wielowarstwowej (w przypadku wyprowadzeń komponentów przewlekanych) lub na górnej warstwie sygnałowej (w przypadku wyprowadzeń komponentów do montażu powierzchniowego). Po umieszczeniu footprintu na PCB wszystkie tworzące go obiekty zostaną przypisane do zdefiniowanych dla nich warstw.

Widoki 2D i 3D footprintu joysticka. Obraz 3D przedstawia zaimportowany model STEP komponentu. Zwróć uwagę, że pod modelem STEP widać pola lutownicze i nadruk komponentu.
Widoki 2D i 3D footprintu joysticka. Obraz 3D przedstawia zaimportowany model STEP komponentu. Zwróć uwagę, że pod modelem STEP widać pola lutownicze i nadruk komponentu.

Footprinty przedstawione na tej stronie służą wyłącznie do zilustrowania wymaganych procedur; ich wymiary nie są dokładne. Zawsze sprawdzaj parametry nowego footprintu, porównując je z kartą katalogową producenta.

Typowa kolejność czynności podczas ręcznego tworzenia footprintu komponentu jest następująca:

  1. Przygotuj obszar projektowy: zdefiniuj opcje przyciągania, skonfiguruj siatki i prowadnice — dowiedz się więcej.

  2. Footprinty należy tworzyć wokół punktu odniesienia obszaru projektowego, znajdującego się w środku edytora footprintów PCB. Ten punkt odniesienia jest w rzeczywistości względnym początkiem układu współrzędnych obszaru projektowego i punktem, za który kursor chwyta footprint komponentu podczas operacji umieszczania i przesuwania (w zależności od bieżącego ustawienia Object Snap Options na stronie PCB Editor – General okna dialogowego Preferences). Użyj skrótu klawiaturowego J, R, aby przejść bezpośrednio do punktu odniesienia. Jeśli przed rozpoczęciem tworzenia footprintu nie przeszedłeś do punktu odniesienia, możesz przenieść punkt odniesienia do footprintu za pomocą poleceń podmenu Edit » Set Reference:
    • Pin 1 — ustaw punkt odniesienia komponentu na wyprowadzeniu 1 footprintu komponentu.

    • Center — ustaw punkt odniesienia komponentu w środku footprintu komponentu.

    • Location — ustaw punkt odniesienia komponentu w miejscu wskazanym przez użytkownika.

    Wybrany punkt zostanie ustawiony na 0,0 — stanie się nowym względnym początkiem układu współrzędnych, a położenia wszystkich obiektów podstawowych zostaną zaktualizowane względem tego punktu.

  3. Umieść pady (Place » Pad) zgodnie z wymaganiami komponentu. Po uruchomieniu polecenia Place Pad, ale przed umieszczeniem pierwszego pada, naciśnij klawisz Tab, aby otworzyć panel Properties i zdefiniować wszystkie właściwości pada, w tym Designator, Size and Shape, Layer oraz Hole Size (w przypadku pada przewlekanego). Oznaczenie jest automatycznie zwiększane przy umieszczaniu kolejnych padów. W przypadku pada do montażu powierzchniowego ustaw Layer na Top Layer. W przypadku pada przewlekanego ustaw Layer na Multi-Layer.

    Niektóre footprinty wymagają padów o nieregularnym kształcie. Można je utworzyć za pomocą obiektów padów o niestandardowym kształcie. Więcej informacji znajdziesz na stronie Dostosowywanie stosu pada.
    • Jedną z najważniejszych czynności podczas tworzenia nowego footprintu komponentu jest rozmieszczenie padów, które posłużą do przylutowania komponentu do PCB. Muszą one znajdować się w ściśle określonych położeniach, odpowiadających wyprowadzeniom rzeczywistego elementu.
    • Należy również zachować ostrożność przy nadawaniu oznaczeń padom, ponieważ to właśnie tę właściwość Altium Designer wykorzystuje do mapowania numerów wyprowadzeń symbolu schematowego.
  4. Aby zapewnić dokładne rozmieszczenie padów, rozważ skonfigurowanie siatki specjalnie do tego zadania. Użyj skrótu klawiaturowego Ctrl+G, aby otworzyć okno dialogowe edytora siatki kartezjańskiej, a klawisza Q, aby przełączyć siatkę z jednostek calowych na metryczne.

  5. Aby precyzyjnie umieścić pad podczas przesuwania go myszą, użyj klawiszy strzałek do przesuwania kursora o bieżący krok siatki. Dodatkowo przytrzymanie Shift umożliwia przesuwanie z krokiem równym 10-krotności kroku siatki. Bieżące współrzędne X, Y są wyświetlane na pasku stanu oraz w wyświetlaczu Heads Up. Wyświetlacz Heads Up pokazuje zarówno położenie, jak i różnicę między położeniem ostatniego kliknięcia a bieżącym położeniem kursora. Użyj skrótu Shift+H, aby włączyć lub wyłączyć wyświetlacz Heads Up. Możesz też kliknąć dwukrotnie umieszczony pad, aby go edytować, i wprowadzić wymagane współrzędne X i Y w panelu Properties .

  6. Aby sprawdzić odległość między dwoma punktami w obszarze projektowym, użyj Reports » Measure Distance (skrót Ctrl+M). Postępuj zgodnie z komunikatami na pasku stanu.

  7. Atrybuty specyficzne dla padów, takie jak maska lutownicza i maska pasty lutowniczej, są obliczane automatycznie na podstawie wymiarów pada i odpowiednich reguł projektowych dotyczących masek. Chociaż ustawienia masek można definiować ręcznie dla każdego pada, utrudnia to ich późniejsze modyfikowanie podczas projektowania płytki. Zwykle robi się to tylko wtedy, gdy nie można objąć danych padów regułami projektowymi. Pamiętaj, że reguły definiuje się w edytorze PCB podczas projektowania płytki.

  8. Użyj ścieżek, łuków i innych obiektów podstawowych, aby zdefiniować obrys komponentu widoczny na warstwie opisowej PCB Top Overlay. Jeśli podczas umieszczania komponent zostanie przeniesiony na spód płytki, obrys zostanie automatycznie przeniesiony na warstwę Bottom Overlay.

  9. Umieść ścieżki i inne obiekty podstawowe na warstwie mechanicznej, aby zdefiniować dodatkowe szczegóły mechaniczne, takie jak obszar zajmowany przez komponent (courtyard). Warstwy mechaniczne są warstwami ogólnego przeznaczenia. Należy określić funkcję tych warstw i używać ich konsekwentnie we wszystkich footprintach.

  10. Umieść obiekty brył 3D, aby zdefiniować trójwymiarowy kształt rzeczywistego komponentu, który ma zostać zamontowany na PCB.

    Obiekt bryły 3D dodany do footprintu może odwoływać się do modelu 3D przesłanego do połączonego obszaru roboczego Workspace.
  11. Teksty Designator i Comment są automatycznie dodawane do warstwy opisowej footprintu podczas umieszczania go w obszarze projektowym PCB. Dodatkowe teksty Designator i Comment można uwzględnić, umieszczając ciągi specjalne .Designator i .Comment na warstwie mechanicznej.

    Podczas umieszczania tekstów Designator i Comment należy zdefiniować parę warstw w edytorze PCB. Dzięki temu teksty będą powiązane ze stroną płytki, na której zamontowany jest komponent, i będą przenoszone na drugą stronę płytki wraz z komponentem. Więcej informacji znajdziesz w sekcji Obsługa specjalnych wymagań dotyczących warstw poniżej.
  12. Zdefiniuj właściwości footprintu (np. jego nazwę i opis) na karcie Footprint panelu Properties w trybie Library Options (aktywnym, gdy w obszarze projektowym nie jest zaznaczony żaden obiekt; można go otworzyć za pomocą polecenia Tools » Footprint Properties z menu głównego). Zapoznaj się z poniższą sekcją, aby dowiedzieć się więcej o opcjach i elementach sterujących dostępnych na karcie Footprint panelu.

  • Aby stosować ujednolicone definicje padów i przelotek we wszystkich footprintach, do ich umieszczania można używać biblioteki padów i przelotek (*.PvLib) — dowiedz się więcej.
  • Edytor footprintów PCB udostępnia również kreatory przyspieszające tworzenie footprintów:
    • Kreator IPC Compliant Footprint Wizard – generuje footprint PCB w pełni zgodny z rewizją B normy IPC 7351 — Generic Requirements for Surface Mount Design and Land Pattern Standard — dowiedz się więcej.
    • Kreator IPC Compliant Footprints Batch Generator – podczas pracy z plikową biblioteką footprintów PCB użyj IPC Compliant Footprints Batch Generator , aby szybko wygenerować wiele footprintów o różnych poziomach gęstości rozmieszczenia — dowiedz się więcej.
    • Kreator Footprint Wizard – umożliwia wybór spośród różnych typów obudów i wprowadzenie odpowiednich informacji, a następnie tworzy wzorzec PCB komponentu – dowiedz się więcej.

Przygotowanie obszaru projektowego

Domyślnie siatki są wyświetlane w postaci kropek. Jeśli wolisz, możesz wyświetlać je w postaci linii. Ustawienie to można zmienić w oknie dialogowym Grid Editor, otwieranym przez kliknięcie przycisku Properties w panelu Properties, jak pokazano na poniższej ilustracji. Możesz też nacisnąć skrót klawiaturowy Ctrl+G, aby otworzyć to okno.

Na ilustracji siatka o mniejszym skoku jest wyświetlana jako kropki, a siatka o większym skoku — jako linie.
Na ilustracji siatka o mniejszym skoku jest wyświetlana jako kropki, a siatka o większym skoku — jako linie.

Panel właściwości

Podczas edycji wzorca w edytorze wzorców PCB, gdy w obszarze projektowym nie jest zaznaczony żaden obiekt, panel Properties wyświetla Library Options.

Poniższe rozwijane sekcje zawierają informacje o opcjach i elementach sterujących dostępnych na karcie General panelu:

Poniższe rozwijane sekcje zawierają informacje o opcjach i elementach sterujących dostępnych na karcie Footprint panelu:

Możliwość definiowania właściwości obudowy na karcie Footprint panelu Properties jest dostępna po włączeniu opcji PCB.FootprintParameters w oknie dialogowym Ustawienia zaawansowane. Gdy ta opcja jest wyłączona, właściwości obudowy definiuje się w oknie dialogowym PCB Library Footprint (), otwieranym przez wybranie polecenia Tools » Footprint Properties z menu głównego, wybranie wpisu obudowy w obszarze Footprints panelu PCB Library i kliknięcie przycisku Edit lub dwukrotne kliknięcie wpisu obudowy w obszarze Footprints panelu PCB Library.

Po wybraniu obiektu projektowego panel wyświetli opcje właściwe dla danego typu obiektu. Poniższa tabela zawiera typy obiektów, które można umieszczać w obszarze projektowym obudowy PCB – kliknij łącze, aby przejść do strony właściwości danego obiektu.

Bryła 3D Łuk
Łuk obszaru zabronionego Wypełnienie
Wypełnienie obszaru zabronionego Pole lutownicze
Region Region obszaru zabronionego
Tekst (ciąg znaków, ramka tekstowa) Ścieżka
Ścieżka obszaru zabronionego Przelotka

Rozszerzenia maski lutowniczej i maski pasty lutowniczej

Aby sprawdzić, czy maska lutownicza i/lub maska pasty lutowniczej zostały poprawnie zdefiniowane w edytorze obudów PCB, otwórz panel Konfiguracja widoku i włącz opcję wyświetlania () dla każdej warstwy maski.

Pierścień widoczny wokół krawędzi każdego pola lutowniczego w kolorze warstwy Top Solder Mask przedstawia krawędź kształtu maski lutowniczej wystającą spod wielowarstwowego pola lutowniczego o wartość rozszerzenia, ponieważ multi-layer znajduje się na szczycie kolejności rysowania warstw — jest rysowana na wierzchu. Ustawienie Layer Drawing Order znajduje się na stronie PCB Editor - Display w oknie dialogowym Preferences).

Poniższy obraz przedstawia footprint PCB z fioletowym obramowaniem (w kolorze warstwy Top Solder Mask) widocznym wokół krawędzi każdego pola lutowniczego.

Aby szybko przeglądać warstwy, użyj trybu pojedynczej warstwy (Shift+S) w połączeniu z Ctrl+Shift+Wheel roll.

Domyślnie kształt tworzony na warstwach masek odpowiada kształtowi pola lutowniczego, powiększonemu lub pomniejszonemu o wartość określoną przez reguły projektowe rozszerzenia maski lutowniczej i rozszerzenia maski pasty lutowniczej ustawione na płytce PCB, na której umieszczono footprint. W niektórych przypadkach może być konieczne nadpisanie reguł projektowych rozszerzenia i określenie rozszerzenia maski jako atrybutu pola lutowniczego, wybranie jednego ze standardowych, predefiniowanych kształtów maski lub utworzenie własnego kształtu. W takich sytuacjach maski pasty lutowniczej i maski lutownicze można skonfigurować dla wybranego pola lutowniczego w jego panelu Properties — dowiedz się więcej. Można też umieścić odpowiednie obiekty podstawowe (regiony, ścieżki itp.) na wymaganej warstwie maski.

W bibliotece PCB wszystkie obiekty, których rozszerzenie maski lutowniczej jest określane przez reguły, będą miały wartość rozszerzenia równą 0 mil. Ta funkcja jest dostępna po włączeniu opcji PCB.SolderMaskZeroExpansion w oknie dialogowym Advanced Settings. Gdy ta opcja jest wyłączona, wartość rozszerzenia maski lutowniczej dla takich obiektów w bibliotece PCB wynosi 4 mil.

Obsługa parametrów

Parametry przypisywane do obiektów w Altium Designer zapewniają rozbudowany i elastyczny sposób dodawania dodatkowych informacji do projektu PCB. Jako właściwości obiektu nadrzędnego parametry można przypisywać na różnych poziomach, w tym do projektów, dokumentów, szablonów i poszczególnych obiektów w dokumencie projektu.

Więcej informacji można znaleźć w sekcji Obiekt parametru.

Parametry dostępne w środowisku PCB można wykorzystywać do filtrowania w zapytaniach, regułach projektowych, skryptach i wariantach, a także stosować we footprintach komponentów PCB do wyświetlania niestandardowych ciągów tekstowych w umieszczonych footprintach.

Parametry przekazywane przez zlecenie zmian inżynierskich

Obsługa parametrów PCB opiera się na funkcjach mechanizmu ECO i dokumentu PCB, które umożliwiają przenoszenie parametrów komponentów zdefiniowanych przez użytkownika do środowiska PCB i ich przechowywanie w tym środowisku. Jest to transfer jednokierunkowy, a przekazane parametry są w środowisku PCB dostępne tylko do odczytu.

Transfer parametrów odbywa się przez utworzenie zlecenia ECO ze schematu do PCB za pomocą polecenia menu Design » Update PCB Document.

Po wykonaniu zlecenia ECO (za pomocą przycisku Execute Changes ) wszystkie nowe parametry komponentów schematu zdefiniowane przez użytkownika zostaną przeniesione do odpowiedniego wystąpienia footprintu w projekcie PCB. 

Wykrywanie i przenoszenie parametrów do PCB zależy od ustawień opcji projektu (Project » Project Options). W oknie dialogowym Project Options ustaw sposób wykrywania różnic i wprowadzania zmian w sekcji Differences Associated with Parameters na karcie Comparator oraz w sekcji Modifications Associated with Parameters na karcie ECO Generation.

Aby wyświetlić przeniesione parametry w edytorze PCB, kliknij dwukrotnie komponent, aby otworzyć panel Properties , a następnie wybierz kartę Parameters . Na karcie zostaną wyświetlone bieżące parametry użytkownika przypisane do wybranego footprintu komponentu. Parametry wybranego footprintu komponentu są również dostępne w panelu Components .

Łącza do informacji referencyjnych

Środowisko PCB automatycznie przyjmuje ze schematu predefiniowane parametry ComponentLink. Są one definiowane jako pary parametrów (opis i adres URL łącza), które zwykle tworzą odnośniki do określonych plików lub lokalizacji internetowych — najczęściej witryny producenta lub adresu URL karty katalogowej.

Informacje o parametrach łączy referencyjnych można znaleźć w sekcjach Definiowanie klikalnych łączy do informacji referencyjnych w bibliotece schematów oraz Uzyskiwanie dostępu do klikalnych łączy do informacji referencyjnych w dokumencie PCB.

Zarówno w środowisku projektowania schematów, jak i PCB dostęp do łączy można uzyskać z menu kontekstowego otwieranego prawym przyciskiem myszy po najechaniu kursorem na komponent (w opcjach podmenu References). Te specjalne parametry dodaje się w panelu Properties , a po przeniesieniu do środowiska PCB są one wyświetlane jako parametry footprintu komponentu. 

Parametry w footprintach źródłowych

Parametry przekazywane do PCB mogą służyć do umieszczania dodatkowych informacji produkcyjnych lub funkcjonalnych płytki we footprintach komponentów. Po dodaniu specjalnych ciągów parametrów do footprintów w bibliotece źródłowej niestandardowe ciągi będą interpretowane na docelowej warstwie mechanicznej lub warstwie opisowej.

Specjalny ciąg reprezentujący parametr zdefiniowany przez użytkownika można dodać do źródłowego footprintu komponentu za pomocą przycisku i listy rozwijanej ciągów specjalnych () w panelu Properties .

W poniższym footprincie bibliotecznym ciąg specjalny .Designator umieszczono na warstwie Mechanical 2.

Specjalny ciąg reprezentujący parametr użytkownika można dodać do footprintu komponentu.

Gdy ten niestandardowy parametr zostanie również przypisany do komponentów schematu, a dane parametru zostaną przeniesione do PCB, zinterpretowane ciągi footprintu pojawią się zarówno w widoku płytki, jak i w wygenerowanych plikach wyjściowych. W tym przypadku specjalny ciąg parametru zawiera niestandardowy identyfikator części komponentu ułatwiający montaż.

Stosowanie parametrów użytkownika we footprintach komponentów jako ciągów specjalnych może spełniać wiele innych niestandardowych wymagań dotyczących PCB, w tym zapewniać etykiety funkcji przełączników i złączy — ciąg parametru „funkcja” można umieścić na warstwie Top Overlay we footprintach tych typów komponentów.

Aby zobaczyć zinterpretowaną wartość ciągów specjalnych w układzie płytki, włącz opcję Special Strings w obszarze Additional Options na karcie View Options w panelu View Configuration. Ciągi specjalne są zawsze przekształcane w generowanych plikach wyjściowych.
W razie potrzeby w edytorze schematów włącz opcję Display Names of Special Strings that have No Value Defined na stronie Schematic – Graphical Editing w oknie dialogowym Preferences.

Zapytania dotyczące parametrów

Ciągi parametrów w środowisku PCB są również dostępne za pośrednictwem języka zapytań Altium Designer, dzięki czemu można ich używać w funkcjach filtrowania obiektów, w tym w funkcji znajdowania podobnych obiektów.

Aby zaznaczyć podobne obiekty, kliknij komponent prawym przyciskiem myszy, a następnie wybierz Find Similar Objects z menu kontekstowego, aby otworzyć okno dialogowe Find Similar Objects.

Okno dialogowe Znajdź podobne obiekty zawiera Parameters sekcja, w której można wybrać odpowiednie opcje filtrowania.

Panel PCB Filter może stosować słowa kluczowe zapytań dotyczące konkretnych parametrów jako kryteria filtrowania i służyć do tworzenia reguł projektowych na podstawie parametrów PCB.

Do pracy z parametrami footprintów PCB dostępnych jest kilka słów kluczowych zapytań, w tym funkcje służące do konwersji ciągów znaków na liczby (takie jak StrToNumber). Konwersja wartości tekstowych uwzględnia jednostki (V, mA, mV, kOhm itp.) i pozwala określić wynik zapytania poprzez przetwarzanie numeryczne wartości parametru zapisanej jako ciąg znaków.

Obsługiwane typy jednostek, które można wskazać w zapytaniach, to:

  • % – Procent
  • A – Prąd
  • C – Temperatura
  • dB – Decybele
  • F – Pojemność
  • G – Konduktancja
  • H – Indukcyjność
  • Hz – Częstotliwość
  • Kg – Masa
  • m – Długość
  • Ohm – Rezystancja
  • Q – Ładunek
  • s – Czas
  • V – Napięcie
  • W – Moc
  • Z – Impedancja

Do pracy z parametrami footprintów komponentów PCB dostępnych jest kilka słów kluczowych zapytań dotyczących parametrów.

Przykład pokazany w powyższym oknie dialogowym Query Helper przetwarza parametr Voltage Rating każdego komponentu (z użyciem konwersji ciągu znaków na liczbę – StrToNumber(Unit Value, Unit Type)), aby określić, czy jego wartość przekracza 50 V. Po zastosowaniu w panelu PCB Filter na przykładowej płytce zostaje wskazany jeden komponent wysokonapięciowy, C1 (którego parametr Voltage Rating ma wartość 3 kV.

Obsługiwana jest również notacja naukowa E, więc przykładowe zapytanie filtrujące kondensatory o pojemności powyżej 1 nF wyglądałoby następująco:
StrToNumber(ParameterValue('CapacitanceValue'), F) > 1e-9
Alternatywnie funkcję konwersji na liczbę można zastosować zarówno do zwracanej wartości ParameterValue, and jak i do wartości porównawczej:
StrToNumber(ParameterValue('CapacitanceValue'), F) > StrToNumber('1nF', F)

Reguły i skrypty

Zapytania dotyczące parametrów PCB można również stosować w skryptach i regułach projektowych Altium Designer. Te ostatnie mogą przeprowadzać kontrole poprawności układu płytki, na przykład wykrywać parametry footprintów w celu oceny rozmieszczenia komponentów lub przypisania warstw. Należy pamiętać, że funkcje wymienione w powyższym oknie dialogowym Query Helper są dostępne w języku skryptowym.

Poniższy przykład przedstawia zapytanie dotyczące napięcia znamionowego kondensatora (patrz powyższe zapytanie filtrujące) zastosowane w regule rozmieszczania komponentów. Po uruchomieniu reguła sprawdza określone wartości odstępów dla komponentów wykrytych jako elementy wysokonapięciowe (>50V).

Reguły projektowe zdefiniowane na podstawie określonych parametrów footprintów, przeniesionych ze schematu, mogą służyć do wykrywania niestandardowych warunków w układzie płytki.

Podobnie niestandardowe parametry PCB mogą służyć do sprawdzania zgodności komponentów z warstwami, na przykład gdy komponent nie nadaje się do lutowania na fali, a zatem nie może być umieszczony na warstwie dolnej. W takim przypadku zapytanie dopasowujące obiekty, które przetwarza niestandardowy parametr „WaveSoldering” (Yes/No), można zastosować w regule dozwolonych warstw.

Reguła uruchamiana w trybie wsadowym sprawdzi następnie wartość tego parametru komponentu i zgłosi naruszenie, jeśli komponent nie może być umieszczony na warstwie dolnej.

Warianty

Parametry przeniesione do PCB, które są uwzględnione w wariantach projektu (Warianty projektu), są przetwarzane zgodnie z wyborem wariantu.

W praktyce parametr komponentu zmieniający się w zależności od wariantu będzie w edytorze PCB dynamicznie wykrywany przez ciąg zapytania lub na przykład wyświetlany na warstwie płytki za pomocą ciągu specjalnego. 

Parametry footprintów definiowane przez użytkownika

Ta funkcja jest dostępna po włączeniu opcji PCB.FootprintParameters w oknie dialogowym ustawień zaawansowanych.

Altium Designer obsługuje parametry footprintów definiowane przez użytkownika. Sekcja Parameters na karcie Footprint panelu Properties  w trybie Library Options  umożliwia przeglądanie i edycję parametrów footprintu, gdy w obszarze projektowym edytora footprintów PCB nie jest zaznaczony żaden obiekt.

Po umieszczeniu komponentu na PCB parametry te można zobaczyć w panelu Properties  w trybie Component  na karcie Parameters .

  • Parametry footprintów komponentów umieszczonych na PCB zostaną przeniesione do footprintów w bibliotekach wygenerowanych za pomocą polecenia Make PCB Library lub Make Integrated Library z menu głównego edytora PCB.
  • Parametry footprintów są obsługiwane przez mechanizm porównywania Altium Designer oraz uwzględniane w generowanych plikach wyjściowych Pick and Place i ODB++.
Altium MCAD CoDesigner obsługuje umieszczanie natywnych komponentów MCAD w środowisku MCAD zgodnie ze skonfigurowanymi powiązaniami. W niektórych przypadkach z jednym komponentem powiązanych jest kilka footprintów z różnymi modelami (np. dioda LED, którą można zamontować na PCB na dwa sposoby: pionowo, z prostymi wyprowadzeniami, lub poziomo, z wygiętymi wyprowadzeniami). Za pomocą parametrów footprintów można teraz odwoływać się do różnych modeli MCAD przypisanych do tych footprintów. Dowiedz się więcej o łączeniu natywnych komponentów projektowych ECAD i MCAD.

Ciągi oznaczenia i komentarza

Domyślne ciągi oznaczenia i komentarza

Po umieszczeniu footprintu na płytce przypisywane są mu oznaczenie i komentarz na podstawie informacji pobranych ze schematu projektu. Nie trzeba ręcznie definiować symboli zastępczych dla ciągów oznaczenia i komentarza, ponieważ są one dodawane automatycznie podczas umieszczania footprintu na płytce. Położenie tych ciągów jest określane przez opcję Autoposition dla ciągu oznaczenia i komentarza w panelu Properties w trybie Parameter , gdy ciąg oznaczenia lub komentarza jest zaznaczony w obszarze projektowym. Domyślne położenie i rozmiar ciągów oznaczenia i komentarza konfiguruje się dla odpowiedniego obiektu podstawowego na stronie Edytor PCB — Ustawienia domyślne okna dialogowego Preferences .

Dodatkowe ciągi oznaczenia i komentarza

W niektórych sytuacjach mogą być potrzebne dodatkowe kopie ciągów oznaczenia lub komentarza. Na przykład zakład montażowy może wymagać szczegółowego rysunku montażowego z oznaczeniem wewnątrz obrysu każdego komponentu, podczas gdy Twoja firma wymaga, aby na gotowej płytce PCB oznaczenie znajdowało się tuż nad komponentem na warstwie opisowej. Ten wymóg dodatkowego oznaczenia można spełnić, umieszczając w footprincie ciąg specjalny .Designator. Dostępny jest również ciąg specjalny .Comment, który pozwala określić położenie ciągu komentarza na innych warstwach lub w innych miejscach.

Aby spełnić wymagania zakładu montażowego, ciąg .Designator należy umieścić na warstwie mechanicznej w edytorze footprintów PCB, a następnie wygenerować wydruki uwzględniające tę warstwę jako część instrukcji montażu projektu.

Obsługa specjalnych wymagań dotyczących poszczególnych warstw

Komponent PCB może mieć szereg specjalnych wymagań, takich jak punkt kleju lub zdefiniowana zdzieralna maska lutownicza. Wiele z tych wymagań jest powiązanych ze stroną płytki, na której zamontowano komponent, i musi zostać przeniesionych na drugą stronę płytki po odwróceniu komponentu.

Zamiast udostępniać dużą liczbę warstw specjalnego przeznaczenia, które mogą być rzadko używane, edytor PCB w Altium Designer obsługuje takie wymagania za pomocą funkcji par warstw. Para warstw to dwie warstwy mechaniczne zdefiniowane jako para. Za każdym razem, gdy komponent jest przenoszony z jednej strony płytki na drugą, wszystkie obiekty na sparowanej warstwie mechanicznej są przenoszone na drugą warstwę mechaniczną z tej pary. Przy takim podejściu należy wybrać odpowiednią warstwę mechaniczną dla punktu kleju (lub innych specjalnych wymagań) i zdefiniować jego kształt za pomocą dostępnych obiektów. Po umieszczeniu takiego footprintu na płytce należy skonfigurować parowanie warstw. Dzięki temu oprogramowanie wie, na którą warstwę przenieść obiekty po odwróceniu komponentu na drugą stronę płytki. Par warstw nie można definiować w edytorze footprintów PCB; robi się to w edytorze PCB.

Parowanie warstw należy zdefiniować before odwróceniem komponentu. Jeśli parowanie zostanie zdefiniowane po przeniesieniu komponentu na dolną stronę płytki, obiekty na warstwie mechanicznej zostaną odwrócone, ale pozostaną na swojej pierwotnej warstwie. Jeśli zapomnisz utworzyć pary warstw przed odwróceniem, możesz przeprowadzić aktualizację z biblioteki, aby odświeżyć instancję komponentu umieszczoną na płytce.

Nazwy warstw mechanicznych można edytować bezpośrednio w panelu View Configurations, klikając prawym przyciskiem myszy, a następnie wybierając Edit Layer.

Typowym podejściem do zarządzania wykorzystaniem warstw mechanicznych jest przypisanie osobnego numeru warstwy do każdej wymaganej funkcji warstwy mechanicznej. Wymaga to od wszystkich projektantów stosowania tego samego schematu przypisania i numeracji warstw. Może też powodować trudności w przypadku komponentów pozyskanych z innych źródeł, w których nie stosuje się tego samego schematu przypisania i numeracji. Jeśli zastosowano inny schemat, obiekty projektowe trzeba przenieść z ich bieżącej warstwy mechanicznej na warstwę mechaniczną przypisaną do danej funkcji.

Problem ten rozwiązuje wprowadzenie właściwości Layer Type. Gdy komponent jest umieszczany z biblioteki w edytorze PCB, kopiowany z jednej biblioteki do drugiej lub tworzony za pomocą IPC Footprint Wizard, istniejące przypisania typów warstw są automatycznie dopasowywane, niezależnie od numerów warstw mechanicznych przypisanych do tych typów. Obiekty są przenoszone na odpowiednie warstwy zgodnie z ich typem warstwy. Jeśli oprogramowanie nie może dopasować warstw według typu, dopasuje je według numeru.

Zarówno dla pojedynczych warstw mechanicznych, jak i par warstw komponentu można wybrać typ warstwy z predefiniowanej listy. Aby otworzyć pokazane poniżej okna dialogowe, kliknij prawym przyciskiem myszy pojedynczą warstwę, a następnie wybierz z menu polecenie Edit Layer lub Add Component Layer.

Szczegółowe informacje o typach warstw mechanicznych związanych z komponentami znajdziesz na stronie Praca z warstwami mechanicznymi.

Dodawanie wysokości do footprintu PCB

Na najbardziej podstawowym poziomie reprezentacji 3D do footprintu PCB można dodać informację o wysokości. W tym celu otwórz panel Properties w trybie Library Options (aktywnym, gdy w obszarze projektowym nie jest zaznaczony żaden obiekt) i wprowadź zalecaną wysokość komponentu w polu Height na karcie Footprint tego panelu.

Reguły projektowe dotyczące wysokości można definiować podczas projektowania płytki (kliknij Design » Rules w edytorze PCB). Zazwyczaj służą one do sprawdzania maksymalnej wysokości komponentów należących do danej klasy lub znajdujących się w zdefiniowanym obszarze typu Room.

Lepszym sposobem definiowania informacji o wysokości jest dołączenie brył 3D do footprintu PCB.

Zarządzanie komponentami zawierającymi obiekty trasowania

Podczas przenoszenia projektu footprint określony dla każdego komponentu jest pobierany z dostępnych bibliotek i umieszczany na płytce. Następnie właściwość sieci każdego pola lutowniczego w footprincie jest ustawiana na nazwę sieci połączonej z danym wyprowadzeniem komponentu na schemacie. Wszystkie obiekty stykające się z polem lutowniczym łączą się z tą samą siecią co to pole.

Edytor PCB zawiera rozbudowane narzędzie do zarządzania sieciami. Aby je uruchomić, wybierz Design » Netlist » Configure Physical Nets z menu głównego, aby otworzyć okno dialogowe konfiguracji sieci fizycznych. Kliknij przycisk Menu, aby wyświetlić menu opcji. Kliknij listę rozwijaną w nagłówku New Net Name, aby wybrać sieć, która zostanie przypisana do nieprzypisanych obiektów podstawowych.

Footprinty z wieloma polami lutowniczymi połączonymi z tym samym wyprowadzeniem

Pokazany poniżej footprint tranzystora SOT223 ma wiele pól lutowniczych połączonych z tym samym logicznym wyprowadzeniem komponentu na schemacie — wyprowadzeniem 2. Aby utworzyć to połączenie, dodano dwa pola lutownicze o tym samym oznaczeniu — „2”. Gdy w edytorze schematów zostanie użyte polecenie Design » Update PCB w celu przeniesienia informacji projektowych na PCB, po synchronizacji w edytorze PCB widoczne będą linie połączeń prowadzące do obu pól lutowniczych, co oznacza, że należą one do tej samej sieci. Do obu tych pól można poprowadzić ścieżki.

Footprint SOT223 z dwoma polami lutowniczymi o oznaczeniu 2.
Footprint SOT223 z dwoma polami lutowniczymi o oznaczeniu 2.

Przygotowanie warstwy opisowej

Aby pomóc w rozwiązywaniu typowych problemów związanych z projektowaniem pod kątem produkcji (DFM), wynikających z nakładania się nadruku warstwy opisowej na odsłoniętą miedź i otwory, edytor footprintów PCB udostępnia specjalną funkcję przygotowania warstwy opisowej footprintów. Problemy te można skutecznie rozwiązać poprzez:

  • automatyczne przycinanie linii i łuków warstwy opisowej;
  • automatyczne przycinanie lub przesuwanie wypełnień i regionów;
  • automatyczne przesuwanie tekstów warstwy opisowej.
Narzędzie do przygotowania warstwy opisowej jest dostępne również podczas projektowania PCB — dowiedz się więcej.

Aby uzyskać dostęp do narzędzia przygotowania warstwy opisowej w edytorze footprintów PCB, użyj polecenia Tools » Silkscreen Preparation z menu głównego. Otworzy się okno dialogowe Silkscreen Preparation.

W tym oknie dialogowym można skonfigurować ustawienia przycinania i przesuwania obiektów warstwy opisowej. Dostępne są następujące opcje:

  • Clip to Exposed Copper — włącz, aby automatycznie przycinać obiekty względem odsłoniętej miedzi.
  • Clip to Solder Mask Openings — włącz, aby automatycznie przycinać obiekty względem otwarć w masce lutowniczej.
  • Silkscreen Clearance — określ minimalny dopuszczalny odstęp między obiektami warstwy opisowej a odsłoniętą miedzią, otwarciami w masce lutowniczej i otworami.
  • Min Remaining Length — jeśli po przycięciu długość linii lub łuku jest mniejsza od zdefiniowanej wartości, obiekty te zostaną usunięte z footprintu. Pamiętaj, że jest to długość mierzona między wierzchołkami, a nie między krawędziami — pokaż ilustrację.
  • Move Text — włącz, aby odsuwać teksty warstwy opisowej od odsłoniętej miedzi, otwarć w masce lutowniczej i otworów, jeśli odległość między nimi jest mniejsza niż Silkscreen Clearance. Przesunięcie jest ograniczone wartością Max Distance.
  • Fill & Region — wybierz działanie wykonywane dla wypełnień i regionów, gdy odległość między nimi a odsłoniętą miedzią, otwarciami w masce lutowniczej i otworami jest mniejsza niż Silkscreen Clearance:
    • None – wypełnienia i regiony pozostają bez zmian.
    • Clip – wypełnienia i regiony zostaną przycięte, aby zachować Silkscreen Clearance. W razie potrzeby wypełnienia są przekształcane w regiony.
    • Move – wypełnienia i regiony zostaną odsunięte od odsłoniętej miedzi / otworów w masce lutowniczej oraz otworów w płytce. Przesunięcie jest ograniczone wartością Max Distance.
  • Max Distance – określ maksymalną odległość, o jaką można przesunąć ciągi tekstowe, oznaczenia komponentów, wypełnienia i regiony, aby zachować Silkscreen Clearance.

Kliknij OK, aby przyciąć i/lub przesunąć obiekty warstwy opisowej zgodnie z ustawieniami w oknie dialogowym.

Jeśli nie można wykonać działania na obiekcie (np. nie można przesunąć ciągu tekstowego z powodu ograniczenia Max Distance), w panelu Messages pojawi się komunikat dotyczący tego obiektu.

Poniżej przedstawiono przykład działania narzędzia do przygotowywania warstwy opisowej.

Javascript

Tworzenie obudowy PCB za pomocą kreatora obudów zgodnych z IPC

IPC Compliant Footprint Wizard generuje obudowę PCB w pełni zgodną z rewizją B normy IPC 7351 – Generic Requirements for Surface Mount Design and Land Pattern Standard. Zamiast korzystać bezpośrednio z wymiarów obudowy PCB (jak robi to kreator obudów PCB), IPC Compliant Footprint Wizard wykorzystuje informacje o wymiarach samego komponentu, a następnie oblicza odpowiednie właściwości padów i pozostałych elementów obudowy PCB zgodnie z algorytmami opublikowanymi przez IPC.

Zamiast wymagać wprowadzenia właściwości padów i ścieżek definiujących obudowę PCB, Wizard przyjmuje jako dane wejściowe rzeczywiste wymiary komponentu. Następnie, na podstawie wzorów opracowanych dla normy IPC-7351, Wizard generuje obudowę PCB przy użyciu standardowych obiektów Altium Designer, takich jak pady i ścieżki.

  • To okno dialogowe jest zgodne z rewizją B normy IPC 7351 – Ogólne wymagania dotyczące projektowania montażu powierzchniowego i standard układów pól lutowniczych. Norma IPC-7351B została opublikowana w 2010 roku i zastępuje normę IPC-7351A (opublikowaną w 2007 roku).

  • Aby uzyskać dostęp do IPC Compliant Footprint Wizard w Altium Designer, należy zainstalować rozszerzenie IPC Footprint Generator. To rozszerzenie jest domyślnie instalowane wraz z Altium Designer. Można je instalować lub usuwać ręcznie.

    Więcej informacji o zarządzaniu rozszerzeniami można znaleźć na stronie Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Aby uruchomić IPC Compliant Footprint Wizard, wybierz Tools » IPC Compliant Footprint Wizard z menu głównego w dokumencie biblioteki PCB.

Na stronie Select Component Type wybierz rodzinę komponentów, dla której chcesz utworzyć obudowę PCB na stronie Select Component Type. Obszar podglądu po prawej stronie kreatora zmienia się dynamicznie, pokazując aktualnie wybrany komponent, a także typy obudów, które można wygenerować. Poniższa tabela zawiera typy komponentów i obudów obsługiwane przez kreator.

Nazwa Opis Obsługiwane obudowy
BGA Obudowa z siatką wyprowadzeń kulkowych BGA, CGA
BQFP Płaska obudowa z wyprowadzeniami z czterech stron i narożnymi osłonami ochronnymi BQFP
CAPAE Aluminiowy kondensator elektrolityczny CAPAE
CFP Płaska obudowa ceramiczna z wyprowadzeniami z dwóch stron — przycięte i uformowane wyprowadzenia typu gull-wing CFP
Matryca elementów chipowych Matryca elementów chipowych Matryca elementów chipowych
DFN Płaska obudowa bezwyprowadzeniowa z polami z dwóch stron DFN
CHIP Komponenty chipowe, 2 wyprowadzenia Kondensator, cewka indukcyjna, rezystor
CQFP Płaska obudowa ceramiczna z wyprowadzeniami z czterech stron — przycięte i uformowane wyprowadzenia typu gull-wing CQFP
DPAK Obudowa tranzystorowa DPAK
LCC Bezwyprowadzeniowa obudowa układu scalonego LCC
LGA Obudowa z siatką pól kontaktowych LGA
MELF Komponenty MELF, 2 wyprowadzenia Dioda, rezystor
MOLDED Komponenty w obudowie formowanej, 2 wyprowadzenia Kondensator, cewka indukcyjna, dioda
PLCC Kwadratowa obudowa układu scalonego z tworzywa sztucznego — wyprowadzenia typu J PLCC
PQFN Płaska obudowa bezwyprowadzeniowa z polami z czterech stron, cofniętymi względem krawędzi PQFN
PQFP Płaska obudowa z tworzywa sztucznego z wyprowadzeniami z czterech stron PQFP, PQFP z odsłoniętym padem
PSON Małogabarytowa obudowa bezwyprowadzeniowa z polami cofniętymi względem krawędzi PSON
QFN Płaska obudowa bezwyprowadzeniowa z polami z czterech stron QFN, LLP
QFN-2ROW Kwadratowa płaska obudowa bezwyprowadzeniowa z polami z czterech stron w dwóch rzędach Dwurzędowa QFN
SODFL Małogabarytowa obudowa diody z płaskimi wyprowadzeniami SODFL
SOIC Małogabarytowa obudowa układu scalonego, raster 1,27 mm — wyprowadzenia typu gull-wing SOIC, SOIC z odsłoniętym padem
SOJ Obudowa małogabarytowa — wyprowadzenia typu J SOJ
SON Małogabarytowa obudowa bezwyprowadzeniowa SON, SON z odsłoniętym padem
SOP, TSOP Obudowa małogabarytowa — wyprowadzenia typu gull-wing SOP, TSOP, TSSOP
SOT143/343 Małogabarytowa obudowa tranzystora SOT143, SOT343
SOT223 Małogabarytowa obudowa tranzystora SOT223
SOT23 Małogabarytowa obudowa tranzystora 3 wyprowadzenia, 5 wyprowadzeń, 6 wyprowadzeń
SOT89 Małogabarytowa obudowa tranzystora SOT89
SOTFL Małogabarytowa obudowa tranzystora z płaskimi wyprowadzeniami 3 wyprowadzenia, 5 wyprowadzeń, 6 wyprowadzeń
DRUTOWE Precyzyjna cewka drutowa, 2 wyprowadzenia Cewka indukcyjna

Kolejne strony kreatora zmieniają się w zależności od wybranego typu komponentu. Przejdź przez intuicyjne strony kreatora, aby skonfigurować obudowę PCB danego komponentu zgodnie z wymaganiami. Kilka uwag dotyczących pracy z IPC Compliant Footprint Wizard:

  • Wszystkie wymiary w kreatorze wprowadza się w jednostkach metrycznych (mm).

  • Można wprowadzać gabaryty obudowy, informacje o wyprowadzeniach, odstępy między nasadami wyprowadzeń, parametry spoin lutowniczych i tolerancje oraz natychmiast przeglądać wyniki.

    Modyfikacja tolerancji IPC może spowodować utworzenie obudów PCB niezgodnych z IPC.

  • Można wprowadzać wymiary mechaniczne, takie jak obrys strefy zajętości, obrys montażowy oraz informacje o bryle komponentu (3D).

  • Do Wizard można wracać, co ułatwia przeglądanie i wprowadzanie zmian.

  • Podgląd obudowy PCB jest wyświetlany na każdym etapie. Dla każdego typu komponentu obszar Preview aktualizuje się dynamicznie, pokazując nowe położenie, rozmiar itp. dla poszczególnych ustawień. W obszarze Preview można kliknąć  lub , aby przełączać podgląd między widokiem 2D a 3D.

  • W razie potrzeby można wyświetlić podgląd modelu 3D STEP przed jego wygenerowaniem. Kliknij Generate STEP Model Preview na dowolnej stronie w Wizard po wybraniu typu komponentu, aby zobaczyć podgląd modelu 3D STEP w obszarze Preview.

  • Maski pasty lutowniczej są dzielone na małe wypełnienia w przypadku obudów z dużym padem termicznym (o wymiarach 2,1 mm × 1,6 mm lub większych).

  • W przypadku obudów z wyprowadzeniami typu gull-wing pady są przycinane, aby nie wystawały pod korpus obudowy.

  • W przypadku małych obudów z dużym centralnym padem termicznym pady obwodowe są przycinane, aby zapewnić wymagany odstęp między padami zgodnie z normą IPC.

  • Gdy stosowane jest przycinanie padów, w oknie dialogowym wyświetlane jest ostrzeżenie.

  • Nazwa i opis footprintu są sugerowane automatycznie na podstawie informacji wprowadzonych w Wizard , ale można je zmienić, aby dostosować je do wymagań organizacji.

  • Zgodnie z normą IPC kreator obsługuje trzy warianty footprintów (_L, _N, _M), z których każdy jest dostosowany do innej gęstości upakowania elementów na płytce.

  • Przycisk Finish można nacisnąć na dowolnym etapie, aby wygenerować aktualnie wyświetlany footprint. Jeśli klikniesz Finish przed ukończeniem całego Wizard, footprint zostanie utworzony z użyciem domyślnych ustawień systemowych dla wybranego typu komponentu.

  • Podczas pracy z biblioteką footprintów PCB opartą na plikach użyj generatora wsadowego footprintów zgodnych z IPC, aby szybko wygenerować wiele footprintów o różnych poziomach gęstości upakowania.

Gdy kreator jest uruchamiany z biblioteki footprintów PCB opartej na plikach, dostępna jest strona Footprint Destination, na której można wybrać miejsce zapisania nowo utworzonego footprintu – pokaż obraz:

  • Wybierz Existing PcbLib File, jeśli chcesz zapisać footprint w istniejącym pliku biblioteki PCB. Możesz wpisać ścieżkę do pliku bezpośrednio w polu tekstowym lub użyć , aby otworzyć okno dialogowe i wyszukać odpowiedni plik.
  • Wybierz New PcbLib File, jeśli chcesz zapisać footprint w nowym pliku biblioteki PCB. Wprowadź nazwę nowego pliku biblioteki PCB w polu tekstowym. System doda do nazwy nowego pliku biblioteki rozszerzenie .PcbLib.
  • Wybierz Current PcbLib File, aby zapisać footprint we wskazanym pliku biblioteki PCB.
  • Włącz Produce 3D/STEP model, aby wygenerować model 3D STEP.
  • Jeśli masz ważną licencję „MCAD Co-Designer - SOLIDWORKS(R)”, możesz zapisać model jako plik typu Parasolid. Kliknij listę rozwijaną po prawej stronie Format, a następnie wybierz Parasolid. Plik wskazany w polu tekstowym External File jest teraz plikiem *.x_t. Jest to nazwa i lokalizacja pliku, który zostanie zapisany.
  • Wybierz Embedded (domyślnie) lub External File. Wybierz External File, aby zapisać model 3D STEP jako plik zewnętrzny. Domyślnym typem pliku jest STEP, a nazwa pliku jest wyświetlana w polu tekstowym External File z rozszerzeniem *.step. W razie potrzeby kliknij , aby wyszukać i wybrać folder, w którym ma zostać zapisany wygenerowany model 3D STEP.

Tworzenie footprintu za pomocą kreatora footprintów

Edytor footprintów PCB zawiera Footprint Wizard. Ten Wizard umożliwia wybór spośród różnych typów obudów i wprowadzenie odpowiednich informacji, a następnie tworzy footprint komponentu. Pamiętaj, że w Footprint Wizard podajesz wymagane wymiary padów i obrysu komponentu na warstwie opisowej.

Aby uruchomić Footprint Wizard, wybierz Tools » Footprint Wizard z menu głównego lub kliknij prawym przyciskiem myszy w obszarze projektowym i wybierz polecenie Tools » Footprint Wizard z menu kontekstowego.

Na stronie Component patterns określ układ komponentu, który chcesz utworzyć. Wybierz odpowiedni układ z listy, a następnie z listy rozwijanej wybierz jednostkę dla komponentu (Imperial (mil) lub Metric (mm)). Dostępne układy to:

  • Ball Grid Arrays (BGA)
  • Capacitors
  • Diodes
  • Dual In-line Packages (DIP)
  • Edge Connectors
  • Leadless Chip Carriers (LCC)
  • Pin Grid Arrays (PGA)
  • Quad Packs (QUAD)
  • Resistors
  • Small Outline Packages (SOP)
  • Staggered Ball Grid Arrays (SBGA)
  • Staggered Pin Grid Arrays (SPGA)

Kolejne strony kreatora zmieniają się w zależności od wybranego układu komponentu. Przejdź przez intuicyjne strony kreatora, aby skonfigurować footprint danego komponentu zgodnie z wymaganiami.

Podczas konfigurowania stylu nazewnictwa padów dla footprintu o układzie Edge Connectors, Leadless Chip Carriers (LCC) lub Quad Packs (QUAD) kliknij zieloną strzałkę, aby zmienić kolejność lub kierunek nadawania nazw – pokaż obraz.

Generowanie raportu komponentu

Aby wygenerować raport dla aktywnego footprintu PCB, wybierz polecenie Reports » Component z menu głównego. Po uruchomieniu polecenia raport zostanie wygenerowany (<PCBLibraryDocumentName>.CMP) w tym samym folderze co źródłowy dokument biblioteki PCB i automatycznie otwarty jako aktywny dokument w głównym oknie projektowym. Raport zawiera między innymi wymiary footprintu oraz zestawienie obiektów podstawowych, które go tworzą, wraz z warstwami, na których się znajdują.

Raport zostanie dodany do panelu Projects jako dokument niezależny w podfolderze Documentation\Text Documents.

AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Contents