Creating the Layout Drawing

Po uchwyceniu projektu wiązki w postaci schematu połączeń można utworzyć fizyczną reprezentację projektu jako rysunek układu wiązki (*.LdrDoc). Dodaj ten dokument do projektu wiązki z panelu Projects, klikając prawym przyciskiem myszy wpis projektu, a następnie wybierając Add New to Project » Harness Wiring Diagram z menu kontekstowego (lub używając polecenia File » New » Harness Layout Drawing z menu głównego).

Konfigurowanie dokumentu rysunku układu wiązki

Opcje dokumentu rysunku układu można skonfigurować w panelu Properties gdy w obszarze projektowym dokumentu nie jest zaznaczony żaden obiekt. Główne ustawienia to:

  • W obszarze General na karcie General panelu – wybierz jednostki miary obowiązujące dla dokumentu i jego elementów graficznych oraz ustaw siatki, aby ułatwić rozmieszczanie. Altium Designer oferuje trzy typy siatki: siatkę widoczną do nawigacji, siatkę przyciągania do rozmieszczania oraz odległość przyciągania wspomagającą tworzenie połączeń.

  • W obszarze Page Options na karcie General panelu – skonfiguruj rozmiar arkusza dokumentu i tabliczkę tytułową lub wybierz spośród dostępnych szablonów rysunku układu wiązki.

Karty General i Parameters panelu Properties, gdy w dokumencie rysunku układu wiązki nie jest zaznaczony żaden obiekt 
Karty General i Parameters panelu Properties, gdy w dokumencie rysunku układu wiązki nie jest zaznaczony żaden obiekt

  • Konfigurowanie dokumentu rysunku układu wiązki jest podobne do konfigurowania dokumentu schematu (*.SchDoc) projektu PCB. Więcej informacji można znaleźć na stronie Setting Up a Schematic Document.

  • Użyj listy rozwijanej Length Units, aby wybrać jednostki długości dla dokumentu. Wartości Bundle Length oraz obiektów bundle Length Value i Offset Length będą wyświetlane z użyciem wybranych jednostek. Obsługiwane jednostki to mm, cm, m, in i ft. Domyślne jednostki długości dla nowo tworzonych dokumentów rysunku układu można zdefiniować na stronie Harness Design – General page w oknie dialogowym Preferences.

  • Aby dowiedzieć się więcej o tworzeniu szablonów dokumentów rysunku układu, zobacz stronę Creating Harness Template Documents.

  • Domyślne właściwości obiektów rysunku układu wiązki można skonfigurować na stronie Harness Design – Defaults page w oknie dialogowym Preferences. Właściwości te będą stosowane podczas umieszczania kolejnych obiektów.

  • Podczas tworzenia dokumentu rysunku układu wiązki można także używać obiektów tekstowych i rysunkowych. Praca z tymi obiektami w dokumencie rysunku układu wiązki jest podobna do pracy z nimi w dokumencie schematu (*.SchDoc) projektu PCB. Więcej informacji o tych obiektach można znaleźć w Working with Text Objects on a Schematic oraz Working with Drawing Objects on a Schematic.

    • Zwróć uwagę, że aktywne łącza do obiektów schematu połączeń wiązki (np. przewodów i komponentów) oraz obiektów rysunku układu wiązki (np. bundle i punktów połączeń) są również obsługiwane w ramkach tekstowych i notatkach. Kliknij łącze w umieszczonej ramce tekstowej lub notatce, aby wykonać cross-probing do tego obiektu w powiązanym dokumencie.

  • Aby sprawdzić rysunek układu wiązki pod kątem naruszeń logicznych, elektrycznych i kreślarskich, obsługiwanych jest wiele kontroli naruszeń. Więcej informacji można znaleźć na stronie Validating the Harness Design .

  • Dokument rysunku układu wiązki można zapisać w formacie ASCII, co może być korzystne przy udostępnianiu. Użyj polecenia File » Save As i wybierz Harness Layout ascii (*.LdrDoc) z listy rozwijanej Save as type w oknie dialogowym Save As, które się otworzy. Podczas zapisywania rysunku układu ASCII za pomocą polecenia File » Save otworzy się okno dialogowe File Format, informujące o użyciu formatu ASCII. Wybierz wersję ASCII w oknie dialogowym , aby nadal używać tego formatu.

Importowanie danych ze schematu połączeń

Wybierz z menu głównego polecenie Design » Import Wiring Diagram, aby zaimportować dane projektowe ze schematu połączeń. Komponent zostanie umieszczony na arkuszu rysunku układu w pozycjach względnych zdefiniowanych w schemacie połączeń. Punkty połączeń skojarzone z komponentami również zostaną umieszczone obok każdego komponentu na rysunku układu.

Dokument rysunku układu wiązki z danymi zaimportowanymi ze schematu połączeń
Dokument rysunku układu wiązki z danymi zaimportowanymi ze schematu połączeń

  • Po użyciu tego polecenia zastosowane zmiany są wyświetlane w panelu Messages ().

  • Wszelkie zmiany w schemacie połączeń można zaimportować do rysunku za pomocą tego samego polecenia Design » Import Wiring Diagram.

Praca z komponentami

Początkowo każdy komponent jest reprezentowany na rysunku układu przez swój symbol. Właściwości umieszczonego komponentu można skonfigurować w panelu Properties, gdy komponent jest zaznaczony w obszarze projektowym. Panel Properties dla komponentu zawiera następujące karty:

 
 
 
 
 
  • General – ogólne właściwości komponentu, takie jak oznaczenie, komentarz, położenie, reprezentacja modelu, parametry itp.

  • Pins – lista wyprowadzeń komponentu.

  • Cavities – widok tylko do odczytu gniazd przypisanych do komponentu. Przypisania gniazd można modyfikować wyłącznie w schemacie połączeń – dowiedz się więcej.

  • Associated Parts – umożliwia przypisanie do komponentu dodatkowych części, takich jak koszulka termokurczliwa.

Podczas wklejania wyciętych/skopiowanych komponentów wiązki na rysunku układu wiązki oznaczenia wklejonych komponentów są zgodne z opcją Reset Parts Designators On Paste ze strony Schematic – Graphical Editing page okna dialogowego Preferences. Po wklejeniu komponentów część numeryczna ich oznaczeń zostanie zresetowana do ?, jeśli opcja jest włączona.

Konfigurowanie reprezentacji komponentu

Używając opcji Graphical SymbolPhysical Model w obszarze Model panelu Properties (na karcie General) po zaznaczeniu komponentu, można przełączać się między reprezentacją symboliczną (komponentu symbol) a rzutem modelu 3D (komponentu footprint). Użyj innych ustawień w obszarze panelu, aby skonfigurować reprezentację.

Javascript ID: Harness_LD_HarnessComponent_ModelType_AD25

Komponent reprezentowany przez swój symbol schematowy

Ten sam komponent reprezentowany przez rzut swojego modelu 3D

W przypadku użycia reprezentacji Physical Model użyj opcji Style , aby wyświetlić model albo jako Solid (bez linii), albo jako Wireframe. Użyj opcji z listy rozwijanej Side, aby wybrać żądaną stronę widoku modelu (dostępne są opcje ortogonalne i izometryczne). Poniższe obrazy przedstawiają niektóre ustawienia wraz z odpowiadającymi im wynikami w obszarze projektowym.

Javascript ID: Harness_LD_HarnessComponent_ModelType_Footprint_Config_AD25

Widok modelu fizycznego można obracać graficznie w obszarze projektowym, chwytając uchwyt obrotu znajdujący się w prawym dolnym rogu widoku modelu i używając myszy; pole Rotation będzie aktualizowane automatycznie (obrót co 1 stopień). Można także przytrzymać klawisz Alt, aby ograniczyć obrót do kroków co 45 stopni. Pomocniczo podczas obracania widoku myszą bieżący kąt jest wyświetlany w Status Bar.

Jeśli projekt zawierający modele obrócone z użyciem niestandardowych wartości zostanie otwarty w wersji Altium Designer wcześniejszej niż 26.9, zostanie wyświetlony komunikat ostrzegający o zgodności wstecznej. Można ponownie wygenerować modele fizyczne przy użyciu poprzedniej funkcjonalności, tj. wyboru z list rozwijanych. 

  • Dla obu stylów Solid i Wireframe wartość Zoom definiuje rozmiar zielonego obwiedniowego prostokąta widoku modelu w obszarze projektowym, a widok modelu zawsze mieści się w tym prostokącie.

  • Ułatwiając integrację podczas używania Altium MCAD CoDesigner with harness design projects, modele 3D używane w fizycznych widokach komponentów wiązki są osadzane w dokumencie rysunku układu (w formacie Parasolid). Wszelkie brakujące modele 3D (istniejące, ale nieosadzone) zostaną osadzone po zapisaniu dokumentu (File » Save). Ta funkcja jest w Open Beta i jest dostępna po włączeniu opcji HarnessDesign.Embed3DModel w oknie dialogowym Advanced Settings dialog.

Adding Multiple Physical Model Views

  • Użyj strzałki listy rozwijanej, aby wyświetlić i edytować właściwości widoku fizycznego ().

  • Za pomocą kontrolki Add Component View w panelu Properties można dodać wiele widoków modelu fizycznego dla komponentu ().  

  • Dodatkowe widoki fizyczne dodane dla komponentu można niezależnie przesuwać w obszarze projektowym metodą przeciągnij i upuść.

  • Niezależnie od tego, który widok modelu fizycznego komponentu jest zaznaczony w obszarze projektowym, panel Properties  wyświetla właściwości samego komponentu.

Definiowanie rozmieszczenia fizycznego na rysunku układu wiązki

Wszystkie połączenia fizyczne w obrębie wiązki są definiowane jako bundle wiązki (nawet jeśli bundle zawiera tylko jeden przewód). Każdy bundle musi zaczynać się i kończyć w punkcie połączenia. Podczas początkowego importu danych projektu wiązki (jak opisano powyżej) obok każdego komponentu automatycznie umieszczany jest punkt połączenia, a ten punkt połączenia jest skojarzony z komponentem i wszystkimi jego wyprowadzeniami. Jeśli wymaga tego fizyczna struktura projektu, można umieścić nowe punkty połączeń i skonfigurować przypisane do nich obiekty.

Aby ułatwić zrozumienie łączności komponentów w dokumencie rysunku układu wiązki, można wyświetlić w dokumencie graf połączeń. Gdy opcja Connective Graph jest włączona na stronie System – Navigation page okna dialogowego Preferences, użyj skrótu Alt+Click na komponencie, aby wyświetlić graf połączeń w obszarze projektowym (). Wyczyść graf za pomocą skrótu Shift+C lub polecenia Clear Filter z menu prawego przycisku myszy w obszarze projektowym.

Praca z punktami połączeń

Aby umieścić nowy punkt połączenia, użyj polecenia Place » Connection Point z menu głównego. Punkty połączeń są wyświetlane w obszarze projektowym, jak pokazano poniżej.

Właściwości umieszczonego punktu połączenia (jego położenie, reprezentacja wizualna itd.) można skonfigurować w panelu Properties, gdy punkt połączenia jest zaznaczony w obszarze projektowym.

Panel Properties, gdy zaznaczony jest punkt połączenia
Panel Properties, gdy zaznaczony jest punkt połączenia

Użyj obszaru Associated Parts panelu Properties dla zaznaczonego punktu połączenia, aby zarządzać listą części skojarzonych z punktem połączenia, tj. obiektów fizycznych, które chcesz powiązać z wyświetlaną reprezentacją graficzną. Model 3D części skojarzonej z punktem połączenia może służyć do reprezentowania punktu połączenia w dokumencie. Gdy punkt połączenia jest zaznaczony, wybierz Physical Model w obszarze Properties panelu Properties, a następnie użyj listy rozwijanej Associated Part w obszarze Type, aby wybrać wymaganą skojarzoną część (). Model zostanie wygenerowany i wyświetlony w dokumencie. Użyj opcji w obszarze Type, aby skonfigurować wyświetlanie modelu ().

Ułatwiając integrację podczas używania Altium MCAD CoDesigner with harness design projects, modele 3D używane w fizycznych widokach punktów połączeń są osadzane w dokumencie rysunku układu (w formacie Parasolid). Wszelkie brakujące modele 3D (istniejące, ale nieosadzone) zostaną osadzone po zapisaniu dokumentu (File » Save). Ta funkcja jest w Open Beta i jest dostępna po włączeniu opcji HarnessDesign.Embed3DModel w oknie dialogowym Advanced Settings dialog.

Przypisywanie obiektów do punktów połączeń

Obiekty przypisane do punktu połączenia można konfigurować zależnie od potrzeb i założeń projektowych. Jeden lub wiele obiektów (komponenty, splajsy/odgałęzienia, obiekty „brak połączenia” oraz ekrany z połączeniem) można przypisać do punktu połączenia za pomocą okna dialogowego Add Assigned Objects, otwieranego po kliknięciu przycisku   w obszarze Assigned Objects  panelu Properties .

  • Domyślnie w oknie dialogowym włączona jest opcja Show only unassigned objects i wyświetlane są tylko te obiekty, które nie są obecnie przypisane do innych punktów połączeń. Wyłącz tę opcję, aby wyświetlić listę wszystkich obiektów na rysunku układu.

  • Jeśli w oknie dialogowym zostanie wybrany obiekt już przypisany do innego punktu połączenia, zostaną pokazane odpowiednie ostrzeżenia i ikony ().

  • Aby uniknąć przypisania splajsu do więcej niż jednego punktu połączenia, splajs jest automatycznie usuwany z punktu połączenia, jeśli jest już przypisany do innego punktu połączenia.

Gdy komponent jest przypisany do punktu połączenia, w obszarze projektowym między komponentem a punktem połączenia wyświetlana jest linia kreska-kropka, jak pokazano poniżej. W Properties można wybrać, które wyprowadzenia komponentu są przypisane. Kliknij komórkę w kolumnie Pins siatki w obszarze Assigned Objects, aby uzyskać dostęp do listy rozwijanej służącej do wyboru wymaganych wyprowadzeń komponentu.

Podczas przeciągania jednego punktu połączenia na drugi (tam, gdzie jest to prawidłowe) na rysunku układu, oba są łączone w pojedynczy obiekt, a ich listy przypisanych obiektów są scalane.

Praca z bundle wiązki

Aby umieścić nowy bundle wiązki, użyj polecenia Place » Harness Bundle z menu głównego (skrót: Shift+B).

Po wybraniu polecenia kliknij punkt połączenia (na kursorze pojawi się czerwony krzyżyk, gdy znajdzie się nad hotspotem punktu połączenia), aby umieścić punkt początkowy bundle wiązki. Ustaw kursor i klikaj, aby zakotwiczyć serię punktów wierzchołkowych definiujących kształt bundle wiązki. Po umieszczeniu końcowego punktu wierzchołkowego na hotspotcie innego punktu połączenia kliknij prawym przyciskiem myszy, aby zakończyć umieszczanie.

Domyślnie bundle wiązki jest umieszczany w trybie Any Angle. Podczas umieszczania bundle wiązki naciśnij Shift+Spacebar, aby przełączać tryby umieszczania. Tryb określa sposób tworzenia narożników podczas umieszczania bundle oraz kąty, pod jakimi można je umieszczać.  W trybie 90 Degree lub 45 Degree (prawdziwe tryby ortogonalne) naciśnij Spacebar, aby przełączać między podtrybami początku i końca. Bieżący tryb i podtryb są pokazywane na pasku stanu.

Przykład bundle wiązki umieszczonego między punktami połączeń CP1 i CP_P2.
Przykład bundle wiązki umieszczonego między punktami połączeń CP1 i CP_P2.

Po umieszczeniu i zaznaczeniu wierzchołki bundle wiązki można przeciągać, aby zmienić kąt między dwoma sąsiednimi odcinkami.

  • Gdy bundle wiązki są podłączone do punktu połączenia, aktualnie nieprzypisane splajsy zostaną automatycznie przypisane do punktu połączenia zgodnie ze schematem połączeń.

  • Punkt połączenia można umieścić bezpośrednio na istniejącym bundle wiązki. Powoduje to podział pierwotnego bundle wiązki na dwa oddzielne bundle.

  • Gdy punkt połączenia, który dzieli bundle na rysunku układu na dwa, zostanie usunięty, oba bundle są automatycznie scalane w pojedynczy obiekt bundle.

Właściwości umieszczonego bundle wiązki (położenie, reprezentacja wizualna itd.) można skonfigurować w panelu Properties, gdy bundle wiązki jest zaznaczony w obszarze projektowym.

Panel Properties, gdy zaznaczony jest bundle wiązki
Panel Properties, gdy zaznaczony jest bundle wiązki

Każda wiązka przewodów automatycznie będzie zawierać obiekty (przewody i/lub kable) zgodnie z połączeniami zdefiniowanymi na schemacie okablowania. Obiekty te są wyświetlane w obszarze Bundle Objects panelu Properties, gdy wiązka jest zaznaczona. Kliknij obiekt na tej liście, aby podświetlić wszystkie wiązki, przez które przechodzi wybrany obiekt.

W przypadku złożonej, rozgałęzionej struktury fizycznej wiązki może być konieczna zmiana przypisania przewodu do innej wiązki. Użyj listy rozwijanej w obszarze Bundle Objects Assignment panelu Properties, gdy wymagana wiązka jest zaznaczona w obszarze roboczym, aby w razie potrzeby zaktualizować przypisanie przewodu do tej wiązki.

Korzystając z pola Length w obszarze Properties panelu, możesz zdefiniować długość wybranej wiązki. Długości przewodów i kabli przechodzących przez wiązki są obliczane na podstawie wartości Length tych wiązek. Obliczone wartości długości przewodu/kabla są wyświetlane w kolumnie Length Value siatki w obszarze Bundle Objects panelu.

Dodawanie widoku segmentu przewodu

Widok segmentu przewodu przedstawia przewody znajdujące się wewnątrz segmentu, tj. pojedyncze przewody, skręcone pary przewodów oraz przewody będące częścią kabli. Pozwala to dokładnie zobaczyć, jak przewody fizycznie są ułożone wewnątrz segmentu wiązki. Każdy przewód jest opisany i pokolorowany zgodnie ze zdefiniowanym kolorem przewodu, a także ma grubość zależną od wartości jego parametru Thickness (zdefiniowanego na schemacie okablowania (*.WirDoc)). Możesz umieścić widok segmentu umieszczonego segmentu wiązki na rysunku rozmieszczenia (*.LdrDoc) za pomocą polecenia Add Segment View w obszarze Model panelu Properties . Obszar Segment View wyświetli wtedy listę rozwijaną, w której można wybrać poziom Zoom dla dodawanego widoku. Obszar roboczy zostanie powiększony do widoku, jak pokazano w przykładowym pokazie slajdów poniżej. Aby usunąć widok segmentu, użyj polecenia Delete w obszarze Segment View. Kliknij, aby zaznaczyć widok, i przenieś go w żądane miejsce w obszarze roboczym.

Kliknij Add Segment View, aby dodać nowy widok.

Lista rozwijana Zoom umożliwia wybór poziomu powiększenia wymaganego dla widoku segmentu. 

Właściwości przewodu ze schematu okablowania są przenoszone do widoku segmentu, jak pokazano dla W9.

Aby usunąć widok segmentu, kliknij Delete.  

Dodawanie punktu przerwania

Punkt przerwania, używany jako oznaczenie, że wiązka jest Not to Scale (NTS), można umieścić na wiązce przewodów. Wiązka będzie wyświetlać symbol przerwania pośrodku swojego najdłuższego segmentu, jak pokazano na pierwszym obrazie poniżej, a właściwości będą wyświetlać Drawn Length. Aby umieścić przerwanie, włącz opcję Add Break Symbol w obszarze Properties właściwości wiązki. Osłony wiązki, które obejmują wiązkę z punktem przerwania, również będą wyświetlać przerwanie w tym samym miejscu. Jeśli osłona wiązki kończy się w punkcie przerwania wiązki, osłona zostanie narysowana jako nieco dłuższa, jak pokazano na drugim obrazie.

Umieszczony punkt przerwania na wiązce

Umieszczona osłona nad umieszczonym punktem przerwania

 
  • W razie potrzeby możesz zastąpić obliczoną długość przewodu/kabla. Wprowadź wymaganą wartość Offset Length lub wybierz Manual z listy rozwijanej w kolumnie Length Type, aby ręcznie zdefiniować wymaganą długość bezwzględną.

  • Dla przewodów, których długość została zdefiniowana w narzędziu MCAD, a następnie przeniesiona do Altium Designer za pomocą MCAD CoDesigner, wpis MCAD CoDesigner będzie widoczny w pozycji Length Type. W takim przypadku Offset Length nie może zostać zdefiniowane, ale można zastąpić wartość długości, wybierając Manual z listy rozwijanej (). Dowiedz się więcej o Synchronizing a Harness Design Project przy użyciu MCAD CoDesigner.

  • Jednostki, w których wartość Length wiązki oraz wartości Length Value i Offset Length jej obiektów są wyświetlane w panelu Properties, gdy wiązka jest zaznaczona, określa się za pomocą listy rozwijanej Length Units na karcie General panelu Properties, gdy w dokumencie nie jest zaznaczony żaden obiekt.

Ponowne przypisywanie obiektów wiązki

Możesz ponownie przypisać obiekty wiązki na rysunku rozmieszczenia, gdy przewód może przebiegać więcej niż jedną ścieżką między złączami źródłowym i docelowym. Domyślnie taki przewód zostanie automatycznie przypisany do najkrótszej ścieżki wiązki, ale możesz to nadpisać. Kontrolka Assign Objects to Bundle pojawia się na dole sekcji Bundle Objects panelu Properties (gdy wiązka jest zaznaczona w obszarze roboczym) i tylko wtedy, gdy istnieje alternatywna ścieżka prowadzenia. Otwiera się okno dialogowe Assign Objects to Bundle, w którym można wybrać obiekty (przewody/kable) do przeniesienia między odpowiednimi i prawidłowymi wiązkami.

Osłanianie wiązek przewodów

Obiekt osłony wiązki (Place » Harness Covering) można umieścić na wiązce przewodów. Długość osłony można modyfikować graficznie w obszarze roboczym podczas umieszczania lub po nim.

Po wybraniu polecenia umieszczenia osłony wiązki w obszarze roboczym pojawi się pomarańczowa kropka, gdy kursor znajdzie się nad wiązką przewodów, co oznacza, że osłona wiązki może zostać umieszczona (szara kropka oznacza, że osłona wiązki nie może zostać umieszczona w tym konkretnym miejscu). Kliknij w miejscu, w którym ma się zaczynać osłona, następnie przesuń kursor wzdłuż wiązki do punktu, w którym osłona ma się kończyć, i kliknij ponownie. Osłony wiązek mogą na siebie nachodzić, jak pokazano na poniższym filmie. Możesz także zastosować/przedłużyć osłonę wiązki przez punkt połączeniowy (punkt połączenia na rysunku rozmieszczenia, w którym zbiegają się dwie lub więcej wiązek). Eliminuje to potrzebę stosowania oddzielnych osłon wiązek między punktami połączeniowymi w sekcji zawierającej kilka złączy.

Początek osłony jest traktowany jako najbardziej wysunięty w lewo, najwyżej położony punkt jej ścieżki, a ścieżka obejmuje tylko te wiązki, na których leży osłona.

Właściwości umieszczonej osłony wiązki można konfigurować w panelu Properties, gdy osłona wiązki jest zaznaczona w obszarze roboczym.

Panel Properties, gdy zaznaczona jest osłona wiązki
Panel Properties, gdy zaznaczona jest osłona wiązki

Możesz zdefiniować rozmiar obiektu osłony wiązki względem rozmiaru wiązki, którą osłania (wartości Line Width tej wiązki), używając listy rozwijanej Size w panelu Properties. Przewiń poniższe obrazy, aby zobaczyć przykłady osłon wiązek o różnych rozmiarach dla różnych rozmiarów wiązek przewodów.

 
 
 
 
 
 

Po umieszczeniu osłony wiązki na rysunku rozmieszczenia możesz przypisać do niej komponent biblioteczny (lub, jeśli komponent jest już przypisany do osłony wiązki, możesz wybrać inny komponent). Aby to zrobić, zaznacz osłonę wiązki i kliknij przycisk  po prawej stronie pola Design Item ID w obszarze General panelu Properties. W otwartym oknie dialogowym Replace przejdź do wymaganego komponentu i wybierz go. Umieszczona osłona wiązki zostanie zaktualizowana o parametry wybranego komponentu.

Dodawanie etykiet układu

Fizyczne etykiety można umieszczać na rysunku rozmieszczenia (Place » Layout Label).

Właściwości umieszczonej etykiety układu (jej oznaczenie, tekst, reprezentacja wizualna itp.) można konfigurować w panelu Properties, gdy etykieta układu jest zaznaczona w obszarze roboczym.

Panel Properties, gdy etykieta układu jest zaznaczona
Panel Properties, gdy etykieta układu jest zaznaczona

Podczas definiowania tekstu etykiety w polu Text użyj Ctrl+Enter lub Shift+Enter, aby dodać nową linię tekstu. Włącz Show only first line, aby w obszarze roboczym wyświetlać tylko pierwszy wiersz pola Text. Tekst etykiety układu można także wyrównać zgodnie z potrzebami za pomocą kontrolek Alignment.

Javascript ID: Harness_LD_LayoutLabel_TextOptions_AD25
  • Aby wyświetlić tekst etykiety w BOM, możesz włączyć kolumnę Label Text w dokumencie ActiveBOM projektu () lub w tabeli BOM na rysunku produkcyjnym (). Zwróć uwagę, że właściwość Type etykiety układu musi być ustawiona na Standard, aby pojawiła się ona w BOM ().

  • Po umieszczeniu etykiety układu na rysunku rozmieszczenia możesz przypisać do niej komponent biblioteczny (lub, jeśli komponent jest już przypisany do etykiety układu, możesz wybrać inny komponent). Aby to zrobić, zaznacz etykietę układu i kliknij przycisk  po prawej stronie pola Design Item ID w obszarze General panelu Properties. W otwartym oknie dialogowym Replace przejdź do wymaganego komponentu i wybierz go. Umieszczona etykieta układu zostanie zaktualizowana o parametry wybranego komponentu.

Aktualizowanie obiektów rysunku rozmieszczenia z bibliotek

Następujące obiekty można aktualizować z ich źródłowej biblioteki Workspace:

  • Komponenty wiązki

  • Części powiązane z komponentami wiązki

  • Części powiązane z punktami połączeń

  • Osłony wiązki

  • Etykiety układu

Gdy obiekt jest zaznaczony, informacje o połączonym komponencie Workspace można znaleźć w panelu Properties (np. na karcie Associated Parts dla części powiązanych z komponentem wiązki lub w obszarze General dla etykiety układu).

Jeśli dostępna jest nowsza rewizja komponentu Workspace, wpis dotyczący statusu rewizji będzie to odzwierciedlał za pomocą tekstu Out of date. Na poziomie pojedynczego obiektu połączenie można zaktualizować do najnowszej rewizji komponentu Workspace, klikając przycisk .

Przykład wskazania nieaktualnej rewizji komponentu wiązki
Przykład wskazania nieaktualnej rewizji komponentu wiązki

Funkcja Update from Libraries (Tools » Update from Libraries) może być również używana do aktualizacji nieaktualnych komponentów połączonych z obiektami wymienionymi powyżej. Zwróć uwagę, że aby obiekt został uwzględniony w aktualizacji przy użyciu funkcji Update from Libraries, komponent przypisany do obiektu musi zawierać łącze do symbolu schematowego.

Adnotowanie obiektów rysunku rozmieszczenia wiązki

Użyj poleceń z menu Tools » Annotation, aby nadawać oznaczenia następującym obiektom w dokumencie rysunku rozmieszczenia wiązki:

  • Komponenty wiązki

  • Punkty połączeń

  • Wiązki przewodów

  • Osłony wiązki

  • Etykiety układu

Adnotowanie obiektów w dokumencie rysunku rozmieszczenia wiązki jest podobne do adnotowania komponentów w dokumencie schematu (*.SchDoc) projektu PCB. Skorzystaj z poniższych łączy, aby dowiedzieć się więcej o poleceniach adnotacji dostępnych dla dokumentu rysunku rozmieszczenia wiązki:

Sonda krzyżowa między schematem okablowania a rysunkiem rozmieszczenia

Obsługiwana jest sonda krzyżowa między schematem okablowania a rysunkiem rozmieszczenia projektu wiązki. Polecenie Cross Probe jest dostępne w menu głównym Tools oraz w menu po kliknięciu prawym przyciskiem w obszarze roboczym.

Sonda krzyżowa może być wykonywana:

  • Między komponentami na schemacie okablowania i na rysunku rozmieszczenia.

  • Z przewodu na schemacie okablowania do wiązki/wiązek, przez które ten przewód przechodzi na rysunku rozmieszczenia.

  • Z wiązki na rysunku rozmieszczenia do przewodu/przewodów przechodzących przez tę wiązkę na schemacie okablowania.

Javascript ID: Harness_CrossProbe_AD25

Sonda krzyżowa z komponentu na schemacie okablowania do odpowiadającego mu komponentu na rysunku rozmieszczenia.

Sonda krzyżowa z komponentu na rysunku rozmieszczenia do odpowiadającego mu komponentu na schemacie okablowania.

Sonda krzyżowa z przewodu na schemacie okablowania do odpowiadających mu wiązek na rysunku rozmieszczenia.

Sonda krzyżowa z wiązki na rysunku rozmieszczenia do odpowiadających jej przewodów na schemacie okablowania.

AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Content