Creating the Physical Multi-board Assembly

Altium Designer umożliwia tworzenie zespołu wielopłytkowego, określanego jako multi-board assembly. Po zdefiniowaniu logicznej struktury systemu na schemacie wielopłytkowym (*.MbsDoc), fizyczny projekt wielopłytkowy jest następnie tworzony przez przeniesienie projektu systemu do pustego dokumentu zespołu wielopłytkowego (*.MbaDoc). Proces ten spowoduje załadowanie do edytora zespołu wielopłytkowego fizycznej reprezentacji (PCB i innych zespołów wielopłytkowych) wskazanej przez każdy blok logiczny na schemacie wielopłytkowym. Ta strona omawia ten proces.

Aby dowiedzieć się więcej o etapie projektowania logicznego zespołu wielopłytkowego, przejdź do strony Tworzenie logicznego projektu systemu.

Projekty wielopłytkowe i powiązane z nimi podprojekty można zapisać w połączonym Workspace, gdzie mogą korzystać z funkcji kontroli wersji, udostępniania i zarządzania zapewnianych przez Altium 365 Workspace lub Enterprise Server Workspace.

Aby uzyskać informacje o przechowywaniu i udostępnianiu projektu wielopłytkowego w Altium 365 Workspace, przejdź do strony Workspace Projects .

Aby utworzyć nowy dokument zespołu wielopłytkowego:

  1. Dodaj nowy dokument zespołu wielopłytkowego (*.MbaDoc) do projektu wielopłytkowego, klikając prawym przyciskiem myszy wpis projektu w panelu Projects, a następnie wybierając Add New to Project » Multi-board Assembly z menu kontekstowego.

    Każdy projekt wielopłytkowy może zawierać tylko jeden dokument zespołu wielopłytkowego.

  2. Zapisz nowy dokument zespołu wielopłytkowego (kliknij prawym przyciskiem myszy jego wpis w panelu Projects i wybierz Save As z menu kontekstowego).

  3. Przenieś logiczną reprezentację systemu ze schematu wielopłytkowego do dokumentu zespołu wielopłytkowego – dowiedz się więcej.

  4. Jeśli obudowa jest dostępna, załaduj ją do zespołu – dowiedz się więcej.

  5. Ustaw położenie każdego elementu w obrębie zespołu – więcej informacji znajdziesz na stronie Positioning & Orienting Your Boards.

  6. Połącz elementy w obrębie zespołu za pomocą więzów – więcej informacji znajdziesz na stronie Working with Mates.

Przykładowy zespół wielopłytkowy. Wiele połączonych PCB umieszczono w obudowie.
Przykładowy zespół wielopłytkowy. Wiele połączonych PCB umieszczono w obudowie.

Opening a Multi-board Assembly Created in Altium Designer 18

Zespoły wielopłytkowe utworzone w Altium Designer 18 muszą zostać zaimportowane ze względu na zmiany formatu plików wymagane do obsługi silnika 3D i rozszerzonego zestawu funkcji. Po otwarciu dokumentu zespołu wielopłytkowego w starym formacie zostanie otwarte okno dialogowe Legacy document import.

Wybierz polecenie Design » Import w edytorze zespołu wielopłytkowego, aby wygenerować ECO, które ponownie załadują moduły podrzędne.

Zwróć uwagę, że ze względu na zmiany formatu plików wymagane do obsługi rozszerzonego zestawu funkcji i silnika 3D, zespołu wielopłytkowego zapisanego w nowszej wersji Altium Designer nie można otworzyć w Altium Designer 18.

Edytor Multi-board Assembly używa biblioteki Open CASCADE do modelowania geometrycznego zespołu wielopłytkowego. Należy pamiętać, że podczas otwierania starszego dokumentu zespołu wielopłytkowego (z poprzedniej wersji oprogramowania) utworzone więzy zostaną usunięte (możesz wybrać zachowanie względnych pozycji części zespołu albo umieszczenie ich w linii). Podczas otwierania masz możliwość utworzenia kopii zapasowej tej starszej wersji.

Ta funkcja jest w fazie Open Beta i jest dostępna po włączeniu opcji System.MBAEngine.UseOpenCascade w oknie dialogowym Advanced Settings.

Przenoszenie projektu systemu do dokumentu zespołu wielopłytkowego

Projekt wielopłytkowy jest przenoszony ze schematu wielopłytkowego do dokumentu zespołu wielopłytkowego za pomocą jednego z następujących poleceń:

  • Design » Update Assembly - <MultiBoardAssemblyDocumentName>.MbaDoc z menu głównego edytora schematu wielopłytkowego.

  • Design » Import Changes From <MultiBoardProjectName>.PrjMbd z menu głównego edytora zespołu wielopłytkowego.

Po uruchomieniu jednego z tych poleceń oprogramowanie analizuje każdy moduł na schemacie wielopłytkowym, identyfikuje PCB/zespół wybrany dla każdego projektu podrzędnego i przedstawia listę modyfikacji wymaganych do dodania każdej z tych płytek do zespołu w oknie dialogowym Engineering Change Order.

Płytka z każdego projektu PCB jest wymieniona jako modyfikacja ECO i zostaje załadowana do edytora Multi-board Assembly po wykonaniu ECO.
Płytka z każdego projektu PCB jest wymieniona jako modyfikacja ECO i zostaje załadowana do edytora Multi-board Assembly po wykonaniu ECO.

Po kliknięciu przycisku  płytki/zespoły są ładowane do edytora zespołu wielopłytkowego. Każda płytka/zespół jest umieszczana w przestrzeni projektowej w tej samej orientacji, jaką ma w projekcie podrzędnym. Ten proces zajmie trochę czasu, ponieważ pełny zestaw danych dla każdego PCB musi zostać przeanalizowany i załadowany.

Płytki w tym zespole wielopłytkowym załadowane do przestrzeni projektowej edytora zespołu wielopłytkowego, gotowe do pozycjonowania.
Płytki w tym zespole wielopłytkowym załadowane do przestrzeni projektowej edytora zespołu wielopłytkowego, gotowe do pozycjonowania.

  • Za pomocą opcji na stronie Multi-board Assembly – General w oknie dialogowym Preferences możesz skonfigurować, czy wolne bryły 3D z podrzędnych PCB mają być importowane oraz czy bryły 3D o wysokości mniejszej niż określona wartość nie mają być importowane.

  • Użyj polecenia View » Toggle Units z menu głównego (lub skrótu Q), aby przełączać jednostki między imperialnymi a metrycznymi.

Dodawanie dodatkowych obiektów do zespołu wielopłytkowego

Możesz także załadować dodatkowe obiekty do zespołu wielopłytkowego (oprócz PCB wskazanych na schemacie wielopłytkowym). Dodatkowe obiekty można załadować za pomocą menu Design lub przy użyciu przycisków znajdujących się w górnej części panelu Multi-board Assembly.

Każda jednostka, czyli element zespołu wielopłytkowego, jest określana jako part.

Użyj odpowiedniego polecenia lub przycisku, aby:

  • Insert PCB Part () – wstawić kolejne PCB do tego zespołu.

  • Insert MBA Part () – wstawić kolejny zespół wielopłytkowy do tego zespołu.

  • Insert STEP Part () – wstawić do tego zespołu model mechaniczny w formacie STEP.

  • Pamiętaj, że część jest wstawiana do zespołu wielopłytkowego jako pojedyncza jednostka. Na przykład jeśli wstawisz model STEP obudowy, który składa się z górnej i dolnej połowy, nie będzie można manipulować tymi połówkami niezależnie. W takiej sytuacji należy wstawić każdą połówkę do zespołu osobno.

  • Wstawiony zespół lub PCB jest not dodawany do projektu Multi-board Design (*.PrjMbd), dlatego nie jest widoczny jako element podrzędny tego projektu w panelu Projects.

Aktualizacja lub edycja części zespołu

Blokowanie/odblokowywanie części

Aby zablokować/odblokować część, zaznacz żądaną część, kliknij prawym przyciskiem myszy, a następnie wybierz polecenie Lock Selected Part/Unlock Selected Part z menu kontekstowego, aby zablokować/odblokować część (lub części połączone więzami) w jej bieżącej lokalizacji w przestrzeni projektowej edytora zespołu. Alternatywnie kliknij prawym przyciskiem wpis części w panelu Multiboard Assembly, a następnie wybierz Locked.

  • Zablokowanej części nie można edytować/przesuwać.

  • Zablokowane części są oznaczone ikoną kłódki w panelu Multiboard Assembly.

  • Zablokowana pojedyncza część nie wyświetla gizma obiektu (więcej informacji o gizmie obiektu znajdziesz na stronie Positioning & Orienting Your Boards). Zablokowana część nie może zostać powiązana więzem, jeśli jest wybrana jako źródło (obiekt, który się porusza – aby dowiedzieć się więcej o łączeniu części więzami, przejdź do strony Working with Mates).

Aktualizacja części

Jeśli część lub bryła 3D dodana do zespołu została zaktualizowana, aktualizację można załadować do zespołu wielopłytkowego za pomocą jednego z następujących działań:

  • Wybierz polecenie Edit » Update All Parts z menu głównego lub kliknij prawym przyciskiem myszy w dowolnym miejscu przestrzeni projektowej i wybierz polecenie Update All Parts z menu kontekstowego (skrót: Shift+Ctrl+U), aby zaktualizować wszystkie części aktywnego zespołu wielopłytkowego najnowszymi informacjami o układzie z odpowiadających im podrzędnych dokumentów PCB.

  • Zaznacz wymaganą część/wymagane części i wybierz polecenie Edit » Update Selected Part z menu głównego lub kliknij prawym przyciskiem myszy w dowolnym miejscu przestrzeni projektowej i wybierz polecenie Update Selected Part z menu kontekstowego (skrót: Ctrl+U), aby zaktualizować zaznaczone części aktywnego zespołu wielopłytkowego najnowszymi informacjami o układzie z odpowiadających im podrzędnych dokumentów PCB.

  • Zaznacz wymaganą bryłę 3D i wybierz polecenie Edit » Update Selected 3D Body z menu głównego lub kliknij prawym przyciskiem myszy w dowolnym miejscu przestrzeni projektowej i wybierz polecenie Update Selected 3D Body z menu kontekstowego, aby zaktualizować zaznaczone bryły 3D aktywnego zespołu wielopłytkowego najnowszymi informacjami o układzie z odpowiadających im podrzędnych dokumentów PCB.

Edycja części

Sesję edycji zespołu lub PCB można uruchomić z poziomu edytora zespołu wielopłytkowego. Zaznacz wymaganą część i uruchom polecenie Edit » Edit Selected Part lub kliknij prawym przyciskiem myszy w dowolnym miejscu przestrzeni projektowej i wybierz polecenie Edit Selected Part z menu kontekstowego (skrót: Ctrl+E). Po uruchomieniu polecenia wejdziesz w tryb edycji części, a wybrane PCB zostanie powiększone i wyśrodkowane (tam, gdzie to możliwe), aby dopasować się do głównego okna projektu. Płytka pozostanie wyświetlana w pełnych kolorach, a wszystkie pozostałe płytki będą wyszarzone (tylko do odczytu).

Wprowadź wymagane zmiany w rozmieszczeniu komponentów, korzystając z ręcznego rozmieszczania i/lub funkcji wyrównywania. Po zakończeniu edycji użyj polecenia Finish Part Editing (Ctrl+E). Widok przestrzeni projektowej powróci do dopasowania wszystkich płytek w zespole, a edytowana płytka pozostanie zaznaczona.

Jeśli chcesz anulować edycję bez wprowadzania zmian, użyj polecenia Cancel Part Editing.

Nawigacja i zarządzanie zespołem wielopłytkowym

Do nawigacji i zarządzania zespołem wielopłytkowym możesz używać panelu Multiboard Assembly.

Panel przedstawia rozwijany widok drzewa kompletnej struktury zespołu, w tym:

  • Uwzględnione płytki (PCB) i zespoły wielopłytkowe oraz komponenty, warstwy i sieci w obrębie każdego PCB

  • Dołączone modele STEP

  • Inne dołączone zespoły wielopłytkowe

  • Więzy utworzone między obiektami w zespole

Podświetlanie elementów w zespole wielopłytkowym

Panel Multiboard Assembly zapewnia możliwości podświetlania, gdzie część wybrana w drzewie jest podświetlana w przestrzeni projektowej. Podświetlanie jest dwukierunkowe dla zaznaczeń dokonanych na najwyższym poziomie drzewa zespołu; na przykład stan zaznaczenia wpisów panelu będzie się zmieniał w odpowiedzi na obiekty najwyższego poziomu wybrane w przestrzeni projektowej. Z poziomu panelu zaznaczanie jest obsługiwane na wszystkich poziomach drzewa, gdzie ma to sens. Na przykład zaznaczenie pojedynczej sieci spowoduje podświetlenie tej sieci na całej płytce, ale zaznaczenie pojedynczej warstwy dielektrycznej nie spowoduje podświetlenia tej warstwy. Do wielokrotnego zaznaczania w panelu można używać standardowych skrótów Windows Shift+Click lub Ctrl+Click.

Trzy płytki zaznaczone w przestrzeni projektowej są również podświetlone w panelu.
Trzy płytki zaznaczone w przestrzeni projektowej są również podświetlone w panelu.

Podświetlanie z poziomu panelu to doskonała metoda lokalizowania konkretnej części lub analizowania przebiegu zestawu sieci przechodzących pod płytką-córką.

Sterowanie widocznością i przezroczystością części zespołu

Oprócz podświetlania konkretnej części lub części, panel może być również używany do sterowania widocznością i przezroczystością części aktualnie zaznaczonych w panelu. Kliknij prawym przyciskiem zaznaczone części, a następnie wybierz Visible lub Transparent z menu kontekstowego. Przezroczyste części staną się półprzezroczyste. Części z wyłączoną opcją Visible będą ukryte.

Javascript ID: MBA_Pnl_MultiboardAssembly_PartVisibility

Model STEP jest w pełni widoczny w zespole.

Ten sam model został uczyniony przezroczystym.

Ten sam model został całkowicie ukryty.

Możesz również sterować widocznością PCB, komponentu PCB lub modelu STEP bezpośrednio w przestrzeni projektowej.

  • W przypadku całego obiektu, takiego jak PCB lub model STEP, zaznacz obiekt, a następnie kliknij prawym przyciskiem myszy, aby wyświetlić menu kontekstowe, i wybierz opcję Visible, aby ukryć obiekt. Użyj panelu Multi-board Assembly, aby przywrócić widoczność.

  • W przypadku komponentu PCB zaznacz PCB w przestrzeni projektowej, kliknij prawym przyciskiem myszy i wybierz Edit Selected Part. Następnie kliknij prawym przyciskiem dowolny komponent na tej płytce i wybierz z menu kontekstowego polecenie Visible lub Transparent. Po zakończeniu konfigurowania widoczności komponentów na tej płytce kliknij ją ponownie prawym przyciskiem myszy i wybierz Finish Editing Part lub Cancel Editing Part.

Pomiar odległości

Polecenie Tools » Measure Distance z menu głównego (skrót: Ctrl+M) służy do pomiaru odległości między bryłami 3D w zespole wielopłytkowym. Po uruchomieniu polecenia wejdziesz w tryb pomiaru. Pomiar wykonuje się następująco:

  1. Wybierz pierwszy obiekt 3D lub konkretną ścianę tego obiektu. Gdy przesuwasz kursor nad potencjalnym obiektem 3D, kolor tego obiektu będzie się zmieniał. Jeśli chcesz wybrać konkretną ścianę obiektu, przytrzymaj klawisz Ctrl  podczas przesuwania kursora – ściana aktualnie znajdująca się pod kursorem zostanie podświetlona. Po ustawieniu kursora kliknij, aby potwierdzić wybór obiektu/ściany.

  2. Wybierz drugi obiekt 3D lub konkretną ścianę tego obiektu.

  3. Narzędzie wizualnie przedstawia najkrótszą odległość między dwoma wybranymi obiektami (ścianami).

  4. Kontynuuj pomiar odległości między innymi obiektami/ścianami lub naciśnij Esc, aby wyjść z trybu pomiaru.

  • Wszystkie wyniki pomiarów podczas aktywnej sesji pomiarowej są prezentowane w panelu Messages. Możesz kliknąć dwukrotnie wpis, aby przejść do tego pomiaru w przestrzeni projektowej.

  • Po zakończeniu sesji pomiarowej wszystkie wizualne pomiary zostaną usunięte wraz ze wszystkimi wpisami pomiarów w panelu Messages.

  • Po najechaniu kursorem na bryłę 3D (lub jej ścianę) kolor zmieni się na określony dla koloru systemowego Highlight Under Cursor w sekcji System Colors panelu View Configuration.

Sprawdzanie kolizji

Kolizje są sygnalizowane zawsze wtedy, gdy powierzchnie dwóch obiektów stykają się lub przecinają.

Aby sprawdzić kolizje, wybierz Tools » Check Collisions (skrót: Ctrl+K). Po uruchomieniu polecenia oprogramowanie sprawdza kolizje między różnymi elementami wchodzącymi w skład zespołu wielopłytkowego. Najpierw każda płytka jest sprawdzana pod kątem kolizji z górną i dolną częścią obudowy/korpusu (części STEP), a następnie sprawdzane są kolizje między samymi płytkami (PCB).

Wszelkie kolizje będą zgłaszane w panelu Messages, a powodujące je obiekty zostaną podświetlone przy użyciu koloru systemowego Violation. Użyj obszaru Details panelu Messages, aby sprawdzić, który komponent na płytce biorącej udział w konflikcie powoduje kolizję.

W razie potrzeby naruszenia kolizji podświetlone w przestrzeni projektowej po uruchomieniu sprawdzania kolizji można usunąć, wybierając polecenie Tools » Clear Violations.

  • Sprawdzanie kolizji będzie wykonywane między wszystkimi płytkami a częściami obudowy/korpusu niezależnie od widoczności płytki/części w przestrzeni projektowej.

  • Powierzchnie połączone więzami nie są uznawane za kolidujące.

Obsługa rigid-flex

Edytor zespołu wielopłytkowego obsługuje PCB rigid-flex. Rigid-flex to nazwa nadawana obwodowi drukowanemu będącemu połączeniem zarówno obwodów elastycznych, jak i sztywnych. Edytor zespołu wielopłytkowego wyświetla PCB w końcowym złożonym stanie zdefiniowanym w edytorze PCB.

Aby uzyskać informacje o projektowaniu PCB rigid-flex, przejdź do strony Designing a Rigid-Flex PCB.

Eksport do MCAD

Zespół można wyeksportować w formacie STEP 3D lub Parasolid. Aby wyeksportować cały zespół do STEP 3D (*.step lub *.stp), wybierz File » Export » STEP 3D  z menu głównego. Aby wyeksportować cały zespół w formacie Parasolid (*.x_t), wybierz File » Export » Parasolid z menu głównego.

Przykład pliku STEP zespołu wielopłytkowego otwartego w narzędziu MCAD.
Przykład pliku STEP zespołu wielopłytkowego otwartego w narzędziu MCAD.

Zespół wielopłytkowy można również synchronizować między Altium Designer a obsługiwanym narzędziem MCAD za pomocą funkcji Altium MCAD CoDesigner.

Aby dowiedzieć się więcej, przejdź do strony Synchronizing a Multi-board Assembly.

Eksport do PDF 3D

Dokument zespołu wielopłytkowego można również wyeksportować do pliku PDF (*.pdf). Aby to zrobić, wybierz polecenie File » Export to PDF File z menu głównego.

Aby uzyskać więcej informacji, przejdź do strony Preparing a PDF3D File.

AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Content