Trabalhando com Parâmetros de Objetos de Projeto
Num relance
- Saiba onde os parâmetros estão presentes no Altium Designer, incluindo os níveis de objeto, documento e projeto, e como os parâmetros de sistema e de usuário se diferenciam.
- Veja como adicionar, editar, mover, bloquear e gerenciar textos de parâmetros por meio do painel Properties, da área de projeto e dos fluxos de trabalho com bibliotecas.
- Entenda o comportamento dos parâmetros específicos de componentes, incluindo designadores, posicionamento automático e tipos especiais de parâmetros, como links.
Parâmetros são strings de texto de uso geral que são objetos filhos de um objeto pai. Eles identificam e acrescentam informações a esse objeto pai e são acessados diretamente no painel Properties quando selecionados em uma folha de esquemático.
Por exemplo, os componentes de esquemático fazem uso extensivo de parâmetros. Os parâmetros de uso geral dos componentes podem ser usados para diversas funções, incluindo detalhes do componente, como potência, tensão etc., detalhes do fornecedor, incluindo o nome do fornecedor e o número de peça, detalhes do projeto do componente de biblioteca, como o número de revisão do símbolo, e detalhes de documentação, como uma URL que direciona para a folha de dados de um componente.
Os parâmetros também podem ser definidos nos níveis da folha de esquemático (documento) e do projeto. Os parâmetros no nível do documento são usados para definir campos como o título e o número do documento, enquanto os parâmetros no nível do projeto são ideais para definir campos como o projetista ou o nome do projeto.
Os parâmetros são usados em objetos, documentos e projetos para acrescentar informações detalhadas ao projeto. Um componente é mostrado na imagem acima.
Os parâmetros são adicionados ou incluídos automaticamente como propriedades do objeto pai e não são posicionados de forma independente como uma string de texto. Os tipos de parâmetros disponíveis podem ser agrupados, de modo geral, em parâmetros do sistema e do usuário, sendo estes últimos adicionados manualmente.
Parâmetros de identificação e do sistema
Os objetos posicionados em um esquemático incluem automaticamente um conjunto de parâmetros essenciais do sistema. Eles fornecem as informações básicas do objeto usadas pelo sistema para distinguir o nome, o tipo e a fonte de dados do objeto pai. Os parâmetros inerentes do sistema para objetos incluem, entre outros, as propriedades Comment, Description e Design Item ID (Referência da biblioteca). Os parâmetros do sistema dos objetos podem ser acessados na seção General do painel Propriedades (na aba General) quando um objeto pai é selecionado Quando visível e selecionado na área de projeto, um parâmetro individual pode ser acessado pelo modo correspondente do painel Propriedades, conforme descrito abaixo
Parâmetros do usuário
É possível adicionar parâmetros a qualquer um dos seguintes objetos de projeto.
| Component | Adicione parâmetros definidos pelo usuário na região Parameters do painel Propriedades quando um objeto de componente (peça) estiver selecionado ou durante a definição do componente no editor de Biblioteca de Esquemáticos. Os parâmetros do sistema, como designador e comentário, estão sempre presentes em um objeto de componente, conforme descrito acima. O painel Properties é acessado clicando duas vezes em um objeto ou clicando com o botão direito do mouse em um objeto e escolhendo Properties no menu de contexto. Selecione um objeto na área de projeto se o painel Properties já estiver ativo. |
| Part | Na região Parameters do painel Properties quando um objeto Peça estiver selecionado. |
| Pin | Na aba Parameters do painel Properties quando um objeto Pino estiver selecionado em um arquivo *.SchLib. |
| Port | Na aba Parameters do painel Properties quando um objeto Porta estiver selecionado. |
| Sheet Symbol | Na aba Parameters do painel Properties quando um objeto Símbolo de folha estiver selecionado. |
| Document | Na aba Parameters do painel Propriedades quando estiver no modo Document Options (desmarque todos os objetos do esquemático ou clique em uma área vazia da folha do documento). Um conjunto de parâmetros padrão é incluído automaticamente em uma nova folha de esquemático, conforme determinado pelo modelo de folha aplicado/padrão. |
| Project | Na caixa de diálogo Opções do projeto (Project » Opções do projeto). Os parâmetros no nível do projeto são listados e adicionados na aba Parameters da caixa de diálogo. |
Os parâmetros do usuário estão disponíveis na região Parameters do painel Properties ou da caixa de diálogo modal quando o objeto pai está selecionado. Os parâmetros podem ser adicionados e editados. As exceções são os parâmetros do projeto (pela caixa de diálogo Opções do projeto) e os parâmetros dos pinos do componente (por meio de Propriedades do pino ou da visualização modal da Pin caixa de diálogo). Quando visível e selecionado na área de projeto, um parâmetro individual pode ser acessado pelo modo correspondente do painel Propriedades ou da caixa de diálogo modal, conforme descrito abaixo.
Primeiro: parâmetros do usuário de um componente no painel Properties (região Parameters). Segundo: um parâmetro individual do sistema no painel Properties.
Edição gráfica
As strings de parâmetros visíveis podem ser editadas graficamente diretamente na área de projeto.
Clique e arraste um parâmetro para reposicioná-lo. Para editar a string do parâmetro no próprio local:
-
Arraste o cursor do mouse ao redor do objeto de parâmetro mantendo o botão do mouse pressionado.
-
Após ser selecionado, o objeto será destacado por uma borda verde.
-
Selecione
Enterpara começar a editar o texto. -
Após concluir a edição, pressione
Enternovamente ou clique fora da string para sair do modo de edição no próprio local.
Uma string de parâmetro pode ser selecionada e editada diretamente na área de projeto. Selecione a string inteira para substituí-la ao digitar.
Os parâmetros visíveis e selecionáveis na área de projeto podem ser arrastados para um novo local e girados durante o processo. Clique e arraste a string do parâmetro, use as teclas Spacebar e Shift+Spacebar para girá-la em incrementos de 90° e, em seguida, clique para confirmar a nova posição/orientação.
Consulte Posicionamento de strings de parâmetros abaixo para obter informações sobre Autopositioning dos parâmetros de componentes e as opções relacionadas do painel Properties.
Parâmetros bloqueados
Um parâmetro que seja filho de uma Peça de componente pode ser bloqueado, o que significa que suas strings Name e Value não podem ser editadas. Isso pode ser feito:
-
alternando o ícone de cadeado associado à sua entrada na região Parameters do painel Properties ou da caixa de diálogo modal do objeto pai, ou
-
marcando a opção Lock Parameter no painel Propriedades quando o parâmetro estiver diretamente selecionado na área de projeto.
Uma vez bloqueada, a string do parâmetro não pode ser editada no painel Properties, na caixa de diálogo modal (em Parameters para o objeto pai) nem no espaço de projeto usando a edição no local.
Parâmetros de componentes
Os parâmetros de componentes, os parâmetros de esquemático mais evidentes e usados com maior frequência, incluem conjuntos adicionais de parâmetros e recursos dedicados que ampliam a capacidade de definir objetos de componente.
Definição de parâmetros na biblioteca de esquemáticos
Os parâmetros filhos de um objeto de componente pai podem ser definidos na biblioteca de origem do componente antes de suao inserção em um esquemático. O painel Properties é usado para editar e adicionar parâmetros a uma entrada de componente no editor de bibliotecas de esquemáticos, da mesma maneira que ao trabalhar com parâmetros no editor de esquemáticos.
Com um documento de biblioteca de componentes de esquemático aberto, selecione uma entrada de componente no painel Biblioteca SCH para acessar as propriedades de seus parâmetros no painel Properties.
Acesse as propriedades de um componente da biblioteca selecionando sua entrada no painel SCH Library.
O designador e o comentário de um componente da biblioteca não ficam visíveis por padrão no espaço de projeto do editor de bibliotecas de esquemáticos, mas podem ser exibidos marcando a opção Show Comment/Designator no modo Opções da biblioteca do painel Propriedades (Tools » Document Options) – disponível quando nenhum objeto está selecionado no espaço de projeto.
Os parâmetros pertencentes a um componente da biblioteca são definidos e editados usando o mesmo processo aplicado aos componentes inseridos no esquemático. A tecla Tab pode ser usada para criar ou editar parâmetros durante a inserção de um objeto no espaço de projeto. Os parâmetros são acessados pelo painel Properties ou pela caixa de diálogo modal, onde os parâmetros básicos do sistema estão disponíveis na aba General do painel, e os parâmetros do usuário são adicionados/editados no menu suspenso Parameters do painel.
O parâmetro Designador
No editor de bibliotecas de esquemáticos, o parâmetro Designator de um componente normalmente recebe um prefixo adequado seguido de um ponto de interrogação. Quando o componente é inserido em um esquemático a partir da biblioteca, o ponto de interrogação é detectado pela ferramenta de anotação do editor de esquemáticos e substituído por um sufixo numérico adequado durante a anotação do projeto.
O editor de esquemáticos também inclui um recurso simples de incremento automático do designador, que pode ser usado durante a inserção de várias instâncias da mesma peça. Para usá-lo, pressione Tab enquanto o primeiro componente estiver flutuando no cursor para pausar a inserção e, em seguida, insira um designador adequado no painel Properties; por exemplo, R1. Os componentes subsequentes receberão então os designadores R2, R3 etc.
Ao inserir componentes com várias partes e atribuir o designador inicial dessa maneira, um sufixo de parte será adicionado automaticamente, por exemplo, U3A, U3B etc. Se o designador inicial não for atribuído, todas as partes terão o mesmo sufixo. Isso pode ser resolvido pelo recurso de anotação do editor de esquemáticos. O sufixo de parte pode ser alfabético ou numérico, conforme especificado pela opção Alpha Numeric Suffix na página Esquemático - Geral da caixa de diálogo Preferences.
Posicionamento da string do parâmetro
O comportamento padrão da string de um parâmetro de componente é posicioná-la automaticamente (ou seja, manter a orientação) quando um componente é girado durante ou após a inserção. Se esse comportamento não for necessário, desative a opção Autoposition para a entrada do parâmetro do componente na região Parameters do painel Properties. Para acessar a opção, selecione o parâmetro na lista e clique em Other. Observe que, durante a inserção do componente, as teclas Spacebar e Shift+Spacebar são usadas para girá-lo. Um objeto de componente já inserido pode ser girado pelo menu Rotation na região Location do painel Properties ou selecionando o componente e pressionando Spacebar ou Shift+Spacebar.
Clique e arraste um parâmetro visível para reposicioná-lo manualmente no esquemático; as teclas de atalho padrão de orientação serão aplicadas. Se a opção Autoposition estiver desativada para esse parâmetro and a opção Mark Manual Parameters estiver ativada na página Esquemático - Edição gráfica da caixa de diálogo Preferences, os parâmetros movidos manualmente serão identificados por um ponto no canto inferior esquerdo de sua caixa de seleção.
Parâmetros de componentes para fins específicos
Os parâmetros de componentes para fins específicos estão disponíveis para criar links para URLs relacionadas ou documentação em arquivos. Para um componente selecionado, esses parâmetros são adicionados clicando em Add na região Parameters do painel Properties e selecionando Link no menu suspenso, ou na aba Parameters para links de ajuda dedicados que são ativados usando a tecla F1.
Parâmetros de link
O recurso de links permite definir e apresentar links nomeados para qualquer quantidade de URLs ou documentos de referência.
Para adicionar um link de referência a um componente, selecione o componente no espaço de projeto e clique em Links na região Parameters do painel Properties. Selecione Link no menu suspenso Add na parte inferior da região Parameters . Insira o Name e o Value do link (URL de destino ou caminho do arquivo) na grade. O link poderá então ser acessado clicando com o botão direito do mouse no componente no espaço de projeto e selecionando o <name> do link no submenu References.
Os links de componentes, conforme apresentados no painel e no espaço de projeto, são baseados internamente em pares Nome/Valor no formato ComponentLinknDescription/ComponentLinknURL (em que n é o número do link na lista, com base na ordem de criação). Consulte a entrada do Editor de tabelas de parâmetros desse componente para ver mais detalhes.
O parâmetro HelpURL
Semelhante ao parâmetro de link, o parâmetro HelpURL permite definir um link de um componente para um documento externo, como um PDF, ou para a URL de uma página da web. Quando adicionado como parâmetro de componente, o link é ativado quando a tecla F1 é pressionada com o cursor sobre o componente na folha do esquemático ou quando o componente está selecionado no painel Libraries. Observe que essa ação substituirá a função normal da tecla F1, que abre a página relevante na documentação on-line da Altium.
O link de ajuda é adicionado como um parâmetro do usuário no painel Properties quando um componente está selecionado no espaço de projeto. Clique em Parameters na região Parameters do painel Properties e selecione Parameter no menu suspenso Add na parte inferior da região Parameters . Insira "HelpURL" como o Name do parâmetro e o caminho/URL de destino como o Valuedo parâmetro.
Ao especificar o valor do parâmetro, ele pode ser uma URL, um caminho absoluto para um documento ou apenas o nome do documento. Quando F1 é pressionado com o cursor sobre o objeto de componente posicionado, ou quando a opção References » Help é usada no menu do botão direito, uma busca pela referência de Ajuda é realizada da seguinte forma:
- Se um caminho for especificado, esse local será pesquisado primeiro.
-
Se o documento não puder ser encontrado nesse local, ou se nenhum caminho for especificado, a pasta
\Helpda instalação do software será pesquisada. - Se o destino for uma URL, a página da web será aberta no navegador interno do software ou em um navegador externo, dependendo do estado da opção Open internet links in external Web browser na página Sistema - Visualização da caixa de diálogo Preferences.
Indireção - Um parâmetro como valor de uma string
A maioria dos parâmetros de componentes pode ser exibida em uma folha de esquemático ativando o ícone de visibilidade (quando disponível) no painel Properties. Os parâmetros de identificador e de sistema estão disponíveis na aba General do painel, e os parâmetros do usuário são acessados na região Parameters do painel.
Outros parâmetros, no entanto, como os parâmetros de documento e de projeto, não podem ser exibidos diretamente na folha de esquemático, mas podem ser inseridos em um objeto de texto padrão usando uma técnica conhecida como String Indirection. A indireção ocorre quando a entrada de Valor de um objeto de string é o nome de um parâmetro disponível (como um parâmetro de documento ou de projeto) precedido por um sinal de igual, por exemplo, =Title.
O software detecta automaticamente essas strings e procura um nome de parâmetro disponível que corresponda à entrada de valor do objeto de texto posicionado. O exemplo de Title é encontrado como um parâmetro de documento, fazendo com que a string de texto interprete e exiba o valor do parâmetro de título, por exemplo, MyDocument. Um nome de parâmetro pode ser associado ao valor de uma string de texto selecionada por meio da edição no próprio local (ou seja, digitando =Title) ou, como uma abordagem mais informativa, usando o menu suspenso Text no painel Propriedades para selecionar entre as strings de parâmetros disponíveis.
Strings especiais
As strings de parâmetros disponíveis como strings indiretas (veja acima) são conhecidas como special strings. O valor apresentado por essas strings é inferido dinamicamente a partir de modelos ou de dados do sistema e de origem. Assim, por exemplo, a string especial =Time detectará e mostrará a hora atual do sistema, e =DocumentName mostrará o nome do arquivo do documento de esquemático atual (por exemplo, MySchematic.SchDoc).
Há um grande número de strings especiais predefinidas disponíveis. Consulte a página Trabalhando com objetos de texto em um esquemático para saber mais sobre essas strings especiais. Qualquer parâmetro de documento ou de projeto definido pelo usuário também pode ser usado como uma string especial e ser associado por indireção a uma string de texto na folha de esquemático.
Os parâmetros têm uma hierarquia, o que significa que você pode criar um parâmetro com o mesmo nome em diferentes níveis do projeto, cada um com valores diferentes. Para um parâmetro de componente, o Altium Designer resolve isso da seguinte forma:
-
Parâmetro de componente (prioridade mais alta)
-
Variante
-
Documento de esquemático
-
Símbolo de folha (para ver o valor do parâmetro do símbolo de folha acima, selecione a aba Compiled na parte inferior da área de projeto)
-
Projeto
A maioria das opções e dos controles deste painel é simples e não exige explicações adicionais. Uma opção que exige explicação é descrita abaixo.
-
Allow Synchronization with Database (somente na caixa de diálogo Preferences ) - habilite para sincronizar com o banco de dados. Esta opção é usada para controlar se o comentário pode ser atualizado. Por padrão, essas opções estão habilitadas para sempre permitir a sincronização com a biblioteca ou o banco de dados de origem. Você pode desabilitar esta opção para impedir que esse comentário seja incluído em um processo de atualização.
Usando o Gerenciador de parâmetros
Os atributos de projeto definidos pelo usuário são adicionados ao seu projeto por meio de parâmetros. Os parâmetros podem ser adicionados e editados individualmente, ou você pode usar a caixa de diálogo Parameter Table Editor (Tools » Parameter Manager) para adicionar e editar parâmetros em todo o projeto ou em uma biblioteca inteira. Esses parâmetros “pertencem” a vários tipos de objetos nos documentos de esquemático de origem do projeto ativo ou a componentes na biblioteca ativa. Isso oferece uma maneira rápida e eficiente de reunir todos os parâmetros em um único local para edição, com a possibilidade de criar uma Ordem de Alteração de Engenharia para implementar quaisquer alterações de parâmetros que você fizer diretamente em cada objeto de projeto “proprietário” afetado.
Quando você abre a caixa de diálogo, ela reúne todos os dados de parâmetros de todo o projeto e os apresenta em uma grade semelhante a uma tabela. Quando a caixa de diálogo é iniciada a partir de um esquemático, a caixa de diálogo Parameter Editor Options é aberta. Selecione o tipo de parâmetros que deseja carregar na caixa de diálogo Parameter Table Editor. Por exemplo, se você estiver trabalhando com parâmetros de componentes, desabilite todas as opções na região Include Parameters Owned By exceto Parts. Você pode refinar ainda mais o escopo de inclusão de objetos usando o campo suspenso no centro da caixa de diálogo. Escolha incluir todos os objetos, apenas objetos com parâmetros existentes ou apenas objetos com parâmetros existentes que sejam efetivamente usados.
Outro exemplo: se você estiver trabalhando com parâmetros de documento, habilite apenas a opção Documents. Observe que a opção Exclude System Parameters inclui itens como configurações de modelos de componentes, parâmetros de documento que foram definidos no modelo e assim por diante. Explore esta opção quando estiver mais familiarizado com o gerenciamento de parâmetros.
Se quiser editar os parâmetros apenas de objetos específicos do projeto, selecione os objetos conforme necessário e habilite a opção Selected Objects Only . Somente os objetos da sua seleção serão incluídos, desde que o tipo de objeto correspondente tenha sido habilitado na região Include Parameters Owned By da caixa de diálogo.
Após selecionar as opções necessárias, clique em OK para abrir a caixa de diálogo Parameter Table Editor.
A maioria das opções e dos campos da caixa de diálogo é autoexplicativa. As explicações para os demais são apresentadas abaixo.
-
Remove Columns - clique para remover colunas. Esta opção está disponível apenas para colunas com informações estáticas.
-
Add Column - clique para adicionar uma coluna. A caixa de diálogo Add Parameter é aberta, permitindo definir o nome do parâmetro.
-
Reset Column Order - clique para exibir as colunas em ordem alfabética.
-
Accept Changes (Create ECO) - para aplicar essas alterações aos componentes, é necessário gerar uma ECO (Ordem de Alteração de Engenharia). Clique para abrir a caixa de diálogo Engineering Change Order.
Menu do botão direito
-
Revert - clique para desfazer as edições nas células selecionadas.
-
Add - clique para adicionar informações à célula selecionada. Use o menu suspenso exibido para selecionar as informações desejadas.
-
Rename Column - clique para abrir a caixa de diálogo Renomear parâmetro existente, na qual você pode renomear um parâmetro existente.
-
Remove Columns - clique para excluir a coluna selecionada.
-
Report - clique para abrir a caixa de diálogo Report Preview e gerar um relatório.
-
Cross Probe - clique para realizar a sondagem cruzada do objeto selecionado. O objeto selecionado será destacado na folha do esquemático.
Notas
-
Você pode arrastar e soltar colunas na área da grade para alterar a ordem de exibição das colunas. A nova ordem é salva no arquivo do projeto para que seja mantida quando a caixa de diálogo for acessada novamente.
-
É possível impedir a atualização dos parâmetros das seguintes maneiras:
- No nível de parâmetro de cada componente, habilite a opção Lock Parameter no modo Component do painel Properties (clique duas vezes em um componente para acessá-lo). A opção Allow Synchronization With Database também é usada para controlar se o comentário pode ser atualizado. Por padrão, essa opção está habilitada para sempre permitir a sincronização com a biblioteca/banco de dados de origem. Você pode desabilitar essa opção para impedir que o comentário seja incluído em um processo de atualização.
- No nível de vínculo com o banco de dados — a área Field Mapping do documento de vínculo com o banco de dados correspondente (arquivo *.DbLink, *.DbLib ou *.SvnDbLib) inclui várias opções que controlam se os parâmetros podem ser atualizados, incluindo Update Values, Add to Design e Remove from Design.
Use esta caixa de diálogo para adicionar, editar e remover parâmetros em todo o projeto. A caixa de diálogo pode ser usada para editar diretamente os parâmetros existentes no projeto ou para configurar atualizações de parâmetros a partir de um banco de dados vinculado (por meio de um arquivo DbLink, DbLib ou SvnDbLib). Observe que esses arquivos de vínculo com bibliotecas de banco de dados incluem opções que controlam se um parâmetro deve ou não ser atualizado. As alterações são então implementadas por meio de uma Ordem de Alteração de Engenharia (ECO) que você cria nesta caixa de diálogo.
Adicionar um parâmetro
Para adicionar um novo parâmetro, clique no botão (ou clique com o botão direito em qualquer lugar da grade principal e escolha o comando Add Column no menu de contexto). A caixa de diálogo Add Parameter será aberta. Para apenas criar o novo parâmetro, sem atribuir valores a nenhum dos objetos, insira o nome desejado e clique em OK. Se quiser adicionar o parâmetro a todos os objetos com um valor específico, habilite a opção Add to all objects, insira o valor desejado e clique em OK. Uma coluna para o novo parâmetro será adicionada ao final das colunas existentes (na extremidade direita da lista).
Renomear um parâmetro
Para renomear um parâmetro, clique com o botão direito em uma célula da coluna que deseja renomear e selecione Rename Column no menu suspenso. A caixa de diálogo Rename Existing Parameter será aberta. Insira o novo nome no campo Enter the new name for the parameter e clique em OK. Observe que o cabeçalho da coluna terá sido alterado e agora terá um pequeno triângulo azul ao lado do nome. Esse ícone indica que o valor dessa célula foi alterado.

A caixa de diálogo Rename Existing Parameter
Adicionar um parâmetro a componentes selecionados
Para adicionar um parâmetro aos componentes, selecione as células no editor da caixa de diálogo Parameter Table Editor usando as combinações de teclas Shift+Click ou Ctrl+Click, clique com o botão direito e escolha Add no menu suspenso. Após selecionar Add, um pequeno símbolo de adição verde será exibido em cada célula. Isso indica que um novo parâmetro foi adicionado.
Agora que o parâmetro foi adicionado, você pode definir o tipo de componente para cada componente. A caixa de diálogo Parameter Table Editor oferece suporte aos atalhos padrão de edição de tabelas. Você pode pressionar F2 para editar uma célula e, em seguida, pressionar Enter para aplicar a edição. É possível editar várias células selecionando-as e, em seguida, clicando com o botão direito e escolhendo Edit no menu. Insira o novo valor e pressione Enter para aplicar a edição a todas as células selecionadas.
Aplicar as alterações de parâmetros
As edições de parâmetros que acabaram de ser concluídas estão armazenadas na caixa de diálogo Parameter Table Editor e ainda não foram aplicadas aos componentes nas folhas do esquemático. Para aplicar essas alterações aos componentes, você precisa gerar uma ECO e depois aplicá-la ao projeto. Na caixa de diálogo Parameter Table Editor, clique no botão Accept Changes (Create ECO) . A caixa de diálogo Parameter Editor Table será fechada, e a caixa de diálogo Engineering Change Order será aberta.
Clique no botão Validate Changes para verificar se as alterações podem ser aplicadas. Se forem válidas, uma marca de verificação verde será exibida na coluna Check .
Clique em Execute Changes para aplicar as alterações de parâmetros aos componentes. Depois que as alterações forem aplicadas, feche a caixa de diálogo Engineering Change Order .
).
).







