Importando Bibliotecas Existentes para o Seu Workspace Conectado
Num relance
- Saiba como acessar o Library Importer e escolher entre os modos Simples e Avançado.
- Entenda quais bibliotecas e dados de componentes podem ser importados, além das principais limitações.
- Explore as prévias de importação, a classificação de componentes, as configurações de parâmetros e os relatórios para revisar e aprimorar suas importações.
O Altium Designer, em conjunto com seu Workspace conectado, oferece um processo simplificado e altamente automatizado para importar rapidamente suas bibliotecas existentes para esse Workspace. A interface desse processo – o Library Importer – apresenta uma solução de um clique que analisa automaticamente as bibliotecas selecionadas e as importa para o Workspace ao qual você está conectado.
Compatível com todos os tipos de bibliotecas relacionados a metodologias mais antigas de gerenciamento de componentes (SchLib, PcbLib, IntLib, DbLib, SVNDbLib), o Importador de Bibliotecas é uma solução dedicada à criação rápida da biblioteca de componentes do Workspace da sua empresa, para que você possa aproveitar suas diversas vantagens: armazenamento e gerenciamento centralizados e de alta integridade, facilidade de reutilização de projetos e informações da cadeia de suprimentos em tempo real.
O Importador de Bibliotecas oferece um modo de interface Simple minimalista, no qual as bibliotecas de componentes selecionadas, baseadas em arquivos ou bancos de dados, são importadas como componentes do Workspace em uma única etapa, enquanto o importador cuida automaticamente da classificação por tipo, da pasta de origem de destino, da inclusão de parâmetros e do tipo de valor, além da transferência de todos os dados relevantes. A interface também está disponível em um modo Advanced que oferece uma prévia completa da importação proposta e acesso aos dados e às configurações relacionados. E, embora a importação seja um processo de um único clique por padrão, o importador também oferece opções de configuração avançadas por meio do painel Propriedades, para maior controle sobre a forma exata como a importação é realizada.
O que é importado?
Todas as informações presentes na biblioteca de origem são importadas para os componentes do Workspace, incluindo todos os modelos de domínio referenciados (símbolos esquemáticos, footprints de PCB, modelos de simulação), informações paramétricas, opções de peças atribuídas, arquivos de folhas de dados etc. Modelos de componentes também são criados quando necessário e podem ser refinados e usados em importações de bibliotecas posteriores.
Se seus componentes originais tiverem vários footprints de PCB definidos, o Importador de Bibliotecas transferirá esses modelos e manterá o footprint padrão atual. E, se você trabalha apenas com bibliotecas de PCB – sua única preocupação é o layout de PCB –, o Importador de Bibliotecas permite importar somente essas bibliotecas ou pode ser alternado para um modo de importação apenas de modelos, no qual os tipos de modelos especificados são importados de bibliotecas integradas ou de bancos de dados. Bibliotecas que incluem vários tipos de componentes (bibliotecas monolíticas) também são detectadas e processadas automaticamente.
Embora o processo de importação de bibliotecas precise lidar com fontes de bibliotecas baseadas em arquivos e bancos de dados que podem usar diversos padrões de formatação, seus processos de análise automatizada detectam os tipos de componentes na biblioteca de origem (resistor, capacitor etc.), bem como os nomes dos parâmetros e seus tipos de valor (Volts, Ohms etc.). O sistema realiza e gerencia uma série de validações, por exemplo, para garantir que não haja IDs duplicados nos componentes resultantes da biblioteca do Workspace ou que não sejam criados modelos ou modelos de componentes duplicados, e que essas entidades sejam reutilizadas entre os componentes (vinculadas a eles) quando necessário. E, se surgirem problemas, o sistema os sinaliza e apresenta sugestões de como resolvê-los, buscando retomar a importação da maneira mais rápida e tranquila possível.
Os tipos de bibliotecas que podem ser importados são:
-
Biblioteca de esquemáticos (
*.SchLib). -
Biblioteca de footprints de PCB (
*.PcbLib). -
Biblioteca integrada (
*.IntLib) -
Biblioteca de banco de dados (
*.DbLib). -
Biblioteca de banco de dados SVN (
*.SVNDbLib).
Acesso ao Importador de Bibliotecas
O Importador de Bibliotecas está disponível quando você está conectado a um Workspace. Para acessar o importador no modo Simple :
-
No painel Componentes, escolha a opção Import Library no menu
. Se uma biblioteca baseada em arquivos ou banco de dados estiver selecionada na coluna Categories do painel (ou no menu suspenso superior quando o painel estiver no modo compacto), o Importador de Bibliotecas será aberto para essa biblioteca. Quando um tipo de componente da biblioteca do Workspace estiver selecionado, a caixa de diálogo padrão Open do Windows será aberta para localizar e selecionar um arquivo de biblioteca a ser importado.
-
Clique com o botão direito em um arquivo de biblioteca no painel Projetos e selecione Import Library no menu de contexto.
-
Selecione Tools » Import Library no editor de símbolos esquemáticos ou de footprints de PCB quando um arquivo de biblioteca local estiver aberto.
-
Selecione File » Import Library ou Tools » Import Library no Editor de Bibliotecas de Banco de Dados.
-
Na caixa de diálogo Preferências de Bibliotecas, selecione uma entrada de biblioteca na guia Installed e clique no controle Import .
-
Arraste um arquivo de biblioteca de uma pasta do Windows e solte-o no painel Explorador.
O modo Simples oferece opções para importar imediatamente a biblioteca selecionada ou abrir o Importador de Bibliotecas no modo de interface gráfica completa

O Importador de Bibliotecas quando acessado no modo Simple de importação com um clique.
Para acessar diretamente o Importador de Bibliotecas no modo de interface Advanced, selecione File » Library Importer no menu principal.

O Importador de Bibliotecas, quando acessado no modo de interface Advanced completa, também permite um processo de importação com um clique.
Modo Simples
O modo Simples do Importador de Bibliotecas pré-seleciona todos os aspectos do processo de importação com base na análise da biblioteca de origem e do Workspace conectado. A caixa de diálogo Library Importer apresenta então um resumo da estrutura de importação, incluindo a contagem total de cada tipo de item. A importação da biblioteca é realizada em uma única etapa pelo comando
.
Esse modo de interface Simples atende aos formatos de bibliotecas de origem mais comuns, que tendem a conter tipos de componentes comuns (resistores, capacitores, circuitos integrados etc.) e valores de parâmetros padronizados. Durante o processo de análise inicial, o sistema deduz o tipo dos componentes da biblioteca com base no designador ou em palavras-chave dos parâmetros (LD?, LED etc.) e, em seguida, localiza um modelo de componente correspondente no Workspace de destino (LED). Esse modelo é aplicado à importação desses componentes, definindo as configurações de importação, como pasta de destino (Components/LED), mapeamento de parâmetros, unidades dos valores dos parâmetros e assim por diante – modelos adequados estarão disponíveis no Workspace se a opção de incluir dados de exemplo tiver sido selecionada durante a ativação de um Workspace do Altium 365 ou a instalação do Altium On-Prem Enterprise Server.
Os resultados da importação da biblioteca, na forma de componentes recém-criados no Workspace, podem ser vistos nos painéis Explorer e Components. Os componentes importados incluem todos os modelos, os parâmetros conforme interpretados pelos Modelos de Componente aplicados, as Opções de Peças derivadas dos dados de origem dos Links de Fornecedor e quaisquer links ou arquivos de referência.
Alguns pontos importantes sobre o processo de importação de bibliotecas:
-
Bibliotecas monolíticas (aquelas que contêm vários tipos de componentes) são divididas automaticamente em subgrupos, nos quais cada grupo representa um tipo de componente encontrado na biblioteca. Os grupos são processados como bibliotecas individuais.
-
Uma biblioteca de origem com um tipo de componente não reconhecido (não detectado) será importada sem interpretação, com tipos de componentes não atribuídos, em uma pasta
Components/Uncategorizeddo Workspace. Antes de executar a importação, isso pode ser resolvido aplicando o Mapeamento de Designadores ou o Agrupamento por Parâmetros no modo Advanced (interface completa). Como alternativa, você pode prosseguir com a importação e modificar as configurações e a pasta do componente posteriormente, por meio do painel Explorer. - O processo de importação de bibliotecas inclui uma etapa automática de Validação dos componentes. Os componentes que gerarem um erro de validação serão ignorados.
- Se forem detectados modelos duplicados na biblioteca de origem a ser importada, apenas um desses modelos será importado e vinculado aos componentes resultantes no Workspace de destino. Uma notificação correspondente será exibida na parte superior da caixa de diálogo Library Importer.
-
Quaisquer erros encontrados durante o processo poderão ser visualizados em Importing Report, disponível pelo botão
quando a importação for concluída.
Modo avançado
A interface gráfica completa do Importador de Bibliotecas é apresentada no modo Advanced, que oferece controle detalhado sobre o gerenciamento de bibliotecas, tipos de componentes e parâmetros de componentes. Em conjunto com o painel Properties, a importação de bibliotecas de componentes para o Workspace pode ser configurada de acordo com suas necessidades específicas. Observe que as configurações do importador podem ser salvas e restauradas por meio da exportação/importação de arquivos de configuração.
O modo avançado é ativado quando o Importador de Bibliotecas é aberto pelo comando File » Library Importer ou quando o botão
é selecionado no modo simples. As bibliotecas são adicionadas à seção SOURCE LIBRARIES do importador (se ainda não estiver preenchida) arrastando e soltando um arquivo de biblioteca na área, clicando com o botão direito em <All Libraries> e selecionando Add Library no menu de contexto ou selecionando o botão
.
A seção Import Preview lista os grupos de tipos de componentes identificados nas bibliotecas de origem — como Types ou o Folder Structure proposto — e inclui uma visualização em grade desses componentes baseada em parâmetros (Components). Os valores dos parâmetros na grade podem ser editados diretamente, evitando a necessidade de abrir e editar a biblioteca de origem. A área inferior Details inclui informações adicionais provenientes do componente selecionado no momento — Opções de Peças, Modelos e Folhas de Dados.
Independentemente das opções detalhadas e dos dados apresentados na interface, a visualização avançada do importador pode ser usada da mesma forma que a visualização simples — basta clicar no botão
para iniciar o processo de importação, sem intervenção. Assim como no processo da visualização simples, o importador já analisou a biblioteca, deduziu o tipo dos componentes que ela contém e aplicou o Modelo de Componente correto. Por sua vez, o modelo determina a pasta de destino no Workspace, os Esquemas de Nomenclatura e as Definições de Ciclo de Vida aplicados e o mapeamento/interpretação dos parâmetros.
Bibliotecas monolíticas
As bibliotecas de origem que contêm vários tipos de componentes são detectadas pelas rotinas de análise do importador e separadas em grupos de sub-bibliotecas, nos quais podem ser processadas como bibliotecas individuais por tipo. A detecção do tipo de componente se baseia nos Designadores dos componentes de origem (R?, C? etc.) e também em palavras-chave (Resistor, Res etc.) contidas nos outros parâmetros principais dos componentes (Descrição, ID etc.).
No exemplo mostrado abaixo, a biblioteca de origem (ProjectABC.IntLib) foi “dividida” automaticamente de acordo com os tipos de componentes detectados (Capacitores, Resistores etc.), que podem ser selecionados na coluna Folder Structure (ou na coluna Types) para visualizar as entradas dos componentes que os compõem na grade Components.
Observe que a apresentação da listagem Components pode ser alterada de várias maneiras:
-
Clique em um cabeçalho de coluna para reordenar a lista por essa coluna de parâmetro e clique novamente para inverter a ordem.
-
No menu de contexto acessado ao clicar com o botão direito no cabeçalho:
-
Escolha Clear Sorting para restaurar a ordenação padrão da listagem (pela coluna Name em ordem crescente).
-
Escolha Best Fit para ajustar a largura de uma coluna específica ao seu conteúdo.
-
Escolha Select Best Fit All Columns para ajustar a largura de todas as colunas disponíveis ao seu conteúdo.
-
Escolha Select Columns para acessar a caixa de diálogo Select Columns, na qual as colunas de parâmetros podem ser habilitadas, desabilitadas e reordenadas na lista.
-
-
Clique no ícone de filtro de um cabeçalho para restringir a listagem a um valor disponível na coluna de parâmetro, a valores vazios/não vazios ou a uma configuração de filtro Custom. O filtro aplicado é mostrado na parte inferior da listagem, onde pode ser habilitado/desabilitado (usando a caixa de seleção associada), modificado em Filter Editor ou excluído. Selecionar All pelo ícone de filtro do cabeçalho também removerá o filtro aplicado.
Componentes não categorizados
Se uma entrada de subgrupo de biblioteca tiver o nome Uncategorized (e estiver listada como Uncategorized em Types ou Folder Structure e acompanhada de
ícone), isso indica que o importador não conseguiu detectar e atribuir um tipo a esse grupo de componentes – o Tipo de componente está efetivamente definido como None. Neste caso, os componentes não detectados (CIs de lógica inversora) usam um prefixo de designador não reconhecido (U?) e seus parâmetros não contêm palavras-chave detectadas, como IC, logic etc.
Esse problema pode ser resolvido mapeando manualmente os designadores usados nesses componentes para o tipo de componente desejado na caixa de diálogo Library Splitting, acessada pelo botão
– disponível quando a biblioteca de origem (ProjectABC.IntLib) está selecionada. A caixa de diálogo Library Splitting, com os valores padrão, oferece controles para definir opções personalizadas de agrupamento de bibliotecas para componentes não categorizados, com base no mapeamento de designadores por tipos de componente e na divisão baseada em parâmetros.
Com a opção Map Designators da caixa de diálogo selecionada, escolha a opção de tipo de componente aplicável aos componentes não categorizados na lista suspensa Component Type (todos os tipos de componente disponíveis estão incluídos). Confirme o mapeamento entre tipo e designador (o tipo de componente Logic para os designadores U?) com o botão
.
Com o tipo de componente agora especificado pelo mapeamento aplicado, o importador usará o Modelo de componente correspondente (Logic) para configurar a importação da biblioteca conforme definido nas configurações do modelo (pasta, nomenclatura etc.).
Observe que, graças à flexibilidade das configurações do Importador de bibliotecas, um novo tipo de biblioteca de componentes (não categorizado) pode ser importado com toda a infraestrutura necessária para futuras importações desse tipo de biblioteca. Ao escolher uma configuração de importação adequada – novo Tipo de componente, Modelo de componente, pasta de destino, mapeamento de parâmetros e tipos de unidade dos valores dos parâmetros –, o único requisito para a próxima importação desse tipo de biblioteca será selecionar o Tipo de componente definido anteriormente. O Tipo de componente selecionado determinará, então, todos os outros aspectos da importação.
Excluir do importador
Você também pode excluir tipos específicos de componente da importação. Para excluir um tipo de componente, na lista Types, clique com o botão direito no tipo de componente que deseja excluir e selecione Exclude from Importer no menu de contexto – altere a listagem da coluna de Folder Structure para Types, se desejar
O tipo de componente excluído ficará esmaecido na lista Types. Para visualizar os componentes excluídos na grade, clique em Show Excluded Component (n), em que n indica o número de componentes excluídos.
Incluir no importador
Se você excluiu um tipo de componente da importação usando o comando Exclude from Importer descrito acima e precisar incluí-lo novamente, clique com o botão direito no tipo de componente esmaecido na lista Types (ou Folder Structure) e selecione Include to Importer no menu de contexto. O tipo de componente voltará a ser exibido na lista Types, indicando que não está excluído.
Erros e avisos de validação
Os componentes que não serão importados corretamente para o Workspace, ou que não serão importados, são indicados por marcadores de aviso ou erro na interface avançada quando o Importador de bibliotecas é executado ou quando uma Validação da importação é realizada A validação também verifica caminhos de pasta do Workspace vazios, parâmetros de sistema conflitantes e modelos duplicados. Um erro fatal bloqueará a importação.
Ao tentar realizar a importação, o painel Messages é preenchido com as violações detectadas, e uma caixa de diálogo oferece a opção de abandonar ou prosseguir com a configuração de importação atual. Neste último caso, os componentes inválidos não serão importados ou o processo de importação falhará.
No caso de uma importação cancelada ou quando a Validação manual é executada, todos os componentes que não passarem nas verificações de importação serão associados a ícones de erro/aviso, com informações adicionais na área inferior Details. Os ícones na coluna de visualização Status indicam as entradas específicas de componentes que violam as regras de verificação da importação.
As verificações de validação predefinidas disponíveis estão listadas abaixo.
A descrição do componente é muito longa
Report mode:
Resumo
Essa violação ocorre quando a descrição de um componente a ser importado tem mais de 256 caracteres.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
<ComponentName> description more then 256 characters.
em que:
-
ComponentNameé o nome do componente que apresenta a violação.
Recomendação para resolução
Edite a descrição do componente na biblioteca de origem para que ela não exceda o limite de comprimento.
Erros no modelo de componente
Report mode:
Resumo
Essa violação ocorre quando há um erro em um modelo de componente aplicado aos componentes a serem importados.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Component template has errors: <Descripion>
em que:
-
Descripioné a descrição do erro no modelo de componente.
Recomendação para resolução
Com base na descrição do erro, localize e corrija o erro na biblioteca de origem ou na configuração de importação da biblioteca.
HRID de componente duplicado
Report mode:
Resumo
Essa violação ocorre quando os IDs de item dos componentes a serem importados são iguais.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
<ComponentName1> component HRID is duplicated with <ComponentName2> component HRID.
em que:
-
ComponentName1eComponentName2são os nomes dos componentes que apresentam a violação.
Recomendação para resolução
Na região Parameter Mapping do painel Properties, certifique-se de que o parâmetro ID esteja mapeado para um parâmetro da biblioteca de origem que tenha valores exclusivos para os componentes que apresentam a violação. Você também pode definir o mapeamento desse parâmetro como <Auto> – nesse caso, os IDs de item dos componentes serão definidos automaticamente com base no Naming Scheme especificado na região Component do painel (na aba Advanced).
Como alternativa, certifique-se de que o parâmetro selecionado para o ID do item tenha valores exclusivos para cada componente com essa violação na biblioteca de origem.
Geometria de modelo duplicada
Report mode:
Resumo
Esta violação ocorre quando os componentes a serem importados têm modelos de símbolos com a mesma geometria nas bibliotecas de origem.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
<SymbolModelName1> model has the same geometry as <SymbolModelName2> in your source library. Imported components will be linked to <SymbolModelName2>
onde:
-
SymbolModelName1eSymbolModelName2são os nomes dos modelos de símbolos com essa violação.
HRID do componente vazio
Report mode:
Resumo
Esta violação ocorre quando o ID do item de um componente a ser importado está vazio.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
<ComponentName> component HRID is empty.
onde:
-
ComponentNameé o nome do componente com essa violação.
Recomendação para resolução
Na região Parameter Mapping do painel Properties, certifique-se de que o parâmetro ID esteja mapeado para um parâmetro da biblioteca de origem que tenha um valor para o componente com essa violação. Você também pode definir o mapeamento desse parâmetro como <Auto> – nesse caso, o ID do item do componente será definido automaticamente com base no Naming Scheme especificado na região Component do painel (na aba Advanced).
Como alternativa, certifique-se de que o parâmetro selecionado tenha um valor na biblioteca de origem.
As configurações da entidade têm a definição de ciclo de vida vazia
Report mode:
Resumo
Esta violação ocorre quando uma biblioteca de origem inclui conteúdo cujo tipo não está associado a uma definição de ciclo de vida.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
<ContentType> entity settings in library <LibraryName>.<LibraryType> have empty Lifecycle Definition.
onde:
-
ContentTypeé o tipo de conteúdo (por exemplo, componente ou símbolo) que não está associado a uma definição de ciclo de vida. -
LibraryNameé o nome da biblioteca de origem que inclui conteúdo cujo tipo não está associado a uma definição de ciclo de vida. -
LibraryTypeé o nome do grupo de sub-bibliotecas que inclui conteúdo cujo tipo não está associado a uma definição de ciclo de vida.
Recomendação para resolução
Certifique-se de que uma definição de ciclo de vida esteja selecionada na lista suspensa Lifecycle Definition para o tipo de conteúdo com essa violação no painel Properties (na aba Advanced). Se houver opções disponíveis na lista suspensa, certifique-se de que o tipo de conteúdo com essa violação esteja associado a uma definição de ciclo de vida. Consulte a página Como definir definições de ciclo de vida para um Workspace para saber mais.
As configurações da entidade têm o esquema de nomenclatura de revisões vazio
Report mode:
Resumo
Esta violação ocorre quando uma biblioteca de origem inclui conteúdo cujo tipo não está associado a um esquema de nomenclatura de revisões.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
<ContentType> entity settings in library <LibraryName>.<LibraryType> have empty Revision Naming Scheme.
onde:
-
ContentTypeé o tipo de conteúdo (por exemplo, componente ou símbolo) que não está associado a um esquema de nomenclatura de revisões. -
LibraryNameé o nome da biblioteca de origem que inclui conteúdo cujo tipo não está associado a um esquema de nomenclatura de revisões. -
LibraryTypeé o nome do grupo de sub-bibliotecas que inclui conteúdo cujo tipo não está associado a um esquema de nomenclatura de revisões.
Recomendação para resolução
Certifique-se de que uma definição de ciclo de vida esteja selecionada na lista suspensa Esquema de nomenclatura de revisões para o tipo de conteúdo com essa violação no painel Properties (na aba Advanced). Se houver opções disponíveis na lista suspensa, certifique-se de que o tipo de conteúdo com essa violação esteja associado a um esquema de nomenclatura de revisões. Consulte a página Como definir esquemas de nomenclatura de revisões para um Workspace para saber mais.
A pasta não existe
Report mode:
Resumo
Esta violação ocorre quando uma pasta para a qual o conteúdo será importado não existe no Workspace conectado.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Folder '<FolderPath>' does not exist
onde:
-
FolderPathé um caminho para a pasta de destino que não existe no Workspace conectado.
Recomendação para resolução
No painel Properties, especifique uma pasta de destino clicando no botão
à direita do campo Folder para o conteúdo que será salvo no Workspace. Na caixa de diálogo Choose Folder que se abre, navegue até uma pasta existente e selecione-a ou crie uma nova na hora.
Footprint não encontrado nas bibliotecas disponíveis
Report mode:
Resumo
Esta violação ocorre quando um componente tem um footprint vinculado que não pode ser encontrado nas bibliotecas disponíveis.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Footprint <FootprintName> is not found in available libraries. Any referenced footprints can only be found if the relevant PcbLib(s) are either installed, or are added to the Library Importer directly.
onde:
-
FootprintNameé o nome do footprint ausente.
Recomendação para resolução
Adicione as bibliotecas que contêm footprints vinculados ao Importador de bibliotecas. Isso pode ser feito clicando no controle Choose a Library na região Details quando um componente com essa violação estiver selecionado na região Components.
Como alternativa, certifique-se de que as bibliotecas que contêm footprints vinculados aos componentes a serem importados estejam instaladas (consulte a página Como pesquisar componentes em bibliotecas baseadas em banco de dados e arquivos para saber mais sobre bibliotecas instaladas) ou edite o vínculo com o footprint na biblioteca de origem.
Consulte a seção Importação de bibliotecas de esquemáticos para saber mais.
Mapeamento de parâmetros inválido
Report mode:
Resumo
Esta violação ocorre quando há um erro na configuração do mapeamento de parâmetros.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Parameter mapping in library <LibraryName>.<LibraryType> has error: <Descripion>
onde:
-
LibraryNameé o nome da biblioteca de origem na qual se encontra um componente com mapeamento incorreto de parâmetros. -
LibraryTypeé o nome do grupo de subbibliotecas no qual se encontra um componente com mapeamento incorreto de parâmetros. -
Descripioné a descrição da violação de mapeamento de parâmetros.
Recomendação para resolução
Na região Parameter Mapping do painel Properties, localize os parâmetros com o ícone
e atualize o mapeamento conforme necessário. Como alternativa, remova as entradas de mapeamento com erros.
Item com HRID já liberado
Report mode:
Resumo
Esta violação ocorre quando o ID do item de um componente a ser importado é igual ao ID de um item que já existe no Workspace de destino.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Item with HRID <ItemID> already released.
onde:
-
ItemIDé o ID usado para um item no Workspace.
Recomendação para resolução
Na região Parameter Mapping do painel Properties, certifique-se de que o parâmetro ID esteja mapeado para um parâmetro da biblioteca de origem que tenha um valor exclusivo. Você também pode definir o mapeamento desse parâmetro como <Auto> – nesse caso, o ID do item do componente será definido automaticamente com base no Naming Scheme especificado na região Component do painel (na aba Advanced). Nesse caso, certifique-se de que o Naming Scheme esteja configurado para gerar IDs de item exclusivos.
Como alternativa, certifique-se de que o parâmetro selecionado para o ID do item tenha um valor exclusivo na biblioteca de origem.
Definição de ciclo de vida para importar folhas de dados não encontrada
Report mode:
Resumo
Esta violação ocorre quando uma biblioteca de origem inclui componentes com folhas de dados vinculadas e o tipo de conteúdo Datasheet não está associado a uma definição de ciclo de vida.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Lifecycle Definition to import <LibraryName>.<LibraryType> library datasheets is not found.
onde:
-
LibraryNameé o nome da biblioteca de origem cujos componentes incluem folhas de dados. -
LibraryTypeé o nome do grupo de subbibliotecas cujos componentes incluem folhas de dados.
Recomendação para resolução
Certifique-se de que o tipo de conteúdo Datasheet esteja associado a uma definição de ciclo de vida. Consulte a página Definição de ciclos de vida para um Workspace para saber mais.
Como alternativa, desative a importação de arquivos de folhas de dados alterando a opção Migrate na região Datasheet do painel Properties (na aba Advanced).
A descrição do modelo é muito longa
Report mode:
Resumo
Esta violação ocorre quando a descrição de um modelo de componente tem mais de 256 caracteres.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Description of Model '<ModelName>' of component '<ComponentName>' more then 256 characters.
onde:
-
ModelNameé o nome do modelo com erro. -
ComponentNameé o nome do componente que inclui o modelo com erro.
Recomendação para resolução
Edite a descrição do modelo na biblioteca de origem para que ela não exceda o limite de comprimento.
O valor do parâmetro obrigatório está vazio
Report mode:
Resumo
Esta violação ocorre quando o template de componente vinculado tem um parâmetro marcado como obrigatório e esse parâmetro não tem valor na biblioteca de origem.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
<ParameterName> required parameter value in component <ComponentName> is empty.
onde:
-
ParameterNameé o nome do parâmetro com erro. -
ComponentNameé o nome do componente que inclui o parâmetro com erro.
Recomendação para resolução
Adicione um valor ao parâmetro com erro na biblioteca de origem ou diretamente no Importador de bibliotecas, na área da grade. Como alternativa, edite o mapeamento de parâmetros na região Parameter Mapping do painel Properties (na aba General) para que o parâmetro obrigatório seja mapeado para um parâmetro da biblioteca de origem que tenha um valor.
Esquema de nomenclatura de revisões para importar folhas de dados não encontrado
Report mode:
Resumo
Esta violação ocorre quando uma biblioteca de origem inclui componentes com folhas de dados vinculadas e o tipo de conteúdo Datasheet não está associado a um esquema de nomenclatura de revisões.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Revision Naming Scheme to import <LibraryName>.<LibraryType> library datasheets is not found.
onde:
-
LibraryNameé o nome da biblioteca de origem cujos componentes incluem folhas de dados. -
LibraryTypeé o nome do grupo de subbibliotecas cujos componentes incluem folhas de dados.
Recomendação para resolução
Certifique-se de que o tipo de conteúdo Datasheet esteja associado a um esquema de nomenclatura de revisões. Consulte a página Definição de esquemas de nomenclatura de revisões para um Workspace para saber mais.
Como alternativa, desative a importação de arquivos de folhas de dados alterando a opção Migrate na região Datasheet do painel Properties (na aba Advanced).
Arquivo de modelo de simulação não encontrado
Report mode:
Resumo
Esta violação ocorre quando um componente tem um modelo de simulação vinculado que não pode ser encontrado no caminho especificado.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Simulation model file <Path> is not found.
onde:
-
Pathé o caminho especificado para o modelo de simulação.
Recomendação para resolução
Certifique-se de que o modelo de simulação esteja localizado no caminho especificado. Como alternativa, atualize o caminho para o modelo na biblioteca de origem.
O nome do símbolo não pode estar vazio
Report mode:
Resumo
Esta violação ocorre quando um componente não tem um símbolo vinculado.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Symbol name cannot be empty.
Recomendação para resolução
Certifique-se de que um vínculo com um símbolo esteja definido corretamente para o componente na biblioteca de origem.
Você não tem permissão de acesso para modificar a pasta
Report mode:
Resumo
Esta violação ocorre quando você não tem permissões de gravação em uma pasta de destino no Workspace conectado.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
You do not have access right to modify folder <FolderPath>.
onde:
-
FolderPathé o caminho para a pasta de destino no Workspace conectado para a qual você não tem direitos de edição.
Recomendação para resolução
Peça a um administrador do seu Workspace que conceda a você permissões de gravação na pasta (consulte a página Controle de acesso ao conteúdo do Workspace para saber mais).
Como alternativa, use o painel Properties para selecionar outra pasta na qual você tenha permissões de gravação. Clique no botão
à direita do campo Folder do conteúdo que será salvo no Workspace e, na caixa de diálogo Choose Folder que será aberta, navegue até uma pasta existente e selecione-a ou crie uma nova.
As verificações definidas pelo usuário são configuradas na região Import Checks do painel Properties. Use o menu suspenso Report Mode para escolher um nível de relatório diferente para o tipo de violação associado. Essas verificações estão listadas abaixo.
Componente duplicado por parâmetro
Default report mode:
Resumo
Esta violação ocorre quando um componente das bibliotecas de origem a serem importadas tem o valor de um parâmetro definido como exclusivo e um componente no Workspace de destino tem o mesmo valor para esse parâmetro. Consulte a seção Detecção de duplicatas para saber mais.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Component <ComponentName> is duplicated with components by parameter <ParameterName> (<ParameterValue>):
- Server components: <WorkspaceComponentList>
onde:
-
ComponentNameé o nome do componente que apresenta a violação. -
ParameterNameé o nome do parâmetro definido como exclusivo. -
ParameterValueé o valor do parâmetro definido como exclusivo. -
WorkspaceComponentListé a lista de IDs de item-revisão dos componentes no Workspace de destino que têm valores duplicados de parâmetros definidos como exclusivos.
Recomendação para resolução
Verifique os parâmetros dos componentes na biblioteca de origem a ser importada e certifique-se de que o parâmetro correto esteja selecionado como exclusivo no menu suspenso Unique Field da aba Advanced do painel Properties.
Se o componente a ser importado for o mesmo que já existe no Workspace de destino, ele poderá ser excluído da migração – saiba mais.
Componente duplicado por opções de peças
Default report mode:
Resumo
Esta violação ocorre quando o Workspace de destino inclui um componente que tem a mesma opção de peça que um componente nas bibliotecas de origem a serem importadas. Consulte a seção Detecção de duplicatas para saber mais.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Component <ComponentName> is duplicated with components by Part Choices:
- Server components: <WorkspaceComponentList> (<Manufacturer> <PartNumber>)
onde:
-
ComponentNameé o nome do componente que apresenta a violação. -
WorkspaceComponentListé a lista de IDs de item-revisão dos componentes no Workspace de destino que têm a mesma opção de peça que o componente em uma biblioteca de origem a ser importada. -
Manufactureré o parâmetro de fabricante da opção de peça duplicada. -
PartNumberé o parâmetro de código da peça da opção de peça duplicada.
Recomendação para resolução
Verifique os parâmetros dos componentes na biblioteca de origem a ser importada e certifique-se de que os mapeamentos dos parâmetros das opções de peças (listados na região Part Choices Mapping da aba General do painel Properties) estejam corretos.
Se o componente a ser importado for o mesmo que já existe no Workspace de destino, ele poderá ser excluído da migração – saiba mais.
Modelo de componente duplicado
Atualmente, essa verificação não é realizada pela funcionalidade de validação do Importador de bibliotecas.
Tipo de componente indefinido
Default report mode:
Resumo
Esta violação ocorre quando há um componente não categorizado, ou seja, um componente sem um tipo de componente atribuído.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
<ComponentName> component type is undefined.
onde:
-
ComponentNameé o nome do componente que apresenta a violação.
Recomendação para resolução
Atribua um tipo de componente ao componente não categorizado. Consulte a seção Componentes não categorizados para saber mais.
Folha de dados não encontrada
Default report mode:
Resumo
Esta violação ocorre quando uma folha de dados não pode ser encontrada pelo link definido em um componente na biblioteca de origem.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Datasheet <Path> is not found.
onde:
-
Pathé o caminho para a folha de dados definido no componente na biblioteca de origem.
Recomendação para resolução
Localize e restaure o arquivo da folha de dados ausente no local esperado. Como alternativa, desative a importação de arquivos de folhas de dados alterando a opção Migrate na região Datasheet do painel Properties (na aba Advanced).
Importação de mapeamento de pinos não suportada
Default report mode:
Resumo
Esta violação ocorre quando um componente na biblioteca de origem tem um mapeamento de pinos personalizado.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Import for <ComponentName> component pin mapping is not supported.
onde:
-
ComponentNameé o nome do componente que apresenta a violação.
Recomendação para resolução
Após a importação, você pode verificar o mapeamento de pinos e configurá-lo conforme necessário ao editar o componente no Editor de componentes, no modo de edição de componente único – saiba mais.
Valor de parâmetro inválido
Default report mode:
Resumo
Esta violação ocorre quando o valor de um parâmetro do componente não pode ser interpretado como um valor válido do tipo de unidade especificado.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
<ParameterName> parameter value <ParameterValue> in component <ComponentName> cannot be converted to unit of type <UnitType>.
onde:
-
ParameterNameé o nome do parâmetro do componente que apresenta a violação. -
ParameterValueé o valor do parâmetro do componente que apresenta a violação. -
ComponentNameé o nome do componente que tem o parâmetro que apresenta a violação. -
UnitTypesão as unidades de medida atualmente definidas para o parâmetro que apresenta a violação.
Recomendação para resolução
Edite o valor do parâmetro problemático na área de grade do Importador de Bibliotecas para um formato válido. Como alternativa, altere a unidade do parâmetro mapeado Type, conforme determinado pelo modelo de componente aplicado, para não interpretado Text na região Parameter Mapping do painel Properties (na aba General) quando a biblioteca de origem estiver selecionada.
Mapeamento inválido de opção de peça
Default report mode:
Resumo
Esta violação ocorre quando há um erro na configuração do mapeamento de opções de peças.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
Part Choice mapping in library <LibraryName>.<LibraryType> has error: <Descripion>
onde:
-
LibraryNameé o nome da biblioteca de origem na qual foi encontrado um componente com mapeamento incorreto de opções de peças. -
LibraryTypeé o nome do grupo de subbibliotecas no qual foi encontrado um componente com mapeamento incorreto de opções de peças. -
Descripioné a descrição da violação de mapeamento de opções de peças.
Recomendação para resolução
Na região Part Choices Mapping do painel Properties, localize os parâmetros com o ícone
e atualize o mapeamento conforme necessário. Como alternativa, remova as entradas de mapeamento com erros.
Nome de parâmetro duplicado em relação a um parâmetro do sistema
Default report mode:
Resumo
Esta violação ocorre quando um componente na biblioteca de origem inclui um parâmetro com o mesmo nome de um parâmetro do sistema. Esses parâmetros são os seguintes:
-
AncestorItemRevisionGUID -
Cat -
ComponentType -
ContentType -
ContentTypeGUID -
CreatedAt -
CreatedBy -
CreatedByGUID -
DynamicData -
Folder -
FolderGuid -
Hrid -
Id -
ItemDescription -
ItemGUID -
ItemHRID -
LatestRevision -
LifeCycle -
LifecycleStateGUID -
ModifiedBy -
ReleaseDate -
ReleaseDateNum -
ReleaseNote -
RevisionId -
RevisionNamingSchemeGUID -
SourceGUID -
SourceVaultGUID -
Text -
Updated -
UpdatedByGUID
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
'<ParameterName>' is system parameter
onde
-
ParameterNameé o nome do parâmetro problemático do componente.
Recomendação para resolução
Remova a entrada de mapeamento do parâmetro problemático da região Parameter Mapping do painel Properties (na aba General). Como alternativa, remova o parâmetro problemático do componente na biblioteca de origem ou renomeie-o.
Parâmetros de simulação são ignorados
Default report mode:
Resumo
Esta violação ocorre quando um componente na biblioteca de origem tem um modelo de simulação vinculado.
Notificação
Uma notificação é exibida no painel Messages no seguinte formato:
<ComponentName> component simulation parameters are skipped (<SimulationParameterList>).
onde:
-
ComponentNameé o nome do componente problemático na biblioteca de origem. -
SimulationParameterListé uma lista, separada por vírgulas, de parâmetros de simulação que serão ignorados durante a importação.
Recomendação para resolução
Após a importação, você pode configurar o vínculo com o modelo de simulação conforme necessário ao editar o componente no editor de componentes em seu modo de edição de componente único – saiba mais.
Resolução de erros e avisos
Erros de parâmetros, como no exemplo mostrado aqui, em que o valor Forward Voltage do componente não pode ser interpretado como uma tensão válida, podem ser resolvidos das seguintes formas:
-
Editando o valor do parâmetro problemático – localize e edite sua célula para um formato válido.
-
Alterando a unidade do parâmetro mapeado Type, conforme determinado pelo modelo de componente aplicado, de
Voltagepara não interpretadoText– selecione a biblioteca de origem na interface do importador e, em seguida, altere oForward VoltageType na lista do painel Propriedades Parameter Mapping (na aba General). -
Removendo o componente do processo de importação – clique com o botão direito na entrada correspondente e escolha a opção Exclude from Importer .
Um erro de arquivo ausente, como o arquivo de folha de dados não localizado mostrado aqui, pode ser resolvido das seguintes formas:
- A solução óbvia de localizar e restaurar o arquivo ausente no local esperado.
- Desativando a importação de arquivos de folhas de dados – altere a opção Migrate na seção do painel Propriedades Datasheet (na aba Advanced).
- Excluindo o componente do processo de importação da biblioteca – conforme descrito acima.
Use o campo Search (no canto superior direito) se desejar encontrar entradas de componentes específicas. A pesquisa filtra a lista de itens pelos valores de parâmetros correspondentes ao tipo de componente selecionado no momento – selecione All em Types (Folder Structure) para que a pesquisa se aplique a todos os componentes nas bibliotecas de origem disponíveis.
Importação de biblioteca de esquemáticos
Se você encontrar um erro de “modelo não encontrado” (como Footprint <footprint name> not found in available libraries) ao tentar importar uma biblioteca de esquemáticos, isso significa que o Importador de Bibliotecas não consegue localizar os modelos vinculados aos componentes no SCHLIB.
No Modo Simples, esses erros serão exibidos no Importing Report baseado em HTML, acessível pelo botão
, que fica disponível após a execução da importação. No Modo Avançado, os erros são indicados por ícones de status na interface principal e como entradas no painel Messages – isso ocorre ao executar uma verificação de validação ou ao tentar importar a biblioteca
Os footprints ausentes são detectados corretamente pelo processo de validação, que também fornece uma opção Choose a Library em seu relatório de erros (no menu suspenso Details). Caso mais de um footprint de componente tenha sido detectado como ausente, uma caixa de diálogo Apply PcbLib Selection oferece opções para usar a PcbLib especificada para essa instância ou para todos os componentes com footprints ausentes.
Outra forma de resolver (ou evitar) esse problema é garantir que os arquivos de biblioteca de modelos necessários estejam disponíveis no Altium Designer. As bibliotecas são instaladas pela página Gerenciamento de dados – Bibliotecas baseadas em arquivos da caixa de diálogo Preferences.
Como alternativa, se você não desejar instalar várias bibliotecas de modelos, será necessário colocá-las no caminho padrão de bibliotecas do software (ou editar o caminho) e verificar se a biblioteca de origem dos modelos está especificada para os componentes da biblioteca de esquemáticos:
- Inclua a biblioteca de modelos no local do caminho de pesquisa padrão do software. Adicione a biblioteca de modelos, como uma biblioteca de PCB correspondente, ao local especificado pelo caminho padrão de bibliotecas do sistema. Para verificar esse local, consulte a entrada Library Path na página Sistema – Locais padrão da caixa de diálogo Preferences. Se um arquivo de biblioteca tiver sido adicionado/copiado para esse caminho, talvez seja necessário reiniciar o Altium Designer para registrar a alteração.
-
Especifique o nome da biblioteca de modelos de destino para os componentes da biblioteca de esquemáticos. Para que a biblioteca de modelos vinculada a um componente da biblioteca de esquemáticos seja reconhecida pelo Importador de Bibliotecas, especifique seu nome na caixa de diálogo Modelo de PCB da biblioteca.
Detecção de duplicatas
O Importador de Bibliotecas também inclui mecanismos para evitar a criação de componentes duplicados no Workspace de destino. Isso é feito durante a validação, comparando os parâmetros de identificação dos componentes e as Escolhas de Peças da biblioteca de origem com os dos componentes no Workspace de destino e nas bibliotecas de origem a serem importadas. Com as configurações padrão do importador, uma etapa de Validação sinalizará uma mensagem Warning quando for detectada a mesma entrada de componente Name ou Part Choices (indicando um possível componente duplicado). A mensagem de aviso/erro exibida inclui o tipo de violação de duplicidade (parâmetro ou Escolha de Peça), o nome do componente da biblioteca que apresenta a violação e o componente (por ID) com o qual ele está em conflito.

Duas possíveis duplicidades detectadas pelo processo de Validação, em que o Name do componente (imagem superior) ou seu Part Choice (imagem inferior) já existem em componentes do Workspace.
O par nome-valor do parâmetro usado para detectar violações de duplicidade é especificado na região Duplicates Detection do painel Properties, na aba Advanced. Use o menu suspenso Unique Field (definido como Name por padrão) para selecionar um dos parâmetros disponíveis na biblioteca de origem. Essa seleção é particularmente útil para configurações de bibliotecas corporativas que usam um campo de identificação proprietário integrado ao sistema empresarial mais amplo.

Uma violação de duplicidade detectada em que o valor de um parâmetro especificado (ERP-REF) é o mesmo para um componente da biblioteca local e um componente do Workspace.
É possível definir um tipo diferente de sinalização de status para as violações de duplicidade selecionando uma alternativa em Report Mode, na região Import Checks, na aba General do painel Properties.
A detecção de duplicidades também é realizada para modelos de símbolos dos componentes. Se os componentes a serem importados tiverem modelos de símbolos com a mesma geometria nas bibliotecas de origem, apenas um desses modelos será importado.
Bibliotecas com Modelo Único
A detecção automática de duplicidades também é usada para processar bibliotecas de origem que utilizam um modelo de símbolo comum para todos os componentes. Essas bibliotecas tendem a ser compostas por um único tipo de componente com diferentes estilos e valores, como resistores de um determinado formato de encapsulamento, em que o símbolo de cada um é uma representação gráfica padrão.
Essa condição de modelo único e comum é detectada pelo Importador de Bibliotecas, que então configura a importação para transferir um modelo de símbolo aplicável a todos os componentes importados, em vez de um símbolo correspondente com nome individual para cada componente. O símbolo a ser importado adota o nome de um dos símbolos a serem importados, e todos os parâmetros dos componentes permanecem inalterados.
O símbolo de biblioteca importado (que tem um nome genérico e o campo Descrição em branco) pode ser editado para atender às suas necessidades. No painel Componentes, use a opção Edit do menu de contexto para executar a ação. Durante o processo, selecione a opção Update items related to <symbol ID> na caixa de diálogo Create Revisions for Item para garantir que os componentes importados usem a nova revisão do símbolo.
Importação Somente de Modelos
O Importador de Bibliotecas pode ser alternado para um modo de importação especial Models Only, que detecta e processa os modelos de componentes disponíveis em uma biblioteca de origem.
No modo Somente Modelos, o processo de análise do importador detectará todos os modelos de Símbolo, Footprint e Simulação disponíveis em uma biblioteca de origem (IntLib, SchLib, PcbLib etc.) e, em seguida, importará esses modelos para o Workspace usando os locais, os esquemas de nomenclatura e as definições de ciclo de vida padrão do sistema.
Quando o Importador de Bibliotecas é alternado para o modo Avançado ou aberto nesse modo (File » Library Importer), ficam disponíveis todos os detalhes da importação de modelos proposta. A região Import Preview mostra o Folder Structure que será usado no Workspace de destino, cujas configurações padrão podem ser modificadas no campo Folder para cada tipo de modelo no painel Properties. Os esquemas de nomenclatura e a definição de Ciclo de Vida aplicados a cada modelo podem ser selecionados entre os tipos disponíveis no sistema (consulte o painel Propriedades, abaixo).
A importação de modelos de componentes para o Workspace pode ser limitada por tipo, se desejado, desabilitando (ou habilitando) tipos de modelo específicos no painel Properties por meio de seus respectivos botões
.
Após configurar o Importador de Bibliotecas, selecione o botão
para concluir a importação dos modelos de componentes listados. Os resultados podem ser consultados no arquivo de log de importação, disponibilizado pela caixa de diálogo de progresso Library Importer , ou pela visualização dos modelos importados no painel Componentes.
Importação Somente de Componentes
De modo semelhante ao modo de importação Models Only descrito acima, o Importador de Bibliotecas pode ser alternado para um modo de importação especial Components Only, que permite importar os componentes disponíveis em uma biblioteca de origem sem seus modelos vinculados.
No modo Somente Componentes, o processo de análise do importador detectará todos os componentes, parâmetros e Escolhas de Peças em uma biblioteca de origem e, em seguida, importará esses componentes para o Workspace usando o local, o esquema de nomenclatura e a definição de ciclo de vida padrão do sistema.
Quando o Library Importer é alternado para o modo Avançado ou aberto nesse modo (File » Library Importer), ficam disponíveis todos os detalhes da importação de componentes proposta. A pasta aplicada, os esquemas de nomenclatura e a definição de ciclo de vida podem ser selecionados entre os tipos disponíveis no sistema (consulte painel Properties, abaixo).
Após configurar o Library Importer, selecione o botão
para concluir a importação dos componentes listados. Apenas itens de componentes serão criados no Workspace, sem modelos vinculados. Os resultados podem ser consultados no arquivo de log da importação, disponibilizado pela caixa de diálogo de progresso Library Importer , ou visualizando os componentes importados no painel Components.
Painel Properties
As configurações do painel Properties associado ao Library Importer oferecem controle avançado sobre a configuração de importação da biblioteca selecionada (ou do grupo de subbibliotecas). O painel pode ser acessado no modo Avançado do Library Importer selecionando a opção Properties no menu do botão
(no canto inferior direito da área de projeto), clicando no botão
no canto superior direito da visualização do Library Importer ou clicando no botão
ao lado de <All Libraries> ou de uma entrada de categoria específica na lista Source Libraries.
As opções do painel são definidas pelas configurações padrão do sistema ou pelas configurações especificadas pelo modelo de componente aplicado, que, por sua vez, é determinado pelo tipo de componente detectado na biblioteca — LED no exemplo mostrado aqui. As configurações também podem ser editadas pelo usuário, permitindo adaptar o processo de importação conforme necessário, e podem ser restauradas pelo link Reset to Default (no canto superior direito).
As seções da guia General do painel são as seguintes:
-
General:
-
Component Type – o tipo de componente detectado pelo importador para a biblioteca selecionada e, por associação, o modelo aplicado (consulte Component Template abaixo). Substitua essa configuração editando o campo, o que criará um novo tipo de componente, ou selecionando outro tipo nas opções do menu suspenso (ou pelo botão — essa é outra forma de resolver um problema de componente não categorizado. Escolha a opção
[LibraryName]para definir o tipo como o nome da biblioteca selecionada. -
Component Template – o modelo de componente do Workspace que será aplicado aos componentes importados e, por associação, sua configuração de tipo de componente. Substitua essa configuração selecionando outro modelo nas opções do menu suspenso (ou pelo botão Defina essa opção como
[Create new]para criar automaticamente um modelo derivado dos parâmetros da biblioteca de origem e das configurações atuais do Library Importer, ou escolha [No Template] para impedir que um modelo seja aplicado ou criado.
-
Component Type – o tipo de componente detectado pelo importador para a biblioteca selecionada e, por associação, o modelo aplicado (consulte Component Template abaixo). Substitua essa configuração editando o campo, o que criará um novo tipo de componente, ou selecionando outro tipo nas opções do menu suspenso (ou pelo botão — essa é outra forma de resolver um problema de componente não categorizado. Escolha a opção
-
Parameter Mapping – a correspondência entre os parâmetros da biblioteca e os do modelo de componente aplicado (ou as configurações padrão quando não há um modelo disponível), além do tipo de valor de cada parâmetro (texto ou um tipo com suporte a unidades). Use as opções do menu suspenso da coluna Source Library Parameter para alterar o mapeamento e as opções do menu da coluna Type para substituir a configuração existente, determinada pelo modelo ou pelos padrões. Escolha a opção
<Skip>para não incluir um parâmetro. Qualquer parâmetro que não tenha sido automaticamente associado a um parâmetro da biblioteca de origem (definido como<Skip>pelo sistema) pode ser mapeado manualmente para um parâmetro adequado do modelo — por exemplo, o parâmetro de origemROHSpode ser selecionado para corresponder ao parâmetroRoHS Compliantdefinido pelo modelo do Workspace. Os nomes dos parâmetros podem ser editados, e conjuntos de parâmetros podem ser adicionados, editados e removidos. Os parâmetros básicos do componente (ID,Name,Description) podem ser remapeados, mas, fora isso, são somente leitura. -
Part Choice Mapping – a lista de parâmetros de peças do fabricante ou de links de fornecedores reconhecidos pelo importador, que serão usados para gerar entradas de opções de peças para os componentes importados. Use as opções do menu suspenso para redefinir o mapeamento ou adicionar e excluir conjuntos de mapeamento. Observe que, por padrão, os parâmetros de peças do fabricante e de links de fornecedores não são incluídos (são ignorados) no processo de importação. Quando vários links de fornecedores estão incluídos em um componente da biblioteca, a referência do fornecedor principal (
Supplier 1/Supplier Part Number 1) é usada nas entradas do campo de opções de peças. -
Import Checks – visualize ou defina a resposta de erro/aviso do importador às violações das regras de validação da importação. Use o menu suspenso Report Mode para alterar a resposta e o ícone de uma entrada Violation Type. Observe que, se o modo de relatório
Fatal Errorestiver selecionado, ele bloqueará o processo de importação quando essa violação for detectada.
A guia Advanced do painel oferece configurações para todos os itens de objetos de dados do importador, conforme definido pelos padrões do sistema ou pelo modelo de componente aplicado. Isso inclui modelos de componentes, arquivos de folhas de dados e quaisquer modelos de componente criados. Com exceção da opção Datasheet (um controle para habilitar/desabilitar), as configurações de cada objeto de importação incluem:
- Folder – a pasta de destino do Workspace para o objeto importado, que pode ser editada manualmente (por exemplo, para criar uma nova pasta de destino) ou selecionada pelo botão de navegação
- Naming Scheme – a especificação de nomenclatura do objeto no Workspace, conforme definida pelo modelo de componente ou, na ausência de um modelo ativo, o esquema definido para a pasta de destino (ou inserido manualmente). Use o menu suspenso para escolher entre os esquemas de nomenclatura disponíveis. Observe que uma alteração no caminho da pasta de destino (Folder) pode ser acompanhada de uma alteração no esquema de nomenclatura aplicado, conforme definido pela própria pasta ou por um modelo de componente aplicado/associado.
- Revision Naming Scheme – o padrão de nomenclatura usado para as revisões do objeto no Workspace, conforme definido pelo modelo aplicado ou selecionado nas opções do menu suspenso da entrada. Apenas os esquemas habilitados pelo sistema estarão disponíveis como opção.
- Lifecycle Definition – o sistema de ciclo de vida usado para o objeto, conforme definido pelo modelo aplicado ou selecionado nas opções do menu suspenso da entrada. Somente as definições habilitadas pelo sistema estarão disponíveis como opção.
Exportação e importação da configuração
O Importador de Bibliotecas permite exportar um arquivo de texto detalhado que registra a configuração atual, incluindo todas as configurações de importação ajustáveis, como caminhos de destino, mapeamento de parâmetros, esquema de nomenclatura, definições de ciclo de vida, tipos de componentes de destino e assim por diante.
O arquivo de configuração do importador é salvo por meio do comando File » Export » Importer Config como um arquivo do tipo *.lmcfg e pode ser restaurado a qualquer momento pela opção de menu File » Import » Importer Config .
A capacidade de restaurar uma configuração é particularmente útil quando o banco de dados de origem ou a biblioteca baseada em arquivos tiver sido atualizado e essas alterações precisarem ser importadas para o Workspace. Se a configuração tiver sido exportada quando a biblioteca foi importada pela primeira vez, a configuração restaurada (importada) restabelecerá exatamente as configurações utilizadas, garantindo um esquema consistente de transferência de dados para essa biblioteca (ou bibliotecas).

























