Modelos de componentes
Num relance
- Aprenda a configurar pastas do Workspace e itens de modelo de componente com esquemas adequados de nomenclatura, revisão e ciclo de vida.
- Entenda como os modelos controlam os parâmetros dos componentes, incluindo valores obrigatórios e valores padrão somente leitura.
- Descubra como editar modelos diretamente e salvá-los novamente no seu Workspace como novas revisões.
Para ajudar a agilizar a criação dos seus componentes, o Altium Designer, em conjunto com seu Workspace conectado, permite criar e definir Component Templates (Itens de Modelo de Componente) nesse Workspace. Assim como um modelo de esquemático pode ser usado para predefinir informações nas folhas de esquemático que o referenciam, um modelo de componente é referenciado por um componente da biblioteca do Workspace e fornece configurações predefinidas para uso na definição desse componente.
Em particular, os modelos de componente foram desenvolvidos com foco nas informações paramétricas, permitindo definir, em um único local, um conjunto de parâmetros que ficará disponível para o componente que referencia o modelo. Por meio do modelo, você pode controlar quais desses parâmetros ficarão visíveis, preencher valores padrão e até marcar como obrigatórios os parâmetros necessários. São realizadas verificações de validação ao salvar o componente para garantir a conformidade.
Esses modelos de componente são criados diretamente no Workspace. Depois que um modelo de componente é criado (e seus dados são salvos em uma revisão), ele pode ser reutilizado na criação de um ou mais componentes.
Tipo de pasta
Ao criar a pasta na qual os modelos de componente serão armazenados, você pode especificar o tipo da pasta. Isso não afeta o conteúdo da pasta — a liberação de um modelo de componente sempre resultará em um Item de Modelo de Componente correspondente. Essa configuração simplesmente fornece uma indicação visual do que está armazenado em uma pasta e pode ser útil ao procurar conteúdo específico em um Workspace. Para indicar que uma pasta será usada para armazenar modelos de componente, defina seu Folder Type como Component Templates ao definir as propriedades da pasta na caixa de diálogo Editar pasta.

Especificar o tipo da pasta — seu uso pretendido — fornece uma indicação visual do conteúdo dessa pasta ao navegar pelo Workspace.
Esquema de nomenclatura de itens
Outro aspecto importante da pasta principal é o Item Naming Scheme utilizado nela. Ele define o formato do ID exclusivo de cada Item criado nessa pasta específica. Vários exemplos de esquemas padrão estão disponíveis, utilizando o código abreviado do tipo de pasta (CTC – Coleção de Modelos de Componente) ou do tipo de conteúdo (CMPT – Modelo de Componente):
-
$CONTENT_TYPE_CODE-001-{0000}– por exemplo,CMPT-001-0001. -
$CONTENT_TYPE_CODE-001-{A00}– por exemplo,CMPT-001-A01. -
$FOLDER_TYPE_CODE-001-{0000}– por exemplo,CTC-001-0001. -
$FOLDER_TYPE_CODE-001-{A000}– por exemplo,CTC-001-A001.
Ao usar um esquema de nomenclatura padrão, o software atribuirá automaticamente o próximo ID exclusivo disponível com base nesse esquema, após verificar todo o Workspace e os identificadores do conteúdo existente. Isso pode economizar bastante tempo ao criar modelos de componente manualmente.
Também é possível definir um esquema personalizado para uma pasta, bastando digitá-lo no campo e garantir que a parte variável esteja entre chaves (por exemplo, CMP-TMP-{0000}).

O esquema de nomenclatura de itens da pasta principal é aplicado ao ID exclusivo de cada Item criado nessa pasta.
Tipo de conteúdo
Ao criar um Item de Modelo de Componente de destino para armazenar seu modelo de componente, certifique-se de que seu Content Type esteja definido como Component Template na caixa de diálogo Criar novo item. Se você estiver criando o Item em uma pasta do tipo Component Templates, esse tipo de conteúdo estará disponível no menu de contexto acessado com o botão direito do mouse ao criar o Item.

Criação de um modelo de componente em uma pasta Component Templates — o Content Type correto está disponível no menu de contexto.
Definição do ciclo de vida e nomenclatura de revisões do item
Related pages: Definição de esquemas de nomenclatura de revisões para um Workspace, Definição de ciclos de vida para um Workspace
Ao definir um modelo de componente, certifique-se de especificar o tipo de gerenciamento do ciclo de vida a ser usado para o modelo de componente e o esquema de nomenclatura utilizado para suas revisões, respectivamente.
O controle sobre quais tipos de conteúdo podem usar uma determinada definição de ciclo de vida ou um esquema de nomenclatura de revisões pode ser definido e habilitado globalmente na caixa de diálogo Content Types durante a definição de cada esquema. Os esquemas padrão atribuídos para uso por um modelo de componente são: Generic Lifecycle e 1-Level Revision Scheme, respectivamente.
Especifique os esquemas necessários na caixa de diálogo Create New Item, usando os campos Lifecycle Definition e Revision Naming Scheme, respectivamente.

Seleção dos esquemas de definição do ciclo de vida e de nomenclatura de revisões para um modelo de componente criado manualmente.
Como salvar um modelo de componente
Related page: Criação e edição de conteúdo
Até aqui, discutimos o suporte a modelos de componente no Workspace em termos dos tipos de pasta e de conteúdo relacionados. Salvar um modelo de componente já definido em uma revisão desse Item de Modelo de Componente pode ser feito de forma simplificada.
Um modelo de componente pode ser editado e salvo na revisão inicial de um Item de Modelo de Componente recém-criado, graças ao suporte do Workspace à edição direta. A edição direta elimina a necessidade de manter dados de origem separados sob controle de versão. Você pode simplesmente editar um tipo de conteúdo compatível usando um editor temporário carregado com os dados de origem mais recentes, diretamente do próprio Workspace. Quando a edição é concluída, a entidade é salva (ou salva novamente) em uma revisão planejada subsequente do Item ao qual pertence, e o editor temporário é fechado. Não há arquivos no seu disco rígido, dúvidas sobre estar trabalhando com os dados de origem corretos ou mais recentes, nem necessidade de manter um software separado de controle de versão. O Workspace cuida de tudo, com alto nível de integridade e de uma forma que agiliza consideravelmente as alterações nos seus dados.
Ao criar um Item de Modelo de Componente, você tem a opção de editar e salvar um modelo de componente na revisão inicial desse Item, após a criação. Para isso, habilite a opção Open for editing after creation, na parte inferior da caixa de diálogo Create New Item (que está habilitada por padrão). O Item será criado e o Editor de Modelos de Componentes temporário será aberto, apresentando um documento .CMPT como documento ativo na janela principal de projeto. Esse documento será nomeado de acordo com o Item-Revisão, no formato: <Item><Revision>.CMPT (por exemplo, CMPT-0001-1.CMPT).
Use o documento para definir o modelo de componente conforme necessário. Para obter mais informações sobre como fazer isso, consulte Definição do modelo.
Há três controles relevantes para a edição direta, disponíveis no Quick Access Bar (no canto superior esquerdo da janela principal do aplicativo) ou na barra de ferramentas Component Template Standard:
-
– Save Active Document. Use este botão para salvar localmente quaisquer alterações feitas no documento. Isso permite salvar as alterações atuais, caso deseje voltar mais tarde para fazer outras alterações antes de salvar definitivamente no Workspace.
-
/
– Save to Server. Use este botão para salvar o modelo de componente definido no Workspace, armazenando-o na revisão inicial (planejada) do Item de Modelo de Componente de destino. A caixa de diálogo Edit Revision será exibida, na qual você poderá alterar o Nome e a Descrição e adicionar notas de versão conforme necessário. O documento e o editor serão fechados após o salvamento. O documento que contém o modelo de componente de origem, *.CMPT, será armazenado na revisão do Item. -
/
– Discard Local Changes. Use este botão se desejar cancelar a edição e descartar quaisquer alterações feitas. O documento e o editor serão fechados, e nada será liberado para o Item de Modelo de Componente de destino.
Esses controles também estão disponíveis como comandos – Save (Atalho: Ctrl+S), Save to Server (Atalho: Ctrl+Alt+S) e Discard Local Changes – no menu principal File e no menu de contexto da entrada do modelo de componente no painel Projects.
Os dados salvos no Workspace consistem no modelo de componente de origem, definido no arquivo de Modelo de Componente (<Item><Revision>.CMPT).
Herança de um modelo de componente
Você pode usar um modelo de componente do tipo de componente raiz se o subtipo não tiver um modelo de componente vinculado. Ao criar uma hierarquia de tipos de componentes, os subtipos de componentes herdarão o modelo de componente atribuído ao tipo de componente raiz/pai.
O Editor CMPT (Modelo de Componente)
Definição do modelo
O Editor de Modelos de Componentes é essencialmente dividido em duas regiões principais, ilustradas na imagem a seguir e resumidas logo depois.
- Upper Region – para definir opções no nível do componente (opções de ciclo de vida, nomenclatura e pasta) para um componente que faz referência ao modelo.
- Lower Region – para definir os parâmetros a serem usados por um componente que faz referência ao modelo.
Especificação das opções do componente
A metade superior do editor é dedicada à definição dos valores padrão das seguintes propriedades do componente:
-
Lifecycle Definition – escolha a definição de ciclo de vida a ser aplicada a um componente criado usando o modelo. O campo de lista suspensa apresenta todas as definições configuradas para o Workspace e cujo uso é permitido por um componente.
-
Revision Naming – escolha o esquema de nomenclatura de revisões a ser aplicado a um componente criado usando o modelo. O campo de lista suspensa apresenta todos os esquemas configurados para o Workspace e cujo uso é permitido por um componente.
-
Component Naming – use este campo para definir um esquema padrão de nomenclatura de itens para um componente criado usando o modelo, garantindo um ID exclusivo para o componente resultante no Workspace. A entrada aqui será usada como modelo para nomear automaticamente o componente (no campo Id associado (ao usar o Editor de Componentes no modo Single Component Editing), ou no campo Item ID (ao usar o Editor de Componentes no modo Batch Component Editing)). O software atribuirá automaticamente o próximo ID exclusivo disponível, com base nesse esquema, após verificar todo o Workspace e os identificadores do conteúdo existente. Um esquema padrão de nomenclatura de itens –
CMP-{00000}– é fornecido, mas você pode, é claro, criar seu próprio esquema digitando-o no campo e garantindo que a parte variável esteja entre chaves (por exemplo,CMP-001-{0000}). -
Default Folder – para especificar uma pasta padrão no Workspace de destino na qual armazenar um componente salvo. Para isso, clique no botão Choose para acessar a caixa de diálogo Choose Folder (uma versão do painel Explorer), na qual você pode navegar até uma pasta existente no Workspace e selecioná-la, ou criar uma nova pasta na hora.
Quando o modelo é referenciado, as entradas especificadas nesta região são usadas para preencher previamente os campos correspondentes no Editor de Componentes (quando disponíveis):
- Single Component Editing mode – os campos Id e Folder, na área Advanced Settings da região Component.
- Batch Component Editing mode – na guia Document Options da caixa de diálogo Opções do Documento e, consequentemente, os campos Item ID e FolderPath, na área Component da região de definições de componentes.

Quando o modelo é referenciado, as entradas são usadas para preencher previamente os campos correspondentes ao editar um componente no Editor de Componentes no modo Single Component Editing (à esquerda) e no modo Batch Component Editing (à direita).
Definição de parâmetros
A metade inferior do editor é dedicada à definição e ao gerenciamento dos parâmetros que serão disponibilizados para um componente que faça referência ao modelo.
Parâmetros padrão do sistema
Vários parâmetros do sistema são incluídos por padrão ao criar um novo modelo de componente, conforme ilustrado na imagem a seguir e detalhado na sequência.
-
ComponentType– este parâmetro permite especificar o tipo de componente. Isso facilita pesquisas direcionadas por meio do poderoso recurso de pesquisa do Workspace – um recurso que não apenas permite pesquisar por tipo de componente, mas também realizar pesquisas mais inteligentes, com suporte a parâmetros de componentes que reconhecem unidades. Ao navegar pelos componentes do seu próprio Workspace usando o painel Componentes, o agrupamento Categories dos componentes é derivado dos parâmetrosComponentTypeassociados a cada componente. Clique no campo Default Value associado e, em seguida, clique no botão
para acessar a caixa de diálogo Choose component type. Use-a para selecionar o tipo de componente desejado e clique em OK – o tipo escolhido será inserido como valor do parâmetro ComponentType, de volta à grade principal de parâmetros.

Exemplo de modelo de componente, com o parâmetro do sistema ComponentType definido comoDiodes. -
SCHLIBePCBLIB– esses dois parâmetros permitem especificar modelos padrão de símbolo e de footprint, respectivamente. Clique no campo Default Value associado a cada parâmetro e, em seguida, clique no botão
para acessar uma caixa de diálogo na qual você pode escolher o modelo desejado.

Especifique modelos de símbolo e de footprint como parte do seu modelo de componente. -
NameeDescription– esses dois parâmetros permitem definir o nome e a descrição do componente, respectivamente. Insira os textos desejados no campo Default Value associado a cada parâmetro.
Especifique os parâmetrosNameeDescriptioncomo parte do seu modelo de componente.
Adição de um novo parâmetro de usuário
Para adicionar um novo parâmetro de usuário à lista, clique no botão
(ou use o comando Add no menu de contexto) – o parâmetro é adicionado ao final da lista atual.

Exemplo de adição de um novo parâmetro de usuário ao modelo.
Cada parâmetro é apresentado na grade com as seguintes informações:
-
Name – use este campo para nomear o parâmetro, normalmente com um nome significativo que indique sua finalidade. Quando adicionados inicialmente, os parâmetros recebem nomes padrão (
Parameter,Parameter 1,Parameter 2e assim por diante). -
Type – o tipo de parâmetro. Inicialmente, esta entrada terá o valor padrão
Text, mas há suporte para diversos tipos de dados com reconhecimento de unidades, bem como para o tipoPCBLIB, que facilita a definição de múltiplos footprints, eHarnessWiring, que facilita a definição de um componente de fiação de chicote. Também há suporte para tipos de parâmetros definidos pelos dicionários disponíveis – saiba mais. -
Visible – habilite esta opção (que é o estado padrão de um parâmetro recém-adicionado) para que a opção Show correspondente ao parâmetro esteja habilitada ao editar um ou mais componentes no Editor de Componentes (configurado no modo Batch Component Editing). Isso, por sua vez, controla a exibição da coluna correspondente a esse parâmetro na região inferior do Editor de Componentes, onde são definidas as próprias definições dos componentes. Esta propriedade não tem efeito ao definir um componente usando o modo Single Component Editing do editor.
-
Read Only – habilite esta opção para tornar o parâmetro somente leitura. Ao editar um componente que faz referência ao modelo, o valor do parâmetro não poderá ser editado.
-
Required – habilite esta opção para tornar o parâmetro um 'parâmetro obrigatório'. Ao editar um componente que faz referência ao modelo, o parâmetro deve ter um valor definido; caso contrário, não será possível salvar o componente. No Editor de Componentes, esse parâmetro é identificado pela célula de valor com uma borda vermelha (no modo Batch Component Editing) ou com o ícone
(no modo Single Component Editing), quando nenhum valor tiver sido inserido.
-
Default Value – use este campo para inserir um valor padrão para o parâmetro.
-
Description – adicione uma descrição para o parâmetro, por exemplo, uma nota concisa sobre o que ele oferece. Se um parâmetro no modelo tiver uma descrição definida, a coluna Description será apresentada na região Parameters do Editor de Componentes em seu Single Component Editing, conforme apropriado.
A lista de parâmetros também oferece suporte a ações simples de copiar e colar, permitindo duplicar um ou mais parâmetros de usuário existentes. Os parâmetros colados serão adicionados ao final da lista.
Ordenação e dimensionamento das colunas
A ordem das colunas é personalizável. Clique no cabeçalho de uma coluna e arraste-o horizontalmente até a nova posição desejada. As posições válidas são destacadas por setas verticais de posicionamento.
Classificação
Os parâmetros podem ser classificados por uma coluna específica clicando no cabeçalho dessa coluna. Clique uma vez para classificar em ordem crescente (com base no conteúdo dessa coluna). Clique novamente para classificar em ordem decrescente.
Você pode classificar por várias colunas. Com os parâmetros já classificados por uma coluna específica, Shift+Click em outra coluna para fazer uma classificação secundária pelo conteúdo dessa coluna.
Tipos de dados de parâmetros de componentes com reconhecimento de unidades
O Editor de Modelos de Componentes permite definir tipos de dados explícitos para os parâmetros de componentes definidos em um modelo de componente (*.CMPT). Além disso, esses tipos de dados reconhecem unidades, com suporte a diversos prefixos de unidades comuns. Assim, você pode inserir o valor de um parâmetro usando vários formatos – como 2.2k, 2k2, 4M, 2.5GHz – e o Workspace conta com a inteligência necessária para reconhecer o valor numérico dessas entradas.
Esse recurso de um modelo de componente facilita buscas direcionadas por meio do recurso de Pesquisa Avançada do servidor – um recurso que não só permite pesquisar por tipo de componente, mas também realizar buscas mais inteligentes, com pesquisas por intervalos. Usando o poder dos parâmetros de componentes com reconhecimento de unidades, você pode definir rapidamente uma pesquisa, por exemplo, para encontrar todos os capacitores com capacitância entre 47uF e 220uF.
Use as seções recolhíveis a seguir para saber mais sobre os parâmetros com reconhecimento de unidades.
Unidades compatíveis
Os seguintes tipos de dados com reconhecimento de unidades são compatíveis ao definir um parâmetro de usuário como parte de um modelo de componente:
-
Inteiro
-
Decimal
-
Ampere (A)
-
Área (mm2)
-
Bit
-
Candela (cd)
-
Celsius (C)
-
Decibel (dB)
-
Farad (F)
-
Grama (g)
-
Henry (H)
-
Hertz (Hz)
-
Joule (J)
-
Lúmen (lm)
-
Metro (m)
-
Milímetro (mm)
-
Ohm
-
Porcentagem (%)
-
Pascal (Pa)
-
Bar (bar)
-
Libras por polegada quadrada (psi)
-
Rotações por minuto (rpm)
-
Segundo (s)
-
Siemens (S)
-
Coeficiente de temperatura (ppm/°C)
-
Tesla (T)
-
Volt (V)
-
Watts(W)
Prefixos de unidade compatíveis
A tabela a seguir lista os prefixos de unidade compatíveis ao inserir um valor para um tipo de parâmetro com reconhecimento de unidades.
| Prefixo | Termo | Valor (científico) | Valor (normal) |
|---|---|---|---|
| T | Tera | 1 x 1012 | 1.000.000.000.000 |
| G | Giga | 1 x 109 | 1.000.000.000 |
| M | Mega | 1 x 106 | 1.000.000 |
| k | quilo | 1 x 103 | 1.000 |
| m | mili | 1 x 10-3 | 1 / 1.000 |
| u | micro | 1 x 10-6 | 1 / 1.000.000 |
| n | nano | 1 x 10-9 | 1 / 1.000.000.000 |
| p | pico | 1 x 10-12 | 1 / 1.000.000.000.000 |
| f | femto | 1 x 10-15 | 1 / 1.000.000.000.000.000 |
Adição de um parâmetro de componente com reconhecimento de unidades
Ao adicionar um parâmetro ao modelo (clique em
na região Parameters), use o campo Type associado para escolher o tipo de dado com reconhecimento de unidades desejado na lista suspensa.

Seleção de um tipo de dado compatível com reconhecimento de unidades para um parâmetro de usuário em um modelo de componente. Neste exemplo, Ampere é o tipo de parâmetro.
Ao inserir um valor para um parâmetro de componente que usa um tipo de dado com reconhecimento de unidades — seja como Default Value em um modelo de componente ou como o valor necessário em uma definição de componente — considere o seguinte:
-
Você pode inserir o valor em diversos formatos:
-
Apenas valor numérico (por exemplo,
10). Observe que, se o tipo de dado tiver uma unidade, ela será aplicada automaticamente. Os tipos com unidades apresentam a unidade entre parênteses após o nome. -
Valor numérico em notação científica (por exemplo,
1e10,1E6). -
Valor numérico e unidades (por exemplo,
10F). -
Valor numérico com prefixo (por exemplo,
10k). A unidade apropriada será adicionada automaticamente (quando aplicável). -
Valor numérico com prefixo e unidades (por exemplo,
10kF). -
Valor numérico com prefixo no formato típico de engenharia (por exemplo, para uma resistência:
2k2,2K2,10r2,10R2). O valor será normalizado automaticamente de acordo com esse formato (por exemplo,2K2se tornará2.2k).
-
Apenas valor numérico (por exemplo,
-
Você pode inserir o prefixo e/ou as unidades com ou sem espaço após o valor numérico (por exemplo,
10uFou10 uF). O espaço será removido automaticamente.
Validação de dados
Quando um tipo de dado com reconhecimento de unidades é usado para um parâmetro de componente, o valor inserido é validado em relação ao tipo de dado especificado. Isso garante que a unidade de medida correta para esse tipo de dado seja usada. Por exemplo, um parâmetro do tipo Celsius não pode ter um valor de 10V!
A validação é realizada sempre que um parâmetro de componente com um tipo de dado com reconhecimento de unidades é usado e um valor é fornecido para esse parâmetro:
- Ao definir um valor padrão para um parâmetro em um modelo de componente.
- Ao definir um valor para um parâmetro como parte da definição de um componente no Editor de Componentes.
- Ao configurar uma pesquisa por intervalo, baseada no valor do parâmetro, como parte de um esquema de pesquisa salvo.

Exemplo de validação de dados em ação no Editor de Modelos de Componentes.
Tipos de dados de parâmetros definidos por dicionários
Dicionários são tipos de parâmetros personalizados com vários valores definidos. Os dicionários são gerenciados pelos administradores do Workspace na página Settings – Vault – Dictionaries da interface do Workspace no navegador, que pode ser acessada pelo Editor de Modelos de Componentes escolhendo a opção Add New Dictionary na lista suspensa Type ou clicando no controle Manage Dictionaries no canto superior direito da região Parameters.

Acesse a página de gerenciamento de dicionários na interface do Workspace no navegador pelo Editor de Modelos de Componentes.
Os dicionários definidos estão disponíveis como tipos de parâmetros na lista suspensa Type.

Selecione um tipo de parâmetro definido por dicionário na lista suspensa Tipo.
Os valores definidos para o tipo selecionado definido no dicionário estão disponíveis na lista suspensa Default Value. Selecione o valor desejado para usar como padrão do parâmetro ou selecione <None>.

Selecione um valor padrão entre os definidos para o tipo selecionado definido no dicionário.
Definindo múltiplos footprints
O Editor de modelos de componentes também oferece suporte à definição de múltiplos footprints de PCB como parte de um modelo de componente. É possível especificar qualquer quantidade de vínculos com modelos de footprint, um recurso muito útil para quem deseja criar componentes que façam referência a 3 footprints, atendendo aos requisitos do IPC para diferentes níveis de densidade: L (menor, ou mínimo de cobre), M (maior, ou máximo de cobre) e N (nominal, ou intermediário de cobre).
Para adicionar uma definição de modelo de footprint ao modelo de componente, clique em
para adicionar um novo parâmetro e escolha a opção PCBLIB no menu suspenso associado ao campo Type.

Transforme um parâmetro recém-adicionado em uma definição de modelo de footprint definindo seu Type como PCBLIB.

Um exemplo de componente definido no Editor de componentes (modo Single Component Editing), usando um modelo de componente referenciado. O modelo de componente tem três modelos de footprint definidos, que são carregados na definição do componente. Observe que a entrada de modelo PCBLIB no modelo de componente é usada como modelo de footprint padrão (identificado por um ícone no canto superior esquerdo) ao definir o componente. Passe o cursor sobre a imagem para ver o mesmo componente sendo definido com o Editor de componentes no modo Batch Component Editing. Nesse caso, o footprint padrão é denominado PCBLIB (default).
Importação e exportação de modelos de componentes
Um arquivo de modelo de componente existente (*.CMPT) ou um arquivo de biblioteca de componentes (*.CMPLIB) pode ser importado para o Editor de modelos de componentes, e o modelo de componente em edição pode ser exportado para um arquivo de modelo de componente (*.CMPT). Use os comandos File » Import » Component Template, File » Import » Component Library e File » Export do menu principal do Editor de componentes para selecionar a ação desejada e a caixa de diálogo padrão do Windows que será aberta para navegar até o local desejado e selecionar um arquivo para importar ou definir o nome do arquivo a ser exportado.
Reutilizando um modelo de componente
O uso de uma revisão de um modelo de componente — ou, mais precisamente, a referência a uma delas a partir da revisão do componente que você está editando — pode ser feito das seguintes maneiras.
Ao criar um novo componente
Ao criar um novo componente usando o comando File » New » Component nos menus principais, você pode escolher o modelo na caixa de diálogo Create new component.

Vinculando rapidamente um modelo de componente a partir de uma lista de todos os modelos disponíveis, ao criar um novo componente.
Manualmente no Editor de componentes
A reutilização de uma revisão de um modelo de componente no Editor de componentes depende do modo de operação do editor.
No modo de edição de componente único
Ao editar um único componente nesse modo do Editor de componentes, escolha o modelo de componente desejado no menu suspenso associado ao campo Template — parte do grupo Advanced Settings, na região Component do editor. Todos os modelos de componentes disponíveis no mesmo Workspace em que o próprio componente reside são listados por nome, com suas revisões mais recentes indicadas entre colchetes. Escolha o modelo desejado para aplicá-lo.

Vinculando rapidamente um modelo de componente a partir de um menu com todos os modelos disponíveis, ao editar a revisão de um componente usando o Editor de componentes no modo Single Component Editing.
No modo de edição de componentes em lote
Há duas maneiras de vincular uma revisão de um modelo de componente à revisão do componente que está sendo editada:
-
Na aba Template da caixa de diálogo Opções do documento (Edit » Document Options). Clique no botão Choose à direita do campo Item Revision. Isso dá acesso à caixa de diálogo Choose Item (uma versão do painel Explorer). Use essa caixa de diálogo para localizar e selecionar a revisão do modelo de componente desejado. Após clicar em OK, será criado um vínculo entre a revisão do componente e a revisão de destino do modelo de componente. Esse vínculo pode ser verificado na aba Template da caixa de diálogo Document Options.

Vinculando manualmente um componente a uma revisão de um modelo de componente no Workspace de destino. -
No menu Add associado à região Required Models/Parameters do Editor de Componentes. O submenu Templates lista todos os templates de componentes – por nome – atualmente disponíveis no mesmo Workspace em que o próprio componente reside, com suas revisões mais recentes indicadas entre colchetes. Clique em uma entrada para criar um vínculo com a revisão mais recente desse template de componente. Mais uma vez, a confirmação do vínculo pode ser vista na aba Templates da caixa de diálogo Document Options.

Vinculando rapidamente um template de componente a partir de um menu com todos os templates disponíveis.
Herdado da pasta de componentes do Workspace
Você pode especificar um template de componente para ser usado automaticamente em todos os componentes (e suas respectivas revisões) armazenados em uma pasta de componentes no Workspace.
Especifique o template desejado usando o campo Component Template, ao definir as propriedades da pasta, na caixa de diálogo Editar pasta. A lista suspensa associada ao campo lista todos os templates de componentes – por nome – atualmente disponíveis no mesmo Workspace em que a própria pasta de componentes reside, com suas revisões mais recentes indicadas entre colchetes. Escolha uma entrada para criar um vínculo com a revisão mais recente desse template de componente para cada componente criado posteriormente nessa pasta.

Especifique um template de componente padrão a ser aplicado a todos os componentes criados na pasta de componentes principal.
Se um template de componente for escolhido no nível da pasta, esse mesmo template será usado, por padrão, quando componentes forem criados nas subpastas abaixo dela. Isso facilita a herança rápida do template por todos os componentes nas subpastas.
Impacto nos modelos e parâmetros de componentes ao usar um template de componente
Ao editar uma revisão de um componente, quando uma revisão de um template de componente está vinculada/referenciada, ocorre o seguinte no Editor de Componentes em relação aos modelos e parâmetros:
- Os modelos definidos no template referenciado são adicionados à região Models (modo Single Component Editing) e à região Model Links (modo Batch Component Editing).
- Um modelo referenciado existente será mantido, e o componente continuará usando esse modelo, a menos que ele seja alterado manualmente de forma intencional.
-
Os parâmetros definidos no template referenciado são adicionados à região Parameters (modo Single Component Editing) e à região Required Models/Parameters (modo Batch Component Editing).

Exemplo de parâmetros após a vinculação a uma revisão de um template de componente, ao usar o Editor de Componentes no modo Single Component Editing (à esquerda) e no modo Batch Component Editing (à direita). -
Somente no modo Batch Component Editing, os parâmetros baseados no template configurados para serem exibidos são agrupados na área de definições de componentes do editor, com
Template Parametersusado como texto do cabeçalho.
Aparência dos parâmetros de exemplo baseados no template na área em que as próprias definições dos componentes são estabelecidas, ao usar o Editor de Componentes no modo Batch Component Editing. -
Os campos de valor dos parâmetros baseados no template que foram marcados como somente leitura não poderão ser editados. Para todos os outros parâmetros baseados no template que não foram marcados como somente leitura, você pode alterar os valores conforme necessário.
-
Se um parâmetro baseado no template tiver sido marcado como obrigatório, mas não tiver recebido um valor no template, seu campo de valor aparecerá com uma borda vermelha (no modo Batch Component Editing) ou contendo o ícone
(no modo Single Component Editing), alertando que é necessário um valor para esse parâmetro. Você não poderá salvar um componente no Workspace até que os valores de todos os parâmetros obrigatórios sejam definidos.
Salvando novamente um template de componente
A qualquer momento, você pode retornar a qualquer revisão de um template de componente no Workspace e editá-la diretamente. Clique com o botão direito na revisão e escolha o comando Edit no menu de contexto. Mais uma vez, o editor temporário será aberto, com o template contido na revisão aberto para edição. Faça as alterações necessárias e salve o template de componente na próxima revisão do Item.

Acessando o comando para iniciar a edição direta de uma revisão existente de um template de componente.
Baixando dados salvos
Baixe os dados armazenados em uma revisão de um template de componente clicando com o botão direito nessa revisão (no painel Explorer) e escolhendo o comando Operations » Download no menu de contexto. O arquivo do template de componente será baixado em uma subpasta do diretório escolhido, nomeada com o ID da revisão do Item. O arquivo pode ser encontrado na pasta Released dentro dela.
Exclusão reversível
Quando conectado a um Workspace, você dispõe de uma funcionalidade flexível para remover um template de componente diretamente no Altium Designer, a partir do painel Explorer. Clique com o botão direito na entrada do template de componente no painel e escolha o comando Delete Item no menu de contexto. A caixa de diálogo Delete Items será exibida para confirmar a exclusão. A ação é, na verdade, uma “exclusão reversível”, na qual o template de componente será movido para a área Trash do Workspace. A Trash é basicamente uma lixeira para a qual qualquer conteúdo do Workspace pode ser movido (por meio de uma ação de exclusão reversível). Ela fica isolada do restante do Workspace.

Exclusão reversível de um template de componente. O template será movido para a área Trash do Workspace.
Para prosseguir com a exclusão, clique no botão
. O item será removido e uma caixa de diálogo Deletion Summary confirmará que a exclusão foi concluída com sucesso. Se houver algum problema com a exclusão, você será notificado.
Todo o conteúdo excluído dessa maneira pode ser encontrado na página Trash da interface do Workspace no navegador. Observe que você só pode visualizar o conteúdo que você mesmo excluiu de forma reversível. Os administradores poderão visualizar todo o conteúdo da página Trash – ou seja, todo o conteúdo que foi excluído de forma reversível.
Aspectos a considerar em relação a um modelo de componente excluído de forma reversível:
- O modelo de componente não estará disponível no seu software de projeto nem na interface Web.
- Todos os locais em que o modelo de componente estava sendo usado indicarão que ele foi excluído.
- Um modelo de componente pode ser restaurado ou excluído permanentemente na página Trash, desde que você tenha permissões de edição. A exclusão permanente só é possível se ele não estiver sendo usado por um item pai.







).