Шаблоны компонентов

Краткий обзор

Шаблоны компонентов в подключенном рабочем пространстве помогают упростить создание компонентов в Altium Designer благодаря многократно используемым настройкам и параметрам. В этой статье объясняется, как упорядочивать элементы шаблонов компонентов, выбирать схемы именования и жизненного цикла, а также использовать прямое редактирование для настройки и сохранения шаблонов в рабочем пространстве. Кроме того, рассматриваются средства управления видимостью параметров, значениями по умолчанию, обязательными полями и возможностью переопределения значений разработчиком. Читайте дальше, чтобы приступить к созданию многократно используемых шаблонов, обеспечивающих единообразие описаний компонентов.

- Узнайте, как настроить папки рабочего пространства и элементы шаблонов компонентов с подходящими схемами именования, ревизий и жизненного цикла.
- Разберитесь, как шаблоны управляют параметрами компонентов, включая обязательные значения и значения по умолчанию, доступные только для чтения.
- Узнайте, как редактировать шаблоны напрямую и сохранять их в рабочем пространстве в виде новых ревизий.
Узнайте больше с ИИ:

Чтобы упростить создание компонентов, Altium Designer совместно с подключенным рабочим пространством поддерживает создание и настройку Component Templates (элементов шаблонов компонентов) в этом рабочем пространстве. Подобно тому, как шаблон схемы позволяет заранее задать информацию для использующих его листов схемы, шаблон компонента используется библиотечным компонентом рабочего пространства и предоставляет предустановленные настройки для его определения.

В частности, шаблоны компонентов разработаны с особым вниманием к параметрическим данным: они позволяют централизованно задать набор параметров, доступных компоненту, который использует этот шаблон. С помощью шаблона можно управлять видимостью параметров, задавать значения по умолчанию и даже отмечать параметры, обязательные для заполнения. При сохранении компонента выполняются проверки на соответствие этим требованиям.

Значения по умолчанию для многих настроек шаблона можно заблокировать, сделав их доступными только для чтения, или выборочно разрешить разработчику переопределять их при создании компонента.

Шаблон компонента также служит основой для создания обобщенного компонента. Подробнее см. на странице Создание обобщенных компонентов.

Доступность шаблонов компонентов зависит от лицензии на программное обеспечение. Дополнительные сведения см. в блоке Note в правой части страницы.

Такие шаблоны компонентов создаются непосредственно в рабочем пространстве. После создания шаблона компонента и сохранения его данных в ревизии его можно многократно использовать для создания одного или нескольких компонентов.

Тип папки

При создании папки для хранения шаблонов компонентов можно указать ее тип. Это не влияет на содержимое папки: при выпуске шаблона компонента всегда создается соответствующий элемент шаблона компонента (Component Template Item). Тип папки лишь визуально указывает на ее содержимое, что удобно при поиске определенных данных в рабочем пространстве. Чтобы обозначить папку как контейнер для шаблонов компонентов, при настройке ее свойств в диалоговом окне Edit Folder задайте для Folder Type значение Component Templates.

Указание типа папки — ее назначения — позволяет визуально определить ее содержимое при просмотре рабочего пространства.
Указание типа папки — ее назначения — позволяет визуально определить ее содержимое при просмотре рабочего пространства.

Тип содержимого

При создании целевого элемента шаблона компонента (Component Template Item), в котором будет храниться ваш шаблон, убедитесь, что для Content Type задано значение Component Template в диалоговом окне Create New Item. Если элемент создается в папке типа Component Templates, этот тип содержимого будет доступен в контекстном меню, вызываемом правой кнопкой мыши.

Создание шаблона компонента в папке Component Templates — нужный Content Type доступен в контекстном меню.
Создание шаблона компонента в папке Component Templates — нужный Content Type доступен в контекстном меню.

Сохранение шаблона компонента

Related page: Создание и редактирование содержимого

До этого мы рассматривали поддержку шаблонов компонентов в рабочем пространстве с точки зрения связанных типов папок и содержимого. Сохранить настроенный шаблон компонента в ревизии такого элемента шаблона компонента можно простым и удобным способом.

Благодаря поддержке непосредственного редактирования в рабочем пространстве шаблон компонента можно отредактировать и сохранить в начальной ревизии вновь созданного элемента шаблона компонента. Непосредственное редактирование избавляет от необходимости отдельно хранить исходные данные под управлением системы контроля версий. Достаточно открыть поддерживаемый тип содержимого во временном редакторе, в который загружаются актуальные исходные данные прямо из рабочего пространства. По завершении редактирования объект сохраняется или повторно сохраняется в следующей запланированной ревизии родительского элемента, а временный редактор закрывается. На жестком диске не остается файлов, не возникает сомнений в том, что вы работаете с нужной и актуальной версией исходных данных, и не требуется обслуживать отдельную систему контроля версий. Рабочее пространство берет все это на себя, обеспечивая целостность данных и значительно ускоряя внесение изменений.

При создании элемента шаблона компонента можно сразу после его создания отредактировать и сохранить шаблон компонента в начальной ревизии этого элемента. Для этого включите параметр Open for editing after creation в нижней части диалогового окна Create New Item (по умолчанию он включен). Элемент будет создан, и откроется временный редактор шаблонов компонентов, в котором документ .CMPT будет активным документом в главном окне проектирования. Имя этого документа будет соответствовать элементу и его ревизии в формате: <Item><Revision>.CMPT (например, CMPT-0001-1.CMPT).

 
 
 
 
 

Пример редактирования начальной ревизии шаблона компонента непосредственно из рабочего пространства: временный редактор шаблонов компонентов предоставляет документ для настройки шаблона компонента.
Пример редактирования начальной ревизии шаблона компонента непосредственно из рабочего пространства: временный редактор шаблонов компонентов предоставляет документ для настройки шаблона компонента.

Настройте шаблон компонента в этом документе в соответствии с требованиями. Подробнее об этом см. в разделе Настройка шаблона.

При непосредственном редактировании доступны три соответствующих элемента управления: в Quick Access Bar (в левом верхнем углу главного окна приложения) или на панели инструментов Component Template Standard:

  • — Save Active Document. Используйте эту кнопку для локального сохранения изменений, внесенных в документ. Это позволяет сохранить текущие изменения, чтобы позднее вернуться к редактированию, прежде чем окончательно сохранить шаблон в рабочем пространстве.
  • / — Save to Server. Используйте эту кнопку, чтобы сохранить настроенный шаблон компонента в рабочем пространстве, в начальной (запланированной) ревизии целевого элемента шаблона компонента. Появится диалоговое окно Edit Revision, в котором при необходимости можно изменить имя и описание, а также добавить примечания к выпуску. После сохранения документ и редактор закроются. Документ с исходным шаблоном компонента *.CMPT будет сохранен в ревизии элемента.

    Для удобства элемент управления Save to Server также доступен справа от записи шаблона компонента непосредственно на панели Projects.
  • / — Discard Local Changes. Используйте эту кнопку, если хотите отменить редактирование и отклонить все внесенные изменения. Документ и редактор закроются, и в целевой элемент шаблона компонента ничего не будет выпущено.

Эти элементы управления также доступны в виде команд — Save (сочетание клавиш: Ctrl+S), Save to Server (сочетание клавиш: Ctrl+Alt+S) и Discard Local Changes — в главном меню File и в контекстном меню записи шаблона компонента на панели Projects.

Сохраненные в рабочем пространстве данные представляют собой исходный шаблон компонента, заданный в файле шаблона компонента (<Item><Revision>.CMPT).

 
 
 
 
 

Пример настроенного шаблона компонента, сохраненного в рабочем пространстве.
Пример настроенного шаблона компонента, сохраненного в рабочем пространстве.

Наследование шаблона компонента

Эта функция доступна, если параметр UI.ComponentTemplateInheritance включен в диалоговом окне Advanced Settings.

Если с подтипом не связан шаблон компонента, можно использовать шаблон корневого типа компонентов. При построении иерархии типов компонентов подтипы наследуют шаблон компонента, назначенный корневому или родительскому типу компонентов.

Редактор CMPT (шаблонов компонентов)

Для доступа к редактору шаблонов компонентов в Altium Designer необходимо установить программное расширение Component Template Editor. По умолчанию это расширение устанавливается вместе с Altium Designer. Его можно установить или удалить вручную.

Подробнее об управлении расширениями см. на странице Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Настройка шаблона

Редактор шаблонов компонентов состоит из двух основных областей, показанных на следующем изображении и кратко описанных далее.

 
 
 
 
 

Редактор шаблонов компонентов можно условно разделить на две основные области.
Редактор шаблонов компонентов можно условно разделить на две основные области.

  1. Upper Region — для задания настроек уровня компонента (жизненный цикл, именование и настройки папки) для компонента, использующего этот шаблон.
  2. Lower Region — для задания параметров компонента, использующего этот шаблон.

Задание настроек компонента

Верхняя половина редактора предназначена для задания значений по умолчанию для следующих свойств компонента:

  • Lifecycle Definition — выберите определение жизненного цикла, которое будет применяться к компоненту, созданному на основе шаблона. В раскрывающемся списке представлены все определения, заданные для рабочего пространства и разрешенные для использования с компонентами.

  • Revision Naming — выберите схему именования ревизий, которая будет применяться к компоненту, созданному на основе шаблона. В раскрывающемся списке представлены все схемы, заданные для рабочего пространства и разрешенные для использования с компонентами.

    Если для каких-либо определений жизненного цикла или схем именования ревизий включена возможность управления их использованием по типам содержимого, а для типа содержимого Component не задано использование конкретного определения или схемы, то это определение или схема не будет доступно в соответствующем раскрывающемся списке.

  • Component Naming – используйте это поле, чтобы задать схему именования элементов по умолчанию для компонента, создаваемого на основе шаблона. Это обеспечит уникальность идентификатора компонента в рабочем пространстве. Введенное здесь значение будет использоваться в качестве шаблона для автоматического именования компонента (в соответствующем поле Id при использовании редактора компонентов в режиме Single Component Editing или в поле Item ID при использовании редактора компонентов в режиме Batch Component Editing). Программа автоматически назначит следующий доступный уникальный идентификатор на основе этой схемы, предварительно проверив все рабочее пространство и идентификаторы существующего содержимого. По умолчанию предусмотрена схема именования элементов CMP-{00000}, но вы, конечно, можете создать собственную схему, введя ее в это поле. При этом переменная часть должна быть заключена в фигурные скобки (например, CMP-001-{0000}).

  • Default Folder – позволяет указать папку по умолчанию в целевом рабочем пространстве для хранения сохраненного компонента. Для этого нажмите кнопку Choose, чтобы открыть диалоговое окно Choose Folder (вариант панели Explorer), в котором можно найти и выбрать существующую папку рабочего пространства или сразу создать новую.

Поле для задания целевого рабочего пространства отсутствует, поскольку всегда используется то же рабочее пространство, в котором находится ревизия шаблона компонента.

Параметр Allow override для каждого свойства позволяет независимо определять, может ли пользователь изменять это свойство при задании компонента в редакторе компонентов: если параметр включен — может, если выключен — нет.

При использовании шаблона значения, заданные в этой области, используются для предварительного заполнения соответствующих полей редактора компонентов (если они доступны):

  • Single Component Editing mode – поля Id и Folder в области Advanced Settings раздела Component.
  • Batch Component Editing mode – на вкладке Document Options диалогового окна Document Options и, соответственно, поля Item ID и FolderPath в области Component раздела определений компонентов.

При использовании шаблона заданные значения используются для предварительного заполнения соответствующих полей при редактировании компонента в редакторе компонентов в режиме Single Component Editing (слева) и режиме Batch Component Editing (справа).
При использовании шаблона заданные значения используются для предварительного заполнения соответствующих полей при редактировании компонента в редакторе компонентов в режиме Single Component Editing (слева) и режиме Batch Component Editing (справа).

Задание параметров

Нижняя половина редактора предназначена для задания параметров, которые будут доступны компоненту, использующему шаблон, и управления ими.

 
 
 
 
 

Пример параметров, заданных в шаблоне компонента.
Пример параметров, заданных в шаблоне компонента.

Системные параметры по умолчанию

При создании нового шаблона компонента в него по умолчанию включаются различные системные параметры, показанные на следующем изображении и подробно описанные далее.

 
 
 
 
 

Системные параметры по умолчанию, включенные в новый шаблон компонента.
Системные параметры по умолчанию, включенные в новый шаблон компонента.

  • ComponentType – этот параметр позволяет указать тип компонента. Это упрощает целевой поиск с помощью мощного средства поиска рабочего пространства, которое позволяет не только искать по типу компонента, но и выполнять более интеллектуальный поиск благодаря поддержке параметров компонентов с учетом единиц измерения. При просмотре компонентов вашего рабочего пространства на панели Components группировка компонентов Categories формируется на основе параметров ComponentType, связанных с каждым компонентом. Щелкните соответствующее поле Default Value, затем нажмите кнопку , чтобы открыть диалоговое окно Choose component type. Выберите в нем нужный тип компонента и нажмите OK — выбранный тип будет вставлен в качестве значения параметра ComponentType в основную таблицу параметров.

    В диалоговом окне Choose component type отображается набор типов компонентов, заданных на странице Data Management – Component Types диалогового окна Preferences. Нажмите кнопку в нижней части диалогового окна Choose component type, чтобы перейти на эту страницу настроек, где можно адаптировать список под свои задачи: добавить новые типы и подтипы либо изменить и удалить существующие.

    Пример шаблона компонента, в котором системному параметру ComponentType присвоено значение Diodes.
    Пример шаблона компонента, в котором системному параметру ComponentType присвоено значение Diodes.

    Для этого параметра установлен тип данных ComponentType, который нельзя изменить. Кроме того, параметр ComponentType нельзя удалить. Чтобы очистить значение, выберите ячейку и нажмите клавишу Delete .

  • SCHLIB и PCBLIB – эти два параметра позволяют указать модели условного графического обозначения и посадочного места по умолчанию соответственно. Щелкните соответствующее поле Default Value для каждого параметра, затем нажмите кнопку , чтобы открыть диалоговое окно выбора нужной модели.

    Обратите внимание: вы выбираете саму модель, а не конкретную ее ревизию. Таким образом, компонент, использующий шаблон, всегда будет использовать последнюю ревизию выбранной модели.

    Задайте модели условного графического обозначения и посадочного места в шаблоне.
    Задайте модели условного графического обозначения и посадочного места в шаблоне.

    Для этих параметров установлены типы данных SCHLIB и PCBLIB соответственно, которые нельзя изменить. Кроме того, параметры моделей нельзя удалить. Чтобы очистить значение, выберите ячейку и нажмите клавишу Delete.

  • Name и Description – эти два параметра позволяют задать имя и описание компонента соответственно. Введите нужные строки в соответствующее поле Default Value каждого параметра.

    Задайте параметры Name и Description в шаблоне.
    Задайте параметры Name и Description в шаблоне.

    Для обоих этих параметров установлен тип данных Text, который нельзя изменить. Кроме того, эти параметры нельзя удалить.

Поддерживается копирование и вставка системных параметров с возможностью вставки между документами шаблонов.

Выберите один или несколько параметров в шаблоне компонента, затем выполните команду Copy в контекстном меню выбранных параметров (сочетание клавиш: Ctrl+C). Скопированные параметры можно вставить в другой шаблон компонента с помощью команды Paste из контекстного меню (сочетание клавиш: Ctrl+V).

 
 
 
 
 

SCHLIB, Name и Description — системные параметры, выбранные и скопированные в шаблоне компонента Diodes.

Эти параметры были вставлены в другой шаблон компонента (Zeners), а их значения были применены к соответствующим параметрам. 

 

Добавление нового пользовательского параметра

Чтобы добавить в список новый пользовательский параметр, нажмите кнопку (или выполните команду Add в контекстном меню) — параметр будет добавлен в конец текущего списка.

 
 
 
 
 

Пример добавления нового пользовательского параметра в шаблон.
Пример добавления нового пользовательского параметра в шаблон.

Для каждого параметра в таблице представлены следующие сведения:

  • Name — используйте это поле, чтобы задать имя параметра. Как правило, следует выбирать осмысленное имя, отражающее его назначение. При добавлении параметрам присваиваются имена по умолчанию (Parameter, Parameter 1, Parameter 2 и т. д.).

  • Type — тип параметра. Изначально по умолчанию устанавливается Text, однако поддерживается ряд типов данных с учетом единиц измерения, а также тип PCBLIB, позволяющий задать несколько посадочных мест, и тип HarnessWiring, позволяющий задать компонент схемы соединений жгута. Также поддерживаются типы параметров, определенные в доступных словарях — подробнее.

  • Visible — включите этот параметр (для вновь добавленного параметра он включен по умолчанию), чтобы соответствующая опция Show была включена при редактировании одного или нескольких компонентов в редакторе компонентов, работающем в режиме Batch Component Editing. Эта опция, в свою очередь, управляет отображением соответствующего столбца параметра в нижней области редактора компонентов, где задаются определения самих компонентов. Это свойство не влияет на определение компонента в режиме Single Component Editing редактора.

  • Read Only — включите эту опцию, чтобы сделать параметр доступным только для чтения. При редактировании компонента, ссылающегося на шаблон, значение параметра будет недоступно для изменения.

  • Required — включите эту опцию, чтобы сделать параметр обязательным. При редактировании компонента, ссылающегося на шаблон, для этого параметра необходимо задать значение, иначе сохранить компонент будет невозможно. Если значение не введено, в редакторе компонентов такой параметр выделяется красной рамкой ячейки значения (в режиме Batch Component Editing) или значком в ячейке (в режиме Single Component Editing).

  • Default Value — используйте это поле, чтобы ввести значение параметра по умолчанию.

    • Если параметр отмечен как обязательный (включена опция Required) и при этом доступен только для чтения (включена опция Read Only), значение по умолчанию MUST быть введено. В противном случае при редактировании компонента, ссылающегося на шаблон, параметр будет отмечен как не имеющий значения, но исправить это не удастся, поскольку параметр доступен только для чтения и его нельзя изменить. Пока эта проблема не будет устранена, сохранить новую ревизию этого шаблона компонента в рабочей области будет невозможно.

    • При редактировании ревизии компонента существующий пользовательский параметр, имя которого совпадает с именем параметра в связанном шаблоне компонента, будет заменен версией из шаблона. При этом имеющееся значение параметра сохранится (и не будет перезаписано значением по умолчанию из шаблона).

  • Description — добавьте произвольное описание параметра, например краткое пояснение его назначения. Если для параметра в шаблоне задано описание, то в области Parameters редактора компонентов в режиме Single Component Editing будет отображаться столбец Description.

Список параметров также поддерживает обычные операции копирования и вставки, позволяя дублировать один или несколько существующих пользовательских параметров. Вставленные параметры добавляются в конец списка.

Поддерживаются стандартные сочетания клавиш для копирования (Ctrl+C) и вставки (Ctrl+V); эти команды также доступны в контекстном меню. Для копирования и вставки можно выбрать несколько пользовательских параметров стандартными способами с использованием Ctrl+Click и Shift+Click.
Чтобы удалить из списка один или несколько пользовательских параметров, выберите их, а затем нажмите кнопку или используйте команду Remove в контекстном меню.

Типы данных параметров компонентов с учетом единиц измерения

Редактор шаблонов компонентов позволяет явно задавать типы данных для параметров, определенных в шаблоне компонента (*.CMPT). Кроме того, эти типы данных учитывают единицы измерения и поддерживают ряд распространенных приставок. Поэтому значение параметра можно вводить в различных форматах, например 2.2k, 2k2, 4M, 2.5GHz, а рабочая область автоматически распознает числовое значение этих записей.

Эта возможность шаблона компонента упрощает целевой поиск с помощью серверной функции расширенного поиска, которая позволяет искать не только по типу компонента, но и по диапазонам значений. Благодаря параметрам компонентов с учетом единиц измерения можно быстро настроить поиск, например найти все конденсаторы с емкостью от 47 мкФ до 220 мкФ.

Параметры с учетом единиц измерения также используются для интеллектуальной фильтрации при поиске среди собственных компонентов с помощью панели Components.

Подробнее о параметрах с учетом единиц измерения см. в следующих раскрывающихся разделах.

Типы данных параметров, определяемые словарями

Словари — это пользовательские типы параметров с несколькими заданными значениями. Управление словарями выполняется администраторами рабочего пространства на странице Settings – Vault – Dictionaries браузерного интерфейса рабочего пространства. Перейти к ней из редактора шаблонов компонентов можно, выбрав пункт Add New Dictionary в раскрывающемся списке Type или нажав элемент управления Manage Dictionaries в правом верхнем углу области Parameters.

  • Страницу Settings – Vault – Dictionaries также можно открыть со страницы Управление данными – Словари диалогового окна Preferences, нажав элемент управления Manage Dictionaries, а также со страницы Управление данными – Серверы диалогового окна Preferences, нажав элемент управления Properties для активного или известного рабочего пространства и выбрав пункт Dictionaries в меню.

  • Если для параметра выбран тип, определяемый словарем, страницу Settings – Vault – Dictionaries также можно открыть, щелкнув ячейку параметра в столбце Type, а затем нажав кнопку  ().

Открытие страницы управления словарями в браузерном интерфейсе рабочего пространства из редактора шаблонов компонентов.
Открытие страницы управления словарями в браузерном интерфейсе рабочего пространства из редактора шаблонов компонентов.

Подробнее об управлении словарями через браузерный интерфейс рабочего пространства (рабочее пространство Altium 365, рабочее пространство Enterprise Server).

Созданные словари доступны в качестве типов параметров в раскрывающемся списке Type.

Выберите тип параметра, определяемый словарем, в раскрывающемся списке «Тип».
Выберите тип параметра, определяемый словарем, в раскрывающемся списке «Тип».

Значения, заданные для выбранного типа на основе словаря, доступны в раскрывающемся списке Default Value. Выберите нужное значение, чтобы использовать его в качестве значения параметра по умолчанию, или выберите <None>.

Выберите значение по умолчанию из значений, заданных для выбранного типа на основе словаря.
Выберите значение по умолчанию из значений, заданных для выбранного типа на основе словаря.

  • Значения по умолчанию проверяются при сохранении шаблона компонента в рабочую область. Если значение по умолчанию перестанет соответствовать словарю (например, значение было удалено из словаря, а затем шаблон, использующий это значение, был открыт для редактирования), оно будет выделено красным цветом в столбце Default Value, а при попытке сохранить шаблон обратно в рабочую область на панели Messages появится сообщение об ошибке.

  • Если значение параметра компонента перестанет соответствовать словарю (например, в шаблоне компонента тип этого параметра был изменен с Text на тип на основе словаря, а текущее значение параметра компонента не совпадает ни с одним значением выбранного типа на основе словаря), при редактировании компонента в редакторе компонентов этот параметр будет выделен: в режиме редактирования одного компонента рядом с несоответствующим значением параметра появится значок восклицательного знака, а в режиме пакетного редактирования компонентов значение параметра будет выделено красным цветом. Убедитесь, что все параметры компонента соответствуют значениям шаблона; в противном случае вы не сможете сохранить компонент в следующей ревизии.

  • Если словари были изменены в браузерном интерфейсе подключенной рабочей области, необходимо отключиться от рабочей области и подключиться к ней снова, чтобы эти изменения отобразились в Altium Designer. Подробнее см. на странице Доступ к рабочей области.

Задание нескольких посадочных мест

Редактор шаблонов компонентов также поддерживает задание нескольких посадочных мест печатной платы в шаблоне компонента. Можно указать любое количество ссылок на модели посадочных мест. Эта возможность будет полезна тем, кто хочет создавать компоненты, ссылающиеся на три посадочных места, которые соответствуют требованиям IPC для разных уровней плотности: L (наименьшая, или минимальная площадь меди), M (наибольшая, или максимальная площадь меди) и N (номинальная, или средняя площадь меди).

Чтобы добавить в шаблон еще одно определение модели посадочного места, нажмите для добавления нового параметра, затем выберите пункт PCBLIB в раскрывающемся меню поля Type.

Чтобы преобразовать добавленный параметр в определение модели посадочного места, установите для его Type значение PCBLIB.
Чтобы преобразовать добавленный параметр в определение модели посадочного места, установите для его Type значение PCBLIB.

Имя параметра изменится с Parameter на PCBLIB n, где n — следующее доступное целое число, позволяющее различать несколько моделей посадочных мест (например, PCBLIB 1, PCBLIB 2 и т. д.). Моделью по умолчанию будет модель, связанная с записью PCBLIB. Когда посадочные места добавляются в редактор компонентов при определении компонента, модель посадочного места по умолчанию обозначается значком в левом верхнем углу окна предварительного просмотра модели (в режиме Single Component Editing) и записью PCBLIB (default) в области Required Models/Parameters (в режиме Batch Component Editing).

Пример компонента, определяемого в редакторе компонентов (режим Single Component Editing) с использованием связанного шаблона компонента. В шаблоне заданы три модели посадочных мест, которые добавляются в определение компонента. Обратите внимание: запись модели PCBLIB в шаблоне используется как модель посадочного места по умолчанию при определении компонента (она отмечена значком в левом верхнем углу). Наведите указатель на изображение, чтобы увидеть определение того же компонента в редакторе компонентов в режиме Batch Component Editing. В этом случае посадочное место по умолчанию обозначается как PCBLIB (default).
Пример компонента, определяемого в редакторе компонентов (режим Single Component Editing) с использованием связанного шаблона компонента. В шаблоне заданы три модели посадочных мест, которые добавляются в определение компонента. Обратите внимание: запись модели PCBLIB в шаблоне используется как модель посадочного места по умолчанию при определении компонента (она отмечена значком в левом верхнем углу). Наведите указатель на изображение, чтобы увидеть определение того же компонента в редакторе компонентов в режиме Batch Component Editing. В этом случае посадочное место по умолчанию обозначается как PCBLIB (default).

Импорт и экспорт шаблонов компонентов

Существующий файл шаблона компонента (*.CMPT) или файл библиотеки компонентов (*.CMPLIB) можно импортировать в редактор шаблонов компонентов, а редактируемый шаблон компонента можно экспортировать в файл шаблона компонента (*.CMPT). Используйте команды File » Import » Component Template, File » Import » Component Library и File » Export главного меню редактора компонентов, чтобы выбрать нужное действие, а затем в открывшемся стандартном диалоговом окне Windows перейдите в нужную папку и выберите файл для импорта или задайте имя экспортируемого файла.

Повторное использование шаблона компонента

Использовать ревизию шаблона компонента — точнее, сослаться на нее из редактируемой ревизии компонента — можно следующими способами.

Компонент может ссылаться только на один шаблон компонента одновременно.

При создании нового компонента

При создании нового компонента с помощью команды File » New » Component главного меню можно выбрать шаблон в диалоговом окне Create new component.

Быстрое связывание с шаблоном компонента из списка всех доступных шаблонов при создании нового компонента.
Быстрое связывание с шаблоном компонента из списка всех доступных шаблонов при создании нового компонента.

Вручную из редактора компонентов

Способ использования ревизии шаблона компонента из редактора компонентов зависит от режима работы редактора.

В режиме редактирования одного компонента

При редактировании одного компонента в этом режиме редактора компонентов выберите нужный шаблон компонента в раскрывающемся меню поля Template, которое входит в группу Advanced Settings в области Component редактора. В списке по именам перечислены все шаблоны компонентов, доступные в той же рабочей области, где находится сам компонент; их последние ревизии указаны в скобках. Выберите нужный шаблон, чтобы применить его.

Быстрое связывание с шаблоном компонента из меню всех доступных шаблонов при редактировании ревизии компонента в редакторе компонентов в режиме Single Component Editing.
Быстрое связывание с шаблоном компонента из меню всех доступных шаблонов при редактировании ревизии компонента в редакторе компонентов в режиме Single Component Editing.

В режиме пакетного редактирования компонентов

Связать ревизию шаблона компонента с редактируемой ревизией компонента можно двумя способами:

  • На вкладке Template диалогового окна Параметры документа (Edit » Document Options). Нажмите кнопку Choose справа от поля Item Revision. Откроется диалоговое окно Choose Item (вариант панели Explorer). В этом диалоговом окне найдите и выберите ревизию нужного шаблона компонента. После нажатия OK будет создана связь между ревизией компонента и выбранной ревизией шаблона компонента. Эту связь можно увидеть на вкладке Template диалогового окна Document Options.

    Связывание компонента с ревизией шаблона компонента в целевой рабочей области вручную.
    Связывание компонента с ревизией шаблона компонента в целевой рабочей области вручную.

    Используемый шаблон компонента можно изменить в любой момент: нажмите Choose и выберите ревизию другого шаблона компонента.
    Состояние связанной ревизии элемента шаблона компонента отображается на вкладке Template диалогового окна Document Options. Если доступна более новая ревизия связанного элемента, нажмите кнопку , чтобы использовать последнюю ревизию.
  • Из меню Add, связанного с областью Required Models/Parameters редактора компонентов. В подменю Templates перечислены по именам все шаблоны компонентов, доступные в том же рабочем пространстве, где находится сам компонент; их последние ревизии указаны в скобках. Щелкните нужный пункт, чтобы создать ссылку на последнюю ревизию соответствующего шаблона компонента. Проверить наличие ссылки также можно на вкладке Templates диалогового окна Document Options.

    Быстрое связывание с шаблоном компонента через меню всех доступных шаблонов.
    Быстрое связывание с шаблоном компонента через меню всех доступных шаблонов.

Наследование из папки компонентов рабочего пространства

Можно указать шаблон компонента, который будет автоматически использоваться для всех компонентов и их ревизий, хранящихся в папке компонентов рабочего пространства.

Шаблон компонента по умолчанию можно задать только для папки типа Components.

Укажите нужный шаблон в поле Component Template при настройке свойств папки в диалоговом окне Edit Folder. В раскрывающемся списке этого поля перечислены по именам все шаблоны компонентов, доступные в том же рабочем пространстве, где находится сама папка компонентов; их последние ревизии указаны в скобках. Выберите нужный пункт, чтобы для каждого нового компонента, создаваемого в этой папке, формировалась ссылка на последнюю ревизию соответствующего шаблона компонента.

Укажите шаблон компонента по умолчанию, который будет применяться ко всем компонентам, создаваемым в родительской папке компонентов.
Укажите шаблон компонента по умолчанию, который будет применяться ко всем компонентам, создаваемым в родительской папке компонентов.

Чтобы не использовать эту возможность, оставьте или установите в поле Component Template значение None.

Если шаблон компонента выбран на уровне папки, по умолчанию он будет использоваться и при создании компонентов во вложенных папках. Это позволяет быстро распространить наследование шаблона на все компоненты в дочерних папках.

При сохранении ревизии компонента в рабочем пространстве фактически фиксируется конкретная ревизия используемого шаблона компонента: создается жесткая ссылка на эту ревизию, которая сохраняется до изменения вручную.

Влияние шаблона компонента на модели и параметры

При редактировании ревизии компонента, связанной с ревизией шаблона компонента, в редакторе компонентов происходит следующее в отношении моделей и параметров:

  • Модели, определенные в связанном шаблоне, добавляются в область Models (режим Single Component Editing) и область Model Links (режим Batch Component Editing).
  • Существующая связанная модель сохраняется, и компонент продолжает использовать ее, пока она не будет намеренно изменена вручную.
  • Параметры, определенные в связанном шаблоне, добавляются в область Parameters (режим Single Component Editing) и область Required Models/Parameters (режим Batch Component Editing).

    Пример параметров после связывания с ревизией шаблона компонента при использовании редактора компонентов в режиме Single Component Editing (слева) и режиме Batch Component Editing (справа).
    Пример параметров после связывания с ревизией шаблона компонента при использовании редактора компонентов в режиме Single Component Editing (слева) и режиме Batch Component Editing (справа).

    Все параметры, полученные из связанного шаблона компонента, отмечаются значком (режим Single Component Editing) или значком (режим Batch Component Editing). Кроме того, только в режиме пакетного редактирования компонентов состояние опции Show для каждого параметра из шаблона соответствует состоянию опции Visible в шаблоне.
    Параметры из шаблона нельзя удалить.
    При необходимости можно добавлять дополнительные пользовательские параметры.
  • Только в режиме Batch Component Editing параметры из шаблона, для которых включено отображение, объединяются в отдельную группу в области определений компонентов редактора с заголовком Template Parameters.

    Пример отображения параметров из шаблона в области определений компонентов при использовании редактора компонентов в режиме Batch Component Editing.
    Пример отображения параметров из шаблона в области определений компонентов при использовании редактора компонентов в режиме Batch Component Editing.

  • Поля значений параметров из шаблона, помеченных как доступные только для чтения, недоступны для редактирования. Значения всех остальных параметров из шаблона, не помеченных как доступные только для чтения, можно изменять по мере необходимости.

    В режиме Single Component Editing редактора компонентов параметр шаблона, доступный только для чтения, отмечается в области Parameters значком .
  • Если параметр из шаблона помечен как обязательный, но его значение в шаблоне не задано, поле значения отображается с красной рамкой (в режиме Batch Component Editing) или со значком (в режиме Single Component Editing), указывая на необходимость задать значение этого параметра. Сохранить компонент в рабочем пространстве можно только после задания значений всех обязательных параметров.

    В режиме Single Component Editing редактора компонентов обязательный параметр шаблона отмечается в области Parameters значком .

Повторное сохранение шаблона компонента

В любой момент можно вернуться к любой ревизии шаблона компонента в рабочем пространстве и отредактировать ее напрямую. Щелкните ревизию правой кнопкой мыши и выберите в контекстном меню команду Edit. Снова откроется временный редактор с шаблоном из выбранной ревизии, готовым к редактированию. Внесите необходимые изменения, затем сохраните шаблон компонента в следующую ревизию элемента.

При щелчке правой кнопкой мыши по записи верхнего уровня самого шаблона компонента для редактирования открывается последняя ревизия этого шаблона.

Доступ к команде запуска непосредственного редактирования существующей ревизии шаблона компонента.
Доступ к команде запуска непосредственного редактирования существующей ревизии шаблона компонента.

Скачивание сохраненных данных

Чтобы скачать данные, хранящиеся в ревизии шаблона компонента, щелкните эту ревизию правой кнопкой мыши (на панели Explorer) и выберите в контекстном меню команду Operations » Download. Файл шаблона компонента будет скачан во вложенную папку выбранного каталога, имя которой соответствует идентификатору ревизии элемента. Сам файл находится внутри нее в папке Released.

Вызовите команду Download для записи верхнего уровня самого шаблона компонента, чтобы скачать файл шаблона, хранящийся в его последней ревизии.
Нажмите кнопку Explore в диалоговом окне Download from Server, чтобы быстро открыть папку загрузки.

Мягкое удаление

При подключении к рабочему пространству доступны гибкие возможности удаления шаблона компонента непосредственно из Altium Designer с помощью панели Explorer. Щелкните запись шаблона компонента на панели правой кнопкой мыши и выберите в контекстном меню команду Delete Item. Появится диалоговое окно Delete Items, в котором нужно подтвердить удаление. Фактически выполняется «мягкое удаление»: шаблон компонента перемещается в область Trash рабочего пространства. Область Trash по сути представляет собой корзину, в которую можно переместить любое содержимое рабочего пространства с помощью мягкого удаления. Она изолирована от остальной части рабочего пространства.

Мягкое удаление позволяет удалить даже шаблон компонента, который в данный момент используется.
За одно действие можно удалить несколько шаблонов компонентов. Выберите все нужные шаблоны стандартными средствами множественного выбора (Shift+Click, Ctrl+Click), затем щелкните правой кнопкой мыши и выберите в контекстном меню команду Delete Items.

Мягкое удаление шаблона компонента. Шаблон будет перемещен в область Trash рабочего пространства.
Мягкое удаление шаблона компонента. Шаблон будет перемещен в область Trash рабочего пространства.

Чтобы продолжить удаление, нажмите кнопку . Элемент будет удален, а диалоговое окно Deletion Summary подтвердит успешное удаление. Если при удалении возникнет проблема, вы получите соответствующее уведомление.

Все содержимое, удаленное таким способом, можно найти на странице Trash веб-интерфейса рабочего пространства. Обратите внимание: вы можете просматривать только то содержимое, которое вы сами удалили обратимым способом. Администраторы могут видеть все содержимое страницы Trash, то есть все содержимое, удаленное обратимым способом.

При обратимом удалении шаблона компонента следует учитывать следующее:

  • Шаблон компонента будет недоступен как в программе проектирования, так и в веб-интерфейсе.
  • Везде, где использовался шаблон компонента, будет отображаться информация о его удалении.
  • Шаблон компонента можно восстановить или удалить безвозвратно со страницы Trash, если у вас есть права на редактирование. Безвозвратное удаление возможно только в том случае, если шаблон не используется родительским элементом.
Обратите внимание: если вы удалили шаблон компонента обратимым способом, переместив его в Trash, вы можете создать новый шаблон компонента с тем же именем. Если впоследствии вы восстановите исходный шаблон компонента, а его имя уже будет занято, к нему будет добавлен целочисленный суффикс, чтобы имя оставалось уникальным в пределах рабочего пространства.
AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents