Шаблоны компонентов

Для упрощения создания компонентов Altium Designer совместно с подключенным рабочим пространством поддерживает создание и определение Component Templates (элементов шаблонов компонентов) в этом рабочем пространстве. Подобно тому как шаблон схемы позволяет заранее задать информацию на листах схемы, которые на него ссылаются, компонент библиотеки рабочего пространства ссылается на шаблон компонента, содержащий предопределенные настройки для его описания.

Шаблоны компонентов разработаны прежде всего для работы с параметрической информацией: они позволяют в одном месте определить набор параметров, доступных компоненту, который ссылается на шаблон. С помощью шаблона можно управлять видимостью этих параметров, задавать значения по умолчанию и даже отмечать отдельные параметры как обязательные. При сохранении компонента выполняются проверки, обеспечивающие соблюдение этих требований.

Значения по умолчанию для многих настроек шаблона можно сделать доступными только для чтения либо выборочно разрешить разработчику переопределять их при описании компонента.

Шаблон компонента также служит основой для создания универсального компонента. Подробнее см. на странице Создание универсальных компонентов.

Доступ к шаблонам компонентов зависит от лицензии на программное обеспечение. Дополнительную информацию см. в блоке Note в правой части страницы.

Такие шаблоны компонентов создаются непосредственно в рабочем пространстве. После создания шаблона компонента (и сохранения данных в его ревизии) его можно повторно использовать для создания одного или нескольких компонентов.

Тип папки

При создании папки для хранения шаблонов компонентов можно указать ее тип. Это не влияет на содержимое папки: выпуск шаблона компонента всегда приводит к созданию соответствующего элемента шаблона компонента. Тип папки лишь служит визуальной подсказкой о ее содержимом и помогает при поиске нужных данных в рабочем пространстве. Чтобы обозначить папку как контейнер для шаблонов компонентов, задайте для Folder Type значение Component Templates при определении свойств папки в диалоговом окне Edit Folder.

Указание типа папки — ее назначения — позволяет визуально определить ее содержимое при просмотре рабочего пространства.
Указание типа папки — ее назначения — позволяет визуально определить ее содержимое при просмотре рабочего пространства.

Тип содержимого

При создании целевого элемента шаблона компонента для хранения вашего шаблона убедитесь, что для его Content Type задано значение Component Template в диалоговом окне Create New Item. Если вы создаете элемент в папке типа Component Templates, этот тип содержимого будет доступен в контекстном меню, открываемом щелчком правой кнопки мыши при создании элемента.

Создание шаблона компонента в папке Component Templates — нужный Content Type доступен в контекстном меню.
Создание шаблона компонента в папке Component Templates — нужный Content Type доступен в контекстном меню.

Сохранение шаблона компонента

Related page: Создание и редактирование содержимого

До сих пор мы рассматривали поддержку шаблонов компонентов в рабочем пространстве с точки зрения соответствующих типов папок и содержимого. Сохранить готовый шаблон компонента в ревизии такого элемента шаблона компонента можно простым и удобным способом.

Благодаря поддержке прямого редактирования в рабочем пространстве шаблон компонента можно отредактировать и сохранить в начальной ревизии вновь созданного элемента шаблона компонента. Прямое редактирование избавляет от необходимости отдельно хранить исходные данные под управлением системы контроля версий. Вы можете просто редактировать поддерживаемый тип содержимого во временном редакторе, в который загружаются последние исходные данные непосредственно из рабочего пространства. После завершения редактирования объект сохраняется (или повторно сохраняется) в следующей запланированной ревизии родительского элемента, а временный редактор закрывается. На жестком диске нет файлов, не нужно сомневаться, что вы работаете с правильной или последней версией исходных данных, и не требуется поддерживать отдельное программное обеспечение для контроля версий. Рабочее пространство берет все это на себя, обеспечивая целостность данных и значительно ускоряя внесение изменений.

При создании элемента шаблона компонента вы можете отредактировать шаблон компонента и сохранить его в начальной ревизии этого элемента. Для этого включите опцию Open for editing after creation в нижней части диалогового окна Create New Item (по умолчанию она включена). Будет создан элемент и открыт временный редактор шаблонов компонентов, в котором документ .CMPT будет активным документом в главном окне проектирования. Имя этого документа будет соответствовать элементу и его ревизии в формате: <Item><Revision>.CMPT (например, CMPT-0001-1.CMPT).

 
 
 
 
 

Пример редактирования начальной ревизии шаблона компонента непосредственно из рабочего пространства — временный редактор шаблонов компонентов предоставляет документ для определения шаблона компонента.
Пример редактирования начальной ревизии шаблона компонента непосредственно из рабочего пространства — временный редактор шаблонов компонентов предоставляет документ для определения шаблона компонента.

Используйте этот документ, чтобы определить шаблон компонента в соответствии с вашими требованиями. Подробнее см. в разделе Определение шаблона.

При непосредственном редактировании доступны три элемента управления, расположенные в Quick Access Bar (в левом верхнем углу главного окна приложения) или на панели инструментов Component Template Standard:

  • — Save Active Document. Используйте эту кнопку для локального сохранения изменений в документе. Это позволяет сохранить текущие изменения, если вы хотите вернуться к редактированию позже, прежде чем окончательно сохранить шаблон в рабочем пространстве.
  • / — Save to Server. Используйте эту кнопку, чтобы сохранить определённый шаблон компонента в рабочем пространстве, в начальной (запланированной) ревизии целевого элемента шаблона компонента. Откроется диалоговое окно Edit Revision, в котором можно изменить имя и описание, а также при необходимости добавить примечания к выпуску. После сохранения документ и редактор закроются. Документ с исходным шаблоном компонента, *.CMPT, будет сохранён в ревизии элемента.

    Элемент управления Save to Server также расположен справа от записи шаблона компонента непосредственно на панели Projects.
  • / — Discard Local Changes. Используйте эту кнопку, чтобы отменить редактирование и отбросить все внесённые изменения. Документ и редактор закроются, и в целевой элемент шаблона компонента ничего не будет выпущено.

Эти элементы управления также доступны в виде команд — Save (сочетание клавиш: Ctrl+S), Save to Server (сочетание клавиш: Ctrl+Alt+S) и Discard Local Changes — в главном меню File и в контекстном меню записи шаблона компонента на панели Projects.

Сохранённые в рабочем пространстве данные представляют собой исходный шаблон компонента, определённый в файле шаблона компонента (<Item><Revision>.CMPT).

 
 
 
 
 

Пример определённого шаблона компонента, сохранённого в рабочем пространстве.
Пример определённого шаблона компонента, сохранённого в рабочем пространстве.

Наследование шаблона компонента

Эта функция доступна, когда опция UI.ComponentTemplateInheritance включена в диалоговом окне Advanced Settings.

Если к подтипу не привязан шаблон компонента, можно использовать шаблон корневого типа компонентов. При построении иерархии типов компонентов подтипы наследуют шаблон компонента, назначенный корневому или родительскому типу компонентов.

Редактор CMPT (шаблонов компонентов)

Для доступа к редактору шаблонов компонентов в Altium Designer необходимо установить программное расширение Component Template Editor. По умолчанию это расширение устанавливается вместе с Altium Designer. Его можно установить или удалить вручную.

Подробнее об управлении расширениями см. на странице Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Определение шаблона

Редактор шаблонов компонентов разделён на две основные области, показанные на следующем изображении и кратко описанные ниже.

 
 
 
 
 

Редактор шаблонов компонентов можно условно разделить на две основные области.
Редактор шаблонов компонентов можно условно разделить на две основные области.

  1. Upper Region — для определения настроек уровня компонента (жизненного цикла, именования и папки) для компонента, ссылающегося на шаблон.
  2. Lower Region — для определения параметров, используемых компонентом, ссылающимся на шаблон.

Настройка свойств компонента

Верхняя половина редактора предназначена для определения значений по умолчанию для следующих свойств компонента:

  • Lifecycle Definition — выберите определение жизненного цикла, которое будет применяться к компоненту, созданному с использованием шаблона. В раскрывающемся списке перечислены все определения, заданные для рабочего пространства и разрешённые для использования компонентами.

  • Revision Naming — выберите схему именования ревизий, которая будет применяться к компоненту, созданному с использованием шаблона. В раскрывающемся списке перечислены все схемы, заданные для рабочего пространства и разрешённые для использования компонентами.

    Если для каких-либо определений жизненного цикла или схем именования ревизий включена настройка, управляющая их использованием в зависимости от типа содержимого, а для типа содержимого «Компонент» не задано использование определенного определения или схемы, то это определение или схема не будет доступно в соответствующем раскрывающемся списке.

  • Component Naming – используйте это поле, чтобы задать схему именования элементов по умолчанию для компонента, создаваемого на основе шаблона, и обеспечить уникальный идентификатор компонента в рабочем пространстве. Введенное здесь значение будет использоваться как шаблон для автоматического именования компонента (в соответствующем поле Id при использовании редактора компонентов в режиме Single Component Editing или в поле Item ID при использовании редактора компонентов в режиме Batch Component Editing). Программа автоматически назначит следующий доступный уникальный идентификатор на основе этой схемы, проверив все рабочее пространство и идентификаторы существующего содержимого. По умолчанию предусмотрена схема именования элементов CMP-{00000}, но вы можете создать собственную, введя ее в поле и заключив переменную часть в фигурные скобки (например, CMP-001-{0000}).

  • Default Folder – позволяет указать папку по умолчанию в целевом рабочем пространстве для хранения сохраненного компонента. Для этого нажмите кнопку Choose, чтобы открыть диалоговое окно Choose Folder (вариант панели Explorer), в котором можно найти и выбрать существующую папку в рабочем пространстве или сразу создать новую.

Поле для выбора целевого рабочего пространства отсутствует, поскольку всегда используется то же рабочее пространство, в котором находится ревизия шаблона компонента.

Параметр Allow override для каждого свойства позволяет независимо управлять тем, может ли пользователь изменять это свойство (включено) или нет (отключено) при определении компонента в редакторе компонентов.

При использовании шаблона значения, заданные в этой области, используются для предварительного заполнения соответствующих полей в редакторе компонентов (если они доступны):

  • Single Component Editing mode – поля Id и Folder в области Advanced Settings раздела Component.
  • Batch Component Editing mode – на вкладке Document Options диалогового окна Document Options и, соответственно, поля Item ID и FolderPath в области Component раздела определений компонентов.

При использовании шаблона заданные значения используются для предварительного заполнения соответствующих полей при редактировании компонента в редакторе компонентов в режиме Single Component Editing (слева) и режиме Batch Component Editing (справа).
При использовании шаблона заданные значения используются для предварительного заполнения соответствующих полей при редактировании компонента в редакторе компонентов в режиме Single Component Editing (слева) и режиме Batch Component Editing (справа).

Определение параметров

Нижняя половина редактора предназначена для определения параметров, которые будут доступны компоненту, использующему шаблон, и управления ими.

 
 
 
 
 

Пример параметров, заданных в шаблоне компонента.
Пример параметров, заданных в шаблоне компонента.

Системные параметры по умолчанию

При создании нового шаблона компонента в него по умолчанию включаются различные системные параметры, показанные на следующем изображении и подробно описанные далее.

 
 
 
 
 

Системные параметры, включенные по умолчанию в новый шаблон компонента.
Системные параметры, включенные по умолчанию в новый шаблон компонента.

  • ComponentType – этот параметр позволяет указать тип компонента. Это упрощает целевой поиск с помощью мощного средства поиска рабочего пространства, которое позволяет не только искать по типу компонента, но и выполнять более точный поиск благодаря поддержке параметров компонентов с учетом единиц измерения. При просмотре компонентов вашего рабочего пространства с помощью панели Components группировка компонентов Categories определяется параметрами ComponentType, связанными с каждым компонентом. Щелкните соответствующее поле Default Value, а затем нажмите кнопку , чтобы открыть диалоговое окно Choose component type. Выберите в нем нужный тип компонента и нажмите OK — выбранный тип будет подставлен в качестве значения параметра ComponentType в основной таблице параметров.

    В диалоговом окне Choose component type отображается набор типов компонентов, заданных на странице Data Management – Component Types диалогового окна Preferences. Нажмите кнопку в нижней части диалогового окна Choose component type, чтобы перейти на эту страницу настроек, где можно адаптировать список к своим потребностям: добавить новые типы и подтипы либо изменить и удалить существующие.

    Пример шаблона компонента, в котором системному параметру ComponentType присвоено значение Diodes.
    Пример шаблона компонента, в котором системному параметру ComponentType присвоено значение Diodes.

     
     
     
     
     

    Для этого параметра задан тип данных ComponentType, который нельзя изменить. Кроме того, параметр ComponentType нельзя скопировать или удалить. Выберите ячейку и нажмите клавишу Delete , чтобы очистить значение.

  • SCHLIB и PCBLIB — эти два параметра позволяют указать модели символа и посадочного места по умолчанию соответственно. Щелкните соответствующее поле Default Value для каждого параметра, а затем нажмите кнопку , чтобы открыть диалоговое окно выбора нужной модели.

    Обратите внимание: вы выбираете модель, а не конкретную ревизию этой модели. Таким образом, компонент, использующий шаблон, всегда будет использовать последнюю ревизию выбранной модели.

    Укажите модели символа и посадочного места в шаблоне.
    Укажите модели символа и посадочного места в шаблоне.

     
     
     
     
     

    Для этих параметров заданы типы данных SCHLIB и PCBLIB соответственно, которые нельзя изменить. Кроме того, параметры моделей нельзя скопировать или удалить. Выберите ячейку и нажмите клавишу Delete , чтобы очистить значение.

  • Name и Description — эти два параметра позволяют задать имя и описание компонента соответственно. Введите нужные строки в соответствующее поле Default Value для каждого параметра.

    Задайте параметры Name и Description в шаблоне.
    Задайте параметры Name и Description в шаблоне.

     
     
     
     
     

    Для обоих параметров задан тип данных Text, который нельзя изменить. Кроме того, эти параметры нельзя скопировать или удалить.

Добавление нового пользовательского параметра

Чтобы добавить новый пользовательский параметр в список, нажмите кнопку (или используйте команду Add в контекстном меню) — параметр будет добавлен в конец текущего списка.

 
 
 
 
 

Пример добавления нового пользовательского параметра в шаблон.
Пример добавления нового пользовательского параметра в шаблон.

Для каждого параметра в таблице отображается следующая информация:

  • Name – используйте это поле, чтобы задать имя параметра — как правило, осмысленное имя, отражающее его назначение. При добавлении параметрам присваиваются имена по умолчанию (Parameter, Parameter 1, Parameter 2 и т. д.).

  • Type – тип параметра. Изначально по умолчанию задается Text, однако поддерживается ряд типов данных с учетом единиц измерения, а также тип PCBLIB, позволяющий задать несколько посадочных мест, и HarnessWiring, позволяющий задать компонент схемы соединений жгута. Также поддерживаются типы параметров, определенные в доступных словарях — подробнее.

  • Visible – включите эту опцию (для нового параметра она включена по умолчанию), чтобы соответствующая опция Show для параметра была включена при редактировании одного или нескольких компонентов в редакторе компонентов (в режиме Batch Component Editing). Это, в свою очередь, управляет отображением соответствующего столбца параметра в нижней области редактора компонентов, где задаются определения самих компонентов. Это свойство не влияет на определение компонента в режиме Single Component Editing редактора.

  • Read Only – включите эту опцию, чтобы сделать параметр доступным только для чтения. При редактировании компонента, ссылающегося на шаблон, значение параметра будет недоступно для изменения.

  • Required – включите эту опцию, чтобы сделать параметр обязательным. При редактировании компонента, ссылающегося на шаблон, для параметра необходимо задать значение, иначе сохранить компонент будет невозможно. В редакторе компонентов такой параметр при отсутствии значения выделяется красной рамкой ячейки значения (в режиме Batch Component Editing) или значком в ней (в режиме Single Component Editing).

  • Default Value – используйте это поле, чтобы ввести значение параметра по умолчанию.

    • Если параметр отмечен как обязательный (включена опция Required) и при этом доступен только для чтения (включена опция Read Only), значение по умолчанию MUST быть задано. В противном случае при редактировании компонента, ссылающегося на шаблон, параметр будет отмечен как не имеющий значения, но исправить это будет невозможно, поскольку он доступен только для чтения и не допускает изменений. Пока эта проблема не будет устранена, новую ревизию этого шаблона компонента нельзя сохранить в рабочем пространстве.

    • При редактировании ревизии компонента существующий пользовательский параметр, имя которого совпадает с именем параметра в связанном шаблоне компонента, будет заменен версией из шаблона. Существующее значение этого параметра будет сохранено (и не будет перезаписано значением по умолчанию из шаблона).

  • Description – добавьте описание параметра, например краткое пояснение его назначения. Если для параметра в шаблоне задано описание, столбец Description будет соответственно отображаться в области Parameters редактора компонентов в его Single Component Editing.

Список параметров также поддерживает простые операции копирования и вставки, позволяя дублировать один или несколько существующих пользовательских параметров. Вставленные параметры добавляются в конец списка.

Поддерживаются стандартные сочетания клавиш для копирования (Ctrl+C) и вставки (Ctrl+V); эти команды также доступны в контекстном меню. Для копирования и вставки можно выбрать несколько пользовательских параметров стандартными способами с помощью Ctrl+Click и Shift+Click.
Чтобы удалить из списка один или несколько пользовательских параметров, выберите их, затем нажмите кнопку или воспользуйтесь командой Remove в контекстном меню.

Типы данных параметров компонентов с учетом единиц измерения

Редактор шаблонов компонентов позволяет явно задавать типы данных для параметров компонентов, определенных в шаблоне компонента (*.CMPT). Кроме того, эти типы данных учитывают единицы измерения и поддерживают ряд распространенных приставок. Поэтому значение параметра можно вводить в различных форматах, например 2.2k, 2k2, 4M, 2.5GHz, — рабочая область автоматически распознает числовое значение, соответствующее введенной записи.

Эта возможность шаблона компонента упрощает целевой поиск с помощью серверной функции расширенного поиска, которая позволяет искать не только по типу компонента, но и по диапазонам значений. Благодаря параметрам компонентов с учетом единиц измерения можно быстро задать поиск, например найти все конденсаторы с емкостью от 47uF до 220uF.

Параметры с учетом единиц измерения также используются для интеллектуальной фильтрации при поиске собственных компонентов на панели Components.

Подробнее о параметрах с учетом единиц измерения см. в раскрывающихся разделах ниже.

Типы данных параметров на основе словарей

Словари — это пользовательские типы параметров с набором заданных значений. Управление словарями выполняется администраторами рабочего пространства на странице Settings – Vault – Dictionaries в браузерном интерфейсе рабочего пространства. Открыть эту страницу из редактора шаблонов компонентов можно, выбрав Add New Dictionary в раскрывающемся списке Type или нажав элемент управления Manage Dictionaries в правом верхнем углу области Parameters.

  • Страницу Settings – Vault – Dictionaries также можно открыть со страницы Управление данными – Словари диалогового окна Preferences, нажав элемент управления Manage Dictionaries, а также со страницы Управление данными – Серверы диалогового окна Preferences, нажав элемент управления Properties для активного или известного рабочего пространства и выбрав пункт Dictionaries в меню.

  • Если для параметра выбран тип на основе словаря, страницу Settings – Vault – Dictionaries также можно открыть, щёлкнув ячейку параметра в столбце Type, а затем нажав кнопку ().

Откройте страницу управления словарями в браузерном интерфейсе рабочего пространства из редактора шаблонов компонентов.
Откройте страницу управления словарями в браузерном интерфейсе рабочего пространства из редактора шаблонов компонентов.

Подробнее об управлении словарями в браузерном интерфейсе рабочего пространства (рабочее пространство Altium 365, рабочее пространство Enterprise Server).

Заданные словари доступны в качестве типов параметров в раскрывающемся списке Type.

Выберите тип параметра на основе словаря в раскрывающемся списке «Тип».
Выберите тип параметра на основе словаря в раскрывающемся списке «Тип».

Значения, заданные для выбранного типа на основе словаря, доступны в раскрывающемся списке Default Value. Выберите нужное значение в качестве значения параметра по умолчанию или выберите <None>.

Выберите значение по умолчанию из значений, заданных для выбранного типа на основе словаря.
Выберите значение по умолчанию из значений, заданных для выбранного типа на основе словаря.

  • Значения по умолчанию проверяются при сохранении шаблона компонента в рабочее пространство. Если значение по умолчанию больше не соответствует словарю (например, значение было удалено из словаря, после чего шаблон, использующий это значение, был открыт для редактирования), оно будет выделено красным в столбце «Значение по умолчанию», а при попытке сохранить шаблон в рабочее пространство на панели Messages появится сообщение об ошибке.

  • Если значение параметра компонента перестаёт соответствовать словарю (например, тип этого параметра в шаблоне компонента был изменён с текстового на тип на основе словаря, а текущее значение параметра компонента не совпадает ни с одним значением выбранного типа на основе словаря), этот параметр будет выделен при редактировании компонента в редакторе компонентов: в режиме редактирования одного компонента рядом с несоответствующим значением параметра появится значок восклицательного знака, а в режиме пакетного редактирования компонентов значение параметра будет выделено красным. Убедитесь, что все параметры компонента соответствуют значениям шаблона; иначе вы не сможете сохранить следующую ревизию компонента.

  • Если словари были изменены в браузерном интерфейсе подключённого рабочего пространства, необходимо отключиться от рабочего пространства и подключиться к нему повторно, чтобы эти изменения отобразились в Altium Designer. Подробнее см. на странице Доступ к рабочему пространству.

Задание нескольких посадочных мест

Редактор шаблонов компонентов также позволяет задавать несколько посадочных мест печатной платы в шаблоне компонента. Можно указать любое количество ссылок на модели посадочных мест. Эта возможность особенно полезна при создании компонентов с тремя посадочными местами, соответствующими требованиям IPC для разных уровней плотности: L (наименьший, или минимальная площадь меди), M (наибольший, или максимальная площадь меди) и N (номинальный, или средняя площадь меди).

Чтобы добавить в шаблон ещё одно определение модели посадочного места, нажмите для добавления нового параметра, затем выберите пункт PCBLIB в раскрывающемся меню поля Type.

Преобразуйте добавленный параметр в определение модели посадочного места, установив для его Type значение PCBLIB.
Преобразуйте добавленный параметр в определение модели посадочного места, установив для его Type значение PCBLIB.

Имя параметра изменится с Parameter на PCBLIB n, где n — следующее доступное целое число, позволяющее различать модели посадочных мест (например, PCBLIB 1, PCBLIB 2 и т. д.). Моделью по умолчанию будет модель, связанная с записью PCBLIB. При добавлении посадочных мест в редактор компонентов во время определения компонента модель посадочного места по умолчанию обозначается значком в левом верхнем углу окна предварительного просмотра модели (в режиме Single Component Editing) и записью PCBLIB (default) в области Required Models/Parameters (в режиме Batch Component Editing).

Пример компонента, определяемого в редакторе компонентов (режим Single Component Editing) с использованием связанного шаблона компонента. В шаблоне заданы три модели посадочных мест, которые добавляются в определение компонента. Обратите внимание: при определении компонента запись модели PCBLIB в шаблоне используется как модель посадочного места по умолчанию (она отмечена значком в левом верхнем углу). Наведите указатель на изображение, чтобы увидеть определение того же компонента в редакторе компонентов в режиме Batch Component Editing. В этом случае посадочное место по умолчанию обозначается как PCBLIB (default).
Пример компонента, определяемого в редакторе компонентов (режим Single Component Editing) с использованием связанного шаблона компонента. В шаблоне заданы три модели посадочных мест, которые добавляются в определение компонента. Обратите внимание: при определении компонента запись модели PCBLIB в шаблоне используется как модель посадочного места по умолчанию (она отмечена значком в левом верхнем углу). Наведите указатель на изображение, чтобы увидеть определение того же компонента в редакторе компонентов в режиме Batch Component Editing. В этом случае посадочное место по умолчанию обозначается как PCBLIB (default).

Импорт и экспорт шаблона компонента

Существующий файл шаблона компонента (*.CMPT) или файл библиотеки компонентов (*.CMPLIB) можно импортировать в редактор шаблонов компонентов, а редактируемый шаблон компонента можно экспортировать в файл шаблона компонента (*.CMPT). Используйте команды File » Import » Component Template, File » Import » Component Library и File » Export главного меню редактора компонентов, чтобы выбрать нужное действие, а затем в открывшемся стандартном диалоговом окне Windows перейдите в нужную папку и выберите файл для импорта или задайте имя экспортируемого файла.

Повторное использование шаблона компонента

Использовать ревизию шаблона компонента — точнее, связать с ней редактируемую ревизию компонента — можно следующими способами.

Компонент может быть связан только с одним шаблоном компонента одновременно.

При создании нового компонента

При создании нового компонента с помощью команды File » New » Component главного меню можно выбрать шаблон в диалоговом окне Create new component.

Быстрое подключение шаблона компонента из списка всех доступных шаблонов при создании нового компонента.
Быстрое подключение шаблона компонента из списка всех доступных шаблонов при создании нового компонента.

Вручную в редакторе компонентов

Способ повторного использования ревизии шаблона компонента в редакторе компонентов зависит от режима работы редактора.

В режиме редактирования одного компонента

При редактировании одного компонента в этом режиме редактора компонентов выберите нужный шаблон компонента в раскрывающемся меню поля Template, входящего в группу Advanced Settings в области Component редактора. В списке приведены названия всех шаблонов компонентов, доступных в том же рабочем пространстве, где находится сам компонент; их последние ревизии указаны в скобках. Выберите нужный шаблон, чтобы применить его.

Быстрое подключение шаблона компонента из меню всех доступных шаблонов при редактировании ревизии компонента в редакторе компонентов в режиме Single Component Editing.
Быстрое подключение шаблона компонента из меню всех доступных шаблонов при редактировании ревизии компонента в редакторе компонентов в режиме Single Component Editing.

В режиме пакетного редактирования компонентов

Связать редактируемую ревизию компонента с ревизией шаблона компонента можно двумя способами:

  • На вкладке Template диалогового окна Параметры документа (Edit » Document Options). Нажмите кнопку Choose справа от поля Item Revision. Откроется диалоговое окно Choose Item (вариант панели Проводник). В этом окне найдите и выберите ревизию нужного шаблона компонента. После нажатия OK будет создана связь между ревизией компонента и выбранной ревизией шаблона компонента. Эту связь можно увидеть на вкладке Template диалогового окна Document Options.

    Ручное связывание компонента с ревизией шаблона компонента в целевом рабочем пространстве.
    Ручное связывание компонента с ревизией шаблона компонента в целевом рабочем пространстве.

    Используемый шаблон компонента можно изменить в любой момент: нажмите Choose и выберите ревизию другого шаблона компонента.
    Состояние связанной ревизии элемента шаблона компонента отображается на вкладке Template диалогового окна Document Options. Если доступна более новая ревизия связанного элемента, нажмите кнопку , чтобы использовать эту последнюю ревизию.
  • В меню Add, связанном с областью Required Models/Parameters редактора компонентов. В подменю Templates приведены названия всех шаблонов компонентов, доступных в том же рабочем пространстве, где находится сам компонент; их последние ревизии указаны в скобках. Нажмите на запись, чтобы создать связь с последней ревизией соответствующего шаблона компонента. Проверить наличие связи также можно на вкладке Templates диалогового окна Document Options.

    Быстрое подключение шаблона компонента из меню всех доступных шаблонов.
    Быстрое подключение шаблона компонента из меню всех доступных шаблонов.

Наследование от папки компонентов в рабочем пространстве

Можно указать шаблон компонента, который будет автоматически использоваться для всех компонентов (и их ревизий), хранящихся в папке компонентов рабочего пространства.

Шаблон компонента по умолчанию можно задать только для папки типа Components.

Укажите нужный шаблон в поле Component Template при настройке свойств папки в диалоговом окне Редактирование папки. В раскрывающемся списке этого поля приведены названия всех шаблонов компонентов, доступных в том же рабочем пространстве, где находится сама папка компонентов; их последние ревизии указаны в скобках. Выберите запись, чтобы каждый компонент, впоследствии создаваемый в этой папке, связывался с последней ревизией соответствующего шаблона компонента.

Укажите шаблон компонента по умолчанию, который будет применяться ко всем компонентам, создаваемым в родительской папке компонентов.
Укажите шаблон компонента по умолчанию, который будет применяться ко всем компонентам, создаваемым в родительской папке компонентов.

Чтобы не использовать эту возможность, оставьте или установите в поле Component Template значение None.

Если шаблон компонента выбран на уровне папки, этот же шаблон будет по умолчанию использоваться при создании компонентов во вложенных папках. Это позволяет быстро распространить шаблон на все компоненты в дочерних папках посредством наследования.

При сохранении ревизии компонента в рабочее пространство конкретная ревизия используемого шаблона компонента фактически фиксируется: создаётся жёсткая связь с этой ревизией, которую можно изменить только вручную.

Влияние использования шаблона компонента на модели и параметры компонента

Если при редактировании ревизии компонента устанавливается связь с ревизией шаблона компонента, в редакторе компонентов с моделями и параметрами происходит следующее:

  • Модели, заданные в связанном шаблоне, добавляются в область Models (режим Single Component Editing) и область Model Links (режим Batch Component Editing).
  • Уже связанная модель сохраняется, и компонент продолжает использовать её, если она не будет явно изменена вручную.
  • Параметры, заданные в связанном шаблоне, добавляются в область Parameters (режим Single Component Editing) и область Required Models/Parameters (режим Batch Component Editing).

    Пример параметров после связывания с ревизией шаблона компонента при использовании редактора компонентов в режиме Single Component Editing (слева) и режиме Batch Component Editing (справа).
    Пример параметров после связывания с ревизией шаблона компонента при использовании редактора компонентов в режиме Single Component Editing (слева) и режиме Batch Component Editing (справа).

    Все параметры, полученные из связанного шаблона компонента, отмечаются значком (режим Single Component Editing) и значком (режим Batch Component Editing). Кроме того, только в режиме пакетного редактирования компонентов состояние опции Show для каждого параметра из шаблона соответствует состоянию опции Visible в шаблоне.
    Параметры, полученные из шаблона, нельзя удалить.
    При необходимости можно добавлять дополнительные пользовательские параметры.
  • Только в режиме Batch Component Editing параметры из шаблона, для которых включено отображение, объединяются в группу в области определений компонентов редактора; в качестве заголовка используется Template Parameters.

    Пример отображения параметров на основе шаблона в области определения компонентов при использовании редактора компонентов в режиме Batch Component Editing.
    Пример отображения параметров на основе шаблона в области определения компонентов при использовании редактора компонентов в режиме Batch Component Editing.

  • Поля значений параметров на основе шаблона, отмеченных как доступные только для чтения, нельзя редактировать. Значения всех остальных параметров на основе шаблона, не отмеченных как доступные только для чтения, можно изменять по мере необходимости.

    В редакторе компонентов в режиме Single Component Editing параметр шаблона, доступный только для чтения, отмечается в области Parameters значком .
  • Если параметр на основе шаблона отмечен как обязательный, но в шаблоне для него не задано значение, его поле значения отображается с красной рамкой (в режиме Batch Component Editing) или со значком (в режиме Single Component Editing), указывающим, что для этого параметра необходимо задать значение. Вы не сможете сохранить компонент в рабочую область, пока не будут заданы значения всех обязательных параметров.

    В редакторе компонентов в режиме Single Component Editing обязательный параметр шаблона отмечается в области Parameters значком .

Повторное сохранение шаблона компонента

На любом этапе можно вернуться к любой ревизии шаблона компонента в рабочей области и отредактировать ее напрямую. Щелкните правой кнопкой мыши по ревизии и выберите команду Edit в контекстном меню. Снова откроется временный редактор, в котором шаблон из выбранной ревизии будет открыт для редактирования. Внесите необходимые изменения, затем сохраните шаблон компонента в следующую ревизию элемента.

Если щелкнуть правой кнопкой мыши по записи верхнего уровня самого шаблона компонента, для редактирования будет открыта последняя ревизия этого шаблона.

Доступ к команде запуска непосредственного редактирования существующей ревизии шаблона компонента.
Доступ к команде запуска непосредственного редактирования существующей ревизии шаблона компонента.

Скачивание сохраненных данных

Чтобы скачать данные, хранящиеся в ревизии шаблона компонента, щелкните правой кнопкой мыши по этой ревизии (на панели Explorer) и выберите команду Operations » Download в контекстном меню. Файл шаблона компонента будет скачан в подпапку выбранного каталога, имя которой соответствует идентификатору ревизии элемента. Файл находится в папке Released внутри этой подпапки.

Чтобы скачать файл шаблона компонента, хранящийся в последней ревизии этого шаблона, вызовите команду Download для записи верхнего уровня самого шаблона компонента.
Нажмите кнопку Explore в диалоговом окне Download from Server, чтобы быстро открыть папку со скачанными файлами.

Мягкое удаление

При подключении к рабочей области доступен гибкий механизм удаления шаблона компонента непосредственно из Altium Designer, с панели Explorer. Щелкните правой кнопкой мыши по записи шаблона компонента на панели и выберите команду Delete Item в контекстном меню. Появится диалоговое окно Delete Items, в котором нужно подтвердить удаление. Фактически выполняется «мягкое удаление»: шаблон компонента перемещается в раздел Trash рабочей области. Раздел Trash по сути представляет собой корзину, в которую можно переместить любое содержимое рабочей области посредством мягкого удаления. Он изолирован от остальной рабочей области.

Механизм мягкого удаления позволяет удалить даже тот шаблон компонента, который в данный момент используется.
За одну операцию можно удалить несколько шаблонов компонентов. Выберите все необходимые шаблоны компонентов с помощью стандартных средств множественного выбора (Shift+Click, Ctrl+Click), затем щелкните правой кнопкой мыши и выберите команду Delete Items в контекстном меню.

Мягкое удаление шаблона компонента. Шаблон будет перемещен в раздел Trash рабочей области.
Мягкое удаление шаблона компонента. Шаблон будет перемещен в раздел Trash рабочей области.

Чтобы продолжить удаление, нажмите кнопку . Элемент будет удален, а диалоговое окно Deletion Summary подтвердит успешное удаление. Если при удалении возникнет проблема, вы получите соответствующее уведомление.

Все содержимое, удаленное таким образом, находится на странице Trash браузерного интерфейса рабочей области. Обратите внимание: вы можете просматривать только то содержимое, которое лично удалили посредством мягкого удаления. Администраторы могут видеть все содержимое страницы Trash, то есть все содержимое, которое было удалено посредством мягкого удаления.

При мягком удалении шаблона компонента следует учитывать следующее:

  • Шаблон компонента будет недоступен как в программном обеспечении для проектирования, так и в веб-интерфейсе.
  • Во всех местах, где использовался шаблон компонента, будет отображаться информация о том, что он удален.
  • Шаблон компонента можно восстановить или удалить безвозвратно со страницы Trash, если у вас есть права на редактирование. Безвозвратное удаление возможно только в том случае, если шаблон не используется родительским элементом.
Обратите внимание: если вы выполнили мягкое удаление шаблона компонента, переместив его в Trash, вы можете снова создать шаблон компонента с тем же именем. Если впоследствии вы восстановите исходный шаблон компонента, а его первоначальное имя уже будет занято, к имени будет добавлен целочисленный суффикс, чтобы обеспечить его уникальность в рабочей области.
AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents