Altium Designer Documentation

Варианты проекта

Последнее изменение: Pavel Demidov; 08.05.2020

Содержание

Полное содержание

Иллюстрация трех вариантов умных часов

Когда изделие необходимо разработать и изготовить в виде набора вариаций (исполнений) этого изделия, где каждая из этих вариаций имеет разные опции или функции, возможность реализации вариантов проекта (Design Variants) избавляет от необходимости создавать уникальные версии этого проекта для каждого варианта.

На практике, вариант проекта использует один базовый проект, но на плату устанавливается набор компонентов, указанный для этой вариации. Затем вариант может быть указан при формировании выходных данных для изготовления проекта (состав изделия, файлы для установки поверхностно монтируемых компонентов, сборочные чертежи и т.д.), которые, в свою очередь, определяют, как будет изготовлен печатный узел.

Возможность создания вариантов одного и того же базового проекта делает создание проектов в Altium Designer намного более гибким. Используя варианты, вы можете определить, любое количество вариаций проекта платы, где каждый компонент может быть настроен как:

  • Установленный на плате.
  • Неустановленный на плате.
  • Установленный на плате, но с измененными параметрами компонента, такими как номинал.
  • Совершенно другой компонент, в качестве альтернативной замены компонента.

Варианты проекта, которые используют любой из этих типов вариаций, называются вариантами сборки (Assembly Variants), поскольку они влияют только на процесс сборки – в этом случае, все варианты используют одну и ту же печатную плату.

Altium Designer также поддерживает вариации информации в плате на слое шелкографии компонентов, например, изменение комментария компонента. Для таких вариантов необходимо изготовление двух шаблонов для шелкографии, что приводит к изготовлению двух разных печатных плат. Такой тип вариаций называется вариантами изготовления (Fabrication Variant).

Создание вариантов проекта, их изменение и управление ими осуществляется в диалоговом окне Variant Management Altium Designer, которое открывается с помощью команды Projects » Variants главного меню.

Логические и физические компоненты

Полезно понимать, что в Altium Designer, по сути, есть два типа компонентов: логические компоненты и физические компоненты. Различие заключается в том, что компоненты, размещенные на листе схемы, являются логическими компонентами, каждый из которых представляет концептуальную сущность, которая, в конечном итоге, будет установлена на печатную плату.

Хотя такая однозначная модель, где каждый логический компонент соответствует одному физическому компоненту, хорошо работает в простых проектах, она не способна поддерживать некоторые более мощные функции Altium Designer. Примером могут служить многоканальные проекты, где участки цепей "дублируются" необходимое количество раз, и варианты, где один проект может быть реализован с различными компонентами, установленными в каждом из вариантов. Для этих функций необходимо, чтобы один логический компонент представлял множество физических компонентов.

Altium Designer обеспечивает это через технологию компиляции. При компиляции логического проекта, которая осуществляется автоматически, в оперативной памяти создаются физические компоненты, готовые к передаче в рабочую область конструкции платы.

Для поддержки таких ситуаций, где доступ к физическим компонентам необходим на уровне схемы, например при определении вариантов, физический проект становится доступным в редакторе схем через вкладки, расположенные в нижней части схемного листа. Вкладка Editor слева представляют стандартный логический проект, а прочие "скомпилированные" вкладки представляют эквивалентный физический проект, который будет передан в редактор плат – обратите внимание, что схема на скомпилированных вкладках доступна только для чтения.

Работа с физическим отображением определенного варианта проекта в редакторе схемВид физического проекта в редакторе схем. Выберите нужный вариант проекта, дважды щелкнув ЛКМ по записи варианта в панели Projects.

Для изучения вариантов проекта дважды щелкните ЛКМ по нужному варианту в панели Projects и переключитесь на скомпилированную вкладку схемы (вкладку физического проекта). При переключении на скомпилированную вкладку панель инструментов Active Bar в верхней части рабочей области изменится, и здесь будут отображены специфичные для вариантов кнопки. Эти кнопки доступны только когда вариант выбран в панели Projects.
Обратите внимание, что при переходе на скомпилированную вкладку, доступные элементы меню изменятся, и они будут отражать команды, которые могут быть запущены при просмотре физического проекта. Щелкните ЛКМ по вкладке логического проекта (Editor) в нижней части листа схемы, чтобы вернуться к стандартным меню редактирования.

Типы вариаций

Функциональная возможность создания вариантов, как следует из названия, формирует вариации оригинального, или "базового", проекта платы. После создания этого базового проекта, создание вариантов осуществляется в менеджере вариантов путем задания компонентов на плате как установленных, установленных с отличными параметрами, неустановленных, либо использования альтернативных компонентов.

Установленный компонент

"Установленный" является состоянием по умолчанию для компонента перед применением каких-либо вариаций – если компонент установлен, то он не изменён. Все компоненты являются установленными по умолчанию при создании нового варианта в диалоговом окне Variant Management (см. ниже), где установленное состояние компонента представлено пустой ячейкой.

Установленный с отличными параметрами

Процесс определения варианта позволяет задавать компоненту любые отличные параметры. Изменение значения параметра является локальной вариацией, которая повлияет только на выходную документацию – изначальная схема и компонент с отличным параметром не изменяются каким-либо образом. На изображении ниже, у компонента C8 отличается параметр Value, и эта вариация обозначается курсивным шрифтом при отображении значения этого параметра.

Неустановленный компонент

Когда компонент задан как Not Fitted, он все еще существует на схеме и он будет передан на плату (посадочное место может быть размещено), но он будет удален из соответствующей выходной документации, такой как состав изделия (BOM). Способ, которым неустановленные компоненты представляются в документации, может быть настроен. Например, они могут быть отмечены перекрестием на схеме и в распечатках платы – см. диалоговое окно Variant Options, открываемое с помощью кнопки Drawing Style в диалоговом окне Variant Management.

Варианты, пример неустановленных компонентов и компонентов в отличными параметрами
В выбранном варианте (BGA) компоненты C4 и C6 установлены, C5 и C7 не установлены, C8 установлен, но с отличным значением параметра.

Альтернативный компонент

Вариация также может быть задана как совершенно другой компонент, т.е. как альтернативный компонент. При выборе скомпилированной вкладки в редакторе схем, альтернативный компонент будет показан при переключении между вариантами. Для вариации этого типа, у альтернативного компонента должен быть тот же набор выводов, размещенных в тех же местах, что и у базового компонента. Это ключевое требование, которое обеспечивает корректную связность при компиляции проекта. Наведите курсор мыши на изображение ниже, чтобы отобразить альтернативные компоненты для R3 и Q1 в варианте TSOP.

Варианты, пример альтернативного компонента
Q1 является NPN-транзистором в варианте BGA и JFET-транзистором в варианте TSOP (наведите курсор мыши на изображение, чтобы увидеть вариант TSOP) – обратите внимание, что в каждом случае используются одни и те же выводы.

Существует два способа обработки альтернативного компонента на плате:

  • Если используется одно и то же посадочное место – если у выбранного альтернативного компонента используется посадочное место с тем же именем, что и у базового компонента, то только один экземпляр этого посадочного места будет передан в плату. Поскольку компоненту может быть назначено множество посадочных мест, необходимо убедиться, что в диалоговом окне Variant Management для каждого варианта выбрано корректное посадочное место.
  • Если используются разные посадочные места – если у выбранного альтернативного компонента компонента используется посадочное место с именем, отличным от базового компонента, то в плату будут переданы оба посадочных места. Затем вам будет необходимо решить, как эти два посадочных места будут размещены на плате. Обратите внимание, что у обоих посадочных мест будет одно и то же позиционное обозначение, поскольку только один из этих компонентов будет установлен. На анимации ниже показано, как это может быть реализовано, когда в одном варианте используется оперативная память в BGA, а другом варианте – оперативная память в TSOP.

Изменение типа компонента

Возможность выбирать альтернативный компонент не ограничена выбором компонента того же типа, поэтому вы можете, например, задать резистор в качестве базового компонента, затем определить конденсатор в качестве альтернативного компонента. При выборе типа альтернативного компонента важно понимать следующее:

  • Позиционное обозначение – есть только одно позиционное обозначение для каждого логического базового компонента, и именно это позиционное обозначение используется для всех вариантов. Если, например, резистор меняется на конденсатор, для этого может понадобиться использование специального префикса позиционного обозначения, такой как R_C или R-C.
  • Выводы – у альтернативного компонента должно быть то же количество выводов, что и у базового компонента, и эти выводы должны располагаться в тех же местах и иметь те же электрические типы. Если эти условия не соблюдены, появится предупреждение.

Многоканальные проекты

Главная страница: Многолистовые и многоканальные проекты

Многоканальный проект позволяет проектировщику указать, что один лист схемы или дерево листов дублируются, т.е. область проекта повторяется множество раз. Копирование и вставка вручную не требуется, поскольку система управляет процессом дублирования, и проектировщик лишь определяет способ аннотирования, используемый для идентификации повторяющихся компонентов.

В многоканальных проектах Altium Designer поддерживается возможность замены базового компонента совершенно другим компонентом для выбранного варианта.

Видео с демонстрацией двух вариантов сборки одной платы На анимации, в варианте BGA установлены два устройства оперативной памяти, а в варианте установлены четыре устройства оперативной памяти. Это реализовано путем задания одного из двух каналов памяти как неустановленного в варианте BGA.

С точки зрения каналов:

  • В варианте компоненты могут варьироваться для всех каналов, что включает в себя вариации: компоненты установлены/не установлены, отличаются определенные параметры компонентов, либо выбраны альтернативные компоненты.
  • Для определенного канала в многоканальном проекте, компоненты могут варьироваться: компоненты установлены/не установлены, либо отличаются определенные параметры компонентов.

Сводка по поддерживаемым вариациям

Тип вариации Применено ко всем каналам В определенном канале
Установлен/не установлен Поддерживается Поддерживается
Измененные параметры Поддерживается Поддерживается
Альтернативный компонент Поддерживается Не поддерживается
Основное правило: если вы используете альтернативный компонент, он должен использоваться во всех каналах.

Создание и настройка варианта

Создание и настройка вариантов осуществляется в диалоговом окне Variant Management. Чтобы открыть его, выберите команду Variants из меню Project (последовательность клавиш: C, V).

Диалоговое окно содержит две основные области:

  • Верхняя область Components for project, в которой приводится список всех компонентов в базовом проекте и столбцы для вариантов, если они применены.
  • Нижняя область Component Parameters, в которой приведена информация по всем параметрам компонентов, выделенных в данный момент в верхней области, и столбцы для вариантов, если они применены.

Диалоговое окно Variant Management, варианты не заданы
Создание и настройка вариантов осуществляется в диалоговом окне Variant Management.

Для перехода к компоненту на схеме дважды щелкните по нему в диалоговом окне Variant Management либо выберите команду Cross Probe из контекстного меню.

Создание нового варианта

Нажмите кнопку Кнопка Add Variant в диалоговом окне Variant Management для создания нового варианта базового проекта. Будет открыто диалоговое окно Edit Project Variant, где следует ввести имя варианта в поле Description и нажать OK. Прочие опции в этом диалоговом окне описаны подробнее ниже.

Кнопка Add Variant включает в себя выпадающее меню, которое предоставляет доступ к команде Clone Selected Variant (доступна, когда выбран существующий вариант). Клонирование позволяет легко и быстро создать ряд похожих вариантов.

В правой части диалогового окна Variant Management появится дополнительный столбец, заголовком которого будет название нового варианта. Все ячейки в этом столбце будут пустыми, что означает, что этот компонент установлен и он не отличается базового проекта. Компоненты теперь могут быть настроены для этого нового варианта. На изображении ниже показан проект с двумя созданными вариантами: BGA и TSOP.

Диалоговое окно Variant Management, задано два варианта
Участок 1 на изображении приводит информацию о компонентах в базовом проекте, участок 2 приводит информацию о компонентах в варианте BGA, и участок 3 приводит информацию о компонентах в варианте TSOP.

Чтобы активировать вариант, щелкните ЛКМ по его названию в заголовке столбца или по какой-либо из ячеек этого варианта.

Диалоговое окно Variant Management включает в себя ряд функциональных возможностей интерфейса, которые помогают для отображения полезной информации. Они настраиваются через контекстное меню.

Контекстное меню диалогового окна Variant Management

Полезные команды:

  • Columns (Столбцы):
    • Столбец Hierarchy Path (Путь иерархии) – отображает расположение компонента в иерархии проекта.
    • Столбец Original Library Link (Ссылка на изначальную библиотеку) – отображает, откуда был взят компонент.
  • Set Selected As (Задать выделенное как) – подменю, используемое для выбора типа вариации (установлен, не установлен, альтернативный). Можно использовать вместо нажатия по элементу управления Кнопка с многоточием, используемая для настройки варианта в ячейке компонента. Доступно только при щелчке ПКМ по ячейке компонента в варианте.
  • Only Show Varied Parameters (Отображать только измененные компоненты) – отображает в диалоговом окне Variant Management только компоненты, к которым применены какие-либо вариации.
  • Filter (Фильтр) – подменю, которое позволяет управлять тем, какие типы вариаций необходимо отображать в диалоговом окне Variant Management (измененные параметры, не установлен, альтернативный). Хорошо работает в сочетании с командой Only Show Varied Parameters.
Измененные параметры – параметр, который отличается от базового проекта, отображается полужирным шрифтом в области Component Parameters диалогового окна Variant Management, что упрощает его визуальную идентификацию.

Определение вариаций компонентов

После того, как сам вариант создан, вы можете начать изменять состояние каждого из компонентов. Это осуществляется щелчком по ячейке компонента в столбце варианта для отображения элемента управления Кнопка с многоточием, используемая для настройки варианта или щелчком ПКМ по невыделенной ячейке для доступа к подменю Set Selected As.

Элемент управления Кнопка с многоточием, используемая для настройки варианта открывает диалоговое окно Edit Component Variation, в котором (как и подменю Set Selected As) доступны три опции:

  • Fitted – в этом варианте проекта будет установлен (будет использоваться) изначальный компонент, который используется в базовом проекте. Для нового варианта, все компоненты устанавливаются по умолчанию, и ячейки этих установленных компонентов пусты. Обратите внимание, для установленного компонента также могут быть изменены отдельные параметры путем ввода нового значения параметра в области параметров для этого варианта.
  • Not Fitted – в этом варианте проекта изначальный компонент, который используется в базовом проекте, не будет установлен (не будет использоваться). Для этого состояния компонента, в ячейке отображается текст Not Fitted, и нижняя область параметров диалогового окна будет пустой.
  • Alternate Part – эта опция позволяет выбрать другой (альтернативный) компонент. Когда этот компонент выбран, в ячейке отображается исходная ссылка на альтернативный компонент. В нижней области параметров компонента будут отображены все параметры альтернативного компонента.
Поддерживаются стандартные способы Windows для множественного выделения. Используйте их для выбора и одновременной настройки множества компонентов.

Выбор альтернативного компонента

При выборе в диалоговом окне Edit Component Variation опции Alternate Part будут отображены базовые параметры существующего компонента. Используйте кнопку , чтобы найти нужный альтернативный компонент в диалоговом окне Replace Component, которое является аналогом панели Components. Поддерживаются все модели хранения компонентов Altium Designer, такие как независимые библиотеки, библиотеки на основе баз данных, а также серверные компоненты (как показано в примере ниже).

После выбора альтернативного компонента, система проверяет совместимость по выводам между выбранным альтернативным компонентом и изначальным базовым компонентом. Чтобы альтернативный компонент был совместимым по выводам, у него должно быть то же количество выводов, что и у изначального компонента, и у этих выводов должно быть то же расположение и электрический тип. Графические примитивы, используемые в символах этих двух компонентов, не обязательно должны совпадать.

Если система обнаружит, что альтернативный компонент не является совместимым по выводам, перед принятием размещения необходимо закрыть диалоговое окно Confirm. В этом случае, необходимо осознавать потенциальное влияние на связность, а также то, что при валидации проекта (Project » Validate <НазваниеПроекта>) могут появиться нарушения.

Диалоговое окно Variant Management, настройка альтернативного компонента
Пример задания альтернативного компонента.

Примененный альтернативный компонент может быть передан обратно в рабочую область редактора. На листе схемы, применимом для этого компонента, переключитесь на скомпилированную вкладку и выберите нужный вариант в разделе Variants проекта в панели Projects.

Редактор схем будет использовать графику символа альтернативного компонента. Тем не менее, если компонент совместим по выводам и графически схож с оригинальным компонентом, изменение может быть малозаметным.

Для упрощения визуальной идентификации измененных компонентов, цвет и шрифт измененных параметров (например, строка комментария компонента) также отличается. Это настраивается в диалоговом окне Variant Options – нажмите кнопку в диалоговом окне Variant Management, чтобы открыть диалоговое окно. Обратите внимание на зеленый курсивный шрифт, используемый для альтернативного компонента, на анимации ниже.

Видео, демонстрирующее отображение вариантов параметровГрафическое отличие измененного компонента. В этом примере, оба варианта использует один и тот же символ компонента, но в варианте BGA используется другой размер оперативной памяти.

Если альтернативный компонент не используется в других местах проекта, графика символа альтернативного компонента сохраняется в папке проекта в отдельном файле [ИмяПроекта].PrjPcbVariants. Использование файла .PrjPcbVariants позволяет проекту быть независимым от исходных библиотек, которые использовались для создания проекта. Обратите внимание, что изменения параметров для альтернативных компонентов, определенных в диалоговом окне Variant Management, сохраняются в самом файле проекта.

Режим отображения символа

Если базовый компонент использует режим графического отображения, отличный от режима Normal по умолчанию, и для этого компонента используется альтернативный компонент, заданный в варианте, то альтернативный компонент попытается использовать тот же графический режим отображения. Если альтернативный компонент не включает в себя этот графический режим отображения, будет использоваться режим Normal.

Режимы отображения компонента определяются в редакторе схемных библиотек с помощью команд Component Display Mode, и их выбор для размещенного компонента осуществляется в разделе Graphical панели Properties, как показано ниже. В этом примере, символ базового компонента использует режим Alternate 1.

Свойства компонента на схеме, выбор альтернативного графического режима
Альтернативный компонент попытается использовать режим графического отображения с тем же номером, что и у базового компонента.

Altium Designer поддерживает несколько подходов к хранению компонентов и работе с ними, в том числе использование файла DBLink в проекте. Файл DBLink является интерфейсом между компонентами на схеме и базой данных предприятия.

Вместо создания ссылки из каждого компонента на определенную запись в базе данных (как это обычно происходит при размещении компонента из библиотеки типа DBLib), модель DBLink основана на том, что проектировщик инициирует запрос на основе одного или множества параметров компонента. Система проведет в базе данных поиск записи с полями, которые содержат совпадающие значения, и при совпадении, прочие значения полей из этой записи (такие как номер компонента) будут возвращены в компонент Altium Designer. Отображение параметров компонентов в поля базы данных определяется в документе DBLink как в целевой базе данных.

► Узнайте больше о Работе с библиотеками на основе баз данных.

В проекте, в котором не используются варианты, запрос осуществляется через команду Update Parameters from Database, и его также можно осуществить в процессе формирования состава изделия включением опции Include Parameters from Database (см. ниже) для извлечения данных компонента, специфичных для состава изделия (BOM), таких как цена.

Для проекта, который включает в себя варианты, параметры, используемые для запроса в базу данных, изменяются в диалоговом окне Variant Management. Поскольку значения этих параметров существуют только в диалоговом окне Variant Management, для извлечения информации из базы данных не используется команда Update Parameters from Database – вместо этого, параметры извлекаются из базы данных при формировании состава изделия.

Отображение данных в менеджере вариантов

Диалоговое окно Variant Management включает в себя функциональные возможности для управления объемом отображаемых данных, которые могут быть особенно полезными при работе с большим проектом.

  • Чтобы удалить не нужный в данный момент столбец, щелкните ПКМ в верхней части диалогового окна и используйте опцию Columns из контекстном меню для переключения видимости любого из столбцов.
  • Чтобы отобразить только измененные компоненты, щелкните ПКМ в верхней части диалогового окна и выберите опцию Only Show Varied Components из контекстного меню.
  • Когда выбран режим Only Show Varied Components, снова щелкните ПКМ и настройте опции фильтра (Filter). На изображении ниже, фильтр был настроен на отображение только тех компонентов, для которых используются альтернативные компоненты.
  • Для изменения порядка вариантов, перетащите с зажатой ЛКМ заголовок столба варианта в новое место. Используйте это в сочетании с флажком Fit to Width для позиционирования и задания размера интересующего варианта.

Диалоговое окно Variant Management, где применен фильтр для отображения только альтернативных компонентов
Диалоговое окно Variant Management со скрытыми заголовками столбцов и фильтром, примененным только для отображения компонентов, которые используют альтернативные компоненты.

Отображение вариантов в проектных документах

Способ, которым измененные компоненты представляются в документах схем (и в распечатках плат), настраивается в диалоговом окне Variant Options. Эти настройки впоследствии влияют на то, как вариации компонентов представляются в распечатках и выходных документах PDF, а также в выходных чертежах платы, таких как сборочные чертежи. Чтобы открыть диалоговое окно Variant Options, нажмите кнопку Drawing Style в нижней части диалогового окна Variant Management после выбора ячейки в соответствующем столбце варианта.

Диалоговое окно Variant Options, где настроено отображение измененных параметровИспользуйте диалоговое окно Variant Options для настройки того, как варианты представляются в документах схем и в выходных документах плат.

Сброс и обновление данных вариантов

Настройки вариантов в диалоговом окне Variant Management, в конечном итоге, сохраняются в файле проекта. Это включает в себя неустановленные состояния, локальные вариации параметров компонентов в установленном состоянии и значения параметров альтернативных компонентов. Сами альтернативные компоненты сохраняются в файле [ИмяПроекта].PrjPcbVariants. Диалоговое окно Variant Management включает в себя команду для сброса параметров и обновления компонентов, что помогает убедиться, что они синхронизированы с исходными библиотеками компонентов.

Обновление измененных параметров

Параметры, измененные локально в диалоговом окне Variant Management, могут быть восстановлены до своих изначальных значений щелчком ПКМ по измененному параметру (показаны полужирным шрифтом) в списке параметров варианта и выбором Reset Selected из контекстного меню – как показано ниже. Обратите внимание, что можно выбрать сразу множество параметров и сбросить их в одно действие, либо использовать Reset All для всех параметров компонента.

Диалоговое окно Variant Management, сброс измененного параметра
Восстановить значения измененных параметров можно с помощью команды Reset Selected.

Обновление параметра альтернативного компонента

Если у библиотечного компонента, который используется в качестве альтернативного компонента, изменены параметры в библиотеке, то эти изменения можно перенести непосредственно в определения вариантов проекта щелчком ПКМ по списку параметров этого варианта и выбором Update Values from Library из меню (как показано ниже). Обратите внимание, что при этом будут обновлены параметры – если необходимо обновить графику, используйте способ, описанный ниже.

Диалоговое окно Variant Management, обновление значений параметров компонентов из библиотеки, запуск команды
Если альтернативный компонент был изменен в библиотеке, используйте команду Update Values from Library для обновления копии, используемой в проекте.

После запуска команды Update Values from Library, найдите компонент в исходной библиотеке или на сервере управляемых данных (через диалоговое окно Browse Libraries или диспетчер содержимого сервера) и нажмите OK, чтобы открыть диалоговое окно Update Project Variants From Library. Включите или отключите опции Parameters from Library Component и Variants to Update, затем нажмите OK, чтобы завершить процесс обновления.

Если компонент, выбранный для обновления параметров, является серверным управляемым компонентом, будет открыто диалоговое окно, аналогичное панели Components, а не диалоговое окно Browse Libraries. Найдите нужный компонент, нажмите OK, чтобы открыть диалоговое окно Update Project Variants From Library и выберите нужные параметры для обновления, как описано здесь.

Диалоговое окно Variant Management, обновление значений параметров компонентов из библиотеки, выбор нужных параметров
Обновление измененного компонента из исходной библиотеки. Здесь вы задаете, какие параметры необходимо обновить и к каким вариантам следует применить обновления.

Все параметры перечислены в левой части диалогового окна Update Project Variants From Library – если необходимо, вы можете снять выделение с любого параметра, чтобы исключить его из процесса обновления. В правой части диалогового окна может быть изменен целевой вариант проекта (Project Variant To Update) – по умолчанию будет выбран вариант, который был выбран при активации команды Update Values from Library.

Обратите внимание, что этот процесс обновления параметров обновит значения параметров непосредственно из библиотеки в диалоговом окне Variant Management, но не копию компонента, которая сохранена в файле [ИмяПроекта].PrjPcbVariants. Если позже вы выполните одну из команд для сброса значений параметров, которая извлечет значения из файла PrjPcbVariants, она может откатить параметр до более раннего значения и перезаписать текущие изменения. Чтобы этого не произошло, обновите компонент в файле PrjPcbVariants с помощью процесса, описанного ниже.

Полное обновление альтернативного компонента

Если исходный компонент, который используется в качестве альтернативного компонента, был изменен в своей библиотеке, его можно обновить в проекте запуском мастера Update from Library.

Этот мастер, запускаемый из меню Tools редактора схем, включает в себя опцию Include Variants. Когда эта опция включена, в списке компонентов будут отображены все компоненты, используемые в качестве альтернативных компонентов. Отметьте в списке компоненты, которые необходимо обновить, затем завершите обновление необходимых компонентов из источника.

Диалоговое окно Variant Management, полное обновление альтернативного компонента из библиотеки
Для полного обновления альтернативного компонента, в том числе его графики, поставьте флажок Include Variants и включите компонент, который необходимо обновить.

Если были изменены библиотечные компоненты, используемые в базовом проекте, они обновляются обычными способами:

  • с помощью команды Tools » Update from Library редактора схем, или
  • с помощью команды Tools » Update Schematics редактора схемных библиотек.

Изменение множества параметров множества компонентов

Диалоговое окно Variant Management поддерживает множественное выделение, что означает, что в верхней части диалогового окна может быть одновременно выбрано любое количество компонентов, после чего выполняется обновление любого количества параметров, выбранных в нижней части диалогового окна. Это диалоговое окно также предоставляет фильтры (через контекстное меню) для дальнейшего сужения выделения и отображаемых данных.

Например, чтобы сбросить параметры, измененные вручную, для всех компонентов во всех вариантах:

  1. В верхней части диалогового окна используйте опцию Only Show Varied Components в сочетании с опцией Filter контекстного меню, чтобы показывать только установленные компоненты с измененными параметрами (Show Fitted with Varied Parameters). Список компонентов должен теперь отображать только компоненты с измененными вручную параметрами.
  2. Щелкните ПКМ в списке компонентов и выберите Select All из контекстного меню. Будут выбраны все компоненты, отображенные в данный момент в верхней части диалогового окна.
  3. Затем щелкните ПКМ в нижней части диалогового окна и выберите Select All из контекстного меню. Теперь будут выделены все параметры всех компонентов. Обратите внимание, что для применения какого-либо действия (например, сброс) к компонентам в определенном варианте (столбце) следует выбрать команду Select Column.
  4. Снова щелкните ПКМ в списке параметров и выберите Reset Selected из контекстного меню. Наведите курсор мыши на изображение ниже, чтобы отобразить шаги 2, 3 и 4.

Диалоговое окно Variant Management, где применен фильтр для отображения измененных параметров, и последующий сброс измененных параметров
Сброс всех параметров, измененных вручную, для всех компонентов во всех вариантах. Наведите курсор мыши на изображение, чтобы увидеть шаги 2, 3 и 4.

Если вы экспериментировали с настройками фильтра и применили различные фильтры, вам может понадобиться сбросить фильтр перед применением другого обновления. Для этого отключите опцию Only Show Varied Components для очистки фильтра, затем включите его снова и очистите опции Filter необходимым образом.

Работа с параметрами вариантов

Altium Designer поддерживает параметры на различных уровнях проекта. Например, параметры на уровне документа могут быть добавлены в лист схемы на вкладке Parameters в панели Properties редактора схем (когда нет выделенных объектов). Параметры на уровне проекта могут быть добавлены в проект на вкладке Parameters диалогового окна Options for Project (Project » Options). Далее, параметры также могут быть добавлены в вариант через диалоговое окно Edit Project Variant. В диалоговом окне Variant Management выберите столбец вариантов и нажмите кнопку Edit Variant, чтобы открыть это диалоговое окно.

Существует иерархия параметров, добавленных на разные уровни проекта, что означает, что вы можете создать параметры с одним и тем же именем на разных уровнях проекта, но с разными значениями. Altium Designer решает подобные ситуации на основе приоритетов следующим образом:

  1. Вариант (наивысший приоритет)
  2. Документ схемы
  3. Проект

Такой порядок означает, что значение параметра, определенного на уровне документа схемы, переопределяет значение, определенное в настройках проекта, а значение параметра, определенного в варианте, переопределяет значение, определенное в документе схемы. Обратите внимание, что параметры на уровне схемы не доступны в плате или в составе изделия – для документов этих типов следует использовать параметры проекта или варианта.

На изображении ниже, параметр под названием ProjectTitle был определен для проекта, а также для каждого варианта. На анимации ниже показано поведение платы при использовании селектора вариантов для отображения базового проекта, затем для каждого варианта.

Параметры вариантов, где они определяются, и понимание порядка их приоритета
Параметр ProjectTitle, добавленный в проект (через диалоговое окно Options for Project) был также добавлен в каждый вариант, но с разными значениями в каждом случае.

Обратите внимание на опцию Allow variation of fabrication outputs в диалоговом окне Edit Project Variation. Включите ее, если проект должен поддерживать различные данные для изготовления печатной платы, например, формирование специфичной для вариантов шелкографии.

Видео, демонстрирующее параметры вариантов Специальная строка .ProjectTitle была размещена на слое шелкографии платы, и она автоматически связывается с параметрами проекта и варианта с теми же названиями.

Работа с вариантами в редакторе схем

Редактор схем Altium Designer включает в себя ряд функциональных возможностей, которые обеспечивают полную видимость вариаций компонентов в процессе ввода схемы. Эти возможности описаны ниже.

Проверка измененных компонентов

Как было обозначено ранее, для проверки вариаций на схеме необходимо:

  • Выберите нужный вариант в разделе Variants панели Projects.
  • Выберите скомпилированную вкладку в нижней части листа схемы.
  • Измененные компоненты будут отображены на листе в соответствии с настройками в диалоговом окне Variant Options.

Проверка измененных компонентов на схеме
Выберите вариант и затем переключитесь на скомпилированный лист, чтобы отобразить на листе схемы измененные компоненты (обозначаются измененными параметрами).

Выбор на схеме компонентов с вариациями

Вместо того, чтобы искать и выбирать компоненты из списка в диалоговом окне Variant Management, может быть удобнее сделать определенный выбор непосредственно на схеме. Для этого выделите компонент(ы) на листе, затем щелкните ПКМ и выберите Part Actions » Variants из контекстного меню.

Изменение выбранных на схеме свойств компонентов с вариациями
Здесь были выделены два компонента (светодиоды) на скомпилированной вкладке схемы для варианта BGA – команда Variant из контекстного меню откроет только эти компоненты в диалоговом окне Variant Management.

Обратите внимание, что контекстное подменю Part Actions также включает в себя команды для переключения установленного/неустановленного состояния (Toggle Fitted/Not Fitted) и для выбора альтернативного компонента (Choose Alternate Part).

Команда Variants из контекстного меню откроет диалоговое окно Variant Management, в списке которого будут представлены только выделенные компоненты. Необходимые варианты затем могут быть настроены обычным образом, после чего следует нажать OK для применения этих вариаций к проекту.

Диалоговое окно Variant Management, открытое для отображения только выделенных на схеме компонентов
Здесь показано диалоговое окно Variant Management, открытое из двух выделенных на листе схемы компонентов, и, соответственно, оно включает в себя только эти два компонента (светодиоды).

Такой способ можно использовать при первой настройке вариаций компонентов, либо когда необходимо изменить существующие вариации компонентов. Помимо того, что в диалоговом окне Variant Management представлены только выделенные компоненты, только один вариант будет представлен, как показано выше, если этот вариант (например BGA) выбран в данный момент в панели инструментов Variants, независимо от того, сколько вариантов определено в проекте.

Графическое редактирование вариаций компонентов

Варианты компонентов могут быть также созданы и изменены при работе непосредственно в схеме на уровне символов. Обратите внимание, что редактор схем должен отображать скомпилированный вид варианта (должна быть выбрана вкладка внизу), и в панели Projects должен быть выбран необходимый вариант.

Существует команда для быстрого переключения между состояниями компонента Fitted и Not Fitted для варианта проекта. Запустите эту команду с помощью кнопки Кнопка Toggle Fitted State в панели инструментов Active Bar для вариантов (отображается, когда вариант выбран в панели Projects). Курсор будет изменен на перекрестие, и при щелчке ЛКМ по компоненту его состояние будет переключаться между Fitted и Not Fitted – соответствующая запись в диалоговом окне Variants Manager отразит все изменения.

Состояние установки компонента будет обозначено графически в соответствии с настройками диалогового окна Variant Options (которое открывается нажатием кнопки Кнопка Drawing Style, открывающая диалоговое окно Variant Options в диалоговом окне Variants Management).

Графическое редактирование вариаций компонентовПереключение состояния установки определенных компонентов на схеме.

Графическое изменение параметров

Изменения можно внести непосредственно в отображенный параметр варианта компонента выделением текста параметра щелчком мыши и повторным щелчком мыши для перехода в режим редактирования. Изменения будут приняты записью этого компонента в диалоговом окне Variants Manager.

Обратите внимание, что видимость параметров компонента настраивается в панели Properties. Когда параметр компонента выбран, используйте иконку , связанную со значением параметра, для переключения его видимости.

Графическое редактирование вариаций компонентовВыделите параметр, затем щелкните ЛКМ по нему еще раз, чтобы перейти в режим прямого редактирования.

Параметр можно также изменить напрямую в диалоговом окне Parameter Variation, которое открывается двойным щелчком по тексту параметра. Как обычно, это функция доступна только на скомпилированном виде схемы, и любые изменения будут также зарегистрированы в диалоговом окне Variant Manager.

Редактирование вариаций параметров в диалоговом окне Parameter VariationВ скомпилированном виде дважды щелкните ЛКМ по параметру варианта, чтобы перейти в редактирование в диалоговом окне Parameter Variation.

Графическое редактирование позиционного обозначения

Чтобы изменить физическое позиционное обозначение компонента непосредственно на скомпилированном виде документа исходной схемы, щелкните ЛКМ по позиционному обозначению, чтобы выделить его, затем щелкните еще раз, чтобы начать редактирование. Обратите внимание, что редактирование позиционного обозначения по месту доступно только при включенной опции Enable In-Place Editing на странице Schematic - General диалогового окна Preferences (Щелкните ЛКМ по иконке шестеренки, чтобы открыть диалоговое окно Preferences).

Графическое редактирование позиционного обозначения компонентаВыделите позиционное обозначение, затем щелкните ЛКМ еще раз, чтобы включить прямое редактирование.

Прямое редактирование позиционных обозначений, по сути, является более быстрым графическим способом определения заблокированного физического позиционного обозначения (Locked Physical Designator), которое также может быть определено в диалоговом окне Physical Component Properties (дважды щелкните ЛКМ по компоненту) или в диалоговом окне Designator Annotation (дважды щелкните ЛКМ по позиционному обозначению).

Диалоговое окно Physical Component Properties, предоставляющее доступ к опциям редактирования и аннотирования позиционных обозначений для вариантов  Диалоговое окно Designator Annotation также предоставляет доступ к опциям редактирования и аннотирования позиционных обозначений для вариантовДиалоговые окна, связанные с компонентом или позиционным обозначением, обеспечивают доступ к редактированию позиционного обозначения и настройкам аннотирования.

С точки зрения аннотирования компонентов, эти диалоговые окна предоставляют доступ к одному и тому же содержимому. Используйте опции в области Annotate для определения:

  • Пользовательского позиционного обозначения с помощью опции Lock Physical Designator и ввода нового позиционного обозначения. Это та самая опция, которая задается при графическом редактировании позиционного обозначения, как обозначено выше.
  • Позиционного обозначения, сформированного с помощью определенной схемы именования. В этом случае, включите опцию Apply Naming Scheme и используйте кнопку Annotate Options, чтобы открыть диалоговое окно Board Level Annotation Options. Здесь вы можете выбрать предопределенную схему именования или указать собственную, пользовательскую схему. Физическое позиционное обозначение будет сформировано на основе логического позиционного обозначения и указанной схемы именования.

► Для получения более подробной информации по аннотированию и схемам именования перейдите на страницу Аннотирование компонентов.

Опции, заданные в диалоговом окне Board Level Annotation Options, когда определена схема именования, являются глобальными для проекта, и они переопределяют схему именования, определенную на вкладке Multi-Channel диалогового окна Options for Project (Project » Project Options).

Работа с вариантами в редакторе плат

В редакторе плат Altium Designer всегда отображаются все посадочные места всех компонентов. Это необходимо, поскольку посадочные места для всех вариантов сборки должны быть изготовлены в печатной плате. Монтаж компонентов в процессе изготовления печатного узла затем определяет, какой вариант устройства будет создан.

Поскольку все посадочные места всегда видны в плате, может быть сложно понять, какие компоненты каким вариантам принадлежат. Подобно редактору схем, редактор плат включает в себя панель инструментов Variants, которую можно использовать для переключения между вариантами. Видимая подсказка позволяет понять, установлен или не установлен компонент в определенном варианте, если компонент включает в себя 3D-модель – эта модель исчезает и появляется для обозначения того, установлен компонент или нет. Такое визуальное поведение намного проще наблюдать, когда плата находится в режиме 3D-отображения, как показано на анимации ниже.

Проект платы с альтернативными компонентами

Существует только один тип вариаций, который влияет на размещение компонентов на этапе процесса конструирования платы – когда указан альтернативный компонент, и этот альтернативный компонент использует посадочное место, отличное от базового проекта. В этом случае, на плате должны быть размещены два посадочных места.

Существуют различные пути, как эти два посадочных места могут быть размещены:

  • Посадочные места размещены друг рядом с другом.
  • Меньшее посадочное место размещено внутри большего, как показано на анимации ниже, где компонент SRAM доступен как в корпусе TSOP, так и в корпусе BGA.
  • Посадочные места совмещаются друг с другом (размещаются один над другим). Это может быть применимо, например, если посадочные места идентичны, но содержат разные 3D-модели, и, соответственно, имеют разные названия. Это также показано на изображении ниже, где совмещены два посадочных места для светодиодов DS1 и DS2.

Видео, демонстрирующее, как компоненты с вариациями, использующие различные посадочные места, могут быть размещены на плате Простая анимация, где два альтернативных компонента, которые используют разные посадочные места, могут быть размещены на плате.

Компоненты на плате, которые используют одно посадочное место, но разные 3D-модели, могут быть совмещены на плате
Две инстанции светодиода DS1 используют посадочные места с одним рисунком, но с разными 3D-моделями для каждого варианта, и, соответственно, они могут быть совмещены.

Altium Designer поддерживает проверку правил проектирования для совмещенных альтернативных компонентов, поэтому нет необходимости задавать дополнительные правила. Альтернативные компоненты используют одинаковый идентификатор (UID) компонента, тем не менее, система понимает, что это альтернативные компоненты, и она не будет отображать нарушение для совмещенных или перекрывающихся посадочных мест альтернативных компонентов.

Просмотр вариантов в Web Review

Серверная функциональная возможность Web Review от Altium обеспечивает универсальный доступ на чтение проектов на сервере через стандартный веб-браузер. Web Review позволяет осуществлять навигацию по документам проекта, получать доступ к свойствам выделенных объектов, размещать комментарии к схемам и многое другое. Функциональные возможности также позволяют просматривать варианты проекта в схемах.

Чтобы открыть Web Review из Altium Designer:

  • Выберите проект в панели Explorer и нажмите кнопку .
  • Когда управляемый проект открыт в Altium Designer:
    • Выберите команду Project » Show in Web Browser из главного меню.
    • Щелкните ПКМ по названию проекта в панели Projects и выберите команду Show in Web Browser из контекстного меню.
При открытии Web Review из Altium Designer любым из способов выше будет отображена самая новая версия выбранного проекта. Либо, если проект был выпущен, Web Review можно открыть с помощью иконки на вкладке Releases в панели Explorer, на виде Project. В этом случае, Web Review откроет выбранный в данный момент выпуск, который подсвечен синим цветом на вкладке Releases.

При просмотре документа схемы через интерфейс Web Review, выбор отображаемого варианта проекта осуществляется с помощью выпадающего списка, расположенного справа от названия документа страницы. По умолчанию отображается базовый проект ([No Variation]). Выпадающий список включает в себя поле динамического фильтра для поиска вариантов с определенными именами.

Интерфейс Web Review извлекает данные о свойствах объектов из исходных файлов проекта. Выберите элемент или объекта на виде схемы, чтобы просмотреть подробную информацию о нем в области Properties справа. Данные в этой области соответствуют выбранному варианту, и они отображают измененные данные для разных вариантов (наведите курсор на изображение, чтобы увидеть различия).

► Перейдите на страницу Web Review для получения более подробной информации о доступе к проектным документам на сервере.

Формирование выходной документации для вариантов

Варианты сборки влияют на всю выходную документацию, которая включает в себя информацию об устанавливаемых компонентах:

  • Состав изделия (через ActiveBOM или непосредственно через Report Manager)
  • Распечатки схем
  • 3D-распечатки платы
  • 3D-видео платы
  • Сборочные чертежи
  • Файлы для установки поверхностно монтируемых компонентов (Pick & Place)
  • Отчет о контрольных точках (Testpoints)

Варианты изготовления также влияют на следующие выходные документы:

  • Слои шелкографии Gerber
  • Слои шелкографии ODB++

Выбор варианта для выходных документов

При запуске команды из редактора схем или редактора плат, такой как команда на распечатку схемы или формирование файлов Gerber непосредственно из редактора плат, выходной документ будет сформирован на основе варианта, выбранного в данный момент в панели Projects.

Выберите вариант в панели Projects перед формированием выходных документов из меню редактора схем или редактора платВыходной документ, формируемый непосредственно из меню редактора схем или редактора плат, зависит от варианта, выбранного в панели Projects.

Если выходной документ формируется через другой интерфейс, например Report Manager или OutputJob, то этот интерфейс будет включать в себя выбор варианта.

Интерфейсы формирования выходных документов, такие как Report Manager и редактор OutputJob, включают в себя возможности выбора вариантаЩелкните ПКМ в Report Manager для переключения между вариантами.

Работа с вариантами в редакторе OutputJob

Главная страница: Подготовка множества выходных документов в файле OutputJob

Существует два подхода к настройке файла OutputJob для поддержки вариантов:

  • Choose a single variant for the whole OutputJob file (Выбрать один вариант для всего файла OutputJob) – используйте эту опцию, если вы предпочитаете использовать отдельные файлы OutputJob для каждого варианта, или
  • Choose a different variant for each output (Выбрать различные варианты для каждого выходного документа) – используйте эту опцию, если нужен один файл OutputJob, настроенный на формирование выходных документов для множества вариантов.

Выбор опции осуществляется в области Variant Choice редактора OutputJob. Когда включена вторая опция, для каждого выходного документа, который поддерживает варианты, должен быть выбран нужный вариант, как показано на изображении ниже.

В редакторе OutputJob вы можете выбрать вариант для всех задач в файле или выборочно задать вариант для каждой задачи
Файл OutputJob, где выбрана опция Choose a different variant, и задания на формирование выходных файлов для обоих вариантов, настроенных в файле OutputJob.

При использовании первого подхода, каждый выходной файл для определенного варианта будет автоматически настроен для этого варианта. Преимуществом этой опции является то, что нет необходимости явно выбирать вариант для каждого выходного документа, в то время как недостатком является то, что необходим отдельный файл OutputJob для каждого варианта в проекте.

Если из проекта необходимо сформировать варианты изготовления печатной платы, включите опцию Allow variation of fabrication outputs в диалоговом окне Edit Project Variant (см. Работа с параметрами вариантов выше). Если вариант указан в задании на формирование выходного документа для изготовления печатной платы и в этом варианте не включена эта опция, название варианта в этом задании будет отображено красным шрифтом.

Обратите внимание, что красное название варианта является лишь предупреждением, но специфичные для вариантов выходные файлы все еще могут быть сформированы. Если вариант для изготовления печатной платы не нужен, убедитесь, что в выпадающем меню Variant для этого задания на формирование выходного документа задано [No Variations] – в этом режиме будет сформирован выходной документ из базового проекта.

► Для получения более подробной информации по вариантам в файлах OutputJob перейдите на страницу Подготовка множества выходных документов в файле OutputJob.

Работа с вариантами в ActiveBOM

Главная страница: Управление составом изделия с ActiveBOM

Хотя состав изделия (BOM) может быть сформирован непосредственно из схемы или из файла OutputJob, рекомендуемым подходом является использование ActiveBOM. Помимо компонентов, установленных на плату, ActiveBOM позволяет добавлять в свои документы дополнительные компоненты и специфичные для состава изделия данные, например, не уточненные на данный момент компоненты, крепеж, пустая плата, монтажный клей. Также могут быть добавлены пользовательские столбцы, в том числе столбец номеров строк, который поддерживает автоматическую и ручную нумерацию, с полной поддержкой копирования/вставки.

Для компонентов, которые включают в себя информацию о производителе, ActiveBOM может использовать облачные службы Altium для доступа к подробной актуальной информации о цепочке поставок. Эта поддержка распространяется не только на компоненты, размещенные на сервере управляемых данных, но и на компоненты, связанные с цепочкой поставок, а также на компоненты, в параметрах которого уже содержатся соответствующие данные производителя.

ActiveBOM поддерживает варианты следующим образом:

  • Отображение состава изделия для определенного варианта в базовом режиме отображения или в плоском режиме отображения.
  • Опция для включения неустановленных объектов в список объектов состава изделия.
  • Отображение объединенного списка всех компонентов, используемых во всех вариантах, в объединенном режиме отображения.
  • Определение ручных решений как для базовых компонентов, так и для измененных компонентов.

ActiveBOM включает в себя объединенный режим отображения, который позволяет отображать информацию о компонентах во всех вариантах в едином составе изделияActiveBOM включает в себя объединенный режим отображения, который позволяет отображать информацию о компонентах во всех вариантах в едином составе изделия.

► Узнайте больше о работе с вариантами в ActiveBOM.

Ошибки вариантов

Настройки вариантов хранятся в файле проекта (*.PrjPcb), и эти данные считываются, анализируются и загружаются в диалоговое окно Variant Management при его открытии. Если при загрузке данных будут обнаружены какие-либо проблемы, такие как несоответствия между позиционными обозначениями компонентов или идентификаторами UID компонентов, будет открыто диалоговое окно Information с описанием проблемы.

Информационное диалоговое окно со сведениями об обнаруженных ошибках вариантов
Исправьте несоответствия позиционных обозначений или идентификаторов UID перед продолжением процесса проектирования.

Несоответствия идентификаторов UID компонентов исправляются автоматически, и эти исправления будут сохранены вместе с проектом. Дубликаты позиционных обозначений должны быть исправлены на уровне схемы. Чтобы исправить это, выполните валидацию проекта (Project » Validate <НазваниеПроекта>) и проверьте предупреждения/ошибки в панели Messages.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.