Managing Design Attributes with the Properties Panel in Altium Designer

Вы просматриваете версию 20.2. Для самой новой информации, перейдите на страницу Managing Design Attributes with the Properties Panel in Altium Designer для версии 21
 

Summary

The Interactive Properties panel provides universal editing access to the properties of documents and objects in design editors. The panel dynamically determines its content based on the document or object that is currently selected and presents specific properties and settings that relate to that document/object.

Panel Access

The Properties panel is available in all editors and can be accessed in the following ways: 

  • Click the Panels button at the bottom right of the design space, then click Properties.
  • Choosing View » Panels » Properties from the main menus.
  • Double-click on an object in the design space.
  • Using the F11 keyboard shortcut. 

Schematic Support

When the active document is a schematic document (*.SchDoc) and no design object is selected in the design space, the Properties panel presents the Document Options

The following collapsible sections contain information about the options and controls available under the panel's General tab:

The following collapsible section contains information about the options and controls available under the panel's Parameters tab:

When a design object is selected, the panel will present options specific to that object type. The following table lists the object types available for placement on a schematic sheet - click a link to access the properties page for that object.

Arc Bezier
Blanket Bus
Bus Entry Comment
Compile Mask Designator
Ellipse Graphic
Harness Connector Harness Entry
Net Label No ERC
Note Offsheet Connector
Parameter Parameter Set
Part Polygon
Polyline Port
Power Object Probe
Rectangle Round Rectangle
Sheet Entry Sheet Symbol
Sheet Symbol Designator Sheet Symbol Filename
Signal Harness Text Frame
Text String Wire
Pin Harness Connector Type

Modifying Data Strings  

Using Formulas

The Properties panel has the ability to modify data strings using formulas in the Schematic Editor. Formulas and expressions offer a convenient method of modifying attribute parameters of multiple selected objects to change their location or string-based values such as the Designator and Comment. This allows you to apply a specific expression to the selected string objects. The expression can include any built-in arithmetic operators and functions that apply to strings (found in Pascal). If you want to use the current value for the attribute as part of the expression, you will need to make reference to this original value either by using the full name of the attribute or by using the exclamation character (the supported substitute for the name of the attribute currently being modified). When using attribute names, if any names contain spaces, these must be replaced by the underscore character. For example, use of the Component Designator field within a formula should be entered as Component_Designator.

Using the Smart Edit Feature

Some parameter string fields also provide access to the Smart Edit dialog when multiple objects are selected, which is opened from the associated  button.

The Properties panel offers further support for string modification through its Smart Edit feature. Select the cell entries pertaining to the attribute that you want to modify for all required objects, right-click then choose Smart Edit from the menu that appears. The Smart Edit dialog will open.

The dialog offers two methods for performing string modification accessed from the Batch Replace and Formula tabs.

Schematic Library Support

When the active document is a Schematic Library document (*.SchLib), choose the Tools » Document Options command from the main menus - the Properties panel presents the Library Options. The following collapsible sections contain information about the options and controls available:

When a design object is selected, the panel will present options specific to that object type. The following table lists the object types available for placement within the library design space. Click a link to access the properties page for that object.

Arc Ellipse
Graphic IEEE Symbol
Pin Polygon
Polyline Rectangle
Round Rectangle Text Frame
Text String Bezier

PCB Support

When the active document is a PCB document (*.PcbDoc) and when no design object is currently selected in the design space, the Properties panel presents the Board mode. The following collapsible sections contain information about the options and controls available:

When a design object is selected, the panel will present options specific to that object type. The following table lists the object types available for placement within a PCB document - click a link to access the properties page for that object.

3D Body Accordion
Angular Dimension Arc
Arc Keepout Component
Drill Table Embedded Board Array
Fill Fill Keepout
Layer Stack Table Linear Dimension
OLE Object Ordinate Dimension
Pad Polygon Pour
Radial Dimension Region
Region Keepout String
Track Track Keepout
Via Comment
Standard Dimension

Design View

Center Dimension Baseline Dimension
Linear Diameter Dimension Radial Diameter Dimension
Although Tracks and Lines are actually the same object, the difference is how the software behaves during their placement, which is why there are different commands. 

After launching the Place » Line command, the cursor will change to a cross-hair and the editor will enter line placement mode. Placement is made by performing the following actions:

  1. Click to define the starting position of the line.
  2. Move the cursor to set the length and angle the line then click again to complete placement.
  3. Continue placing further lines, or right-click or press Esc to exit the placement mode.

Database Component Library Synchronization

When signed in to your Altium 365 Workspace, select File » New » Components Synchronization Configuration in Altium Designer to create a synchronization document.

For more information on Component Synchronization Configuration, see the Component Database to Server Data Synchronization page.

 

PCB Library Support

When the active document is a PCB Library document (*.PcbLib) and when no design object is currently selected in the design space, the Properties panel presents the Library Options. The following collapsible sections contain information about the options and controls available.

When a design object is selected, the panel will present options specific to that object type. The following table lists the object types available for placement within the library design space - click a link to access the properties page for that object.

3D Body Accordion
Arc Arc Keepout
Fill Fill Keepout
Pad Region
Region Keepout String
Track Track Keepout
Via  

Interactive Routing Support

When the active document is a PCB document (*.PcbDoc) and you are currently using the interactive routing tool, the Properties panel presents options pertinent to that tool. The following collapsible sections contain information about the options and controls available:

Interactive Differential Pair Routing Support

When the active document is a PCB document (*.PcbDoc) and you are currently using the interactive differential pair routing tool, the Properties panel presents options pertinent to that tool. The following collapsible sections contain information about the options and controls available:

Interactive Sliding Support

When the active document is a PCB document (*.PcbDoc) and you are currently using the interactive sliding tool, the Properties panel presents options pertinent to that tool. The following collapsible sections contain information about the options and controls available:

Interactive Multi-Routing Support

When the active document is a PCB document (*.PcbDoc) and you are currently using the interactive multi-routing tool, the Properties panel presents options pertinent to that tool. The following collapsible sections contain information about the options and controls available:

 

Interactive Length Tuning Support

When the active document is a PCB document (*.PcbDoc) and you are currently using the interactive length tuning tool to place an accordion or have interactively selected an accordion object, the Properties panel presents options pertinent to that accordion.

The following collapsible sections contain information about the options and controls available:

Refer to the object page to learn more about the Accordion object. Refer to the Length Tuning page to learn more about interactive length tuning.

Interactive Differential Pair Length Tuning Support

When the active document is a PCB document (*.PcbDoc) and you are currently using the interactive differential pair length tuning tool, the Properties panel presents options pertinent to that tool. The following collapsible sections contain information about the options and controls available:

Layer Stack Support

When the active document is a Layer Stack document (*.PcbDoc [Stackup]), the Properties panel presents options pertinent to that layer stack depending on the chosen tab (located at the bottom of the Layer Stack). Tabs include Stackup, Impedance, Via Types, Back Drills, and Printed Electronics Stackup. The following collapsible sections contain information about the options and controls available for the various Layer Stack tabs:

Via Shielding Support

When the active document is a PCB document (*.PcbDoc) and you select or double-click on a shielding via, the Properties panel presents options pertinent to that union object. The following collapsible sections contain information about the options and controls available:

The vias in a Via Shielding are members of a Union object. If the Display popup selection dialog option is disabled in the Preferences dialog, a single click on a via in a Via Shielding Union will select just that via. A second click in the same location will select the Via Shielding Union, displaying its properties in the Properties panel.

See the Add Shielding to Net dialog for more information about the Via Shielding options during initial placement.

See Via Stitching and Via Shielding for more information about working with Shielding Vias.

After modifying a value in the panel, the message Changes pending, Apply will appear at the bottom of the panel. You must click Apply for the changes to be made to the design.

Via Stitching Support

When the active document is a PCB document (*.PcbDoc) and you select or double-click on a stitching via, the Properties panel presents options pertinent to that union object. The following collapsible sections contain information about the options and controls available.

The vias in a Via Stitching are members of a Union object. If the Display popup selection dialog option is disabled in the Preferences dialog, a single click on a via in a Via Stitching Union will select just that via. A second click in the same location will select the Via Stitching Union, displaying its properties in the Properties panel.

See the Add Stitching to Net dialog for more information about the Via Stitching options during initial placement.

See Via Stitching and Via Shielding for more information about working with Stitching Vias.

After modifying a value in the panel, the message Changes pending, Apply will appear at the bottom of the panel. You must click Apply for the changes to be made to the design.

Multi-board Schematic Support

When the active document is a multi-board schematic document (*.MbsDoc) and when no design object is currently selected in the design space, the Properties panel presents the Document Options.

The following collapsible sections contain information about the options and controls available under the panel's General tab:

The following collapsible section contains information about the options and controls available under the panel's Parameters tab:

When a design object is selected in the design space, the Properties panel will present options specific to that object type – the panel changes to that object 'mode'. The following table lists the object types available for placement within a multi-board schematic document, where each listed entry links to its associated properties information (Properties panel mode) page.

Arc Circle
Connection Line
Module Module Entry
Picture Rectangle
Region Text

Multi-board Assembly Mate Support

When the active document is a Multi-board Assembly document (*.MbaDoc) and a Mate is selected, the Properties panel presents the Mate mode.

The Properties panel in Mate mode

The Properties panel in Mate mode

The following collapsible sections contain information about the options and controls available:

ActiveBOM Support

When the active document is a BOM document (*.BomDoc), the Properties panel presents the Document Options.  

The following collapsible sections contain information about the options and controls available:

Draftsman Support

See the Draftsman Properties panel page.

Library Migrator Support

Примечание

Доступные функциональные возможности зависят от вашего уровня Подписки на ПО Altium Designer.

Content