Нумерация листов схемы
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Краткий обзор
- Узнайте, где находятся инструменты нумерации листов, как редактировать SheetNumber, DocumentNumber и SheetTotal и в каких случаях нужно включать или отключать автоматическую нумерацию.
- Разберитесь в различиях между нумерацией логических листов схем и аннотированием экземпляров скомпилированных листов, включая способы хранения и отображения этих данных.
- Узнайте, как использовать специальные строки, такие как =SheetNumber, в основных надписях, печатных документах и данных проекта, чтобы отображать выбранную нумерацию.
Нумерация листов схемы в проекте позволяет управлять обозначениями листов и сохранять их в виде параметров в соответствующих документах схем. Затем с помощью специальных строк (=SheetNumber, =DocumentNumber, =SheetTotal) эти значения можно отобразить на листе (например, в основной надписи) в виде текстовых объектов. Нумерация изменяет не позиционные обозначения компонентов, а обозначения (номера) листов схемы и поэтому относится к общему процессу назначения обозначений в проекте.
Нумерация листов
Для доступа к нумерации листов выберите Tools » Annotation » Number Schematic Sheets в главном меню, чтобы открыть диалоговое окно Sheet Numbering For Project.

Используйте диалоговое окно Sheet Numbering For Project для нумерации и упорядочивания листов схемы в проекте.
Параметры и элементы управления диалогового окна Sheet Numbering For Project
Назначение многих параметров и элементов управления этого диалогового окна очевидно и не требует дополнительных пояснений. Ниже описаны те, для которых пояснения необходимы.
| SheetNumber DocumentNumber |
Эти поля можно редактировать непосредственно в таблице. Щелкните один раз, чтобы выбрать ячейку, и еще раз, чтобы перейти в режим редактирования. Используйте команды контекстного меню для копирования и вставки значений или редактирования нескольких выбранных ячеек. В последнем случае выберите нужные ячейки, затем щелкните правой кнопкой мыши одну из них и выберите команду Edit. Введите новое значение и нажмите Enter; это значение будет применено ко всем выбранным ячейкам. |
| SheetTotal | Текущее значение параметра SheetTotal уровня документа. Это поле обновляется при нажатии кнопки Update Sheet Count. |
| Automatic Sheet Numbering (Project Option) | Включите этот параметр, чтобы применить автоматическую нумерацию листов схемы в проекте. Это позволяет управлять обозначениями листов и сохранять их в виде параметров в соответствующих документах схем. Этот параметр также можно включить в диалоговом окне Project Options — Options . |
| Auto Sheet Number Auto Document Number |
Нажмите, чтобы применить нумерацию листов/документов в соответствии с выбранной схемой или методом нумерации. Нажмите стрелку раскрывающегося списка рядом с кнопкой, чтобы открыть доступные варианты нумерации.
|
| Update the Sheet Count | Нажмите, чтобы подсчитать общее количество листов в текущем проекте и записать результат в столбец SheetTotal. Подсчитываются все листы проекта независимо от схемы нумерации, выбранной в предыдущих элементах управления. Для доступа к этому полю необходимо отключить параметр Automatic Sheet Numbering (Project Option) . |
Нумерация листов схемы и Device Sheets
Номера листов или документов нельзя задать для Device Sheets, доступных только для чтения (состояние по умолчанию). В диалоговом окне Sheet Numbering For Project они отмечены штриховкой, указывающей на невозможность их обновления, как показано на рисунке ниже. Если разрешить редактирование Device Sheets, штриховка исчезнет и нумерацию можно будет настроить обычным способом.
Автоматическая нумерация листов
Автоматическую нумерацию листов можно включить или отключить с помощью параметра Automatic Sheet Numbering на вкладке Options диалогового окна Project Options и параметра Automatic Sheet Numbering (Project Option) в диалоговом окне Sheet Numbering For Project. Для автоматической нумерации листов достаточно включить этот параметр в одном из диалоговых окон. Если он отключен в обоих окнах, листы можно нумеровать вручную.
Если один из указанных выше параметров включен, автоматическую нумерацию можно применять к листам схемы непосредственно на панели Projects . Чтобы изменить нумерацию, перетащите листы схемы на панели. Номер листа отображается слева от имени листа схемы.
Назначение обозначений скомпилированным листам
Назначение обозначений скомпилированным листам позволяет управлять нумерацией скомпилированных листов (физических экземпляров листа) аналогично тому, как нумерация листов управляет нумерацией логических листов.
Для примера рассмотрим проект, содержащий документ схемы с именем Input channel.SchDoc. Схема на этом листе используется в проекте восемь раз, поэтому после компиляции проекта будет создано восемь экземпляров Input channel.SchDoc (то есть по одному на каждый экземпляр схемы на физической печатной плате). Нумерация листов используется для присвоения номера листу Input channel.SchDoc в логической структуре проекта; назначение обозначений скомпилированным листам служит для нумерации отдельных экземпляров этого листа в физическом (скомпилированном) представлении проекта.
Назначение обозначений скомпилированным листам выполняется в диалоговом окне Annotate Compiled Sheets, которое открывается выбором команды Tools » Annotation » Annotate Compiled Sheets в главном меню.
В диалоговом окне перечислены все скомпилированные листы текущего проекта. Вы можете задать собственные имена скомпилированным листам, введя их непосредственно в поле Sheet Number . Используйте любую комбинацию символов (буквенно-цифровых или иных), затем нажмите OK , чтобы применить заданные обозначения.
Нажмите кнопку Annotate Sheet, чтобы назначить обозначения листам, предварительно выбрав параметры, доступные при нажатии стрелки рядом с кнопкой. (При необходимости описание полей см. в разделе «Нумерация листов».) Значение SheetNumber будет обновлено в соответствии с вашим выбором.
Номера листов, обновленные с помощью этого диалогового окна, сохраняются в файле проекта *.Annotation во вложенной папке Settings\Annotation Documents на панели Projects . Благодаря этому сведения о назначенных обозначениях и настройки сохраняются между сеансами редактирования проекта.
Использование обозначений скомпилированных листов при назначении обозначений на уровне платы
После нумерации скомпилированных листов в диалоговом окне Annotate Compiled Sheets ключевое слово $SheetNumber можно использовать в схеме именования в диалоговом окне Board Level Annotation Options. Если скомпилированные листы проекта ещё не пронумерованы, по умолчанию будет использоваться нумерация листов, заданная в диалоговом окне Sheet Numbering For Project.
Использование нумерации скомпилированных листов в проекте
После нумерации скомпилированных листов можно разместить в проекте специальную строку SheetNumber для отображения этой информации.
-
Специальная строка отображается всегда; если значение отсутствует, отображается имя параметра.
-
Разместите специальную строку со значением
=SheetNumber, чтобы использовать значения нумерации скомпилированных листов. Специальные строки можно использовать в значениях свойств параметров, текстовых строках, метках цепей и т. д. -
Номер листа, назначенный в диалоговом окне, можно вывести при печати скомпилированного (физического) листа с помощью специальной строки =SheetNumber. Он будет обновляться во всех печатных выходных документах проекта.

