Ярлыки редактора схем и библиотеки схем

Краткий обзор

Эта статья — практический справочник по сочетаниям клавиш, используемым в редакторах схем и библиотек схем Altium Designer. Прежде чем перейти к доступным командам, вы сможете быстро разобраться в обозначениях сочетаний клавиш и действий мышью. В статье собраны сочетания клавиш для повседневных задач: редактирования, выделения, перемещения, выравнивания, настройки отображения, управления сеткой, поиска текста, открытия панелей и многого другого. Они помогут работать эффективнее, не обращаясь постоянно к меню. Если вы регулярно пользуетесь этими редакторами, это руководство поможет ускорить выполнение типовых задач и увереннее работать в среде проектирования. Читайте дальше, чтобы сделать работу со схемами быстрее и удобнее.

- Понятный обзор обозначений сочетаний клавиш и действий мышью в Altium Designer.
- Список сочетаний клавиш по категориям для типовых задач при работе со схемами: редактирования, выделения, перемещения, выравнивания, навигации и настройки отображения.
- Краткая справка по сочетаниям клавиш для управления сеткой, поиска текста и открытия основных панелей в редакторах схем и библиотек схем.
Узнайте больше с ИИ:

В следующих разделах приведены сочетания клавиш, предназначенные для редактора схем и/или редактора схемных символов. Общие сведения о сочетаниях клавиш, включая их просмотр и редактирование, общие сочетания клавиш среды Altium и клавиши быстрого доступа, см. в разделе Сочетания клавиш Altium Designer.

При просмотре списков сочетаний клавиш учитывайте следующее:

  • В обозначениях сочетаний клавиш знак плюс (+) означает, что несколько клавиш необходимо удерживать нажатыми в указанной последовательности. Например, Shift+F1 означает, что нужно удерживать клавишу Shift, а затем нажать клавишу F1. Аналогично, Shift+Ctrl+PgUp означает, что нужно удерживать клавишу Shift , затем, не отпуская ее, удерживать клавишу Ctrl  и нажать клавишу PgUp.
  • При использовании стандартных кнопок мыши Click означает однократное нажатие левой кнопки мыши, Double-Click — двойной щелчок левой кнопкой мыши, а Right-Click — однократное нажатие правой кнопки мыши.

Стандартные сочетания клавиш

Следующие сочетания клавиш являются стандартными для редактора схем и/или редактора схемных символов. Они доступны при обычной работе и не требуют выполнения интерактивной операции.

General Editing

Double-Click Изменить свойства объекта, находящегося под курсором.
Right-Click Открыть контекстное меню рабочей области или объекта, находящегося под курсором. Если выполняется интерактивная команда, прервать текущую операцию.
F2 Редактировать выбранный текстовый объект на месте (непосредственное редактирование).
Ctrl+C Копировать выделенное
Ctrl+X Вырезать выделенное
Ctrl+V Вставить выделенное
Ctrl+R Скопировать выбранные объекты и многократно вставлять их в нужных местах рабочей области (штампование).
Shift+Ctrl+V Открыть диалоговое окно «Умная вставка».
Delete Удалить выделенное
Ctrl+Z Отменить
Ctrl+Y Повторить

Selecting

Shift+F Вызвать функцию поиска похожих объектов (щелкните объект, который будет использоваться в качестве образца).
Click Выделить объект под курсором или снять с него выделение.
Shift+Click Изменить состояние выделения объекта под курсором, не затрагивая выделение других объектов.
Shift+Ctrl+X Включить или выключить режим перекрестного выделения.
Shift+Ctrl+Y Включить или выключить параметр Reposition selected component in PCB режима перекрестного выделения.
Ctrl+A Выделить все объекты в текущем документе.
Alt+Click На объекте цепи — выделить этот объект и подсветить все объекты, связанные с этой цепью, на всех листах активного проекта.
Click (вне объектов), Hold&Drag (слева направо) Выделить все объекты, полностью попадающие в область выделения.
Click (вне объектов), Hold&Drag (справа налево) Выделить все объекты, полностью попадающие в область выделения или пересекаемые ее границей.
Ctrl+n (n = от 1 до 8) Сохранить текущее выделение в ячейке памяти n.
Alt+n (n = от 1 до 8) Восстановить выделение из ячейки памяти n.
Shift+n (n = от 1 до 8) Добавить текущее выделение к выделению, уже сохраненному в ячейке памяти n.
Alt+Shift+n (n = от 1 до 8) Восстановить выделение из ячейки памяти n и добавить его к текущему выделению в рабочей области.
Shift+Ctrl+n (n = от 1 до 8) Применить фильтрацию на основе набора выделенных объектов в ячейке памяти n.

Moving

Click (на объекте), Hold&Drag

Переместить отдельный объект под курсором (или группу выделенных объектов, если объект входит в эту группу). Если параметр Always Drag включен (на странице Schematic - Graphical Editing диалогового окна Preferences ), при перемещении электрического объекта с помощью этого сочетания клавиш его соединения с другими электрическими объектами сохраняются.

Ctrl+Click, Hold&Drag Переместить отдельный объект под курсором (или группу выделенных объектов, если объект входит в эту группу). Если параметр Always Drag выключен (на странице Schematic - Graphical Editing диалогового окна Preferences ), при перемещении электрического объекта с помощью этого сочетания клавиш его соединения с другими электрическими объектами сохраняются.
Left Arrow Переместить курсор влево в рабочей области текущего документа на один шаг сетки привязки.
Shift+Left Arrow Переместить курсор влево в рабочей области текущего документа на 10 шагов сетки привязки.
Right Arrow Переместить курсор вправо в рабочей области текущего документа на один шаг сетки привязки.
Shift+Right Arrow Переместить курсор вправо в рабочей области текущего документа на 10 шагов сетки привязки.
Up Arrow Переместить курсор вверх в рабочей области текущего документа на один шаг сетки привязки.
Shift+Up Arrow Переместить курсор вверх в рабочей области текущего документа на 10 шагов сетки привязки.
Down Arrow Переместить курсор вниз в рабочей области текущего документа на один шаг сетки привязки.
Shift+Down Arrow Переместить курсор вниз в рабочей области текущего документа на 10 шагов сетки привязки.
Ctrl+Left Arrow Переместить текущее выделение (один или несколько выбранных объектов проекта) влево в рабочей области текущего документа на один шаг сетки привязки.
Shift+Ctrl+Left Arrow Переместить текущее выделение (один или несколько выбранных объектов проекта) влево в рабочей области текущего документа на 10 шагов сетки привязки.
Ctrl+Right Arrow Переместить текущее выделение (один или несколько выбранных объектов проекта) вправо в рабочей области текущего документа на один шаг сетки привязки.
Shift+Ctrl+Right Arrow Переместить текущее выделение (один или несколько выбранных объектов проекта) вправо в рабочей области текущего документа на 10 шагов сетки привязки.
Ctrl+Up Arrow Переместить текущее выделение (один или несколько выбранных объектов проекта) вверх в рабочей области текущего документа на один шаг сетки привязки.
Shift+Ctrl+Up Arrow Переместить текущее выделение (один или несколько выбранных объектов проекта) вверх в рабочей области текущего документа на 10 шагов сетки привязки.
Ctrl+Down Arrow Переместить текущее выделение (один или несколько выбранных объектов проекта) вниз в рабочей области текущего документа на один шаг сетки привязки.
Shift+Ctrl+Down Arrow Переместить текущее выделение (один или несколько выбранных объектов проекта) вниз в рабочей области текущего документа на 10 шагов сетки привязки.

Aligning

Shift+Ctrl+L Выровнять выбранные объекты по левым краям.
Shift+Ctrl+R Выровнять выбранные объекты по правым краям.
Shift+Ctrl+H Установить одинаковые горизонтальные интервалы между выбранными объектами.
Shift+Ctrl+T Выровнять выбранные объекты по верхним краям.
Shift+Ctrl+B Выровнять выбранные объекты по нижним краям.
Shift+Ctrl+V Установить одинаковые вертикальные интервалы между выбранными объектами.
Shift+Ctrl+D Переместить выбранные объекты к ближайшим узлам текущей сетки привязки.
Spacebar Повернуть выделенное против часовой стрелки на 90°.
Shift+Spacebar Повернуть выделенное по часовой стрелке на 90°.

Viewing the Schematic

Ctrl+PgDn Показать все объекты проекта в текущем документе.
PgUp Увеличить масштаб относительно текущего положения курсора.

Также можно использовать мышь для увеличения масштаба определенной области документа одним из следующих способов (если применимо и в зависимости от назначения кнопок мыши):

  • Удерживая клавишу Ctrl , прокрутите колесо мыши вверх. Использование клавиши Ctrl задано по умолчанию; эту настройку можно изменить на странице System - Mouse Wheel Configuration диалогового окна Preferences.
  • Удерживая клавишу Ctrl и правую кнопку мыши, переместите мышь вперед.
  • Удерживая сначала правую, затем левую кнопку мыши, переместите мышь вперед.
  • Нажмите и удерживайте колесо мыши, затем переместите мышь вперед.
PgDn Уменьшение масштаба относительно текущего положения курсора.

Уменьшить масштаб области документа с помощью мыши можно одним из следующих способов (если они доступны и в зависимости от назначения кнопок мыши):

  • Удерживая клавишу Ctrl , прокрутите колесо мыши вниз. Использование клавиши Ctrl задано по умолчанию; эту настройку можно изменить на странице System - Mouse Wheel Configuration диалогового окна Preferences.
  • Удерживая клавишу Ctrl и правую кнопку мыши, переместите мышь назад.
  • Удерживая сначала правую, затем левую кнопку мыши, переместите мышь назад.
  • Нажмите и удерживайте колесо мыши, затем переместите мышь назад.
Mouse Wheel Прокрутка по вертикали в рабочей области проекта. Это настройка по умолчанию, которую можно изменить на странице System - Mouse Wheel Configuration диалогового окна Preferences.
Shift+Mouse Wheel Прокрутка по горизонтали в рабочей области проекта. Это настройка по умолчанию, которую можно изменить на странице System - Mouse Wheel Configuration диалогового окна Preferences.
Shift+Ctrl+Mouse Wheel Переключение между каналами многоканального проекта. При прокрутке колеса мыши вверх/вниз активной становится вкладка следующего/предыдущего скомпилированного канала (в нижней части главного окна проектирования). Это настройка по умолчанию, которую можно изменить на странице System - Mouse Wheel Configuration диалогового окна Preferences.
Home Перерисовка вида в главном окне проектирования с размещением в центре окна точки, в которой находился курсор перед запуском команды.
End Обновление экрана, то есть перерисовка текущего документа для устранения нежелательных артефактов отображения.
Alt+End Перерисовка текущего слоя текущего документа для устранения нежелательных артефактов отображения.
Alt+F5 Переключение редактора текущего документа между развернутым и обычным состояниями.
F5 Включение или выключение отображения функции Net Color Override.
Shift+C Сброс фильтра, примененного к активному документу.
Right-Click, Hold&Drag Отображение курсора в виде руки для панорамирования; перетаскивайте его, чтобы перемещать вид рабочей области проекта.

Grids

G Последовательное переключение вперед между предустановленными настройками сетки привязки.
Shift+G Последовательное переключение назад между предустановленными настройками сетки привязки.
Shift+Ctrl+G Включение или выключение видимой сетки в текущем документе.
Ctrl+Shift Временное отключение сетки.
Shift+E Включение или выключение электрической сетки курсора.

Finding Text

Ctrl+F Поиск текста.
Ctrl+H Поиск и замена текста.
F3 Поиск следующего вхождения искомого текста.

Quick Panel Access

F11 Отображение или скрытие панели Properties.
F12 Отображение или скрытие панели SCH Filter или панели SCHLIB Filter, в зависимости от контекста.
Shift+F12 Отображение или скрытие панели List (панели SCH List или SCHLIB List), в зависимости от контекста.

Commenting

Alt+Ctrl+C Добавление новой ветки комментариев к точке, объекту или области в активном документе схемы. Прежде чем начать использовать комментарии, убедитесь, что вы открыли (получили из хранилища) управляемый проект и работаете с одним из его исходных документов схемы.

Miscellaneous

Ctrl+Double-Click
  • На входе листа — переход к соответствующему порту на дочернем листе, на который ссылается родительский символ листа этого входа.
  • На порту — переход к соответствующему входу листа в родительском символе листа, который ссылается на дочерний лист с этим портом.
  • На порту — переход к другому порту с тем же именем в указанном целевом документе схемы (доступно только в том случае, если параметр Net Identifier Scope, задаваемый на вкладке Options окна Project Options dialog , имеет значение Flat или Global).
  • На символе листа — переход вниз по иерархии проекта с открытием дочернего листа, на который ссылается этот символ.
Ctrl+L Выполнение Board Level Annotation с помощью диалогового окна Board Level Annotate.
Ctrl+W Переход в режим размещения проводников.
Ctrl+Home Перемещение курсора в абсолютное начало координат (0,0) текущего документа.
Ctrl+Q
  • В главной рабочей области проекта — открытие диалогового окна Selection Memory, в котором можно управлять всеми аспектами функции запоминания выделения.
  • В диалоговом окне или на панели — переключение единиц измерения (только в этом окне или на этой панели) между метрическими (мм) и дюймовыми (мил).
Ctrl+M Измерение и отображение расстояния между любыми двумя точками текущего документа.
F9

Запуск моделирования активного проекта с использованием видов анализа и соответствующих настроек, заданных на панели Simulation Dashboard. Если моделирование проекта выполняется впервые, будут запущены виды анализа по умолчанию — Operating Point, DC Sweep, Transient Analysis и AC Analysis — с настройками по умолчанию. В последнем случае настоятельно рекомендуется сначала настроить моделирование на панели Simulation Dashboard. Обратите внимание: команда Run Simulation, которой назначено это сочетание клавиш, доступна только при установленном системном расширении Mixed Simulation. Оно добавляет меню Simulate в редактор схем. Подробнее см. Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

 , Click Перекрестный выбор: переход от выбранного объекта текущего документа схемы к соответствующему объекту в документе печатной платы с сохранением активности исходного документа (Continuous Mode).
, Ctrl+Click Перекрестный выбор: переход от выбранного объекта текущего документа схемы к соответствующему объекту в документе печатной платы с активацией целевого документа (Jump To Mode).

Сочетания клавиш для интерактивных операций

Следующие сочетания клавиш становятся доступными после запуска интерактивного процесса, например размещения нового объекта проекта или перемещения существующего. Обратите внимание, что доступные сочетания клавиш зависят от интерактивной команды и конкретного объекта проекта, с которым она работает.

F1 Открытие диалогового окна Graphical Editing Hot key List, содержащего список доступных сочетаний клавиш (без возможности их выполнения), а также ссылки на документацию по выполняемой команде.
Shift+F1 Открытие меню со списком всех сочетаний клавиш, доступных на текущем этапе выполнения интерактивной команды.
Enter Действует как Click мыши при размещении/перемещении объекта.
PgUp Увеличить масштаб.
PgDn Уменьшить масштаб.
End Обновить экран.
Home Изменить вид так, чтобы курсор (с прикрепленным размещаемым/перемещаемым объектом) находился в центре окна проектирования.
Left Arrow Переместить курсор (с прикрепленным размещаемым/перемещаемым объектом) влево в рабочей области текущего документа на один шаг сетки привязки.
Shift+Left Arrow Переместить курсор (с прикрепленным размещаемым/перемещаемым объектом) влево в рабочей области текущего документа на 10 шагов сетки привязки.
Right Arrow Переместить курсор (с прикрепленным размещаемым/перемещаемым объектом) вправо в рабочей области текущего документа на один шаг сетки привязки.
Shift+Right Arrow Переместить курсор (с прикрепленным размещаемым/перемещаемым объектом) вправо в рабочей области текущего документа на 10 шагов сетки привязки.
Up Arrow Переместить курсор (с прикрепленным размещаемым/перемещаемым объектом) вверх в рабочей области текущего документа на один шаг сетки привязки.
Shift+Up Arrow Переместить курсор (с прикрепленным размещаемым/перемещаемым объектом) вверх в рабочей области текущего документа на 10 шагов сетки привязки.
Down Arrow Переместить курсор (с прикрепленным размещаемым/перемещаемым объектом) вниз в рабочей области текущего документа на один шаг сетки привязки.
Shift+Down Arrow Переместить курсор (с прикрепленным размещаемым/перемещаемым объектом) вниз в рабочей области текущего документа на 10 шагов сетки привязки.
Tab Приостановить интерактивную операцию и перейти в соответствующий режим панели Properties , где можно на ходу изменить свойства размещаемого/перемещаемого объекта. Последующие нажатия Tab в панели Properties (как и в любом диалоговом окне) позволяют последовательно переходить между ее полями.
X Зеркально отразить размещаемый/перемещаемый объект относительно оси X.
Y Зеркально отразить размещаемый/перемещаемый объект относительно оси Y.
Alt Ограничить перемещение горизонтальной или вертикальной осью в зависимости от начального направления движения.
Shift При автоматическом панорамировании во время размещения/перемещения объекта — повысить скорость панорамирования.
Esc
(или Right-Click)
Выйти из текущего процесса — завершить этап выполняемой интерактивной команды или саму команду.
Spacebar
  • Повернуть размещаемый/перемещаемый объект против часовой стрелки. Поворот выполняется с шагом 90°.
  • Переключить подрежимы начала и конца при размещении провода/шины/сигнального жгута в режиме размещения 90 Degree или 45 Degree.
  • Последовательно переключать режимы размещения линии.
Shift+Spacebar
  • Повернуть размещаемый/перемещаемый объект по часовой стрелке. Поворот выполняется с шагом 90°.
  • Последовательно переключать режимы размещения провода/шины/сигнального жгута.
Ctrl+Spacebar Изменить режим прокладки всех подключенных проводов, шин или сигнальных жгутов при перетаскивании электрического объекта.
Insert
Click&Hold+Insert На выбранном сегменте размещенного провода, линии, шины или сигнального жгута либо на ребре размещенного полигона — добавить вершину в этой точке.
Click&Hold+Delete На вершине размещенного провода, линии, шины, сигнального жгута или полигона — удалить эту вершину.
Backspace или Delete Удалить последнюю размещенную вершину при размещении провода, линии, шины, сигнального жгута или полигона.
+ (на цифровой клавиатуре) Увеличить размер размещаемого/перемещаемого символа IEEE.
- (на цифровой клавиатуре) Уменьшить размер размещаемого/перемещаемого символа IEEE.
S Перенести выбранный перемещаемый вход листа (или несколько входов) на противоположную сторону родительского символа листа.
V Изменить порядок на обратный при перемещении двух или более выбранных входов листа.
T
  • Переключить тип ввода/вывода при перемещении одного или нескольких выбранных входов листа.
  • Переключить тип ввода/вывода для всех входов листа при графическом изменении размера родительского символа листа.

Сочетания клавиш для всплывающих меню

Следующие сочетания клавиш открывают определенные всплывающие меню команд непосредственно в рабочей области проектирования. Некоторые из них могут быть вам знакомы: это подменю, доступные в главных меню редактора. Для каждого главного меню также назначена клавиша быстрого вызова из рабочей области проектирования. Подробнее см. Клавиши быстрого доступа.

A Подменю Align (из главного меню Edit).
B Подменю Toolbars  (из главного меню Вид ).
J Подменю Jump  (из главного меню Edit).
K Подменю Panels (из главного меню Вид ).
M Подменю Move  (из главного меню Edit).
O Всплывающее меню для быстрого доступа к параметрам и настройкам.
S Подменю Select  (из главного меню Edit).
X Подменю DeSelect  (из главного меню Edit).
Y Всплывающее меню с командами фильтрации.
Z Всплывающее меню с командами масштабирования.

 

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents