Tìm kiếm & Đặt linh kiện

Altium Training

Altium Essentials: Schematic Capture

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Trái tim của mọi thiết kế điện tử là các linh kiện. Linh kiện mà bạn cuối cùng sẽ hàn lên bo mạch cần được biểu diễn, hay mô hình hóa, trong từng miền thiết kế dưới dạng ký hiệu trên sơ đồ nguyên lý, dưới dạng mô hình SPICE trong trình mô phỏng, dưới dạng footprint trên bo mạch và dưới dạng mô hình STEP 3D trong tệp bạn bàn giao cho nhà thiết kế cơ khí.

Tìm hiểu thêm về Xây dựng & Duy trì Linh kiện và Thư viện của Bạn.

Bảng điều khiển Components của Altium Designer cung cấp một giao diện mạnh mẽ mà bạn có thể dùng để tương tác với tất cả linh kiện của mình - cả trong Workspace lẫn ngoài Workspace. Bạn có thể tìm kiếm linh kiện cần thiết bằng cách chỉ định danh mục và dùng chế độ tìm kiếm đơn giản bằng cách nhập truy vấn (toàn bộ hoặc một phần tên linh kiện, giá trị, v.v.) vào trường tìm kiếm . Ngoài ra, bảng điều khiển còn cung cấp khả năng tìm kiếm tham số (theo bộ lọc/facet) để chỉ định các tham số linh kiện mục tiêu cho các linh kiện Workspace của bạn. Bảng điều khiển cũng cung cấp các tùy chọn để chỉnh sửa một linh kiện Workspace thông qua Component Editor in its Single Component Editing mode, xem linh kiện trong Workspace nguồn của nó và thực hiện các chức năng quản lý linh kiện như tạo và sao chép linh kiện hoặc chỉnh sửa Part Choices và Type của linh kiện đã chọn. Một linh kiện có thể được đặt vào sơ đồ nguyên lý bằng cách kéo thả nó hoặc dùng lệnh Place  từ menu chuột phải của linh kiện.

Và mặc dù dĩ nhiên bạn có thể tự tạo linh kiện của riêng mình, Altium Designer cung cấp một Manufacturer Part Search panel mạnh mẽ có thể được dùng để tìm kiếm các mã linh kiện sản xuất thực tế. Nếu bạn có Workspace, bạn có thể lưu các linh kiện đó trong Workspace đó rồi truy cập chúng thông qua bảng Components. Quá trình này liên quan đến việc tạo một linh kiện Workspace mới - sử dụng Component Editor ở chế độ Single Component Editing - rồi lưu vào Workspace của bạn.

Bảng Components cung cấp quyền truy cập trực tiếp đến các Workspace components khả dụng và các linh kiện thư viện cơ sở dữ liệudựa trên tệp trong Altium Designer.

Bảng điều khiển lấy linh kiện từ một connected Workspace và mọi thư viện đang mở hoặc đã cài đặt. Bảng điều khiển cung cấp đầy đủ chi tiết của linh kiện được chọn (Parameters, Models, Part Choices, dữ liệu nhà cung cấp, v.v.), khả năng so sánh linh kiện và, đối với linh kiện Workspace, khả năng tìm kiếm tham số dựa trên bộ lọc để chỉ định các tham số linh kiện mục tiêu.

Bảng Components ở chế độ bình thường

Bảng Components ở chế độ thu gọn

 

Bảng Components sử dụng chức năng và chế độ xem của công cụ tìm kiếm cơ bản được áp dụng trong Manufacturer Part Search panel. Trong khi bảng Manufacturer Part Search tận dụng dịch vụ Altium Parts Provider và tập trung vào tìm kiếm dữ liệu nhà sản xuất và nhà cung cấp linh kiện, bảng Components được điền sẵn các linh kiện sẵn sàng đặt từ connected Workspace của bạn và từ các nguồn thư viện cơ sở dữ liệu và dựa trên tệp.

Đối với các linh kiện Workspace, chỉ phiên bản sửa đổi mới nhất của mỗi linh kiện được hiển thị trong bảng.
Mặc dù phần lớn chức năng làm việc với linh kiện đều có sẵn thông qua bảng Components, bạn cũng có thể dùng Explorer panel – về cơ bản, bảng trước cung cấp một tập con các chức năng có trong bảng sau, và tập trung hơn vào quản lý linh kiện. Sẽ có một số tính năng liên quan đến chính các linh kiện mà vẫn chỉ có thể thực hiện thông qua bảng Explorer (thêm datasheet mà không chỉnh sửa, thay đổi trạng thái, xóa hàng loạt linh kiện và mô hình, v.v.), nhưng đây chủ yếu là cho các trường hợp không điển hình, trường hợp biên, hoặc như một phần của hoạt động quản trị/cấu trúc Workspace. Hãy nhớ rằng linh kiện chỉ là một loại nội dung – bảng Explorer thực sự phát huy thế mạnh với toàn bộ dải loại nội dung được Workspace hỗ trợ. Ví dụ, việc tạo và quản lý các mẫu linh kiện – một thực thể rất liên quan đến linh kiện – chỉ có thể được thực hiện từ bên trong bảng Explorer (trừ khi các mẫu được tạo tại thời điểm nhập thư viện bằng Library Importer).

Truy cập Bảng Components

Để mở bảng Components, hãy chọn View » Panels » Components từ các menu chính hoặc tùy chọn Components từ menu của nút ở góc dưới bên phải màn hình chính. Khi dùng cấu hình thiết kế đáp ứng, bố cục bảng sẽ tự động thích ứng giữa chế độ bình thường toàn màn hình () và chế độ thu gọn () khi các tùy chọn Categories/Filters được thu gọn thành menu.

Từ trong một tài liệu schematic, dùng phím tắt P, P để mở bảng Components. Bạn cũng có thể dùng lệnh Place » Part từ các menu chính, lệnh Place » Part từ menu chuột phải của vùng thiết kế trong trình biên tập schematic, hoặc nút Part () trên Active Bar.

Từ trong một tài liệu PCB, dùng phím tắt P, C để mở bảng Components. Bạn cũng có thể dùng lệnh Place » Component từ các menu chính, lệnh Place » Component từ menu chuột phải của vùng thiết kế trong trình biên tập PCB, hoặc lệnh Component () trên Active Bar.

Ở lần khởi chạy đầu tiên của bảng Components trong phiên Altium Designer hiện tại, các điều khiển sau sẽ khả dụng khi được kết nối với một Workspace:

  • Use Existing Components – nhấp để duyệt kiểu linh kiện hiện đang được chọn trong hộp thả xuống phía trên của bảng.

  • Delete Existing Components – nhấp để mở hộp thoại Delete Existing Components rồi đến trang Data Cleanup của Settings trong Workspace của bạn, nơi bạn có thể chọn các loại nội dung sẽ bị xóa.

  • Import Library – nhấp để mở hộp thoại Open chuẩn của Windows rồi chọn một thư viện cơ sở dữ liệu hoặc thư viện dựa trên tệp được lưu trên thư mục cục bộ hoặc thư mục mạng của bạn. Sau khi mở một tệp thư viện, Library Importer in its Simple mode sẽ khởi chạy với thư viện đã chọn được nạp sẵn.

  • Create Component – nhấp để mở Create New Component dialog rồi đến Component Editor ở Single Component Editing mode sẵn sàng để định nghĩa một linh kiện mới.

Ngăn Categories của bảng (hoặc menu thả xuống trong chế độ thu gọn) liệt kê tất cả các linh kiện Workspace khả dụng dưới mục danh mục All và mọi thư viện khả dụng. Khi bảng ở chế độ bình thường, hãy nhấp biểu tượng danh sách Categories hoặc biểu tượng « để thu gọn hoặc mở rộng phần hiển thị của cột và dùng nút (góc trên bên phải) để bật/tắt hiển thị của ngăn linh kiện Details. Khi duyệt qua ngăn Categories, có thể dùng các phím tắt Up/DownPgUp/PgDn để di chuyển qua danh sách. Có thể dùng các phím tắt Left/Right để mở và đóng từng nhánh riêng lẻ.

Việc nhóm Categories cho các linh kiện Workspace được suy ra từ các tham số Component Type gắn với từng linh kiện. Ví dụ, nếu Component Type của một linh kiện được chỉ định là Resistor, thì linh kiện đó sẽ được liệt kê dưới danh mục Resistor trong bảng Components (bất kể nó nằm trong thư mục workspace nào).

Để chỉ định hoặc thay đổi kiểu của một linh kiện ngay tức thì, hãy nhấp chuột phải vào mục của nó rồi chọn tùy chọn Operations » Change Component Type từ menu ngữ cảnh để mở hộp thoại Choose component type dialog.

Tham số Type của một linh kiện được thiết lập:

Component Types được quản lý (tạo/chỉnh sửa/xóa) trên trang Data Management – Component Types của hộp thoại Preferences. Nút Templates của hộp thoại sẽ mở hộp thoại Edit Templates, nơi Component Template được liên kết với từng Component Type có thể được chỉ định hoặc thay đổi.

NOTE: CategoryMục danh mục mà một linh kiện được liệt kê dưới đó được xác định bởi tham số Component Type của nó và không liên quan đến thư mục Workspace nơi nó nằm. Vì vậy, nếu bạn di chuyển một linh kiện sang thư mục khác thông qua Explorer panel, thay đổi như vậy sẽ không được phản ánh trong bảng Components.

Menu Thao tác

Các tùy chọn trong menu thao tác cho phép bạn thiết lập tùy chọn cho thư viện dựa trên tệp, thực hiện tìm kiếm và chỉ định có hiển thị tập hợp mô hình linh kiện hay không. Để truy cập các tùy chọn này, hãy chọn nút menu thao tác ở góc trên bên phải của bảng.

  • Create Component – chọn để mở hộp thoại Create new component rồi đến Component Editor ở Single Component Editing mode sẵn sàng để định nghĩa một linh kiện mới.
  • Import Library – chọn để mở hộp thoại Open chuẩn của Windows và chọn một thư viện cơ sở dữ liệu hoặc thư viện dựa trên tệp được lưu trên thư mục cục bộ hoặc thư mục mạng của bạn. Sau khi mở một tệp thư viện, Library Importer in its Simple mode sẽ khởi chạy với thư viện đã chọn được nạp sẵn.
  • Clean-up Library – chọn để mở hộp thoại Delete Existing Components rồi đến trang Data Cleanup của Settings trong Workspace của bạn, nơi bạn có thể chọn các loại nội dung sẽ bị xóa.
  • Models – chọn để bao gồm các mục của tập hợp mô hình thư viện trong danh sách Categories. Các mục bổ sung trong chế độ duyệt này bao gồm các tập hợp mô hình Symbol, Footprint và Simulation lấy từ Workspace đã kết nối, cũng như các thư viện PCB footprint đã cài đặt (*.PcbLib).
  • File-based Libraries Preferences – chọn để mở hộp thoại Available File-based Libraries, nơi bạn có thể xem các điều khiển để thêm thư viện cơ sở dữ liệu và thư viện dựa trên tệp vào dự án hiện tại hoặc xóa thư viện khỏi dự án, cài đặt thư viện và chỉ định đường dẫn tìm kiếm thư viện. Tham khảo phần Quản lý Thư viện Cơ sở dữ liệu và Dựa trên tệp Khả dụng của trang Tìm kiếm Linh kiện trong Thư viện Dựa trên tệp & Cơ sở dữ liệu để tìm hiểu thêm.
  • File-based Library Search – chọn để mở hộp thoại File-based Libraries Search, nơi bạn có thể tìm kiếm một linh kiện khi bạn không biết thư viện cơ sở dữ liệu hoặc thư viện dựa trên tệp nào chứa nó, hoặc thậm chí không biết nó có sẵn hay không. Tham khảo phần Tìm kiếm Linh kiện trong Thư viện Cơ sở dữ liệu và Dựa trên tệp của trang Tìm kiếm Linh kiện trong Thư viện Dựa trên tệp & Cơ sở dữ liệu để tìm hiểu thêm.
  • Refresh – nhấp để làm mới nhanh bảng điều khiển. Lựa chọn linh kiện hiện tại sẽ được giữ lại.

Danh sách Linh kiện

Ngay trong lưới danh sách linh kiện, nội dung được bao gồm trong danh sách được quản lý bằng:

  • Thiết lập thứ tự sắp xếp danh sách linh kiện – nhấp vào tiêu đề cột để sắp xếp danh sách linh kiện theo dữ liệu của cột đó. Nhấp lại vào tiêu đề để đảo ngược thứ tự sắp xếp.

  • Thiết lập thứ tự của các cột được hiển thị – kéo và thả tiêu đề cột đến vị trí mới.

  • Chỉ định các cột tham số nào sẽ được hiển thị – nhấp chuột phải vào tiêu đề cột và chọn Select Columns để mở hộp thoại Select Columns, qua đó bạn có thể điều khiển khả năng hiển thị của cột tham số và di chuyển thứ tự vị trí của nó.

    Hộp thoại Select columns
    Hộp thoại Select columns

    • Hộp thoại liệt kê tất cả các cột có thể hiển thị trong bảng Components. Khi một mục hiển thị , cột đó sẽ được hiển thị trong bảng Components . Khi một mục hiển thị , cột đó sẽ not được hiển thị trong bảng Components. Nhấp vào các biểu tượng để bật/tắt chức năng hiện/ẩn.

    • Bạn cũng có thể điều khiển việc hiển thị của tất cả các cột bằng cách nhấp vào biểu tượng / trên thanh tiêu đề cột. Khi một số cột hiển thị còn các cột khác bị ẩn, biểu tượng  sẽ được hiển thị.

    • Di chuột lên thanh tiêu đề của cột thứ hai và nhấp vào biểu tượng  để mở danh sách thả xuống, từ đó bạn có thể chọn cột cần hiển thị.

    • Dùng các nút  /  để di chuyển mục đã chọn lên hoặc xuống trong danh sách. Chỉ các mục được đặt là hiển thị () mới có thể được di chuyển. Điều này xác định thứ tự các cột sẽ xuất hiện trong bảng Components.

  • Nhóm danh sách theo dữ liệu cột – nhấp chuột phải vào tiêu đề cột, chọn tùy chọn Enable Columns Grouping rồi kéo tiêu đề một cột (ví dụ: Footprint) vào vùng nhóm ở đầu danh sách. Các mục trong danh sách sẽ được gom dưới từng tham số duy nhất (ví dụ: loại footprint) từ cột nhóm đã chỉ định.

    Khi dùng Grouping để đối chiếu linh kiện trong danh sách, có giới hạn 10.000 mục có thể được hỗ trợ.

  • Lọc danh sách theo một mục cột cụ thể – chọn trong tiêu đề cột để hiển thị danh sách các mục tham số duy nhất của nó rồi chọn một mục để giới hạn các linh kiện được liệt kê thành những linh kiện có chứa tham số đã chỉ định (ví dụ: mã loại footprint). Chọn tùy chọn All để đặt lại bộ lọc. Chọn (Custom) để mở hộp thoại Filter Editor nhằm tinh chỉnh thêm việc lọc trong cột đã chọn.

Hiển thị Cột

Có nhiều cách khác nhau để bạn có thể hiển thị nội dung trong bảng Components. Khi nhấp chuột phải vào tên của từng cột (Name, Description, Footprint), bạn có thể chọn từ các tùy chọn sau, tùy theo cách bạn muốn hiển thị các linh kiện:

  • Best Fit – gộp nội dung từ các cột NameDescriptions lại với nhau để chúng được đặt sát nhau, không có khoảng trống dư giữa mỗi cột.

  • Best Fit All Columns – gộp nội dung từ tất cả các cột lại với nhau để chúng được đặt sát nhau, không có khoảng trống dư giữa mỗi cột.

  • Clear Sorting – dùng để hoàn tác việc sắp xếp các cột.

  • Enable Columns Grouping – cho phép bạn kéo tiêu đề cột theo một cột cụ thể, cho phép bạn thay đổi thứ tự của các cột Name, DescriptionFootprint.

  • Select Columns – mở hộp thoại Select Columns, cho phép bạn chọn các cột khác mà bạn muốn hiển thị trong phần này.

  • Apply Column Visibility to Child Categories – trong trường hợp danh mục đã chọn có danh mục con, hãy dùng lệnh này để đảm bảo khả năng đẩy các thiết lập hiển thị cột từ danh mục cha xuống các danh mục con. Lệnh này chỉ khả dụng khi tồn tại danh mục con.

Tìm kiếm và Chức năng Linh kiện

Tìm kiếm Linh kiện

Để tìm kiếm các linh kiện khả dụng trong bảng Components, hãy nhập một cụm từ vào trường Search và/hoặc dùng các lựa chọn CategoriesFilters của bảng để thu hẹp danh sách linh kiện theo đúng nhu cầu của bạn. Bộ lọc chỉ được hỗ trợ cho Workspace components, và cũng như trong Manufacturer Part Search panel, bảng Components hỗ trợ các bộ lọc tìm kiếm có nhận biết đơn vị (từ văn bản sang số). Chức năng tìm kiếm ưu tiên kết quả theo tiêu chí tìm kiếm đã nhập.

Chức năng Search cho phép bạn chọn rồi chỉnh sửa hoặc thêm vào một chuỗi Search đang hoạt động.

Nhấp vào chuỗi tìm kiếm 'đang hoạt động' để đưa nó vào trường Search. Bạn có thể dùng lại hoặc chỉnh sửa tìm kiếm đó từ trường Search.

Trường Search cũng hỗ trợ tìm kiếm bằng ký tự đại diện, được biểu thị bằng dấu hoa thị (*) trong chuỗi.

Hộp thoại Find Similar Components được truy cập bằng cách nhấp chuột phải vào một linh kiện được liệt kê, rồi chọn Find Similar Components, cung cấp khả năng định nghĩa các tùy chọn tìm kiếm dựa trên linh kiện đã chọn.

Kết quả tìm kiếm cuối cùng sẽ phụ thuộc vào loại linh kiện đã chọn, dù là linh kiện Workspace hay không phải Workspace, và trạng thái kết nối Workspace của bạn. Ví dụ, linh kiện Workspace thường sẽ hiển thị nhiều tham số hơn linh kiện không phải Workspace. Để cụ thể gom các linh kiện và tham số giống hoặc khác với linh kiện đã chọn, có thể sử dụng các danh sách thả xuống để chọn các tùy chọn Same, Any hoặc Different.

Đặt Linh kiện

Một linh kiện đã chọn được đặt vào sơ đồ nguyên lý bằng cách kéo và thả, chọn Place từ menu ngữ cảnh chuột phải của nó, dùng nút trong ngăn Details, nhấp đúp vào mục của linh kiện cần thiết hoặc dùng phím nóng Enter.

Để đặt một linh kiện từ bảng, bạn có thể:

  • Nhấp nút Place trong ngăn Component Details – con trỏ sẽ tự động di chuyển vào trong phạm vi của tờ sơ đồ nguyên lý và linh kiện sẽ xuất hiện nổi theo con trỏ; hãy đặt vị trí rồi nhấp để đặt. Sau khi đặt một linh kiện, một bản thể khác của cùng linh kiện đó sẽ xuất hiện trên con trỏ; nhấp chuột phải để thoát khỏi chế độ đặt.

    Components panel, placing from component details pane

  • Nhấp chuột phải vào linh kiện và chọn Place từ menu ngữ cảnh. Linh kiện sẽ xuất hiện nổi theo con trỏ; hãy đặt vị trí rồi nhấp để đặt. Lưu ý rằng nếu bảng đang nổi đè lên vùng thiết kế, nó sẽ mờ đi để bạn có thể nhìn thấy sơ đồ nguyên lý và đặt linh kiện. Sau khi đặt một linh kiện, một bản thể khác của cùng linh kiện đó sẽ xuất hiện trên con trỏ; nhấp chuột phải để thoát khỏi chế độ đặt.

  • Click, Hold&Drag – nhấp và kéo linh kiện từ vùng lưới của panel sang một trang schematic. Chế độ này yêu cầu giữ chuột; linh kiện sẽ được đặt khi bạn nhả chuột. Sau khi đặt linh kiện, bạn có thể chọn một linh kiện khác hoặc một lệnh khác.

    Kéo & thả chỉ đặt một экземпляr duy nhất của linh kiện. Nếu bạn cần đặt nhiều экземпляr, hãy dùng lệnh/nút Place , hoặc nhấp đúp vào mục linh kiện.

Việc đặt một linh kiện thực sự rất đơn giản. Nhưng trước khi làm bất cứ điều gì, trước tiên hãy bảo đảm rằng trang schematic (hoặc tài liệu PCB) sẽ nhận linh kiện đang được mở trong Altium Designer và là tài liệu đang hoạt động. Nếu các tài liệu đang mở trên nhiều cửa sổ, cũng hãy bảo đảm rằng cửa sổ chứa tài liệu schematic đang hoạt động đó đang có tiêu điểm.

Khi làm việc với Altium Designer trên nhiều cửa sổ, nếu panel Components hoặc panel Explorer được dock vào một cửa sổ không chứa schematic đích, lệnh Place sẽ vẫn bị làm mờ. Điều này là do thao tác nhấp bên trong một panel đã dock sẽ đưa tiêu điểm về cửa sổ mà panel đó đang gắn vào. Tuy nhiên, khi panel ở trạng thái nổi, cửa sổ Altium cần thiết có thể được đưa vào tiêu điểm (cửa sổ có schematic đích đang hoạt động), và cửa sổ đó sẽ giữ tiêu điểm khi làm việc trong panel.

Đặt linh kiện nhiều phần

Nếu linh kiện đang được đặt có nhiều phần, phần được chọn bên dưới hình xem trước symbol trong vùng Models của panel sẽ được đặt đầu tiên.

Sau khi một phần của linh kiện nhiều phần được đặt, có thể đổi sang phần khác của linh kiện này bằng danh sách thả xuống Part trong panel Properties khi phần đó được chọn, hoặc có thể chuyển sang phần khả dụng tiếp theo bằng lệnh Edit » Increment Part Number từ menu chính hoặc lệnh Part Actions » Increment Part Number từ menu chuột phải của phần đó.

Altium Designer hỗ trợ hiển thị một linh kiện nhiều phần dưới dạng một symbol duy nhất (tất cả các phần con) hoặc nhiều symbol (mỗi symbol cho một phần con riêng lẻ) chỉ với một linh kiện duy nhất, bằng cách sử dụng các chế độ hiển thị Normal và Alternate đã được định nghĩa (Show example).

  • Nếu một linh kiện nhiều phần có các phần con trống trong chế độ hiển thị của nó (normal hoặc alternate), các phần con này sẽ bị bỏ qua khi đặt (Show example).

  • Nếu một linh kiện nhiều phần chỉ có primitive được định nghĩa trong một phần con, hậu tố designator sẽ bị ẩn khi phần con đó được đặt lên một trang schematic (Show example).

  • Khi một phần con không có primitive cho chế độ hiển thị đang chọn hoặc một chế độ hiển thị không có primitive cho phần con đang chọn, mục tương ứng trong danh sách thả xuống Part of Mode trong panel Properties của linh kiện sẽ bị làm mờ (). Khi một mục như vậy được chọn trong danh sách thả xuống, các biểu tượng cảnh báo sẽ được hiển thị ().

  • Vi phạm Unused sub-part in component sẽ không xảy ra khi chạy kiểm tra thiết kế nếu một linh kiện có các phần con không có primitive và các phần con này không được đặt trên schematic.

Lọc qua các linh kiện

Khi xem các linh kiện Workspace, khung Filters được điền bởi các tùy chọn lọc đã chọn dựa trên tìm kiếm hiện tại và các tham số sẵn có. Lọc tham số cho danh sách linh kiện cung cấp thêm các tùy chọn để định vị một linh kiện cụ thể hoặc một loại linh kiện cụ thể. Mở khung Filters từ nút phía trên khung Categories. Ở chế độ thu gọn của panel, nhấp nút để bung Filters ra dưới dạng phần mở rộng của panel.

Lưu ý rằng bộ lọc chỉ được hỗ trợ cho Workspace components. Sử dụng trường Filter Search trong khung để tìm một bộ lọc tham số cụ thể.

Javascript ID: Pnl_Components_Filter
  • Khả năng tìm kiếm tham số trong Filters của panel phụ thuộc vào việc dữ liệu tham số linh kiện phù hợp được truyền từ Workspace lưu trữ các linh kiện Workspace đó. Do đó, chức năng Filter có thể bị vô hiệu hóa khi phần mềm được kết nối với một sản phẩm máy chủ Altium cũ hơn. Để bật Filter cho các phiên bản máy chủ trước đó, hãy bật tùy chọn ComponentSearch.LegacyAFS.Filters trong Advanced Settings dialog.

  • Lưu ý rằng để một tham số xuất hiện trong khung Filters, ít nhất phải có hai giá trị khác nhau cho tham số đó được các linh kiện trong danh mục đã chọn sử dụng. Cũng lưu ý rằng chỉ tối đa 100 tham số phổ biến nhất (những tham số được nhiều linh kiện hơn trong Workspace đã kết nối sử dụng, trên tất cả các loại linh kiện) được hiển thị trong khung Filters. Các tham số sau (hoặc các tham số bắt đầu bằng các tên sau) luôn được hiển thị ở đầu khung: Power, Value, Resistance, Res, Capacitance, Case, Package, Tolerance, RoHS, Lead.

Các tùy chọn Filters của panel có thể được điều chỉnh theo nhu cầu của bạn bằng cách chọn các kiểu tham số cụ thể làm Favorites; sau đó chúng sẽ được chuyển lên đầu danh sách cho Category linh kiện hiện tại. Di chuột sang bên phải tên của một bộ lọc tham số và nhấp biểu tượng để đặt bộ lọc đó làm Favorite. Các thiết lập bộ lọc Favorite được áp dụng và lưu cho từng Category linh kiện riêng lẻ.

Đối với linh kiện Workspace, menu chuột phải cung cấp các tùy chọn để chỉnh sửa linh kiện thông qua Component Editor (Edit) và thực hiện các chức năng quản lý linh kiện như tạo và nhân bản linh kiện, hoặc chỉnh sửa Part Choices và Type của linh kiện đã chọn (Operations).

 
 
 
 
 

Các tùy chọn thông tin bổ sung trong khung Details của linh kiện bao gồm: xem hình ảnh model, xem datasheet trực tuyến (References), thông tin Supplier trực tiếp (Part Choices), xem nơi part đã được sử dụng trong các dự án Workspace, các managed sheet và reuse block (Where Used), và thông qua menu chuột phải, khả năng sao chép dữ liệu tham số của linh kiện đã chọn hoặc toàn bộ (chi tiết kỹ thuật) ở định dạng phân tách bằng tab, cũng như đặt lại các tham số được đánh dấu là yêu thích về năm tham số mặc định.

Khi duyệt các linh kiện trong một Altium 365 Workspace đã kết nối và nếu phát hiện bất kỳ vấn đề nào liên quan đến tình trạng của linh kiện đã chọn, sẽ có chỉ báo bằng biểu tượng (đối với lỗi) hoặc (đối với lỗi nghiêm trọng) trên dòng Component issues phía trên danh sách tham số linh kiện. Con số bên phải biểu tượng cho biết số lượng vấn đề được phát hiện. Nhấp mũi tên xuống ở bên phải con số để xem mô tả ngắn của các vấn đề.

Ví dụ về các vấn đề sức khỏe thư viện được phát hiện.
Ví dụ về các vấn đề sức khỏe thư viện được phát hiện.

Tình trạng thư viện Workspace của bạn có thể được khám phá chi tiết hơn thông qua trang bảng điều khiển Library Health có thể truy cập từ giao diện trình duyệt của Altium 365 Workspace. Xem Library Health Dashboard để tìm hiểu thêm.

Bạn có thể sử dụng tính năng lọc tùy chỉnh để tinh chỉnh thêm việc lọc trong panel Components. ​​​​​​

Tính năng này khả dụng bằng cách:

  1. nhấp vào biểu tượng bộ lọc () trong phần đầu để hiển thị danh sách thả xuống Filter,

  2. danh sách này hỗ trợ lọc bằng cách chọn một Filter Value (mặc định), hoặc bằng cách cấu hình một Filter Rule do người dùng định nghĩa. Nếu bạn chọn một giá trị từ danh sách, giá trị đó sẽ tự động được chuyển thành một biểu thức (sau đó có thể chỉnh sửa).

  3. Nếu bạn chọn Filter Rules để tự định nghĩa bộ lọc của mình, bạn sẽ chọn một toán tử từ danh sách thả xuống thứ nhất, sau đó chọn hoặc nhập một giá trị lọc trong danh sách thả xuống thứ hai.

  4. Bộ lọc hiện tại được hiển thị bên dưới danh sách kết quả, nhấp nút để mở hộp thoại Filter Editor và chỉnh sửa bộ lọc của bạn.

Nơi được sử dụng

Chọn một linh kiện Workspace trong panel Components để xem thông tin về nơi bản revision mới nhất của nó hiện đang được sử dụng trong vùng Where Used. Vùng này cung cấp thông tin lọc nhanh cho:

  • Projects – các dự án Workspace mà linh kiện đã được sử dụng. Thông tin only được hiển thị sau khi dự án đã được lưu vào Workspace.

  • Managed Sheets – các trang schematic được quản lý mà linh kiện đã được sử dụng. 

  • Reuse Blocks – các Reuse Block được lưu trữ như một phần của thư viện của Workspace đã kết nối.

Lưu ý rằng các tab sẽ chỉ được hiển thị nếu có một thực thể trong Workspace sử dụng linh kiện đã chọn.

Nếu một linh kiện không được sử dụng trong tất cả các design variants của một dự án Workspace, mục của dự án trong vùng Where Used sẽ hiển thị số lượng biến thể có sử dụng linh kiện đó và tổng số biến thể của dự án này, cũng như danh sách các biến thể có sử dụng linh kiện đó ().

Bộ đệm dữ liệu linh kiện

Khi sử dụng panel Components, dữ liệu cho các linh kiện Workspace được lưu đệm vào máy cục bộ từ Workspace. Điều này cung cấp chế độ truy cập ngoại tuyến cho các linh kiện Workspace khi Altium Designer không được kết nối với Workspace, và do đó cho phép duyệt và đặt linh kiện bình thường, v.v.

Ở lần khởi chạy đầu tiên của panel Components trong phiên Altium Designer hiện tại, một cảnh báo sẽ được hiển thị trong panel khi ở chế độ ngoại tuyến, cùng với các điều khiển để tiếp tục sử dụng dữ liệu linh kiện đã lưu đệm hoặc xóa bộ đệm.

Nhấp vào Use Cached Data để sử dụng các linh kiện đã lưu đệm. Trạng thái này sẽ được biểu thị bằng văn bản cảnh báo Offline mode – cached data is being used trong thanh dưới của khung danh sách linh kiện của panel. Lưu ý rằng Filters sẽ không được bật trong chế độ này.

Bộ đệm sẽ tích lũy dữ liệu linh kiện theo thời gian và có thể được xóa bất kỳ lúc nào (cho tất cả Workspace) bằng tùy chọn Clear Cache có trong Known Servers trên trang Data Management – Servers page của hộp thoại Preferences.

Hành vi lưu đệm sẽ chỉ hiển thị các linh kiện đã lưu đệm từ Workspace hiện đang được kết nối, chẳng hạn như Altium 365 Workspace, nghĩa là một số dữ liệu đã lưu đệm nhất định có thể bị vô hiệu hóa. Hành vi này có thể được quản lý từ trang Data Management – Servers của hộp thoại Preferences.

Danh sách Part Choices

Chỉnh sửa Part Choices List được liên kết với một linh kiện Workspace bằng cách chọn tùy chọn Operations » Create/Edit Part Choices  từ menu chuột phải của mục đó.

Sử dụng nút của hộp thoại Edit Part Choices sau đây để mở hộp thoại Add Part Choices, hộp thoại này sẽ tự động tìm kiếm các nhà sản xuất part theo tham số Name của linh kiện đã chọn. Bỏ chọn thuật ngữ tìm kiếm được xác định trước để tự tìm kiếm các phương án thay thế. Về mặt chức năng, hộp thoại này là phiên bản modal của Manufacturer Part Search panel.

Danh sách Part Choice có thể được xếp hạng bằng cách chọn mức biểu tượng ngôi sao phù hợp, khi đó danh sách sẽ tự động được sắp xếp lại với lựa chọn của nhà sản xuất được xếp hạng cao nhất ở trên cùng.

Part Choices đi kèm với linh kiện ở bất cứ nơi nào dữ liệu của nó được áp dụng, chẳng hạn trong thiết kế schematic, tài liệu BOM, báo cáo đầu ra, v.v.

Khi một linh kiện được chọn trong panel Components, danh sách part choice của nó có thể được xem trong vùng Part Choices của khung Details. Thông tin cơ bản (tồn kho, giá đơn vị trung vị và vòng đời của nhà sản xuất) về part choice liên quan cũng có sẵn ở đầu khung Details. Dải màu đi kèm cho biết mức độ phù hợp cơ bản của part khi sử dụng dựa trên trạng thái Lifecycle suy ra của nó – ví dụ, một linh kiện được gắn cờ Obsolete (đỏ) không được khuyến nghị bằng linh kiện được đánh giá là Volume Production (xanh lá). Di chuột lên dải màu để xem trạng thái Manufacturer Lifecycle của nó.

Nếu bạn sử dụng chức năng tích hợp Silicon Expert hoặc Z2 Data, dữ liệu và các điều khiển bổ sung có thể khả dụng ở đầu khung Details. Tham khảo các trang Pulling Part Data from SiliconExpert và Pulling Part Data from Z2Data để tìm hiểu thêm.

Nếu bạn đã bật tính năng Part Choice Revision Control cho Workspace của mình, việc chọn tùy chọn Operations » Create/Edit Part Choices  sẽ mở Component Editor (ở chế độ Single Component Editing hoặc Batch Component Editing) thay vì hộp thoại Edit Part Choices. Hãy áp dụng mọi thay đổi cần thiết cho các part choice và lưu linh kiện trở lại Workspace vào revision linh kiện tiếp theo.

Menu chuột phải của Components Panel

Menu bật lên khi nhấp chuột phải cho panel cung cấp các lệnh sau:

  • Place [ComponentName/FootprintName/SimulationModelName] – dùng để đặt linh kiện hoặc simulation model hiện được chọn lên tài liệu schematic đang hoạt động hoặc footprint hiện được chọn lên tài liệu PCB đang hoạt động.

  • Find Similar Components – dùng để mở hộp thoại Find Similar Components dialog nhằm thiết lập tiêu chí tìm kiếm để tìm các linh kiện tương tự linh kiện đã chọn.

  • Navigate to [ComponentName] – dùng để mở linh kiện Workspace đã chọn trong Explorer panel, tại đó bạn có thể truy cập thông tin Item chi tiết và quản lý các thiết lập revision và lifecycle cho các Item, cũng như chi tiết nơi được sử dụng và chuỗi cung ứng, cùng nhiều tùy chọn khác.

  • Edit – nhấp để chỉnh sửa linh kiện Workspace đã chọn thông qua Component Editor (ở chế độ Single Component Editing hoặc Batch Component Editing) hoặc chỉnh sửa domain model đã chọn (symbol, footprint hoặc simulation model) trong trình chỉnh sửa tương ứng của nó. Nếu loại linh kiện hiện tại khác với template hiện đang được sử dụng, hộp thoại Change component type sẽ mở ra (). Sử dụng hộp thoại này để thay đổi loại linh kiện của linh kiện đã chọn.

  • Create – nhấp để mở hộp thoại Create new component nhằm chọn loại linh kiện khi thêm linh kiện mới.

  • Delete – nhấp để xóa (các) linh kiện đã chọn khỏi Workspace đã kết nối của bạn.

  • Operations – dùng để truy cập menu thả xuống của các chức năng bổ sung cho linh kiện Workspace như mô tả bên dưới.

    • Submit Request – dùng để truy cập các định nghĩa quy trình yêu cầu part đang hoạt động. Nếu không có định nghĩa quy trình đang hoạt động nào khả dụng cho chủ đề quy trình Part Requests, nút Submit Request sẽ bị làm mờ (không khả dụng). Bạn có thể cần đăng xuất khỏi Workspace rồi đăng nhập lại hoặc khởi động lại Altium Designer để làm mới.

    • Download – dùng để tải xuống (các) linh kiện đã chọn thành một Integrated Library (*.IntLib) đã biên dịch và nén zip, cùng với gói thư viện nguồn của nó (*.LibPkg) và các tệp thư viện. Chọn nhiều mục linh kiện để tải xuống các linh kiện đó trong một phiên duy nhất.

    • Make a copy – nhấp để sao chép linh kiện đã chọn. Trình chỉnh sửa linh kiện sẽ mở ở chế độ Single Component Editor.

    • Change Component Type – dùng để mở hộp thoại Choose component type (), từ đó bạn có thể thay đổi loại hiện tại của linh kiện sang một trong các loại đã được định nghĩa khác có trong danh sách. Hộp thoại hiển thị thông tin về bất kỳ template linh kiện nào được liên kết với một loại linh kiện và thư mục trong Workspace đã kết nối nơi có thể tìm thấy/lưu các linh kiện của loại đó. Nhấp vào nút để quản lý danh sách các Loại Linh kiện hiện có trên trang Data Management – Component Types của hộp thoại Preferences

    • Change State – dùng để thay đổi trạng thái revision của (các) linh kiện đang được chọn. Sau khi dùng lệnh này, hộp thoại Batch state change dialog sẽ mở ra, cho phép bạn thay đổi trạng thái revision của (các) linh kiện.

    • Create/Edit Part Choices – dùng để truy cập hộp thoại Edit Part Choices, nơi bạn có thể tạo hoặc chỉnh sửa danh sách part choice được liên kết với linh kiện Workspace.

      Nếu bạn đã bật tính năng Part Choice Revision Control cho Workspace của mình, việc chọn lệnh này sẽ mở Component Editor ở chế độ Single Component Editing hoặc Batch Component Editing.
    • Full Item History – dùng để truy cập chế độ xem chi tiết cho linh kiện hiện đang chọn, được mở dưới dạng một thẻ xem mới trong Altium Designer. Item View cung cấp chế độ xem rất chi tiết về lịch sử Revision và Lifecycle của một Item cụ thể, đồng thời hiển thị tất cả các phần tử cấu thành Item đó. Chế độ xem này cũng bao gồm một Timeline. Hãy dùng Timeline để xem chính xác thời gian và ngày tháng của bất kỳ thay đổi nào được thực hiện ở mức Revision hoặc Lifecycle State của Item đó và ai là người đã thực hiện thay đổi.

     

  • Refresh – bấm để làm mới nhanh panel. Phần chọn linh kiện hiện tại sẽ được giữ lại.

Tính năng So sánh Linh kiện

Tính năng Compare cho phép bạn so sánh các tham số của hai linh kiện (part) được chọn. Tính năng này được truy cập bằng cách chọn hai linh kiện trong vùng lưới khi biểu tượng được bật (màu xanh). Vùng Selected Component Details sẽ mở ra ở bên phải vùng lưới. Vùng phía trên (vùng 1 trong hình bên dưới) hiển thị hình ảnh, tên, mô tả và giá của các linh kiện được chọn cạnh nhau. Bấm nút Datasheet để mở datasheet của nhà sản xuất (nếu có) cho linh kiện tương ứng. Bấm nút Place để đặt linh kiện vào không gian thiết kế. Linh kiện sẽ xuất hiện ở trạng thái nổi trong không gian thiết kế; bấm để đặt linh kiện vào vị trí mong muốn. Bạn có thể tiếp tục đặt thêm linh kiện hoặc nhấp chuột phải hay Esc để thoát khỏi chế độ đặt và quay lại panel Components.

Vùng phía dưới (vùng 2 trong hình bên dưới) hiển thị chế độ xem cạnh nhau của các tham số linh kiện, với các điểm khác biệt được tô đỏ để dễ so sánh.

Tính năng Compare cũng khả dụng khi panel Components ở chế độ thu gọn, dù cách hoạt động có hơi khác một chút. Tính năng này được truy cập bằng cách chọn hai linh kiện trong vùng lưới. Vùng Selected Component Details sẽ mở ra bên dưới vùng lưới. Vùng phía trên hiển thị tên, giá và chế độ xem các tham số của linh kiện, với các điểm khác biệt được tô đỏ để dễ so sánh. Vùng phía dưới hiển thị chế độ xem cạnh nhau của SymbolsModels của các linh kiện.

Tính năng và chức năng Compare cũng có trong Manufacturer Part Search panel.

Chỉnh sửa Symbol và Footprint của Linh kiện

Symbol và footprint của một linh kiện nhất định có thể được ẩn trong phần Models của khung Details, được truy cập bằng cách bấm Info button ở góc trên bên phải. Khi đã ẩn, symbol và footprint sẽ được thay bằng các liên kết có thể bấm để khôi phục các mục đã ẩn về chế độ xem ban đầu. Ngoài ra còn có khả năng thay đổi tỷ lệ kích thước của các model đang hiển thị. Với cả symbol và footprint, hãy bấm và kéo cạnh dưới của vùng model để thay đổi kích thước hình ảnh.

Lưu ý rằng khả năng ẩn và thay đổi tỷ lệ các chế độ xem model cũng có trong khung Details của Manufacturer Part Search panel.

Đối với tệp Schematic Library (*.SchLib) đang được duyệt trong panel Components, symbol và footprint của linh kiện được chọn có thể được chỉnh sửa bằng nút ở góc dưới bên phải của phần xem trước model.

Khả năng chỉnh sửa footprint sẽ khả dụng khi truy cập Components, miễn là các footprint hợp lệ và đã được liên kết đã có sẵn.

Hộp thoại Chọn Linh kiện

Công cụ tìm kiếm và chế độ xem được dùng trong panel Components cũng được áp dụng trong các ứng dụng Altium Designer khác, nơi cần chọn linh kiện. Chức năng tìm kiếm linh kiện được tích hợp trong các hộp thoại (modal) này, cùng với nút xác nhận OK và một số khác biệt nhỏ trong các lệnh thao tác có sẵn. Hộp thoại này thường được gọi là Component Search.

  • Tài liệu ActiveBOM – chế độ xem tìm kiếm Components được dùng khi thay đổi một Workspace component sang một linh kiện thay thế. Nhấp chuột phải vào một mục linh kiện trong danh sách và chọn Change [component name] từ menu ngữ cảnh để mở hộp thoại Replace Component.
  • Item Manager – chế độ xem tìm kiếm Components được dùng khi chọn thủ công một Workspace component để thay thế linh kiện hiện tại. Nhấp chuột phải vào một mục linh kiện trong danh sách và chọn Choose manually từ menu ngữ cảnh để mở hộp thoại Replace Component dialog.
  • Variant Management – chế độ xem tìm kiếm Components được dùng khi chọn một biến thể dự án linh kiện thay thế. Chọn một Alternate part làm Component Variation, sau đó Choose trong hộp thoại Edit Component Variation dialog để mở hộp thoại Replace Component dialog.

Truy cập và Đặt Generic Components

Tính năng này đang ở giai đoạn Open Beta và khả dụng khi tùy chọn ComponentSearch.GenericComponents được bật trong hộp thoại Advanced Settings dialog.

Để đẩy nhanh quá trình bố trí các giai đoạn đầu của thiết kế, khái niệm Generic Components  tiêu chuẩn, cơ bản được cung cấp. Generic components có thể được đặt nhanh vào thiết kế mà không cần tìm và chọn một part của nhà sản xuất cụ thể từ các nguồn linh kiện hiện có. Generic components được dùng như các phần tử giữ chỗ, có thể dễ dàng thay bằng một linh kiện phù hợp về sau trong quá trình thiết kế – chúng cũng có thể được xem là linh kiện ảo hoặc linh kiện tham số.

Để tìm hiểu thêm về việc tạo generic component, hãy tham khảo trang Creating Generic Components .

Khi Altium Designer được kết nối với một Workspace, các Generic Components khả dụng có thể được truy cập từ panel, nơi chúng được hiển thị khi tùy chọn All được chọn trong khung Categories – hoặc từ menu thả xuống phía trên khi panel ở chế độ thu gọn. Bấm nút trong ô Generic Component để gắn linh kiện vào con trỏ nhằm đặt vào tài liệu schematic đang hoạt động. Khi linh kiện được đặt vào schematic, các primitive chân, đường và viền của symbol – tức là đường bao của nó – sẽ được tô màu đỏ để chỉ ra rằng một generic component đang được sử dụng. Việc chọn chính ô đó trong panel Components sẽ mở danh mục loại linh kiện tương ứng trong panel.

Đặt một generic component từ panel Components
Đặt một generic component từ panel Components

Vì Generic Components không được phép dùng trong thiết kế cuối cùng, chúng sẽ gây ra vi phạm ERC – Generic Component – khi được đặt trong schematic. Mức độ của vi phạm đó – mặc định là một Fatal Error – được xác định trong phần Violations Associated with Components của thiết lập Error Reporting trong hộp thoại Project Options (Project » Project Options).

Chọn một Generic Component đã được đặt để truy cập các thuộc tính của nó trong Properties panel, nơi chỉ cung cấp những thiết lập và tham số liên quan đến loại linh kiện này. Các tham số khả dụng được xác định bởi Component Template liên quan (Resistors trong ví dụ hiển thị ở đây). Các giá trị tham số có thể được nhập thủ công hoặc chọn từ danh sách menu thả xuống, danh sách này cung cấp các giá trị lấy từ tất cả linh kiện khả dụng của loại đó.

Javascript ID: GenericComponents_Parameters

Chỉ định tham số cho generic component – chọn giá trị tham số từ các danh sách thả xuống.

Chỉ định tham số cho generic component – kết quả.

Hỗ trợ cho Jumper Components

Jumper, còn được gọi là wire link, cho phép bạn thay thế việc đi dây bằng một linh kiện Jumper, điều thường là yếu tố thiết yếu để thiết kế thành công một bo mạch một mặt. Altium Designer hỗ trợ sử dụng jumper components thông qua một loại linh kiện đặc biệt là Jumper.

Mặc dù bạn có thể bắt đầu bằng cách đặt trực tiếp các footprint Jumper lên PCB, quy trình làm việc được khuyến nghị là bắt đầu từ schematic. Để tìm hiểu thêm, hãy tham khảo trang Working with Jumper Components.

AI-LocalizedBản địa hóa bằng AI
Nếu bạn phát hiện vấn đề, hãy chọn văn bản/hình ảnh và nhấnCtrl + Enterđể gửi phản hồi cho chúng tôi.
Tính khả dụng của tính năng

Các tính năng bạn có thể sử dụng phụ thuộc vào giải pháp Altium mà bạn đang có – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, hoặc Altium Designer (đang trong thời hạn hiệu lực).

Nếu bạn không thấy một tính năng được nêu trong tài liệu có trong phần mềm thực tế của mình, liên hệ Bộ phận Kinh doanh của Altium để tìm hiểu thêm.

Tài liệu cũ

Tài liệu Altium Designer không còn được phân phiên bản. Nếu bạn cần truy cập tài liệu cho các phiên bản cũ hơn của Altium Designer, hãy truy cập mục Tài liệu cũ trên trang Trình cài đặt khác.

Nội dung