规划刚性区域与柔性区域 - 标准模式
概览
- 了解标准刚柔结合模式与高级刚柔结合模式之间的关键区别,以及如何快速识别 PCB 当前使用的模式。
- 掌握在标准模式下创建和编辑电路板区域的基本流程,包括放置、移动和删除分割线。
- 了解如何分配层叠、重命名区域和定义板形,以正确设置刚性区域和柔性区域。
通过放置一条分割线,可将板形划分为两个区域。此操作需要在 PCB 编辑器处于 Board Planning Mode 时进行。 板区域是分割线之间的区域,系统会为其分配默认区域名称。
放置分割线
要放置分割线:
- 选择 View » Board Planning Mode(或按快捷键 1)进入 Board Planning Mode。
- 选择 Design » Define Split Line 进入分割线放置模式(可使用 D, S 按键序列快速执行此命令)。
- 在板形within单击,开始定义分割线。线的一端会吸附到板形轮廓上距离单击位置最近的点,另一端则随光标移动。
- 将光标移到所需位置,然后单击以放置另一端。 如果位置有效,分割线将保持蓝色。如果位置无效(例如位于板形之外),分割线将变为红色。如果在分割线呈红色时单击放置,该分割线将被移除。
- 此时仍处于分割线放置模式,可根据需要继续放置另一条分割线。如果不需要继续放置,请单击右键或按 Esc 退出分割线放置模式。
板区域是分割线之间的区域,系统会为其分配默认区域名称。

通过放置从板形的一条边延伸到另一条边的分割线,可将电路板划分为不同的区域。

通过放置多条分割线,电路板已被划分为多个不同的区域。请注意,图中还放置了弯折线。
移动分割线
要移动分割线:
- 选择 View » Board Planning Mode 或按快捷键 1 进入 Board Planning Mode。
- 要移动线的端点,请单击并按住该端点,将其沿板形周边拖动到所需位置。光标将受当前捕捉网格约束。
板区域将根据编辑后的分割线新位置重新定义。

选择并拖动分割线的端点节点,以重新定义板区域的范围。
移除分割线
要删除分割线:
- 选择 View » Board Planning Mode 或按快捷键 1 进入 Board Planning Mode。
- 单击并按住其中一个端点,然后按 Delete 键。也可以单击并按住端点,将其移动到板形周边使分割线变为红色的位置(表示分割无效),然后松开。
要从当前电路板中删除一条或多条现有分割线,也可以在 Board Planning Mode 下使用主菜单中的 Design » Delete Split Line 命令。 执行命令后,光标将变为十字形,并进入分割线删除模式。要删除分割线,请将光标置于其任一端点(编辑控制点)上,然后单击或按 Enter。可按此方式继续移除其他分割线,也可以单击右键或按 Esc 退出分割线删除模式。
分配层叠并编辑板区域名称
Related page: 定义层叠
新建电路板时,板上只有一个区域,名称为 Default Layer Stack Region。系统会为该区域分配名为 Board Layer Stack 的默认层叠。
将板形分割成多个区域时,每个新区域也会被分配默认层叠,原始区域命名为 Default Layer Stack Region,后续区域则按 Layer Stack Region 格式命名。如果已在层叠管理器中定义了所需的层叠,就可以为各区域分配层叠,并赋予有意义的名称。
要分配层叠并为区域命名:
- 选择 View » Board Planning Mode 或按快捷键 1 进入 Board Planning Mode。
- 单击 Multi-Layer工作区底部的选项卡,将其设为活动层(如果图层选项卡不可见,请按 L 打开 View Configuration(视图配置)面板,以启用该选项卡)。
- 双击 板区域以打开 Board Region 对话框。如果无法选中该区域并打开对话框,请确保 Selection Filter(选择过滤器) 未排除区域对象。
- 从 Layer stack 下拉列表中选择所需的叠层,为该区域指定层叠结构。
- 根据需要编辑 Name。
- 必须为一个板区域启用 3D Locked 选项,以定义 3D 显示模式下的物理地面参考。
- 单击 OK 以接受设置并关闭对话框。

双击板区域可定义区域名称并指定层叠结构。
通过分割板外形创建区域的步骤概述
通过放置分割线,可将板形状划分为多个独立的板区域。定义板形状的方法有多种。下方视频演示了如何使用机械层上由线条和圆弧构成的轮廓来定义板形状。定义整体轮廓后,再将其分割为不同的刚性区域和柔性区域。
定义板形状和区域:
- 可以在板规划模式(View » Board Planning Mode)下以交互方式定义板形状,也可以在 2D 布局模式(View » 2D Layout Mode)下基于现有轮廓进行定义,如上方视频所示。
- 要基于现有轮廓定义板形状,请在 2D 布局模式下选择该轮廓,然后运行 Design » Board Shape » Define Board Shape from Selected Objects 命令。软件将沿所选走线/圆弧对象的中心线进行描绘,以定义板形状的外边缘。请注意,轮廓走线/圆弧的端点必须重合,描绘算法才能沿中心线连续描绘。如果失败,描绘算法会提示是否尝试沿所选对象的外边缘进行描绘。
- 要以交互方式定义板形状,请切换到板规划模式(快捷键 1),然后选择 Design » Redefine Board Shape 命令。定义板形状时,适用标准的区域对象放置操作方式,可使用捕捉网格和工作区辅助线来辅助此过程。在 Snap Options(捕捉选项)面板中启用 Board Shape(板形状)选项,可在编辑板形状时实现更精确的控制。进一步了解捕捉行为。
- 要定义每个区域的 Name 并为其指定 Layer stack,请双击该区域。或者,将 PCB 面板设置为 Layer Stack Regions 模式,即可查看和编辑区域及弯折线。
- 要将一个板区域分割为两个较小的区域,请使用 Design » Define Split Line 命令。此命令会在两次单击的位置之间放置一条直线。当您在板形状内部单击时,第一个端点将位于最靠近单击位置的板边缘上。移动光标以确定第二个端点的位置,然后再次单击。单击并按住分割线的顶点,可将其移动到新位置。
- 可以编辑现有板区域的位置和形状。运行 Design(设计)Design » Edit Board Shape 命令,然后使用标准的多边形对象编辑方法调整其形状。