定义折弯线 - 标准模式

概览

本文介绍在 Altium Designer 的标准刚挠结合模式下,如何为柔性区域定义、放置、移动、删除和配置弯折线。本文还将说明标准刚挠结合模式与高级刚挠结合模式的区别、如何确认电路板当前使用的模式,以及如何使用相应的编辑器视图和面板来精确管理弯折。如果您希望通过实际操作了解如何在正确的模式下设置弯折位置、角度、半径、受影响区域宽度和折叠顺序,本指南将帮助您更有把握地开展设计。请继续阅读,并在下一个设计中运用这些步骤。

- 了解在标准刚挠结合模式下何时可以使用弯折线,以及该模式与高级刚挠结合模式在电路板区域定义方面的区别。
- 掌握在板规划模式下放置、重新定位、删除和精确对齐弯折线的具体步骤。
- 了解可配置的弯折线属性,包括弯折角度、半径、受影响区域宽度,以及用于 3D 折叠检查的折叠顺序。
使用 AI 深入了解:

Altium 的 PCB 设计软件提供两种刚柔结合设计模式。原始模式(也称为标准模式)称为“刚柔结合”,支持简单的刚柔结合设计。如果您的设计有更复杂的刚柔结合要求,例如柔性区域重叠,则需要使用“高级刚柔结合”模式(也称为刚柔结合 2.0)。可在层叠管理器的 Tools 菜单中选择模式。

这两种模式的根本区别在于:在原始模式中,通过放置分割线将板形分割为多个独立的板区域,分割线作为对象保留下来,用于界定一个板区域的终点和另一个板区域的起点。在高级模式中,每个板区域都是单独放置的;如果对较大的区域进行切割,则会生成两个独立的区域对象。在高级模式中,两个相邻板区域的交界由各自的边缘定义,而不是由分割线定义。由于这一差异,电路板处于高级刚柔结合模式时不存在分割线对象。

► 了解有关设计刚柔结合 PCB 的更多信息

View 菜单提供三种 PCB 编辑器工作模式,并配有易于记忆的快捷键,便于您在以下模式之间快速切换:

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

在 2D 和 3D 视图模式之间切换时,默认会分别保留各视图模式的缩放和方向设置。如果希望切换时保持电路板的位置和方向一致,请按 Ctrl+Alt+2 或 Ctrl+Alt+3,而不是 2 或 3。

刚打开一个 PCB,想知道它使用的是标准刚柔结合模式还是高级刚柔结合模式?

您可以打开层叠管理器进行检查。也可以切换到板规划模式(快捷键为 1),然后查看活动栏:

标准刚柔结合模式
高级刚柔结合模式

要定义柔性电路板的弯折方式,需要放置一条或多条弯折线。弯折线定义了柔性区域表面上发生弯折的位置,还定义了弯折角度、弯折半径 以及参与弯折的条状板面区域的宽度。要放置和编辑弯折线,需将 PCB 编辑器切换到 Board Planning Mode(View » Board Planning Mode,或按快捷键 1)。

弯折线只能放置在 Layer Stack Manager 中配置为 Flex 的区域上。


在柔性区域上放置一条弯折线,并进行配置,使电路板能够折叠 180 度。本视频演示了如何在标准刚柔结合模式下放置弯折线。

放置弯折线

要放置弯折线:

  1. 选择 View » Board Planning Mode 或按快捷键 1,进入 Board Planning Mode。

  2. 弯折线放置在 Multi-Layer 上。 如果编辑区底部未显示 Mutli-Layer 选项卡,请在 View Configuration 面板中启用该层(按快捷键 L 显示该面板)。

  3. 选择 Design » Define Bending Line 命令。

  4. 在要放置弯折线的板区域内单击,线的一端将附着到距离单击位置最近的区域边缘,另一端则附着到光标上。

  5. 将另一端定位到所需位置,然后单击以完成放置。

  6. 此时仍处于弯折线放置模式,可根据需要继续放置其他弯折线。如果不需要继续放置,右键单击或按 Esc 退出弯折线放置模式。

处于 Layer Stack Regions 模式的 PCB 面板会显示 Bending Lines 数据。双击某个条目可打开弯折线对话框。 

此柔性板区域上已放置了三条弯折线。 橙色条带的宽度即为 受影响区域宽度。
此柔性板区域上已放置了三条弯折线。 橙色条带的宽度即为 受影响区域宽度。

当板区域设置为使用柔性层叠时,系统会自动沿其几何中心垂直添加一条弯折线。请根据需要删除该弯折线,或调整其位置并进行配置。

移动弯折线

要修改现有弯折线的位置:

  1. 选择 View » Board Planning Mode (或按快捷键  1)以进入 Board Planning Mode。
  2. 单击以选中包含弯折线的板区域。该区域内所有弯折线的控制点都会显示出来。
  3. 要重新定位线的端点,请单击并按住该节点,将其拖动到板区域轮廓边界上的所需位置。光标将受当前捕捉栅格和/或现有设计对象的约束。
  4. 弯折位置将根据弯折线的新位置重新定义。

选择并拖动弯折线的端点节点,即可更改电路板上的弯折位置。
选择并拖动弯折线的端点节点,即可更改电路板上的弯折位置。

精确定位弯折线

移动弯折线时,其控制点会捕捉到当前捕捉栅格上的位置。移动过程中,它也可以捕捉到现有设计对象,例如机械层上的线。下图展示了将弯折线控制点定位到 Mechanical 2 层上一条线端点的情形(标记为数字 1)。请注意,只有将该机械层设为当前设计层,才能实现捕捉。

数字 1 表示弯折线控制点正捕捉到 Mechanical 2 层上的一条线;请注意,此层为当前层。
数字 1 表示弯折线控制点正捕捉到 Mechanical 2 层上的一条线;请注意,此层为当前层。

为更详细地展示上述过程,下图显示了在 2D Layout Mode 中放置于 Mechanical 2 层上的辅助线。这些辅助线 精确定义了上下参考点,可用于放置 45 度弯折线。

电路板处于2D 布局模式, 其中显示的辅助线有助于精确放置斜向弯折线。电路板处于2D 布局模式, 其中显示的辅助线有助于精确放置斜向弯折线。

电路板处于板规划模式,其中显示的斜向弯折线已捕捉到 Mechanical 2 层上的辅助线。电路板处于板规划模式,其中显示的斜向弯折线已捕捉到 Mechanical 2 层上的辅助线。

删除弯折线

要删除弯折线:

  1. 选择 View » Board Planning Mode(或按快捷键 1)以进入 Board Planning Mode。
  2. 单击并按住其中一个端点, 然后按 Delete 键。也可以在 PCB 面板的 Bending Lines 区域中选中并删除弯折线条目。

当板区域设置为使用柔性层叠时,系统会自动沿其几何中心垂直添加一条弯折线。请根据需要删除该弯折线,或调整其位置并进行配置。

配置弯折线属性

板区域、分割线和弯折线可在 Board Planning Mode 中查看和编辑(按 1)。弯折线可以在设计空间中以交互方式编辑, 也可以通过 PCB进行编辑。面板设置为 Layer Stack Regions 模式时。 要显示该面板,请单击 Altium Designer 右下角的 Panels 按钮,然后从菜单中选择 PCB。在面板顶部的下拉列表中选择 Layer Stack Regions。 在此模式下,面板会显示:

  • Layer Stacks 区域中可用的板层堆栈。
  • Stackup Regions 区域中分配给这些堆栈的区域。
  • Bending Lines 区域中在所选区域内定义的弯折线。

进入 Board Planning Mode 时,PCB 面板将自动配置为 Layer Stack Regions 模式。

要在 PCB 面板中编辑弯折线的属性:

  1. 可以在 2D Layout Mode(按 2)或 Board Planning Mode(按 1)中编辑弯折线。
  2. 勾选面板顶部的 Select 复选框。
  3. 在 PCB 面板的 Stackup Regions 区域中,选择包含该弯折线的板区域。
  4. 从面板的 Bending Lines 区域列表中选择弯折线。如果启用了 PCB 面板的 Select 选项,该弯折线将在电路板上高亮显示(被选中)。也可以从 Bending Lines 区域中删除弯折线条目。
  5. 双击 Bending Lines 区域中的弯折线条目,打开 Bending Line 对话框,如下图所示。

  6. 在 Bending Line 对话框中,编辑前三个属性中的两个,例如 Radius (弯折中心点到弯折表面的距离)和 Bending Angle (柔性区域表面要弯折的角度)。第三个属性 Affected area width(在给定的 Radius 和 Bending Angle 下将发生弯折的表面区域宽度)将自动计算(下文将详细介绍)。请注意,每条弯折线的 Affected area width 均显示为橙色阴影区域。
  7. 在 Bending Line 对话框中,根据需要设置 Fold Index,以定义使用 PCB 面板中的 Fold State 滑块或 View » Fold/Unfold 命令时各弯折的折叠顺序。这些功能用于在 3D 模式下折叠电路板。 数值最小的弯折最先应用,随后按数值从小到大的顺序依次应用。

必须在某个板区域的 Board Region 对话框中勾选 3D Locked 复选框,以定义 3D 显示模式的物理基准平面(Z = 0 的位置)。否则,将不会显示各条已定义弯折线的 Affected area width。

在放置或移动弯折线控制柄时按 Tab,或双击弯折线控制柄,也可以打开 Bending Line 对话框。

定义弯折的要点

弯折线是一种横跨区域放置的线性对象,用于定义电路板相应柔性区域的弯折位置、半径和角度。

定义弯折线:

  • 弯折线在板规划模式下放置(快捷键为 1)。
  • 要放置弯折线,请运行 Design » Define Bending Line 命令。
  • 将弯折线横跨柔性板区域放置。弯折线的起点和终点无需精确接触区域的两侧边缘,软件会自动延长(如果过短)或缩短(如果过长)弯折线。弯折线至少有一端必须接触或越过该区域的边缘。
  • 要编辑弯折线的属性,请单击区域内的任意位置,显示该区域内所有弯折线的顶点,然后:
    • 双击弯折线的顶点以打开 弯折线对话框,或者
    • 显示 PCB 面板并将其设置为 Layer Stack Regions 模式,即可查看和编辑区域及弯折线。
    • 根据需要设置 Bending Angle 和弯折的 Radius。
    • 弯折将按照其 Fold Index 的顺序折叠;当需要检查折叠顺序时,可使用此功能。
  • 要移动弯折线,请单击并拖动各个顶点。
  • 要删除弯折线,请单击并按住其中一个顶点,然后按键盘上的 Delete。
  • 弯折线不能应用于板切口的边缘。如果您的电路板有此需求,请切换到高级刚柔结合模式。
AI-LocalizedAI 翻译
如您发现任何问题,请选中相关文本/图片,并按 Ctrl + Enter 键向我们提交反馈。
Contents
功能可用性

您可使用的功能取决于您所采用的 Altium 解决方案——Altium Develop、Altium Agile Teams、Altium Agile Enterprise,或 Altium Designer(在有效订阅期内)。

如果您在实际软件中未看到文档中介绍的某项功能, 请联系 Altium Sales 了解更多信息。

旧版文档

Altium Designer 文档不再提供版本区分。如果您需要访问 Altium Designer 旧版本的文档,请前往其他安装程序页面的旧版文档部分。

Contents