定义折弯线 - 高级模式

概览

本文介绍 Altium Designer 高级刚柔结合模式中折弯线的工作原理,重点说明该模式与标准刚柔结合模式的区别,以及这些区别如何影响柔性区域的定义和电路板折叠。您将了解如何识别 PCB 当前使用的刚柔结合模式,在板规划模式下放置和调整折弯线、编辑其属性,以及控制电路板在 3D 折叠时的折弯效果。如果您正在进行较复杂的刚柔结合设计,需要有关定义折弯位置、角度、半径和折叠顺序的实用指导,本文将助您更有把握地推进设计。请继续阅读,让您的刚柔结合设计流程更加精确,结果更可预测。

- 了解标准刚柔结合模式与高级刚柔结合模式之间的区别,尤其是高级模式不使用分割线对象的原因。
- 掌握在板规划模式下放置、移动、删除折弯线以及精确定位折弯线的基本流程。
- 了解哪些折弯线属性控制 3D 折弯行为,包括角度、半径、叠层区域分配和折叠顺序。
使用 AI 深入了解:

Altium 的 PCB 设计软件提供两种刚柔结合设计模式。原始模式(即标准模式)称为“刚柔结合”,支持简单的刚柔结合设计。如果您的设计有更复杂的刚柔结合要求,例如柔性区域重叠,则需要使用高级刚柔结合模式(也称为刚柔结合 2.0)。可在层叠管理器的 Tools 菜单中选择模式。

这两种模式的根本区别在于:在原始模式中,通过放置分割线将板形分成独立的板区域,该分割线会保留为一个对象,用于定义一个板区域的结束位置和另一个板区域的起始位置。在高级模式中,每个板区域都是单独放置的;如果对较大的区域进行切割,则会生成两个独立的区域对象。在高级模式中,两个相邻板区域的交界位置由各自的边缘定义,而不是由分割线定义。因此,当电路板处于高级刚柔结合模式时,不存在分割线对象。

► 了解有关设计刚柔结合 PCB 的更多信息

View 菜单提供三种 PCB 编辑器工作模式,并配有易于记忆的快捷键,方便您在以下模式之间快速切换:

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

在 2D 和 3D 视图模式之间切换时,默认会分别保留各视图模式的缩放和方向设置。如果希望切换时看到电路板的相同位置和方向,请按 Ctrl+Alt+2 或 Ctrl+Alt+3,而不是 2 或 3。

刚打开一块 PCB,想知道它使用的是标准刚柔结合模式还是高级刚柔结合模式?

您可以打开层叠管理器进行检查。也可以切换到板规划模式(快捷键为 1),然后查看活动栏:

标准刚柔结合模式
高级刚柔结合模式

要定义柔性板的弯曲方式,需要放置一条或多条弯曲线。弯曲线用于定义柔性区域表面发生弯曲的位置,同时也定义弯曲角度和半径。发生弯曲的条状板面以橙色显示,其宽度根据弯曲角度和半径计算得出(了解有关弯曲线属性的更多信息)。放置和编辑弯曲线时,PCB 编辑器需处于 Board Planning Mode(View » Board Planning Mode,或按快捷键 1)。


在柔性区域上放置一条弯曲线,并进行配置,使电路板能够折叠 180 度。此视频演示了如何在高级刚柔结合模式下放置弯曲线。

放置弯曲线

要放置弯曲线:

  1. 选择 View » Board Planning Mode 或按快捷键 1,进入 Board Planning Mode。
  2. 选择 Place » Define Bending Line 命令,或单击活动栏上的  按钮。
  3. 弯曲线放置在所需板区域的上方,并不附着于该区域(弯曲线通过 Stack Regions 属性与一个或多个板区域关联)。在板区域边缘附近单击,定义弯曲线的起始位置。
  4. 将光标移至所需的终点位置,然后单击以放置弯曲线。请注意,弯曲线至少有一端必须接触或越过其所应用的板区域边界。
  5. 此时仍处于弯曲线放置模式,可根据需要继续放置另一条弯曲线。如果不需要,请右键单击或按 Esc 退出弯曲线放置模式。

可以在 Properties 面板中编辑所选弯曲线的属性。由于弯曲线位于区域上方,单击弯曲线时,可能会选中其下方的区域。保持光标不动,再单击一次,即可选中弯曲线而不是板区域。

所选弯曲线的属性显示在“属性”面板中。
所选弯曲线的属性显示在“属性”面板中。

  • 弯曲线的起点或终点不必精确落在板区域边缘上,软件会自动延长或缩短弯曲线,使其从区域的一侧边缘延伸到另一侧边缘。
  • 确保在 Properties 面板的 Stack Regions 部分中启用了正确的板区域。

移动弯曲线

要修改现有弯曲线的位置:

  1. 选择 View » Board Planning Mode (或按快捷键 1),进入 Board Planning Mode。
  2. 单击并按住弯曲线任意一端的顶点,将该顶点拖动到所需位置,然后松开鼠标按钮。光标将受当前光标捕捉设置的约束,操作过程中可按 Ctrl+E 更改设置。
  3. 弯曲位置将根据弯曲线的新位置重新定义。

选择并拖动弯曲线的顶点,即可更改弯曲线在电路板上的位置;光标将受当前光标捕捉设置的约束。
选择并拖动弯曲线的顶点,即可更改弯曲线在电路板上的位置;光标将受当前光标捕捉设置的约束。

精确定位弯曲线

移动弯曲线的控制点时,控制点会按照当前捕捉设置进行捕捉。在移动过程中按 Ctrl+E,可弹出捕捉设置交互式控制面板,如下图所示。更改设置后,按 Esc 应用设置并关闭面板。

除了捕捉到捕捉栅格和工作区参考线之外,弯曲线还可以捕捉到现有设计对象,例如机械层上的线。下图显示了将弯曲线控制点定位到机械层上一条线的端点的过程。请注意,移动过程中会应用当前的热点捕捉设置(显示在状态栏上);如果机械层不是当前活动设计层,则必须将热点捕捉配置为 All Layers,才能实现此捕捉行为。操作过程中可按快捷键 Shift+E,在可用的热点捕捉模式之间循环切换。

弯曲线的控制点正在捕捉到机械层上放置的一条走线的顶点。
弯曲线的控制点正在捕捉到机械层上放置的一条走线的顶点。

移除弯曲线

要移除弯曲线:

  1. 选择 View » Board Planning Mode(或按快捷键 1),进入 Board Planning Mode。
  2. 单击并按住弯曲线的一个顶点以选中弯曲线,然后按 Delete 键。

配置弯曲线属性

要在 Properties 面板中编辑弯曲线的属性:

  1. 切换到 Board Planning Mode(按 1)。
  2. 单击弯曲线橙色带状区域内的任意位置以选中它。
  3. 可以在 Properties 面板中编辑弯曲线。

当电路板以 3D 模式显示时,可以应用已定义的弯折;按下 5 快捷键即可折叠电路板。勾选了 3D Locked 复选框的刚性板区域是 3D 显示模式的物理基准面(Z = 0 所在位置)。如果电路板未按预期折叠,请检查是否在正确的刚性区域中勾选了 3D Locked 复选框。请注意,在另一个板区域中启用此选项之前,无需先在当前板区域中取消勾选。

AI-LocalizedAI 翻译
如您发现任何问题,请选中相关文本/图片,并按 Ctrl + Enter 键向我们提交反馈。
Contents
功能可用性

您可使用的功能取决于您所采用的 Altium 解决方案——Altium Develop、Altium Agile Teams、Altium Agile Enterprise,或 Altium Designer(在有效订阅期内)。

如果您在实际软件中未看到文档中介绍的某项功能, 请联系 Altium Sales 了解更多信息。

旧版文档

Altium Designer 文档不再提供版本区分。如果您需要访问 Altium Designer 旧版本的文档,请前往其他安装程序页面的旧版文档部分。

Contents