Erstellen eines Mehrkanal-Designs

Auf einen Blick

Dieser Artikel erklärt, wie Sie mit dem Mehrkanaldesign in Altium Designer einen wiederkehrenden Schaltungsabschnitt nur einmal erfassen und anschließend von der Software im gesamten Design wiederholen lassen. Dabei werden Bauteile, Netze und die Übertragung auf die Leiterplatte automatisch verwaltet. Sie erfahren, wie die dynamische Kompilierung und das Unified Data Model diesen Prozess unterstützen, wie Kanäle mithilfe wiederholter Schaltplansymbole oder des Schlüsselworts Repeat erstellt werden und wie Benennungsschemata, Räume und Verbindungseinstellungen helfen, das Endergebnis zu strukturieren. Wenn Sie verstehen möchten, wie Sie wiederkehrende Schaltungsblöcke effizienter erstellen und wie Altium Designer diese vom Schaltplan bis zur Leiterplatte verarbeitet, bietet Ihnen dieser Artikel eine fundierte Grundlage. Lesen Sie weiter und erfahren Sie, wie alles zusammenspielt.

- Wie das Mehrkanaldesign in Altium Designer funktioniert – von der einmaligen Erfassung wiederkehrender Schaltungsabschnitte im Schaltplan bis zur automatischen Vervielfältigung für das Leiterplattenlayout
- Der Unterschied zwischen der Erstellung von Kanälen mit mehreren Schaltplansymbolen und der Verwendung des Schlüsselworts Repeat
- Wie Benennung, Kompilierung, Räume und Verbindungseinstellungen wiederkehrende Kanäle in einem strukturierten Design unterstützen
Mit KI tiefer einsteigen:

Elektronische Designs enthalten häufig wiederkehrende Schaltungsabschnitte. Dabei kann es sich um einen Stereoverstärker oder auch um ein 64-Kanal-Mischpult handeln. Diese Art von Design wird vollständig durch einen Funktionsumfang unterstützt, der als multi-channel design bekannt ist.

Die beiden Decoderkanäle eines Video-Multiplexers: Dank der Mehrkanal-Designstruktur muss der Decoderkanal nur einmal erfasst werden.
Die beiden Decoderkanäle eines Video-Multiplexers: Dank der Mehrkanal-Designstruktur muss der Decoderkanal nur einmal erfasst werden.

Bei einem Mehrkanal-Design erfassen Sie die wiederkehrende Schaltung einmal und weisen die Software anschließend an, sie in der erforderlichen Anzahl zu wiederholen. Bei der automatischen Kompilierung des Designs wird es im Arbeitsspeicher entsprechend erweitert. Dabei werden alle Bauteile und Verbindungen gemäß einem benutzerdefinierten Kanalbenennungsschema in der erforderlichen Anzahl wiederholt.

Das von Ihnen erfasste logische Design wird dabei nie tatsächlich in eine flache Struktur umgewandelt; die Quelldaten bleiben stets als Mehrkanal-Schaltplan erhalten. Bei der Übertragung in das Leiterplattenlayout werden die physischen Bauteile und Netze automatisch in der erforderlichen Anzahl angelegt. Ihnen stehen alle standardmäßigen Werkzeuge für Cross-Probing und Cross-Selecting für die Arbeit zwischen Schaltplan und Leiterplatte zur Verfügung. Außerdem bietet der Leiterplatteneditor ein Werkzeug, mit dem sich die Platzierung und das Routing eines Kanals auf alle anderen Kanäle übertragen lassen. Dabei kann ein gesamter Kanal einfach verschoben und neu ausgerichtet werden.

Dynamische Kompilierung

Related page: Validieren Ihres Designprojekts

Das Verbindungsmodell des Designs wird nach jeder Benutzeraktion durch dynamische Kompilierung schrittweise aktualisiert. Sie müssen das Projekt nicht manuell kompilieren, da dies automatisch erfolgt. Bei einem Designprojekt erfüllt die automatische Kompilierung drei Aufgaben:

  1. Instanziierung der Designhierarchie.
  2. Herstellung der Netzverbindungen zwischen allen Schaltplanblättern des Designs.
  3. Aufbau eines internen einheitlichen Datenmodells (Unified Data Model, UDM) des Designs.

Dadurch wird sichergestellt, dass alle Designänderungen sofort im Navigator und im Projekte-Panel angezeigt werden.

Das kompilierte Modell des Projekts wird als Unified Data Model (UDM) bezeichnet. Das UDM enthält detaillierte Beschreibungen jedes Bauteils im Design sowie seiner Verbindungen zu anderen Bauteilen.

Um anhand des UDM und der Compiler-Einstellungen auf logische, elektrische und zeichnerische Fehler zu prüfen, müssen Sie das Projekt validieren. Diesen Befehl erreichen Sie, indem Sie in den Hauptmenüs den Befehl Project » Validate Project wählen oder im Projekte-Panel mit der rechten Maustaste auf einen Projekteintrag klicken und im Kontextmenü den Befehl Validate Project wählen.

Alle vom Compiler erkannten Verstöße werden als Warnungen und/oder Fehler im Messages-Panel aufgelistet. Bei der Prüfung der Quelldokumente auf Verstöße verwendet der Compiler die Optionen, die auf den Registerkarten Fehlerberichterstattung und Verbindungsmatrix des Dialogfelds Options for Project festgelegt sind, sofern diese für den jeweiligen Projekttyp gelten.

Das Unified Data Model

Um das Mehrkanal-Design zu verstehen, ist es hilfreich zu wissen, wie die Designdaten verwaltet werden. Ein grundlegendes Element der Software ist das Unified Data Model (UDM). Bei der automatischen Kompilierung des Projekts wird ein einziges, zusammenhängendes Modell erstellt, das im Mittelpunkt des Designprozesses steht. Auf die Daten innerhalb dieses Modells kann anschließend mit den verschiedenen Editoren und Diensten der Software zugegriffen werden; sie lassen sich dort auch bearbeiten. Statt für jede Designdomäne einen separaten Datenspeicher zu verwenden, ist das UDM so strukturiert, dass es sämtliche Informationen zu allen Aspekten des Designs aufnehmen kann, einschließlich der Bauteile und ihrer Verbindungen.

Das Unified Data Model stellt allen Editoren sämtliche Designdaten zur Verfügung und ermöglicht damit anspruchsvolle Funktionen wie das Mehrkanal-Design.
Das Unified Data Model stellt allen Editoren sämtliche Designdaten zur Verfügung und ermöglicht damit anspruchsvolle Funktionen wie das Mehrkanal-Design.

Das UDM wird in Kombination mit dem hierarchischen Designsystem genutzt, um Mehrkanal-Designfunktionen bereitzustellen. Ein „Kanal“ ist die Schaltung innerhalb eines Blattsymbols. Unterhalb dieses Blattsymbols kann sich ein einzelnes Blatt oder ein ganzer Zweig der Projektstruktur mit weiteren untergeordneten Blättern befinden. Sie können auch Kanäle innerhalb von Kanälen erstellen. Bei einem zweistufigen Mehrkanal-Design werden die übergeordneten Kanäle als Bänke und die untergeordneten als Kanäle bezeichnet.

Da diese vollständige, für die Leiterplattenumsetzung vorbereitete Beschreibung im Arbeitsspeicher vorliegt, lässt sich ein Schaltungsabschnitt wiederholen, sofern wiederholte Objekte wie Bauteilbezeichner und Netze systematisch behandelt werden können. Die systematische Benennung wird auf der Registerkarte „Mehrkanal“ des Dialogfelds Options for Project festgelegt, wie weiter unten erläutert.

Erstellen eines Mehrkanal-Designs

Ein Design ist ein Mehrkanal-Design, wenn ein Teil der Schaltung wiederholt wird. Dies erfolgt auf der Ebene der Blattsymbole, und zwar auf eine der folgenden Arten:

  • Platzieren mehrerer Blattsymbole, die alle auf denselben untergeordneten Schaltplan verweisen, oder
  • Konfigurieren eines einzelnen Blattsymbols so, dass der referenzierte untergeordnete Schaltplan in der erforderlichen Anzahl wiederholt wird.

Erstes Bild: Vier Blattsymbole verweisen alle auf dasselbe untergeordnete Blatt (PortIO.SchDoc). Zweites Bild: Mithilfe des Schlüsselworts Repeat wird InputChannel.SchDoc achtmal und OutputChannel.SchDoc zweimal wiederholt.
Erstes Bild: Vier Blattsymbole verweisen alle auf dasselbe untergeordnete Blatt (PortIO.SchDoc). Zweites Bild: Mithilfe des Schlüsselworts Repeat wird InputChannel.SchDoc achtmal und OutputChannel.SchDoc zweimal wiederholt.

Diese beiden Ansätze zum Erstellen eines Mehrkanal-Designs sind in den obigen Bildern dargestellt. Im ersten Bild gibt es vier Blattsymbole, die alle auf dasselbe untergeordnete Blatt (PortIO.SchDoc) verweisen. Im zweiten Bild wird InputChannel.SchDoc achtmal und OutputChannel.SchDoc zweimal wiederholt, da das Schlüsselwort Repeat im Feld Designator des Blattsymbols enthalten ist.

Wiederholte Bauteilbezeichner und Netznamen im Projekt werden mithilfe eines standardisierten Benennungsschemas eindeutig zugeordnet. Ein solches Benennungsschema besteht beispielsweise darin, den wiederholten Bauteilen und Netzkennungen (Netzlabels und Ports) einen Kanalindex hinzuzufügen, wie in den Hervorhebungen in den folgenden Bildern gezeigt.

Beachten Sie die Registerkarten am unteren Rand des Schaltplans, die beim Öffnen des Projekts angezeigt werden. Die Registerkarte Editor enthält das logische Design so, wie Sie es erfasst haben. Die weiteren, kompilierten Registerkarten (COUT1 und COUT2) stellen das physische Design dar, das an den Leiterplatteneditor übertragen wird. Für jeden physischen Kanal gibt es eine Registerkarte.

Das kompilierte Projekt mit der Registerkarte für die logische Ansicht und einer Registerkarte für jeden physischen Kanal, der auf die Leiterplatte übertragen wird. Beachten Sie, wie die wiederholten Bezeichner und Netzkennungen verwaltet werden.
Das kompilierte Projekt mit der Registerkarte für die logische Ansicht und einer Registerkarte für jeden physischen Kanal, der auf die Leiterplatte übertragen wird. Beachten Sie, wie die wiederholten Bezeichner und Netzkennungen verwaltet werden.

Das Kanalbenennungsschema wird auf der Registerkarte „Mehrkanal“ des Dialogfelds Options for Project festgelegt.

Das Schlüsselwort Repeat

Wie bereits erwähnt, wird ein Kanal wiederholt, indem mehrere Blattsymbole platziert werden, die auf dasselbe untergeordnete Blatt verweisen, oder indem das Schlüsselwort Repeat im Feld „Bezeichner“ des Blattsymbols angegeben wird. Bei Verwendung des Schlüsselworts Repeat wird das Blattsymbol als Stapel mehrerer Blattsymbole dargestellt.

Die Repeat-Anweisung definiert den Kanalbezeichner und die Anzahl der Kanäle. Beachten Sie, dass das Blattsymbol als Stapel mehrerer Symbole dargestellt wird, um wiederholte Kanäle zu kennzeichnen.
Die Repeat-Anweisung definiert den Kanalbezeichner und die Anzahl der Kanäle. Beachten Sie, dass das Blattsymbol als Stapel mehrerer Symbole dargestellt wird, um wiederholte Kanäle zu kennzeichnen.

Jeder Kanal wird durch einen Kanalbezeichner identifiziert, der aus dem Designator des Blattsymbols stammt. Wenn das Design durch Platzieren mehrerer Blattsymbole in Kanäle aufgeteilt wird, entspricht der Kanalbezeichner dem für jedes Blattsymbol definierten Wert Designator. Wenn die Kanalaufteilung mithilfe des Schlüsselworts Repeat erfolgt, ist der Kanalbezeichner der durch das Schlüsselwort Repeat definierte ChannelIdentifier+ChannelIndex.

Die Syntax des Feldes Designator bei Verwendung des Schlüsselworts Repeat lautet wie folgt:

Repeat(<ChannelIdentifier>,<ChannelIndex_1>,<LastChannelIndex_n>)

Wenn die Option New Indexing of Sheet Symbols auf der Registerkarte Options des Dialogs Project Options aktiviert ist, kann jede Ziffer oder Zahl als erster oder letzter Index eines wiederholten Schaltplansymbols verwendet werden, einschließlich 0. Der letzte Index muss immer größer als der erste sein; negative Zahlen sind nicht zulässig.

Benennung bei Mehrkanal-Designs

Das Konzept, eine Schaltung einmal zu erfassen und anschließend zu wiederholen – das Mehrkanal-Design –, basiert auf dem einheitlichen Datenmodell (Unified Data Model, UDM) der Software. Wiederholte Bauteile werden nach einem systematischen Benennungsschema benannt, das auf der Registerkarte Multi-Channel des Dialogs Options for Project konfiguriert wird, wie unten gezeigt.

Der Dialog enthält einen oberen Bereich zur Steuerung der Benennung der Rooms und einen unteren Bereich zur Steuerung der Benennung der Bauteile innerhalb dieser Rooms. Auf Room-Ebene stehen zwei flache und drei hierarchische Benennungsstile zur Verfügung. In der Regel benötigen Sie einen hierarchischen Benennungsstil nur dann, wenn das Design Kanäle innerhalb von Kanälen enthält. Andernfalls ist ein flacher Benennungsstil für Rooms kürzer und leichter verständlich.

Für die Benennung der Bauteile liefern die Optionen $Component$ChannelAlpha oder $Component_$ChannelIndex die kürzesten und am leichtesten verständlichen Bauteilbezeichnungen. Mithilfe der verfügbaren Schlüsselwörter können Sie auch ein eigenes Benennungsschema für die Bezeichner erstellen.

Wiederholte Bauteile (und Netze) werden durch Anwendung eines systematischen Benennungsschemas verwaltet, das auf der Registerkarte Multi-Channel des Dialogs Project Options ausgewählt wird.
Wiederholte Bauteile (und Netze) werden durch Anwendung eines systematischen Benennungsschemas verwaltet, das auf der Registerkarte Multi-Channel des Dialogs Project Options ausgewählt wird.

  • Neben den Bauteilen werden mit dem Schema Component Naming auch die Netze innerhalb jedes Kanals eindeutig identifiziert. Dieses Schema wird verwendet, um Netzkennungen, einschließlich Netzlabels und Ports, umzubenennen.
  • Die Anzeige dieser Namen auf dem Schaltplanblatt wird weiter unten im Abschnitt Anzeigen der kompilierten Namen erläutert.

Die Rolle des Rooms

Ein Room ist ein PCB-Designobjekt, mit dem ein Bereich auf der Leiterplatte definiert wird. Dieser kann anschließend auf zwei Arten verwendet werden:

  1. Contain objects – Obwohl ein Room wie ein beliebiges polygonales Objekt platziert wird, wird er tatsächlich als Designregel für die Platzierung erstellt. Zur Definition eines Rooms gehört die Angabe der Objekte, die sich innerhalb dieses Rooms befinden müssen – häufig sind dies Bauteile. Wird der Room verschoben, werden auch alle darin enthaltenen Bauteile verschoben.
  2. To scope other design rules – Rooms sind nicht nur selbst Regeln, sondern können auch dazu verwendet werden, den Gültigkeitsbereich anderer Designregeln festzulegen. Beispielsweise definiert eine Designregel für die Leiterbahnbreite die Breite für eine Netzklasse. Eine Regel mit höherer Priorität und einem Room als Gültigkeitsbereich kann dann innerhalb dieses Rooms eine andere Breite für diese Netzklasse vorgeben.

Rooms eignen sich sehr gut für Mehrkanal-Designs. Sie können bei der Übertragung des Designs vom Schaltplaneditor in den PCB-Editor automatisch erstellt werden. Grundlage dafür sind die Optionen auf der Registerkarte Class Generation des Dialogs Project Options, wobei für jedes Schaltplansymbol ein Room erstellt wird. Der Room gruppiert nicht nur die Bauteile des jeweiligen Kanals, sondern kann auch zur Benennung der darin enthaltenen Bauteile verwendet werden. Rooms und ihre Rolle im Leiterplattenentwurf werden im Abschnitt Mehrkanal-PCB-Design dieses Artikels näher erläutert.

Wenn Sie eine flache Bauteilnummerierung bevorzugen, können Sie das systematische Benennungsschema durch eine Annotation auf Leiterplattenebene ersetzen. Sie wird so bezeichnet, weil die Bauteilbezeichner nur auf das vollständige, kompilierte Design (physisches Design) angewendet werden, aus dem die Leiterplatte entstehen soll.

Konnektivität in einem Mehrkanal-Design

Setzen Sie für ein Mehrkanal-Design die Einstellung Net Identifier Scope auf Automatic, Hierarchical oder Strict Hierarchical. Ein Mehrkanal-Design muss hierarchisch aufgebaut sein, da die Software dieses Strukturmodell verwendet, um die Kanäle beim Kompilieren des Designs im Speicher zu instanziieren.

Bei einem Netz, das mit einem wiederholten Kanal verbunden ist, muss die Software zwei unterschiedliche Konnektivitätsanforderungen unterstützen. Das Netz ist entweder:

  • allen Kanälen gemeinsam oder
  • in jedem Kanal individuell.

In welchem Umfang dies unterstützt wird, hängt davon ab, wie die Kanäle definiert wurden: über mehrere Schaltplansymbole oder über das Schlüsselwort Repeat. Verwendet ein Design mehrere Schaltplansymbole (ein eigenes Schaltplansymbol für jeden Kanal), ist die Netzkonnektivität durch die vom Entwickler eingezeichnete Verdrahtung explizit festgelegt.

Dieses Design verwendet das Schlüsselwort Repeat, um mehrere Kanäle zu erstellen.
Dieses Design verwendet das Schlüsselwort Repeat, um mehrere Kanäle zu erstellen.

Wenn das Design das Schlüsselwort Repeat verwendet, gelten die folgenden Konventionen für die Konnektivität.

Passing a Net to all Channels Wenn ein Netz in allen Kanälen verfügbar sein soll, wird es einfach mit einem Schaltplanblatteintrag verbunden. Dies ist in der obigen Abbildung für das Netz Monitor dargestellt, das mit dem Schaltplansymbol InputChannel.SchDoc verbunden ist. Die Netze Effects, MB1 und MB2 sind ebenfalls in allen Kanälen verfügbar. Netze in einem Bus werden auf die gleiche Weise behandelt: Wird ein Bus mit einem Schaltplanblatteintrag verbunden, steht jedes Element dieses Busses in allen Kanälen zur Verfügung.
Passing a net to a Specific Channel Um jedem Kanal ein einzelnes Netz aus einem Bus zuzuweisen, wird das Schlüsselwort Repeat im Schaltplanblatteintrag verwendet. Dies ist in der obigen Abbildung für den Bus Headphone dargestellt, dessen Schaltplanblatteintrag den Namen Repeat(Headphone) trägt. In diesem Fall wird das Netz Headphone1 mit dem Kanal CIN1 verbunden, Headphone2 mit dem Kanal CIN2 und so weiter. Wenn die Kanäle mit dem Schlüsselwort Repeat erstellt wurden, ist es nicht möglich, ein einzelnes Netz nur an einen bestimmten Kanal zu übergeben. Falls dies erforderlich ist, müssen Sie für jeden Kanal ein eigenes Schaltplansymbol platzieren.
Beachten Sie, dass die Übergabe von Harnesses an Kanäle bei Verwendung des Schlüsselworts Repeat nicht unterstützt wird.

Wie die Netze benannt werden

Letztlich kann jedes Netz auf der Leiterplatte nur einen Namen haben (ein PCB-Netz kann nicht zwei Namen haben). Die Software löst Netze mit mehreren Namen innerhalb eines Projekts automatisch zu einem einzigen Namen auf. Bei einem Mehrkanal-Design ist es wichtig, die Benennungsoptionen so zu konfigurieren, dass Ihre Netze für Sie aussagekräftige Bezeichnungen erhalten. Die Optionen zur Netzbenennung befinden sich im Bereich Netlist Options auf der Registerkarte Options des Dialogs Options for Project.

Eine bewährte Vorgehensweise für diese Einstellungen in einem Mehrkanal-Design besteht darin, die Option Higher Level Names Take Priority zu aktivieren und zusätzlich alle Netze, die mit einem untergeordneten Kanal-Schaltplanblatt verbunden sind, mit Netzlabels zu versehen.

Betrachten Sie als Beispiel die folgenden Abbildungen. Beachten Sie, dass beide Schaltplansymbole auf das Blatt PCB_Decoder.SchDoc verweisen. Es gibt also zwei Kanäle dieser Schaltung, die als U_PCB_DecoderA und U_PCB_DecoderB bezeichnet sind.

Das Schaltplansymbol enthält einen Schaltplanblatteintrag namens TDI, der die Leitung TTest DData IIn in einer JTAG-Boundary-Scan-Kette darstellt. TDO (Test Data Out) von DecoderA ist dann mit dem TDI des nächsten Bausteins in der Kette verbunden, der sich im Kanal DecoderB befindet.

Die beiden Decoder-Kanäle werden erstellt, indem zwei Schaltplansymbole platziert werden, die beide auf denselben Schaltplan, PCB_Decoder.SchDoc, verweisen.
Die beiden Decoder-Kanäle werden erstellt, indem zwei Schaltplansymbole platziert werden, die beide auf denselben Schaltplan, PCB_Decoder.SchDoc, verweisen.

Wenn das Projekt geöffnet wird, erscheinen die Kanalregisterkarten U_PCB_DecoderA und U_PCB_DecoderB am unteren Rand der Schaltplanansicht. Diese Registerkarten zeigen das physische Design so, wie es an den PCB-Editor übergeben wird. In den folgenden Abbildungen ist links auf der Registerkarte Editor der ursprünglich erfasste Schaltplan der Decoderschaltung zu sehen, gefolgt von den beiden physischen Kanälen dieses Schaltplans, U_PCB_DecoderA und U_PCB_DecoderB.

Im ursprünglich erfassten Schaltplan wurde das Netz vom Entwickler mit TDI bezeichnet (erste Abbildung). Beachten Sie, dass die Software auf der Registerkarte DecoderA den übergeordneten Netznamen TDO_CONTROLLER übernommen hat (zweite Abbildung), da es sich um einen Netznamen auf einer höheren Hierarchieebene handelt, dem in diesem Design Vorrang eingeräumt wurde. Für DecoderB ist kein übergeordneter Name definiert. Daher wird der ursprüngliche Netzname TDI in diesem Kanal als TDI_2 bezeichnet (dritte Abbildung). Dies entspricht dem Benennungsschema, das auf der Registerkarte Mehrkanal des Dialogs Project Options festgelegt wurde. Das Schema Component Naming wird verwendet, um sowohl Bauteile als auch Netze innerhalb jedes Kanals zu kennzeichnen.

Der Schaltplan PCB_Decoder.SchDoc: erste Abbildung – der erfasste Schaltplan; zweite und dritte Abbildung – die kompilierte Ansicht der beiden Kanäle.
Der Schaltplan PCB_Decoder.SchDoc: erste Abbildung – der erfasste Schaltplan; zweite und dritte Abbildung – die kompilierte Ansicht der beiden Kanäle.

Anzeigen der kompilierten Namen

Das Verfolgen und Analysieren der Netze in einem Mehrkanaldesign kann verwirrend sein, da sich die Namen ändern müssen, um wiederholte Netze zu kennzeichnen und dabei weiterhin eindeutig zu bleiben. Zur Unterstützung stehen verschiedene Optionen zur Verfügung, mit denen sich die Anzeige kompilierter Objektnamen steuern lässt, darunter Bauteilbezeichner, Netzbezeichnungen, Versorgungsanschlüsse und Ports. Außerdem gibt es Optionen für Blatt- und Dokumentnummern. Diese werden wichtig, wenn Sie Druckausgaben erstellen möchten.

Die Anzeige kompilierter Objektnamen wird auf der Seite Schaltplan – Compiler des Dialogs Preferences konfiguriert, wie in der folgenden Abbildung gezeigt.

Konfigurieren Sie die Anzeige kompilierter Objektnamen. Hochgestellte Angaben sind bei Bauteilbezeichnern hilfreich.
Konfigurieren Sie die Anzeige kompilierter Objektnamen. Hochgestellte Angaben sind bei Bauteilbezeichnern hilfreich.

In der Regel empfiehlt es sich, Bauteilbezeichner und Netzbezeichnungen anzuzeigen. Ports sind bei der Fehlersuche hilfreich. Blattnummern und Dokumentnummern sind ebenfalls wichtig und müssen korrekt konfiguriert werden. Links zu Informationen über die Bauteil- und Blattnummerierung finden Sie im Abschnitt Design-Annotation.

Beachten Sie, dass die Option Net Labels auf der Seite Schematic - Compiler des Dialogs Preferences auch die Expansion von Versorgungsanschlussobjekten bestimmt.

Wenn die Option Display superscript if necessary ausgewählt ist, enthält die aktuelle Dokumentansicht die Objektkennung aus der nicht sichtbaren Ansicht als hochgestellte Angabe. Konfigurieren Sie diese Einstellungen nach Ihren Wünschen.

Die Ansicht für Kanal 2 (CIN2) eines Mehrkanaldesigns. Beachten Sie, dass die Bauteilbezeichner und Netznamen des ursprünglichen logischen Schaltplans hochgestellt angezeigt werden.
Die Ansicht für Kanal 2 (CIN2) eines Mehrkanaldesigns. Beachten Sie, dass die Bauteilbezeichner und Netznamen des ursprünglichen logischen Schaltplans hochgestellt angezeigt werden.

Sie fragen sich, warum einige Schaltplanelemente auf den Kanalregisterkarten (physische Ansicht) abgeblendet sind? Standardmäßig werden Objekte, die auf der Kanalregisterkarte bearbeitet werden können, mit normaler Darstellungsintensität angezeigt, während nicht bearbeitbare Objekte abgeblendet werden. Die Abblendung wird auf der Seite System - Navigation des Dialogs Preferences eingestellt. Der Vorteil der Abblendung besteht darin, dass sie Bearbeitungsversuche verhindert, die nicht unterstützt werden, beispielsweise das Verschieben einer Netzbezeichnung auf einer Kanalregisterkarte. Stellen Sie den Abblendungsgrad nach Bedarf ein.

Beheben von Fehlern durch mehrere Netznamen

Die Fehlerprüfungsoptionen des Schaltplaneditors sind standardmäßig so eingestellt, dass jedes Netz mit mehreren Namen gemeldet wird. Dies kann auftreten, wenn Sie den Namen absichtlich ändern, beispielsweise wenn ein Netz in ein Blattsymbol eintritt und Sie innerhalb dieses Blatts einen anderen Namen verwenden möchten. Die folgende Abbildung zeigt mehrere Beispiele dafür: Die Ausgänge Left und Right werden auf dem obersten Blatt zu einem Bus zusammengefasst, heißen in den Blatteinträgen jedoch Left und Right.

Hier wurde ein Bus verwendet, da sich damit die beiden Ausgangskanäle durch ein einziges Blattsymbol mit dem Schlüsselwort Repeat darstellen lassen. Bei Verwendung separater Leitungen für den linken und rechten Kanal hätte der Entwickler separate Blattsymbole für die linken und rechten Ausgangskanäle platzieren müssen, die beide auf dasselbe untergeordnete Schaltplanblatt verweisen. Anschließend hätte jeder Ausgang mit dem jeweiligen Ausgangsblattsymbol verbunden werden müssen.

Sie müssen der Software vorgeben, wie sie mit mehreren Netzkennungen umgehen soll. Dazu haben Sie folgende Möglichkeiten:

  • Setzen Sie die Fehlerprüfung Nets with multiple names auf der Registerkarte Fehlermeldungen des Dialogs Options for Project auf No Report. Dies ist nicht die bevorzugte Option, da dadurch die Prüfung auf diesen Fehler im gesamten Design deaktiviert wird. Alternativ können Sie:
  • Eine spezifische No-ERC-Anweisung auf den betroffenen Netzen platzieren, indem Sie im Panel Messages mit der rechten Maustaste auf einen Fehler oder eine Warnung klicken und den Befehl Place Specific No ERC Marker for this violation auswählen. Dadurch wechseln Sie in den Platzierungsmodus für NoERC-Objekte. Eine vorkonfigurierte spezifische NoERC-Markierung hängt am Mauszeiger und kann auf dem fehlerhaften Netz platziert werden. Nach dem Platzieren können Sie durch Doppelklicken Stil und Farbe konfigurieren.

Beachten Sie das orange eingekreiste kleine Dreieck. Dabei handelt es sich um eine spezifische No-ERC-Markierung, die platziert wurde, um die Fehlermeldungen zu doppelten Netznamen für die Netze MB1 und MB2 zu deaktivieren.
Beachten Sie das orange eingekreiste kleine Dreieck. Dabei handelt es sich um eine spezifische No-ERC-Markierung, die platziert wurde, um die Fehlermeldungen zu doppelten Netznamen für die Netze MB1 und MB2 zu deaktivieren.

Annotation von Multi-Board-Designs

Ein wesentlicher Bestandteil der Designerfassung ist die Annotation des Designs, also die Vergabe einer eindeutigen Kennung für jedes Bauteil und jedes Schaltplanblatt. In einem Mehrkanaldesign erfolgt dies in zwei Schritten: Zunächst müssen die platzierten Bauteile und die gezeichneten Blätter nummeriert werden. Anschließend müssen auch die Bauteile und Blätter nummeriert werden, die durch die wiederholten Kanäle instanziiert werden.

Wenn Sie eine fortlaufende Bauteilnummerierung bevorzugen, können Sie das systematische Benennungsschema durch eine Annotation auf Leiterplattenebene ersetzen. Sie wird so genannt, weil die Bauteilbezeichner nur auf das vollständige, kompilierte Design (physisches Design) angewendet werden, aus dem die Leiterplatte entstehen soll. Beachten Sie, dass die Schaltplan-Annotation eine Voraussetzung für die Annotation auf Leiterplattenebene ist. Sie stellt sicher, dass mehrteilige Bauteile zu Gehäusen zusammengefasst werden und jedes Bauteil eine eindeutige Kennung erhält.

Diese Annotationen auf Leiterplattenebene werden in einer .Annotation-Datei gespeichert, die jeden logischen Bezeichner dem zugewiesenen physischen Bezeichner zuordnet. Diese Datei ist Teil des Projekts, daher werden Sie aufgefordert, sie zu speichern.

Beachten Sie, dass die Annotation in einem Mehrkanaldesign zu recht langen Bauteilbezeichnern führen kann. Dadurch kann es schwierig werden, die Bezeichnertexte auf der Leiterplatte zu positionieren. Sie können auf der Leiterplatte zwischen der Anzeige logischer und physischer Bezeichner wählen – mehr erfahren.
Um ausgewählten Bauteilen im PCB-Editor systematisch anhand ihrer Position Bezeichner zuzuweisen, können Sie auch die positionsbasierte PCB-Annotation verwenden.

Mehrkanal-PCB-Design

Wenn Sie ein Design vom Schaltplaneditor an den PCB-Editor übertragen, werden die Bauteile jedes Blatts in einem PCB-Platzierungsraum gruppiert, sofern in den Projektoptionen die Erstellung von Räumen aktiviert ist.

Der große Vorteil von Räumen in einem Mehrkanaldesign besteht darin, dass der PCB-Editor das Kopieren der Platzierung und des Routings von einem Raum (Kanal) in die anderen Räume (Kanäle) unterstützt. Räume lassen sich außerdem wie ein einzelnes Objekt verschieben, was die Anordnung der Kanäle auf der Leiterplatte vereinfacht.

Die acht Eingangs- und zwei Ausgangskanäle nach der Übertragung des Designs vom Schaltplaneditor in den PCB-Editor. Die roten Bereiche sind die Räume.
Die acht Eingangs- und zwei Ausgangskanäle nach der Übertragung des Designs vom Schaltplaneditor in den PCB-Editor. Die roten Bereiche sind die Räume.

Die Funktion von Räumen auf der Leiterplatte

Ein Raum ist ein PCB-Designobjekt, mit dem ein Bereich auf der Leiterplatte definiert wird. Dieser kann anschließend auf zwei Arten verwendet werden:

  1. Contain objects - Ein Raum wird zwar wie ein beliebiges polygonales Objekt platziert, tatsächlich aber als Platzierungs-Designregel angelegt. Zur Definition eines Raums gehört die Festlegung der Objekte, die sich innerhalb dieses Raums befinden müssen – häufig sind dies Bauteile. Wird der Raum verschoben, werden auch alle darin enthaltenen Bauteile verschoben.
  2. To scope other design rules - Räume sind nicht nur eigenständige Regeln, sondern können auch den Geltungsbereich anderer Designregeln festlegen. Beispielsweise kann eine Designregel für die Leiterbahnbreite die Breite für eine Netzklasse definieren. Eine höher priorisierte Designregel mit einem Raum als Geltungsbereich kann dann für diese Netzklasse innerhalb dieses Raums eine andere Breite vorgeben.

Räume eignen sich sehr gut für Mehrkanaldesigns. Sie können bei der Übertragung des Designs vom Schaltplaneditor in den PCB-Editor automatisch erstellt werden. Grundlage hierfür sind die Optionen auf der Registerkarte „Class Generation“ des Dialogs Options for Project, wobei für jedes Schaltplansymbol ein Raum angelegt wird. Der Raum fasst nicht nur die Bauteile des jeweiligen Kanals zusammen, sondern kann auch bei der Benennung der darin enthaltenen Bauteile verwendet werden.

Nützliche Befehle zur Bearbeitung von Räumen

  • Design » Rooms - Dieses Untermenü enthält mehrere nützliche Befehle zum Definieren und Bearbeiten von Räumen.
  • Design » Rooms » Copy Room Formats - Mit diesem Befehl kopieren Sie die Platzierung und das Routing eines Raums (Kanals) in die anderen Räume (Kanäle).
  • Design » Rooms » Move Room - Ein Raum lässt sich verschieben, indem Sie an einer Stelle, an der sich kein anderes Designobjekt unter dem Mauszeiger befindet, klicken und die Maustaste gedrückt halten. Der Mauszeiger rastet am nächstgelegenen Bauteilpad oder Eckpunkt des Raums ein, je nachdem, welcher näher liegt. Verwenden Sie diesen Befehl, wenn Sie nicht klicken und die Maustaste gedrückt halten können, ohne dabei ein Designobjekt anzuklicken.
  • Edit » Select » Room Connections - Mit diesem Befehl wählen Sie alle Kupfersegmente aus, die an einem Pad beginnen und innerhalb des Raums enden.

Bauteilbezeichnungen auf der Leiterplatte anzeigen

In einem Mehrkanaldesign kann es schwierig sein, die Bauteilbezeichnungen zu positionieren, da diese recht lang sein können. Neben der Wahl einer Benennungsoption, die kurze Namen erzeugt, besteht eine weitere Möglichkeit darin, nur die ursprüngliche logische Bauteilbezeichnung anzuzeigen. Beispielsweise würde C30_CIN1 als C30 angezeigt. Dafür müsste die Leiterplatte um eine andere Kennzeichnung ergänzt werden, die die einzelnen Kanäle unterscheidet, etwa durch einen Rahmen um jeden Kanal auf dem Bestückungsdruck.

Im Abschnitt Other des Panels „Properties“ im PCB-Editor (View » Panels » Properties) können Sie zwischen der Anzeige logischer und physischer Bauteilbezeichnungen wählen. Wenn Sie bei Bauteilen in einem Mehrkanaldesign die logischen Bezeichnungen anzeigen lassen, erscheinen diese auf der Leiterplatte und in allen erzeugten Ausgaben, beispielsweise in Ausdrucken und Gerber-Dateien. Beim Erstellen einer Stückliste werden hingegen immer die eindeutigen physischen Bauteilbezeichnungen verwendet.

► Erfahren Sie mehr über das Annotieren der Bauteile

Parametrisches hierarchisches Mehrkanaldesign

Die Herausforderung bei der Wiederverwendung eines Designabschnitts – beispielsweise durch das Verknüpfen eines Schaltplansymbols im aktuellen Projekt mit dem bevorzugten Stromversorgungsschaltplan Ihres Unternehmens – besteht darin, dass die Bauteilwerte nicht in jedem Design gleich sind.

Parametrisches hierarchisches Design löst dieses Problem: Es ermöglicht Ihnen, die Festlegung der Bauteilwerte vom Schaltplanblatt in das Schaltplansymbol zu verlagern, das auf dieses Blatt verweist. Diese Funktion lässt sich auch nahtlos mit Mehrkanaldesigns kombinieren, sodass Sie in jedem Kanal unterschiedliche Bauteilwerte verwenden können. Beachten Sie, dass dafür jeder Kanal ein eigenes Schaltplansymbol benötigt, da dort die Bauteilwerte gespeichert werden.

Beispielsweise kann ein grafischer Equalizer aus vielfach wiederholten identischen Schaltungen bestehen, bei denen sich die einzelnen Kanäle nur durch die Bauteilwerte unterscheiden. So könnte ein Kondensator in den verschiedenen Kanälen die Werte 0.12µF, 0.056µF und 0.033µF haben. Die Umsetzung ist einfach, da Sie diese Werte im Schaltplansymbol angeben, das auf den jeweiligen Kanal verweist. Dadurch sind nicht mehr zahlreiche ähnliche Schaltpläne erforderlich, die sich lediglich in den Bauteilwerten unterscheiden.

Parametrische Bauteile werden definiert, indem ihr Wert als Parameter des übergeordneten Schaltplansymbols deklariert und dieser Parameter anschließend im betreffenden Bauteil referenziert wird. Die folgende Abbildung zeigt links das oberste Blatt eines grafischen Equalizers und daneben die Parameter des 1-kHz-Schaltplansymbols. Außerdem sind der erstellte Schaltplan der untergeordneten Ebene und der kompilierte 1-kHz-Kanal zu sehen, die über die unteren Registerkarten ausgewählt wurden.

Ein grafischer Equalizer mit unterschiedlichen Kondensator- und Widerstandswerten in jedem Kanal. Die tatsächlichen Bauteilwerte werden in den Schaltplansymbolen definiert, sodass nur ein einziger untergeordneter Schaltplan erstellt werden muss.
Ein grafischer Equalizer mit unterschiedlichen Kondensator- und Widerstandswerten in jedem Kanal. Die tatsächlichen Bauteilwerte werden in den Schaltplansymbolen definiert, sodass nur ein einziger untergeordneter Schaltplan erstellt werden muss.

Jeder dieser Schaltplansymbolparameter wird außerdem als value eines Parameters in einem Schaltplanbauteil auf einem untergeordneten Blatt definiert, wie in der folgenden Abbildung dargestellt. Der Wert jedes Schaltplansymbolparameters wird an das zugehörige Schaltplanbauteil übergeben und dort dem Feld „Comment“ des Bauteils zugeordnet. Beachten Sie: Wenn zur Anzeige des Werts eines Schaltplanbauteils direkt ein „Value“-Parameter anstelle des „Comment“-Parameters verwendet wird, müssen Sie lediglich den Schaltplansymbolparameter dem „Value“-Parameter des Bauteils zuordnen (Value=C2_Value) und diesen sichtbar machen.

Da der Parameter Value  den Wert =C2_Value hat, weiß der Compiler, dass er in einem übergeordneten Schaltplansymbol nach dem tatsächlichen Bauteilwert suchen muss.
Da der Parameter Value den Wert =C2_Value hat, weiß der Compiler, dass er in einem übergeordneten Schaltplansymbol nach dem tatsächlichen Bauteilwert suchen muss.

Die parametrische Hierarchie ist nicht auf Bauteilwerte beschränkt. Sie können jeden Bauteilparameter sowie andere Objekttextbeschriftungen auf dem Schaltplanblatt parametrisch referenzieren. Ausgenommen sind grundlegende Verbindungselemente wie Bauteilkennungen, Port-Objekte und Dokumentdateinamen. Wenn Sie auf Parameter eines Symbols verweisen, das sich in der Hierarchie mehrere Blätter weiter oben befindet, durchsucht das System die Hierarchie, bis es den passenden Parameter findet.

AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents