Trabajar con exclusiones específicas de objetos en una placa
De un vistazo
- Comprende qué son las zonas de exclusión específicas por objeto, cómo se comportan en Altium Designer y dónde conviene utilizarlas en el diseño de PCB.
- Aprende a configurar las zonas de exclusión para restringir únicamente determinados tipos de objetos, lo que te ofrece un control más flexible sobre el enrutado, la colocación de cobre y el comportamiento de las vías.
- Conoce los aspectos básicos de la colocación y edición de objetos de exclusión, incluidas las pistas y los arcos de exclusión, en los editores de PCB y de bibliotecas de PCB.
Una Keepout en el diseño de PCB es un área o perímetro definido por el usuario en el trazado que los objetos de cobre no pueden intersectar. Normalmente se incluye para controlar el área utilizada por las acciones automatizadas de colocación de cobre, como los vertidos de polígonos y el enrutamiento interactivo. Una zona de exclusión también representa una ubicación no válida al colocar objetos de cobre manualmente.
Como áreas prohibidas especificadas durante el trazado del diseño, los objetos de exclusión utilizan las reglas de restricción de separación existentes para controlar el enrutamiento y detectar infracciones de colocación, pero, a diferencia de otros objetos colocados, no se pueden asignar a una red ni aparecen en las salidas generadas o en las impresiones. En su forma más sencilla, una zona de exclusión actúa como un objeto de «interferencia» que impide que otros objetos de cobre intersecten su área, según lo especificado por la regla global de separación. Los objetos de exclusión se pueden colocar en la capa de exclusión (donde se aplican a todas las capas de señal) o en una capa de señal (donde solo se aplican a los objetos de esa capa).
Altium Designer permite crear y aplicar zonas de exclusión gracias a su compatibilidad con Object Specific Keepouts. Los objetos de exclusión colocados se pueden configurar para especificar a qué tipos de objetos se aplican, como pistas, áreas de cobre, vías y pads, lo que mejora significativamente la flexibilidad y la eficacia de las zonas de exclusión.

Objetos de exclusión de distintos tipos colocados en un diseño de PCB.
En el editor de PCB y en el editor de bibliotecas de PCB, los objetos de exclusión se muestran con un tramado cruzado. Los objetos de exclusión colocados en la capa de exclusión (es decir, que se aplican a todas las capas de señal) se muestran con el color de la capa de exclusión, mientras que las zonas de exclusión colocadas en una capa de señal específica (es decir, que se aplican únicamente a esa capa de señal) aparecen con el color de dicha capa.
Las zonas de exclusión son ideales para definir regiones de la placa en las que no se puede enrutar (como áreas eléctricamente sensibles o de alta tensión), ubicaciones específicas de cobre expuesto, como marcas fiduciales y puntos de prueba, o áreas mecánicamente incompatibles (como orificios de montaje o las esquinas de una PCB). La naturaleza configurable de las zonas de exclusión específicas para objetos también permite colocarlas sobre otros objetos cuando se han asignado Keepout Restrictions específicos. Cuando se configura para restringir únicamente las vías, por ejemplo, se puede colocar una zona de exclusión sobre regiones de cobre existentes (como un vertido de polígono) para controlar la extensión de la costura de vías automatizada.
Las zonas de exclusión específicas para objetos se pueden colocar en el editor de PCB y en el editor de bibliotecas de PCB.
Para obtener más información sobre la colocación y edición de objetos de exclusión de PCB, consulte las secciones desplegables siguientes:
Exclusión de pista

Una exclusión de pista colocada
Una pista es un objeto de diseño primitivo. Además de la pista estándar que se utiliza para las tareas de diseño, hay un segundo tipo de pista disponible, denominado pista de exclusión. Una pista de exclusión se puede colocar como objeto de exclusión específico de una capa o como exclusión para todas las capas para actuar, por ejemplo, como barrera de colocación o enrutamiento. La diferencia entre una pista estándar y una pista de exclusión es que los rellenos de tipo exclusión específicos de una capa no se incluyen en la generación de salidas, como Gerber u ODB++. Una región de exclusión se identifica por tener un contorno con el color de exclusión.
Tras iniciar el comando de colocación de pistas de exclusión, el cursor cambiará a una cruz y se activará el modo de colocación de pistas de exclusión. La colocación se realiza mediante la siguiente secuencia de acciones:
- Haga clic o pulse Enter para fijar el punto inicial del primer segmento de pista de exclusión.
- Mueva el cursor para definir el segmento de pista de exclusión y, a continuación, haga clic o pulse Enter para fijar el punto final de este primer segmento, que también es el punto inicial del siguiente segmento conectado.
- Siga posicionando el cursor y, a continuación, haga clic o pulse Enter para fijar una serie de vértices que definan la serie de segmentos de pista de exclusión conectados.
- Haga clic con el botón derecho o pulse Esc para finalizar la serie actual de segmentos de pista de exclusión conectados.
Durante la colocación, también se pueden realizar las siguientes acciones:
- Pulse la tecla * del teclado numérico para recorrer las capas de señal disponibles. También puede utilizar la combinación Shift+Ctrl+Wheel Roll para desplazarse por las capas de enrutamiento; cada paso de la rueda del ratón cambiará a la siguiente (o anterior) capa de señal disponible.
- Pulse las teclas + y - del teclado numérico para recorrer hacia delante y hacia atrás todas las capas actualmente visibles en el diseño.
Al colocar segmentos de pista de exclusión, hay cinco modos de esquina disponibles, cuatro de los cuales también tienen submodos de dirección de esquina. Durante la colocación:
- Pulse Shift+Spacebar para recorrer los cinco modos de esquina disponibles.
- Pulse Spacebar para alternar entre los dos submodos de dirección de esquina.
- En cualquiera de los modos de esquina con arco, mantenga pulsadas las teclas , o . para reducir o ampliar el arco. Mantenga pulsada la tecla Shift al hacerlo para acelerar el cambio de tamaño del arco.
- Pulse la tecla de acceso directo 1 para alternar entre colocar un segmento por clic o dos segmentos por clic. En el primer modo, el segmento de pista sin relleno se denomina segmento de anticipación.
- Pulse la tecla Backspace para eliminar el último vértice.
El método de edición gráfica permite seleccionar un objeto de pista de exclusión colocado directamente en el espacio de diseño y cambiar gráficamente su tamaño, forma o ubicación.
Cuando se selecciona una pista de exclusión, están disponibles los siguientes controles de edición:
- Haga clic en los controles de los extremos para reposicionar los puntos finales de la pista.
- Haga clic y arrastre el control central para cambiar la forma de la pista.
Propiedades de la exclusión de pista

El modo Keepout - Track del panel Properties.
Ubicación
-
(X/Y)
- X (primer campo): la coordenada X (horizontal) actual del punto de referencia de la pista de exclusión con respecto al origen actual. Edítela para cambiar la posición X de la pista de exclusión. El valor se puede introducir en unidades métricas o imperiales; incluya las unidades cuando introduzca un valor cuyas unidades no sean las predeterminadas actuales.
- Y (segundo campo): la coordenada Y (vertical) actual del punto de referencia de la pista de exclusión con respecto al origen actual. Edítela para cambiar la posición Y de la pista de exclusión. El valor se puede introducir en unidades métricas o imperiales; incluya las unidades cuando introduzca un valor cuyas unidades no sean las predeterminadas actuales.
Propiedades
- Component: este campo se muestra en el editor de PCB solo cuando la pista de exclusión seleccionada forma parte de un componente de PCB y muestra el designador del componente de PCB al que pertenece. Seleccione el elemento en el que se puede hacer clic Component enlace para abrir el modo Componente del panel Propiedades del componente principal.
- Restricted for Layer - utilice la lista desplegable para seleccionar la capa restringida.
- Width - muestra el ancho actual de la pista de exclusión. Edite este campo para cambiar el ancho de la pista de exclusión dentro del intervalo de 0.001mil a 10000mil.
- Start (X/Y) - muestra la coordenada X/Y actual del punto inicial de la pista de exclusión con respecto al origen actual.
- End (X/Y) - muestra la coordenada X/Y actual del punto final de la pista de exclusión, con respecto al origen actual.
- Length - muestra la longitud actual de la pista de exclusión. Edite este campo para cambiar la longitud de la pista de exclusión dentro del intervalo de 0.001mil a 10000mil.
Restricciones de exclusión
Utilice esta sección para seleccionar qué tipos de objetos estarán restringidos por la zona de exclusión. Al desmarcar un tipo de objeto, la zona de exclusión permitirá que los objetos de ese tipo la invadan (no se excluirán) al no aplicar la regla de separación correspondiente. Las opciones incluyen:
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Arco de exclusión

Dos arcos de exclusión en la capa inferior: a la izquierda, un arco de exclusión de círculo completo; a la derecha, un arco de exclusión seleccionado para su edición.
Un arco de exclusión es un objeto de diseño primitivo. Es, en esencia, un segmento de pista circular que se puede colocar en cualquier capa. Además del arco estándar, que se utiliza para tareas de diseño como definir el contorno de un componente o trazar rutas curvas, existe un segundo tipo de arco, denominado arco de exclusión. Un arco de exclusión se puede colocar en una capa de señal para crear una barrera o una zona prohibida específica de esa capa. También se puede colocar en la capa Keepout, donde se aplicará a todas las capas de señal. La diferencia entre un arco estándar y un arco de exclusión es que los arcos de exclusión específicos de una capa no se incluyen en la generación de archivos de salida, como Gerber u ODB++. Un arco de exclusión se identifica por tener un contorno del color de Keepout.
La forma de colocar un arco depende del método de colocación que haya elegido activar. Se admiten cuatro métodos distintos de colocación de arcos:
- Place arc by center – este método permite colocar un objeto de arco utilizando el centro del arco como punto inicial.
- Place arc by edge – este método permite colocar un objeto de arco utilizando el extremo del arco como punto inicial. El ángulo del arco está fijado en 90°.
- Place arc by edge (any angle) – este método permite colocar un objeto de arco utilizando el extremo del arco como punto inicial. El ángulo del arco puede tener cualquier valor.
- Place full circle arc – este método permite colocar un arco de 360° (círculo completo).
Placing a Keepout Arc Starting at the Center
Tras ejecutar el comando, el cursor adoptará la forma de una cruz y se activará el modo de colocación de arcos de exclusión. La colocación se realiza mediante la siguiente secuencia de acciones:
- Haga clic o pulse Enter para fijar el punto central del arco de exclusión.
- Mueva el cursor para ajustar el radio del arco de exclusión y, a continuación, haga clic o pulse Enter para establecerlo.
- Mueva el cursor para ajustar el punto inicial del arco de exclusión y, a continuación, haga clic o pulse Enter para fijarlo.
- Mueva el cursor para cambiar la posición del punto final del arco de exclusión y, a continuación, haga clic o pulse Enter para fijarlo y completar la colocación del arco de exclusión.
- Continúe colocando más arcos de exclusión o haga clic con el botón derecho o pulse Esc para salir del modo de colocación.
Placing a Keepout Arc Starting at the Edge
Tras ejecutar el comando, el cursor adoptará la forma de una cruz y se activará el modo de colocación de arcos de exclusión. La colocación se realiza mediante la siguiente secuencia de acciones:
- Haga clic o pulse Enter para fijar el punto inicial del arco de exclusión.
- Mueva el cursor para cambiar la posición del punto final del arco de exclusión y, a continuación, haga clic o pulse Enter para fijarlo y completar la colocación del arco de exclusión.
- Continúe colocando más arcos de exclusión o haga clic con el botón derecho o pulse Esc para salir del modo de colocación.
Placing a Keepout Arc Starting at the Edge (any angle)
Tras ejecutar el comando, el cursor adoptará la forma de una cruz y se activará el modo de colocación de arcos de exclusión. La colocación se realiza mediante la siguiente secuencia de acciones:
- Haga clic o pulse Enter para fijar el punto inicial del arco de exclusión.
- Mueva el cursor para ajustar el radio del arco de exclusión y, a continuación, haga clic o pulse Enter para fijar el punto central.
- Mueva el cursor para cambiar la posición del punto final del arco de exclusión y, a continuación, haga clic o pulse Enter para fijarlo y completar la colocación del arco de exclusión.
- Continúe colocando más arcos de exclusión o haga clic con el botón derecho o pulse Esc para salir del modo de colocación.
Placing a Full Circle Keepout Arc
Tras ejecutar el comando, el cursor adoptará la forma de una cruz y se activará el modo de colocación de arcos de exclusión. La colocación se realiza mediante la siguiente secuencia de acciones:
- Haga clic o pulse Enter para fijar el punto central del arco de exclusión.
- Mueva el cursor para ajustar el radio del arco de exclusión y, a continuación, haga clic o pulse Enter para establecerlo y completar la colocación del arco de exclusión.
- Continúe colocando más arcos de exclusión o haga clic con el botón derecho o pulse Esc para salir del modo de colocación.
En todos los métodos (excepto en los arcos de círculo completo), pulse Spacebar antes de definir el punto final del arco de exclusión para trazar el arco en sentido contrario.
El método de edición gráfica permite seleccionar un objeto de arco colocado directamente en el espacio de diseño y cambiar gráficamente su tamaño, forma o ubicación.
Al seleccionar un objeto de arco de exclusión, están disponibles los siguientes controles de edición:

Un arco de exclusión seleccionado
- Haga clic y arrastre A para ajustar el radio.
- Haga clic y arrastre B para ajustar los extremos (ángulos inicial y final).
-
Haga clic en cualquier punto del arco alejado de los controles de edición y, a continuación, arrastre para cambiarlo de posición. También puede hacer clic y arrastrar el punto central del arco. Mientras lo arrastra, puede girar el arco o reflejarlo:
- Pulse Spacebar para girar el arco en sentido antihorario o Shift+Spacebar para girarlo en sentido horario. La rotación se realiza de acuerdo con el valor de Rotation Step definido en la página PCB Editor – General del cuadro de diálogo Preferences.
- Pulse las teclas X o Y para reflejar el arco respecto al eje X o al eje Y, respectivamente.
Propiedades del arco de exclusión

El modo Keepout - Arc del panel Properties.
Ubicación
-
(X/Y)
- X (primer campo): la coordenada X (horizontal) actual del punto de referencia del arco de exclusión, con respecto al origen actual del espacio de diseño. Edítela para cambiar la posición X del arco de exclusión. El valor se puede introducir en unidades métricas o imperiales; incluya las unidades cuando introduzca un valor cuyas unidades no sean las predeterminadas actuales.
- Y (segundo campo): la coordenada Y (vertical) actual del punto de referencia del arco de exclusión, con respecto al origen actual. Edítela para cambiar la posición Y del arco de exclusión. El valor se puede introducir en unidades métricas o imperiales; incluya las unidades cuando introduzca un valor cuyas unidades no sean las predeterminadas actuales.
Propiedades
- Component: este campo se muestra en el editor de PCB solo cuando el arco de exclusión seleccionado forma parte de un componente de PCB y muestra el designador del componente de PCB al que pertenece. Seleccione el enlace Component para abrir el modo Component del panel Properties para el componente al que pertenece.
- Restricted Layer : este campo muestra la capa de restricción a la que está asignado actualmente el arco de exclusión. Para cambiar la capa, haga clic en el campo y seleccione una capa de la lista desplegable.
- Width : este campo muestra el ancho de la línea del arco de exclusión. Introduzca un valor diferente para el ancho si es necesario.
- Radius : este campo muestra el radio del arco, medido desde el punto central hasta el centro de la línea del arco de exclusión. Introduzca un valor diferente para el radio si es necesario.
- Start Angle : este campo muestra el ángulo inicial del arco de exclusión, medido desde el eje X en el primer cuadrante (geometría plana). Introduzca un valor diferente para el ángulo inicial si es necesario.
- End Angle : este campo muestra el ángulo final del arco de exclusión. Introduzca un valor diferente para el ángulo final si es necesario.
Restricciones de exclusión
Utilice esta sección para seleccionar los tipos de objetos a los que se aplicará la exclusión. Al desmarcar un tipo de objeto, se permitirá que los objetos de ese tipo invadan la zona de exclusión (no quedarán excluidos) al no aplicarse la regla de separación correspondiente. Las opciones incluyen:
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Región de exclusión

Una región de exclusión
Una región de exclusión es un objeto de diseño primitivo. Además de la región estándar utilizada para las tareas de diseño, existe un segundo tipo de región, denominado región de exclusión. Una región de exclusión se puede colocar como un objeto de exclusión específico de una capa o como una exclusión para todas las capas, para actuar, por ejemplo, como una barrera para la colocación o el enrutamiento. La diferencia entre una región estándar y una región de exclusión es que los rellenos de tipo exclusión específicos de una capa no se incluyen en la generación de archivos de salida, como Gerber u ODB++. Una región de exclusión se identifica por tener un contorno del color de exclusión.
Tras iniciar el comando de colocación de regiones de exclusión (Place » Keepout » Solid Region), el cursor cambiará a una cruz y se activará el modo de colocación de regiones de exclusión. La colocación se realiza mediante la siguiente secuencia de acciones:
- Sitúe el cursor y haga clic para fijar el vértice inicial de la región de exclusión.
- Mueva el cursor para colocar el segundo vértice. El comportamiento predeterminado consiste en colocar dos bordes con cada clic, con una forma de esquina definida por el usuario entre ellos.
- Siga moviendo el ratón y haciendo clic para colocar más vértices.
- Después de colocar el último vértice, haga clic con el botón derecho o pulse Esc para cerrar y completar la colocación de la región de exclusión. No es necesario cerrar manualmente la región, ya que el software completará automáticamente la forma conectando el punto inicial con el último punto colocado.
- Continúe colocando más regiones de exclusión o haga clic con el botón derecho o pulse Esc para salir del modo de colocación.
El método de edición gráfica permite seleccionar un objeto colocado directamente en el espacio de diseño y cambiar gráficamente su tamaño, forma o ubicación.

Una región de exclusión seleccionada
Move Region Vertices
Las regiones de exclusión contienen dos tipos de puntos, o «tiradores», con los que se puede editar la forma de la región.
- Full Handles : situados en las esquinas de la región de exclusión.
- Empty Handles : situados en el centro de los segmentos creados por los tiradores rellenos.
Se puede modificar la forma de una región de exclusión existente moviendo estos tiradores, o vértices, situados en cada esquina o en el centro de cada borde.
Para modificar la forma de la región de exclusión:
-
Haga clic y seleccione una región de exclusión; esto resaltará sus vértices y cambiará el cursor a una cruz.
- Click sobre un tirador relleno para mover esa esquina.
- Click a lo largo de un borde para mover el borde completo.
- Click sobre un tirador vacío para mover todo el lado (tanto para pistas como para arcos).
- Ctrl+Click sobre un tirador vacío para dividir ese borde en dos. Ctrl solo debe mantenerse pulsado al inicio del movimiento. Después se pueden utilizar los atajos de teclado Shift+Spacebar para alternar entre los modos (arco, inglete y cualquier ángulo).
- Si el modo de colocación «cualquier ángulo» crea vértices no deseados, o para eliminar vértices adicionales en general, haga clic en Ctrl y arrastre el tirador relleno central. Aparecerá un icono de X sobre el tirador y, al arrastrar el borde, los vértices de ese borde se reducirán a uno.
Modify Region Border
Además de editar los vértices, también puede utilizar el comando Modify Region Border para cambiar fácilmente la forma de los polígonos. El comando se ejecuta haciendo clic con el botón derecho en el polígono deseado y seleccionando Polygon Actions » Modify Polygon Border. Una vez iniciado el comando, el cursor se convierte en una cruz. Cada vez que haga clic, se añadirá un nuevo vértice. Al igual que durante la colocación de regiones de exclusión, se pueden utilizar los atajos Shift+Spacebar para cambiar las formas de las esquinas.
Propiedades de la región de exclusión

El modo Keepout - Region del panel Properties.
Propiedades
- Component – este campo se muestra en el editor de PCB solo cuando la región de exclusión seleccionada forma parte de un componente de PCB y muestra el designador del componente de PCB al que pertenece. Seleccione el enlace Component para abrir el modo Componente del panel Propiedades correspondiente al componente al que pertenece.
- Restricted for Layer - utilice la lista desplegable para seleccionar la capa en la que se encuentra la región de exclusión.
- Arc Approximation - introduzca la desviación máxima respecto a un arco perfecto.
- Area - el área total del objeto colocado.
- Locked (solo en el panel Properties) - active esta opción para bloquear la región de exclusión.
Vértices del contorno
Esta sección se utiliza para modificar los vértices individuales del objeto de región seleccionado actualmente. Puede modificar las ubicaciones de los vértices existentes, añadir nuevos vértices o eliminarlos según sea necesario. Se pueden definir conexiones mediante arcos entre los vértices, y también se permite exportar la información de los vértices a un archivo en formato CSV e importarla desde él.
-
Vertices Grid - enumera todos los vértices definidos actualmente para la región en términos de:
- Index - el índice asignado al vértice (no editable).
- X - la coordenada X (horizontal) del vértice. Haga clic para editarla.
- Y - la coordenada Y (vertical) del vértice. Haga clic para editarla.
- Arc Angle (Neg = CW) - el ángulo del arco que se dibuja para conectar este vértice con el siguiente. De forma predeterminada, las conexiones son segmentos rectos y este campo permanece vacío. Haga clic para editarlo y, a continuación, introduzca el ángulo de arco que necesite. Si introduce un valor positivo, el arco se dibujará en sentido antihorario. Para dibujar un arco en sentido horario, introduzca un valor negativo.
-
Add - haga clic para añadir un nuevo vértice. El nuevo vértice se añadirá debajo de la entrada de vértice que tenga el foco y, al principio, tendrá las mismas coordenadas X,Y que dicha entrada. Haga clic en
para eliminar el vértice seleccionado actualmente.
Restricciones de exclusión
Utilice esta sección para seleccionar los tipos de objetos que quedarán restringidos por la zona de exclusión. Al desmarcar un tipo de objeto, la zona de exclusión permitirá que los objetos de ese tipo la invadan (no quedarán excluidos) al no aplicar la regla de separación correspondiente. Las opciones incluyen:
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Relleno de exclusión
Un relleno de exclusión es un objeto de diseño primitivo que se puede colocar en cualquier capa. Además del relleno estándar que se utiliza para tareas de diseño como definir el contorno de un componente, existe un segundo tipo de relleno denominado relleno de exclusión. Un relleno de exclusión se puede colocar como un objeto de exclusión específico de una capa o como una zona de exclusión para todas las capas, para actuar, por ejemplo, como barrera para la colocación o el enrutamiento. La diferencia entre un relleno estándar y uno de exclusión es que los rellenos de tipo exclusión específicos de una capa no se incluyen en la generación de archivos de salida, como Gerber u ODB++. Un relleno de exclusión se identifica por tener un contorno del color de las zonas de exclusión.
Tras ejecutar el comando de colocación de rellenos de exclusión, el cursor cambiará a una cruz y se activará el modo de colocación de rellenos de exclusión. Para colocar un relleno, realice la siguiente secuencia de acciones:
- Haga clic o pulse Enter para fijar la primera esquina del relleno de exclusión.
- Mueva el cursor para ajustar el tamaño del relleno de exclusión y, a continuación, haga clic o pulse Enter para fijar la esquina diagonalmente opuesta y completar la colocación del relleno de exclusión.
- Continúe colocando más rellenos de exclusión o haga clic con el botón derecho o pulse Esc para salir del modo de colocación.
El método de edición gráfica permite seleccionar un objeto colocado directamente en el espacio de diseño y cambiar gráficamente su tamaño, forma o ubicación.
Al seleccionar un objeto de relleno de exclusión, están disponibles los siguientes controles de edición:

Un relleno de exclusión seleccionado
- Haga clic, mantenga pulsado y arrastre los controles de las esquinas para cambiar el tamaño del relleno de exclusión en las direcciones vertical y horizontal simultáneamente.
- Haga clic, mantenga pulsado y arrastre los controles laterales, superior e inferior para cambiar el tamaño del relleno de exclusión en las direcciones vertical y horizontal por separado.
- Haga clic, mantenga pulsado y arrastre el control central para girar el relleno de exclusión alrededor de su punto central.
-
Haga clic en cualquier punto del relleno de exclusión alejado de los controles de edición y, a continuación, mantenga pulsado y arrastre para cambiarlo de posición. Mientras lo arrastra, puede girar el relleno de exclusión o reflejarlo:
- Pulse Spacebar para girar el relleno de exclusión en sentido antihorario o Shift+Spacebar para girarlo en sentido horario. El giro se realiza de acuerdo con el valor de Rotation Step definido en la página Editor de PCB – General del cuadro de diálogo Preferences.
- Pulse las teclas X o Y para reflejar el relleno de exclusión con respecto al eje X o al eje Y.
Propiedades del relleno de exclusión

El modo Keepout - Fill del panel Properties.
Ubicación
-
(X/Y)
- X (primer campo) - la coordenada X (horizontal) actual del punto de referencia del relleno de exclusión, con respecto al origen actual del espacio de diseño. Edítela para cambiar la posición X del relleno de exclusión. El valor se puede introducir en unidades métricas o imperiales; incluya las unidades al introducir un valor cuyas unidades no sean las predeterminadas actualmente.
- Y (segundo campo) - la coordenada Y (vertical) actual del punto de referencia del relleno de exclusión, con respecto al origen actual. Edítela para cambiar la posición Y del relleno de exclusión. El valor se puede introducir en unidades métricas o imperiales; incluya las unidades al introducir un valor cuyas unidades no sean las predeterminadas actualmente.
- Rotation - el ángulo de rotación del relleno de exclusión (en grados), medido en sentido antihorario desde cero (la horizontal 3 o'clock). Edítelo para cambiar la rotación del relleno de exclusión. La resolución angular mínima es de 0,001°.
Propiedades
- Component – este campo se muestra en el editor de PCB solo cuando el relleno de exclusión seleccionado forma parte de un componente de PCB y muestra el designador del componente de PCB al que pertenece. Seleccione el enlace Component para abrir el modo Componente del panel Propiedades correspondiente al componente al que pertenece.
- Restricted for Layer - utilice el menú desplegable para seleccionar la capa restringida.
- Area - indica el área del objeto colocado.
- Length - muestra la longitud actual del relleno de exclusión. Edite este campo para cambiar la longitud dentro del intervalo de 0.001mil a 10000mil.
- Width - muestra el ancho actual del relleno de exclusión. Edite este campo para cambiar el ancho dentro del intervalo de 0.001mil a 10000mil.
Restricciones de exclusión
Utilice esta sección para seleccionar los tipos de objetos que quedarán restringidos por la zona de exclusión. Al desmarcar un tipo de objeto, la zona de exclusión permitirá que los objetos de ese tipo invadan su área (no quedarán excluidos) al no aplicarles la regla de separación correspondiente. Las opciones incluyen:
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Colocación de zonas de exclusión
Las zonas de exclusión se colocan en el espacio de diseño del editor desde el menú Place » Keepout; el tipo de zona de exclusión seleccionado (pista, relleno, región o arco) se colocará en la capa activa. Seleccione las propiedades de la zona de exclusión para editar sus características físicas, su capa o sus restricciones por tipo de objeto. Las propiedades de Keepout relacionadas son:
- Restricted for Layer – establece la capa de la zona de exclusión y, por tanto, la capa de la placa en la que se restringirán los objetos de cobre (quedarán excluidos). Para una zona de exclusión en todas las capas, seleccione Keep-Out Layer.
- Keepout Restrictions – determina los tipos de objetos que quedarán restringidos por la zona de exclusión. Al desmarcar un tipo de objeto, la zona de exclusión permitirá que los objetos de ese tipo invadan su área (no quedarán excluidos), al no aplicarles la regla de separación correspondiente.
En la imagen siguiente, los dos rellenos de exclusión tienen distintas restricciones de capa y de objetos. Estas permiten que el relleno de exclusión de la capa superior (a la izquierda) admita un pad de orificio pasante (TH), mientras restringe todos los demás tipos de objetos, y que el de la capa de exclusión (a la derecha) admita únicamente pistas.

Ejemplo de dos rellenos de exclusión colocados en distintas capas de una PCB y configurados para restringir la colocación de diferentes tipos de objetos.
La flexibilidad inherente de las zonas de exclusión permite utilizarlas en una amplia variedad de tareas para controlar el diseño de las PCB. Como las zonas de exclusión pueden superponerse, asignarse a cualquier capa de señal (como la superior o la inferior) y configurarse para rechazar objetos específicos, pueden utilizarse para controlar con precisión el cosido de vías y los rellenos poligonales, por ejemplo.
Control de rellenos poligonales
En el ejemplo de diseño de PCB que se muestra a continuación, se han añadido rellenos de exclusión alrededor de los pads multicapa en una región donde puede haber alta tensión, que necesita un aislamiento eléctrico suficiente respecto a los rellenos poligonales conectados a tierra que se añadirán posteriormente. Los rellenos de exclusión se asignan a la capa superior y se configuran para restringir únicamente los objetos de cobre, lo que impedirá la presencia de rellenos poligonales, rellenos y regiones, pero permitirá las pistas y los pads existentes, etc. En otras palabras, la regla de infracción de separación solo se aplicará a los objetos clasificados como «cobre».

Rellenos de exclusión colocados en la capa de exclusión y configurados para aplicarse únicamente a objetos de cobre.
La disposición de zonas de exclusión anterior obligará a los rellenos poligonales colocados en las capas de señal (en este caso, las capas superior e inferior) a evitar las tres áreas de exclusión. Sin embargo, el pads de la capa superior asociado al área en cuestión no tendrá una separación adecuada respecto al relleno de la capa superior.
En este caso, pueden añadirse más zonas de exclusión a la capa superior para que su relleno poligonal mantenga una distancia adecuada respecto a todos los pads relacionados. En la imagen siguiente, se han añadido otros dos rellenos de exclusión a la capa superior, que aquí se muestra en modo de una sola capa para mayor claridad. Tenga en cuenta que la cobertura de exclusión mostrada podría haberse creado con una única región, en lugar de dos rellenos superpuestos.

Rellenos de exclusión colocados en la capa superior y configurados para aplicarse únicamente a objetos de cobre.
Cuando finalmente se añadan los rellenos poligonales al diseño, el conjunto de zonas de exclusión controlará los rellenos para generar un contorno de separación distinto en cada capa alrededor de la región. Observe que, en este ejemplo, la separación asociada a las zonas de exclusión es mayor que la de los objetos normales debido a una regla de separación de zonas de exclusión personalizada (véase más abajo).

Los rellenos poligonales evitan los objetos de exclusión colocados.
La influencia del conjunto de zonas de exclusión en los rellenos poligonales puede apreciarse claramente al visualizar el diseño en modo 3D de una sola capa, como se muestra a continuación: la capa superior a la izquierda y la capa inferior a la derecha.

La capa superior (izquierda) y la capa inferior (derecha) de la PCB mostradas en modo 3D de una sola capa.
Control del cosido de vías
La aplicación de formas de exclusión configuradas para restringir objetos de tipo vía sobre áreas de cobre multicapa permite controlar la extensión del cosido automático de vías (Tools » Via Stitching/Shielding). Las formas de exclusión pueden configurarse para cualquier capa o para una de las capas del área de cobre, de modo que las vías entre esas capas queden excluidas (restringidas).
En el ejemplo siguiente, se han añadido formas de exclusión en las esquinas superior e inferior izquierdas del diseño. Estas se configuran para restringir objetos de tipo vía, lo que impedirá que el cosido automático de vías coloque vías dentro de esos perímetros.

Regiones de exclusión configuradas para aplicarse únicamente a vías.
Además de evitar las pistas, los pads y las vías existentes, como ocurre normalmente, el cosido de vías también evita las formas de exclusión según lo establecido por la regla de separación correspondiente.

La PCB después de añadir el cosido de vías.
Zonas de exclusión en componentes
Las zonas de exclusión se añaden a las huellas de los componentes en el editor de bibliotecas de PCB mediante el mismo procedimiento que se utiliza en el espacio de diseño del editor de PCB.
La zona de exclusión añadida a la huella del componente que se muestra a continuación está configurada para restringir todos los objetos, pero permitir las pistas. De este modo, permite las conexiones de red en un diseño que utilice el componente, mientras restringe la colocación de otros tipos de objetos en sus proximidades.

También pueden añadirse objetos de exclusión a las huellas de los componentes en el editor de bibliotecas de PCB.
Trabajo con zonas de exclusión
La implementación de las zonas de exclusión específicas por objeto de Altium Designer se refleja en todas las funciones asociadas e incluye compatibilidad con las consultas (y, por tanto, con las reglas de diseño), el panel PCB List y también los documentos de diseño de PCB importados o de versiones anteriores.
Regla de separación de zonas de exclusión
Al igual que ocurre con otras primitivas de objeto, la regla de separación eléctrica actual determinará las restricciones de separación de las zonas de exclusión; véase Design » Rules. Si se requiere una restricción de separación distinta para las zonas de exclusión, cree una regla específica aplicando la comprobación de atributo IsKeepOut como consulta personalizada.
Asegúrese de que la regla de separación personalizada para zonas de exclusión tenga una prioridad mayor que la regla de separación existente (global). En el siguiente ejemplo, se ha creado una regla para las zonas de exclusión (Clearance_Keepout) con una distancia de separación que duplica la de la regla de separación base (Clearance). Como se muestra en la sección del diseño de la placa, la pista trazada entre los dos pads evita la zona de exclusión (a la derecha) con un margen mayor que el de la región de la capa superior (a la izquierda).

Se puede crear una regla de separación adicional para los objetos de exclusión.
Convertir objetos primitivos en objetos de exclusión
Los objetos primitivos existentes en las capas de señal se pueden convertir en objetos de exclusión, en la misma capa, mediante el comando Convertir primitivas en objetos de exclusión (Tools » Convert » Convert Selected Primitives to Keepout).

Un objeto primitivo se puede convertir en un objeto de exclusión equivalente (y viceversa).
Acceso mediante paneles
Se puede acceder a las zonas de exclusión específicas de objetos de un diseño de placa mediante los paneles Lista de PCB y Filtro de PCB.
El panel PCB Filter permite utilizar la palabra clave de consulta IsKeepOut para localizar y, opcionalmente, seleccionar objetos de exclusión en el diseño.

El panel PCB Filter se puede utilizar para localizar objetos de exclusión en el diseño.
El panel PCB List se puede utilizar para enumerar, seleccionar y editar los objetos de exclusión del tipo seleccionado; por ejemplo, rellenos de exclusión, como se muestra en la imagen del panel Lista que aparece a continuación. También se muestra un relleno estándar de la capa superior (el último de la lista) a modo de comparación. Si all los rellenos (u otros tipos de objetos, como las regiones) incluidos en el diseño están definidos como objetos de exclusión, el panel PCB List incluirá el conjunto completo de atributos de restricción de los objetos de exclusión.

El panel PCB List se puede utilizar para enumerar, seleccionar y editar los objetos de exclusión del tipo seleccionado.
Importación de diseños de PCB
Altium Designer puede importar archivos de diseño de una amplia variedad de otras herramientas de diseño mediante las funciones de conversión automatizada del Asistente de importación (File » Import Wizard). Los objetos de tipo exclusión incluidos en los archivos de diseño de PCB de otras herramientas de diseño, algunos de los cuales son específicos de objetos, se convierten mediante el asistente en zonas de exclusión específicas de objetos, siempre que sea posible.
El proceso de conversión de zonas de exclusión del asistente es compatible con diseños de placas de sistemas ECAD populares, como Mentor® Graphics Pads™ y Cadence® Allegro™. Las zonas de exclusión también se interpretan correctamente durante el proceso de exportación a IDF.
