Trabajar con componentes colocados

De un vistazo

Este artículo explica cómo se representan y gestionan los componentes, también llamados piezas en muchos casos, en los esquemas de Altium Designer. Se describe qué es una pieza, cómo funcionan los componentes de varias piezas y las distintas formas de colocarlos desde el panel Componentes o el editor de bibliotecas de esquemas. También se explica cómo buscar componentes, realizar acciones básicas de edición gráfica, como mover, girar y reflejar, y utilizar las herramientas que vinculan los componentes del esquema con sus equivalentes en la PCB, como el sondeo cruzado, el modo de selección cruzada y la selección de componentes para su colocación en el editor de PCB. Además, conocerá las principales opciones de Propiedades de la pieza disponibles en la pestaña General, que le ayudarán a comprender mejor cómo se definen y controlan los componentes colocados. Siga leyendo para trabajar con más confianza con los componentes de sus esquemas.

- Descubra de dónde proceden los componentes, cómo se gestionan las piezas y los componentes de varias piezas, y las principales formas de colocarlos en un esquema.
- Aprenda a buscar componentes de forma más eficiente y a realizar cambios gráficos rápidos durante o después de su colocación.
- Comprenda cómo se relacionan los componentes del esquema con los de la PCB y qué propiedades principales puede revisar o editar después de colocarlos.
Profundiza con IA:

Un componente dentro de una biblioteca representa el dispositivo físico que se coloca en la placa de circuito impreso real. En una hoja de esquemático, un componente se representa mediante su modelo de símbolo esquemático. Cada componente puede contener una o varias partes.

Actualización y sustitución de componentes desde una biblioteca

Una vez colocados inicialmente los componentes en las hojas de esquema del diseño de una placa, se necesita algún método para actualizar esas instancias de componentes con los cambios realizados en sus componentes de origen vinculados en el espacio de trabajo correspondiente. En otras palabras, una forma de mantener el diseño sincronizado con las entidades del espacio de trabajo que utiliza.

Por ejemplo, puede que un componente se haya vuelto a guardar en el espacio de trabajo, quizá para reflejar un cambio en un modelo secundario. Esto genera una nueva revisión de ese componente. La instancia colocada de dicho componente utiliza ahora una revisión anterior y quizá desee actualizarla para que utilice la revisión más reciente. También es posible que haya decidido utilizar un componente completamente distinto y solo necesite sustituir el componente existente en el diseño por otro alternativo.

  • Esta página describe cómo actualizar un componente colocado desde su espacio de trabajo conectado. Para obtener información sobre cómo actualizar un componente colocado desde una biblioteca de base de datos o basada en archivos, consulte la página Actualización de componentes desde bibliotecas de bases de datos y basadas en archivos.

  • Los componentes colocados en un proyecto de diseño desde sus espacios de trabajo conectados se pueden modificar localmente (por ejemplo, se pueden añadir, cambiar o eliminar parámetros desde el panel Propiedades cuando se selecciona un componente colocado en el espacio de diseño). Si necesita que el componente colocado coincida con su equivalente en la biblioteca del espacio de trabajo (en otras palabras, si necesita revertir los cambios locales), puede utilizar el cuadro de diálogo Actualizar desde biblioteca (Tools » Update From Libraries).

Existen varios métodos para gestionar los componentes después de su colocación inicial en un diseño.

Cambio de una instancia individual de un componente

Cada componente colocado tiene un vínculo a la revisión del componente en el espacio de trabajo. Esta información se encuentra en el panel Propiedades, al consultar las propiedades del componente seleccionado.

Cada instancia colocada de un componente tiene un vínculo a la revisión específica de ese componente en el espacio de trabajo.Cada instancia colocada de un componente tiene un vínculo a la revisión específica de ese componente en el espacio de trabajo.

Si hay disponible una revisión posterior del componente existente, la entrada del estado de revisión (en el panel Properties) lo indicará mediante el texto Out of date, a la derecha del estado del ciclo de vida de la revisión actual. Tenga en cuenta que, si el estado del ciclo de vida se ha marcado como no permitido para el diseño (con la opción Allowed to be used in designs desactivada en el cuadro de diálogo Propiedades del estado), la entrada se mostrará como Inapplicable.

En este nivel básico de componente individual, la instancia colocada se puede:

  • Actualizar a la última revisión del componente existente haciendo clic en el botón .

Ejemplo de actualización del mismo componente a su última revisión: pase el cursor sobre la imagen para ver el resultado.Ejemplo de actualización del mismo componente a su última revisión: pase el cursor sobre la imagen para ver el resultado.

  • Sustituir por la última revisión de otro componente del espacio de trabajo (un sustituto) o por un componente de una biblioteca basada en archivos haciendo clic en el botón , a la derecha del campo Design Item ID. Se abrirá el cuadro de diálogo Replace Component, que muestra los componentes del espacio de trabajo conectado y de las bibliotecas basadas en archivos disponibles. El componente actual se muestra al principio de la lista. Busque el componente de sustitución que necesite, selecciónelo y haga clic en OK.

    Ejemplo de sustitución del componente existente por otro diferente (una alternativa)Ejemplo de sustitución del componente existente por otro diferente (una alternativa)

    El cuadro de diálogo Replace Component proporciona acceso directo a todos los componentes disponibles de las bibliotecas del espacio de trabajo y de las bibliotecas basadas en archivos. El cuadro de diálogo ofrece información completa sobre el componente seleccionado (parámetros, modelos, opciones de piezas, datos de proveedores, etc.), comparación de componentes y, para los componentes de bibliotecas del espacio de trabajo, una función de búsqueda paramétrica basada en filtros que permite especificar los parámetros deseados del componente.

    También se puede acceder al cuadro de diálogo Replace Component desde otras ubicaciones de Altium Designer al sustituir un componente, por ejemplo, desde un documento ActiveBOM o desde el cuadro de diálogo Administrador de elementos.

Cambios de componentes por lotes: el Administrador de elementos

Related page: Gestión de contenido con el Administrador de elementos

La modificación individual de componentes resulta útil, pero pronto se vuelve tediosa cuando se trabaja con un número considerable de componentes. Para ello, necesita un único lugar centralizado desde el que realizar varios cambios por lotes. Aquí es donde entra en juego el Administrador de elementos (Tools » Item Manager).

El Item Manager es el «centro de control» para sincronizar las entidades de diseño de Workspace —colocadas en hojas de esquemático— con el contenido de origen al que están vinculadas en un Workspace. Detecta y enumera automáticamente todos los componentes, indica si son entidades de Workspace o no y, a continuación, compara la revisión del elemento de cada componente de Workspace presente en los esquemáticos con las revisiones disponibles de ese componente en el Workspace. Para cada entidad, se proporciona información sobre el elemento vinculado actualmente: su revisión, su estado del ciclo de vida y el Workspace de origen en el que reside.

La comparación automatizada de revisiones del contenido de Workspace identifica el contenido desactualizado. Después, puede seleccionarlo y prepararlo para actualizarlo a la última revisión con un esfuerzo mínimo. Para obtener más información, consulte Detectar cuándo se requieren actualizaciones.

Tiene pleno control sobre cuáles de estas entidades de Workspace se actualizan y cómo. Por ejemplo:

  • Seleccione una entrada individual y actualícela para utilizar la última revisión del elemento vinculado, o elija utilizar la última revisión de un elemento completamente diferente.
  • Seleccione un grupo de entradas que utilicen el mismo elemento vinculado y actualícelas a la última revisión de ese elemento, o elija utilizar la última revisión de un elemento completamente diferente.

Todos los cambios propuestos se reflejan en el administrador.

Una vez configurados los cambios según sus necesidades, genere una orden de cambio de ingeniería (ECO) y revise las acciones que se realizarán para implementar esos cambios. Desactive cualquier acción si es necesario: ¡usted siempre tiene el control! Cuando esté listo, ejecute la ECO y se aplicarán los cambios. Gestione el contenido de Workspace colocado en su diseño de forma rápida, eficiente y sencilla.

Si está seguro de los cambios que va a realizar, puede utilizar la función Item Manager's Apply ECO para aplicarlos de forma silenciosa, sin abrir el cuadro de diálogo Engineering Change Order.

Los siguientes ejemplos ilustran el uso del Item Manager:

  • Actualizar varios componentes para utilizar la última revisión del componente de Workspace existente.

Actualice un grupo de componentes desactualizados a sus últimas revisiones.
Actualice un grupo de componentes desactualizados a sus últimas revisiones.

Reemplace uno o varios componentes por un componente de Workspace diferente.
Reemplace uno o varios componentes por un componente de Workspace diferente.

El Item Manager no solo permite mantener los componentes de sus diseños sincronizados con los cambios en el contenido de origen de los Workspaces conectados, sino que también es una potente herramienta para facilitar la migración de sus diseños de placa existentes: de utilizar elementos de diseño locales a utilizar contenido de diseño de Workspace. Una vez que haya migrado los componentes de su diseño a un Workspace, así como las hojas de esquemático (hojas de dispositivo), utilice el Item Manager para «reemplazar» los componentes y símbolos de hoja existentes por sus versiones recién migradas al Workspace. En otras palabras, los componentes siguen siendo los mismos desde la perspectiva del diseño, pero cambia su origen.

Las potentes funciones de correspondencia automática le permiten asociar rápidamente componentes locales y símbolos de hoja con elementos del Workspace.

Cambiar un componente desde un BomDoc

Es habitual detectar un problema con un componente al revisar el BomDoc y prepararlo para pedir las piezas. Por ejemplo, puede que el diseñador haya olvidado finalizar la selección de un componente, o que un componente haya llegado al final de su vida útil (EOL) y el diseñador quiera consultar el precio y la disponibilidad de posibles sustitutos. Aunque podría resolverlo volviendo al esquemático y editando el componente, seleccionando una pieza adecuada y actualizando después el BomDoc, ActiveBOM permite hacerlo directamente desde el BomDoc y, a continuación, transferir ese cambio al esquemático mediante una orden de cambio de ingeniería.

Desde el BomDoc, haga clic con el botón derecho en los componentes seleccionados y seleccione el comando Operations » Change <ComponentName>. Se abrirá el cuadro de diálogo Reemplazar componente, desde el que podrá buscar el componente de sustitución. Cuando encuentre el componente de sustitución deseado, selecciónelo y haga clic en OK. Se abrirá el cuadro de diálogo Engineering Change Order, que detalla los cambios necesarios para sincronizar el esquemático con el BomDoc.

Ejemplo de sustitución de un componente directamente desde un BomDoc.
Ejemplo de sustitución de un componente directamente desde un BomDoc.

  • La función de reemplazo de componentes busca un componente nuevo en el Workspace activo.
  • Si el cambio de componente también afecta al diseño de la placa, deberá actualizar también la PCB desde el esquemático.
  • El cuadro de diálogo Replace Component tiene una distribución similar y comparte muchas de sus funciones con el panel Componentes. 

Reemplazar un componente genérico

Cuando un diseño haya avanzado hasta el punto en que un componente genérico pueda sustituirse por un componente físico específico, abra el cuadro de diálogo Reemplazar componente seleccionando el botón en el panel Properties. Tenga en cuenta que también puede hacerlo desde el Administrador de elementos o mediante el documento ActiveBOM del proyecto.

Los valores de los parámetros que se hayan aplicado al componente genérico (en este caso, los valores de potencia y resistencia) se utilizan automáticamente como términos de búsqueda en el cuadro de diálogo Replace Generic Component, lo que permite elegir un componente de sustitución adecuado entre los resultados filtrados. En este ejemplo, dos entradas de componentes cumplen los criterios de búsqueda.

Javascript ID: GenericComponents_Replace_AD23

Reemplazar un componente genérico mediante el panel Properties.

Reemplazar un componente genérico mediante el panel Properties.

Tenga en cuenta que la lógica de reemplazo de componentes también admite selecciones múltiples. Cuando se seleccionan varios componentes genéricos para reemplazarlos mediante el panel Properties, el componente de fabricante elegido en el cuadro de diálogo Replace Generic Component reemplazará todos los componentes seleccionados.

Gestionar las huellas en todo el diseño

El editor de esquemáticos de Altium Designer incluye un potente Footprint Manager. Se abre desde el menú Herramientas del editor de esquemáticos (Tools » Footprint Manager) y permite, mediante el Footprint Manager, revisar todas las huellas asociadas a cada componente de todo el proyecto. La compatibilidad con la selección múltiple facilita editar la asignación de huellas de varios componentes, cambiar la forma en que se vincula la huella o cambiar la huella asignada actualmente a los componentes que tienen varias huellas asignadas. El Footprint Manager facilita la revisión y detección de problemas con las asignaciones de huellas en todo el diseño, lo que resulta especialmente útil cuando se trabaja en un diseño heredado o procedente de otra organización. Los cambios de diseño se aplican mediante el sistema ECO, que actualiza tanto el esquemático como la PCB si es necesario.

El cuadro de diálogo Footprint Manager presenta una lista de todos los componentes de todos los esquemáticos de origen del proyecto activo. Utilice los controles disponibles en el lado derecho del cuadro de diálogo para gestionar las huellas disponibles para los componentes del diseño y las que estos utilizan actualmente. Sus funciones incluyen:

  • La posibilidad de añadir, editar y eliminar modelos de huella para uno o varios componentes seleccionados.
  • Copiar huellas entre componentes.
  • Cambiar la huella asignada actualmente (la huella que se utilizará para representar un componente en el entorno de PCB, de entre las distintas huellas que pueda tener disponibles ese componente).
  • Validar las huellas para garantizar que los modelos de huella estén realmente disponibles, especialmente los establecidos como modelo actual.

Una vez realizados todos los cambios necesarios en las asignaciones de modelos de huella, estos se implementan mediante una orden de cambio de ingeniería (ECO) estándar. Para ello, simplemente haga clic en el botón Accept Changes (Create ECO), situado en la esquina inferior derecha del cuadro de diálogo Footprint Manager.

En un diseño que contenga hojas de dispositivo, los componentes de dichas hojas solo aparecerán en la lista si las hojas no están marcadas como de solo lectura. Cambie el estado de solo lectura de las hojas de dispositivo de los proyectos desde la página Gestión de datos - Hojas de dispositivo del cuadro de diálogo Preferences.
Si el diseño se ha creado utilizando diversas bibliotecas y las huellas se han añadido o editado manualmente, es imprescindible revisar detenidamente todos los datos de las huellas. El Footprint Manager puede ayudar a unificar las huellas en todo el diseño, pero también será necesario realizar algunas comprobaciones de coherencia. El sistema no puede detectar errores de diseño, como asignar una resistencia de 20 W a una huella 0603. Todos estos aspectos deben revisarse con cuidado, teniendo en cuenta que los nombres de las huellas pueden variar entre proveedores de componentes. ¡No dé nada por sentado!
AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Nav
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents