Trabajar con componentes colocados
De un vistazo
- Descubra de dónde proceden los componentes, cómo se gestionan las piezas y los componentes de varias piezas, y las principales formas de colocarlos en un esquema.
- Aprenda a buscar componentes de forma más eficiente y a realizar cambios gráficos rápidos durante o después de su colocación.
- Comprenda cómo se relacionan los componentes del esquema con los de la PCB y qué propiedades principales puede revisar o editar después de colocarlos.
Un componente dentro de una biblioteca representa el dispositivo físico que se coloca en la placa de circuito impreso real. En una hoja de esquemático, un componente se representa mediante su modelo de símbolo esquemático. Cada componente puede contener una o varias partes.
Parte

La parte representa el componente electrónico físico real.
Resumen
Una parte es una primitiva de diseño eléctrico. Es un símbolo esquemático que representa un dispositivo electrónico, como una resistencia, un interruptor, un amplificador operacional, un regulador de tensión, etc. Las partes se almacenan dentro de componentes en bibliotecas de componentes esquemáticos. Tenga en cuenta que cada componente puede contener una o varias partes. Además de una representación simbólica del componente, la parte también incluye enlaces a modelos, como la huella de PCB, así como parámetros que se utilizan para documentar detalles como los parámetros del componente y la información del proveedor. La forma en que se añaden los enlaces a modelos y los parámetros a la parte depende del tipo de almacenamiento de biblioteca que se utilice.
Disponibilidad
Las partes se pueden colocar tanto en el editor de esquemáticos como en el editor de bibliotecas de esquemáticos.
- En el editor de esquemáticos, haga clic en Place » Part.
- Haga clic con el botón derecho en el espacio de diseño y, a continuación, seleccione Place » Part en el menú contextual.
- En el panel Components, haga clic con el botón derecho en un componente y seleccione Place <ComponentName>.
- En el panel Components, seleccione un componente genérico como marcador de posición.
- Arrastre y suelte un componente desde el panel Components.
- Seleccione el botón Place en la sección Details del panel Components, o utilice el método abreviado de teclado Enter.
- En el panel SCH Library, cuando esté en el editor de bibliotecas de esquemáticos, seleccione un componente y, a continuación, haga clic en Place.
Colocación desde el panel Components
En el editor de esquemáticos, el proceso de selección y colocación de partes se puede realizar desde el panel Components.
- El panel muestra el contenido de la biblioteca seleccionada actualmente. Utilice el menú desplegable situado junto al nombre de la biblioteca para elegir otra biblioteca.
- Utilice el campo de máscara situado debajo del campo de la biblioteca seleccionada actualmente para filtrar la lista y agilizar el proceso de búsqueda, o desplácese y seleccione la parte que necesite.
- Haga clic en Place, haga doble clic o haga clic y arrastre para colocar el componente seleccionado en la hoja de esquemático activa. Mientras la parte esté flotando en el cursor, puede girarla (pulse Spacebar), reflejarla respecto a un eje (pulse X o Y) o editarla (pulse Tab) antes de colocarla.
- Las columnas que se muestran en la lista de componentes de la biblioteca seleccionada actualmente se pueden reorganizar (haciendo clic y arrastrando) o reconfigurar (haciendo clic con el botón derecho y seleccionando Select Columns).
-
Haga clic en el botón
de una ficha de componente genérico para adjuntar el componente al cursor y colocarlo en el documento de esquemático activo. Al seleccionar la propia ficha, se abrirá la categoría de ese tipo de componente en el panel Components.
Búsqueda de un componente
Las opciones del menú de bibliotecas que no pertenecen a un espacio de trabajo permiten establecer preferencias, realizar búsquedas y migrar el contenido de bibliotecas basadas en bases de datos y en archivos. Para acceder a estas opciones, seleccione el botón del menú de bibliotecas
situado en la parte superior derecha del panel Components.
Seleccione File-based Libraries Preferences para abrir el cuadro de diálogo Available File-based Libraries, donde encontrará controles para añadir o eliminar bibliotecas, instalar bibliotecas y especificar rutas de búsqueda de bibliotecas.
La lista actual de componentes de bibliotecas basadas en bases de datos y en archivos se puede filtrar introduciendo una frase de búsqueda en el campo Search del panel Components. Para acceder a funciones de búsqueda más avanzadas para bibliotecas de componentes, seleccione la opción File-based Libraries Search en el menú
del panel (arriba a la derecha), que abre el cuadro de diálogo File-based Libraries Search. Este cuadro de diálogo ofrece opciones de búsqueda flexibles, incluidas restricciones de filtrado basadas en consultas y la posibilidad de buscar en todas las bibliotecas disponibles basadas en bases de datos y en archivos, o en aquellas que se encuentran en una ruta especificada.
- La Scope de búsqueda predeterminada consiste en buscar Components en Available File-based Libraries.
- Como alternativa, el cuadro de diálogo también permite buscar entre Libraries on path almacenados en carpetas de una unidad. Para ello, active la opción Libraries on path y, a continuación, configure las opciones Path según sea necesario.
- Los Filters utilizan «AND» y, por lo tanto, es mejor empezar con un filtro sencillo y, si hay muchos resultados, utilizar el modo Refine last search para buscar dentro de los resultados.
- Los resultados de la búsqueda mediante consultas se presentan en el cuadro de diálogo File-based Libraries Search al seleccionar Helper.
Colocación desde el editor de bibliotecas de esquemáticos
También se puede colocar una parte directamente desde una biblioteca abierta en el editor de bibliotecas de esquemáticos a través del panel SCH Library. Tenga en cuenta lo siguiente:
- Al hacer clic en el botón Place del panel, la parte (componente) seleccionada se colocará en la última hoja de esquemático activa.
- Mientras la parte esté flotando en el cursor, puede girarla (pulse Spacebar), reflejarla respecto a un eje (pulse X o Y) o editarla (pulse Tab) antes de colocarla. La acción también se puede realizar mientras se arrastra el objeto. La rotación se realiza en incrementos de 90°.
-
Si una parte se coloca directamente desde una biblioteca, no es necesario añadir primero esa biblioteca en el cuadro de diálogo Available File-based Libraries.
Edición gráfica
La edición gráfica de una parte se limita a moverla, girarla y reflejarla. Cuando se selecciona una parte en el espacio de diseño, aparece un recuadro de selección discontinuo a su alrededor. Para manipular gráficamente un componente seleccionado:
- Pulse Delete para eliminar la parte seleccionada del diseño.
- Haga clic y mantenga pulsado el botón para mover la parte seleccionada. El cursor saltará al punto de conexión eléctrica más cercano (el extremo de conexión del pin más cercano).
- Pulse Spacebar para girar el arco en sentido antihorario o Shift+Spacebar para girarlo en sentido horario. La acción también se puede realizar mientras se arrastra el objeto. La rotación se realiza en incrementos de 90°.
- Mientras una parte se mueve con el cursor, pulse la tecla X o Y para reflejarla respecto a ese eje.
Trabajo entre el componente del esquemático y el componente de la PCB
El software incluye herramientas que facilitan el trabajo entre el componente del esquemático y ese mismo componente en la PCB. Estas herramientas incluyen la localización cruzada, la selección cruzada y la selección de componentes de la PCB desde el esquemático.
Localización cruzada
Como su nombre indica, la localización cruzada permite hacer clic en un componente en un editor y saltar a ese componente en el otro editor. Para utilizar la localización cruzada:
- Haga clic en Cross Probe, ubicado en el menú Tools del editor de esquemáticos o de PCB.
- Al hacer clic en el componente en el editor de esquemáticos, este se centrará y se ampliará en el editor de PCB. El nivel de zoom se establece en la página Sistema – Navegación del cuadro de diálogo Preferences.
- El comportamiento predeterminado es permanecer en el mismo editor, listo para localizar otro componente. Para cambiar al otro editor al realizar la localización cruzada, mantenga pulsada la tecla Ctrl.
Modo de selección cruzada
El modo de selección cruzada selecciona el mismo componente en el otro editor. Tenga en cuenta que no amplía ni centra la vista. La selección cruzada puede estar activada o desactivada. Haga clic en Tools » Cross Select Mode para activar o desactivar el modo. Seleccione varios componentes manteniendo pulsada la tecla Shift mientras hace clic para seleccionarlos.
Selección de los componentes de la PCB
Esta función permite seleccionar varios componentes del esquemático en un orden específico y, a continuación, colocar esos mismos componentes en el editor de PCB en el mismo orden. Para utilizar esta función:
- Seleccione los componentes en el esquemático uno a uno (mantenga pulsada la tecla Shift mientras hace clic para seleccionar varios componentes).
- Cambie al editor de PCB y pulse el atajo de teclado I, C para ejecutar el comando Reposition Selected Components. El comando Reposition Selected Components también está disponible en el menú contextual después de pulsar el atajo de teclado I.
Propiedades de la parte
Pestaña General
General
-
Reuse Block – cuando el componente forma parte de un bloque de reutilización, este campo muestra el nombre del bloque de reutilización principal. Haga clic en el hipervínculo Reuse Block para ver las propiedades de este bloque de reutilización.
-
Designator – introduzca el designador. Utilice el icono del ojo para mostrar u ocultar el designador. Utilice el icono del candado para bloquear o desbloquear el designador. Obtenga más información sobre el designador.
-
Comment – introduzca un nombre o comentario. Utilice el icono del ojo para mostrar u ocultar el nombre. Utilice el icono del candado para bloquear o desbloquear el nombre. El campo Comentario también puede utilizarse para mostrar el valor de un parámetro definido por el usuario o del sistema. Obtenga más información sobre el comentario.
-
Part <x> of Parts – muestra el número de la parte seleccionada y el número total de partes. Haga clic en
para bloquear o desbloquear los campos y, a continuación, utilice la lista desplegable para seleccionar el número de la parte asociada.
-
Description – la descripción del componente o de la parte.
-
Type – seleccione aquí uno de los siguientes tipos de componente para la huella del componente. Los tipos disponibles son:
-
Standard– componentes que poseen propiedades eléctricas estándar, se sincronizan siempre entre el esquemático y la PCB (la huella, los pines/pads y las asignaciones de redes deben coincidir) y se incluyen en la lista de materiales (BOM). Un ejemplo es un componente eléctrico estándar, como una resistencia. -
Mechanical– componentes que no tienen propiedades eléctricas, no se sincronizan (deben colocarse manualmente en ambos editores) y se incluyen en la BOM. Un ejemplo es un disipador de calor. -
Graphical– componentes que no tienen propiedades eléctricas, no se sincronizan (deben colocarse manualmente en ambos editores) y not se incluyen en la BOM. Un ejemplo es el logotipo de una empresa. -
Net Tie (In BOM)– componentes que se utilizan para cortocircuitar dos o más redes diferentes, se sincronizan siempre entre el esquemático y la PCB (la huella, los pines/pads y las asignaciones de redes deben coincidir) y se incluyen en la BOM. Se diferencian de un componente estándar en que no se comprueba la conectividad creada por el cobre dentro de la huella; este cobre es el que permite cortocircuitar las redes. Nota: active la opción Verify Shorting Copper en el cuadro de diálogo Comprobador de reglas de diseño para verificar que no haya cobre sin conectar dentro del componente. -
Net Tie (No BOM)– componentes que se utilizan para cortocircuitar dos o más redes diferentes, se sincronizan siempre entre el esquemático y la PCB (la huella, los pines/pads y las asignaciones de redes deben coincidir) y not se incluyen en la BOM. Se diferencian de un componente estándar en que no se comprueba la conectividad creada por el cobre dentro de la huella; este cobre es el que permite cortocircuitar las redes. Nota: active la opción Verify Shorting Copper en el cuadro de diálogo Comprobador de reglas de diseño para verificar que no haya cobre sin conectar en el componente. -
Standard (No BOM)– componentes que poseen propiedades eléctricas estándar, se sincronizan siempre entre el esquemático y la PCB (la huella, los pines/pads y las asignaciones de redes deben coincidir) y not se incluyen en la BOM. Un ejemplo es un componente de punto de prueba que se desea excluir de la BOM. -
Jumper– componentes que se utilizan para incluir puentes de alambre en un diseño de PCB, por ejemplo, en una PCB de una sola cara que no puede enrutarse por completo en una sola capa. Para este tipo de componente, la huella y los pines del componente se sincronizan entre el esquemático y la PCB, pero las asignaciones de redes no, y el componente se incluye en la BOM. Además de seleccionar esta opción a nivel de componente, ambos pads del componente deben tener su JumperID establecido en el mismo valor distinto de cero. Los componentes de tipo puente no necesitan estar cableados en el esquemático; solo deben incluirse en él si son necesarios en la BOM. Si no son necesarios en la BOM, pueden colocarse directamente en la PCB, donde se establece el Component Type, se configuran los JumperIDs y se asigna manualmente el Nets a los pads.
-
-
Design Item ID – este campo muestra el nombre del componente seleccionado (para un componente de Workspace), el campo clave elegido definido en Field Settings región del archivo DbLib/SVNDbLib (para un componente de biblioteca de base de datos), o el parámetro Design Item ID definido para el símbolo del componente (para un componente de biblioteca basada en archivos). Haga clic en
para abrir el cuadro de diálogo Reemplazar componente. Este cuadro de diálogo permite acceder a todos los detalles del componente seleccionado (parámetros, modelos, opciones de pieza, datos de proveedores, etc.), comparar componentes y reemplazar el componente actual por otro, entre otras posibilidades. Si se selecciona otro componente como reemplazo, este campo mostrará el Design Item ID completo del componente recién seleccionado. Haga clic en el botón Validate para mostrar información sobre la ubicación del componente. Si no es un componente de un espacio de trabajo, aparecerá la ruta del archivo en el que está guardado en su equipo. Si es un componente de un espacio de trabajo, la información indicará simplemente que se ha encontrado el componente.
-
Source – muestra el nombre de la biblioteca de origen del componente. Haga clic en
para buscar y seleccionar la biblioteca deseada.
-
Revision state – este campo muestra el estado actual del ciclo de vida de la revisión del componente seleccionado, con el icono de color y el nombre del estado de la revisión.
-
Revision status – si la revisión del componente seleccionado se encuentra en un estado aplicable (se permite su uso en diseños), la entrada indicará si la revisión es la más reciente (
Up to date) o no (Out of date). Si la revisión se encuentra en un estado no aplicable (no se permite su uso en diseños), la entrada mostraráNot applicable. Haga clic en el botón
para actualizar el componente a la revisión más reciente.
-
Component issues (solo en el panel Properties) – si un componente seleccionado procedente del espacio de trabajo de Altium 365 conectado presenta algún problema de salud, se indicará mediante el icono
(para errores) o
(para errores graves). El número a la derecha del icono indica la cantidad de problemas encontrados. Haga clic en la flecha hacia abajo situada a la derecha del número para ver las descripciones breves de los problemas.

Un ejemplo de problemas de salud de la biblioteca encontrados. -
Supply Chain Data (solo en el panel Properties) – muestra la información de la cadena de suministro de la opción de pieza relacionada:
- Mediana del precio unitario. Esta entrada se mostrará en rojo si no hay precios o si el precio = 0.
- Existencias. Esta entrada muestra la suma total de las existencias disponibles de los proveedores habilitados como parte de la fuente Altium Parts Provider para su espacio de trabajo.
-
Barra del ciclo de vida del fabricante. Pase el cursor sobre la barra para ver información adicional. Puede aparecer en uno de estos cuatro estados:
- Blanco/Gris = Predeterminado, desconocido o sin información
- Verde = Estados Nuevo o Producción en volumen
- Naranja = No recomendado para nuevos diseños
- Rojo = Obsoleto o Fin de vida útil (EOL)
Ubicación
-
(X/Y)
- X (primer campo) – la coordenada X (horizontal) actual del punto de referencia del objeto, relativa al origen actual del espacio de diseño. Edítela para cambiar la posición X del objeto. El valor puede introducirse en unidades métricas o imperiales; incluya las unidades al introducir un valor cuyas unidades no sean las predeterminadas actualmente.
- Y (segundo campo) – la coordenada Y (vertical) actual del punto de referencia del objeto, relativa al origen actual. Edítela para cambiar la posición Y del objeto. El valor puede introducirse en unidades métricas o imperiales; incluya las unidades al introducir un valor cuyas unidades no sean las predeterminadas actualmente.
-
Rotation – utilice el menú desplegable para seleccionar la rotación. Las opciones son
0 Degrees,90 Degrees,180 Degreesy270 Degrees.
Parámetros
-
Grid – muestra los Name y Value de los parámetros asociados al componente seleccionado actualmente. Utilice
para bloquear/desbloquear un parámetro de la lista e impedir que se actualice. Los valores de los parámetros pueden introducirse manualmente o seleccionarse en una lista desplegable que ofrece valores procedentes de todos los componentes disponibles de ese tipo. Puede alternar el icono del ojo para mostrar/ocultar el parámetro.
-
Favorites – los parámetros marcados como favoritos se mostrarán en la lista Parámetros, mientras que los que no estén marcados permanecerán ocultos. Sitúe el cursor a la derecha del nombre de un filtro de parámetros y haga clic en el icono
para marcar el filtro como favorito. Para quitar un parámetro de los favoritos, vuelva a hacer clic en el icono.
Para ver todos los parámetros ocultos, haga clic en el control Show More situado en la parte inferior de la lista. Haga clic en el control Show Less para ver solo los parámetros favoritos.
-
Font – haga clic en la fuente que se muestra para cambiar su estilo.
-
Other – haga clic para abrir un menú desplegable y cambiar opciones adicionales:
- Show Parameter Name – habilite esta opción para mostrar el nombre del parámetro.
- Allow Synchronization with Database – habilite esta opción para sincronizar con la base de datos. Esta opción se utiliza para controlar si el comentario puede actualizarse. De forma predeterminada, estas opciones están habilitadas para permitir siempre la sincronización con la biblioteca/base de datos de origen. Puede deshabilitar esta opción para impedir que ese comentario se incluya en un proceso de actualización.
- (X/Y) – introduzca las coordenadas X e Y.
-
Rotation – utilice el menú desplegable para seleccionar la rotación. Las opciones son:
0°,90°,180°y270°. - Autoposition – marque esta opción para habilitar el posicionamiento automático, de modo que el parámetro se posicione automáticamente cada vez que se gire el componente asociado. Deshabilite esta opción para mantener la posición del parámetro con respecto al componente asociado cuando este se gire.
-
Add – haga clic para añadir un parámetro, como una huella, un modelo o una regla, entre otros. Haga clic en
para eliminar una entrada seleccionada de la tabla. Haga clic en
para editar el parámetro mediante su cuadro de diálogo correspondiente.
Gráfico
-
Mode – utilice el menú desplegable para seleccionar el modo deseado. Si no hay otros modos disponibles además de Normal, este menú desplegable aparecerá atenuado.
- Mirrored – habilite esta opción para reflejar la pieza.
- Local Colors – habilite la opción de color local para sustituir los colores de relleno, línea y pines del componente del esquemático por los colores de los cuadros de color Fill, Lines y Pins, respectivamente. Deshabilite esta opción para utilizar los colores predefinidos de la biblioteca.
Opciones de componentes
Esta sección proporciona información sobre las opciones de componentes y los enlaces de proveedores asignados al componente seleccionado. Consulte la página Añadir información de la cadena de suministro a un componente para obtener más información sobre los datos que proporcionan las entradas de esta sección.
Pestaña Pines
-
Grid – esta sección muestra el Pins y Names de todos los pines del componente seleccionado. Utilice el icono del ojo para mostrar/ocultar el pin. Utilice el icono del candado para bloquear/desbloquear los pines.
Para un pin multifunción (un pin que tiene funciones especificadas en el campo Functions del modo Pines del panel Propiedades), haga clic en la celda del pin en la columna Name y seleccione la función del pin en el menú desplegable que aparece. La función seleccionada se mostrará como nombre del pin en la hoja de esquemático.
- Show Full/Show Short - en Show Full se muestran los nombres completos ampliados de todos los pines de la lista; en el modo Show Short, se muestra el nombre actual del pin.
-
– cuando el botón está activado (el icono de candado cerrado), los pines del componente no se pueden editar en el editor de esquemas (pero sí en el editor de bibliotecas de esquemas). Desactive esta opción para editar un pin del componente en la hoja de esquema.
-
– haga clic para mostrar todos los pines ocultos y sus propiedades (nombres y números), incluidos los pines que tengan la propiedad Show desactivada en el Editor de pines del componente. Tenga en cuenta que, si está trabajando en el editor de bibliotecas de esquemas, también debe activar la opción View » Show Hidden Pins para mostrar los pines ocultos en el editor de bibliotecas.
-
– haga clic para añadir un pin al componente. Configure el pin en el panel Properties, haga clic y arrástrelo para colocarlo.
-
– haga clic para eliminar los pines seleccionados del componente.
-
– haga clic para abrir el cuadro de diálogo Editor de pines del componente. Este cuadro de diálogo ofrece una forma cómoda de ver y editar todos los pines del componente abierto actualmente en el editor de bibliotecas de esquemas o del componente seleccionado (o una parte de este) en el editor de esquemas.
Propiedades del componente genérico
Componentes genéricos

Colocación de un componente genérico desde el panel Components
Cuando Altium Designer está conectado a un espacio de trabajo, se puede acceder a los componentes genéricos disponibles desde el panel Componentes, donde se muestran al seleccionar la opción All en el panel Categories, o desde el menú desplegable superior cuando el panel está en modo compacto. Haga clic en el botón
de la ficha de un componente genérico para adjuntar el componente al cursor y colocarlo en el esquema activo. Al seleccionar la propia ficha, se abrirá la categoría de ese tipo de componente en el panel Components.
Propiedades del componente genérico
General
- Designator – introduzca el designador. Utilice el icono del ojo para mostrar u ocultar el designador. Haga clic en el icono del candado para bloquear o desbloquear el designador.
- Comment – introduzca el nombre. Utilice el icono del ojo para mostrar u ocultar el nombre.
-
Description – la descripción del componente o de la parte genéricos.
- Replace – seleccione el botón Replace cuando el diseño haya avanzado hasta el punto en que se pueda sustituir un componente genérico por un componente físico específico mediante el cuadro de diálogo Reemplazar componente.
Ubicación
-
(X/Y)
- X (primer campo) – la coordenada X (horizontal) actual del punto de referencia del objeto, relativa al origen actual del espacio de diseño. Edítela para cambiar la posición X del objeto. El valor puede introducirse en unidades métricas o imperiales; incluya las unidades al introducir un valor cuyas unidades no sean las predeterminadas actualmente.
- Y (segundo campo) – la coordenada Y (vertical) actual del punto de referencia del objeto, relativa al origen actual. Edítela para cambiar la posición Y del objeto. El valor puede introducirse en unidades métricas o imperiales; incluya las unidades al introducir un valor cuyas unidades no sean las predeterminadas actualmente.
- Rotation – utilice el menú desplegable para seleccionar la rotación.
Parámetros
- Grid – muestra los Name y Value de los parámetros asociados al componente seleccionado actualmente. Utilice el icono del candado para bloquear o desbloquear un parámetro de la lista. Los valores de los parámetros pueden introducirse manualmente o seleccionarse de una lista desplegable que ofrece valores procedentes de todos los componentes disponibles de ese tipo. Puede utilizar el icono del ojo para mostrar u ocultar el parámetro.
- Font – haga clic en la fuente mostrada para cambiar el estilo de fuente.
-
Other – haga clic para abrir un menú desplegable y cambiar otras opciones:
- Show Parameter Name – active esta opción para mostrar el nombre del parámetro.
- Allow Synchronization with Database – active esta opción para sincronizar con la base de datos. Esta opción se utiliza para controlar si se puede actualizar el comentario. De forma predeterminada, estas opciones están activadas para permitir siempre la sincronización con la biblioteca o base de datos de origen. Puede desactivar esta opción para evitar que ese comentario se incluya en un proceso de actualización.
- (X/Y) – introduzca las coordenadas X e Y.
- Rotation – utilice el menú desplegable para seleccionar la rotación.
- Autoposition – marque esta opción para activar el posicionamiento automático, lo que significa que el parámetro se posicionará automáticamente cada vez que se gire el componente asociado. Desactive esta opción para mantener la posición del parámetro con respecto al componente asociado cuando este se gire.
Designador
El designador identifica de forma única cada componente del diseño.
Resumen
El campo del designador es un objeto de parámetro secundario de un componente (parte) del esquema. Se utiliza para identificar de forma única cada parte colocada y distinguirla de todas las demás partes colocadas en todas las hojas de esquema del proyecto.
Disponibilidad y colocación
El designador se coloca automáticamente al colocar el objeto de la parte del componente principal. No es un objeto de diseño que se pueda colocar directamente.
Edición gráfica
La cadena del designador se puede editar gráficamente mediante lo que se conoce como edición in-place. Para editar una cadena de designador in situ, seleccione el designador arrastrando el cursor a su alrededor y, a continuación, pulse Intro.

Ejemplo de edición in situ
Una vez finalizada la edición, pulse Enter o haga clic fuera de la cadena para salir del modo de edición in situ.
Edición no gráfica
Hay dos aspectos que deben tenerse en cuenta al editar el designador: la edición de su valor y la edición de sus propiedades de visualización.
Las cadenas del designador (y del comentario) pueden mostrarse en el editor de bibliotecas de esquemas y, a continuación, puede hacerse doble clic en ellas para editar sus propiedades. El icono
asociado al campo en el panel Properties se utiliza para mostrar u ocultar el designador.
Edición del valor del designador en el editor de esquemas
El designador puede definirse en el editor de esquemas mientras se coloca el componente o después de haberlo colocado en una hoja de esquema en el Properties panel.
- Para editar el designador durante la colocación del componente, pulse la tecla Tab mientras el componente esté flotando en el cursor. Se abrirá el panel Properties ; introduzca la cadena del designador que desee. Haga clic en el botón de pausa superpuesto en el espacio de diseño para reanudar la colocación.
- Continúe colocando componentes o pulse Esc para finalizar la colocación.
- Pulse Spacebar para girar el arco en sentido antihorario o Shift+Spacebar para girarlo en sentido horario. Esta acción también puede realizarse mientras se arrastra el objeto. El giro se realiza en incrementos de 90°.
- Para editar el designador después de la colocación, haga doble clic en el componente colocado para abrir el panel Propiedades , donde podrá editar el designador.
Edición de las propiedades de visualización del designador
El aspecto de la cadena del designador, que incluye el tipo, el tamaño y el color de la fuente, puede configurarse en la página Esquema - Valores predeterminados del cuadro de diálogo Preferences. Estos ajustes se aplicarán a menos que se anulen mediante los ajustes definidos en el símbolo del componente en el editor de bibliotecas de esquemas.
Fijación de la ubicación de la cadena del designador
El comportamiento predeterminado del designador consiste en posicionarse automáticamente cuando se gira un componente durante su colocación. Si no necesita este comportamiento, desactive la opción Autoposition en el cuadro de diálogo Preferences (consulte la imagen anterior), ya sea durante la creación del símbolo o después de haber colocado el componente en una hoja de esquema. Tenga en cuenta que, al hacerlo, este parámetro se clasifica como manual parameter (es decir, un parámetro posicionado manualmente). Los parámetros manuales se identifican mediante un punto en la esquina inferior izquierda de su cuadro de selección.
Notas
-
El editor de esquemas incluye una función sencilla de incremento automático del designador que puede utilizarse al colocar varias instancias de un mismo componente. Para utilizarla, pulse Tab mientras el primer componente esté flotando en el cursor e introduzca un designador adecuado, por ejemplo,
R1. Los componentes siguientes se designarán entonces comoR2,R3, etc. Tenga en cuenta que, cuando pase a colocar un tipo de componente diferente, deberá pulsar de nuevo Tab e introducir un prefijo de designador adecuado. -
Al colocar componentes de varias partes y asignar el designador inicial como se acaba de describir, se asignará automáticamente un sufijo de parte, por ejemplo,
U3A,U3B, etc. Si no se asigna el designador inicial, todas las partes tendrán el mismo sufijo. Esto se resuelve mediante el comando Annotation del editor de esquemas. El sufijo de parte puede ser alfabético o numérico. Utilice la opción Alpha Numeric Suffix de la página Esquema - General del cuadro de diálogo Preferences para configurarlo.
Propiedades del designador
Ubicación
-
(X/Y)
- X (primer campo): la coordenada X (horizontal) actual del punto de referencia del objeto, con respecto al origen actual del espacio de trabajo. Edítela para cambiar la posición X del objeto. El valor puede introducirse en unidades métricas o imperiales; incluya las unidades cuando introduzca un valor cuyas unidades no sean las predeterminadas actualmente.
- Y (segundo campo): la coordenada Y (vertical) actual del punto de referencia del objeto, con respecto al origen actual. Edítela para cambiar la posición Y del objeto. El valor puede introducirse en unidades métricas o imperiales; incluya las unidades cuando introduzca un valor cuyas unidades no sean las predeterminadas actualmente.
- Rotation : utilice la lista desplegable para seleccionar el giro.
Propiedades
- Object : muestra el objeto asociado.
- Nombre : active este campo haciendo clic en el icono de visibilidad para añadir el prefijo «Designador:» al propio valor del designador. Esto permite distinguir visualmente y confirmar que el valor de texto es un designador dentro del documento de esquema.
-
Value : muestra el nombre del designador. Alterne el estado del icono del ojo
para mostrar u ocultar el valor.
- Posicionamiento automático : marque esta casilla para activar el posicionamiento automático, de modo que el texto permanezca en la posición elegida al mover y girar el componente.
- Bloquear parámetro : marque esta casilla para bloquear el parámetro, lo que impide editar su valor desde el panel Properties o desde el documento de esquema.
- Permitir sincronización con la base de datos : active esta opción para sincronizar con la base de datos. Esta opción se utiliza para controlar si el comentario puede actualizarse. De forma predeterminada, estas opciones están activadas para permitir siempre la sincronización con la biblioteca o base de datos de origen. Puede desactivar esta opción para evitar que ese comentario se incluya en un proceso de actualización.
- Fuente : utilice los controles para seleccionar la fuente, su tamaño y su color, y añadir los estilos que desee, como negrita, cursiva y subrayado.
- Alineación : haga clic en las flechas para configurar la alineación del texto o en el círculo para centrarlo.
- Override Library Primitive (solo en el cuadro de diálogo Preferences ): marque esta casilla para anular los ajustes de primitivas definidos para el objeto designador en una biblioteca. De este modo, cuando se coloque un componente, adoptará los ajustes de primitivas que haya definido en el cuadro de diálogo Preferencias, en lugar de los definidos para el componente en la biblioteca.
Comentario
Un comentario permite mostrar información adicional de un componente.
Resumen
El campo Comentario es un objeto de parámetro secundario de un componente de esquema (parte). Muestra información adicional sobre el componente.
Disponibilidad y colocación
El comentario se configura al colocar el objeto de parte del componente principal. No es un objeto de diseño que pueda colocarse directamente.
Edición gráfica
El comentario se puede editar gráficamente mediante lo que se conoce como edición in-place. Para editar un comentario directamente, haga clic una vez para seleccionarlo, espere un segundo y vuelva a hacer clic para acceder al modo de edición.
Haga clic una vez para seleccionar la cadena de texto.
Una vez finalizada la edición, pulse Enter o haga clic fuera de la cadena para salir del modo de edición directa.
Edición no gráfica
Hay dos aspectos que deben tenerse en cuenta al editar el comentario: la edición de su valor y la edición de sus propiedades de visualización.
Edición del comentario en el editor de esquemas
El comentario se puede definir en el editor de esquemas durante la colocación del componente o después de colocarlo en una hoja de esquema, en el campo Comment del panel Properties.
- Para editar el comentario durante la colocación del componente, pulse la tecla Tab mientras el componente esté unido al cursor. Se abrirá el panel Properties ; introduzca el comentario deseado. Haga clic en el botón de pausa superpuesto en el espacio de diseño para reanudar la colocación del componente.
- Continúe colocando componentes o pulse Esc para finalizar la colocación.
- Para editar el comentario después de la colocación, haga doble clic en el componente colocado para abrir el panel Propiedades , donde podrá editar el comentario.
Edición de las propiedades de visualización del comentario
El aspecto de los comentarios, que incluye el tipo, el tamaño y el color de la fuente, se puede configurar en la página Esquema - Valores predeterminados del cuadro de diálogo Preferences .
Fijación de la ubicación del comentario
De forma predeterminada, el comentario se posiciona automáticamente cuando se gira un componente durante la colocación. Si no necesita este comportamiento, desactive la opción Autoposition en el cuadro de diálogo Preferences (consulte la imagen anterior), ya sea durante la creación del símbolo o después de colocar el componente en una hoja de esquema. Tenga en cuenta que, al hacerlo, este parámetro se clasifica como manual parameter (es decir, un parámetro posicionado manualmente). Los parámetros manuales se identifican mediante un punto en la esquina inferior izquierda de su cuadro de selección.
Propiedades del comentario
Ubicación
-
(X/Y)
- X (primer campo): la coordenada X (horizontal) actual del punto de referencia del objeto, relativa al origen actual del espacio de diseño. Edítela para cambiar la posición X del objeto. El valor se puede introducir en unidades métricas o imperiales; incluya las unidades cuando introduzca un valor cuyas unidades no sean las predeterminadas actuales.
- Y (segundo campo): la coordenada Y (vertical) actual del punto de referencia del objeto, relativa al origen actual. Edítela para cambiar la posición Y del objeto. El valor se puede introducir en unidades métricas o imperiales; incluya las unidades cuando introduzca un valor cuyas unidades no sean las predeterminadas actuales.
- Rotation : utilice la lista desplegable para seleccionar la rotación. Las opciones son: 0 Degrees, 90 Degrees, 180 Degrees y 270 Degrees.
Propiedades
- Componente : muestra el nombre del componente asociado. Haga clic en el enlace Component para abrir el panel Propiedades de la pieza, donde podrá editar las opciones del componente, así como el propio comentario, que se definirá en el campo Comment de dicho panel.
- Nombre : habilite este campo haciendo clic en el icono de visibilidad para añadir el prefijo «Comentario:» al propio valor del comentario. Esto permite distinguir visualmente y confirmar que el valor de texto es un comentario dentro del documento de esquema.
-
Valor : muestra el nombre del comentario. Alterne el estado de para mostrar u ocultar el valor.
- Posicionamiento automático : marque esta casilla para habilitar el posicionamiento automático, de modo que el texto permanezca en la posición elegida cuando el componente se mueva y gire.
- Bloquear parámetro : marque esta casilla para bloquear el parámetro, lo que impide editar el valor desde el panel Properties o el documento de esquema.
- Permitir sincronización con la base de datos : habilite esta opción para sincronizar con la base de datos. Esta opción se utiliza para controlar si el comentario se puede actualizar. De forma predeterminada, esta opción está habilitada para permitir siempre la sincronización con la biblioteca o base de datos de origen. Puede deshabilitar esta opción para evitar que el comentario se incluya en un proceso de actualización.
- Fuente : utilice los controles para seleccionar la fuente, su tamaño y su color, y añadir las características especiales que desee, como negrita, cursiva y subrayado.
- Alineación : haga clic en las flechas para configurar la alineación del texto o en el círculo para centrarlo.
- Override Library Primitive (solo en el cuadro de diálogo Preferences ): marque esta casilla para anular la configuración de primitivas definida para el objeto de comentario en una biblioteca. Por lo tanto, al colocar un componente, este adoptará la configuración de primitivas que haya definido en el cuadro de diálogo Preferences, en lugar de la definida para el componente en la biblioteca.
Actualización y sustitución de componentes desde una biblioteca
Una vez colocados inicialmente los componentes en las hojas de esquema del diseño de una placa, se necesita algún método para actualizar esas instancias de componentes con los cambios realizados en sus componentes de origen vinculados en el espacio de trabajo correspondiente. En otras palabras, una forma de mantener el diseño sincronizado con las entidades del espacio de trabajo que utiliza.
Por ejemplo, puede que un componente se haya vuelto a guardar en el espacio de trabajo, quizá para reflejar un cambio en un modelo secundario. Esto genera una nueva revisión de ese componente. La instancia colocada de dicho componente utiliza ahora una revisión anterior y quizá desee actualizarla para que utilice la revisión más reciente. También es posible que haya decidido utilizar un componente completamente distinto y solo necesite sustituir el componente existente en el diseño por otro alternativo.
Existen varios métodos para gestionar los componentes después de su colocación inicial en un diseño.
Cambio de una instancia individual de un componente
Cada componente colocado tiene un vínculo a la revisión del componente en el espacio de trabajo. Esta información se encuentra en el panel Propiedades, al consultar las propiedades del componente seleccionado.
Cada instancia colocada de un componente tiene un vínculo a la revisión específica de ese componente en el espacio de trabajo.
En este nivel básico de componente individual, la instancia colocada se puede:
-
Actualizar a la última revisión del componente existente haciendo clic en el botón
.
Ejemplo de actualización del mismo componente a su última revisión: pase el cursor sobre la imagen para ver el resultado.
-
Sustituir por la última revisión de otro componente del espacio de trabajo (un sustituto) o por un componente de una biblioteca basada en archivos haciendo clic en el botón
, a la derecha del campo Design Item ID. Se abrirá el cuadro de diálogo Replace Component, que muestra los componentes del espacio de trabajo conectado y de las bibliotecas basadas en archivos disponibles. El componente actual se muestra al principio de la lista. Busque el componente de sustitución que necesite, selecciónelo y haga clic en OK.
Ejemplo de sustitución del componente existente por otro diferente (una alternativa)
El cuadro de diálogo Replace Component proporciona acceso directo a todos los componentes disponibles de las bibliotecas del espacio de trabajo y de las bibliotecas basadas en archivos. El cuadro de diálogo ofrece información completa sobre el componente seleccionado (parámetros, modelos, opciones de piezas, datos de proveedores, etc.), comparación de componentes y, para los componentes de bibliotecas del espacio de trabajo, una función de búsqueda paramétrica basada en filtros que permite especificar los parámetros deseados del componente.
Opciones y controles del cuadro de diálogo Sustituir componente
- Search - utilice el cuadro de texto de búsqueda para buscar manualmente un componente específico.
-
- haga clic para expandir o contraer el Categories panel, para mostrar determinados tipos de componentes o todos los componentes disponibles. Utilice la barra de búsqueda situada debajo del Categories panel para buscar manualmente una categoría específica de componentes o una biblioteca de componentes basada en archivos disponible.
-
- haga clic para acceder a un menú y seleccionar entre las siguientes opciones:
- File-based Libraries Preferences - haga clic para abrir el cuadro de diálogo Bibliotecas basadas en archivos disponibles y añadir o eliminar bibliotecas.
- File-based Libraries Search - haga clic para abrir el cuadro de diálogo Búsqueda de bibliotecas basadas en archivos y buscar bibliotecas.
- Refresh - haga clic para actualizar el cuadro de diálogo.
-
- haga clic para abrir o cerrar la Details región del cuadro de diálogo (descrita a continuación).
Filtros
Cuando se selecciona una categoría de componentes del espacio de trabajo, haga clic en el icono Filters para abrir la región Filters, donde podrá filtrar con mayor precisión las categorías seleccionadas en la lista Components . Las opciones del panel Filters se pueden adaptar a sus necesidades seleccionando determinados tipos de parámetros como Favorites, que pasarán al principio de la lista para la categoría de componentes actual. Pase el cursor a la derecha del nombre de un filtro de parámetros y haga clic en el icono para establecerlo como favorito. Los ajustes de los filtros favoritos se aplican y se guardan para cada Categories de componentes.
Componentes
- Name - el nombre del componente.
- Description - la descripción de cada componente.
- Footprint - la huella del componente.
- Results - muestra el número total de componentes encontrados o incluidos en la búsqueda.
Detalles
- Component Revision ID - muestra el ID de revisión y el precio de un componente determinado. Haga clic en el ID de revisión para abrir el panel Explorador y obtener más información sobre un componente.
- References - haga clic para abrir la información de referencia del componente en un navegador web. Utilice el menú desplegable para acceder a Manufacturer URL o Datasheet.
- Place - haga clic para colocar el componente seleccionado en un documento de esquema.
- Component information - muestra información relevante sobre el componente, incluidos el fabricante, la fecha de lanzamiento y la descripción. Haga clic en el vínculo Show More para ver toda la información; haga clic en Show Less para contraerla.
- Models - expanda para ver los modelos proporcionados. Utilice los vínculos disponibles para mostrar distintas partes de un mismo modelo.
- References - expanda para acceder a Manufacturer URL, Datasheet y Package Specification.
- Part Choices - expanda para ver las opciones de piezas. Se proporciona un nombre, un precio y una descripción. También se mostrará la hoja de datos del componente.
- Where Used - expanda para ver los proyectos que utilizan el componente.
Menú contextual
- Find Similar Components - haga clic para abrir el cuadro de diálogo Buscar componentes similares, donde podrá buscar otros componentes con características similares.
- Place <component> - haga clic para colocar el componente en el documento correspondiente.
- Edit - haga clic para abrir los documentos de biblioteca del componente seleccionado.
- Navigate to <revision> - haga clic para abrir el componente seleccionado en el panel Explorador.
- Operations - pase el cursor para acceder a las opciones Submit Request, Create, Download, Clone, Change Component Type, Create / Edit PCL y Full Item History.
- Refresh- haga clic para actualizar y ver las actualizaciones o modificaciones recientes. También puede actualizar mediante el atajo F5.
- Library Report - cuando se selecciona una biblioteca basada en archivos en el panel Categories, haga clic para acceder al cuadro de diálogo Configuración del informe de biblioteca, en el que puede utilizar los controles disponibles para configurar un informe de biblioteca.
Cambios de componentes por lotes: el Administrador de elementos
Related page: Gestión de contenido con el Administrador de elementos
La modificación individual de componentes resulta útil, pero pronto se vuelve tediosa cuando se trabaja con un número considerable de componentes. Para ello, necesita un único lugar centralizado desde el que realizar varios cambios por lotes. Aquí es donde entra en juego el Administrador de elementos (Tools » Item Manager).
El Item Manager es el «centro de control» para sincronizar las entidades de diseño de Workspace —colocadas en hojas de esquemático— con el contenido de origen al que están vinculadas en un Workspace. Detecta y enumera automáticamente todos los componentes, indica si son entidades de Workspace o no y, a continuación, compara la revisión del elemento de cada componente de Workspace presente en los esquemáticos con las revisiones disponibles de ese componente en el Workspace. Para cada entidad, se proporciona información sobre el elemento vinculado actualmente: su revisión, su estado del ciclo de vida y el Workspace de origen en el que reside.
Tiene pleno control sobre cuáles de estas entidades de Workspace se actualizan y cómo. Por ejemplo:
- Seleccione una entrada individual y actualícela para utilizar la última revisión del elemento vinculado, o elija utilizar la última revisión de un elemento completamente diferente.
- Seleccione un grupo de entradas que utilicen el mismo elemento vinculado y actualícelas a la última revisión de ese elemento, o elija utilizar la última revisión de un elemento completamente diferente.
Todos los cambios propuestos se reflejan en el administrador.
Una vez configurados los cambios según sus necesidades, genere una orden de cambio de ingeniería (ECO) y revise las acciones que se realizarán para implementar esos cambios. Desactive cualquier acción si es necesario: ¡usted siempre tiene el control! Cuando esté listo, ejecute la ECO y se aplicarán los cambios. Gestione el contenido de Workspace colocado en su diseño de forma rápida, eficiente y sencilla.
Los siguientes ejemplos ilustran el uso del Item Manager:
- Actualizar varios componentes para utilizar la última revisión del componente de Workspace existente.

Actualice un grupo de componentes desactualizados a sus últimas revisiones.
- Sustituir un par de componentes por la última revisión de un componente de Workspace diferente, elegido mediante el cuadro de diálogo Reemplazar componente.

Reemplace uno o varios componentes por un componente de Workspace diferente.
El Item Manager no solo permite mantener los componentes de sus diseños sincronizados con los cambios en el contenido de origen de los Workspaces conectados, sino que también es una potente herramienta para facilitar la migración de sus diseños de placa existentes: de utilizar elementos de diseño locales a utilizar contenido de diseño de Workspace. Una vez que haya migrado los componentes de su diseño a un Workspace, así como las hojas de esquemático (hojas de dispositivo), utilice el Item Manager para «reemplazar» los componentes y símbolos de hoja existentes por sus versiones recién migradas al Workspace. En otras palabras, los componentes siguen siendo los mismos desde la perspectiva del diseño, pero cambia su origen.
Cambiar un componente desde un BomDoc
Es habitual detectar un problema con un componente al revisar el BomDoc y prepararlo para pedir las piezas. Por ejemplo, puede que el diseñador haya olvidado finalizar la selección de un componente, o que un componente haya llegado al final de su vida útil (EOL) y el diseñador quiera consultar el precio y la disponibilidad de posibles sustitutos. Aunque podría resolverlo volviendo al esquemático y editando el componente, seleccionando una pieza adecuada y actualizando después el BomDoc, ActiveBOM permite hacerlo directamente desde el BomDoc y, a continuación, transferir ese cambio al esquemático mediante una orden de cambio de ingeniería.
Desde el BomDoc, haga clic con el botón derecho en los componentes seleccionados y seleccione el comando Operations » Change <ComponentName>. Se abrirá el cuadro de diálogo Reemplazar componente, desde el que podrá buscar el componente de sustitución. Cuando encuentre el componente de sustitución deseado, selecciónelo y haga clic en OK. Se abrirá el cuadro de diálogo Engineering Change Order, que detalla los cambios necesarios para sincronizar el esquemático con el BomDoc.

Ejemplo de sustitución de un componente directamente desde un BomDoc.
Reemplazar un componente genérico
Cuando un diseño haya avanzado hasta el punto en que un componente genérico pueda sustituirse por un componente físico específico, abra el cuadro de diálogo Reemplazar componente seleccionando el botón
en el panel Properties. Tenga en cuenta que también puede hacerlo desde el Administrador de elementos o mediante el documento ActiveBOM del proyecto.
Los valores de los parámetros que se hayan aplicado al componente genérico (en este caso, los valores de potencia y resistencia) se utilizan automáticamente como términos de búsqueda en el cuadro de diálogo Replace Generic Component, lo que permite elegir un componente de sustitución adecuado entre los resultados filtrados. En este ejemplo, dos entradas de componentes cumplen los criterios de búsqueda.
|
Reemplazar un componente genérico mediante el panel Properties. Reemplazar un componente genérico mediante el panel Properties. |
Gestionar las huellas en todo el diseño
El editor de esquemáticos de Altium Designer incluye un potente Footprint Manager. Se abre desde el menú Herramientas del editor de esquemáticos (Tools » Footprint Manager) y permite, mediante el Footprint Manager, revisar todas las huellas asociadas a cada componente de todo el proyecto. La compatibilidad con la selección múltiple facilita editar la asignación de huellas de varios componentes, cambiar la forma en que se vincula la huella o cambiar la huella asignada actualmente a los componentes que tienen varias huellas asignadas. El Footprint Manager facilita la revisión y detección de problemas con las asignaciones de huellas en todo el diseño, lo que resulta especialmente útil cuando se trabaja en un diseño heredado o procedente de otra organización. Los cambios de diseño se aplican mediante el sistema ECO, que actualiza tanto el esquemático como la PCB si es necesario.
El cuadro de diálogo Footprint Manager presenta una lista de todos los componentes de todos los esquemáticos de origen del proyecto activo. Utilice los controles disponibles en el lado derecho del cuadro de diálogo para gestionar las huellas disponibles para los componentes del diseño y las que estos utilizan actualmente. Sus funciones incluyen:
- La posibilidad de añadir, editar y eliminar modelos de huella para uno o varios componentes seleccionados.
- Copiar huellas entre componentes.
- Cambiar la huella asignada actualmente (la huella que se utilizará para representar un componente en el entorno de PCB, de entre las distintas huellas que pueda tener disponibles ese componente).
- Validar las huellas para garantizar que los modelos de huella estén realmente disponibles, especialmente los establecidos como modelo actual.
Una vez realizados todos los cambios necesarios en las asignaciones de modelos de huella, estos se implementan mediante una orden de cambio de ingeniería (ECO) estándar. Para ello, simplemente haga clic en el botón Accept Changes (Create ECO), situado en la esquina inferior derecha del cuadro de diálogo Footprint Manager.
Opciones y controles del cuadro de diálogo Administrador de huellas
Lista de componentes
Esta es una lista de todos los componentes de las hojas de esquemático del proyecto de diseño de PCB activo. La información incluye:
- Designator
- Comment
- Current Footprint
- Design Item ID
- Part Count
- Sheet Name
Ver y editar huellas
Esta es una lista de las huellas asociadas al componente seleccionado en Component List. Utilice los controles de la parte inferior del área o los comandos del menú contextual para gestionar las huellas de la lista.
Menú contextual
-
Add - haga clic para abrir el cuadro de diálogo Modelo de PCB y elegir un nuevo modelo de huella que añadir al componente de esquemático resaltado. No está disponible cuando se selecciona un componente gestionado.
-
Remove - haga clic para eliminar la huella seleccionada. No está disponible cuando se selecciona un componente gestionado.
-
Edit Footprint - haga clic para abrir el cuadro de diálogo Modelo de PCB. El cuadro de diálogo PCB Model define qué modelo de huella está vinculado al componente de esquemático y en qué bibliotecas puede buscar la huella el editor de esquemáticos. No está disponible cuando se selecciona un componente gestionado.
-
Validate Footprint Paths - haga clic para confirmar que la huella resaltada se encuentra en la ubicación permitida. Si no se encuentra la huella, aparece Not Validated en el campo Found In. Si la huella se valida, se muestra su ruta completa.
-
Change PCB Library - haga clic para abrir el cuadro de diálogo Edit PCB Library y cambiar la biblioteca de PCB de la huella seleccionada. Este cuadro de diálogo es una versión simplificada del cuadro de diálogo PCB Model y permite acceder a las opciones de PCB Library para definir dónde puede buscar modelos de huella el software.

El cuadro de diálogo Edit PCB Library- Any - busca un modelo coincidente en todas las bibliotecas disponibles.
- Library name - busca un modelo coincidente únicamente en las bibliotecas disponibles con este nombre.
- Library path - busca un modelo coincidente únicamente en una biblioteca con este nombre y en esta ubicación. Escriba manualmente la ruta y el nombre de la biblioteca, o haga clic en el botón Choose para abrir el cuadro de diálogo Open de Windows, que le permite buscar la biblioteca necesaria.
- Use footprint from source integrated library, database library, or server - busca el modelo únicamente en la biblioteca integrada, la biblioteca de base de datos o el servidor desde el que se colocó el componente. La biblioteca integrada o de base de datos debe estar disponible o, en el caso de un servidor, debe estar conectado a él.
-
Copy - haga clic para copiar los detalles de la huella seleccionada.
-
Paste - haga clic para pegar (añadir) los detalles de la huella copiada en el componente de esquemático seleccionado.
-
Select All - haga clic para seleccionar todas las huellas visibles en la lista View and Edit Footprints.
-
Set As Current - haga clic para establecer la huella seleccionada como huella actual (indicada mediante un
en la columna Current ).
-
Add to All Parts - haga clic para añadir la huella seleccionada a todas las demás partes del mismo componente de esquemático (este comando solo está disponible si el componente seleccionado es un componente de varias partes y una o más de sus partes no tienen especificada esta huella).
Controles adicionales
-
Menu - haga clic para ver un menú con los mismos controles que el menú contextual anterior.
-
Add, Remove, Edit, Validate - estos botones realizan las mismas funciones que las opciones de menú descritas anteriormente.
-
Accept Changes (Create ECO) - haga clic para aceptar los cambios en los componentes de esquemático y sus modelos de huella vinculados y abrir el cuadro de diálogo Engineering Change Order. En el cuadro de diálogo ECO, puede validar y ejecutar los cambios después de revisar las modificaciones realizadas en los valores de huella de los componentes de esquemático correspondientes.












