Création du document BOM

En un coup d'œil

Cet article vous explique comment créer et utiliser le document ActiveBOM, ou BomDoc, dans Altium Designer, en commençant par son ajout à un projet et la manière dont il compile et intègre automatiquement les composants du projet. Il vous donne également un aperçu pratique de la liste des éléments de nomenclature, des modes d’affichage disponibles, des fonctions courantes de modification et de filtrage, du regroupement des composants identiques, de l’organisation des colonnes et de l’ajout d’éléments et de colonnes de nomenclature personnalisés pour les pièces qui ne sont pas directement placées dans la conception. Si vous souhaitez découvrir clairement comment configurer ActiveBOM et vous y repérer afin de gérer plus efficacement la nomenclature de votre projet, poursuivez votre lecture et passez à l’étape suivante en toute confiance.

- Vous apprendrez à créer un BomDoc, découvrirez ce qui se passe lorsqu’il est ajouté à un projet et comprendrez une limitation essentielle : un seul BomDoc est autorisé par projet.
- Vous découvrirez l’organisation de la liste des éléments de nomenclature, notamment les modes d’affichage, les commandes de gestion des colonnes, les outils de modification, le fonctionnement du regroupement et les options de configuration de l’affichage.
- Vous comprendrez comment ActiveBOM gère les composants regroupés et les entrées de nomenclature personnalisées, afin de prendre en compte aussi bien les composants de la conception que les éléments supplémentaires du projet.
Approfondissez avec l'IA :

Création du document de nomenclature

Le document de nomenclature de travail d’ActiveBOM est appelé BomDoc. Ajoutez un nouveau BomDoc au projet via le sous-menu File » New ou en faisant un clic droit sur le projet dans le panneau Projects. Lorsque le projet contient au moins un composant, vous pouvez créer un nouveau BomDoc en cliquant sur la commande + Create située à côté de l’entrée ActiveBOM dans la structure du projet, dans le panneau Projects. Notez que chaque projet PCB ne peut contenir qu’un seul BomDoc.

La commande + Create est disponible lorsque l’option BOM.ActiveBOMDesignPreview est activée dans la boîte de dialogue Advanced Settings.

Lorsque vous ajoutez un nouveau BomDoc à votre projet, le schéma est automatiquement compilé et tous les composants existants sont répertoriés dans le BomDoc. Pour les composants de la bibliothèque de l’espace de travail qui incluent des choix de pièces, les solutions sont détaillées dans la partie inférieure de l’interface, comme expliqué dans la section Comprendre la solution ci-dessous.

À mesure que des composants supplémentaires sont placés sur le schéma, ils sont automatiquement ajoutés au BomDoc. Des éléments de nomenclature et des paramètres supplémentaires peuvent également être ajoutés manuellement directement dans ActiveBOM via le bouton Add new situé au-dessus de la liste des composants. Consultez la section Éléments et colonnes de nomenclature personnalisés pour en savoir plus.

  • À l’ouverture du BomDoc, le projet est automatiquement compilé, et la liste des pièces de la conception ainsi que leurs informations d’approvisionnement sont actualisées. Cette opération peut prendre un certain temps lors de la première ouverture d’une conception volumineuse et peut entraîner le marquage du BomDoc comme fichier modifié, alors qu’il vient simplement d’être ouvert.
  • Le BomDoc est automatiquement actualisé lors de son activation si le projet contient des composants modifiés et enregistrés dans l’espace de travail connecté. La colonne Revision Status affiche l’état Out of date des composants modifiés, afin que vous puissiez immédiatement identifier ceux qui doivent être mis à jour vers leurs dernières révisions. 
  • Chaque projet de conception ne peut contenir qu’un seul BomDoc.

La liste des éléments de nomenclature

La partie supérieure du BomDoc présente, sous forme de tableau, tous les composants détectés dans le projet de conception PCB, ainsi que les éléments de nomenclature supplémentaires que vous avez ajoutés directement au BomDoc. Cette zone est appelée liste des éléments de nomenclature.

La liste des composants, ou des éléments de nomenclature, affichée dans la vue de base.
La liste des composants, ou des éléments de nomenclature, affichée dans la vue de base.

Trois modes d’affichage sont disponibles pour présenter les éléments de nomenclature. Sélectionnez le mode souhaité à l’aide des boutons situés au-dessus de la liste :

Flat view button, click to display each BOM Item in its own row in the BOM Item list  Flat view - une ligne pour chaque composant.

Base view button, click to cluster common BOM Items into the same row in the BOM Item list Base view - une ligne pour chaque composant unique du projet ; la colonne Designator répertorie les repères de tous les composants de ce type. Plusieurs options de présentation sont disponibles pour les repères regroupés. Sélectionnez le mode Designator Grouping souhaité dans le panneau Properties.

Consolidated view button, click to display a consolidated BOM when the project includes variants Consolidated view - utilisé lorsque le projet comprend des variantes pour afficher une nomenclature consolidée de toutes les variantes.

Fonctions de modification de la liste des éléments de nomenclature

La liste des composants propose plusieurs fonctions de modification similaires à celles d’un tableur, notamment :

  • Utilisez l’onglet Column du panneau Properties pour afficher ou masquer une colonne et définir un alias pour son nom. Vous pouvez également définir un alias dans la boîte de dialogue Enter Column Properties, accessible en faisant un clic droit sur un nom de colonne dans la zone d’en-tête des colonnes du BomDoc, puis en sélectionnant la commande Rename Column dans le menu contextuel. Notez que l’alias est utilisé comme nom de colonne dans les nomenclatures générées.
  • Vous pouvez également ajouter et supprimer des colonnes à l’aide de la boîte de dialogue Select Columns, accessible en faisant un clic droit sur un nom de colonne dans la zone d’en-tête des colonnes du BomDoc, puis en choisissant Select Columns.

    La boîte de dialogue Select Columns
    La boîte de dialogue Select Columns

    Si vous utilisez les fonctionnalités d’intégration SiliconExpert ou Z2Data, vous pouvez également sélectionner des colonnes de paramètres SiliconExpert ou Z2Data, respectivement. Consultez les pages Récupération des données de pièces depuis SiliconExpert et Récupération des données de pièces depuis Z2Data pour en savoir plus.
  • Faites glisser les colonnes pour modifier leur ordre.
  • Triez selon n’importe quelle colonne et maintenez la touche Shift enfoncée pour effectuer un tri secondaire sur une ou plusieurs autres colonnes.
  • Cliquez sur l’icône de filtre pour filtrer selon les valeurs des colonnes. Grid displays include a Filter icon, click this to configure filtering based on values present in this column
  • Sélectionnez des cellules à l’aide des méthodes de sélection standard de Windows.
  • Copiez le contenu des cellules depuis ActiveBOM et collez des valeurs provenant d’un tableur externe dans des colonnes ActiveBOM personnalisées.
  • Des numéros de ligne configurables par l’utilisateur peuvent être définis lorsque la nomenclature est en vue de base. Dans la vue de base, cliquez sur le bouton Set line numbers (Set Line Numbers button, click the arrow to configure line numbering) pour ajouter un numéro de ligne à chaque ligne. Cliquez sur l’icône de liste déroulante à droite du bouton pour ouvrir la boîte de dialogue Line # Options, dans laquelle vous pouvez définir la valeur de départ et l’incrément. Consultez la section Colonne de numéros de ligne pour en savoir plus.
  • Cliquez sur la liste déroulante Add New (Add new button, click to add an additonal row or column to the BomDoc) pour ajouter des lignes ou des colonnes supplémentaires. Consultez la section Éléments et colonnes de nomenclature personnalisés pour en savoir plus.
  • Cliquez sur le bouton Group by (Group by button, use this to group the grid by the enabled column) pour regrouper la grille selon la colonne activée. Plusieurs colonnes de regroupement peuvent être activées (voir l’image) et leur ordre peut être modifié par glisser-déposer. Il s’agit d’une fonction d’affichage de la grille : le regroupement n’est pas transféré à la boîte de dialogue Report Manager lors de l’exécution de la commande Bill of Materials.
  • Cliquez sur le bouton Reset Supply Chain () pour supprimer le classement des solutions défini par l'utilisateur et les priorités SPN attribuées manuellement aux éléments de nomenclature sélectionnés.
  • La configuration actuelle de la grille des éléments de nomenclature peut être enregistrée sous forme d'un jeu de nomenclature. Consultez la section Configuration et enregistrement de l'affichage de la grille des éléments de nomenclature pour en savoir plus.
  • Utilisez les raccourcis Windows standard pour faire défiler la liste des éléments de nomenclature :
    • Défilement vertical = MouseWheel Roll
    • Défilement horizontal = Shift + MouseWheel Roll

De nombreuses options de configuration et d'affichage de la nomenclature se définissent dans le panneau Properties d'ActiveBOM.

Identification des composants identiques

Pour pouvoir regrouper les composants identiques dans les vues de base et consolidée, ActiveBOM utilise les mécanismes suivants :

  • Pour les composants de la bibliothèque de l'espace de travail : selon DesignItemID.
  • Pour les composants ne provenant pas de la bibliothèque de l'espace de travail : selon DesignItemID et Library Name, ainsi que selon les paramètres de composant activés dans la boîte de dialogue Component Grouping. Cette approche permet aux concepteurs de créer dans la bibliothèque des composants génériques ne provenant pas de la bibliothèque de l'espace de travail, puis de renseigner leurs caractéristiques spécifiques après leur placement. Les paramètres activés par défaut dans la boîte de dialogue Component Grouping sont Comment, Description et Value. Cliquez sur le bouton Component Grouping Edit dans le panneau Properties d'ActiveBOM pour ouvrir la boîte de dialogue. Notez que ce bouton n'est disponible que si la conception contient des composants ne provenant pas de la bibliothèque de l'espace de travail.

Remarques sur le regroupement des composants :

  • La boîte de dialogue Component Grouping permet d'identifier les composants identiques afin de les regrouper. Bien que d'autres paramètres ou propriétés, tels que les propriétés des composants PCB, puissent figurer dans la boîte de dialogue Component Grouping, seuls les paramètres de composant peuvent servir à définir les composants identiques.
  • Si vous souhaitez regrouper des composants dans le BomDoc ou dans une nomenclature personnalisée à d'autres fins, par exemple pour regrouper les composants de la face supérieure et ceux de la face inférieure, passez à la vue Liste, puis utilisez le bouton Group by dans ActiveBOM (voir l'image), ou utilisez la fonction de regroupement par colonne dans Report Manager (voir l'image). Les paramètres disponibles dans la liste déroulante Group by d'ActiveBOM sont ceux dont la visibilité est actuellement activée dans l'onglet Columns du panneau Properties.

Les groupes de colonnes

La liste des composants d'ActiveBOM comporte des groupes de colonnes distincts dans chaque mode d'affichage. L'image ci-dessus présente la vue de base.
La liste des composants d'ActiveBOM comporte des groupes de colonnes distincts dans chaque mode d'affichage. L'image ci-dessus présente la vue de base.

La grille des éléments de nomenclature est organisée selon les principaux groupes suivants :

  1. Item Details (surligné en orange dans l'image) : ces colonnes affichent les caractéristiques des composants, telles que le repère, la description, la référence de bibliothèque et d'autres paramètres de composant.
  2. Solutions (surligné en vert dans l'image) : le fabricant et le ou les fournisseurs les mieux classés de la chaîne d'approvisionnement. Le nombre de solutions (références fabricant) et le nombre de fournisseurs pour chaque solution sont configurés dans le panneau Properties d'ActiveBOM. Ils sont signalés par un bandeau de couleur unie dans la vignette du fournisseur. Le classement est automatique, mais peut également être défini manuellement, comme expliqué dans la section Comprendre la solution ci-dessous.
  3. BOM Status (surligné en cyan dans l'image) : une indication du risque actuel associé à chaque composant. Survolez une icône pour afficher une description ou activez la colonne détaillée BOM Status dans le panneau Properties pour afficher cette description.
Dans la vue consolidée, un groupe supplémentaire, intitulé Variants, est ajouté juste avant la colonne d'état de la nomenclature. Ce groupe comprend une paire de colonnes pour chaque variante, affichant la quantité et le prix unitaire de chaque composant (voir l'image). Consultez la section Utilisation des variantes pour en savoir plus.
L'affichage des colonnes et la définition des alias peuvent être gérés dans la section Columns du panneau Properties d'ActiveBOM. Pour ajouter une ligne, un composant ou une colonne personnalisés, cliquez sur le bouton Add new situé au-dessus de la liste des composants.

Éléments et colonnes de nomenclature personnalisés

Image showing a custom row being added to a BomDoc

La gestion de la nomenclature d'un projet de conception de PCB nécessite de gérer des composants et des éléments de nomenclature autres que ceux placés dans le schéma et sur le PCB, par exemple des pièces dont les caractéristiques restent à préciser, des fixations, le circuit imprimé nu ou la colle de montage. Dans de nombreux cas, des éléments de nomenclature ou des paramètres personnalisés sont utilisés dans le projet de conception de PCB. Pour ces situations, ActiveBOM permet d'ajouter des éléments de nomenclature et des colonnes (paramètres) supplémentaires, qui peuvent ensuite être inclus dans la nomenclature générée :

  • Custom row -  un moyen simple d'ajouter un élément de nomenclature personnalisé à prendre en compte dans la conception (circuit imprimé nu, colle, etc.). Tous les champs d'une ligne personnalisée sont définis par l'utilisateur. Les lignes personnalisées ne sont pas gérées par ActiveBOM : par exemple, si la quantité est définie sur 3, la vue à plat n'affichera pas 3 éléments distincts. La recherche dans la chaîne d'approvisionnement n'est pas non plus prise en charge pour les lignes personnalisées.
  • Custom column - une colonne de nomenclature supplémentaire, gérée dans ActiveBOM, pouvant contenir n'importe quel texte défini par l'utilisateur.
  • Custom Item - un élément de nomenclature supplémentaire, généralement destiné aux éléments qui seront nécessaires, mais dont les caractéristiques ne sont pas encore entièrement connues ou qui n'existent pas encore dans la bibliothèque. Cela permet d'inclure leur coût dans l'estimation du coût global de la carte.
  • Managed Component - un élément de nomenclature supplémentaire, géré manuellement dans le document de nomenclature. La boîte de dialogue Component Search s'ouvre et répertorie les composants de l'espace de travail actuellement connecté.

    La boîte de dialogue Component Search utilise les fonctionnalités de base du moteur de recherche et le mode d'affichage employés dans le panneau Manufacturer Part Search. Alors que le panneau Manufacturer Part Search exploite le service Altium Parts Provider et se concentre sur la recherche de données concernant les fabricants et les fournisseurs de composants, la boîte de dialogue Component Search présente des composants prêts à être placés, issus de la bibliothèque de votre espace de travail et de bibliothèques basées sur des fichiers.

    L’élément de nomenclature supplémentaire choisi peut être modifié à tout moment via le sous-menu contextuel Operations.
    • Utilisez l’onglet Column du panneau Properties pour rechercher, afficher et gérer rapidement la visibilité, le nom ou les alias des colonnes. Lorsqu’un alias est défini pour un nom de colonne, il s’affiche dans la grille des éléments de nomenclature.
    • Tous les éléments de nomenclature et paramètres supplémentaires ajoutés dans ActiveBOM sont disponibles pour les autres sorties de nomenclature, ainsi que via l’API du logiciel.
Les champs d’une ligne, d’une colonne ou d’un élément personnalisé ne peuvent être modifiés que lorsque le document ActiveBOM est en mode Vue de base.

 

Ajout d’instances d’un composant géré ou d’un élément personnalisé

Après avoir ajouté un composant géré ou un élément personnalisé, faites un clic droit dessus et sélectionnez la commande Operations » Add Instances of pour accéder à la boîte de dialogue Add to BOM Components. Utilisez cette boîte de dialogue pour définir le nombre d’instances du composant à ajouter à la nomenclature.

Indiquez Designator prefix, le paramètre facultatif Separator (qui peut être défini pour obtenir des résultats tels que X-1 ou X:1) et Quantity de composants requis (cette valeur sert à définir la plage de désignateurs et apparaît également dans la colonne Quantity d’ActiveBOM). Tous les autres paramètres, tels que la description, peuvent être modifiés directement dans la grille des éléments de nomenclature.

Modification/suppression d’un composant géré ou d’un élément personnalisé

Pour modifier le désignateur ou supprimer une instance d’un composant géré ou d’un élément personnalisé, faites un clic droit dessus et sélectionnez la commande Operations » Edit item. La boîte de dialogue Change / Remove s’ouvre.

Sources de données

Les sources de données disponibles par défaut dans ActiveBOM sont les paramètres des composants du schéma (Icon indicating that this parameter was sourced from a schematic component), les paramètres des composants de l’espace de travail pour le contenu de l’espace de travail (Icon indicating that this parameter was sourced from a Workspace Library component stored) et les données fournies par ActiveBOM (Icon indicating that this parameter was sourced from the ActiveBOM document (BomDoc)). À partir de ces sources, ActiveBOM génère la grille principale des éléments de nomenclature du projet. Les sources de données sont activées et leur affichage est contrôlé dans l’onglet Columns du panneau Propriétés d’ActiveBOM.

En activant le bouton Sources correspondant (au-dessus de la liste des colonnes), la nomenclature peut également inclure des informations provenant des sources de données supplémentaires suivantes :

Click the PCB source button to include parameters from the PCB The PCB - activez ces options pour inclure les données de position, de rotation et de face du PCB dans les Columns disponibles, pour chacun des composants. Si le projet contient plusieurs documents PCB, la boîte de dialogue Choisir le PCB à utiliser s’ouvre pour vous permettre de sélectionner le PCB souhaité.

Click the Database source button to include parameters from the database (database components only) Database - pour charger des paramètres de composants supplémentaires à partir d’une base de données externe (via *.DbLib, *.SVNDbLib ou *.DbLink).

Click the Altium Cloud Services source button to include parameters from the Altium Parts Provider Altium Cloud Services - activez cette option pour accéder à un large éventail de données supplémentaires sur les composants, pour les éléments de nomenclature identifiés par Altium Parts Provider et présentant une solution d’approvisionnement.

Click the Document Parameters source button to include parameters from the project schematic documents Document Parameters - activez cette option pour inclure tous les paramètres de documents schématiques détectés dans l’ensemble des schémas du projet PCB dans les Columns disponibles.

La source de chaque paramètre est indiquée par l’icône dans la liste des colonnes.
La source de chaque paramètre est indiquée par l’icône dans la liste des colonnes.

  • Les boutons situés au-dessus de la liste des colonnes permettent d’activer ou de désactiver la source de données correspondante. Si une source est désactivée, toutes les données provenant de cette source sont supprimées de la grille.
  • Les cases à cocher sous la liste Columns constituent des filtres pratiques pour cette liste. Utilisez-les pour ajouter ou supprimer une source de données dans la liste Columns, sans supprimer les données de la grille.

Outre l’utilisation d’Altium Parts Provider, il est également possible de se connecter à une base de données d’entreprise existante via une connexion ODBC. Pour cela, activez la fonctionnalité Custom Parts Provider Synchronization dans Altium Designer (sélectionnez l’option Custom Data Synchronization sur la page Configure Platform (sous Importers\Exporters)), puis activez-la en tant que fournisseur sur la page Data Management - Parts Providers de la boîte de dialogue Preferences . Cette fonctionnalité permet à la base de données d’entreprise de se comporter comme un fournisseur de composants du Workspace.

Pour en savoir plus, consultez les informations sur les fournisseurs de composants basés sur une base de données personnalisée sur la page Part Source Configuration (Altium 365 Workspace, Enterprise Server Workspace).

Colonne des numéros de ligne

Pour les conceptions de circuits imprimés accompagnées de plans d’assemblage, ou pour l’échange de données de nomenclature entre ingénieurs de conception, ingénieurs chargés des coûts et spécialistes des achats, le numéro de ligne de nomenclature (numéro de position de l’élément de nomenclature) constitue un moyen simple de distinguer individuellement les lignes de nomenclature. Il peut ensuite être utilisé pour identifier explicitement ou find le repère, le composant et sa représentation correspondants dans la conception.

En tant que source des données de nomenclature du projet, ActiveBOM prend en charge les numéros de ligne définis par l’utilisateur pour la nomenclature du projet et propose des fonctions de gestion manuelle et automatique de ces numéros (numéros de position des éléments de nomenclature).

  • Pour définir automatiquement le numéro de position de tous les éléments de nomenclature du projet (en mode Base), cliquez sur le bouton Set Line # . Les numéros de ligne s’affichent dans la colonne Line #, dans le groupe de colonnes Item Details. Cliquez sur l’icône de liste déroulante à droite du bouton pour ouvrir la boîte de dialogue Line # Options, dans laquelle vous pouvez définir les valeurs de départ et d’incrément.

    La boîte de dialogue Line Number Options
    La boîte de dialogue Line Number Options

    • Start number - la valeur à utiliser si la première cellule Line # est vide.
    • Increment - incrémenter chaque champ Line # vide de cette valeur.
    Les valeurs saisies dans la boîte de dialogue sont conservées pour les utilisations ultérieures de la commande Line #.
  • Pour modifier manuellement les numéros de ligne, passez en mode Base, puis sélectionnez les cellules souhaitées dans la colonne Line # et :
    • Appuyez sur Delete sur le clavier pour effacer le contenu des cellules, puis
    • saisissez manuellement de nouvelles valeurs, ou
    • collez une plage de valeurs depuis le presse-papiers Windows.
  • Pour renuméroter les lignes ou poursuivre la numérotation à partir d’un numéro ajouté manuellement, cliquez sur la cellule Line # de l’élément souhaité, puis sur le bouton Set Line # Set Line Number button. La boîte de dialogue Line Numbering s’ouvre. Vous pouvez y utiliser les numéros existants comme références et numéroter de manière continue les cellules vides sélectionnées ou toutes les cellules vides, en partant des cellules non vides les plus proches situées au-dessus (Continue numbering), ou supprimer tous les numéros existants et renuméroter toutes les lignes (Renumber all). Les dernières valeurs de départ et d’incrément définies dans la boîte de dialogue Line # Options servent à calculer les numéros ajoutés. Si nécessaire, vous pouvez saisir une valeur initiale dans la cellule Line # sélectionnée pour définir le numéro de départ.

    La variante Continue numbering de la boîte de dialogue Line numbering s’ouvre lorsque CERTAINS numéros de ligne d’un document ActiveBOM (*BomDoc) ont déjà été définis.

    La variante Renumber all de la boîte de dialogue Line numbering s’ouvre lorsque TOUS les numéros de ligne d’un document ActiveBOM (*BomDoc) ont déjà été définis.

Les fonctions de gestion des numéros de ligne ne sont disponibles qu’en mode Base.

Configuration et enregistrement de l’affichage de la grille des éléments de nomenclature

Comme dans tout bon tableur, la grille des éléments de nomenclature peut être configurée selon vos besoins. Outre les fonctions classiques de classement et de tri des colonnes, la configuration actuelle peut être enregistrée sous la forme d’un BOM Set.

Utilisation des BOM Sets

Vous pouvez enregistrer autant de configurations de la grille des éléments de nomenclature que vous le souhaitez. Chacune d’elles est appelée BOM Set. Après avoir configuré la grille selon vos besoins, cliquez sur le bouton Add dans la zone BOM Sets du panneau Properties d’ActiveBOM pour ajouter un BOM Set à la liste.

Cliquez sur l’icône en forme d’œil pour activer un BOM Set.
Cliquez sur l’icône en forme d’œil pour activer un BOM Set.

Les BOM Sets sont configurés dans le panneau Properties d’ActiveBOM.

Le BOM Set souhaité peut être sélectionné lors de la génération de la nomenclature dans le Report Manager.

Remplacement d’un composant

Il n’est pas rare de détecter un problème avec un composant lors de la vérification du BomDoc et de sa préparation en vue de la commande des composants. Par exemple, le concepteur peut avoir oublié de finaliser le choix d’un composant, ou un composant est arrivé en fin de vie et le concepteur souhaite examiner le prix et la disponibilité de solutions de remplacement potentielles. Auparavant, la seule façon de résoudre ce problème consistait à revenir au schéma et à modifier le composant, à sélectionner une référence appropriée, puis à actualiser le BomDoc.

Vous pouvez désormais également remplacer un composant dans le BomDoc, puis répercuter cette modification dans le schéma au moyen d’un ordre de modification technique (ECO). Cliquez avec le bouton droit sur le ou les composants sélectionnés, puis sélectionnez la commande Operations » Change <ComponentName>. La boîte de dialogue Replace Component s’ouvre et vous permet de rechercher le composant de remplacement.

An existing part can be replaced via the right-click menu The Replace Component dialog is used to replace an existing component

Lorsque vous cliquez sur le bouton Replace Component OK, la boîte de dialogue Engineering Change Order s’ouvre et détaille les modifications nécessaires pour synchroniser le schéma avec le BomDoc.

  • La fonction Remplacer le composant recherche un nouveau composant dans l’espace de travail actuellement connecté. Si votre recherche ne renvoie aucun composant approprié, la boîte de dialogue affiche un lien permettant d’ouvrir le panneau Recherche de composants fabricant, dans lequel vous pouvez effectuer un clic droit pour : Acquire le composant dans votre propre espace de travail (via la boîte de dialogue Create New Component et l’éditeur de composants) ; ou Download le composant localement sous forme de package de bibliothèque intégrée dans une archive ZIP. Ces commandes ne sont disponibles que si le composant choisi dans le panneau Manufacturer Part Search comprend des modèles Altium Designer (repérez l’icône Icon that displays when a part includes schematic and PCB design models).
  • Au lieu d’utiliser les fonctions de recherche, de catégories et de filtres de la boîte de dialogue Replace Component, vous pouvez également effectuer un clic droit sur un résultat et accéder à la boîte de dialogue Find Similar Components. L’intérêt de cette boîte de dialogue est qu’elle reprend les valeurs du composant sur lequel vous avez effectué un clic droit pour vous permettre de trouver rapidement plusieurs composants partageant des propriétés et des paramètres communs, sur une plage de valeurs (voir l’image).
  • Si le changement de composant affecte également la conception du circuit imprimé, une Update PCB doit aussi être effectuée depuis le schéma.

En savoir plus sur l’application des ECO.

Utilisation des variantes

ActiveBOM prend en charge les projets de circuits imprimés comportant des variantes de conception. La fonction de variantes de conception permet de créer une conception de circuit imprimé de base unique, puis d’y monter des composants selon différentes configurations. Chaque configuration de montage de la carte assemblée est appelée design variant.

Utilisation des variantes de conception :

Image showing how to select a variant of the project

ActiveBOM prend en charge les variantes de différentes manières :

  • Affichage de la nomenclature d’une variante spécifique en mode d’affichage de base ou à plat
  • Option permettant d’inclure les éléments non montés dans la liste des éléments de nomenclature
  • Affichage d’une liste consolidée de tous les composants utilisés dans toutes les variantes, en mode d’affichage consolidé
  • Définition de solutions manuelles pour les composants de base comme pour les composants modifiés dans les variantes

Variantes en mode d’affichage de base

Pour la variante sélectionnée, activez l’option Show Not Fitted dans le panneau Properties afin d’inclure ces composants dans la grille des éléments de nomenclature. Lorsque cette option est activée, la colonne Fitted s’affiche automatiquement dans les détails de l’élément.

En mode d’affichage de base, la colonne Fitted affiche soit Fitted, soit Not Fitted. Si un composant est modifié dans une variante (un composant de remplacement a été choisi pour cette variante), les détails du composant de remplacement s’affichent automatiquement pour cet élément de nomenclature.

Notez que la variante actuelle est affichée dans la barre d’état d’ActiveBOM.
Notez que la variante actuelle est affichée dans la barre d’état d’ActiveBOM.

Variantes en mode d’affichage consolidé

Le mode d’affichage consolidé affiche tous les composants utilisés dans toutes les variantes. Il offre les fonctionnalités suivantes :

  • Si un composant est modifié dans une variante, un élément de nomenclature est créé pour chaque composant de remplacement utilisé, chacun de ces éléments portant le même repère. Par exemple, dans l’image ci-dessous, les composants DS1 et DS2 figurent chacun deux fois dans la liste, car la variante BGA utilise une LED de couleur différente de celle de la variante TSOP. Le composant R1 apparaît trois fois, car les variantes BGA et TSOP utilisent chacune une résistance différente de celle de la conception de base.
  • En mode d’affichage consolidé, lorsque l’option Show Not Fitted est activée, la colonne Fitted affiche Fitted ou Varied. Comme la vue consolidée présente tous les composants utilisés dans toutes les variantes, chaque composant affiché est monté soit dans la conception de base, soit dans une variante.
  • Chaque variante comporte une colonne <VariantName> - Qty (indiquant le nombre de composants de ce type utilisés dans cette variante) et une colonne <VariantName> - Price, qui correspond au prix unitaire multiplié par la valeur de la colonne de quantité.
  • Certains concepteurs créant une documentation de fabrication pour la conception de base ainsi que pour les variantes, une colonne Quantity est également disponible. Elle indique le nombre d’instances de ce composant utilisées pour fabriquer la conception de base. Masquez cette colonne si vous ne générez pas de documentation de fabrication pour la conception de base.
  • En mode d’affichage consolidé, la grille utilise une couleur pour signaler les cellules dont la valeur diffère de celle de la cellule correspondante dans la conception de base, comme illustré ci-dessous.

La couleur d’une cellule indique que sa valeur diffère de celle de la cellule correspondante dans la conception de base.
La couleur d’une cellule indique que sa valeur diffère de celle de la cellule correspondante dans la conception de base.

Pour en savoir plus sur les variantes, consultez la page Variantes de conception.

Travail entre le BomDoc, le schéma et le circuit imprimé

Deux fonctions sont disponibles pour vous aider à travailler entre le BomDoc, le schéma et la conception du circuit imprimé : la sélection croisée et le pointage croisé. Le comportement de ces fonctions est configuré sur la page Système - Navigation de la boîte de dialogue Preferences.

Ces deux fonctions permettent de localiser un même composant dans d’autres documents. La différence est que le mode de sélection croisée sélectionne le composant dans le document cible sans afficher activement ce document, tandis que le pointage croisé affiche activement le document cible et peut également basculer vers son éditeur pour en faire l’éditeur actif.

Vous pouvez effectuer une sélection croisée ou un pointage croisé du BomDoc vers le schéma et le circuit imprimé, mais pas du schéma ou du circuit imprimé vers le BomDoc.

Mode de sélection croisée

Le mode de sélection croisée doit être activé dans chaque éditeur dans lequel vous souhaitez l’utiliser. Sélectionnez la commande Tools » Cross Select Mode (Shift+Ctrl+X). Lorsque ce mode est activé, l’icône du menu est mise en évidence par un contour Cross Select icon, displays in the Tools menu when Cross Selection is enabled in an editor.

Le mode de sélection croisée nécessite que le document cible soit ouvert. Lorsque vous sélectionnez un composant dans la liste des éléments de nomenclature du BomDoc, ce composant est sélectionné et centré dans les documents cibles de schéma et de circuit imprimé (si Zooming est activé dans les options Cross Select Mode sur la page Système - Navigation de la boîte de dialogue Preferences). Notez que le document cible ne devient pas le document actif.

Si le BomDoc est en mode d’affichage de base, toutes les instances de ce composant sont sélectionnées sur le schéma et le circuit imprimé, comme illustré ci-dessous.

Le comportement d’affichage du mode de sélection croisée est contrôlé à l’aide des options Cross Select Mode sur la page Système - Navigation de la boîte de dialogue Preferences .

Le document cible ne devient pas le document actif. Il est donc conseillé d’ouvrir les documents source et cible côte à côte.

La sélection croisée du schéma (ou du circuit imprimé) vers le BomDoc est également prise en charge.

Utilisez la fonction de sélection croisée pour localiser et sélectionner, dans le schéma et sur le circuit imprimé, le composant choisi dans la liste des éléments de nomenclature.
Utilisez la fonction de sélection croisée pour localiser et sélectionner, dans le schéma et sur le circuit imprimé, le composant choisi dans la liste des éléments de nomenclature.

Pointage croisé

Alors que la sélection croisée est simplement un mode qui, une fois activé, affiche le résultat à chaque clic dans la liste des éléments de nomenclature, le pointage croisé est une action explicite.

Choisissez Tools » Cross Probe dans les menus principaux ou faites un clic droit sur un élément de nomenclature et sélectionnez Cross Probe dans le menu contextuel pour effectuer une navigation croisée vers ce composant sur le schéma. La navigation croisée s’effectuera également vers le composant sur le PCB si le fichier de la carte est ouvert.

Une fonctionnalité essentielle de la navigation croisée est la possibilité de basculer vers l’éditeur du document cible. Pour effectuer une navigation croisée et changer d’éditeur, maintenez la touche Ctrl enfoncée tout en sélectionnant la commande Cross Probe.

Faites un clic droit pour accéder à la commande de navigation croisée ; une entrée sera disponible pour le repère de chaque composant présent dans cet élément de nomenclature.
Faites un clic droit pour accéder à la commande de navigation croisée ; une entrée sera disponible pour le repère de chaque composant présent dans cet élément de nomenclature.

Lors de la navigation croisée, il est plus efficace d’afficher côte à côte les documents BomDoc (source) et schématique (cible), soit en fractionnant la fenêtre principale de conception, soit en ouvrant le schéma dans une nouvelle fenêtre. Les commandes correspondant à ces deux possibilités sont disponibles dans le menu contextuel de l’onglet du document.

Panneau Propriétés

Lorsque le document actif est un document de nomenclature (*.BomDoc), le panneau Properties présente les Document Options.

Les sections repliables suivantes contiennent des informations sur les options et commandes disponibles :

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents