Création du document BOM
En un coup d'œil
- Vous apprendrez à créer un BomDoc, découvrirez ce qui se passe lorsqu’il est ajouté à un projet et comprendrez une limitation essentielle : un seul BomDoc est autorisé par projet.
- Vous découvrirez l’organisation de la liste des éléments de nomenclature, notamment les modes d’affichage, les commandes de gestion des colonnes, les outils de modification, le fonctionnement du regroupement et les options de configuration de l’affichage.
- Vous comprendrez comment ActiveBOM gère les composants regroupés et les entrées de nomenclature personnalisées, afin de prendre en compte aussi bien les composants de la conception que les éléments supplémentaires du projet.
Création du document de nomenclature
Le document de nomenclature de travail d’ActiveBOM est appelé BomDoc. Ajoutez un nouveau BomDoc au projet via le sous-menu File » New ou en faisant un clic droit sur le projet dans le panneau Projects. Lorsque le projet contient au moins un composant, vous pouvez créer un nouveau BomDoc en cliquant sur la commande + Create située à côté de l’entrée ActiveBOM dans la structure du projet, dans le panneau Projects. Notez que chaque projet PCB ne peut contenir qu’un seul BomDoc.
Lorsque vous ajoutez un nouveau BomDoc à votre projet, le schéma est automatiquement compilé et tous les composants existants sont répertoriés dans le BomDoc. Pour les composants de la bibliothèque de l’espace de travail qui incluent des choix de pièces, les solutions sont détaillées dans la partie inférieure de l’interface, comme expliqué dans la section Comprendre la solution ci-dessous.
À mesure que des composants supplémentaires sont placés sur le schéma, ils sont automatiquement ajoutés au BomDoc. Des éléments de nomenclature et des paramètres supplémentaires peuvent également être ajoutés manuellement directement dans ActiveBOM via le bouton Add new situé au-dessus de la liste des composants. Consultez la section Éléments et colonnes de nomenclature personnalisés pour en savoir plus.
La liste des éléments de nomenclature
La partie supérieure du BomDoc présente, sous forme de tableau, tous les composants détectés dans le projet de conception PCB, ainsi que les éléments de nomenclature supplémentaires que vous avez ajoutés directement au BomDoc. Cette zone est appelée liste des éléments de nomenclature.

La liste des composants, ou des éléments de nomenclature, affichée dans la vue de base.
Trois modes d’affichage sont disponibles pour présenter les éléments de nomenclature. Sélectionnez le mode souhaité à l’aide des boutons situés au-dessus de la liste :
Flat view - une ligne pour chaque composant.
Base view - une ligne pour chaque composant unique du projet ; la colonne Designator répertorie les repères de tous les composants de ce type. Plusieurs options de présentation sont disponibles pour les repères regroupés. Sélectionnez le mode Designator Grouping souhaité dans le panneau Properties.
Consolidated view - utilisé lorsque le projet comprend des variantes pour afficher une nomenclature consolidée de toutes les variantes.
Fonctions de modification de la liste des éléments de nomenclature
La liste des composants propose plusieurs fonctions de modification similaires à celles d’un tableur, notamment :
- Utilisez l’onglet Column du panneau Properties pour afficher ou masquer une colonne et définir un alias pour son nom. Vous pouvez également définir un alias dans la boîte de dialogue Enter Column Properties, accessible en faisant un clic droit sur un nom de colonne dans la zone d’en-tête des colonnes du BomDoc, puis en sélectionnant la commande Rename Column dans le menu contextuel. Notez que l’alias est utilisé comme nom de colonne dans les nomenclatures générées.
-
Vous pouvez également ajouter et supprimer des colonnes à l’aide de la boîte de dialogue Select Columns, accessible en faisant un clic droit sur un nom de colonne dans la zone d’en-tête des colonnes du BomDoc, puis en choisissant Select Columns.

La boîte de dialogue Select ColumnsOptions/commandes de la boîte de dialogue Select Columns
- Search - saisissez des caractères dans le champ pour filtrer la liste des colonnes et afficher uniquement celles dont le nom contient les caractères saisis.
-
Visibility column - permet de déterminer si une colonne ActiveBOM est visible dans le document ActiveBOM (
*.BomDoc). Cliquez sur l’icône en forme d’œil pour afficher ou masquer une colonne. Les colonnes visibles sont toujours répertoriées en haut de la boîte de dialogue, dans l’ordre dans lequel elles apparaissent dans le BomDoc. -
Data Source column - affiche la source de données de la colonne. Les sources de données prises en charge comprennent :
-
- éléments ajoutés directement à la nomenclature
-
- paramètres des composants du schéma
-
- paramètres des composants de l’espace de travail
-
- paramètres de base de données liée (DbLink, DbLib)
-
- paramètres du document schématique
-
- Altium Cloud Services
-
- Column Name - affiche le nom de la source de données, qui apparaît comme nom de colonne dans le BomDoc.
- Up / Down - permet de déplacer la colonne actuellement sélectionnée vers le haut ou vers le bas de la liste. La colonne se déplace ainsi vers la gauche ou vers la droite dans le BomDoc lorsque vous cliquez sur OK. Notez que seules les colonnes visibles peuvent être déplacées dans cet ordre.
-
- cliquez sur le symbole de filtre à côté de chaque en-tête pour filtrer les informations de la grille selon l’élément de liste choisi.
- Faites glisser les colonnes pour modifier leur ordre.
- Triez selon n’importe quelle colonne et maintenez la touche Shift enfoncée pour effectuer un tri secondaire sur une ou plusieurs autres colonnes.
-
Cliquez sur l’icône de filtre pour filtrer selon les valeurs des colonnes.
- Sélectionnez des cellules à l’aide des méthodes de sélection standard de Windows.
- Copiez le contenu des cellules depuis ActiveBOM et collez des valeurs provenant d’un tableur externe dans des colonnes ActiveBOM personnalisées.
- Des numéros de ligne configurables par l’utilisateur peuvent être définis lorsque la nomenclature est en vue de base. Dans la vue de base, cliquez sur le bouton Set line numbers pour ajouter un numéro de ligne à chaque ligne. Cliquez sur l’icône de liste déroulante à droite du bouton pour ouvrir la boîte de dialogue Line # Options, dans laquelle vous pouvez définir la valeur de départ et l’incrément. Consultez la section Colonne de numéros de ligne pour en savoir plus.
- Cliquez sur la liste déroulante Add New pour ajouter des lignes ou des colonnes supplémentaires. Consultez la section Éléments et colonnes de nomenclature personnalisés pour en savoir plus.
- Cliquez sur le bouton Group by pour regrouper la grille selon la colonne activée. Plusieurs colonnes de regroupement peuvent être activées (voir l’image) et leur ordre peut être modifié par glisser-déposer. Il s’agit d’une fonction d’affichage de la grille : le regroupement n’est pas transféré à la boîte de dialogue Report Manager lors de l’exécution de la commande Bill of Materials.
- Cliquez sur le bouton Reset Supply Chain pour supprimer le classement des solutions défini par l'utilisateur et les priorités SPN attribuées manuellement aux éléments de nomenclature sélectionnés.
- La configuration actuelle de la grille des éléments de nomenclature peut être enregistrée sous forme d'un jeu de nomenclature. Consultez la section Configuration et enregistrement de l'affichage de la grille des éléments de nomenclature pour en savoir plus.
-
Utilisez les raccourcis Windows standard pour faire défiler la liste des éléments de nomenclature :
- Défilement vertical = MouseWheel Roll
- Défilement horizontal = Shift + MouseWheel Roll
Les groupes de colonnes

La liste des composants d'ActiveBOM comporte des groupes de colonnes distincts dans chaque mode d'affichage. L'image ci-dessus présente la vue de base.
La grille des éléments de nomenclature est organisée selon les principaux groupes suivants :
- Item Details (surligné en orange dans l'image) : ces colonnes affichent les caractéristiques des composants, telles que le repère, la description, la référence de bibliothèque et d'autres paramètres de composant.
- Solutions (surligné en vert dans l'image) : le fabricant et le ou les fournisseurs les mieux classés de la chaîne d'approvisionnement. Le nombre de solutions (références fabricant) et le nombre de fournisseurs pour chaque solution sont configurés dans le panneau Properties d'ActiveBOM. Ils sont signalés par un bandeau de couleur unie dans la vignette du fournisseur. Le classement est automatique, mais peut également être défini manuellement, comme expliqué dans la section Comprendre la solution ci-dessous.
- BOM Status (surligné en cyan dans l'image) : une indication du risque actuel associé à chaque composant. Survolez une icône pour afficher une description ou activez la colonne détaillée BOM Status dans le panneau Properties pour afficher cette description.
Éléments et colonnes de nomenclature personnalisés
La gestion de la nomenclature d'un projet de conception de PCB nécessite de gérer des composants et des éléments de nomenclature autres que ceux placés dans le schéma et sur le PCB, par exemple des pièces dont les caractéristiques restent à préciser, des fixations, le circuit imprimé nu ou la colle de montage. Dans de nombreux cas, des éléments de nomenclature ou des paramètres personnalisés sont utilisés dans le projet de conception de PCB. Pour ces situations, ActiveBOM permet d'ajouter des éléments de nomenclature et des colonnes (paramètres) supplémentaires, qui peuvent ensuite être inclus dans la nomenclature générée :
- Custom row - un moyen simple d'ajouter un élément de nomenclature personnalisé à prendre en compte dans la conception (circuit imprimé nu, colle, etc.). Tous les champs d'une ligne personnalisée sont définis par l'utilisateur. Les lignes personnalisées ne sont pas gérées par ActiveBOM : par exemple, si la quantité est définie sur 3, la vue à plat n'affichera pas 3 éléments distincts. La recherche dans la chaîne d'approvisionnement n'est pas non plus prise en charge pour les lignes personnalisées.
- Custom column - une colonne de nomenclature supplémentaire, gérée dans ActiveBOM, pouvant contenir n'importe quel texte défini par l'utilisateur.
- Custom Item - un élément de nomenclature supplémentaire, généralement destiné aux éléments qui seront nécessaires, mais dont les caractéristiques ne sont pas encore entièrement connues ou qui n'existent pas encore dans la bibliothèque. Cela permet d'inclure leur coût dans l'estimation du coût global de la carte.
-
Managed Component - un élément de nomenclature supplémentaire, géré manuellement dans le document de nomenclature. La boîte de dialogue Component Search s'ouvre et répertorie les composants de l'espace de travail actuellement connecté.
Options et commandes de la boîte de dialogue de recherche de composants
- Search - utilisez la zone de texte de recherche pour rechercher manuellement un composant spécifique.
-
- cliquez pour accéder à un menu et sélectionner l'une des options suivantes :
- File-based Libraries Preferences - cliquez pour ouvrir la boîte de dialogue Available File-based Libraries afin d'ajouter ou de supprimer des bibliothèques.
- File-based Libraries Search - cliquez pour ouvrir la boîte de dialogue File-based Libraries Search afin de rechercher des bibliothèques.
- Refresh - cliquez pour actualiser la boîte de dialogue.
-
- cliquez pour ouvrir ou fermer la Details zone de la boîte de dialogue (décrite ci-dessous).
Catégories
Utilisez ce filtre pour afficher certains types de composants ou tous les composants disponibles. Utilisez
pour accéder à la Categories barre de recherche, qui permet de rechercher manuellement un composant spécifique ou un fichier .IntLib.
Filtres
Cliquez sur l'icône Filters pour ouvrir la zone Filters , dans laquelle vous pouvez affiner le filtrage des catégories sélectionnées dans la liste Components .
Composants
- Name - le nom du composant.
- Description - la description de chaque composant.
- Footprint - l’empreinte du composant.
- Operating Temperature Range - la plage de températures appropriée dans laquelle ces composants fonctionnent.
- Package Description - la description du boîtier du composant.
- Manufacturer Part Search - cliquez pour ouvrir le panneau Recherche de pièces fabricant afin de rechercher et de choisir la référence de composant la plus adaptée.
- Create component - cliquez pour ouvrir la boîte de dialogue Create new component afin de sélectionner le type de composant.
- Results - indique le nombre total de composants trouvés/répertoriés dans la recherche.
Détails
- Component Revision ID - indique l’identifiant de révision et le prix d’un composant donné. Cliquez sur l’identifiant de révision pour ouvrir le panneau Explorateur et obtenir davantage d’informations sur un composant.
- References - cliquez pour ouvrir les informations de référence du composant dans un navigateur Web. Utilisez la liste déroulante pour accéder à Manufacturer URL ou à Datasheet.
- Place - cliquez pour placer le composant sélectionné sur un document schématique.
- Component information - présente les informations pertinentes sur le composant, notamment le fabricant, la date de publication et les informations descriptives. Cliquez sur le lien Show More pour afficher toutes les informations ; cliquez sur Show Less pour réduire les informations affichées.
- Models - développez pour afficher les modèles fournis. Utilisez les liens disponibles pour afficher les différentes parties d’un même modèle.
- References - développez pour accéder à Manufacturer URL ou à Datasheet.
- Part Choices - développez pour afficher les choix de pièces. Un nom, un prix et une description sont fournis. La fiche technique du composant est également répertoriée.
- Where Used - développez pour afficher les projets qui utilisent le composant.
Menu contextuel
- Place <component> - cliquez pour placer le composant dans le document approprié.
- Edit - cliquez pour ouvrir les documents de bibliothèque de composants du composant sélectionné.
- Navigate to <revision> - cliquez pour ouvrir le composant sélectionné dans le panneau Explorateur.
- Operations - survolez pour accéder aux options Submit Request, Create, Download, Make a copy, Change Component Type, Create / Edit PCL et Full Item History.
- Refresh - cliquez pour actualiser l’affichage et consulter les mises à jour ou modifications récentes. Vous pouvez également actualiser l’affichage à l’aide du raccourci F5.
Ajout d’instances d’un composant géré ou d’un élément personnalisé
Après avoir ajouté un composant géré ou un élément personnalisé, faites un clic droit dessus et sélectionnez la commande Operations » Add Instances of pour accéder à la boîte de dialogue Add to BOM Components. Utilisez cette boîte de dialogue pour définir le nombre d’instances du composant à ajouter à la nomenclature.
Indiquez Designator prefix, le paramètre facultatif Separator (qui peut être défini pour obtenir des résultats tels que X-1 ou X:1) et Quantity de composants requis (cette valeur sert à définir la plage de désignateurs et apparaît également dans la colonne Quantity d’ActiveBOM). Tous les autres paramètres, tels que la description, peuvent être modifiés directement dans la grille des éléments de nomenclature.
Modification/suppression d’un composant géré ou d’un élément personnalisé
Pour modifier le désignateur ou supprimer une instance d’un composant géré ou d’un élément personnalisé, faites un clic droit dessus et sélectionnez la commande Operations » Edit item. La boîte de dialogue Change / Remove s’ouvre.
Options et commandes de la boîte de dialogue de modification/suppression
- BOM Components - la grille de la boîte de dialogue répertorie chaque instance du nouvel élément. Pour modifier le préfixe ou la valeur du désignateur, cliquez dans la cellule New Designator appropriée et modifiez-la selon vos besoins.
- Remove All - cliquez sur ce bouton pour sélectionner toutes les instances de l’élément de nomenclature supplémentaire répertoriées dans la boîte de dialogue et les marquer pour suppression. Lorsque vous cliquez sur le bouton OK de la boîte de dialogue, tous les éléments marqués pour suppression sont supprimés de la grille des éléments de nomenclature d’ActiveBOM. Notez que, puisqu’il ne reste plus aucune instance de ce nouvel élément, l’élément est également supprimé. Cette action ne peut pas être annulée.
- Remove None - cliquez sur ce bouton pour effacer toutes les marques de suppression.
- Remove Selected - lorsqu’une instance non marquée pour suppression est sélectionnée, le troisième bouton permet de marquer pour suppression les instances actuellement sélectionnées.
- Restore Selected - lorsqu’une instance marquée pour suppression est sélectionnée, le troisième bouton permet d’effacer la marque de suppression des instances actuellement sélectionnées.
Sources de données
Les sources de données disponibles par défaut dans ActiveBOM sont les paramètres des composants du schéma , les paramètres des composants de l’espace de travail pour le contenu de l’espace de travail et les données fournies par ActiveBOM À partir de ces sources, ActiveBOM génère la grille principale des éléments de nomenclature du projet. Les sources de données sont activées et leur affichage est contrôlé dans l’onglet Columns du panneau Propriétés d’ActiveBOM.
En activant le bouton Sources correspondant (au-dessus de la liste des colonnes), la nomenclature peut également inclure des informations provenant des sources de données supplémentaires suivantes :
The PCB - activez ces options pour inclure les données de position, de rotation et de face du PCB dans les Columns disponibles, pour chacun des composants. Si le projet contient plusieurs documents PCB, la boîte de dialogue Choisir le PCB à utiliser s’ouvre pour vous permettre de sélectionner le PCB souhaité.
Database - pour charger des paramètres de composants supplémentaires à partir d’une base de données externe (via *.DbLib, *.SVNDbLib ou *.DbLink).
Altium Cloud Services - activez cette option pour accéder à un large éventail de données supplémentaires sur les composants, pour les éléments de nomenclature identifiés par Altium Parts Provider et présentant une solution d’approvisionnement.
Document Parameters - activez cette option pour inclure tous les paramètres de documents schématiques détectés dans l’ensemble des schémas du projet PCB dans les Columns disponibles.

La source de chaque paramètre est indiquée par l’icône dans la liste des colonnes.
Priorité des paramètres des sources de données
Si un même paramètre est présent dans plusieurs sources de données, les priorités suivantes sont appliquées dans ActiveBOM (de la plus élevée à la plus faible) :
- Nomenclature
- PCB
- Documents
- Serveur
- Base de données
- Cloud
- Schéma
- Manuel
Colonne des numéros de ligne
Pour les conceptions de circuits imprimés accompagnées de plans d’assemblage, ou pour l’échange de données de nomenclature entre ingénieurs de conception, ingénieurs chargés des coûts et spécialistes des achats, le numéro de ligne de nomenclature (numéro de position de l’élément de nomenclature) constitue un moyen simple de distinguer individuellement les lignes de nomenclature. Il peut ensuite être utilisé pour identifier explicitement ou find le repère, le composant et sa représentation correspondants dans la conception.
En tant que source des données de nomenclature du projet, ActiveBOM prend en charge les numéros de ligne définis par l’utilisateur pour la nomenclature du projet et propose des fonctions de gestion manuelle et automatique de ces numéros (numéros de position des éléments de nomenclature).
-
Pour définir automatiquement le numéro de position de tous les éléments de nomenclature du projet (en mode Base), cliquez sur le bouton Set Line #
. Les numéros de ligne s’affichent dans la colonne Line #, dans le groupe de colonnes Item Details. Cliquez sur l’icône de liste déroulante à droite du bouton pour ouvrir la boîte de dialogue Line # Options, dans laquelle vous pouvez définir les valeurs de départ et d’incrément.

La boîte de dialogue Line Number Options- Start number - la valeur à utiliser si la première cellule Line # est vide.
- Increment - incrémenter chaque champ Line # vide de cette valeur.
-
Pour modifier manuellement les numéros de ligne, passez en mode Base, puis sélectionnez les cellules souhaitées dans la colonne Line # et :
- Appuyez sur Delete sur le clavier pour effacer le contenu des cellules, puis
- saisissez manuellement de nouvelles valeurs, ou
- collez une plage de valeurs depuis le presse-papiers Windows.
-
Pour renuméroter les lignes ou poursuivre la numérotation à partir d’un numéro ajouté manuellement, cliquez sur la cellule Line # de l’élément souhaité, puis sur le bouton Set Line #
. La boîte de dialogue Line Numbering s’ouvre. Vous pouvez y utiliser les numéros existants comme références et numéroter de manière continue les cellules vides sélectionnées ou toutes les cellules vides, en partant des cellules non vides les plus proches situées au-dessus (Continue numbering), ou supprimer tous les numéros existants et renuméroter toutes les lignes (Renumber all). Les dernières valeurs de départ et d’incrément définies dans la boîte de dialogue Line # Options servent à calculer les numéros ajoutés. Si nécessaire, vous pouvez saisir une valeur initiale dans la cellule Line # sélectionnée pour définir le numéro de départ.
Configuration et enregistrement de l’affichage de la grille des éléments de nomenclature
Comme dans tout bon tableur, la grille des éléments de nomenclature peut être configurée selon vos besoins. Outre les fonctions classiques de classement et de tri des colonnes, la configuration actuelle peut être enregistrée sous la forme d’un BOM Set.
Fonctions de configuration de la grille
- Afficher ou masquer une colonne : utilisez la fonction Columns du panneau Properties. Utilisez le champ Search en haut du panneau pour trouver rapidement une colonne.
- Modifier l’ordre des colonnes : cliquez sur le titre d’une colonne, maintenez le bouton enfoncé, puis faites-la glisser à l’emplacement souhaité.
- Modifier la largeur d’une colonne : placez le pointeur sur le bord de la colonne dans la zone de titre, puis cliquez et faites glisser (repérez le curseur , ou double-cliquez à cet endroit pour ajuster automatiquement la largeur au contenu de la colonne.
-
Trier l’ensemble de la grille selon une colonne :
- Cliquez sur le titre de la colonne pour trier la grille dans l’ordre alphanumérique selon le contenu de cette colonne.
- Cliquez une deuxième fois pour inverser l’ordre de tri.
- Maintenez la touche Maj enfoncée et cliquez sur le titre d’une autre colonne pour effectuer un tri secondaire selon son contenu.
-
Filtrer la grille selon une valeur précise : cliquez sur l’icône de filtre
pour filtrer la grille selon une valeur présente dans cette colonne. Sélectionnez (Custom) pour accéder à la boîte de dialogue Filter Editor et définir la condition, l’opérateur, la valeur, le type d’opérateur, etc., afin de filtrer la colonne sélectionnée.
- Enregistrer la configuration sous la forme d’un BOM Set : voir les détails ci-dessous.
Utilisation des BOM Sets
Vous pouvez enregistrer autant de configurations de la grille des éléments de nomenclature que vous le souhaitez. Chacune d’elles est appelée BOM Set. Après avoir configuré la grille selon vos besoins, cliquez sur le bouton Add dans la zone BOM Sets du panneau Properties d’ActiveBOM pour ajouter un BOM Set à la liste.

Cliquez sur l’icône en forme d’œil pour activer un BOM Set.
Les BOM Sets sont configurés dans le panneau Properties d’ActiveBOM.
Remplacement d’un composant
Il n’est pas rare de détecter un problème avec un composant lors de la vérification du BomDoc et de sa préparation en vue de la commande des composants. Par exemple, le concepteur peut avoir oublié de finaliser le choix d’un composant, ou un composant est arrivé en fin de vie et le concepteur souhaite examiner le prix et la disponibilité de solutions de remplacement potentielles. Auparavant, la seule façon de résoudre ce problème consistait à revenir au schéma et à modifier le composant, à sélectionner une référence appropriée, puis à actualiser le BomDoc.
Vous pouvez désormais également remplacer un composant dans le BomDoc, puis répercuter cette modification dans le schéma au moyen d’un ordre de modification technique (ECO). Cliquez avec le bouton droit sur le ou les composants sélectionnés, puis sélectionnez la commande Operations » Change <ComponentName>. La boîte de dialogue Replace Component s’ouvre et vous permet de rechercher le composant de remplacement.
Lorsque vous cliquez sur le bouton Replace Component OK, la boîte de dialogue Engineering Change Order s’ouvre et détaille les modifications nécessaires pour synchroniser le schéma avec le BomDoc.
Utilisation des variantes
ActiveBOM prend en charge les projets de circuits imprimés comportant des variantes de conception. La fonction de variantes de conception permet de créer une conception de circuit imprimé de base unique, puis d’y monter des composants selon différentes configurations. Chaque configuration de montage de la carte assemblée est appelée design variant.
Utilisation des variantes de conception :
- Les variantes de conception sont configurées dans la boîte de dialogue de gestion des variantes ou dans le gestionnaire de variantes (Project » Variants).
- Pour examiner une variante, double-cliquez sur son nom dans le dossier Variantes du projet, dans le panneau Projects, comme illustré ci-dessous.
ActiveBOM prend en charge les variantes de différentes manières :
- Affichage de la nomenclature d’une variante spécifique en mode d’affichage de base ou à plat
- Option permettant d’inclure les éléments non montés dans la liste des éléments de nomenclature
- Affichage d’une liste consolidée de tous les composants utilisés dans toutes les variantes, en mode d’affichage consolidé
- Définition de solutions manuelles pour les composants de base comme pour les composants modifiés dans les variantes
Variantes en mode d’affichage de base
Pour la variante sélectionnée, activez l’option Show Not Fitted dans le panneau Properties afin d’inclure ces composants dans la grille des éléments de nomenclature. Lorsque cette option est activée, la colonne Fitted s’affiche automatiquement dans les détails de l’élément.
En mode d’affichage de base, la colonne Fitted affiche soit Fitted, soit Not Fitted. Si un composant est modifié dans une variante (un composant de remplacement a été choisi pour cette variante), les détails du composant de remplacement s’affichent automatiquement pour cet élément de nomenclature.

Notez que la variante actuelle est affichée dans la barre d’état d’ActiveBOM.
Variantes en mode d’affichage consolidé
Le mode d’affichage consolidé affiche tous les composants utilisés dans toutes les variantes. Il offre les fonctionnalités suivantes :
- Si un composant est modifié dans une variante, un élément de nomenclature est créé pour chaque composant de remplacement utilisé, chacun de ces éléments portant le même repère. Par exemple, dans l’image ci-dessous, les composants DS1 et DS2 figurent chacun deux fois dans la liste, car la variante BGA utilise une LED de couleur différente de celle de la variante TSOP. Le composant R1 apparaît trois fois, car les variantes BGA et TSOP utilisent chacune une résistance différente de celle de la conception de base.
-
En mode d’affichage consolidé, lorsque l’option Show Not Fitted est activée, la colonne Fitted affiche
FittedouVaried. Comme la vue consolidée présente tous les composants utilisés dans toutes les variantes, chaque composant affiché est monté soit dans la conception de base, soit dans une variante. - Chaque variante comporte une colonne <VariantName> - Qty (indiquant le nombre de composants de ce type utilisés dans cette variante) et une colonne <VariantName> - Price, qui correspond au prix unitaire multiplié par la valeur de la colonne de quantité.
- Certains concepteurs créant une documentation de fabrication pour la conception de base ainsi que pour les variantes, une colonne Quantity est également disponible. Elle indique le nombre d’instances de ce composant utilisées pour fabriquer la conception de base. Masquez cette colonne si vous ne générez pas de documentation de fabrication pour la conception de base.
- En mode d’affichage consolidé, la grille utilise une couleur pour signaler les cellules dont la valeur diffère de celle de la cellule correspondante dans la conception de base, comme illustré ci-dessous.

La couleur d’une cellule indique que sa valeur diffère de celle de la cellule correspondante dans la conception de base.
Pour en savoir plus sur les variantes, consultez la page Variantes de conception.
Travail entre le BomDoc, le schéma et le circuit imprimé
Deux fonctions sont disponibles pour vous aider à travailler entre le BomDoc, le schéma et la conception du circuit imprimé : la sélection croisée et le pointage croisé. Le comportement de ces fonctions est configuré sur la page Système - Navigation de la boîte de dialogue Preferences.
Ces deux fonctions permettent de localiser un même composant dans d’autres documents. La différence est que le mode de sélection croisée sélectionne le composant dans le document cible sans afficher activement ce document, tandis que le pointage croisé affiche activement le document cible et peut également basculer vers son éditeur pour en faire l’éditeur actif.
Vous pouvez effectuer une sélection croisée ou un pointage croisé du BomDoc vers le schéma et le circuit imprimé, mais pas du schéma ou du circuit imprimé vers le BomDoc.
Mode de sélection croisée
Le mode de sélection croisée doit être activé dans chaque éditeur dans lequel vous souhaitez l’utiliser. Sélectionnez la commande Tools » Cross Select Mode (Shift+Ctrl+X). Lorsque ce mode est activé, l’icône du menu est mise en évidence par un contour
.
Le mode de sélection croisée nécessite que le document cible soit ouvert. Lorsque vous sélectionnez un composant dans la liste des éléments de nomenclature du BomDoc, ce composant est sélectionné et centré dans les documents cibles de schéma et de circuit imprimé (si Zooming est activé dans les options Cross Select Mode sur la page Système - Navigation de la boîte de dialogue Preferences). Notez que le document cible ne devient pas le document actif.
Si le BomDoc est en mode d’affichage de base, toutes les instances de ce composant sont sélectionnées sur le schéma et le circuit imprimé, comme illustré ci-dessous.

Utilisez la fonction de sélection croisée pour localiser et sélectionner, dans le schéma et sur le circuit imprimé, le composant choisi dans la liste des éléments de nomenclature.
Pointage croisé
Alors que la sélection croisée est simplement un mode qui, une fois activé, affiche le résultat à chaque clic dans la liste des éléments de nomenclature, le pointage croisé est une action explicite.
Choisissez Tools » Cross Probe dans les menus principaux ou faites un clic droit sur un élément de nomenclature et sélectionnez Cross Probe dans le menu contextuel pour effectuer une navigation croisée vers ce composant sur le schéma. La navigation croisée s’effectuera également vers le composant sur le PCB si le fichier de la carte est ouvert.
Une fonctionnalité essentielle de la navigation croisée est la possibilité de basculer vers l’éditeur du document cible. Pour effectuer une navigation croisée et changer d’éditeur, maintenez la touche Ctrl enfoncée tout en sélectionnant la commande Cross Probe.

Faites un clic droit pour accéder à la commande de navigation croisée ; une entrée sera disponible pour le repère de chaque composant présent dans cet élément de nomenclature.
Panneau Propriétés
Lorsque le document actif est un document de nomenclature (*.BomDoc), le panneau Properties présente les Document Options.
Les sections repliables suivantes contiennent des informations sur les options et commandes disponibles :
Général
- Production Quantity – le nombre de cartes à fabriquer. Il est important de renseigner ce champ, car il est utilisé lors des recherches dans la chaîne d’approvisionnement pour vérifier la disponibilité des composants auprès des fournisseurs.
- Currency – la devise préférée pour l’affichage du prix des composants. Les taux de change utilisés pour la conversion des devises sont actualisés quotidiennement, à condition que vous soyez connecté à votre compte Altium. Lorsque vous vous déconnectez d’Altium (sur la page Système – Gestion du compte de la boîte de dialogue Preferences), vous perdez l’accès à ces taux actualisés. Dans ce cas, une option de la boîte de dialogue des rapports de nomenclature permet d’utiliser les données mises en cache.
- Price Per Board – calculée à partir des données des fournisseurs, cette valeur correspond à la somme des Supplier Subtotals per Board, comme décrit ci-dessous. Notez que le Price Per Board ne tient pas compte des quantités minimales de commande (MOQ).
- Order Price – somme des Supplier Subtotals. Notez que le Order Price tient compte des MOQ ; il correspond au montant payé au fournisseur.
Chaîne d’approvisionnement
Les informations sur la chaîne d’approvisionnement sont présentées dans la partie inférieure de l’interface ActiveBOM : un composant fabricant apparaît à gauche, accompagné à sa droite d’une ou plusieurs vignettes de fournisseurs colorées. Cette zone affiche des données lorsque des informations valides sur la chaîne d’approvisionnement peuvent être identifiées pour un élément de nomenclature. Chacune de ces lignes Manufacturer & Supplier(s) Details est appelée une solution. Les informations sur le fabricant sont abrégées en MPN (références fabricant) et celles sur le fournisseur en SPN (références fournisseur).
- Solutions per Item – le nombre de références fabricant que vous souhaitez trouver pour chaque élément de nomenclature.
- Suppliers per Solution – le nombre de fournisseurs que vous souhaitez trouver pour chaque référence fabricant.
-
Solutions
- Exclude Invalid SPNs – sélectionnez cette option pour exclure les SPN non valides.
- Favorite Suppliers List – ouvre la boîte de dialogue Fournisseurs favoris, dans laquelle vous pouvez configurer la liste globale des fournisseurs pour ce BomDoc.
-
Manufacturer Link – ouvre la boîte de dialogue Définir les champs de liaison fabricant, dans laquelle sont identifiés les paramètres des composants du schéma contenant le nom du fabricant et la référence fabricant. Si la conception contient des composants de bibliothèque ne provenant pas d’un espace de travail (composants qui n’ont pas été placés depuis un espace de travail et ne disposent pas non plus d’informations fournisseur), ActiveBOM peut interroger Altium Parts Provider pour identifier des solutions d’approvisionnement adaptées. Plusieurs paires de paramètres Nom / Référence peuvent être définies. Dans la boîte de dialogue, cliquez sur le bouton Detect fields pour ajouter automatiquement toutes les paires de paramètres dont le nom contient le terme
manufactureret qui peuvent être associées de manière logique.
Éléments de nomenclature
Cette zone permet de configurer le regroupement des éléments de nomenclature dans la grille des éléments de nomenclature.
-
Items
-
Show not Fitted – si le projet PCB comprend des variantes et que la variante choisie comporte des composants définis sur
Not Fitted, activez cette option pour afficher les éléments non montés dans la grille des éléments de nomenclature. - Designator Grouping – les modes d’affichage de base et consolidé présentent les composants identiques sur une seule ligne dans la grille des éléments de nomenclature. Utilisez cette option pour définir si les repères sont affichés individuellement ou sous forme de plages lorsqu’une ligne contient plusieurs composants.
- Component Grouping – cliquez sur le bouton Edit pour ouvrir la boîte de dialogue Component Grouping. Dans la vue Base ou Consolidated, ActiveBOM considère les composants comme identiques lorsqu’ils partagent le même ItemID (bibliothèque d’espace de travail) ou LibRef (bibliothèque basée sur des fichiers ou une base de données). Activez des paramètres dans la boîte de dialogue pour affiner davantage le regroupement des composants. Notez que si le projet ne contient que des composants gérés, le bouton Edit ne sera pas accessible, car les composants gérés sont toujours regroupés par ItemID.
-
Show not Fitted – si le projet PCB comprend des variantes et que la variante choisie comporte des composants définis sur
Jeux de nomenclature
Les jeux de nomenclature permettent de capturer la disposition et la configuration de la grille des éléments de nomenclature et de les enregistrer sous la forme d’un jeu nommé. Vous pouvez définir autant de jeux de nomenclature que vous le souhaitez.
-
Current BOM Set – cliquez sur l’icône en forme d’œil pour appliquer ce jeu de nomenclature à la grille des éléments de nomenclature.
-
Add – configurez la visibilité, l’ordre et la largeur des colonnes, puis cliquez sur Add pour enregistrer cette configuration en tant qu’ensemble de nomenclature. Pour modifier le nom de l’ensemble de nomenclature, cliquez une fois pour le sélectionner, puis une seconde fois pour modifier le texte.
-
Update – si la configuration de la grille des éléments de nomenclature est modifiée, cliquez sur Update pour enregistrer à nouveau cette configuration.
-
Delete – cliquez sur
pour supprimer l’ensemble de nomenclature actuellement sélectionné.
Vérifications de la nomenclature
ActiveBOM effectue une vérification complète de chaque élément de nomenclature et de toutes les données de chaîne d’approvisionnement détectées pour cet élément.
- Violation Type grid – affiche la liste des types et du nombre de violations actuellement présents dans le BomDoc. Cliquez sur l’icône de filtre pour afficher uniquement les éléments de nomenclature qui ne satisfont pas à cette vérification. Notez qu’un élément de nomenclature peut échouer à plusieurs vérifications.
-
BOM Checks – cliquez sur
pour ouvrir la boîte de dialogue Vérifications de la nomenclature, dans laquelle vous pouvez configurer le mode de signalement pour chaque type de violation possible.
Colonnes
Cette zone du panneau permet de configurer les paramètres affichés pour chaque élément de nomenclature ainsi que les sources de données disponibles pour ces paramètres.
-
Sources – outre les données ajoutées directement dans le BomDoc , les sources de données disponibles par défaut dans ActiveBOM sont les paramètres des composants du schéma et les paramètres des composants de la bibliothèque de l’espace de travail pour le contenu de cet espace À partir de ces sources, ActiveBOM génère la grille principale des éléments de nomenclature du projet. La nomenclature peut également inclure des informations provenant des sources de données supplémentaires suivantes :
-
PCB – activez cette option pour inclure les données de position, de rotation et de face du circuit imprimé dans les Columns disponibles pour chaque composant.
-
Database – activez cette option pour charger des paramètres de composants supplémentaires depuis une base de données externe (*.DbLib,*.SVNDbLibou*.DbLink). -
Document – activez cette option pour inclure tous les paramètres de document schématique détectés dans l’ensemble des schémas du projet PCB dans les Columns disponibles.
-
Altium Cloud Services – activez cette option pour accéder à un large éventail de données supplémentaires sur les composants pour les éléments de nomenclature identifiés par Altium Parts Provider et disposant d’une solution d’approvisionnement.
-
-
Columns – liste de toutes les sources d’informations sur les composants disponibles pour ActiveBOM. La zone Colonnes peut être triée en cliquant sur l’un des en-têtes.
- Visibility – chaque ligne comporte une icône en forme d’œil ; cliquez dessus pour contrôler la visibilité de cette colonne dans la grille principale des éléments de nomenclature.
- Source – affiche une icône indiquant la source du paramètre.
- Name – nom de la propriété ou du paramètre tel qu’il est défini dans le document source ou saisi pour une colonne BomDoc créée par l’utilisateur.
- Alias – si nécessaire, un alias peut être défini pour renommer une colonne.
- Add – cliquez pour ajouter une nouvelle colonne personnalisée à la grille des éléments de nomenclature.





