Librerie schematiche
A colpo d'occhio
- Scopri come creare librerie, inclusa una libreria di lavoro o un archivio che riproduca esattamente i componenti utilizzati in un progetto.
- Impara a gestire i componenti e a convertire le porte dei fogli schematici in pin dei simboli.
- Scopri come aggiungere e organizzare modelli di footprint, simulazione e integrità del segnale, incluse le informazioni di mappatura necessarie per collegarli ai simboli.
Il componente fisico che viene montato sulla scheda è rappresentato da un simbolo schematico durante l'acquisizione dello schema e da un footprint PCB durante la progettazione della scheda. I componenti di Altium Designer possono essere:
- Creati e posizionati da librerie locali oppure
- Posizionati direttamente da un Workspace connesso, accessibile a tutto il team di progettazione.
I simboli possono essere copiati dall'editor schematico in una libreria schematica, copiati tra librerie schematiche oppure creati da zero utilizzando Schematic Symbol Generation Tool o gli strumenti di disegno.
Creazione di una nuova libreria schematica
Per creare una nuova libreria schematica, seleziona il comando File » New » Library dai menu principali e seleziona l'opzione Schematic Library nell'area File della finestra di dialogo New Library.
Dopo aver fatto clic su Create, viene creato un nuovo documento di libreria schematica denominato Schlib1.SchLib, che viene visualizzato nel pannello Projects, e viene mostrato un foglio del componente vuoto denominato Component_1.
Il contenuto della libreria è visualizzato nel pannello SCH Library.
Ora puoi aggiungere, rimuovere o modificare i componenti schematici nella nuova libreria schematica utilizzando i comandi dell'editor dei simboli schematici.
Creazione di una libreria schematica dai documenti schematici
Puoi anche creare una libreria schematica di tutti i componenti utilizzati nei documenti schematici sorgente del progetto attivo facendo clic su Design » Make Schematic Library. Questa funzione è molto utile se desideri creare una libreria di lavoro esatta, o un archivio, del progetto completato. Se sono presenti componenti con lo stesso riferimento di libreria ma una struttura interna diversa, si aprirà la finestra di dialogo Component Grouping, nella quale specificare i parametri da utilizzare per il raggruppamento.
Tutti i documenti schematici sorgente del progetto attivo verranno aperti, se non lo sono già, e un documento di libreria (<ProjectName>.SchLib) verrà creato automaticamente e aggiunto al progetto. Il documento si aprirà come documento attivo nell'editor dei simboli schematici. La libreria conterrà tutti i componenti utilizzati nel progetto. Il file creato verrà visualizzato nel pannello Projects come parte del progetto, nella sottocartella Libraries\Schematic Library Documents. Inizialmente, il file non viene salvato sul disco rigido.
Creazione di una libreria schematica da un foglio schematico
È possibile creare un nuovo simbolo di componente schematico dal foglio schematico attivo; le porte presenti sul foglio diventeranno i pin del componente. A tale scopo, scegli il comando Design » Create Component From Sheet dai menu principali oppure fai clic con il pulsante destro del mouse nello spazio di progettazione principale, lontano dagli oggetti del progetto, e scegli il comando Sheet Actions » Create Component From Sheet dal menu contestuale.
Dopo aver avviato il comando, verrà visualizzata la finestra di dialogo Symbol Options. Utilizza questa finestra di dialogo per definire l'altezza e la larghezza del simbolo, la lunghezza dei pin e il loro stile, in relazione alle porte sul foglio sorgente.

La finestra di dialogo Symbol Options
Opzioni e controlli della finestra di dialogo Symbol Options
- Auto Width - consente di determinare automaticamente la larghezza del componente creato. Se l'opzione non è selezionata, puoi personalizzare la larghezza inserendo un valore nella casella di testo.
- Auto Height - consente di determinare automaticamente l'altezza del componente creato. Se l'opzione non è selezionata, puoi personalizzare l'altezza inserendo un valore nella casella di testo.
- Pin Length - inserisci un valore per la lunghezza dei pin del componente creato. Il valore predefinito è 10.
-
Style - consente di selezionare lo stile delle porte:
- Input/Output - le porte di ingresso appariranno come pin sul lato destro del simbolo e le porte di uscita appariranno come pin sul lato sinistro del simbolo. Entrambe sono disposte in ordine alfabetico.
- Relative Schematic Port Layout - le porte sul foglio schematico appariranno come pin sul simbolo nello stesso ordine dello schema.
- Proportional Schematic Port Layout - le porte sul foglio schematico appariranno come pin sul simbolo e le dimensioni del simbolo verranno adattate per rispecchiare la disposizione delle porte nello schema.
Dopo aver fatto clic su OK nella finestra di dialogo, il nuovo componente verrà creato in un nuovo documento di libreria schematica (Schlib1.SchLib), con lo stesso nome del documento schematico. La libreria verrà aperta come documento attivo e il nuovo componente verrà presentato come componente attivo al suo interno.
Creazione di un nuovo componente schematico
In una libreria schematica è possibile creare un numero qualsiasi di simboli di componenti. Per creare un nuovo componente schematico in una libreria esistente, seleziona Tools » New Component dai menu principali o dal menu contestuale dello spazio di progettazione oppure fai clic sul pulsante Add sotto l'area Design Item ID nel pannello SCH Library.
Dopo aver avviato il comando, si aprirà la finestra di dialogo New Component. Utilizza il campo Design Item ID della finestra di dialogo per assegnare al componente un nome appropriato.

La finestra di dialogo New Component
Dopo aver fatto clic su OK, nella libreria verrà creato un nuovo componente con questo nome e nello spazio di progettazione verrà aperto e reso attivo un foglio del componente vuoto.
Poiché una nuova libreria contiene sempre un componente vuoto, puoi anche rinominare Component_1 per iniziare a creare un componente. A tale scopo, seleziona Component_1 dall'elenco Design Item ID nel pannello SCH Library, quindi fai clic sul pulsante Edit nel pannello oppure fai doppio clic su Component_1 per aprire il pannello Properties in modalità Component. Digita nel campo Design Item ID il nuovo nome del componente che lo identifica in modo univoco, quindi premi Enter.
Per rimuovere il componente corrente dalla libreria attiva, scegli Tools » Remove Component dai menu principali oppure fai clic con il pulsante destro del mouse nello spazio di progettazione, quindi scegli Tools » Remove Component dal menu contestuale. I componenti possono anche essere eliminati direttamente dal pannello SCH Library. Seleziona i componenti desiderati nell'elenco Design Item ID , quindi fai clic sul pulsante Delete sotto l'elenco oppure fai clic con il pulsante destro del mouse e scegli il comando Delete dal menu contestuale. Utilizzando il pannello per eliminare i componenti, è possibile eseguire eliminazioni multiple.
Aggiunta di modelli al componente schematico
È possibile aggiungere a un componente schematico un numero qualsiasi di modelli di footprint PCB, nonché file di modello utilizzati per la simulazione dei circuiti e l'analisi dell'integrità del segnale. Se un componente dispone di più modelli (ad esempio, più footprint), è possibile selezionare il modello appropriato nel pannello Properties quando si posiziona il componente su uno schema. Per quanto riguarda il reperimento dei modelli, è possibile crearli autonomamente oppure scaricare da Internet il file di modello di un produttore. Le librerie PCB possono includere un numero qualsiasi di footprint PCB.
È possibile aggiungere modelli al componente corrente nei seguenti modi:
-
Dall'area Model nella parte inferiore dell'area di progettazione (fare clic sul simbolo delle frecce rivolte verso il basso nell'angolo inferiore destro dell'area di progettazione, come mostrato nell'immagine seguente).

Fare clic sul simbolo della freccia evidenziato per accedere all'area Model dell'area di progettazione. -
Utilizzando il menu a discesa Add nell'area Parameters del pannello Properties in modalità Component e selezionando quindi il modello.
-
La finestra di dialogo Model Manager dell'editor dei simboli schematici (Tools » Model Manager, oppure facendo clic con il pulsante destro del mouse su un componente nel pannello SCH Library e selezionando Model Manager dal menu contestuale) consente di visualizzare e organizzare i modelli di tutti i componenti presenti nella libreria schematica attiva. Ad esempio, è possibile aggiungere lo stesso modello a più componenti selezionati.

La finestra di dialogo Model ManagerOpzioni e controlli della finestra di dialogo Model Manager
-
Mask – digitare il nome di un componente in questo campo per filtrare i contenuti. Utilizzare "
*" come carattere jolly. - Component list – elenca tutti i componenti esistenti nella libreria schematica corrente e le relative descrizioni.
- Model list – elenca tutti i modelli associati al componente selezionato. Il menu contestuale di quest'area include i comandi per Add, Copy, Paste, Remove o Edit un modello.
-
Add – fare clic per accedere a un menu a discesa e scegliere tra le opzioni di modello elencate di seguito. Per ogni opzione si aprirà una finestra di dialogo associata, che consente di personalizzare (se necessario) e aggiungere il modello desiderato.
-
Footprint– disposizione fisica necessaria sul circuito stampato per montare un componente o un elemento di fissaggio. -
Pin Info– aggiunge un file Pin Info, utilizzabile come descrizione dei pin di un FPGA/MC per qualsiasi strumento FPGA di terze parti o per altri tipi di componenti. -
PCB3D– aggiunge un modello 3D al componente. -
Simulation– aggiunge un modello Spice al componente per eseguire una simulazione del circuito. -
Ibis Model– aggiunge un modello Ibis per migliorare la modellazione dei pin dei circuiti integrati durante le analisi dell'integrità del segnale. -
Signal Integrity– aggiunge un modello di integrità del segnale per configurare e controllare le analisi dell'integrità del segnale.
-
- Copy – fare clic per copiare il modello desiderato dall'elenco.
- Paste – fare clic per incollare un modello nell'elenco. Il nuovo modello apparirà in fondo all'elenco.
- Remove – fare clic per rimuovere i footprint selezionati.
- Edit – fare clic per aprire la finestra di dialogo corrispondente, nella quale è possibile modificare l'assegnazione del modello.
- Refresh Preview – fare clic per aggiornare l'anteprima del modello. Fare clic su 2D/3D per passare dall'anteprima 2D a quella 3D e viceversa.
-
Mask – digitare il nome di un componente in questo campo per filtrare i contenuti. Utilizzare "
Mappatura del modello sul simbolo
Durante il collegamento del modello, le informazioni sul componente devono essere mappate dallo schema al modello di destinazione.
Le informazioni specifiche del dominio risiedono in file di modello con un formato predefinito, come i file IBIS, MDL e CKT. Per consentire al sistema di accedere a tali informazioni sono necessarie altre informazioni, come la mappatura dei pin e la netlist tra il simbolo schematico e il modello specifico del dominio. Queste informazioni vengono definite in un editor di modelli specifico del dominio, che si apre quando un modello viene aggiunto o modificato. Oltre al riferimento al file di modello, l'editor includerà anche tutte le informazioni sulla mappatura dei pin o sulla netlist necessarie per quel tipo di modello.
Percorsi di ricerca dei file di modello
Quando si aggiunge un modello a un componente nell'editor dei simboli schematici, viene creato un collegamento al modello; i dati del modello non vengono copiati né memorizzati nel componente schematico. Ciò significa che i modelli collegati devono essere disponibili sia durante la creazione della libreria sia quando il componente viene posizionato su un foglio schematico. Quando si lavora nell'editor delle librerie, il collegamento dal componente alle informazioni del modello viene risolto utilizzando i seguenti percorsi di ricerca validi:
- La ricerca viene eseguita prima nelle librerie incluse nel progetto del pacchetto di librerie corrente.
- Successivamente, la ricerca viene eseguita nelle librerie PCB (non nelle librerie integrate) disponibili nell'elenco corrente Installed Libraries. Nota: è possibile modificare l'ordine delle librerie nell'elenco.
- Infine, la ricerca viene eseguita in tutte le librerie di modelli presenti nei percorsi di ricerca del progetto. I percorsi di ricerca sono definiti nella scheda Search Paths della finestra di dialogo Project Options (Project » Project Options). Nota: non è possibile sfogliare le librerie presenti nei percorsi di ricerca per individuare un modello; tuttavia, il compilatore le include nella ricerca di un modello.
Consultare la sezione Gestione delle librerie disponibili basate su database e su file della pagina Ricerca di componenti nelle librerie basate su file e database per ulteriori informazioni sulle modalità di ricerca dei modelli nell'editor dei simboli schematici e nell'editor degli schemi.
Aggiunta di un footprint al componente schematico
Per aggiungere un footprint al componente schematico corrente, scegliere Footprint quando si seleziona un'opzione per aggiungere un modello come descritto sopra. Si aprirà la finestra di dialogo PCB Model.

La finestra di dialogo PCB Model
Opzioni e controlli della finestra di dialogo PCB Model
Modello di footprint
- Name - visualizza il nome del footprint.
- Browse - fare clic per aprire la finestra di dialogo Browse Libraries e cercare il footprint di destinazione.
- Pin Map - fare clic per aprire la finestra di dialogo Model Map e mappare i pin tra il simbolo schematico e il footprint PCB.
- Description - inserire una descrizione significativa per il footprint.
Libreria PCB
- Any - abilitare per cercare il footprint desiderato in tutte le librerie attualmente disponibili.
- Library name - abilitare per cercare il footprint desiderato nella libreria indicata. Inserire il nome della libreria direttamente nel campo di testo.
- Library path - abilitare per cercare i footprint desiderati nella libreria indicata nel percorso specificato. Fare clic sul pulsante Choose per selezionare un percorso.
- Use footprint from component library - questa opzione diventa disponibile quando il componente viene posizionato da una libreria compilata, ad esempio una libreria integrata, o da un server. Se necessario, è possibile modificarla per un componente già posizionato, consentendo di selezionare una libreria PCB di origine diversa.
Footprint selezionato
Quest'area mostra l'anteprima del footprint desiderato. Fare clic sull'icona in basso a sinistra nell'anteprima per passare dalla modalità 2D alla modalità 3D e viceversa. L'area di visualizzazione rimane vuota se il footprint non viene trovato nella libreria PCB specificata.
Nella parte superiore della finestra di dialogo PCB Model è presente un campo Name che deve contenere il nome del footprint. È possibile inserire il nome direttamente oppure utilizzare il pulsante Browse per trovarlo nelle librerie di footprint disponibili tramite la finestra di dialogo Sfoglia librerie. Il menu a discesa Libraries consente di accedere a un elenco delle librerie disponibili. Fare clic sul pulsante
per aprire la finestra di dialogo Librerie basate su file disponibili, nella quale è possibile aggiungere o rimuovere librerie. Se il footprint desiderato non è disponibile in nessuna delle librerie attuali, occorre cercarlo utilizzando il pulsante Find per aprire la finestra di dialogo Ricerca nelle librerie basate su file.
Nella parte inferiore della finestra di dialogo PCB Model è presente una stringa di testo che indica dove è stato trovato il modello.
La capacità del software di trovare il modello dipende dall'impostazione che definisce dove può cercare i modelli. Si tratta dell'impostazione immediatamente sotto il nome del modello. Le opzioni vanno da Any, che indica di cercare questo modello in tutte le librerie disponibili, a Integrated Library o Server, che indicano che il modello può essere utilizzato solo dalla libreria integrata o dal Workspace specificati.
La finestra di dialogo PCB Model include queste opzioni:
Per configurare la mappatura dei pin per un footprint collegato, fare clic su Pin Map nella finestra di dialogo PCB Model per aprire la finestra di dialogo Model Map e apportare le modifiche necessarie alle coppie pin-pad. Si noti che si sta mappando la proprietà Designator del pin del simbolo schematico al designatore del pin equivalente del modello, che per un footprint PCB corrisponde al Designator del pad.
- Component Pin Designator colonna - elenca tutti i pin del simbolo schematico; questo campo non è modificabile.
- Model Pin Designator colonna - elenca i numeri dei pin del modello. In questo esempio, mostra i pad del footprint PCB assegnato; modificare ciascuno di questi campi per associare il pad del PCB al pin equivalente del simbolo schematico.
Aggiungere un modello di simulazione al componente schematico
Quando si crea un nuovo componente, in genere si reperisce il modello SPICE dal sito del produttore del dispositivo. Per aggiungere un modello di simulazione al componente schematico corrente, scegliere Simulation quando si seleziona un'opzione per aggiungere un modello come descritto sopra. Si aprirà la finestra di dialogo Modello di simulazione . In questa finestra di dialogo si eseguono la selezione del modello e la mappatura tra i pin del simbolo schematico e i pin del modello.
È inoltre possibile utilizzare SPICE Model Wizard (Tools » XSpice Model Wizard) per creare determinati tipi di modelli SPICE da aggiungere al componente: ulteriori informazioni.
Aggiungere un modello nella fase di progettazione dello schema
Nella fase di progettazione dello schema, il progetto è un insieme di componenti collegati logicamente. Per testare o implementare il progetto, ad esempio tramite simulazione circuitale, layout PCB, analisi dell'integrità del segnale e così via, è necessario trasferirlo a un altro dominio di progettazione. A tale scopo, deve essere disponibile un modello adatto di ciascun componente per il dominio di destinazione.
-
I footprint vengono collegati al componente schematico aggiungendoli nell'area Parametri del pannello Properties. Fare clic sul menu a discesa Add, quindi selezionare Footprint per aprire la finestra di dialogo PCB Model e configurare il footprint.
-
I modelli vengono collegati al componente schematico aggiungendoli nell'area Parametri del pannello Properties. Fare clic sul menu a discesa Add , quindi selezionare Simulation o Ibis Model per aprire la rispettiva finestra di dialogo.
Utilizzare i parametri per aggiungere dettagli al componente
I parametri del componente consentono di definire informazioni aggiuntive sul componente. I parametri permettono di specificare ulteriori informazioni testuali sul componente. Queste possono includere specifiche elettriche (ad esempio potenza o tolleranza), dettagli relativi all'acquisto o alle scorte, note del progettista, riferimenti alle schede tecniche del componente: in pratica, qualsiasi informazione utile per lo scopo desiderato, come dati richiesti dall'azienda nella distinta base, dati del produttore, un riferimento alla scheda tecnica del componente o istruzioni di progettazione, quali regole di progettazione o assegnazione a una classe PCB, ecc.
I parametri possono essere definiti nell'editor delle librerie schematiche durante la creazione del componente utilizzando il pannello Properties.
Aggiungere parametri a un componente
Per un singolo componente, i parametri vengono aggiunti nell'area Parameters del pannello Properties in modalità Component . Come accennato, questa operazione può essere eseguita nella libreria oppure dopo che il componente è stato posizionato sul foglio dello schema.
Per aggiungere un parametro a un componente schematico, procedere come segue:
- Fare doppio clic sul nome del componente nel pannello Libreria SCH per aprire il pannello Proprietà in modalità Componente.
- Nell'area Parameters, selezionare Parameter dal menu a discesa Add.
- Inserire il nome desiderato per il parametro e un valore.
- Assicurarsi che l'opzione di visibilità del parametro sia abilitata se si desidera visualizzare il nome e il valore quando il componente viene posizionato su un foglio dello schema.
-
Fare clic su Font Link e Other nella parte inferiore dell'area Parameters per accedere a ulteriori opzioni di configurazione dei parametri.
Aggiunta di parametri a più componenti
I parametri sono un elemento fondamentale di ogni componente ed è comune che molti parametri vengano utilizzati in più componenti. Oltre ad aggiungerli singolarmente a ciascun componente, è possibile utilizzare il comando Parameter Manager (Tools » Parameter Manager) per aggiungerli a più componenti. Oltre ad aggiungere e rimuovere parametri, è anche possibile modificarne i valori su più componenti.

La finestra di dialogo Parameter Table Editor consente di modificare tutti i parametri di tutti i componenti.
Note sulla modifica di più parametri:
- I parametri dei componenti di una libreria o dei componenti utilizzati in un progetto schematico possono essere modificati con la stessa procedura. Selezionare Tools » Parameter Manager nell'editor degli schematici o nell'editor delle librerie di schematici per avviare la procedura.
- Poiché i parametri possono essere aggiunti a diversi tipi di oggetti, il primo passaggio consiste nel selezionare i tipi di oggetto per i quali modificare i parametri nella finestra di dialogo Parameter Editor Options.
- La modifica dei parametri viene eseguita nella finestra di dialogo Editor della tabella dei parametri. È possibile accedere alla finestra di dialogo in diversi modi, quindi il suo titolo può variare. La modalità di utilizzo è la stessa indipendentemente da come vi si accede: utilizzare le combinazioni di tasti standard di Windows per selezionare le celle desiderate, quindi fare clic con il pulsante destro del mouse e scegliere un'azione di modifica.
- Le modifiche non vengono applicate immediatamente, ma tramite un ordine di modifica tecnica (ECO).
- Ogni cella in corso di modifica è contrassegnata da una piccola icona colorata. Per una descrizione di ciascuna icona, consultare la pagina Finestra di dialogo Editor della tabella dei parametri.
Associazione di un parametro al campo Commento del componente
I parametri predefiniti del componente visualizzati sullo schematico sono il designatore e il commento. Quando il progetto viene trasferito dall'editor degli schematici all'editor PCB, anche le stringhe Designatore e Commento sono le stringhe predefinite che possono essere facilmente visualizzate sulla scheda.
Per visualizzare il valore di qualsiasi parametro del componente sullo schematico e sul PCB, ad esempio il valore di un parametro denominato Capacitance, è possibile associare qualsiasi parametro del componente al campo Comment del componente utilizzando una tecnica nota come riferimento indiretto alle stringhe.
Questa operazione viene eseguita inserendo il nome del parametro nel formato =ParameterName. Ad esempio, per associare il valore del parametro Capacitance al campo Comment del componente, inserire la stringa =Capacitance nel campo Comment del pannello Properties, come mostrato di seguito. Una stringa definita con la sintassi '=ParameterName' viene chiamata special string.
Le stringhe speciali vengono convertite automaticamente per la visualizzazione sullo schermo. Se un parametro associato come stringa speciale non ha un valore, viene invece visualizzato il nome del parametro in grigio, se l'opzione Display Names of Special Strings that have No Value Defined è abilitata nella pagina Schematico - Modifica grafica della finestra di dialogo Preferences. Se questa opzione è disabilitata, non viene visualizzato nulla.

Utilizzare la funzionalità delle stringhe speciali per associare il valore di qualsiasi parametro al Comment del componente.
Definizione di collegamenti cliccabili alle informazioni di riferimento
L'area Parametri del pannello Properties in modalità Component consente di aggiungere un collegamento facendo clic sul menu a discesa Add e selezionando Link. Questa funzionalità può essere utilizzata, ad esempio, per includere collegamenti a una scheda tecnica o al sito web di un produttore. È possibile definire un numero qualsiasi di collegamenti per un componente.
Un collegamento deve essere configurato come segue:
- Name - consente di definire la voce visualizzata nel menu:
-
Url - consente di definire il documento di destinazione. I seguenti esempi sono voci valide:
-
C:\Design_Projects\Schematics\Modifications.txt -
C:\Design_Projects\Schematics\MyDataSheet.pdf -
https://www.altium.com -
www.altium.com/documentation
-
I collegamenti visualizzati nel pannello sono attivi: facendo clic sul testo del collegamento, l'URL viene aperto nel browser preferito. Per modificare un collegamento esistente, fare clic in un punto qualsiasi della cella al di fuori del testo del collegamento, quindi fare clic sul pulsante di modifica.
È possibile accedere ai collegamenti tramite il menu contestuale facendo clic con il pulsante destro del mouse sul componente posizionato nello schematico. Sebbene sia possibile definire un numero qualsiasi di collegamenti con nome, solo i primi 9 saranno disponibili nel menu contestuale References dell'editor degli schematici. Gli ulteriori collegamenti con nome non verranno visualizzati nel menu Reference dell'editor degli schematici, ma saranno inclusi nel PDF generato e funzioneranno come collegamenti attivi quando si fa clic sul componente nel documento PDF (vedere di seguito).
Fare clic con il pulsante destro del mouse su un componente nel foglio per accedere ai relativi collegamenti.
Dopo aver avviato il comando, verrà aperto il documento di destinazione indicato. Una pagina web di destinazione specificata tramite URL verrà aperta direttamente (se disponibile). Per un documento PDF o di testo, la ricerca viene eseguita come segue:
-
Se è specificato un percorso, la ricerca viene eseguita prima in quella posizione.
-
Se il documento non viene trovato in questa posizione, o se non è specificato alcun percorso, la ricerca viene eseguita nella cartella
\Helpdell'installazione di Altium Designer.
Verifica del componente e generazione dei report
Per verificare che i nuovi componenti siano stati creati correttamente, è possibile generare diversi report. Assicurati di salvare il file di libreria prima di generare i report.
Elenco della libreria
Il Library List elenca ciascun componente e i relativi dettagli presenti nel documento di libreria attivo.
- Seleziona Reports » Library List.
-
Viene generato un file di testo ASCII (<LibraryName>.rep), che viene aperto come documento attivo. Il file include il numero totale dei componenti nella libreria e riporta il nome e una descrizione di ciascun componente, se disponibile.
Viene inoltre creato e aperto un secondo file (<LibraryName>.csv), a cui fa riferimento il file .rep. Si tratta di un file con valori separati da virgole, contenente informazioni più dettagliate per ciascun componente della libreria, estratte dalle proprietà di ogni componente.
Report della libreria
Puoi generare un report dal documento di libreria attivo, contenente informazioni sui componenti memorizzati nella libreria. Il report può essere configurato per includere informazioni su parametri, pin e modelli, nonché anteprime dei componenti e dei modelli (a colori o in bianco e nero). Il report può essere generato come documento Microsoft Word (*.doc) o come documento HTML standard (*.html).
-
Seleziona Reports » Library Report per aprire la finestra di dialogo Library Report Settings. Utilizza questa finestra di dialogo per configurare il contenuto e lo stile del report, nonché il percorso e il nome con cui generarlo. Per impostazione predefinita, il report avrà lo stesso nome della libreria schematica e verrà salvato nella stessa posizione.
Opzioni e controlli della finestra di dialogo Library Report Settings
Nome del file di output
- Output File Name - mostra il nome completo del file di output, incluso il percorso. Utilizza l'icona di esplorazione delle cartelle per cercare e selezionare una posizione e un nome diversi
- Document style - l'estensione del file sarà .doc e il report della libreria verrà generato in formato Word.
- Browser style - l'estensione del file sarà .html e verrà generata una pagina web in un browser Internet. Se lo desideri, puoi modificare il nome completo del file di output.
- Open generated report - abilita questa opzione per aprire il report generato in MS Word o in un browser Internet.
- Add generated report to current project - abilita questa opzione per aggiungere il report generato al progetto corrente.
Includi nel report
- Component's Parameters - abilita questa opzione per includere nel report i parametri del componente.
- Component's Pins - abilita questa opzione per includere nel report i pin del componente.
- Component's Models - abilita questa opzione per includere nel report i modelli del componente.
Disegna anteprime per
- Components - abilita questa opzione per disegnare un'anteprima dei componenti nel report.
- Models - abilita questa opzione per disegnare un'anteprima dei modelli nel report.
Impostazioni
- Use Color - abilita questa opzione per consentire al report della libreria di contenere elementi a colori, sia nei documenti Word sia in quelli web.
-
Configura le impostazioni del report, quindi fai clic su OK. Se hai scelto di aprire il report dopo la generazione, questo verrà aperto a condizione che sia disponibile Microsoft Word (per un report in formato Doc) o il browser predefinito (per un report in formato HTML).
Se hai scelto di aggiungere il report al progetto dopo la generazione, questo apparirà nel pannello Projects nella sottocartella Generated\Documents (per un report in formato HTML) o nella sottocartella Generated\Text Documents (per un report in formato Doc).
Controllo delle regole dei componenti
Il Component Rule Checker verifica la presenza di errori quali duplicati e pin mancanti.
-
Seleziona Reports » Component Rule Check (scorciatoia R, R) per aprire la finestra di dialogo Library Component Rule Check. Imposta gli attributi da verificare, quindi fai clic su OK.
Opzioni e controlli della finestra di dialogo Library Component Rule Check
Duplicati
- Component Names – abilita questa opzione per verificare la presenza di nomi di componenti duplicati.
- Pins – abilita questa opzione per verificare la presenza di pin duplicati.
Elementi mancanti
- Description – abilita questa opzione per verificare la presenza di descrizioni mancanti.
- Footprint – abilita questa opzione per verificare la presenza di nomi di footprint mancanti.
- Default Designator – abilita questa opzione per verificare la presenza di designatori predefiniti mancanti.
- Pin Name – abilita questa opzione per verificare la presenza di nomi di pin mancanti.
- Pin Number – abilita questa opzione per verificare la presenza di numeri di pin mancanti.
- Missing Pins In Sequence – abilita questa opzione per verificare la presenza di pin mancanti in una sequenza.
-
Nell'area di progettazione viene visualizzato un report intitolato <
libraryname.ERR>, che elenca tutti i componenti che violano le regole verificate. - Apporta le modifiche necessarie alla libreria, quindi genera nuovamente il report.
- Salva la libreria schematica. Chiudi il report per tornare all'area di progettazione dell'editor schematico.
Copia di componenti da altre fonti
Spostamento e copia di componenti da altre librerie
Puoi anche copiare componenti nella tua libreria schematica da altre librerie schematiche aperte e modificarne le proprietà secondo necessità. Se il componente fa parte di una libreria integrata, dovrai aprire il file .IntLib e scegliere Yes per estrarre le librerie sorgente. Apri quindi la libreria sorgente generata (*.SchLib) dal pannello Projects .
-
Seleziona il componente da spostare o copiare nell'elenco Design Item ID del pannello SCH Library affinché venga visualizzato nella finestra di progettazione.
-
Seleziona Tools » Move Component o Tools » Copy Component per aprire la finestra di dialogo Destination Library, che elenca tutti i documenti di libreria schematica attualmente aperti. Nella finestra di dialogo verranno elencate tutte le librerie aperte, indipendentemente dal fatto che siano documenti liberi o facciano parte del progetto corrente o di qualsiasi altro progetto aperto.
-
Seleziona il documento in cui desideri spostare/copiare il componente, quindi fai clic su OK. Il componente o una sua copia verrà inserito nella libreria di destinazione, dove potrai modificarlo, se necessario.
Copia di componenti dagli schemi
Puoi anche copiare componenti dai fogli dello schema alla tua libreria schematica e modificarne le proprietà secondo necessità. Seleziona il componente che desideri copiare sul foglio dello schema e copialo utilizzando il comando Copy dal menu contestuale del componente selezionato (scorciatoia: Ctrl+C). Quindi apri la libreria schematica di destinazione, fai clic con il pulsante destro del mouse nell'area dell'elenco dei componenti del pannello SCH Library e seleziona Paste (scorciatoia: Ctrl+V).
Tieni presente che, se il componente è stato posizionato su un foglio dello schema dal Workspace connesso o dal pannello Manufacturer Part Search, il collegamento al Workspace di origine viene mantenuto. Questi componenti sono contraddistinti dall'icona
nel pannello SCH Library. Puoi rimuovere i collegamenti al Workspace per tutti i componenti della libreria aperta scegliendo il comando Tools » Clear Server Links dai menu principali. Dopo aver avviato il comando, si apre la finestra di dialogo Confirm Clear Vault Links. Fai clic su Yes per rimuovere i collegamenti al Workspace specificati nella finestra di dialogo e salvare la libreria; fai clic su No per uscire dalla finestra di dialogo senza eseguire alcuna azione.

La finestra di dialogo Confirm Clear Vault Links
Copia di più componenti
Puoi anche utilizzare il pannello SCH Library per copiare più componenti. Seleziona i componenti nel pannello utilizzando le funzioni standard Ctrl+Click o Shift+Click, quindi fai clic con il pulsante destro del mouse su uno dei componenti selezionati e scegli Copy dal menu a comparsa. Puoi quindi fare clic con il pulsante destro del mouse nell'elenco e:
- Incollare i componenti nella stessa libreria.
- Incollare i componenti in un'altra libreria aperta.
- Copiare e incollare componenti da uno schema in una libreria aperta utilizzando la stessa tecnica.
Spostamento di un progetto da una posizione a un'altra
Quando un componente viene posizionato in un progetto da una libreria, viene memorizzato nella cache del file di progetto, in modo che il documento possa essere aperto in qualsiasi posizione senza che le librerie di origine debbano essere presenti o caricate. Questo è utile quando si sposta un progetto da una posizione a un'altra, poiché non è necessario spostare anche le librerie. Tieni presente che anche il nome della libreria di origine e i nomi dei modelli vengono memorizzati nelle proprietà del componente posizionato.
Pannello SCH Library
Il pannello SCH Library consente di visualizzare e modificare i componenti memorizzati nel documento della libreria schematica attivo. Il pannello consente inoltre di trasferire direttamente al documento dello schema le modifiche apportate ai componenti nella libreria e di definire i collegamenti ai modelli per un componente.

Esplora, visualizza e modifica in modo interattivo i componenti della libreria schematica e i relativi pin.
Contenuto e utilizzo del pannello SCH Library
Esplorazione della libreria
Quando fai clic su una voce di componente nell'elenco, questa diventa la parte attiva nella finestra dell'editor di progettazione. La finestra dell'editor di progettazione è modificabile e consente di cambiare il simbolo del componente e di aggiungere, modificare o rimuovere i modelli collegati al componente secondo necessità. Selezionando un oggetto Pin nel pannello, l'oggetto grafico corrispondente viene evidenziato e ingrandito nell'area di lavoro dell'editor. In questo modo, il pannello SCH Library offre un metodo rapido e semplice per esplorare, visualizzare e accedere ai componenti e ai pin della libreria schematica.
Filtro dei contenuti
I contenuti dell'elenco Components possono essere filtrati, consentendoti di trovare rapidamente un componente specifico all'interno della libreria. Questo è particolarmente utile se la libreria contiene un numero elevato di elementi. Il filtro può essere applicato utilizzando uno dei metodi descritti nelle sezioni seguenti.
Filtro indiretto
Questo metodo utilizza il campo di ricerca nella parte superiore del pannello per filtrare i contenuti dell'elenco. La maschera dei nomi viene applicata in base al testo inserito nel campo. Rimarranno visualizzati solo i componenti dell'elenco che corrispondono al criterio inserito.
La funzione di filtro non distingue tra maiuscole e minuscole e supporta il filtraggio durante la digitazione: il contenuto dell'elenco Components viene filtrato man mano che digiti.
Utilizza il carattere jolly * per filtri più elaborati. Ad esempio, digitando MN* verranno visualizzati solo i footprint dei componenti i cui nomi iniziano con MN oppure, come nell'immagine seguente, digitando *r34 verranno visualizzati solo i footprint dei componenti il cui nome contiene R34.
Filtro diretto
Questo metodo è disponibile per tutte le aree del pannello e consente di passare rapidamente a una voce digitando direttamente nell'area dell'elenco. Non viene applicata alcuna maschera, quindi l'intero contenuto dell'elenco rimane sempre visibile.
Per utilizzare questa funzione e trovare rapidamente il footprint di un componente, fai clic nella sezione Components del pannello, quindi digita la prima lettera del footprint del componente a cui desideri passare. Ad esempio, se desideri passare rapidamente alle voci dei componenti che iniziano con la lettera R, premi R sulla tastiera. Verrà attivato il primo componente nell'elenco che inizia con R.
Se sono presenti più Design Item IDs che iniziano con la stessa lettera, soprattutto se la libreria è particolarmente grande, digita altre lettere per individuare la voce specifica desiderata. Ad esempio, digita res per evidenziare il primo elemento della serie RES nell'elenco.
Filtro combinato
In alcune situazioni può essere utile utilizzare contemporaneamente il filtro indiretto e quello diretto. Se, ad esempio, sai che il componente che desideri individuare ha una variante di sottotipo BRMZ e un prefisso AD74, queste informazioni possono essere utilizzate rispettivamente come criteri per il filtro indiretto (maschera) e per quello diretto.
Sezioni del pannello
Componenti
Quando fai clic su una voce nell'Components elenco, questa diventa la parte attiva nella finestra dell'editor di progettazione e per i quattro pulsanti situati direttamente sotto l'elenco. Questi pulsanti offrono i seguenti comandi utilizzabili per l'elenco dei componenti:
-
Place - fai clic per posizionare il componente attivo in un documento schematico. Il documento schematico utilizzato dipende dalla presenza o meno di documenti schematici attualmente aperti.
- Se non ci sono documenti schematici aperti, facendo clic sul pulsante verrà creato un nuovo documento schematico, che diventerà il documento attivo nella finestra dell'editor di progettazione. Il componente di libreria attivo apparirà agganciato al cursore, pronto per essere posizionato.
- Se sono attualmente aperti uno o più documenti schematici, l'ultimo documento attivo (indipendentemente dal progetto a cui appartiene) diventerà il documento attivo nella finestra dell'editor di progettazione e il componente di libreria attivo apparirà agganciato al cursore, pronto per essere posizionato.
- Add - fai clic per aggiungere un nuovo componente al documento di libreria. Si aprirà la finestra di dialogo Nuovo componente. Inserisci il nome desiderato per il nuovo componente da aggiungere all'elenco. Nella finestra dell'editor di progettazione verrà aperto un foglio vuoto, pronto per la definizione del componente.
- Delete - fai clic per eliminare definitivamente i componenti selezionati dal documento di libreria. Si aprirà una finestra di dialogo che chiederà se procedere con l'eliminazione.
- Edit - fai clic per aprire il pannello Proprietà, in cui puoi visualizzare/modificare le proprietà associate al componente attivo. Il pannello consente di creare collegamenti a nuovi modelli o di modificare quelli esistenti. Anche facendo doppio clic su una Design Item ID voce si aprirà il Propertiespannello.
Menu contestuale
Facendo clic con il pulsante destro del mouse su una voce nell'Components elenco si aprirà un menu di comandi.
I comandi sono i seguenti:
- Select all - seleziona rapidamente tutte le voci dei componenti nell'elenco.
- Update Schematic Sheets - fai clic per trasferire tutte le modifiche apportate ai componenti nel documento di libreria attivo a tutti i documenti schematici aperti. Verranno aggiornate tutte le istanze dei componenti modificati presenti nei documenti di progettazione.
-
Model Manager - accedi alla finestra di dialogo Gestione modelli, in cui puoi aggiungere, modificare o rimuovere modelli per qualsiasi componente contenuto nella libreria attiva.
- Copy - inserisci una copia dei componenti selezionati negli appunti interni dell'editor delle librerie schematiche.
- Cut - inserisci una copia dei componenti selezionati negli appunti interni dell'editor delle librerie schematiche ed elimina definitivamente i componenti dalla libreria. Apparirà una finestra di dialogo che chiederà conferma prima di procedere con l'eliminazione.
- Paste - incolla un componente dagli appunti interni dell'editor delle librerie schematiche nel documento di libreria attivo.
- Delete - utilizza questo comando per eliminare definitivamente i componenti selezionati dal documento di libreria. Apparirà una finestra di dialogo che chiederà se procedere con l'eliminazione.
Note
-
Per selezionare più voci in un elenco sono supportate le funzionalità standard Ctrl+Click e Shift+Click.
-
Il componente attivo è quello il cui simbolo e le cui informazioni sul modello corrispondente sono attualmente visualizzati nella finestra dell'editor di progettazione. Un componente può essere attivo senza essere necessariamente selezionato nell'Components elenco.
-
Ctrl+Click su una voce selezionata in un elenco per deselezionarla.
-
Le scorciatoie da tastiera Home, Down Arrow, Up Arrow e End e i comandi First Component, Next Component, Previous Component e Last Component del sottomenu Tools del menu contestuale dell'area di progettazione possono essere utilizzati per visualizzare rispettivamente la prima voce, la successiva, la precedente e l'ultima in un'area elenco.
-
I componenti multiparte vengono visualizzati nell'elenco con una freccia accanto. Ogni parte è elencata sotto come voce secondaria.
-
Nelle sezioni del pannello che contengono più colonne di dati, è possibile ordinare i dati in base a qualsiasi colonna facendo clic sulla relativa intestazione. Fai clic una volta per ordinare in ordine crescente; fai nuovamente clic per ordinare in ordine decrescente.
-
Puoi modificare l'ordine di visualizzazione delle colonne di dati. Per spostare una colonna, fai clic sulla relativa intestazione e trascinala orizzontalmente nella posizione desiderata. Una posizione valida è indicata dalla comparsa di due frecce di posizionamento.
-
Il componente che incolli nel documento di libreria attivo può provenire da un documento schematico o da un altro documento di libreria schematica.
-
Se sono stati copiati negli appunti più componenti dal progetto principale nell'editor schematico, tutti i componenti selezionati verranno incollati nel documento di libreria.
-
Se lo stesso componente viene incollato nella libreria più di una volta, oppure se viene aggiunto alla libreria più di un nuovo componente senza rinominarlo, le copie vengono distinte dai suffissi _1, _2, _3, ecc.
-
Per trasferire le modifiche apportate ai componenti nel documento di libreria, deve essere aperto un documento schematico.
-
Quando viene creato un nuovo documento di libreria schematica, il pannello conterrà un unico componente vuoto: Component_1.











