Importazione delle librerie esistenti nel tuo Workspace connesso

A colpo d'occhio

Porta le tue librerie di componenti esistenti nel Workspace connesso con il Library Importer di Altium Designer. Questo articolo spiega come la modalità Semplice del Library Importer automatizza le importazioni più comuni e come la modalità Avanzata ti offre un maggiore controllo sui tipi di componenti, sui parametri e sulle impostazioni di importazione. Descrive inoltre i formati di libreria supportati, i dati trasferiti e i controlli di convalida che aiutano a individuare eventuali problemi di importazione. Continua a leggere per trovare l'approccio di importazione più adatto alle tue librerie e compiere il passo successivo verso una gestione centralizzata dei componenti.

- Scopri come accedere al Library Importer e scegliere tra le modalità Semplice e Avanzata.
- Scopri quali librerie e dati dei componenti possono essere importati e quali sono le principali limitazioni.
- Esplora le anteprime di importazione, la classificazione dei componenti, le impostazioni dei parametri e i report per verificare e perfezionare le tue importazioni.
Approfondisci con l'IA:

Altium Designer, insieme al tuo Workspace connesso, offre un processo semplificato e altamente automatizzato per importare rapidamente le librerie esistenti in tale Workspace. L'interfaccia di questo processo – Library Importer – offre una soluzione con un solo clic che analizza automaticamente le librerie selezionate e le importa nel Workspace a cui sei attualmente connesso.

Compatibile con tutti i tipi di librerie legati alle precedenti metodologie di gestione dei componenti (SchLib, PcbLib, IntLib, DbLib, SVNDbLib), il Library Importer è una soluzione dedicata alla creazione rapida della libreria di componenti del Workspace aziendale, per consentirti di sfruttarne i numerosi vantaggi: elevata integrità, archiviazione e gestione centralizzate, facilità di riutilizzo dei progetti e informazioni in tempo reale sulla catena di approvvigionamento.

Il Library Importer offre una modalità di interfaccia Simple essenziale, in cui le librerie di componenti selezionate, basate su database o su file, vengono importate come componenti del Workspace in un unico passaggio. L'importatore gestisce automaticamente la classificazione per tipo, la cartella di destinazione dei dati sorgente, l'inclusione dei parametri e il tipo dei relativi valori, nonché il trasferimento di tutti i dati pertinenti. L'interfaccia è disponibile anche in modalità Advanced, che offre un'anteprima completa dell'importazione proposta e l'accesso ai dati e alle impostazioni correlati. Sebbene l'importazione sia per impostazione predefinita un processo con un solo clic, l'importatore offre anche opzioni di configurazione avanzate tramite il pannello Properties, per un controllo più preciso sulle modalità di esecuzione dell'importazione.

Cosa viene importato?

Tutte le informazioni presenti nella libreria sorgente originale vengono importate nei componenti del Workspace, inclusi tutti i modelli di dominio referenziati (simboli schematici, footprint PCB, modelli di simulazione), le informazioni parametriche, le scelte dei componenti assegnate, i file delle schede tecniche e così via. Ove necessario, vengono creati anche modelli di componente, che possono poi essere perfezionati e utilizzati per le successive importazioni di librerie.

Se per i componenti originali sono definiti più footprint PCB, il Library Importer trasferisce tali modelli e mantiene il footprint predefinito corrente. Se invece lavori solo con librerie PCB, occupandoti esclusivamente del layout PCB, il Library Importer supporta l'importazione delle sole librerie di questo tipo. In alternativa, può essere impostato su una modalità di importazione dei soli modelli, in cui vengono importati tipi di modelli specifici da librerie integrate o basate su database. Anche le librerie che includono più tipi di componenti (librerie monolitiche) vengono rilevate ed elaborate automaticamente.

Sebbene il processo di importazione delle librerie debba gestire librerie sorgente basate su database e su file che possono utilizzare diversi standard di formattazione, i processi di analisi automatica rilevano i tipi di componenti presenti nella libreria sorgente (resistore, condensatore, ecc.), nonché i nomi dei parametri e i tipi dei relativi valori (volt, ohm, ecc.). Il sistema esegue e gestisce una serie di verifiche, ad esempio per garantire che non vi siano ID duplicati per i componenti risultanti nella libreria del Workspace, che non vengano creati modelli o modelli di componente duplicati e che tali elementi vengano riutilizzati tra i componenti (tramite collegamenti), ove necessario. Se si verificano problemi, il sistema li segnala e suggerisce come risolverli, con l'obiettivo di ripristinare il corretto svolgimento dell'importazione nel modo più rapido e fluido possibile.

I tipi di librerie che possono essere importati sono:

  • Libreria di simboli schematici (*.SchLib).

  • Libreria di footprint PCB (*.PcbLib).

  • Libreria integrata (*.IntLib)

  • Libreria basata su database (*.DbLib).

  • Libreria basata su database SVN (*.SVNDbLib).

L'importazione delle informazioni di mappatura dei pin (per i modelli di simulazione) non è attualmente supportata.

Accesso al Library Importer

Il Library Importer è disponibile quando sei connesso a un Workspace. Per accedere all'importatore in modalità Simple:

  • Nel pannello Components, scegli l'opzione Import Library dal menu . Se nella colonna Categories del pannello (o nel menu a discesa in alto quando il pannello è in modalità compatta) è attualmente selezionata una libreria basata su database o su file, il Library Importer si apre per tale libreria. Quando è selezionato un tipo di componente della libreria del Workspace, si apre la finestra di dialogo standard di Windows Open, che consente di individuare e selezionare un file di libreria da importare.

    Le librerie basate su database e su file attualmente disponibili nel software possono essere visualizzate e gestite nella finestra di dialogo Libraries Preferences, accessibile tramite l'opzione Libraries Preferences nel menu del pulsante  del pannello Components.

    Puoi anche visualizzare e gestire le librerie basate su file attualmente installate nella pagina Data Management – File-based Libraries della finestra di dialogo Preferences.

  • Fai clic con il pulsante destro del mouse su un file di libreria nel pannello Projects e seleziona Import Library dal menu contestuale.

  • Seleziona Tools » Import Library nell'editor dei simboli schematici o dei footprint PCB quando è aperto un file di libreria locale.

  • Seleziona File » Import Library o Tools » Import Library nell'editor delle librerie basate su database.

  • Nella finestra di dialogo Libraries Preferences, seleziona una voce di libreria nella scheda Installed, quindi fai clic sul controllo Import.

  • Trascina un file di libreria da una cartella di Windows al pannello Explorer.

La modalità semplice offre opzioni per importare immediatamente la libreria selezionata () o aprire il Library Importer nella modalità con interfaccia grafica completa ().

Il Library Importer aperto nella modalità Simple di importazione con un solo clic.
Il Library Importer aperto nella modalità Simple di importazione con un solo clic.

Per accedere direttamente al Library Importer nella modalità di interfaccia Advanced, seleziona File » Library Importer dal menu principale.

Il Library Importer, aperto nella modalità di interfaccia completa Advanced, supporta anche un processo di importazione con un solo clic.
Il Library Importer, aperto nella modalità di interfaccia completa Advanced, supporta anche un processo di importazione con un solo clic.

Modalità semplice

La modalità semplice del Library Importer preseleziona tutti gli aspetti del processo di importazione in base all'analisi della libreria sorgente e del Workspace connesso. La finestra di dialogo Library Importer presenta quindi un riepilogo della struttura di importazione, incluso il numero totale di elementi per ciascun tipo. L'importazione della libreria viene eseguita in un unico passaggio tramite il comando .

Questa modalità di interfaccia semplice è adatta ai formati di libreria sorgente più comuni, che in genere contengono tipi di componenti comuni (resistori, condensatori, circuiti integrati, ecc.) e valori dei parametri standardizzati. Durante il processo di analisi iniziale, il sistema deduce il tipo di componenti presenti nella libreria in base al designatore o alle parole chiave dei parametri (LD?, LED, ecc.), quindi individua un modello di componente corrispondente nel Workspace di destinazione (LED). Questo modello viene applicato all'importazione di tali componenti e definisce quindi le impostazioni di importazione, come la cartella di destinazione (Components/LED), la mappatura dei parametri, le unità dei valori dei parametri e così via. Nel Workspace sono disponibili modelli adatti se è stata selezionata l'opzione per includere i dati di esempio durante l'attivazione di un Workspace Altium 365 o l'installazione di Altium On-Prem Enterprise Server.

I risultati dell'importazione della libreria, sotto forma di nuovi componenti creati nel Workspace, sono visibili sia nel pannello Explorer sia nel pannello Components. I componenti importati includono tutti i modelli, i parametri interpretati in base ai modelli di componente applicati, le scelte dei componenti derivate dai dati di origine dei collegamenti ai fornitori e tutti i collegamenti o file di riferimento.

Tutti i modelli di componente creati da Library Importer sono accessibili nella cartella Managed Content\Templates\Component Templates del pannello Explorer.

Se per qualsiasi motivo, ad esempio un risultato di importazione insoddisfacente, desideri eliminare un insieme di componenti, puoi rimuovere completamente quelli selezionati nel pannello Components scegliendo l'opzione Delete dal menu contestuale accessibile con il pulsante destro del mouse. Oltre ai componenti selezionati, è possibile eliminare anche i modelli associati, se non sono utilizzati da altri componenti.

Gli aspetti importanti del processo di importazione delle librerie sono:

  • Le librerie monolitiche (quelle che contengono più tipi di componenti) vengono suddivise automaticamente in sottogruppi, ciascuno dei quali rappresenta un tipo di componente presente nella libreria. I gruppi vengono elaborati come librerie singole.

  • Una libreria di origine con un tipo di componente non riconoscibile (non rilevato) verrà importata senza interpretazione, con tipi di componente non assegnati, in una cartella Components/Uncategorized del Workspace. Prima di eseguire l'importazione, è possibile risolvere questo problema applicando la mappatura dei designatori o il raggruppamento dei parametri nella modalità Advanced (interfaccia completa). In alternativa, puoi procedere con l'importazione e modificare in seguito le impostazioni e la cartella del componente tramite il pannello Explorer.
  • Il processo di importazione delle librerie include una fase di convalida automatica dei componenti. I componenti che generano un errore di convalida verranno ignorati.
  • Se nella libreria di origine da importare vengono rilevati modelli duplicati, ne verrà importato solo uno, che sarà collegato ai componenti risultanti nel Workspace di destinazione. Nella parte superiore della finestra di dialogo Library Importer verrà visualizzata una notifica appropriata.
  • Tutti gli errori riscontrati durante il processo possono essere visualizzati nel Importing Report, accessibile tramite il pulsante al termine dell'importazione.

Modalità avanzata

L'interfaccia grafica completa di Library Importer viene visualizzata in modalità Advanced, che offre un controllo dettagliato sulla gestione delle librerie, dei tipi di componente e dei parametri dei componenti. In combinazione con il pannello Properties, consente di configurare l'importazione delle librerie di componenti nel Workspace in base alle tue esigenze specifiche. Tieni presente che le impostazioni dello strumento di importazione possono essere salvate e ripristinate esportando/importando file di configurazione.

La modalità avanzata viene attivata quando Library Importer viene aperto tramite il comando File » Library Importer o quando si seleziona il pulsante in modalità semplice. Le librerie vengono aggiunte alla sezione SOURCE LIBRARIES dello strumento di importazione (se non è già popolata) trascinando un file di libreria nell'area, facendo clic con il pulsante destro del mouse su <All Libraries> e selezionando Add Library dal menu contestuale oppure selezionando il pulsante .

La sezione Import Preview elenca i gruppi di tipi di componente identificati nelle librerie di origine, come Types () o come Folder Structure proposto (), e include una vista a griglia di tali componenti basata sui parametri (Components). I valori dei parametri nella griglia possono essere modificati direttamente, evitando così di dover aprire e modificare la libreria di origine. L'area Details in basso include ulteriori informazioni ricavate dal componente attualmente selezionato: scelte dei componenti, modelli e schede tecniche.

Puoi modificare il tipo di componente facendo clic con il pulsante destro del mouse su un tipo nell'elenco Types e selezionando il comando Change Component Type.

Indipendentemente dalle opzioni dettagliate e dai dati presentati nell'interfaccia, la vista avanzata dello strumento di importazione può essere utilizzata allo stesso modo della vista semplice: basta fare clic sul pulsante per avviare il processo di importazione, senza ulteriori interventi. Come nel processo della vista semplice, lo strumento di importazione ha analizzato la libreria, dedotto il tipo di componenti che contiene e applicato il modello di componente corretto. A sua volta, il modello determina la cartella di destinazione nel Workspace, gli schemi di denominazione e le definizioni del ciclo di vita applicati, nonché la mappatura e l'interpretazione dei parametri.

  • Usa il pulsante (in alto a sinistra) per aggiornare Library Importer. Questa operazione ricarica tutte le librerie di origine e i dati del Workspace per recepire eventuali modifiche apportate dopo l'apertura dello strumento di importazione.
  • Usa il campo di ricerca (in alto a destra) per filtrare le voci dei componenti in base a un valore di parametro corrispondente.

Librerie monolitiche

Le librerie di origine che contengono più tipi di componenti vengono rilevate dalle procedure di analisi dello strumento di importazione e suddivise in gruppi di sottolibrerie, che possono essere elaborati come librerie separate per tipo. Il rilevamento del tipo di componente si basa sui designatori dei componenti di origine (R?, C?, ecc.) e sulle parole chiave (Resistor, Res, ecc.) contenute negli altri parametri principali dei componenti (descrizione, ID, ecc.).

Nell'esempio riportato di seguito, la libreria di origine (ProjectABC.IntLib) è stata suddivisa automaticamente in base ai tipi di componente rilevati (condensatori, resistori, ecc.), che possono essere selezionati nella colonna Folder Structure (o nella colonna Types) per visualizzare in anteprima le voci dei componenti che li costituiscono nella griglia Components.

I tipi di componente che attualmente non esistono nel Workspace ma che verranno creati durante il processo di importazione sono contrassegnati dall'icona .

Tieni presente che la visualizzazione dell'elenco Components può essere modificata in diversi modi:

  • Fai clic sull'intestazione di una colonna per riordinare l'elenco in base al parametro di quella colonna, quindi fai nuovamente clic per invertire l'ordine.

  • Dal menu contestuale dell'intestazione, accessibile con il pulsante destro del mouse:

    • Scegli Clear Sorting per ripristinare l'ordinamento predefinito dell'elenco (in base alla colonna Name in ordine crescente).

    • Scegli Best Fit per adattare la larghezza di una specifica colonna al suo contenuto.

    • Scegli Select Best Fit All Columns per adattare tutte le colonne disponibili alla larghezza del rispettivo contenuto.

    • Scegli Select Columns per accedere alla finestra di dialogo Select Columns, in cui è possibile abilitare e disabilitare le colonne dei parametri e modificarne l'ordine nell'elenco.

  • Fai clic sull'icona del filtro () all'interno di un'intestazione per limitare l'elenco a un valore disponibile nella colonna del parametro, ai valori vuoti/non vuoti o a un'impostazione di filtro Custom. Il filtro applicato viene visualizzato nella parte inferiore dell'elenco, dove può essere abilitato/disabilitato (tramite la casella di controllo associata), modificato nel Filter Editor o eliminato. Anche selezionando All tramite l'icona del filtro nell'intestazione () si rimuove il filtro applicato.

Componenti non categorizzati

Se una voce di sottogruppo della libreria è denominata Uncategorized (ed è elencata come Uncategorized sotto Types o Folder Structure ed è accompagnata da  icona), ciò indica che l'utilità di importazione non è riuscita a rilevare e assegnare un tipo a quel gruppo di componenti: il tipo di componente è di fatto impostato su None. In questo caso, i componenti non identificati (circuiti integrati logici inverter) utilizzano un prefisso del designatore non riconosciuto (U?) e i loro parametri non contengono parole chiave rilevabili come IC, logic, ecc.

Se viene eseguita l'importazione, i componenti vengono importati come tipo non categorizzato, senza interpretazione. Tuttavia, se sono presenti parametri chiave/standard (come Resistance, Capacitance, Tolerance, ecc.), l'utilità di importazione assegnerà automaticamente a questi parametri un tipo di unità appropriato (Ohm, Farad, Percent, ecc.).

Questo problema può essere risolto mappando manualmente i designatori utilizzati per quei componenti al tipo di componente desiderato nella finestra di dialogo Library Splitting, accessibile tramite il pulsante , disponibile quando è selezionata la libreria di origine (ProjectABC.IntLib). La finestra di dialogo Library Splitting, con i valori predefiniti, offre controlli per impostare opzioni personalizzate di raggruppamento delle librerie per i componenti non categorizzati, in base alla mappatura dei designatori per tipo di componente e alla suddivisione basata sui parametri.

Con l'opzione Map Designators della finestra di dialogo selezionata, scegliere il tipo di componente appropriato per i componenti non categorizzati dall'elenco a discesa Component Type (che include tutti i tipi di componente disponibili). Confermare la mappatura tipo-designatore completata (il tipo di componente Logic ai designatori U?) con il pulsante .

Ora che il tipo di componente è specificato dalla mappatura applicata, l'utilità di importazione utilizzerà il modello di componente corrispondente (Logic) per configurare l'importazione della libreria secondo le impostazioni del modello (cartella, denominazione, ecc.).

  • La finestra di dialogo Library Splitting include anche l'opzione per raggruppare i componenti suddivisi in base al valore di un parametro specificato (ad esempio, un parametro Category o Component_Type), se definito nella libreria di origine. A tale scopo, selezionare l'opzione Parameter Grouping della finestra di dialogo e quindi un parametro appropriato dal menu a discesa.
  • In alternativa, è possibile selezionare manualmente il tipo di componente di una libreria nella sezione General del pannello Properties.
  • Per modificare il tipo di componente di una singola voce nell'elenco Components, fare clic nella relativa cella Component Type, quindi scegliere un tipo alternativo dal menu a discesa oppure fare clic con il pulsante destro del mouse sul tipo di componente e selezionare Change Component Type dal menu contestuale.

Si noti che, grazie alla flessibilità delle impostazioni di Library Importer, è possibile importare un nuovo tipo di libreria di componenti (non categorizzato) con tutta l'infrastruttura necessaria per le importazioni future di quel tipo di libreria. Scegliendo una configurazione di importazione appropriata (nuovo tipo di componente, modello di componente, cartella di destinazione, mappatura dei parametri e tipi di unità dei valori dei parametri), l'unico requisito per la successiva importazione di quel tipo di libreria sarà selezionare il tipo di componente definito in precedenza. Il tipo di componente selezionato determinerà quindi tutti gli altri aspetti dell'importazione.

Esclusione dall'importazione

È anche possibile escludere tipi di componente specifici dall'importazione. Per escludere un tipo di componente, nell'elenco Types fare clic con il pulsante destro del mouse sul tipo di componente da escludere, quindi selezionare Exclude from Importer dal menu contestuale. Se lo si desidera, modificare la visualizzazione della colonna da Folder Structure a Types ().

Il tipo di componente escluso apparirà in grigio nell'elenco Types. Per visualizzare i componenti esclusi nella griglia, fare clic su Show Excluded Component (n), dove n indica il numero di componenti esclusi.

Inclusione nell'importazione

Se un tipo di componente è stato escluso dall'importazione tramite il comando Exclude from Importer descritto sopra e si desidera invece includerlo, fare clic con il pulsante destro del mouse sul tipo di componente visualizzato in grigio nell'elenco Types (o Folder Structure), quindi selezionare Include to Importer dal menu contestuale. Il tipo di componente verrà nuovamente visualizzato nell'elenco Types, a indicare che non è escluso.

Errori e avvisi di convalida

I componenti che non verranno importati correttamente nel Workspace, o che non verranno importati affatto, sono contrassegnati da indicatori di avviso o errore nell'interfaccia avanzata quando viene eseguito Library Importer () o viene effettuata una convalida dell'importazione (). La convalida verifica anche la presenza di percorsi vuoti delle cartelle del Workspace, parametri di sistema in conflitto e modelli duplicati. Un errore irreversibile bloccherà l'importazione.

Quando si tenta di eseguire l'importazione, il pannello Messages viene popolato con le violazioni rilevate e una finestra di dialogo consente di scegliere se annullare o procedere con la configurazione di importazione corrente. In quest'ultimo caso, i componenti non validi non vengono importati oppure il processo di importazione non va a buon fine.

In caso di annullamento dell'importazione o di esecuzione della convalida manuale, ai componenti che non superano i controlli di importazione vengono associate icone di errore/avviso e ulteriori informazioni nell'area inferiore Details. Le icone nella colonna di anteprima Status indicano le specifiche voci dei componenti che violano le regole di controllo dell'importazione.

I controlli di convalida predefiniti disponibili sono elencati di seguito.

I controlli definibili dall'utente vengono configurati nell'area Import Checks del pannello Properties. Utilizzare il menu a discesa Report Mode per scegliere un diverso livello di segnalazione per il tipo di violazione associato. Questi controlli sono elencati di seguito.

Risoluzione di errori e avvisi

Gli errori dei parametri, come nell'esempio mostrato qui in cui il valore Forward Voltage del componente non può essere interpretato come una tensione valida, possono essere risolti nei seguenti modi:

  • Modificando il valore del parametro che causa l'errore: individua e modifica la relativa cella per renderne il formato conforme.

  • Modificando l'unità del parametro mappato Type, determinata dal template di componente applicato, da Voltage a non interpretata Text: seleziona la libreria sorgente nell'interfaccia dell'importatore, quindi modifica Forward Voltage Type nell'elenco del pannello Properties Parameter Mapping (nella scheda General).

  • Rimuovendo il componente dal processo di importazione: fai clic con il pulsante destro del mouse sulla relativa voce e scegli l'opzione Exclude from Importer .

Un errore dovuto a un file mancante, come il file della scheda tecnica non reperibile mostrato qui, può essere risolto nei seguenti modi:

  • La soluzione più ovvia è individuare il file mancante e ripristinarlo nella posizione prevista.
  • Disabilitando l'importazione dei file delle schede tecniche: modifica l'opzione Migrate nella sezione del pannello Properties Datasheet (nella scheda Advanced).
  • Escludendo il componente dal processo di importazione della libreria, come descritto sopra.

Utilizza il campo Search (in alto a destra) per trovare voci di componenti specifiche. La ricerca filtra l'elenco degli elementi in base ai valori dei parametri corrispondenti per il tipo di componente attualmente selezionato: seleziona All in Types (Folder Structure) per applicare la ricerca a tutti i componenti nelle librerie sorgente disponibili.

Importazione di librerie schematiche

Se riscontri un errore di tipo «modello non trovato» (come Footprint <footprint name> not found in available libraries) durante il tentativo di importare una libreria schematica, significa che il Library Importer non riesce a individuare i modelli collegati ai componenti all'interno della SCHLIB.

In modalità semplice, questi errori vengono mostrati nel Importing Report basato su HTML, accessibile tramite il pulsante disponibile dopo l'esecuzione dell'importazione. In modalità avanzata, gli errori sono indicati da icone di stato nell'interfaccia principale () e da voci nel pannello Messages: ciò avviene durante l'esecuzione di un controllo di convalida () o quando si tenta di importare la libreria ().

I footprint mancanti vengono rilevati correttamente dal processo di convalida, che fornisce anche un'opzione Choose a Library nel relativo rapporto degli errori (nel menu a discesa Details). Se viene rilevato più di un footprint di componente mancante, una finestra di dialogo Apply PcbLib Selection offre la possibilità di utilizzare la PcbLib specificata per questa istanza o per tutti i componenti con footprint mancanti.

Un altro modo per risolvere (o evitare) questo problema consiste nell'assicurarsi che i file delle librerie di modelli richiesti siano disponibili all'interno di Altium Designer. Le librerie vengono installate tramite la pagina Data Management – File-based Libraries della finestra di dialogo Preferences.

In alternativa, se non desideri installare più librerie di modelli, dovrai collocarle nel percorso predefinito delle librerie del software (o modificare il percorso) e verificare che la libreria sorgente del modello sia specificata per i componenti della libreria schematica:

  • Includi la libreria di modelli nel percorso di ricerca predefinito del software. Aggiungi la libreria di modelli, ad esempio una libreria PCB corrispondente, nella posizione specificata dal percorso predefinito delle librerie del sistema. Per verificare questa posizione, consulta la voce Library Path nella pagina System – Default Locations della finestra di dialogo Preferences. Se un file di libreria è stato aggiunto o copiato in tale percorso, potrebbe essere necessario riavviare Altium Designer per registrare la modifica.
  • Specifica il nome della libreria di modelli di destinazione per i componenti della libreria schematica. Affinché il Library Importer possa riconoscere la libreria di modelli collegata a un componente della libreria schematica, specificane il nome nella finestra di dialogo PCB Model della libreria.

Tieni presente che non è necessario, né consigliabile, importare una libreria PCB insieme alla corrispondente libreria schematica, poiché l'importazione dei modelli richiesti e la creazione dei relativi collegamenti verranno eseguite dal Library Importer stesso. Il processo di importazione identifica, individua e trasferisce i modelli corretti per ciascun componente, creando un componente unificato nel Workspace di destinazione.

Rilevamento dei duplicati

Il Library Importer include anche meccanismi per evitare la creazione di componenti duplicati nel Workspace di destinazione. Ciò avviene durante la convalida confrontando i parametri identificativi dei componenti e le scelte dei componenti della libreria di origine con quelli dei componenti presenti nel Workspace di destinazione e nelle librerie di origine da importare. Con le impostazioni predefinite dell'importatore, una fase di convalida () segnala un messaggio Warning quando viene rilevata la stessa voce Name o Part Choices del componente, che indica un potenziale duplicato. Il messaggio di avviso/errore visualizzato include il tipo di violazione per duplicazione (parametro o scelta del componente), il nome del componente di libreria che causa la violazione e il componente (identificato tramite ID) con cui è in conflitto.

Due potenziali duplicazioni rilevate dal processo di convalida, in cui Name (immagine in alto) o Part Choice (immagine in basso) del componente sono già presenti nei componenti del Workspace.
Due potenziali duplicazioni rilevate dal processo di convalida, in cui Name (immagine in alto) o Part Choice (immagine in basso) del componente sono già presenti nei componenti del Workspace.

La coppia nome-valore del parametro utilizzata per rilevare le violazioni per duplicazione è specificata nell'area Duplicates Detection del pannello Properties, nella scheda Advanced. Utilizzare il menu a discesa Unique Field (impostato su Name per impostazione predefinita) per selezionare uno dei parametri disponibili nella libreria di origine. Questa selezione è particolarmente utile per le configurazioni delle librerie aziendali che utilizzano un campo identificativo proprietario collegato al sistema aziendale più ampio.

Una violazione per duplicazione rilevata quando il valore di un parametro specificato (ERP-REF) è identico per un componente della libreria locale e un componente del Workspace.
Una violazione per duplicazione rilevata quando il valore di un parametro specificato (ERP-REF) è identico per un componente della libreria locale e un componente del Workspace.

È possibile impostare un diverso tipo di indicatore di stato per le violazioni per duplicazione selezionando un'opzione Report Mode alternativa nell'area Import Checks, nella scheda General del pannello Properties.

Il rilevamento dei duplicati viene eseguito anche per i modelli di simbolo dei componenti. Se i componenti da importare hanno modelli di simbolo con la stessa geometria nelle librerie di origine, verrà importato solo uno di questi modelli.

Questa funzionalità è disponibile quando l'opzione LibraryMigrator.DuplicatedModelCheck è abilitata nella finestra di dialogo Impostazioni avanzate.

Librerie con un unico modello

Il rilevamento automatico dei duplicati viene utilizzato anche per elaborare librerie di origine che utilizzano un modello di simbolo comune per tutti i componenti. Queste librerie tendono a essere composte da un unico tipo di componente con stili e valori diversi, ad esempio resistori con un particolare formato di package, per i quali il simbolo è una rappresentazione grafica standard.

Questa condizione di modello unico e comune viene rilevata dal Library Importer, che configura quindi l'importazione per trasferire un solo modello di simbolo valido per tutti i componenti importati, anziché un simbolo corrispondente, con un nome distinto, per ciascun componente. Il simbolo da importare assume il nome di uno dei simboli da importare e tutti i parametri dei componenti rimangono invariati.

Il simbolo di libreria importato (che presenta il nome generico e il campo Descrizione vuoto) può essere modificato in base alle proprie esigenze. Nel pannello Componenti, utilizzare l'opzione Edit del menu contestuale per avviare l'operazione. Durante il processo, selezionare l'opzione Update items related to <symbol ID> nella finestra di dialogo Create Revisions for Item per assicurarsi che i componenti importati utilizzino la nuova revisione del simbolo.

Unione dei tipi di componente

L'insieme dei tipi di componente registrati nel sistema, ovvero, in pratica, nel Workspace connesso, può essere visualizzato e gestito nella pagina Gestione dati – Tipi di componente della finestra di dialogo Preferences. I tipi sono elencati con i relativi Template dei componenti e Folder del Workspace e includono tutti i nuovi tipi creati quando il Library Importer ha importato file di libreria nel Workspace.

La creazione di più nuovi tipi di componente può verificarsi tipicamente quando una configurazione del Library Importer ha utilizzato il raggruppamento per parametro (il valore di un parametro del componente specificato) per determinare il tipo di ciascun componente importato. Ad esempio, il parametro Categories potrebbe essere Resistor-0608 per un gruppo di componenti importati e Resistor-0402 per un altro, e così via. In questo caso, per l'utilizzo futuro sarebbe preferibile raggrupparli tutti sotto l'unico tipo di componente Resistors.

Anziché modificare manualmente tutti i tipi di componente in queste circostanze, la pagina Tipi di componente in Preferences consente di unire le voci dei tipi selezionate in un'unica voce specificata. Per ulteriori informazioni, consultare la sezione Unione dei tipi di componente della pagina Tipi di componente.

Il risultato di questa unione è che, quando Resistors viene scelto come tipo di componente importato nel Library Importer, verrà applicato anche se si seleziona in alternativa uno qualsiasi dei modelli uniti (Resistor_0402 ecc.).

Importazione dei soli modelli

Il Library Importer può essere impostato su una speciale modalità di importazione Models Only che rileva ed elabora i modelli di componente disponibili in una libreria di origine.

Questa funzionalità è disponibile quando l'opzione LibraryMigrator.ModelsOnlyMode è abilitata nella finestra di dialogo Impostazioni avanzate.

Nella modalità Solo modelli, il processo di analisi dell'importatore rileva tutti i modelli di simbolo, footprint e simulazione disponibili in una libreria di origine (IntLib, SchLib, PcbLib ecc.), quindi li importa nel Workspace utilizzando le posizioni, gli schemi di denominazione e le definizioni del ciclo di vita predefiniti del sistema.

Quando il Library Importer viene impostato sulla modalità avanzata () o aperto in tale modalità (File » Library Importer), sono disponibili tutti i dettagli dell'importazione dei modelli proposta. L'area Import Preview mostra Folder Structure che verrà utilizzato nel Workspace di destinazione e che può essere modificato rispetto alle impostazioni predefinite nel campo Folder per ciascun tipo di modello nel pannello Properties. Gli schemi di denominazione applicati e la definizione del ciclo di vita per ciascun modello possono essere selezionati tra i tipi disponibili nel sistema (vedere pannello Proprietà, di seguito).

Se lo si desidera, l'importazione dei modelli di componente nel Workspace può essere limitata per tipo, disabilitando (o abilitando) tipi di modello specifici nel pannello Properties tramite i relativi pulsanti .

Una volta configurato il Library Importer, selezionare il pulsante per completare l'importazione dei modelli di componente elencati. I risultati possono essere esaminati nel file di registro dell'importazione, accessibile dalla finestra di dialogo di avanzamento Library Importer (), oppure visualizzando i modelli importati nel pannello Componenti.

Importazione dei soli componenti

Analogamente alla modalità di importazione Models Only descritta sopra, il Library Importer può essere impostato su una speciale modalità di importazione Components Only che consente di importare i componenti disponibili in una libreria di origine senza i modelli collegati.

Questa funzionalità è disponibile quando l'opzione LibraryMigrator.ReleaseComponentsWithoutModels è abilitata nella finestra di dialogo Impostazioni avanzate.

Nella modalità Solo componenti, il processo di analisi dell'importatore rileva tutti i componenti, i parametri e le scelte dei componenti presenti in una libreria di origine, quindi importa questi componenti nel Workspace utilizzando la posizione, lo schema di denominazione e la definizione del ciclo di vita predefiniti del sistema.

Quando Library Importer viene impostato sulla modalità avanzata () o aperto in modalità avanzata (File » Library Importer), sono disponibili tutti i dettagli dell'importazione dei componenti proposta. La cartella applicata, gli schemi di denominazione e la definizione del ciclo di vita possono essere selezionati tra i tipi disponibili nel sistema (vedere pannello Properties, di seguito).

Una volta configurato Library Importer, selezionare il pulsante per completare l'importazione dei componenti elencati. Nel Workspace verranno creati solo elementi componente, senza modelli collegati. I risultati possono essere esaminati nel file di registro dell'importazione, accessibile dalla finestra di avanzamento Library Importer (), oppure visualizzando i componenti importati nel pannello Components. 

Pannello Properties

Le impostazioni del pannello Properties associato a Library Importer offrono un controllo avanzato sulla configurazione dell'importazione per la libreria selezionata (o per il gruppo di sottolibrerie). È possibile accedere al pannello dalla modalità avanzata di Library Importer selezionando l'opzione Properties dal menu del pulsante  (in basso a destra nell'area di progettazione), facendo clic sul pulsante  in alto a destra nella vista di Library Importer oppure facendo clic sul pulsante  accanto a <All Libraries> o a una specifica voce di categoria nell'elenco Source Libraries.

Le impostazioni delle opzioni del pannello sono definite dalle impostazioni predefinite del sistema o da quelle specificate nel template di componente applicato, a sua volta determinato dal tipo di componente rilevato nella libreria: LED nell'esempio qui mostrato. Le impostazioni possono anche essere modificate dall'utente, consentendo di adattare il processo di importazione alle proprie esigenze, e possono essere ripristinate tramite il collegamento Reset to Default (in alto a destra).

Le sezioni della scheda General del pannello sono le seguenti:

  • General:
    • Component Type – il tipo di componente rilevato dall'importatore per la libreria selezionata e, di conseguenza, il template applicato (vedere Component Template di seguito). È possibile sovrascrivere questa impostazione modificando il campo, creando così un nuovo tipo di componente, oppure selezionando un tipo alternativo dalle opzioni del menu a discesa (o tramite il pulsante ): questo è un altro modo per risolvere un problema di componente non categorizzato. Scegliere l'opzione [LibraryName] per assegnare al tipo il nome della libreria selezionata.
    • Component Template – il template di componente del Workspace che verrà applicato ai componenti importati e, di conseguenza, la relativa impostazione del tipo di componente. È possibile sovrascrivere questa impostazione selezionando un template alternativo dalle opzioni del menu a discesa (o tramite il pulsante ). Impostare questa opzione su [Create new] per creare automaticamente un template derivato dai parametri della libreria di origine e dalle impostazioni correnti di Library Importer, oppure scegliere [No Template] per impedire l'applicazione o la creazione di un template.

      Si noti che le impostazioni Component Type e Component Template sono di fatto collegate quando vengono impostate su un tipo/template disponibile: ad esempio, se una delle due è impostata su Capacitors, l'altra viene automaticamente impostata su Capacitors. Tuttavia, se in questo caso l'impostazione Component Template viene modificata in [Create New], verrà creato un altro template Capacitors (con un suffisso di versione/revisione appropriato nel nome) conforme alle impostazioni correnti. I template di componente esistenti non vengono modificati dal processo di importazione.
  • Parameter Mapping – la corrispondenza tra i parametri della libreria e quelli del template di componente applicato (o delle impostazioni predefinite, se non è disponibile alcun template), nonché il tipo di valore di ciascun parametro (testo o un tipo che supporta le unità di misura). Utilizzare le opzioni del menu a discesa della colonna Source Library Parameter per modificare la mappatura e le opzioni del menu della colonna Type per sovrascrivere l'impostazione esistente determinata dal template o dai valori predefiniti. Scegliere l'opzione <Skip> per non includere un parametro. Qualsiasi parametro che non sia stato associato automaticamente a un parametro della libreria di origine (impostato dal sistema su <Skip>) può essere mappato manualmente a un parametro appropriato del template: ad esempio, il parametro di origine ROHS potrebbe essere selezionato per corrispondere al parametro RoHS Compliant definito dal template del Workspace. I nomi dei parametri possono essere modificati e i set di parametri possono essere aggiunti, modificati e rimossi. I parametri di base del componente (ID, Name, Description) possono essere rimappati, ma per il resto sono di sola lettura.

    Per il parametro del Workspace ID, il parametro della libreria di origine è impostato su <Auto>. In questo modo, gli ID dei componenti vengono creati automaticamente in base a Naming Template, specificato nella sezione Component della scheda Advanced del pannello. La mappatura degli ID può essere modificata per utilizzare qualsiasi parametro della libreria di origine (che sia univoco per ciascuna voce componente), scegliendo un'alternativa dal menu a discesa del parametro della libreria di origine. Si noti che i parametri di base del componente (ID, Name, Description) possono essere rimappati, ma per il resto sono di sola lettura.
  • Part Choice Mapping – l'elenco dei parametri relativi ai codici parte del produttore o ai collegamenti ai fornitori riconosciuti dall'importatore, che verranno utilizzati per ricavare le voci Part Choices per i componenti importati. Utilizzare le opzioni del menu a discesa per ridefinire la mappatura oppure aggiungere ed eliminare set di mappatura. Si noti che, per impostazione predefinita, i parametri relativi ai codici parte del produttore e ai collegamenti ai fornitori non vengono inclusi nel processo di importazione (vengono ignorati). Quando un componente di libreria include più collegamenti a fornitori, per le voci del campo Part Choices viene utilizzato il riferimento al fornitore principale (Supplier 1 / Supplier Part Number 1).
  • Import Checks – consente di visualizzare o impostare la risposta dell'importatore, sotto forma di errore o avviso, alle violazioni delle regole di convalida dell'importazione. Utilizzare il menu a discesa Report Mode per modificare la risposta e l'icona di una voce Violation Type. Si noti che, se viene selezionata la modalità di segnalazione Fatal Error, il rilevamento di questa violazione bloccherà il processo di importazione.

La scheda Advanced del pannello offre impostazioni per tutti gli elementi oggetto dati dell'importatore, definite dai valori predefiniti del sistema o dal template di componente applicato. Questi includono i modelli dei componenti, i file delle schede tecniche e gli eventuali template di componente creati. Ad eccezione dell'opzione Datasheet (un comando di attivazione/disattivazione), le impostazioni per ciascun oggetto da importare includono:

  • Folder – la cartella di destinazione del Workspace per l'oggetto importato, che può essere modificata manualmente (ad esempio, per creare una nuova cartella di destinazione) o selezionata tramite il pulsante Sfoglia ().
  • Naming Scheme – la specifica di denominazione dell'oggetto nel Workspace, definita dal template di componente oppure, in assenza di un template attivo, dallo schema impostato per la cartella di destinazione (o immesso manualmente). Utilizzare il menu a discesa per scegliere tra gli schemi di denominazione disponibili. Si noti che una modifica al percorso della cartella di destinazione (Folder) può comportare una modifica dello schema di denominazione applicato, come definito dalla cartella stessa o da un template di componente applicato/associato.
  • Revision Naming Scheme – lo schema di denominazione utilizzato per le revisioni dell'oggetto nel Workspace, definito dal template applicato o selezionato dalle opzioni del menu a discesa della voce. Saranno disponibili come opzioni solo gli schemi abilitati dal sistema.
  • Lifecycle Definition – il sistema del ciclo di vita utilizzato per l'oggetto, impostato dal modello applicato o selezionato tra le opzioni del menu a discesa della voce. Saranno disponibili come opzioni solo le definizioni abilitate dal sistema.
La sezione dell'oggetto Component include l'impostazione per Duplicates Detection, come descritto sopra.

Esportazione e importazione della configurazione

Il Library Importer consente di esportare un file di testo dettagliato che acquisisce la configurazione corrente, incluse tutte le impostazioni di importazione configurabili, come percorsi di destinazione, mappatura dei parametri, schema di denominazione, definizioni dei cicli di vita, tipi di componenti di destinazione e così via.

Il file di configurazione dell'Importer viene salvato tramite il comando File » Export » Importer Config come file di tipo *.lmcfg e può essere ripristinato in qualsiasi momento tramite l'opzione di menu File » Import » Importer Config .

La possibilità di ripristinare una configurazione è particolarmente utile quando il database di origine o la libreria basata su file sono stati aggiornati e tali modifiche devono essere importate nel Workspace. Se la configurazione è stata esportata al momento della prima importazione della libreria, la configurazione ripristinata (importata) ristabilirà esattamente le impostazioni utilizzate, garantendo uno schema di trasferimento dei dati coerente per quella libreria (o quelle librerie).

Si noti che un file di configurazione dell'Importer esportato (salvato) include riferimenti ai file di libreria aperti come librerie di origine al momento dell'esportazione della configurazione. Quando tale file di configurazione dell'Importer viene successivamente importato (ricaricato), una o più delle librerie a cui fa riferimento la configurazione devono essere disponibili, ovvero devono essere attualmente disponibili come librerie di origine nel Library Importer.
AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents