Lavorare con i parametri degli oggetti di progettazione
A colpo d'occhio
- Scopri dove si trovano i parametri in Altium Designer, anche a livello di oggetto, documento e progetto, e quali sono le differenze tra parametri di sistema e parametri utente.
- Scopri come aggiungere, modificare, spostare, bloccare e gestire le stringhe dei parametri tramite il pannello Properties, l'area di progettazione e i flussi di lavoro delle librerie.
- Comprendi il comportamento dei parametri specifici dei componenti, inclusi i designatori, il posizionamento automatico e i tipi di parametri speciali, come i collegamenti.
I parametri sono stringhe di testo di uso generale che costituiscono oggetti figli di un oggetto padre. Identificano l'oggetto padre e vi aggiungono ulteriori informazioni; sono accessibili direttamente nel pannello Properties quando vengono selezionati in un foglio schematico.
Ad esempio, i componenti dello schematico fanno ampio uso dei parametri. I parametri generici dei componenti possono essere utilizzati per svariate funzioni, tra cui dettagli del componente, come potenza, tensione, ecc., informazioni sul fornitore, inclusi il nome del fornitore e il codice articolo, dettagli di progettazione del componente di libreria, come il numero di revisione del simbolo, e informazioni sulla documentazione, come un URL che rimanda alla scheda tecnica di un componente.
I parametri possono essere definiti anche a livello di foglio schematico (documento) e di progetto. I parametri a livello di documento vengono utilizzati per definire campi come il titolo e il numero del documento, mentre quelli a livello di progetto sono ideali per definire campi come il progettista o il nome del progetto.
I parametri vengono utilizzati per oggetti, documenti e progetti per aggiungere informazioni dettagliate al progetto. Nell'immagine sopra è mostrato un componente.
I parametri vengono aggiunti o inclusi automaticamente come proprietà dell'oggetto padre e non vengono posizionati in modo indipendente come una stringa di testo. I tipi di parametri disponibili possono essere suddivisi, in linea generale, in parametri di sistema e parametri utente; questi ultimi vengono aggiunti manualmente.
Identificatori e parametri di sistema
Gli oggetti posizionati in uno schematico includono automaticamente una serie di parametri di sistema fondamentali. Questi forniscono le informazioni di base sull'oggetto utilizzate dal sistema per distinguere il nome, il tipo e l'origine dei dati dell'oggetto padre. I parametri di sistema intrinseci degli oggetti includono, a titolo esemplificativo, le proprietà Comment, Description e Design Item ID (riferimento di libreria). I parametri di sistema degli oggetti sono accessibili nella sezione General del pannello Proprietà (nella scheda General) quando è selezionato un oggetto padre Quando è visibile e selezionato nell'area di progettazione, un singolo parametro è accessibile tramite la modalità associata del pannello Proprietà, come descritto di seguito
Parametri utente
È possibile aggiungere parametri a uno qualsiasi dei seguenti oggetti di progettazione.
| Component | Aggiungi parametri definiti dall'utente nell'area Parameters del pannello Proprietà quando è selezionato un oggetto componente (parte), oppure durante la definizione del componente nell'editor delle librerie di schematici. I parametri di sistema, come il designatore e il commento, sono sempre presenti per un oggetto componente, come descritto sopra. Per accedere al pannello Properties, fai doppio clic su un oggetto oppure fai clic con il pulsante destro del mouse su un oggetto e scegli Properties dal menu contestuale. Se il pannello Properties è già attivo, seleziona un oggetto nell'area di progettazione. |
| Part | Nell'area Parameters del pannello Properties quando è selezionato un oggetto Parte. |
| Pin | Nella scheda Parameters del pannello Properties quando è selezionato un oggetto Pin all'interno di un file *.SchLib. |
| Port | Nella scheda Parameters del pannello Properties quando è selezionato un oggetto Porta. |
| Sheet Symbol | Nella scheda Parameters del pannello Properties quando è selezionato un oggetto Simbolo di foglio. |
| Document | Nella scheda Parameters del pannello Proprietà quando è attiva la modalità Document Options (deseleziona tutti gli oggetti dello schematico oppure fai clic in uno spazio vuoto del foglio del documento). In un nuovo foglio schematico vengono inclusi automaticamente alcuni parametri predefiniti, determinati dal modello di foglio applicato/predefinito. |
| Project | Nella finestra di dialogo Opzioni progetto (Project » Opzioni progetto). I parametri a livello di progetto vengono elencati e aggiunti nella scheda Parameters della finestra di dialogo. |
I parametri utente sono disponibili nell'area Parameters del pannello Properties o della finestra di dialogo modale quando è selezionato l'oggetto padre. I parametri possono essere sia aggiunti che modificati. Fanno eccezione i parametri di progetto (tramite la finestra di dialogo Opzioni progetto) e i parametri dei pin dei componenti (tramite le Proprietà pin o la vista modale della finestra di dialogo Pin ). Quando è visibile e selezionato nell'area di progettazione, un singolo parametro è accessibile tramite la modalità associata del pannello Proprietà o della finestra di dialogo modale, come descritto di seguito.
Prima immagine: parametri utente del componente nel pannello Properties (area Parameters). Seconda immagine: un singolo parametro di sistema nel pannello Properties.
Modifica grafica
Le stringhe dei parametri visibili possono essere modificate graficamente direttamente nell'area di progettazione.
Fai clic su un parametro e trascinalo per riposizionarlo. Per modificare la stringa del parametro sul posto:
-
Trascina il cursore del mouse attorno all'oggetto parametro tenendo premuto il pulsante del mouse.
-
Una volta selezionato, l'oggetto verrà evidenziato da un bordo verde.
-
Seleziona
Enterper iniziare a modificare il testo. -
Una volta completata la modifica, premi nuovamente
Enteroppure fai clic al di fuori della stringa per uscire dalla modalità di modifica sul posto.
Una stringa di parametro può essere selezionata e modificata direttamente nell'area di progettazione. Seleziona l'intera stringa per sovrascriverla.
I parametri visibili e selezionabili nell'area di progettazione possono essere trascinati in una nuova posizione e ruotati durante lo spostamento. Fai clic sulla stringa del parametro e trascinala, usa i tasti Spacebar e Shift+Spacebar per ruotarla a incrementi di 90°, quindi fai clic per confermare la nuova posizione e il nuovo orientamento.
Consulta Posizionamento delle stringhe dei parametri di seguito per informazioni su Autopositioning dei parametri dei componenti e sulle relative opzioni del pannello Properties.
Parametri bloccati
Un parametro figlio di una Parte del componente può essere bloccato, rendendo non modificabili le sue stringhe Name e Value . Per farlo:
-
attiva l'icona del lucchetto associata alla relativa voce nell'area Parameters del pannello Properties o della finestra di dialogo modale dell'oggetto padre, oppure
-
seleziona l'opzione Lock Parameter nel pannello Proprietà quando il parametro è selezionato direttamente nell'area di progettazione.
Una volta bloccata, la stringa del parametro non può essere modificata nel pannello Properties, nella finestra di dialogo modale (in Parameters per l'oggetto padre) o nello spazio di progettazione tramite modifica sul posto.
Parametri dei componenti
I parametri dei componenti, i parametri schematici più evidenti e utilizzati di frequente, includono ulteriori gruppi di parametri e funzionalità dedicati che ampliano le possibilità di definizione degli oggetti componente.
Definizione dei parametri nella libreria schematica
I parametri figli di un oggetto componente padre possono essere definiti nella libreria sorgente del componente prima delo posizionamento in uno schema. Il pannello Properties viene utilizzato per modificare e aggiungere parametri a una voce di componente nell'editor della libreria schematica, con le stesse modalità utilizzate per i parametri nell'editor degli schemi .
Con un documento di libreria di componenti schematici aperto, selezionare una voce di componente nel pannello Libreria SCH per accedere alle proprietà dei suoi parametri nel pannello Properties.
Accedere alle proprietà di un componente di libreria selezionando la relativa voce nel pannello SCH Library.
Il designatore e il commento di un componente di libreria non sono visibili per impostazione predefinita nello spazio di progettazione dell'editor della libreria schematica, ma possono essere abilitati selezionando l'opzione Show Comment/Designator nella modalità Opzioni libreria del pannello Proprietà (Tools » Document Options), disponibile quando non è selezionato alcun oggetto nello spazio di progettazione.
I parametri appartenenti a un componente di libreria vengono definiti e modificati con la stessa procedura utilizzata per i componenti schematici già posizionati. Il tasto Tab può essere utilizzato per creare o modificare parametri al volo mentre si posiziona un oggetto nello spazio di progettazione. I parametri sono accessibili tramite il pannello Properties o la finestra di dialogo modale, dove i parametri principali di sistema sono disponibili nella scheda General del pannello, mentre i parametri utente vengono aggiunti o modificati nel menu a discesa Parameters del pannello.
Il parametro Designatore
Nell'editor della libreria schematica, al parametro Designator di un componente viene in genere assegnato un prefisso appropriato seguito da un punto interrogativo. Quando il componente viene posizionato in uno schema dalla libreria, il punto interrogativo viene rilevato dallo strumento di annotazione dell'editor degli schemi e sostituito con un suffisso numerico appropriato durante l'annotazione del progetto.
L'editor degli schemi include anche una semplice funzione di incremento automatico del designatore, utilizzabile durante il posizionamento di più istanze della stessa parte. Per utilizzarla, premere Tab mentre il primo componente è agganciato al cursore per sospendere il posizionamento, quindi inserire un designatore appropriato nel pannello Properties, ad esempio R1. Ai componenti successivi verranno quindi assegnati i designatori R2, R3, ecc.
Quando si posizionano componenti composti da più parti e il designatore iniziale viene assegnato in questo modo, viene aggiunto automaticamente un suffisso di parte, ad esempio U3A, U3B, ecc. Se il designatore iniziale non viene assegnato, tutte le parti avranno lo stesso suffisso. Questo problema può essere risolto mediante la funzione di annotazione dell'editor degli schemi. Il suffisso di parte può essere alfabetico o numerico, come specificato dall'opzione Alpha Numeric Suffix nella pagina Schema - Generale della finestra di dialogo Preferences.
Posizionamento della stringa del parametro
Per impostazione predefinita, la stringa di un parametro del componente viene posizionata automaticamente (ovvero ne viene mantenuto l'orientamento) quando un componente viene ruotato durante o dopo il posizionamento. Se questo comportamento non è necessario, disattivare l'opzione Autoposition per la voce del parametro del componente nella sezione Parameters del pannello Properties. Per accedere all'opzione, selezionare il parametro nell'elenco, quindi fare clic su Other. Si noti che durante il posizionamento dei componenti si utilizzano i tasti Spacebar e Shift+Spacebar per la rotazione. Un oggetto componente già posizionato può essere ruotato tramite il menu Rotation nella sezione Location del pannello Properties oppure selezionando il componente e premendo Spacebar o Shift+Spacebar.
Fare clic su un parametro visibile e trascinarlo per riposizionarlo manualmente nello schema; si applicano i tasti di scelta rapida standard per l'orientamento. Se l'opzione Autoposition è disabilitata per quel parametro and l'opzione Mark Manual Parameters è abilitata nella pagina Schema - Modifica grafica della finestra di dialogo Preferences, i parametri spostati manualmente saranno contrassegnati da un punto nell'angolo inferiore sinistro del relativo riquadro di selezione.
Parametri dei componenti per scopi specifici
Sono disponibili parametri dei componenti per scopi specifici che consentono di collegarsi a URL correlati o a documentazione su file. Per un componente selezionato, questi vengono aggiunti facendo clic su Add nella sezione Parameters del pannello Properties e selezionando poi Link dal menu a discesa, oppure nella scheda Parameters per i collegamenti dedicati alla guida, attivabili tramite il tasto F1.
Parametri di collegamento
La funzione dei collegamenti consente di definire e presentare collegamenti con nome a un numero qualsiasi di URL o documenti di riferimento.
Per aggiungere un collegamento di riferimento a un componente, selezionare il componente nello spazio di progettazione, quindi fare clic su Links nella sezione Parameters del pannello Properties. Selezionare Link dal menu a discesa Add nella parte inferiore della sezione Parameters . Inserire nella griglia Name e Value del collegamento (URL di destinazione o percorso del file). Il collegamento sarà quindi accessibile facendo clic con il pulsante destro del mouse sul componente nello spazio di progettazione e selezionando il collegamento <name> dal sottomenu References.
I collegamenti del componente, così come vengono presentati nel pannello e nello spazio di progettazione, si basano internamente su coppie Nome/Valore nel formato ComponentLinknDescription/ComponentLinknURL (dove n è il numero del collegamento nell'elenco, in base all'ordine di creazione). Per maggiori dettagli, consultare la voce relativa a quel componente nell'Editor della tabella dei parametri.
Il parametro HelpURL
Analogamente al parametro di collegamento, il parametro HelpURL consente di definire un collegamento da un componente a un documento esterno, come un PDF, o all'URL di una pagina web. Quando viene aggiunto come parametro del componente, il collegamento si attiva premendo il tasto F1 con il cursore sopra il componente nel foglio schematico o quando il componente è selezionato nel pannello Libraries. Si noti che questa azione sostituisce la normale funzione del tasto F1, che apre la pagina pertinente della documentazione online di Altium.
Il collegamento alla guida viene aggiunto come parametro utente nel pannello Properties quando un componente è selezionato nello spazio di progettazione. Fare clic su Parameters nella sezione Parameters del pannello Properties, quindi selezionare Parameter dal menu a discesa Add nella parte inferiore della sezione Parameters . Inserire "HelpURL" come Name del parametro e il percorso/URL di destinazione come Value del parametro.
Quando si specifica il valore del parametro, è possibile inserire un URL, un percorso assoluto a un documento o semplicemente il nome del documento. Quando si preme F1 con il cursore posizionato sull'oggetto componente inserito, oppure si utilizza l'opzione References » Help dal menu contestuale, la ricerca del riferimento alla Guida viene eseguita come segue:
- Se è specificato un percorso, la ricerca viene eseguita prima in questa posizione.
-
Se il documento non viene trovato in questa posizione, oppure se non è specificato alcun percorso, la ricerca viene eseguita nella cartella
\Helpdell'installazione del software. - Se la destinazione è un URL, la pagina web viene aperta nel browser interno del software o in un browser esterno, a seconda dello stato dell'opzione Open internet links in external Web browser nella pagina Sistema - Visualizzazione della finestra di dialogo Preferences.
Indirezione - Un parametro come valore di una stringa
La maggior parte dei parametri dei componenti può essere visualizzata su un foglio schematico attivando l'icona di visibilità (dove disponibile) nel pannello Properties. I parametri identificativi e di sistema sono disponibili nella scheda General del pannello, mentre i parametri utente sono accessibili nella sezione Parameters.
Altri parametri, invece, come quelli del documento e del progetto, non possono essere visualizzati direttamente sul foglio schematico, ma possono essere inseriti in un oggetto di testo standard mediante una tecnica nota come String Indirection. L'indirezione consiste nell'impostare come valore di un oggetto stringa il nome di un parametro disponibile (ad esempio, un parametro del documento o del progetto) preceduto da un segno di uguale, ad esempio, =Title.
Il software rileva automaticamente queste stringhe e verifica se esiste un nome di parametro disponibile che corrisponda al valore inserito nell'oggetto di testo posizionato. Nell'esempio, Title viene trovato tra i parametri del documento, per cui la stringa di testo interpreta e visualizza il valore del parametro del titolo, ad esempio, MyDocument. È possibile associare un nome di parametro al valore di una stringa di testo selezionata mediante la modifica sul posto (ovvero digitando =Title) oppure, per una scelta più informata, utilizzando il menu a discesa Text nel pannello Proprietà per selezionare una delle stringhe di parametro disponibili.
Stringhe speciali
Le stringhe di parametro disponibili come stringhe indirette (vedere sopra) sono note come special strings. Il valore presentato da queste stringhe viene ricavato dinamicamente dai modelli o dai dati di sistema e di origine; ad esempio, la stringa speciale =Time rileva e mostra l'ora corrente del sistema, mentre =DocumentName mostra il nome del file del documento schematico corrente (ad esempio, MySchematic.SchDoc).
Sono disponibili numerose stringhe speciali predefinite. Consultare la pagina Lavorare con gli oggetti di testo in uno schematico per maggiori informazioni su queste stringhe speciali. Anche qualsiasi parametro del documento o del progetto definito dall'utente può essere utilizzato come stringa speciale e associato tramite indirezione a una stringa di testo sul foglio schematico.
I parametri seguono una gerarchia: è quindi possibile creare un parametro con lo stesso nome a diversi livelli del progetto, assegnandogli valori differenti. Per un parametro di componente, Altium Designer determina il valore da utilizzare nel seguente ordine:
-
Parametro del componente (priorità più alta)
-
Variante
-
Documento schematico
-
Simbolo di foglio (per visualizzare il valore del parametro del simbolo di foglio superiore, selezionare la scheda Compiled nella parte inferiore dell'area di progettazione)
-
Progetto
La maggior parte delle opzioni e dei controlli di questo pannello è intuitiva e non richiede ulteriori spiegazioni. Un'opzione che necessita di chiarimenti è descritta di seguito.
-
Allow Synchronization with Database (solo nella finestra di dialogo Preferences ) - abilitare per sincronizzare con il database. Questa opzione serve a controllare se il commento può essere aggiornato. Per impostazione predefinita, queste opzioni sono abilitate per consentire sempre la sincronizzazione con la libreria o il database di origine. È possibile disabilitare questa opzione per impedire che il commento venga incluso nel processo di aggiornamento.
Utilizzo di Parameter Manager
Gli attributi di progettazione definiti dall'utente vengono aggiunti al progetto mediante i parametri. È possibile aggiungere e modificare i parametri singolarmente, oppure utilizzare la finestra di dialogo Parameter Table Editor (Tools » Parameter Manager) per aggiungere e modificare i parametri nell'intero progetto o in un'intera libreria. Si tratta di parametri che appartengono a vari tipi di oggetti nei documenti schematici di origine del progetto attivo o ai componenti della libreria attiva. Questo offre un modo rapido ed efficiente per riunire tutti i parametri in un unico punto e modificarli, con la possibilità di creare un ordine di modifica tecnica (ECO) per applicare le modifiche apportate ai parametri direttamente a ciascun oggetto di progettazione interessato a cui appartengono.
Quando si apre la finestra di dialogo, vengono raccolti tutti i dati dei parametri dell'intero progetto e presentati in una griglia tabellare. Quando la finestra di dialogo viene avviata da uno schematico, si apre la finestra di dialogo Parameter Editor Options. Selezionare il tipo di parametri da caricare nella finestra di dialogo Parameter Table Editor. Ad esempio, se si sta lavorando sui parametri dei componenti, disabilitare tutte le opzioni nella sezione Include Parameters Owned By tranne Parts. È possibile affinare ulteriormente l'insieme degli oggetti da includere utilizzando il campo a discesa al centro della finestra di dialogo. Scegliere se includere tutti gli oggetti, solo quelli con parametri esistenti oppure solo quelli con parametri esistenti effettivamente utilizzati.
Un altro esempio: se si sta lavorando sui parametri del documento, abilitare solo l'opzione Documents. Si noti che l'opzione Exclude System Parameters include elementi come le impostazioni dei modelli dei componenti, i parametri del documento definiti nel modello e così via. Esplorare questa opzione quando si avrà maggiore familiarità con la gestione dei parametri.
Se si desidera modificare i parametri solo per determinati oggetti del progetto, selezionare gli oggetti desiderati e abilitare l'opzione Selected Objects Only. Verranno inclusi solo gli oggetti selezionati, a condizione che il tipo di oggetto corrispondente sia stato abilitato nella sezione Include Parameters Owned By della finestra di dialogo.
Dopo aver selezionato le opzioni necessarie, fare clic su OK per aprire la finestra di dialogo Parameter Table Editor.
La maggior parte delle opzioni e dei campi della finestra di dialogo è intuitiva. Di seguito sono riportate le spiegazioni di quelli che richiedono chiarimenti.
-
Remove Columns - fare clic per rimuovere le colonne. Questa opzione è disponibile solo per le colonne con informazioni statiche.
-
Add Column - fare clic per aggiungere una colonna. Si apre la finestra di dialogo Add Parameter, nella quale è possibile definire il nome del parametro.
-
Reset Column Order - fare clic per visualizzare le colonne in ordine alfabetico.
-
Accept Changes (Create ECO) - per applicare queste modifiche ai componenti, è necessario generare un ECO (ordine di modifica tecnica). Fare clic per aprire la finestra di dialogo Engineering Change Order.
Menu contestuale
-
Revert - fare clic per annullare le modifiche alle celle selezionate.
-
Add - fare clic per aggiungere informazioni alla cella selezionata. Utilizzare il menu a discesa visualizzato per selezionare le informazioni desiderate.
-
Rename Column - fai clic per aprire la finestra di dialogo Rename Existing Parameter, in cui puoi rinominare un parametro esistente.
-
Remove Columns - fai clic per eliminare la colonna selezionata.
-
Report - fai clic per aprire la finestra di dialogo Report Preview e generare un report.
-
Cross Probe - fai clic per eseguire il cross-probing dell'oggetto selezionato. L'oggetto selezionato verrà evidenziato nel foglio schematico.
Note
-
Puoi trascinare le colonne nell'area della griglia per modificarne l'ordine di visualizzazione. Il nuovo ordine viene salvato nel file di progetto, in modo che venga mantenuto quando si accede nuovamente alla finestra di dialogo.
-
È possibile impedire l'aggiornamento dei parametri nei seguenti modi:
- A livello di parametro del singolo componente, abilita l'opzione Lock Parameter nella modalità Component del pannello Properties (fai doppio clic su un componente per accedervi). L'opzione Allow Synchronization With Database viene utilizzata anche per controllare se il commento può essere aggiornato. Per impostazione predefinita, questa opzione è abilitata per consentire sempre la sincronizzazione con la libreria o il database di origine. Puoi disabilitarla per impedire che il commento venga incluso in un processo di aggiornamento.
- A livello di collegamento al database: l'area Field Mapping del relativo documento di collegamento al database (file *.DbLink, *.DbLib o *.SvnDbLib) include una serie di opzioni che controllano se i parametri possono essere aggiornati, tra cui Update Values, Add to Design e Remove from Design.
Utilizza questa finestra di dialogo per aggiungere, modificare e rimuovere parametri nell'intero progetto. La finestra di dialogo può essere utilizzata per modificare direttamente i parametri esistenti nel progetto o per configurare gli aggiornamenti dei parametri da un database collegato (tramite un file DbLink, DbLib o SvnDbLib). Tieni presente che questi file di collegamento alle librerie di database includono opzioni che controllano se un parametro deve essere aggiornato o meno. Le modifiche vengono quindi applicate tramite un ordine di modifica tecnica (Engineering Change Order), che puoi creare da questa finestra di dialogo.
Aggiunta di un parametro
Per aggiungere un nuovo parametro, fai clic sul pulsante (oppure fai clic con il pulsante destro del mouse in un punto qualsiasi della griglia principale e scegli il comando Add Column dal menu contestuale). Si aprirà la finestra di dialogo Add Parameter. Per creare soltanto il nuovo parametro senza assegnare valori agli oggetti, inserisci il nome desiderato e fai clic su OK. Se desideri aggiungere il parametro a tutti gli oggetti con un valore specifico, abilita l'opzione Add to all objects, inserisci il valore desiderato, quindi fai clic su OK. Verrà aggiunta una colonna per il nuovo parametro alla fine delle colonne esistenti (all'estrema destra dell'elenco).
Ridenominazione di un parametro
Per rinominare un parametro, fai clic con il pulsante destro del mouse su una cella della colonna che desideri rinominare, quindi seleziona Rename Column dal menu a discesa. Si apre la finestra di dialogo Rename Existing Parameter. Inserisci il nuovo nome nel campo Enter the new name for the parameter , quindi fai clic su OK. Nota che l'intestazione della colonna è cambiata e ora presenta un piccolo triangolo blu accanto al nome. Questa icona indica che il valore della cella è stato modificato.

La finestra di dialogo Rename Existing Parameter
Aggiunta di un parametro a componenti selezionati
Per aggiungere un parametro ai componenti, seleziona le celle nell'editor della finestra di dialogo Parameter Table Editor utilizzando le combinazioni di tasti Shift+Click o Ctrl+Click, fai clic con il pulsante destro del mouse, quindi scegli Add dal menu a discesa. Dopo aver selezionato Add, in ogni cella viene visualizzato un piccolo simbolo più verde. Questo indica che è stato aggiunto un nuovo parametro.
Ora che il parametro è stato aggiunto, puoi definire il tipo di componente per ciascun componente. La finestra di dialogo Parameter Table Editor supporta le scorciatoie standard per la modifica delle tabelle. Puoi premere F2 per modificare una cella, quindi premere Enter per applicare la modifica. Per modificare più celle, selezionale, quindi fai clic con il pulsante destro del mouse e scegli Edit dal menu. Inserisci il nuovo valore, quindi premi Enter per applicare la modifica a tutte le celle selezionate.
Applicazione delle modifiche ai parametri
Le modifiche ai parametri appena completate sono attualmente memorizzate nella finestra di dialogo Parameter Table Editor e non sono state applicate ai componenti sui fogli schematici. Per applicare queste modifiche ai componenti, devi generare un ECO e quindi applicarlo al progetto. Nella finestra di dialogo Parameter Table Editor, fai clic sul pulsante Accept Changes (Create ECO) . La finestra di dialogo Parameter Editor Table si chiuderà e si aprirà la finestra di dialogo Engineering Change Order.
Fai clic sul pulsante Validate Changes per verificare che le modifiche possano essere applicate. Se sono valide, verrà visualizzato un segno di spunta verde nella colonna Check .
Fai clic su Execute Changes per applicare le modifiche ai parametri ai componenti. Una volta applicate le modifiche, chiudi la finestra di dialogo Engineering Change Order .
).
).







